ISC/ISL, QSC8.3/QSL9,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module (ECM) Microprocessor

FAULT CODE 111

Electronic Control Module (ECM) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | ECM internal hardware error. | Possible no effect or engine can, perhaps, run rough or not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the left side of the engine block, behind the fuel filter.

Shop Talk

This fault code can be caused only by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 16-Dec-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Speed Sensor (ESS) Circuit

FAULT CODE 115

Engine Speed Sensor (ESS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Yellow SRT: | No engine speed signal detected at pin 17 of the engine harness. | Engine power derate. Possible white smoke.
Engine Speed Sensor (ESS) Circuit

Circuit Description

The engine speed sensor provides engine speed information to the electronic control module (ECM). The sensor must be powered by +5 VDC to operate. The sensor generates its signals by sensing the movement of target teeth cut into a steel ring fastened to the back side of the cam gear. This ring has 71 teeth and a gap where the 72nd tooth would be placed. This missing tooth indicates that cylinder 1 (and 6) is at top dead center.

Component Location

The engine speed sensor is located on the back side of the gear housing, between the fuel injection pump and the air compressor.

Refer to Troubleshooting Fault Code t05-115

Last Modified: 16-Dec-2010


Engine Position Sensor Circuit

FAULT CODE 121

Engine Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 2 LAMP: Yellow SRT: | No engine position signal detected at pin 9 of the engine harness. | No engine speed and position backup for main speed/position sensor.
Engine Position Sensor Circuit

Circuit Description

The engine position sensor provides engine position information to the electronic control module (ECM). The sensor must be powered by +5-VDC to operate. The sensor generates a signal by sensing the movement of target teeth cut into a steel ring fastened to the back side of the cam gear. This ring has 71 teeth and a gap where the 72nd tooth would be placed. This missing tooth indicates that cylinder 1 (and 6) is at top dead center.

Component Location

The engine position sensor is located on the backside of the gear housing, between the fuel injection pump and the air compressor.

Refer to Troubleshooting Fault Code t05-121

Last Modified: 16-Dec-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the boost pressure sensor signal pin-45 of the engine harness. | Engine will derate to no-boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located on the rear of the intake air manifold in the second port on the side of the head to the right of the fuel filter.

Shop Talk

  • Determine if engine is being overfueled.
  • Confirm that the correct intake manifold pressure sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air.
  • Check for high restriction in the intake air manifold due to a shutdown device in the manifold (if the vehicle is equipped with one). Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.
Refer to Troubleshooting Fault Code t05-122

Last Modified: 16-Dec-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the boost pressure sensor signal pin 45 of the engine harness. | Engine will derate to no-boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located on the rear of the intake air manifold in the second port on the side of the head to the right of the fuel filter.

Shop Talk

  • Determine if engine is being overfueled.
  • Confirm that the correct intake manifold pressure sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air.
  • Check for high restriction in the intake air manifold due to a shutdown device in the manifold (if the vehicle is equipped with one). Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.
Refer to Troubleshooting Fault Code t05-123

Last Modified: 16-Dec-2010


Intake Manifold Pressure - Engine Protection

FAULT CODE 124

Intake Manifold Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 0 LAMP: Yellow SRT: | Intake manifold pressure signal indicates intake manifold pressure has exceeded the maximum limit for the given engine rating. | Engine will derate to no-boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor is used by the electronic control module (ECM) to monitor the engine intake manifold pressure. The ECM monitors the voltage on the signal pin 45 and converts this to a pressure value. The intake manifold pressure value is used by the ECM for the engine protection system.

Component Location

The intake manifold pressure sensor is located on the rear of the intake manifold in the second port on the side of the head to the right of the fuel filter.

Shop Talk

Possible causes:

  • Malfunctioning turbocharger wastegate. 010-050 in the ISC Troubleshooting and Repair Manual, Bulletin No. 3666245.
  • Wastegate tampering. 010-100 in the ISC Troubleshooting and Repair Manual, Bulletin No. 3666245.
  • Wrong turbocharger tampering. 010-101 through 010-107 in the ISC Troubleshooting and Repair Manual, Bulletin No. 3666245.
Refer to Troubleshooting Fault Code t05-124

Last Modified: 16-Dec-2010


Accelerator Position Sensor Circuit

FAULT CODE 131 or 132

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 or 132 PID: P091 SPN: 091 FMI: 3 or 4 LAMP: Yellow SRT: | FC 131: High voltage detected at accelerator position signal pin 30 of the OEM harness. FC 132: Low voltage detected at accelerator position signal pin 30 of the OEM harness. | Engine idles when idle validation switch indicates idle and operates at a default set speed when idle validation switch indicates off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: a +5-VDC supply wire (pin 29), a return ground (pin 19), and a signal wire (pin 30).

Note: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensor checks look in good order, then replace the accelerator position sensor and the idle validation switch circuit wires between the accelerator pedal and the ECM with new wires. Run the wires through, or around, the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from entering the operator area.

Note: The three wires in the accelerator position sensor circuit must be twisted together. Depending on ground location, IVS can, perhaps, only be two wires.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 16-Dec-2010


Accelerator Position Sensor Circuit

FAULT CODE 131 or 132

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 or 132 PID: P091 SPN: 091 FMI: 3 or 4 LAMP: Yellow SRT: | Fault Code 131: High voltage detected at accelerator position signal pin 30 of the OEM harness. Fault Code 132: Low voltage detected at accelerator position signal pin 30 of the OEM harness. | Engine idles when idle validation switch indicates idle and operates at a default set speed when idle validation switch indicates off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: a +5-VDC supply wire (pin 29), a return ground (pin 19), and a signal wire (pin 30).

Note: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensor checks look in good order, then replace the accelerator position sensor and the idle validation switch circuit wires between the accelerator pedal and the ECM with new wires. Run the wires through, or around, the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from entering the operator area.

Note: The three wires in the accelerator position sensor circuit must be twisted together. Depending on ground location, idle validation switch can, perhaps, only be two wires.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 16-Dec-2010


Remote Throttle Position Sensor

FAULT CODE 133

Remote Throttle Position Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 29 FMI: 3 LAMP: Red SRT: | High voltage detected at the remote throttle position signal circuit. | Engine will not respond to remote throttle input.
Remote Throttle Position Sensor Circuit

Circuit Description

The remote throttle pedal provides the driver's throttle command to the electronic control module (ECM) through the OEM harness and the original equipment manufacturer's (OEM) interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote throttle pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

The throttle position sensor is a potentiometer. The resistance specifications of the throttle position sensor is as follows:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms; depressed = 200 to 1500 ohms

Note: If the throttle or throttle position sensor is changed or after a calibration download cycle the throttle pedal (keyswitch in the ON position) through its complete travel three times. This procedure calibrates the new throttle with the ECM.

  • The remote throttle enable switch must be turned on for the remote throttle to operate and the feature must be enabled with INSITE™.
  • Possible causes of this fault code include an open circuit in the return wire, short circuit to +5 VDC or 12 VDC, defective remote throttle position sensor, or a failed ECM power supply.
Refer to Troubleshooting Fault Code t05-133

Last Modified: 16-Dec-2010


Remote Throttle Position Sensor

FAULT CODE 134

Remote Throttle Position Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 29 FMI: 4 LAMP: Red SRT: | Low voltage detected at the remote throttle position signal circuit. | Engine will not respond to remote throttle input.
Remote Throttle Position Sensor Circuit

Circuit Description

The remote throttle pedal provides the driver's throttle command to the electronic control module (ECM) through the original equipment manufacturer's (OEM) harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote throttle pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

The remote throttle position sensor is a potentiometer. The resistance specifications of the throttle position sensor are as follows:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms; depressed = 200 to 1500 ohms

Note: If the remote throttle position sensor is changed, or after a calibration download, cycle the throttle pedal (keyswitch in the ON position) through its complete travel three times. This procedure calibrates the new remote throttle with the ECM.

  • The remote throttle enable switch must be turned on for the remote throttle to operate and the feature must be enabled with INSITE™.
  • Possible causes of this fault code include an open circuit in the supply wire, short circuit to ground in the supply or signal wires, defective remote throttle position sensor, or a failed ECM power supply.
Refer to Troubleshooting Fault Code t05-134

Last Modified: 16-Dec-2010


Oil Pressure Sensor Circuit

FAULT CODE 135 (SN)

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Yellow SRT: | High voltage detected at oil pressure sensor signal pin 33 of the engine harness. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, below and to the right of the ECM.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure signal voltage going into the ECM.
Refer to Troubleshooting Fault Code t05-135

Last Modified: 16-Dec-2010


Fault Code Path Selection

FAULT CODE 141
Fault Code Path Selection

Do you have an Oil Pressure Sensor? | Go to 71-fc141sn
Do you have an Oil Pressure Switch? | Go to 71-fc141sw

Last Modified: 27-Jan-2004


Fault Code Path Selection

FAULT CODE 143
Fault Code Path Selection

Do you have an Oil Pressure Sensor? | Go to 71-fc143sn
Do you have an Oil Pressure Switch? | Go to 71-fc143sw

Last Modified: 27-Jan-2004


Coolant Temperature Sensor Circuit

FAULT CODE 144 or 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 or 145 PID: P110 SPN: 110 FMI: 3 or 4 LAMP: Yellow SRT: | FC 144: High voltage detected at the coolant temperature signal pin 23 of the engine harness. FC 145: Low voltage detected at the coolant temperature signal pin 23 of the engine harness. | Default value used for engine coolant temperature. No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located below the thermostat housing.

Shop Talk

The resistance of the sensor varies with the temperature. Use a multimeter and INSITE™ to read the fuel temperature. Compare the resistance value measured with the following table to verify that the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-144

Last Modified: 16-Dec-2010


Coolant Temperature Sensor Circuit

FAULT CODE 144 or 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 or 145 PID: P110 SPN: 110 FMI: 3 or 4 LAMP: Yellow SRT: | FC 144: High voltage detected at the coolant temperature signal pin 23 of the engine harness. FC 145: Low voltage detected at the coolant temperature signal pin 23 of the engine harness. | Default value used for engine coolant temperature. No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located below the thermostat housing.

Shop Talk

The resistance of the sensor varies with the temperature. Use a multimeter and INSITE™ to read the fuel temperature. Compare the resistance value measured with the following table to verify that the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145

Last Modified: 16-Dec-2010


Coolant Temperature - Engine Protection

FAULT CODE 146

Coolant Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0 LAMP: Yellow SRT: | Coolant temperature signal indicates coolant temperature has exceeded the engine protection limit. | Power derate and possible engine shutdown, if engine protection shutdown feature is enabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor (CTS) is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, and the timing and fueling control.

Component Location

The coolant temperature sensor is located below the thermostat housing.

Shop Talk

Make sure the airflow through the radiator is not obstructed.

Refer to Troubleshooting Fault Code t05-146

Last Modified: 16-Dec-2010


Frequency Throttle Circuit

FAULT CODE 147

Frequency Throttle Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 147 PID: P091 SPN: 091 FMI: 8 LAMP: Red SRT: | A frequency below a calibrated value has been detected at frequency throttle signal pin 4 of the engine harness. | Engine will not respond to changes in frequency throttle. The engine will go to low idle.
Frequency Throttle Circuit

Circuit Description

The throttle pedal provides the driver's throttle command to the electronic control module (ECM) through the original equipment manufacturer (OEM) harness and the 23-pin connector to the engine harness. The ECM uses this signal to determine the fueling command.

Component Location

The throttle pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

The frequency throttle can either be used in conjunction with a voltage throttle or by itself.

Refer to Troubleshooting Fault Code t05-147

Last Modified: 16-Dec-2010


Frequency Throttle Circuit

FAULT CODE 148

Frequency Throttle Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 148 PID: P091 SPN: 091 FMI: 8 LAMP: Red SRT: | A frequency above a calibrated value has been detected at the frequency throttle signal pin 4 of the engine harness. | Engine will not respond to changes in the frequency throttle. Engine will go to low idle.
Frequency Throttle Circuit

Circuit Description

The throttle pedal provides the driver's throttle command to the electronic control module (ECM) through the original equipment manufacturer's (OEM) harness and the 23-pin connector to the engine harness. The ECM uses this signal to determine the fueling command.

Component Location

The throttle pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

The frequency throttle can either be used in conjunction with a voltage throttle or by itself.

Refer to Troubleshooting Fault Code t05-148

Last Modified: 16-Dec-2010


Coolant Temperature - Engine Protection

FAULT CODE 151

Coolant Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Coolant temperature signal indicates coolant temperature has exceeded the engine protection limit. | Speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor (CTS) is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, and the timing and fueling control.

Component Location

The coolant temperature sensor (CTS) is located below the thermostat housing.

Shop Talk

Make sure the airflow through the radiator is not obstructed.

Refer to Troubleshooting Fault Code t05-151

Last Modified: 16-Dec-2010


Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Least Severe Level

FAULT CODE 152

Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 152 PID: P110 SPN: 110 FMI: 1/17 LAMP: Warning SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Least Severe Level. Engine coolant temperature is below normal operating temperature limits. | None on performance.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Engine coolant temperature was less than 60°C [140°F] for over 1 hour during a period of extended idle.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the Malfunction Indicator Lamp (MIL) for On-Board Diagnostics (OBD) applications.

Shop Talk

If this fault indicates that coolant temperature is below a calibratible limit set in the ECM, reference the Engine Coolant Temperature Below Normal troubleshooting symptom tree in Section TS of the base engine service manual.

Refer to Troubleshooting Fault Code t05-152.

Last Modified: 20-Feb-2014


Intake Manifold Air Temperature Sensor Circuit

FAULT CODE 153 or 154

Intake Manifold Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 or 154 PID: P105 SPN: 105 FMI: 3 or 4 LAMP: Yellow SRT: | FC 153: High voltage detected at intake manifold air temperature signal pin 34 of the engine harness. FC 154: Low voltage detected at intake manifold air temperature signal pin 34 of the engine harness. | Default value used for intake manifold air temperature. No engine protection for intake manifold air temperature.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine intake air. The intake manifold air temperature signal is used by the ECM for the engine protection system, injection timing, and fueling control.

Component Location

The intake manifold air temperature sensor is located on the side of the intake manifold near the middle of the cylinder head.

Shop Talk

The resistance of the sensor varies with the temperature. Use a multimeter and read the air temperature using INSITE™. Compare the resistance value measured with the following table to verify the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153

Last Modified: 16-Dec-2010


Intake Manifold Air Temperature Sensor Circuit

FAULT CODE 153 or 154

Intake Manifold Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 or 154 PID: P105 SPN: 105 FMI: 3 or 4 LAMP: Yellow SRT: | FC 153: High voltage detected at intake manifold air temperature signal pin 34 of the engine harness. FC 154: Low voltage detected at intake manifold air temperature signal pin 34 of the engine harness. | Default value used for intake manifold air temperature. No engine protection for intake manifold air temperature.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine intake air. The intake manifold air temperature signal is used by the ECM for the engine protection system, injection timing, and fueling control.

Component Location

The intake manifold air temperature sensor is located on the side of the intake manifold near the middle of the cylinder head.

Shop Talk

The resistance of the sensor varies with the temperature. Use a multimeter and read the air temperature using INSITE™. Compare the resistance value measured with the following table to verify the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154

Last Modified: 16-Dec-2010


Primary and Secondary Electronic Control Modules (ECM) Identification Error

FAULT CODE 184

Primary and Secondary Electronic Control Modules (ECM) Identification Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 184 PID: S233 SPN: 609 FMI: 2 (J1587), 2 (J1939) LAMP: Yellow SRT: | Error detected in the control synchronization of multiple engines. | Multiple unit synchronization will be disabled. Engine will only idle.
Primary/Secondary ECM Identification Error

Circuit Description

The QSL9 control system synchronizes two ECMs, one primary and one secondary.

Component Location

The ECMs are located on the left side of the engine block, behind the fuel filter.

Shop Talk

Identification between primary and secondary modules is done at key-on through the harness. Pins 47 and 48 of each engine harness provide the determination of primary or secondary. Reference the following table for primary/secondary identification:

ECM Identification | Pin 47 | Pin 48
Primary | Grounded | Open
Secondary | Open | Grounded
Refer to Troubleshooting Fault Code t05-184

Last Modified: 16-Dec-2010


Air Conditioner Clutch Supply Circuit

FAULT CODE 191

Air Conditioner Clutch Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 191 PID: P050 SPN: 876 FMI: 11 LAMP: SRT: | Air conditioner clutch driver signal indicates a short to ground when commanded on. | Can not turn on air conditioner.
Air Conditioner Clutch Supply Circuit

Circuit Description

The air conditioner clutch solenoid is a device used by the electronic control module (ECM) to control the air conditioner, by sending a signal to open or close the fan clutch solenoid.

Component Location

Refer to an original equipment manufacturer's (OEM) diagram for the location of the air conditioner clutch solenoid.

Shop Talk

Air conditioner clutch solenoid could be malfunctioning due to a failed engine harness or a bad ground on the air conditioner clutch connector.

Refer to Troubleshooting Fault Code t05-191

Last Modified: 16-Dec-2010


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the barometric pressure sensor signal pin 32 of the engine harness. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor monitors atmospheric pressure and passes information to the engine control module (ECM) through the sensor harness.

Component Location

The ambient air pressure sensor is located below the fuel transfer pump. Refer to Procedure 100-002 (Engine Diagrams) in Section E.

Shop Talk

This sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221

Last Modified: 01-Oct-2012


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the barometric pressure sensor SIGNAL pin 32 of the engine harness. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor monitors atmospheric pressure and passes information to the engine control module (ECM) through the sensor harness.

Component Location

The barometric pressure sensor is located near the fuel transfer pump. Refer to Procedure 100-002 in Section E.

Shop Talk

This sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222.

Last Modified: 25-Jul-2016


Engine Overspeed Circuit

FAULT CODE 234

Engine Overspeed Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0 LAMP: Red SRT: | Engine speed signal indicates engine speed has exceeded the overspeed limit. | Fuel to the injectors disabled until the engine speed falls below the overspeed limit.
Engine Overspeed Circuit

Circuit Description

The engine speed sensor provides engine speed information to the electronic control module (ECM). The sensor must be powered by +5 VDC to operate. The sensor generates a signal by sensing the movement of target teeth cut into a steel ring fastened to the backside of the camshaft gear. This ring has 71 teeth and a gap where the 72nd tooth would be placed. This missing tooth indicates that cylinder 1 (and 6) is at top dead center.

Component Location

The engine speed sensor is located on the back side of the gear housing, between the Cummins accumulator pump system (CAPS) fuel pump and the air compressor.

Refer to Troubleshooting Fault Code t05-234

Last Modified: 16-Dec-2010


Engine Coolant Level - Engine Protection

FAULT CODE 235

Engine Coolant Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1 LAMP: Maintenance SRT: | Coolant level signal at pin 27 and pin 37 of the engine harness indicates coolant level is low. | Power and/or speed derates and possible engine shutdown if engine protection shutdown feature is enabled.
Engine Coolant Level - Engine Protection

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness. Because this sensor is complex, do not use a multimeter to check it. If the radiator coolant level drops below a certain level, a progressive power and/or speed derate will occur. Engine can, perhaps, shut down if the engine protection shutdown feature is enabled.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and can vary in location.

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the Weather-Pack four-way connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle turns a corner.
  • Make sure the correct ECM code is in the ECM. Calibrating the ECM with the incorrect DO option can cause Fault Code 235 to be active since some OEMs use a coolant level sensor that requires a special calibration. Refer to OEM service manual.
Refer to Troubleshooting Fault Code t05-235

Last Modified: 16-Dec-2010


Vehicle Speed Sensor Circuit

FAULT CODE 241

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 084 FMI: 2 LAMP: Yellow SRT: | Vehicle speed signal on pins 8 and 18 of the original equipment manufacturer's (OEM) harness has been lost. | Engine speed limited to "Max. Engine Speed without Vehicle Speed Sensor" parameter value. Cruise control, gear-down protection, and road speed governor will not work. Trip information data that are based on mileage will be incorrect.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor (VSS) uses two separate coils of wire (some applications use a single coil sensor) to count gear teeth as they pass in front of the sensor. One coil is used by the electronic control module (ECM) to sense vehicle speed. The other coil is sometimes used by the OEM to send a vehicle speed signal to the speedometer.

Component Location

The VSS is most commonly installed in the rear of the transmission.

Shop Talk

  • Disconnect the vehicle speed sensor connector that connects to the OEM speedometer, or trip recorder, and move the truck. If the fault goes inactive, there is probably electrical noise being fed into the vehicle speed sensor circuit from the OEM device.
  • Verify the vehicle speed sensor wires in the OEM harness are twisted-pairs.
Refer to Troubleshooting Fault Code t05-241

Last Modified: 16-Dec-2010


Vehicle Speed Sensor (VSS) Circuit

FAULT CODE 242

Vehicle Speed Sensor (VSS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 084 FMI: 10 LAMP: Yellow SRT: | Invalid or inappropriate vehicle speed signal detected on pins 8 and 18 of the OEM harness indicating an intermittent connection or possible tampering. | Engine speed limited to "Maximum Engine Speed without Vehicle Speed Sensor" for the duration of the invalid signal.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor (VSS) uses two separate coils of wire (some applications use a single coil sensor) to count gear teeth as they pass in front of the sensor. One coil is used by the electronic control module (ECM) to sense vehicle speed. The other coil is sometimes used by the OEM to send a vehicle speed signal to the speedometer.

Component Location

The VSS is most commonly installed in the rear of the transmission.

Shop Talk

  • Verify that the feature settings for "VSS Antitampering (Fault Code 242), "Application Type," and "Automatic Transmission" are set correctly. If any of these are set incorrectly, Fault Code 242 could occur erroneously.

NOTE: Driving techniques, such as driving for extended periods of time in lower gears, could log Fault Code 242.

  • Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.
  • Interview the driver to discover what occurred when the fault code was logged. Explain the driver actions that can cause Fault Code 242 to be logged.
  • When deactivating the fault, verify that the vehicle is stopped and the engine is shut down.
  • Verify that the keyswitch has been cycled and has remained in the ON position for 30 seconds after the invalid signal has been corrected. This fault will remain active until the keyswitch is cycled and the ECM sees zero vehicle speed and zero engine speed for 30 seconds.
Refer to Troubleshooting Fault Code t05-242

Last Modified: 16-Dec-2010


Fault Code Path Selection

FAULT CODE 243
Fault Code Path Selection

Do you have an ISC engine? | Go to 71-fc243isc
Do you have an ISL engine? | Go to 71-fc243isl

Last Modified: 18-Mar-2003


Engine Fan Clutch Supply Circuit

FAULT CODE 245

Engine Fan Clutch Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S533 SPN: 641 FMI: 4 LAMP: SRT: | Error detected in fan clutch relay enable circuit at pin 41 of the engine harness. | Electronic control module (ECM) can not control the engine cooling fan. Fan will remain either on or off.
Engine Fan Clutch Supply Circuit

Circuit Description

The fan clutch solenoid is a device used by the ECM to control the engine fan by sending a signal to open or close the fan clutch solenoid.

Component Location

Refer to an original equipment manufacturer's (OEM) diagram for the location of the fan clutch solenoid.

Shop Talk

Fan clutch solenoid could be malfunctioning due to a failed engine harness or a bad ground on the fan clutch connector.

Refer to Troubleshooting Fault Code t05-245

Last Modified: 16-Dec-2010


Fuel Temperature Sensor Circuit

FAULT CODE 263 or 265

Fuel Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 or 265 PID: P174 SPN: 174 FMI: 3 or 4 LAMP: Yellow SRT: | FC 263: High voltage detected at the fuel temperature signal pin 35 of the engine harness. FC 265: Low voltage detected at the fuel temperature signal pin 35 of the engine harness. | Default value used for engine fuel temperature. Possible low power and no engine protection for fuel temperature.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel pressure/temperature sensor is used by the electronic control module (ECM) to monitor the fuel temperature in the accumulator. The ECM monitors the voltage on the signal pin, and converts this to a temperature value.

Component Location

The fuel pressure/temperature sensor is located on the rear of the Cummins accumulator pump system (CAPS).

Shop Talk

The resistance of the sensor varies with the temperature. Use a multimeter and INSITE™ to read the fuel temperature. Compare the resistance value measured with the following table to verify that the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-263

Last Modified: 16-Dec-2010


Fuel Temperature Sensor Circuit

FAULT CODE 263 or 265

Fuel Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 or 265 PID: P174 SPN: 174 FMI: 3 or 4 LAMP: Yellow SRT: | FC 263: High voltage detected at the fuel temperature signal pin 35 of the engine harness. FC 265: Low voltage detected at the fuel temperature signal pin 35 of the engine harness. | Default value used for engine fuel temperature. Possible low power and no engine protection for fuel temperature.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel pressure/temperature sensor is used by the electronic control module (ECM) to monitor the fuel temperature in the accumulator. The ECM monitors the voltage on the signal pin, and converts this to a temperature value.

Component Location

The fuel pressure/temperature sensor is located on the rear of the Cummins accumulator pump system (CAPS).

Shop Talk

The resistance of the sensor varies with the temperature. Use a multimeter and INSITE™ to read the fuel temperature. Compare the resistance value measured with the following table to verify that the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-265

Last Modified: 16-Dec-2010


Fuel Pressure Sensor Circuit

FAULT CODE 268

Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 268 PID: P094 SPN: 94 FMI: 2 LAMP: Yellow SRT: | Indicates that the sensor is significantly offset or biased with respect to actual pressure at ambient conditions. | Engine slow to start; engine could run rough
Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor contains supply, signal, and return pins. The electronic control module (ECM) provides 5 VDC to the fuel pressure sensor for a supply voltage. The ECM supplies a shared ground from the fuel pressure sensor circuit. The signal voltage is variable depending on the pressure that is being generated inside the fuel pump's accumulator.

This 5 VDC power supply is a shared supply. Other sensors on this circuit are the engine speed sensor, engine position sensor, oil pressure sensor, intake manifold pressure sensor and ambient air pressure sensor.

The shared ground for the fuel pressure sensor also connects to the injection control valve identifier, temperature sensor, intake manifold air temperature sensor, engine position sensor, oil pressure sensor, intake manifold pressure sensor, and ambient air pressure sensor.

Component Location

The fuel pressure sensor is located on the top rear of the fuel pump. The pressure sensor can be identified by its mounting location, rear center of CAPS Accumulator module.

Shop Talk

This fault can be set due to:

  • ECM calibration is not updated, therefore logging the incorrect fault code. ECM calibrations before December 2000 contained only Fault Code 268 for fuel pressure sensor faults. At that time Fault Code 268 was a fault for sensor bias high or low, erratic pressure, and stuck in range. To assist with troubleshooting, this fault code was split into two separate fault codes, Fault Code 268 and Fault Code 456. Fault Code 268 is fuel pressure sensor biased high or low and can only log while keyswitch is in the ON position and the engine is off. Fault Code 456, on the other hand, is fuel pressure stuck in range, or erratic pressure, and can only log while the engine is running
  • Faulty fuel pressure sensor wiring (pig tail harness), sensor connections (pin fretting), or engine harness issues (shorts) which can cause a faulty pressure signal
  • Internal sensor failures
  • Poor ECM grounds.
Refer to Troubleshooting Fault Code t05-268

Last Modified: 16-Dec-2010


Front Pumping Valve Circuit

FAULT CODE 271 or 272

Front Pumping Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 or 272 PID: S151 SPN: 1347 FMI: 5 or 6 LAMP: Yellow SRT: | FC 271: Low or no current detected at the front pumping valve pin 21 of the engine harness. FC 272: High current detected at the front pumping valve pin 21 of the engine harness. | Engine power will derate.
Front Pumping Valve Circuit

Circuit Description

The pumping control valve of Cummins accumulator pump system (CAPS) regulates the quantity of fuel that is pumped into the accumulator. The electronic control module (ECM) commands the valve to close based on several different parameters including fuel pressure, engine load, and throttle position.

Component Location

The pumping control valves are located on the fuel pump on the top of the accumulator.

Refer to Troubleshooting Fault Code t05-271

Last Modified: 16-Dec-2010


Front Pumping Valve Circuit

FAULT CODE 271 or 272

Front Pumping Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 or 272 PID: S151 SPN: 1347 FMI: 5 or 6 LAMP: Yellow SRT: | FC 271: Low or no current detected at the front pumping valve pin 21 of the engine harness. FC 272: High current detected at the front pumping valve pin 21 of the engine harness. | Engine power will derate.
Front Pumping Valve Circuit

Circuit Description

The pumping control valve of Cummins accumulator pump system (CAPS) regulates the quantity of fuel that is pumped into the accumulator. The electronic control module (ECM) commands the valve to close based on several different parameters including fuel pressure, engine load, and throttle position.

Component Location

The pumping control valves are located on the fuel pump on the top of the accumulator.

Refer to Troubleshooting Fault Code t05-272

Last Modified: 16-Dec-2010


Rear Pumping Valve Circuit

FAULT CODE 273 or 274

Rear Pumping Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 273 or 274 PID: S152 SPN: 1348 FMI: 5 or 6 LAMP: Yellow SRT: | FC 273: Low or no current detected at the rear pumping valve pin 15 of the engine harness. FC 274: High current detected at the rear pumping valve pin 15 of the engine harness. | Engine power will derate.
Rear Pumping Valve Circuit

Circuit Description

The pumping control valve of Cummins accumulator pump system (CAPS) regulates the quantity of fuel that is pumped into the accumulator. The electronic control module (ECM) commands the valve to close based on several different parameters including fuel pressure, engine load, and throttle position.

Component Location

The pumping control valves are located on the fuel pump on the top of the accumulator.

Refer to Troubleshooting Fault Code t05-273

Last Modified: 16-Dec-2010


Rear Pumping Valve Circuit

FAULT CODE 273 or 274

Rear Pumping Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 273 or 274 PID: S152 SPN: 1348 FMI: 5 or 6 LAMP: Yellow SRT: | FC 273: Low or no current detected at the rear pumping valve pin 15 of the engine harness. FC 274: High current detected at the rear pumping valve pin 15 of the engine harness. | Engine power will derate.
Rear Pumping Valve Circuit

Circuit Description

The pumping control valve of Cummins accumulator pump system (CAPS) regulates the quantity of fuel that is pumped into the accumulator. The electronic control module (ECM) commands the valve to close based on several different parameters including fuel pressure, engine load, and throttle position.

Component Location

The pumping control valves are located on the fuel pump on the top of the accumulator.

Refer to Troubleshooting Fault Code t05-274

Last Modified: 16-Dec-2010


Front Pumping Element

FAULT CODE 275

Front Pumping Element

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 275 PID: S151 SPN: 1347 FMI: 7 LAMP: Yellow SRT: | Front Pumping Element. The electronic control module (ECM) has detected a malfunction in the front pumping element. | Derate in power output of the engine.
Front Pumping Element

Circuit Description

The front pumping element in the Cummins® accumulator pump system (CAPS) consists of the front barrel and plunger, front pumping control valve, and the front check valve in the accumulator. These components are part of the accumulator module. The pumping element is responsible for pumping fuel into the accumulator and maintaining the desired pressure in the accumulator.

Component Location

The front pumping element is part of the CAPS fuel pump in the accumulator module.

Shop Talk

  • A plugged fuel filter can cause both Fault Code 275 and Fault Code 328 to be logged intermittently.
  • If Fault Code 275 and Fault Code 328 are both present, check fuel filter restriction.
  • A damaged engine harness can also cause this fault code to be active.
  • If Fault Code 271 or Fault Code 272 is active, troubleshoot it first.
Refer to Troubleshooting Fault Code t05-275

Last Modified: 16-Dec-2010


Injection Control Valve Stator Circuit

FAULT CODE 276

Injection Control Valve Stator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 276 PID: S018 SPN: 633 FMI: 5 LAMP: Yellow SRT: | High current detected on injection control valve stator return pin 7. | Engine power derate. Engine possibly dies.
Injection Control Valve Stator Circuit

Circuit Description

The injection control valve regulates both the quantity of fuel that is injected into each cylinder and the timing of the injection event. The injection control valve stator is the electronic solenoid that actuates the injection control valve. The engine control module (ECM) commands the stator to actuate the injection control valve to open based on several different parameters, including fuel pressure, engine speed, and throttle position.

Component Location

The injection control valve is located on the fuel injection pump on the top of the distributor. The injection control valve stator is mounted onto the front side of the injection control valve with four capscrews.

Shop Talk

This fault code can be caused by a faulty stator, improper or poor grounds, and internal damage to the injection control valve. Inspect the snapshot data to see if the battery voltage dropped below 9-VDC when the fault code logged. In addition to these possible causes, a malfunctioning transient suppressor can also cause Fault Code 276 to become active, and is often accompanied with an engine no-start condition. If these symptoms occur, replace the transient suppressor.

A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Refer to Troubleshooting Fault Code t05-276.

Last Modified: 07-Sep-2012


Injection Control Valve Stator Circuit

FAULT CODE 277

Injection Control Valve Stator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: S018 SPN: 633 FMI: 7 LAMP: Yellow SRT: | Engine ECM has detected a malfunction in the injection control valve. | Engine power derate. Engine possibly dies.
Injection Control Valve Stator Circuit

Circuit Description

The injection control valve regulates both the quantity of fuel that is injected into each cylinder and the timing of the injection event. The injection control valve stator is the electronic solenoid that actuates the injection control valve. The engine control module (ECM) commands the stator to actuate the injection control valve to open based on several different parameters, including fuel pressure, engine speed, and throttle position.

Component Location

The injection control valve is located on the fuel injection pump on the top of the distributor. The injection control valve stator is mounted onto the front side of the injection control valve with four capscrews.

Shop Talk

This fault code can be caused by a faulty stator, improper or poor grounds, and internal damage to the injection control valve. Inspect the snapshot data to see if the battery voltage dropped below 9-VDC when the fault code logged. In addition to these possible causes, a malfunctioning transient suppressor can also cause Fault Code 277 to become active, and is often accompanied with an engine no-start condition. If these symptoms occur, replace the transient suppressor.

A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Refer to Troubleshooting Fault Code t05-277.

Last Modified: 07-Sep-2012


Lift Pump Circuit

FAULT CODE 278

Lift Pump Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 278 PID: P073 SPN: 073 FMI: 11 LAMP: Yellow SRT: | Error detected in lift pump circuit at pins 11 and 22 of the engine harness. | Possible low power, engine may stall, rough operation, or difficult start.
Lift Pump Circuit

Circuit Description

The ECM enables the lift pump by sending a signal directly to the lift pump. The ECM cycles the lift pump on for 30 seconds after turning on the keyswitch.

Component Location

The lift pump is mounted to the engine block on the intake side, toward the rear of the engine.

Shop Talk

This fault code is set by an internal timer expiring within the engine control system code if the lift pump does not complete its pre-charge of the fuel system. In hard-to-diagnose cases, it can be useful to disconnect the OEM harness and run dedicated battery power and ground.

Refer to Troubleshooting Fault Code t05-278

Last Modified: 16-Dec-2010


Injection Control Valve Stator Circuit

FAULT CODE 279

Injection Control Valve Stator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 279 PID: S018 SPN: 633 FMI: 6 LAMP: Yellow SRT: | Low or no current detected on injection control valve stator return pin 7. | Engine power derate.
Injection Control Valve Stator Circuit

Circuit Description

The injection control valve regulates both the quantity of fuel that is injected into each cylinder and the timing of the injection event. The injection control valve stator is the electronic solenoid that actuates the injection control valve. The electronic control module (ECM) commands the stator to actuate the injection control valve to open based on several different parameters, including fuel pressure, engine speed, and throttle position.

Component Location

The injection control valve is located on the fuel injection pump on the top of the distributor. The injection control valve stator is mounted onto the front side of the injection control valve via four capscrews.

Shop Talk

This fault code is primarily caused by an open circuit in the injection control valve stator circuit.

Refer to Troubleshooting Fault Code t05-279

Last Modified: 16-Dec-2010


Pumping Element

FAULT CODE 281 or 282

Pumping Element

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 281 or 282 PID: S151 or S152 SPN: 1347 or 1348 FMI: 7 LAMP: Yellow SRT: | FC 281: Engine ECM has detected a failure in the front pumping element. FC 282: Engine ECM has detected a failure in the rear pumping element. | Possible no effect or engine power derate.
Pumping Element

Circuit Description

These faults are due to a failure internal to the Cummins accumulator pump system (CAPS). The pump must be sent to Cummins ReCon® for repairs. Blowshut is a condition that results when the fuel being moved, as the pumping plunger travels upwards, causes the PCV to close before the electronic control module (ECM) commands the PCV to close.

Component Location

The pumping element is part of the CAPS fuel injection pump.

Shop Talk

Overspeed of the engine could cause this fault.

Refer to Troubleshooting Fault Code t05-281

Last Modified: 16-Dec-2010


Pumping Element

FAULT CODE 281 or 282

Pumping Element

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 281 or 282 PID: S151 or S152 SPN: 1347 or 1348 FMI: 7 LAMP: Yellow SRT: | FC 281: Engine ECM has detected a failure in the front pumping element. FC 282: Engine ECM has detected a failure in the rear pumping element. | Possible no effect or engine power derate.
Pumping Element

Circuit Description

These faults are due to a failure internal to the Cummins accumulator pump system (CAPS). The pump must be sent to Cummins ReCon® for repairs. Blowshut is a condition that results when the fuel being moved, as the pumping plunger travels upwards, causes the PCV to close before the electronic control module (ECM) commands the PCV to close.

Component Location

The pumping element is part of the CAPS fuel injection pump.

Shop Talk

Overspeed of the engine could cause this fault.

Refer to Troubleshooting Fault Code t05-282

Last Modified: 16-Dec-2010


Engine Speed Sensor

FAULT CODE 283 or 284

Engine Speed Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 283 or 284 PID: P190 SPN: 190 FMI: 3 or 4 LAMP: Yellow SRT: | FC 283: High voltage detected at main engine speed sensor voltage supply pin 8 of the engine harness. FC 284: Low voltage detected at main engine speed sensor voltage supply pin 8 of the engine harness. | The electronic control module (ECM) will use the engine speed sensor signal as a backup. Possible white smoke.
Engine Speed Sensor

Circuit Description

The engine speed sensor provides engine speed and position information to the electronic control module (ECM). The sensor must be powered by +5 VDC to operate. The sensor generates its signals by sensing the movement of target teeth cut into a steel ring fastened to the backside of the camshaft gear. This ring has 71 teeth and a gap where the 72nd tooth would be placed. This missing tooth indicates that cylinder 1 (and 6) is at top dead center.

Component Location

The engine speed sensor is located on the backside of the gear housing, between the fuel injection pump and the air compressor.

Refer to Troubleshooting Fault Code t05-283

Last Modified: 16-Dec-2010


Engine Speed Sensor

FAULT CODE 283 or 284

Engine Speed Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 283 or 284 PID: P190 SPN: 190 FMI: 3 or 4 LAMP: Yellow SRT: | FC 283: High voltage detected at main engine speed sensor voltage supply pin 8 of the engine harness. FC 284: Low voltage detected at main engine speed sensor voltage supply pin 8 of the engine harness. | The electronic control module (ECM) will use the engine speed sensor signal as a backup. Possible white smoke.
Engine Speed Sensor

Circuit Description

The engine speed sensor provides engine speed and position information to the electronic control module (ECM). The sensor must be powered by +5 VDC to operate. The sensor generates its signals by sensing the movement of target teeth cut into a steel ring fastened to the backside of the camshaft gear. This ring has 71 teeth and a gap where the 72nd tooth would be placed. This missing tooth indicates that cylinder 1 (and 6) is at top dead center.

Component Location

The engine speed sensor is located on the backside of the gear housing, between the fuel injection pump and the air compressor.

Refer to Troubleshooting Fault Code t05-284

Last Modified: 16-Dec-2010


J1939 Datalink Multiplexing

FAULT CODE 285

J1939 Datalink Multiplexing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9 LAMP: Yellow SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough, or did not receive it at all. | At least one multiplexed device will not operate properly.
J1939 Datalink Multiplexing Circuit

Circuit Description

Inputs, such as throttle pedals, switches, and sensors, can be communicated to the ECM over the J1939 datalink. Messages sent from the vehicle electronic control units (VECUs) are received by the ECM and used for controlling the engine. Both the ECM and VECU must be properly configured so that each device's information is transmitted by the VECU and received by the ECM.

Component Location

The ECM is located on the intake side of the engine, about mid-engine. The J1939 datalink wiring and VECU(s) vary by OEM options.

Shop Talk

This fault occurs when the ECM is set up to receive information about a multiplexed device from a VECU over the J1939 datalink and does not receive a message with that information. This fault can also be caused if the ECM does not receive the information fast enough to control the engine properly. This condition can be caused by the J1939 datalink having an electrical problem, a lack of terminating plugs on the J1939 datalink backbone, the ECM not being set up to receive information, a multiplexed device that truly is not multiplexed, or a VECU not being correctly set up to transmit information on one of its multiplexed devices.

Refer to Troubleshooting Fault Code t05-285

Last Modified: 16-Dec-2010


J1939 Datalink Multiplexing

FAULT CODE 286

J1939 Datalink Multiplexing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13 LAMP: Yellow SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
J1939 Datalink Multiplexing Circuit

Circuit Description

Inputs, such as throttle pedals, switches, and sensors, can be communicated to the ECM over the J1939 datalink. Messages sent from the vehicle electronic control units (VECUs) are received by the ECM and used for controlling the engine. Both the ECM and VECU must be properly configured so that each device's information is transmitted by the VECU and received by the ECM.

Component Location

The ECM is located on the intake side of the engine, about mid-engine. The J1939 datalink wiring and VECU(s) vary by OEM options.

Shop Talk

This fault occurs when the ECM is set up to receive information from several multiplexed switches from VECU(s) and only receives some of the switches. It indicates the ECM is set up to receive too many switches or the VECU(s) is set up to transmit too few switches.

Refer to Troubleshooting Fault Code t05-286

Last Modified: 16-Dec-2010


OEM Pressure - Engine Protection

FAULT CODE 296

OEM Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 296 PID: P223 SPN: 1387 FMI: 14 (J1587), 14 (J1939) LAMP: Red SRT: | OEM pressure signal at pin 48 of the OEM harness indicates pressure outside the engine protection limit. | Speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
OEM Pressure Sensor Circuit

Circuit Description

The OEM pressure sensor is used by the electronic control module (ECM) to monitor an OEM-specific pressure sensor. The ECM monitors the voltage on signal pin 48 and converts this to a pressure value. The OEM pressure value is used by the ECM for the engine/vehicle protection system.

Component Location

The OEM pressure sensor is located in different locations depending on the OEM and equipment model. Refer to the OEM manual.

Shop Talk

Verify with the driver the engine operating condition when the fault occurs. Depending on the engine speed and load, the OEM pressure can fall below or exceed the engine protection limits. The sensor can be used to detect fluid pressure that is too low or too high. Refer to the OEM manual for more information.

Refer to Troubleshooting Fault Code t05-296

Last Modified: 16-Dec-2010


OEM Pressure Sensor Circuit

FAULT CODE 297

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 297 PID: P223 SPN: 1084 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the original equipment manufacturer's (OEM) pressure sensor signal. | Default value used for OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM sensor signal is used by the electronic control module (ECM) to monitor the OEM pressure. The OEM pressure is used by the ECM in one of two ways:

A sensor that has failed high can be caused by an open circuit in the signal or return wire, voltage shorts in the signal or return wire, or a faulty sensor.

1. The ECM can shut down the engine based on an OEM pressure input value exceeding or falling below a customer-specified value.

2. The ECM can control a device (dual output driver A and driver B) based on the value of the OEM pressure.

Component Location

The location varies with the OEM. Refer to the OEM manual.

Shop Talk

The sensor voltage signal is the responsibility of the OEM. Refer to the OEM manual for specifications.

Refer to Troubleshooting Fault Code t05-297

Last Modified: 16-Dec-2010


OEM Pressure Sensor Circuit

FAULT CODE 298

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 298 PID: P223 SPN: 1084 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the original equipment manufacturer's (OEM) pressure sensor signal. | Default value used for OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM sensor signal is used by the electronic control module (ECM) to monitor the OEM pressure. The OEM pressure is used by the ECM in one of two ways:

A sensor that has failed low can be caused by shorts to ground on the signal wire or an internally grounded (faulty) sensor.

1. The ECM can shut down the engine based on an OEM pressure input value exceeding or falling below a customer-specified value.

2. The ECM can control a device (dual-output driver A and driver B) based on the value of the OEM pressure.

Component Location

The location varies with the OEM. Refer to the OEM manual.

Shop Talk

The resistance of all pressure sensors varies with the pressure. Refer to the OEM troubleshooting and repair manual for specifications.

Refer to Troubleshooting Fault Code t05-298

Last Modified: 16-Dec-2010


Real Time Clock - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real Time Clock - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Amber (Maintenance Flashout) SRT: | Real-Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect. Real-time clock lost power. | None on performance. Data in the engine control module (ECM) will not have accurate time and date information.
ISF2.8 CM2220/ISF2.8 CM2220 EC/ISF2.8 CM2220 AN/ISF3.8 CM2220/ISF3.8 CM2220 AN - Real Time Clock Power Circuit
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN - Real Time Clock Power Circuit
ISM11 CM876 SN - Real Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the ECM is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness, if equipped.

Component Location

The real-time clock battery is secured to the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the real-time clock battery voltage is 3.3-VDC.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light and/or illuminates the malfunction indicator lamp (MIL) at initial key-on when the diagnostic runs and fails.
  • The real-time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or damaged real-time clock battery, damaged wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code 319.

Last Modified: 28-Oct-2015


Rear Pumping Element

FAULT CODE 328

Rear Pumping Element

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 328 PID: S152 SPN: 1348 FMI: 7 LAMP: Yellow SRT: | The electronic control module (ECM) has detected a malfunction in the rear pumping element. | Derate in power output of the engine.
Rear Pumping Element

Circuit Description

The rear pumping element consists of the rear barrel and plunger, rear pumping control valve, and rear check valve in the accumulator. These components are part of the accumulator module. The pumping element is responsible for pumping fuel into the accumulator and maintaining the desired pressure in the accumulator.

Component Location

The rear pumping element is part of the Cummins® accumulator pump system (CAPS) fuel pump in the accumulator module.

Shop Talk

  • A plugged fuel filter can cause both Fault Code 275 and Fault Code 328 to be logged intermittently.
  • If Fault Code 275 and Fault Code 328 are both present, check fuel filter restriction.
  • A damaged engine harness could also cause this fault code to be active.
  • If Fault Code 273 or Fault Code 274 is active, troubleshoot it first.
Refer to Troubleshooting Fault Code t05-328

Last Modified: 16-Dec-2010


Fuel Injection Pump

FAULT CODE 329

Fuel Injection Pump

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 329 PID: S233 SPN: 1077 FMI: 12 LAMP: None SRT: | Engine ECM has detected an overpumping malfunction in the Cummins accumulator pump system (CAPS) pump. | Low power; possible engine shutdown.
CAPS Injection Pump

Circuit Description

The ECM monitors several variables, including accumulator pressure, valve close angle, and injection control valve open-time, to determine if the pump has malfunctioned.

Component Location

The CAPS fuel injection pump is located on the intake side of the engine.

Shop Talk

Fault Code 329 can result due to one or more of the following:

  • Other fault codes that are caused by bad grounds. Make sure to troubleshoot other fault codes before following the 329 fault code troubleshooting tree.
  • High fuel inlet restrictions and/or air in the fuel can set the fault code.
  • Fuel that does not meet Fuels for Cummins Engines, Bulletin 3379001, criteria, specifically density and viscosity, has also been know to set fault code 329.
  • High fuel inlet temperatures can also set fault code 329. Fuel temperatures at the inlet to the gear pump should not exceed 60°C [140°F] on ISC and 71°C [160°F] on ISL engines (Not the INSITE electronic service tool temperature reading).
  • This fault code could also be caused by a fuel leak in the sealing plate between the injection control valve and the distributor. The injection control valve module should be replaced if a fuel leak in the sealing plate has been identified. Refer to Procedure 005-078 in the ISC Bulletin 4021418
  • Fault Code 329 can be caused by broken internal injection control valve components and/or by poor lubricity fuel which scuffed the internal components of the injection control valve.
Refer to Troubleshooting Fault Code t05-329

Last Modified: 16-Dec-2010


Auxiliary Speed or Auxiliary Pressure Input Error

FAULT CODE 349

Auxiliary Speed or Auxiliary Pressure Input Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 349 PID: P191 SPN: 191 FMI: 0 LAMP: Yellow SRT: | The auxiliary speed or auxiliary pressure indicates the frequency is above a calibrated threshold value. | Engine will go to idle and lose ability to control the speed of the auxiliary device.
Auxiliary Speed and Pressure Input Circuit

Circuit Description

The auxiliary governor's input is either a frequency signal from an auxiliary speed sensor or a pressure signal from an OEM pressure sensor. It is sent to the electronic control module (ECM) and is used to control the engine speed.

Component Location

The auxiliary speed sensor or pressure sensor location is dependent on the original equipment manufacturer's (OEM) application. Refer to OEM manual for component location.

Shop Talk

The auxiliary speed governor controls engine speed based on a measured auxiliary speed or pressure. The auxiliary speed governor feature must be enabled using INSITE™ and configured properly in the OEM-specific calibration for speed or pressure.

Refer to Troubleshooting Fault Code t05-349

Last Modified: 16-Dec-2010


Sensor Supply Circuit

FAULT CODE 352 or 386

Sensor Supply Circuit

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: 352 or 386
PID: S232
SPN: 620
FMI: 4 or 3
LAMP: Yellow
SRT:

FC 352: Sensor Supply Circuit - Low voltage detected at engine position sensor +5-volts direct current (VDC) supply, pin 10 of the engine harness.

FC 386: Sensor Supply Circuit - High voltage detected at engine position sensor +5-VDC supply, pin 10 of the engine harness.

Default value used for sensors connected to this +5-VDC supply. Engine will derate to no-boost fueling and loss of engine protection for oil pressure, intake manifold pressure, ambient air pressure, and fuel pressure.

Sensor Supply Circuit

Circuit Description

The engine position sensor (EPS), the intake manifold pressure sensor, the oil pressure sensor, the ambient air pressure sensor, and the fuel pressure sensor are powered by the same +5-VDC source and the same return in the engine control module (ECM). This supply is also used to operate the intake manifold air temperature and coolant temperature sensors.

Component Location

The +5-VDC sensor supply circuit is located in the engine harness. See Section E of this manual the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271, for the sensor locations.

Shop Talk

The faults could also cause high- or low-voltage faults on the coolant temperature and intake manifold air temperature sensors.

Refer to Troubleshooting Fault Code t05-352

Last Modified: 03-Dec-2014


Intake Air Heater Relay Circuit

FAULT CODE 381 or 382

Intake Air Heater Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 381 or 382 PID: S237 SPN: 626 FMI: 2 LAMP: Yellow SRT: | FC 381: Error detected in the cold-start air relay 1 enable circuit at pin 41 of the original equipment manufacturer (OEM) harness. FC 382: Error detected in the cold-start air relay 2 enable circuit at pin 31 of the OEM harness. | Intake air heater can not be energized by the electronic control module (ECM). Possible white smoke and/or hard starting in cold ambient conditions.
Intake Air Heater Relay Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The ECM controls relays that switch power to the air heater. There are two heating coils in the heater that are individually controlled by the ECM.

Component Location

The intake air heater is located under the air inlet coverplate on the intake manifold. The location of the heater relays will vary with OEM.

Refer to Troubleshooting Fault Code t05-381

Last Modified: 16-Dec-2010


Intake Air Heater Relay Circuit

FAULT CODE 381 or 382

Intake Air Heater Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 381 or 382 PID: S237 SPN: 626 FMI: 2 LAMP: Yellow SRT: | FC 381: Error detected in the cold-start air relay 1 enable circuit at pin 41 of the original equipment manufacturer (OEM) harness. FC 382: Error detected in the cold-start air relay 2 enable circuit at pin 31 of the OEM harness. | Intake air heater can not be energized by the electronic control module (ECM). Possible white smoke and/or hard starting in cold ambient conditions.
Intake Air Heater Relay Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The ECM controls relays that switch power to the air heater. There are two heating coils in the heater that are individually controlled by the ECM.

Component Location

The intake air heater is located under the air inlet coverplate on the intake manifold. The location of the heater relays will vary with OEM.

Refer to Troubleshooting Fault Code t05-382

Last Modified: 16-Dec-2010


Remote Accelerator Control Circuit

FAULT CODE 385 or 444

Remote Accelerator Control Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 385 or 444 PID: S232 SPN: 620 FMI: 3 or 1 LAMP: Yellow SRT: | FC 385: High voltage detected at remote accelerator position sensor supply pin 10 of the original equipment manufacturer (OEM) harness. FC 444: Low voltage detected at remote accelerator position sensor supply pin 10 of the OEM harness. | Sensors connected to this +5-VDC supply will not function.
Remote Accelerator Control Circuit

Circuit Description

The remote accelerator control assembly contains the remote accelerator position sensor. This sensor sends the accelerator percentage requested by the operator to the electronic control module (ECM). Remote accelerator is used by the ECM to determine fueling. In order for the remote accelerator position sensor to function properly, it is necessary that a good +5-VDC supply voltage be available.

Note: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The remote accelerator position sensor is located on the remote accelerator control assembly somewhere outside the cab.

Refer to Troubleshooting Fault Code t05-385

Last Modified: 16-Dec-2010


Accelerator Position Sensor Circuit

FAULT CODE 387 or 443

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 387 or 443 PID: P091 or S232 SPN: 091 or 620 FMI: 3 or 1 LAMP: Yellow SRT: | FC 387: High voltage detected at accelerator position sensor supply pin 29 of the original equipment manufacturer's (OEM) harness. FC 443: Low voltage detected at accelerator position sensor supply pin 29 of the OEM harness. | Engine idles when accelerator idle validation switch indicates idle and ramps up to a default set speed when idle validation switch indicates off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator pedal assembly with accelerator position sensor relays the accelerator percentage requested by the operator to the electronic control module (ECM). Percent accelerator is used by the ECM to determine fueling. In order for the accelerator position sensor to function properly, it is necessary that a good +5-VDC supply voltage be available.

Component Location

The accelerator position sensor is located on the accelerator pedal inside the vehicle cab.

Refer to Troubleshooting Fault Code t05-387

Last Modified: 16-Dec-2010


Fault Code Path Selection

FAULT CODE 415
Fault Code Path Selection

Do you have an Oil Pressure Sensor? | Go to 71-fc415sn
Do you have an Oil Pressure Switch? | Go to 71-fc415sw

Last Modified: 27-Jan-2004


Water-In-Fuel (WIF) Sensor Circuit

FAULT CODE 418

Water-In-Fuel (WIF) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 097 FMI: 0 LAMP: WIF SRT: | Water-in-fuel signal indicates the water in the fuel filter needs to be drained. | Excessive water in the fuel can lead to severe fuel system damage.
WIF Sensor Circuit

Circuit Description

The WIF sensor is attached to the fuel filter. The WIF sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The WIF circuit contain two wires: A return ground (pin 20), and a signal wire (pin 40).

Component Location

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

The WIF sensor is installed in the bottom of the fuel filter, which is located on the side of the cylinder head approximately midengine.

Refer to Troubleshooting Fault Code t05-418

Last Modified: 12-Oct-2011


Coolant Level Sensor Circuit

FAULT CODE 422

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2 LAMP: Yellow SRT: | Voltage detected simultaneously on both the coolant level high and low signal pins 27 and 37 of the engine harness or no voltage detected on either pin. | No engine protection for coolant level.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness. This sensor is very complex. Do not use a multimeter to check the coolant level sensor. If the radiator coolant level drops below a certain level, a progressive power derate with increasing time after alert will occur.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and will vary in sensor location.

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the Weather-Pack four-way connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle makes a turn.
  • Make sure the correct ECM code is in the ECM. Calibrating the ECM with the incorrect DO option can cause Fault Code 422 to be active since some OEMs use a coolant level sensor that requires a special calibration. Refer to the OEM service manual.
Refer to Troubleshooting Fault Code t05-422

Last Modified: 16-Dec-2010


Water-In-Fuel (WIF) Sensor Circuit

FAULT CODE 429

Water-In-Fuel (WIF) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 097 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at WIF signal pin 40 of the original equipment manufacturer (OEM) harness. | No water-in-fuel detection.
WIF Sensor Circuit

Circuit Description

The WIF sensor is attached to the fuel filter. The WIF sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The WIF circuit contain two wires: A return ground (pin 20), and a signal wire (pin 40).

Component Location

The WIF sensor is installed in the bottom of the fuel filter and is located on the side of the cylinder head approximately midengine.

Shop Talk

The WIF sensor uses the same internal ECM power supply as sensors on engine harness. If Fault Code 352 is also active, use its troubleshooting logic and tree.

Refer to Troubleshooting Fault Code t05-429

Last Modified: 16-Dec-2010


Idle Validation Switch (IVS) Circuit

FAULT CODE 431 or 551

Idle Validation Switch (IVS) Circuit

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: 431 or 551
PID: P091
SPN: 091
FMI: 2 or 4
LAMP: Yellow
SRT:

FC 431: Idle validation signals on pins 25 and 26 of the OEM harness indicate no voltage simultaneously detected on both pins or no voltage detected on either pin.

FC 551: Idle validation signals on pins 25 and 26 of the OEM harness indicate voltage detected simultaneously on both pins.

FC 431: No effect on performance but loss of idle validation.

FC 551: Engine will only idle.

Idle Validation Switch Circuit

Circuit Description

The idle validation switch (IVS) is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal manufacturers to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The IVS is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired IVS.

A bad ground on pin A of the IVS can also cause this fault.

Refer to Troubleshooting Fault Code t05-431

Last Modified: 16-Dec-2010


Accelerator Pedal Circuit (ISS)

FAULT CODE 432

Accelerator Pedal Circuit (ISS)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: P091 SPN: 091 FMI: 13 LAMP: Yellow SRT: | No voltage detected at pin 26 of the original equipment manufacturer's (OEM) harness indicates the accelerator is at the idle position when the accelerator position signal at pin 30 of the OEM harness indicates the accelerator is not at the idle position or idle validation signal at pin 26 of the OEM harness indicates the accelerator is not at the idle position when the accelerator position signal pin 30 of the OEM harness indicates the accelerator is at the idle position. | No effect on engine.
Accelerator Pedal Circuit

Circuit Description

The accelerator pedal assembly relays the accelerator percentage requested by the operator to the electronic control module (ECM). Percent accelerator is used to determine fueling. The accelerator position sensor and the idle validation switch on the accelerator pedal are adjusted at the factory to provide the correct output signals.

Note: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor and the idle validation switch are located on the accelerator pedal in the cab.

Shop Talk

Confirm that the idle validation switch (IVS) is properly calibrated. Refer to the accelerator pedal manufacturer's instructions for adjustment information.

Note: The three wires in the accelerator position sensor circuit must be twisted together. Depending on ground location, IVS can, perhaps, only have two wires.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 16-Dec-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 433

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 433 PID: S102 FMI: 2 LAMP: Yellow SRT: | Boost pressure signal indicates boost pressure is high when other engine parameters (i.e., speed and load) indicate boost pressure can be low, or boost pressure is low when other engine parameters indicate it can be high. | Possible overfueling during acceleration. Increase in black smoke.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located in the rear of the intake manifold, in the second port on the side of the cylinder head to the right of the fuel filter.

Shop Talk

The ECM checks for this fault only at idle speed. If the intake manifold pressure shows too high of a value at this time, the ECM will log a fault code.

Refer to Troubleshooting Fault Code t05-433

Last Modified: 16-Dec-2010


Unswitched Battery Supply Circuit

FAULT CODE 434

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 434 PID: S251 SPN: 627 FMI: 2 LAMP: Yellow SRT: | Supply voltage to the electronic control module (ECM) fell below (+) 6.2 VDC for a fraction of a second, or the electronic control module (ECM) was not allowed to power down correctly (retain unswitched battery voltage for 30 seconds after key turned off). | None on performance. Fault information, trip information data, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There are three in-line 7.5-amp fuses and two 10-amp fuses in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the engine harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the equipment manufacturer. Refer to the equipment manufacturer repair manual.

Shop Talk

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 434.

Refer to Troubleshooting Fault Code t05-434

Last Modified: 16-Dec-2010


Unswitched Battery Supply Circuit

FAULT CODE 441

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1 LAMP: Yellow SRT: | Voltage detected at electronic control module (ECM) power supply pins 38, 39, 40, and 50 of the engine harness indicates ECM supply voltage fell below (+) 6 VDC. | Engine could possibly not start.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery input through the engine harness. There are three in-line 7.5-amp fuses and two 10-amp fuses in the unswitched battery wire of the engine harness to protect it from overheating.

Component Location

The ECM is connected to the battery by the engine harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the equipment manufacturer. Refer to the equipment manufacturer's repair manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Refer to Troubleshooting Fault Code t05-441

Last Modified: 16-Dec-2010


Unswitched Battery Supply Circuit

FAULT CODE 442

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0 LAMP: Yellow SRT: | Voltage detected at electronic control module (ECM) power supply pins 38, 39, 40, and 50 of the engine harness indicates ECM supply voltage is above the maximum system voltage level. | Possible ECM damage.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery input through the engine harness. There is two in-line 10-amp fuses and three 7.5-amp fuses in the unswitched battery wire to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the engine harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM manual for battery location.

Shop Talk

Disconnect all aftermarket devices from the battery supply circuit. Make sure the proper size fuses are being used (10-amp fuse or 7.5-amp fuse).

Refer to Troubleshooting Fault Code t05-442

Last Modified: 16-Dec-2010


Accelerator Position Sensor Circuit

FAULT CODE 387 or 443

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 387 or 443 PID: P091 or S232 SPN: 091 or 620 FMI: 3 or 1 LAMP: Yellow SRT: | FC 387: High voltage detected at accelerator position sensor supply pin 29 of the original equipment manufacturer's (OEM) harness. FC 443: Low voltage detected at accelerator position sensor supply pin 29 of the OEM harness. | Engine idles when accelerator idle validation switch indicates idle and ramps up to a default set speed when idle validation switch indicates off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator pedal assembly with accelerator position sensor relays the accelerator percentage requested by the operator to the electronic control module (ECM). Percent accelerator is used by the ECM to determine fueling. In order for the accelerator position sensor to function properly, it is necessary that a good +5-VDC supply voltage be available.

Component Location

The accelerator position sensor is located on the accelerator pedal inside the vehicle cab.

Refer to Troubleshooting Fault Code t05-443

Last Modified: 16-Dec-2010


Remote Accelerator Control Circuit

FAULT CODE 385 or 444

Remote Accelerator Control Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 385 or 444 PID: S232 SPN: 620 FMI: 3 or 1 LAMP: Yellow SRT: | FC 385: High voltage detected at remote accelerator position sensor supply pin 10 of the original equipment manufacturer (OEM) harness. FC 444: Low voltage detected at remote accelerator position sensor supply pin 10 of the OEM harness. | Sensors connected to this +5-VDC supply will not function.
Remote Accelerator Control Circuit

Circuit Description

The remote accelerator control assembly contains the remote accelerator position sensor. This sensor sends the accelerator percentage requested by the operator to the electronic control module (ECM). Remote accelerator is used by the ECM to determine fueling. In order for the remote accelerator position sensor to function properly, it is necessary that a good +5-VDC supply voltage be available.

Note: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The remote accelerator position sensor is located on the remote accelerator control assembly somewhere outside the cab.

Refer to Troubleshooting Fault Code t05-444

Last Modified: 16-Dec-2010


Fuel Pressure Sensor Circuit

FAULT CODE 449

Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P094 SPN: 094 FMI: 0 LAMP: Yellow SRT: | Fuel pressure signal indicates that fuel pressure has exceeded the maximum limit for the given engine rating. | Power and/or speed derate; engine can, perhaps, die.
Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure/temperature sensor is used by the electronic control module (ECM) to monitor the fuel temperature in the accumulator. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The fuel pressure/temperature sensor is located on the rear of the accumulator.

Shop Talk

A missing weather seal on the 4-pin fuel pressure sensor connector can cause this fault to log intermittently.

Overspeed of the engine can cause this fault.

Refer to Troubleshooting Fault Code t05-449

Last Modified: 16-Dec-2010


Fuel Pressure Sensor Circuit

FAULT CODE 451 or 452

Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 or 452 PID: P094 SPN: 94 FMI: 3 or 4 LAMP: Yellow SRT: | FC 451: High voltage detected at fuel pressure sensor signal pin 46 of the engine harness. FC 452: Low voltage detected at fuel pressure sensor signal pin 46 of the engine harness. | Power and/or speed derate; engine can, perhaps, run rough.
Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure/temperature sensor is used by the electronic control module (ECM) to monitor the fuel temperature in the accumulator. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The fuel pressure/temperature sensor is located on the rear of the accumulator.

Shop Talk

Damaged connector at the fuel pressure sensor or a missing weather seal could cause these faults to go active.

Refer to Troubleshooting Fault Code t05-451

Last Modified: 16-Dec-2010


Fuel Pressure Sensor Circuit

FAULT CODE 451 or 452

Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 or 452 PID: P094 SPN: 94 FMI: 3 or 4 LAMP: Yellow SRT: | FC 451: High voltage detected at fuel pressure sensor signal pin 46 of the engine harness. FC 452: Low voltage detected at fuel pressure sensor signal pin 46 of the engine harness. | Power and/or speed derate; engine can, perhaps, run rough.
Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure/temperature sensor is used by the electronic control module (ECM) to monitor the fuel temperature in the accumulator. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The fuel pressure/temperature sensor is located on the rear of the accumulator.

Shop Talk

Damaged connector at the fuel pressure sensor or a missing weather seal could cause these faults to go active.

Refer to Troubleshooting Fault Code t05-452

Last Modified: 16-Dec-2010


Fuel Pressure Sensor Circuit

FAULT CODE 456

Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 456 PID: P094 SPN: 94 FMI: 10 LAMP: Yellow SRT: | Fuel Pressure Sensor Circuit. Fuel pressure sensor stuck in range while engine is operating or fuel pressure sensor reading erratic in range. | Engine power derate; engine can run rough or die.
Cummins® Accumulator Pump System (CAPS) Injection Pump

Circuit Description

The fuel pressure sensor contains supply, signal, and return pins. The engine control module (ECM) provides 5 volts to the fuel pressure sensor for a supply voltage. The ECM supplies a shared ground from the fuel pressure sensor circuit. The signal voltage is variable depending on the pressure that is being generated inside the fuel pump accumulator.

This 5 volt power supply is a shared supply. Other sensors on this circuit include the engine speed sensor, engine position sensor, oil pressure sensor, intake manifold pressure sensor, and ambient air pressure sensor.

The shared ground for the fuel pressure sensor also connects to the injection control valve identifier, temperature sensor, intake manifold air temperature sensor, engine position sensor, oil pressure sensor, intake manifold pressure sensor, and ambient air pressure sensor.

Component Location

The fuel pressure sensor is located on the top rear of the fuel pump. The pressure sensor can be identified by its mounting location, rear center of the CAPS accumulator module.

Shop Talk

Possible causes of this fault code include:

  • Damaged fuel pressure sensor wiring (pig tail harness), sensor connections (pin fretting), or engine harness issues (shorts) which can cause the pressure signal to erratically spike up or down
  • Excessive fuel inlet restriction
  • Damaged fuel lift pump
  • Internal sensor malfunction.
Refer to Troubleshooting Fault Code t05-456.

Last Modified: 05-Feb-2013


Intake Manifold Air Temperature Sensor - Engine Protection Circuit

FAULT CODE 488

Intake Manifold Air Temperature Sensor - Engine Protection Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0 LAMP: Yellow SRT: | Intake manifold air temperature signal indicates the intake manifold air temperature is approaching the engine protection limit. | Power derate.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine intake air. The intake air temperature is used by the ECM for the engine protection system, and the timing and fueling control.

Component Location

The intake manifold temperature sensor is located on the side of the intake manifold, toward the rear of the cylinder head.

Shop Talk

This is a warning fault code. If the intake manifold air temperature continues to rise, Fault Code 155 will become active and shut down the engine.

  • Possible causes:- clogged, dirty, inadequate capacity air cleaner element.- intake restriction. 010-059 in the Troubleshooting and Repair Manual, ISC Engines, Bulletin No. 3666245.
Refer to Troubleshooting Fault Code t05-488

Last Modified: 16-Dec-2010


Auxiliary Speed or Auxiliary Pressure Input Error

FAULT CODE 489

Auxiliary Speed or Auxiliary Pressure Input Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 489 PID: P191 SPN: 191 FMI: 0 LAMP: Yellow SRT: | The auxiliary speed or auxiliary pressure indicates the frequency is below a calibrated threshold value. | Engine will go to idle and lose ability to control the speed of the auxiliary device.
Auxiliary Speed and Pressure Input Circuit

Circuit Description

The auxiliary governor's input is either a frequency signal from an auxiliary speed sensor or a pressure signal from an OEM pressure sensor. It is sent to the electronic control module (ECM) and is used to control the engine speed.

Component Location

The auxiliary speed sensor or pressure sensor location is dependent on the original equipment manufacturer's (OEM) application. Refer to OEM manual for component location.

Shop Talk

The auxiliary speed governor controls engine speed based on a measured auxiliary speed or pressure. The auxiliary speed governor feature must be enabled using INSITE™ and configured properly in the OEM-specific calibration for speed or pressure.

Refer to Troubleshooting Fault Code t05-489

Last Modified: 16-Dec-2010


Injection Control Valve Identifier Circuit

FAULT CODE 493

Injection Control Valve Identifier Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 493 PID: S018 SPN: 1076 FMI: 13 LAMP: None SRT: | The electronic control module (ECM) detected a failure in the injection control valve identifier circuit. | A 5-percent engine power derate.
Injection Control Valve Identifier Circuit

Circuit Description

The injection control valve identifier optimizes the quantity of fuel that is injected into each cylinder during an injection event. The identifier is matched with each individual injection control valve at the factory to maximize the performance of the CAPS pump.

Component Location

The injection control valve identifier is shrink-wrapped to the injection control valve pigtail, which is located on the CAPS fuel injection pump on the top of the distributor.

Shop Talk

A shrink-wrap sleeve is installed over the injection control valve pigtail and the injection control valve identifier. Tampering could possibly be suspected if the shrink-wrap or identifier is removed.

Refer to Troubleshooting Fault Code t05-493

Last Modified: 16-Dec-2010


Multiple Unit Synchronization Switch Error

FAULT CODE 497

Multiple Unit Synchronization Switch Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 497 PID: S114 SPN: 1377 FMI: 2 (J1587), 2 (J1939) LAMP: Yellow SRT: | Error detected in the multiple unit synchronization control switch input, pins 24 and 38 of the OEM harness. | Multiple unit synchronization feature will be disabled.
Multiple Unit Synchronization Switch Circuit

Circuit Description

The multiple unit synchronization uses a complimentary switch to provide two opposite signals into the ECM.

Component Location

The multiple unit synchronization switch is cab mounted. Refer to OEM manual for specific location.

Shop Talk

When the multiple unit synchronization switch is in the ON position, pin 24 must be grounded, and pin 38 must be open. When the multiple unit synchronization switch is in the OFF position, pin 24 must be open, and pin 38 must be grounded.

Refer to Troubleshooting Fault Code t05-497

Last Modified: 16-Dec-2010


Coolant Level Sensor Circuit

FAULT CODE 515 or 516

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: 515 or 516
PID: P091
SPN: 091
FMI: 3 or 4
LAMP: Yellow
SRT:

FC 515: High voltage detected at the auxiliary +5-VDC sensor supply voltage pin 49 of the engine harness.

FC 516: Low voltage detected at the auxiliary +5-VDC sensor supply voltage pin 49 of the engine harness.

No engine protection for coolant level.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and will vary in sensor location.

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the Weather-Pack four-way connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle makes a turn.
Refer to Troubleshooting Fault Code t05-515

Last Modified: 16-Dec-2010


Coolant Level Sensor Circuit

FAULT CODE 515 or 516

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: 515 or 516
PID: P091
SPN: 091
FMI: 3 or 4
LAMP: Yellow
SRT:

FC 515: High voltage detected at the auxiliary +5-VDC sensor supply voltage pin 49 of the engine harness.

FC 516: Low voltage detected at the auxiliary +5-VDC sensor supply voltage pin 49 of the engine harness.

No engine protection for coolant level.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and will vary in sensor location.

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the Weather-Pack four-way connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle makes a turn.
Refer to Troubleshooting Fault Code t05-516

Last Modified: 16-Dec-2010


Switched Droop Selection Circuit

FAULT CODE 524

Switched Droop Selection Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 524 PID: P113 FMI: 2 LAMP: Yellow SRT: | Error detected on the high-speed governor droop selection switch. | Droop setting defaults to switch position 1 (or normal) preprogrammed droop governor values.
Switched Droop Selection Circuit

Circuit Description

The switched droop circuit allows the operator to select from up to three preprogrammed droop governor values using a two- or three-position switch, depending on which the original equipment manufacturer (OEM) has provided.

Component Location

The location of the droop switch circuit varies with each OEM and equipment model. Refer to the OEM manual.

Shop Talk

The switch can be monitored for proper operation on INSITE™. If the switch is changing state correctly on the service tool, then the problem does not lie in the switch circuit. The three-position switch has three states:

  • Position 1 - open
  • Position 2 - closed
  • Position 3 - 1500 ohm resistance

The two-position switch has two states:

  • Position 1 - open
  • Position 2 - closed
Refer to Troubleshooting Fault Code t05-524

Last Modified: 16-Dec-2010


Dual Output Driver A

FAULT CODE 527

Dual Output Driver A

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: P154 SPN: 702 FMI: 3 LAMP: Yellow SRT: | A problem was detected with the dual output-driver A circuit. | The device controlled by the driver A output circuit will not function properly.
Dual-Output Driver A

Circuit Description

The dual-output driver A will control engine and vehicle functions by controlling original manufacturer's (OEM) devices based on up to 12 selected engine parameters and two selected OEM parameters (OEM switch input and OEM pressure input). The solenoid output will control functions such as a fan clutch, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The OEM device is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-527

Last Modified: 16-Dec-2010


Alternate (Switched) Torque Curve Switch Circuit

FAULT CODE 528

Alternate (Switched) Torque Curve Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 528 PID: P093 SPN: 093 FMI: 2 LAMP: Yellow SRT: | Error detected on the torque curve selection switch. | Torque curve setting defaults to the preprogrammed torque curve.
Alternate Torque Signal Circuit

Circuit Description

The torque curve switch circuit allows the operator to select from up to three preprogrammed torque curves using a two- or three-position switch, depending on which the original equipment manufacturer (OEM) has provided.

Component Location

The location of the torque curve switch circuit varies with each OEM and equipment model. Refer to the OEM manual.

Shop Talk

The switch can be monitored for proper operation in INSITE™. If the switch is changing state correctly on the service tool, then the problem does not lie in the switch circuit. The three position-switch has three states:

  • Position 1 - open
  • Position 2 - closed
  • Position 3 - 1500-ohm resistance

The two position-switch has two states:

  • Position 1 - open
  • Position 2 - closed
Refer to Troubleshooting Fault Code t05-528

Last Modified: 16-Dec-2010


Dual Output Driver B

FAULT CODE 529

Dual Output Driver B

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: S051 SPN: 703 FMI: 3 LAMP: Yellow SRT: | Error detected in the dual-output driver B circuit. | The device being controlled by the driver B output signal will not function properly.
Dual-Output Driver B

Circuit Description

The dual-output driver B will control engine and vehicle functions by controlling original equipment manufacturer's (OEM) devices based on up to 12 selected engine parameters and two selected OEM inputs (the OEM switch and the OEM pressure). The OEM device output will control functions such as a fan clutch, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The location of the OEM device is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-529

Last Modified: 16-Dec-2010


Transient Suppressor Circuit

FAULT CODE 539

Transient Suppressor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 539 PID: P018 SPN: 633 FMI: 11 LAMP: Yellow SRT: | Open circuit detected at the transient suppressor in the injection control valve circuit in the engine harness. | Possible white smoke and rough running.
Injection Control Valve Circuit

Circuit Description

The transient suppressor absorbs the extra current created when the injection control valve closes after an injection event. Without the transient suppressor, high voltage would be transmitted back into the ECM and damage the pump driver circuits.

Component Location

The transient suppressor extends from the trunk of the engine harness and is mounted with a p-clip to the engine block. It is a small copper colored cylinder with a red and a black wire extending from one end. It is located just below where the injection lines connect to the fuel pump. The injection control valve is located at the rear of the fuel injection pump, on the top of the distributor, and below the accumulator.

Shop Talk

When the transient suppressor is working normally, it will generate heat. Caution must be taken when working with it, as it can be hot. The heat generated in the transient suppressor is dependent on the speed of the engine.

Refer to Troubleshooting Fault Code t05-539

Last Modified: 16-Dec-2010


Fault Code Path Selection

FAULT CODE 551
Fault Code Path Selection

Do you have an ISS throttle pedal? | Go to 71-fc551iss
Do you have an NISS throttle pedal? | Go to 71-fc551niss
Do you have an SSS throttle pedal? | Go to 71-fc551sss

Last Modified: 20-Dec-2007


Output Device Driver (Transmission Shift Modulator)

FAULT CODE 768

Output Device Driver (Transmission Shift Modulator)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 768 PID: S009 SPN: 923 FMI: 11 LAMP: Yellow SRT: | Error detected in the output device driver (transmission shift modulation signal) signal pin 21 on the original equipment manufacturer's (OEM) harness. | Can not control the transmission.
Output Device Driver Circuit

Circuit Description

The output device driver is a device used by the electronic control module (ECM) to control the transmission shift modulation signal.

Component Location

Refer to an OEM diagram for the location of the transmission shift modulator.

Shop Talk

The output device driver could be malfunctioning due to a failed engine harness, a bad ground on the transmission shift modulator connector, or a bad transmission shift modulator.

Refer to Troubleshooting Fault Code t05-768

Last Modified: 16-Dec-2010


OEM Input - Engine Protection

FAULT CODE 779

OEM Input - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 779 PID: S051 SPN: 703 FMI: 11 LAMP: Yellow SRT: | OEM input signal indicates OEM value has exceeded the engine protection limit. | Speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
OEM Input Sensor Circuit

Circuit Description

The OEM device input to engine protection allows vehicle OEMs to wire up a device, such as a hydraulic oil temperature limit switch, transmission temperature limit switch, etc., to the ECM. The ECM will monitor values from this device the same as other engine protection inputs, such as coolant level, etc. If a threshold value is exceeded, engine speed derate will occur and possible engine shutdown.

Component Location

The location of the OEM device is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-779

Last Modified: 16-Dec-2010


OEM Pressure - Engine Protection

FAULT CODE 2194

OEM Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2194 PID: P223 SPN: 1387 FMI: 11 (J1587), 11 (J1939) LAMP: Yellow SRT: | OEM pressure signal at pin 48 of the OEM harness indicates pressure outside the engine protection limit. | Power derate and possible engine shutdown if engine protection shutdown feature is enabled.
OEM Pressure Sensor Circuit

Circuit Description

The OEM pressure sensor is used by the electronic control module (ECM) to monitor an OEM-specific pressure sensor. The ECM monitors the voltage on signal pin 48 and converts this to a pressure value. The OEM pressure value is used by the ECM for the engine/vehicle protection system.

Component Location

The OEM pressure sensor is located in different locations depending on the OEM and equipment model. Refer to the OEM manual.

Shop Talk

Verify with the driver the engine operating condition when the fault occurs. Depending on the engine speed and load, the OEM pressure can fall below or exceed the engine protection limits. The sensor can be used to detect fluid pressure that is too low or too high. Refer to the OEM manual for more information.

Refer to Troubleshooting Fault Code t05-2194

Last Modified: 16-Dec-2010


OEM Switch - Engine Protection

FAULT CODE 2195

OEM Switch - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2195 PID: S051 SPN: 703 FMI: 14 (J1587), 14 (J1939) LAMP: Red SRT: | OEM switch signal at pin 16 of the engine harness indicates engine protection condition. | Speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
OEM Switch Circuit

Circuit Description

The OEM switch is used by the electronic control module (ECM) to monitor an OEM-specific switch. The ECM monitors the signal on pin 16 for the engine/vehicle protection system.

Component Location

The OEM switch is located in different locations, depending on the OEM and equipment model. Refer to the OEM manual.

Shop Talk

Verify with the driver the engine operating condition when the fault occurs. Depending on the engine speed and load, the OEM switch can detect a condition that falls below or exceeds the engine protection limit. Refer to the OEM manual for more information.

Refer to Troubleshooting Fault Code t05-2195

Last Modified: 16-Dec-2010


Transmission ECU to ECM Communication - Abnormal Update Rate

FAULT CODE 2559

Transmission ECU to ECM Communication - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2559 PID: SPN: 1845 FMI: 4 LAMP: Amber SRT: | Transmission ECU to ECM Communication Lost - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected between the ECM and the transmission ECU. | None on performance.

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Component values and states from components such as sensors, accelerators, and switches can then be transmitted from the OEM VECU to the Cummins® ECM over the data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins Inc. ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The data link wiring and the devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, a malfunctioning OEM VECU, or a malfunctioning Cummins® ECM. It may be necessary to contact the OEM for the proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-2559.

Last Modified: 01-Jul-2016


Oil Pressure Sensor Circuit

FAULT CODE 141 (SN)

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: | High voltage detected at oil pressure sensor signal pin 33 of the engine harness. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, below and to the right of the ECM.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure signal voltage going into the ECM.
Refer to Troubleshooting Fault Code t05-141sn

Last Modified: 16-Dec-2010


Oil Pressure Switch Circuit

FAULT CODE 141 (SW)

Oil Pressure Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: | Low voltage detected on pin 47 of the engine harness. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Switch Circuit

Circuit Description

The oil pressure switch is used by the electronic control module (ECM) to monitor the lubricating oil pressure.

Component Location

The oil pressure switch is located on the engine block, below and to the right of the ECM.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure signal voltage going into the ECM.
  • If an oil pressure switch is installed, INSITE™ will read a constant value of 379 kPa [55 psi] ±2 kPa [±0.3 psi] if the ECM is reading a signal from the oil pressue switch.
  • The switch is a single wire device which requires engine block ground for operation.
  • Engine Protection will activate, if enabled, if the lubricating oil pressure drops below 41 kPa [6 psi] with the engine running.
Refer to Troubleshooting Fault Code t05-141sw

Last Modified: 16-Dec-2010


Oil Pressure - Engine Protection

FAULT CODE 143 (SN)

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1 LAMP: Yellow SRT: | Oil pressure signal indicates oil pressure below the low engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature enabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, below and to the right of the ECM.

Shop Talk

  • Confirm that the oil pressure sensor supply voltage is between (+) 4.5 and 5.25 VDC at the sensor.
  • Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed under load, the oil pressure can drop below the engine protection limits.
  • Connect a manual gauge to monitor engine oil pressure and compare to the value in INSITE™.
Refer to Troubleshooting Fault Code t05-143sn

Last Modified: 16-Dec-2010


Oil Pressure - Engine Protection With An Oil Pressure Switch

FAULT CODE 143 (SW)

Oil Pressure - Engine Protection With An Oil Pressure Switch

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1 LAMP: Yellow SRT: | Oil pressure signal indicates oil pressure below the low engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature enabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure switch is used by the electronic control module (ECM) to detect the presence of lubricating oil pressure.

Component Location

The oil pressure switch is located on the engine block, below and to the right of the ECM.

Shop Talk

  • Confirm that the oil pressure sensor supply voltage is between (+) 4.5 and 5.25 VDC at the sensor.
  • Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed under load, the oil pressure can drop below the engine protection limits.
  • Connect a manual gauge to monitor the actual oil pressure of the engine.
  • The fault will trigger if lubricating oil pressure drops below 41 kPa [6 psi] for 5 seconds while the engine is running.
  • Engines in the field can have had a jumper harness kit installed which connect the oil pressure switch to pin K in the 23-pin OEM connector or cavity 8 in the Ford OEM connector.
Refer to Troubleshooting Fault Code t05-143sw

Last Modified: 16-Dec-2010


Engine Brake Supply Circuit

FAULT CODE 243 (ISC)

Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 243 PID: P121 SPN: 513 FMI: 4 LAMP: SRT: | Error detected in engine brake relay enable circuit at pin 42 of the engine harness. | Engine brake will not work.
Engine Brake Relay Supply Circuit

Circuit Description

The electronic control module (ECM) enables the engine brake by sending a signal to the engine brake under certain conditions.

Component Location

Refer to the original equipment manufacturer's (OEM) diagram for the location of the engine brake.

Refer to Troubleshooting Fault Code t05-243isc

Last Modified: 16-Dec-2010


Engine Brake Supply Circuit

FAULT CODE 243 (ISL)

Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 243 PID: P121 SPN: 513 FMI: 4 LAMP: SRT: | Error detected in engine brake relay enable circuit at pin 42 of the engine harness. | Engine brake will not work.
Engine Brake Relay Supply Circuit

Circuit Description

The electronic control module (ECM) enables the engine brake by sending a signal to the engine brake under certain conditions.

Component Location

Refer to the original equipment manufacturer's (OEM) diagram for the location of the engine brake.

Shop Talk

The OEM could possibly have installed an engine brake level selector switch. This switch would allow the operator to choose the level of braking.

Refer to Troubleshooting Fault Code t05-243isl

Last Modified: 16-Dec-2010


Oil Pressure - Engine Protection

FAULT CODE 415 (SN)

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Red SRT: | Oil pressure signal indicates oil pressure below the very low engine protection limit. | Power and/or speed derate and possible engine protection shutdown if feature is enabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block below the ECM.

Shop Talk

Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filters change
Refer to Troubleshooting Fault Code t05-415sn

Last Modified: 16-Dec-2010


Oil Pressure - Engine Protection With An Oil Pressure Switch

FAULT CODE 415 (SW)

Oil Pressure - Engine Protection With An Oil Pressure Switch

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Red SRT: | Oil pressure signal indicates oil pressure below the very low engine protection limit. | Power and/or speed derate and possible engine protection shutdown if feature is enabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure switch is used by the electronic control module (ECM) to detect the presence of lubricating oil pressure.

Component Location

The oil pressure switch is located on the engine block below the ECM.

Shop Talk

  • Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.
  • Connect a manual gauge to monitor actual oil pressure of the engine.
  • Engines in the field can have had a jumper harness kit installed which connects the oil pressure switch to pin K in the 23-pin OEM connector or cavity 8 in the Ford OEM connector.
  • The fault will trigger if lubricating oil pressure drops below 41 kPa [6 psi] for 30 seconds. Engine Protection Shutdown will be activated after an additional 30 seconds if the feature is enabled in the ECM.
Refer to Troubleshooting Fault Code t05-415sw

Last Modified: 16-Dec-2010


Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 551 (ISS)

Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source. No voltage detected simultaneously on both the idle validation and off-idle and on-idle switches. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal or lever manufacturers to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other OEM cab switches.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by a short circuit to ground in the harness, an uncalibrated accelerator pedal or lever assembly, or a miswired idle validation switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position, and fully depress and release the pedal or lever 3 times.
Refer to Troubleshooting Fault Code t05-551iss

Last Modified: 16-Dec-2010


Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 551 (NISS)

Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source. No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal or lever manufacturers to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other OEM cab switches.

Component Location

The nonintegrated sensor switch (NISS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by a short circuit to ground in the harness, an uncalibrated accelerator pedal or lever assembly, or a miswired idle validation switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal or lever 3 times.
Refer to Troubleshooting Fault Code t05-551niss

Last Modified: 16-Dec-2010


Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 551 (SSS)

Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source. No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal or lever manufacturers to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other OEM cab switches.

Component Location

The solid state sensor switch (SSS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by a short circuit to ground in the harness, an uncalibrated accelerator pedal or lever assembly, or a miswired idle validation switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position, and fully depress and release the pedal or lever 3 times.
Refer to Troubleshooting Fault Code t05-551sss

Last Modified: 16-Dec-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


NO TITLE

Information Fault Codes

NOTE: - Information Fault Codes have simple, corrective actions and no fault code troubleshooting tree.
- SRT 00-394 applies to all of the Information Fault Codes listed below.
- After correcting the condition that caused the fault, let the engine warm up, then let the engine run for 1 minute to inactivate the fault code. Then, use INSITE™ to clear the fault code.

CODE: 211
LAMP: None
REASON: This fault indicates that the vehicle's electronic control unit (VECU), provided by the OEM, detected an active fault in the vehicle's control system.
EFFECT: None on performance.
ACTION: Refer to the OEM for proper repair procedure. Clear inactive fault code using INSITE™ after OEM problem is corrected.
CODE: 287
LAMP: Yellow
REASON: The OEM vehicle electronic control unit (VECU) detected a fault with its accelerator pedal.
EFFECT: The engine will only idle.
ACTION: Refer to the OEM troubleshooting and repair manual. Troubleshoot the accelerator pedal connected to the OEM supplied vehicle electronic control unit (VECU).
CODE: 288
LAMP: Yellow
REASON: The OEM vehicle electronic control unit (VECU) detected a fault with its remote throttle.
EFFECT: The engine will only idle.
ACTION: Refer to the OEM troubleshooting and repair manual. Troubleshoot the remote throttle pedal connected to the OEM supplied vehicle electronic control unit (VECU).
CODE: 319
LAMP: Maintenance or none
REASON: Real-time clock lost power. Unswitched battery power to the ECM has been interrupted.
EFFECT: None on performance. Data in the ECM will not have accurate time and date information.
ACTION: Set real-time clock using RoadRelay™ (if equipped) or by using INSITE™.
CODE: 599
LAMP: Red
REASON: The dual-output feature in this customer-specialized calibration has initiated an engine shutdown based on operating conditions, engine sensor values, or OEM inputs to the ECM.
EFFECT: Engine will shut down.
ACTION: The dual-output feature is contained only in customer-specialized calibrations. The feature can be set up to shut down the engine based on operating conditions, engine sensor values, or OEM inputs to the ECM. The two OEM inputs are OEM switch input and OEM pressure input. The technician must contact Cummins Engine Company to determine the dual output feature's configuration to understand which parameters and what parameter value(s) are causing the engine to shut down.
CODE: 611
LAMP: None
REASON: The engine was shut down with the keyswitch before proper engine cooldown.
EFFECT: No action is taken by the ECM.
ACTION: Hot shutdowns damage engine components and shorten engine life. Refer to the engine operation and maintenance manual for proper cooldown techniques.

Last Modified: 22-Jan-2003


FAULT CODE 111 - Engine Control Module (ECM) Microprocessor

Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 111 inactive
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • turn the keyswitch to the ON position.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Less than 3 counts

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 111 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-Jul-2012


FAULT CODE 115 - Engine Speed Sensor (ESS) Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the ESS. |
 | STEP 2A. Inspect the ESS and engine harness connectors. | No damaged pins
 | STEP 2B. Check the ESS supply voltage. | (+) 4.5 to 5.25 VDC
 | STEP 2C. Check for signal from the ESS. | Signal present
 | STEP 2D. Inspect the nose of sensor. | No damage found
 | STEP 2E. Check the air gap between the engine speed sensor and the camshaft ring gear. | Sensor maintains the appropriate air gap.
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 115 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the ESS.

Action

Check for an open circuit in the +5-VDC supply wire and the signal wire.

  • Measure the resistance from pin 8 of the engine harness connector to pin A on the harness side of the ESS connector.
  • Measure the resistance from pin 17 of the engine harness connector to pin C on the harness side of the ESS connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the ESS.

Action

Check for a short circuit to ground in the +5-VDC supply wire and the signal wire.

  • Measure the resistance from pin 8 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 17 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the ESS.

Action

Check for a short circuit from pin to pin in the +5-VDC supply wire and the signal wire.

  • Measure resistance from pin 8 and 17 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ESS.

Guided Step 2A - Inspect the ESS and the engine harness connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ESS.
  • Connect the engine harness to the ECM.

Action

Inspect the ESS and the engine harness connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ESS. Refer to Procedure 019-042 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check ESS supply voltage.

Conditions

  • Turn the keyswitch to the ON position.
  • Disconnect the engine harness from the ESS.
  • Connect the engine harness to the ECM.

Action

Check ESS supply voltage.

  • Measure the voltage from pin A to pin B on the harness side of the ESS connector.
OK NOT OK

(+) 4.5 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for signal from the ESS.

Conditions

  • Turn the keyswitch to the ON position.
  • Install breakout cable, Part Number 3824775, between the ESS and the engine harness.

Action

Check for signal from the ESS.

  • Measure the voltage from pin C to pin B on the breakout cable while barring the engine over.
OK NOT OK

Signal present

Replace the ESS. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the nose of sensor.

Conditions

  • Turn the keyswitch to the OFF position
  • Remove sensor from engine.

Action

Inspect nose of sensor for damage or debris:

  • Inspect for metal debris on sensor tip
  • Inspect for damage on sensor caused by camshaft gear
  • Inspect for sensor swelling.
OK NOT OK

No damage found

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2E

Go to 2E

Guided Step 2E - Check the air gap between the engine speed sensor and the camshaft ring gear.

Conditions

  • Install the speed sensor.

Action

Check and adjust the speed sensor air gap.

  • Check the air gap between the ESS/EPS and the camshaft ring gear. Since the EPS and ESS are mounted on the same boss, the air gap can be measured using the outside sensor bore. This measurement can usually be taken without removing the air compressor.
  • Bar the engine over 2 full revolutions (clockwise facing the front of the engine).
  • Use a depth micrometer and measure the distance from the face of the gear housing boss to the face of the camshaft ring gear. Record this measurement “A”.
  • Measure the gap in 45 degree camshaft rotation increments. If the measurements “A” varies by more than 0.051 mm [0.002 in] the tone wheel is warped, or the camshaft gear is walking.
  • Next measure the sensor. Again using a depth micrometer, measure the distance from the bottom of the sensor mounting flange to the tip of the threaded end of the sensor. Record this as measurement “B”. The air gap can be calculated by subtracting B from A (air gap measurement equals A minus B). If the air gap is less than 0.406 mm [0.016 in] add a 0.508 mm [0.020 in] shim to sensor.
OK NOT OK

Sensor maintains the appropriate air gap.

Sensor maintains the appropriate air gap.

Go to 3A

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault codes.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 115 is inactive.
OK NOT OK

Fault Code 115 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic Service Tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 121 - Engine Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes |
 | STEP 1A. Read the fault codes | Fault codes 352 and 386 inactive
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the EPS. |
 | STEP 3A. Inspect the EPS and engine harness connectors. | No damaged pins
 | STEP 3B. Check EPS supply voltage. | (+) 4.5 to 5.25-VDC
 | STEP 3C. Check for signal from the EPS. | Signal present
 | STEP 3D. Inspect the nose of sensor. | No damage found
 | STEP 3E. Check the air gap between the engine position sensor and the camshaft ring gear. | Sensor maintains the appropriate air gap.
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 121 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure must not be followed.

OK NOT OK

Fault Codes 352 and 386 inactive

Possible sensor failure, a short circuit to ground in the sesnor +5-VDC common supply, or a short circuit from pin to pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EPS.

Action

Check for an open circuit in the +5-VDC supply wire and the signal wire.

  • Measure the resistance from pin 9 of the engine harness connector to pin C on the harness side of the EPS connector.
  • Measure the resistance from pin 10 of the engine harness connector to pin A on the harness side of the EPS connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EPS.

Action

Check for a short circuit to ground in the +5-VDC supply wire and the signal wire.

  • Measure the resistance from pin 9 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EPS.

Action

Check for a short circuit from pin to pin in the signal wire.

  • Measure resistance from pin 9 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the EPS.

Guided Step 3A - Inspect the EPS and the engine harness connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the EPS.
  • Connect the engine harness to the ECM.

Action

Inspect the EPS and the engine harness connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position sensor (EPS). Refer to Procedure 019-038 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check EPS supply voltage.

Conditions

  • Turn the keyswitch to the ON position.
  • Disconnect the engine harness from the EPS.
  • Connect the engine harness to the ECM.

Action

Check EPS supply voltage.

  • Measure the voltage from pin A to pin B on the harness side of the EPS connector.
OK NOT OK

(+) 4.5 to 5.25-VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for signal from the EPS.

Conditions

  • Turn the keyswitch to the ON position.
  • Install breakout cable, Part Number 3824775, between the EPS and the engine harness.

Action

Check for signal from the EPS.

  • Measure the voltage from pin C to pin B on the breakout cable while barring the engine over.
OK NOT OK

Signal present

Replace the engine position sensor (EPS). Refer to Procedure 019-038 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the nose of sensor.

Conditions

  • Turn the keyswitch to the OFF position
  • Remove sensor from engine.

Action

Inspect the nose of the sensor for damage or debris:

  • Inspect for metal debris on sensor tip
  • Inspect for damage on the sensor caused by the camshaft gear
  • Inspect for sensor swelling.
OK NOT OK

No damage found

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the air gap between the engine position sensor and the camshaft ring gear.

Conditions

  • Install the speed sensor.

Action

Check and adjust the speed sensor air gap.

  • Check the air gap between the engine position sensor and the camshaft ring gear. The air gap can be measured using the outside sensor bore. This measurement can usually be taken without removing the air compressor.
  • Bar the engine over 2 full revolutions (clockwise facing the front of the engine).
  • Use a depth micrometer and measure the distance from the face of the gear housing boss to the face of the camshaft ring gear. Record this measurement “A”.
  • Measure the gap in 45 degree camshaft rotation increments. If the measurements “A” varies by more than 0.051 mm [0.002 in] the tone wheel is warped, or the camshaft gear is walking.
  • Next measure the sensor. Use a depth micrometer to measure the distance from the bottom of the sensor mounting flange to the tip of the threaded end of the sensor. Record this as measurement “B”. The air gap can be calculated by subtracting B from A (air gap measurement equals A minus B). If the air gap is less than 0.406 mm [0.016 in] add a 0.508 mm [0.020 in] shim to sensor.
OK NOT OK

Sensor maintains the appropriate air gap.

Sensor maintains the appropriate air gap.

Go to 4A

Replace the engine speed sensor. Refer to Procedure 019-038 in Section 19.

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault codes.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 141, 144, 145, 153, 154, and 352 are not active
STEP 2. | Check for mechanical failure. |
 | STEP 2A. Make sure of proper turbocharger operation. | Positive intake manifold pressure from turbocharger and wastegate not stuck closed
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Inspect the sensor circuit for tampering. | No tampering
 | STEP 3b. Inspect the intake manifold pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 3c. Check the intake manifold pressure supply voltage. | (+) 4.5 to 5.25 VDC
 | STEP 3d. Check the intake manifold pressure signal voltage. | (+) 0.44 to 0.56 VDC
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 122 inactive
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch to the ON position.

Action

Read the fault codes.

  • Read fault codes using INSITE™.

If multiple temperature or pressure fault codes exist, this procedure can not be followed.

OK NOT OK

Fault Codes 135, 141, 144, 145, 153, 154, and 352 are not active

Possible sensor failure.

Short circuit to ground in sensor +5-VDC common supply, or short circuit from pin to pin.

Go to 2A

Go to Fault Code 352 or 386

Guided Step 2 - Check for mechanical failure.

Guided Step 2A - Make sure of proper turbocharger operation.

Conditions

  • Turn the keyswitch to the OFF position.

Action

Make sure of proper turbocharger operation.

  • Check for positive intake manifold pressure using a mechanical gauge.
OK NOT OK

Positive intake manifold pressure from turbocharger and wastegate not stuck closed

Low intake manifold pressure

Correct the base engine malfunction.

See the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.

Go to 3A

Go to 5A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch to the OFF position.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure sensor and the engine harness for external wires or damaged harness braiding.
OK NOT OK

No tampering

Remove and record tampering.

If tampering has occurred, repair the circuit and record the tampering.

Go to 3B

Go to 5A

Guided Step 3B - Inspect the intake manifold pressure sensor and engine harness connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the sensor connector for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the intake manifold pressure sensor or the engine harness, whichever has damaged pins.

  • Repair the engine harness. 019-201, 019-202, or 019-205.
  • Replace the engine harness. 019-043
  • .
  • Replace the intake manifold pressure sensor. 019-061.

Go to 3C

Go to 5A

Guided Step 3C - Check the intake manifold pressure supply voltage.

Conditions

  • Turn the keyswitch to the ON position.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure supply voltage.

  • Measure the voltage from pin A to pin B of the intake manifold pressure sensor circuit.
OK NOT OK

(+) 4.5 to 5.25 VDC

Replace the engine harness

019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check the intake manifold pressure signal voltage.

Conditions

  • Turn the keyswitch to the ON position.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure signal voltage.

  • Measure the voltage from pin B to pin C of the intake manifold pressure sensor circuit.
OK NOT OK

(+) 0.44 to 0.56 VDC

Replace the intake manifold pressure sensor

019-061.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. 019-204.
  • Replace the engine harness. 019-043.
  • Replace the ECM. 019-031.

Go to 4B

Go to 5A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 4B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 45 on the engine harness connector to pin C on the harness side of the intake manifold pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness.

019-043.

Go to 4C

Go to 5A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 45 on the harness side of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness.

019-043.

Go to 4D

Go to 5A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 on the harness side of the engine harness connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness.

019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify that Fault Codes 122 is inactive.
OK NOT OK

Fault Code 122 inactive

Return to troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Dec-2010


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 141, 144, 145, 153, 154, and 352 are not active
STEP 2. | Check for mechanical failure. |
 | STEP 2A. Make sure of proper turbocharger operation. | Positive intake manifold pressure from turbocharger and wastegate not stuck closed
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Inspect the sensor circuit for tampering. | No tampering
 | STEP 3B. Inspect the intake manifold pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 3C. Check the intake manifold pressure supply voltage. | (+) 4.5 to 5.25 VDC
 | STEP 3D. Check the intake manifold pressure signal voltage. | (+) 0.44 to 0.56 VDC
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 123 inactive
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure can not be followed.

OK NOT OK

Fault Codes 135, 141, 144, 145, 153, 154, and 352 are not active

Possible sensor failure.

Short circuit to ground in sensor +5-VDC common supply, or short circuit from pin to pin.

Go to 2A

Go to Fault Code 352 or 386

Guided Step 2 - Check for mechanical failure.

Guided Step 2A - Make sure of proper turbocharger operation.

Conditions

  • Turn the keyswitch to the OFF position.

Action

Make sure of proper turbocharger operation.

  • Check for positive intake manifold pressure using a mechanical gauge.
OK NOT OK

Positive intake manifold pressure from turbocharger and wastegate not stuck closed

Low intake manifold pressure.

Correct the base engine malfunction.

Reference the Troubleshooting and Repair Manual, ISC Engines, Bulletin Number 3666245.

Go to 3A

Go to 5A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch to the OFF position.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure sensor and the engine harness for external wires or damaged harness braiding.
OK NOT OK

No tampering

Remove and record tampering.

If tampering has occurred, repair the circuit and record the tampering.

Go to 3B

Go to 5A

Guided Step 3B - Inspect the intake manifold pressure sensor and engine harness connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the sensor connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the intake manifold pressure sensor or the engine harness, whichever has damaged pins.

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the intake manifold pressure supply voltage.

Conditions

  • Turn the keyswitch to the ON position.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure supply voltage.

  • Measure the voltage from pin A to pin B of the intake manifold pressure sensor circuit.
OK NOT OK

(+) 4.5 to 5.25 VDC

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the intake manifold pressure signal voltage.

Conditions

  • Turn the keyswitch to the ON position.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure signal voltage.

  • Measure the voltage from pin B to pin C of the intake manifold pressure sensor circuit.
OK NOT OK

(+) 0.44 to 0.56 VDC

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 45 on the engine harness connector to pin C on the harness side of the intake manifold pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 45 on the harness side of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 on the harness side of the engine harness connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 123 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

All faults codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 124 - Intake Manifold Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct within 5 in Hg
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 124 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn the keyswitch to the ON position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical intake manifold pressure gauge to the engine.
  • Connect INSITE™ to the vehicle datalink.
  • Start the engine, and compare the intake manifold pressure sensor reading on INSITE™ monitor screen to the reading on the mechanical intake manifold pressure gauge.

Note: The engine must be revved up to make it easier to see differences in readings.

OK NOT OK

Sensor reading is correct within 5 in HgLocate and repair the cause of high intake manifold pressure. Reference the Troubleshooting and Repair Manual, ISC Engines, Bulletin No. 3666245 (reference the Shop Talk for correct procedures).

Fault Code 123 is active

Go to 2A

Fault Code 123

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 124 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Aug-2012


FAULT CODE 131 or 132 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify that the accelerator position sensor is connected to the OEM harness. | Sensor is connected
 | STEP 1B. Inspect the harness and the accelerator position sensor connector pins. | No damaged pins
 | STEP 1C. Check the accelerator position resistance. | 2000 to 3000 ohms
 | STEP 1D. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms, Depressed: 250 to 1500 ohms, Released resistance must be at least 1000 ohms more than depressed resistance.
 | STEP 1E. Check for a short circuit to ground in the sensor +5-VDC supply. | More than 100k ohms
 | STEP 1F. Check for a short circuit to ground in the sensor signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply, signal, and return wires of the OEM harness. | Less than 10 ohms
 | STEP 2C. Check for a short circuit between the +5-VDC supply wire and any other wire in the OEM harness. | More than 100k ohms
 | STEP 2D. Check for a short circuit between the accelerator position signal wire and any other wire in the OEM harness. | More than 100k ohms
 | STEP 2E. Check for a short circuit to ground in the accelerator position sensor +5-VDC supply circuit (Fault Code 132 only). | More than 100k ohms
 | STEP 2F. Check for a short circuit to ground in the accelerator position sensor signal circuit (Fault Code 132 only). | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the accelerator position supply voltage. | (+) 4.75 to 5.25 VDC
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 131 or 132 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the accelerator position sensor is connected to the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.

Action

Verify that the accelerator position sensor is connected to the OEM harness.

Verify that the accelerator position sensor is connected to the OEM harness.
OK NOT OK

Sensor connected

Connect the OEM harness

Go to 1B

Go to 4A

Guided Step 1B - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the accelerator position sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to OEM service manual.
  • Replace the accelerator position sensor. Refer to OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the accelerator position sensor resistance.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the accelerator position sensor.

  • Measure the resistance from pin 4 [pin A] to pin 5 [pin C] on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector onto the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

OK NOT OK

2000 to 3000 ohms

Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1D

Go to 4A

Guided Step 1D - Check the resistance between sensor pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Measure when the pedal is depressed and released.

  • Measure the resistance from pin 4 [pin A] to pin 5 [pin C] on the sensor side of the accelerator position sensor.

Install the 6-pin, Part Number 3824892, or the 3-pin repair connector, Part Number 3823255, into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and the letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

OK NOT OK

Released: 1500 to 3000 ohms, Depressed: 250 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit to ground in the sensor +5-VDC supply.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the sensor +5-VDC supply.

  • Measure the resistance from pin 5 [pin C] on the sensor side of the accelerator position sensor to engine block ground.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and the letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

OK NOT OK

More than 100k ohms

Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1F

Go to 4A

Guided Step 1F - Check for a short circuit to ground in the signal wire.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the signal wire.

  • Measure the resistance from pin 3 [pin B] on the sensor side of the accelerator position sensor to engine block ground.

Install the 6 pin, Part Number 3824892, or the 3 pin, Part Number 3823255, repair connector into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

OK NOT OK

More than 100k ohms

Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or ECM, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit in the supply, signal, and return wires of the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit in the supply, signal and return wires of the OEM harness.

  • Measure the resistance from pin 29 of the OEM harness connector to the throttle +5-VDC supply pin 5 [pin C] on the harness side of the accelerator position sensor.
  • Measure the resistance from pin 30 of the OEM harness connector to the accelerator position signal pin 3 [pin B] on the harness side of the accelerator position sensor.
  • Measure the resistance from pin 19 of the OEM harness connector to the throttle return pin 4 [pin A] on the harness side of the accelerator position sensor.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit between +5-VDC supply wire and any other wire in the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from the +5-VDC supply wire to any other wire in the OEM harness.

  • Measure the resistance from pin 29 to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit between accelerator position signal wire and any other wire in the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit between the accelerator position signal wire and any other wire in the OEM harness.

  • Measure the resistance from pin 30 to all other pins in OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground of the accelerator position sensor +5-VDC supply circuit (Fault Code 132 only).

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground of the accelerator position signal sensor supply circuit.

  • Measure the resistance from pin 29 of the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Check for a short circuit to ground in the accelerator position sensor signal circuit (Fault Code 132 only).

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground of the accelerator position sensor signal circuit.

  • Measure the resistance from pin 30 of the OEM harness connector to engine block.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM

Guided Step 3A - Check the accelerator position supply voltage.

Conditions

  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.
  • Turn the keyswitch to the ON position.

Action

Check the accelerator position supply voltage.

  • Measure the voltage from pin 19 to pin 29 in the OEM port of the ECM.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and depress the accelerator pedal to full position. Release the pedal and turn the keyswitch to the OFF position.
  • Wait for 15 seconds.
  • Turn the keyswitch to the ON position.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 131 or 132 inactive

Return to troubleshooting step, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 131 or 132 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack® test lead, Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the accelerator position sensor is connected to the OEM harness. | Sensor is connected
 | STEP 1B. Inspect the harness and the accelerator position sensor connector pins. | No damaged pins
 | STEP 1C. Check the accelerator position resistance. | 2000 to 3000 ohms
 | STEP 1D. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms, Depressed: 250 to 1500 ohms, Released resistance must be at least 1000 ohms more than depressed resistance.
 | STEP 1E. Check for a short circuit to ground in the sensor +5-VDC supply. | More than 100k ohms
 | STEP 1F. Check for a short circuit to ground in the sensor signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply, signal, and return wires of the OEM harness. | Less than 10 ohms
 | STEP 2C. Check for a short circuit between the +5-VDC supply wire and any other wire in the OEM harness. | More than 100k ohms
 | STEP 2D. Check for a short circuit between the accelerator position signal wire and any other wire in the OEM harness. | More than 100k ohms
 | STEP 2E. Check for a short circuit to ground in the accelerator position sensor +5-VDC supply circuit (Fault Code 132 only). | More than 100k ohms
 | STEP 2F. Check for a short circuit to ground in the accelerator position sensor signal circuit (Fault Code 132 only). | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the accelerator position supply voltage. | (+) 4.75 to 5.25 VDC
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 131 or 132 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the accelerator position sensor is connected to the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.

Action

Verify that the accelerator position sensor is connected to the OEM harness.

  • Verify the accelerator position sensor is connected to the OEM harness.
OK NOT OK

Sensor connected

Connect the OEM harness

Go to 1B

Go to 4A

Guided Step 1B - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the accelerator position sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or replace the sensor, whichever has the damaged pins.

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to OEM service manual.
  • Replace the accelerator position sensor. Refer to OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the accelerator position sensor resistance.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the accelerator position sensor.

  • Measure the resistance from pin 4 [pin A] to pin 5 [pin C] on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector onto the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

2000 to 3000 ohms

Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1D

Go to 4A

Guided Step 1D - Check the resistance between sensor pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Measure when the pedal is depressed and released.

  • Measure the resistance from pin 4 [pin A] to pin 3 [pin B] on the sensor side of the accelerator position sensor.

Install the 6-pin, Part Number 3824892, or the 3-pin repair connector, Part Number 3823255, into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and the letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit to ground in the sensor +5-VDC supply.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the sensor +5-VDC supply.

  • Measure the resistance from pin 5 [pin C] on the sensor side of the accelerator position sensor to engine block ground.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and the letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1F

Go to 4A

Guided Step 1F - Check for a short circuit to ground in the signal wire.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the signal wire.

  • Measure the resistance from pin 3 [pin B] on the sensor side of the accelerator position sensor to engine block ground.

Install the 6 pin, Part Number 3824892, or the 3 pin, Part Number 3823255, repair connector into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or replace the ECM, whichever has damaged pins.

  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-071 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit in the supply, signal, and return wires of the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit in the supply, signal and return wires of the OEM harness.

  • Measure the resistance from pin 29 of the OEM harness connector to the throttle +5-VDC supply pin 5 [pin C] on the harness side of the accelerator position sensor.
  • Measure the resistance from pin 30 of the OEM harness connector to the accelerator position signal pin 3 [pin B] on the harness side of the accelerator position sensor.
  • Measure the resistance from pin 19 of the OEM harness connector to the throttle return pin 4 [pin A] on the harness side of the accelerator position sensor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit between +5-VDC supply wire and any other wire in the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from the +5-VDC supply wire to any other wire in the OEM harness.

  • Measure the resistance from pin 29 to all other pins in the OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit between accelerator position signal wire and any other wire in the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit between the accelerator position signal wire and any other wire in the OEM harness.

  • Measure the resistance from pin 30 to all other pins in OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground of the accelerator position sensor +5-VDC supply circuit (Fault Code 132 only).

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground of the accelerator position signal sensor supply circuit.

  • Measure the resistance from pin 29 of the OEM harness connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Check for a short circuit to ground in the accelerator position sensor signal circuit (Fault Code 132 only).

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground of the accelerator position sensor signal circuit.

  • Measure the resistance from pin 30 of the OEM harness connector to engine block.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM

Guided Step 3A - Check the accelerator position supply voltage.

Conditions

  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.
  • Turn the keyswitch to the ON position.

Action

Check the accelerator position supply voltage.

  • Measure the voltage from pin 19 to pin 29 in the OEM port of the ECM.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and depress the accelerator pedal to full position. Release the pedal and turn the keyswitch to the OFF position.
  • Wait for 15 seconds.
  • Turn the keyswitch to the ON position.
  • Use INSITE™ electronic service tool, verify Fault Code 131 or 132 is inactive.
OK NOT OK

Fault Code 131 or 132 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 133 - Remote Throttle Position Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Isolate the remote throttle position sensor circuit. |
 | STEP 1A. Inspect the OEM harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check for active fault codes. | Fault Code 131, 132, and 352 are active
 | STEP 1C. Disconnect the remote throttle connector; check if fault code deactivates. | Fault Code 133 active
STEP 2. | Check the remote throttle position sensor. |
 | STEP 2A. Inspect the harness and the remote throttle position sensor connector pins. | No damaged pins
 | STEP 2B. Check the remote throttle position resistance. | 250 to 3000 ohms
 | STEP 2C. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms, Depressed: 250 to 1500 ohms, Released resistance must be at least 1000 ohms more than depressed resistance
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit between the +5-VDC supply and return wires. | 250 to 3000 ohms
 | STEP 3C. Check for an open circuit in the return wire. | Less than 10 ohms
 | STEP 3D. Check the resistance in the +5-VDC supply wire and signal wire circuit. | Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms; Released resistance must be at least 1000 ohms more than depressed resistance
 | STEP 3E. Check for a short circuit between the remote throttle position signal wire and the supply wire in the OEM harness. | More than 100k ohms
 | STEP 3F. Check for a short circuit between the remote throttle position signal and supply wire to all other wires in the OEM harness connector. | More than 100k ohms
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Isolate the remote throttle position sensor circuit.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the OEM harness and the remote throttle position sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the remote throttle position sensor. Refer to OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 131, 132, and 352 are active

Fault Code 131 inactive

Go to 1C

Go to 4A

Guided Step 1C - Disconnect the remote throttle connector; check if fault code deactivates.

Conditions

  • Disconnect the remote throttle connector.

Action

Check for fault code deactivates.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 133 active

Go to Fault Code 131. Replace the remote throttle position sensor. Refer to OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the remote throttle position sensor.

Guided Step 2A - Inspect the harness and the remote throttle position sensor connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the remote throttle position sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the remote throttle position sensor. Refer to OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the remote throttle position resistance.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for an open or short circuit between pins in the remote throttle position sensor.

  • Measure the resistance between the +5-VDC supply and the remote throttle position sensor return on the sensor side of the remote throttle position sensor when the remote throttle is released and when it is depressed.
OK NOT OK

250 to 3000 ohms

Replace the remote throttle position sensor. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the resistance between sensor pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check the resistance between sensor pins.

Measure when the pedal is depressed and released.

  • Measure the resistance between the +5-VDC supply and the signal wire on the sensor side of the remote throttle position sensor.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the remote throttle position sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the remote throttle.

Action

Inspect the harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 3B - Check for a short circuit between the +5-VDC supply and return wires.

Conditions

  • Turn the keyswitch to the OFF position.
  • Connect the OEM harness to the remote throttle position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance between the +5-VDC supply and return wires.

  • Measure the resistance between pin 10 and pin 20 in the OEM harness when the remote throttle pedal is up or down.
OK NOT OK

250 to 3000 ohms

Repair or replace the OEM harness. Refer to Procedure 019-071.

Go to 3C

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit in the return wire.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness to the remote throttle position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from pin 20 of the OEM harness connector to pin A of the remote throttle position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to Procedure 019-071.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance in the +5-VDC supply wire and the signal wire circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Connect the OEM harness to the remote throttle position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance in the +5-VDC supply wire and the signal wire circuit.

  • Measure the resistance between pin 10 and pin 9 when the remote throttle is released and when it is depressed.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance

Repair or replace OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit between the remote throttle position signal wire and the supply wire in the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit between the remote throttle position signal wire and the supply wire in the OEM harness.

  • Measure the resistance from pin 9 of the OEM harness connector to pin B of the remote throttle position sensor connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit between the remote throttle position signal and supply wire to all other wires in the OEM harness connector.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the negative (-) battery terminal.

Action

Check for a short circuit between the remote throttle position signal and supply wire to all other wires in the OEM harness connector.

  • Measure the resistance from pin 9 and pin 10 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and depress the remote throttle to full position three times. Release the remote throttle, and turn the keyswitch to the OFF position.
  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 133 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 134 - Remote Throttle Position Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Isolate the remote throttle position sensor circuit. |
 | STEP 1A. Inspect the OEM harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check for active fault codes. | Fault Code 132 inactive
 | STEP 1C. Disconnect the remote throttle connector; check if fault code deactivates. | Fault Code 134 active
STEP 2. | Check the remote throttle position sensor. |
 | STEP 2A. Inspect the harness and the remote throttle position sensor connector pins. | No damaged pins
 | STEP 2B. Check the remote throttle position resistance. | 2000 to 3000 ohms
 | STEP 2C. Check for short circuit to ground on the remote throttle sensor +5-VDC supply wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground on the remote throttle sensor signal wire. | More than 100k ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit in the supply or signal wires of the OEM harness. | Less than 10 ohms
 | STEP 3C. Check for short circuit to ground in the remote throttle position sensor +5-VDC supply circuit. | More than 100k ohms
 | STEP 3D. Check for a short circuit to ground in the remote throttle position sensor signal circuit. | More than 100k ohms
 | STEP 3E. Check for a short circuit between the +5-VDC signal wire and any other wire in the OEM harness. | More than 100k ohms
 | STEP 3F. Check for a short circuit between the remote throttle position signal wire and the other signal wire in the OEM harness. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Isolate the remote throttle position sensor circuit.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the OEM harness and the remote throttle position sensor connector pins for:

  • Corroded pins
  • Loose connector
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the remote throttle position sensor. Refer to OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 132 active

Fault Code 132 inactive

Go to 1C

Go to 4A

Guided Step 1C - Disconnect the remote throttle connector; check if fault code deactivates.

Conditions

  • Disconnect the remote throttle connector.

Action

Check for fault code deactivation.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 134 active

Fault Code 134 inactive. Replace the remote throttle position sensor. Refer to OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the remote throttle position sensor.

Guided Step 2A - Inspect the harness and the remote throttle position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the remote throttle position sensor connector pins for:

  • Corroded pins
  • Loose connector
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the remote throttle position sensor. Refer to OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the remote throttle position resistance.

Conditions

  • Turn keyswitch OFn.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for an open or short circuit between pins in the remote throttle position sensor.

  • Measure the resistance between the +5-VDC supply and the remote throttle position sensor return on the sensor side of the remote throttle position sensor when the remote throttle is released and when it is depressed.
OK NOT OK

2000 to 3000 ohms

Replace the remote throttle position sensor. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground on the remote throttle sensor +5-VDC supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for short circuit to ground on the remote throttle sensor +5-VDC supply.

  • Measure the resistance between the +5-VDC supply on the sensor side of the remote throttle position sensor and the chassis ground.
OK NOT OK

More than 100k ohms

Replace the remote throttle position sensor. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground on the sensor signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for a short circuit to ground on the sensor signal wire.

  • Measure the resistance between the signal wire on the sensor side of the remote throttle position sensor and the chassis ground.
OK NOT OK

More than 100k ohms

Replace the remote throttle position sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the ECM connector pins for:

  • Corroded pins
  • Loose connector
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the supply or signal wires of the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness to the remote throttle position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit in the supply or signal wires of the OEM harness.

  • Measure the resistance between pin 10 of the OEM harness and the +5-VDC supply on the harness side of the remote throttle position sensor.
  • Measure the resistance between pin 9 of the OEM harness and the signal wire on the harness side of the remote throttle position sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19..

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the remote throttle position sensor +5-VDC supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness to the remote throttle position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the remote throttle position sensor +5-VDC supply circuit.

  • Measure the resistance between the pin 10 of the OEM harness and the chassis ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the remote throttle position sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness to the remote throttle position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the remote throttle position sensor signal circuit.

  • Measure the resistance between the pin 9 of the OEM harness and the chassis ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit between +5-VDC supply wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness to the remote throttle position sensor.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM negative (-) battery terminal.

Action

Check for a short circuit between +5-VDC supply wire and any other wire in the OEM harness.

  • Measure the resistance between the pin 10 and all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit between remote throttle position signal wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness to the remote throttle position sensor.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM negative (-) battery terminal.

Action

Check for a short circuit between remote throttle position signal wire and any other wire in the OEM harness.

  • Measure the resistance between the pin 9 and all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch OFF.

Action

Disable the fault code.

  • Turn keyswitch ON and depress the remote throttle to full position three times. Release the remote throttle and the keyswitch OFF.
  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 134 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch OFF.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 135 (SN) - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 352 and 386 inactive
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the engine harness and oil pressure sensor connector pins. | No damaged pins
 | STEP 2B. Check the oil pressure sensor supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 2C. Check the oil pressure sensor signal voltage. | (+) 0.40 to 0.60 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 352 and 386 inactive

Possible sensor failure, a short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin to pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the engine harness and the oil pressure sensor connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Inspect the oil pressure sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the oil pressure sensor or the engine harness, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the oil pressure sensor supply voltage.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the engine harness from the oil pressure sensor.
  • Install oil pressure sensor breakout cable, Part Number 3824775.

Action

Check the oil pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B on the harness side of the oil pressure sensor connector.

Pressure sensor breakout cable kit, Part Number 3824775 of kit, Part Number 3824773, is available to assist with this step.
OK NOT OK

(+) 4.75 to 5.25 VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the oil pressure sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install oil pressure sensor breakout cable, Part Number 3824775.

Action

Check the oil pressure sensor signal voltage.

  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

(+) 0.40 to 0.60 VDC

Replace the oil pressure sensor

Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 33 of the engine harness connector to pin C on the harness side of the oil pressure sensor connector.
  • Measure the resistance from pin 10 of the engine harness connector to pin A on the harness side of the oil pressure sensor connector.
  • Measure the resistance from pin 19 of the engine harness connector to pin B on the harness side of the oil pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 33 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the engine harness connector to all other pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 135 is inactive and did not reoccur.
  • Turn keyswitch Nn.
OK NOT OK

Fault Code 135 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Oct-2012


FAULT CODE 141 (SN) - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 352 and 386 inactive
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the engine harness and oil pressure sensor connector pins. | No damaged pins
 | STEP 2B. Check the oil pressure sensor supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 2C. Check the oil pressure sensor signal voltage. | (+) 0.40 to 0.60 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 352 and 386 inactive

Possible sensor failure, a short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin to pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the engine harness and the oil pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Inspect the oil pressure sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the oil pressure sensor or the engine harness, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the oil pressure sensor supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the oil pressure sensor.
  • Install oil pressure sensor breakout cable, Part Number 3824775.

Action

Check the oil pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B on the harness side of the oil pressure sensor connector.

Pressure sensor breakout cable kit, Part Number 3824775, of kit, Part Number 3824773, is available to assist with this step.
OK NOT OK

(+) 4.75 to 5.25 VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the oil pressure sensor signal voltage.

Conditions

  • Turn the keyswitch ON.
  • Install oil pressure sensor breakout cable, Part Number 3824775.

Action

Check the oil pressure sensor signal voltage.

  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

(+) 0.40 to 0.60 VDC

Replace the oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 33 of the engine harness connector to pin C on the harness side of the oil pressure sensor connector.
  • Measure the resistance from pin 10 of the engine harness connector to pin A on the harness side of the oil pressure sensor connector.
  • Measure the resistance from pin 19 of the engine harness connector to pin B on the harness side of the oil pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 33 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the engine harness connector to all other pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • Turn keyswitch ON.
OK NOT OK

Fault Code 141 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Oct-2012


FAULT CODE 141 (SW) - Oil Pressure Switch Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 352 and 386 inactive
STEP 2. | Check the oil pressure switch. |
 | STEP 2A. Inspect the engine harness and oil pressure switch connector pins. | No damaged pins
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 352 and 386 inactive

Possible sensor failure, a short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin to pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check the oil pressure switch.

Guided Step 2A - Inspect the engine harness and the oil pressure switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.

Action

Inspect the oil pressure switch and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the oil pressure switch or the engine harness, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure switch.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 47 of the engine harness connector to the oil pressure switch connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 47 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 47 of the engine harness connector to all other pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the oil pressure switch.

Refer to Procedure 019-066 in Section 19.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • Turn keyswitch OFF.
OK NOT OK

Fault Code 141 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2015


FAULT CODE 143 (SN) - Oil Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 143 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to vehicle data link.
  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge.

If necessary, increase engine rpm to make it easier to see differences in the readings.
OK NOT OK

The sensor reading is correct.

Refer to the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193.

Fault Code 141 active

Go to 2A

Fault Code 141

Guided Step 2 - Clear the fault code

Guided Step 2A - Disable the fault code

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

If the fault was at a particular speed, operate the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 143 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™ electronic service tool.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Oct-2012


FAULT CODE 143 (SW) - Oil Pressure - Engine Protection With An Oil Pressure Switch

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the switch accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 143 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn the keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to vehicle data link.

The switch will display 379.9 kPa [55.1 psi] in INSITE™ if it detects actual oil pressure above 41 kPa [6 psi].
OK NOT OK

The switch is detecting pressure.

Reference the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193.

Fault Code 141 active

Go to 2A

Fault Code 141

Guided Step 2 - Clear the fault code

Guided Step 2A - Disable the fault code

Conditions

  • Connect all the components.
  • Turn the keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

If the fault was at a particular speed, run the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 143 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Oct-2012


FAULT CODE 144 or 145 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Wait until the coolant temperature is below 50° C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead and Part Number 3824803 - female Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 not active
 | STEP 1B. Check for active fault codes. | Fault Codes 122, 135, 153, 221, 263, and 451 are not active
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector. | No damaged pins
 | STEP 2B. Check the resistance of the coolant temperature sensor. | 175 ohms to 244k ohms
 | STEP 2C. Check for a short circuit to ground in coolant temperature sensor. | Greater than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 144 and 145 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 441 not active

Fault Code 441 is active.

Go to 1B

Fault Code 441

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 153, 221, 263, and 451 are not active

Possible sensor failure, short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin to pin, or an open circuit in the sensor common ground.

Go to 2A

Go to Fault Code 352 or 386

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the coolant temperature sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin A to pin B of the coolant temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the coolant temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness to pin A on the harness side of the coolant temperature sensor connector.
  • Measure the resistance from pin 23 of the engine harness to pin B on the harness side of the coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 23 of the engine harness to engine block ground.
  • Measure the resistance from pin 19 of the engine harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 23 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin 19 of the engine harness to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 144 and 145 is inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Oct-2012


FAULT CODE 144 or 145 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Wait until the coolant temperature is below 50° C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3824803 - female Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 not active
 | STEP 1B. Check for active fault codes. | Fault Codes 122, 135, 153, 221, 263, and 451 are not active
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector. | No damaged pins
 | STEP 2B. Check the resistance of the coolant temperature sensor. | 175 ohms to 244k ohms
 | STEP 2C. Check for a short circuit to ground in coolant temperature sensor. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 144 and 145 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 441 not active

Fault Code 441 is active.

Go to 1B

Fault Code 441

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 153, 221, 263, and 451 are not active

Possible sensor failure, short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin to pin, or an open circuit in the sensor common ground.

Go to 2A

Go to Fault Code 352 or 386

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the coolant temperature sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin A to pin B of the coolant temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the coolant temperature sensor.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the coolant temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness to pin A on the harness side of the coolant temperature sensor connector.
  • Measure the resistance from pin 23 of the engine harness to pin B on the harness side of the coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 23 of the engine harness to engine block ground.
  • Measure the resistance from pin 19 of the engine harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 23 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin 19 of the engine harness to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 144 and 145 is inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Oct-2012


FAULT CODE 146 - Coolant Temperature - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 146 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn the keyswitch to the ON position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.
  • If a temperature measuring device is not available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct. Reference the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.

Sensor reading incorrect. Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 146 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Oct-2012


FAULT CODE 147 - Frequency Throttle Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and the 23-pin connector. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 147 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and the 23-pin connector.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness and the 23-pin harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-207 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Dry connector with electrical contact cleaner, Part Number 3824510.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the frequency accelerator to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin Q of the OEM harness to the corresponding pin of the frequency throttle connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the frequency throttle.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin Q of the OEM harness 23-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the 23-pin connector.
  • Disconnect the engine harness from the frequency throttle.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin Q of the OEM harness 23-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Dry the connector with electrical contact cleaner, Part Number 3824510.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit as follows:

  • Measure the resistance from pin 4 of the engine harness ECM connector to pin Q of the 23-pin connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 4 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 4 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms. Replace the OEM frequency throttle. Refer to the OEM service manual.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 147 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 05-Jun-2015


FAULT CODE 148 - Frequency Throttle Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and the 23-pin connector. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 148 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and the 23-pin connector.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the OEM harness and the engine harness connector pins for the following:

  • .
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell brokenWire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-207 in Section 19.Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Dry connector with electrical contact cleaner, Part Number 3824510.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the frequency throttle to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin Q of the OEM harness to the corresponding pin of the frequency throttle connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the frequency throttle.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin Q of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine 23-pin harness connector.
  • Disconnect the engine harness from the frequency throttle.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin Q of the engine harness 23-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19..

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.Replace the engine harness.Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Dry the connector with electrical contact cleaner, Part Number 3824510.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit as follows:

  • Measure the resistance from pin 4 of the engine harness ECM connector to pin Q of the engine harness 23-pin connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 4 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 4 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms. Replace the OEM frequency throttle. Refer to the OEM service manual.

Replace the engine harness. Refer to Procedure 019-043 in Section 19/

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 148 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 05-Jun-2015


FAULT CODE 151 - Coolant Temperature - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 151 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn the keyswitch to the ON position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ to the vehicle data link.
  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.Note: If a temperature measuring device is not available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct Reference the Troubleshooting and Repair Manual, ISC Engines, Bulletin No. 3666245.

Sensor reading is incorrectReplace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 151 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Oct-2012


FAULT CODE 152 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC, QSC8.3, and ISL | 3666271

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the Coolant Temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

  • Reference the Engine Coolant Temperature Below Normal troubleshooting symptom tree in Section TS in the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Feb-2014


FAULT CODE 153 or 154 - Intake Manifold Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3824803 - female Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 is not active
 | STEP 1B. Check for active fault codes. | Fault Codes 122, 135, 144, 221, 263, and 451 are not active
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and the engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor resistance. | 175 ohms to 244k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 153 or 154 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 441 is not active

Fault Code 441 is active.

Go to 1B

Fault Code 441

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch to the ON position.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 221, 263, and 451 are not active.

Possible sensor failure, a short circuit to ground in the sensor +5-VDC common supply, a short circuit from pin to pin, or an open circuit on the sensor common ground.

Go to 2A

Go to Fault Code 352 or 386

Guided Step 2 - Check the intake manifold air temperature sensor.

Guided Step 2A - Inspect the intake manifold air temperature sensor and the engine harness connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Inspect the intake manifold air temperature sensor and the engine harness connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the intake manifold air temperature sensor or the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Check the resistance of the intake manifold air temperature sensor.

  • Measure the resistance from pin A to pin B of the intake manifold temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the intake manifold air temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness to pin A on the harness side of the intake manifold temperature sensor connector.
  • Measure the resistance from pin 34 of the engine harness to pin B on the harness side of the intake manifold temperature sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to the ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 34 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 19 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin 34 of the engine harness to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 153 or 154 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All the faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Oct-2012


FAULT CODE 153 or 154 - Intake Manifold Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3824803 - female Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 is not active
 | STEP 1B. Check for active fault codes. | Fault Codes 122, 135, 144, 221, 263, and 451 are not active
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and the engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor resistance. | 175 ohms to 244k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 153 or 154 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 441 is not active

Fault Code 441 is active.

Go to 1B

Fault Code 441

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch to the ON position.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 221, 263, and 451 are not active.

Possible sensor failure, a short circuit to ground in the sensor +5-VDC common supply, a short circuit from pin to pin, or an open circuit on the sensor common ground.

Go to 2A

Go to Fault Code 352 or 386

Guided Step 2 - Check the intake manifold air temperature sensor.

Guided Step 2A - Inspect the intake manifold air temperature sensor and the engine harness connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Inspect the intake manifold air temperature sensor and the engine harness connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the intake manifold air temperature sensor or the engine harness, whichever has the damaged pins.

Repair the engine harness. Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Check the resistance of the intake manifold air temperature sensor.

  • Measure the resistance from pin A to pin B of the intake manifold temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the intake manifold air temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

  • .
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness to pin A on the harness side of the intake manifold temperature sensor connector.
  • Measure the resistance from pin 34 of the engine harness to pin B on the harness side of the intake manifold temperature sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to the ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 34 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 19 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin 34 of the engine harness to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 153 or 154 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All the faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Oct-2012


FAULT CODE 184 - Primary and Secondary Electronic Control Modules (ECM) Identification Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check each engine harness. |
 | STEP 1A. Inspect pins 47 and 48 for damage. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 184 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 184 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check each engine harness.

Guided Step 1A - Inspect pins 47 and 48 for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect pins 47 and 48 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged pins. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 184 active

Repair complete.

Go to 1C

Go to 2B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

If the ECM is the primary ECM:

  • Connect test lead, Part Number 3822758.
  • Measure the resistance from pin 47 of the engine harness connector to engine block ground.

If the ECM is the secondary ECM:

  • Connect test lead, Part Number 3822758.
  • Measure the resistance from pin 48 of the engine harness connector to engine block ground.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

If the ECM is the primary ECM:

  • Connect test lead, Part Number 3822758.
  • Measure the resistance from pin 48 of the engine harness connector to engine block ground.

If the ECM is the secondary ECM:

  • Connect test lead, Part Number 3822758.
  • Measure the resistance from pin 47 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Connect test lead, Part Number 3822758.
  • Measure the resistance from pin 47 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 48 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 184 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Oct-2012


FAULT CODE 191 - Air Conditioner Clutch Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the air conditioner clutch. |
 | STEP 1A. Inspect and test the air conditioner clutch and air conditioner clutch relay (if equipped). | Air conditioner clutch and relay within specifications
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness, air conditioner clutch relay, and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the engine harness and OEM harness connectors. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 191 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the air conditioner clutch.

Guided Step 1A - Check the air conditioner clutch and the air conditioner clutch relay (if equipped).

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the air conditioner clutch or air conditioner clutch relay.

Action

Check the fan clutch for:

  • Damaged pins
  • Open or short circuits
  • Excessive current draw (power fan clutch directly from battery)
  • Perform this test in accordance with the OEM instructions.
OK NOT OK

Air conditioner clutch and relay within specifications

Repair or replace the air conditioner clutch. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness, the air conditioner clutch relay, and the ECM connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Inspect the engine harness and the ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the engine harness connector to pin J of the 23-pin OEM harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 in the engine harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit between pins.

  • Measure the resistance from pin 1 to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the engine harness and OEM harness connection.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the air conditioner clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Inspect the OEM harness and 23 pin connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or air conditioner clutch relay, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-207 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the fan clutch relay. Refer to OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the air conditioner clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from pin J of the 23-pin connector on the OEM side to the air conditioner clutch solenoid or relay.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the air conditioner clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure resistance from pin J of the 23-pin OEM harness connector to ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the air conditioner clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure resistance from pin J of the 23-pin OEM harness connector to all other pins in the 23-pin connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 191 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISC, QSC8.3, and ISL | 3666271
Engine Wiring Harness | Refer to Procedure 019-043 | ISC, QSC8.3, and ISL | 3666271

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference Fault Code 386 troubleshooting symptom tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Oct-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISC, QSC8.3, and ISL | 3666271
Engine Wiring Harness | Refer to Procedure 019-043 | ISC, QSC8.3, and ISL | 3666271

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352 troubleshooting symptom tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Oct-2012


FAULT CODE 234 - Engine Overspeed Circuit

Associated Procedures

Cautions and Warnings

WARNING

If flammable vapors are detected, shut down the engine, ventilate the area, and do not restart the engine until the source of the vapors is located and repaired.
CAUTION

If the engine speed stays above 2800 rpm, the engine must be shut off immediately.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for overspeed. |
 | STEP 1A. Check for proper operating conditions. | Proper vehicle operation
 | STEP 1B. Check for an alternate fuel source. | No alternate fuel source
 | STEP 1C. Check transmission operation. | Transmission functions properly
 | STEP 1D. Inspect the harness and the sensor connector. | No damaged pins
 | STEP 1E. Check the vehicle speed sensor. | Vehicle speed sensor OK
 | STEP 1F. Check the vehicle speed sensor circuit for signs of tampering. | No tampering
 | STEP 1G. Check the rpm with INSITE™ service tool monitor mode. | Correct rpm reading
 | STEP 1H. Check for an active fault at low rpm. | Inactive fault at low rpm
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Identify the reason for overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Verify with operator the following:

  • Engine was motoring downhill when the fault was logged.
OK NOT OK

Proper vehicle operation

Check the engine for damage. Electronics are OK. Inspect the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the operator reported a fuel-controlled event where the engine rapidly accelerated to or past overspeed limit without accelerator input to cause speed increase, followed by a sharp engine cutout.
  • Check the intake manifold for sources of flammable vapors, and check the turbocharger seals to verify there are no oil leaks.
OK NOT OK

No alternate fuel source

Locate the alternate fuel source

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

Inspect the base engine for damage due to the overspeed condition.

Go to 1C

Go to 2A

Guided Step 1C - Check transmission operation.

Conditions

  • Inspect transmission speed sensor.

Action

Test drive vehicle to check for proper operation of transmission.

Test drive vehicle to check for proper operation of transmission.
OK NOT OK

Transmission functions properly

Instruct operator of proper operation. Repair transmission. Refer to original equipment manufacturer (OEM) service manual.

Go to 1D

Go to 2A

Guided Step 1D - Inspect the harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the harness and the sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or the VSS, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the VSS. Refer to Procedure 019-090 in Section 19.
  • Refer to Procedure 019-091 in Section 19.
  • Inspect the base engine for damage due to the overspeed condition.

Go to 1E

Go to 2A

Guided Step 1E - Check the vehicle speed sensor.

Conditions

  • Turn the keyswitch to the OFF position.

Action

Check the vehicle speed sensor.

  • Verify vehicle speed sensor meets manufacturer's specifications.
OK NOT OK

Vehicle speed sensor OK

Replace the vehicle speed sensor. Refer to Procedure 019-090 in Section 19.

Refer to Procedure 019-091 in Section 19.

Inspect the base engine for damage due to overspeed condition.

Go to 1F

Go to 2A

Guided Step 1F - Check the vehicle speed sensor circuit for signs of tampering.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor circuit for signs of tampering such as:

  • Extra wires spliced into the vehicle speed sensor wiring
  • Cut braiding in the wires
  • Signs of unnecessary sensor removal and installation.
OK NOT OK

No tampering

Repair the vehicle speed sensor circuit

  • Magnetic pickup VSS. Refer to Procedure 019-091 in Section 19.
  • Digital input VSS [minigen]. Refer to Procedure 019-090 in Section 19.
  • Inspect the base engine for damage due to the overspeed condition.

Go to 1G

Go to 2A

Guided Step 1G - Check the rpm with the monitor mode.

Conditions

  • Keep the engine running.
  • Turn the keyswitch to the ON position.

Action

Check the rpm with the monitor mode.

  • Use INSITE™ electronic service tool to monitor the engine rpm.

Use INSITE™ electronic service tool to compare the engine speed reading to a mechanical tachometer or the dash tachometer.
OK NOT OK

Correct rpm reading

Inspect engine speed sensor. Check the engine speed sensor as outlined for Fault Code 115. Inspect the base engine for damage due to the overspeed condition.

Go to 1H

Go to 2A

Guided Step 1H - Check for an active fault at low rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active fault code at low rpm.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • Check for active Fault Code 234 when the engine is not running above 2800 rpm.
OK NOT OK

Inactive fault code at low rpm

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 234 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Jun-2015


FAULT CODE 235 - Engine Coolant Level - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
WARNING

Clear all faults before replacing the ECM.
CAUTION

Do not add cold coolant to a hot engine. Castings can be damaged. Allow engine to cool to below 50°C [120°F] before adding coolant.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the coolant level. |
 | STEP 1A. Check the coolant level. | Coolant level normal?
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault is still active with the engine running. | Fault code still activ?e
STEP 3. | Check engine harness. |
 | STEP 3A. Inspect the engine harness, coolant level sensor, and engine control module (ECM) connectors. | No damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check sensor supply voltage. | (+) 4.5 to 5.25 VDC?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 235 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify the coolant level.

Guided Step 1A - Check the coolant level.

Action

Check coolant level.

  • Remove the radiator cap, and inspect coolant level.
OK NOT OK

Coolant level is normal

Add coolant to the radiator. Make sure the coolant has the proper ratio of antifreeze and water.

Go to 2A

Go to 4A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Confirm the fault is still active with the engine running.

Conditions

  • Turn keyswitch ON.

Action

Confirm the fault is still active with the engine running.

  • Start the engine and let it idle for at least 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 235 is still active

Fault Code 235 is inactive

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, coolant level sensor, and ECM connectors.

Conditions

  • Turn keyswithch ON.
  • Disconnect the engine harness from the engine control module (ECM).
  • Disconnect the engine harness from the coolant level sensor.

Action

Inspect the engine harness, coolant level sensor, and ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair damaged pins. Repair or replace the engine harness, ECM, or coolant level sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant level sensor.

Action

Check for open circuit in the coolant level sensor circuit.

  • Measure the resistance from pin B on the harness side of the coolant level sensor circuit to pin 19 of the engine harness connector.
  • Measure the resistance from pin D on the harness side of the coolant level sensor circuit to pin 27 of the engine harness connector.
  • Measure the resistance from pin A on the harness side of the coolant level sensor circuit to pin 37 of the engine harness connector.
  • Measure the resistance from pin C on the harness side of the coolant level sensor circuit to pin 49 of the engine harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check sensor supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the coolant level sensor.
  • Connect the engine harness to the ECM.

Action

Check sensor supply voltage.

  • Measure the voltage from pin C of the sensor connector, harness side, to engine block ground.
OK NOT OK

(+) 4.5 to 5.25 VDC

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Reference the OEM service manual before replacing the coolant level sensor.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 235 is inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault code.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 24-Oct-2012


FAULT CODE 241 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Troubleshoot all faults before replacing ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle speed sensor (VSS). |
 | STEP 1A. Inspect the OEM harness and the sensor connectors. | No damaged pins
 | STEP 1B. Check the VSS for proper adjustment (if adjustable). | 1/2 to 3/4 turn out from gear for threaded type of sensor
 | STEP 1C. Check for the correct sensor resistance. | 750 to 1500 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 10M ohms
 | STEP 1E. Check for a short circuit between coils (if two coils exist). | More than 10M ohms
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the harness and the engine control module (ECM) connectors. | No damaged pins
 | STEP 2B. Check for correct circuit resistance. | 750 to 1500 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM components. |
 | STEP 3A. Check for an external recording device. | No external device
 | STEP 3B. Check for a transmission tailshaft gear slipping on the shaft. | Gear attached properly
 | STEP 3C. Check for interference on the OEM harness. | Fault Code 241 inactive
 | STEP 3C-1. Disable the fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 241 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the vehicle speed sensor (VSS).

Guided Step 1A - Inspect the OEM harness and the sensor connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the VSS.

Action

Inspect the OEM harness and the sensor connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the VSS. Refer to Procedure 019-090 in Section 19.
  • Refer to Procedure 019-091 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the VSS for the proper adjustment (if adjustable).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Check the VSS for the proper adjustment (if adjustable).

Check the VSS for the proper adjustment (if adjustable).
OK NOT OK

1/2 to 3/4 of a turn out from the gear for threaded type of sensor

Adjust the VSS. Refer to Procedure 019-090 in Section 19.

Refer to Procedure 019-091 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for the correct sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Check the vehicle speed sensor for the correct resistance.

  • Measure the resistance from pin A to pin B for each VSS connector on the sensor side.
OK NOT OK

750 to 1500 ohms

Replace the VSS. Refer to Procedure 019-090 in Section 19.

Refer to Procedure 019-091 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Check the VSS for a short circuit to ground.

  • Measure the resistance from pin A on the sensor side of one of the VSS connectors to engine block ground.
  • Measure the resistance from pin A on the sensor side of the other VSS connector to engine block ground.
OK NOT OK

More than 10M ohms

Replace the VSS. Refer to Procedure 019-090 in Section 19.

Refer to Procedure 019-091 in Section 19.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit between coils (if two coils exist).

Conditions

  • TTurn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Check the VSS for a short circuit between coils.

  • Measure the resistance from pin A on the sensor side of one of the VSS connectors to pin A of the other connector.
OK NOT OK

More than 10M ohms

Replace the VSS. Refer to Procedure 019-090 in Section 19.

Refer to Procedure 019-091 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the harness and the ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 2B

Go to 4A

Guided Step 2B - Check for the correct circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the OEM harness to the VSS.

Action

Check for the correct circuit resistance.

  • Check the OEM harness for the proper resistance between pin 8 and pin 18 of the OEM harness connector.
OK NOT OK

750 to 1500 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19..

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the OEM harness from the ECM.

Action

Check the harness for a short circuit to ground.

  • Measure the resistance from pin 8 of the OEM harness connector to engine block ground.
  • Measure the resistance from pin 18 of the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pins 8 and 18 to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check OEM components.

Guided Step 3A - Check for an external recording device.

Conditions

Turn keyswitch OFF.

Action

Check for an external recording device or similar devices attached to the vehicle speed sensor circuit.

Check for an external recording device or similar devices attached to the vehicle speed sensor circuit.
OK NOT OK

No external device

Disconnect device from circuit

Go to 3B

Go to 4A

Guided Step 3B - Check for the transmission tailshaft gear slipping on its shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the VSS.

Action

Check for the transmission tailshaft gear slipping on its shaft.

  • Check to make sure the transmission gear inside the sensor mounting is not slipping on the shaft. Do this by trying to spin the gear with a standard screwdriver.
OK NOT OK

Gear attached properly

Repair transmission gear. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for interference on the OEM harness.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Check for interference on the OEM harness.

  • Install a pair of twisted jumper wires from the VSS to the ECM. Connect the wires from pin A on the harness side of the VSS connector to pin 8 on the OEM harness connector and from pin B on the harness side of the VSS connector to pin 18 of the OEM harness connector.
  • Disconnect the speedometer connector at the VSS.
  • Drive the vehicle. The vehicle speed must exceed 16 kph [10 mph].
OK NOT OK

Fault Code 241 inactive

There is an interference on the OEM harness. Locate and remove the source of interference.

Replace the VSS. Refer to Procedure 019-090 in Section 19.

Refer to Procedure 019-091 in Section 19.

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Drive the vehicle. The vehicle speed must exceed 16 kph [10 mph].
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 241 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Drive the vehicle. The vehicle speed must exceed 16 kph [10 mph].
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 241 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 242 - Vehicle Speed Sensor (VSS) Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are set correctly. |
 | STEP 1A. Verify that the customer wants VSS antitampering (Fault Code 242) enabled. | Customer wants VSS antitampering (Fault Code 242) enabled
 | STEP 1B. Verify that automatic transmission is set correctly for application. | Automatic transmission is set correctly
 | STEP 1C. Verify that application type is set correctly for application. | Application type is set correctly
STEP 2. | Look for signs of tampering. |
 | STEP 2A. Inspect the VSS. | No signs of tampering detected at or with the vehicle speed sensor
 | STEP 2B. Inspect OEM VSS circuit. | No signs of tampering detected with the VSS leads or the original equipment manufacturer (OEM) harness
 | STEP 2C. Monitor vehicle speed. | Electronic service tool displays correct speed
 | STEP 2C-1. Verify the vehicle speed. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 242 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Verify that the feature settings are set correctly.

Guided Step 1A - Verify that the customer wants VSS antitampering (Fault Code 242) enabled.

Conditions

  • Turn keyswitch to the OFF position.

Action

Verify that the customer wants VSS antitampering (Fault Code 242) enabled.

Talk to the owner of the vehicle to see if this feature is required for the application of this vehicle.
OK NOT OK

Customer wants VSS antitampering (Fault Code 242) enabled

Use INSITE™ electronic service tool to adjust the feature setting to its correct value.

Go to 1B

Go to 3A

Guided Step 1B - Verify that automatic transmission is set correctly for application.

Conditions

Action

Verify that automatic transmission is set correctly for application.

  • Use INSITE™ electronic service tool to verify that this feature is activated if an automatic transmission is used, or deactivated if a manual transmission is used.
OK NOT OK

Automatic transmission is set correctly

Use INSITE™ electronic service tool to adjust the feature setting to its correct value.

Go to 1C

Go to 3A

Guided Step 1C - Verify that application type is set correctly for application.

Action

Verify that application type is set correctly for application.

  • Use INSITE™ electronic service tool to verify that this feature setting is set correctly for the application in which this vehicle is used.

NOTE: Driving for extended periods of time in lower gears is considered an on/off highway application.

OK NOT OK

Application type is set correctly

Use INSITE™ electronic service tool to adjust the feature setting to its correct value.

Go to 2A

Go to 3A

Guided Step 2 - Look for signs of tampering.

Guided Step 2A - Inspect the VSS.

Conditions

Action

Inspect the VSS for:

  • Improper mounting of the VSS
  • VSS improperly connected to OEM harness
  • Other external device connected in place of VSS
  • Any evidence that tampering with the VSS has taken place.
OK NOT OK

No signs of tampering detected at or with the vehicle speed sensor

VSS is improperly installed, connected, or has been tampered with.

  • Use the following procedures to correctly install and connect the VSS to the OEM harness. Refer to Procedure 019-090 in Section 19. Refer to Procedure 019-091 in Section 19.
  • Remove any tampering device.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the OEM VSS circuit.

Action

Inspect the OEM VSS circuit for:

  • Broken, cut, or incorrect routing of the VSS wires
  • Any devices connected in series or parallel with the VSS
  • Any other wires added to the VSS circuit
  • Any evidence that tampering with the VSS circuit has taken place.
OK NOT OK

No signs of tampering detected with the VSS leads or the OEM harness

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Monitor the vehicle speed.

Action

To check the vehicle speed, using INSITE™.

  • Verify that the vehicle speed is zero when the vehicle is stationary and the engine is running.
  • Drive the vehicle, or run on a chassis dynamometer. Compare the vehicle speed read by the electronic service tool to the speedometer on the dash.

Note: If the dash is an electronic dash that uses the ECM to obtain vehicle speed, perform a road test, and use a stopwatch and road mile markers to determine the true vehicle speed.

OK NOT OK

Electronic service tool displays correct speed

INSITE™ electronic service tool and speedometer do not match.

Verify the VSS parameters are adjusted correctly in the ECM. Check the VSS and the OEM harness in Steps 2A and 2B above. Repair any problems found.

Go to 2C-1

Go to 3A

Guided Step 2C-1 - Verify the vehicle speed.

Conditions

Action

Use INSITE ™ electronic service tool to verify that the speed reported is accurate or reasonable for the present gear.

(For example: 40 mph in top gear is probably inaccurate.)
OK NOT OK

Vehicle speed is accurate for current gear

Vehicle speed read by electronic service tool is inaccurate

Verify VSS parameters are adjusted correctly in the ECM. Check VSS and OEM harness in Steps 2A and 2B above. Repair any problems found.

Fault Code 241

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Turn keyswitch OFF.
  • Turn keyswitch ON (do not start engine).

Note: Vehicle speed and engine speed must be zero for at least 30 seconds to disable the fault code.

OK NOT OK

Fault Code 242 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 243 (ISC) - Engine Brake Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness, engine brake, and engine control module (ECM) connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the engine harness and original equipment manufacturer (OEM) harness connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 243 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM 23-pin connector.

Action

Inspect the engine harness and the ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM 23-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 42 of the ECM connector to pin O of the 23-pin OEM harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM 23-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 42 in the engine harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM 23-pin connector.

Action

Check for a short circuit between pins.

  • Measure the resistance from pin 42 to all other pins in the ECM connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the engine brake.

Action

Inspect the OEM harness, 23-pin connector, and the engine brake connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness or engine brake connectors, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-207 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine brake connector. Refer to original equipment manufacturer's service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the engine brake.
  • Measure the resistance from pin O of the 23-pin OEM connector on the OEM side to pin 2 of the engine brake connector.

Action

Check for an open circuit.

  • Measure the resistance from pin O of the 23-pin OEM connector on the OEM side to pin 1 of the engine brake connector.
OK NOT OK

Less than 10 ohms

Repair the OEM harness.

Refer to Procedure 019-207 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the engine brake.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin O of the 23-pin connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the engine brake.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin O of the 23-pin OEM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 243 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Jun-2015


FAULT CODE 243 (ISL) - Engine Brake Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness, engine brake, and engine control module (ECM) connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check engine brake harness. |
 | STEP 3A. Inspect the engine brake harness and connectors. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check engine brake solenoid resistance. | 9.5 to 11.5 ohms (cold); 11.5 to 14 ohms (hot)
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 243 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness, engine brake, and ECM connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM 23-pin connector.

Action

Inspect the engine harness and the ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM 23-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 42 of the ECM connector to pin O of the 23-pin OEM harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM 23-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 42 in the engine harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM 23-pin connector.

Action

Check for a short circuit between pins.

  • Measure the resistance from pin 42 to all other pins in the ECM connector.
OK NOT OK

More than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the engine brake.

Action

Inspect the OEM harness, 23-pin connector, and the engine brake connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness or engine brake connectors, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-207 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine brake connector. Refer to OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the engine brake.
  • Measure the resistance from pin O of the 23-pin OEM connector on the OEM side to pin 2 of the engine brake connector.

Action

Check for an open circuit.

  • Measure the resistance from pin O of the 23-pin OEM connector on the OEM side to pin 1 of the engine brake connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

Repair the OEM harness. Refer to Procedure 019-207 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the engine brake.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin O of the 23-pin connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the engine brake.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin O of the 23-pin OEM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check engine brake harness.

Guided Step 3A - Inspect the engine brake harness and connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine brake.
  • Disconnect the engine brake harness from pass-throughs.

Action

Inspect the engine brake harness and connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair pins, engine brake harness, or replace engine brake harness

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine brake.
  • Disconnect the engine brake harness from the pass-throughs.

Action

Check for an open circuit.

  • Measure resistance from pin 1 to pass-through connector #1.
  • Measure resistance from pin 2 to pass-through connector #2.
OK NOT OK

Less than 10 ohms

Replace the engine brake harness.

Refer to Procedure 019-136 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine brake.
  • Disconnect the engine brake harness from pass-throughs.

Action

Check for a short circuit to ground.

  • Measure resistance from pin 1 to ground.
  • Measure resistance from pin 2 to ground.
OK NOT OK

More than 100k ohms

Replace the engine brake harness.

Refer to Procedure 019-136 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine brake.
  • Disconnect the engine brake harness from pass-throughs.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 1 to pin 2.
OK NOT OK

More than 100k ohms

Replace the engine brake harness.

Refer to Procedure 019-136 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine brake solenoid resistance.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine brake.
  • Disconnect the engine brake harness from pass-throughs.

Action

Check the engine brake solenoid resistance.

  • Measure the resistance from the pass-through post #1 on the engine to ground.
  • Measure the resistance from the pass-through post #2 on the engine to ground.
OK NOT OK

9.5 to 11.5 ohms (cold); 11.5 to 14 ohms (hot)

Repair or replace engine brake solenoid.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 243 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 245 - Engine Fan Clutch Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fan clutch. |
 | STEP 1A. Inspect and test the fan clutch and fan clutch relay (if equipped). | Fan clutch and relay within specifications
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness, fan clutch relay, and the engine control module (ECM) connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the engine harness and original equipment manufacturer (OEM) harness connectors. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 245 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check fan clutch.

Guided Step 1A - Check fan clutch and fan clutch relay (if equipped).

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the fan clutch or fan clutch relay.

Action

Check the fan clutch for:

  • Damaged pins
  • Open or short circuits
  • Excessive current draw (power fan clutch directly from battery)
  • Perform this test in accordance with the OEM service manual.
OK NOT OK

Fan clutch within specifications

Repair or replace the fan clutch. Refer to OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness, fan clutch relay, and the ECM connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Inspect the engine harness and the ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness, or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 41 of the engine harness connector to pin N of the 23-pin OEM harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 41 in the engine harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit between pins.

  • Measure the resistance from pin 41 to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the engine harness and the OEM harness connectors.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the fan clutch relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Inspect the OEM harness and 23-pin connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or fan clutch relay, whichever has damaged pins.

  • Repair the OEM harness. or Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19
  • Refer to Procedure 019-207 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the fan clutch relay. Refer to OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the fan clutch relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from pin N of the 23-pin connector on the OEM side to the fan clutch and solenoid or relay.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the fan clutch solenoid or relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure resistance from pin N of the 23-pin OEM harness connector to ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the OEM harness from the fan clutch relay.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure resistance from pin N of the 23-pin OEM harness connector to all other pins in the 23-pin connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 245 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 263 or 265 - Fuel Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP™/Cannon™/Metri-Pack™/Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 221, 263, 352, and 451 are not active
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the engine harness and fuel temperature sensor connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the fuel temperature sensor. | 175 to 244k ohms
 | STEP 2C. Check for a short circuit to ground in fuel temperature sensor. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the engine control module (ECM) connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 263 and 265 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, 263, 352, and 451 are not active

Possible sensor failure, short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin to pin, or an open circuit in the sensor common ground.

Go to 2A

Go to Fault Code 352 or 386

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the fuel temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the harness and the sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the fuel temperature sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the fuel temperature sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Install the fuel pressure/temperature sensor breakout cable, Part Number 3162982.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance from pin B to pin D of the fuel temperature sensor.
OK NOT OK

175 to 244k ohms

Replace the fuel temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the fuel temperature sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the fuel temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel pressure/temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 35 of the engine harness to pin D on the harness side of the fuel temperature sensor.
  • Measure the resistance from pin 19 of the engine harness to pin B on the harness side of the fuel temperature sensor.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 35 of the engine harness to engine block ground.
  • Measure the resistance from pin 19 of the engine harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin 19 of the engine harness to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 263 and 265 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 263 or 265 - Fuel Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Cannon™/ Metri-Pack™/ Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 221, 263, 352, and 451 are not active
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the engine harness and fuel temperature sensor connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the fuel temperature sensor. | 175 to 244k ohms
 | STEP 2C. Check for a short circuit to ground in fuel temperature sensor. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the engine control module (ECM) connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 263 and 265 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, 263, 352, and 451 are not active

Possible sensor failure, short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin to pin, or an open circuit in the sensor common ground.

Go to 2A

Go to Fault Code 352 or 386

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the fuel temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the harness and the sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the fuel temperature sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the fuel temperature sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Install the fuel pressure/temperature sensor breakout cable, Part Number 3162982.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance from pin B to pin D of the fuel temperature sensor.
OK NOT OK

175 to 244k ohms

Replace the fuel temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the fuel temperature sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the fuel temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel pressure/temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 35 of the engine harness to pin D on the harness side of the fuel temperature sensor.
  • Measure the resistance from pin 19 of the engine harness to pin B on the harness side of the fuel temperature sensor.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 35 of the engine harness to engine block ground.
  • Measure the resistance from pin 19 of the engine harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin 19 of the engine harness to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 263 and 265 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 268 - Fuel Pressure Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | No other active faults
STEP 2. | Inspect fuel pressure sensor circuit. |
 | STEP 2A. Inspect circuit for damage. | No damage to circuit
STEP 3. | Check the ECM calibration. |
 | STEP 3A. Check ECM software release date. | ECM calibration revision date is after December 2000
STEP 4. | Check the engine wiring harness. |
 | STEP 4A. Inspect the engine wiring harness and the engine control module (ECM) connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Inspect the fuel pressure sensor circuit for a short circuit. | Greater than 100k ohms
 | STEP 4D. Inspect the fuel pressure sensor circuit for short circuit to ground. | Greater than 100k ohms
STEP 5. | Monitor fuel pressure. |
 | STEP 5A. Use INSITE™ electronic service tool to monitor fuel pressure. | Fuel pressure in range
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault codes. | Fault code 268 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault code .
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Only Fault Code 268 present

Other fault codes present

Go to 2A

Go to appropriate tree

Guided Step 2 - Inspect fuel pressure sensor circuit.

Guided Step 2A - Inspect circuit for damage.

Conditions

  • Turn key switch OFF.

Action

Check the pressure sensor.

  • Make sure pins are not fretted.
  • Make sure sensor potting is intact.

Check the pressure sensor pig tail.

  • Check for wire abrasion.
  • Check for shorts to rate shape tube or adjacent wires.
  • Make sure wires have not come out of sensor or connector by flexing and tugging on wires.
  • Make sure triangular connector has not rubbed against rate shape tube.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damage to circuit.

Signs of damage.

Replace fuel pressure sensor and install pressure sensor bracket kit if not already installed. Refer to Bulletin 4021293. Refer to Bulletin 4021294.

Go to 3A

Go to 6A

Guided Step 3 - Check the ECM calibration.

Guided Step 3A - Check the ECM software release

Conditions

N/A

Action

Check the software release.

  • Use the ECM Calibration Revision History on the current INCAL™ Calibration CD-ROM to check the ECM calibration.
OK NOT OK

ECM calibration revision date is after December 2000.

ECM calibration revision date is before December 2000.

Update the ECM calibration. Clear the fault codes and then check again for active or inactive fault codes.

Go to 4A

Appropriate fault code tree.

Guided Step 4 - Check the engine wiring harness.

Guided Step 4A - Inspect the engine wiring harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the fuel pressure sensor.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 4B

Go to 6A

Guided Step 4B - Inspect the fuel pressure sensor circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the fuel pressure sensor.

Action

Check for an open circuit in the fuel pressure sensor circuit.

  • Measure the resistance from pin 46 of the engine wiring harness to pin C of the fuel pressure sensor connector.
  • Measure the resistance from pin 10 of the engine wiring harness to pin A of the fuel pressure sensor connector.
  • Measure the resistance from pin 19 of the engine wiring harness to pin B of the fuel pressure sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms (no open circuit).

Repair or replace the engine wiring harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19..
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19..

Go to 4C

Go to 6A

Guided Step 4C - Inspect the fuel pressure sensor circuit for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from all of the sensors that share the common ground.

Action

Check for a short circuit in the fuel pressure sensor circuit.

  • Measure the resistance from pin 46 of the engine wiring harness to all other pins in the ECM connector.
  • Measure the resistance from pin 10 of the engine wiring harness to all other pins in the ECM connector.
  • Measure the resistance from pin 19 of the engine wiring harness to all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

If greater than 100k ohms (no shorts).

Repair or replace the engine wiring harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19..
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19..

Go to 4D

Go to 6A

Guided Step 4D - Inspect the fuel pressure sensor circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from all of the sensors that share the common ground.

Action

Check for a short circuit in the fuel pressure sensor circuit.

  • Measure the resistance from pin 46 of the engine wiring harness to chassis ground.
  • Measure the resistance from pin 10 of the engine wiring harness to chassis ground.
  • Measure the resistance from pin 19 of the engine wiring harness to chassis ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

If greater than 100k ohms (no shorts).

Repair or replace the wiring engine wiring harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19..
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19..

Go to 5A

Go to 6A

Guided Step 5 - Monitor the fuel pressure.

Guided Step 5A - Use INSITE™ electronic service tool to monitor the fuel pressure.

Conditions

  • Connect all components.
  • Turn keyswitch OFF for at least 10 minutes.
  • Turn keyswitch ON, but do not start engine.

Action

Check the fuel pressure.

  • Use INSITE™ electronic service tool with keyswitch in the ON position and no engine speed to measure the fuel pressure.

Accumulator pressure must be between -4930 and 8136 kPa [-715 and 1180 psi].

OK NOT OK

Fuel pressure in range

Fuel pressure out of range.

Replace fuel pressure sensor and install pressure sensor bracket kit if not already installed. Refer to Bulletin 4021293. Bulletin 4021294.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 268 is inactive and did not reoccur.
OK NOT OK

Fault Code 268 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault code.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Oct-2012


FAULT CODE 271 or 272 - Front Pumping Valve Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the front pumping valve. |
 | STEP 1A. Inspect the pumping valve connector for damaged pins. | No damaged pins
 | STEP 1B. Check the resistance of the front pumping valve. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to ground in the front pumping valve. | More than 100k ohms
 | STEP 1D. Check for open circuit in pumping control valve harness. | Less than 10 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness, pumping valve connector, and the engine control module (ECM) connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 271 or 272 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the front pumping valve.

Guided Step 1A - Inspect front pumping valve and connector for damaged pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the pumping control valve at the terminals.
  • Disconnect the engine harness from the front pumping control valve at the 4-pin connector.

Action

Inspect the front pumping valve 4-pin connector and pumping control valve terminals for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the pumping control valve harness or fuel pump accumulator module, whichever has damaged pins.

  • Replace the pumping control valve harness. Refer to Procedure 005-016 in Section 19.
  • Replace the fuel pump accumulator module. Refer to Procedure 005-085 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the front pumping valve.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the front pumping control valve.

Action

Check resistance of front pumping control valve.

  • Measure the resistance between the terminals on top of the front pumping control valve.
OK NOT OK

0.5 to 1.5 ohms

Replace fuel pump accumulator module. Refer to Procedure 005-085 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for short circuit to ground in front pumping control valve.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the front pumping valve coil.

Action

Check for short to ground in front pumping control valve.

  • Measure the resistance between one of the terminals of the front pumping control valve connector and chassis ground.
OK NOT OK

More than 100k ohms

Replace fuel pump accumulator module. Refer to Procedure 005-085 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for open circuit in pumping control valve harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Connect the pumping control valve harness to the front pumping control valve.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for an open circuit in the control valve harness.

  • Measure the resistance from pin 1 to the appropriate ring terminal of the pumping control valve harness.
  • Measure the resistance from pin 2 to the appropriate ring terminal of the pumping control valve harness.
OK NOT OK

Less than 10 ohms

Replace the accumulator module. Refer to Procedure 005-085 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness, pumping valve connector, and ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Inspect the engine harness, pumping control valve connector, and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for an open circuit in the front pumping control valve.

  • Measure the resistance from pin 31 of the engine harness to pin 2 of the front pumping control valve connector on the engine harness side.
  • Measure the resistance from pin 21 of the engine harness to pin 1 of the front pumping control valve connector on the engine harness side.
OK NOT OK

Less than 10 ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pins 21 and 31 of the engine harness connector to chassis ground.
OK NOT OK

More than 100k ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 21 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 31 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 271 or 272 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 273 or 274 - Rear Pumping Valve Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rear pumping valve. |
 | STEP 1A. Inspect rear pumping valve and connector for damaged pins. | No damaged pins
 | STEP 1B. Check the resistance of the pumping control valve. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to ground in rear pumping valve. | More than 100k ohms
 | STEP 1D. Check for open circuit in pumping control valve harness. | Less than 10 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness, pumping valve connector, and engine control module (ECM) connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 273 and 274 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the rear pumping valve.

Guided Step 1A - Inspect rear pumping valve and connector for damaged pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.
  • Disconnect the pumping control valve harness from the rear pumping control valve.

Action

Inspect the rear pumping control valve connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the pumping control valve harness or fuel pump accumulator module, whichever has damaged pins.

  • Replace the pumping control valve harness. Refer to Procedure 005-016 in Section 19.
  • Replace the fuel pump accumulator module. Refer to Procedure 005-085 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the pumping control valve.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the rear pumping control valve.

Action

Check resistance of rear pumping control valve.

  • Measure the resistance between the terminals on top of the rear pumping control valve.
OK NOT OK

0.5 to 1.5 ohms

Replace fuel pump accumulator module. Refer to Procedure 005-085 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for short circuit to ground in rear pumping valve.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the rear pumping control valve.

Action

Check for short to ground in the rear pumping control valve.

  • Measure the resistance between one of the terminals of the rear pumping control valve and chassis ground.
OK NOT OK

More than 100k ohms

Replace fuel pump accumulator module. Refer to Procedure 005-085 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for open circuit in pumping control valve harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the rear pumping control valve.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for an open circuit in the control valve harness.

  • Measure the resistance from pin 3 to the appropriate ring connector of the pumping control valve harness.
  • Measure the resistance from pin 4 to the appropriate ring connector of the pumping control valve harness.
OK NOT OK

Less than 10 ohms

Replace the accumulator module. Refer to Procedure 005-085 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness, pumping valve connector, and ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Inspect the engine harness, pumping control valve connector, and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for an open circuit in the rear pumping control valve.

  • Measure the resistance from pin 15 of the engine harness to pin 4 of the rear pumping control valve connector on the engine harness side.
  • Measure the resistance from pin 25 of the engine harness to pin 3 of the rear pumping control valve connector on the engine harness side.
OK NOT OK

Less than 10 ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pins 15 and 25 of the engine harness connector to chassis ground.
OK NOT OK

More than 100k ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the rear pumping control valve at the 4-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 15 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 25 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 273 and 274 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 273 or 274 - Rear Pumping Valve Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rear pumping valve. |
 | STEP 1A. Inspect rear pumping valve and connector for damaged pins. | No damaged pins
 | STEP 1B. Check the resistance of the pumping control valve. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to ground in rear pumping valve. | More than 100k ohms
 | STEP 1D. Check for open circuit in pumping control valve harness. | Less than 10 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness, pumping valve connector, and engine control module (ECM) connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 273 and 274 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the rear pumping valve.

Guided Step 1A - Inspect rear pumping valve and connector for damaged pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.
  • Disconnect the pumping control valve harness from the rear pumping control valve.

Action

Inspect the rear pumping control valve connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the pumping control valve harness or fuel pump accumulator module, whichever has damaged pins.

  • Replace the pumping control valve harness. Refer to Procedure 005-016 in Section 19 in the Troubleshooting and Repair Manual, ISC Engine, Bulletin 3666245.
  • Replace the fuel pump accumulator module. Refer to Procedure 005-085 in Section 19 in the Troubleshooting and Repair Manual, ISC Engine, Bulletin 3666245.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the pumping control valve.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the rear pumping control valve.

Action

Check resistance of rear pumping control valve.

  • Measure the resistance between the terminals on top of the rear pumping control valve.
OK NOT OK

0.5 to 1.5 ohms

Replace fuel pump accumulator module. Refer to Procedure 005-085 in Section 19 in the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.

Go to 1C

Go to 3A

Guided Step 1C - Check for short circuit to ground in rear pumping valve.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the rear pumping control valve.

Action

Check for short to ground in the rear pumping control valve.

  • Measure the resistance between one of the terminals of the rear pumping control valve and chassis ground.
OK NOT OK

More than 100k ohms

Replace fuel pump accumulator module. Refer to Procedure 005-085 in Section 19 in the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.

Go to 1D

Go to 3A

Guided Step 1D - Check for open circuit in pumping control valve harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the pumping control valve harness from the rear pumping control valve.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for an open circuit in the control valve harness.

  • Measure the resistance from pin 3 to the appropriate ring connector of the pumping control valve harness.
  • Measure the resistance from pin 4 to the appropriate ring connector of the pumping control valve harness.
OK NOT OK

Less than 10 ohms

Replace the accumulator module. Refer to Procedure 005-085 in Section 19 in the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness, pumping valve connector, and ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Inspect the engine harness, pumping control valve connector, and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for an open circuit in the rear pumping control valve.

  • Measure the resistance from pin 15 of the engine harness to pin 4 of the rear pumping control valve connector on the engine harness side.
  • Measure the resistance from pin 25 of the engine harness to pin 3 of the rear pumping control valve connector on the engine harness side.
OK NOT OK

Less than 10 ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the pumping control valve at the 4-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pins 15 and 25 of the engine harness connector to chassis ground.
OK NOT OK

More than 100k ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the rear pumping control valve at the 4-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 15 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 25 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 273 and 274 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 275 - Front Pumping Element

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Read fault codes. | Fault Code 328 is not present
STEP 2. | Verify pumping valve solenoid performance. |
 | STEP 2A. Verify pumping valve solenoid performance. | Solenoid clicks when activated
 | STEP 2A-1. Check fault codes. |
 | STEP 2A-2. Attempt to start the engine. |
 | STEP 2B. Verify pumping element performance. | Pumping elements performing equally
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 275 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 328 is not present

Fault Code 328 is present

If present, verify that the fuel filter is not plugged. Refer to Procedure 006-020 in Section 6 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418.

Go to 2A

Go to 3A

Guided Step 2 - Verify pumping valve solenoid performance.

Guided Step 2A - Check pumping valve circuit performance.

Conditions

  • Turn keyswitch to the ON position.

Action

Verify pumping valve solenoid circuit performance.

  • Use INSITE™ electronic service tool to run the solenoid click test on the front pumping valve solenoid. Refer to Procedure 005-079 in Section 5 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418. Listen for a click when activating the test to verify that the solenoid is operating.
OK NOT OK

Solenoid clicks when activated

Solenoid does not click when activated or clicks erratically.

Go to 2A-2

Go to 2A-1

Guided Step 2A-1 - Check fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 271 inactive or not present.

Fault Code 271 active.

Go to 2A-2

Refer to Fault Code 271

Guided Step 2A-2 - Attempt to start the engine.

Conditions

  • Turn keyswitch to the ON position with the engine operating.

Action

Attempt to start the engine.
OK NOT OK

Engine starts

Engine does not start.

Replace the fuel pump accumulator module. Refer to Procedure 005-085 in Section 5 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418.

Go to 2B

Go to 3A

Guided Step 2B - Verify pumping element performance.

Conditions

  • Turn keyswitch to the ON position with the engine operating.

Action

Verify pumping element performance.

  • Use INSITE™ electronic service tool to run the pumping plunger cutout test on each pumping plunger. Refer to Procedure 005-079 in Section 5 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418. Observe valve close angle (VCA), accumulator pressure, accumulator pressure set point, and engine speed for each pumping plunger as the other is cut out.
OK NOT OK

Pumping element performs equally

Replace the fuel pump accumulator module

Refer to Procedure 005-085 in Section 5 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 275 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 276 - Injection Control Valve Stator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Deutsch™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injection control valve. |
 | STEP 1A. Record and clear the inactive fault codes. | All inactive fault codes cleared.
 | STEP 1B. Check for codes after performing a click test. | Fault Code 276 or 277 logged, or no fault codes present.
STEP 2. | Check the injection control valve. |
 | STEP 2A. Inspect the injection control valve stator connector for damaged pins. | No damaged pins.
 | STEP 2B. Check the resistance of the injection control valve stator. | 0.1 to 1.0 ohms.
 | STEP 2C. Check for a short circuit to ground in the injection control valve stator. | More than 100k ohms.
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and the engine control module (ECM) connector pins. | No damaged pins.
 | STEP 3B. Check for an open circuit. | Less than 10 ohms.
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 3C-1. Check for a short circuit to ground. |
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms.
STEP 4. | Check the ECM ground circuit. |
 | STEP 4A. Check the negative (-) battery connection for corrosion. | Connection is tight and corrosion free.
 | STEP 4B. Check the resistance of the ECM ground circuit. | Less than 10 ohms.
 | STEP 4C. Inspect the 23-pin original equipment manufacturer (OEM) connector. | No damaged or loose connections.
 | STEP 4D. Check the resistance of the OEM ground circuit. | Less than 10 ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 276 inactive.
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the injection control valve.

Guided Step 1A - Record and clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Record and clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All inactive fault codes cleared.

All inactive fault codes not cleared.

Go to 1B

Go to 5B

Guided Step 1B - Check for codes after performing a click test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to run the solenoid click test on the injection control valve.

  • Listen for a strong, steady, audible click when activating the test and while wiggling the injection control valve stator wires.
OK NOT OK

Fault Code 276 or 277 logged, or no fault codes present.

Injection control valve stops clicking or does not click while wiggling wires.

Injection control valve clicks erratically during wiggling of wires.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

NOTE: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Go to 2A

Go to 5A

Guided Step 2 - Check the injection control valve.

Guided Step 2A - Inspect the injection control valve stator connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve.

Action

Inspect the injection control valve connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

NOTE: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Go to 2B

Go to 5A

Guided Step 2B - Check the resistance of the injection control valve stator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check the resistance of the injection control valve stator.

  • Measure the resistance between pin 1 and pin 2 of the injection control valve stator connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

0.1 to 1.0 ohms.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

NOTE: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the injection control valve stator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check for a short circuit to ground in the injection control valve stator.

  • Measure the resistance from pin 1 of the injection control valve stator connector to chassis ground.
  • Measure the resistance from pin 2 of the injection control valve stator connector to chassis ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

More than 100k ohms.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

Note: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - No damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins.

Repair the damaged pins.

Repair or replace the engine wiring harness or ECM, whichever has the damaged pins.

  • Repair the engine wiring harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

NOTE: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve.

Action

Check for an open circuit in the injection control valve circuit of the engine harness.

  • Measure the resistance from pin 7 of the engine wiring harness to pin 1 of the injection control valve connector.
  • Measure the resistance from pin 6 of the engine wiring harness to pin 2 of the injection control valve connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Note: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the engine wiring harness connector to chassis ground.
  • Measure the resistance from pin 7 of the engine wiring harness connector to chassis ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

More than 100k ohms.

Go to 3D

Go to 3C-1

Guided Step 3C-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve stator.
  • Disconnect the transient suppressor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the engine wiring harness connector to chassis ground.
  • Measure the resistance from pin 7 of the engine wiring harness connector to chassis ground.
OK NOT OK

More than 100k ohms.

Replace the transient suppressor.

  • Refer to Procedure 019-184 in Section 19.

NOTE: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Replace the engine wiring harness.

  • Refer to Procedure 019-043 in Section 19.

NOTE: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Go to 5A

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine wiring harness connector to all other pins in the connector and to the transient suppressor case.
  • Measure the resistance from pin 7 of the engine wiring harness connector to all other pins in the connector and to the transient suppressor case.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

More than 100k ohms.

  • Short circuit from pin 6 to pin 7 or to transient suppressor case. Replace the transient suppressor. Refer to Procedure 019-184 in Section 19.
  • Short circuit from pin 6 or pin 7 to any other pins. Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Note: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM ground circuit.

Guided Step 4A - Check the negative (-) battery connection for corrosion.

Conditions

  • Turn keyswitch ON.

Action

Check the negative (-) battery connection for corrosion and that all connections are tight.

Check the negative (-) battery connection for corrosion and that all connections are tight.
OK NOT OK

Connection is tight and corrosion free.

Tighten the connection.

  • Tighten the loose connection and clean the terminal. Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Check the resistance of the ECM ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for an open circuit in the ECM ground circuits.

  • Measure the resistance from pin 20 to the negative (-) battery terminal.
  • Measure the resistance from pin 28 to the negative (-) battery terminal.
  • Measure the resistance from pin 29 to the negative (-) battery terminal.
  • Measure the resistance from pin 30 to the negative (-) battery terminal.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms.

Replace the injection control valve module. Use the following procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 005-078 in Section 5.

NOTE: A damaged injection control valve may also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor may cause damage to the injection control valve.

Ground wire open in either engine or OEM harness.

Go to 5A

Go to 4C

Guided Step 4C - Inspect the 23-pin OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the battery supply at the 23-pin OEM connector.

Action

Inspect the 23-pin OEM connector on both the battery side and harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins or loose connections.

Repair or replace the damaged pins.

Refer to Procedure 019-207 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check the resistance of the OEM ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the 23-pin Deutsch™ connector.

Action

Check the resistance of the OEM ground circuit.

  • Measure the resistance from pins E, F, H, P, and W of the battery return connector to the negative (-) battery terminal.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the OEM wiring harness.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute, then increase the engine rpm above 1800 rpm, then go back to idle three consecutive times.
  • Use INSITE™ electronic service tool to verify Fault Code 276 is inactive.
OK NOT OK

Fault Code 276 inactive.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 277 - Injection Control Valve Stator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Deutsch™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injection control valve. |
 | STEP 1A. Record and clear the inactive fault codes. | All inactive fault codes cleared.
 | STEP 1B. Check for codes after performing a click test. | Fault Code 276 or 277 logged, or no fault codes present.
STEP 2. | Check the injection control valve. |
 | STEP 2A. Inspect the injection control valve stator connector for damaged pins. | No damaged pins.
 | STEP 2B. Check the resistance of the injection control valve stator. | 0.1 to 1.0 ohms.
 | STEP 2C. Check for a short circuit to ground in the injection control valve stator. | More than 100k ohms.
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and the engine control module (ECM) connector pins. | No damaged pins.
 | STEP 3B. Check for an open circuit. | Less than 10 ohms.
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 3C-1. Check for a short circuit to ground. |
 | STEP 3D. Check for a short circuit from pin-to-pin. | More than 100k ohms.
STEP 4. | Check the ECM ground circuit. |
 | STEP 4A. Check the negative (-) battery connection for corrosion. | Connection is tight and corrosion free.
 | STEP 4B. Check the resistance of the ECM ground circuit. | Less than 10 ohms.
 | STEP 4C. Inspect the 23-pin original equipment manufacturer (OEM) connector. | No damaged pins or loose connections.
 | STEP 4D. Check the resistance of the OEM ground circuit. | Less than 10 ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 277 inactive.
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the injection control valve.

Guided Step 1A - Record and clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Record and clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All inactive fault codes cleared.

All inactive fault codes not cleared.

Go to 1B

Go to 5B

Guided Step 1B - Check for codes after performing a click test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to run the solenoid click test on the injection control valve.

  • Listen for a strong, steady, audible click when activating the test and while wiggling the injection control valve stator wires.
OK NOT OK

Fault Code 276 or 277 logged, or no fault codes present.

Injection control valve stops clicking or does not click while wiggling wires.

Injection control valve clicks erratically during wiggling of wires.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

Note: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Go to 2A

Go to 5A

Guided Step 2 - Check the injection control valve.

Guided Step 2A - Inspect the injection control valve stator connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve.

Action

Inspect the injection control valve connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Go to 2B

Go to 5A

Guided Step 2B - Check the resistance of the injection control valve stator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check the resistance of the injection control valve stator.

  • Measure the resistance between pin 1 and pin 2 of the injection control valve stator connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

0.1 to 1.0 ohms.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the injection control valve stator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check for a short circuit to ground in the injection control valve stator.

  • Measure the resistance from pin 1 of the injection control valve stator connector to chassis ground.
  • Measure the resistance from pin 2 of the injection control valve stator connector to chassis ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

More than 100k ohms.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - No damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins.

Repair the damaged pins.

Repair or replace the engine wiring harness or ECM, whichever has the damaged pins.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-250 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve.

Action

Check for an open circuit in the injection control valve circuit.

  • Measure the resistance from pin 7 of the engine wiring harness to pin 1 of the injection control valve connector.
  • Measure the resistance from pin 6 of the engine wiring harness to pin 2 of the injection control valve connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the engine wiring harness connector to chassis ground.
  • Measure the resistance from pin 7 of the engine wiring harness connector to chassis ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

More than 100k ohms.

Go to 3D

Go to 3C-1

Guided Step 3C-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve stator.
  • Disconnect the transient suppressor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the engine wiring harness connector to chassis ground.
  • Measure the resistance from pin 7 of the engine wiring harness connector to chassis ground.
OK NOT OK

More than 100k ohms.

Replace the transient suppressor.

  • Refer to Procedure 019-184 in Section 19.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Replace the engine wiring harness.

  • Refer to Procedure 019-043 in Section 19.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Go to 5A

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine wiring harness connector to all other pins in the connector and to the transient suppressor case.
  • Measure the resistance from pin 7 of the engine wiring harness connector to all other pins in the connector and to the transient suppressor case.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

More than 100k ohms.

  • Short circuit from pin 6 to pin 7 or to transient suppressor case. Replace the transient suppressor. Refer to Procedure 019-184 in Section 19.
  • Short circuit from pin 6 or pin 7 to any other pins. Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM ground circuit.

Guided Step 4A - Check the negative (-) battery connection for corrosion.

Conditions

  • Turn keyswitch ON.

Action

Check the negative (-) battery connection for corrosion and that all connections are tight.
OK NOT OK

Connection is tight and corrosion free.

Tighten the connection.

  • Tighten the loose connection and clean the terminal. Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Check the resistance of the ECM ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for an open circuit in the ECM ground circuits.

  • Measure the resistance from pin 20 to the negative (-) battery terminal.
  • Measure the resistance from pin 28 to the negative (-) battery terminal.
  • Measure the resistance from pin 29 to the negative (-) battery terminal.
  • Measure the resistance from pin 30 to the negative (-) battery terminal.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms.

Replace the injection control valve module. Use the following procedure in the ISC, ISCe, QSC8.3, ISL and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-078 in Section 5.

NOTE: A damaged injection control valve can also damage the transient suppressor and/or the ECM. Trying to start the engine with a damaged ECM and/or transient suppressor can cause damage to the injection control valve.

Ground wire open in either engine or OEM harness.

Go to 5A

Go to 4C

Guided Step 4C - Inspect the 23-pin OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the battery supply at the 23-pin OEM connector.

Action

Inspect the 23-pin OEM connector on both the battery side and harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins or loose connections.

Repair or replace the damaged pins.

Refer to Procedure 019-223 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check the resistance of the OEM ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the 23-pin Deutsch™ connector.

Action

Check the resistance of the OEM ground circuit.

  • Measure the resistance from pins E, F, H, P, and W of the battery return connector to the negative (-) battery terminal.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the OEM wiring harness.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute, then increase the engine rpm above 1800 rpm, then go back to idle three consecutive times.
  • Use INSITE™ electronic service tool to verify Fault Code 277 is inactive.
OK NOT OK

Fault Code 277 inactive.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 278 - Lift Pump Circuit

Associated Procedures

Cautions and Warnings

WARNING

Check and clear all active fault codes before replacing the engine control module (ECM).
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the lift pump. |
 | STEP 1A. Inspect the engine harness and lift pump connectors. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the lift pump. | 0.1 to 100k ohms for 12-VDC and 24-VDC lift pumps?
 | STEP 1C. Check for a short to ground. | Greater than 100k ohms?
STEP 2. | Check engine harness. |
 | STEP 2A. Inspect harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the lift pump supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit in the lift pump return circuit. | Less than 10 ohms?
 | STEP 2C-1. Check for an open circuit in the engine harness lift pump return circuit. |
 | STEP 2D. Check for short to ground. | Greater than 100k ohms?
 | STEP 2E. Check for short from pin to pin. | Greater than 100k ohms?
 | STEP 2F. Measure the engine harness voltage at the lift pump connector. | (+) 11 to 13-VDC - (+) 12-VDC systems; (+) 23 to 25-VDC - (+) 24-VDC systems?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 278 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the lift pump.

Guided Step 1A - Inspect the engine harness and lift pump connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Inspect the engine harness and lift pump connectors for:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or lift pump, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the fuel lift pump. Use the following procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Engines, Bulletin 4021418. Refer to Procedure 005-045 in Section 5.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the lift pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Check the resistance of the lift pump.

  • Measure the resistance from pin 1 to pin 2 of the lift pump harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

0.1 to 100k ohms for 12-VDC and 24-VDC lift pumps?

Replace the fuel lift pump.

  • Use the following procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Engines, Bulletin 4021418. Refer to Procedure 005-045 in Section 5.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Check for a short to ground in the lift pump.

  • Measure the resistance from pin 1 of the lift pump connector, pump side, to engine block ground.
  • Measure the resistance from pin 2 of the lift pump connector, pump side, to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Greater than 100k ohms?

Replace the fuel lift pump.

  • Use the following procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Engines, Bulletin 4021418. Refer to Procedure 005-045 in Section 5.

Go to 2A

Go to 3A

Guided Step 2 - Check engine harness.

Guided Step 2A - Inspect engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for open circuit in the lift pump supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the lift pump connector from the engine harness.

Action

Check for an open circuit in the lift pump supply pin.

  • Measure the resistance from pin 11 of the engine harness connector to pin 1 of the lift pump connector.
  • Measure the resistance from pin 22 of the engine harness connector to pin 1 of the lift pump connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms?

Replace or repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the lift pump return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the lift pump connector from the engine harness.

Action

Check for an open circuit in the lift pump return pin.

  • Measure the resistance from pin 2 of the lift pump connector, harness side, and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms?

Less than 10 ohms?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for an open circuit in the engine harness lift pump return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump connector from the engine harness.
  • Disconnect the lift pump engine harness from the 23-pin original equipment manufacturer (OEM) connector.

Action

Check for an open circuit in the lift pump supply pin.

  • Measure the resistance from pin 2 of the lift pump connector, harness side, and pin W on the 23-pin OEM connector, engine harness side.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

Less than 10 ohms?

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 2D - Check for short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the lift pump.

Action

Check for short circuit to ground.

  • Measure the resistance from pin 11 of the engine harness to engine block ground.
  • Measure the resistance from pin 22 of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for short from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the lift pump.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 11 of the engine harness connector to all other pins in the connector, except pin 22.
  • Measure the resistance from pin 22 of the engine harness connector to all other pins in the connector, except pin 11.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Measure the engine harness voltage at the lift pump connector.

Conditions

  • Connect all components.
  • Disconnect the engine harness from the lift pump.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the engine harness voltage at the lift pump connector.

  • Measure the harness voltage between the connector terminals with the lift pump disconnected from the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.
OK NOT OK

(+) 11 to 13-VDC - (+) 12-VDC systems; (+) 23 to 25-VDC - (+) 24-VDC systems?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 278 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 279 - Injection Control Valve Stator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP™/Deutsch™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injection control valve. |
 | STEP 1A. Record and clear the inactive fault codes. | All inactive fault codes cleared
 | STEP 1B. Check for codes after performing a click test. | Fault Code 276, 277, or 279 logged, or no fault codes present
STEP 2. | Check the injection control valve. |
 | STEP 2A. Inspect the injection control valve stator connector for damaged pins. | No damaged pins
 | STEP 2B. Check the resistance of the injection control valve stator. | 0.1 to 1.0 ohms
 | STEP 2C. Check for a short circuit to ground in the injection control valve stator. | More than 100k ohms
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and the engine control module (ECM) connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 279 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injection control valve.

Guided Step 1A - Record and clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Record and clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.
OK NOT OK

All inactive fault codes cleared

All inactive fault codes not cleared.

Go to 1B

Go to 4B

Guided Step 1B - Check for codes after performing a click test.

Conditions

  • Turn keyswitch ON.

Action

Use INSITE™ to run the solenoid click test on the injection control valve.

  • Listen for a strong, steady, audible click when activating the test and while wiggling the injection control valve stator wires.
OK NOT OK

Fault Code 276, 277, or 279 logged, or no fault codes present

Injection control valve stops clicking or does not click while wiggling wires.

Injection control valve clicks erratically during wiggling of wires.

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19..

Go to 2A

Go to 5A

Guided Step 2 - Check the injection control valve.

Guided Step 2A - Inspect the injection control valve stator connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve.

Action

Inspect the injection control valve connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the injection control valve stator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check the resistance of the injection control valve stator.

  • Measure the resistance between pin 1 and pin 2 of the injection control valve stator connector.
OK NOT OK

0.1 to 1.0 ohms

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the injection control valve stator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check for a short circuit to ground in the injection control valve stator.

  • Measure the resistance from pin 1 of the injection control valve stator connector to chassis ground.
  • Measure the resistance from pin 2 of the injection control valve stator connector to chassis ground.
OK NOT OK

More than 100k ohms

Replace the injection control valve stator. Refer to Procedure 019-430 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - No damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Inspect the engine wiring harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins.

Repair the damaged pins

Repair or replace the engine wiring harness or ECM, whichever has the damaged pins.

  • Repair the engine wiring harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19, or Refer to Procedure 019-204 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the injection control valve stator.

Action

Check for an open circuit in the injection conrol valve circuit.

  • Measure the resistance from pin 7 of the engine wiring harness to pin 1 of the injection control valve connector.
  • Measure the resistance from pin 6 of the engine wiring harness to pin 2 of the injection control valve connector.
OK NOT OK

Less than 10 ohms

Replace the injection control valve module. Refer to Procedure 005-078 in Section 5 in the ISC, ISCe, QSC8.3, ISL and QSL9 Engines Troubleshooting and Repair Manual, Bulletin 3666245.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute, then rev the engine above 1800 rpm, then go back to idle three consecutive times.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 279 inactive

Return to the troubleshooting steps or contact a Cummin®s authorized repair location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 281 or 282 - Pumping Element

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Read fault codes. | Fault Code 281 or 282 inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 281 or 282 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check fault codes.

Guided Step 1A - Read fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 281 or 282 inactive

Replace fuel pump accumulator module. Refer to Procedure 005-085 in Section 5 in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin No. 4021418.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 281 or 282 is inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate trouble-shooting chart

Last Modified: 27-Oct-2012


FAULT CODE 281 or 282 - Pumping Element

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Read fault codes. | Fault Code 281 or 282 inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 281 or 282 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check fault codes.

Guided Step 1A - Read fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 281 or 282 inactive

Replace fuel pump accumulator module. Refer to Procedure 005-085 in Section 5 in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin No. 4021418.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 281 or 282 is inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 283 or 284 - Engine Speed Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 is not active
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the harness and sensor pins. | No damaged pins
 | STEP 2B. Check for short circuit to ground. | More than 100k ohms
STEP 3. | Check engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check sensor supply voltage. | (+) 4.5 to 5.25 VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 283 or 284 is inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 441 is not active

Fault Code 441 is active

Go to 2A

Fault Code 441

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the harness and sensor pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the harness from the engine speed sensor.

Action

Inspect the engine harness and sensor connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or engine speed sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the harness from the engine speed sensor.
  • Connect the breakout cable, Part Number 3824775 to engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the engine speed sensor connector to ground.
  • Measure the resistance from pin B of the engine speed sensor connector to ground.
  • Measure the resistance from pin C of the engine speed sensor connector to ground.
OK NOT OK

More than 100k ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3B

Go to 4A

Guided Step 3B - Check for open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 8 of the engine harness connector to pin A on the harness side of the engine speed sensor.
  • Measure the resistance from pin 18 of the engine harness connector to pin B on the harness side of the engine speed sensor.
  • Measure the resistance from pin 17 of the engine harness connector to pin C on the harness side of the engine speed sensor.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for short circuit to ground.

  • Measure the resistance from pin 8 of the engine harness connector to ground.
  • Measure the resistance from pin 18 of the engine harness connector to ground.
  • Measure the resistance from pin 17 of the engine harness connector to ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 8 to all other pins on the harness side of the engine harness connector.
  • Measure the resistance from pin 18 to all other pins on the harness side of the engine harness connector.
  • Measure the resistance from pin 17 to all other pins on the harness side of the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3E

Go to 4A

Guided Step 3E - Check sensor supply voltage.

Conditions

  • Connect the engine harness to the ECM.
  • Disconnect the engine harness from the engine speed sensor.
  • Turn keyswitch to the ON position.

Action

Check sensor supply voltage.

  • Measure voltage from pin A on the harness side of the engine speed sensor connector to engine block ground.
OK NOT OK

(+) 4.5 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 283 or 284 is inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2012


FAULT CODE 283 or 284 - Engine Speed Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 is not active
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the harness and sensor pins. | No damaged pins
 | STEP 2B. Check for short circuit to ground. | More than 100k ohms
STEP 3. | Check engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check sensor supply voltage. | (+) 4.5 to 5.25 VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 283 or 284 is inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 441 is not active

Fault Code 441 is active

Go to 2A

Fault Code 441

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the harness and sensor pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the harness from the engine speed sensor.

Action

Inspect the engine harness and sensor connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or engine speed sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the harness from the engine speed sensor.
  • Connect the breakout cable, Part Number 3824775 to engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the engine speed sensor connector to ground.
  • Measure the resistance from pin B of the engine speed sensor connector to ground.
  • Measure the resistance from pin C of the engine speed sensor connector to ground.
OK NOT OK

More than 100k ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3B

Go to 4A

Guided Step 3B - Check for open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 8 of the engine harness connector to pin A on the harness side of the engine speed sensor.
  • Measure the resistance from pin 18 of the engine harness connector to pin B on the harness side of the engine speed sensor.
  • Measure the resistance from pin 17 of the engine harness connector to pin C on the harness side of the engine speed sensor.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for short circuit to ground.

  • Measure the resistance from pin 8 of the engine harness connector to ground.
  • Measure the resistance from pin 18 of the engine harness connector to ground.
  • Measure the resistance from pin 17 of the engine harness connector to ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 8 to all other pins on the harness side of the engine harness connector.
  • Measure the resistance from pin 18 to all other pins on the harness side of the engine harness connector.
  • Measure the resistance from pin 17 to all other pins on the harness side of the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3E

Go to 4A

Guided Step 3E - Check sensor supply voltage.

Conditions

  • Connect the engine harness to the ECM.
  • Disconnect the engine harness from the engine speed sensor.
  • Turn keyswitch to the ON position.

Action

Check sensor supply voltage.

  • Measure voltage from pin A on the harness side of the engine speed sensor connector to engine block ground.
OK NOT OK

(+) 4.5 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 283 or 284 is inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Nov-2012


FAULT CODE 285 - J1939 Datalink Multiplexing

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part No. 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM) for proper multiplexing configuration. |
 | STEP 1A. Determine which vehicle inputs (throttle, switches, lamps, sensors) are multiplexed over the J1939 data link. | Devices in step 1A must match devices in step 1B
 | STEP 1B. Use INSITE™ electronic service tool to verify that the proper devices are set to be multiplexed in the ECM. | Devices in step 1B must match devices in step 1A
STEP 2. | Inspect the J1939 connectors on the backbone harness and engine harness connectors. |
 | STEP 2A. Inspect the ECM, engine harness, and 3-pin connectors. | No damaged pins
 | STEP 2B. Inspect the vehicle electronic control unit (VECU) 3-pin and associated connectors. | No damaged pins
STEP 3. | Inspect the engine harness. |
 | STEP 3A. Check for open circuit. | Less than 10 ohms
 | STEP 3B. Check the resistance value in the J1939 harness. | 55 to 65 ohms
 | STEP 3C. Check for a short circuit to power. | Less than (+) 1.5-VDC
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit pin to pin. | More than 100k ohms
STEP 4. | Inspect the SAE J1939 backbone harness. |
 | STEP 4A. Check for an open circuit. | Less than 10 ohms
 | STEP 4B. Check for a short circuit to power. | Less than (+) 1.5-VDC
 | STEP 4C. Check for a short circuit to ground. | More than 100k ohms
STEP 5. | Inspect the original equipment manufacturer (OEM) wiring. |
 | STEP 5A. Check for an open circuit. | Less than 10 ohms
 | STEP 5B. Check for a short circuit to power. | Less than (+) 1.5-VDC
 | STEP 5C. Check for a short circuit to ground. | More than 100k ohms
STEP 6. | Check for proper communication with the J1939 devices. |
 | STEP 6A. Check communication with the VECU(s). | Proper communication between multiplexing devices and VECU(s)
STEP 7. | Clear the fault code. |
 | STEP 7A. Disable the fault code. | Fault Code 285 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM for proper multiplexing configuration.

Guided Step 1A - Determine which vehicle inputs (throttle, switches, lamps, sensors) are multiplexed over the J1939 data link.

Conditions

  • Connect with the OEM service tool to the VECU.
  • Turn keyswitch to the ON position.

Action

Check which vehicle inputs are multiplexed over the J1939 data link in the VECU.

  • Read the devices that are sending input information with the OEM service tool.
OK NOT OK

Devices in step 1A must match devices in step 1B

Go to 1B

Go to 1B

Guided Step 1B - Use INSITE™ electronic service tool to verify that the proper devices are set to be multiplexed in the ECM.

Conditions

  • Connect the INLINE 2™ data link adapter.
  • Connect INSITE™.
  • Turn keyswitch to the ON position.

Action

ECM settings match devices installed on vehicle.

  • Use INSITE™ electronic service tool to read the ECM settings for devices.
OK NOT OK

INSITE™ electronic service tool readout matches ECM settings for devices (Devices in step 1B match step 1A)

Configure ECM to match vehicle devices. Use INSITE™ electronic service tool to configure the ECM to work with the multiplexed devices.

Go to 2A

Go to 7A

Guided Step 2 - Inspect the J1939 connectors on the backbone harness and engine harness connectors.

Guided Step 2A - Inspect the ECM, engine harness, and 3-pin connectors.

Conditions

  • Disconnect the engine harness from the ECM.
  • Disconnect the multiplexed devices.

Action

Inspect the ECM, engine harness, J1939 connectors, and multiplexed devices for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pinsRepair or replace the ECM, engine harness, J1939, 3-pin connector, or multiplexed devices, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number. 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair or replace the ECM. Refer to Procedure 019-031 in Section 19 in the ISC and QSC8.3 Engines, Electronic Control System, Bulletin 3666271.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19 in the ISC and QSC8.3 Engines, Electronic Control System, Bulletin 3666271.
  • Repair or replace the 3-pin connectors. Refer to Procedure 019-203 in Section 19 in the ISC and QSC8.3 Engines, Electronic Control System, Bulletin 3666271.
  • Repair or replace the multiplexed devices. Refer to ISC troubleshooting and repair manual for specific device.

Go to 2B

Go to 7A

Guided Step 2B - Inspect the VECU 3-pin and associated connectors.

Conditions

  • Disconnect the VECU(s) from the J1939 backbone harness.
  • Disconnect the multiplexed devices from the VECU(s).

Action

Inspect the VECU(s), 3-pin, and multiplexed devices connectors for:
OK NOT OK

No damaged pins

Repair the damaged pinsRepair or replace the VECU(s), 3-pin connector, or multiplexed devices, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair or replace the VECU(s). Refer to OEM manual for repair procedure.
  • Repair the 3-pin connector. Refer to Procedure 019-203 in Section 19 in the ISC and QSC8.3 Engines, Electronic Control System, Bulletin 3666271.
  • Repair or replace the multiplexed devices. Refer to the ISC troubleshooting and repair manual.

Go to 3A

Go to 7A

Guided Step 3 - Inspect the engine harness.

Guided Step 3A - Check for open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the J1939 backbone connector from the engine harness.

Action

Check for an open circuit.

  • Measure resistance from supply pin 2 at the engine harness connector to pin A at the data link connector at the J1939 backbone.
  • Measure the resistance from pin 12 at the engine harness connector to pin B at the J1939 backbone.
  • Measure the resistance from pin 44 at the engine harness connector to pin C at the J1939 backbone.
OK NOT OK

Less than 10 ohms

Replace the engine harnessRefer to Procedure 019-043 in Section 19 in the ISC and QSC8.3 Engines, Electronic Control System, Bulletin 3666271.

Go to 3B

Go to 7A

Guided Step 3B - Check the resistance value in the J1939 harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the engine harness connector from the J1939 backbone harness.

Action

Check the resistance value of the J1939 harness.

  • Measure from pin A to pin B at the J1939 harness connector, OEM side.
OK NOT OK

55 to 65 ohms

J1939 backbone termination resistors missing or damaged. Replace the termination resistors.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit to power.

Conditions

  • Disconnect the J1939 backbone harness from the engine harness.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch to the ON position.

Action

Check for a short circuit to power.

  • Measure the voltage from pin 2 in the engine harness connector to engine block ground.
  • Measure the voltage from pin 12 at the engine harness connector to engine block ground.
OK NOT OK

Less than (+) 1.5 VDC

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19 in the ISC and QSC8.3 Engines, Electronic Control System, Bulletin 3666271.

Go to 3D

Go to 7A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the J1939 backbone harness from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 in the engine harness connector to ground.
  • Measure the resistance from pin 12 in the engine harness connector to ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19 in the ISC and QSC8.3 Engines, Electronic Control System, Bulletin 3666271.

Go to 3E

Go to 7A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the J1939 backbone harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 in the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 44 in the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 12 in the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19 in the ISC and QSC8.3 Engines, Electronic Control System, Bulletin 3666271

Go to 4A

Go to 7A

Guided Step 4 - Inspect the SAE J1939 backbone harness.

Guided Step 4A - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the J1939 backbone.
  • Disconnect the VECU(s) connector from the J1939 backbone.

Action

Check for an open circuit.

  • Measure resistance from pin A at the engine harness connector to pin A at the VECU(s) connector.
  • Measure resistance from pin B at the engine harness connector to pin B at the VECU(s) connector.
  • Measure resistance from pin C at the engine harness connector to pin C at the VECU(s) connector.
OK NOT OK

Less than 10 ohms

Replace the J1939 backbone. Refer to OEM service manual.

Go to 4B

Go to 7A

Guided Step 4B - Check for a short circuit to power.

Conditions

  • Disconnect the engine harness connector from the J1939 backbone.
  • Disconnect the VECU(s) connector from the J1939 backbone.
  • Turn keyswitch to the ON position.

Action

Check for a short circuit to power.

  • Measure the voltage from pin A of the J1939 backbone connector, engine harness side, to the engine block ground.
  • Measure the voltage from pin B of the J1939 backbone connector, engine harness side, to the engine block ground.
OK NOT OK

Less than (+) 1.5 VDC

Replace the J1939 backbone. Refer to the OEM service manual.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the J1939 backbone.
  • Disconnect the VECU(s) connector from the J1939 backbone.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the J1939 backbone connector, engine harness side, to the engine block ground.
  • Measure the resistance from pin B of the J1939 backbone connector, engine harness side, to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the J1939 backbone. Refer to the OEM service manual.

Go to 5A

Go to 7A

Guided Step 5 - Inspect the OEM wiring.

Guided Step 5A - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the VECU(s) connector from the J1939 backbone.
  • Disconnect the VECU(s) connector from the VECU(s).

Action

Check for an open circuit.

  • Measure resistance from pin A of the J1939 backbone connector to the corresponding pin in the VECU connector.
  • Measure resistance from pin B of the J1939 backbone connector to the corresponding pin in the VECU connector.
  • Measure resistance from pin C of the J1939 backbone connector to the corresponding pin in the VECU connector.
OK NOT OK

Less than 10 ohms

Repair or replace OEM wiring. Refer to OEM service manual.

Go to 5B

Go to 7A

Guided Step 5B - Check for a short circuit to power.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the VECU(s) connector from the J1939 backbone.
  • Disconnect the VECU(s) connector from the VECU(s).

Action

Check for a short circuit to power.

  • Measure voltage from pin A of the J1939 backbone connector, OEM side, to engine block ground.
  • Measure voltage from pin B of the J1939 backbone connector, OEM side, to engine block ground.
OK NOT OK

Less than (+) 1.5 VDC

Repair or replace OEM wiring. Refer to OEM manual for repair procedures.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the VECU(s) connector from the J1939 backbone.
  • Disconnect the VECU(s) connector from the VECU(s).

Action

Check for a short circuit to ground.

  • Measure resistance from pin A of the J1939 backbone connector, OEM side, to engine block ground.
  • Measure resistance from pin B of the J1939 backbone connector, OEM side, to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace OEM wiring. Refer to OEM service manual.

Go to 6A

Go to 7A

Guided Step 6 - Check for proper communication with the J1939 devices.

Guided Step 6A - Check communication with the VECU(s).

Conditions

  • Install the OEM service tool software.
  • Turn keyswitch to the ON position.

Action

Check communication with the VECU(s).

  • Using the OEM service tool software and/or INSITE™ electronic service tool to confirm communication between VECU(s) and multiplexing devices.
OK NOT OK

Proper communication between multiplexing devices and VECU(s)

Refer to OEM for additional repair procedures.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault code.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let it idle for one (1) minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 285 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Nov-2012


FAULT CODE 286 - J1939 Data Link Multiplexing

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the vehicle electronic control unit (VECUs) and engine control module (ECM) have matching settings. |
 | STEP 1A. Consult OEM information and/or use original equipment manufacturer (OEM) service tool to verify which input parameters are wired to VECU(s). | Physical input devices to VECU match VECU configuration
 | STEP 1B. Determine which parameters are set to be received over the J1939 datalink. Look at the menu: Adjustable Features and Parameters - J1939 Multiplexing. | INSITE™ readout matches ECM settings for devices (Devices in step 1B match step 1A)
STEP 2. | Change the settings. |
 | STEP 2A. ECM is set up to receive parameters that the VECU(s) is not transmitting. | ECM setting now matches VECU configuration
 | STEP 2B. The VECU(s) is not set up to transmit information from all of the multiplex devices. | VECU(s) parameters match all input devices that are wired to VECU(s)
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 286 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify that the VECU(s) and ECM have matching settings.

Guided Step 1A - Consult OEM information and/or use OEM service tool to verify which input parameters are wired to VECU(s).

Conditions

  • Turn keyswitch to the ON position.
  • Connect to the vehicle VECU with OEM service tool.

Action

Check that the vehicle inputs are multiplexed.

  • Determine which input devices (throttle, cruise switches, clutch switch, etc.) are wired to the vehicle's VECU(s).
  • Using OEM service tool to verify the VECU is configured properly.
OK NOT OK

Physical input devices to VECU match VECU configuration

Change multiplex settings.

Go to 1B

Go to 2B

Guided Step 1B - Determine which parameters are set to be received over the J1939 data link. Look at the menu: Adjustments - Features and Parameters 2.

Conditions

  • Connect the INLINE 2™ data link adapter to the engine and PC.
  • Connect INSITE™.
  • Turn keyswitch to the ON position and start the INSITE™ job.

Action

ECM settings match devices installed on vehicle.

  • Use INSITE™ electronic service tool toread the ECM settings for devices.
  • Information for settings in menu: Adjustments - Features and Parameters 2.
OK NOT OK

Use INSITE™ electronic service tool to readout matches ECM settings for devices (Devices in step 1B match step 1A)

The INSITE™ electronic service tool configuration does not match the VECU configuration.

Go to 3A

Go to 2A

Guided Step 2 - Change the settings.

Guided Step 2A - ECM is set up to receive parameters that the VECU(s) is not transmitting.

Conditions

  • Start INSITE™electronic service tool and connect to ECM.

Action

Change ECM setting to match VECU configuration.

  • If the ECM is set up to receive any of the parameters that the VECU(s) is not transmitting over the data link, turn off multiplexing for those parameters in the ECM with INSITE™electronic service tool.
OK NOT OK

ECM setting now matches VECU configuration

Check OEM multiplex settings.

Go to 3A

Go to 1A

Guided Step 2B - The VECU(s) is not set up to transmit all of the information from all of the multiplex devices.

Conditions

  • Install OEM service tool.
  • Turn keyswitch to the ON position.

Action

Change the setting of the VECU(s) to transmit all information.

  • VECU(s) is not set up to transmit information from all of the devices connected to it. Change the setting in the VECU(s). Refer to OEM service manual.
OK NOT OK

VECU(s) parameters match all input devices that are wired to VECU(s)

Check OEM multiplex settings.

Go to 3A

Go to 1A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let it idle for one (1) minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 286 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Nov-2012


FAULT CODE 296 - OEM Pressure - Engine Protection

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Refer to original equipment manufacturer (OEM) manual for specification
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 296 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn the keyswitch to the ON position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical pressure gauge to the engine.
  • Connect INSITE™ to the vehicle data link.
  • Start the engine, and compare the pressure sensor reading on INSITE™ electronic service tool monitor screen to the reading on the mechanical pressure gauge.

Increase the engine rpm to make it easier to see differences in readings.
OK NOT OK

Refer to OEM service manual for specification. Locate and repair the cause of high pressure.

See Shop Talk in the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245 for correct procedures.

Replace sensor. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 48 of the OEM harness connector to the corresponding pin of the OEM switch connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 48 of the OEM harness connector, OEM side, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 48 of the OEM harness connector, OEM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 296 inactive

Return to the troubleshooting steps or contact al Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jun-2015


FAULT CODE 297 - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Wait until the fluid temperature is below 50°C [120°F] before working on the OEM system. Failure to do so can cause personal injury from heated liquid spray.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the original equipment manufacturer (OEM) pressure sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | No damaged pins
 | STEP 1B. Check the voltage of the OEM pressure sensor. | Refer to the OEM service manual; Typical good voltages range from (+) 0.5 to 4.5 VDC
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 297 active
 | STEP 2C. Check for an open circuit in the signal wire. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from the signal wire to all other pins. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check for appropriate ECM response. | Fault Code 297 inactive; Fault Code 298 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 297 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM pressure sensor.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or the OEM pressure sensor.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Repair or replace the OEM pressure sensor. Refer to the OEM service manual.
  • Dry the connector using electrical contact cleaner, Part Number 3824510.
  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner.

Go to 1B

Go to 4A

Guided Step 1B - Check the voltage of the OEM pressure sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the voltage of the OEM pressure sensor.

Check the voltage of the OEM pressure sensor.
OK NOT OK

Refer to the OEM service manual. Typical good voltages range from (+) 0.5 to 4.5 VDC.

Replace the OEM pressure sensor or repair OEM pressure sensor voltage source/wiring. Refer to the OEM service manual for procedure.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Dry the connector using electrical contact cleaner, Part Number 3824510.
  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit in the signal wire.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit in the signal wire.

  • Measure the resistance from pin 48 of the OEM harness connector to the appropriate pin of the OEM pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from the signal wire to all other pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from the signal wire to all other pins.

  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check for appropriate ECM response.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Check for appropriate ECM response.

  • Turn the keyswitch to the ON position.
  • Use INSITE™ electronic service tool to read the fault codes
OK NOT OK

Fault Code 297 inactive; Fault Code 298 active

Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 297 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Jun-2015


FAULT CODE 298 - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Wait until the fluid temperature is below 50°C [120°F] before working on the OEM system. Failure to do so can cause personal injury from heated liquid spray.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the original equipment manufacturer (OEM) pressure sensor. |
 | STEP 1A. Inspect the OEM harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the OEM pressure sensor. | Refer to the OEM manual; Typical good voltages range from (+) 0.5 to 4.5 VDC.
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 298 active
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from the signal pin to all other pins. | More than 100k ohms
 | STEP 2E. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 3. | Check the engine control module (ECM). |
 | STEP 3A. Check for appropriate ECM response. | Fault Code 298 inactive; Fault Code 297 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 298 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM pressure sensor.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or the OEM pressure sensor.

  • Repair the OEM harness. Refer to the OEM service manual for procedure.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Repair or replace the OEM pressure sensor. Refer to the OEM service manual for procedure.
  • Dry the connector using electrical contact cleaner, Part Number 3824510.
  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the OEM pressure sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the resistance of the OEM pressure sensor.

Check the resistance of the OEM pressure sensor.
OK NOT OK

Refer to the OEM service manual. Typical good voltages range from (+) 0.5 to 4.5 VDC.

Replace the OEM pressure sensor, or repair OEM pressure sensor voltage source/wiring. Refer to the OEM servicer manual for procedure.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and OEM harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Dry the connector using electrical contact cleaner, Part Number 3824510.
  • Flush the dirt, debris, or moisture from the connector pins with electronic contact cleaner, Part Number 3824510.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 48 of the OEM harness connector to the appropriate pin of the OEM pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from the signal pin to all other pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for a short circuit from the signal pin to all other pins.

  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the signal wire.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for a short circuit to ground in the signal wire.

  • Measure the resistance from pin 48 of the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check for appropriate ECM response.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check for appropriate ECM response.

  • Disconnect the OEM interface harness from the ECM.
  • Turn the keyswitch to the ON position.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 inactive; Fault Code 297 active

Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 298 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 319 - Real Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISC, QSC8.3, ISL, QSL9CM554 (CAPS) | 3666271
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 F103 | 4310839
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL8.9 CM2150 SN | 4022190
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 F101 | 4310846
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB/ISD4.5 CM2150 B119 | 4358465
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB/ISD6.7 CM2150 B120 | 4358470
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL8.9 CM2150 L110 | 4358475
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 F110 | 4358480
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL9 CM2350 L111 | 4367223
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2350 F109 | 4367218
Real-Time Clock Battery | Refer to Procedure 019-311 | ISC, QSC8.3, ISL, QSL9CM554 (CAPS) | 3666271

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery and connections. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the real-time clock battery voltage at the ECM harness connector. | Between 3.3 and 3.6 VDC?
 | STEP 1B-1. Inspect the real-time clock battery and engine wire harness connector pins. |
 | STEP 1B-2. Check the real-time clock battery voltage at the battery module connector. |
STEP 2. | Check the battery module harness. |
 | STEP 2A. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the real-time clock battery and connections.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab..

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the real-time clock battery voltage at the ECM harness connector.

Conditions

  • Equip engine with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 3.3 and 3.6 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the real-time clock battery and engine wire harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the real-time clock battery or engine harness.

  • Repair or replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1B-2

Guided Step 1B-2 - Check the real-time clock battery voltage at the battery module connector.

Conditions

  • Equip engine with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 3.3 and 3.6 VDC?
YES NO
No Repair

Replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Check for an open circuit in the engine harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jun-2015


FAULT CODE 328 - Rear Pumping Element

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Read fault codes. | Fault Code 275 is inactive
STEP 2. | Verify pumping valve solenoid performance. |
 | STEP 2A. Check pumping valve solenoid performance. | Solenoid clicks when activated
 | STEP 2A-1. Check fault codes. |
 | STEP 2A-2. Attempt to start the engine. |
 | STEP 2B. Verify pumping element performance. | Pumping elements perform equally
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 328 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Verify that Fault Code 275 is not present.
OK NOT OK

Fault Code 275 is inactive

Fault Code 275 is present

If present, verify that the fuel filter is not plugged. Refer to Procedure 006-020 in Section 6 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418.

Go to 2A

Go to 3A

Guided Step 2 - Verify pumping valve solenoid performance.

Guided Step 2A - Check pumping valve circuit performance.

Conditions

  • Turn keyswitch to the ON position.

Action

Verify pumping valve solenoid circuit performance.

  • Use INSITE™ electronic service tool to run the solenoid click test on the rear pumping valve solenoid. 005-079 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418. Listen for an audible click when activating the test to verify that the solenoid is operating.
OK NOT OK

Solenoid clicks when activated

Solenoid does not click when activated or clicks erratically.

Go to 2A-2

Go to 2A-1

Guided Step 2A-1 - Check fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 273 inactive or not present.

Fault Code 273 active

Go to 2A-2

Refer to Fault Code 273

Guided Step 2A-2 - Attempt to start the engine.

Conditions

  • Turn keyswitch to the ON position with the engine operating.

Action

Attempt to start the engine.
OK NOT OK

Engine starts

Engine does not start.

Replace the fuel pump accumulator module. Refer to Procedure 005-085 in Section 5 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418.

Go to 2B

Go to 3A

Guided Step 2B - Verify pumping element performance.

Conditions

  • Turn keyswitch to the ON position with the engine operating.

Action

Verify pumping element performance.

  • Use INSITE™ electronic service tool to run the pumping plunger cutout test on each pumping plunger. Refer to Procedure 005-079 in Section 5 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418. Observe vehicle certification agency (VCA), accumulator pressure, accumulator pressure set point, and engine speed for each pumping plunger as the other is cut out.
OK NOT OK

Pumping elements perform equally

Replace the fuel pump accumulator module

Refer to Procedure 005-085 in Section 19 in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 328 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Nov-2012


FAULT CODE 329 - Fuel Injection Pump

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes
STEP 2. | Check the fuel filter. |
 | STEP 2A. Check for a plugged fuel filter. | Fuel filter not plugged
STEP 3. | Check for air in the fuel. |
 | STEP 3A. Verify there is no air in fuel. | No air detected
STEP 4. | Check inlet restriction. |
 | STEP 4A. Measure fuel inlet restriction. | Less than 254 mm-Hg [10 in-Hg] of restriction
STEP 5. | Check fuel pump gear pump pressure. |
 | STEP 5A. Check gear pump pressure. | Pressure meets minimum specifications: rpm 200: 12 kPa [2 psi] rpm 700; 138 kPa [20 psi] rpm 1300; 379 kPa [55 psi]; rpm 2200: 827 kPa [120 psi]
STEP 6. | Perform pumping control valve click test. |
 | STEP 6A. Perform click test. | Pumping control valve clicks
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault codes. | Fault Code 329 inactive
 | STEP 7B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other fault codes

Troubleshoot active or inactive fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the fuel filter.

Guided Step 2A - Check for a plugged fuel filter.

Conditions

  • Turn keyswitch OFF.

Action

Check for a plugged fuel filter.
OK NOT OK

Fuel filter not plugged

Replace fuel filter. Refer to Procedure 006-015 in Section 6 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 3A

Go to 7A

Guided Step 3 - Check for air in the fuel.

Guided Step 3A - Verify there is no air in fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in Section 6 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.
OK NOT OK

No air detected

Air detected.

Correct source of air leak. Refer to Procedure 006-003 in Section 6 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 4A

Go to 7A

Guided Step 4 - Check inlet restriction.

Guided Step 4A - Measure fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check inlet restriction.

  • Start the engine and idle low.
  • Run the engine to high idle.
  • Refer to Procedure 006-020 in Section 6 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.
OK NOT OK

Less than 254 mm-Hg [10 in-Hg] of restriction

More than 254 mm-Hg [10 in-Hg] restriction detected.

Correct source of inlet restriction. Refer to Procedure 006-020 in Section 6 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 5A

Go to 7A

Guided Step 5 - Check fuel pump gear pump pressure.

Guided Step 5A - Check gear pump pressure.

Conditions

  • Turn keyswitch ON.

Action

Check fuel pump gear pump pressure.

Refer to Procedure 005-089 in Section 5 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.
OK NOT OK

Pressure meets minimum specifications:

Rpm 200: 12 kPa [2 psi]

Rpm 700: 138 kPa [20 psi]

Rpm 1300: 379 kPa [55 psi]

Rpm 2200: 827 kPa [120 psi]

Low pressure.

Replace the fuel pump gear pump module. Refer to Procedure 005-089 in Section 5 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 6A

Go to 7A

Guided Step 6 - Perform pumping control valve click test.

Guided Step 6A - Perform test.

Conditions

  • Turn keyswitch ON.

Action

Perform pumping control valve click test.

Refer to Procedure 005-079 in Section 5 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.
OK NOT OK

Pumping control valve clicks

Replace the injection control valve module. Refer to Procedure 005-078 in Section 5 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Replace the fuel pump accumulator module.

Refer to Procedure 005-085 in Section 5 in the ISC, ISCe, QSC8.3, ISL, ISLe3 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 7A

Go to 7A

Guided Step 7 - Clear fault codes.

Guided Step 7A - Disable fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 329 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Nov-2012


FAULT CODE 349 - Auxiliary Speed or Auxiliary Pressure Input Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Read fault codes. | No other fault codes active
STEP 2. | Check the auxiliary device for proper function. |
 | STEP 2A. Refer to the original equipment manufacturer (OEM) service manual for auxiliary device overspeed. | Auxiliary device functioning properly
STEP 3. | Check the auxiliary speed sensor. |
 | STEP 3A. Inspect the OEM harness and the sensor connectors. | No damaged pins
 | STEP 3B. Check the auxiliary speed sensor for proper adjustment (if adjustable). | 1/2 to 3/4 turn out from gear for threaded type of sensor
 | STEP 3C. Check for the correct sensor resistance. | 750 to 1500 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit between coils (if two coils exist). | More than 100k ohms
STEP 4. | Check the auxiliary pressure sensor. |
 | STEP 4A. Inspect pins. | No bent pins
 | STEP 4B. Measure voltage to the ECM. | (+) 0.5 to 4.5 VDC
STEP 5. | Check the OEM harness. |
 | STEP 5A. Inspect the OEM harness and the ECM connectors. | No damaged pins
 | STEP 5B. Check for an open circuit. | Less than 10 ohms
 | STEP 5C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault code 349 inactive
 | STEP 6B. Clear any inactive fault codes. | All faults cleared

Guided Step 1 - Check for fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other fault codes active

Troubleshoot other fault codes first.

Go to 2A

Appropriate fault tree

Guided Step 2 - Check the auxiliary device for proper function.

Guided Step 2A - Refer to the OEM service manual for auxiliary device overspeed.

Action

Refer to the OEM troubleshooting and repair manual.

  • Refer to the OEM service manual for proper function of the auxiliary device.
  • Check for slipping clutches or broken driveline components.
  • Measure OEM pressure to verify proper OEM equipment function.
OK NOT OK

Auxiliary device functioning properly

Repair the auxiliary device. Refer to the OEM service manual.

3A for auxiliary speed applications; 4A for auxiliary pressure applications

Go to 6A

Guided Step 3 - Check the auxiliary speed sensor.

Guided Step 3A - Inspect the OEM harness and the sensor connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Inspect the OEM harness and the sensor connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.
  • Replace the auxiliary speed sensor. Refer to the OEM service manual.

Go to 3B

Go to 6A

Guided Step 3B - Check the auxiliary speed sensor for the proper adjustment (if adjustable).

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Check the auxiliary speed sensor for the proper adjustment (if adjustable).

Check the auxilairy speed sensor for the proper adjustment (if adjustable).
OK NOT OK

1/2 to 3/4 of a turn out from the gear

Adjust the auxiliary speed sensor. Refer to the OEM service manual.

Go to 3C

Go to 6A

Guided Step 3C - Check for the correct sensor resistance.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Check the auxiliary speed sensor for the correct resistance.

  • Measure the resistance from pin A to pin B for each auxiliary speed sensor connector on the sensor side.
OK NOT OK

750 to 1500 ohms

Replace the auxiliary speed sensor. Refer to the OEM service manual.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Check the auxiliary speed sensor for a short circuit to ground.

  • Measure the resistance from pin A on the sensor side of the auxiliary speed sensor connector to engine block ground.
  • Measure the resistance from pin B on the sensor side of the auxiliary speed sensor connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the auxiliary speed sensor. Refer to the OEM service manual.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit between coils (if two coils exist).

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Check the auxiliary speed sensor for a short circuit between coils.

  • Measure the resistance from pin A on the sensor side of one of the auxiliary speed sensor connectors to pin A of the other connector.
OK NOT OK

More than 100k ohms

Replace the auxiliary speed sensor. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 4 - Check the auxiliary pressure sensor.

Guided Step 4A - Inspect pins.

Action

Inspect sensor and OEM harness connector pins.

Inspect sensor and OEM harness connector pins.
OK NOT OK

No bent pins

Go to 4B

Go to 6A

Guided Step 4B - Measure voltage to ECM.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM connector from the ECM.

Action

Measure voltage.

  • Measure pin 48 to engine block ground.
OK NOT OK

(+) 0.5 to 4.5 VDC

Replace pressure sensor. Refer to OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Inspect the OEM harness and the ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair damaged pins. Repair or replace the OEM harness or OEM Interface harness, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.
  • Dry the connector by using an electrical contact cleaner, Part Number 3824510.
  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner.

Go to 5B

Go to 6A

Guided Step 5B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the auxiliary speed or pressure input signal sending unit.

Action

Check for an open circuit.

  • Measure the resistance from pin 8 of the OEM harness to pin A of the OEM harness, auxiliary speed sensor.
  • Measure the resistance from pin 18 of the OEM harness to pin B of the OEM harness, auxiliary speed sensor.
  • Measure the resistance from pin 48 of the OEM harness to pin X of the OEM harness, auxiliary speed sensor.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the auxiliary speed or pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 18 of the OEM harness to engine block ground.
  • Measure the resistance from pin 8 of the OEM harness to engine block ground.
  • Measure the resistance from pin 48 of the OEM harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.

Go to 5D

Go to 6A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the auxiliary speed or pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 18 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 8 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start engine, and let idle for 1 minute.
OK NOT OK

Fault Code 349 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear any inactive fault codes.

Conditions

  • Connect all components.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 352 or 386 - Sensor Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensors. |
 | STEP 1A. Read the fault codes. | Fault Code 386 still active
 | STEP 1B. Check the engine position sensor. | Fault Code 352 still active
 | STEP 1C. Check the intake manifold pressure sensor. | Fault Code 352 still active
 | STEP 1D. Check the oil pressure sensor. | FC 352 still active
 | STEP 1E. Check the ambient air pressure sensor. | Fault Code 352 still active
 | STEP 1F. Check the fuel pressure sensor. | Fault Code 352 still active
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and engine control module (ECM) connectors. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin-to-pin. | More than 100k ohms
 | STEP 2D. Check sensor supply voltage. | (+) 4.75 to 5.25 VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Codes 352 and 386 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the sensors.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 386 still active

Fault Code 352 still active

Go to 2A

Go to 1B

Guided Step 1B - Check the engine position sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool .
  • Disconnect the engine position sensor from the engine harness.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 352 still active

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 352 still active

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check the oil pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 352 still active

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check the ambient air pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool .
  • Disconnect the ambient air pressure sensor from the engine sensor.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 352 still active

Replace the ambient air pressure sensor. Use the following procedure in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 1F

Go to 3A

Guided Step 1F - Check the fuel pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 352 still active

Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the fuel temperature sensor from the engine harness.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the fuel temperature sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 10 of the engine harness connector to all the other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check sensor supply voltage.

Conditions

  • Connect the engine harness to the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for sensor +5 VDC supply voltage.

  • Measure the voltage from pin A on the harness side of the engine speed sensor to engine block ground.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 352 and 386 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Dec-2014


FAULT CODE 381 or 382 - Intake Air Heater Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check original equipment manufacturer (OEM) harness. |
 | STEP 1A. Inspect the OEM harness, intake air heater relay, and engine control module (ECM) connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the relay and relay ground. | Refer to OEM troubleshooting and repair manual
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Codes 381 and 382 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check OEM harness.

Guided Step 1A - Inspect the OEM harness, intake air heater relay, and ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intake air heater relay.

Action

Inspect the OEM harness, intake air heater relay, and ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair damaged pins. Repair or replace the OEM harness, ECM, or intake air heater relay, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19, and Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the intake air heater relay. Refer to the OEM service manual.

Go to 1B

Go to 2A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the intake air heater relay connector.

Action

Check for an open circuit in the relay enable circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness connector to the harness side of the heater relay connector.

Refer to the following to determine the correct pins to check for each fault: FC 381: OEM harness connector pin 41 to heater relay 1 (pin A). FC 382: OEM harness connector pin 31 to heater relay 2 (pin C).

OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 1C

Go to 2A

Guided Step 1C - Check for an open circuit in the relay and relay ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the intake air heater relay connector.

Action

Check for an open circuit in the relay and relay ground.

  • Measure the resistance of the relay and its ground on the pull-in coil side of the relay.
OK NOT OK

Refer to OEM service manual

Replace relay or ground circuit. Refer to OEM service manual.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the intake air heater relay connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the intake air heater relay circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness connector to engine block ground.

Refer to the following to determine the correct pins to check for each fault: FC 381: OEM harness connector pin 41. FC 382: OEM harness connector pin 31.

OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 1E

Go to 2A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the intake air heater relay connector from the OEM harness.

Action

Check for a short circuit from pin to pin in the intake air heater relay circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness to all other pins in the OEM harness connector.

Refer to the following to determine the correct pins to check for each fault: FC 381: OEM harness connector pin 41. FC 382: OEM harness connector pin 31.

OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Check for a short circuit from pin to pin in the intake air heater relay circuit.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 381 and 382 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 381 or 382 - Intake Air Heater Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check original equipment manufacturer (OEM) harness. |
 | STEP 1A. Inspect the OEM harness, intake air heater relay, and engine control module (ECM) connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the relay and relay ground. | Refer to OEM troubleshooting and repair manual
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Codes 381 and 382 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check OEM harness.

Guided Step 1A - Inspect the OEM harness, intake air heater relay, and ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intake air heater relay.

Action

Inspect the OEM harness, intake air heater relay, and ECM connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair damaged pins. Repair or replace the OEM harness, ECM, or intake air heater relay, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the intake air heater relay. Refer to the OEM service manual.

Go to 1B

Go to 2A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the intake air heater relay connector.

Action

Check for an open circuit in the relay enable circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness connector to the harness side of the heater relay connector.

Refer to the following to determine the correct pins to check for each fault: FC 381: OEM harness connector pin 41 to heater relay 1 (pin A). FC 382: OEM harness connector pin 31 to heater relay 2 (pin C).

OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 1C

Go to 2A

Guided Step 1C - Check for an open circuit in the relay and relay ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the intake air heater relay connector.

Action

Check for an open circuit in the relay and relay ground.

  • Measure the resistance of the relay and its ground on the pull-in coil side of the relay.
OK NOT OK

Refer to OEM troubleshooting and repair manual

Replace relay or ground circuit. Refer to OEM service manual.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the intake air heater relay connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the intake air heater relay circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness connector to engine block ground.

Refer to the following to determine the correct pins to check for each fault: FC 381: OEM harness connector pin 41. FC 382: OEM harness connector pin 31.

OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 1E

Go to 2A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the intake air heater relay connector from the OEM harness.

Action

Check for a short circuit from pin to pin in the intake air heater relay circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness to all other pins in the OEM harness connector.

Refer to the following to determine the correct pins to check for each fault: FC 381: OEM harness connector pin 41. FC 382: OEM harness connector pin 31.

OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Check for a short circuit from pin to pin in the intake air heater relay circuit.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 381 and 382 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


FAULT CODE 385 or 444 - Remote Accelerator Control Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822917 - female AMP™/Metri-Pack™/Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and sensor connectors. | No damaged pins
 | STEP 1B. Check for active fault codes. | Fault Code 385, 441, or 444 remains active
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness and engine control module (ECM) connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for a short circuit to a voltage source. | Less than (+) 1.0 VDC
STEP 3. | Check the ECM voltage. |
 | STEP 3A. Measure the sensor supply voltage from the ECM. | (+) 4.75 to 5.25 VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 385 or 444 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the remote accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and sensor connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Inspect the OEM harness and the sensor connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Replace the damaged pins.

Repair or replace the OEM harness or the remote accelerator position sensor, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19
  • Refer to Procedure 019-205 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Repair or replace the remote accelerator position sensor. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Use INSITE™ electronic service tool to read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 385, 441, or 444 remains active

Replace the accelerator pedal assembly or the accelerator position sensor.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the OEM harness connector to pin C on the harness side of the remote accelerator position sensor connector.
  • Measure the resistance from pin 20 of the OEM harness connector to pin A on the harness side of the remote accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to a chassis ground.

  • Measure the resistance from pin 10 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 20 in the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure the resistance from pin 10 to all other pins in the OEM harness.
  • Measure the resistance from pin 20 to all other pins in the OEM harness.
OK NOT OK

More than 100k ohms

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.
  • Connect the OEM harness to the remote accelerator position sensor.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage from pin 10 in the OEM harness connector to engine block ground.
  • Measure the voltage from pin 20 in the OEM harness connector to engine block ground.
OK NOT OK

Less than (+) 1.0 VDC

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM voltage.

Guided Step 3A - Measure the sensor supply voltage from the ECM.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin 10 to pin 20 on the ECM OEM connector.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM.

Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault codes.

  • Start the engine, and let idle for 1 minute.
  • Depress and release the accelerator pedal several times to be sure the ECM is getting an accelerator signal.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 385 or 444 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2015


FAULT CODE 387 or 443 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead, Part Number 3822917 - female AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect original equipment manufacturer (OEM) harness and sensor connectors. | No damaged pins
 | STEP 1B. Check for active fault code. | Fault Code 387 or 443 remains active
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and engine control module (ECM) connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for a short circuit to a voltage source. | Less than (+) 1.0 VDC
STEP 3. | Check the ECM voltage. |
 | STEP 3A. Measure the sensor supply voltage from the ECM. | (+) 4.75 to 5.25 VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 387 or 443 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and sensor connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the sensor connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Replace the damaged pins.

Repair or replace the OEM harness or the accelerator position sensor, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Repair or replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Use INSITE™ electronic service tool to read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 387 or 443 remains active

Replace the accelerator pedal assembly or the accelerator position sensor.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 29 of the OEM harness connector to pin C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 19 of the OEM harness connector to pin A on the harness side of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to a chassis ground.

  • Measure the resistance from pin 29 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 19 in the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms.

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 29 to all other pins in the OEM harness connector.
  • Measure the resistance from pin 19 to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.
  • Connect the OEM harness to the accelerator position sensor.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage from pin 29 in the OEM harness connector to engine block ground.
  • Measure the voltage from pin 19 in the OEM harness connector to engine block ground.
OK NOT OK

Less than (+) 1.0 VDC

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM voltage.

Guided Step 3A - Measure the sensor supply voltage from the ECM.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin 29 to pin 19 on the ECM OEM connector port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM.

Refer to Procedure 019-031 in Section 19 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Depress and release the accelerator pedal several times to be sure the ECM is getting an accelerator signal.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 387 and 443 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair completed

Appropriate troubleshooting charts

Last Modified: 03-Jun-2015


FAULT CODE 415 (SN) - Oil Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 415 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch to the ON position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ to the vehicle data link.
  • Start the engine, and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge.

NOTE: The engine must be revved up to make it easier to see differences in readings.

OK NOT OK

Sensor reading correct within 5 psi.

Locate and repair the cause of low oil pressure.

Refer to Procedure 007-052 in Section 7 in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193.

Sensor reading incorrect

Go to 2A

Refer to Fault code 135 or 141

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 415 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Nov-2012


FAULT CODE 415 (SW) - Oil Pressure - Engine Protection With An Oil Pressure Switch

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the switch accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 415 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the switch accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch to the ON position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ to the vehicle data link.
  • Start the engine. The switch will display 379.9 kPa [55.1 psi] in INSITE™ if it detects actual oil pressure above 41 kPa [6 psi].
OK NOT OK

The switch is detecting oil pressure

Locate and repair the cause of low oil pressure.

Refer to Procedure 007-052 in Section 7 in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193.

The switch is not detecting oil pressure

Go to 2A

Refer to Fault code 135 or 141

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 415 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Nov-2012


FAULT CODE 418 - Water-In-Fuel (WIF) Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel filter. |
 | STEP 1A. Drain the water from the fuel filter. | Fault Code 418 is inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 418 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the fuel filter.

Guided Step 1A - Drain the water from the fuel filter.

Conditions

  • Turn the keyswitch to the ON position.

Action

Drain the water from the fuel filter.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 418 is inactive

Drain water from the fuel filter.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 418 inactive

Return to troubleshooting steps, or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn the keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Nov-2012


FAULT CODE 422 - Coolant Level Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
WARNING

Wait until the coolant temperature is below 50° C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3822917 - female AMP™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female AMP test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes and presence of a coolant level switch. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 154, and 352 are not active
 | STEP 1B. Check if the vehicle has a coolant level switch. | Coolant level switch present
 | STEP 1B-1. Check if a shorting plug is installed. |
STEP 2. | Check the coolant level sensor jumper harness. |
 | STEP 2A. Inspect the coolant level sensor and the coolant level sensor jumper harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit pin to pin. | More than 100k ohms
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 422 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes and presence of coolant level switch.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 145, 154, and 352 are not active

Fault codes are active

Go to 1B

Go to Fault Code 352 or 386

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
Guided Step 1B - Check if the vehicle has a coolant level switch.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check if the vehicle has a coolant level switch.

Check if the vehicle has a coolant level switch.
OK NOT OK

Coolant level switch present

No coolant level switch present

Go to 2A

Go to 1B-1

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
Guided Step 1B-1 - Check if a shorting plug is installed.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check if a shorting plug is installed in place of the coolant level switch harness connection.

Check if a shorting plug is installed in place of th coolant level switch harness connection.
OK NOT OK

Shorting plug installed

Install the shorting plug

Go to 2A

Go to 4A

Guided Step 2 - Check the coolant level sensor jumper harness.

Guided Step 2A - Inspect the coolant level sensor and the coolant level sensor jumper harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the coolant level sensor jumper harness from the coolant level sensor.

Action

Inspect the coolant level sensor and the coolant level sensor jumper harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the coolant level sensor jumper harness or the coolant level sensor, whichever has the damaged pins.

  • Repair the coolant level sensor jumper harness. Refer to Procedure 019-201 or Refer to Procedure 019-205 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the coolant level sensor jumper harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the coolant level sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

WARNING

Wait until the coolant temperature is below 50° C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant level sensor jumper harness.
  • Disconnect the coolant level sensor jumper harness from the coolant level sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin A on the coolant level sensor jumper harness connectors.
  • Measure the resistance from pin B to pin B on the coolant level sensor jumper harness connectors.
  • Measure the resistance from pin C to pin C on the coolant level sensor jumper harness connectors.
  • Measure the resistance from pin D to pin D on the coolant level sensor jumper harness connectors.
OK NOT OK

Less than 10 ohms

Repair or replace the coolant level sensor jumper harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant level sensor jumper harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A on the coolant level sensor jumper harness connector to engine block ground.
  • Measure the resistance from pin B on the coolant level sensor jumper harness connector to engine block ground.
  • Measure the resistance from pin C on the coolant level sensor jumper harness connector to engine block ground.
  • Measure the resistance from pin D on the coolant level sensor jumper harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant level sensor jumper harness. Refer to the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant level sensor jumper harness.
  • Disconnect the coolant level sensor jumper harness from the coolant level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A on the coolant level sensor jumper harness conductor to all other pins in the connector.
  • Measure the resistance from pin B on the coolant level sensor jumper harness conductor to all other pins in the connector.
  • Measure the resistance from pin C on the coolant level sensor jumper harness conductor to all other pins in the connector.
  • Measure the resistance from pin D on the coolant level sensor jumper harness conductor to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the coolant level sensor jumper harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3B

Go to 4A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female AMP test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant level sensor jumper harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 37 in the engine harness connector to pin A on the engine harness side of the coolant level sensor jumper harness connector.
  • Measure the resistance from pin 19 in the engine harness connector to pin B on the engine harness side of the coolant level sensor jumper harness connector.
  • Measure the resistance from pin 49 in the engine harness connector to pin C on the engine harness side of the coolant level sensor jumper harness connector.
  • Measure the resistance from pin 27 in the engine harness connector to pin D on the engine harness side of the coolant level sensor jumper harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3C

Go to 4A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant level sensor jumper harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground in the coolant level sensor signal wires.

  • Measure the resistance from pin 49 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 27 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 37 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3D

Go to 4A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant level sensor jumper harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 27 in the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 37 in the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Using INSITE™, verify Fault Code 422 is inactive.
OK NOT OK

Fault Code 422 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2013


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor supply fault code. |
 | STEP 1A. Read fault codes. | Fault Code 441 not active
STEP 2. | Check OEM harness. |
 | STEP 2A. Inspect the OEM harness, WIF sensor, and ECM connectors. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check sensor supply voltage. | (+) 4.75 to 5.25 VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 429 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for sensor supply fault code.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.
  • Connect all components.

Action

temp

  • Read fault codes using INSITE™.
OK NOT OK

Fault Code 441 not active

Fault Code 441 active

Go to 2A

Fault Code 441

Guided Step 2 - Check OEM harness.

Guided Step 2A - Inspect the OEM harness, WIF sensor, and ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the WIF sensor.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness, WIF sensor, and ECM connectors for:

  • Bent of broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the ECM, WIF sensor, or OEM harness, whichever has the damaged pins.

  • Repair OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205 and Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the WIF sensor. Refer to Procedure 006-015 in the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.
  • Repair or replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the WIF sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 40 of the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the WIF sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 40 to all other pins on the harness side of the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check sensor supply voltage.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the WIF sensor.
  • Connect the OEM harness to the ECM.

Action

Check sensor supply voltage.

  • Measure the voltage from pin B on the harness side of the WIF sensor connector to engine block ground.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace WIF sensor. Refer to Procedure 006-015 in the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.

Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify that the Fault Code 429 is inactive.
OK NOT OK

Fault Code 429 inactive

Return to troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3822917 - female AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the IVS is connected to the OEM harness. | IVS connected
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 or 551 active
 | STEP 1C. Inspect the OEM harness and the IVS connector. | No damaged pins
 | STEP 1D. Check for an open circuit. | Less than 10 ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connectors. | No damaged pins
 | STEP 2B. Check the ECM supply. | (+) 4.75 to 5.25 VDC
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 or 551 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the accelerator pedal.

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
Guided Step 1A - Verify the IVS is connected to the OEM harness.

Conditions

  • Turn keyswitch to the OFF position.

Action

Verify the IVS is connected to the OEM harness.

Verify the IVS is connected to the OEM harness.
OK NOT OK

IVS connected

Connect the IVS. Connect the OEM harness to the IVS. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch to the ON position.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 or 551 active

Pedal was not calibrated. Fault Code 431 or 551 is inactive.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the OEM harness and the IVS connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the IVS.

Action

Inspect the OEM harness and the IVS connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the IVS or OEM harness, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Repair or replace the IVS. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the IVS.

Action

Check for an open circuit in the IVS.

  • Measure the resistance from pin B to pin A on the switch side of the IVS connector with the accelerator pedal released.
  • Measure the resistance from pin C to pin A on the switch side of the IVS connector with the accelerator pedal depressed.
OK NOT OK

Less than 10 ohms

Replace the IVS. Refer to the OEM troubleshooting and repair manual.

Go to 1E

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the IVS.

Action

Check for a short circuit from pin to pin in the IVS.

  • Measure the resistance from pin B to pin C on the switch side of the IVS connector with the accelerator pedal released and depressed.
OK NOT OK

More than 100k ohms

Replace the IVS. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the IVS.

Action

Inspect the OEM harness and ECM connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female AMP/Metri-Pack test lead.
Guided Step 2B - Check the ECM supply.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.

Action

Check the ECM supply.

  • Measure the voltage from pin 25 on the ECM side of the OEM harness connector to engine block ground.
  • Measure the voltage from pin 26 on the ECM side of the OEM harness connector to engine block ground.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the IVS.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pins 25 and 26 of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the IVS.

Action

Check for an open circuit.

  • Measure the resistance from pin 26 on the harness side of the OEM harness connector to pin B on the harness side of the IVS connector.
  • Measure the resistance from pin 25 on the harness side of the OEM harness connector to pin C on the harness side of the IVS connector.
  • Measure the resistance from pin A on the harness side of the IVS connector to engine block ground.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2E

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness to the IVS.

Action

Check for a short circuit from pin to ground.

  • Measure the resistance from pin 25 on the harness side of the OEM connector to engine block ground.
  • Measure the resistance from pin 26 on the harness side of the OEM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and completely depress and release the accelerator pedal four to five times.
  • Turn the keyswitch to the OFF position for 5 seconds.
  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify that Fault Code 431 or 551 is inactive.
OK NOT OK

Fault Code 431 or 551 inactive

Return to troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault status. |
 | STEP 1A. Perform the fault code disable procedure. | Fault Code 432 still active
 | STEP 1B. Check for idle validation fault codes. | Fault Codes 431 and 551 inactive
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the accelerator position sensor circuit. | 1500 to 3000 ohms (released); 250 to 1500 ohms (depressed); Released value must be at least 1000 ohms greater than depressed value
 | STEP 2B-1. Check the resistance of the accelerator position sensor. |
 | STEP 2B-2. Check the resistance in the OEM harness. |
 | STEP 2C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2C-1. Check for an open circuit of the accelerator position sensor supply and return circuit. |
 | STEP 2C-2. Check for an open circuit in the OEM harness. |
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D-1. Check for a short circuit to ground in the accelerator position sensor. |
 | STEP 2D-2. Check for a short circuit to ground in the OEM harness. |
 | STEP 2E. Check for a short circuit from pin to pin in the OEM harness. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 432 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the fault status.

Guided Step 1A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch to the ON position.
  • All components connected.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal to the full-fuel position, and release it completely three times.
  • Read the inactive fault codes using INSITE™.
OK NOT OK

Fault Code 432 still active

Replace the accelerator pedal assembly. Refer to the equipment manufacturer's troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check for idle validation fault codes.

Conditions

  • Turn keyswitch to the ON position.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 431 and 551 are inactive

Fault codes are active.

Go to 2A

Fault Code 431 or 551

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.
Guided Step 2B - Check the resistance of the accelerator position sensor circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance.

  • Measure the resistance from pin 29 to pin 30 of the OEM harness connector with the accelerator pedal in the released (idle) position.
  • Repeat the measurement with the accelerator pedal in the depressed (full-fuel) position.
  • Resistance with the pedal released must be at least 1000 ohms greater than when it is depressed.
OK NOT OK

1500 to 3000 ohms (released); 250 to 1500 ohms (depressed); Released value must be at least 1000 ohms greater than depressed value

Go to 2C

Go to 2B-1

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
Guided Step 2B-1 - Check the resistance of the accelerator position sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance of the throttle position sensor.

  • Measure the resistance from pin C to pin B on the sensor side of the accelerator position sensor connector with the accelerator pedal in the released (idle) position.
  • Repeat the above measurement with the accelerator pedal in the depressed (full fuel) position.
  • Resistance when the pedal is released must be at least 1000 ohms greater than when it is depressed.
OK NOT OK

1500 to 3000 ohms (released); 250 to 1500 ohms (depressed); Released value must be at least 1000 ohms greater than depressed value

Replace the accelerator pedal assembly. Refer to the OEM troubleshooting and repair manual.

Go to 2B-2

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.
Guided Step 2B-2 - Check the resistance in the OEM harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance in the OEM harness.

  • Measure the resistance from pin 29 of the OEM harness connector to pin C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 30 of the OEM harness connector to pin B on the harness side of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 29 to pin 19 of the OEM harness connector (the accelerator pedal can be either released or depressed).
OK NOT OK

2000 to 3000 ohms

Go to 2D

Go to 2C-1

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
Guided Step 2C-1 - Check for an open circuit of the accelerator position sensor supply and return circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit of the accelerator position sensor supply and return circuit.

  • Measure the resistance from pin C to pin A on the sensor side of the accelerator position sensor connector (the accelerator pedal can be either released or depressed).
OK NOT OK

2000 to 3000 ohms

Replace the accelerator pedal assembly. Refer to the OEM troubleshooting and repair manual.

Go to 2C-2

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.
Guided Step 2C-2 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance in the OEM harness from the ECM.

  • Measure the resistance from pin 29 of the OEM harness connector to pin C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 19 of the OEM harness connector to pin A on the harness side of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness from ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 29 in the OEM harness to the engine block ground.
  • Measure the resistance from pin 30 in the OEM harness to the engine block ground.
OK NOT OK

More than 100k ohms

Go to 2E

Go to 2D-1

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 2D-1 - Check for a short circuit to ground in the accelerator position sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the accelerator position sensor.

  • Measure the resistance from pin B on the sensor side of the accelerator position sensor connector to the engine block ground.
  • Measure the resistance from pin C on the sensor side of the accelerator position sensor connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the accelerator pedal assembly. Refer to the OEM troubleshooting and repair manual.

Go to 2D-2

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-2 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 29 of the OEM harness to the engine block ground.
  • Measure the resistance from pin 30 of the OEM harness to the engine block ground.
OK NOT OK

More than 100k ohms

Replace or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2E

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit from pin to pin in the OEM harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for short circuit from pin to pin in the OEM harness.

  • Measure the resistance from pin 29 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 30 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 19 in the OEM harness to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Depress the accelerator pedal to the full fuel position and release it completely three times.
  • Start the engine, and let idle for 1 minute.
  • Drive the vehicle.
  • Using INSITE™, verify Fault Code 432 is inactive.
OK NOT OK

Fault Code 432 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure sensor. |
 | STEP 1A. Inspect the sensor circuit for tampering. | No tampering
 | STEP 1B. Inspect the engine harness and the sensor connectors. | No damaged pins
 | STEP 1C. Check intake manifold pressure signal voltage. | (+) 0.44 to 0.56 VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for an open circuit in the return line. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 433 inactive
 | STEP 3B. Clear the inactive fault code. | All faults cleared

Guided Step 1 - Check the intake manifold pressure sensor.

Guided Step 1A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch to the OFF position.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure sensor and the engine harness for external wires or damaged harness braiding.
OK NOT OK

No tampering

Remove and record tampering.

If tampering has occurred, repair the circuit, and record the tampering.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine harness and the sensor connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the harness and the sensor connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061.

Go to 1C

Go to 3A

Guided Step 1C - Check the intake manifold pressure signal voltage.

Conditions

  • Turn the keyswitch to the ON position.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure signal voltage.

  • Measure the voltage from pin B to pin C of the intake manifold pressure sensor circuit.
OK NOT OK

(+) 0.44 to 0.58 VDC

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the harness and the ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the harness and the ECM connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins..

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short from pin to pin.

  • Measure the resistance from pin 45 in the engine harness connector to all other pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 45 in the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for an open circuit in the return line.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the return line.

  • Measure the resistance from pin 19 of the engine harness connector to pin B of the intake manifold pressure sensor connector on the harness side.
OK NOT OK

Less than 10 ohms.

Replace the intake manifold pressure sensor. Refer to Procedure 019-061.

Replace the engine harness.

Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify Fault Code 433 is inactive.
OK NOT OK

Fault Code 433 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault code.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-Jan-2013


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/AMP/Metri-Pack test lead.
CAUTION

To avoid damaging the ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the batteries and the OEM connector. |
 | STEP 1A. Inspect the 23-pin OEM connector. | No damaged pins or loose connections
 | STEP 1B. Check the resistance of the battery supply circuit. | Less than 10 ohms
 | STEP 1C. Check the battery voltage. | Normal conditions: At least (+) 12 VDC- (+) 12-VDC system; At least (+) 24 VDC- (+) 24-VDC system; During cranking: At least (+) 6.2 VDC - (+) 12-VDC system; At least (+) 12 VDC - (+) 24-VDC system
 | STEP 1D. Check the battery connections. | Connections are tight and corrosion-free
STEP 2. | Check the fuses. |
 | STEP 2A. Check if the three 7.5-amp fuses are installed correctly. | Fuses installed correctly
 | STEP 2B. Check if the two 10-amp fuses are installed correctly. | Fuses installed correctly
 | STEP 2C. Check if the fuses are blown. | Fuses not blown
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit in the battery power circuits. | (+) 10 to 15 VDC - (+) 12-VDC system; (+) 22 to 27 VDC - (+) 24-VDC system
 | STEP 3C. Check for a short circuit in the battery return wires. | More than 100k ohms
 | STEP 3D. Check the add-on or the accessory wiring at positive (+) terminal of the battery. | No damaged wires
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 434 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the batteries and the OEM connector.

Guided Step 1A - Inspect the 23-pin OEM connector.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the battery supply at the 23-pin OEM connector.

Action

Inspect the 23-pin OEM connector on both the battery side and harness side for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins or loose connections

Repair or replace the damaged pins. Refer to Procedure 019-207 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 1B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/AMP/Metri-Pack test lead.
Guided Step 1B - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the 23-pin Deutsch connector.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance from pins B, C, D, M, and S of the battery supply connector to the positive (+) battery terminal.
  • Measure the resistance from pins E, F, H, P, and W of the battery return connector to the negative (-) battery terminal.
OK NOT OK

Less than 10 ohms

Repair or replace the harness. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the battery voltage.

Conditions

  • Turn keyswitch to the ON position.
  • Connect the engine harness from the 23-pin Deutsch connector.

Action

Check the battery voltage.

  • Place positive (+) probe of multimeter on the positive battery terminal and touch negative (-) probe to the negative battery terminal. Measure the voltage before and during cranking.
OK NOT OK

Normal conditions: at least (+) 12 VDC - (+) 12-VDC system at least (+) 24 VDC - (+) 24-VDC system; During cranking: at least (+) 6.2 VDC - (+) 12-VDC system at least (+) 12 VDC - (+) 24-VDC system

Charge or replace the battery. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check the battery connections.

Conditions

  • Turn keyswitch to the ON position.
  • Connect the engine harness to the 23-pin Deutsch connector.

Action

Check the battery connections.

Check the battery connections.
OK NOT OK

Connections are tight and corrosion-free

Tighten the connections. Tighten the loose connections, and clean the terminals. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuses.

Guided Step 2A - Check if the three 7.5-amp fuses are installed correctly.

Conditions

  • Turn keyswitch to the ON position.
  • Connect the engine harness to the 23-pin Deutsch connector.

Action

Check if the three 7.5-amp fuses are installed correctly.

  • Inspect the three 7.5-amp fuses for correct installation.
OK NOT OK

Fuses installed correctly

Install the fuses correctly. Refer to Procedure 019-198 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

Guided Step 2B - Check if the two 10-amp fuses are installed correctly.

Conditions

  • Turn keyswitch to the ON position.
  • Connect the engine harness to the 23-pin Deutsch connector.

Action

Check if the 10-amp fuses are installed correctly.

  • Inspect the 10-amp fuses for correct installation.
OK NOT OK

Fuses installed correctly

Install the fuses correctly. Refer to Procedure 019-198 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

Guided Step 2C - Check if the fuses are blown.

Conditions

  • Turn keyswitch to the ON position.
  • Connect the engine harness to the 23-pin Deutsch connector.

Action

Check if the three 7.5-amp fuses and the two 10-amp fuses are blown.

Check if the three 7.5-amp fuses and the two 10-amp fuses are blown.
OK NOT OK

Fuses not blown

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

CAUTION

To avoid damaging the ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Connect the engine harness to the 23-pin Deutsch connector.
  • Disconnect the engine harness from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch to the OFF position.
  • Connect the engine harness to the 23-pin Deutsch connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the battery power and return circuits.

  • Measure the voltage from pin 38 to pins 20, 28, 29, and 30.
  • Measure the voltage from pin 39 to pins 20, 28, 29, and 30.
  • Measure the voltage from pin 40 to pins 20, 28, 29, and 30.
  • Measure the voltage from pin 50 to pins 20, 28, 29, and 30.
OK NOT OK

(+) 10 to 15 VDC - (+) 12-VDC system; (+) 22 to 27 VDC - (+) 24-VDC system

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3C

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit in the battery return wires.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the 23-pin Deutsch connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit.

  • Measure the resistance from pin 38 to all other pins in the engine harness.
  • Measure the resistance from pin 39 to all other pins in the engine harness.
  • Measure the resistance from pin 40 to all other pins in the engine harness.
  • Measure the resistance from pin 50 to all other pins in the engine harness.
  • Measure the resistance from pin 20 to all other pins in the engine harness.
  • Measure the resistance from pin 28 to all other pins in the engine harness.
  • Measure the resistance from pin 29 to all other pins in the engine harness.
  • Measure the resistance from pin 30 to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3D

Go to 4A

Guided Step 3D - Check the add-on or accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check the add-on or the accessory wiring at positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block ground.
OK NOT OK

No damaged wires

Repair or replace the damaged wiring. Refer to the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify Fault Code 434 is inactive.
OK NOT OK

Fault Code 434 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Cannon Metri-Pack Deutsch test leadPart Number 3822917 - female AMP/Cannon Metri-Pack Deutsch test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Inspect connector on engine to determine which test lead to use:Part Number 3822758 - male AMP/Cannon/Metri-Pack/Deutsch test leadPart Number 3822917 - female AMP/Cannon/Metri-Pack/Deutsch test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Cannon/Metri-Pack/Deutsch test leadPart Number 3822917 - female AMP/Cannon/Metri-Pack/Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC- (+) 12-VDC system; At least (+) 24 VDC- (+) 24-VDC system; During cranking: At least (+) 6.2 VDC- (+) 12-VDC system; At least (+) 12 VDC- (+) 24-VDC system
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the fuse connections. | Fuses installed correctly
 | STEP 2B. Check the fuse. | Fuses not blown
 | STEP 2C. Inspect the 23-pin power connector. | No damaged pins or loose connections
 | STEP 2D. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms
 | STEP 2E. Check for an add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires
STEP 3. | Check the engine harness. |
 | STEP 3A. Check for short circuit from pin to pin. | More than 100k ohms
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the equipment battery system.

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch to the OFF position.

Action

Inspect the battery cable connections for:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections. Tighten the battery connections, and clean the battery terminals. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.
OK NOT OK

Normal conditions: At least (+) 12 VDC - (+) 12-VDC system; At least (+) 24 VDC - (+) 24-VDC system; During cranking: At least (+) 6.2 VDC - (+) 12-VDC system; At least (+) 12 VDC - (+) 24-VDC system

Charge or replace the battery. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the fuse connections.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the 7.5-amp fuses and two 10-amp fuses from the engine harness.

Action

Check if the three 7.5-amp fuses and the two 10-amp fuses are installed correctly.

Check if the three 7.5-amp fuses and the two 10-amp fuses are installed correctly.
OK NOT OK

Fuses installed correctly

Install fuses correctly. Refer to Procedure 019-198 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuse.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the 7.5-amp fuses and the two 10-amp fuses from the engine harness.

Action

Check if the three 7.5-amp fuses and the two 10-amp fuses are blown.

Check if the three 7.5-amp fuses and the two 10-amp fuses are blown.
OK NOT OK

Fuses not blown

Replace the fuses. Refer to Procedure 019-198 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the 23-pin power connector.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the battery at the 23-pin Deutsch connector.

Action

Inspect the 23-pin connectors on the both battery side and the harness side for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins or loose connections

Repair or replace the 23-pin connector. Refer to Procedure 019-207 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Inspect connector on engine to determine which test lead to use:Part Number 3822758 - male AMP/Cannon/Metri-Pack/Deutsch test leadPart Number 3822917 - female AMP/Cannon/Metri-Pack/Deutsch test lead.
Guided Step 2D - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the battery supply at the 23-pin Deutsch connector.

Action

Check for an open circuit in the battery supply and return circuits.

  • Measure the resistance from pins B, C, D, M, and S to the positive (+) terminal of the battery.
  • Measure the resistance from pins E, F, H, P, and W to the negative (-) battery terminal.
OK NOT OK

Less than 10 ohms

Repair or replace the harness. Refer to the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or installation error that can cause supply wire to be shorted to the engine block ground.
OK NOT OK

No damaged wires

Repair the damaged wiring. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Cannon/Metri-Pack/Deutsch test leadPart Number 3822917 - female AMP/Cannon/Metri-Pack/Deutsch test lead.
Guided Step 3A - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin Deutsch connector.

Action

Check for a short circuit.

  • Measure the resistance from pin 38 to all other pins in the engine harness.
  • Measure the resistance from pin 39 to all other pins in the engine harness.
  • Measure the resistance from pin 40 to all other pins in the engine harness.
  • Measure the resistance from pin 50 to all other pins in the engine harness.
  • Measure the resistance from pin 20 to all other pins in the engine harness.
  • Measure the resistance from pin 28 to all other pins in the engine harness.
  • Measure the resistance from pin 29 to all other pins in the engine harness.
  • Measure the resistance from pin 30 to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect engine harness from the ECM.
  • Disconnect engine harness from the 23-pin connector.

Action

Check for an open circuit.

  • Measure the resistance, on the engine harness side, from pin 38 of the ECM connector to pin M of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin 39 of the ECM connector to pin B of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin 40 of the ECM connector to pin C of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin 50 of the ECM connector to pin D of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin 20 of the ECM connector to pin E of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin 28 of the ECM connector to pin F of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin 29 of the ECM connector to pin H of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin 30 of the ECM connector to pin P of the 23-pin connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin Deutsch connector.

Action

Check for a short circuit.

  • Measure the resistance from pin 38 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin 39 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin 40 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin 50 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin 20 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin 28 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin 29 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin 30 of the ECM connector on the engine harness to chassis ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify that Fault Code 441 is inactive.
OK NOT OK

Fault Code 441 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive Fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part No. 3823995 - male Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check the battery voltage. | Less than (+) 32 VDC
 | STEP 1B. Check the battery ground. | Less than 10 ohms
 | STEP 1C. Check the alternator. | Alternator functioning normally
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 442 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the equipment battery system.

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part No. 3823995 - male Weather-Pack test lead.
Guided Step 1A - Check the battery voltage.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the engine harness from the battery at the positive 23-pin Deutsch connector.

Action

Check the battery voltage.

  • Measure the battery voltage from pin B of the positive (+) lead of the power connector to engine block ground.
  • Measure the battery voltage from pin C of the positive (+) lead of the power connector to engine block ground.
  • Measure the battery voltage from pin D of the positive (+) lead of the power connector to engine block ground.
  • Measure the battery voltage from pin M of the positive (+) lead of the power connector to engine block ground.
  • Measure the battery voltage from pin S of the positive (+) lead of the power connector to engine block ground.
OK NOT OK

Less than (+) 32 VDC

Install the battery system correctlyRefer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 2A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part No. 3823995 - male Weather-Pack test lead.
Guided Step 1B - Check the battery ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the engine harness from the battery at the 23-pin Deutsch connector.

Action

Check the battery ground.

  • Measure the resistance from pin E of the negative (-) lead of the power connector to ground.
  • Measure the resistance from pin F of the negative (-) lead of the power connector to ground.
  • Measure the resistance from pin H of the negative (-) lead of the power connector to ground.
  • Measure the resistance from pin P of the negative (-) lead of the power connector to ground.
  • Measure the resistance from pin W of the negative (-) lead of the power connector to ground.
OK NOT OK

Less than 10 ohms

Install the battery system correctlyRefer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 2A

Guided Step 1C - Check the alternator.

Conditions

  • Turn keyswitch to the OFF position.

Action

Inspect the alternator for normal operation.
OK NOT OK

Alternator functioning normally

Repair or replace the alternatorRefer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify Fault Code 442 is inactive.
OK NOT OK

Fault Code 442 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack test leadPart Number 3822917 - female AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect OEM harness and sensor connectors. | No damaged pins
 | STEP 1B. Check for active fault code. | Fault Code 387 or 443 remains active
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for a short circuit to a voltage source. | Less than (+) 1.0 VDC
STEP 3. | Check the ECM voltage. |
 | STEP 3A. Measure the sensor supply voltage from the ECM. | (+) 4.75 to 5.25 VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 387 or 443 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and sensor connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the sensor connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Replace the damaged pins. Repair or replace the OEM harness or the accelerator position sensor, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Repair or replace the accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Read the fault codes using INSITE.

Read the fault codes using INSITE™.
OK NOT OK

Fault Code 387 or 443 remains active

Replace the accelerator pedal assembly or the accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 29 of the OEM harness connector to pin C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 19 of the OEM harness connector to pin A on the harness side of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to a chassis ground.

  • Measure the resistance from pin 29 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 19 in the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms.

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 29 to all other pins in the OEM harness connector.
  • Measure the resistance from pin 19 to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2E

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.
  • Connect the OEM harness to the accelerator position sensor.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage from pin 29 in the OEM harness connector to engine block ground.
  • Measure the voltage from pin 19 in the OEM harness connector to engine block ground.
OK NOT OK

Less than (+) 1.0 VDC

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM voltage.

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female AMP/Metri-Pack test lead.
Guided Step 3A - Measure the sensor supply voltage from the ECM.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin 29 to pin 19 on the ECM OEM connector port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Depress and release the accelerator pedal several times to be sure the ECM is getting an accelerator signal.
  • Using INSITE™, verify Fault Code 387 or 443 inactive.
OK NOT OK

Fault Code 387 and 443 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair completed

Appropriate troubleshooting charts

Last Modified: 03-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack/Deutsch test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822917 - female AMP/Metri-Pack/Deutsch test lead.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack/Deutsch test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack/Deutsch test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female AMP/Metri-Pack/Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and sensor connectors. | No damaged pins
 | STEP 1B. Check for active fault codes. | Fault Code 385, 441, or 444 remains active
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for a short circuit to a voltage source. | Less than (+) 1.0 VDC
STEP 3. | Check the ECM voltage. |
 | STEP 3A. Measure the sensor supply voltage from the ECM. | (+) 4.75 to 5.25 VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 385 or 444 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the remote accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and sensor connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Inspect the OEM harness and the sensor connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Replace the damaged pins.

Repair or replace the OEM harness or the remote accelerator position sensor, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Repair or replace the remote accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Read the fault codes using INSITE™.

Read the fault codes using INSITE™.
OK NOT OK

Fault Code 385, 441, or 444 remains active

Replace the accelerator pedal assembly or the accelerator position sensor.

Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack/Deutsch test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the OEM harness connector to pin C on the harness side of the remote accelerator position sensor connector.
  • Measure the resistance from pin 20 of the OEM harness connector to pin A on the harness side of the remote accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness.

Refer to Procedure 019-0710 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack/Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to a chassis ground.

  • Measure the resistance from pin 10 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 20 in the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness.

Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack/Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to a chassis ground.

  • Measure the resistance from pin 10 to all other pins in the OEM harness.
  • Measure the resistance from pin 20 to all other pins in the OEM harness.
OK NOT OK

More than 100k ohms

Replace the OEM harness.

Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2E

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Metri-Pack/Deutsch test lead.
Guided Step 2E - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.
  • Connect the OEM harness to the remote accelerator position sensor.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage from pin 10 in the OEM harness connector to engine block ground.
  • Measure the voltage from pin 20 in the OEM harness connector to engine block ground.
OK NOT OK

Less than (+) 1.0 VDC

Replace the OEM harness.

Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM voltage.

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female AMP/Metri-Pack/Deutsch test lead.
Guided Step 3A - Measure the sensor supply voltage from the ECM.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin 10 to pin 20 on the ECM OEM connector.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM.

Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault codes.

  • Start the engine, and let idle for 1 minute.
  • Depress and release the accelerator pedal several times to be sure the ECM is getting an accelerator signal.
  • Using INSITE™, verify Fault Code 385 or 444 is inactive.
OK NOT OK

Fault Code 385 or 444 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pressure sensor circuit. |
 | STEP 1A. Inspect fuel pressure sensor circuit for signs of tampering. | No tampering
STEP 2. | Check fault codes. |
 | STEP 2A. Read fault codes. | Fault Code 449 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 449 inactive
 | STEP 3B. Clear the inactive fault code. | All faults cleared

Guided Step 1 - Check the fuel pressure sensor circuit.

Guided Step 1A - Inspect the fuel pressure sensor circuit for signs of tampering.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check the fuel pressure sensor circuit for signs of tampering; such as:

  • Extra wires spliced into the fuel pressure sensor wiring
  • Cut braiding in the wire harness
  • Signs of unnecessary sensor removal and installation
  • Missing weather seal on fuel pressure connector.
OK NOT OK

No tampering

Remove extra wires, or replace missing weather seal.

Go to 2A

Go to 3A

Guided Step 2 - Check fault codes.

Guided Step 2A - Read fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Operate engine from low to high idle several times, or test-drive the vehicle before reading fault codes.
  • Using INSITE™, read the fault codes.
OK NOT OK

Fault Code 449 inactive

Replace the fuel pump accumulator module005-085 in the ISC Troubleshooting and Repair Manual, Bulletin 3666245.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start engine, and let idle for 1 minute.
  • Using INSITE™, verify that Fault Code 449 is inactive and did not reoccur.
OK NOT OK

Fault Code 449 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear all the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate trouble-shooting charts

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Deutsch/Metri-Pack test leadPart Number 3162982 - fuel pressure breakout cable.
CAUTION

To avoid damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3162982 - fuel pressure breakout cable.
CAUTION

To avoid damaging the new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Deutsch/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read fault codes. | Fault Codes 122, 123, 135, 141, 144, 145, 153, 154, 263, 265, and 352 inactive
STEP 2. | Check the fuel pressure sensor. |
 | STEP 2A. Inspect the fuel pressure sensor and engine harness connector. | No damaged pins
 | STEP 2B. Check the fuel pressure supply voltage. | (+) 4.5 to 5.25 VDC
 | STEP 2C. Check the fuel pressure signal voltage. | (+) 0.31 to 0.69 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Codes 451 and 452 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.
  • All components connected.

Action

Read the fault codes.

  • Read active fault codes using INSITE™.
OK NOT OK

Fault Codes 122, 123, 135, 141, 144, 145, 153, 154, 263, 265, and 352 inactive

Fault codes are active

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pressure sensor.

Guided Step 2A - Inspect the fuel pressure sensor and engine harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the fuel pressure sensor.

Action

Inspect the engine harness, fuel pressure sensor, and ECM connectors for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the fuel pressure/temperature sensor. Refer to Procedure 019-153 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3162982 - fuel pressure breakout cable.
Guided Step 2B - Check the fuel pressure supply voltage.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel pressure sensor.
  • Install fuel pressure breakout cable Part Number 3162982.
  • Turn keyswitch to the ON position.

Action

Check the fuel pressure supply voltage.

  • Measure the voltage from pin A to pin B of the fuel pressure sensor breakout cable.
OK NOT OK

(+) 4.5 to 5.25 VDC

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pressure signal voltage.

Conditions

  • Turn keyswitch to the ON position.
  • Connect the fuel pressure sensor breakout cable, Part Number 3162982, between the sensor and the engine harness.

Action

Check the fuel pressure signal voltage.

  • Measure the voltage from pin B to pin C of the fuel pressure sensor breakout cable.
OK NOT OK

(+) 0.31 to 0.69 VDC

Replace the fuel pressure/temperature sensor. Refer to Procedure 019-153 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

CAUTION

To avoid damaging the new ECM, all other fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Deutsch/Metri-Pack test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a open circuit.

  • Measure the resistance from pin 46 of the engine harness to pin C on the harness side of the fuel pressure sensor.
  • Measure the resistance from pin 19 of the engine harness to pin B on the harness side of the fuel pressure sensor.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3C

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Deutsch/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 46 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Deutsch/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the fuel pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 46 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin 19 of the engine harness to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify that Fault Code 451 and 452 are inactive and did not reoccur.
OK NOT OK

Fault Code 451 and 452 is inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location, if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Dec-2010


FAULT CODE 456 - Fuel Pressure Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | Other active fault codes?
STEP 2. | Inspect fuel pressure sensor circuit. |
 | STEP 2A. Inspect circuit for damage. | No damage to circuit.
STEP 3. | Check the inlet restriction. |
 | STEP 3A. Measure fuel inlet restriction. | Less than 254 mm Hg [10 in Hg] of restriction at CAPS inlet.
STEP 4. | Check for air in the fuel system. |
 | STEP 4A. Verify that there is no air in the fuel system. | No air detected.
STEP 5. | Check the fuel lift pump. |
 | STEP 5A. Measure the fuel lift pump flow. | Fuel lift pump flow meets specifications.
STEP 6. | Check the wiring harness. |
 | STEP 6A. Inspect the engine wiring harness and the engine control module (ECM) connector pins. | No damaged pins.
 | STEP 6B. Check for an open circuit. | Less than 10 ohms.
 | STEP 6C. Inspect the fuel pressure sensor circuit for a short circuit. | More than 100k ohms.
 | STEP 6D. Inspect the fuel pressure sensor circuit for a short circuit to ground. | More than 100k ohms.
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault codes. | Fault code disabled.
 | STEP 7B. Clear inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other active fault codes.

Other active fault codes.

Go to 2A

Appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the fuel pressure sensor circuit.

Guided Step 2A - Inspect the fuel pressure sensor circuit for visual damage.

Conditions

  • Turn keyswitch to the OFF.

Action

Check the fuel pressure supply voltage.

  • Make sure pins are not fretted.
  • Make sure sensor potting is intact.

Check the pressure sensor pig tail.

  • Check for wire abrasion.
  • Check for shorts to the rate shape tube or adjacent wires.
  • Make sure wires have not come out of the sensor or connector by flexing and tugging on wires.
  • Make sure the triangular connector has not rubbed against the rate shape tube.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No visual signs of damage.

Visual signs of damage.

Replace the fuel pressure sensor and install the pressure sensor bracket kit, it it is not already installed. Reference Service Bulletin 4021293 and/or 4021294.

Go to 3A

Go to 7A

Guided Step 3 - Check the inlet restriction.

Guided Step 3A - Measure the fuel inlet restriction.

Conditions

  • Turn keyswitch to the ON.
  • If intermittent issue, check the inlet restriction while duplicating the complaint.

Action

Check the inlet restriction.

  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-020 in Section 6.
OK NOT OK

Less than 254 mm Hg [10 in Hg] of restriction at CAPS inlet.

More than 254 mm Hg [10 in Hg] of restriction at CAPS inlet.

Correct source of inlet restriction.

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-020 in Section 6.

Go to 4A

Go to 7A

Guided Step 4 - Check for air in the fuel system.

Guided Step 4A - Verify there is no air in the fuel.

Conditions

  • Turn keyswitch to the ON.
  • If intermittent issue, check for air while duplicating the complaint.

Action

Check for air in the fuel.

  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-020 in Section 6.
OK NOT OK

No air detected.

Air detected.

Correct source of the air leak.

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-003 in Section 6.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel lift pump.

Guided Step 5A - Measure the fuel lift pump flow.

Conditions

  • Turn keyswitch ON.

Action

Perform fuel lift pump flow test.

  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-045 in Section 5.
OK NOT OK

Fuel lift pump flow meets specifications.

Fuel lift pump flow does not meet specifications.

Replace the fuel lift pump.

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-045 in Section 5.

Go to 6A

Go to 7A

Guided Step 6 - Check the engine wiring harness.

Guided Step 6A - Inspect the engine wiring harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the fuel pressure sensor.

Action

Inspect the engine wiring harness and ECM connectors pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins.

Damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6B

Go to 7A

Guided Step 6B - Inspect the fuel pressure sensor circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the fuel pressure sensor.

Action

Check for an open circuit in the fuel pressure sensor circuit.

  • Measure the resistance from pin-46 of the engine wiring harness to pin-C of the fuel pressure sensor connector.
  • Measure the resistance from pin-10 of the engine wiring harness to pin-A of the fuel pressure sensor connector.
  • Measure the resistance from pin-19 of the engine wiring harness to pin-B of the fuel pressure sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

If less than 10 ohms, no open circuit.

Repair or replace the engine wiring harness.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6C

Go to 7A

Guided Step 6C - Inspect the fuel pressure sensor circuit for a short circuit.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from all sensors that share the common ground.

Action

Check for a short circuit in the fuel pressure sensor circuit.

  • Measure the resistance from pin-46 of the engine wiring harness to all other pins in the ECM connector.
  • Measure the resistance from pin-10 of the engine wiring harness to all other pins in the ECM connector.
  • Measure the resistance from pin-19 of the engine wiring harness to all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

If greater than 100k ohms, no shorts.

Repair or replace the engine wiring harness.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6D

Go to 7A

Guided Step 6D - Inspect the fuel pressure sensor circuit for a short circuit to ground.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from all sensors that share the common ground.

Action

Check for a short circuit in the fuel pressure sensor circuit.

  • Measure the resistance from pin-46 of the engine wiring harness to chassis ground.
  • Measure the resistance from pin-10 of the engine wiring harness to chassis ground.
  • Measure the resistance from pin-19 of the engine wiring harness to chassis ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

If greater than 100k ohms, no shorts.

Repair or replace the engine wiring harness.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 456 is inactive.
OK NOT OK

Fault Code 456 inactive.

Return to the troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to the appropriate troubleshooting chart.

Guided Step 7B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 15-Apr-2013


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct within 5°F
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 488 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch to the ON position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the intake manifold air temperature sensor.
  • Connect INSITE™ to the datalink.
  • Run the engine, and compare the intake manifold temperature sensor reading on INSITE™ monitor screen to the reading from the temperature probe.

NOTE: If a temperature measuring device is not available, answer "OK" to this step.

NOTE: Readings can, perhaps, need to be checked while engine is operating at normal temperature conditions (180°F coolant).

OK NOT OK

Sensor reading is correct within 5°FLocate and repair the cause of high intake manifold air temperature. (Refer to the Shop Talk section of this fault code for the correct procedure.)

Sensor reading not within 5°F.

Go to 2A

Fault Code 154

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Load and operate engine to typical operating temperature (180°F coolant).
  • Using INSITE™, verify Fault Code 488 is inactive and did not reoccur.
OK NOT OK

Fault Code 488 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active faults. |
 | STEP 1A. Read fault codes. | No other faults active
STEP 2. | Check the auxiliary device for proper function. |
 | STEP 2A. Refer to OEM troubleshooting and repair manual for auxiliary device overspeed. | Auxiliary device functioning properly
STEP 3. | Check the auxiliary speed sensor. |
 | STEP 3A. Inspect the OEM harness and the sensor connectors. | No damaged pins
 | STEP 3B. Check for proper adjustment (if adjustable). | 1/2 to 3/4 turn out from gear for threaded type of sensor
 | STEP 3C. Check for the correct sensor resistance. | 750 to 1500 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit between coils (if two coils exist). | More than 100k ohms
STEP 4. | Check the auxiliary pressure sensor. |
 | STEP 4A. Inspect pins. | No bent pins
 | STEP 4B. Measure voltage to the ECM. | (+) 0.5 to 4.5 VDC
STEP 5. | Check the OEM harness. |
 | STEP 5A. Inspect the OEM harness and the ECM connectors. | No damaged pins
 | STEP 5B. Check for an open circuit. | Less than 10 ohms
 | STEP 5C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 489 inactive
 | STEP 6B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for active fault.

Guided Step 1A - Read fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

No other active fault codes

Troubleshoot other fault codes first.

Go to 2A

Appropriate fault tree

Guided Step 2 - Check the auxiliary device for proper function.

Guided Step 2A - Refer to the OEM troubleshooting and repair manual for auxiliary device overspeed.

Action

Refer to the OEM troubleshooting and repair manual.

  • Refer to the OEM troubleshooting and repair manual for proper function of the auxiliary device.
  • Check for slipping clutches or broken driveline components.
  • Measure OEM pressure to verify proper OEM equipment function.
OK NOT OK

Auxiliary device functioning properly

Repair the auxiliary device. Refer to the OEM troubleshooting and repair manual.

3A for auxiliary speed applications; 4A for auxiliary pressure applications

Go to 6A

Guided Step 3 - Check the auxiliary speed sensor.

Guided Step 3A - Inspect the OEM harness and the sensor connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Inspect the OEM harness and the sensor connectors for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.
  • Replace the auxiliary speed sensor. Refer to the OEM troubleshooting and repair manual.

Go to 3B

Go to 6A

Guided Step 3B - Check the auxiliary speed sensor for the proper adjustment (if adjustable).

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Check the auxiliary speed sensor for the proper adjustment (if adjustable).

Check the auxiliary speed sensor for the proper adjustment (if adjustable).
OK NOT OK

1/2 to 3/4 of a turn out from the gear for threaded type of sensor

Adjust the auxiliary speed sensor. Refer to the OEM troubleshooting and repair manual.

Go to 3C

Go to 6A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.
Guided Step 3C - Check for the correct sensor resistance.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Check the auxiliary speed sensor for the correct resistance.

  • Measure the resistance from pin A to pin B for each auxiliary speed sensor connector on the sensor side.
OK NOT OK

750 to 1500 ohms

Replace the auxiliary speed sensor. Refer to the OEM troubleshooting and repair manual.

Go to 3D

Go to 6A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Check the auxiliary speed sensor for a short circuit to ground.

  • Measure the resistance from pin A on the sensor side of the auxiliary speed sensor connector to engine block ground.
  • Measure the resistance from pin B on the sensor side of the auxiliary speed sensor connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the auxiliary speed sensor. Refer to the OEM troubleshooting and repair manual.

Go to 3E

Go to 6A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.
Guided Step 3E - Check for a short circuit between coils (if two coils exist).

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the auxiliary speed sensor.

Action

Check the auxiliary speed sensor for a short circuit between coils.

  • Measure the resistance from pin A on the sensor side of one of the auxiliary speed sensor connectors to pin A of the other connector.
OK NOT OK

More than 100k ohms

Replace the auxiliary speed sensor. Refer to the OEM troubleshooting and repair manual.

Go to 5A

Go to 6A

Guided Step 4 - Check the auxiliary pressure sensor.

Guided Step 4A - Inspect pins.

Action

Inspect sensor and OEM harness connector pins.

Inspect sensor and OEM harness connector pins.
OK NOT OK

No bent pins

Go to 4B

Go to 6A

Guided Step 4B - Measure voltage to the ECM.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM connector from the ECM.

Action

Measure voltage.

  • Measure pin 48 to engine block ground.
OK NOT OK

(+) 0.5 to 4.5 VDC

Replace pressure sensor. Refer to OEM troubleshooting and repair manual.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Inspect the OEM harness and the ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM harness.

Action

Inspect the OEM harness and the ECM connectors for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair damaged pins. Repair or replace the OEM harness or OEM interface harness, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-207 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.
  • Dry the connector by using an electrical contact cleaner, Part Number 3824510.
  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner.

Go to 5B

Go to 6A

Guided Step 5B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the auxiliary speed or pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 8 of the OEM harness connector to pin A of the OEM harness auxiliary speed sensor.
  • Measure the resistance from pin 18 of the OEM harness connector to pin B of the OEM harness auxiliary speed sensor.
  • Measure the resistance from pin 48 of the OEM harness connector to pin X of the OEM harness auxiliary pressure sensor.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the auxiliary speed or pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 18 of the OEM harness to engine block ground.
  • Measure the resistance from pin 8 of the OEM harness to engine block ground.
  • Measure the resistance from pin 48 of the OEM harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.

Go to 5D

Go to 6A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the auxiliary speed or pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 18 of the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 8 of the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 48 of the OEM harness to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Engines, Bulletin 3666271.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start engine, and let idle for 1 minute.
OK NOT OK

Fault Code 489 inactive

Return to troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear any inactive fault codes.

Conditions

Connect all components.

Action

Clear any inactive fault codes.

  • Erase any inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP/Deutsch/Metri-Pack test leadPart Number 3823993 - male Deutsch/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injection control identifier. |
 | STEP 1A. Inspect the injection control valve connector for damaged pins. | No damaged pins
 | STEP 1B. Inspect the injection control valve identifier. | Identifier and shrink-wrap intact
 | STEP 1C. Check for short circuit to ground in the injection control valve identifier circuits. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 493 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injection control identifier.

Guided Step 1A - Inspect the injection control valve connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injection control valve.

Action

Inspect the injection control valve connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or injection control valve, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the fuel pump injection control valve module. 005-087 in the ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the injection control valve identifier.

Conditions

  • Turn keyswitch OFF.

Action

Check the injection control valve identifier.

  • Check the injection control valve identifier.
OK NOT OK

Identifier and shrink-wrap intact

Replace the fuel pump injection control valve module. 005-087 in the ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 1C

Go to 3A

Guided Step 1C - Check for short circuit to ground in injection control valve identifier circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injection control valve coil.

Action

Check for short to ground in the injection control valve identifier.

  • Measure the resistance between pin 3 of the injection control valve identifier connector to chassis ground.
  • Measure the resistance between pin 4 of the injection control valve identifier connector to chassis ground.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

OK NOT OK

More than 100k ohms

Replace the fuel pump injection control valve module. 005-087 in the ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injection control valve.

Action

Check for an open circuit in the injection control valve.

  • Measure the resistance from pin 19 of the engine harness to pin 4 of the injection control valve identifier connector.
  • Measure the resistance from pin 36 of the engine harness to pin 3 of the injection control valve identifier connector.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injection control valve and all other sensors on the common ground..

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 36 of the engine harness connector to chassis ground.
  • Measure the resistance from pin 19 of the engine harness connector to chassis ground.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

Guided Step 2D - Check for short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM and all other sensors on the common ground.

Action

Check for short circuit from pin-to-pin.

  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 36 of the engine harness connector to all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 493 is inactive.
OK NOT OK

Fault Code 493 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the switch. |
 | STEP 1A. Check the resistance from the OEM harness connector pin 24 to ground. | Less than 10 ohms
 | STEP 1B. Check the resistance from the OEM harness connector pin 38 to ground. | More than 100k ohms
 | STEP 1C. Check the resistance from the OEM harness connector pin 24 to ground. | More than 100k ohms
 | STEP 1D. Check the resistance from the OEM harness connector pin 38 to ground. | Less than 10 ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness connector for damaged pins. | No damaged pins
 | STEP 2B. Check the OEM harness for a short circuit from pin 38 to all other pins. | More than 100k ohms
 | STEP 2C. Check the OEM harness for a short circuit from pin 24 to all other pins. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 497 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the switch.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1A - Check the resistance from the OEM harness connector pin 24 to ground.

Conditions

  • Turn keyswitch OFF.
  • Turn the multiple unit synchronization switch to the ON position.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance from the OEM harness connector pin 24 to ground.

  • Measure the resistance from pin 24 of the OEM ECM harness connector to engine block ground.
OK NOT OK

Less than 10 ohms

Replace the OEM harness/multiple unit synchronization switch. Refer to the OEM manual for the procedure.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check the resistance from the OEM harness connector pin 38 to ground.

Conditions

  • Turn keyswitch OFF.
  • Turn the multiple unit synchronization switch to the ON position.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance from the OEM harness connector pin 38 to ground.

  • Measure the resistance from pin 38 of the OEM ECM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness/multiple unit synchronization switch. Refer to the OEM manual for the procedure.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check the resistance from the OEM harness connector pin 24 to ground.

Conditions

  • Turn keyswitch OFF.
  • Turn the multiple unit synchronization switch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance from the OEM harness connector pin 24 to ground.

  • Measure the resistance from pin 24 of the OEM ECM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness/multiple unit synchronization switch. Refer to the OEM manual for the procedure.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check the resistance from the OEM harness connector pin 38 to ground.

Conditions

  • Turn keyswitch OFF.
  • Turn the multiple unit synchronization switch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance from the OEM harness connector pin 38 to ground.

  • Measure the resistance from pin 38 of the OEM ECM harness connector to engine block ground.
OK NOT OK

Less than 10 ohms

Replace the OEM harness/multiple unit synchronization switch. Refer to the OEM manual for the procedure.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check the OEM harness connector for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check the OEM harness for a short circuit from pin 38 to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check the OEM harness for a short circuit from pin 38 to all other pins.

  • Measure the resistance from pin 38 of the OEM ECM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the OEM harness for a short circuit from pin 24 to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check the OEM harness for a short circuit from pin 24 to all other pins.

  • Measure the resistance from pin 24 of the OEM ECM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Verify that Fault Code 497 is inactive.
OK NOT OK

Fault Code 497 inactive

Return to the troubleshooting step, or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2015


Associated Procedures

Cautions and Warnings

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant level sensor. Failure to do so can cause personal injury from heated coolant spray.
WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant level sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant level sensor. |
 | STEP 1A. Inspect the engine harness and coolant level sensor connector pins. | No damaged pins
 | STEP 1B. Check for active fault codes. | Fault Code 515 or 516 remains active
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to a voltage source. | Less than (+) 1.0 VDC
STEP 3. | Check the ECM supply voltage. |
 | STEP 3A. Measure the sensor supply voltage from the ECM. | (+) 4.5 to 5.25 VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 515 or 516 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the coolant level sensor.

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant level sensor. Failure to do so can cause personal injury from heated coolant spray.
Guided Step 1A - Inspect the engine harness and the coolant level sensor connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant level sensor.

Action

Inspect the engine harness and the coolant level sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the coolant level sensor, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-205 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Check for active fault codes.

  • Using INSITE™, read the fault codes.
OK NOT OK

Fault Code 515 or 516 remains active

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant level sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or the ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2B

Go to 4A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant level sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant level sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 37 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 27 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 49 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant level sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 37 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 49 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 27 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 2D - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant level sensor.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage from pin 37 of the engine harness connector to engine block ground.
  • Measure the voltage from pin 27 of the engine harness connector to engine block ground.
  • Measure the voltage from pin 49 of the engine harness connector to engine block ground.
OK NOT OK

Less than (+) 1.0 VDC

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check for the ECM voltage.

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant level sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 3A - Measure the sensor supply voltage from the ECM.

Conditions

  • Connect the engine harness to the ECM.
  • Disconnect the engine harness from the coolant level sensor.
  • Turn keyswitch to the ON position.

Action

Measure the sensor supply voltage from the ECM.

  • Measure the voltage from pin C of the coolant level sensor, harness side, to engine block ground.
OK NOT OK

(+) 4.5 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify that Fault Code 515 or 516 is inactive.
OK NOT OK

Fault Code 515 or 516 inactive

Return to troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3823254 - male three-way Metri-Pack connector test leadPart Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823254 - male three-way Metri-Pack connector test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit pin to pin. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM and engine harness connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM switch circuit. |
 | STEP 3A. Inspect the OEM switch. | No damaged pins
 | STEP 3B. Check resistance in position 2. | Less than 10 ohms
 | STEP 3C. Check resistance in position 3. | Between 1000 and 2000 ohms. Step 3C can only be performed if the OEM has provided a three-position switch.
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 524 inactive
 | STEP 4B. Clear the inactive fault code. | All faults codes cleared

Guided Step 1 - Check the engine harness.

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing connector seal.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Repair the engine harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Dry the connector using electrical contact cleaner, Part Number 3824510.

Go to 1B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823254 - male three-way Metri-Pack connector test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the OEM harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 24 of the engine harness connector to pin V of the OEM 23-pin connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 1C

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3823254 - male three-way Metri-Pack connector test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the OEM harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short to ground.

  • Measure the resistance from pin 24 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 1D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 1D - Check for a short circuit pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the OEM harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short to all other pins in the connector.

  • Measure resistance from pin 24 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the engine harness connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the OEM harness and the engine harness connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-207 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Repair the OEM harness. Refer to Procedure 019-207 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Dry the connector using electrical contact cleaner, Part Number 3824510.

Go to 2B

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the droop select switch.

Action

Check for an open circuit.

  • Measure the resistance from pin V of the OEM harness 23-pin connector to the appropriate pin of the droop select switch connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM 23-pin connector.
  • Disconnect the OEM harness from the droop select switch.

Action

Check for a short to ground.

  • Measure the resistance from pin V of the OEM harness 23-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM 23-pin connector.
  • Disconnect the OEM harness from the droop select switch.

Action

Check for a short from pin to pin.

  • Measure the resistance from pin V of the OEM harness 23-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM switch circuit.

Guided Step 3A - Inspect the OEM switch

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM switch circuit from the OEM.

Action

Inspect OEM switch pins for the following:

  • Bent or broken pins
  • Pushed back or extended pins
  • Corroded pins
  • Moisture in or on switch
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or the OEM switches, whichever have the damaged pins. Refer to the OEM troubleshooting and repair manual.

Go to 3B

Go to 4A

Guided Step 3B - Check resistance in position 2.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the 23-pin OEM harness connector.

Action

Check resistance in position 2.

  • Position the droop selection switch to the Number 2 position.
  • Measure the resistance from pin V of the OEM 23-pin connector to the engine block ground.
OK NOT OK

Less than 10 ohms

Repair or replace the switch or OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3C

Go to 4A

Guided Step 3C - Check resistance in position 3.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the 23-pin OEM harness connector.

Action

Check resistance in position 3.

  • Position the droop selection switch to the Number 3 position.
  • Measure the resistance from pin V of the OEM 23-pin connector to the engine block ground.

Step 3C can only be performed if the OEM has provided a three-position switch.

OK NOT OK

Between 1000 and 2000 ohms

Step 3C can only be performed if the OEM has provided a three-position switch.

Repair or replace the switch or OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 524 is inactive.
OK NOT OK

Fault Code 524 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Refer to the appropriate troubleshooting charts for any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test leadPart Number 3822917 - female Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM device. |
 | STEP 1A. Check for extra wires going to the OEM device. | No extra wires
 | STEP 1B. Clean the OEM device wire terminals or OEM connectors. | Terminals or OEM connectors clean
 | STEP 1C. Check OEM device resistance. | Refer to OEM specifications
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the ECM and the OEM harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit of the solenoid supply wire to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 527 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM device.

Guided Step 1A - Check for extra wires going to the OEM device.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check for extra wires.

Check for extra wires.
OK NOT OK

No extra wires

Remove the extra wires

Go to 1B

Go to 3A

Guided Step 1B - Clean the OEM wire terminals or OEM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the control wire from the OEM device.

Action

Clean the OEM device post and the wiring terminal or OEM connectors.

  • Clean the post of the device and the terminal or connectors for the control wire of the OEM harness.
OK NOT OK

Terminals or OEM connectors clean

Repair ring terminal, or replace the OEM device

  • Repair the ring terminal. Refer to Procedure 019-197 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the OEM device. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the OEM device resistance.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness.

Action

Check the shutoff resistance.

  • Measure the resistance from the OEM device to engine block ground.
OK NOT OK

Refer to OEM specifications

Repair the OEM device. Refer to OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Check the ECM and OEM harness connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Dry the connector by using an electrical contact cleaner, Part Number 3824510.

Go to 2B

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM device.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 on the ECM side of the OEM harness connector to the OEM device connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the OEM drive supply wire to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM device.

Action

Check for a short in the OEM device supply wire to ground.

  • Measure the resistance from pin 5 to engine block ground.
OK NOT OK

More than 100k ohms

Replace OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM device.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 to all other wires in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
OK NOT OK

Fault Code 527 inactive

Return to troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™, Part Number 3824801.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM switch circuit. |
 | STEP 2A. Inspect the OEM switch. | No damaged pins
 | STEP 2B. Check resistance in position 2. | Less than 10 ohms
 | STEP 2C. Check resistance in position 3. | Between 1000 and 2000 ohms. Step 2C can only be performed if the OEM has provided a three-position switch.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 528 inactive
 | STEP 3B. Clear the inactive fault code. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Dry the connector using electrical contact cleaner, Part Number 3824510.

Go to 1B

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the torque curve switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 39 of the OEM harness to the appropriate pin of the torque curve selection switch connector harness side.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 1C

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the torque curve select switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 39 of the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 1D

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the torque curve select switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 39 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM switch circuit.

Guided Step 2A - Inspect the OEM switch.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM switch circuit from the OEM.

Action

Inspect OEM switch pins for the following:

  • Bent or broken pins
  • Pushed back or extended pins
  • Corroded pins
  • Moisture in or on switch
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or the OEM switch, whichever has the damaged pins. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Check resistance in position 2.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Check resistance in position 2.

  • Position the torque curve switch to the number 2 position.
  • Measure the resistance from pin 39 of the OEM harness to the engine block ground.
OK NOT OK

Less than 10 ohms

Replace the switch. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check resistance in position 3.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Check resistance in position 3.

  • Position the torque curve switch to the number 3 position.
  • Measure the resistance from pin 39 of the OEM harness to the engine block ground.

Step 2C can only be performed if the OEM has provided a three-position switch.

OK NOT OK

Between 1000 and 2000 ohms

Step 2C can only be performed if the OEM has provided a three-position switch.

Replace the switch. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable fault code

  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 528 is inactive.
OK NOT OK

Fault Code 528 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Refer to the appropriate troubleshooting charts for any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test leadPart Number 3822917 - female Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid pin and harness damage use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM device. |
 | STEP 1A. Check for extra wires going to the OEM device. | No extra wires
 | STEP 1B. Clean the OEM device wire terminals or OEM connectors. | OEM device post clean
 | STEP 1C. Check the OEM device resistance. | Refer to OEM specifications
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness and the OEM 23-pin harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit of the OEM device supply wire to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the ECM and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short of the OEM device supply wire to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 529 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM device.

Guided Step 1A - Check for extra wires going to the OEM device.

Conditions

  • Turn keyswitch to the OFF position.

Action

Check for extra wires going to the OEM device.

Check for extra wires going to the OEM device.
OK NOT OK

No extra wires

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the OEM device wire terminals or OEM connectors.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the control wire from the OEM device.

Action

Clean the OEM device post and the wiring terminal.

  • Clean the post of the device and the terminal or OEM connectors for the device control wire of the OEM harness.
OK NOT OK

OEM device post clean

Repair ring terminal or replace the OEM device.

  • Repair the ring terminal. Refer to Procedure 019-197 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the OEM device. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the OEM device resistance.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM device.

Action

Check the OEM device resistance.

  • Measure the resistance from the OEM device to engine block ground.
OK NOT OK

Refer to OEM specifications

Replace the OEM device. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the engine harness and OEM 23-pin harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect OEM harness from the engine harness at the 23-pin connector.

Action

Check the engine harness and OEM harness connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM harness or the engine harness, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-207 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Repair the engine harness. Refer to Procedure 019-207 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Dry the connector by using an electrical contact cleaner, Part Number 3824510.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the OEM device.
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from pin J of the 23-pin connector on the OEM side to the OEM device connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin 3666271.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the OEM device supply wire to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM device.

Action

Check for a short in the OEM device supply wire to ground.

  • Measure the resistance from pin J of the 23-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 2D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM device.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between pin J in the OEM harness 23-pin connector and all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect engine harness from the ECM.

Action

Check the ECM and engine harness connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace engine harness. Refer to Procedure 019-043 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Replace the ECM. Refer Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.
  • Dry the connector by using an electrical contact cleaner, Part Number 3824510.

Go to 3B

Go to 4A

CAUTION

To avoid pin and harness damage use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/Cannon/Metri-Pack test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 on the ECM side of the engine harness connector to pin J of the OEM 23-pin connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-031 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short in the OEM device supply wire to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23-pin connector.

Action

Check for a short in the OEM device supply wire to ground.

  • Measure the resistance from the pin 1 to engine block ground.
OK NOT OK

More than 100k ohms

Replace engine harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 3D

Go to 4A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/Cannon/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 to all other wires in the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-071 in the Troubleshooting and Repair Manual, ISC Fuel System ISC Series Engines, Bulletin 3666271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
OK NOT OK

Fault Code 529 inactive

Return to troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™, Part Number 3824801.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2015


Associated Procedures

Cautions and Warnings

WARNING

When the transient suppressor is working normally, it will absorb heat and can become hot to touch. Wear gloves and exercise caution to reduce the possibility of injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male AMP/Deutsch/Metri-Pack test leadPart Number 3823993 - male Deutsch/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a pin-to-pin short circuit. | More than 100k ohms
STEP 3. | Check transient suppressor. |
 | STEP 3A. Inspect the transient suppressor and engine harness wires. | No damaged wires
 | STEP 3B. Check for open circuit in the transient suppressor circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 539 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other fault codes active

Troubleshoot other fault codes first.

Go to 2A

Appropriate fault code tree

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.
OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Call for pre-authorization to replace the ECM
  • Replace ECM.
  • Refer to Procedure 019-031.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the injection control valve.

Action

Check for an open circuit in the injection control valve.

  • Measure the resistance from pin 7 of the engine harness to pin 1 of the injection control valve connector.
  • Measure the resistance from pin 6 of the engine harness to pin 2 of the injection control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

OK NOT OK

Less than 10 ohms

Repair or replace engine harness. Refer to Procedure 019-043, Refer to Procedure 019-201, and Refer to Procedure 019-205.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the injection control valve solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the engine harness connector to chassis ground.
  • Measure the resistance from pin 7 of the engine harness connector to chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

OK NOT OK

More than 100k ohms

Repair or replace engine harness. Refer to Procedure 019-043, Refer to Procedure 019-201, and Refer to Procedure 019-205.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from pin 6 of the engine harness connector to all other pins except 7 in the connector.
  • Measure the resistance from pin 7 of the engine harness connector to all other pins except 6 in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

OK NOT OK

More than 100k ohms

Repair or replace engine harness. Refer to Procedure 019-043, Refer to Procedure 019-201, and Refer to Procedure 019-205.

Go to 3A

Go to 4A

Guided Step 3 - Check the transient suppressor.

Guided Step 3A - Inspect the transient suppressor and engine harness wires.

Conditions

  • Turn keyswitch to the OFF position.

Action

Inspect the transient suppressor and engine harness wires for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.
OK NOT OK

No damaged wires

Repair or replace engine harness. Refer to Procedure 019-043, Refer to Procedure 019-201, and Refer to Procedure 019-205.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the transient suppressor circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the injection control valve.

Action

Remove transient suppressor from engine harness by cutting the red and black wires extending from the suppressor.

  • Measure the resistance from the freshly cut red wire to pin 6 on the engine harness connector.
  • Measure the resistance from the freshly cut black wire to pin 7 of the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

OK NOT OK

Less than 10 ohms

Replace the transient suppressor. Refer to Procedure 019-184.

Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 539 is inactive.
OK NOT OK

Fault Code 539 inactive

Return to the troubleshooting steps or contact a Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ISS. |
 | STEP 1A. Inspect the ISS and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the ISS for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than +4.0-VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2A-4. Check for a pin to pin short circuit in the OEM harness. |
 | STEP 2A-5. Check the ECM voltage. |
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ISS.

Guided Step 1A - Inspect the ISS from the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Inspect the OEM harness and ISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the ISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin at the switch connector with the pedal or lever released and depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the ISS switch.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than +4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, of pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to return.

  • Measure the resistance from the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the resistance from the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ISS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ISS connector of the OEM harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the ISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check the ECM voltage.

  • Measure the voltage between the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage between the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than +4.0-VDC?
YES NO

Replace the ISS.

Refer to the OEM service manual.

  • Call for pre-authorization.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3A

Repair complete

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the OEM harness ECM connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ISS.

Refer to the OEM service manual.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever 3 times.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 551 code is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to erase the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2015


Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the NISS. |
 | STEP 1A. Inspect the NISS and harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the NISS for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than +4.0-VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2A-4. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 2A-5. Check the ECM voltage. |
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the NISS.

Guided Step 1A - Inspect the NISS and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Inspect the OEM harness and NISS from the OEM harness.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the NISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and the idle validation off-idle SIGNAL pin at the switch connector with the pedal or lever released and depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the NISS.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than +4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to return.

  • Measure the resistance from the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.
  • Measure the resistance from the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the NISS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the NISS connector of the OEM harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the NISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage between the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.
  • Measure the voltage between the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than +4.0-VDC?
YES NO

Replace the NISS.

Refer to the OEM service manual.

  • Call for pre-authorization.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3A

Repair Complete

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the OEM harness ECM connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever 3 times.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2015


Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SSS. |
 | STEP 1A. Inspect the SSS and harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the SSS for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than +4.0-VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2A-4. Check for a short circuit from pin to pin in the OEM harness. |
 | STEP 2A-5. Check the ECM voltage. |
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | More than 100k ohms.
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the SSS.

Guided Step 1A - Inspect the SSS and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.

Action

Inspect the OEM harness and SSS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the SSS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin at the switch connector with the pedal or lever released and depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the SSS.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than +4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to return.

  • Measure the resistance from the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.
  • Measure the resistance from the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Repair Complete

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the SSS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the SSS connector of the OEM harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a short circuit from pin to pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the SSS.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the SSS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage between the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.
  • Measure the voltage between the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than +4.0-VDC?
YES NO

Replace the SSS.

Refer to the OEM service manual.

  • Call for pre-authorization.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3A

Repair Complete

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit from pin to pin in the OEM harenss.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the OEM harness ECM connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the SSS.

Refer to the OEM service manual.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever 3 times.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete.

Appropriate troubleshooting steps

Last Modified: 04-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part No. 3822758 - male Deutsch/AMP/Metri-Pack test leadPart No. 3823993 - male Deutsch test leadPart No. 3823994 - female Deutsch test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part No. 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the transmission shift modulator. |
 | STEP 1A. Inspect and test the transmission shift modulator. | Transmission shift modulator within specifications
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 768 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the transmission shift modulator.

Guided Step 1A - Inspect and test the transmission shift modulator.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the transmission shift modulator.

Action

Check the transmission shift modulator for:

  • Damaged pins
  • Open or short circuits
  • Excessive current draw (power fan clutch directly from battery)
  • Perform this test in accordance with the OEM instructions.
OK NOT OK

Transmission shift modulator within specifications

Repair or replace the transmission shift modulatorRefer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the transmission shift modulator.
  • Disconnect the engine harness from the OEM harness connector.

Action

Inspect the OEM harness and connector for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pinsRepair or replace the OEM harness or the transmission shift modulator, whichever has damaged pins.

  • Replace the OEM harness. 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin No. 3666271.
  • Replace the transmission shift modulator. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part No. 3823993 - male Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the transmission shift modulator.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 on the OEM side to the transmission shift modulator.
OK NOT OK

Less than 10 ohms

Replace the OEM harness 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin No. 3666271.

Go to 2C

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part No. 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the transmission shift modulator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure resistance from pin 21 of the harness connector to ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness 019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin No. 3666271.

Go to 2D

Go to 3A

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part No. 3823993 - male Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the OEM harness from the transmission shift modulator relay.
  • Disconnect the engine harness from the OEM harness connector.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure resistance from pin 21 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness019-071 in the Troubleshooting and Repair Manual, ISC Fuel Systems ISC Series Engines, Bulletin No. 3666271.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify Fault Code 768 is inactive.
OK NOT OK

Fault Code 768 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy. | Sensor reading is correct
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 779 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch to the ON position.

Action

Verify the sensor accuracy with inspection of the OEM device.

  • Locate the OEM input device and what vehicle condition is being monitored with the sensor.Refer to the OEM vehicle manual for proper troubleshooting and repair of that component.
OK NOT OK

Sensor reading is correct

Sensor reading is incorrectReplace the sensor. Refer to OEM for procedure.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Using INSITE™, verify Fault Code 779 is inactive.
OK NOT OK

Fault Code 779 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Refer to OEM manual for specification
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2194 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn the keyswitch to the ON position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical pressure gauge to the engine.
  • Connect INSITE™ to the vehicle datalink.
  • Start the engine, and compare the pressure sensor reading on the INSITE™ monitor screen to the reading on the mechanical pressure gauge.

Increase the engine rpm to make it easier to see differences in readings.
OK NOT OK

Refer to OEM manual for specification. Locate and repair the cause of high pressure.

See Shop Talk in the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245 for correct procedures.

Replace sensor. Refer to the OEM manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or damage in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 48 of the OEM harness connector to the corresponding pin of the OEM switch connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 48 of the OEM harness connector, OEM side, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 48 of the OEM harness connector, OEM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ to verify Fault Code 2194 is inactive.
OK NOT OK

Fault Code 2194 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jun-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy by inspecting the OEM device. | Refer to the OEM manual for specification
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and 23-pin connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2195 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy by inspecting the OEM device.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy by inspecting the OEM device.

  • Locate the OEM input device and what vehicle condition is being monitored with the sensor.
OK NOT OK

Refer to the OEM manual for specification

Replace sensor. Refer to the OEM manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and 23-pin connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the OEM harness and 23-pin connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or damage in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for an open circuit.

  • Measure the resistance from pin U of the 23-pin OEM harness connector to the corresponding pin of the OEM switch connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin U of the 23-pin OEM harness connector, OEM side, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin U of the 23-pin OEM harness connector, OEM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or damage in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 16 of the engine harness connector to pin U of the 23-pin OEM harness connector, engine harness side.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 16 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 16 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 2195 is inactive.
OK NOT OK

Fault Code 2195 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jun-2015


FAULT CODE 2559 - Transmission ECU to ECM Communication - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 2559 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit ( VECU ) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration matches the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the service data link harness. | Resistance between 54 to 66 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM data link harness. | Resistance between 54 to 66 ohms?
 | STEP 5C. Check for a short circuit in the ECM data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 2559 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2559 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

NOTE: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration matches the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the service data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the data link (+) wire and the data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 to 66 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the data link (+) wire and the data link (-) wire on the appropriate Cummins® ECM OEM connection to the data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 to 66 ohms?
YES NO
No Repair

An open or short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the data link (+) wire and the data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 54 to 66 ohms between the data link (+) and the data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2559 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jun-2016


INDEX
71-ifctabl.htm

71-fc111.htm

71-t05-111.htm

71-fc115.htm

71-t05-115.htm

71-fc121.htm

71-t05-121.htm

71-fc122.htm

71-t05-122.htm

71-fc123.htm

71-t05-123.htm

71-fc124.htm

71-t05-124.htm

71-fc131.htm

71-t05-131.htm

71-fc132.htm

71-t05-132.htm

71-fc133.htm

71-t05-133.htm

71-fc134.htm

71-t05-134.htm

71-fc135.htm

71-t05-135.htm

71-fc141.htm

71-fc141sn.htm

71-t05-141sn.htm

71-fc141sw.htm

71-t05-141sw.htm

71-fc143.htm

71-fc143sn.htm

71-t05-143sn.htm

71-fc143sw.htm

71-t05-143sw.htm

71-fc144.htm

71-t05-144.htm

71-fc145.htm

71-t05-145.htm

71-fc146.htm

71-t05-146.htm

71-fc147.htm

71-t05-147.htm

71-fc148.htm

71-t05-148.htm

71-fc151.htm

71-t05-151.htm

71-fc152.htm

71-t05-152.htm

71-fc153.htm

71-t05-153.htm

71-fc154.htm

71-t05-154.htm

71-fc184.htm

71-t05-184.htm

71-fc191.htm

71-t05-191.htm

71-fc221.htm

71-t05-221.htm

71-fc222.htm

71-t05-222.htm

71-fc234.htm

71-t05-234.htm

71-fc235.htm

71-t05-235.htm

71-fc241.htm

71-t05-241.htm

71-fc242.htm

71-t05-242.htm

71-fc243.htm

71-fc243isc.htm

71-t05-243isc.htm

71-fc243isl.htm

71-t05-243isl.htm

71-fc245.htm

71-t05-245.htm

71-fc263.htm

71-t05-263.htm

71-fc265.htm

71-t05-265.htm

71-fc268.htm

71-t05-268.htm

71-fc271.htm

71-t05-271.htm

71-fc272.htm

71-t05-272.htm

71-fc273.htm

71-t05-273.htm

71-fc274.htm

71-t05-274.htm

71-fc275.htm

71-t05-275.htm

71-fc276.htm

71-t05-276.htm

71-fc277.htm

71-t05-277.htm

71-fc278.htm

71-t05-278.htm

71-fc279.htm

71-t05-279.htm

71-fc281.htm

71-t05-281.htm

71-fc282.htm

71-t05-282.htm

71-fc283.htm

71-t05-283.htm

71-fc284.htm

71-t05-284.htm

71-fc285.htm

71-t05-285.htm

71-fc286.htm

71-t05-286.htm

71-fc296.htm

71-t05-296.htm

71-fc297.htm

71-t05-297.htm

71-fc298.htm

71-t05-298.htm

71-fc319.htm

71-t05-319.htm

71-fc328.htm

71-t05-328.htm

71-fc329.htm

71-t05-329.htm

71-fc349.htm

71-t05-349.htm

71-fc352.htm

71-t05-352.htm

71-fc381.htm

71-t05-381.htm

71-fc382.htm

71-t05-382.htm

71-fc385.htm

71-t05-385.htm

71-fc387.htm

71-t05-387.htm

71-fc415.htm

71-fc415sn.htm

71-t05-415sn.htm

71-fc415sw.htm

71-t05-415sw.htm

71-fc418.htm

71-t05-418.htm

71-fc422.htm

71-t05-422.htm

71-fc429.htm

71-t05-429.htm

71-fc431.htm

71-t05-431.htm

71-fc432.htm

71-t05-432.htm

71-fc433.htm

71-t05-433.htm

71-fc434.htm

71-t05-434.htm

71-fc441.htm

71-t05-441.htm

71-fc442.htm

71-t05-442.htm

71-fc443.htm

71-t05-443.htm

71-fc444.htm

71-t05-444.htm

71-fc449.htm

71-t05-449.htm

71-fc451.htm

71-t05-451.htm

71-fc452.htm

71-t05-452.htm

71-fc456.htm

71-t05-456.htm

71-fc488.htm

71-t05-488.htm

71-fc489.htm

71-t05-489.htm

71-fc493.htm

71-t05-493.htm

71-fc497.htm

71-t05-497.htm

71-fc515.htm

71-t05-515.htm

71-fc516.htm

71-t05-516.htm

71-fc524.htm

71-t05-524.htm

71-fc527.htm

71-t05-527.htm

71-fc528.htm

71-t05-528.htm

71-fc529.htm

71-t05-529.htm

71-fc539.htm

71-t05-539.htm

71-fc551.htm

71-fc551iss.htm

71-t05-551iss.htm

71-fc551niss.htm

71-t05-551niss.htm

71-fc551sss.htm

71-t05-551sss.htm

71-fc768.htm

71-t05-768.htm

71-fc779.htm

71-t05-779.htm

71-fc2194.htm

71-t05-2194.htm

71-fc2195.htm

71-t05-2195.htm

71-fc2559.htm

71-t05-2559.htm