ISM, QSM11

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module (ECM) Microprocessor

FAULT CODE 111

Electronic Control Module (ECM) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the ECM related to the memory hardware failures or internal ECM voltage supply circuits. | Engine will not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the fuel pump side of the engine and can be located either above the air compressor (high-mount) or above the starter (low-mount).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 02-Sep-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Position Sensor Circuit

FAULT CODE 115

Engine Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2/2 LAMP: Red SRT: | No engine speed signal detected at both engine position sensor circuits. | Engine will shut down and will not start.
Engine Position Sensor Circuit

Circuit Description

The engine position sensor monitors the engine position and the engine speed, then passes this information to the electronic control module (ECM) through the sensor harness.

Component Location

The engine position sensor is located above the accessory drive.

Shop Talk

  • If the fault occurs only at a certain engine temperature, check the engine position sensor circuit while the engine is at that particular temperature.
  • Check the camshaft end play to make sure that the camshaft gear is not moving too far away from the end of the engine position sensor.
  • Check for moisture in the sensor harness connector at the ECM.
  • Possible causes of this fault code include a damaged engine position sensor, short circuit, or an open circuit.
Refer to Troubleshooting Fault Code t05-115

Last Modified: 02-Sep-2010


Engine Position Sensor Circuit

FAULT CODE 121

Engine Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10/10 LAMP: Yellow SRT: | No engine speed signal detected at one of the engine position sensor circuits. | None on performance.
Engine Position Sensor Circuit

Circuit Description

The engine position sensor monitors the engine position and the engine speed and passes this information to the electronic control module (ECM) through the sensor harness.

Component Location

The engine position sensor is located above the accessory drive.

Shop Talk

  • If the fault occurs only at a certain engine temperature, check the engine position sensor circuit while the engine is at that particular temperature.
  • Check the camshaft end play to make sure the camshaft gear is not moving too far away from the end of the engine position sensor.
  • Check for moisture in the sensor harness connector at the ECM.
  • Possible causes for this fault include a damaged engine position sensor, a short circuit to ground, or an open circuit.
Refer to Troubleshooting Fault Code t05-121

Last Modified: 02-Sep-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the intake manifold pressure sensor circuit. | Derate in power output of the engine.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located in the air intake manifold toward the front of the engine.

Shop Talk

  • Determine if engine is being overfueled.
  • Confirm that the correct intake manifold pressure sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air.
  • Inspect the intake manifold pressure sensor circuit for signs of tampering. Remove any extra wires from the circuit.
Refer to Troubleshooting Fault Code t05-122

Last Modified: 02-Sep-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the intake manifold pressure sensor circuit. | Derate in power output of the engine.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located in the air intake manifold toward the front of the engine.

Shop Talk

  • Check for high restriction in the intake air manifold due to a shutdown device in the manifold if the vehicle is equipped with one. Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature. Removing it can cause severe personal injury or death.
  • Check for installation of a torque-limiting device breakout wiring harness. Temporarily remove the torque-limiting device from the engine harness and install the intake manifold pressure sensor directly to the engine harness. If Fault Code 123 becomes inactive, inspect the torque-limiting device.
Refer to Troubleshooting Fault Code t05-123

Last Modified: 02-Sep-2010


Accelerator Position Sensor Circuit

FAULT CODE 131

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | High voltage detected at accelerator position sensor. | Severe derate (power and speed). Limp home power only.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: + 5-VDC supply, return ground, and signal.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensor checks look good, then replace the accelerator position sensor, and the idle validation switch circuit wires between the accelerator pedal and the ECM with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from entering the operator area.

Note: The three wires in the accelerator position sensor circuit must be twisted together. The same applies for the three wires in the idle validation switch circuit.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 02-Sep-2010


Accelerator Position Sensor Circuit

FAULT CODE 132

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at the accelerator position sensor circuit. | Severe derate (power and speed). Limp home power only.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: + 5-VDC supply, return, and signal.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

  • Check for external circuits hooked into the accelerator position sensor circuit and for tampering in the circuit.
  • If all the wiring and the sensor checks are good, replace the accelerator position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires. If the fault code goes away, replace the OEM harness. Seal openings in the bulkhead to prevent toxic and noxious fumes from entering the operator area.
  • Verify that the three accelerator position sensor circuit wires are twisted together. Verify that the three idle validation switch circuit wires are twisted together.
Refer to Troubleshooting Fault Code t05-132

Last Modified: 02-Sep-2010


Remote Throttle Position Sensor Circuit

FAULT CODE 133

Remote Throttle Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 974 FMI: 3/3 LAMP: Red SRT: | High voltage detected at the remote throttle position signal circuit. | None on performance if remote throttle is not used.
Remote Throttle Position Sensor Circuit

Circuit Description

The remote throttle pedal provides the driver's throttle command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote throttle pedal location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The throttle position sensor is a potentiometer. The throttle position sensor resistance specifications are:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, Depressed = 200 to 1500 ohms

Note: If the throttle or throttle position sensor is replaced, or if a calibration download is performed, cycle the throttle pedal (turn keyswitch on) through its complete travel three times. This procedure calibrates the new throttle with the ECM.

  • The remote throttle enable switch must be turned on for the remote throttle to operate.
  • Possible causes of this fault code include an open circuit in the return wire, short circuit to + 5 VDC or + 12 VDC, defective remote throttle position sensor, or a failed ECM power supply.
Refer to Troubleshooting Fault Code t05-133

Last Modified: 02-Sep-2010


Remote Throttle Position Sensor Circuit

FAULT CODE 134

Remote Throttle Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at the remote throttle position signal circuit. | None on performance if remote throttle is not used.
Remote Throttle Position Sensor Circuit

Circuit Description

The remote throttle pedal provides the driver's throttle command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote throttle pedal location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The remote throttle position sensor is a potentiometer. The throttle position sensor resistance specifications are:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, Depressed = 200 to 1500 ohms

Note: If the remote throttle position sensor is replaced, or after a calibration download is performed, cycle the throttle pedal (turn keyswitch on) through its complete travel three times. This procedure calibrates the new remote throttle with the ECM.

  • The remote throttle enable switch must be on for the remote throttle to operate.
  • Possible causes of this fault code include an open circuit in the supply wire, short circuit to ground in the supply or signal wires, defective remote throttle position sensor, or a failed ECM power supply.
Refer to Troubleshooting Fault Code t05-134

Last Modified: 02-Sep-2010


Oil Pressure Sensor Circuit

FAULT CODE 135

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the oil pressure circuit. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.

Refer to Troubleshooting Fault Code t05-135

Last Modified: 02-Sep-2010


Engine Oil Pressure/Temperature Sensor Circuit

FAULT CODE 141

Engine Oil Pressure/Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the oil pressure circuit. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

If Fault Code 143 or 415 is present, the problem is probably base engine related.

Refer to Troubleshooting Fault Code t05-141

Last Modified: 07-Aug-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
ISM - Engine Oil Rifle Pressure 1

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor SUPPLY 1 circuit. The ECM also provides a ground on the sensor RETURN circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor SIGNAL circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

If the ECM detects low signal voltage indicating a low engine oil pressure, this fault code sets.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section .E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is less than 55 kPa [8 psi] at 800 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate is issued by the ECM limiting the power output of the engine.

Conditions for Clearing the Fault Code

The ECM will turn OFF the amber CHECK ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code t05-143

Last Modified: 07-Oct-2010


Coolant Temperature Sensor Circuit

FAULT CODE 144

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the coolant temperature circuit. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located in front of the turbocharger.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your reading to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-144

Last Modified: 02-Sep-2010


Coolant Temperature Sensor Circuit

FAULT CODE 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the coolant temperature circuit. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located in front of the turbocharger.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your reading to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145

Last Modified: 02-Sep-2010


Frequency Throttle Circuit

FAULT CODE 147 (Industrial)

Frequency Throttle Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 147 PID: P091 SPN: 91 FMI: 8/8 LAMP: Red SRT: | A frequency of less than 100 Hz has been detected at frequency throttle signal pin 30 of the engine harness. | Calibration-dependent power and speed derate.
Frequency Throttle Circuit

Circuit Description

The frequency throttle provides the driver's throttle command to the ECM through the OEM harness and the engine harness. The ECM uses this signal to determine the fueling command.

Component Location

Throttle location varies with each OEM. Refer to the OEM manual.

Shop Talk

The frequency throttle can either be used in conjunction with a voltage throttle or by itself.

Refer to Troubleshooting Fault Code t05-147

Last Modified: 02-Sep-2010


Frequency Throttle Circuit

FAULT CODE 148 (Industrial)

Frequency Throttle Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 148 PID: P091 SPN: 91 FMI: 8/8 LAMP: Red SRT: | A frequency of more than 100 Hz was detected at the frequency throttle signal pin of the actuator harness connector at the ECM. | Calibration-dependent power and speed derate.
Frequency Throttle Circuit

Circuit Description

The frequency throttle provides the driver's throttle command to the electronic control module (ECM) through the OEM engine harness and the actuator harness. The ECM uses this signal to determine the fueling command.

Component Location

Throttle location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The frequency throttle can be used either in conjunction with a voltage throttle or by itself.

Refer to Troubleshooting Fault Code t05-148

Last Modified: 02-Sep-2010


Intake Manifold Temperature Sensor Circuit

FAULT CODE 153

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the intake manifold temperature sensor circuit. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for intake manifold temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the engine intake air. The intake manifold temperature signal is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The intake manifold temperature sensor is located on the top front half of the intake manifold.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your reading to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153

Last Modified: 02-Sep-2010


Intake Manifold Temperature Sensor Circuit

FAULT CODE 154

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the intake manifold temperature sensor circuit. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for intake manifold temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor monitors the temperature of the engine intake air for the ECM. The ECM uses the intake manifold temperature signal for the engine protection system, timing, and fueling control.

Component Location

The intake manifold temperature sensor is located on the top half of the intake manifold, at the front.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your reading to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154

Last Modified: 02-Sep-2010


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine power derate.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the intake manifold temperature was greater than 105°C [221°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 16-Oct-2018


Sensor Voltage Supply

FAULT CODE 187

Sensor Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 620 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the ECM voltage supply line to some sensors (VSEN 2 supply). | Engine will run derated. No engine protection for oil pressure or coolant level.
Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies each of these sensors with +5-VDC. If the supply line to any sensor is damaged, the sensor will not work correctly.

Component Location

Fuel inlet restriction sensor is located on the fuel pump inlet.

Oil pressure/temperature sensor is located in front of the air compressor.

Oil level sensor is located in the oil pan.

Wet tank pressure sensor is located on the air compressor

Coolant level sensor. Refer to the OEM manual for proper location.

Top 2 transmission position sensor - located on the transmission if vehicle has a Spicer™ Top 2 Automate transmission. Refer to the OEM manual for proper location.

Shop Talk

Low voltage on the sensor + 5-volt supply line will be caused by a short to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time, unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code t05-187

Last Modified: 02-Sep-2010


ICON™ Lamp

FAULT CODE 198

ICON™ Lamp

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 198 PID: S122, 3 SPN: 612 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the ICON™ lamp circuit when low voltage was expected by the ECM. | The ICON™ system will be disabled. Only mandatory shutdown will be enabled.
ICON™ Lamp Circuit

Circuit Description

The ICON™ lamp circuit illuminates the ICON™ lamp to indicate when the ICON™ system is active. In addition, ICON™ fault codes will be flashed out on this lamp. The lamp circuit requires a specific flash timing (on/off timing). If the on/off voltage is incorrect, ICON™ will be disabled. The lamp circuit must be functional to enable ICON™.

Component Location

The ICON™ lamp is located in the vehicle cab on the dash panel.

Shop Talk

This fault indicates a short circuit to battery voltage. The ICON™ lamp will only flash out the active fault codes.

Refer to Troubleshooting Fault Code t05-198

Last Modified: 02-Sep-2010


ICON™ Lamp

FAULT CODE 199

ICON™ Lamp

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 199 PID: S122, 4 SPN: 612 FMI: 4 LAMP: Yellow SRT: | Less than 6 VDC (low voltage) detected at the ICON™ lamp circuit when high voltage was expected by the ECM. | The ICON™ system will be disabled. Only mandatory shutdown will be enabled.
ICON™ Lamp Circuit

Circuit Description

The ICON™ lamp circuit illuminates the ICON™ lamp to indicate when the ICON™ system is active. In addition, ICON™ active fault codes will be flashed out on this lamp. The lamp circuit requires a specific flash timing (on/off timing). If the on/off voltage is incorrect, ICON™ will be disabled. The lamp circuit must be functional to enable ICON™.

Component Location

The ICON™ lamp is located in the vehicle cab on the dash panel.

Shop Talk

This fault indicates a short circuit to ground or an open circuit.

Refer to Troubleshooting Fault Code t05-199

Last Modified: 02-Sep-2010


Oil Temperature Sensor Circuit

FAULT CODE 212

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the oil temperature circuit. | No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

Sensor resistance varies with temperature. Compare your reading to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-212

Last Modified: 02-Sep-2010


Oil Temperature Sensor Circuit

FAULT CODE 213

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the oil temperature circuit. | No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition could be incurred, possibly leading to shutdown.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your readings with this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-213

Last Modified: 02-Sep-2010


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 FMI: 0/0 LAMP: Red SRT: | Engine oil temperature signal indicates engine oil temperature above threshold for high oil temperature. | Engine will shut down.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The combination oil pressure and oil temperature sensor is located on the cylinder block directly above the accessory drive.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool, or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool, or equivalent, can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214

Last Modified: 21-Jun-2019


Wet Tank Pressure Sensor Circuit

FAULT CODE 216

Wet Tank Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 216 PID: P046 SPN: 46 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at air compressor wet tank pressure signal circuit. | Air compressor will run continuously.
Wet Tank Pressure Sensor Circuit

Circuit Description

The wet tank pressure sensor provides the wet tank pressure signal to the electronic control module (ECM).

Component Location

The wet tank pressure sensor is located on the air compressor. It is part of the electronic air governor and is nonserviceable.

Shop Talk

This fault indicates that signal pin 19 on the ECM sensor port now has a short circuit to at least +5 VDC.

Refer to Troubleshooting Fault Code t05-216

Last Modified: 02-Sep-2010


Wet Tank Pressure Sensor Circuit

FAULT CODE 217

Wet Tank Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 217 PID: P046 SPN: 46 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at air compressor wet tank pressure sensor. | Air compressor will run continuously.
Wet Tank Pressure Sensor Circuit

Circuit Description

The wet tank pressure sensor provides the wet tank pressure signal to the electronic control module (ECM).

Component Location

The wet tank pressure sensor is located on the air compressor. It is part of the electronic air governor and is nonserviceable.

Shop Talk

This fault indicates that signal pin 19 on the ECM sensor port has a short circuit to ground.

Refer to Troubleshooting Fault Code t05-217

Last Modified: 02-Sep-2010


Wet Tank Pressure Sensor Circuit

FAULT CODE 218

Wet Tank Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 218 PID: P046 SPN: 46 FMI: 2/2 LAMP: Yellow SRT: | Voltage at wet tank pressure signal indicates wet tank pressure is too high or too low. | Air compressor will run continuously.
Wet Tank Pressure Sensor Circuit

Circuit Description

The wet tank pressure sensor provides the wet tank pressure sensor signal to the electronic control module (ECM).

Component Location

The wet tank pressure sensor is located on the air compressor. It is part of the electronic air governor and is nonserviceable.

Shop Talk

This fault indicates that the pressure in the wet tank is lower or higher than specifications.

Refer to Troubleshooting Fault Code t05-218

Last Modified: 02-Sep-2010


Ambient Air Pressure Sensor Circuit

FAULT CODE 221

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the ambient air pressure sensor circuit. | Derate in power output of engine.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor monitors atmospheric pressure and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The ambient air pressure sensor is located below the ECM.

Shop Talk

Monitor the ambient air pressure reading with a service tool to confirm that the pressure reading matches the actual air pressure.

Refer to Troubleshooting Fault Code t05-221

Last Modified: 02-Sep-2010


Ambient Air Pressure Sensor Circuit

FAULT CODE 222

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the ambient air pressure circuit. | Derate in power output of engine.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor monitors atmospheric pressure and passes information to the electronic control module (ECM) through the sensor harness.

Component Location

The ambient air pressure sensor is located below the ECM.

Shop Talk

Monitor the ambient air pressure reading with a service tool to confirm that the pressure reading matches the actual air pressure.

Refer to Troubleshooting Fault Code t05-222

Last Modified: 02-Sep-2010


Burn Valve Solenoid Fault

FAULT CODE 223

Burn Valve Solenoid Fault

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S085 SPN: 1265 FMI: 4/4 LAMP: Yellow SRT: | Incorrect voltage detected at the Centinel™ actuator circuit by the ECM. | None on performance. Centinel™ deactivated.
Burn Valve Solenoid

Circuit Description

The burn valve solenoid controls the flow of oil into the fuel drainline during the burn cycle.

Component Location

The burn valve solenoid is on top of the oil control valve. The oil control valve is on the left side of the engine below the fuel delivery housing.

Refer to Troubleshooting Fault Code t05-223

Last Modified: 02-Sep-2010


Sensor Voltage Supply

FAULT CODE 227

Sensor Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 620 FMI: 3 LAMP: Yellow SRT: | High voltage detected on the electronic control module (ECM) voltage supply line to some sensors. (VSEN 2) | Engine will run derated. No engine protection for oil pressure and coolant level.
Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies each of these sensors with + 5 VDC. If the supply wire to any sensor is damaged, the sensor will not work correctly.

Note: In the above picture, the circuits for the wet tank pressure sensor/air compressor and Top 2 Gear Position wires are labeled differently on the industrial wiring diagram. The equivalent differences in the industrial labels are as follows:

  • Wet Tank Pressure Sensor + 5-Volt Supply = OEM Pressure Supply (Pins 1 to 18)
  • Wet Tank Pressure Signal = OEM Pressure Signal (Pins 3 to 19)
  • Wet Tank Pressure Return = OEM Pressure Return (Pins 2 to 20)
  • Air Compressor Actuator = Switched Output A (Pins 5 to 14)
  • Air Compressor Return = Spare (Pins 6 to 11)
  • Top 2 Gear Position + 5-Volt Supply = Spare (Pins 14 to 19)
  • Top 2 Gear Position Input = Spare (Pins 15 to 18)
  • Top 2 Gear Position Return = Spare (Pins 16 to 17)

Component Location

Fuel inlet restriction sensor is located on the fuel pump inlet.

Oil pressure/temperature sensor is located in front of the air compressor.

Oil level sensor is located in the oil pan.

Wet tank pressure sensor is located on the air compressor.

Coolant level sensor. Refer to OEM for proper location.

Top 2 transmission position sensor - located on the transmission if vehicle has a Spicer™ Top 2 Automate transmission. Refer to OEM for proper location.

Shop Talk

High voltage on the sensor + 5-VDC supply line will be caused by a short to battery in the supply line or a short between an actuator wire and the supply wire.

Refer to Troubleshooting Fault Code t05-227

Last Modified: 02-Sep-2010


Vehicle Speed Sensor Circuit

FAULT CODE 2291

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2291 PID: SPN: FMI: LAMP: Yellow SRT: | More than 0-mph vehicle speed detected when ICON™ is enabled. | The ICON™ system will be disabled. Only mandatory shutdown will be enabled.
Integrated Idle ICON™ Circuit

Circuit Description

The ECM monitors vehicle speed when ICON™ is enabled for safety violation. The ECM reviews data through the magnetic pickup. This fault code indicates that vehicle speed has been detected.

Component Location

The vehicle speed sensor circuit is located on the vehicle transmission side.

Shop Talk

This fault indicates a vehicle speed greater than 0 mph when ICON™ is enabled. Typically, a loose or faulty ground will generate noise in the vehicle speed sensor circuit.

Refer to Troubleshooting Fault Code t05-2291

Last Modified: 02-Sep-2010


Engine Overspeed

FAULT CODE 234

Engine Overspeed

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0 LAMP: Red SRT: | Engine speed signal indicates engine speed is greater than 2650 rpm. | Fuel shutoff valve is closed until the engine speed drops. The fuel shutoff valve will open when engine speed falls below 2000 rpm.
Engine Overspeed Circuit

Circuit Description

The engine speed/position sensor provides engine speed and position information to the electronic control module (ECM) through the engine harness.

Component Location

The engine speed/position sensor is located above the air compressor.

Shop Talk

Possible causes of this fault code include external fuel sources drawn into the intake air passage, reverse powering (motoring) of the engine, or tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks.

  • Inspect the engine speed/position sensors for damage or tampering.
Refer to Troubleshooting Fault Code t05-234

Last Modified: 02-Sep-2010


Engine Coolant Level - Engine Protection

FAULT CODE 235

Engine Coolant Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant level signal at pin 22 of the sensor harness connector indicates coolant level is below the normal range. | Progressive power and speed derate with increasing time after alert. If engine protection shutdown is enabled, engine will shut down 30 seconds after the engine protection lamp starts flashing.
Engine Coolant Level - Engine Protection

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness. Because this sensor is complex, do not use a multimeter to check it. If the radiator coolant level drops below a certain level, a progressive power and/or speed derate will occur. Engine can shut down if the engine protection shutdown feature is enabled.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and can vary in location.

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the Weather-Pack four-way connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle turns a corner.
Refer to Troubleshooting Fault Code t05-235

Last Modified: 02-Sep-2010


Multiple Unit Synchronization (soft-coupled Marine)

FAULT CODE 237

Multiple Unit Synchronization (soft-coupled Marine)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 237 PID: S030 SPN: 644 FMI: 2/2 LAMP: Yellow SRT: 00-395 | Duty cycle of the throttle input signal to the primary or secondary engine for multiple unit synchronization is less than 3 percent or more than 97 percent. | All engines (primary and secondary) are shut down with increasing time after alert if hard-coupled. Only secondary engines are shut down with increasing time after alert if soft-coupled.
Multiple Unit Synchronization Circuit, Soft-Coupled Marine

Circuit Description

The primary engine broadcasts the engine speed control message over the SAE J1939 datalink to all secondary engines. Jumper wires are used to configure an engine as a primary engine or as a secondary engine. Only one engine can be configured as the primary engine. Up to 5 engines can be configured as secondary engines on the same SAE J1939 datalink.

Component Location

The SAE J1939 datalink and jumper wire connections are part of the OEM harness. Location of the jumper wire connections vary by the OEM. Refer to the OEM manual for component location.

Shop Talk

The configuration of the 3-pin inputs to the electronic control module (ECM) on the OEM harness determines if an engine is a primary or secondary engine. See the matrix provided. To activate a pin, the pin must be grounded. To deactivate a pin, the pin must be an open circuit.

Pin 3 | Pin 2 | Pin 1 | Primary/Secondary
INACTIVE | INACTIVE | INACTIVE | Default to Primary
INACTIVE | INACTIVE | ACTIVE | Primary
INACTIVE | ACTIVE | INACTIVE | Secondary 0
INACTIVE | ACTIVE | ACTIVE | Secondary 1
ACTIVE | INACTIVE | INACTIVE | Secondary 2
ACTIVE | INACTIVE | ACTIVE | Secondary 3
ACTIVE | ACTIVE | INACTIVE | Secondary 4
ACTIVE | ACTIVE | ACTIVE | Default to Primary

Verify that the keyswitch is on for all multiple unit synchronization engines. Verify that no throttle faults are active.

Verify that the SAE J1939 datalink is active and communicates correctly with INSITE™ electronic service tool on all engines. If any ECM will not communicate over the SAE J1939 datalink. Refer to Procedure 022-999 in Section F.

Refer to Troubleshooting Fault Code t05-237

Last Modified: 02-Sep-2010


Vehicle Speed Sensor Circuit

FAULT CODE 241

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2/2 LAMP: Yellow SRT: | The ECM lost the vehicle speed signal. | Engine speed limited to Maximum Engine Speed without Vehicle Speed Sensor parameter value. Cruise control, gear-down protection, and road speed governor will not work (automotive only).
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor (VSS) uses two separate coils of wire to count gear teeth as they pass in front of the sensor. One coil is used by the electronic control module (ECM) to sense vehicle speed. The other coil is sometimes used to send a vehicle speed signal to the speedometer.

Component Location

The VSS is installed in the rear of the transmission.

Shop Talk

  • Disconnect the vehicle speed sensor connector that connects to the OEM speedometer, or trip recorder, and move the truck. If the fault goes inactive, there is probably electrical noise being fed into the vehicle speed sensor circuit from the OEM device.
  • Verify the vehicle speed sensor wires in the OEM harness are twisted pairs.
Refer to Troubleshooting Fault Code t05-241

Last Modified: 02-Sep-2010


Vehicle Speed Sensor Circuit

FAULT CODE 242

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 84 FMI: 10/10 LAMP: Yellow SRT: | Invalid or inappropriate vehicle speed signal detected. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to maximum engine speed without vehicle speed sensor parameter value. Cruise control, progressive shifting, gear-down protection, and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor (VSS) uses two separate coils of wire to count gear teeth as they pass in front of the sensor. One coil is used by the ECM to sense vehicle speed. The other is sometimes used by the OEM to send a vehicle speed signal to the speedometer.

Component Location

The vehicle speed sensor is installed in the rear of the transmission.

Shop Talk

  • Verify that the feature settings for VSS Anti-tampering (Fault Code 242), Application Type, and Automatic Transmission are set correctly. If any of these are set incorrectly, Fault Code 242 could occur erroneously.

Note: Driving techniques, such as driving for extended periods of time in lower gears, could log Fault Code 242.

  • Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.
  • Interview the driver to discover what occurred when the fault code was logged. Explain the driver actions that can cause Fault Code 242 to be logged.
  • When deactivating the fault, verify that the vehicle is stopped and the engine is shut down.
  • Verify that the keyswitch has been cycled and has remained in the ON position for 30 seconds after the invalid signal has been corrected. This fault will remain active until the keyswitch is cycled and the ECM sees zero vehicle speed and zero engine speed for 30 seconds.
Refer to Troubleshooting Fault Code t05-242

Last Modified: 02-Sep-2010


Engine Fan Clutch Supply Circuit

FAULT CODE 245

Engine Fan Clutch Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4/4 LAMP: Yellow SRT: | Less than 6 VDC detected at fan clutch when on. Indicates an excessive current draw from the electronic control module (ECM) or a faulty ECM output circuit. | The fan can stay on all the time.
Engine Fan Clutch Supply Circuit

Circuit Description

The fan clutch solenoid is a device used by the ECM to control the engine fan by sending a signal to open or close the fan clutch solenoid.

Component Location

Refer to an OEM diagram for the location of the fan clutch solenoid.

Shop Talk

Possible cause for this fault code:

  • ECM fan clutch supply has a short circuit to ground.
Refer to Troubleshooting Fault Code t05-245

Last Modified: 02-Sep-2010


Ambient Air Temperature Sensor Circuit

FAULT CODE 249

Ambient Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the ambient air temperature circuit. | No effect on engine performance. The idle shutdown ambient air temperature override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override (automotive only).
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the ambient air. The ambient air temperature signal is used by the ECM for the idle shutdown ambient air temperature override and ICON™ features.

Component Location

The ambient air temperature sensor location is OEM-dependent. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The resistance of the sensor varies with the temperature. The reading you observe should compare to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-249

Last Modified: 02-Sep-2010


Fuel Shutoff Solenoid Supply Circuit

FAULT CODE 254

Fuel Shutoff Solenoid Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Less than Positive (+) 6 VDC detected at fuel shutoff circuit or an excessive current draw from the electronic control module (ECM) or faulty ECM output circuit. | The ECM turns off the fuel shutoff supply voltage. The engine will shut down.
Fuel Shutoff Solenoid Circuit

Circuit Description

The fuel shutoff solenoid is a device used by the ECM to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel shutoff solenoid.

Component Location

The fuel shutoff solenoid is located on the fuel pump housing near the fuel outlet line. Unspecified earlier versions used a dedicated return wire (pin 32) that is mounted to one of the shutoff solenoid mounting bolts. Newer models use only a fuel shutoff supply wire (pin 33).

Shop Talk

  • Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit.
  • If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and pulled down the voltage on the fuel shutoff circuit.
  • Inspect the engine-block-to-chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.
  • Check the starter solenoid Positive (+) terminal for a loose connector or accessory wiring with damaged insulation.
Refer to Troubleshooting Fault Code t05-254

Last Modified: 02-Sep-2010


Fuel Shutoff Solenoid Supply Circuit

FAULT CODE 255

Fuel Shutoff Solenoid Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S017 SPN: 632 FMI: 3/3 LAMP: Yellow SRT: | Externally supplied voltage detected going to fuel shutoff solenoid supply circuit. | None on performance. Fuel shutoff valve stays on.
Fuel Shutoff Circuit

Circuit Description

If voltage is externally supplied to the fuel shutoff valve, it will stay open.

Component Location

The fuel shutoff solenoid is located on the fuel pump housing near the fuel outlet line. Unspecified earlier versions used a dedicated return wire (pin 32) that is mounted to one of the shutoff solenoid mounting bolts. Newer models use only a fuel shutoff supply wire (pin 33).

Shop Talk

If there is an external shutdown system on the vehicle, make sure it is not wired incorrectly and feeding voltage into the fuel shutoff supply circuit.

Refer to Troubleshooting Fault Code t05-255

Last Modified: 02-Sep-2010


Ambient Air Temperature Sensor Circuit

FAULT CODE 256

Ambient Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the ambient air temperature circuit. | No effect on engine performance. The idle shutdown ambient air temperature override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override (automotive only).
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the ambient air. The ambient air temperature signal is used by the ECM for the idle shutdown ambient air temperature override and ICON™ features.

Component Location

The ambient air temperature sensor location is OEM-dependent. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The resistance of the sensor varies with the temperature. The reading you observe should compare to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-256

Last Modified: 02-Sep-2010


J1939 Datalink Multiplexing

FAULT CODE 285

J1939 Datalink Multiplexing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Yellow SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough, or did not receive it at all. | At least one multiplexed device will not operate properly.
J1939 Datalink Multiplexing Circuit

Circuit Description

Inputs such as throttle pedals, switches, and sensors can be communicated to the ECM over the J1939 datalink. Messages sent from the vehicle electronic control units (VECU) are received by the ECM and used for controlling the engine. Both the ECM and VECU must be properly configured so that each device's information is transmitted by the VECU and received by the ECM.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 datalink wiring and VECU(s) vary by OEM options.

Shop Talk

This fault occurs when the ECM is set up to receive information about a multiplexed device from a VECU over the J1939 datalink and does not receive a message with that information. This fault can also be caused if the ECM does not get the information fast enough to control the engine properly. This condition can be caused by the following:

  • The J1939 datalink having an electrical problem
  • A lack of terminating plugs on the J1939 datalink backbone
  • The ECM not being set up to receive information
  • A multiplexed device that truly is not multiplexed
  • A VECU not being correctly set up to transmit information on one of its multiplexed devices.
Refer to Troubleshooting Fault Code t05-285

Last Modified: 02-Sep-2010


J1939 Datalink Multiplexing

FAULT CODE 286

J1939 Datalink Multiplexing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Yellow SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
J1939 Datalink Multiplexing Circuit

Circuit Description

Inputs such as throttle pedals, switches, and sensors can be communicated to the ECM over the J1939 datalink. Messages sent from the vehicle electronic control units (VECU) are received by the ECM and used for controlling the engine. Both the ECM and VECU must be properly configured so that each device's information is transmitted by the VECU and received by the ECM.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 datalink wiring and VECU(s) vary by OEM options.

Shop Talk

This fault occurs when the ECM is set up to receive information from several multiplexed switches from VECU(s) and only gets some of the switches. It indicates the ECM is set up to receive too many switches or the VECU(s) is set up to transmit too few switches.

Refer to Troubleshooting Fault Code t05-286

Last Modified: 02-Sep-2010


OEM Temperature Sensor Circuit

FAULT CODE 293 (INDUSTRIAL)

OEM Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 293 PID: S154 SPN: 1083 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the OEM temperature sensor signal pin of the 31-pin OEM connector. | No engine protection for OEM temperature.
OEM Temperature Sensor Circuit

Circuit Description

The OEM sensor signal is used by the electronic control module (ECM) to monitor the OEM temperature. The OEM temperature is used by the ECM for the engine protection system. A sensor that has failed high can be caused by an open circuit in the signal or return wire, voltage shorts in the signal or return wire, or a faulty sensor.

Component Location

The location varies with the OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The resistance of all temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-293

Last Modified: 02-Sep-2010


OEM Temperature Sensor Circuit

FAULT CODE 294 (INDUSTRIAL)

OEM Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 294 PID: S154 SPN: 1083 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the OEM temperature sensor signal pin of the 31-pin OEM connector. | No engine protection for OEM temperature.
OEM Temperature Sensor Circuit

Circuit Description

The OEM sensor signal is used by the electronic control module (ECM) to monitor the OEM temperature. The OEM temperature is used by the ECM for the engine protection system. A sensor that has failed low can be caused by a short circuit to ground on a supply or return wire, or an internally grounded (faulty) sensor.

Component Location

The location varies with the OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The resistance of all temperature sensors varies with the temperature. Check the temperature thresholds using INSITE™.

Refer to Troubleshooting Fault Code t05-294

Last Modified: 02-Sep-2010


Ambient Air Pressure Sensor

FAULT CODE 295

Ambient Air Pressure Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2 LAMP: Yellow SRT: | An error in the ambient air pressure sensor signal was detected by the ECM. | Engine is derated to no air setting.

Component Location

The ambient air pressure sensor is located below the ECM.

Shop Talk

At key-on, the readings for ambient pressure from the ambient air pressure sensor, intake manifold pressure sensor, and oil pressure sensor are compared. This fault code occurs if the ambient air pressure sensor reading is different from the other two.

Refer to Troubleshooting Fault Code t05-295

Last Modified: 02-Sep-2010


OEM Pressure Sensor Circuit

FAULT CODE 297 (INDUSTRIAL)

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 297 PID: S223 SPN: 1084 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the OEM pressure sensor signal pin. | No engine protection for OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM pressure. The OEM pressure is used by the ECM for the engine protection system. A sensor that has failed high can be caused by an open circuit in the signal or return wire, a voltage short in the signal or return wire, or a faulty sensor.

Component Location

The location varies with the OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The sensor voltage signal is supplied by the ECM on pin 18 of the sensor harness connector.

Refer to Troubleshooting Fault Code t05-297

Last Modified: 02-Sep-2010


OEM Pressure Sensor Circuit

FAULT CODE 298 (INDUSTRIAL)

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 298 PID: S223 SPN: 1084 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the OEM pressure sensor signal pin of the 31-pin OEM connector. | No engine protection for OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM pressure. The OEM pressure is used by the ECM for the engine protection system. A sensor that has failed low can be caused by a short circuit to ground on the signal wire, or an internally grounded (faulty) sensor.

Component Location

The location varies with the OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The resistance of all pressure sensors varies with the pressure. Refer to the OEM troubleshooting and repair manual for specifications.

Refer to Troubleshooting Fault Code t05-298

Last Modified: 02-Sep-2010


Injector Circuit

FAULT CODE 311

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 PID: S001 SPN: 651 FMI: 6/6 LAMP: Yellow SRT: | Current detected at the injector for cylinder number 1 when the voltage is turned off. | The injector for cylinder number 1 is turned off.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an ISM and QSM actuator harness - one internal and the other external. The external portion of the actuator harness extends from the connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness with a 15-pin connector at the backside of the rocker lever housing. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Possible causes for this fault code include low injector solenoid resistance, short to battery voltage, and a short between injector solenoid wires.

Refer to Troubleshooting Fault Code t05-311

Last Modified: 02-Sep-2010


Injector Circuit

FAULT CODE 312

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 PID: S005 SPN: 655 FMI: 6/6 LAMP: Yellow SRT: | Current detected at the injector for cylinder No. 5 when the voltage is turned off. | The injector for cylinder No. 5 is turned off.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an ISM/QSM actuator harness - one internal and the other external. The external portion of the actuator harness extends from the connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness with a 15-pin connector at the backside of the rocker lever housing. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Possible causes for this fault code include low injector solenoid resistance, a short to battery voltage, and a short between injector solenoid wires.

Refer to Troubleshooting Fault Code t05-312

Last Modified: 02-Sep-2010


Injector Circuit

FAULT CODE 313

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 PID: S003 SPN: 653 FMI: 6/6 LAMP: Yellow SRT: | Current detected at the injector for cylinder No. 3 when voltage is turned off. | The injector for cylinder No. 3 is turned off.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an ISM and QSM actuator harness - one internal and the other external. The external portion of the actuator harness extends from the connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness with a 15-pin connector at the backside of the rocker lever housing. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Possible causes for this fault code include low injector solenoid resistance, a short to battery voltage, and a short between injector solenoid wires.

Refer to Troubleshooting Fault Code t05-313

Last Modified: 02-Sep-2010


Injector Circuit

FAULT CODE 314

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 PID: S006 SPN: 656 FMI: 6/6 LAMP: Yellow SRT: | Current detected at the injector for cylinder No. 6 when voltage is turned off. | The injector for cylinder No. 6 is turned off.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an ISM/QSM actuator harness - one internal and the other external. The external portion of the actuator harness extends from the connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness with a 15-pin connector at the backside of the rocker lever housing. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Possible causes for this fault code include low injector solenoid resistance, a short to battery voltage, and a short between injector solenoid wires.

Refer to Troubleshooting Fault Code t05-314

Last Modified: 02-Sep-2010


Injector Circuit

FAULT CODE 315

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 PID: S002 SPN: 652 FMI: 6/6 LAMP: Yellow SRT: | Current detected at the injector for cylinder No. 2 when the voltage is turned off. | The injector for cylinder No. 2 is turned off.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an ISM and QSM actuator harness - one internal and the other external. The external portion of the actuator harness extends from the connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness with a 15-pin connector at the backside of the rocker lever housing. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Possible causes for this fault code include low injector solenoid resistance, a short to battery voltage, and a short between injector solenoid wires.

Refer to Troubleshooting Fault Code t05-315

Last Modified: 02-Sep-2010


Real-Time Clock Power Circuit

FAULT CODE 319

Real-Time Clock Power Circuit

Printable Version Printable Version

Overview

Real-Time Clock Power Circuit

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real-time clock lost power. | None on performance. Data in the ECM will not have accurate time and date information.
Real-Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the ECM is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery backup module (if equipped).

Component Location

The real-time clock battery backup module is secured to the wiring harness in the vicinity of the ECM. The ECM is located on the fuel pump side of the engine either above the air compressor (high-mount) or above the starter (low-mount).

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault:

  • A weak or failed battery backup module
  • Failed wiring or connectors between the battery backup module and ECM
  • The engine is not equipped with a battery backup module, and lost vehicle battery power to the ECM.
Refer to Troubleshooting Fault Code t05-319

Last Modified: 02-Sep-2010


Injector Circuit

FAULT CODE 321

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 PID: S004 SPN: 654 FMI: 6/6 LAMP: Yellow SRT: | Current detected at the injector for cylinder No. 4 when the voltage is turned off. | The injector for cylinder No. 4 is turned off.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an ISM and QSM actuator harness - one internal and the other external. The external portion of the actuator harness extends from the connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness with a 15-pin connector at the backside of the rocker lever housing. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Possible causes for this fault code include low injector solenoid resistance, a short to battery voltage, and a short between injector solenoid wires.

Refer to Troubleshooting Fault Code t05-321

Last Modified: 02-Sep-2010


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 1 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves are actuated by the engine control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a SUPPLY and a RETURN wire. An electrical pulse is sent to the injector from the ECM on the SUPPLY wire and it returns on the RETURN wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or an open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-322

Last Modified: 20-May-2015


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 5 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-323

Last Modified: 02-Sep-2010


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 3 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-324

Last Modified: 02-Sep-2010


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 6 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-325

Last Modified: 02-Sep-2010


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 2 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-331

Last Modified: 02-Sep-2010


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 4 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-332

Last Modified: 02-Sep-2010


Ignition Bus Relay Circuit

FAULT CODE 338

Ignition Bus Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S087, 3 SPN: 1267 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the ignition bus relay output circuit (ignition relay positive (+)) when low voltage was expected by the ECM. | The ICON™ will be disabled. Only mandatory shutdown will be enabled. Engine can be started normally. No power to the keyswitch ignition circuit.
Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

Circuit Description

The ignition bus relay controls ignition circuits powering the heating/air conditioning controls and other equipment connected to the ignition bus relay(s) (optional second relay can be installed for additional accessories). This relay(s) is controlled by ignition relay positive (+) signal from the ECM OEM 50-pin connector pin 35.

Component Location

The ignition bus relay is located under the dash inside the vehicle cab.

Shop Talk

This fault typically indicates a short circuit from the ignition relay positive (+) output of battery voltage. Ignition relay (+) pin outputs 12 VDC to open the ignition bus relay(s) when ICON™ has powered the vehicle down and needs to disconnect power going to the cab circuits. The ignition bus relay(s) is normally closed when no power is applied.

Refer to Troubleshooting Fault Code t05-338

Last Modified: 02-Sep-2010


Ignition Bus Relay Circuit

FAULT CODE 339

Ignition Bus Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S087, 4 SPN: 1267 FMI: 4 LAMP: Yellow SRT: | Less than 6 VDC detected at the ignition bus relay output circuit when the high voltage was expected by the ECM. | The ICON™ will be disabled. Only mandatory shutdown will be enabled. Constant power will be at the keyswitch ignition circuit.
Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

Circuit Description

The ignition bus relay controls ignition circuits powering the heating/air conditioning controls and other equipment connected to the ignition bus relay(s). This relay(s) is controlled by ignition relay positive (+) signal from the ECM OEM connector pin 35.

Component Location

The ignition bus relay is located under the dash inside the vehicle cab.

Shop Talk

This fault typically indicates a short circuit to ground or an open circuit from the ECM connector pin 35 (ignition relay positive (+)). Ignition relay positive (+) (pin 35) outputs 12 VDC to open the ignition bus relay(s) when ICON™ has powered down the vehicle and needs to disconnect power going to the cab circuit. The ICON™ bus relay(s) is normally closed when no power is applied.

Refer to Troubleshooting Fault Code t05-339

Last Modified: 02-Sep-2010


Unswitched Battery Supply Circuit

FAULT CODE 341

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 341 PID: S253 SPN: 630 FMI: 2/2 LAMP: Yellow SRT: | Severe loss of data from the ECM. | Possibly no noticeable performance effects, or engine dying, or difficulty in starting the engine. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There are two in-line 15-amp fuses in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-341

Last Modified: 02-Sep-2010


Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Yellow SRT: | Internal ECM error. | Possibly none on performance, or severe derate.
Electronic Control Module

Circuit Description

The ECM monitors both signal voltage output to the injectors and ECM input from the engine position sensor.

Component Location

The ECM is located on the fuel pump side of the engine.

Shop Talk

  • Loose engine or chassis ground connections can cause Fault Code 343 to be logged. Pay special attention to the negative starter post connection.
  • Moisture in the ECM connectors can also cause the ECM to log Fault Code 343.
  • Symptoms can include intermittent stumble or rough running.

Note: It is always a good idea to check the resistance of the meter leads by reading the resistance displayed by the tool when touching the positive and negative leads together. Subtract this reading from any readings taken for resistance. This will provide a more accurate resistance measurement. Note: Always reapply dielectric grease when reconnecting an electrical connection.

Refer to Troubleshooting Fault Code t05-343

Last Modified: 23-Jan-2014


Auxiliary Speed Governor Circuit

FAULT CODE 349

Auxiliary Speed Governor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 349 PID: P191 FMI: 0/16 LAMP: Yellow SRT: | A frequency greater than calibrated threshold was detected at the tailshaft governor signal pin of the 31-pin connector. | Calibration-dependent power and speed derate.
Auxiliary Speed Governor Circuit

Circuit Description

The auxiliary speed governor provides a means to govern the engine independent of engine speed. This circuit controls output shafts or other devices downstream of a torque converter.

The auxiliary speed governor provides a means to control the output shafts or other devices downstream of a torque converter, independent of engine speed.

Component Location

The auxiliary speed governor location varies with the OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

This fault can only be caused by a high-frequency input into the auxiliary speed governor circuit.

Refer to Troubleshooting Fault Code t05-349

Last Modified: 02-Sep-2010


Sensor Voltage Supply

FAULT CODE 352

Sensor Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 620 FMI: 4 LAMP: Yellow SRT: | Low voltage detected on the internal electronic control module (ECM) supply line to some of the sensors. | Engine is derated to no-air setting.
Sensor Supply Circuit

Circuit Description

The ECM supplies each of these sensors with +5 VDC. If the supply line to any sensor is damaged, the sensor will not work correctly.

Component Location

There are two components involved in the sensor voltage supply: The intake manifold pressure sensor and the ambient air pressure sensor. The ambient air pressure sensor is located to the left of the ECM when looking at the side of the engine opposite of the intake manifold. The intake manifold pressure sensor is located on the topside of the air intake manifold toward the front of the engine.

Shop Talk

Low voltage on the sensor +5-VDC supply line will be caused by a short to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-352

Last Modified: 02-Sep-2010


ICON™ Engine Auto Start Failure

FAULT CODE 359

ICON™ Engine Auto Start Failure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 359 PID: SPN: FMI: 11 LAMP: Yellow SRT: | The ICON™ system has failed to start the engine automatically. | The ICON™ system will be disabled. Only mandatory shutdown will be enabled. Can possibly start engine normally.
Integrated Idle ICON™ Circuit

Circuit Description

The starter relay circuit controls and monitors both the starter relay coil and return signal. The starter relay is used by the ICON™ feature to perform automatic starts of the engine.

Component Location

The starter relay is mounted on the fire wall of the vehicle on the intake side of the engine.

Shop Talk

This fault code is set if two consecutive automatic starts fail. If a start is commanded by the ECM and 200 rpm is not reached within 2 seconds nor 450 rpm within 14 seconds, then the start failed. After the first failure, ICON™ waits one minute and tries again. If the second start fails, the fault is set. It is cleared as soon as a manual start is successful.

Refer to Troubleshooting Fault Code t05-359

Last Modified: 02-Sep-2010


Engine Protection Torque Derate - Condition Exists

FAULT CODE 3714

Engine Protection Torque Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3714 PID: FMI: 11/31 LAMP: Amber SRT: | Engine Protection Torque Derate - Condition Exists. SAE J1939 multiplexing heartbeat message from OEM device lost or torque derate imposed by OEM device. | Amber warning lamp will illuminate. Torque derate will be imposed.
J1939 Data Link Multiplexing Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hardwired to an OEM electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM device to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM device is received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 heartbeat message from the multiplexed OEM device for more than 60 seconds.

The multiplexed OEM device sends a request for a torque derate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light 30 seconds after the heartbeat message from the OEM device is lost or a torque derate is requested by the OEM device.
  • The ECM will impose a torque derate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light 30 seconds after the heartbeat message from the OEM device is restored or a torque derate is no longer being requested by the OEM device.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is setup properly (components enabled and OEM device source addressed correctly) to receive information from an OEM device, but the OEM device is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM device source address of the device transmitting the component message is incorrect in the Cummins® ECM, or the OEM device is not setup to transmit the multiplexed component message.
  • A malfunctioning J1939 data link connection between the OEM device and Cummins® ECM, a malfunctioning connection between the component and the OEM device, a malfunctioning OEM device, or a malfunctioning Cummins® ECM. It can be necessary to contact the OEM for the proper multiplexing configuration.
  • When the heartbeat message from the OEM device is lost or interrupted. In addition to the fault, a 60 percent torque derate will be imposed. Refer to the OEM service manual.
  • When the OEM device is requesting a torque derate between 0 and 100 percent. Refer to the OEM service manual.
Refer to Troubleshooting Fault Code t05-3714

Last Modified: 02-Sep-2010


Intake Air Heater Number 1 Circuit Error

FAULT CODE 381

Intake Air Heater Number 1 Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 381 PID: S237 SPN: 626 FMI: 11 LAMP: Yellow SRT: | Error detected in the cold start aid relay 1 enable circuit. | Intake air heater number 1 can be ON or OFF all of the time or is damaged.
Intake Air Heater Number 1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The electronic control module (ECM) controls relays that switch power to the air heater.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the heater relays will vary with original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the device is activated. In some cases the diagnostic can also run at some fixed intervals.

Conditions for Setting the Fault Codes

  • Intake air heater circuits are short circuited.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The intake air heater operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn OFF the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

  • These faults could also indicate the intake air heater circuits are shorted to battery positive (+). This would command the grids to be on full time. This will drain the batteries, burn out grids, and/or destroy intake gaskets.
  • The intake air heater circuits will only activate when intake manifold temperature is below 19°C [66°F] when the keyswitch is in the ON position.
  • If the intake air heaters are not installed and Fault Code 381 is active, then use INSITE™ to disable this feature, “Intake Air Heater.”
Refer to Troubleshooting Fault Code t05-381.

Last Modified: 23-Aug-2011


Sensor Voltage Supply

FAULT CODE 386

Sensor Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 620 FMI: 3 LAMP: Yellow SRT: | High voltage detected on the internal electronic control module (ECM) supply wire to the sensors. | Engine is derated to no-air setting.
Sensor Voltage Supply Circuit

Circuit Description

The ECM supplies each of these sensors with +5 VDC. If the supply wire to any sensor is damaged, the sensor will not work correctly.

Component Location

There are two components involved in the sensor voltage supply: The intake manifold pressure sensor and the ambient air pressure sensor. The ambient air pressure sensor is located to the left of the ECM when looking at the side of the engine opposite the intake manifold. The intake manifold pressure sensor is located on the topside of the intake manifold toward the front of the engine.

Shop Talk

High voltage on the sensor +5-VDC supply wire will be caused by a short to battery of the supply wire or a short between an actuator wire and the supply wire.

Refer to Troubleshooting Fault Code t05-386

Last Modified: 02-Sep-2010


Throttle Voltage Supply

FAULT CODE 387

Throttle Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 387 PID: P221 SPN: 1043 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on the ECM voltage supply line to the throttle(s) (VTP supply). | Engine will only idle.
Throttle Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies the throttle and remote throttle with +5 VDC. If the supply line to the throttles is damaged, the throttle will not work correctly.

Component Location

The throttle pedal is located in the cab. Refer to the OEM troubleshooting and repair manual for the location of the remote throttle.

Shop Talk

High voltage on the + 5-VDC supply line will be caused by a short circuit to battery of the supply line or a short circuit between an actuator and the supply line.

Refer to Troubleshooting Fault Code t05-387

Last Modified: 02-Sep-2010


Engine Brake Supply Circuit

FAULT CODE 388

Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 388 PID: S079 SPN: 1072 FMI: 11 LAMP: Yellow SRT: | Less than 6 VDC detected at the engine brake circuit 1 when on indicates an excessive current draw from the electronic control module (ECM) or faulty ECM output circuit. | Engine brake 1 can not be activated.
Engine Brake Supply Circuit

Circuit Description

The ECM enables the engine brake by sending a signal directly to the engine brakes. The ECM will only enable the engine brakes under certain conditions.

Component Location

Refer to an OEM diagram for the location of the engine brake.

Shop Talk

A possible cause for this fault code is an ECM engine brake driver 1 short to ground.

Refer to Troubleshooting Fault Code t05-388

Last Modified: 02-Sep-2010


Engine Brake Supply Circuit

FAULT CODE 392

Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 392 PID: S080 SPN: 1073 FMI: 11 LAMP: Yellow SRT: | Less than 6 VDC detected at engine brake circuit 2 when on indicates an excessive current draw from the electronic control module (ECM) or a faulty ECM output circuit. | Engine brake 2 can not be activated.
Engine Brake Relay Supply Circuit

Circuit Description

The ECM enables the engine brake by sending a signal directly to the engine brakes. The ECM will only enable the engine brakes under certain operating conditions.

Component Location

Refer to an OEM diagram for the location of the engine brake.

Shop Talk

A possible cause for this fault code is an ECM engine brake driver 2 short to ground.

Refer to Troubleshooting Fault Code t05-392

Last Modified: 02-Sep-2010


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: FMI: LAMP: Shutdown SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Voltage signal indicates oil pressure has dropped below the shutdown threshold for low oil pressure. | Engine will shut down. Low oil pressure relay driver is energized.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

Confirm that the oil pressure sensor supply voltage is between 4.75 and 5.25 VDC at the sensor. See Fault Code 141. Verify with the operator at what engine speed the fault occurs. If the engine is being operated a speed to low under load (lugging), the oil pressure can drop below the engine protection limits because of the oil temperature. Oil pressure is a function of engine speed, oil level, and regulator function. Operating the engine at a low speed under load will not cause the oil pressure to be low unless the oil is hot, at a low level, regulator has malfunctioned, or a loss is occurring somewhere in the system.

  • Refer to specific engine wiring diagram for the output voltage of the pressure sensor.
  • NOTE: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.
Refer to Troubleshooting Fault Code t05-415.

Last Modified: 19-Jun-2017


Intake Manifold Pressure Sensor

FAULT CODE 419

Intake Manifold Pressure Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 419 PID: P102 SPN: 1319 FMI: 2 LAMP: Yellow SRT: | An error in the intake manifold pressure sensor signal was detected by the ECM. | Engine is derated to no-air setting.

Component Location

The intake manifold pressure sensor is located in the air intake manifold toward the front of the engine.

Shop Talk

At key-on, the readings for ambient pressure from the ambient air pressure sensor, intake manifold pressure sensor, and oil pressure sensor are compared. This fault code occurs if the intake manifold pressure sensor reading is different from the other two.

Refer to Troubleshooting Fault Code t05-419

Last Modified: 02-Sep-2010


Coolant Level Sensor Circuit

FAULT CODE 422

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2/2 LAMP: Yellow SRT: | Voltage detected simultaneously on both the coolant level high and low signal circuits or no voltage detected on both circuits. | No engine protection for coolant level.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the sensor harness. This sensor is very complex. Do not use a multimeter to check the coolant level sensor. If the radiator coolant level drops below a certain level, a power derate will occur and become greater as time goes by.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

Possible causes for this fault code include:

  • Open circuit
  • Short circuit to ground
  • Short circuit to another wire.
Refer to Troubleshooting Fault Code t05-422

Last Modified: 02-Sep-2010


J1939 Datalink Communication

FAULT CODE 426

J1939 Datalink Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | Communication between the electronic control module (ECM) and another device on the J1939 datalink has been lost. | None on performance. J1939 devices possibly do not operate.
J1939 Datalink Circuit

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and VECUs can communicate with the ECM over the J1939 datalink. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the J1939 datalink.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 datalink wiring and the J1939 devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the J1939 datalink and then can no longer transmit on the datalink. Possible causes could be the following: Unplugging an electronic service tool before keying off the ECM, the J1939 datalink having an intermittent electrical problem, the ECM (or another J1939 device) tying up communications by an electrical problem, or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-426

Last Modified: 02-Sep-2010


Water-In-Fuel (WIF) Sensor Circuit

FAULT CODE 428

Water-In-Fuel (WIF) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at water-in-fuel (WIF) sensor circuit. | None on performance.
WIF Sensor Circuit

Circuit Description

The WIF sensor is attached to the fuel filter. The WIF sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The WIF circuit contain two wires: A return ground (pin 10) and a signal wire (pin 9).

Component Location

The WIF sensor is installed in the fuel filter and is located on the side of the head, approximately midengine.

Shop Talk

Possible causes for this fault code include: Short circuit to a + 5-VDC supply wire.

Refer to Troubleshooting Fault Code t05-428

Last Modified: 02-Sep-2010


Water-In-Fuel (WIF) Sensor Circuit

FAULT CODE 429

Water-In-Fuel (WIF) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at water-in-fuel (WIF) sensor circuit. | None on performance.
WIF Sensor Circuit

Circuit Description

The WIF sensor is attached to the fuel filter. The WIF sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The WIF circuit contains two wires: A return ground (pin 10) and a signal wire (pin 9).

Component Location

The WIF sensor is installed in the fuel filter and is located on the side of the head approximately midengine.

Shop Talk

The WIF sensor uses the same internal ECM power supply as sensors on engine harness. If Fault Code 352 is also active, use that troubleshooting logic and tree.

Refer to Troubleshooting Fault Code t05-429

Last Modified: 02-Sep-2010


Fault Code Path Selection

FAULT CODE 431
Fault Code Path Selection

Do you have an NISS throttle pedal? | Go to 82-fc431niss
Do you have an ISS throttle pedal? | Go to 82-fc431iss
Do you have an SSS throttle pedal? | Go to 82-fc431sss

Last Modified: 12-Jan-2004


Idle Validation Switch Circuit

FAULT CODE 431

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle signal pins. | None on performance.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired idle validation switch.
  • The integrated sensor switch (ISS) has a different idle validation switch (IVS) resistance specification (125 ohms) as compared to nonintegrated sensor switch (NISS) (10 ohms).
Refer to Troubleshooting Fault Code t05-431iss

Last Modified: 02-Sep-2010


Idle Validation Switch Circuit

FAULT CODE 431

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: P091 SPN: 91 FMI: 2/2 LAMP: Yellow SRT: | Voltage detected simultaneously on both the idle validation off-idle and on-idle signal pins. | None on performance.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The nonintegrated sensor switch (NISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired idle validation switch.
  • The integrated sensor switch (ISS) has a different idle validation switch (IVS) resistance specification (125 ohms) as compared to nonintegrated sensor switch (NISS) (10 ohms).
Refer to Troubleshooting Fault Code t05-431niss

Last Modified: 02-Sep-2010


Idle Validation Switch Circuit

FAULT CODE 431

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: P091 SPN: 91 FMI: 2/2 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle signal pins. | None on performance.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The solid-state switch (SSS) is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired idle validation switch.

Refer to Troubleshooting Fault Code t05-431sss

Last Modified: 02-Sep-2010


Accelerator Pedal Circuit

FAULT CODE 432

Accelerator Pedal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13/13 LAMP: Red SRT: | Voltage detected at idle validation on-idle circuit when voltage at throttle position circuit indicates the pedal is not at idle or voltage detected at idle validation off-idle circuit when voltage at throttle position circuit indicates the pedal is at rest. | Engine will only idle.
Accelerator Pedal Circuit

Circuit Description

The accelerator pedal assembly relays the accelerator percentage requested by the operator to the electronic control module (ECM).

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

Confirm that the idle validation switch (IVS) is properly calibrated. Refer to the accelerator pedal manufacturer's instructions for adjustment information.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 02-Sep-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 433

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 433 PID: P102 SPN: 102 FMI: 2/2 LAMP: Yellow SRT: | Voltage signal at the intake manifold pressure circuit indicates high intake manifold pressure but other engine characteristics indicate that intake manifold pressure must be low. | Derate to no-air setting.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If intake manifold pressure exceeds 127 mm-Hg [5 in-Hg] for more than 20 seconds while the engine is under 5-percent load, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located on the top of the intake manifold toward the front of engine. Refer to Procedure 100-002 in Section E.

Shop Talk

The ECM checks for this fault only at engine speeds up to 50 rpm above the set idle speed. If the intake manifold pressure shows too high of a value at this time, the ECM will log this fault code.

Refer to Troubleshooting Fault Code t05-433

Last Modified: 02-Sep-2010


Unswitched Battery Supply Circuit

FAULT CODE 434

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 434 PID: S251 SPN: 627 FMI: 2/2 LAMP: Yellow SRT: | Supply voltage to the electronic control module (ECM) fell below (+) 6.2-VDC for a fraction of a second or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after keyswitch is turned off). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There are two in-line 15-ampere fuses in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire, and one 5-ampere fuse when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Shop Talk

  • Examine the injector pigtail nuts and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specification and log Fault Code 434.
Refer to Troubleshooting Fault Code t05-434

Last Modified: 02-Sep-2010


Oil Pressure Sensor

FAULT CODE 435

Oil Pressure Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2 LAMP: Yellow SRT: | An error in the oil pressure sensor signal was detected by the ECM. | None on performance; no engine protection for oil pressure.
Oil Pressure Sensor

Circuit Description

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

At key-on, the readings for ambient pressure from the ambient air pressure sensor, intake manifold pressure sensor, and oil pressure sensor are compared. This fault code occurs if the oil pressure sensor reading is different from the other two.

Refer to Troubleshooting Fault Code t05-435

Last Modified: 02-Sep-2010


Unswitched Battery Supply Circuit

FAULT CODE 441

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Yellow SRT: | Battery voltage below normal operating level. | Possible no noticeable performance effects or possible rough idle.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire of the OEM harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to the OEM troubleshooting and repair manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Refer to Troubleshooting Fault Code t05-441

Last Modified: 02-Sep-2010


Unswitched Battery Supply Circuit

FAULT CODE 442

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Yellow SRT: | Battery voltage above normal operating level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire to protect the OEM harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to the OEM troubleshooting and repair manual for battery location.

Shop Talk

Disconnect all aftermarket devices from the battery supply circuit. Make sure the proper-size fuses are being used (15-amp fuses).

Refer to Troubleshooting Fault Code t05-442

Last Modified: 02-Sep-2010


Throttle Voltage Supply

FAULT CODE 443

Throttle Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443 PID: S221 SPN: 1043 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the electronic control module (ECM) voltage supply line to the throttle(s). | Engine will only idle.
Throttle Position Supply Voltage Circuit

Circuit Description

The ECM supplies the accelerator and the remote throttle with +5 VDC. If the supply line to the accelerators is damaged, the accelerators will not work correctly.

Component Location

Accelerator pedal is located in the cab. Refer to the OEM manual for remote throttle location.

Shop Talk

Low voltage on the +5-VDC supply line will be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed accelerator, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-443

Last Modified: 02-Sep-2010


Wastegate Actuator Number 1 Circuit

FAULT CODE 465

Wastegate Actuator Number 1 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 465 PID: S032 SPN: 1188 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the wastegate actuator number 1 circuit when no voltage was being supplied by the engine control module (ECM). | Engine will run derated.
Wastegate Actuator number 1 Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Component Location

The wastegate controller is located on the air inlet horn. Actuator number 1 is the rear-most solenoid on the controller.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the harness
  • An open circuit in the harness, connector, or wastegate control valve
  • Improperly mounted wastegate actuator solenoid.
Refer to Troubleshooting Fault Code t05-465

Last Modified: 05-Jul-2012


Wastegate Actuator Number 1 Circuit

FAULT CODE 466

Wastegate Actuator Number 1 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 466 PID: S032 SPN: 1188 FMI: 4/4 LAMP: Yellow SRT: | Less than + 6 VDC detected at the wastegate actuator number 1 circuit when on indicates an excessive current draw from the electronic control module (ECM) or faulty ECM output circuit. | Engine will run derated.
Wastegate Actuator number 1 Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Component Location

The wastegate controller is located on the air inlet horn. Actuator number 1 is the front most solenoid on the controller.

Shop Talk

  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry surface.
  • Check the starter solenoid + terminal for a loose connector or accessory wiring with damaged insulation.
  • Low voltage can be caused by a short circuit to ground, a short circuit to another wire in the harness, or a shorted solenoid coil.
  • Inspect the wastegate actuator number 1 circuit for external wires that can be spliced into powering another device. Remove any extra wires that are found in the circuit.
Refer to Troubleshooting Fault Code t05-466

Last Modified: 02-Sep-2010


ICON™ Cab Thermostat Circuit

FAULT CODE 469

ICON™ Cab Thermostat Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 469 PID: S215 SPN: FMI: 2/2 LAMP: None SRT: | The ICON™ cab thermostat has logged a fault (E3 on the cab thermostat), or the cab thermostat signal to the ECM is lost. | E3 will cycle the engine between 20 minutes run and 15 minutes off or until the desired set-point is reached. (This is a selectable response of the E3 fault in the thermostat trim table.) The ICON™ system will not be disabled. Engine mode will remain active.
ICON™ Cab Thermostat Circuit

Circuit Description

The cab thermostat is used to control the cab temperature, either for heating or cooling. It is required for cab comfort mode operation. The thermostat communicates with the ECM to command when to autostart the engine to maintain cab temperature. Also, the thermostat is connected to the keyswitch to detect when the ignition is turned on.

Component Location

The cab thermostat is mounted in the bunk area, on the wall above the bed.

Shop Talk

E3 is an indication that one of the following has occurred: (1) Engine has run for more than 60 minutes, and cool or heat set point is not achieved, and external ambient temperature is within -18° to 43°C [0 to 110°F] (thermostat-adjustable trim 01 and 02, see thermostat trim table in the ICON™ Operation and Maintenance Manual, Bulletin 3666422); (2) a cab thermostat request to start the engine has been requested four times in one hour, and the ambient temperature is within -18° to 43°C [0 to 110°F]. E3 can indicate potential tampering of the thermostat. For example, the operator has chosen cool mode but turned the heater on or opened the windows. The air-conditioning system will attempt to cool the truck below the cool set point for 60 minutes. At this time, an E3 fault (Fault Code 469) will be logged. A similar situation can occur for heat mode. Once an E3 is displayed on the thermostat, the engine will cycle on for 20 minutes and off for 15 minutes. If the desired temperature set-point is reached in the tamper mode operation (20 minutes on and 15 minutes off), it will return to normal cab mode operation. To clear E3, disable ICON™, key off for approximately 30 seconds, and then reactivate ICON™.

Note: The thermostat fault E1 (cab temperature sensor), E2 (external ambient air temperature sensor), and E3 (tamper mode) do not flash out on the ICON™ lamp, but merely display on the thermostat display screen. INSITE™ electronic service tool will log an active Fault Code 469 until cleared. Refer to the Cab Thermostat Displays a Fault Code troubleshooting symptom tree in Section TS. Investigate the related fault codes that also can possibly be active.

Refer to Troubleshooting Fault Code t05-469

Last Modified: 02-Sep-2010


Crankcase Oil Level Sensor Circuit

FAULT CODE 472

Crankcase Oil Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 472 PID: S017 SPN: 1380 FMI: 2/2 LAMP: Maintenance SRT: | Either high or low voltage detected on the crankcase oil level sensor circuit by the electronic control module (ECM). | None on performance. Centinel™ system deactivated.
Crankcase Oil Level Sensor Circuit

Circuit Description

The crankcase oil level sensor is used by the ECM to monitor the lubricating oil level. The ECM monitors the voltage on the signal pin and converts this to an electronic value. The oil level value is used by the ECM for the engine protection system.

Component Location

The oil level sensor is located in the side of the oil pan on the exhaust side of the engine.

Shop Talk

Low voltage can be caused by an open circuit in the signal wire, a short circuit to ground in the signal wire, a short circuit to ground of the supply wire, an open circuit in the supply wire, or a faulty sensor.

High voltage can be caused by the signal wire shorting to another wire in the harness, an open circuit in the return wire, or a faulty sensor.

Refer to Troubleshooting Fault Code t05-472

Last Modified: 02-Sep-2010


Starter Solenoid Lockout Relay Driver Circuit

FAULT CODE 474

Starter Solenoid Lockout Relay Driver Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 474 PID: S237 SPN: 1321 FMI: 2/2 LAMP: Yellow SRT: | Either low voltage detected when + 12 VDC are commanded or voltage detected when no voltage is commanded. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Solenoid Lockout Relay Circuit

Circuit Description

The starter solenoid lockout relay driver circuit is a solenoid driven by the electronic control module (ECM) that electrically isolates the starter motor relay when the engine is running.

Component Location

Refer to an OEM diagram for the exact location.

Refer to Troubleshooting Fault Code t05-474

Last Modified: 02-Sep-2010


Electronic Air Compressor Governor Circuit

FAULT CODE 475

Electronic Air Compressor Governor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 475 PID: S089 SPN: 1351 FMI: 4/4 LAMP: Yellow SRT: | Low voltage was detected on the electronic air compressor circuit when high voltage was expected. | Air compressor will not shut off.
Electronic Air Compressor Governor Circuit

Circuit Description

The electronic air compressor governor is a device used by the electronic control module (ECM) to control output of the air compressor.

Component Location

The electronic air compressor governor is located on the top of the air compressor.

Shop Talk

  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.
  • Check the starter solenoid positive (+) terminal for a loose connector or accessory wiring with damaged insulation.
  • Low voltage can be caused by short circuit to ground, a short circuit to another wire in the harness, or a shorted solenoid coil.
  • Voltage is required at the electronic air compressor governor to turn the compressor off. No voltage turns the compressor on.
Refer to Troubleshooting Fault Code t05-475

Last Modified: 02-Sep-2010


Electronic Air Compressor Governor Circuit

FAULT CODE 476

Electronic Air Compressor Governor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 476 PID: S089 SPN: 1351 FMI: 3/3 LAMP: Yellow SRT: | High voltage or an open circuit detected at the electronic air compressor governor actuator circuit. | Air compressor runs continuously or not at all.
Electronic Air Compressor Governor Circuit

Circuit Description

The electronic air compressor governor is a device used by the electronic control module (ECM) to control the output of the air compressor.

Component Location

The air compressor governor actuator is located on top of the air compressor.

Shop Talk

High voltage can be caused by a short circuit to battery or a short circuit to another wire in the harness.

Voltage is required at the electronic air compressor governor to turn the compressor off. No voltage turns the compressor on.

Refer to Troubleshooting Fault Code t05-476

Last Modified: 02-Sep-2010


Auxiliary Speed Input Error

FAULT CODE 489 (INDUSTRIAL)

Auxiliary Speed Input Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 489 PID: P191 SPN: 191 FMI: 1/18 LAMP: Yellow SRT: | Auxiliary speed frequency on input pin indicates the frequency is below a calibration-dependent threshold. | Engine will only idle.
Auxiliary Speed Input Circuit

Circuit Description

The auxiliary speed input is a frequency signal from an auxiliary speed or pressure pickup. It is sent to the electronic control module (ECM) and is used to control the engine speed. Auxiliary reference speed is based on the throttle position.

Component Location

The auxiliary speed or pressure pickup device location is dependent on the OEM application. Refer to the OEM troubleshooting and repair manual for component location.

Shop Talk

The auxiliary speed governor controls engine speed based on a measured auxiliary speed or pressure.

Refer to Troubleshooting Fault Code t05-489

Last Modified: 02-Sep-2010


Wastegate Actuator Number 2 Circuit

FAULT CODE 491

Wastegate Actuator Number 2 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 491 PID: S088 SPN: 1189 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the wastegate actuator number 2 circuit when no voltage was being supplied by the engine control module (ECM). | Engine will run derated.
Wastegate Actuator Number 2 Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Component Location

The wastegate controller is located on the air inlet horn. Actuator number 2 is the front-most solenoid on the controller.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the harness
  • An open circuit in the harness, connector, or wastegate control valve
  • Improperly mounted wastegate actuator solenoid.
Refer to Troubleshooting Fault Code t05-491

Last Modified: 05-Jul-2012


Wastegate Actuator Number 2 Circuit

FAULT CODE 492

Wastegate Actuator Number 2 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 492 PID: S088 SPN: 1189 FMI: 4/4 LAMP: Yellow SRT: | Less than + 6 VDC detected at the wastegate actuator number 2 circuit when activated indicates an excessive current draw from the electronic control module (ECM) or faulty ECM output circuit. | Engine will run derated.
Wastegate Actuator Number 2 Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Component Location

The wastegate controller is located on the air inlet horn. Actuator number 2 is the rear-most solenoid on the controller.

Shop Talk

  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry surface.
  • Check the starter solenoid + terminal for a loose connector or accessory wiring with damaged insulation.
  • Low voltage can be caused by short circuit to ground, a short circuit to another wire in the harness, or a shorted solenoid coil.
  • Inspect the wastegate actuator number 2 circuit for external wires that can be spliced into powering another device. Remove any extra wires that are found in the circuit.
Refer to Troubleshooting Fault Code t05-492

Last Modified: 02-Sep-2010


Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 497

Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 497 PID: S114 SPN: 1377 FMI: 2/2 LAMP: Amber SRT: | Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect. | Various optional switch inputs to the engine control module (ECM) may not operate correctly.
Multiple Unit Synchronization Switch Circuit

Circuit Description

The Multiple Unit Synchronization feature uses an ON/OFF switch and a complementary switch. The complementary switch is used by the ECM to determine the type of coupling (hard or soft) to use between multiple engines when the multiple unit synchronization switch is engaged. This feature is installed by the original equipment manufacturer (OEM) to support this feature.

Component Location

The multiple unit synchronization switch is mounted by the OEM. Refer to the OEM manual for the specific location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected the multiple unit synchronous ON/OFF switch and multiple unit synchronous complimentary ON/OFF switch have different values.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The Multiple Unit Synchronization feature allows two or more engines to be controlled by a single throttle signal and run at a similar speed. There are three engine configurations available with this feature: soft-coupled, hard-coupled, and soft-coupled marine.

The hard-coupled configuration has the primary and all secondary engines in series with each other. The primary engine outputs a throttle signal, which is received by the first secondary engine. This secondary engine then outputs the throttle signal to the next secondary engine in the series. This process repeats until the primary engine receives the throttle signal.

Refer to Troubleshooting Fault Code t05-497

Last Modified: 18-May-2015


Switched Output A Error

FAULT CODE 527 (INDUSTRIAL)

Switched Output A Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: P40 PID: S154 SPN: 702 FMI: 3/3 LAMP: Yellow SRT: | Less than + 17.0 VDC detected at the switched output A signal pin of the 31-pin OEM connector. | No action taken by the electronic control module (ECM).
Switched Output A Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device, and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-527

Last Modified: 02-Sep-2010


Switched Output B Error

FAULT CODE 528 (INDUSTRIAL)

Switched Output B Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 528 PID: P093 SPN: 93 FMI: 2/2 LAMP: Yellow SRT: | Less than + 17.0 VDC detected at the switch output B signal pin of the 31-pin OEM connector. | No action taken by the electronic control module (ECM).
Switched Output B Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device, and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-528

Last Modified: 02-Sep-2010


Switched Output B Error

FAULT CODE 529 (INDUSTRIAL)

Switched Output B Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: S51 SPN: 703 FMI: 3/3 LAMP: Yellow SRT: | Less than + 17 VDC detected at the switched output B signal pin at the electronic control module (ECM). | No action taken by the ECM.
Switched Output B Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device, and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-529

Last Modified: 02-Sep-2010


Autoshift Low Gear Actuator (Lockout Solenoid)

FAULT CODE 536

Autoshift Low Gear Actuator (Lockout Solenoid)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 536 PID: S044 SPN: 718 FMI: 11/11 LAMP: Yellow SRT: | Either low voltage detected on autoshift low gear actuator circuit when + 12 VDC are commanded or voltage detected when no voltage is commanded. | Top 2 lockout solenoid will not function properly. Transmission will not shift properly.
Top 2 Lockout Solenoid Circuit

Circuit Description

The autoshift low gear actuator is an ECM-driven solenoid that controls a Top 2 transmission.

Component Location

The autoshift low gear actuator is located on the topside of a transmission toward the back. Refer to an OEM diagram for a specific location.

Refer to Troubleshooting Fault Code t05-536

Last Modified: 02-Sep-2010


Autoshift High Gear Actuator (Shift Solenoid)

FAULT CODE 537

Autoshift High Gear Actuator (Shift Solenoid)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 537 PID: S043 SPN: 717 FMI: 11/11 LAMP: Yellow SRT: | Either low voltage detected on autoshift high gear actuator circuit when (+) 12 VDC are commanded or voltage detected when no voltage is commanded. | Top 2 shift solenoid will not function properly. Transmission will not shift properly.
Top 2 Shift Solenoid Circuit

Circuit Description

The autoshift high gear actuator is an ECM-driven solenoid that controls a Top 2 transmission.

Component Location

The autoshift high gear actuator is located on the topside of the transmission toward the back. Refer to an OEM diagram for the specific location.

Refer to Troubleshooting Fault Code t05-537

Last Modified: 02-Sep-2010


Autoshift Neutral Actuator

FAULT CODE 538

Autoshift Neutral Actuator

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 538 PID: S045 SPN: 719 FMI: 11/11 LAMP: Yellow SRT: | Either low voltage detected on autoshift neutral gear actuator circuit when + 12 VDC are commanded or voltage detected when no voltage is commanded. | Top 2 neutral actuator will not function properly. Transmission will not shift properly.
Top 2 Shift Solenoid Circuit

Circuit Description

The autoshift neutral actuator is an ECM-driven solenoid that controls a Top 2 transmission.

Component Location

The autoshift neutral actuator is located on the topside of the transmission toward the back. Refer to an OEM diagram for the specific location.

Refer to Troubleshooting Fault Code t05-538

Last Modified: 02-Sep-2010


ICON™ Starter Relay Input Circuit

FAULT CODE 541

ICON™ Starter Relay Input Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 541 PID: S123 SPN: 615 FMI: 11/31 LAMP: Yellow SRT: | Incorrect voltage detected at the ICON™ starter relay input circuit by the ECM. | The ICON™ system will be disabled. Mandatory shutdown can still be enabled. Engine can be started normally.
ICON™ Starter Relay/Interlock Circuit

Circuit Description

Incorrect voltage detected at the ICON™ starter relay circuit by the ECM.

Component Location

The ICON™ starter relay is located on the vehicle-side fire wall near the vehicle starter relay.

Shop Talk

This fault indicates a short circuit to battery/ground or an open ICON™ starter relay circuit. All interlock switches must be closed and the ICON™ lamp must be functional before the ICON™ system can be enabled for the engine to run while ICON™ is active. These circuits apply only when ICON™ is enabled.

Refer to Troubleshooting Fault Code t05-541

Last Modified: 02-Sep-2010


Top 2 Transmission Circuit - Mechanical System Failure

FAULT CODE 544

Top 2 Transmission Circuit - Mechanical System Failure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 544 PID: S151 SPN: 611 FMI: 7/7 LAMP: Yellow SRT: | Autoshift failure; at least three shift attempts were missed. | Top 2 transmission will not be controlled correctly. Transmission remains in manual mode.
Top 2 Transmission Circuit

Circuit Description

The Top 2 transmission circuit controls a Top 2 transmission to autoshift between the Top 2 gears.

Component Location

The Top 2 shift/lockout solenoids are on the topside of the transmission, near the back. Refer to an OEM diagram for the exact location.

Refer to Troubleshooting Fault Code t05-544

Last Modified: 02-Sep-2010


Fault Code Path Selection

FAULT CODE 551
Fault Code Path Selection

Do you have an IVS throttle pedal? | Go to 82-fc551ivs
Do you have an ISS throttle pedal? | Go to 82-fc551iss
Do you have an SSS throttle pedal? | Go to 82-fc551sss

Last Modified: 12-Jan-2004


Idle Validation Switch Circuit

FAULT CODE 551

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

ISS

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Engine will only idle.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The integrated sensor/switch (ISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by a loose connection, an accelerator pedal that is not calibrated, or an IVS that is wired wrong. Breakout cable, Part Number 3824892, is required to check the voltage levels of the SSS.
  • If all wiring and sensor checks are good, replace the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault clears, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from seeping into the cab.
  • Verify that the three idle validation switch circuit wires are twisted together.
  • The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is on.
  • With keyswitch on, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal.
Refer to Troubleshooting Fault Code t05-551iss

Last Modified: 02-Sep-2010


Idle Validation Switch Circuit

FAULT CODE 551

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

IVS

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Engine will only idle.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch (IVS) is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The IVS is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, an accelerator pedal that is not calibrated, or an IVS that is wired wrong. Breakout cable, Part Number 3824892, is required to check the voltage levels of the SSS.

  • If all wiring and sensor checks are good, replace the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault clears, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from seeping into the cab.
  • NOTE: Check that the three idle validation switch circuit wires are twisted together.
  • The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is on.
  • With keyswitch on, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal.
Refer to Troubleshooting Fault Code t05-551ivs

Last Modified: 02-Sep-2010


Idle Validation Switch Circuit

FAULT CODE 551

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

SSS

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Engine will only idle.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch (IVS) is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. Solid-state integrated sensor switch (SSS) is an active electronic component that requires voltage to inspect the circuit.

Component Location

The SSS is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, an accelerator pedal that is not calibrated, or an IVS that is wired wrong. Breakout cable, Part Number 3824892, is required to check the voltage levels of the SSS.

  • If all wiring and sensor checks are good, replace the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault clears, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from seeping into the cab.

Note: Check that the three idle validation switch circuit wires are twisted together.

  • The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. They must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is on.
  • With keyswitch on, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This maneuver will recalibrate the ECM and accelerator pedal.
Refer to Troubleshooting Fault Code t05-551sss

Last Modified: 02-Sep-2010


Fuel Inlet Restriction Sensor Circuit

FAULT CODE 581

Fuel Inlet Restriction Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 581 PID: P015 SPN: 1381 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on fuel inlet restriction sensor signal pin. | Fuel inlet restriction monitor deactivated.
Fuel Inlet Restriction Sensor Circuit

Circuit Description

The fuel inlet restriction sensor provides a fuel pressure signal to the electronic control module (ECM).

Component Location

The fuel inlet restriction sensor is located on the fuel filter head.

Shop Talk

This fault indicates that a short circuit of at least positive + 5 VDC has occurred at signal pin 28 on the actuator harness connector at the ECM.

Refer to Troubleshooting Fault Code t05-581

Last Modified: 02-Sep-2010


Fuel Inlet Restriction Sensor Circuit

FAULT CODE 582

Fuel Inlet Restriction Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 582 PID: P015 SPN: 1381 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the fuel inlet restriction sensor signal pin. | Fuel inlet restriction monitor deactivated.
Fuel Inlet Restriction Sensor Circuit

Circuit Description

The fuel inlet restriction sensor provides a fuel pressure signal to the electronic control module (ECM).

Component Location

The fuel inlet restriction sensor is located on the fuel filter head.

Shop Talk

  • This fault indicates that the voltage at signal pin 28 on the ECM is out of specification.
  • The ECM provides a supply voltage of + 4.75 to 5.25 VDC. The sensor signal voltage to the ECM is from + 4.16 to 4.83 VDC.
  • A quick check to determine if the sensor is functioning is to measure the pin-to-pin resistance of the sensor.

Description | Pin-to-Pin Resistance (k ohms)
Supply voltage to ground | 13.35
Supply voltage to signal | 1.77
Signal to ground | 14.68
Refer to Troubleshooting Fault Code t05-582

Last Modified: 02-Sep-2010


Fuel Inlet Restriction Sensor Circuit

FAULT CODE 583

Fuel Inlet Restriction Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 583 PID: P015 SPN: 1381 FMI: 1/18 LAMP: Yellow SRT: | Restriction has been detected by the fuel inlet restriction sensor. | Fuel inlet restriction monitor warning is set.
Fuel Inlet Restriction Sensor Circuit

Circuit Description

The fuel inlet restriction sensor provides a signal to the electronic control module (ECM).

Component Location

The fuel inlet restriction sensor is located on the inlet to the fuel filter head.

Shop Talk

This fault indicates that the fuel inlet restriction has exceeded 12 in Hg. Typical causes for this fault code include a plugged fuel filter and a collapsed fuel supply hose.

Refer to Troubleshooting Fault Code t05-583

Last Modified: 02-Sep-2010


ICON™ Starter Relay Input Circuit

FAULT CODE 588

ICON™ Starter Relay Input Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 588 PID: S121 SPN: 611 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the alarm circuit when low voltage was expected by the ECM. | The ICON™ system will be disabled. Only mandatory shutdown will be enabled. Engine can be started normally.
Engine Start Alarm Circuit

Circuit Description

The alarm circuit turns on the audible alarm to warn of an impending engine start.

Component Location

The ICON™ alarm is mounted on the vehicle's fire wall on the intake side of the engine.

Shop Talk

This fault typically indicates short circuit to battery or an open circuit. The fan 2 clutch feature is not used.

Refer to Troubleshooting Fault Code t05-588

Last Modified: 02-Sep-2010


Engine Start Alarm Circuit

FAULT CODE 589

Engine Start Alarm Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 589 PID: S121 SPN: 611 FMI: 4/4 LAMP: Yellow SRT: | Less than + 6 VDC detected at the engine start alarm circuit when high voltage was expected by the ECM. | The ICON™ idle control system will be disabled. Only mandatory shutdown will be enabled. Engine can be started normally.
Engine Start Alarm Circuit

Circuit Description

The engine start alarm circuit turns on the audible engine start alarm to warn of an impending automatic engine start.

Component Location

The engine start alarm is located on the vehicle's fire wall on the intake side of the engine.

Shop Talk

This fault typically indicates an open circuit between the alarm coil (pins A and B), or from pin B of the alarm to battery voltage, or from pin A of the alarm to pin 32 of the ECM. Another typical cause for this fault code is a short circuit from pin A or B of the alarm, or from ECM pin 32 to ground. The alarm must sound for 14 seconds before an engine start. The alarm is actuated by supplying a signal from pin 25 of the ECM connector to pin B of the alarm connector.

Refer to Troubleshooting Fault Code t05-589

Last Modified: 02-Sep-2010


Voltage Monitor - High Voltage

FAULT CODE 596

Voltage Monitor - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Yellow SRT: | High battery voltage detected by the battery voltage monitor feature. | Yellow lamp will be lit until high battery voltage condition is corrected.
Voltage Monitor Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire of the OEM harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Overcharged batteries caused by a faulty alternator or regulator.
Refer to Troubleshooting Fault Code t05-596

Last Modified: 02-Sep-2010


Voltage Monitor - Low Voltage

FAULT CODE 597

Voltage Monitor - Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 67 FMI: 1/18 LAMP: Yellow SRT: | ICON™ has restarted the engine three times in 7 hours due to low battery voltage. | The engine will run continuously. The ICON™ system will not be disabled. Accessories will not be on.
Voltage Monitor Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire of the OEM harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for the battery location.

Shop Talk

Make certain that the ECM unswitched battery supply is coming directly from the battery and not the starter.

The following are possible causes of this fault:

  • Undercharged batteries caused by a faulty alternator or regulator
  • High-current devices on the vehicle such as refrigerators, citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code t05-597

Last Modified: 02-Sep-2010


Voltage Monitor - Very Low Voltage

FAULT CODE 598

Voltage Monitor - Very Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Very low battery voltage detected by the battery voltage monitor feature. | Red lamp lit until very low battery voltage condition is corrected. The electronic control module (ECM) can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. The engine will run continuously if ICON™ is active (automotive only).
Voltage Monitor Supply Circuit

Circuit Description

The ECM receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire of the OEM harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Undercharged batteries caused by a faulty alternator or regulator.
Refer to Troubleshooting Fault Code t05-598

Last Modified: 02-Sep-2010


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect. Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
ISX and ISM - Adaptive Cruise Control Circuit

Circuit Description

The adaptive cruise control unit communicates with the engine control module (ECM) sending and receiving vehicle speed control messages through the SAE J1939 data link.

Component Location

The location of the adaptive cruise control unit will vary by equipment manufacturer. Refer to the equipment manufacturer service information for specific location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the adaptive cruise control module for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Refer to Troubleshooting Fault Code t05-784.

Last Modified: 23-Nov-2015


Cylinder Power Imbalance

FAULT CODE 951

Cylinder Power Imbalance

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 951 PID: P166 SPN: 166 FMI: 2/2 LAMP: None SRT: | Cylinder Power Imbalance Between Cylinders. A power imbalance between cylinders was detected by the electronic control module (ECM). | Engine can have rough idle or misfire.
Cylinder Power Imbalance

Circuit Description

The ECM calculates the power output of each cylinder at engine idle speeds.

Component Location

The ECM is located on the fuel system side of the engine. It is attached at the cylinder head between cylinders 2 and 3.

Shop Talk

At engine idle speeds, the ECM measures the instantaneous acceleration of each cylinder as it fires, to determine the cylinder's power. The ECM adjusts fueling to individual cylinders if the imbalance is within pre-defined limits. If the imbalance is greater than the pre-defined limits, Fault Code 951 will be set active.

Refer to Troubleshooting Fault Code t05-951

Last Modified: 02-Sep-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 497 - Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 497 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) switch circuit. |
 | STEP 2A. Inspect the OEM switch. | Dirty or damaged pins?
 | STEP 2B. Check the OEM switch. | Multiple unit synchronization switch and the multi-unit synchronization complementary switch operating correctly?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 497 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Check if an ECM calibration is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 497 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM switch circuit.

Guided Step 2A - Inspect the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multiple unit synchronization switch from the OEM harness.
  • Disconnect the multple unit synchronization complementary switch from the OEM harness.

Action

Inspect the multi-unit synchronization switch, multi-unit synchronization complementary switch, and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multi-unit synchronization switch from the OEM harness.
  • Disconnect the multi-unit synchronization complementary switch from the harness.

Action

Check the functionality of the multi-unit synchronization switch and the multi-unit synchronization complementary switch.

Use the following procedure for troubleshooting information for the multi-unit synchronization switch. Refer to Procedure 019-270 in Section 19.

Multi-unit synchronization switch and the multi-unit synchronization complementary switch operating correctly?
YES NO
No Repair

Repair

Replace the multi-unit synchronization switch or the multi-unit synchronization complementary switch. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the multiple unit synchronization switch from the harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the multiple unit synchronization switch pin in the OEM harness ECM connector and all other pins in the OEM connector.
  • Measure the resistance between the multiple unit synchronization complimentary switch pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from ECM.
  • Disconnect the multi-unit synchronization switch from the OEM harness.
  • Disconnect the multi-unit synchronization complimentary switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the multiple unit synchronization switch pin in the OEM harness ECM connector and ground.
  • Measure the resistance between the multiple unit synchronization complementary switch pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the multiple unit synchronization complimentary switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM harness ECM connector multiple unit synchronization switch pin and the OEM harness multiple unit synchronization switch pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 497 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Nov-2014


NO TITLE

Information Fault Codes

NOTE: - Information Fault Codes have simple, corrective actions and no fault code troubleshooting tree.
- SRT 00-394 applies to all of the Information Fault Codes listed below.
- After correcting the condition that caused the fault, let the engine warm up; then let the engine run for 1 minute to inactivate the fault code. Then, use INSITE™ to clear the fault code.

CODE: 143
LAMP: Yellow
REASON: Oil pressure signal indicates oil pressure is below the low-pressure engine protection limit.
EFFECT: Progressive power and speed derate with increasing time after alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the Low Oil Pressure symptom troubleshooting procedure in the ISM/QSM11 Series Engines, Troubleshooting and Repair Manual, Bulletin No. 3666322-00.
CODE: 151
LAMP: Red
REASON: Coolant temperature signal indicates temperature is above 104°C (220°F).
EFFECT: Progressive power derate with increasing time after alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the High Coolant Temperature symptom troubleshooting procedure in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00.
CODE: 155
LAMP: Red
REASON: Intake manifold temperature signal indicates temperature is above 93°C (200°F).
EFFECT: Progressive power derate with increasing time after alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the High Intake Manifold Temperature symptom troubleshooting procedure in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00.
CODE: 211
LAMP: None
REASON: Additional OEM or vehicle diagnostic codes have been logged. Check other ECMs for diagnostic codes.
EFFECT: None on engine performance.
ACTION: Refer to the appropriate OEM manual for assistance in troubleshooting this fault.
CODE: 214
LAMP: Red
REASON: Oil temperature signal indicates oil temperature is above 123.9°C (255°F).
EFFECT: Progressive power derate with increasing time after alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the High Oil Temperature symptom troubleshooting procedure in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00.
CODE: 219
LAMP: Maintenance
REASON: Low oil level was detected in the Centinel™ makeup oil tank.
EFFECT: None on performance. Centinel™ system deactivated.
ACTION: Add engine oil to the Centinel™ makeup oil tank. If fault remains active with a full oil tank, remove and clean the oil level sensor.
CODE: 287
LAMP: Red
REASON: The OEM vehicle electronic control unit (VECU) detected a fault with its throttle pedal.
EFFECT: The engine will only idle.
ACTION: Refer to the OEM troubleshooting and repair manual. Troubleshoot the accelerator pedal connected to the OEM supplied vehicle electronic control unit (VECU).
CODE: 288
LAMP: Red
REASON: The OEM vehicle electronic control unit (VECU) detected a fault with its remote throttle.
EFFECT: The engine will NOT respond to the remote throttle.
ACTION: Refer to the OEM Troubleshooting and Repair Manual. Troubleshoot the remote throttle pedal connected to the OEM supplied vehicle electronic control unit (VECU).
CODE: 295
LAMP: Yellow
REASON: An error in the ambient air pressure sensor signal was detected by the ECM.
EFFECT: Engine is derated to no-air setting.
ACTION: Verify ambient air pressure value is from 25.0 in Hg to 30.5 in Hg using INSITE™. Replace ambient air pressure sensor if necessary.
CODE: 299
LAMP: Yellow
REASON: The engine was shut down by a device other than the keyswitch before the proper engine cool down resulting in a filtered load factor above the maximum shutdown threshold.
EFFECT: No action taken by the ECM.
ACTION:
CODE: 415
LAMP: Red
REASON: Oil pressure signal indicates oil pressure below the very low oil pressure engine protection limit.
EFFECT: Progressive power derate with increasing time after alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the Low Oil Pressure symptom troubleshooting procedure in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00.
CODE: 418
LAMP: Maintenance
REASON: Water has been detected in the fuel filter.
EFFECT: Possible white smoke, loss of power, or hard starting.
ACTION: Drain water from fuel filter. Refer to the Water in Fuel symptom troubleshooting procedure in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00, if fault reoccurs frequently.
CODE: 419
LAMP: Yellow
REASON: An error in the intake manifold pressure sensor signal was detected by the ECM.
EFFECT: Engine is derated to no-air setting.
ACTION: Verify intake manifold pressure value is from -2.5 in Hg to 2.5 in Hg using INSITE™. Replace intake manifold pressure/temperature sensor if necessary.
CODE: 435
LAMP: Yellow
REASON: An error in the oil pressure sensor signal was detected by the ECM.
EFFECT: None on performance. No engine protection for oil pressure.
ACTION: Verify oil pressure valve is from -1.5 psi to 4.0 psi when the engine is stopped using INSITE™. Replace oil pressure/temperature sensor if necessary.
CODE: 471
LAMP: Yellow
REASON: Low crankcase oil level was detected by the ECM.
EFFECT: None on performance. Centinel™ system is deactivated.
ACTION:
CODE: 595
LAMP: Yellow
REASON: Turbocharger overspeed protection fault.
EFFECT: The engine will run derated.
ACTION: Refer to the High Turbocharger Speed symptom troubleshooting procedure in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00.
CODE: 611
LAMP: None
REASON: Engine shutdown by operator before the proper engine cool down, resulting in filtered load factor above maximum shutdown threshold.
EFFECT: No action taken by the ECM.
ACTION: Refer to the Hot Shutdown symptom troubleshooting procedures.
CODE: 775
LAMP: Maintenance
REASON: A slow leak has been detected in the air system.
EFFECT: None on performance.
ACTION: Check the vehicle air system for leaks. Refer to Section 012-019 in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00.
CODE: 776
LAMP: Yellow
REASON: A fast leak has been detected in the air system.
EFFECT: None on performance.
ACTION: Check the vehicle air system for leaks. Refer to Section 012-019 in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00.
CODE: 951
LAMP: None
REASON: A power imbalance between cylinders was detected by the ECM.
EFFECT: Engine can possibly have rough idle or misfire.
ACTION: Check fuel quality. Check for air being ingested by the fuel. It is normal to have an inactive Fault Code 951 after a service procedure introduced air into the fuel system, such as a filter change. Perform Cylinder Performance Test to determine if a particular cylinder or cylinders are high or low on power. Refer to Procedure 014-008 Cylinder Performance Test in the ISM/QSM11 Series Engines Troubleshooting and Repair Manual, Bulletin No. 3666322-00.

Last Modified: 28-Jun-2002


FAULT CODE 111 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all the components.

Action

Check the ECM.

  • Turn keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 111 inactive?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ to read the inactive counts of Fault Code 111.
OK NOT OK

Less than 3 counts?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for at least 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 111 is inactive.
OK NOT OK

Fault Code 111 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Jan-2014


FAULT CODE 115 - Engine Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine position sensor. |
 | STEP 1A. Inspect the engine position sensor and the sensor harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Inspect the engine position sensor. | No damaged engine position sensor?
 | STEP 1D. Check the resistance of the engine position sensor. | 1000 to 2000 ohms?
 | STEP 1E. Check for a short circuit between the coils. | Greater than 100k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | 1000 to 2000 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine position sensor.

Guided Step 1A - Inspect the engine position sensor and the sensor harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Inspect the sensor harness and the engine position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace engine position sensor. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the sensor connector to the engine block ground.
  • Measure the resistance from pin B of the sensor connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine position sensor

Refer to Procedure 019-038 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the engine position sensor.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Remove the engine position sensor.

Action

Inspect the engine position sensor for damage.

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear or flywheel ring gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.
OK NOT OK

No damaged engine position sensor?

Replace the engine position sensor

Refer to Procedure 019-038 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check the resistance of the engine position sensor.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Check the resistance of the engine position sensor.

  • Measure the resistance from pin A to pin D of the engine position sensor.
  • Measure the resistance from pin B to pin C of the engine position sensor.
OK NOT OK

1000 to 2000 ohms?

Replace the engine position sensor

Refer to Procedure 019-038 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit between the coils.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for a short circuit between the coils.

  • Measure the resistance from pin A to pin B of the engine position sensor.
OK NOT OK

Greater than 100k ohms

Replace the engine position sensor

Refer to Procedure 019-038 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the sensor harness from the engine position sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine position sensor and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for short circuit to the ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check for short circuit to ground.

  • Measure the resistance from pin 47 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 50 of the sensor harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 47 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 48 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 49 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 50 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Connect the sensor harness to the engine position sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 49 to pin 50 of the sensor harness connector.
  • Measure the resistance from pin 47 to pin 48 of the sensor harness connector.
OK NOT OK

1000 to 2000 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ to verify Fault Code 115 is inactive.
OK NOT OK

Fault Code 115 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 121 - Engine Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine position sensor. |
 | STEP 1A. Inspect the engine position sensor and engine harness connectors. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Inspect the engine position sensor. | No damaged engine position sensor?
 | STEP 1D. Check the resistance of the engine position sensor. | 1000 to 2000 ohms?
 | STEP 1E. Check for a short circuit between the coils. | Greater than 100k ohms?
STEP 2. | Check the sensor harness and the ECM connector pins. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | 1000 to 2000 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine position sensor.

Guided Step 1A - Inspect the engine position sensor and the engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Inspect the engine position sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position sensor. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the sensor connector to engine block ground.
  • Measure the resistance from pin B of the sensor connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine position sensor

Refer to Procedure 019-038 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the engine position sensor.

Action

Inspect the engine position sensor and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check the resistance of the engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check the resistance of the engine position sensor.

  • Measure the resistance from pin A to pin D of the engine position sensor.
  • Measure the resistance from pin B to pin C of the engine position sensor.
OK NOT OK

1000 to 2000 ohms?

Replace the engine position sensor.

Refer to Procedure 019-038 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit between the coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for a short circuit between the coils.

  • Measure the resistance from pin A to pin B of the engine position sensor.
OK NOT OK

Greater than 100k ohms?

Replace the engine position sensor

Refer to Procedure 019-038 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 47 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 50 of the sensor harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 47 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 48 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 49 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 50 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Connect the sensor harness to the engine position sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 49 to pin 50 of the sensor harness connector.
  • Measure the resistance from pin 47 to pin 48 of the sensor harness connector.
OK NOT OK

1000 to 2000 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Using INSITE™ electronic service tool to verify Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure sensor. |
 | STEP 1A. Inspect the intake manifold pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 122 active?
 | STEP 1C. Check the intake manifold pressure sensor supply voltage. | + 4.75 to 5.25 VDC?
 | STEP 1C-1. Measure the voltage to the sensor. |
 | STEP 1C-2. Measure the voltage from the ECM. |
 | STEP 1D. Check the intake manifold pressure sensor signal voltage. | + 0.70 to 1.40 VDC?
 | STEP 2D-1. Check for a short circuit from pin-to-pin. |
 | STEP 1D-2. Check the resistance in the sensor harness. |
 | STEP 1D-3. Check for an ECM response. |
 | STEP 1D-4. Check the signal pin to return pin resistance. |
STEP 2. | Check the engine harness and the ECM. |
 | STEP 2A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 122 active?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the resistance of the sensor harness. | Less than 10 ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 122 inactive and Fault Code 123 active?
 | STEP 3B. Check the ECM signal to ground resistance. | Less than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold pressure sensor.

Guided Step 1A - Inspect the intake manifold pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or replace the intake manifold pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active?

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Disconnect all pressure and temperature sensors from the engine harness.
  • Disconnect the coolant level sensor or shorting plug from the engine harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

+ 4.75 to 5.25 VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage to the sensor.

Conditions

  • Disconnect all pressure and temperature sensors from their connectors on the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824774, to the sensor harness connector.
  • Note: Do not connect the sensor to the breakout cable
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

+ 4.75 to 5.25 VDC?

Replace the intake manifold pressure sensor

Refer to Procedure 019-061 in Section 19.

Does not meet specifications.

Go to 4A

Go to 1C-2

Guided Step 1C-2 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage out of the ECM from pin 40 to pin 37 at the ECM sensor port.
OK NOT OK

+ 4.75 to 5.25 VDC?

Replace the intake manifold pressure sensor

Refer to Procedure 019-061 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check the intake manifold pressure sensor signal voltage.

Conditions

  • Disconnect all sensors from their connectors on the sensor harness, except the intake manifold pressure sensor.
  • Disconnect the coolant level sensor or shorting plug from the sensor harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor signal voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Measure the signal voltage from pin C to pin B of the breakout cable.
OK NOT OK

+ 0.70 to 1.40 VDC?

Does not meet specifications.

Go to 2A

Go to 1D-1

Guided Step 1D-1 - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all sensors and the coolant level sensor or shorting plug from their connectors.

Action

Check for a short pin to pin.

  • Measure resistance from pin 40 of the sensor harness connector to all other pins in the connector.
  • Measure resistance from pin 39 of the sensor harness connector to all other pins in the connector.
  • Measure resistance from pin 37 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-2

Go to 4A

Guided Step 1D-2 - Check the resistance in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for resistance in the sensor harness.

  • Measure the resistance from pin 37 of the sensor harness connector to pin A of the sensor connector.
  • Measure the resistance from pin 40 of the sensor harness connector to pin B of the sensor connector.
  • Measure the resistance from pin 39 of the sensor harness connector to pin C of the sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-3

Go to 4A

Guided Step 1D-3 - Check for an ECM response.

Conditions

  • Disconnect sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 inactive and Fault Code 123 active?

Fault Code 122 active

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 1D-4

Go to 4A

Guided Step 1D-4 - Check the signal pin to return pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from the ECM.

Action

Check signal pin to return pin resistance.

  • Measure the resistance from pin 39 to pin 40 at the sensor port of the ECM.
OK NOT OK

Less than 100k ohms?

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

Greater than 100k ohms?

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 2 - Check the engine harness and the ECM.

Guided Step 2A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active?

Repair complete.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all sensors from their connectors on the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 40 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 39 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 37 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the resistance of the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from ECM.
  • Disconnect intake manifold pressure sensor from sensor harness.

Action

Check the resistance of the sensor harness.

  • Measure the resistance from pin 39 of the sensor harness connector to pin C of the sensor connector.
  • Measure the resistance from pin 40 of the sensor harness connector to pin B of the sensor connector.
  • Measure the resistance from pin 37 of the sensor harness connector to pin A of the sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 inactive and Fault Code 123 active?

Fault Code 122 active

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the ECM signal to ground resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the ECM signal pin resistance.

  • Measure the resistance from pin 39 of the ECM sensor port to engine block ground.
OK NOT OK

Less than 100k ohms?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 122 is inactive.
OK NOT OK

Fault Code 122 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 inactive?
STEP 2. | Check for a mechanical failure. |
 | STEP 2A. Make sure of the proper operation of the turbocharger. | Positive intake manifold pressure from the turbocharger?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Inspect the intake manifold pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 123 inactive?
 | STEP 3C. Check the ECM intake manifold pressure sensor supply voltage. | + 4.75 to 5.25 VDC?
 | STEP 3C-1. Measure the voltage from the ECM. |
 | STEP 3D. Check the ECM intake manifold pressure sensor signal voltage. | + 0.42 to 0.58 VDC?
 | STEP 3D-1. Check for a short circuit to ground. |
 | STEP 3D-2. Check for a short circuit from pin-to-pin. |
STEP 4. | Check the sensor harness. |
 | STEP 4A. Inspect the sensor harness and the ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 123 inactive?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check for an ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 123 inactive and Fault Code 122 active?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 352 inactive?

Possible sensor failure, short circuit to ground in sensor +5-VDC common supply, or short circuit from pin-to-pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check for a mechanical failure.

Guided Step 2A - Make sure of the proper operation of the turbocharger.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Make sure of the proper operation of the turbocharger.

  • Check for the positive intake manifold pressure.
OK NOT OK

Positive intake manifold pressure from the turbocharger?

Low intake manifold pressure?

Correct the base engine malfunction causing low intake manifold pressure.

Go to 3A

Go to 6A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Inspect the intake manifold pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the engine harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or the intake manifold pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 inactive?

Fault Code 123 active.

Go to 6B

Go to 3C

Guided Step 3C - Check the ECM intake manifold pressure sensor supply voltage.

Conditions

  • Install the breakout cable between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

+ 4.75 to 5.25 VDC?

Go to 3D

Go to 3C-1

Guided Step 3C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage at the ECM from pin 37 to pin 40 of the ECM sensor port.
OK NOT OK

+ 4.75 to 5.25 VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 3D - Check the ECM intake manifold pressure sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3824774 between the intake manifold pressure sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage from pin B (or BLACK) to pin C (or YELLOW) of the breakout cable.
OK NOT OK

+ 0.42 to 0.58 VDC?

Does not meet specifications.

Go to 3D-1

Go to 4A

Guided Step 3D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 39 of the sensor harness connector to chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3D-2

Go to 6A

Guided Step 3D-2 - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 39 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the intake manifold pressure sensor

Refer to Procedure 019-059 in Section 19.

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 6A

Guided Step 4 - Check the sensor harness.

Guided Step 4A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace engine harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 inactive?

Fault Code 123 active.

Go to 6B

Go to 4C

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 39 of the sensor harness connector to pin C of the intake manifold pressure sensor connector, harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for an ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire between ECM sensor port pin 37 and pin 39.
OK NOT OK

Fault Code 123 inactive?

Fault Code 122 active?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 123 is inactive.
OK NOT OK

Fault Code 123 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 131 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect the harness and the accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the accelerator position resistance. | 250 to 3000 ohms?
 | STEP 1C. Check the resistance between sensor pins. Note: Take the measurement when the pedal is depressed and released. | Released: 1500 to 3000 ohms, Depressed: 250 to 1500 ohms, Released resistance must be at least 1000 ohms more than depressed resistance
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness, bulkhead connector, and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance between the + 5-VDC SUPPLY and RETURN wires. | 2000 to 3000 ohms?
 | STEP 2C. Check the resistance in the + 5-VDC SUPPLY wire and SIGNAL wire circuit. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit between the accelerator position SIGNAL wire and the RETURN wire in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit between the accelerator position SIGNAL wire and another SIGNAL wire or the switch SUPPLY wire. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit between the accelerator position SIGNAL wire and the wires connected to the stop lamp, warning lamp, and maintenance lamp. | Greater than 100k ohms?
 | STEP 2G. Check for a short circuit between the accelerator position SIGNAL wire and all other wires in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the + 5-VDC supply and the accelerator position sensor return on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Note: Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for IVS, a 6-pin repair connector, Part Number 3824910, for ISS, and the breakout cable, Part Number 3824892, for SSS if needed.

OK NOT OK

250 to 3000 ohms?

Replace the accelerator position sensor

Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Note: Take the measurement when the pedal is depressed and released.

  • Measure the resistance between the + 5-VDC SUPPLY and the SIGNAL wire on the sensor side of the accelerator position sensor.

Note: Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for IVS, a 6-pin repair connector, Part Number 3824910, for ISS, and the breakout cable, Part Number 3824892, for SSS if needed.

OK NOT OK

Released: 1500 to 3000 ohms?

Depressed: 250 to 1500 ohms?

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the harness, bulkhead connector, and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness, bulkhead connector, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty of damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the resistance between the + 5-VDC SUPPLY and RETURN wires.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance between the (+) 5-VDC SUPPLY and RETURN wires.

  • Measure the resistance between pin 48 and pin 49 in the OEM harness when the accelerator pedal is up or down.
OK NOT OK

2000 to 3000 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check the resistance in the + 5-VDC SUPPLY wire and SIGNAL wire circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance in the (+) 5-VDC SUPPLY wire and SIGNAL wire circuit.

  • Measure the resistance between pin 48 and pin 47 when the accelerator pedal is released and when it is depressed.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit between the accelerator position SIGNAL wire and the RETURN wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and the RETURN wire in the OEM harness.

  • Measure the resistance from pin 47 to pin 49 in the OEM harness connector.

Note: Turn all cab switches to the OFF or NEUTRAL position. Use the trailer handbrake to set the service brake. Disconnect the clutch switch and the idle validation switch.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit between the accelerator position SIGNAL wire and another SIGNAL wire or the switch SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the clutch and brake switches.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and another wire or the switch SUPPLY wire.

  • Measure the resistance between pin 47 and pins 1, 2, 3, and 13 of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit between the accelerator position SIGNAL wire and the wires connected to the stop lamp, warning lamp, and maintenance lamp.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and the wires connected to the stop lamp, warning lamp, and maintenance lamp.

  • Measure the resistance between pin 47 and pins 5, 6, and 16 of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2G

Go to 3A

Guided Step 2G - Check for a short circuit between the accelerator position SIGNAL wire and all other wires in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and the other SIGNAL wires in the OEM harness.

  • Measure the resistance between pin 47 and all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and depress the accelerator pedal to full position three times. Release the pedal and turn the keyswitch off.
  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Jul-2012


FAULT CODE 132 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect the harness and the accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the accelerator position sensor resistance. | 2000 to 3000 ohms?
 | STEP 1C. Check for a short circuit to ground in the sensor +5-VDC supply. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit to ground in the sensor SIGNAL wire. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the SUPPLY or SIGNAL wires of the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground in the accelerator position sensor + 5-VDC supply circuit. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the accelerator position sensor signal circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit between the positive +5-VDC SUPPLY wire and any other wire in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit between the accelerator position SIGNAL wire and any other wire in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 132 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between pins on the sensor.

  • Measure the resistance between the + 5-VDC supply and the accelerator position sensor return on the sensor side of the accelerator position sensor connector, when the accelerator pedal is released.

Note: Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for IVS, a 6-pin repair connector, Part Number 3824910, for ISS, and the breakout cable, Part Number 3824892, for SSS, if needed.

OK NOT OK

2000 to 3000 ohms?

Replace the accelerator position sensor

Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground in the sensor +5-VDC supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the sensor (+) 5-VDC supply.

  • Measure the resistance from the positive +5-VDC supply on the sensor side of the accelerator position sensor to chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the accelerator position sensor

Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground in the sensor SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the sensor SIGNAL wire.

  • Measure the resistance from the SIGNAL pin of the accelerator position sensor to chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the accelerator position sensor

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the SUPPLY or SIGNAL wires of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the SUPPLY or the SIGNAL wires of the OEM harness.

  • Measure the resistance between pin 47 of the OEM harness connector and the SIGNAL wire on the harness side of the accelerator sensor.
  • Measure the resistance between pin 48 of the OEM harness connector and the +5-VDC supply on the harness side of the accelerator position sensor.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground in the accelerator position sensor +5-VDC supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the accelerator position sensor (+) 5-VDC supply circuit.

  • Measure the resistance between pin 48 of the OEM harness and the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the accelerator position sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the accelerator position sensor signal circuit.

  • Measure the resistance from pin 47 of the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit between the +5-VDC SUPPLY wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit between the (+) 5-VDC SUPPLY wire and any other wire in the OEM harness.

  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit between the accelerator position SIGNAL wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit between the accelerator position SIGNAL wire and any other wire in the OEM harness.

  • Measure the resistance between pin 47 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and depress the accelerator pedal to full position four times. Release the pedal and turn the keyswitch OFF.
  • Use INSITE™ electronic service tool to verify Fault Code 132 is inactive.
OK NOT OK

Fault Code 132 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 133 - Remote Throttle Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Isolate the remote throttle position sensor circuit. |
 | STEP 1A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for active fault codes. | Fault Codes 131, 132, and 352 are active?
 | STEP 1C. Disconnect the remote throttle connector; check if fault code deactivates. | Fault Code 133 active?
STEP 2. | Check the remote throttle position sensor. |
 | STEP 2A. Inspect the harness and the remote throttle position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote throttle position sensor resistance. | 250 to 3000 ohms?
 | STEP 2C. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms Depressed: 250 to 1500 ohms Released resistance must be at least 1000 ohms more than depressed resistance.
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance between the + 5-VDC SUPPLY and RETURN wires. | 2000 to 3000 ohms?
 | STEP 3C. Check for an open circuit in the RETURN wire. | Greater than 100k ohms?
 | STEP 3D. Check the resistance in the + 5-VDC SUPPLY wire and SIGNAL wire circuit. | Released: 1500 to 3000 ohms Depressed: 250 to 1500 ohms
 | STEP 3E. Check for a short circuit between the remote throttle position SIGNAL wire and the SUPPLY wire in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for a short circuit between the remote throttle position SIGNAL and SUPPLY wires to all other wires in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Isolate the remote throttle position sensor circuit.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the OEM harness and the remote throttle position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the remote throttle position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.
OK NOT OK

Fault Codes 131, 132, and 352 are active

Fault Code 131 inactive

Go to 1C

Go to 4A

Guided Step 1C - Disconnect the remote throttle connector; check if fault code deactivates.

Conditions

  • Disconnect the remote throttle connector.

Action

Check for fault code deactivates.

  • Use INSITE™ electronic service tool to check for inactive fault codes.
OK NOT OK

Fault Code 133 active

Fault Code 133 inactive

Replace the remote throttle position sensor

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the remote throttle position sensor.

Guided Step 2A - Inspect the harness and the remote throttle position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the remote throttle position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the remote throttle position sensor. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the remote throttle position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for an open or short circuit between pins in the remote throttle position sensor.

  • Measure the resistance between the + 5-VDC supply and the remote throttle position sensor return on the sensor side of the remote throttle position sensor when the remote throttle is released and when it is depressed.
OK NOT OK

250 to 3000 ohms?

Replace the remote throttle position sensor

Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check the resistance between sensor pins.

Note: Take the measurement when the pedal is depressed and released.

  • Measure the resistance between the + 5-VDC SUPPLY and the SIGNAL wire on the sensor side of the remote throttle position sensor.
OK NOT OK

Released: 1500 to 3000 ohms, Depressed: 250 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the remote throttle position sensor

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the remote throttle.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance between the + 5-VDC SUPPLY and RETURN wires.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the remote throttle position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance between the (+) 5-VDC SUPPLY and RETURN wires.

  • Measure the resistance between pin 48 and pin 49 in the OEM harness when the remote throttle pedal is up or down.
OK NOT OK

2000 to 3000 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 49 of the OEM harness connector to pin C (or 3) of the remote throttle position sensor connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance in the + 5-VDC SUPPLY wire and the SIGNAL wire circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the remote throttle position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance in the (+) 5-VDC SUPPLY wire and the SIGNAL wire circuit.

  • Measure the resistance between pin 48 and pin 21 of the OEM harness connector when the remote throttle is released and when it is depressed.
OK NOT OK

Released: 1500 to 3000 ohms Depressed: 250 to 1500 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit between the remote throttle position SIGNAL wire and the SUPPLY wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the remote throttle position SIGNAL wire and the SUPPLY wire in the OEM harness.

  • Measure the resistance from pin 48 of the OEM harness connector to pin B (or 2) of the remote throttle position sensor connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit between the remote throttle position SIGNAL and SUPPLY wires to all other wires in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the negative battery terminal.

Action

Check for a short circuit between the remote throttle position SIGNAL and SUPPLY wires to all other wires in the OEM harness connector.

  • Measure the resistance from pin 21 and pin 48 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in SEction 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and depress the remote throttle to full position three times. Release the remote throttle and turn the keyswitch to OFF.
  • Start the engine and idle for one minute.
  • UsE INSITE™ to verify that Fault Code 133 is inactive.
OK NOT OK

Fault Code 133 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Jul-2012


FAULT CODE 134 - Remote Throttle Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Isolate the remote throttle position sensor circuit. |
 | STEP 1A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for active fault codes. | Fault Code 132 active?
 | STEP 1C. Disconnect the remote throttle connector; check if fault code deactivates. | Fault Code 134 active?
STEP 2. | Check the remote throttle position sensor. |
 | STEP 2A. Inspect the harness and the remote throttle position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote throttle position sensor resistance. | 2000 to 3000 ohms?
 | STEP 2C. Check for a short circuit to ground in the remote throttle position sensor + 5-VDC SUPPLY wire. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the remote throttle position sensor SIGNAL wire. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the SUPPLY or SIGNAL wires of the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the remote throttle position sensor + 5-VDC supply circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the remote throttle position sensor signal circuit. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit between the remote throttle position sensor + 5-VDC SIGNAL wire and any other wire in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for a short circuit between the remote throttle position sensor SIGNAL wire and any other wire in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Isolate the remote throttle position sensor circuit.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the OEM harness and the remote throttle position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the remote throttle position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to check for active codes.
OK NOT OK

Fault Code 132 active?

Fault Code 132 inactive.

Go to 1C

Go to 4A

Guided Step 1C - Disconnect the remote throttle connector; check if fault code deactivates.

Conditions

  • Disconnect the remote throttle connector.

Action

Check for deactivation of fault codes.

  • Use INSITE™ electronic service tool to check for inactive fault codes.
OK NOT OK

Fault Code 134 active?

Fault Code 134 inactive

Replace the remote throttle position sensor

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the remote throttle position sensor.

Guided Step 2A - Inspect the harness and the remote throttle position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the remote throttle position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the remote throttle position sensor. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the remote throttle position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for an open or short circuit between pins in the remote throttle position sensor.

  • Measure the resistance between the + 5-VDC supply and the remote throttle position sensor return on the sensor side of the remote throttle position sensor when the remote throttle is released.
OK NOT OK

2000 to 3000 ohms?

Replace the remote throttle position sensor

Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the remote throttle position sensor + 5-VDC SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for short circuit to ground in the remote throttle position sensor (+) 5 VDC supply.

  • Measure the resistance between the + 5-VDC supply on the sensor side of the remote throttle position sensor and the chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the remote throttle position sensor.

Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the remote throttle position sensor SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for a short circuit to ground in the remote throttle position sensor SIGNAL wire.

  • Measure the resistance between the SIGNAL wire on the sensor side of the remote throttle position sensor and the chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the remote throttle position sensor

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the SUPPLY or SIGNAL wires of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the SUPPLY or SIGNAL wires of the OEM harness.

  • Measure the resistance between pin 48 of the OEM harness connector and the + 5-VDC supply on the harness side of the remote throttle position sensor.
  • Measure the resistance between pin 21 of the OEM harness connector and the SIGNAL wire on the harness side of the remote throttle position sensor.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the remote throttle position sensor + 5-VDC supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the remote throttle position sensor (+) 5-VDC supply circuit.

  • Measure the resistance between pin 48 of the OEM harness connector and the chassis ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the remote throttle position sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the remote throttle position sensor signal circuit.

  • Measure the resistance between pin 21 of the OEM harness connector and the chassis ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit between the remote throttle position sensor + 5-VDC SUPPLY wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM negative (-) battery terminal.

Action

Check for a short circuit between the remote throttle position sensor (+) 5-VDC SUPPLY wire and any other wire in the OEM harness.

  • Measure the resistance between pin 48 of the OEM harness connector and all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit between the remote throttle position sensor SIGNAL wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM negative (-) battery terminal.

Action

Check for a short circuit between remote throttle position sensor SIGNAL wire and any other wire in the OEM harness.

  • Measure the resistance between pin 21 of the OEM harness connector and all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and depress the remote throttle to full position three times. Release the remote throttle and turn the keyswitch OFF.
  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify the Fault Code 134 is inactive.
OK NOT OK

Fault Code 134 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Jul-2012


FAULT CODE 135 - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure/temperature sensor. |
 | STEP 1A. Inspect the oil pressure/temperature sensor and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 135 inactive?
 | STEP 1C. Check the oil pressure/temperature sensor supply voltage. | +4.75 to 5.25 VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the oil pressure/temperature sensor signal voltage. | + 0.50 to 1.40 VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins or loose connection?
 | STEP 2B. Read the fault codes. | Fault Code 135 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 135 inactive and Fault Code 141 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the oil pressure/temperature sensor.

Guided Step 1A - Inspect the oil pressure/temperature sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the oil pressure/temperature sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 inactive?

Fault Code 135 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the oil pressure/temperature sensor supply voltage.

Conditions

  • Install breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the oil pressure/temperature sensor supply voltage.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

+ 4.75 to 5.25 VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage at the ECM from pin 45 to pin 43 of the ECM sensor port.
OK NOT OK

+4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check the oil pressure/temperature sensor signal voltage.

Conditions

  • Install breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the oil pressure/temperature sensor signal voltage.

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

0.50 to 1.40 VDC?

Does not meet specifications.

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 inactive?

Fault Code 135 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin from pin.

  • Measure the resistance from pin 44 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 43 of the sensor harness connector to pin B (or 2) on the harness side of the oil pressure/temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Replace the oil pressure/temperature sensor

Refer to Procedure 019-155 in Section 19.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Disconnect the sensor harness connector from the ECM.
  • Use INSITE™ electronic service tool to check for the appropriate ECM response.
OK NOT OK

Fault Code 135 inactive

Fault Code 141 active

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 135 is inactive.
OK NOT OK

Fault Code 135 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 141 - Engine Oil Pressure/Temperature Sensor Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM570 QSM11 CM570 | 3666266
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM570 QSM11 CM570 | 3666266
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | ISM11 CM570 QSM11 CM570 | 3666266

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 141 active?
STEP 2. | Check the oil pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the oil pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor supply voltage and return circuit. |
 | STEP 3C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for an open circuit in the original equipment manufacturer (OEM) harness signal side. | Less than 10 ohms?
 | STEP 3E. Check for an open circuit in the OEM harness return side. | Less than 10 ohms?
 | STEP 3F. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3G. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3H. Check for an active fault code. | Fault Code 141 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the oil pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the oil pressure/temperatrue sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and oil pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure/temperature sensor from the engine harness.
  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for an open circuit in the OEM harness signal side.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the oil pressure/temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector oil pressure/temperature sensor SIGNAL pin and the OEM harness oil pressure/temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the OEM harness return side.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the oil pressure/temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector oil pressure/temperature sensor RETURN pin and the OEM harness oil pressure/temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open returnl circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the oil pressure/temperature sensor from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the oil pressure/temperature sensor SIGNAL pin in the OEM harness ECM connector and chassis ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the oil pressure/temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the oil pressure/temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3H

Go to 4A

Guided Step 3H - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check for the appropriate circuit respons after 30 seconds.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 04-Aug-2015


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Repair

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 31-Jul-2012


FAULT CODE 144 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the coolant temperature sensor and sensor harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 144 inactive?
 | STEP 1C. Check the resistance of the coolant temperature sensor. | 300 ohms to 90k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 144 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the coolant temperature sensor.

Guided Step 1A - Inspect the coolant temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.

Action

Inspect the coolant temperature sensor and sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start and idle the engine for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 144 inactive?

Fault Code 144 active.

Go to 3B

Go to 1C

Guided Step 1C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the coolant temperature sensor.
OK NOT OK

300 ohms to 90k ohms?

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start and idle the engine for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 144 inactive?

Fault Code 144 active.

Go to 3B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 2 of the sensor harness connector to all other pins.
  • Measure the resistance from pin 3 of the sensor harness connector to all other pins.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 of the sensor harness connector to pin B (or 2) of the coolant temperature sensor connector.
  • Measure the resistance from pin 3 of the sensor harness connector to pin A (or 1) of the coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 144 is inactive.
OK NOT OK

Fault Code 144 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 145 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the coolant temperature sensor and sensor harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 145 inactive?
 | STEP 1C. Check the resistance of the coolant temperature sensor. | 300 ohms to 90k ohms?
 | STEP 1D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 145 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the coolant temperature sensor.

Guided Step 1A - Inspect the coolant temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the sensor harness, or replace the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 inactive?

Fault Code 145 active.

Go to 3B

Go to 1C

Guided Step 1C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the coolant temperature sensor.
OK NOT OK

300 ohms to 90k ohms?

Replace the coolant temperature sensor

Refer to Procedure 019-019 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A (or 1) of the coolant temperature sensor to engine block ground.
  • Measure the resistance from pin B (or 2) of the coolant temperature sensor to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the coolant temperature sensor

Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 inactive?

Fault Code 145 active.

Go to 3B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 2 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 3 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 3 of the sensor harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 145 is inactive.
OK NOT OK

Fault Code 145 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 147 (Industrial) - Frequency Throttle Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and the engine harness connectors. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 147 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and the engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.

Action

Inspect the OEM harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency throttle.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 22 of the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency throttle.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 22 of the OEM harness 31-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM interface harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 30 of the OEM harness connector to pin 22 of the engine harness 31-pin OEM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 30 of the actuator harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 30 of the actuator harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 147 is inactive.
OK NOT OK

Fault Code 147 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 148 (Industrial) - Frequency Throttle Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and the actuator harness connectors. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 148 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 148 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and the actuator harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the actuator harness at the 31-pin connector.

Action

Inspect the OEM harness and the actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Connect the frequency throttle to the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 22 of the OEM harness 31-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the frequency throttle from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 22 of the OEM harness 31-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 30 of the actuator harness connector to pin 22 of the 31-pin connector on the actuator harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 30 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 30 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 148 inactive?

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 148 is inactive.
OK NOT OK

Fault Code 148 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Jul-2012


FAULT CODE 153 - Intake Manifold Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - 2-way Metri-Pack™ connector.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold temperature sensor. |
 | STEP 1A. Inspect the intake manifold temperature sensor and the sensor harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 153 inactive?
 | STEP 1C. Check the resistance of the intake manifold temperature sensor. | 175 ohms to 244k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 153 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold temperature sensor.

Guided Step 1A - Inspect the intake manifold temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold temperature sensor.

Action

Inspect the intake manifold temperature sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 153 inactive?

Fault Code 153 active.

Go to 3B

Go to 1C

Guided Step 1C - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance from pin A to pin B of the intake manifold temperature sensor.
OK NOT OK

175 ohms to 244k ohms?

Replace the intake manifold temperature sensor

Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 153 inactive?

Fault Code 153 active.

Go to 3B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 38 of the sensor harness connector to all other pins in the sensor harness.
  • Measure the resistance from pin 40 of the sensor harness connector to all other pins in the sensor harness.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 40 of the sensor harness connector to pin 1 (or A) of the intake manifold temperature sensor connector, harness side.
  • Measure the resistance from pin 38 of the sensor harness connector to pin 2 (or B) of the intake manifold temperature sensor connector, harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 153 is inactive.
OK NOT OK

Fault Code 153 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 154 - Intake Manifold Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - 2-way Metri-Pack™ connector.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 145 and 213 are not active?
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the intake manifold temperature sensor and the sensor harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 154 inactive?
 | STEP 2C. Check the resistance of the intake manifold temperature sensor. | 175 ohms to 244k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 154 inactive
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All the fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 145 and 213 are not active?

Possible sensor failure, a short circuit to ground in the sensor + 5-VDC common supply, or a short circuit from pin to pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the intake manifold temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold temperature sensor.

Action

Inspect the intake manifold temperature sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 154 inactive?

Fault Code 154 active.

Go to 4B

Go to 2C

Guided Step 2C - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance from pin A to pin B of the intake manifold temperature sensor.
OK NOT OK

175 ohms to 244k ohms?

Replace the intake manifold temperature sensor.

Refer to Procedure 019-059 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the intake manifold temperature sensor to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the intake manifold temperature sensor

Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 154 inactive?

Fault Code 154 active.

Go to 4B

Go to 3C

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 40 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 38 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to the ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 40 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 38 of the sensor harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 154 is inactive.
OK NOT OK

Fault Code 154 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Jul-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Temperature Sensor | Refer to Procedure 019-059 | Electronic Control System ISM and QSM11 Engines | 3666266

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manfiold air temperature reading. |
 | STEP 1A. Monitor intake manfiold air temperature reading. | Temperature sensor reading with the recommended Cummins® electronic service tool, or equivalent, correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manfiold air temperature reading.

Guided Step 1A - Monitor intake manfiold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Monitor the intake manifold temperature reading.

  • Use the recommended Cummins® electronic service tool, or equivalent, to monitor the intake manifold air temperature value.
  • Compare the temperature reading with the recommended Cummins® electronic service tool, or equivalent, to a mechanical gauge or a known value.

Does the temperature sensor reading with the recommended Cummins® electronic service tool, or equivalent, correlate to a known value or a mechanical gauge?

YES NO

Repair

Refer to the Intake Manfiold Air Temperature Above Specification troubleshooting symptom tree in Section TS in Service Manual ISM, ISMe, and QSM11, Bulletin 3666322.

Repair

Replace the intake manfiold air temperature sensor.

  • Refer to Procedure 019-059 in the Associated Procedures Table.

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool, or equivalent, to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 16-Oct-2018


FAULT CODE 187 - Sensor Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for failed sensors. |
 | STEP 1A. Check the oil pressure/temperature sensor. | Less than + 4.5-VDC and Fault Code 187 still active?
 | STEP 1B. Check the fuel inlet restriction sensor, if equipped. | Less than + 4.5-VDC and Fault Code 187 still active?
 | STEP 1C. Check the wet tank pressure sensor, if equipped. | Less than + 4.5-VDC and Fault Code 187 still active?
 | STEP 1D. Check coolant level sensor. | Less than + 4.5-VDC and Fault Code 187 still active?
 | STEP 1E. Check Top 2 transmission position sensor, if equipped. | Less than + 4.5-VDC and Fault Code 187 still active?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the supply voltage from the ECM. | + 4.75 to 5.25-VDC?
 | STEP 2C. Check for a short circuit to ground in the sensor SUPPLY wires. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 187 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for failed sensors.

Guided Step 1A - Check the oil pressure/temperature sensor.

Conditions

  • Disconnect the sensor harness from the oil pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the oil pressure/temperature sensor.

  • Measure the voltage from pin A (or 1) to pin B (or 2) on the oil pressure/temperature sensor connector.
OK NOT OK

Less than + 4.5-VDC and Fault Code 187 still active?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the fuel inlet restriction sensor.

Conditions

  • Optional equipment; check vehicle to see if so equipped.
  • If not equipped, go to Step 1C.
  • Disconnect the actuator harness from the fuel inlet restriction sensor.
  • Turn keyswitch ON.

Action

Check the fuel inlet restriction sensor.

  • Measure the voltage from pin A (or 1) to pin B (or 2) on the fuel inlet restriction sensor connector.
OK NOT OK

Less than + 4.5-VDC and Fault Code 187 still active?

Replace the fuel pump inlet restriction sensor.

Go to 1C

Go to 3A

Guided Step 1C - Check the wet tank pressure sensor.

Conditions

  • Optional equipment; check vehicle to see if so equipped.
  • If not equipped, go to Step 1D.
  • Disconnect the sensor harness from the wet tank pressure sensor.
  • Turn keyswitch ON.

Action

Check the wet tank pressure sensor.

  • Measure the voltage from pin A (or 1) to pin B (or 2) on the wet tank pressure sensor connector.
OK NOT OK

Less than + 4.5-VDC and Fault Code 187 still active?

Replace the wet tank pressure sensor/governor assembly. Reference the OEM troubleshooting and repair manual for the proper procedure.

Go to 1D

Go to 3A

Guided Step 1D - Check the coolant level sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the sensor harness from the coolant level sensor.

Action

Check the coolant level sensor.

  • Measure the voltage from pin C (or 3) to pin B (or 2) on the coolant level sensor connector.
OK NOT OK

Less than + 4.5-VDC and Fault Code 187 still active?

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check the Top 2 transmission position sensor.

Conditions

  • Optional equipment; check vehicle to see if so equipped.
  • Following step only applies if vehicle has Spicer™ Top 2 transmission.
  • If not equipped, go to Step 2A.
  • Turn keyswitch ON.
  • Disconnect the sensor harness from the Top 2 transmission position sensor.

Action

Check the Top 2 transmission position sensor.

  • Measure the voltage from pin A (or 1) to pin B (or 2) on the Top 2 transmission position connector.
OK NOT OK

Less than + 4.5-VDC and Fault Code 187 still active?

Replace the Top 2 transmission position sensor. Reference the OEM troubleshooting and repair manual for the proper procedure.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the supply voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage from the ECM.

  • Measure the supply voltage out of the ECM sensor harness connector port at pins 18, 25, and 45 to ground.
  • Measure the supply voltage out of the ECM actuator harness connector port at pins 19 and 29 to ground.
OK NOT OK

+ 4.75 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground in the sensor SUPPLY wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground in the sensor SUPPLY wires.

  • Measure the resistance from pins 18, 25, and 45 in the sensor harness connector to engine block ground.
  • Measure the resistance from pins 19 and 29 in the actuator harness connector to engine block ground.
  • Disconnect the oil pressure/temperature sensor from the engine harness.
  • Disconnect the fuel inlet restriction sensor from the engine harness, if equipped.
  • Disconnect the wet tank pressure sensor from the engine harness, if equipped.
  • Disconnect the coolant level sensor from the engine harness.
  • Disconnect the Top 2 transmission position sensor from the engine harness, if equipped.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the oil pressure/temperature sensor from the engine harness.
  • Disconnect the fuel inlet restriction sensor from the engine harnes, if equipped.
  • Disconnect the wet tank pressure sensor from the engine harness, if equipped.
  • Disconnect the coolant level sensor from the engine harness.
  • Disconnect the Top 2 transmission position sensor from the engine harness, if equipped.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 18 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 25 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 45 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 19 to all other pins in the actuator harness connector.
  • Measure the resistance from pin 29 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 187 is inactive.
OK NOT OK

Fault Code 187 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Aug-2012


FAULT CODE 198 - ICON™ Lamp

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ or flash out ICON™ lamp for ICON™ fault codes. | Fault Code 198 inactive?
STEP 2. | Check the OEM engine wiring harness and engine control module (ECM) connector pins. |
 | STEP 2A. Inspect the OEM engine wiring harness and ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to the battery. | Less than 1.5 VDC?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the ICON™ lamp. |
 | STEP 3A. Check the ICON™ lamp connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Check the ICON™ lamp for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 198 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read the fault codes with INSITE™ or flash out ICON™ lamp for ICON™ fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ or flash out ICON™ lamp.
OK NOT OK

Fault Code 198 inactive?

Fault Code 198 active

Go to 4A

Go to 2A

Guided Step 2 - Check the OEM engine wiring harness and ECM connector pins.

Guided Step 2A - Inspect the OEM engine wiring harness and ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine wiring harness connector from the ECM.

Action

Inspect the OEM engine wiring harness connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to the battery.

Conditions

  • Disconnect the OEM engine wiring harness connector from the ECM.
  • Remove the bulb from the ICON™ lamp holder.
  • Turn keyswitch ON.

Action

Measure the voltage using a multimeter.

  • Measure the voltage from pin 4 in the OEM engine wiring harness connector at the ECM to ground.
OK NOT OK

Less than 1.5 VDC?

Repair or replace the OEM engine wiring harness

  • Repair the OEM engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM engine wiring harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine wiring harness connector from the ECM.
  • Remove the bulb from the ICON™ lamp holder.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 4 in the OEM engine wiring harness connector at the ECM to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ICON™ lamp.

Guided Step 3A - Check the ICON™ lamp connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ lamp connector from the OEM cab harness.

Action

Inspect the ICON™ lamp and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Flush the dirt, debris, and moisture from the connector pins. Repair the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the lamp connector pins. Refer to Procedure 019-202 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the ICON™ lamp for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ lamp connector from the OEM cab harness.

Action

Check the ICON™ lamp for a short circuit to ground.

  • Measure the resistance from pin A of the ICON™ lamp connector to engine block ground.
  • Measure the resistance from pin B of the ICON™ lamp connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the ICON™ lamp

  • Repair the ICON™ lamp, Part Number 4009767. Refer to Procedure 019-202 in Section 19.
  • Replace the ICON™ lamp, Part Number 4009767. Refer to Procedure 019-046 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 198 is inactive.
OK NOT OK

Fault Code 198 inactive?

Return to the troubleshooting steps, or contact the nearest Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Aug-2012


FAULT CODE 199 - ICON™ Lamp

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool or flash out engine lamp for active fault code. | Fault Code 199 inactive?
STEP 2. | Check the ICON™ lamp. |
 | STEP 2A. Check the bulb for continuity. | Less than 10 ohms?
 | STEP 2B. Check for voltage to the ICON™ lamp. | Greater than 6 VDC?
STEP 3. | Check the fuse. |
 | STEP 3A. Check the 5-amp ignition fuse. | Fuse installed correctly?
 | STEP 3B. Check if the 5-amp fuse is blown. | Fuse not blown?
STEP 4. | Check the OEM cab harness connectors at the fire wall and the OEM harness engine control module (ECM) connector. |
 | STEP 4A. Inspect the OEM harness for damaged pins. | Dirty or damaged pins?
STEP 5. | Check the ICON™ lamp circuit for an open or short circuit. |
 | STEP 5A. Check the ICON™ lamp for an open circuit. | Less than 10 ohms?
 | STEP 5B. Check for a short circuit. | Greater than 100k ohms?
 | STEP 5C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 199 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool or flash out engine lamp for active fault code.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ electronic service tool or flash out engine lamp for active fault codes.
OK NOT OK

Fault Code 199 inactive?

Fault Code 199 active

Go to 6A

Go to 2A

Guided Step 2 - Check the ICON™ lamp.

Guided Step 2A - Check the bulb for continuity.

Conditions

  • Turn keyswitch OFF.
  • Remove the bulb from the holder.

Action

Check the resistance of the bulb.

  • Use a multimeter to check the resistance of the bulb.
OK NOT OK

Less than 10 ohms?

Replace the bulb

  • Replace the bulb for a 12-VDC system with a General Electric 1892 bulb or equivalent.

Go to 2B

Go to 6A

Guided Step 2B - Check for voltage to the ICON™ lamp.

Conditions

  • Remove the bulb from the holder.
  • Turn keyswitch ON.

Action

Check for voltage to the lamp.

  • Use a multimeter to measure the voltage at the lamp bulb holder keyswitch side (power side) to chassis ground.
OK NOT OK

Greater than 6 VDC?

Less than 6 VDC

Go to 4A

Go to 3A

Guided Step 3 - Check the fuse.

Guided Step 3A - Check the 5-amp ignition fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check if the 5-amp fuse is installed correctly.
OK NOT OK

Fuse installed correctly?

Install fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check if the 5-amp fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Check if the 5-amp fuse is blown.
OK NOT OK

Fuse not blown

Replace the blown fuse. Refer to Procedure 019-198 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the OEM cab harness connectors at the fire wall and the OEM harness ECM connector.

Guided Step 4A - Inspect the OEM harness for damaged pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the damaged pins

Repair or replace the OEM harness

Flush the dirt, debris, and moisture from the connector pins. Repair or replace the harness.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness. Refer to Procedure 019-305 in the Master Repair Manual IC0N™ Idle Control System, Bulletin 3666415.
  • Contact an authorized OEM repair facility for harness repair/replacement.

Go to 5A

Go to 6A

Guided Step 5 - Check the ICON™ lamp circuit for an open or short circuit.

Guided Step 5A - Check the ICON™ lamp for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Remove the ICON™ lamp bulb from the bulb holder.

Action

Check for an open circuit.

  • Measure the resistance from pin 4 of the OEM harness connector at the ECM to the return side (ECM side) of the ICON™ lamp bulb holder.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Remove the ICON™ lamp bulb from the bulb holder.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 4 of the OEM harness connector at the ECM to ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Remove the ICON™ lamp bulb from the bulb holder.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 4 of the OEM harness connector at the ECM to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 199 is inactive.
OK NOT OK

Fault Code 199 inactive

Return to the troubleshooting steps, or contact the nearest Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 212 - Oil Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure/temperature sensor. |
 | STEP 1A. Inspect the oil pressure/temperature sensor and sensor harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 212 inactive?
 | STEP 1C. Check the resistance of the oil pressure/temperature sensor. | 300 ohms to 90k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 212 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 212 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the oil pressure/temperature sensor.

Guided Step 1A - Inspect the oil pressure/temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the oil pressure/temperature sensor and sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-155 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 inactive?

Fault Code 212 active.

Go to 3B

Go to 1C

Guided Step 1C - Check the resistance of the oil pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check the resistance of the oil pressure/emperature sensor.

  • Measure the resistance from pin 4 (or D) to pin 2 (or B) of the oil pressure/temperature sensor.
OK NOT OK

300 ohms to 90k ohms?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 inactive?

Fault Code 212 active.

Go to 3B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 42 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 43 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 42 of the sensor harness connector to pin 4 (or D) of the oil pressure/temperature sensor.
  • Measure the resistance from pin 43 of the sensor harness connector to pin 2 (or B) of the oil pressure/temperature sensor.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Using INSITE™ electronic service tool to verify that Fault Code 212 is inactive.
OK NOT OK

Fault Code 212 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Aug-2012


FAULT CODE 213 - Oil Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 145 and 154 are not active?
STEP 2. | Check the oil pressure/temperature sensor. |
 | STEP 2A. Inspect the oil pressure/temperature sensor and the sensor harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 213 inactive?
 | STEP 2C. Check the resistance of the oil pressure/temperature sensor. | 300 ohms to 90k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 213 inactive?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 145 and 154 are not active?

Go to 2A

Fault Code 187

Guided Step 2 - Check the oil pressure/temperature sensor.

Guided Step 2A - Inspect the oil pressure/temperature sensor harness and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 213 inactive?

Fault Code 213 active.

Go to 4B

Go to 2C

Guided Step 2C - Check the resistance of the oil pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check the resistance of the oil pressure/temperature sensor.

  • Measure the resistance from pin 4 (or D) to pin 2 (or B) of the oil pressure/temperature sensor.
OK NOT OK

300 ohms to 90k ohms?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 4 (or D) of the oil pressure/temperature sensor to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 213 inactive?

Fault Code 213 active.

Go to 4B

Go to 3C

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 42 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 43 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 42 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 43 of the sensor harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 213 is inactive.
OK NOT OK

Fault Code 213 inactive?

Return to troubleshooting steps or contact your local Cummins®Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 214 - Engine Oil Temperature High - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Thermostat | Refer to Procedure 007-039 | ISM, ISMe, and QSM11 | 3666322
Lubricating Oil Cooler | Refer to Procedure 007-003 | ISM, ISMe, and QSM11 | 3666322

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | High coolant temperature causing high oil temperature. |
 | STEP 1A. Check high coolant temperature fault code. | High engine coolant temperature fault codes?
STEP 2. | Lubricating oil thermostat is malfunctioning. |
 | STEP 2A. Check the lubricating oil thermostat for proper operation. | Thermostat operating correctly?
STEP 3. | Lubricating oil cooler is malfunctioning or restricted. |
 | STEP 3A. Check the lubricating oil cooler. | Debris found in the lubricating oil cooler?
STEP 4. | Lubricating oil cooler is leaking. |
 | STEP 4A. Check for lubricating oil cooler leaks. | Lubricating oil cooler leaks during the pressure test or damage observed during inspection?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - High coolant temperature causing high oil temperature.

Guided Step 1A - Check high coolant temperature fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check high coolant temperature fault code.

  • Check to make certian that high engine coolant temperatures are not causing the high oil temperature symptoms.

High engine coolant temperature fault codes?
YES | NO
No Repair | No Repair

Troubleshoot any high engine coolant temperature fault codes.

Go to 2A

Guided Step 2 - Lubricating oil thermostat is malfunctioning.

Guided Step 2A - Check the lubricating oil thermostat for proper operation.

Conditions

  • N/A

Action

Check the lubricating oil thermostat for proper operation.

  • Check the lubricating oil thermostat for proper operation. Refer to Procedure 007-039 in the Associated Procedures Table.

Thermostat operating correctly?
YES NO
No Repair

Repair

Replace the lubricating oil thermostat.

  • Refer to Procedure 007-039 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Lubricating oil cooler is malfunctioning or restricted.

Guided Step 3A - Check the lubricating oil cooler.

Conditions

  • Turn keyswitch OFF.

Action

Check the lubricating oil cooler.

  • Inspect the lubricating oil cooler for debris. Refer to Procedure 007-003 in the Associated Procedures Table.

Debris found in the lubricating oil cooler?
YES NO

Repair

Clean or replace the lubricating oil cooler.

  • Refer to Procedure 007-003 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Lubricating oil cooler leaking.

Guided Step 4A - Check for lubricating oil cooler leaks.

Conditions

  • N/A

Action

Check for lubricating oil cooler leaks.

  • Pressure test the lubricating oil cooler. Refer to Procedure 007-003 in the Associated Procedures Table.

Lubricating oil cooler leaks during the pressure test or damage observed during inspection?
YES NO

Repair

  • Replace the lubricating oil cooler. Refer to Procedure 007-003 in the Associated Procedures Table.
  • Replace the lubricating oil cooler element, mounting plate gasket or o-ring. Refer to Procedure 007-003 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or Call for assistance.

Last Modified: 01-Jul-2019


FAULT CODE 216 - Wet Tank Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wet tank pressure sensor. |
 | STEP 1A. Inspect the sensor harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 216 inactive?
 | STEP 1C. Check the supply voltage. | +4.75 to 5.25 VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
STEP 2. | Check the sensor harness and the ECM. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 216 inactive?
 | STEP 2C. Check for a short circuit from the SIGNAL wire to all other wires in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 216 inactive and Fault Code 217 active?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 216 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the wet tank pressure sensor.

Guided Step 1A - Inspect the sensor harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wet tank pressure sensor from the engine harness.

Action

Inspect the sensor harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the air compressor governor assembly. Refer to Procedure 019-169 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 216 inactive?

Fault Code 216 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the supply voltage.

Conditions

  • Disconnect the engine harness from the wet tank pressure sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage from pin 1 (or A) to pin 2 (or B) of the wet tank pressure sensor connector, engine harness side.
OK NOT OK

+4.75 to 5.25 VDC?

Does not meet specifications.

Go to 2A

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the wet tank pressure sensor from the sensor harness.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage at the ECM from pin 18 to pin 20 of the ECM sensor port.
OK NOT OK

+4.75 to 5.25 VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 2 - Check the sensor harness and the ECM.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the wet tank pressure sensor from the engine harness.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 216 inactive?

Fault Code 216 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from the SIGNAL wire to all other wires in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL wire to all other wires in the engine harness.

  • Measure the resistance from pin 19 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 19 in the sensor harness connector to all pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL wire to all other wires in the engine harness.

  • Measure the resistance from pin 20 of the sensor harness connector to pin 2 of the wet tank pressure sensor harness connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-206 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to check for the appropriate ECM response.
OK NOT OK

Fault Code 216 inactive?

Fault Code 217 active?

Replace the air compressor governor assembly

Refer to Procedure 019-169 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 216 is inactive.
OK NOT OK

Fault Code 216 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Aug-2012


FAULT CODE 216 - Wet Tank Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 inactive?
STEP 2. | Check the wet tank pressure sensor. |
 | STEP 2A. Inspect the sensor harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 217 inactive?
 | STEP 2C. Check the supply voltage. | + 4.75 to 5.25 VDC?
 | STEP 2C-1. Measure the voltage from the ECM. |
STEP 3. | Check the sensor harness and the ECM. |
 | STEP 3A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 217 inactive?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 217 inactive and Fault Code 216 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 217 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187 inactive?

Possible sensor failure, short circuit to ground in sensor + 5-VDC common supply, or short circuit from pin-to-pin.

Go to 2A

Fault Code 187

Guided Step 2 - Check the wet tank pressure sensor.

Guided Step 2A - Inspect the sensor harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wet tank pressure sensor from the engine harness.

Action

Inspect the sensor harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the electronic air compressor governor assembly. Refer to Procedure 019-169 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 217 inactive?

Fault Code 217 active.

Go to 5B

Go to 2C

Guided Step 2C - Check the supply voltage.

Conditions

  • Disconnect the engine harness from the wet tank pressure sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage from pin 1 (or A) to pin 2 (or B) on the wet tank pressure sensor, engine harness side.
OK NOT OK

+ 4.75 to 5.25 VDC?

Does not meet specifications.

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the wet tank pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage at the ECM from pin 18 to pin 20 of the ECM sensor port.
OK NOT OK

+ 4.75 to 5.25 VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the sensor harness and the ECM.

Guided Step 3A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the wet tank pressure sensor from the engine harness.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 217 inactive?

Fault Code 217 active.

Go to 5B

Go to 3C

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Read the fault codes.

  • Measure the resistance from pin 19 of the sensor harness connector to pin 3 (or C) of the wet tank pressure sensor harness connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Read the fault codes.

  • Measure the resistance from pin 19 of the sensor harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Read the fault codes.

  • Measure the resistance from pin 19 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire between the ECM sensor port pin 18 and pin 19.
OK NOT OK

Fault Code 217 inactive?

Fault Code 216 active

Replace the electronic air compressor governor assembly

Refer to Procedure 019-169 in Section 19.

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 217 is inactive.
OK NOT OK

Fault Code 217 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Aug-2012


FAULT CODE 218 - Wet Tank Pressure Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a mechanical gauge. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 218 inactive?
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify sensor accuracy with a mechanical gauge.

  • Connect a mechanical pressure gauge to the wet tank.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Start engine and compare the service tool monitor screen to reading on mechanical pressure gauge.
OK NOT OK

Sensor reading is correct?

Reference the appropriate Air Compressor troubleshooting symptom tree in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Replace the electronic air compressor governor

Refer to Procedure 019-169 in Section 19.

Base engine troubleshooting and repair manual

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 218 is inactive.
OK NOT OK

Fault Code 218 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Aug-2012


FAULT CODE 221 - Ambient Air Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ambient air pressure sensor. |
 | STEP 1A. Inspect the ambient air pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 221 inactive?
 | STEP 1C. Check the ECM ambient air pressure sensor supply voltage. | +4.75 to 5.25-VDC
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the ECM ambient air pressure sensor signal voltage. | Altitude (ft) Voltage (VDC), 0 (sea level) - +3.40 to 4.50, 3000 - +2.80 to 3.80, 6000 - +2.20 to 3.25, 9000 - +1.70 to 2.70, 12000 - +1.20 to 2.20?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 221 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 221 inactive and Fault Code 222 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ambient air pressure sensor.

Guided Step 1A - Inspect the ambient air pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Inspect the ambient air pressure sensor and sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19
  • .

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 inactive?

Fault Code 221 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the ECM ambient air pressure sensor supply voltage.

Conditions

  • Install breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure sensor supply voltage.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

+4.75 to 5.25-VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage at the ECM from pin 17 to pin 31 of the ECM sensor connector port.
OK NOT OK

+4.75 to 5.2- VD?C

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check the ECM ambient air pressure sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure signal voltage.

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

Altitude (ft) Voltage (VDC), 0 (sea level) - +3.40 to 4.50, 3000 - +2.80 to 3.80, 6000 - +2.20 to 3.25, 9000 - +1.70 to 2.70, 12000 - +1.20 to 2.20?

Go to 3A

Go to 2A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 inactive?

Fault Code 221 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 6 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 31 of the sensor harness connector to the engine block ground.
OK NOT OK

Less than 10 ohms?

Replace the ambient air pressure sensor

Refer to Procedure 019-004 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Disconnect the sensor harness connector from the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 inactive and Fault Code 222 active?

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 221 is inactive.
OK NOT OK

Fault Code 221 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Aug-2012


FAULT CODE 222 - Ambient Air Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP/Metri-Pack™ test lead and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 123 inactive?
STEP 2. | Check the ambient air pressure sensor. |
 | STEP 2A. Inspect the ambient air pressure sensor and sensor harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 222 inactive?
 | STEP 2C. Check the ECM ambient air pressure supply voltage. | + 4.75 to 5.25-VDC?
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 2D. Check the ECM ambient air pressure signal voltage. | Altitude (ft) Voltage (VDC), 0 (sea level) - + 3.40 to 4.50, 3000 - + 2.80 to 3.80, 6000 - 2.20 to 3.25, 9000 - + 1.70 to 2.70, 12000 - + 1.20 to 2.20?
 | STEP 2D-1. Check for a short circuit to ground. |
 | STEP 3D-2. Check for a short circuit from pin-to-pin. |
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 222 inactive?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 222 inactive and Fault Code 221 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 inactive?

Go to 2A

Fault Code 352

Guided Step 2 - Check the ambient air pressure sensor.

Guided Step 2A - Inspect the ambient air pressure sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Inspect the ambient air pressure sensor and sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the ECM ambient air pressure supply voltage.

Conditions

  • Install the breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure supply voltage.

  • Use a multimeter to measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

+ 4.75 to 5.25-VDC?

Does not meet specifications.

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage at the ECM from pin 17 to pin 31 of the ECM sensor connector port.
OK NOT OK

+ 4.75 to 5.25-VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Check the ECM ambient air pressure signal voltage.

Conditions

  • Install the breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure signal voltage.

  • Measure the signal voltage from pin B (or BLACK) to pin C (or YELLOW) of the breakout cable.
OK NOT OK

Altitude (ft) - Voltage (VDC), 0 (sea level) - + 3.40 to 4.50, 3000 - + 2.80 to 3.80, 6000 - + 2.20 to 3.25, 9000 - + 1.70 to 2.70, 12000 - + 1.20 to 2.20?

Go to 2D-1

Go to 3A

Guided Step 2D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the sensor harness connector to the chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 6 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the ambient air temperature sensor.

Refer to Procedure 019-004 in Section 19.

Replace the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit in the ambient air pressure signal wire.

  • Measure the resistance from sensor harness connector pin 6 to the ambient air pressure sensor signal pin C (or 3).
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire between ECM sensor port pin 6 and pin 17.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive and Fault Code 221 active?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 222 is inactive.
OK NOT OK

Fault Code 222 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Aug-2012


FAULT CODE 223 - Burn Valve Solenoid Fault

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the burn valve solenoid. |
 | STEP 1A. Verify the burn valve solenoid is connected to the engine harness. | Solenoid is connected?
 | STEP 1B. Inspect the burn valve solenoid and solenoid connector on the engine harness. | Dirty or damaged pins?
 | STEP 1C. Check the burn valve solenoid for an open circuit. | Less than 120 ohms?
 | STEP 1D. Check the burn valve solenoid for a short circuit. | Greater than 80 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2B-1. Check for an open circuit in the Centinel™ jumper harness. |
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP ?2C-1. Check for a short circuit to ground in the Centinel™ jumper harness. |
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 223 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the burn valve solenoid.

Guided Step 1A - Verify the burn valve solenoid is connected to the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the burn valve solenoid is connected to the engine harness.
OK NOT OK

Solenoid is connected?

Connect the solenoid to the engine harness.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the burn valve solenoid and the solenoid connector on the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the burn valve solenoid.

Action

Inspect the burn valve solenoid and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or replace the burn valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the burn valve solenoid. Refer to the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 1C

Go to 3A

Guided Step 1C - Check the burn valve solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the engine harness.

Action

Check the burn valve solenoid for an open circuit.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the burn valve solenoid connector.
OK NOT OK

Less than 120 ohms?

Replace the burn valve solenoid.

Refer to the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 1D

Go to 3A

Guided Step 1D - Check the burn valve solenoid for a short circuit to ground.

Conditions

  • Disconnect the engine harness from the burn valve solenoid.

Action

Check the burn valve solenoid for a short circuit to ground.

  • Measure the resistance from pin A (or 1) of the burn valve solenoid to engine block ground.
OK NOT OK

Greater than 80 ohms?

Replace the burn valve solenoid.

Refer to the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the burn valve solenoid circuit.

  • Measure the resistance from pin 34 of the actuator harness connector to pin 5 of the burn valve solenoid, harness side.
  • Measure the resistance from pin 43 of the actuator harness connector to pin 6 of the burn valve solenoid, harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-206 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an open circuit in the Centinel™ jumper harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the jumper harness from the burn valve solenoid.
  • Disconnect the jumper harness from the engine harness.

Action

Check for an open circuit in the Centinel™ jumper harness.

  • Measure the resistance from the signal pin of the 2-pin connector end of the Centinel™ jumper harness to pin 5 of the 6-pin connector end of the harness.
  • Measure the resistance from the return pin of the 2-pin connector end of the Centinel™ jumper harness to pin 6 of the 6-pin connector end of the harness.
OK NOT OK

Less than 10 ohms?

Repair or replace the Centinel jumper harness.

Refer to the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 34 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 43 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-1

Go to 3A

Guided Step 2C-1 - Check for a short circuit to ground in the Centinel™ jumper harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the jumper harness from the burn valve solenoid.
  • Disconnect the jumper harness from the engine harness.

Action

Check for a short circuit to ground in the Centinel™ jumper harness.

  • Measure the resistance from pin A (or 1) of the 2-pin jumper harness connector to engine block ground.
  • Measure the resistance from pin B (or 2) of the 2-pin jumper harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the Centinel jumper harness.

Refer to the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the burn valve solenoid.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 31-pin OEM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 34 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 43 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 223 is inactive.
OK NOT OK

Fault Code 223 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 10-Aug-2012


FAULT CODE 227 - Sensor Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the supply voltage from the ECM. | + 4.75 to 5.25-VDC?
 | STEP 1C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit to battery voltage. | Greater than 100k ohms?
 | STEP 1D-1. Check for a short circuit to battery voltage. |
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to battery voltage. | Greater than 100k ohms?
 | STEP 2C-1. Check for a short circuit to battery voltage. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor harness.

Guided Step 1A - Inspect harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, connector or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part No. 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the supply voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage from the ECM.

  • Measure the supply voltage out of the ECM sensor connector port at pins 18, 25, and 45 to ground.
  • Measure the supply voltage out of the ECM actuator connector port at pins 19 and 29 to ground.
OK NOT OK

+ 4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 18 of the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from pin 25 of the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from pin 45 of the sensor harness connector to all other pins in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to battery voltage.

  • Measure the resistance from pin 18 of the sensor harness connector to pin 7 of the 50-pin OEM harness connector.
  • Measure the resistance from pin 25 of the sensor harness connector to pin 7 of the 50-pin OEM harness connector.
  • Measure the resistance from pin 45 of the sensor harness connector to pin 7 of the 50-pin OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Go to 2A

Go to 1D-1

Guided Step 1D-1 - Check for a short circuit to battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 50-pin OEM harness connector from the ECM.
  • Disconnect the 31-pin OEM harness connector from the engine harness.

Action

Check for a short circuit to battery voltage.

  • Measure the resistance from pin 7 of the 50-pin OEM harness connector to pin 7 of the 31-pin OEM connector, OEM harness side.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Secton 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, connector or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 19 of the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 29 of the actuator harness connector to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to battery voltage.

  • Measure the resistance from pin 19 of the actuator harness connector to pin 7 of the 50-pin OEM harness connector.
  • Measure the resistance from pin 29 of the actuator harness connector to pin 7 of the 50-pin OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Check for a short circuit to battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 50-pin OEM harness connector from the ECM.
  • Disconnect the 31-pin OEM harness connector from the engine harness.

Action

Check for a short circuit to battery voltage.

  • Measure the resistance from pin 7 of the 50-pin OEM harness connector to pin 14 of the 31-pin OEM connector, OEM harness side.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 227 is inactive.
OK NOT OK

Fault code 227 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Aug-2012


FAULT CODE 234 - Engine Overspeed

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

If the engine speed stays above 2650 rpm, the engine must be shut OFF immediately.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Not motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | No alternate fuel source?
 | STEP 1C. Check the engine rpm with the monitor mode. | Correct rpm reading?
 | STEP 1D. Check the injector overhead settings. | Correct injector overhead settings?
 | STEP 1E. Check for an active fault at low engine rpm. | Inactive fault at low rpm?
 | STEP 1F. Test the vehicle. | Inactive fault?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.
OK NOT OK

Not motoring downhill?

Check the engine for damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 2650 rpm, followed by moderate deceleration to 2000 rpm.
OK NOT OK

No alternate fuel source?

Locate the alternative fuel source

  • Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

Go to 1C

Go to 2A

Guided Step 1C - Check the engine rpm with the monitor mode.

Conditions

  • Turn keyswitch ON.

Action

Check the engine rpm with the monitor mode.

  • Use INSITE™ electronic service tool to monitor the engine rpm.
OK NOT OK

Correct rpm reading?

Inspect the engine position sensor

  • Check the engine position sensor as outlined for Fault Codes 115 and 121.

Go to 1D

Fault Codes 115 and 121

Guided Step 1D - Check the injector overhead settings.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector overhead settings.

  • Check for correct injector overhead settings. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, 3666322. Refer to Procedure 003-004 in Section 3.
OK NOT OK

Correct injector overhead settings?

Reset the overhead

  • Reset the overhead according to the outer base circle method. Inspect the base engine for damage due to overspeed condition.

Go to 1E

Go to 2A

Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active fault at low engine rpm.

  • Check for active Fault Code 234 when the engine is not running above 2650 rpm.
OK NOT OK

Inactive fault at the low rpm?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Test the vehicle.

Action

Test the vehicle.

  • Check if the overspeed condition is still present.
OK NOT OK

Inactive fault?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and check again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 234 is inactive.
OK NOT OK

Fault Code 234 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Aug-2012


FAULT CODE 235 - Engine Coolant Level - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

Do not add cold coolant to a hot engine. Castings can be damaged. Allow engine to cool to below 50°C [122°F] before adding coolant.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the coolant level. |
 | STEP 1A. Check the coolant level. | Coolant level is normal?
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault is still active with the engine running. | Fault Code 235 still active?
STEP 3. | Check engine harness. |
 | STEP 3A. Inspect the engine harness, 31-pin OEM, and ECM connectors. | Dirty or damaged pins?
 | STEP 3B. Check sensor supply voltage. | +4.5 to 5.5-VDC?
 | STEP 3B-1. Measure voltage from the ECM. |
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness, coolant level sensor, and ECM connectors. | Dirty or damaged pins?
 | STEP 4B. Check the sensor supply voltage. | +4.5 to 5.5-VDC?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 235 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the coolant level.

Guided Step 1A - Check the coolant level.

Conditions

  • Allow engine to cool.

Action

Check coolant level.

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level is normal?

Add coolant to the radiator. Note: Make sure the coolant has the proper ratio of antifreeze and water.

Go to 2A

Go to 5A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Confirm the fault is still active with the engine running.

Conditions

  • Turn the keyswitch ON.

Action

Confirm the fault is still active with the engine running.

  • Start the engine and idle for at least one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 235 still active?

Fault Code 235 inactive.

Go to 3A

Go to 5A

Guided Step 3 - Check engine harness.

Guided Step 3A - Inspect the engine harness, 31-pin OEM, and ECM connectors.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Inspect the engine harness, 31-pin OEM, and ECM connectors for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

Dirty or damaged pins?

Repair damaged pins

Repair or replace the engine harness, or replace the coolant level sensor or the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check sensor supply voltage.

Conditions

  • Disconnect the engine harness from the 31-pin OEM connector.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check sensor supply voltage.

  • Measure the voltage from pin 7 of the 31-pin OEM connector, engine harness side, to engine block ground.
OK NOT OK

+4.5 to 5.5-VDC?

Does not meet specifications.

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Measure voltage from the ECM.

Conditions

  • Disconnect the sensor from the 31-pin OEM connector.
  • Disconnect the sensor connector from the ECM.
  • Turn keyswitch ON.

Action

Measure voltage from the ECM.

  • Measure the voltage from pin 25 to pin 23 of the ECM sensor connector port.
OK NOT OK

+4.5 to 5.5-VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the 31-pin OEM connector at the engine harness.

Action

Check for open circuit in the coolant level sensor circuit.

  • Measure the resistance from pin 19 on the sensor harness side of the 31-pin OEM connector to pin 23 of the sensor harness connector at the ECM.
  • Measure the resistance from pin 6 on the sensor harness side of the 31-pin OEM connector to pin 22 of the sensor harness connector at the ECM.
  • Measure the resistance from pin 5 on the sensor harness side of the 31-pin OEM connector to pin 24 of the sensor harness connector at the ECM.
  • Measure the resistance from pin 7 on the sensor harness side of the 31-pin OEM connector to pin 25 of the sensor harness connector at the ECM.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness, coolant level sensor, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Inspect the OEM harness, coolant level sensor, and ECM connectors for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or replace the coolant level sensor or the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the sensor supply voltage.

Conditions

  • Disconnect the OEM harness from the coolant level sensor.
  • Connect the engine harness to the 31-pin OEM connector.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from supply, pin C (or 3) of the sensor connector, engine harness side to engine block ground.
OK NOT OK

+4.5 to 5.5-VDC?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the 31-pin OEM connector.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for an open circuit in the coolant level sensor circuit.

  • Measure the resistance from pin D (or 4) on the OEM harness side of the coolant level sensor connector to pin 5 of the OEM 31-pin connector, OEM harness side.
  • Measure the resistance from pin A (or 1) on the OEM harness side of the coolant level sensor connector to pin 6 of the OEM 31-pin connector, OEM harness side.
  • Measure the resistance from pin C (or 3) on the OEM harness side of the coolant level sensor connector to pin 7 of the OEM 31-pin connector, OEM harness side.
  • Measure the resistance from pin B (or 2) on the OEM harness side of the coolant level sensor connector to pin 19 of the OEM 31-pin connector, OEM harness side.
OK NOT OK

Less than 10 ohms?

Replace the coolant level sensor.

Refer to Procedure 019-017 in Section 19.

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 235 is inactive.
OK NOT OK

Fault Code 235 inactive?

Return to the troubleshooting steps, or contact your local Cummins®Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B®

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-May-2015


FAULT CODE 237 - Multiple Unit Synchronization (soft-coupled Marine)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine engine configuration. |
 | STEP 1A. Check engine configuration. | All secondary engines configured correctly?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to the engine block ground. | Greater than 100k ohms for inactive pins and less than 10 ohms for active pins?
STEP 3. | Inspect the SAE J1939 connectors on the backbone harness and engine harness connectors. |
 | STEP 3A. Inspect the ECM connectors. | Dirty or damaged pins?
STEP 4. | Inspect the SAE J1939 backbone harness. |
 | STEP 4A. Check for an open circuit in the SUPPLY wire. | Less than 10 ohms?
 | STEP 4B. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
 | STEP 4C. Check the resistance value in the SAE 1939 harness. | 55 to 65 ohms?
 | STEP 4D. Check for an open circuit in the shield wire. | Less than 10 ohms?
 | STEP 4E. Check for a short circuit to power in the SUPPORT wire. | Less than positive +1.5-VDC?
 | STEP 4F. Check for a short circuit to power in the RETURN wire. | Less than positive +1.5-VDC?
 | STEP 4G. Check for a short circuit to ground in the SUPPLY wire. | Greater than 100k ohms?
 | STEP 4H. Check for a short circuit to ground in the RETURN wire. | Greater than 100k ohms?
 | STEP 4I. Check for a short circuit from pin-to-pin in the OEM connector. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 237 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Determine engine configuration.

Guided Step 1A - Check engine configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check engine configuration.

  • Use INSITE™ electronic service tool to determine if a secondary engine is configured as a primary engine.
OK NOT OK

All secondary engines configured correctly?

Calibrate with correct configuration calibration. Secondary engine configured as a primary engine.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Disconnect the secondary engine OEM harness connector from the ECM.
  • Turn keyswitch ON.
  • Note the position of the multiple unit synchronization switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the OEM harness connector pin 22 to all other pins in the connector.
  • Measure the resistance from the OEM harness connector pin 31 to all other pins in the connector.
  • Measure the resistance from the OEM harness connector pin 32 to all other pins in the connector.
  • Measure the resistance from the OEM harness connector pin 34 to all other pins in the connector (multiple unit synchronization switch must be in the ON position).
  • Measure the resistance from the OEM harness connector pin 42 to all other pins in the connector (multiple unit synchronization switch must be in the OFF position).

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to the engine block ground.

Conditions

  • Disconnect the secondary engine OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to the engine block ground.

  • Measure the resistance from the OEM harness connector pin 22 to the engine block ground.
  • Measure the resistance from the OEM harness connector pin 31 to the engine block ground.
  • Measure the resistance from the OEM harness connector pin 32 to the engine block ground.
  • Measure the resistance from the OEM harness connector pin 34 to the engine block ground.
  • Measure the resistance from the OEM harness connector pin 42 to the engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms for inactive pins?

Less than 10 ohms for active pins?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Inspect the SAE J1939 connectors on the backbone harness and engine harness connectors.

Guided Step 3A - Inspect the ECM connectors.

Conditions

  • Disconnect the ECM connectors.
  • Disconnect the OEM harness.

Action

Inspect the ECM, OEM harness, and J1939 connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, SAE J1939, and 3-pin connectors, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Inspect the SAE J1939 backbone harness.

Guided Step 4A - Check for an open circuit in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 connector from the primary and secondary ECMs.

Action

Check for an open circuit in the SUPPLY wire.

  • Measure resistance from SUPPLY pin 46 of the OEM harness connector to pin A of the data link connector at the other ECMs.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the secondary ECMs.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 37 of the OEM connector to pin B of the other ECMs.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the resistance value in the SAE J1939 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the secondary ECMs.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance value of the J1939 harness.

  • Measure the resistance from pin 46 of the OEM harness connector to pin 37 of the OEM harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

55 to 65 ohms?

J1939 backbone termination resistors missing or damaged.

Replace both termination resistors.

Go to 4D

Go to 5A

Guided Step 4D - Check for an open circuit in the shield wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the primary ECM.
  • Disconnect the J1939 harness from the secondary ECMs.

Action

Check for an open circuit in the shield wire.

  • Measure the resistance from pin 36 of the OEM harness connector at the ECM to pin C of the other ECMs.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a short circuit to power in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the secondary ECMs.
  • Disconnect the OEM harness connector from the primary ECM.
  • Turn keyswitch ON.

Action

Check for a short to power in the SUPPLY wire.

  • Measure the voltage from pin 46 of the ECM to ground at the J1939 connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.
OK NOT OK

Less than positive +1.5-VDC?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a short circuit to power in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the secondary ECMs.
  • Disconnect the OEM harness connector from the primary ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to power in the RETURN wire.

  • Measure the voltage from pin 37 at the OEM harness connector to ground at the secondary ECMs.

Refer to the wiring diagram or circuit diagram for connector pin identification.
OK NOT OK

Less than positive +1.5-VDC?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Check for a short circuit to ground in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the primary ECM.
  • Disconnect the J1939 harness from the secondary ECMs.

Action

Check for a short to ground in the SUPPLY wire.

  • Measure the resistance from pin 46 of the OEM harness connector to ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4H

Go to 5A

Guided Step 4H - Check for a short circuit to ground in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the primary ECM.
  • Disconnect the J1939 harness from the secondary ECMs.

Action

Check for a short to ground in the RETURN wire.

  • Measure the resistance from pin 37 of the OEM harness connector to ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4I

Go to 5A

Guided Step 4I - Check for a short circuit from pin-to-pin in the OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the primary ECM.
  • Disconnect the J1939 harness from the secondary ECMs.

Action

Check for a short circuit from pin-to-pin in the OEM connector.

  • Measure the resistance from pin 46 of the OEM harness connector to all other pins in the connector, except pins 36 and 37.
  • Measure the resistance from pin 36 of the OEM harness connector to all other pins in the connector, except pins 46 and 37.
  • Measure the resistance from pin 37 of the OEM harness connector to all other pins in the connector, except pins 36 and 46.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 237 is inactive.
OK NOT OK

Fault Code 237 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Aug-2012


FAULT CODE 241 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the VSS. |
 | STEP 1A. Inspect the harness and the sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the VSS for proper adjustment. | 1/2 to 3/4 of a turn out from the gear?
 | STEP 1C. Check the VSS for the correct resistance. | 750 to 1500 ohms?
 | STEP 1D. Check the VSS for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1E. Check the VSS for a short circuit between coils. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for the correct circuit resistance. | 750 to 1500 ohms?
 | STEP 2C. Check the harness for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM components. |
 | STEP 3A. Check for an external recording device. | No external device?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear attached properly?
 | STEP 3C. Check for interference on the OEM harness. | Fault Code 241 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the VSS.

Guided Step 1A - Inspect the harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the OEM 31-pin Deutsch connector.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the VSS. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the VSS for the proper adjustment.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Check the VSS for the proper adjustment.
OK NOT OK

1/2 to 3/4 of a turn out from the gear?

Adjust the VSS. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19

Go to 1C

Go to 4A

Guided Step 1C - Check the VSS for the correct resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Check the vehicle speed sensor for the correct resistance.

  • Measure the resistance from pin A (or 1) to pin B (or 2) for each VSS connector on the sensor side.
OK NOT OK

750 to 1500 ohms?

Replace the VSS. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check the VSS for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the VSS for a short circuit to ground.

  • Measure the resistance between pin A (or 1) on the sensor side of one of the VSS connectors and the chassis ground.
  • Measure the resistance between pin A (or 1) on the sensor side of the other VSS connector and the chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the VSS. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 1E

Go to 4A

Guided Step 1E - Check the VSS for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Check the VSS for a short circuit between coils.

  • Measure the resistance between pin A (or 1) on the sensor side of one of the VSS connectors and pin A of the other connector.
OK NOT OK

Greater than 100k ohms?

Replace the VSS. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for the correct circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Connect the actuator harness to the VSS.

Action

Check for the correct circuit resistance.

  • Check for the proper resistance from pin 30 to pin 40 of the actuator harness connector.
OK NOT OK

750 to 1500 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the VSS.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the harness for a short circuit to ground.

  • Measure the resistance from pin 30 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 40 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM components.

Guided Step 3A - Check for an external recording device.

Action

Check for an external recording device or similar devices attached to this circuit.
OK NOT OK

No external device?

Disconnect device from circuit.

Go to 3B

Go to 4A

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • VSS removed.

Action

Check for the gear slipping on the shaft.

  • Check to make sure the transmission gear inside the sensor mounting is not slipping on the shaft. Do this by trying to spin the gear with a standard screwdriver.
OK NOT OK

Gear attached properly?

Repair transmission gear. Reference the OEM troubleshooting and repair manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for interference on the OEM harness.

Conditions

  • Connect all the components.

Action

Check for interference on the OEM harness.

  • Install a pair of twisted jumper wires from the VSS to the ECM. Connect the wires from pin A (or 1) to pin 21 of the OEM 31-pin connector and from pin B (or 2) to pin 22 of the OEM 31-pin connector.
  • Disconnect the speedometer connector at the VSS.
  • Drive the vehicle. The vehicle speed must exceed 10 mph.
OK NOT OK

Fault Code 241 inactive?

There is interference on the OEM harness.

Locate and remove the source of interference.

Replace the VSS. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 241 is inactive.
OK NOT OK

Fault Code 241 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Aug-2012


FAULT CODE 242 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are set correctly (automotive only). |
 | STEP 1A. Verify that the customer wants VSS Anti-tampering (Fault Code 242) enabled. | Customer wants VSS anti-tampering (Fault Code 242) enabled.
 | STEP 1B. Verify that VSS Type is set correctly for the application. | VSS Type is set correctly?
 | STEP 1C. Verify that Transmission Type is set correctly for the application. | Transmission Type is set correctly?
STEP 2. | Look for signs of tampering (automotive only). |
 | STEP 2A. Inspect the VSS. | No signs of tampering detected at or with the vehicle speed sensor?
 | STEP 2B. Inspect original equipment manufacturer (OEM) VSS circuit. | No signs of tampering detected at or with the vehicle speed sensor?
 | STEP 2C. Inspect the keyswitch circuit. | No signs of tampering detected with the keyswitch?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the SIGNAL wire. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the actuator harness. |
 | STEP 4A. Inspect the actuator harness and engine control module (ECM) connectors. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the SIGNAL wire. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100 ohms?
STEP 5. | Check the vehicle speed reporting. |
 | STEP 5A. Monitor the vehicle speed. | INSITE™ electronic service tool displays correct speed?
 | STEP 5B. Verify the vehicle speed. | Vehicle speed is accurate for present gear?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 242 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify that the feature settings are set correctly (automotive only).

Guided Step 1A - Verify that the customer wants VSS anti-tampering (Fault Code 242) enabled.

Conditions

Action

Verify that the customer wants VSS anti-tampering (Fault Code 242) enabled.

Talk to the owner of the vehicle to see if this feature is required for the application of this vehicle.
OK NOT OK

Customer wants VSS anti-tampering (Fault Code 242) enabled?

Adjust the feature setting to its correct value using INSITE™ electronic service tool.

Go to 1B

Go to 6A

Guided Step 1B - Verify that VSS Type is set correctly for the application.

Conditions

  • Connect the INSITE™ electronic service tool.

Action

Verify that VSS Type is set correctly for the application.

  • Use INSITE™ electronic service tool to verify this feature setting is set correctly for the application in which this vehicle is used.
OK NOT OK

VSS Type is set correctly?

Adjust the feature setting to its correct value using INSITE™ electronic service tool.

Go to 1C

Go to 6A

Guided Step 1C - Verify that Transmission Type is set correctly for the application.

Conditions

  • Connect the INSITE™ electronic service tool.

Action

Verify that Transmission Type is set correctly for the application.

  • Use INSITE™ electronic service tool to verify this feature setting is set correctly for the application in which this vehicle is used.
OK NOT OK

Transmission Type is set correctly?

Adjust the feature setting to its correct value using INSITE™ electronic service tool.

Go to 2A

Go to 6A

Guided Step 2 - Look for signs of tampering (automotive only).

Guided Step 2A - Inspect the VSS.

Conditions

Action

Inspect the VSS for the following:

  • Improper mounting of the VSS
  • VSS improperly connected to OEM harness
  • Other external device connected in place of VSS
  • Any evidence that tampering with the VSS has taken place.
OK NOT OK

No signs of tampering detected at or with the vehicle speed sensor?

VSS is improperly installed, connected, or has been tampered with.

  • Correctly install and connect the VSS to the OEM harness. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.
  • Remove any tampering device.

Go to 2B

Go to 6A

Guided Step 2B - Inspect the OEM VSS circuit.

Action

Inspect the OEM VSS circuit for the following:

  • Broken, cut, or incorrect routing of the VSS wires
  • Any devices connected in series or parallel with the VSS
  • Any other wires added to the VSS circuit
  • Any evidence that tampering with the VSS circuit has taken place.
OK NOT OK

No signs of tampering detected with the VSS leads or the OEM harness?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Inspect the keyswitch circuit.

Action

Inspect the keyswitch circuit for the following:

  • Broken, cut, or incorrect routing of the keyswitch wires
  • Any devices connected in series or parallel with the keyswitch
  • Any other wires added to the keyswitch circuit
  • Any evidence that tampering with the keyswitch circuit has taken place.
OK NOT OK

No signs of tampering detected with the keyswitch circuit?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the engine harness from the OEM harness at the Deutsch 31-pin connector.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the VSS sensor. Refer to Procedure 019-091 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the engine harness from the OEM harness at the Deutsch 31-pin connector.

Action

Check for an open circuit in the SIGNAL wire.

  • Measure the resistance from pin A (or 1) of the VSS connector to pin 21 of the Deutsch 31-pin connector.
  • Measure the resistance from pin B (or 2) of the VSS connector to pin 22 of the Deutsch 31-pin connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the engine harness from the OEM harness at the Deutsch 31-pin connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin A (or 1) of the VSS connector to chassis ground.
  • Measure the resistance from pin B (or 2) of the VSS connector to chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the VSS sensor. Refer to Procedure 019-091 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the engine harness from the OEM harness at the Deutsch 31-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 21 of the VSS connector to all other pins in the Deutsch 31-pin connector, actuator harness side.
  • Measure the resistance from pin 22 of the VSS connector to all other pins in the Deutsch 31-pin connector, actuator harness side.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the actuator harness.

Guided Step 4A - Inspect the actuator harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the Deutsch 31-pin connector.

Action

Inspect the harness and the ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the Deutsch 31-pin connector.

Action

Check for an open circuit in the SIGNAL wire.

  • Measure the resistance from pin 40 of the actuator connector at the ECM to pin 21 of the Deutsch 31-pin connector.
  • Measure the resistance from pin 30 of the actuator connector at the ECM to pin 22 of the Deutsch 31-pin connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the Deutsch 31-pin connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin 40 of the actuator harness connector to the engine block ground.
  • Measure the resistance from pin 30 of the actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the vehicle speed reporting.

Guided Step 5A - Monitor the vehicle speed.

Conditions

  • Connect the INSITE™ service tool.

Action

To check the vehicle speed, use INSITE™ electronic service tool for the following:

  • Verify that the vehicle speed is zero when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed read by the electronic service tool to the speedometer on the dash.

Note: If the dash is an electronic dash that uses the ECM to obtain vehicle speed, perform a road test and use a stopwatch and road mile markers to determine the true vehicle speed.

OK NOT OK

INSITE™ electronic service tool displays correct speed?

INSITE ™ electronic service tool and speedometer do not match.

Verify the VSS parameters are adjusted correctly in the ECM. Check the VSS and the OEM harness in Steps 2A and 2B above. Repair any problems found.

Go to 5B

Go to 6A

Guided Step 5B - Verify the vehicle speed.

Conditions

  • Connect the INSITE™ electronic service tool.

Action

Verify that the speed reported by the INSITE™ electronic service tool is accurate or reasonable for the present gear.

(For example, 40 mph in top gear is probably inaccurate data.)
OK NOT OK

Vehicle speed is accurate for present gear

Vehicle speed read by INSITE™ electronic service tool is inaccurate

Verify VSS parameters are adjusted correctly in the ECM. Check VSS and OEM harness in Steps 2A and 2B above. Repair any problems found.

Fault Code 241

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ to verify Fault Code 242 is inactive.
OK NOT OK

Fault Code 242 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Aug-2012


FAULT CODE 245 - Engine Fan Clutch Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the fan clutch connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit in the actuator harness. | Less than 10 ohms?
 | STEP 1C. Check for a short circuit to ground in the actuator harness. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin in the actuator harness. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the 31-pin Deutsch connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 245 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and the fan clutch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 12 of the OEM 31-pin connector, engine harness side, to pin 5 of the actuator harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM 31-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 5 in the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin-to-pin in the actuator harness.

Conditions

  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 5 in the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the 31-pin Deutsch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin Deutsch connector.
  • Disconnect the actuator harness from the 31-pin Deutsch connector.

Action

Inspect the 31-pin Deutsch connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM 31-pin connector.
  • Disconnect the OEM harness connector from the fan clutch solenoid.

Action

Inspect the 31-pin Deutsch connector for the following:

  • Measure the resistance from pin 12 of the OEM 31-pin connector to pin A (or 1) of the fan clutch solenoid connector.
  • Measure the resistance from pin 13 of the OEM 31-pin connector to pin B (or 2) of the fan clutch solenoid connector.
OK NOT OK

Less than 10 ohms>

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness from the 31-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 12 of the 31-pin connector, OEM harness side, to engine block ground.
  • Measure the resistance from pin 13 of the 31-pin connector, OEM harness side, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness from the 31-pin connector.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin 12 of the 31-pin connector, OEM harness side, to all other pins in the connector.
  • Measure the resistance from pin 13 of the 31-pin connector, OEM harness side, to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 245 is inactive.
OK NOT OK

Fault Code 245 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Aug-2012


FAULT CODE 249 - Ambient Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ambient air temperature sensor. |
 | STEP 1A. Inspect the ambient air temperature sensor and the sensor harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 249 inactive?
 | STEP 1C. Check the resistance of the ambient air temperature sensor. | 175 ohms to 244k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 249 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and the 31-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 249 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ambient air temperature sensor.

Guided Step 1A - Inspect the ambient air temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Inspect the ambient air temperature sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ambient air temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air temperature sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 249 inactive?

Fault Code 249 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the resistance of the ambient air temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Check the resistance of the ambient air temperature sensor.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the ambient air temperature sensor.
OK NOT OK

175 ohms to 244k ohms?

Replace the ambient air temperature sensor

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 249 inactive?

Fault Code 249 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin (non-ICON™-equipped vehicles only). For ICON™-equipped vehicles, reference the OEM documentation.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 12 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM 31-pin connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin 12 of the sensor harness connector to pin 4 of the OEM 31-pin connector, engine harness side.
  • Measure the resistance from pin 13 of the sensor harness connector to pin 3 of the OEM 31-pin connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the 31-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin connector.

Action

Inspect the OEM harness and the 31-pin OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM harness from the ambient air temperature sensor.

Action

Check for a short circuit from pin-to-pin in the OEM harness.

  • Measure the resistance from pin 3 of the OEM 31-pin connector, OEM harness side, to all other pins in the connector.
  • Measure the resistance from pin 4 of the OEM 31-pin connector, OEM harness side, to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM harness from the ambient air temperature sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 4 of the OEM 31-pin connector, OEM harness side, to the SIGNAL pin in the 2-pin sensor harness connector.
  • Measure the resistance from pin 3 of the OEM 31-pin connector, OEM harness side, to the RETURN pin in the 2-pin sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 249 is inactive.
OK NOT OK

Fault Code 249 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM and QSM11 Engines | 3666266
Engine Wiring Harness | Refer to Procedure 019-043 | ISM and QSM11 Engines | 3666266
Fuel Shutoff Valve | Refer to Procedure 019-050 | ISM and QSM11 Engines | 3666266

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff solenoid post. | Extra wires?
 | STEP 1B. Check for corrosion on the solenoid post. | Corrosion found?
 | STEP 1C. Check the supply voltage at the fuel shutoff solenoid. | Greater than positive +6 VDC?
 | STEP 1C-1. Check the actuator harness and the ECM connector pins. |
 | STEP 1C-2. Check for an open circuit. |
 | STEP 1C-3. Check for a short circuit from pin-to-pin. |
 | STEP 1C-4. Measure the voltage from the ECM. |
 | STEP 1D. Check the fuel shutoff solenoid resistance. | 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
STEP 2. | Check the ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Diable the fault code. | Fault code inactive?

Guided Step 1 - Check the fuel shutoff solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires.

  • Check for extra wires on the fuel shut off solenoid post.

Extra wires?
YES NO
No Repair

Repair

Remove extra wires and connect to positive +12 VDC supply.

Go to 1B

Go to 2A

Guided Step 1B - Check for corrosion on the solenoid post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff control wire from the fuel shutoff solenoid.

Action

Check for corrosion.

  • Check for corrosion on the solenoid post.

Corrosion found?
YES NO
No Repair

Repair

Clean the solenoid post and wiring terminal. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 1C

Go to 2A

Guided Step 1C - Check the supply voltage at the fuel shutoff solenoid.

Conditions

  • Disconnect the actuator harness from the fuel shutoff solenoid.
  • Turn keyswitch ON.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff control wire connectors on the harness side to engine block ground.

Greater than positive +6-VDC?
YES | NO
No Repair | No Repair

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1C-2

Go to 1D

Guided Step 1C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit at pin 33.

  • Measure the resistance from pin 33 of the actuator harness to the fuel shutoff control wire.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 1C-3

Go to 2A

Guided Step 1C-3 - Check for a short sircuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 33 of the actuator harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 1C-4

Go to 2A

Guided Step 1C-4 - Measure the voltage from the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage at the ECM from pin 33 of the actuator harness connector port to engine block ground.

Greater than positive +6-VDC?
YES NO

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 1D - Check the fuel shutoff solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff solenoid.

Action

Check the fuel shutoff solenoid resistance.

  • Measure the resistance from the fuel shutoff solenoid to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?

YES NO
No Repair

Repair

Replace the fuel shutoff solenoid.

Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 31-May-2019


FAULT CODE 255 - Fuel Shutoff Solenoid Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for the external voltage source. | Less than positive +1.5-VDC?
 | STEP 1C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 255 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty damaged pins?

Repair the damaged pinsRepair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check for the external voltage source.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the external voltage source.

  • Measure the voltage from pin 33 in actuator harness connector to engine block ground.
OK NOT OK

Less than positive +1.5-VDC?

Remove the external voltage source. There is an external source connected to the wire at which more than positive +1.5-VDC was measured. Find the voltage source and remove it from the circuit.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the fuel shutoff solenoid.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 33 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 255 is inactive.
OK NOT OK

Fault Code 255 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 256 - Ambient Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ambient air temperature sensor. |
 | STEP 1A. Inspect the ambient air temperature sensor and the sensor harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 256 inactive?
 | STEP 1C. Check the resistance of the ambient air temperature sensor. | 175 ohms to 244k ohms?
 | STEP 1D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 256 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check for the OEM harness. |
 | STEP 3A. Inspect the OEM harness and the 31-pin connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes | Fault Code 256 inactive?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ambient air temperature sensor.

Guided Step 1A - Inspect the ambient air temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Inspect the ambient air temperature sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the engine harness, or replace the ambient air temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air temperature sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 256 is inactive.
OK NOT OK

Fault Code 256 inactive?

Fault Code 256 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the resistance of the ambient air temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Check the resistance of the ambient air temperature sensor.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the ambient air temperature sensor.
OK NOT OK

175 ohms to 244k ohms?

Replace the ambient air temperature sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A (or 1) of the ambient air temperature sensor to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the ambient air temperature sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 256 is inactive.
OK NOT OK

Fault Code 256 inactive?

Fault Code 256 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin (non-ICON™-equipped vehicles only). For ICON™-equipped vehicles, refer to OEM documentation.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 12 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 12 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 13 of the sensor harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the 31-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the 31-pin connector.

Action

Inspect the OEM harness and the 31-pin connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 256 is inactive.
OK NOT OK

Fault Code 256 inactive?

Fault Code 256 active.

Go to 4B

Go to 3C

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin connector.
  • Disconnect the OEM harness from the ambient air temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the 31-pin connector to all other pins in the connector.
  • Measure the resistance from pin 4 of the 31-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin connector.
  • Disconnect the OEM harness from the ambient air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM 31-pin connector to engine block ground.
  • Measure the resistance from pin 4 of the OEM 31-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 256 is inactive.
OK NOT OK

Fault Code 256 inactive

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 285 - J1939 Data Link Multiplexing

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for proper multiplexing configuration. |
 | STEP 1A. Determine which vehicle inputs (throttle, switches, lamps, sensors) are multiplexed over the J1939 data link. | INSITE™ electronic service tool readout matches ECM settings for devices (devices in step 1A match step 1B)?
 | STEP 1B. Verify that the proper devices are set to be multiplexed in the ECM using INSITE™ electronic service tool. | INSITE™ electronic service tool readout matches ECM settings for devices (devices in step 1B match step 1A)
 | STEP 1B-1. Change the ECM settings to match the vehicle's multiplexed devices. |
STEP 2. | Check the J1939 connectors on the backbone harness and engine harness connectors. |
 | STEP 2A. Inspect the ECM, OEM harness, and 3-pin connectors. | Dirty or damaged pins?
 | STEP 2B. Inspect the VECU 3-pin and associated connectors. | Dirty or damaged pins?
STEP 3. | Check the SAE J1939 backbone harness. |
 | STEP 3A. Check for an open circuit in the SUPPLY wire. | Less than 10 ohms?
 | STEP 3B. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the shield wire. | Less than 10 ohms?
 | STEP 3D. Check the resistance value of the J1939 harness. | 55 to 65 ohms?
 | STEP 3E. Check for a short circuit to power in the SUPPLY wire. | Less than positive +1.5-VDC?
 | STEP 3F. Check for a short circuit to power in the RETURN wire. | Less than positive +1.5-VDC?
 | STEP 3G. Check for a short circuit to ground in the SUPPLY wire. | Greater than 100k ohms?
 | STEP 3H. Check for a short circuit to ground in the RETURN wire. | Greater than 100k ohms?
 | STEP 3I. Check for a short circuit pin to pin in the OEM connector. | Greater than 100k ohms?
STEP 4. | Check for proper communication with the J1939 devices. |
 | STEP 4A. Check communication with the ECM. | Established communication by monitoring engine speed?
 | STEP 4B. Check communication with the VECU(s). | Proper communication between multiplexing devices and vehicle electronic control units (VECU(s))?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for proper multiplexing configuration.

Guided Step 1A - Determine which vehicle inputs (throttle, switches, lamps, sensors) are multiplexed over the J1939 data link.

Conditions

  • Install the INLINE II™ data link adapter.
  • Install INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check that the vehicle inputs are multiplexed over the J1939 data link.

  • Read the devices that are sending input information with INSITE™ electronic service tool.
OK NOT OK

INSITE™ electronic service tool readout matches ECM settings for devices (devices in step 1A match step 1B)?

INSITE™ electronic service tool readout matches ECM settings for devices (devices in step 1A match step 1B)?

Go to 1B

Go to 1B

Guided Step 1B - Verify that the proper devices are set to be multiplexed in the ECM using INSITE™ electronic service tool.

Conditions

  • Install the INLINE II™ data link adapter.
  • Install INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

ECM settings match devices installed on vehicle.

  • Use INSITE™ electronic service tool to read the ECM settings for devices.
OK NOT OK

INSITE™ electronic service tool readout matches ECM settings for devices (devices in step 1B match step 1A)?

Configure ECM to match vehicle devices.

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Change the ECM settings to match the vehicle's multiplexed devices.

Conditions

  • Install the INLINE II™ data link adapter.
  • Install INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Match the multiplexed devices to the ECM.

  • Use INSITE™ electronic service tool to configure the ECM to work with the multiplexed devices.
OK NOT OK

ECM matches multiplexed devices?

ECM matches multiplexed devices?

Go to 2A

Go to 5A

Guided Step 2 - Check the J1939 connectors on the backbone harness and engine harness connectors.

Guided Step 2A - Inspect the ECM, OEM harness, and 3-pin connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connector.
  • Disconnect the OEM harness.
  • Disconnect the multiplexed devices.

Action

Inspect the ECM, OEM harness, J1939 connectors, and multiplexed devices for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, J1939 backbone harness, or the multiplexed device(s), or replace the ECM, whichever have the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the backbone harness J1939 connector(s). Refer to Procedure 019-203 in Section 19.
  • Repair or replace the multiplexed devices. Reference the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, for specific device.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the VECU 3-pin and associated connectors.

Conditions

  • Disconnect the VECU(s) from the J1939 backbone harness.
  • Disconnect the multiplexed devices from the VECU(s).

Action

Inspect the VECU(s), 3-pin, and multiplexed devices connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the VECU(s), 3-pin connector, or multiplexed devices, whichever have the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the VECU(s). Refer to the OEM troubleshooting and repair manual for repair procedure.
  • Repair the 3-pin connector. Refer to Procedure 019-203 in section 19.
  • Repair or replace the multiplexed devices. Reference the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 3A

Go to 5A

Guided Step 3 - Check the SAE J1939 backbone harness.

Guided Step 3A - Check for an open circuit in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 connector from the VECU(s).

Action

Check continuity in the SUPPLY wire.

  • Measure resistance from supply pin 46 at the OEM harness connector to pin A at the data link connector at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 37 at the OEM connector to pin B at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit in the shield wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for an open circuit in the shield wire.

  • Measure the resistance from pin 36 at the OEM connector to pin C at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the resistance value of the J1939 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the engine harness from the J1939 backbone harness.

Action

Check the resistance value of the J1939 harness.

  • Measure the resistance from pin A to pin B of the J1939 harness connector, OEM side.
OK NOT OK

55 to 65 ohms?

J1939 backbone termination resistors missing or damaged. Replace the termination resistors.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to power in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to power in the SUPPLY wire.

  • Measure the voltage from pin 46 at the ECM to engine block ground.
OK NOT OK

Less than positive +1.5-VDC?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check for a short circuit to power in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to power in the RETURN wire.

  • Measure the voltage from pin 37 at the OEM harness connector to engine block ground.
OK NOT OK

Less than positive +1.5-VDC?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 5A

Guided Step 3G - Check for a short circuit to ground in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short circuit to ground in the SUPPLY wire.

  • Measure the resistance from pin 46 in the OEM harness connector to ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3H

Go to 5A

Guided Step 3H - Check for a short circuit to ground in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short circuit to ground in the RETURN wire.

  • Measure the resistance from pin 37 in the OEM harness connector to ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3I

Go to 5A

Guided Step 3I - Check for a short circuit from pin-to-pin in the OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the engine harness from the J1939 backbone harness.

Action

Check for a short circuit from pin to pin in the OEM connector.

  • Measure the resistance from pin 46 in the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 36 in the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 37 in the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for proper communication with the J1939 devices.

Guided Step 4A - Check communication with the ECM.

Conditions

  • Install INLINE II™ data link adapter.
  • Install INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check communication with ECM.

  • Set up INSITE™ electronic service tool to use the J1939 data link. Refer to the INSITE™ electronic service tool manual for details.
OK NOT OK

Established communication by monitoring engine speed?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check communication with the VECU(s).

Conditions

  • Install the OEM service tool software.
  • Turn keyswitch ON.

Action

Check communication with the VECU(s).

  • Use the OEM service tool software, confirm communication between VECU(s) and multiplexing devices.
OK NOT OK

Proper communication between multiplexing devices and VECU(s)?

Replace the VECU(s). Refer to the OEM troubleshooting and repair manual for repair procedures.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 285 is inactive.
OK NOT OK

Fault Code 285 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 286 - J1939 Data Link Multiplexing

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the vehicle electronic control units (VECU(s)) and engine control module (ECM) have matching settings. |
 | STEP 1A. Consult OEM information and/or use OEM service tool to verify which input parameters are wired to VECU(s). | Physical input devices to VECU match VECU configuration?
 | STEP 1B. Determine which parameters are set to be received over the J1939 data link. Look at the menu: Adjustments - Features and Parameters 2. | INSITE™ electronic service tool readout matches ECM setting for devices (devices in step 1B match step 1A)?
STEP 2. | Change the settings. |
 | STEP 2A. ECM is set up to receive parameters that the VECU(s) is not transmitting. | ECM setting now matches VECU configuration?
 | STEP 2B. The VECU(s) is not set up to transmit information from all of the multiplex devices. | VECU(s) parameters match all input devices that are wired to VECU(s)?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify that the VECU(s) and ECM have matching settings.

Guided Step 1A - Consult OEM information and/or use OEM service tool to verify which input parameters are wired to VECU(s).

Conditions

  • Turn keyswitch to the ON position.
  • Connect to the vehicle VECU with OEM service tool.

Action

Check that the vehicle inputs are multiplexed.

Determine which input devices (throttle, cruise switches, clutch switch, etc.) are wired to the vehicle's VECU(s).

Use OEM service tool to verify the VECU is configured properly.
OK NOT OK

Physical input devices to VECU match VECU configuration?

Change multiplex settings.

Go to 1B

Go to 2B

Guided Step 1B - Determine which parameters are set to be received over the J1939 data link. Look at the menu: Adjustments - Features and Parameters 2.

Conditions

  • Install the INLINE II™ data link adapter to the engine and PC.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON and start INSITE™ electronic service tool job.

Action

ECM settings match devices installed on vehicle.

  • Use INSITE™ electronic service tool to read the ECM settings for devices.
  • Information for settings in menu: Adjustments - Features and Parameters 2.
OK NOT OK

INSITE™ readout matches ECM settings for devices (devices in step 1B match step 1A)

The INSITE™ configuration does not match the VECU configuration.

Go to 3A

Go to 2A

Guided Step 2 - Change the settings.

Guided Step 2A - ECM is set up to receive parameters that the VECU(s) is not transmitting.

Conditions

  • Start INSITE™ and connect to ECM.

Action

Change ECM setting to match VECU configuration.

  • If the ECM is set up to receive any of the parameters that the VECU(s) is not transmitting over the data link, turn off multiplexing for those parameters in the ECM using INSITE™ electronic service tool.
OK NOT OK

ECM setting now matches VECU configuration.

Check OEM multiplex settings.

Go to 3A

Go to 1A

Guided Step 2B - The VECU(s) is not set up to transmit all of the information from all of the multiplex devices.

Conditions

  • Install OEM service tool.
  • Turn keyswitch ON.

Action

Change the setting of the VECU(s) to transmit all information.

  • VECU(s) is not set up to transmit information from all of the devices connected to it. Change the setting in the VECU(s). Refer to the OEM troubleshooting and repair manual for instruction.
OK NOT OK

VECU(s) parameters match all input devices that are wired to VECU(s)?

Check OEM multiplex settings.

Go to 3A

Go to 1A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool verify that Fault Code 286 is inactive.
OK NOT OK

Fault Code 286 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 293 (INDUSTRIAL) - OEM Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM temperature sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 293 inactive?
 | STEP 1C. Check the resistance of the OEM temperature sensor. | Refer to the OEM troubleshooting and repair manual.
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 293 inactive?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from the SIGNAL pin to all other pins. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 293 inactive?
 | STEP 3C. Check for an open circuit in the SIGNAL wire. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from the SIGNAL pin to all other pins. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 293 inactive and Fault Code 294 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 293 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM temperature sensor.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM temperature sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or the OEM temperature sensor.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to the OEM troubleshooting and repair manual for procedure.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the OEM temperature sensor. Refer to the OEM troubleshooting and repair manual for procedure.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 293 is inactive.
OK NOT OK

Fault Code 293 inactive?

Fault Code 293 active.

Go to 5B

Go to 1C

Guided Step 1C - Check the resistance of the OEM temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM temperature sensor.

Action

Check the resistance of the OEM temperature sensor.
OK NOT OK

Refer to the OEM troubleshooting and repair manual.

Replace the OEM temperature sensor.

Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the engine harness 31-pin connector.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 293 is inactive.
OK NOT OK

Fault Code 293 inactive?

Fault Code 293 active.

Go to 5B

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the engine harness 31-pin connector.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector, OEM side, to the OEM temperature sensor connector pin.
  • Measure the resistance from pin 3 of the OEM harness 31-pin connector, OEM side, to the OEM temperature sensor connector pin.
OK NOT OK

Less than 10 ohms.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from the SIGNAL pin to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the engine harness 31-pin connector.

Action

Check for a short circuit from the SIGNAL pin to all other pins.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector, OEM side to all other pins in the connector.
  • Measure the resistance from pin 3 of the OEM harness 31-pin connector, OEM side to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the engine harness 31-pin connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector, OEM side, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 293 is inactive.
OK NOT OK

Fault Code 293 inactive?

Fault Code 293 active.

Go to 5B

Go to 3C

Guided Step 3C - Check for an open circuit in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit in the SIGNAL wire.

  • Measure the resistance from pin 12 of the sensor harness connector at the ECM to pin 4 of the OEM 31-pin connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

  • Measure the resistance from pin 12 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper ECM response.

  • Disconnect the OEM harness connector from the ECM.
  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 293 inactive and Fault Code 294 active?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 293 is inactive.
OK NOT OK

Fault Code 293 inactive?

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-May-2015


FAULT CODE 294 (INDUSTRIAL) - OEM Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM temperature sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 294 inactive?
 | STEP 1C. Check the resistance of the OEM temperature sensor. | Refer to the OEM troubleshooting and repair manual.
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 294 inactive
 | STEP 2C. Check for a short circuit from the SIGNAL pin to all other pins. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 294 inactive?
 | STEP 3C. Check for a short circuit from the SIGNAL pin to all other pins. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 294 inactive and Fault Code 293 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 294 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM temperature sensor.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or the OEM temperature sensor, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM temperature sensor. Refer to the OEM troubleshooting and repair manual for procedure.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service too to verify that Fault Code 294 is inactive.
OK NOT OK

Fault Code 294 inactive?

Fault Code 294 active.

Go to 5B

Go to 1C

Guided Step 1C - Check the resistance of the OEM temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check the resistance of the OEM temperature sensor.
OK NOT OK

Refer to the OEM troubleshooting and repair manual

Replace the OEM temperature sensor.

Refer to the OEM troubleshooting and repair manual for procedure.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the engine harness 31-pin connector.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 294 is inactive.
OK NOT OK

Fault Code 294 inactive?

Fault Code 294 active.

Go to 5B

Go to 2C

Guided Step 2C - Check for a short circuit from the SIGNAL pin to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the engine harness 31-pin connector.

Action

Check for a short circuit from the SIGNAL pin to all other pins.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector, OEM side, to all other pins in the connector.
  • Measure the resistance from pin 3 of the OEM harness 31-pin connector, OEM side, to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the engine harness 31-pin connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin 4 of the of the OEM harness 31-pin connector, OEM side, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness, OEM harness, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 294 is inactive.
OK NOT OK

Fault Code 294 inactive?

Fault Code 294 active.

Go to 5B

Go to 3C

Guided Step 3C - Check for a short circuit from the SIGNAL pin to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL pin to all other pins.

  • Measure the resistance from pin 12 of the sensor harness connector, at the ECM, to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin 12 of the sensor harness connector, at the ECM, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper ECM response.

  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Install a jumper wire, Part Number 3822917, to OEM 31-pin connector pin 3 and pin 4.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 294 inactive and Fault Code 293 active?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 294 is inactive.
OK NOT OK

Fault Code 294 inactive?

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-Aug-2012


FAULT CODE 295 - Ambient Air Pressure Sensor

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 115. |
 | STEP 1A. Check to see if Fault Code 115 is active at engine start-up. | Fault Code 115 inactive?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for a valid fault code. | Fault Code 295 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 295 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for Fault Code 115.

Guided Step 1A - Check to see if Fault Code 115 is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if Fault Code 115 is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 115 inactive?

Troubleshoot Fault Code 115 first.

Go to 2A

Fault Code 115

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for a valid fault code.

Conditions

  • Make certain that the oil temperature is greater than 4°C [40°F].
  • Turn keyswitch OFF.

Action

Check for a valid fault code.

  • Wait 30 seconds.
  • Turn keyswitch ON and wait 15 seconds.
OK NOT OK

Fault Code 295 inactive?

Replace the sensor. Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 295 is inactive.
OK NOT OK

Fault Code 295 inactive?

Return to the troubleshooting steps, or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 287 (INDUSTRIAL) - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the fluid temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM pressure sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the OEM pressure sensor. | Refer to the OEM troubleshooting and repair manual.
 | STEP 1C. Check the supply voltage from the ECM. | +4.75 to 5.25-VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the sensor signal voltage. | +0.4 to 4.5-VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 297 active?
 | STEP 2C. Check for an open circuit in the SIGNAL wire. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from the SIGNAL and RETURN pins to all other pins. | Greater than 100k ohms?
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 297 active?
 | STEP 3C. Check for an open circuit in the SIGNAL wire. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from the SIGNAL and RETURN pins to all other pins. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 297 inactive and Fault Code 298 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 297 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM pressure sensor.

Guided Step 1A - Inspect the OEM harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or the OEM pressure sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM pressure sensor. Refer to the OEM troubleshooting and repair manual for procedure.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the OEM pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the resistance of the OEM pressure sensor.

  • Refer to the OEM troubleshooting and repair manual.
OK NOT OK

Refer to the OEM troubleshooting and repair manual.

Replace the OEM pressure sensor.

Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the supply voltage from the ECM.

Conditions

  • Install breakout cable, Part Number 3162898, between the sensor and the sensor harness connector.
  • Turn keyswitch ON.

Action

Check the ECM supply voltage to the pressure sensor.

  • Measure the supply voltage from pin A (or 1) to pin B (or 2) of the breakout cable.
OK NOT OK

+ 4.75 to 5.25-VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Use a multimeter to check the voltage from the SUPPLY pin to the RETURN pin in the ECM sensor port.
OK NOT OK

+ 4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Call for pre-authorization. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 1D - Check the sensor signal voltage.

Conditions

  • Install breakout cable, Part Number 3162898, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the signal voltage by installing the breakout cable's SIGNAL pin connector (C or 3) and RETURN pin connector (B or 2) into the multimeter.
OK NOT OK

+ 0.4 to 4.5-VDC?

+ 0.4 to 4.5-VDC

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM connector.

Action

Inspect the OEM harness and the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM connector.

Action

Check for an open in the SIGNAL wire.

  • Measure the resistance from the SIGNAL pin of the OEM connector, OEM harness side, to the SIGNAL pin of the OEM harness, pressure sensor connector side.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM connector.

Action

Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

  • Measure the resistance from the SIGNAL pin of the OEM connector to all other pins in the connector.
  • Measure the resistance from the RETURN pin of the OEM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness at the OEM connector.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness at the OEM connector.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit in the SIGNAL wire.

  • Measure the resistance from the SIGNAL pin of the sensor harness connector to the SIGNAL pin of the OEM connector, sensor harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

  • Measure the resistance from the SIGNAL pin of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from RETURN pin of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for appropriate ECM response.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 inactive and Fault Code 298 active?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 297 is inactive.
OK NOT OK

Fault Code 297 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Aug-2012


FAULT CODE 298 (INDUSTRIAL) - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the fluid temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM pressure sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the OEM pressure sensor. | Refer to the OEM troubleshooting and repair manual
 | STEP 1C. Check the supply voltage from the ECM. | +4.75 to 5.25-VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the sensor signal voltage. | +0.4 to 4.5-VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and 31-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 298 active?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from the SIGNAL pin to all other pins. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100k ohms?
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 298 active?
 | STEP 3C. Check for an open circuit in the sensor harness. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from the signal pin to all other pins. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 298 inactive and Fault Code 297 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 298 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM pressure sensor.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or the OEM pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM troubleshooting and repair manual for procedure.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM pressure sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the OEM pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the resistance of the OEM pressure sensor.

  • Refer to the OEM troubleshooting and repair manual for procedure.
OK NOT OK

Refer to the OEM troubleshooting and repair manual.

Replace the OEM pressure sensor.

Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the supply voltage from the ECM.

Conditions

  • Install the breakout cable, Part Number 3162898, between the sensor and the sensor harness.
  • Turn keyswitch ON.

Action

Check the ECM pressure sensor supply voltage.

  • Measure the supply voltage from pin A (or 1) to pin B (or 2) of the breakout cable.
OK NOT OK

+4.75 to 5.25-VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn the keyswitch ON.

Action

Using a multimeter, measure the voltage from the ECM.

  • Measure the voltage at the ECM from the SIGNAL pin to the RETURN pin of the ECM actuator port.
OK NOT OK

+4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 1D - Check the sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor signal voltage.

  • Measure the signal voltage from pin B (or BLACK) to pin C (or YELLOW) of the breakout cable.
OK NOT OK

+0.4 to 4.5-VDC?

Replace the OEM pressure sensor.

Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and 31-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the 31-pin OEM connector.

Action

Inspect the OEM harness and 31-pin OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the 31-pin OEM connector.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from the SUPPLY pin of the OEM connector, OEM harness side, to the SIGNAL pin of the OEM sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from the SIGNAL pin to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the 31-pin OEM connector.

Action

Check for a short circuit from the SIGNAL pin to all other pins.

  • Measure the resistance from the SIGNAL pin of the 31-pin OEM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the 31-pin OEM connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from the SIGNAL pin of the 31-pin OEM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from the SIGNAL pin of the OEM connector, actuator side, to the SIGNAL pin of the sensor harness connector at the ECM.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from the SIGNAL pin to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL pin to all other pins.

  • Measure the resistance from the SIGNAL pin of the sensor harness connector at the ECM to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from the SIGNAL pin of the sensor harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.

Action

Check for appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, between the OEM connector SIGNAL pin and SUPPLY pin.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 inactive and Fault Code 297 active?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 298 inactive.
OK NOT OK

Fault Code 298 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Aug-2012


FAULT CODE 311 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for Fault Code 111. | Fault Code 111 is not active?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the internal actuator harness. |
 | STEP 3A. Inspect the internal actuator harness, pass-through connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the internal actuator harness. | Greater than 100k ohms?
 | STEP 3C. Check the resistance of the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 3D. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for Fault Code 111.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 is not active?

Possible injector failure, a short circuit to ground in the injector 5-VDC supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 111

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Inspect the actuator harness, the actuator harness 15-pin connector, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 9 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 9 in the actuator harness connector to all pins in the sensor harness connector.
  • Measure the resistance from pin 10 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 10 in the actuator harness connector to all pins in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Greater than 100k ohms?

Go to 3A

Go to 4A

Guided Step 3 - Check the internal actuator harness.

Guided Step 3A - Inspect the internal actuator harness, pass-through connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the internal actuator harness and the 15-pin connector.

Action

Inspect the internal actuator harness, 15-pin connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin in the internal actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 15-pin connector.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check for a short circuit from pin-to-pin in the internal harness.

  • Measure the resistance from pin 1 of the 15-pin connector to all other pins in the connector.
  • Measure the resistance from pin 2 of the 15-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the internal actuator harness.

  • Repair the internal actuator harness. Refer to Procedure 019-215 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance from pin A to pin B of the injector solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Replace the injector.

Refer to Procedure 006-026 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the injector.

Refer to Procedure 006-026 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 311 is inactive.
OK NOT OK

Fault Code 311 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Aug-2012


FAULT CODE 312 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for Fault Code 111. | Fault Code 111 is not active?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the internal actuator harness. |
 | STEP 3A. Inspect the internal actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the internal actuator harness. | Greater than 100k ohms?
 | STEP 3C. Check the resistance of the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 3D. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 312 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for Fault Code 111.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 is not active?

Possible injector failure, a short circuit to ground in the injector 5-VDC supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 111

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Inspect the actuator harness, the actuator harness 15-pin connector, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 3 in the actuator harness connector to all pins in the sensor harness connector.
  • Measure the resistance from pin 4 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 4 in the actuator harness connector to all pins in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Go to 3A

Go to 4A

Guided Step 3 - Check the internal actuator harness.

Guided Step 3A - Inspect the internal actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the internal actuator harness and the 15-pin connector.

Action

Inspect the internal actuator harness, 15-pin connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin in the internal actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 15-pin connector.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check for a short circuit from pin-to-pin in the internal harness.

  • Measure the resistance from pin 9 of the 15-pin connector to all other pins in the connector.
  • Measure the resistance from pin 10 of the 15-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the internal actuator harness.

  • Repair the internal actuator harness. Refer to Procedure 019-215 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance from pin A to pin B of the injector solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Replace the injector.

Refer to Procedure 006-026 in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the injector.

Refer to Procedure 006-026 in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 312 is inactive.
OK NOT OK

Fault Code 312 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Aug-2012


FAULT CODE 313 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for Fault Code 111. | Fault Code 111 is not active?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the internal actuator harness. |
 | STEP 3A. Inspect the internal actuator harness, pass-through connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the internal actuator harness. | Greater than 100k ohms?
 | STEP 3C. Check the resistance of the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 3D. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 313 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for Fault Code 111.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 is not active?

Possible injector failure, a short circuit to ground in the injector 5-VDC supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 111

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Inspect the actuator harness, the actuator harness 15-pin connector, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 6 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 6 in the actuator harness connector to all pins in the sensor harness connector.
  • Measure the resistance from pin 16 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 16 in the actuator harness connector to all pins in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Go to 3A

Go to 4A

Guided Step 3 - Check the internal actuator harness.

Guided Step 3A - Inspect the internal actuator harness, pass-through connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the internal actuator harness and the 15-pin connector.

Action

Inspect the internal actuator harness, 15-pin connector, and ECM connector pins for the following:I

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin in the internal actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 15-pin connector.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check for a short circuit from pin-to-pin in the internal harness.

  • Measure the resistance from pin 5 of the 15-pin connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the 15-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the internal actuator harness.

  • Repair the internal actuator harness. Refer to Procedure 019-215 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance from pin A to pin B of the injector solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Replace the injector.

Refer to Procedure 006-026 in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the injector.

Refer to Procedure 006-026 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 313 is inactive.
OK NOT OK

Fault Code 313 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Aug-2012


FAULT CODE 314 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for Fault Code 111. | Fault Code 111 is not active?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the internal actuator harness. |
 | STEP 3A. Inspect the internal actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the internal actuator harness. | Greater than 100k ohms?
 | STEP 3C. Check the resistance of the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 3D. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 314 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for Fault Code 111.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 is not active?

Possible injector failure, a short circuit to ground in the injector 5-VDC supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 111

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Inspect the actuator harness, the actuator harness 15-pin connector, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 2 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 2 in the actuator harness connector to all pins in the sensor harness connector.
  • Measure the resistance from pin 1 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 1 in the actuator harness connector to all pins in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Go to 3A

Go to 4A

Guided Step 3 - Check the internal actuator harness.

Guided Step 3A - Inspect the internal actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the internal actuator harness and the 15-pin connector.

Action

Inspect the internal actuator harness, 15-pin connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin in the internal actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 15-pin connector.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check for a short circuit from pin-to-pin in the internal harness.

  • Measure the resistance from pin 11 of the 15-pin connector to all other pins in the connector.
  • Measure the resistance from pin 12 of the 15-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the internal actuator harness

  • Repair the internal actuator harness. Refer to Procedure 019-215 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance from pin A to pin B of the injector solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Replace the injector.

Refer to Procedure 006-026 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the injector.

Refer to Procedure 006-026 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute .
  • Use INSITE™ electronic service tool to verify Fault Code 314 is inactive.
OK NOT OK

Fault Code 314 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Aug-2012


FAULT CODE 315 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for Fault Code 111. | Fault Code 111 is not active?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the internal actuator harness. |
 | STEP 3A. Inspect the internal actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the internal actuator harness. | Greater than 100k ohms?
 | STEP 3C. Check the resistance of the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 3D. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 315 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for Fault Code 111.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 is not active?

Possible injector failure, a short circuit to ground in the injector 5-VDC supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 111

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Inspect the actuator harness, the actuator harness 15-pin connector, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 7 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 7 in the actuator harness connector to all pins in the sensor harness connector.
  • Measure the resistance from pin 8 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 8 in the actuator harness connector to all pins in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Go to 3A

Go to 4A

Guided Step 3 - Check the internal actuator harness.

Guided Step 3A - Inspect the internal actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the internal actuator harness and the 15-pin connector.

Action

Inspect the internal actuator harness, 15-pin connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin in the internal actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 15-pin connector.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check for a short circuit from pin-to-pin in the internal harness.

  • Measure the resistance from pin 3 of the 15-pin connector to all other pins in the connector.
  • Measure the resistance from pin 4 of the 15-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the internal actuator harness.

  • Repair the internal actuator harness. Refer to Procedure 019-215 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance from pin A to pin B of the injector solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Replace the injector.

Refer to Procedure 006-026 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the injector

Refer to Procedure 006-026 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 315 is inactive.
OK NOT OK

Fault Code 315 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Aug-2012


FAULT CODE 319 - Real-Time Clock Power Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check battery backup module. |
 | STEP 1A. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the battery backup voltage at the ECM connector. | +3.3 to 3.6-VDC?
 | STEP 1B-1. Inspect the battery backup module and actuator harness connector pins. |
 | STEP 1B-2. Check battery backup voltage at the battery module connector. |
STEP 2. | Check the battery backup module harness. |
 | STEP 2A. Check for an open circuit in the SUPPLY wire. | Less than 10 ohms
 | STEP 2B. Check for an open circuit in the RETURN wire. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 319 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the battery backup module.

Guided Step 1A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery backup voltage at the ECM connector.

Conditions

  • Engine equipped with optional real-time clock battery backup module.
  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the battery backup voltage at the ECM connector.

  • Measure battery voltage from pin 20 to pin 47 at the ECM connector.

Note: Gently flex the harness when checking the voltage to check for internally broken or frayed wires.
OK NOT OK

+3.3 to 3.6-VDC?

Does not meet specifications.

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the battery backup module and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery backup module from the actuator harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the battery backup module and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 3A

Guided Step 1B-2 - Check the battery backup voltage at the battery module connector.

Conditions

  • Engine equipped with optional real-time clock battery backup module.
  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the battery backup module.

Action

Check the battery backup voltage at the battery module connector.

  • Measure the battery voltage from battery supply positive (+) to battery return negative (-) at the battery module connector, battery module side.

Note: Gently flex the harness when checking the voltage to check for internally broken or frayed wires.
OK NOT OK

+3.3 to 3.6-VDC?

Does not meet specifications.

Replace the battery backup module

Refer to Procedure 019-311.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery backup module harness.

Guided Step 2A - Check for an open circuit in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery backup module from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect for continuity in the SUPPLY wire.

  • Measure the resistance from pin 20 at the actuator harness connector to pin A (or 1) at the engine harness connector at the battery backup module.

Note: Gently flex the harness when checking the resistance to check for internally broken or frayed wires.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery backup module from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect for continuity in the RETURN wire.

  • Measure the resistance from pin 47 at the actuator harness connector to pin B (or 2) at the engine harness connector at the battery backup module.

Note: Gently flex the harness when checking the resistance to check for internally broken or frayed wires.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the battery backup module from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 20 of the actuator harness connector to all the other pins in the connector.

Note: Gently flex the harness when checking the resistance to check for internally broken or frayed wires.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the battery backup module from the engine harness.

Action

Check for a short circuit to ground in the battery backup module harness.

  • Measure the resistance from pin 20 in the actuator harness connector to engine block ground.

Note: Gently flex the harness when checking the resistance to check for internally broken or frayed wires.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to set real-time clock to correct time.
  • Use INSITE™ electronic service tool to verify Fault Code 319 is inactive.

Note: It is necessary to set the real-time clock with the INSITE™ electronic service tool to make Fault Code 319 go inactive.
OK NOT OK

Fault Code 319 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Aug-2012


FAULT CODE 321 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for Fault Code 111. | Fault Code 111 is not active?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the internal actuator harness. |
 | STEP 3A. Inspect the internal actuator harness, pass-through connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the internal actuator harness. | Greater than 100k ohms?
 | STEP 3C. Check the resistance of the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 3D. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 321 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for Fault Code 111.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 is not active?

Possible injector failure, a short circuit to ground in the injector 5-VDC supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 111

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Inspect the actuator harness, the actuator harness 15-pin connector, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 26 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 26 in the actuator harness connector to all pins in the sensor harness connector.
  • Measure the resistance from pin 36 in the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 36 in the actuator harness connector to all pins in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Go to 3A

Go to 4A

Guided Step 3 - Check the internal actuator harness.

Guided Step 3A - Inspect the internal actuator harness, pass-through connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the internal actuator harness and the 15-pin connector.

Action

Inspect the internal actuator harness, 15-pin connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin in the internal actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 15-pin connector.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check for a short circuit from pin-to-pin in the internal harness.

  • Measure the resistance from pin 7 of the 15-pin connector to all other pins in the connector.
  • Measure the resistance from pin 8 of the 15-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the internal actuator harness.

  • Repair the internal actuator harness. Refer to Procedure 019-215 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the injector solenoid.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance from pin A to pin B of the injector solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Replace the injector.

Refer to Procedure 006-026 in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the solenoid.
OK NOT OK

0.5 to 1.5 ohms?

Replace the injector.

Refer to Procedure 006-026 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 321 is inactive.
OK NOT OK

Fault Code 321 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Aug-2012


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758, male Deutsch™/AMP™/Metri-Pack™ test lead and, Part Number 3822917, female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Resistance of the circuit greater than 1 ohm?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 322 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 111

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 9 and 10 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post-to-post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid less than 0.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater then 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post-to-post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 10 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 9 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the circuit greater than 1 ohm?
YES NO

Repair

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 322 is inactive.

Fault Code 322 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-May-2015


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal, or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Was the resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Is the resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Is the resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Is the resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Is the resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Is the resistance of the circuit greater than 1 ohm?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 323 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 111

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for or general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 4 and 3 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Was the resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedeure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

User the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid less than 0.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater then 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 4 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 3 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the circuit greater than 1 ohm?
YES NO

Repair

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 323 is inactive.

Fault Code 323 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Jun-2012


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal, or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Was the resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Is the resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Is the resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Is the resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Is the resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Is the resistance of the circuit greater than 1 ohm?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 324 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 111

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 6 and 16 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

–

Was the resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid less than 0.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater then 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in Section 3 of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 6 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 16 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the circuit greater than 1 ohm?
YES NO

Repair

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 324 is inactive.

Fault Code 324 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Jun-2012


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal, or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Was the resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Is the resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Is the resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Is the resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Is the resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Is the resistance of the circuit greater than 1 ohm?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 325 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 111

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 2 and 1 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Was the resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid less than 0.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater then 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in Section 3 of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 2 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 1 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the circuit greater than 1 ohm?
YES NO

Repair

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 325 is inactive.

Fault Code 325 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Jun-2012


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal, or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Was the resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Is the resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Is the resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Is the resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Is the resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Is the resistance of the circuit greater than 1 ohm?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 331 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 111

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 8 and 7 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Was the resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid less than 0.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater then 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in Section 3 of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 8 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 7 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the circuit greater than 1 ohm?
YES NO

Repair

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 331 is inactive.

Fault Code 331 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Jun-2012


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal, or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Was the resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Is the resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Is the resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Is the resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Is the resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Is the resistance of the circuit greater than 1 ohm?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 332 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 111

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 26 and 36 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

–

Was the resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid less than 0.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance greater then 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in Section 3 of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Repair

Replace the injector. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 26 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 36 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance of the circuit greater than 1 ohm?
YES NO

Repair

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 332 is inactive.

Fault Code 332 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Jun-2012


FAULT CODE 338 - Ignition Bus Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read fault codes with INSITE™ electronic service tool or flash out with ICON™ lamp. | Fault Code 338 inactive?
STEP 2. | Perform the ignition bus relay test if INSITE™ electronic service tool is available. |
 | STEP 2A. Perform the ignition bus relay test if INSITE™ electronic service tool is available. | Dashboard blowers turn off?
STEP 3. | Inspect the original equipment manufacturer (OEM) harness bulkhead connector and OEM engine harness ECM connector. |
 | STEP 3A. Inspect the OEM engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the idle shutdown vehicle accessory/ignition bus relay. |
 | STEP 4A. Check the idle shutdown vehicle accessory/ignition bus relay connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the idle shutdown vehicle accessory relay coil resistance. | Refer to the OEM troubleshooting and repair manual for specifications.
 | STEP 4C. Check for a short circuit to the battery at ignition bus relay. | Less than 1.5-VDC?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 338 inactive; Dashboard blowers turned off?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read fault codes with INSITE™ electronic service tool or flash out with ICON™ lamp.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes or flash out ICON™ lamp.
OK NOT OK

Fault Code 338 inactive?

Fault Code 338 active

Go to 2A

Go to 2A

Guided Step 2 - Perform the ignition bus relay test if INSITE™ electronic service tool is available.

Guided Step 2A - Perform the ignition bus relay test if INSITE™ is available.

Conditions

  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the ignition bus relay test.

  • Refer to Procedure 019-308 in Section 19.
OK NOT OK

Dashboard/blowers turn off?

Dashboard/blowers do not turn off

Go to 5A

Go to 3A

Guided Step 3 - Inspect the OEM harness bulkhead connector and OEM engine harness ECM connector.

Guided Step 3A - Inspect the OEM engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the bulkhead.
  • Disconnect the OEM harness to the ECM.

Action

Check the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 5A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 35 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the idle shutdown vehicle accessory/ignition bus relay.

Guided Step 4A - Check the idle shutdown vehicle accessory/ignition bus relay connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check the OEM harness and the idle shutdown vehicle accessory relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Replace idle shutdown vehicle accessory/ignition bus relay, Part Number 4009762.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the idle shutdown vehicle accessory relay coil resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check the idle shutdown vehicle accessory/ignition relay resistance.

  • Measure the resistance of the idle shutdown vehicle accessory/ignition relay coil.
OK NOT OK

Reference the OEM troubleshooting and repair manual for specifications.

Replace the idle shutdown vehicle accessory/ignition bus relay, Part Number 4009762.

Reference the OEM troubleshooting and repair manual.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to the battery at ignition bus relay.

Conditions

  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.
  • Connect the OEM harness to the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to the battery.

  • Measure the voltage from pin 85 (or high side) of the idle shutdown vehicle accessory/ignition bus relay to engine block ground.
OK NOT OK

Less than 1.5-VDC?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 338 is inactive.
  • Use INSITE™ electronic service tool to perform ignition bus relay test.
OK NOT OK

Fault Code 338 inactive; Dashboard blowers turned off?

Return to the troubleshooting steps, or contact the nearest Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Aug-2012


FAULT CODE 339 - Ignition Bus Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read fault codes with INSITE™ electronic service tool or flash out with ICON™ lamp. | Fault Code 339 inactive?
STEP 2. | Check the idle shutdown vehicle accessory/ignition bus relay. |
 | STEP 2A. Perform the ignition bus relay test if INSITE™ electronic service tool is available. | Dashboard blowers turn off?
STEP 3. | Inspect the original equipment manufacturer (OEM) harness connector and the fire wall bulkhead OEM harness connector. |
 | STEP 3A. Inspect the OEM harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 43. | Check the idle shutdown vehicle accessory/ignition bus relay. |
 | STEP 4A. Check the idle shutdown vehicle accessory/ignition bus relay connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the idle shutdown vehicle accessory/ignition bus relay coil resistance. | Refer to the OEM troubleshooting and repair manual for specifications.
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 339 inactive; Dashboard blowers turned off?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read fault codes with INSITE™ electronic service tool or flash out with ICON™ lamp.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes or flash out ICON™ lamp.
OK NOT OK

Fault Code 339 inactive?

Fault Code 339 active

Go to 2A

Go to 2A

Guided Step 2 - Check the idle shutdown vehicle accessory/ignition bus relay.

Guided Step 2A - Perform the ignition bus relay test if INSITE™ electronic service tool is available.

Conditions

  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to perform the ignition bus relay test.

  • Refer to Procedure 019-308 in Section 19.
OK NOT OK

Dashboard/blowers turn off?

Does not meet specifications

Go to 5A

Go to 3A

Guided Step 3 - Inspect the OEM harness connector and the fire wall bulkhead OEM harness connector.

Guided Step 3A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM and the OEM harness bulkhead connector.

Action

Use INSITE™ electronic service tool to perform the ignition bus relay test. Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the OEM harness and/or ECM.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 35 (or idle shutdown) of the OEM harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 35 to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check for an open circuit.

  • Measure the resistance from the idle shutdown accessory/ignition bus relay connector pin 86 to engine block ground.
  • Measure the resistance from the idle shutdown vehicle accessory/ignition bus relay connector pin 85 to the OEM harness connector at ECM pin 35.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the idle shutdown vehicle accessory/ignition bus relay.

Guided Step 4A - Check the idle shutdown vehicle accessory/ignition bus relay connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check the OEM harness and the idle shutdown vehicle accessory relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Replace the idle shutdown vehicle accessory/ignition bus relay, Part Number 4009762, or equivalent

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the idle shutdown vehicle accessory/ignition bus relay coil resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check the idle shutdown vehicle accessory/ignition relay resistance.

  • Measure the resistance of the idle shutdown vehicle accessory/ignition relay coil.
OK NOT OK

Refer to the OEM troubleshooting and repair manual for specifications.

Replace the idle shutdown vehicle accessory/ignition bus relay, Part Number 4009762, or equivalent

Refer to the OEM troubleshooting and repair manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 339 is inactive.
  • Use INSITE™ electronic service tool to perform ignition bus relay test.
OK NOT OK

Fault Code 339 inactive; Dashboard blowers turned off?

Return to the troubleshooting steps, or contact the nearest Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Aug-2012


FAULT CODE 341 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | Active fault codes?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the resistance of the battery supply circuit. | Less than 10 ohms?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least +12-VDC, During cranking: At least + 6.2-VDC?
 | STEP 2C. Check the battery connections. | Connections are tight and corrosion-free?
STEP 3. | Check the two 15-amp fuses. |
 | STEP 3A. Verify that the two 15-amp fuses are installed correctly. | Fuses installed correctly?
 | STEP 3B. Verify that the two 15-amp fuses are not blown. | Fuses not blown?
STEP 4. | Check the original equipment manufacturer (OEM) harness |
 | STEP 4A. Check the add-on or the accessory wiring at positive (+) terminal of the battery. | Dirty or damaged wires?
STEP 5. | Calibrate the ECM. |
 | STEP 5A. Calibrate the ECM. | Fault Code 341 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 341 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Active fault codes?

Troubleshoot the active fault codes.

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance from pin 7 of the OEM harness connector to the positive (+) battery terminal.
  • Measure the resistance from pin 8 of the OEM harness connector to the positive (+) battery terminal.
  • Measure the resistance from pin 17 of the OEM harness connector to the positive (+) battery terminal.
  • Measure the resistance from pin 18 of the OEM harness connector to the positive (+) battery terminal.
  • Measure the resistance from pin 28 of the OEM harness connector to the positive (+) battery terminal.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place positive (+) probe of the multimeter on the positive (+) battery terminal and touch negative (-) probe to the negative battery terminal while trying to start engine.
OK NOT OK

Normal conditions: at least +12-VDC; During cranking: at least +6.2-VDC?

Charge or replace the battery.

Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Inspect the battery terminal connections.
OK NOT OK

Connections are tight and corrosion-free?

Tighten the connections

Tighten the loose connections and clean the terminals.

Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the two 15-amp fuses.

Guided Step 3A - Verify that the two 15-amp fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the two 15-amp fuses are installed correctly.

  • Inspect the two 15-amp fuses for correct installation.
OK NOT OK

Fuses installed correctly?

Install the fuses correctly

Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check if the two 15-amp fuses are blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the two 15-amp fuses are not blown.

  • Inspect the two 15-amp fuses to see if they are blown.
OK NOT OK

Fuses not blown?

Locate the short circuit.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Check the add-on or accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair or replace the damaged wiring.

Go to 5A

Go to 5A

Guided Step 5 - Calibrate the ECM.

Guided Step 5A - Calibrate the ECM.

Conditions

  • Connect all components.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECM.
OK NOT OK

Fault Code 341 inactive?

Fault Code 341 active.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service too to verify Fault Code 341 is inactive.
OK NOT OK

Fault Code 341 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Aug-2012


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than three inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Recalibrate the ECM. |
 | STEP 4A. Recalibrate the ECM. | Fault Code 343 active after recalibrating the ECM?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During cranking: At least (+) 6.2-VDC?
YES NO
No Repair

Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Repair

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair

Repair or replace the damaged wiring.

Repair

Repair or replace the OEM power harness from the OEM power connector to the batteries. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Repair

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Recalibrate the ECM.

Guided Step 4A - Recalibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 343 active after recalibrating the ECM?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Jan-2014


FAULT CODE 349 - Auxiliary Speed Governor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check frequency input signal sending unit. |
 | STEP 1A. Verify frequency input signal sending unit accuracy. | Frequency input signal sending unit output is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 349 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check frequency input signal sending unit.

Guided Step 1A - Verify frequency input signal sending unit accuracy.

Conditions

  • Turn keyswitch ON.

Action

Verify frequency input signal sending unit accuracy.

  • Refer to the OEM troubleshooting and repair manual for testing procedures.
OK NOT OK

Frequency input signal sending unit output is correct?

Does not meet specifications.

Repair or replace the OEM frequency input signal sending unit.

Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.

Note: If the fault was at a particular rpm, run engine at that rpm to verify the problem is corrected.
OK NOT OK

Fault Code 349 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Aug-2012


FAULT CODE 352 - Sensor Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for failed sensors. |
 | STEP 1A. Check the intake manifold pressure sensor. | Less than +4.5-VDC
 | STEP 1B. Check the ambient air pressure sensor. | Less than +4.5-VDC
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 352 inactive?
 | STEP 2C. Check the supply voltage. | +4.75 to 5.25-VDC?
 | STEP 2D. Check for a short circuit to ground in the sensor SUPPLY wires. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for failed sensors.

Guided Step 1A - Check the intake manifold pressure sensor.

Conditions

  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor.

  • Measure the voltage from pin A to pin B on the intake manifold pressure connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the ambient air pressure sensor.

Conditions

  • Disconnect the sensor harness from the ambient air pressure sensor.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor.

  • Measure the voltage from pin A to pin B on the ambient air pressure sensor connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the ambient air pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins.

Repair the damaged pins.

Repair or replace the engine harness, connector or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 352 is inactive.
OK NOT OK

Fault Code 352 inactive?

Fault Code 352 active

Go to 3B

Go to 2C

Guided Step 2C - Check the supply voltage.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage from the ECM sensor port pins 17 and 37 to ground.
OK NOT OK

+4.75 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the sensor SUPPLY wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the ambient air pressure sensor.
  • Disconnect the intake manifold pressure sensor.

Action

Check for a short circuit to ground in the sensor SUPPLY wires.

  • Measure the resistance from pins 17 and 37 in the sensor harness to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the intake manifold pressure sensor.
  • Disconnect the ambient air pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 17 to all other pins in the sensor harness.
  • Measure the resistance from pin 37 to all other pins in the sensor harness.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 352 is inactive.
OK NOT OK

Fault Code 352 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Aug-2012


FAULT CODE 359 - ICON™ Engine Auto Start Failure

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Interview the driver to determine when the failure occurred, what the general setup information is, and if any hard start problems occur during manual starts. |
 | STEP 1A. Interview the driver to determine when the failure occurred, what the general setup information is, and if any hard start problems occur during manual starts. | Engine problem?
STEP 2. | Read all fault codes. |
 | STEP 2A. Read fault codes with INSITE™ electronic service tool or flash out with ICON™ lamp. | Fault Code 359 inactive?
 | STEP 2B. Manually start the engine. | Engine starts?
STEP 3. | Check the starter relay contacts. |
 | STEP 3A. Perform the starter relay and interlocks test. | Starter engages?
 | STEP 3B. Check for an open circuit in the ICON™ starter relay coil. | Less than 10 ohms?
STEP 4. | Activate ICON™; check the ECM for active fault codes. |
 | STEP 4A. Activate ICON™; check the ECM for active fault codes. | No active fault codes; Engine performs autostart?
STEP 5. | Check the vehicle speed sensor. |
 | STEP 5A. Monitor for vehicle speed when starting the engine if INSITE™ electronic service tool is available. | 0 mph?
 | STEP 5B. Inspect angle of hood tilt switch. | Greater than 30-degree angle
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 359 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Interview the driver to determine when the failure occurred, what the general setup information is, and if any hard start problems occur during manual starts.

Guided Step 1A - Interview the driver to determine when the failure occurred, what the general setup information is, and if any hard start problems occur during manual starts.

Conditions

  • Check the settings of the cab-mounted thermostat for ICON™.
  • Make certain that the idle shutdown timer and cab thermostat settings are correct in INSITE™ electronic service tool.

Action

Interview the driver to determine if engine or ICON™ has a problem.
OK NOT OK

Engine problem?

Fault Code 359, ICON™ problem

Appropriate troubleshooting and repair manual

Go to 2A

Guided Step 2 - Read all fault codes.

Guided Step 2A - Read fault codes with INSITE™ electronic service tool or flash out with ICON™ lamp.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes or flash out with ICON™ lamp.
OK NOT OK

Fault Code 359 inactive?

Fault Code 359 active or Fault Code 2291 inactive

Go to 5A

Go to 2B

Guided Step 2B - Manually start the engine.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Manually start the engine.

  • Start the engine using the keyswitch.
OK NOT OK

Engine starts?

Refer to the appropriate troubleshooting and repair manual for hard start symptoms.

Go to 3A

Appropriate troubleshooting and repair manual

Guided Step 3 - Check the starter relay contacts.

Guided Step 3A - Perform the starter relay and interlocks test.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Perform the starter relay and interlocks test.

  • Perform the starter relay and interlocks test using INSITE™ electronic service tool.
OK NOT OK

Starter engages?

Starter does not engage

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ICON™ starter relay coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ starter relay.

Action

Check for an open circuit in the ICON™ starter relay coil.

  • Measure the resistance between the starter relay coil contacts.
OK NOT OK

Less than 10 ohms?

Does not meet specifications.

Replace relay.

Go to 4A

Go to 4A

Guided Step 4 - Activate ICON™; check the ECM for active fault codes.

Guided Step 4A - Activate ICON™; check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Start and run the engine in ICON™ mode.
  • Perform autostart with the cab thermostat or battery voltage request.

Action

Check the ECM for active fault codes.

  • Perform an autostart with ICON™. After initial activation of ICON™, engine will shut down in one minute.
  • Request autostart with the cab thermostat. If the cab thermostat is not available, load the batteries to less than 12.2-VDC.
OK NOT OK

No active fault codes; Engine performs autostart?

Active fault codes present

Engine does not autostart

Go to 5A

Troubleshoot active fault codes, 5A

Guided Step 5 - Check the vehicle speed sensor.

Guided Step 5A - Monitor for vehicle speed when starting the engine if INSITE™ electronic service tool is available.

Conditions

  • Turn keyswitch ON.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Perform several manual starts to detect vehicle speed.

  • Monitor the vehicle speed parameter with INSITE™ electronic service tool.
OK NOT OK

0 mph?

More than 0 mph

Go to 5B

Refer to Troubleshooting Fault Code 2291

Guided Step 5B - Inspect angle of hood tilt switch.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the hood tilt switch angle installation.

  • Measure the angle of the hood tilt switch.
  • Inspect the hood tilt switch to make certain that it is secure and tight.
OK NOT OK

Greater than 30-degree angle?

Refer to the Master Repair Manual, ICON™ Idle Control System Aftermarket Kit and OEM Installations, Bulletin 3666415, for installation guidelines.

Increase angle to greater than 30 degrees

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 359 is inactive.
OK NOT OK

Fault Code 359 inactive?

Return to the troubleshooting steps, or contact a local Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Aug-2012


FAULT CODE 381 - Intake Air Heater Number 1 Circuit Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 381 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake air heater relay. | Less than 10 ohms?
 | STEP 2C. Check the intake air heater diagnostic voltage, SUPPLY wire, and return circuit. | Greater than 3.75-VDC?
 | STEP 2D. Check for an open circuit in the intake air heater relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 381 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 381 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 381 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake air heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check the intake air heater relay resistance.

  • Measure the resistance between the intake air heater SIGNAL pin and the intake air heater RETURN pin at the intake air heater relay.

Note: For 12 volt systems, both relays must be checked individually.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the intake air heater relay.

Replace the intake air heater relay.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the intake air heater diagnostic voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the intake air heater supply voltage and return circuit.

  • Measure the voltage between the intake air heater relay SIGNAL wire and the intake air heater relay RETURN wire at the intake air heater relay connector of the OEM harness.

Note: For 12 volt systems, both leads must be tested.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the intake air heater relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake air heater relay RETURN pin at the intake air heater relay connector to ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected.

Refer to the OEM wiring diagram for RETURN wire configuration.

  • If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness, if possible.

  • Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intake air heater relay SIGNAL pin and the OEM harness intake air heater relay connector SIGNAL wire.

Note: For 12 volt systems, both leads must be tested.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open intake air heater relay signal circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake air heater relay SIGNAL wire has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 381 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 381 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Aug-2012


FAULT CODE 386 - Sensor Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the supply voltage. | +4.75 to 5.25-VDC?
 | STEP 1C. Check for a short circuit to the battery. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 386 is inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor harness.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from each sensor.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the sensor harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the supply voltage.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage out of the ECM from the SUPPLY pin for each sensor (pin 17 for ambient air pressure, pin 37 for intake manifold pressure) to ground.
OK NOT OK

+4.75 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit to the battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 17 of the sensor harness connector to pin 7 of the OEM harness connector.
  • Measure the resistance from pin 37 of the sensor harness connector to pin 7 of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the sensor harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 17 of the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from pin 37 of the sensor harness connector to all other pins in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the sensor harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 386 is inactive.
OK NOT OK

Fault Code 386 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Aug-2012


FAULT CODE 387 - Throttle Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the supply voltage. | + 4.75 to 5.25-VDC?
 | STEP 1C. Check for a short circuit to battery. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 387 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the supply voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage out of the ECM OEM harness connector port at pin 48 to ground.
OK NOT OK

+ 4.75 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit to battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to battery.

  • Measure the resistance from pin 7 to pin 48 in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the throttle sensor and the remote throttle sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 48 to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 387 is inactive.
OK NOT OK

Fault Code 387 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 388 - Engine Brake Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake connector. |
 | STEP 1A. Inspect the engine brake connector. | Dirty or damaged pins?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the actuator harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Less than 100k ohms?
 | STEP 2C. Check for an short circuit to ground. | Greater than 100 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 388 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine brake connector.

Guided Step 1A - Inspect the engine brake connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake connector from the engine brake actuator.

Action

Check the engine brake connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine brake connector. Refer to Procedure 019-197 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM.
  • Disconnect the actuator harness from the 15-pin connector.

Action

Inspect the actuator harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 44 of the actuator harness connector to all other pins in the actuator harness connector.
  • Measure the resistance from pin 31 of the actuator harness connector to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 44 in the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 388 is inactive.
OK NOT OK

Fault Code 388 inactive.

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Aug-2012


FAULT CODE 392 - Engine Brake Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake harness connectors. |
 | STEP 1A. Inspect the engine brake solenoid and brake harness connector pins. | Dirty or damaged pins?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and engine brake harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 392 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine brake connectors.

Guided Step 1A - Inspect the engine brake solenoid and brake harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake harness from the engine brake solenoid.

Action

Inspect the engine brake solenoid and brake harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine brake solenoid or engine brake harness, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine brake harness. Refer to Procedure 019-206 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 019-063 in Section 19.
  • Replace the engine brake solenoid. Reference the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and engine brake harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the engine harness.

Action

Inspect the actuator harness and engine brake harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or engine brake harness, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine brake harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 019-063 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM.
  • Disconnect the engine brake harness from the brake actuators.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 15 to all other pins in the actuator harness connector.
  • Measure the resistance from pin 31 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from the engine harness.
  • Disconnect the engine brake harness from the engine brake actuators.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 13 of the engine brake harness to engine block ground.
  • Measure the resistance from pin 14 of the engine brake harness to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine brake harness.

Refer to Procedure 019-063 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 392 is inactive.
OK NOT OK

Fault Code 392 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Aug-2012


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 415 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 415 active or inactive with more than one count in the last 25 engine hours?
YES NO

Repair

Low engine oil pressure has been detected.

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the appropriate service manual.

 No Repair

Appropriate fault code troubleshooting tree.

Repair complete.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 19-Jun-2017


FAULT CODE 419 - Intake Manifold Pressure Sensor

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 115. |
 | STEP 1A. Check to see if Fault Code 115 is active at engine start-up. | Fault Code 115 inactive?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for a valid fault code. | Fault Code 419 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 419 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for Fault Code 115.

Guided Step 1A - Check to see if Fault Code 115 is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if Fault Code 115 is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 115 inactive?

Troubleshoot Fault Code 115 first.

Go to 2A

Fault Code 115

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for a valid fault code.

Conditions

  • Make certain that the oil temperature is greater than 4°C [40°F].
  • Turn keyswitch OFF.

Action

Check for a valid fault code.

  • Wait 30 seconds.
  • Turn keyswitch ON and wait 15 seconds.
OK NOT OK

Fault Code 419 inactive?

Replace the sensor.

Refer to Procedure 019-061 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Verify that Fault Code 419 is inactive.
OK NOT OK

Fault Code 419 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Aug-2012


FAULT CODE 422 - Coolant Level Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes and the presence of the coolant level sensor. |
 | STEP 1A. Read the fault codes. | Fault Code 187 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check if vehicle has a coolant level sensor. | Coolant level sensor present?
 | STEP 1B-1. Check if a coolant level sensor is used in the application, or if a shorting plug is installed in the coolant level sensor harness connection. |
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Inspect the engine harness and coolant level sensor connectors. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness and the engine control module (ECM) connectors. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the coolant level sensor circuit. | Less than 10 ohms?
 | STEP 2C-1. Inspect the original equipment manufacturer (OEM) harness sensor connector and 31 pin OEM connector pins. |
 | STEP 2C-2. Check for an open circuit in the engine harness. |
 | STEP 2C-3. Check for an open circuit in the OEM harness. |
STEP 3. | Check for a short circuit to ground in the SIGNAL wires. |
 | STEP 3A. Check for a short circuit to ground in the coolant level sensor SIGNAL wires. | Greater than 100k ohms?
 | STEP 3A-1. Check for a short circuit to ground in the engine harness. |
 | STEP 3A-2. Check for a short circuit to ground in the OEM harness. |
STEP 4. | Check for a short circuit between the SIGNAL wires and any other wires in the engine harness or OEM harness. |
 | STEP 4A. Check for a short circuit between the SIGNAL wires and any other wires in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 4A-1. Check for a short circuit in the engine harness. |
 | STEP 4A-2. Check for a short circuit in the OEM harness. |
STEP 5. | Check for a short circuit to ground in the SUPPLY wire. |
 | STEP 5A. Check for a short circuit to ground in the SUPPLY wire. | Greater than 100k ohms?
 | STEP 5A-1. Check for a short circuit in the engine harness. |
 | STEP 5A-2. Check for a short circuit in the OEM harness. |
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 422 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes and the presence of the coolant level sensor.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to Fault Code 187 troubleshooting tree

Go to 1B

Guided Step 1B - Check if vehicle has a coolant level sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check to see if the vehicle has a coolant level sensor.

Coolant level sensor present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Check if a coolant level sensor is used in the application, or if a shorting plug is installed in the coolant level sensor harness connection.

Conditions

  • Turn keyswitch OFF.

Action

Check if a shorting plug is installed in the coolant level sensor harness connection.

  • Note: Check the OEM wiring from the shorting plug to the engine harness connection for problems. Reference the OEM and the engine harness wiring diagrams.

If a Shorting plug is used in the application, is it present and properly installed?
YES NO
No Repair

Repair

Install the shorting plug.

Go to 2A

Go to 6A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Inspect the harness and the coolant level sensor connectors.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM harness from the coolant level sensor.

Action

Inspect the harness and the coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the OEM harness, or replace the coolant level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 6A

Go to 2C

Guided Step 2C - Check for an open circuit in the coolant level sensor circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for an open circuit in the coolant level sensor circuit.

  • Measure the resistance from pin 25 in the sensor harness connector to pin C (or 3) on the harness side of the coolant level sensor connector.
  • Measure the resistance from pin 23 in the sensor harness connector to pin B (or 2) on the harness side of the coolant level sensor connector.
  • Measure the resistance from pin 24 in the sensor harness connector to pin D (or 4) on the harness side of the coolant level sensor connector.
  • Measure the resistance from pin 22 in the sensor harness connector to pin A (or 1) on the harness side of the coolant level sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Inspect the OEM harness sensor connector and 31 pin OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the engine harness from the OEM harness at the 31 pin OEM connector.

Action

Inspect the OEM harness sensor connector and 31 pin OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Associated Procedure Tables.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 6A

Go to 2C-2

Guided Step 2C-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the engine harness from the OEM harness at the 31 pin OEM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin 22 in the sensor harness connector to pin 6 on the engine harness side of the 31 pin OEM connector.
  • Measure the resistance from pin 23 in the sensor harness connector to pin 19 on the engine harness side of the 31 pin OEM connector.
  • Measure the resistance from pin 24 in the sensor harness connector to pin 5 on the engine harness side of the 31 pin OEM connector.
  • Measure the resistance from pin 25 in the sensor harness connector to pin 7 on the engine harness side of the 31 pin OEM connector.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. 019-208 in Section 19. 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C-3

Go to 6A

Guided Step 2C-3 - Check for an open circuit in OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM harness at the 31 pin OEM connector
  • Disconnect the OEM harness at the Weather-Pack™ four-way connector.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 6 on the OEM harness side of the 31 pin OEM connector to pin A (or 1) on the OEM harness side of the 4 pin connector.
  • Measure the resistance from pin 19 on the OEM harness side of the 31 pin OEM connector to pin B (or 2) on the OEM harness side of the 4 pin connector.
  • Measure the resistance from pin 7 on the OEM harness side of the 31 pin OEM connector to pin C (or 3) on the OEM harness side of the 4 pin connector.
  • Measure the resistance from pin 5 on the OEM harness side of the 31 pin OEM connector to pin D (or 4) on the OEM harness side of the 4 pin connector.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check for a short circuit to ground in the SIGNAL wires.

Guided Step 3A - Check for a short circuit to ground in the coolant level sensor SIGNAL wires.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit to ground in the coolant level sensor signal wires.

  • Measure the resistance from pin 22 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 24 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 25 of the sensor harness connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

Does not meet specifications.

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the engine harness from the OEM harness at the 31 pin OEM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance from pin 22 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 24 of the sensor harness connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19 in the Associated Procedure Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the engine harness from the OEM harness at the 31 pin OEM connector.

Action

Check for a short circuit to ground in OEM harness.

  • Measure the resistance from pin A (or 1) on the OEM harness side of the 4 pin connector to engine block ground.
  • Measure the resistance from pin C (or 3) on the OEM harness side of the 4 pin connector to engine block ground.
  • Measure the resistance from pin D (or 4) on the OEM harness side of the 4 pin connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for a short circuit between the SIGNAL wires and any other wires in the engine harness or OEM harness.

Guided Step 4A - Check for a short circuit between the SIGNAL wires and any other wires in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM connector from the coolant level sensor.

Action

Check for a short circuit between the SIGNAL wires and any other wires in the OEM harness or engine harness.

  • Measure the resistance from pin 22 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 24 of the sensor harness connector to all other pins in the connector.

Greater than 100k ohms?
YES NO

Repair

Replace the coolant level sensor. Refer to Procedure 019-017 in the Associated Procedure Table.

No Repair

Go to 4A-1

Go to 6A

Guided Step 4A-1 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM connector from the coolant level sensor
  • Disconnect the engine harness from the OEM harness at the 31 pin OEM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance from pin 22 of the sensor harness connector to pins 24, 23, and 25 of the connector.
  • Measure the resistance from pin 24 of the sensor harness connector to pins 22, 23, and 25 of the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associate Procedures Table.

Go to 4A-2

Go to 6A

Guided Step 4A-2 - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the OEM harness at the OEM side of the 31 pin OEM connector.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin A (or 1) in the OEM harness connector to pins B (or 2), C (or 3), and D (or 4).
  • Measure the resistance from pin D (or 4) in the OEM harness connector to pins A (or 1), B (or 2), and C (or 3).

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for a short circuit to ground in the SUPPLY wire.

Guided Step 5A - Check for a short circuit to ground in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF
  • Disconnect the sensor harness connector from the ECM
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit to ground in the SUPPLY wire.

  • Measure the resistance from pin 25 in the sensor harness connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 5A-1

Go to 6A

Guided Step 5A-1 - Check for a short circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the sensor harness from the OEM harness at the 31 pin OEM connector.

Action

Check for a short circuit in the sensor harness.

  • Measure the resistance from pin 25 of the sensor harness connector to pin 22 of the connector.
  • Measure the resistance from pin 25 of the sensor harness connector to pin 23 of the connector.
  • Measure the resistance from pin 25 of the sensor harness connector to pin 24 of the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A-2

Go to 6A

Guided Step 5A-2 - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the sensor harness from the OEM harness at the 31 pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack™ four-way connector.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin C (or 3) in the OEM harness connector to pins A (or 1), B (or 2), and D (or 4).

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 422 is inactive.

Fault Code 422 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 6B

Escalate or call for assistance.

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Jan-2019


FAULT CODE 426 - J1939 Data Link Communication

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for proper multiplexing configuration. |
 | STEP 1A. Verify that the proper devices are set. | INSITE™ electronic service tool readout matches ECM settings for devices?
 | STEP 1B. Check data link output. | Fault Code 426 inactive?
STEP 2. | Check the SAE J1939 connectors on the backbone harness and engine harness connectors. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) harness, J1939 and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Inspect the connectors on any other device connected to the J1939 data link. | Dirty or damaged pins?
STEP 3. | Check the SAE J1939 backbone harness. |
 | STEP 3A. Check for an open circuit in the SUPPLY wire. | Less than 10 ohms?
 | STEP 3B. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
 | STEP 3C. Check the resistance value in the J1939 harness. | 55 to 65 ohms?
 | STEP 3D. Check for an open circuit in the shield wire. | Less than 10 ohms?
 | STEP 3E. Check for a short circuit to power in the SUPPLY wire. | Less than +1.5-VDC?
 | STEP 3F. Check for a short circuit to power in the RETURN wire. | Less than +1.5-VDC?
 | STEP 3G. Check for a short circuit to ground in the SUPPLY wire. | Greater than 100k ohms?
 | STEP 3H. Check for a short circuit to ground in the RETURN wire. | Greater than 100k ohms?
 | STEP 3I. Check for a short circuit from pin-to-pin in the OEM connector. | Greater than 100k ohms?
STEP 4. | Check for malfunctioning J1939 devices. |
 | STEP 4A. Check communication between the ECM and other multiplex devices. | Established communication?
 | STEP 4A-1. Check for malfunctioning J1939 devices. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for proper multiplexing configuration.

Guided Step 1A - Verify that the proper devices are set.

Conditions

  • Install INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check that the vehicle inputs are multiplexed over the J1939 data link.

  • Read the devices that are sending input information with INSITE™ electronic service tool.
  • Information for settings are in menu: Adjustable Features and Parameters - J1939 Multiplexing.
OK NOT OK

INSITE™ readout matches ECM settings for devices?

Configure the ECM to match the multiplexing devices.

Go to 1B

Go to 5A

Guided Step 1B - Check data link output.

Conditions

  • Install the INLINE II™ data link adapter.
  • Install INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Using INSITE™ electronic service tool to read the engine speed.
  • Check for any active fault codes.
OK NOT OK

Fault Code 426 inactive?

Go to 5A

Go to 2A

Guided Step 2 - Check the SAE J1939 connectors on the backbone harness and engine harness connectors.

Guided Step 2A - Inspect the OEM harness, J1939 and ECM connectors.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the multiplexed devices.

Action

Inspect the OEM harness, J1939, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, J1939, 3-pin connector(s), or multiplexed devices, or replace the ECM, whichever have the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the 3-pin connectors. Refer to Procedure 019-203 in Section 19.
  • Reference the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the connectors on any other device connected to the J1939 data link.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VECU(s) from the J1939 backbone harness.
  • Disconnect the multiplexed devices from the VECU(s).

Action

Inspect the connectors on the VECU(s), 3-pin connectors, and multiplexed devices connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the VECU(s), 3-pin connector, or multiplexed devices, whichever have the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the VECU(s). Reference the OEM troubleshooting and repair manual for repair procedure.
  • Repair the 3-pin connector. Refer to Procedure 019-203 in Section 19.
  • Reference the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 3A

Go to 5A

Guided Step 3 - Check the SAE J1939 backbone harness.

Guided Step 3A - Check for an open circuit in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 connector from the VECU(s).

Action

Check for an open circuit in the SUPPLY wire.

  • Measure resistance from SUPPLY pin 46 at the OEM harness connector to pin A at the data link connector at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 37 at the OEM connector to pin B at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the resistance value in the J1939 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness form the VECU(s).
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance value of the J1939 harness.

  • Measure from pin 46 in the OEM harness connector to pin 37 in the OEM harness connector.
OK NOT OK

55 to 65 ohms?

J1939 backbone termination resistors missing or damaged.

Replace both termination resistors.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the shield wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for an open circuit in the shield wire.

  • Measure the resistance from pin 36 at the OEM harness connector at the ECM to pin C at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to power in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short to power in the SUPPLY wire.

  • Measure the voltage from pin 46 at the ECM to ground at the J1939 connector.
OK NOT OK

Less than +1.5-VDC?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check for a short circuit to power in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to power in the RETURN wire.

  • Measure the voltage from pin 37 at the OEM harness connector to ground at the VECU(s) connector.
OK NOT OK

Less than +1.5-VDC?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 5A

Guided Step 3G - Check for a short circuit to ground in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for short to ground in the SUPPLY wire.

  • Measure the resistance from pin 46 in the OEM harness connector to ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3H

Go to 5A

Guided Step 3H - Check for a short circuit to ground in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short to ground in the RETURN wire.

  • Measure the resistance from pin 37 in the OEM harness connector to ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3I

Go to 5A

Guided Step 3I - Check for a short circuit from pin-to-pin in the OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short from pin-to-pin in the OEM connector.

  • Measure the resistance from pin 46 in the OEM harness connector to all other pins in the connector, except pins 36 and 37.
  • Measure the resistance from pin 36 in the OEM harness connector to all other pins in the connector, except pins 46 and 37.
  • Measure the resistance from pin 37 in the OEM harness connector to all other pins in the connector, except pins 36 and 46.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for malfunctioning J1939 devices.

Guided Step 4A - Check communication between the ECM and the multiplex devices.

Conditions

  • Install INSITE™ electronic service tool.
  • Install INLINE II™ data link adapter.
  • Disconnect all J1939 devices from the J1939 data link.
  • Turn keyswitch ON.

Action

Check communication with the ECM using INSITE™ electronic service tool over J1939.

  • Use INSITE™ electronic service tool to confirm communication between ECM and multiplexing devices.
OK NOT OK

Established communication?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Check for malfunctioning J1939 devices.

Conditions

  • Install INSITE™ electronic service tool.
  • Install INLINE II™ data link adapter.
  • Turn keyswitch ON.

Action

Check for malfunctioning J1939 devices.

  • Disconnect J1939 devices from the J1939 backbone one-by-one until communication can be established using INSITE™ electronic service tool.

Note: Before disconnecting J1939 devices, remember to turn the keyswitch off, so the ECM will not register fault code.

OK NOT OK

Proper communication between J1939 devices and J1939 backbone?

Replace malfunctioning J1939 device

Reference the OEM troubleshooting and repair manual for repair procedures.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 426 is inactive.
OK NOT OK

Fault Code 426 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Aug-2012


FAULT CODE 428 - Water-In-Fuel (WIF) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check engine harness. |
 | STEP 1A. Inspect the engine harness, WIF sensor, and ECM connectors. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1C. Check sensor supply voltage. | + 4.75 to 5.25-VDC?
 | STEP 1D. Measure the voltage from the ECM. | + 4.75 to 5.25-VDC?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 428 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check engine harness.

Guided Step 1A - Inspect the engine harness, WIF sensor, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the WIF sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness, WIF sensor, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM or WIF sensor, or whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the WIF sensor. Refer to Procedure 019-127 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the WIF sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 9 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 10 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check sensor supply voltage.

Conditions

  • Disconnect the sensor harness from the WIF sensor.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check sensor supply voltage.

  • Measure the voltage from pin B (or 2) on the harness side of the WIF sensor connector to engine block ground.
OK NOT OK

+ 4.75 to 5.25-VDC?

Replace the WIF sensor

Refer to Procedure 019-127 in Section 19.

Go to 2A

Go to 1D

Guided Step 1D - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness from the WIF sensor.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of ECM.

  • Measure the voltage out of the ECM from pin 9 to pin 10 of the ECM sensor port.
OK NOT OK

+ 4.75 to 5.25-VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 428 is inactive.
OK NOT OK

Fault Code 428 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


FAULT CODE 429 - Water-In-Fuel (WIF) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness, WIF sensor, and ECM connectors. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1D. Check the sensor supply voltage. | + 4.75 to 5.25-VDC?
 | STEP 1E. Measure the supply voltage from the ECM. | + 4.75 to 5.25-VDC?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 429 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness, WIF sensor, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the WIF sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness, WIF sensor, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the WIF sensor or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the WIF sensor. Refer to Procedure 019-127 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the WIF sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 9 of the sensor harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the WIF sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 9 in the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check the sensor supply voltage.

Conditions

  • Disconnect the sensor harness from the WIF sensor.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from pin B (or 2) on the harness side of the WIF sensor connector to engine block ground.
OK NOT OK

+ 4.75 to 5.25-VDC?

Replace WIF sensor

Refer to Procedure 019-127 in Section 19.

Does not meet specifications.

Go to 2A

Go to 1E

Guided Step 1E - Measure the supply voltage from the ECM.

Conditions

  • Disconnect the sensor harness from the WIF sensor.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the supply voltage from the ECM.

  • Measure the voltage from pin 9 of the ECM sensor port to pin 10 of the ECM sensor port.
OK NOT OK

+ 4.75 to 5.25-VDC?

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 429 is inactive.
OK NOT OK

Fault Code 429 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tools to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


FAULT CODE 431 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ISS. |
 | STEP 1A. Verify the ISS is connected to the OEM harness. | ISS is connected?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 inactive?
 | STEP 1C. Inspect the OEM harness and ISS connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an open circuit. | Less than 125 ohms?
 | STEP 1E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM supply voltage. | + 4.75 to 5.25 VDC?
 | STEP 2C. Check for an open circuit. | Less than 125 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ISS.

Guided Step 1A - Verify the ISS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the ISS is connected to the OEM harness.

  • Inspect the ISS connection.
OK NOT OK

ISS is connected?

Connect the ISS.

Connect the OEM harness to the ISS.

Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 inactive?

Go to 3A

Go to 1C

Guided Step 1C - Inspect the OEM harness and ISS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ISS.

Action

Inspect the OEM harness and ISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins.

Repair or replace the ISS or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the ISS if the connector pins are damaged. Reference the OEM troubleshooting and repair manual.
  • Replace the ISS connector if it is oversized or damaged. Reference the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ISS.

Action

Check for an open circuit.

  • Measure the resistance from the idle signal pin to the return wire pin on the ISS with the pedal released.
  • Measure the resistance from the off-idle signal pin to the return wire pin on the ISS with the pedal depressed.
OK NOT OK

Less than 125 ohms?

Replace the IVS

Reference the OEM troubleshooting and repair manual.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ISS.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the idle signal pin to the off-idle signal pin on the ISS with the pedal released and depressed.
OK NOT OK

Greater than 100k ohms?

Replace the ISS.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the ECM supply voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM supply voltage.

  • Measure the voltage from pin 3 of the ECM OEM port to the engine block ground.
  • Measure the voltage from pin 13 of the ECM OEM port to the engine block ground.
OK NOT OK

+ 4.75 to 5.25 VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the ISS.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 of the OEM harness connector to pin 19 of the OEM harness connector with the accelerator pedal released.
  • Measure the resistance from pin 13 of the OEM harness connector to pin 19 of the OEM harness connector with the accelerator pedal depressed.
OK NOT OK

Less than 125 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the ISS.
  • All cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch to the OFF position for 5 seconds.
  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Oct-2012


FAULT CODE 431 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the NISS. |
 | STEP 1A. Verify the NISS is connected to the OEM harness. | NISS is connected?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 inactive?
 | STEP 1C. Inspect the OEM harness and NISS connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an open circuit. | Less than 10 ohms?
 | STEP 1E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM supply voltage. | +4.75 to 5.25-VDC?
 | STEP 2C. Check for an open circuit. | Less than 125 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the NISS.

Guided Step 1A - Verify the NISS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the NISS is connected to the OEM harness.
OK NOT OK

NISS is connected?

Connect the OEM harness to the NISS. Reference the OEM troubleshooting and repair manual.

Connect the NISS.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 inactive?

Go to 1C

Go to 3A

Guided Step 1C - Inspect the OEM harness and NISS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the NISS.

Action

Inspect the OEM harness and NISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins.

Repair or replace the NISS or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the NISS if the connector pins are damaged. Reference the OEM troubleshooting and repair manual.
  • Replace the NISS connector if it is oversize or damaged. Reference the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the NISS.

Action

Check for an open circuit.

  • Measure the resistance from the idle SIGNAL pin to the RETURN wire pin on the NISS with the pedal released.
  • Measure the resistance from the off-idle SIGNAL pin to the RETURN wire pin on the NISS with the pedal depressed.
OK NOT OK

Less than 10 ohms?

Replace the NISS.

Reference the OEM troubleshooting and repair manual.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the NISS.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the idle SIGNAL pin to the off-idle SIGNAL pin on the NISS with the pedal released and depressed.
OK NOT OK

Greater than 100k ohms?

Replace the NISS.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the ECM supply voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM supply voltage.

  • Measure the voltage from pin 3 of the ECM OEM port to the engine block ground.
  • Measure the voltage from pin 13 of the ECM OEM port to the engine block ground.
OK NOT OK

+ 4.75 to 5.25 VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the NISS.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the OEM harness connector to pin 19 (or applicable cab common RETURN pin) of the OEM harness connector with the accelerator pedal released.
  • Measure the resistance from pin 3 of the OEM harness connector to pin 19 (or applicable cab common RETURN pin) of the OEM harness connector with the accelerator pedal depressed. Note: Pin 9, 10, 19, or 20 can be used as cab common returns depending on the OEM configuration.
OK NOT OK

Less than 125 ohms?

Repair or replace the OEM harness.

Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the NISS.
  • All cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch to the OFF position for 5 seconds.
  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Oct-2012


FAULT CODE 431 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SSS. |
 | STEP 1A. Verify the SSS is connected to the OEM harness. | SSS is connected?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 inactive?
 | STEP 1C. Inspect the OEM harness and SSS connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an open circuit. | Less than 125 ohms?
 | STEP 1E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM supply voltage. | +4.75 to 5.25-VDC?
 | STEP 2C. Check for an open circuit. | Less than 125 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the SSS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the SSS is connected to the OEM harness.

  • Inspect the SSS connection.
OK NOT OK

SSS is connected?

Connect the SSS.

Connect the OEM harness to the SSS. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 inactive?

Go to 1C

Go to 3A

Guided Step 1C - Inspect the harness and SSS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the SSS.

Action

Inspect the OEM harness and SSS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins.

Repair or replace the SSS or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the SSS if the connector pins are damaged. Reference the OEM troubleshooting and repair manual.
  • Replace the SSS connector if it is oversized or damaged. Reference the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the SSS.

Action

Check for an open circuit.

  • Measure the resistance from the idle SIGNAL pin to the RETURN wire pin on the SSS with the pedal released.
  • Measure the resistance from the off-idle SIGNAL pin to the RETURN wire pin on the SSS with the pedal depressed.
OK NOT OK

Less than 125 ohms?

Replace the SSS.

Reference the OEM troubleshooting and repair manual.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the SSS.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the idle SIGNAL pin to the off-idle SIGNAL pin on the SSS with the pedal released and depressed.
OK NOT OK

Greater than 100k ohms?

Replace the SSS.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the ECM supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the ECM supply voltage.

  • Measure the voltage from pin 3 of the ECM OEM port to the engine block ground.
  • Measure the voltage from pin 13 of the ECM OEM port to the engine block ground.
OK NOT OK

+ 4.75 to 5.25 VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the SSS.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 of the OEM harness connector to pin 19 (or applicable cab common return pin) of the OEM harness connector with the accelerator pedal released.
  • Measure the resistance from pin 13 of the OEM harness connector to pin 19 (or applicable cab common return pin) of the OEM harness connector with the accelerator pedal depressed. Note: Pin 9, 10, 19, or 20 can be used as cab common returns depending on the OEM configuration.
OK NOT OK

Less than 125 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the SSS.
  • All cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch to ON and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch to OFF for 5 seconds.
  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Oct-2012


FAULT CODE 432 - Accelerator Pedal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Perform the fault code disable procedure. | Fault Code 432 still active?
 | STEP 1B. Check for idle validation fault codes. | Fault Codes 131 and 551 inactive?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and the ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check the resistance. | 1500 to 3000 ohms (released), 250 to 1500 ohms (depressed), Released value must be at least 1000 ohms greater than depressed value
 | STEP 2B-1. Check the resistance of the accelerator position sensor. |
 | STEP 2B-2. Check the resistance in the OEM harness. |
 | STEP 2C. Check for a short circuit from pin-to-pin in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 432 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Perform the fault code disable procedure.

Conditions

  • All components connected.
  • Turn keyswitch ON.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal to the full-fuel position and release it completely three times.
  • Use INSITE™ electronic service tool to read the inactive fault codes.
OK NOT OK

Fault Code 432 still active?

Replace the accelerator pedal assembly.

Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check for idle validation fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 131 and 551 inactive?

Go to 2A

Fault Code 131 or 551

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance.

  • Measure the resistance from pin 47 to pin 48 of the OEM harness connector with the accelerator pedal in the released (idle) position.
  • Repeat the measurement with the accelerator pedal in the depressed (full-fuel) position. Note: Resistance with the pedal released must be at least 1000 ohms greater than when it is depressed.
OK NOT OK

1500 to 3000 ohms (released)

250 to 1500 ohms (depressed)

Released value must be at least 1000 ohms greater than depressed value.

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the resistance of the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance of the accelerator position sensor.

  • Measure the resistance from pin C (or 3) to pin B (or 2) on the sensor side of the accelerator position sensor connector with the accelerator pedal in the released (idle) position.
  • Repeat the above measurement with the accelerator pedal in the depressed (full-fuel) position. Note: Resistance when the pedal is released must be at least 1000 ohms greater than when it is depressed.
OK NOT OK

1500 to 3000 ohms (released)

250 to 1500 ohms (depressed)

Released value must be at least 1000 ohms greater than depressed value.

Replace the accelerator pedal assembly

Reference the OEM troubleshooting and repair manual.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check the resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance in the OEM harness.

  • Measure the resistance from pin 47 of the OEM harness connector to pin C (or 3) on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 48 of the OEM harness connector to pin B (or 2) on the harness side of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit from pin-to-pin in the OEM harness.

  • Measure the resistance from pin 47 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 49 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Depress the accelerator pedal to the full-fuel position and release it completely, three times.
  • Start the engine and idle for one minute.
  • Drive the vehicle.
  • Use INSITE™ electronic service tool to verify Fault Code 432 is inactive.
OK NOT OK

Fault Code 432 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Aug-2012


FAULT CODE 433 - Intake Manifold Pressure Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure sensor. |
 | STEP 1A. Inspect the sensor circuit for tampering. | No tampering?
 | STEP 1B. Inspect the harness and the sensor connector pins. | Dirty or damaged pins?
 | STEP 1C. Read the fault codes. | Fault Code 433 inactive?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 433 inactive?
 | STEP 2C. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check the ambient air pressure. | 635 to 774.7 mm-Hg [25.0 to 30.5 in-Hg]?
 | STEP 2G. Check the intake manifold pressure. | Less than 127 mm-Hg [5 in-Hg]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 433 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold pressure sensor.

Guided Step 1A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure sensor and the sensor harness for external wires or damaged harness braiding.
OK NOT OK

No tampering?

Remove and record tampering.

If tampering has occurred, repair the circuit and record the tampering.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor.
  • Refer to Procedure 019-059 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 433 is inactive.
OK NOT OK

Fault Code 433 inactive?

Fault Code 433 active.

Go to 3B

Go to 2A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 433 is inactive.
OK NOT OK

Fault Code 433 inactive?

Fault Code 433 active.

Go to 3B

Go to 2C

Guided Step 2C - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 40 of the sensor harness connector to pin 2 (or B) of the intake manifold pressure sensor connector on the harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 39 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 39 in the sensor harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the ambient air pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ambient air pressure.

  • Use INSITE™ electronic service tool to monitor the ambient air pressure.
OK NOT OK

635 to 774.7 mm-Hg [25.0 to 30.5 in-Hg]?

Replace the ambient air pressure sensor.

  • Refer to Procedure 019-004 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check the intake manifold pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the intake manifold pressure.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to monitor the intake manifold pressure.
OK NOT OK

Less than 5 in-Hg

Refer to Procedure 019-061 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Replace the intake manifold pressure sensor

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 433 is inactive.
OK NOT OK

Fault Code 433 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Aug-2012


FAULT CODE 434 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To avoid personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To avoid pin and harness damage, use Deutsch™/AMP™/Metri-Pack™ test lead. To avoid pin and harness damage, use the following test lead when taking a measurement, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | No active or inactive injector fault codes?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the resistance of the battery supply circuit. | Less than 10 ohms?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC, During cranking: At least (+) 6.2-VDC?
 | STEP 2C. Check the battery connections. | Connections are tight and corrosion-free?
STEP 3. | Check the fuses. |
 | STEP 3A. Check if the two 15-ampere fuses are installed correctly. | Fuses installed correctly?
 | STEP 3B. Check if the two 15-ampere fuses are blown. | Fuses not blown?
 | STEP 3C. Check if the 5-ampere fuse is installed correctly. | Fuse installed correctly?
 | STEP 3D. Check if the 5-ampere fuse is blown. | Fuse not blown?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the battery power circuits. | (+) 10 to 15-VDC?
 | STEP 4C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 4D. Check the add-on or accessory wiring at the (+) terminal of the battery. | Dirty or damaged wires?
 | STEP 4E. Check all engine brake spade connectors. | No loose connections or evidence of arcing?
 | STEP 4F. Check all injector connectors. | No loose connections or evidence of arcing?
 | STEP 4G. Check the keyswitch input-to-ECM wire. | Keyswitch input wire is uninterrupted?
 | STEP 4H. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 434 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No active or inactive injector fault codes?

Troubleshoot the injector fault codes. Reference the appropriate injector fault code troubleshooting symptom tree.

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect both positive and negative terminals from the battery.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance from pins 7, 8, 17, 18, and 28 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pins 29, 30, 39, 40, and 50 of the OEM harness connector to the negative (-) battery terminal connector. For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place positive (+) probe of the multimeter on the positive battery terminal and touch negative (-) probe to the negative battery terminal while trying to start engine.
OK NOT OK

Normal conditions: At least (+) 12-VDCDuring cranking: At least (+) 6.2-VDC?

Charge or replace the battery. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.
OK NOT OK

Connections are tight and corrosion-free?

Tighten the connections. Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the fuses.

Guided Step 3A - Check if the two 15-ampere fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Check if the two 15-amp fuses are installed correctly.

  • Inspect the two 15-ampere fuses for correct installation.
OK NOT OK

Fuses installed correctly?

Install the fuses correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check if the two 15-ampere fuses are blown.

Conditions

  • Turn keyswitch OFF.

Action

Check if the two 15-amp fuses are blown.

  • Inspect the two 15-ampere fuses to see if they are blown.
OK NOT OK

Fuses not blown?

Fuses blown. Locate the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the blown fuse(s).

Go to 3C

Go to 5A

Guided Step 3C - Check if the 5-ampere fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Check if the 5-ampere fuse is installed correctly in the vehicle keyswitch wire.

  • Inspect the 5-ampere fuse for correct installation.
OK NOT OK

Fuse installed correctly?

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check if the 5-ampere fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Check if the 5-ampere fuse is blown.

  • Inspect the 5-ampere fuse to see if it is blown.
OK NOT OK

Fuse not blown?

Fuse blown. Locate the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the blown fuse.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins with electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage from pin 7 to pin 29 of the OEM harness connector.
  • Measure the voltage from pin 8 to pin 30 of the OEM harness connector.
  • Measure the voltage from pin 17 to pin 39 of the OEM harness connector.
  • Measure the voltage from pin 18 to pin 40 of the OEM harness connector.
  • Measure the voltage from pin 28 to pin 50 of the OEM harness connector.
OK NOT OK

(+) 10 to 15-VDC?

Repair or replace the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect both positive (+) and negative (-) terminals from the battery.

Action

Check for a short circuit.

  • Measure the resistance from pin 7 of the OEM harness connector to all other pins in the connector except pins 5, 6, 8, 16, 17, 18, 28, and 38.
  • Measure the resistance from pin 8 of the OEM harness connector to all other pins in the connector except pins 5, 6, 7, 16, 17, 18, 28, and 38.
  • Measure the resistance from pin 17 of the OEM harness connector to all other pins in the connector except pins 5, 6, 7, 8, 16, 18, 28, and 38.
  • Measure the resistance from pin 18 of the OEM harness connector to all other pins in the connector except pins 5, 6, 7, 8, 16, 17, 28, and 38.
  • Measure the resistance from pin 28 of the OEM harness connector to all other pins in the connector except pins 5, 6, 7, 8, 16, 17, 18, and 38.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check the add-on or accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair or replace the damaged wiring.

Go to 4E

Go to 5A

Guided Step 4E - Check all engine brake spade connectors.

Conditions

  • Turn keyswitch OFF.

Action

Check all engine brake spade connectors for the following:

  • Loose connections
  • Arcing.
OK NOT OK

No loose connections or evidence of arcing?

Clean and tighten the spade connectors

Go to 4F

Go to 5A

Guided Step 4F - Check all injector connectors.

Conditions

  • Turn keyswitch OFF.

Action

Check all injector connectors for the following:

  • Loose connections
  • Arcing.
OK NOT OK

No loose connections or evidence of arcing?

Clean and tighten the connectors

Go to 4G

Go to 5A

Guided Step 4G - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

OK NOT OK

Keyswitch input wire is uninterrupted?

Correct the wiring so wire is uninterrupted.

Go to 4H

Go to 5A

Guided Step 4H - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to pin 38 of the OEM harness connector.
OK NOT OK

Less than 5 ohms?

Repair or replace the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn the keyswitch to the OFF position for 30 seconds.
  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 434 is inactive.

Note: For Fault Code 434 to become inactive, the ECM must go through one complete shutdown.

OK NOT OK

Fault Code 434 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Sep-2012


FAULT CODE 435 - Oil Pressure Sensor

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 115. |
 | STEP 1A. Check to see if Fault Code 115 is active at engine start-up. | Fault Code 115 inactive?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for a valid fault code. | Fault Code 435 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 435 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for Fault Code 115.

Guided Step 1A - Check to see if Fault Code 115 is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if Fault Code 115 is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 115 inactive?

Troubleshoot Fault Code 115 first.

Go to 2A

Fault Code 115

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for a valid fault code.

Conditions

  • Make sure that the oil temperature is greater than 4°C [40°F].
  • Turn keyswitch OFF.

Action

Check for a valid fault code.

  • Wait 30 seconds.
  • Turn keyswitch ON, and wait 15 seconds.
OK NOT OK

Fault Code 435 inactive?

Replace the sensor.

Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Verify that Fault Code 435 is inactive.
OK NOT OK

Fault Code 435 inactive?

Return to the troubleshooting steps, or contact the local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Sep-2012


FAULT CODE 441 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Dirty or damaged connections?
 | STEP 1B. Check the battery voltage. | Normal conditions: At least +12 VDC, During cranking: At least +6.2 VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the fuse connections. | Fuses installed correctly?
 | STEP 2B. Check the fuses. | Fuses not blown?
 | STEP 2C. Inspect the OEM harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit in the battery power circuits. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2F. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Dirty or damaged wires?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

No damaged connections?

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.
OK NOT OK

Normal conditions: At least +12 VDC, During cranking: At least +6.2 VDC?

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 15-amp fuses from the OEM harness.

Action

Check if the two 15-amp fuses are installed correctly.
OK NOT OK

Fuses installed correctly?

Install fuses correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 15-amp fuses from the OEM harness.

Action

Check if the two 15-amp fuses are blown.
OK NOT OK

Fuses not blown?

Replace the fuses.

Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Replace the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit in the battery power circuits.

  • Measure the resistance from pin 7 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 8 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 17 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 18 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 28 of the OEM harness connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit.

  • Measure the resistance from pin 7 to all other pins in the OEM harness connector except for pins 8, 17, 18, and 28.
  • Measure the resistance from pin 8 to all other pins in the OEM harness connector except for pins 7, 17, 18, and 28.
  • Measure the resistance from pin 17 to all other pins in the OEM harness connector except for pins 7, 8, 18, and 28.
  • Measure the resistance from pin 18 to all other pins in the OEM harness connector except for pins 7, 8, 17, and 28.
  • Measure the resistance from pin 28 to all other pins in the OEM harness connector except for pins 7, 8, 17, and 18.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause the supply wire to have a short circuit to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair the damaged wiring.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 441 is inactive.
OK NOT OK

Fault Code 441 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Sep-2012


FAULT CODE 442 - Unswitched Battery Supply Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check the battery voltage. | Normal conditions: At least +12 VDC, During cranking: At least +6.2 VDC?
 | STEP 1B. Check the alternator. | Alternator functioning normally?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while cranking the engine.
OK NOT OK

Normal conditions: At least +12 VDC , During cranking: At least +6.2 VDC?

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 2A

Guided Step 1B - Check the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator for normal operation.

Reference the OEM troubleshooting and repair manual for procedure.
OK NOT OK

Alternator functioning normally?

Repair the alternator.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 442 is inactive.
OK NOT OK

Fault Code 442 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Sep-2012


FAULT CODE 443 - Throttle Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Check the accelerator position sensor. | Fault Code 443 active?
 | STEP 1B. Check the remote throttle sensor. | Fault Code 443 active?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100K ohms?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100K ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 443 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Check the accelerator position sensor.

Conditions

  • Disconnect the sensor harness from the accelerator position sensor.

Action

Check the accelerator position sensor.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 443 is still active.
OK NOT OK

Fault Code 443 active?

Replace the accelerator position sensor.

Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the remote throttle sensor.

Conditions

  • Connect the accelerator position sensor to sensor harness.
  • Disconnect the sensor harness from the remote throttle sensor.

Note: Not all vehicles have a remote throttle position sensor. If not, go to Step 2A.

Action

Check the remote throttle sensor.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 443 is still active.
OK NOT OK

Fault Code 443 active?

Replace the remote throttle sensor.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 48 of the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

More than 10 ohms.

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 443 is inactive.
OK NOT OK

Fault Code 443 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Oct-2012


FAULT CODE 465 - Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wiring harness. |
 | STEP 1A. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to the battery. | Less than (+) 1.5-VDC?
STEP 2. | Check the wastegate actuator. |
 | STEP 2A. Inspect the wastegate actuator connector. | Dirty or damaged pins?
 | STEP 2B. Check the actuator solenoid post for corrosion. | Corrosion found?
 | STEP 2C. Check the wastegate actuator resistance. | Resistance from 7 to 8 ohms for 12-VDC solenoids and 28 to 32 ohms for 24-VDC solenoids?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 465 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the wiring harness.

Guided Step 1A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 1.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the actuator harness connector from the ECM
  • Disconnect the engine harness from the wastegate actuator 1.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from pin 24 in the actuator harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to the battery.

Conditions

  • Turn keyswitch OFF
  • Disconnect the actuator harness connector from the ECM
  • Disconnect the engine harness from the wastegate actuator 1.

Action

Check for a short circuit to the battery.

  • Measure the voltage from pin 1 of the wastegate actuator connector to engine block ground.
  • Measure the voltage from pin 24 of the actuator harness connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Less than (+) 1.5-VDC?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the wastegate actuator.

Guided Step 2A - Inspect the wastegate actuator connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the wastegate actuator 1.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the wastegate actuator connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the actuator connector terminal.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if is is damaged or missing.
  • Repair the actuator connector. Refer to Procedure 019-197 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the actuator solenoid post for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Check the solenoid post for corrosion.

Corrosion found on solenoid post?

Clean the solenoid post.
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Resistance from 7 to 8 ohms for 12-VDC solenoids and 28 to 32 for 24-VDC solenoids?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace the actuator solenoid.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 465 is inactive.

Fault Code 465 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Troubleshoot any remaining active fault codes

Last Modified: 01-Nov-2012


FAULT CODE 466 - Wastegate Actuator Number 1 Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness and the ECM connector pins. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Check for an open circuit. | Less than 10 ohms?
STEP 2. | Check the wastegate actuator. |
 | STEP 2A. Inspect the wastegate actuator connector for damaged pins. | Dirty or damaged pins?
 | STEP 2B. Check for corrosion on the solenoid post. | No corrosion ?
 | STEP 2C. Check the wastegate actuator resistance. | 7 to 8 ohms, for + 12-VDC solenoids, 28 to 32 ohms , for + 24-VDC solenoids?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 466 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness and the ECM connector pins.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 24 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Check for a short circuit in the actuator wire to ground.

  • Measure the resistance from pin 24 of the actuator harness connector to ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

Check for an open circuit.

  • Measure the resistance from pin 24 of the actuator harness connector to the wastegate actuator number 1 wire.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the wastegate actuator.

Guided Step 2A - Inspect the wastegate actuator connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 1.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the wastegate actuator connector.

  • Check the wastegate actuator connector for damaged pins.
OK NOT OK

Dirty or damaged pins?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for corrosion on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for corrosion on the solenoid post.

  • Inspect the solenoid post for corrosion.
OK NOT OK

No corrosion?

Clean the solenoid post.

Go to 2C

Go to 3A

Guided Step 2C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator number 1 to engine block ground.
OK NOT OK

7 to 8 ohms for + 12-VDC solenoids, 28 to 32 ohms for + 24-VDC solenoids

Replace the actuator solenoid

Refer to Procedure 010-109 in Section 10 in the Troubleshooting and Repair Manual, ISM and QSM11 Series Engines, Bulletin 3666322.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 466 inactive.
OK NOT OK

Fault Code 466 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 469 - ICON™ Cab Thermostat Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Interview the driver to ascertain the cab temperature system's operation when the fault code occurred and to determine the cab thermostat mode, cab thermostat temperature and range settings, and outside ambient air temperature. |
 | STEP 1A. Check the cab thermostat settings and the cab temperature control settings. | Cab thermostat set correctly; cab temperature controls operated appropriately?
STEP 2. | Read all fault codes. |
 | STEP 2A. Read fault codes with INSITE™ electronic service tool. | Fault codes inactive?
 | STEP 2B. Check the cab thermostat display for a fault code. | Fault codes active?
STEP 3. | Check the ambient air temperature sensor (when cab thermostat fault E2 is displayed). |
 | STEP 3A. Check the ambient air temperature sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the ambient air temperature sensor. | Specifications for resistance at respective ambient air temperature: 0°C [32°F] = 29 to 36k ohms, 25°C [77°F] = 9 to 11k ohms. 50°C [122°F] = 3 to 4k ohms, 75°C [167°F] = 1300 to 1600 ohms, 100°C [212°F] = 600 to 750 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check the cab thermostat (when cab thermostat fault E1 is displayed). |
 | STEP 4A. Check for an open circuit. | Less than 10 ohms?
 | STEP 4B. Check for a short circuit to ground in the cab thermostat output signal. | Greater than 100k ohms?
 | STEP 4C. Check for cab thermostat communication with the ECM. | Communication of cab thermostat to ECM confirmed
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 469 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Interview the driver to ascertain the cab temperature system's operation when the fault code occurred and to determine the cab thermostat mode, cab thermostat temperature and range settings, and outside ambient air temperature.

Guided Step 1A - Check the cab thermostat settings and the cab temperature control settings.

Conditions

  • Turn keyswitch ON.
  • Turn cab thermostat ON.

Action

Check the cab thermostat settings and the cab temperature control settings.

  • Check to see that the cab thermostat mode is set appropriately (heat or cool) for the present ambient air temperature conditions and that both the heat and cool mode set points (the range) are programmed into the thermostat properly. (Refer to Procedure 209-017 in Section F in the Master Repair Manual, ICON™ Idle Control System, 3666415.)
  • Check the cab temperature controls (heat and air conditioning) to make certain that the controls are set appropriately on the cab thermostat mode.
OK NOT OK

Cab thermostat set correctly; cab temperature controls operated appropriately

Set the cab thermostat to the appropriate mode and temperature settings; set the cab temperature controls appropriately to coordinate with the cab thermostat settings

Refer to Procedure 209-017 in Section F. Refer to Procedure 019-300 in Section 19 in the Master Repair Manual, ICON™ Idle Control System, Bulletin 3666415.

Go to 5A

Go to 2A

Guided Step 2 - Read all fault codes.

Guided Step 2A - Read fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Turn cab thermostat ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault codes inactive

Fault codes active

Go to 5A

Go to 2B

Guided Step 2B - Check the cab thermostat display for a fault code.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes on the cab thermostat display.

Note: If this fault occurs after 60 minutes have elapsed, the cool or heat mode set points are set properly, and the vehicle's windows/doors are closed, it indicates that the heater or air conditioning is performing poorly and requires repair, or the insulation in the cab will not allow the cab to maintain temperature. Poor insulation can cause the cab to lose temperature too quickly, which causes an engine restart four times in 1 hour. It can be necessary to decrease the Extreme Hot Temperature Trim (trim 1) or the Extreme Cold Temperature Trim (trim 2). Adjusting the trims allows the ICON™ system to transition into a continuous run mode when the cab is not capable of maintaining temperature.

OK NOT OK

No active fault codes

Check the thermostat set points and adjust if necessary

Refer to Procedure 019-300 in Section 19 or Refer to Procedure 209-017 in Section F in the Master Repair Manual, ICON™ Idle Control System, Bulletin 3666415.

Go to 3A

Go to 5A

Guided Step 3 - Check the ambient air temperature sensor (when cab thermostat fault E2 is displayed).

Guided Step 3A - Check the ambient air temperature sensor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the temperature sensor harness.

Action

Check ambient air temperature sensor and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, and moisture from the connector pins. Repair the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the connector pins. Refer to Procedure 019-202 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the resistance of the ambient air temperature sensor.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the temperature sensor harness.

Action

Check the resistance of the ambient air temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the ambient air temperature sensor.
OK NOT OK

Specifications for resistance at respective ambient air temperature:

  • 0°C [32°F] = 29 to 36k ohms
  • 25°C [77°F] = 9 to 11k ohms
  • 50°C [122°F] = 3 to 4k ohms
  • 75°C [167°F] = 1300 to 1600 ohms
  • 100°C [212°F] = 600 to 750 ohms

Replace the ambient air temperature sensor

Refer to Procedure 019-134 in Section 19 in the Master Repair Manual, ICON™ Idle Control System, Bulletin 3666415.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the temperature sensor harness.
  • Disconnect the temperature sensor harness from the cab thermostat.

Action

Check for an open circuit in the temperature sensor harness.

  • Measure the resistance from pin 1 of the temperature sensor harness connector, sensor end, to pin 1 of the harness, cab thermostat end.
  • Measure the resistance from pin 2 of the temperature sensor harness connector, sensor end, to pin 3 of the harness, cab thermostat end.
OK NOT OK

Less than 10 ohms

Repair or replace the temperature sensor harness

  • Repair the temperature sensor harness. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-203 in Section 19.
  • Replace the temperature sensor harness. Refer to Procedure 019-296 in Section 19 in the Master Repair Manual, ICON™ Idle Control System, Bulletin 3666415.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the temperature sensor harness.
  • Disconnect the temperature sensor harness from the cab thermostat.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the temperature sensor harness connector, sensor end, to engine block ground.
  • Measure the resistance from pin 2 of the temperature sensor harness connector, sensor end, to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the temperature sensor harness

  • Repair the temperature sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the temperature sensor harness. Refer to Procedure 019-296 in Section 19 in the Master Repair Manual, ICON™ Idle Control System, Bulletin 3666415.

Go to 4A

Go to 5A

Guided Step 4 - Check the cab thermostat (when cab thermostat fault E1 is displayed).

Guided Step 4A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cab thermostat from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 of the OEM harness, cab thermostat end, to pin 32 of the OEM harness, ECM end.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for a short circuit to ground in the cab thermostat output signal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cab thermostat from the OEM harness.

Action

Check for a short circuit to ground in the cab thermostat output signal.

  • Measure the resistance from pin 3 of the cab thermostat harness to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the cab thermostat

  • Repair the cab thermostat harness connector. Refer to Procedure 019-202 in Section 19.
  • Replace the cab thermostat. Refer to Procedure 019-300 in Section 19 in the Master Repair Manual, ICON™ Idle Control System, Bulletin 3666415.

Go to 4C

Go to 5A

Guided Step 4C - Check for cab thermostat communication with the ECM.

Conditions

  • Turn keyswitch ON.

Action

Verify that the cab thermostat has communication with the ECM.

Note: When the bunk thermostat is requesting an engine restart or the engine is running due to a cab comfort mode-generated restart, the word “heat” or “cool” will flash on the thermostat display, depending on thermostat mode. This flashing indicates that the thermostat has detected a cab temperature that requires an engine restart and is sending a command to restart the engine to the ECM.

OK NOT OK

Communication of cab thermostat to ECM confirmed

Replace the cab thermostat

Refer to Procedure 019-300 in Section 19 in the Master Repair Manual, ICON™ Idle Control System, Bulletin 3666415.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 469 is inactive.
OK NOT OK

Fault Code 469 inactive

Return to the troubleshooting steps, or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 472 - Crankcase Oil Level Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 141, 187, and 227 are not active?
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the oil level sensor and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the oil level sensor supply voltage. | +4.75 to 5.25-VDC?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 2D. Check the oil level sensor signal voltage. | +0.4 to 4.5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 472 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 135, 141, 187, and 227 are not active?

Fault Codes 135, 141, 187, and 227 active.

Go to 2A

Fault Code 135, 141, 187, 227

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the oil level sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil level sensor.

Action

Inspect the oil level sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the oil level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil level sensor. Refer to Procedure 019-056 in Section 19 in the Master Repair Manual, Centinel™, Bulletin 3666231.

Go to 2B

Go to 4A

Guided Step 2B - Check the oil level sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from the ECM.
  • Disconnect sensor harness from the oil level sensor.
  • Install the breakout cable, Part Number 3824775, between the sensor and the harness connector.

Action

Check the oil level sensor supply voltage.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

+4.75 to 5.25-VDC?

Go to 2C

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Disconnect sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 26 of the ECM sensor harness connector to pin 2 (or B) of the oil level sensor connector.
OK NOT OK

Less than 10 ohms?

Does not meet specifications.

Go to 2C-1

Go to 2C-1

Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Turn keyswitch ON.
  • Disconnect the sensor harness connector from the ECM.

Action

Measure the voltage out of the ECM.

  • Measure the voltage out of the ECM from pin 45 to pin 26 of the ECM sensor port.
OK NOT OK

+4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the oil level sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3824775, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the oil level sensor signal voltage.

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

+0.4 to 4.5-VDC?

Replace the oil level sensor.

Refer Refer to Procedure 019-056 in Section 19 in the Master Repair Manual, Centinel™ System , Bulletin 3666231.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 7 of the sensor harness connector to pin 3 (or C) of the oil level sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 7 of the sensor harness connector to chassis ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 7 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 7 of the sensor harness connector to all pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 472 is inactive.
OK NOT OK

Fault Code 472 inactive?

Return to the troubleshooting steps or contact a local Cummins ®Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Oct-2012


FAULT CODE 474 - Starter Solenoid Lockout Relay Driver Circuit

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the starter solenoid lockout relay. |
 | STEP 1A. Inspect the starter lockout relay and solenoid harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the starter lockout relay. | Reference OEM specifications for resistance value?
 | STEP 1C. Check for a short circuit to ground on starter lockout relay. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and 31-pin connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 474 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the starter solenoid lockout relay.

Guided Step 1A - Inspect the starter lockout relay and solenoid harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the solenoid harness.

Action

Inspect the starter lockout relay and solenoid harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins.

Replace the starter lockout relay

Refer to the OEM troubleshooting and repair manual.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the solenoid harness connector.

Action

Measure the resistance of the starter lockout relay.

  • Measure the resistance between starter lockout relay connector pins.
OK NOT OK

Reference the OEM specifications for resistance value.

Replace the starter lockout relay.

Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to ground on starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the solenoid harness.

Action

Check for a short circuit to ground in the starter lockout relay.

  • Measure the resistance from the starter lockout relay connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the starter lockout relay.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 46 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 46 in the actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and 31-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.

Action

Inspect the OEM harness and 31-pin connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 20 on the OEM harness side of the 31-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Does not meet specifications.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 20 on the OEM harness side of the 31-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 474 is inactive.
OK NOT OK

Fault Code 474 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Oct-2012


FAULT CODE 475 - Electronic Air Compressor Governor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Check the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the electronic air compressor governor. |
 | STEP 2A. Check the engine harness and electronic air compressor governor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 475 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Check the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the air compressor governor solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 14 of the ECM actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the air compressor governor solenoid.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 14 of the actuator harness connector to all other wires in the connector.
  • Measure the resistance from pin 14 of the actuator harness connector to all other wires in the sensor harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

Guided Step 2 - Check the electronic air compressor governor.

Guided Step 2A - Check the engine harness and electronic air compressor governor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic air compressor governor.

Action

Check the engine harness and the electronic air compressor governor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness at the 6-pin air compressor governor solenoid harness.
  • Disconnect the engine harness from the air compressor governor solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 5 of the electronic air compressor governor harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness at the 6-pin air compressor governor solenoid harness connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the electronic air compressor governor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 475 is inactive.
OK NOT OK

Fault Code 475 inactive

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Oct-2012


FAULT CODE 476 - Electronic Air Compressor Governor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wiring harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 1D. Check for short circuit to battery. | Less than + 1.5-VDC?
 | STEP 1E. Check for an open circuit. | Less than 10 ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 476 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the wiring harness.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect actuator and sensor harness connectors from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the air compressor governor solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 14 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the air compressor governor solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 14 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to battery.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the air compressor governor solenoid.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery.

  • Measure voltage from pin 14 of the actuator harness connector to engine block ground.
OK NOT OK

Less than + 1.5-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness at the 6-pin connector air compressor governor solenoid connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 14 of the actuator harness connector to pin 5 of the 6-pin connector.
  • Measure the resistance from pin 11 of the actuator harness connector to pin 6 of the 6-pin connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 476 is inactive.
OK NOT OK

Fault Code 476 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Oct-2012


FAULT CODE 489 (INDUSTRIAL) - Auxiliary Speed Input Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and actuator harness connectors. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 489 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and actuator harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.

Action

Inspect the OEM harness and actuator harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the OEM harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 of the 31-pin OEM harness connector to pin A (or 1) of the OEM harness connector at the frequency input signal sending unit.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 21 of the 31-pin OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 21 of the 31-pin OEM harness connector to all other pins in the connector, except pin 22.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins

Repair or replace the actuator harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if it is damaged or missing.
  • Repair the actuator harness. Refer to Procedure 019-204 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 40 of the actuator harness connector to pin 21 of the 31-pin actuator harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 40 of the 50-pin actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 40 of the 50-pin actuator harness connector to all other pins in the connector, except pin 30.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 489 is inactive.
OK NOT OK

Fault Code 489 inactive?

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear any inactive fault codes.

Conditions

  • Connect all components.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Sep-2012


FAULT CODE 491 - Turbocharger 2 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wiring harness. |
 | STEP 1A. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to the battery. | Less than (+) 1.5-VDC?
STEP 2. | Check the wastegate actuator. |
 | STEP 2A. Inspect the wastegate actuator connector. | Dirty or damaged pins?
 | STEP 2B. Check the actuator solenoid post for corrosion. | Corrosion found?
 | STEP 2C. Check the wastegate actuator resistance. | Resistance from 7 to 8 ohms for (+) 12-VDC solenoids and 28 to 32 ohms for (+) 24-VDC solenoids?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 491 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the wiring harness.

Guided Step 1A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 2.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from pin 23 in the actuator harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to the battery.

Conditions

  • Turn keyswitch ON.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator 2.

Action

Check for a short circuit to the battery.

  • Measure the voltage from pin 2 (or B) on the wastegate actuator connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Less than (+) 1.5-VDC?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the wastegate actuator.

Guided Step 2A - Inspect the wastegate actuator connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator 2.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the wastegate actuator connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the actuator connector terminal.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if is is damaged or missing.
  • Repair the actuator connector. Refer to Procedure 019-197 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the actuator solenoid post for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Check the solenoid post for corrosion.

Corrosion found on solenoid post?
YES NO

Repair

Clean the solenoid post.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator number 2 to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Resistance from 7 to 8 ohms for (+) 12-VDC solenoids and 28 to 32 for (+) 24-VDC solenoids?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace the actuator solenoid.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 491 is inactive.

Fault Code 491 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Troubleshoot any remaining active fault codes.

Last Modified: 27-Sep-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness and ECM connector pins. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for an open circuit. | Less than 10 ohms
STEP 2. | Check the wastegate actuator. |
 | STEP 2A. Inspect the wastegate actuator for damage. | No damage
 | STEP 2B. Check for corrosion on the actuator solenoid post. | No corrosion
 | STEP 2C. Check the wastegate actuator resistance. | 7 to 8 ohms , for + 12-VDC solenoids, 28 to 32 ohms, for + 24-VDC solenoids
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 492 is inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness and ECM connector pins.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Inspect the engine harness and ECM pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 23 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 23 of the actuator harness connector to ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for an open circuit.

  • Measure the resistance from pin 23 of the actuator harness connector to the wastegate actuator number 2 wire.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the wastegate actuator.

Guided Step 2A - Inspect the wastegate actuator connector for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 2.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the wastegate actuator connector.

  • Check the wastegate actuator connector for damage.
OK NOT OK

No damage

Repair the damage

Repair the actuator connector terminal.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the connector. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for corrosion on the actuator solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the solenoid post.

  • Check the solenoid post for corrosion.
OK NOT OK

No corrosion

Clean the solenoid post.

Go to 2C

Go to 3A

Guided Step 2C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator number 2 to engine block ground.
OK NOT OK

7 to 8 ohms for + 12-VDC solenoids, 28 to 32 ohms for + 24-VDC solenoids

Replace the actuator solenoid

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 492 is inactive.
OK NOT OK

Fault Code 492 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 528 (INDUSTRIAL) - Switched Output B Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires?
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean?
 | STEP 1C. Check the solenoid resistance. | 7 to 8 ohms, for + 12-VDC systems, 28 to 32 ohms, for + 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the ECM and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage at the ECM. | Greater than + 5 VDC, for 12-VDC systems, More than + 17 VDC, for 24-VDC systems?
 | STEP 3C. Check for a short circuit to ground in the solenoid SUPPLY wire. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 527 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

Remove any extra wires on the solenoid post.
OK NOT OK

No extra wires?

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean?

Repair ring terminal or replace the solenoid.

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

7 to 8 ohms for + 12-VDC systems, 28 to 32 ohms for + 24-VDC systems?

Replace the solenoid.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.

Action

Inspect the OEM harness and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or actuator harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the actuator harness. Refer to Procedure 019-204 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from the solenoid supply wire to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between pin 27 in the OEM harness 31-pin connector and all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Inspect the ECM and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the ECM and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Connect the male end of jumper wire, Part Number 3822758, to pin 14 of the ECM actuator connector.
  • Attach the clip end of the jumper wire, Part Number 3822758, to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.
  • Dual output A supply voltage is turned ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from pin 14 in the ECM actuator port to engine block ground.
OK NOT OK

Greater than + 5 VDC, for 12-VDC systems, More than + 17 VDC, for 24-VDC systems?

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the solenoid SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness at the 6-pin connector.

Action

Check for a short circuit in the solenoid SUPPLY wire to ground.

  • Measure the resistance from pin 14 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 6-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 14 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 527 is inactive.
OK NOT OK

Fault Code 527 inactive?

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Sep-2012


FAULT CODE 528 (INDUSTRIAL) - Switched Output B Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires?
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean?
 | STEP 1C. Check the solenoid resistance. | 7 to 8 ohms, for + 12-VDC systems, 28 to 32 ohms, for + 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Check the actuator harness. |
 | STEP 3A. Check the ECM and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage at the ECM. | More than + 5 VDC, for 12-VDC systems, More than + 7 VDC, for 24-VDC systems?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 528 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

Remove any extra wires on the solenoid post.
OK NOT OK

No extra wires?

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean?

Repair ring terminal or replace the solenoid.

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

7 to 8 ohms for + 12-VDC systems, 28 to 32 ohms for + 24-VDC systems?

Replace the solenoid.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.

Action

Check the OEM harness and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or actuator harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the actuator harness. Refer to Procedure 019-204 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from the solenoid SUPPLY wire to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM harness connector from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 8 in the 31-pin OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Check the ECM and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the ECM and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Connect the male end of jumper wire, Part Number 3822758, to pin 45 of the ECM actuator connector.
  • Attach the clip end of the jumper wire, Part Number 3822758, to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.
  • Dual output B supply voltage is turned ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from pin 45 in the ECM actuator port to engine block ground.
OK NOT OK

More than + 5 VDC, for + 12-VDC systems, More than + 7 VDC, for + 24-VDC systems?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness at the 31-pin OEM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 45 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 31-pin OEM connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 528 is inactive.
OK NOT OK

Fault Code 528 inactive

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 529 (INDUSTRIAL) - Switched Output B Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires?
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean?
 | STEP 1C. Check the solenoid resistance. | 7 to 8 ohms for + 12-VDC systems, 28 to 32 ohms for + 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Check the actuator harness. |
 | STEP 3A. Check the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage at the ECM. | More than + 5 VDC, for 12-VDC systems, More than + 7 VDC, for 24-VDC systems?
 | STEP 3C. Check for a short circuit to ground in the solenoid SUPPLY wire. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.
OK NOT OK

No extra wires?

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean?

Repair ring terminal or replace the solenoid.

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Reference the OEM troubleshooting and repair manual for procedure.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

7 to 8 ohms for + 12-VDC systems, 28 to 32 ohms for + 24-VDC systems?

Replace the solenoid

Reference the OEM troubleshooting and repair manual for procedure.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.

Action

Check the OEM harness and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or actuator harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the actuator harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-204 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from the solenoid SUPPLY wire to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between pin 8 in the OEM harness 31-pin connector and all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Check the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the actuator harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Connect the male end of jumper wire, Part Number 3822758, to pin 45 of the ECM connector.
  • Connect the clip end of the jumper wire, Part Number 3822758, to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from pin 45 in the ECM actuator port to engine block ground.
OK NOT OK

More than + 5 VDC, for + 12-VDC systems, More than + 7 VDC, for + 24-VDC systems?

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the solenoid SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.

Action

Check for a short circuit to ground in the solenoid SUPPLY wire.

  • Measure the resistance from pin 45 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-204 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 of the actuator harness connector to all other wires in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 529 is inactive.
OK NOT OK

Fault Code 529 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 536 - Autoshift Low Gear Actuator (Lockout Solenoid)

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the autoshift low gear actuator (lockout solenoid). |
 | STEP 1A. Inspect the lockout solenoid and solenoid harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the lockout solenoid. | 14 to 34 ohms?
 | STEP 1C. Check for a short circuit to ground on the lockout solenoid. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin on the lockout solenoid. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit pin to pin. | Greater than 100k ohms?
 | STEP 2B-1. Inspect the 31-pin Deutsch™ connector pins. |
 | STEP 2B-2. Check for a short circuit in the OEM harness. |
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C-1. Check for a short circuit to ground in the OEM harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 536 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the autoshift low gear actuator (lockout solenoid).

Guided Step 1A - Inspect the lockout solenoid and solenoid harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lockout solenoid from the solenoid harness connector pins.

Action

Inspect the lockout solenoid and solenoid harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or lockout solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the lockout solenoid. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the lockout solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lockout solenoid from the solenoid harness connector pins.

Action

Measure the resistance of the lockout solenoid.

  • Measure the resistance between solenoid connector pins B (or 2) and A (or 1).
OK NOT OK

14 to 34 ohms?

Replace the lockout solenoid.

Reference the the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for short circuit to ground on the lockout solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lockout solenoid from the solenoid harness.

Action

Check for a short circuit to ground in the lockout solenoid.

  • Measure the resistance from pin A (or 1) of the lockout solenoid to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the lockout solenoid

Reference OEM troubleshooting and repair manual for repair procedure.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin on the lockout solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lockout solenoid harness from the actuator harness.

Action

Check for a short circuit from pin to pin in the lockout solenoid.

  • Measure the resistance from pin A (or 1) to pin C (or 3) of the lockout solenoid.
OK NOT OK

Greater than 100k ohms?

Replace the lockout solenoid.

Reference OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the actuator harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the actuator harness. Refer to Procedure 019-204 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the lockout solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Does not meet specifications

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Inspect the 31-pin Deutsch™ connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.

Action

Inspect the 31-pin Deutsch™ connector pins that connect the actuator harness to the OEM harness for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the 31-pin Deutsch™ connector.

Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.

  • Repair the damaged pins or replace the connector. Refer to Procedure 019-071 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness from the lockout solenoid.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin 9 of the OEM harness side of the 31-pin connector to all other pins in the 31-pin connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the lockout solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 35 of the actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-1

Go to 3A

Guided Step 2C-1 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the OEM harness from the lockout solenoid.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 8 on the OEM harness side of the 31-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronice service tool to verify that Fault Code 536 is inactive.
OK NOT OK

Fault Code 536 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 537 - Autoshift High Gear Actuator (Shift Solenoid)

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To avoid personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To avoid damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the autoshift high gear actuator (shift solenoid). |
 | STEP 1A. Inspect the shift solenoid and solenoid harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the shift solenoid. | 14 to 34 ohms?
 | STEP 1C. Check for a short circuit to ground on the shift solenoid. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin on the shift solenoid. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2B-1. Inspect the 31-pin Deutsch™ connector pins. |
 | STEP 2B-2. Check for a short circuit in the OEM harness. |
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C-1. Check for a short circuit to ground in the OEM harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 537 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the autoshift high gear actuator (shift solenoid).

Guided Step 1A - Inspect the shift solenoid and solenoid harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the shift solenoid from the solenoid harness connector.

Action

Inspect the shift solenoid and solenoid harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or shift solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the shift solenoid. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the shift solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the shift solenoid from the solenoid harness connector.

Action

Measure the resistance of the shift solenoid.

  • Measure the resistance between solenoid connector pins B (or 2) and C (or 3).
OK NOT OK

14 to 34 ohms?

Replace the shift solenoid.

Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for short circuit to ground on shift solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the shift solenoid from the solenoid harness.

Action

Check for a short circuit to ground in the shift solenoid.

  • Measure the resistance from pin C (or 3) of the shift solenoid to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the shift solenoid.

Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin on the shift solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the shift solenoid harness from the actuator harness.

Action

Check for a short circuit from pin to pin in the shift solenoid.

  • Measure the resistance from pins A (or 1) to C (or 3) of the shift solenoid.
OK NOT OK

Greater than 100k ohms?

Replace the shift solenoid.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the shift solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Does not meet specifications.

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Inspect the 31-pin Deutsch™ connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.

Action

Inspect the 31-pin Deutsch™ connector pins which connect the actuator harness to the OEM harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the 31-pin Deutsch™ connector.

Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.

  • Repair or replace the connector. Refer to Procedure 019-208 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness from the shift solenoid.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin 8 on the OEM harness side of the 31-pin connector to all other pins in the 31-pin connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the shift solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 45 in the actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-1

Go to 3A

Guided Step 2C-1 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness from the shift solenoid.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 8 on the OEM harness side of the 31-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 537 is inactive.
OK NOT OK

Fault Code 537 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 538 - Autoshift Neutral Actuator

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the autoshift neutral actuator. |
 | STEP 1A. Inspect the neutral actuator and solenoid harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the neutral actuator. | 14 to 34 ohms?
 | STEP 1C. Check for a short circuit to ground on the neutral actuator. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin on the neutral actuator. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the 31-pin Deutsch® connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 538 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the autoshift neutral actuator.

Guided Step 1A - Inspect the neutral actuator and solenoid harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral actuator from the solenoid harness connector pins.

Action

Inspect the neutral actuator and solenoid harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or neutral actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19..
  • Replace the neutral actuator. Reference OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the neutral actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral actuator from the solenoid harness connector pins.

Action

Measure the resistance of the neutral actuator.

  • Measure the resistance across the solenoid connector pins.
OK NOT OK

14 to 34 ohms?

Replace the neutral actuator.

Reference to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check for short circuit to ground on neutral actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral actuator from the solenoid harness.

Action

Check for a short circuit to ground in the neutral actuator.

  • Measure the resistance from pin C (or 3) of the neutral actuator to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the shift solenoid.

Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin on the neutral actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral actuator harness from the actuator harness.

Action

Check for a short circuit from pin to pin in the neutral actuator.

  • Measure the resistance from neutral actuator supply pin to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the neutral actuator.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.

Action

Check for a short circuit between the pins.

  • Measure the resistance from pin 34 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 34 in the actuator harness to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the 31-pin Deutsch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.

Action

Inspect the 31-pin Deutsch connector pins that connect the actuator harness to the OEM harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the 31-pin Deutsch™ connector.

Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.

  • Repair or replace the connector. Refer to Procedure 019-208 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the OEM harness from the shift solenoid.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin 10 on the OEM harness side of the 31-pin connector to all other pins in the 31-pin connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-031 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness from the shift solenoid.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 10 on the OEM harness side of the 31-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 538 is inactive.
OK NOT OK

Fault Code 538 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-May-2015


FAULT CODE 541 - ICON™ Starter Relay Input Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp. | Fault Code 541 inactive?
 | STEP 1B. Perform the starter relay/interlock test. | Starter relay engages starter?
STEP 2. | Check the ICON™ starter relay coil. |
 | STEP 2A. Check the continuity of the ICON™ starter relay coil. | Greater than 6 ohms and less than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the ICON™ shorting plug. |
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to the battery. | Less than +1.5-VDC?
STEP 4. | Check the original equipment manufacturer (OEM) engine harness. |
 | STEP 4A. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to the battery. | Less than +1.5-VDC?
 | STEP 4D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 5. | Check the ICON™ interlock switches. |
 | STEP 5A. Check the neutral position switch for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5B. Check the hood tilt switch for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5C. Check the parking brake switch for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5D. Check the optional OEM interlock switches for a short circuit to ground. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 541 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read the fault codes with INSITE™ or flash out with the ICON™ lamp.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.
OK NOT OK

Fault Code 541 inactive?

Fault Code 541 active

Go to 1B

Go to 1B

Guided Step 1B - Perform the starter relay/interlock test.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Perform the starter relay/interlock test.

  • Use INSITE™ electronic service tool to perform the starter relay and interlock test. Refer to the Electronic Service Tool.
OK NOT OK

Starter relay engages starter?

Starter does not engage

Go to 6A

Go to 2A

Guided Step 2 - Check the ICON™ starter relay coil.

Guided Step 2A - Check the continuity of the ICON™ starter relay coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ starter relay from the OEM harness.

Action

Check the continuity of the ICON™ starter relay coil.

  • Measure the resistance from the positive (+) pin 85 of the starter relay to the negative (-) pin 86 of the relay.
OK NOT OK

Greater than 6 ohms and less than 100k ohms?

Replace the relay.

Refer to Procedure 019-302 in the Master Repair Manual, ICON™ Idle Control System, Bulletin 3666415.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the actuator harness from the ECM.
  • Disconnect the 31-pin connector from the OEM harness.
  • Disconnect the sensor harness from the ECM.

Action

Inspect the actuator, sensor harnesses, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector from the OEM harness.
  • Disconnect the actuator harness from the ECM.
  • Verify that the ICON™ shorting plug is connected to the 6-pin engine harness connector.
  • Disconnect the sensor harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 14 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 46 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 16 of the sensor harness connector to all other pins in the connector.
  • For ISM Series engines only: Measure the resistance from pin 21 of the sensor harness connector to all other pins in the connector.
  • For Signature and ISX Series engines only: Measure the resistance from pin 47 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector from the OEM harness.
  • Disconnect the actuator harness from the ECM.
  • Verify that the ICON™ shorting plug is connected to the 6-pin engine harness connector.
  • Disconnect the sensor harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 20 of the 31-pin OEM harness connector, engine harness side, to pin 46 of the actuator harness connector.
  • Measure the resistance from pin 27 of the 31-pin OEM harness connector, engine harness side, to pin 14 of the actuator harness connector.
  • Measure the resistance from pin 31 of the 31-pin OEM harness connector, engine harness side, to pin 16 of the sensor harness connector.
  • For Signature/ISX Series engines only: Measure the resistance from pin 24 of the 31-pin OEM harness connector, engine harness side, to pin 47 of the actuator harness connector.
  • For ISM Series engines only: Measure the resistance from pin 24 of the 31-pin OEM harness connector, engine harness side, to pin 21 of the sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 6A

Guided Step 3C-1 - Check for an open circuit in the ICON™ shorting plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ shorting plug from the 6-pin engine harness connector.

Action

Check for an open circuit in the ICON™ shorting plug.

  • Measure the resistance from pin 4 to pin 5 of the ICON™ shorting plug.
OK NOT OK

Less than 10 ohms?

Replace the shorting plug.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector.
  • Disconnect the actuator harness connector from the ECM.
  • Verify that the ICON™ shorting plug is connected to the 6-pin engine harness connector.
  • Disconnect the sensor harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 14 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 46 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 16 of the sensor harness connector to engine block ground.
  • For ISM Series engines only: Measure the resistance from pin 21 of the sensor harness connector to engine block ground.
  • For Signature/ISX Series engines only: Measure the resistance from pin 47 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to the battery.

Conditions

  • Disconnect the 31-pin OEM connector.
  • Disconnect the actuator harness connector from the ECM.
  • Connect the shorting plug to the 6-pin OEM interface harness.
  • Disconnect the sensor harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to the battery.

  • Measure the voltage from pin 14 of the actuator harness connector to engine block ground.
  • Measure the voltage from pin 46 of the actuator harness connector to engine block ground.
  • Measure the voltage from pin 16 of the sensor harness connector to engine block ground.
  • For ISM Series engines only: Measure the voltage from pin 21 of the sensor harness connector to engine block ground.
  • For Signature/ISX Series engines only: Measure the voltage from pin 47 of the actuator harness to engine block ground.
OK NOT OK

Less than + .5-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the OEM engine harness.

Guided Step 4A - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the ICON™ starter relay from the 31-pin OEM connector.
  • Make certain that the interlock switches (hood tilt, parking brake, and neutral) are closed.

Action

Check for an open circuit.

  • Measure the resistance from pin 20 of the 31-pin OEM connector, OEM side, to the ICON™ starter relay pin on the OEM ECM connector side of the relay.
  • Measure the resistance from pin 27 of the 31-pin OEM connector, OEM side, to the ICON™ starter relay pin on the 31-pin OEM connector side of the relay.
  • Measure the resistance from pin 33 of the 50-pin OEM harness connector to the ICON™ starter relay pin on the OEM ECM connector side of the relay.
  • Measure the resistance from pin 31 to pin 24 on the 31-pin OEM connector, OEM side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine or OEM harness.

  • Repair the engine or OEM harness. Refer to Procedure 019-204 in Section 19, Refer to Procedure 019-208 in Section 19, or Refer to Procedure 019-204 in Section 19.
  • Replace the engine or OEM harness. Refer to Procedure 019-043.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit to the battery.

Conditions

  • Disconnect the 31-pin OEM connector.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the starter relay from the OEM harness.
  • Make certain that all the interlock switches (hood tilt, parking brake, and neutral position) are closed.
  • Turn keyswitch ON.

Action

Check for a short circuit to the battery.

  • Measure the voltage from pin 20 of the 31-pin OEM harness connector, OEM harness side, to engine block ground.
  • Measure the voltage from pin 27 of the 31-pin OEM harness connector, OEM harness side, to engine block ground.
  • Measure the voltage from pin 31 of the 31-pin OEM harness connector, OEM harness side, to engine block ground.
  • Measure the voltage from pin 24 of the 31-pin OEM harness connector, OEM side, to engine block ground.
  • Measure the voltage from pin 33 of the 50-pin OEM harness connector to engine block ground.
OK NOT OK

Less than +1-VDC?

Repair or replace the engine or OEM harness.

  • Repair the engine or OEM harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine or OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the starter relay from the OEM harness.
  • Make certain that all the interlock switches (hood tilt, parking brake, and neutral position) are closed.

Action

Measure the following resistances:

  • Measure the resistance from pin 20 of the 31-pin OEM connector, OEM harness side, to engine block ground.
  • Measure the resistance from pin 24 of the 31-pin OEM connector, OEM harness side, to engine block ground.
  • Measure the resistance from pin 31 of the 31-pin OEM connector, OEM harness side, to engine block ground.
  • Measure the resistance from pin 33 of the 50-pin OEM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine or OEM harness.

  • Repair the engine or OEM harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine or OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ICON™ interlock switches.

Guided Step 5A - Check the neutral position switch for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral position switch from the OEM harness.

Action

Check the neutral position switch for a short circuit to ground.

  • Measure the resistance from neutral position switch connector pin A (or 1), switch side of connector, to engine block ground.
  • Measure the resistance from neutral position switch connector pin B (or 2), switch side of connector, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the neutral position switch

Refer to the OEM troubleshooting and repair manual.

Go to 5B

Go to 6A

Guided Step 5B - Check the hood tilt switch for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the hood tilt switch from the OEM harness.

Action

Check the hood tilt switch for a short circuit to ground.

  • Measure the resistance from hood tilt switch connector pin A (or 1), switch side of connector, to engine block ground.
  • Measure the resistance from hood tilt switch connector pin B (or 2), switch side of connector, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the hood tilt switch

Refer to the OEM troubleshooting and repair manual.

Go to 5C

Go to 6A

Guided Step 5C - Check the parking brake switch for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the parking brake switch from the OEM harness.

Action

Check the parking brake switch for a short circuit to ground.

  • Measure the resistance from parking brake switch connector pin A (or 1), switch side of connector, to engine block ground.
  • Measure the resistance from parking brake switch connector pin B (or 2), switch side of connector, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the parking brake switch.

Reference the OEM troubleshooting and repair manual.

Go to 5D

Go to 6A

Guided Step 5D - Check the optional OEM interlock switches for a short circuit to ground.

Conditions

  • Disconnect any optional OEM interlock switches from the OEM harness.
  • Turn keyswitch OFF.

Action

Check any optional OEM interlock switches for a short circuit to ground.

  • Measure the resistance from OEM optional interlock switch connector pin A (or 1) to engine block ground.
  • Measure the resistance from OEM optional interlock switch connector pin B (or 2) to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM optional interlock switch

Refer to the OEM troubleshooting and repair manual.

6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 541 is inactive.
OK NOT OK

Fault Code 541 inactive?

Return to the troubleshooting steps or contact the local Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Sep-2012


FAULT CODE 544 - Top 2 Transmission Circuit - Mechanical System Failure

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 526 and 537 are inactive?
STEP 2. | Check the lockout solenoid. |
 | STEP 2A. Perform the lockout solenoid click test. | Lockout solenoid clicks?
 | STEP 2B. Check for an open circuit. | +12-VDC?
 | STEP 2C. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2D. Inspect the 31-pin Deutsch™ connector pins. | Dirty or damaged pins?
 | STEP 2E. Read the fault codes. | Fault Code 544 inactive?
 | STEP 2F. Check the resistance of the actuator harness. | Less than 10 ohms?
 | STEP 2G. Check the resistance of the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
STEP 3. | Check the shift solenoid. |
 | STEP 3A. Perform the shift solenoid click test. | Shift solenoid clicks?
 | STEP 3B. Check for an open circuit. | +12-VDC?
 | STEP 3C. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the resistance of the actuator harness. | Less than 10 ohms?
 | STEP 3E. Check the resistance of the OEM harness. | Less than 10 ohms?
STEP 4. | Check the transmission. |
 | STEP 4A. Inspect the transmission. | Transmission functions properly?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 544 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic serivce tool to read fault codes.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 536 and 537 are inactive?

A possible short circuit in Top 2 solenoid circuit.

Go to 2A

Fault Codes 536 and 537

Guided Step 2 - Check the lockout solenoid.

Guided Step 2A - Perform the lockout solenoid click test.

Conditions

  • Connect all components.
  • Install INSITE™ electronic service tool to perform the click test.
  • Install INLINE II™ data link adapter.

Action

Perform the transmission solenoid click test.

  • Refer to the INSITE™ electronic service tool user's manual for click test procedure.
OK NOT OK

Lockout solenoid clicks?

Lockout solenoid does not click.

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Disconnect the OEM connector from the lockout solenoid.
  • Install INSITE™ electronic service tool to perform the click test.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure for +12-VDC at the OEM connector while performing the click test.
  • Refer to the INSITE™ electronic service tool user's manual for the click test procedure.
OK NOT OK

+ 12-VDC?

Replace the lockout solenoid

Reference the OEM troubleshooting and repair manual.

Go to 5A

Go to 2C

Guided Step 2C - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part No. 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Inspect the 31-pin Deutsch™ connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.

Action

Inspect the 31-pin Deutsch™ connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the 31-pin Deutsch connector

Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part No. 3824510.

  • Repair or replace the connector. Refer to Procedure 019-208 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic serice tool to verify Fault Code 544 is inactive.
OK NOT OK

Fault Code 544 inactive?

Fault Code 544 active.

Go to 5B

Go to 2F

Guided Step 2F - Check the resistance of the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 45 of the actuator harness connector to pin 8 of the 31-pin Deutsch™ connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2G

Go to 5A

Guided Step 2G - Check the resistance of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the engine harness connector from the lockout solenoid.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 8 of the OEM harness side of the 31-pin connector to pin A (or 1) of the lockout solenoid.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the shift solenoid.

Guided Step 3A - Perform the shift solenoid click test.

Conditions

  • Install INSITE™ electronic service tool
  • Connect all components.
  • Turn keyswitch ON.

Action

Perform the shift solenoid click test.

  • Use INSITE™ electronic service tool to perform the click test.
  • Refer to INSITE™ electronic service tool user's manual for procedure.
OK NOT OK

Shift solenoid clicks?

Shift solenoid does not click.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Install INSITE™ electronic service tool.
  • Disconnect the OEM connector from the shift solenoid.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure for +12-VDC at the OEM connector while performing the click test.
OK NOT OK

+ 12-VDC?

Replace the shift solenoid.

Reference the OEM troubleshooting and repair manual.

+ 12 VDC

Replace the shift solenoid.

Reference the OEM troubleshooting and repair manual.

Go to 5A

Go to 3C

Guided Step 3C - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the resistance of the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 45 of the actuator harness to pin 8 in the 31-pin Deutsch™ connector.
  • Measure the resistance from pin 35 of the actuator harness to pin 9 in the 31-pin Deutsch™ connector.
  • Measure the resistance from pin 34 of the actuator harness to pin 10 in the 31-pin Deutsch™ connector.
  • Measure the resistance from pin 43 of the actuator harness to pin 11 in the 31-pin Deutsch™ connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check the resistance of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness from the autoshift transmission solenoid connectors.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 10 of the OEM harness side of the 31-pin connector to pin C (or 3) of the shift solenoid connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the transmission.

Guided Step 4A - Inspect the transmission.

Conditions

  • Connect all components.

Action

Inspect the transmission.
OK NOT OK

Transmission functions properly?

Reference the transmission OEM troubleshooting and repair manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 544 is inactive.
OK NOT OK

Fault Code 544 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Sep-2012


FAULT CODE 551 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead and Part Number 3824910 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Check the ISS connector for lubricant. | No lubricant?
 | STEP 1B. Inspect the OEM harness and ISS connector. | Dirty or damaged pins?
 | STEP 1C. Measure the off-idle and idle resistance value. | Less than 125 ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check the voltage at the SIGNAL pins. | +3.80 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Check the ISS connector for lubricant.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS connector from the accelerator pedal.

Action

Check the ISS connector for lubricant.
OK NOT OK

No lubricant?

Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the OEM harness and ISS connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ISS.

Action

Inspect the OEM harness and the ISS connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the ISS or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the ISS. Reference the OEM troubleshooting and repair manual.
  • Replace the switch connector. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Measure the off-idle and idle resistance value.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ISS.

Action

Measure off-idle and idle resistance value.

  • Measure the resistance from the RETURN wire pin to the off-idle SIGNAL pin on the switch side of the idle validation switch connector after slowly actuating the pedal past the on-idle zone until the pedal is fully depressed.
  • Measure the resistance from the RETURN wire pin to the idle SIGNAL pin on the switch side of the idle validation switch connector with the accelerator pedal in the released (idle) position.

Note: There is a switch transition state between on-idle and off-idle when you can expect higher resistance values. Be sure not to reject pedals due to these transition state values. The ECM will not log a fault during these transition states.

OK NOT OK

Less than 125 ohms?

Replace the ISS.

Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ISS.

Action

Check for a short circuit from pin-to-pin.

  • With the accelerator pedal released, measure the resistance from the off-idle pin to the on-idle pin at the switch side of the connector.
  • With the accelerator pedal released, measure the resistance from the off-idle pin to the switch common return at the switch side of the connector.
  • With the accelerator pedal depressed, measure the resistance from the on-idle pin to the switch common RETURN pin at the switch side of the connector.

Note: Connect a mating connector with short lead extensions to the idle validation switch connector. This will allow the electrical leads of the idle validation switch to be softly flexed to check for damaged or partially broken wire strands under the insulation.

OK NOT OK

Greater than 100k ohms?

Replace the ISS.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Turn cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins of the OEM harness connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect ISS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the resistance from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the voltage at the SIGNAL pins.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Connect a jumper wire, Part Number 3822917, from pin 3 of the ECM OEM port to the throttle supply at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 13 of the ECM OEM port to the throttle return at the accelerator pedal.
  • Turn keyswitch ON.

Action

Check the voltage at the SIGNAL pins.

  • Measure the voltage from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the voltage from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

+3.80 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal four to five times.
  • Turn the keyswitch OFF for 5 seconds.
  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.
OK NOT OK

Fault Code 551 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Sep-2012


FAULT CODE 551 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead and Part Number 3824910 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the harness and IVS connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check the voltage at the SIGNAL pins. | +3.80 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the harness and IVS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the IVS.

Action

Inspect the harness and IVS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the IVS or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the IVS if the connector pins are damaged. Reference the OEM troubleshooting and repair manual.
  • Replace the switch connector if damaged. Reference the OEM troubleshooting and repair manual.
  • Install the appropriate connector seal if it is damaged or missing. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the IVS.

Action

Check for a short circuit from pin-to-pin.

  • With the accelerator pedal released, measure the resistance from the off-idle pin to the on-idle pin at the switch side of the connector.
  • With the accelerator pedal released, measure the resistance from the off-idle pin to the switch common return at the switch side of the connector.
  • With the accelerator pedal depressed, measure the resistance from the on-idle pin to the switch common RETURN pin at the switch side of the connector.

Note: Connect a mating connector with short lead extensions to the idle validation switch connector. This will allow the electrical leads of the idle validation switch to be softly flexed to check for damaged or partially broken wire strands under the insulation.

OK NOT OK

Greater than 100k ohms?

Replace the IVS. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the IVS.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the IVS.
  • Turn cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the AC pressure switch.
  • Diagnostic switch should not be in the diagnostic mode.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the IVS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the resistance from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the voltage at the SIGNAL pins.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Connect a jumper wire, Part Number 3822917, from pin 3 of the ECM OEM port to throttle supply at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 13 of the ECM OEM port to throttle return at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 10 of the ECM OEM port to switch common ground at the accelerator pedal.
  • Turn keyswitch ON.

Action

Check the voltage at the SIGNAL pins.

  • Measure the voltage from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the voltage from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

+3.80 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch OFF for 5 seconds.
  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.
OK NOT OK

Fault Code 551 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Sep-2012


FAULT CODE 551 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Vehicle movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead and Part Number 3824892 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the OEM harness and SSS connector pins. | Dirty or damaged pins?
 | STEP 1B. Measure the idle resistance value. | Correct resistance value?
 | STEP 1C. Check for proper IVS signal. | Correct voltage reading?
 | STEP 1C-1. Measure the voltage at the sensor. |
 | STEP 1C-2. Measure the voltage at the ECM. |
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check the voltage at the SIGNAL pins. | +3.80 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the OEM harness and SSS connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the SSS.

Action

Inspect the OEM harness and SSS connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the SSS or the OEM harness, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Reference the OEM troubleshooting and repair manual.
  • Replace the SSS. Reference the OEM troubleshooting and repair manual.
  • Replace the switch connector. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Measure the idle resistance value.

Conditions

  • Turn keyswitch OFF.
  • Install the breakout cable, Part Number 3824892, to the SSS.
  • Do not connect the breakout cable to the OEM harness.

Action

Measure the idle resistance value.

  • With the accelerator pedal released (on-idle), measure the resistance from pin 3 (APS signal) to pin 4 (APS return) on the breakout cable.

Note: Resistance value should be the same as the idle resistance value stamped on the SSS cover, ±20 ohms.
OK NOT OK

Correct resistance value?

Replace the SSS

Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check for proper IVS signal.

Conditions

  • Connect breakout cable, Part Number 3824892, between the OEM harness and the SSS.
  • Connect the OEM harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check for proper IVS signal.

  • Measure the voltage from pin 1 (IVS return) to pin 2 (IVS off-idle) on the breakout cable with the accelerator pedal depressed and released.
  • Measure the resistance from pin 1 (IVS return) to pin 6 (IVS on-idle) on the breakout cable with the accelerator pedal released and depressed.
OK NOT OK

Correct voltage reading?

Pin 1 to pin 2 > + 3.8 VDC, Pin 1 to pin 6 < + 0.8 VDC.

Pedal depressed: Pin 1 to pin 6 > + 3.8 VDC, Pin 1 to pin 2 < + 0.8 VDC.

Pedal released:

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage at the sensor.

Conditions

  • Connect the breakout cable, Part Number 3824892, to the OEM SSS harness.
  • Do not connect the SSS on accelerator pedal to the breakout cable.
  • Connect the OEM harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check for the proper SSS signal.

  • Measure the voltage from pin 1 (IVS) return to pin 2 (IVS off-idle) on the breakout cable with the accelerator pedal depressed and released.
  • Measure the voltage from pin 1 (IVS) return to pin 6 (IVS idle) on the breakout cable with the accelerator pedal released and depressed.
OK NOT OK

Meets specifications?

Replace the SSS.

Correct voltage reading:

Pedal released:

  • Pin 1 to pin 2 > + 3.8 VDC
  • Pin 1 to pin 6 < + 0.8 VDC

Pedal depressed:

  • Pin 1 to pin 6 > + 3.8 VDC
  • Pin 1 to pin 2 < + 0.8 VDC

Does not meet specifications.

Go to 4A

Go to 1C-2

Guided Step 1C-2 - Measure the voltage at the ECM.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Connect a jumper wire, Part Number 3822917, between pin 18 of the ECM OEM port to pin 18 of the ECM OEM harness connector.
  • Connect a jumper wire, Part Number 3822917, between pin 10 of the ECM OEM port to pin 10 of the ECM OEM harness connector.
  • Turn keyswitch ON.

Action

Check the IVS output from the ECM for proper voltage.

  • Measure the voltage from pin 6 of the OEM harness connector to pin 10.
  • Measure the voltage from pin 9 of the OEM harness connector to pin 10.
OK NOT OK

+3.80 to 5.25-VDC?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Connect breakout cable, Part Number 3824892, to the SSS.
  • Do not connect the breakout cable to the OEM harness.
  • Connect multimeter to breakout cable.
  • Accelerator pedal released.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 2 (off-idle) to pin 6 (IVS on-idle) on the breakout cable.
OK NOT OK

Greater than 100k ohms?

Replace the SSS.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the breakout cable from the SSS.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 at OEM harness connector at ECM to pin 2 (or D) [IVS off-idle] of the breakout cable.
  • Measure the resistance from pin 13 at OEM harness connector at ECM to pin 6 (or E) [IVS on-idle] of the breakout cable.
  • Measure the resistance from pin 10 at OEM harness connector at ECM to pin 1 (or F) [IVS return] of the breakout cable.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the breakout cable from the SSS.
  • Turn cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins jn the OEM harness connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect SSS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the resistance from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the voltage at the SIGNAL pins.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Connect a jumper wire, Part Number 3822917, from pin 3 of the ECM OEM port to throttle supply at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 13 of the ECM OEM port to throttle return at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 10 of the ECM OEM port to switch common return at the accelerator pedal.
  • Turn keyswitch ON.

Action

Measure the voltage at the SIGNAL pins.

  • Measure the voltage from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the voltage from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

+3.80 to 5.25-VDC?

Replace the SSS.

Reference the OEM troubleshooting and repair manual.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch OFF for 5 seconds.
  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.
OK NOT OK

Fault Code 551 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Sep-2012


FAULT CODE 581 - Fuel Inlet Restriction Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel inlet restriction sensor. |
 | STEP 1A. Inspect the harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 581 inactive?
 | STEP 1C. Check the supply voltage. | +4.75 to 5.25-VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the signal voltage. | +0.5 to 4.16-VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 581 inactive?
 | STEP 2C. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the SUPPLY, SIGNAL, and RETURN wires. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit from the SUPPLY, SIGNAL, and RETURN wires to all other wires in the engine harness. | Greater than 100k ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 581 inactive and Fault Code 582 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 581 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel inlet restriction sensor.

Guided Step 1A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Inspect fuel inlet restriction sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.

  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the 3-pin Metri-Pack™ connector. Refer to Procedure 019-203 in Section 19.
  • Replace the fuel pump inlet restriction sensor.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 581 inactive?

Fault Code 581 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824775, between the sensor and the harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage by installing the breakout cable's SUPPLY pin A (or RED) and RETURN pin B (or BLACK) connectors into the multimeter.
OK NOT OK

+4.75 to 5.25-VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage from pin 29 to pin 27 at the actuator port of the ECM.
OK NOT OK

+4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check the signal voltage.

Conditions

  • Install breakout cable, Part Number 3824775, between the sensor and the harness connector.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the signal voltage by installing the breakout cable's SIGNAL pin C (or YELLOW) and RETURN pin B (or BLACK) connectors into the multimeter.
OK NOT OK

+0.5 to 4.16-VDC?

Does not meet specifications.

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • UsE INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 581 inactive?

Fault Code 581 active.

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 27 of the actuator harness connector to pin B (or 2) of the 3-pin connector at the sensor.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the SUPPLY, SIGNAL, and RETURN wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for a short circuit to ground in the SUPPLY, SIGNAL, and RETURN wires.

  • Measure the resistance from pin 27 in the actuator harness connector to the engine block ground.
  • Measure the resistance from pin 28 in the actuator harness connector to the engine block ground.
  • Measure the resistance from pin 29 in the actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from the SUPPLY, SIGNAL, and RETURN wires to all other wires in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for a short circuit from the SUPPLY, SIGNAL, and RETURN wires to all other wires in the engine harness.

  • Measure the resistance from pin 27 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 27 in the actuator harness connector to all other pins in the sensor connector.
  • Measure the resistance from pin 28 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 28 in the actuator harness connector to all other pins in the sensor connector.
  • Measure the resistance from pin 29 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 29 in the actuator harness connector to all other pins in the sensor connector.
OK NOT OK

Greater than 100k ohms?

Replace the fuel inlet restriction sensor.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 581 inactive?

Fault Code 582 active?

Fault Code 581 active?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 581 is inactive.
OK NOT OK

Fault Code 581 inactive?

Return to troubleshooting steps, or contact your local Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Sep-2012


FAULT CODE 582 - Fuel Inlet Restriction Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel inlet restriction sensor. |
 | STEP 1A. Inspect the harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 582 inactive?
 | STEP 1C. Check the supply voltage. | +4.75 to 5.25-VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the signal voltage. | +0.5 to 4.16-VDC?
 | STEP 1D-1. Check for a short circuit to ground in the SUPPLY and SIGNAL wires. |
 | STEP 1D-2. Check for a short circuit from the SUPPLY and SIGNAL wires to all other pins in the engine harness. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 582 inactive?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 582 inactive and Fault Code 581 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 582 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel inlet restriction sensor.

Guided Step 1A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Inspect the fuel inlet restriction sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the 3-pin Metri-Pack™ connector. Refer to Procedure 019-203 in Section 19.
  • Replace the fuel inlet restriction sensor. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 582 inactive?

Fault Code 582 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824776, between the sensor and the engine harness sensor connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage by installing the breakout cable's SUPPLY pin A (or RED) and RETURN pin B (or BLACK) connectors into the multimeter.
OK NOT OK

+4.75 to 5.25-VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage from pin 29 to pin 27 at the actuator port of the ECM.
OK NOT OK

+4.75 to 5.25-VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check the signal voltage.

Conditions

  • Install breakout cable, Part Number 3824776, between the sensor and the engine harness sensor connector.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the supply voltage by installing the breakout cable's SIGNAL pin C (or YELLOW) and RETURN pin B (or BLACK) connectors into the multimeter.
OK NOT OK

+0.5 to 4.16-VDC?

Does not meet specifications.

Go to 2A

Go to 1D-1

Guided Step 1D-1 - Check for a short circuit to ground in the SUPPLY and SIGNAL wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for a short circuit to ground in the SUPPLY and SIGNAL wires.

  • Measure the resistance from pin 28 in the actuator harness connector to the engine block ground.
  • Measure the resistance from pin 29 in the actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-2

Go to 4A

Guided Step 1D-2 - Check for a short circuit from the SUPPLY and SIGNAL wires to all other pins in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for a short circuit from the SUPPLY and SIGNAL wires to all other wires in the engine harness.

  • Measure the resistance from pin 28 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 29 in the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the fuel inlet restriction sensor

Refer to Procedure 019-203 in Section 19.

Replace the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 582 inactive?

Fault Code 582 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 29 of the actuator harness connector to pin A (or 1) of the 3-pin connector.
  • Measure the resistance from pin 28 of the actuator harness connector to pin C (or 3) of the 3-pin connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Install test lead, Part Number 3822917, as a jumper wire, between ECM actuator port pins 28 and 29.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 582 inactive?

Fault Code 581 active?

Fault Code 582 active

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 582 is inactive.
OK NOT OK

Fault Code 582 inactive?

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location, if all steps have been completed and checked again

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Sep-2012


FAULT CODE 583 - Fuel Inlet Restriction Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Measure the fuel inlet restriction. |
 | STEP 1A. Measure the fuel restriction. | Less than 12 in-Hg?
 | STEP 1A-1. Recheck the fuel inlet restriction. |
STEP 2. | Inspect the fuel lines or fuel hoses. |
 | STEP 2A. Inspect the metal fuel lines. | No damage?
 | STEP 2B. Inspect the fuel hoses. | No damage?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 583 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Measure the fuel restriction.

Guided Step 1A - Measure the fuel inlet restriction.

Conditions

  • Turn keyswitch OFF.

Action

Measure the fuel inlet restriction.

  • Remove the fuel supply hose to the gear pump and install a manometer.
  • Hold the manometer at the same level as the gear pump connection.
  • Operate the engine at rated speed and no load.
  • Observe the fuel inlet restriction reading on the manometer.
OK NOT OK

Less than 12 in-Hg?

Replace the fuel filter.

Go to 3A

Go to 1A-1

Guided Step 1A-1 - Recheck the fuel inlet restriction.

Conditions

  • Turn keyswitch OFF.

Action

Measure the fuel inlet restriction.

  • Remove the fuel supply hose from the gear pump and install a manometer.
  • Hold the manometer at the same level as the gear pump connection.
  • Operate the engine at rated speed and no load.
  • Observe the fuel inlet restriction reading on the manometer.
OK NOT OK

Less than 6 in-Hg?

Does not meet specifications.

Go to ?3A

Go to 2A

Guided Step 2 - Inspect the fuel lines or fuel hoses.

Guided Step 2A - Inspect the metal fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the metal fuel lines for these conditions:

  • Sharp bends, which can cause a pressure restriction.
OK NOT OK

No damage?

Replace the damaged line(s).

Go to 2B

Go to 3A

Guided Step 2B - Inspect the fuel hoses.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel hoses.

  • Check fuel hoses for separation of the inner lining from the center of the hose, which can cause restriction.
OK NOT OK

No damage?

Replace the damaged hose.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 583 is inactive.
OK NOT OK

Fault Code 583 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all troubleshooting steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Sep-2012


FAULT CODE 588 - ICON™ Starter Relay Input Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp. | Fault Code 588 inactive?
 | STEP 1B. Perform the ICON™ alarm test. | Alarm sounds?
STEP 2. | Check the engine start alarm. |
 | STEP 2A. Inspect the engine start alarm connector for damaged pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine start alarm resistance from pin-to-pin. | Greater than 6 and less than 12k ohms?
 | STEP 2C. Check the engine start alarm resistance to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and the engine start alarm connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to battery voltage. | Less than +1.5-VDC?
 | STEP 3B-1. Check for a short circuit to battery voltage in the OEM harness. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 588 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.
OK NOT OK

Fault Code 588 inactive?

Fault Code 588 active

Go to 1B

Go to 1B

Guided Step 1B - Perform the ICON™ alarm test.

Conditions

  • Connect the INSITE™ electronic service tool to the engine.
  • Turn keyswitch ON.

Action

Perform the ICON™ alarm test.

  • Use INSITE™ electronic service tool to perform the ICON™ alarm test.
OK NOT OK

Alarm sounds?

Alarm does not sound

Go to 4A

Go to 2A

Guided Step 2 - Check the engine start alarm.

Guided Step 2A - Inspect the engine start alarm connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Inspect the engine start alarm connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the damaged pins.

Repair the engine start alarm connector, or replace the engine start alarm, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine start alarm connector. Refer to Procedure 019-202 in Section 19.
  • Replace the engine start alarm. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the engine start alarm resistance from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Check the engine start alarm resistance from pin-to-pin.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the engine start alarm connector.
OK NOT OK

Greater than 6 and less than 12k ohms?

Replace the engine start alarm.

Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the engine start alarm resistance to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Check the engine start alarm resistance to engine block ground.

  • Measure the resistance from pin A (or 1) of the engine start alarm connector to engine block ground.
  • Measure the resistance from pin B (or 2) of the engine start alarm connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine start alarm.

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and the engine start alarm connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and engine start alarm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the damaged pins.

Repair or replace the engine harness or the engine start alarm, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the engine start alarm. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to battery voltage.

Conditions

  • Disconnect the engine start alarm from the engine harness.
  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery voltage.

  • Measure the voltage from pin 25 of the actuator harness connector to engine block ground.
OK NOT OK

Less than +1.5-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a short circuit to battery voltage in the OEM harness.

Conditions

  • Disconnect the 31-pin OEM connector.
  • Disconnect the engine start alarm from the engine harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery voltage in the OEM harness.

  • Measure the voltage from pin 29 of the 31-pin OEM connector, OEM harness side, to engine block ground.
OK NOT OK

Less than +1.5-VDC?

Does not meet specifications

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 588 is inactive.
OK NOT OK

Fault Code 588 inactive?

Return to the troubleshooting steps, or contact the local Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Aug-2012


FAULT CODE 589 - Engine Start Alarm Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic servicew too or flash out with the ICON™ lamp. | Fault Code 589 inactive?
 | STEP 1B. Perform the ICON™ alarm test. | Alarm sounds?
STEP 2. | Check the engine start alarm. |
 | STEP 2A. Inspect the engine start alarm connector for damaged pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine start alarm resistance from pin-to-pin. | Greater than 6 and less than 12k ohms?
 | STEP 2C. Check the engine start alarm resistance to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and the engine start alarm connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3B-1. Check for a short circuit to ground in the OEM harness. |
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit from the alarm connector to the ECM actuator connector. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 589 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.
OK NOT OK

Fault Code 589 inactive?

Fault Code 589 active

Go to 1B

Go to 1B

Guided Step 1B - Perform the ICON™ alarm test.

Conditions

  • Connect the INSITE™ electronic service tool to the engine.
  • Turn keyswitch ON.

Action

Perform the ICON™ alarm test.

  • Use INSITE™ electronic service tool to perform the ICON™ alarm test.
OK NOT OK

Alarm sounds?

Alarm does not sound

Go to 4A

Go to 2A

Guided Step 2 - Check the engine start alarm.

Guided Step 2A - Inspect the engine start alarm connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Inspect the engine start alarm connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the damaged pins.

Repair the engine start alarm connector, or replace the engine start alarm, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine start alarm connector. Refer to Procedure 019-202 in Section 19.
  • Replace the engine start alarm. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the engine start alarm resistance from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Check the engine start alarm resistance from pin-to-pin.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the engine start alarm connector.
OK NOT OK

Greater than 6 and less than 12k ohms?

Replace the engine start alarm.

Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the engine start alarm resistance to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Check the engine start alarm resistance to engine block ground.

  • Measure the resistance from pin A (or 1) of the engine start alarm connector to engine block ground.
  • Measure the resistance from pin B (or 2) of the engine start alarm connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine start alarm.

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and the engine start alarm connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and engine start alarm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the damaged pins.

Repair or replace the engine harness or the engine start alarm, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the engine start alarm. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 25 of the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector.
  • Disconnect the engine start alarm from the engine harness.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 29 of the 31-pin OEM connector, OEM harness side, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Does not meet specifications.

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ engine start alarm from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 32 of the actuator harness connector to pin A (or 1) of the ICON™ alarm connector.
OK NOT OK

Less than 10 ohms?

Does not meet specifications.

Repair or replace the OEM harness.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit from the alarm connector to the ECM actuator connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ engine start alarm from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 25 of the actuator harness connector to pin B (or 2) of the ICON™ alarm connector.
OK NOT OK

Less than 10 ohms?

Does not meet specifications.

Repair or replace the OEM harness.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 589 is inactive.
OK NOT OK

Fault Code 589 inactive?

Return to the troubleshooting steps or contact the local Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Aug-2012


FAULT CODE 596 - Voltage Monitor - High Voltage

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery and alternator cable connections. | No damaged connections?
 | STEP 1B. Check the battery voltage. | Normal conditions: At least + 12 VDC, During cranking: At least + 6.2 VDC?
STEP 2. | Check the charging system. |
 | STEP 2A. Check the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 596 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery and alternator cable connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connections?

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.
OK NOT OK

Normal conditions:

At least (+) 12 VDC

During cranking:

At least (+) 6.2 VDC

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

Start the engine and check the alternator's charging rate (amps).

Note: It will probably be necessary to place a load on the batteries to measure the alternator output properly.
OK NOT OK

Alternator charging within OEM specifications?

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator

Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 6 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 596 is inactive.
OK NOT OK

Fault Code 596 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Aug-2012


FAULT CODE 597 - Voltage Monitor - Low Voltage

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP3/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp. | Fault Code 597 inactive?
STEP 2. | Check the equipment battery charging system. |
 | STEP 2A. Inspect the battery and alternator cable connections. | Connections clean and tight?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC, During cranking: At least (+) 6.2 VDC?
 | STEP 2C. Measure the voltage output of the alternator. | Reference the OEM troubleshooting and repair manual for specifications
STEP 3. | Check the power and ground connections. |
 | STEP 3A. Inspect all engine, chassis power, and ground connections. | Connections clean and tight?
 | STEP 3B. Check all power resistances. | Less than 10 ohms?
 | STEP 3C. Check all ground resistances. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit. | Greater than 100k ohms?
 | STEP 3E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Dirty or damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 597 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.
OK NOT OK

Fault Code 597 inactive?

Fault Code 597 active

Go to 4A

Go to 2A

Guided Step 2 - Check the equipment battery charging system.

Guided Step 2A - Inspect the battery and alternator cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery and alternator cable connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Connections clean and tight?

Repair the damaged connections.

Tighten the battery and alternator connections, and clean the terminals. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.
OK NOT OK

Normal conditions: At least (+) 12 VDC

During cranking: At least (+) 6.2 VDC

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Measure the voltage output of the alternator.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Measure the alternator voltage with the engine at idle.

  • Start and idle the engine.
  • Measure the alternator voltage.
OK NOT OK

Reference the OEM troubleshooting and repair manual for specifications.

Repair or replace the alternator.

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the power and ground connections.

Guided Step 3A - Inspect all engine, chassis power, and ground connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery cables.
  • Disconnect the OEM harness from the ECM.

Action

Inspect all engine, chassis power, and ground connections.
OK NOT OK

Connections clean and tight?

Clean and tighten any loose connections.

Go to 3B

Go to 4A

Guided Step 3B - Check all power resistances.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery cables.
  • Disconnect the OEM harness from the ECM.

Action

Check the power resistances to the ECM.

  • Measure the resistance from pin 7 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 8 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 17 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 18 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 28 of the OEM harness connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the battery harness.

Reference the OEM troubleshooting and repair manual.

Go to 3C

Go to 4A

Guided Step 3C - Check all ground resistances.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery cables.
  • Disconnect the OEM harness from the ECM.

Action

Check the ground resistances.

  • Measure the resistance from pin 29 of the OEM harness connector to the negative (-) battery terminal connector.
  • Measure the resistance from pin 30 of the OEM harness connector to the negative (-) battery terminal connector.
  • Measure the resistance from pin 39 of the OEM harness connector to the negative (-) battery terminal connector.
  • Measure the resistance from pin 40 of the OEM harness connector to the negative (-) battery terminal connector.
  • Measure the resistance from pin 50 of the OEM harness connector to the negative (-) battery terminal connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the battery harness.

Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 4A

Guided Step 3C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery cables.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit.

  • Measure the resistance from pin 7 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 8 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 28 of the OEM harness connector to all other pins in the connector.

Note: Pins 7, 8, 17, 18, and 28 must have continuity.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the SUPPLY wire to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair the damaged wiring.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 6 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 597 is inactive.
OK NOT OK

Fault Code 597 inactive

Return to the troubleshooting steps or contact the local Cummins®Authorized Repair Location if all the steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Aug-2012


FAULT CODE 598 - Voltage Monitor - Very Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery and alternator cable connections. | No damaged connections?
 | STEP 1B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC, During cranking: At least (+) 6.2 VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 598 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery and alternator cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery and alternator cable connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connections?

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.
OK NOT OK

Normal conditions: At least (+) 12 VDC

During cranking: At least (+) 6.2 VDC

Charge or replace the battery.

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

Start the engine and check the alternator's charging rate (amps).

Note: It will probably be necessary to place a load on the batteries to measure the alternator output properly.
OK NOT OK

Alternator charging within OEM specifications?

Repair or replace the alternator and/or the OEM wiring to the alternator.

Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the battery power connector.

Refer to the OEM troubleshooting and repair manual for location and procedure.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Measure the resistance between pin 7 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 8 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 17 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 18 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 28 of the OEM harness connector and the positive (+) terminal of the battery.
OK NOT OK

Less than 10 ohms?

Repair or replace the battery harness.

Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness at the battery power connector.

Action

Check for a short circuit.

  • Measure the resistance from pin 7 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 8 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 17 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 18 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 28 of the OEM harness connector to all other pins in the OEM harness connector.

Note: Pins 7, 8, 17, 18, and 28 should have continuity.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause a short circuit at SUPPLY wire to the engine block ground.
OK NOT OK

Dirty or damaged wires?

Repair the damaged wiring.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 598 is inactive.
OK NOT OK

Fault Code 598 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Aug-2012


FAULT CODE 784 - Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the adaptive cruise control hardware. |
 | STEP 1A. Check for installed adaptive cruise control hardware. | Adaptive cruise control hardware installed on vehicle?
STEP 2. | Check Society of Automotive Engineers (SAE) J1939 communication. |
 | STEP 2A. Check for engine control module (ECM) communication with INSITE™ electronic service tool. | INSITE™ electronic service tool communicates with the ECM?
 | STEP 2B. Inspect the equipment manufacturer harness and ECM connector pins | Dirty or damaged pins?
 | STEP 2C. Check ECM communication with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with the ECM?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 784 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the adaptive cruise control hardware.

Guided Step 1A - Check for installed adaptive cruise control hardware.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle for installed adaptive cruise control hardware.

Adaptive cruise control hardware installed on vehicle?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to disable the Adaptive Cruise feature.

Go to 2A

Go to 3A

Guided Step 2 - Check SAE J1939 communications.

Guided Step 2A - Check for ECM communication with INSITE™.

Conditions

  • Turn keyswitch ON.
  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool.
  • Select INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with the ECM?
YES NO

Repair

The ECM SAE J1939 data link circuit is functioning properly.

See the equipment manufacturer troubleshooting and repair manual for information on troubleshooting the adaptive cruise control unit and the vehicle SAE J1939 network.

No Repair

See the equipment manufacturer service information.

Go to 2B

Guided Step 2B - Inspect the equipment manufacturer harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the equipment manufacturer harness from the ECM.

Action

Inspect the equipment manufacturer harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the equipment manufacturer connector or equipment manufacturer harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the equipment manufacturer harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter to the ECM bench calibration harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with the ECM?
YES NO

Repair

INSITE™ is able to communicate with the ECM. This indicates that the ECM SAE J1939 data link circuit is functioning properly.

See the equipment manufacturer troubleshooting and repair manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

See the equipment manufacturer service information.

See the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TS.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 784 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 11-Dec-2015


FAULT CODE 951 - Cylinder Power Imbalance

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 951. | Active or inactive counts of Fault Code 951?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 951.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 951?
YES NO

Repair

Check fuel quality. Check for air being ingested into the fuel. It is normal to have an inactive Fault Code 951 after a service procedure introduced air into the fuel system, such as a filter change. Perform the Cylinder Cutout Test to determine if a particular cylinder is high or low on power. Refer to INSITE™ electronic service tool for help file for more details.

No Repair

Repair complete

Repair complete

Last Modified: 28-Aug-2012


FAULT CODE 2291 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read all fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp. | Fault Code 2291 inactive?
STEP 2. | Check the power and ground connections. |
 | STEP 2A. Check all engine and chassis power and ground connections. | Clean and tight?
STEP 3. | Check the vehicle speed sensor. |
 | STEP 3A. Inspect the vehicle speed sensor and harness connectors. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the vehicle speed sensor. | Greater than 100k ohms?
STEP 4. | Check for mechanical noise. |
 | STEP 4A. Check the vehicle speed sensor installation. | Sensor installation correct?
 | STEP 4B. Check for excessive mechanical drive movement when vehicle is stationary. | No excessive drive movement?
STEP 5. | Monitor vehicle speed. |
 | STEP 5A. Monitor for vehicle speed when starting the engine if INSITE™ electronic service tool is available. | 0 mph?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2291 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read all fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool or flash out with the ICON™ lamp.
OK NOT OK

Fault Code 2291 inactive?

Fault Code 2291 active

Go to 2A

Go to 2A

Guided Step 2 - Check the power and ground connections.

Guided Step 2A - Check all engine and chassis power and ground connections.

Conditions

  • Turn keyswitch OFF.

Action

Check all engine and vehicle power and ground connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Clean and tight?

Repair damaged connections.

Repair or replace the damaged connections.

Go to 3A

Go to 5A

Guided Step 3 - Check the vehicle speed sensor.

Guided Step 3A - Inspect the vehicle speed sensor and harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM harness.
  • Disconnect the OEM 31-pin Deutsch connector.

Action

Inspect the vehicle speed sensor and harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, and moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the vehicle speed sensor. Refer to Procedure 019-091 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to ground in the vehicle speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM harness.

Action

Check for a short circuit to ground in the vehicle speed sensor.

  • Measure the resistance from pin A of the vehicle speed sensor connector, sensor side, to engine block ground.
  • Measure the resistance from pin B of the vehicle speed sensor connector, sensor side, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the vehicle speed sensor.

Refer to Procedure 019-091 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check for mechanical noise.

Guided Step 4A - Check the vehicle speed sensor installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor installation.

  • Inspect the vehicle speed sensor to verify correct installation.
OK NOT OK

Sensor installation correct?

Reinstall vehicle speed sensor

Refer to Procedure 019-091 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Check for excessive mechanical drive movement when vehicle is stationary.

Conditions

  • Turn keyswitch OFF.

Action

With the vehicle stationary, check the mechanical drive for excessive movement.
OK NOT OK

No excessive drive movement?

Back the sensor out an additional 1/4 of a turn.

Go to 5A

Go to 5A

Guided Step 5 - Monitor vehicle speed.

Guided Step 5A - Monitor for vehicle speed when starting the engine if INSITE™ electronic service tool is available.

Conditions

  • Turn keyswitch ON.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Perform several manual starts to detect vehicle speed.

  • Use INSITE™ electronic service tool to monitor the vehicle speed parameter.
OK NOT OK

0 mph?

More than 0 mph

Go to 6A

Go to 1A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2291 is inactive.
OK NOT OK

Fault Code 2291 inactive?

Return to the troubleshooting steps, or contact the local Cummins®Authorized Repair Location if all the steps have been completed and rechecked.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Aug-2012


FAULT CODE 3714 - Engine Protection Torque Derate - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 3714 inactive.
 | STEP 1B. Check for active J1939 multiplexing faults. | J1939 multiplexing error fault codes such as Fault Code 285 and 286 are inactive?
 | STEP 1C. Check for inactive fault codes. | Fault Code 3714 inactive?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, the ECM contains that revision or higher.
 | STEP 2B. Disable the fault code. | Fault code inactive.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 3714 inactive?

Fault Code 3714 active.

Go to 2A

Go to 1B

Guided Step 1B - Check for active J1939 multiplexing faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active J1939 multiplexing fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

J1939 multiplexing error fault codes such as Fault Code 285 or 286 are active.

J1939 multiplexing error fault codes such as Fault Code 285 and 286 are inactive?

An OEM issue has been detected.

Refer to the OEM service manual. It is possible there is an issue with the device, device setup, or device to data link connection.

Troubleshoot the appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 3714 inactive?

A communication issue between the ECM and the data link, or a damaged ECM, or calibration is causing the fault code.

Fault Code 3714 active.

Appropriate ECM - No Communication troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.
OK NOT OK

If a calibration update for this fault code is available, the ECM contains that revision or higher.

If a calibration update for this fault code is available, the ECM does not contain that revision or higher?

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.
OK NOT OK

Fault code inactive?

Fault code active.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Aug-2012


INDEX
82-ifctabl.htm

82-fc111.htm

82-t05-111.htm

82-fc115.htm

82-t05-115.htm

82-fc121.htm

82-t05-121.htm

82-fc122.htm

82-t05-122.htm

82-fc123.htm

82-t05-123.htm

82-fc131.htm

82-t05-131.htm

82-fc132.htm

82-t05-132.htm

82-fc133.htm

82-t05-133.htm

82-fc134.htm

82-t05-134.htm

82-fc135.htm

82-t05-135.htm

82-fc141.htm

82-t05-141.htm

82-fc143.htm

82-t05-143.htm

82-fc144.htm

82-t05-144.htm

82-fc145.htm

82-t05-145.htm

82-fc147.htm

82-t05-147.htm

82-fc148.htm

82-t05-148.htm

82-fc153.htm

82-t05-153.htm

82-fc154.htm

82-t05-154.htm

82-fc155.htm

82-t05-155.htm

82-fc187.htm

82-t05-187.htm

82-fc198.htm

82-t05-198.htm

82-fc199.htm

82-t05-199.htm

82-fc212.htm

82-t05-212.htm

82-fc213.htm

82-t05-213.htm

82-fc214.htm

82-t05-214.htm

82-fc216.htm

82-t05-216.htm

82-fc217.htm

82-t05-217.htm

82-fc218.htm

82-t05-218.htm

82-fc221.htm

82-t05-221.htm

82-fc222.htm

82-t05-222.htm

82-fc223.htm

82-t05-223.htm

82-fc227.htm

82-t05-227.htm

82-fc234.htm

82-t05-234.htm

82-fc235.htm

82-t05-235.htm

82-fc237.htm

82-t05-237.htm

82-fc241.htm

82-t05-241.htm

82-fc242.htm

82-t05-242.htm

82-fc245.htm

82-t05-245.htm

82-fc249.htm

82-t05-249.htm

82-fc254.htm

82-t05-254.htm

82-fc255.htm

82-t05-255.htm

82-fc256.htm

82-t05-256.htm

82-fc285.htm

82-t05-285.htm

82-fc286.htm

82-t05-286.htm

82-fc293.htm

82-t05-293.htm

82-fc294.htm

82-t05-294.htm

82-fc295.htm

82-t05-295.htm

82-fc297.htm

82-t05-297.htm

82-fc298.htm

82-t05-298.htm

82-fc311.htm

82-t05-311.htm

82-fc312.htm

82-t05-312.htm

82-fc313.htm

82-t05-313.htm

82-fc314.htm

82-t05-314.htm

82-fc315.htm

82-t05-315.htm

82-fc319.htm

82-t05-319.htm

82-fc321.htm

82-t05-321.htm

82-fc322.htm

82-t05-322.htm

82-fc323.htm

82-t05-323.htm

82-fc324.htm

82-t05-324.htm

82-fc325.htm

82-t05-325.htm

82-fc331.htm

82-t05-331.htm

82-fc332.htm

82-t05-332.htm

82-fc338.htm

82-t05-338.htm

82-fc339.htm

82-t05-339.htm

82-fc341.htm

82-t05-341.htm

82-fc343.htm

82-t05-343.htm

82-fc349.htm

82-t05-349.htm

82-fc352.htm

82-t05-352.htm

82-fc359.htm

82-t05-359.htm

82-fc381.htm

82-t05-381.htm

82-fc386.htm

82-t05-386.htm

82-fc387.htm

82-t05-387.htm

82-fc388.htm

82-t05-388.htm

82-fc392.htm

82-t05-392.htm

82-fc415.htm

82-t05-415.htm

82-fc419.htm

82-t05-419.htm

82-fc422.htm

82-t05-422.htm

82-fc426.htm

82-t05-426.htm

82-fc428.htm

82-t05-428.htm

82-fc429.htm

82-t05-429.htm

82-fc431.htm

82-fc431iss.htm

82-t05-431iss.htm

82-fc431niss.htm

82-t05-431niss.htm

82-fc431sss.htm

82-t05-431sss.htm

82-fc432.htm

82-t05-432.htm

82-fc433.htm

82-t05-433.htm

82-fc434.htm

82-t05-434.htm

82-fc435.htm

82-t05-435.htm

82-fc441.htm

82-t05-441.htm

82-fc442.htm

82-t05-442.htm

82-fc443.htm

82-t05-443.htm

82-fc465.htm

82-t05-465.htm

82-fc466.htm

82-t05-466.htm

82-fc469.htm

82-t05-469.htm

82-fc472.htm

82-t05-472.htm

82-fc474.htm

82-t05-474.htm

82-fc475.htm

82-t05-475.htm

82-fc476.htm

82-t05-476.htm

82-fc489.htm

82-t05-489.htm

82-fc491.htm

82-t05-491.htm

82-fc492.htm

82-t05-492.htm

82-fc497.htm

00-t05-497.htm

82-fc527.htm

82-t05-527.htm

82-fc528.htm

82-t05-528.htm

82-fc529.htm

82-t05-529.htm

82-fc536.htm

82-t05-536.htm

82-fc537.htm

82-t05-537.htm

82-fc538.htm

82-t05-538.htm

82-fc541.htm

82-t05-541.htm

82-fc544.htm

82-t05-544.htm

82-fc551.htm

82-fc551iss.htm

82-t05-551iss.htm

82-fc551ivs.htm

82-t05-551ivs.htm

82-fc551sss.htm

82-t05-551sss.htm

82-fc581.htm

82-t05-581.htm

82-fc582.htm

82-t05-582.htm

82-fc583.htm

82-t05-583.htm

82-fc588.htm

82-t05-588.htm

82-fc589.htm

82-t05-589.htm

82-fc596.htm

82-t05-596.htm

82-fc597.htm

82-t05-597.htm

82-fc598.htm

82-t05-598.htm

82-fc784.htm

82-t05-784.htm

82-fc951.htm

82-t05-951.htm

82-fc2291.htm

82-t05-2291.htm

82-fc3714.htm

82-t05-3714.htm