QSX15, Signature/ISX

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Microprocessor

FAULT CODE 111

Engine Control Module Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the ECM related to the memory hardware failures or internal ECM voltage supply circuits. | Engine will not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the intake side of the engine between the air horn and the front of the engine.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111.

Last Modified: 11-Jun-2012
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Camshaft Engine Position Sensor Circuit

FAULT CODE 115

Camshaft Engine Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2/2 LAMP: Red SRT: | Camshaft Engine Position Sensor Circuit. No engine speed signal detected from the camshaft engine position sensor. | Engine may take longer to start.
Camshaft Engine Position Sensor Circuit

Circuit Description

The camshaft engine position sensor provides engine speed and position information to the electronic control module (ECM). The sensor must be powered up by (+) 5 VDC to operate. The sensor generates the signal from an extra lobe on the camshaft.

Component Location

The camshaft engine position sensor is located on the intake side of the engine block on the cylinder head to the right of the ECM. Refer to Procedure 100-002 in Section E for component location.

Shop Talk

Possible causes of this fault code include a damaged camshaft engine position sensor, an open or short circuit, or a power supply voltage failure.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 26-Oct-2010


Crankshaft Engine Position Sensor Circuit

FAULT CODE 121

Crankshaft Engine Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10/10 LAMP: Yellow SRT: | No engine speed signal detected from the crankshaft engine position sensor. | Hard starting, low power, rough idle, or possible white smoke.
Crankshaft Engine Position Sensor Circuit

Circuit Description

The crankshaft engine position sensor provides engine speed and position information to the electronic control module (ECM). The sensor must be powered up by (+) 5-VDC to operate. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The crankshaft engine position sensor is located on the side of the front cover on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams in Section E for component location.

Shop Talk

Possible causes of this fault code include a damaged crankshaft engine position sensor, an open or a short circuit, or power supply voltage failure.

Refer to Troubleshooting Fault Code t05-121.


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the intake manifold pressure sensor circuit. | Derate in power output of the engine.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure/temperature sensor is located in the air intake manifold toward the front of the engine.

Shop Talk

  • Determine if engine is being overfueled.
  • Confirm that the correct intake manifold pressure/temperature sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air.
  • Inspect the intake manifold pressure/temperature sensor circuit for signs of tampering. Remove any extra wires from the circuit.
Refer to Troubleshooting Fault Code t05-122.


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Yellow SRT: | Intake Manifold Pressure Sensor Circuit. Low voltage detected on the intake manifold pressure/temperature sensor. | Derate in power output of the engine.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold pressure and passes information to the engine control module (ECM) through the engine harness. If intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure/temperature sensor is located in the intake air manifold toward the front of the engine.

Shop Talk

  • Check for high restriction in the intake air manifold due to a shutdown device in the manifold if the vehicle is equipped with a shutdown device. Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature. Removing it could cause severe personal injury or death.
  • Check for installation of a torque limiting device breakout wiring harness. Temporarily remove the torque limiting device from the engine harness, and install the intake manifold pressure/temperature sensor directly to the engine harness. If Fault Code 123 becomes inactive, inspect the torque limiting device.
Refer to Troubleshooting Fault Code 123.

Last Modified: 17-Jan-2017


Accelerator Position Sensor Circuit

FAULT CODE 131

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | High voltage detected at accelerator position sensor. | Severe derate (power and speed). Limp home power only.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: (+) 5-VDC supply, return ground, and signal.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensor checks look good, then replace the accelerator position sensor and the idle validation switch circuit wires between the accelerator pedal and the ECM with new wires. Run the wires through or around the bulkhead, without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from entering the operator area.

The three wires in the accelerator position sensor circuit must be twisted together. The same applies for the three wires in the idle validation switch circuit.

Refer to Troubleshooting Fault Code t05-131.


Accelerator Position Sensor Circuit

FAULT CODE 132

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at the accelerator position sensor circuit. | Severe derate (power and speed). Limp home power only.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: (+) 5-VDC supply, return, and signal.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

  • Check for external circuits hooked into the accelerator position sensor circuit and for tampering in the circuit.
  • If all the wiring and the sensor checks are good, replace the accelerator position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires. If the fault code goes away, replace the OEM harness. Seal openings in the bulkhead to prevent toxic and noxious fumes from entering the operator area.
  • Verify that the three accelerator position sensor circuit wires are twisted together. Verify that the three idle validation switch circuit wires are twisted together.
Refer to Troubleshooting Fault Code t05-132.


Remote Throttle Position Sensor Circuit

FAULT CODE 133

Remote Throttle Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 974 FMI: 3/3 LAMP: Red SRT: | High voltage detected at the remote throttle position signal circuit. | None on performance if remote throttle is not used.
Remote Throttle Position Sensor Circuit

Circuit Description

The remote throttle pedal provides the driver's throttle command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote throttle pedal location varies with each OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The throttle position sensor is a potentiometer. The throttle position sensor resistance specifications are:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, Depressed = 200 to 1500 ohms

If the throttle or throttle position sensor is replaced, or after a calibration download is performed, cycle the throttle pedal (turn keyswitch on) through its complete travel three times. This procedure calibrates the new throttle with the ECM.

  • The remote throttle enable switch must be turned on for the remote throttle to operate.
  • Possible causes of this fault code include an open circuit in the return wire, short circuit to (+) 5 VDC or (+) 12 VDC, defective remote throttle position sensor, or a failed ECM power supply.
Refer to Troubleshooting Fault Code t05-133.


Remote Throttle Position Sensor Circuit

FAULT CODE 134

Remote Throttle Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at the remote throttle position signal circuit. | None on performance if remote throttle is not used.
Remote Throttle Position Sensor Circuit

Circuit Description

The remote throttle pedal provides the driver's throttle command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote throttle pedal location varies with each OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The remote throttle position sensor is a potentiometer. The throttle position sensor resistance specifications are:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, Depressed= 200 to 1500 ohms

If the remote throttle position sensor is replaced, or after a calibration download is performed, cycle the throttle pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new remote throttle with the ECM.

  • The remote throttle enable switch must be on for the remote throttle to operate.
  • Possible causes of this fault code include an open circuit in the supply wire, short circuit to ground in the supply or signal wires, defective remote throttle position sensor, or a failed ECM power supply.
Refer to Troubleshooting Fault Code t05-134.


Oil Pressure Sensor Circuit

FAULT CODE 135

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the oil pressure circuit. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.

Refer to Troubleshooting Fault Code t05-135.


Oil Pressure Sensor Circuit

FAULT CODE 141

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the oil pressure circuit. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

If Fault Code 143 or 415 is present, the problem is probably base engine related.

Refer to Troubleshooting Fault Code t05-141.


Engine Oil Pressure Low - Warning

FAULT CODE 143

Engine Oil Pressure Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Pressure Low - Warning. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Oil Pressure

Circuit Description

The engine oil pressure and engine temperature sensors are used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil pressure and engine temperature sensors are located on the cylinder block to the left of the fuel filter, behind the air compressor. See Section E for a detailed component location view.

Refer to Troubleshooting Fault Code t05-143.


Coolant Temperature Sensor Circuit

FAULT CODE 144

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the coolant temperature circuit. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located in front of the turbocharger.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your reading to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-144.


Coolant Temperature Sensor Circuit

FAULT CODE 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the coolant temperature circuit. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located in front of the turbocharger.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your reading to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145.


Frequency Throttle Circuit

FAULT CODE 147 (INDUSTRIAL)

Frequency Throttle Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 147 PID: P91 SPN: 091 FMI: 8/8 LAMP: Red SRT: | A frequency of less than 100 Hz was detected at frequency throttle signal pin of the actuator harness connector at the ECM. | Calibration-dependent power and speed derate.
Frequency Throttle Circuit

Circuit Description

The frequency throttle provides the driver's throttle command to the electronic control module (ECM) through the actuator harness and the OEM engine harness. The ECM uses this signal to determine the fueling command.

Component Location

Throttle location varies with each OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The frequency throttle can either be used in conjunction with a voltage throttle or by itself.

Refer to Troubleshooting Fault Code t05-147.


Frequency Throttle Circuit

FAULT CODE 148 (INDUSTRIAL)

Frequency Throttle Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 148 PID: P091 SPN: 91 FMI: 8/8 LAMP: Red SRT: | A frequency of more than 100 Hz was detected at the frequency throttle signal pin of the actuator harness connector at the ECM. | Calibration-dependent power and speed derate.
Frequency Throttle Circuit

Circuit Description

The frequency throttle provides the driver's throttle command to the electronic control module (ECM) through the OEM engine harness and the actuator harness. The ECM uses this signal to determine the fueling command.

Component Location

Throttle location varies with each OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The frequency throttle can be used either in conjunction with a voltage throttle or by itself.

Refer to Troubleshooting Fault Code t05-148.


Intake Manifold Temperature Sensor Circuit

FAULT CODE 153

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the intake manifold temperature circuit. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for coolant temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor is used by the ECM to monitor the temperature of the engine intake air. The ECM uses the intake manifold temperature signal for the engine protection system, timing, and fueling control.

Component Location

The intake manifold pressure/temperature sensor is located on the side of the intake manifold in front of the air inlet horn.

Shop Talk

Sensor resistance varies with the temperature. Compare your readings with this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153.


Intake Manifold Temperature Sensor Circuit

FAULT CODE 154

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the intake manifold temperature circuit. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for coolant temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor to monitor the temperature of the engine intake air. The ECM uses the intake manifold temperature signal for the engine protection system, timing, and fueling control.

Component Location

The intake manifold pressure/temperature sensor is on the side of the intake manifold in front of the air horn.

Shop Talk

The sensor resistance varies with the temperature. Compare your reading to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154.


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid but Above normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power and derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
ISX - Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold air temperature.

This fault code indicates that the intake manifold air temperature has exceeded the maximum engine protection limit.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold air temperature is greater than 93.3°C [200°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 10 of the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold air temperature sensor measures the temperature of the charge air as it passes through the intake manifold. Possible causes of this fault code include:

  • Restricted air flow through the charge air cooler
  • Undersize charge air cooler
  • High turbocharger compressor outlet temperature
  • For marine engines, verify the cooling water intake is not blocked or clogged with debris.
Refer to Troubleshooting Fault Code t05-155.


Sensor Voltage Supply

FAULT CODE 187

Sensor Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 620 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the ECM voltage supply line to some sensors (VSEN2 supply). | Engine will run derated. No engine protection for oil pressure or coolant level.
Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies each of these sensors with + 5-VDC. If the supply line to any sensor is damaged, the sensor will not work correctly.

Component Location

The front fuel rail pressure sensor is located on the fuel delivery housing.

Rear fuel rail pressure sensor is located on the fuel delivery housing.

Fuel inlet restriction sensor is located on the fuel delivery housing.

Oil pressure/temperature sensor is located below the air compressor.

Wet tank pressure sensor is located on the air compressor.

Coolant level sensor. Use the OEM troubleshooting and repair manual for proper location.

Top 2 transmission position sensor; located on the transmission if vehicle has a Spicer™ Top 2 Automate transmission. Use the OEM troubleshooting and repair manual for proper location.

Shop Talk

Low voltage on the sensor + 5-VDC supply line will be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time, unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. The engine may not start if the camshaft position sensor is unplugged.

Refer to Troubleshooting Fault Code t05-187.


ICON™ Lamp Circuit

FAULT CODE 198

ICON™ Lamp Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 198 PID: S122 SPN: 612 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the ICON™ lamp circuit when low voltage was expected by the ECM. | The ICON™ idle control system will be disabled. Only mandatory shutdown will be enabled.
ICON™ Lamp Circuit

Circuit Description

The ICON™ lamp circuit turns on the ICON™ lamp to indicate when the ICON™ system is active. In addition, ICON™ fault codes will be flashed on this lamp.

Component Location

The ICON™ lamp is typically located in the truck cab on the dashboard panel.

Shop Talk

This fault typically indicates a short circuit to battery voltage. This fault can not be flashed out on the ICON™ lamp. It can be read using INSITE™ or flashing the diagnostic code on the red and yellow lamps.

Refer to Troubleshooting Fault Code t05-198.


ICON™ Lamp Circuit

FAULT CODE 199

ICON™ Lamp Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 199 PID: S122 SPN: 612 FMI: 4/4 LAMP: Yellow SRT: | Less than (+) 6 VDC (low voltage) detected at the ICON™ lamp circuit when high voltage was expected by the ECM. | The ICON™ idle control system will be disabled. Only mandatory shutdown will be enabled.
ICON™ Lamp Circuit

Circuit Description

The ICON™ lamp circuit turns on the ICON™ lamp to indicate when the ICON™ system is active. In addition, ICON™ fault codes will be flashed out on this lamp.

Component Location

The ICON™ lamp is typically located in the vehicle cab on the dashboard panel.

Shop Talk

This fault typically indicates a short circuit to ground or an open circuit. A short circuit to ground can cause the ICON™ lamp to remain on continuously, regardless if ICON™ is enabled or disabled. An open circuit can be caused by a burned-out bulb. This fault code can not be flashed out on the ICON™ lamp. It can be read using INSITE™ or flashing the diagnostic code on the red and yellow lamps.

Refer to Troubleshooting Fault Code t05-199.


Oil Temperature Sensor Circuit

FAULT CODE 212

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the oil temperature circuit. | No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

Sensor resistance varies with temperature. Compare the resistance measurement to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-212.


Oil Temperature Sensor Circuit

FAULT CODE 213

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the oil temperature circuit. | No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition could be incurred, possibly leading to shutdown.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your readings with this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-213.


Engine Oil Temperature High - Data Valid But Above Normal Operational Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature High - Data Valid But Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature High - Data Valid But Above Normal Operational Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red Stop lamp starts flashing.
Engine Oil Temperature

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition could be incurred, possibly leading to shutdown.

Component Location

The engine oil temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor. See Section E for a detailed component location view.

Refer to Troubleshooting Fault Code t05-214.

Last Modified: 07-Jun-2011


Wet Tank Pressure Sensor Circuit

FAULT CODE 216

Wet Tank Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 216 PID: P046 SPN: 46 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at air compressor wet tank pressure signal circuit. | Air compressor will run continuously.
Wet Tank Pressure Sensor Circuit

Circuit Description

The wet tank pressure sensor provides the wet tank pressure signal to the electronic control module (ECM).

Component Location

The wet tank pressure sensor is located on the air compressor. It is part of the electronic air governor and is nonserviceable.

Shop Talk

This fault indicates that signal pin 19 on the ECM sensor port now has a short circuit to at least (+) 5 VDC.

Refer to Troubleshooting Fault Code t05-216.


Wet Tank Pressure Sensor Circuit

FAULT CODE 217

Wet Tank Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 217 PID: P046 SPN: 46 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at air compressor wet tank pressure sensor. | Air compressor will run continuously.
Wet Tank Pressure Sensor Circuit

Circuit Description

The wet tank pressure sensor provides the wet tank pressure signal to the electronic control module (ECM).

Component Location

The wet tank pressure sensor is located on the air compressor. It is part of the electronic air governor and is nonserviceable.

Shop Talk

This fault indicates that signal pin 19 on the ECM sensor port has a short circuit to ground.

Refer to Troubleshooting Fault Code t05-217.


Wet Tank Pressure Sensor Circuit

FAULT CODE 218

Wet Tank Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 218 PID: P046 SPN: 46 FMI: 2/2 LAMP: Yellow SRT: | Voltage at wet tank pressure signal indicates wet tank pressure is too high or too low. | Air compressor will run continuously.
Wet Tank Pressure Sensor Circuit

Circuit Description

The wet tank pressure sensor provides the wet tank pressure sensor signal to the electronic control module (ECM).

Component Location

The wet tank pressure sensor is located on the air compressor. It is part of the electronic air governor and is nonserviceable.

Shop Talk

This fault indicates that the pressure in the wet tank is lower or higher than specifications.

Refer to Troubleshooting Fault Code t05-218.


Ambient Air Pressure Sensor Circuit

FAULT CODE 221

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the ambient air pressure sensor circuit. | Derate in power output of engine.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor monitors atmospheric pressure and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The ambient air pressure sensor is located below ECM.

Shop Talk

Monitor the ambient air pressure reading with a service tool to confirm that the pressure reading matches the actual air pressure.

Refer to Troubleshooting Fault Code t05-221.


Ambient Air Pressure Sensor Circuit

FAULT CODE 222

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the ambient air pressure circuit. | Derate in power output of engine.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor monitors atmospheric pressure and passes information to the electronic control module (ECM) through the sensor harness.

Component Location

The ambient air pressure sensor is located below the ECM.

Shop Talk

Monitor the ambient air pressure reading with a service tool to confirm that the pressure reading matches the actual air pressure.

Refer to Troubleshooting Fault Code t05-222.


Burn Valve Solenoid

FAULT CODE 223

Burn Valve Solenoid

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S085 SPN: 1265 FMI: 4/4 LAMP: Yellow SRT: | Incorrect voltage detected at the Centinel™ actuator circuit by the ECM. | None on performance. Centinel™ deactivated.
Burn Valve Solenoid

Circuit Description

The burn valve solenoid controls the flow of oil into the fuel drainline during the burn cycle.

Component Location

The burn valve solenoid is on top of the oil control valve. The oil control valve is on the left side of the engine below the fuel delivery housing.

Refer to Troubleshooting Fault Code t05-223.


Sensor Voltage Supply

FAULT CODE 227

Sensor Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 620 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on the ECM voltage supply line to some sensors. | Engine will run derated. No engine protection for oil pressure or coolant level.
Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies each of these sensors with (+) 5 VDC. If the supply wire to any sensor is damaged, the sensor will not work correctly.

In the above picture, the circuits for the wet tank pressure sensor/air compressor and Top 2 Gear Position wires are labeled differently on the industrial wiring diagram. The equivalent differences in the industrial labels are as follows:

Wet Tank Pressure Sensor + 5-VDC Supply = OEM Pressure Supply (pins 1 to 18)

Wet Tank Pressure Signal = OEM Pressure Signal (pins 3 to 19)

Wet Tank Pressure Return = OEM Pressure Return (pins 2 to 20)

Air Compressor Actuator = Switched Output A (pins 5 to 14)

Air Compressor Return = Spare (pins 6 to 11)

Top 2 Gear Position + 5-VDC Supply = Spare (pins 14 to 19)

Top 2 Gear Position Input = Spare (pins 15 to 18)

Top 2 Gear Position Return = Spare (pins 16 to 17)

Component Location

1. Front rail pressure sensor is located on the fuel delivery housing.

2. Rear rail pressure sensor is located on the fuel delivery housing.

3. Fuel inlet restriction sensor is located on the fuel delivery housing.

4. Oil pressure/temperature sensor is located below the air compressor (automotive only).

5. Wet tank pressure sensor is located on the air compressor (automotive only).

6. Coolant level sensor. Use the OEM troubleshooting and repair manual for proper location.

7. Top 2 transmission position sensor - located on the transmission if vehicle has a Spicer™ Top 2 transmission. Use the OEM troubleshooting and repair manual for proper location (automotive only).

Shop Talk

High voltage on the sensor (+) 5 VDC supply line will be caused by a short circuit to battery in the supply wire or a short circuit between an actuator wire and the supply wire.

Refer to Troubleshooting Fault Code t05-227.


Engine Overspeed

FAULT CODE 234

Engine Overspeed

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine speed signal indicated engine speed is greater than 2650 rpm. | Fuel shutoff valve closed until the engine speed falls to 2000 rpm.
Engine Overspeed Circuit

Circuit Description

The crankshaft and camshaft engine speed/position sensor provides engine speed and position information to the electronic control module (ECM) through the engine harness.

Component Location

The crankshaft engine speed/position sensor is located in the front cover on the intake side of the engine.

The camshaft engine speed/position sensor is located on the intake side of the cylinder head.

Shop Talk

Possible causes of this fault code include external fuel sources drawn into the intake air passage, reverse powering (motoring) of the engine, and tampering of the engine speed/position sensors.

  • Inspect the intake manifold for sources of flammable vapors.
  • Check the turbocharger seals to verify that there are no oil leaks.
  • Inspect the engine speed/position sensors for damage or tampering.
Refer to Troubleshooting Fault Code t05-234.


Engine Coolant Level - Engine Protection

FAULT CODE 235

Engine Coolant Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant level signal at pin 22 of the sensor harness connector indicates coolant level is below the normal range. | Progressive power and speed derate with increasing time after alert. If engine protection shutdown is enabled, engine will shut down 30 seconds after the engine protection lamp starts flashing.
Engine Coolant Level - Engine Protection

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness. Because this sensor is complex, do not use a multimeter to check it. If the radiator coolant level drops below a certain level, a progressive power and/or speed derate will occur. Engine can shut down if the engine protection shutdown feature is enabled.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and can vary in location.

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the Weather-Pack four-way connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle turns a corner.
Refer to Troubleshooting Fault Code t05-235.


Vehicle Speed Sensor Circuit

FAULT CODE 241

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2/2 LAMP: Yellow SRT: | The ECM lost the vehicle speed signal. | Engine speed limited to "Maximum Engine Speed without Vehicle Speed Sensor" parameter value. Cruise control, gear-down protection and road speed governor will not work (automotive only).
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor uses two separate coils of wire to count gear teeth as they pass in front of the sensor. One coil is used by the electronic control module (ECM) to sense vehicle speed. The other coil is sometimes used to send a vehicle speed signal to the speedometer.

Component Location

The vehicle speed sensor is installed in the rear of the transmission.

Shop Talk

  • Disconnect the vehicle speed sensor connector that connects to the OEM speedometer, or trip recorder, and move the truck. If the fault goes inactive, there is probably electrical noise being fed into the vehicle speed sensor circuit from the OEM device.
  • Verify the vehicle speed sensor wires in the OEM harness are twisted pairs.
Refer to Troubleshooting Fault Code t05-241.


Vehicle Speed Sensor Circuit

FAULT CODE 242

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 84 FMI: 10/10 LAMP: Yellow SRT: | Invalid or inappropriate vehicle speed signal detected. Signal indicates an intermittent connection or vehicle speed sensor tampering. | Engine speed limited to maximum engine speed without vehicle speed sensor parameter value. Cruise control, progressive shifting, gear-down protection, and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor uses two separate coils of wire to count gear teeth as they pass in front of the sensor. One coil is used by the ECM to sense vehicle speed. The other is sometimes used by the OEM to send a vehicle speed signal to the speedometer.

Component Location

The vehicle speed sensor is installed in the rear of the transmission.

Shop Talk

  • Verify that the feature settings for vehicle speed sensor antitampering (Fault Code 242), application type, and automatic transmission are set correctly. If any of these are set incorrectly, Fault Code 242 could occur erroneously.

Driving techniques, such as driving for extended periods of time in lower gears, could log Fault Code 242.

  • Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.
  • Interview the driver to discover what occurred when the fault code was logged. Explain the driver actions that can cause Fault Code 242 to be logged.
  • When deactivating the fault, verify that the vehicle is stopped and the engine is shut down.
  • Verify that the keyswitch has been cycled and has remained in the ON position for 30 seconds after the invalid signal has been corrected. This fault will remain active until the keyswitch is cycled and the ECM sees zero vehicle speed and zero engine speed for 30 seconds.
Refer to Troubleshooting Fault Code t05-242.


Engine Fan Clutch Supply Circuit

FAULT CODE 245

Engine Fan Clutch Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4/4 LAMP: Yellow SRT: | Less than 6 VDC detected at fan clutch when on. Indicates an excessive current draw from the electronic control module (ECM) or a faulty ECM output circuit. | The fan can stay on all the time.
Engine Fan Clutch Supply Circuit

Circuit Description

The fan clutch solenoid is a device used by the ECM to control the engine fan by sending a signal to open or close the fan clutch solenoid.

Component Location

See the OEM diagram for the location of the fan clutch solenoid.

Shop Talk

Possible cause for this fault code:

  • ECM fan clutch supply has a short circuit to ground.
Refer to Troubleshooting Fault Code t05-245.


Ambient Air Temperature Sensor Circuit

FAULT CODE 249

Ambient Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the ambient air temperature circuit. | No effect on engine performance. The idle shutdown ambient air temperature override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override (automotive only).
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the ambient air. The ambient air temperature signal is used by the ECM for the idle shutdown ambient air temperature override and ICON™ features.

Component Location

The ambient air temperature sensor location is OEM-dependent. Use the OEM troubleshooting and repair manual.

Shop Talk

The resistance of the sensor varies with the temperature. The reading you observe should compare to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-249.


Fuel Shutoff Valve Solenoid Supply Circuit

FAULT CODE 254

Fuel Shutoff Valve Solenoid Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Less than (+) 6 VDC detected at fuel shutoff circuit or an excessive current draw from the electronic control module (ECM) or faulty ECM output circuit. | The ECM turns off the fuel shutoff supply voltage. The engine will shut down.
Fuel Shutoff Valve Solenoid Supply Circuit

Circuit Description

The fuel shutoff valve solenoid is a device used by the ECM to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel shutoff valve solenoid.

Component Location

The fuel shutoff valve solenoid is located on the fuel delivery housing above the fuel filter.

Shop Talk

  • Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit.
  • If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and pulled down the voltage on the fuel shutoff circuit.
  • Inspect the engine-block-to-chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.
  • Check the starter solenoid (+) terminal for a loose connector or accessory wiring with damaged insulation.
Refer to Troubleshooting Fault Code t05-254.


Engine Fuel Shutoff Valve Drive Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Drive Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S017 SPN: 632 FMI: 3/3 LAMP: Yellow SRT: | Engine Fuel Shutoff Valve Drive Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or short to voltage source detected at fuel shutoff valve circuit. | None on performance. Fuel shutoff valve stays on.
Engine Fuel Shutoff Valve Drive Circuit

Circuit Description

If voltage is externally supplied to the fuel shutoff valve, it will stay open.

Component Location

The fuel shutoff valve solenoid is located on the fuel delivery housing, below the air inlet horn. The solenoid is controlled by the ECM.

Shop Talk

If there is an external shutdown system on the vehicle, make sure it is not miswired and feeding voltage into the fuel shutoff supply circuit.

Refer to Troubleshooting Fault Code t05-255.


Ambient Air Temperature Sensor Circuit

FAULT CODE 256

Ambient Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the ambient air temperature circuit. | No effect on engine performance. The idle shutdown ambient air temperature override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override (automotive only).
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the ambient air. The ambient air temperature signal is used by the ECM for the idle shutdown ambient air temperature override and ICON™ features.

Component Location

The ambient air temperature sensor location is OEM dependent. Use the OEM troubleshooting and repair manual.

Shop Talk

The resistance of the sensor varies with the temperature. The reading you observe should compare to this table:

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-256.


Fuel Shutoff Valve

FAULT CODE 259

Fuel Shutoff Valve

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 259 PID: S017 SPN: 632 FMI: 7/7 LAMP: Yellow SRT: | The ECM detected that the fuel shutoff valve is stuck open mechanically or leaking. | Engine will have a torque derate.
Fuel Shutoff Valve

Circuit Description

Voltage is supplied to the fuel shutoff valve by the ECM while the engine keyswitch is ON. When the keyswitch is OFF, the voltage to the fuel shutoff valve is turned off by the ECM. The fuel shutoff valve closes and stops fuel from flowing to the fueling and timing actuators.

Component Location

The fuel shutoff valve is located on the fuel delivery housing, below the air inlet horn.

Shop Talk

Upon turning the keyswitch off, the ECM turns off the voltage supplied to keep the fuel shutoff open. The ECM continues to fire the fueling and timing actuators as the engine spins down. The ECM monitors fuel pressure using the fuel pressure sensor during this time. If the fuel pressure does not drop after the fuel shutoff valve is turned off, the ECM activates this fault.

Refer to Troubleshooting Fault Code t05-259.


Sensor Supply Voltage

FAULT CODE 284

Sensor Supply Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 284 PID: P221 SPN: 1043 FMI: 4/4 LAMP: Yellow SRT: | Incorrect voltage detected on the electronic control module (ECM) voltage supply wire to the crankshaft engine position sensor. | Engine can possibly not run or will run derated. Possible hard starting, low power, or white smoke.
Sensor Supply Circuit

Circuit Description

The ECM supplies the crankshaft engine position sensor with (+) 5 VDC. If the supply wire to any sensor is damaged, the sensor will not work correctly.

Component Location

The crankshaft engine position sensor is located in the front cover on the intake side of the engine.

Shop Talk

Incorrect voltage on the sensor (+) 5 VDC supply line will be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-284.


J1939 Datalink Multiplexing

FAULT CODE 285

J1939 Datalink Multiplexing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Yellow SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough, or did not receive it at all. | At least one multiplexed device will not operate properly.
J1939 Datalink Multiplexing Circuit

Circuit Description

Inputs such as throttle pedals, switches, and sensors can be communicated to the ECM over the J1939 datalink. Messages sent from the vehicle electronic control units (VECU) are received by the ECM and used for controlling the engine. Both the ECM and VECU must be properly configured so that each device's information is transmitted by the VECU and received by the ECM.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 datalink wiring and VECU(s) vary by OEM options.

Shop Talk

This fault occurs when the ECM is set up to receive information about a multiplexed device from a VECU over the J1939 datalink and does not receive a message with that information. This fault can also be caused if the ECM does not get the information fast enough to control the engine properly. This condition can be caused by the J1939 datalink having an electrical problem, a lack of terminating plugs on the J1939 datalink backbone, the ECM not being set up to receive information, a multiplexed device that truly is not multiplexed, or a VECU not being correctly set up to transmit information on one of its multiplexed devices.

Refer to Troubleshooting Fault Code t05-285.


J1939 Datalink Multiplexing

FAULT CODE 286

J1939 Datalink Multiplexing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Yellow SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
J1939 Datalink Multiplexing Circuit

Circuit Description

Inputs such as throttle pedals, switches, and sensors can be communicated to the ECM over the J1939 datalink. Messages sent from the vehicle electronic control units (VECU) are received by the ECM and used for controlling the engine. Both the ECM and VECU must be properly configured so that each device's information is transmitted by the VECU and received by the ECM.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 datalink wiring and VECU(s) vary by OEM options.

Shop Talk

This fault occurs when the ECM is set up to receive information from several multiplexed switches from VECU(s) and only gets some of the switches. It indicates the ECM is setup to receive too many switches or the VECU(s) is set up to transmit too few switches.

Refer to Troubleshooting Fault Code t05-286.


OEM Temperature Sensor Circuit

FAULT CODE 293 (INDUSTRIAL)

OEM Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 293 PID: S154 SPN: 1083 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on the OEM temperature sensor signal pin of the 31-pin OEM connector. | No engine protection for OEM temperature.
OEM Temperature Sensor Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM temperature. The OEM temperature is used by the ECM for the engine protection system. A sensor that has failed high can be caused by an open circuit in the signal or return wire, voltage shorts in the signal or return wire, or a faulty sensor.

Component Location

The location varies with the OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The resistance of all temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-293.


OEM Temperature Sensor Circuit

FAULT CODE 294 (INDUSTRIAL)

OEM Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 294 PID: S154 SPN: 1083 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the OEM temperature sensor signal pin of the 31-pin OEM connector. | No engine protection for OEM temperature.
OEM Temperature Sensor Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM temperature. The OEM temperature is used by the ECM for the engine protection system. A sensor that has failed low can be caused by a short circuit to ground on a supply or return wire, or an internally grounded (faulty) sensor.

Component Location

The location varies with the OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The resistance of all temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-294.


Ambient Air Pressure Sensor

FAULT CODE 295

Ambient Air Pressure Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2 LAMP: Yellow SRT: | An error in the ambient air pressure sensor signal was detected by the ECM. | Engine is derated to no air setting.

Component Location

The ambient air pressure sensor is located below the ECM.

Shop Talk

At key-on, the readings for ambient pressure from the ambient air pressure sensor, intake manifold pressure sensor, and oil pressure sensor are compared. This fault code occurs if the ambient air pressure sensor reading is different from the other two.

Refer to Troubleshooting Fault Code t05-295.


OEM Pressure Sensor Circuit

FAULT CODE 297 (INDUSTRIAL)

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 297 PID: S223 SPN: 1084 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the OEM pressure sensor signal pin. | No engine protection for OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM pressure. The OEM pressure is used by the ECM for the engine protection system. A sensor that has failed high can be caused by an open circuit in the signal or return wire, a voltage short in the signal or return wire, or a faulty sensor.

Component Location

The location varies with the OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The sensor voltage signal is supplied by the ECM on pin 18 of the sensor harness connector.

Refer to Troubleshooting Fault Code t05-297.


OEM Pressure Sensor Circuit

FAULT CODE 298 (INDUSTRIAL)

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 298 PID: S223 SPN: 1084 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the OEM pressure sensor signal pin of the 31-pin OEM connector. | No engine protection for OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM pressure. The OEM pressure is used by the ECM for the engine protection system. A sensor that has failed low can be caused by a short circuit to ground on the signal wire, or an internally grounded (faulty) sensor.

Component Location

The location varies with the OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The resistance of all pressure sensors varies with the pressure. Use the OEM troubleshooting and repair manual for specifications.

Refer to Troubleshooting Fault Code t05-298.


Real-Time Clock Power Circuit

FAULT CODE 319

Real-Time Clock Power Circuit

Printable Version Printable Version

Overview

Real-Time Clock Power Circuit

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real-time clock lost power. | None on performance. Data in the ECM will not have accurate time and date information.
Real-Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the ECM is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery backup module (if equipped).

Component Location

The real-time clock battery backup module is secured to the wiring harness in the vicinity of the ECM.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault:

  • A weak or failed battery backup module
  • Failed wiring or connectors between the battery backup module and ECM
  • The engine is not equipped with a battery backup module, and lost vehicle battery power to the ECM.
Refer to Troubleshooting Fault Code t05-319.


Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

FAULT CODE 338

Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S087 SPN: 1267 FMI: 3/3 LAMP: Yellow SRT: | Voltage detected on the idle shutdown vehicle accessory/ignition bus relay circuit when no voltage was being supplied by the ECM or an open circuit was detected. | Vehicle accessories or ignition bus loads controlled by the idle shutdown vehicle accessory relay will not power up.
Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

Circuit Description

The idle shutdown vehicle accessory/ignition bus relay is a device used to control vehicle accessories or ignition bus loads. Vehicle accessories or ignition bus loads will be shut down when the ECM shuts down the engine for excessive idle time.

Component Location

The location of the relay is dependent on the OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

Typically, this fault code indicates a short circuit to battery or an open circuit.

Refer to Troubleshooting Fault Code t05-338.


Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

FAULT CODE 339

Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S087 SPN: 1267 FMI: 4/4 LAMP: Yellow SRT: | Less than (+) 6 VDC detected on the idle shutdown vehicle accessory/ignition bus relay circuit when on indicates an excessive current draw from the ECM or faulty ECM output circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown vehicle accessory relay will not power down.
Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

Circuit Description

The idle shutdown vehicle accessory/ignition bus relay is a device used to control vehicle accessories or ignition bus leads. Vehicle accessories or ignition bus leads will be shut down when the ECM shuts down the engine for excessive idle time.

Component Location

The location of the relay is dependent on the OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

  • Check the starter solenoid positive (+) terminal for a loose connector or accessory wiring with damaged insulation.
  • Low voltage can be caused by a short circuit to ground, a short circuit to another wire in the harness, or a solenoid coil with a short circuit.
  • Inspect the engine block to chassis ground wire. It should be securely fastened to a clean, dry, conductive surface.
Refer to Troubleshooting Fault Code t05-339.


Unswitched Battery Supply Circuit

FAULT CODE 341

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 341 PID: S253 SPN: 630 FMI: 2/2 LAMP: Yellow SRT: | Severe loss of data from the ECM. | Possibly no noticeable performance effects, or engine dying, or difficulty in starting the engine. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There are two in-line 15-amp fuses in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Use the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-341.


Electronic Control Module Warning Internal Hardware Failur - Bad Intelligent Device or Component

FAULT CODE 343

Electronic Control Module Warning Internal Hardware Failur - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Yellow SRT: | Internal ECM error. | Possibly none on performance, or severe derate.
Electronic Control Module (ECM)

Circuit Description

The ECM monitors both signal voltage output to the actuators and ECM input from the engine position sensor.

Component Location

The ECM is bolted to the intake side of the cylinder head between the air inlet horn and the front of the engine. Refer to Procedure 100-002 in Section E for component location.

Shop Talk

  • Loose engine or chassis ground connections can cause Fault Code 343 to be logged. Pay special attention to the negative starter post connection.
  • Moisture in the ECM connectors can also cause the ECM to log Fault Code 343. Symptoms can include intermittent stumble or rough running.

It is always a good idea to check the resistance of the meter leads by reading the resistance displayed by the tool when touching the positive and negative leads together. Subtract this reading from any readings taken for resistance. This will provide a more accurate resistance measurement.

Always reapply dielectric grease when reconnecting an electrical connection.

Refer to Troubleshooting Fault Code t05-343.

Last Modified: 23-Jan-2014


Auxiliary Speed Governor

FAULT CODE 349 (INDUSTRIAL)

Auxiliary Speed Governor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 349 PID: P191 FMI: 0/16 LAMP: Yellow SRT: | A frequency greater than calibrated threshold was detected at the tailshaft governor signal pin of the 31-pin connector. | Calibration-dependent power and speed derate.
Auxiliary Speed Governor Circuit

Circuit Description

The auxiliary speed governor provides a means to govern the engine independent of engine speed. This circuit controls output shafts or other devices downstream of a torque convertor.

The auxiliary speed governor provides a means to control the output shafts or other devices downstream of a torque convertor, independent of engine speed.

Component Location

The auxiliary speed governor location varies with the OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

This fault can only be caused by a high-frequency input into the auxiliary speed governor circuit.

Refer to Troubleshooting Fault Code t05-349.


Sensor Voltage Supply

FAULT CODE 352

Sensor Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 620 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the electronic control module (ECM) voltage supply line to some of the sensors. | Engine is derated to no-air setting.
Sensor Supply Circuit

Circuit Description

The electronic control module (ECM) supplies each of these sensors with(+) 5 VDC. If the supply line to any sensor is damaged, the sensor will not work correctly.

Component Location

Intake manifold pressure/temperature sensor is located on the intake manifold housing.

Ambient air pressure sensor is located below the ECM.

Fuel pressure sensor is located on the fuel manifold housing.

Shop Talk

Low voltage on the sensor (+) 5-VDC supply line will be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-352.


ICON™ Idle Control System

FAULT CODE 359

ICON™ Idle Control System

Printable Version Printable Version

Overview

ICON™ Idle Control System

CODE | REASON | EFFECT
Fault Code: 359 PID: S124 SPN: 613 FMI: 11/31 LAMP: Yellow SRT: | ICON™ has failed to start the engine automatically. | ICON™ will be disabled. Only mandatory shutdown will be enabled. You may or may not be able to start the engine normally.
ICON™ Idle Control System

Circuit Description

The starter relay/interlock circuit controls and monitors both the starter relay coil and the ICON™ interlocks. The starter relay is used by the ICON™ feature to perform automatic starts of the engine. The interlocks are used by the ICON™ feature to monitor if the transmission is in neutral, the position of the hood/cab, and if the parking brakes are set.

Component Location

The location of the starter relay, parking brake switch, neutral position switch, and hood tilt switch vary between OEMs. Consult the specific OEM troubleshooting and repair manual for the exact location.

Shop Talk

This fault code is set if 2 consecutive attempts at starting fail. If a start is commanded by the ECM and neither 200 rpm is reached within 2 seconds nor 450 rpm is reached within 14 seconds, the start failed. After the first failure, the ECM waits 1 minute and then tries again. If the second start attempt fails, the fault is set. It is cleared as soon as a manual start is successful.

Refer to Troubleshooting Fault Code t05-359.


Actuator Circuit

FAULT CODE 378

Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 378 PID: S018 SPN: 633 FMI: 5/5 LAMP: Yellow SRT: | Low current or open circuit detected at front fueling actuator circuit. | Engine will run using only the rear three cylinders.
Front Fueling Actuator Circuit

Circuit Description

The fuel actuators are actuated by the electronic control module (ECM) to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front fueling actuator is mounted on the fuel delivery housing. It is the actuator closest to the front of the engine.

Shop Talk

The possible failure modes are open circuit, short circuit to ground, high actuator resistance, supply wire shorted to battery, and loss of boost voltage inside of ECM.

Refer to Troubleshooting Fault Code t05-378.


Actuator Circuit

FAULT CODE 379

Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 379 PID: S018 SPN: 633 FMI: 6/6 LAMP: Yellow SRT: | High current detected at front fueling actuator circuit. | Engine will run using only the rear three cylinders.
Front Fueling Actuator Circuit

Circuit Description

The fuel actuators are actuated by the electronic control module (ECM) to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front fueling actuator is mounted on the fuel delivery housing. It is the actuator closest to the front of the engine.

Shop Talk

The possible failure modes are short circuit to battery, low actuator resistance, or short circuit between supply and return wires.

Refer to Troubleshooting Fault Code t05-379.


Sensor Voltage Supply

FAULT CODE 386

Sensor Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 1079 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on the electronic control module (ECM) voltage supply wire to the sensors (VSEN1 supply). | Engine is derated to no-air setting.
Sensor Voltage Supply Circuit

Circuit Description

The electronic control module (ECM) supplies each of these sensors with positive (+) 5 VDC. If the supply wire to any sensor is damaged, the sensor will not work correctly.

Component Location

There are three components involved in the sensor voltage supply: Intake manifold pressure/temperature sensor, ambient air pressure/temperature sensor, and the fuel pressure sensor. See Section E for component location.

Shop Talk

High voltage on the sensor (+) 5-VDC supply wire will be caused by a short circuit to battery of the supply wire or a short circuit between an actuator wire and the supply wire.

Refer to Troubleshooting Fault Code t05-386.


Throttle Voltage Supply

FAULT CODE 387

Throttle Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 387 PID: P221 SPN: 1043 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on the ECM voltage supply line to the throttle(s) (VTP supply). | Engine will only idle.
Throttle Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies the throttle and remote throttle with (+) 5 VDC. If the supply line to the throttles is damaged, the throttle will not work correctly.

Component Location

The throttle pedal is located in the cab. Use the OEM troubleshooting and repair manual for the location of the remote throttle.

Shop Talk

High voltage on the (+) 5-VDC supply line will be caused by a short circuit to battery of the supply line or a short circuit between an actuator and the supply line.

Refer to Troubleshooting Fault Code t05-387.


Engine Brake Supply Circuit

FAULT CODE 388

Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 388 PID: S079 SPN: 1072 FMI: 11/11 LAMP: Yellow SRT: | Less than (+) 6 VDC detected at engine brake circuit 1 when on. Indicates an excessive current draw from the ECM or a faulty ECM output circuit. | Engine brake on cylinder number 1 can not be activated.
Engine Brake Relay Supply Circuit

Circuit Description

The electronic control module (ECM) enables the engine brake by sending a signal directly to the engine brakes. The ECM will only enable the engine brakes under certain operating conditions.

Component Location

The engine brakes are located under the valve cover. The 8-pin engine brake connector is located on the intake side of the head above the inlet air horn. The engine brake solenoid for cylinder number 1 is the forward-most of the three engine brake solenoids.

Shop Talk

Possible causes for this fault code include:

  • ECM engine brake circuit 1 shorted to ground
  • This fault code is not used when a three-level engine braking harness (ICON™) is installed.
Refer to Troubleshooting Fault Code t05-388.


Engine Brake Supply Circuit

FAULT CODE 392

Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 392 PID: S029 SPN: 1073 FMI: 11/11 LAMP: Yellow SRT: | Less than (+) 6 VDC detected at engine brake circuit 2 when on indicates an excessive current draw from the electronic control module (ECM) or a faulty ECM output circuit. | Engine brakes on cylinders number 2 and 3 can not be activated.
Engine Brake Relay Supply Circuit

Circuit Description

The ECM enables the engine brake by sending a signal directly to the engine brakes. The ECM will only enable the engine brakes under certain operating conditions.

Component Location

The engine brakes are located under the valve cover.

Shop Talk

Possible causes for this fault code include:

  • ECM engine brake circuit 2 has a short circuit to ground.
Refer to Troubleshooting Fault Code t05-392.


Engine Brake Supply Circuit

FAULT CODE 393

Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 393 PID: S082 SPN: 1112 FMI: 11/11 LAMP: Yellow SRT: | Less than (+) 6-VDC detected at engine brake circuit 3 when on; this indicates an excessive current draw from the ECM or a faulty ECM output circuit. | The engine brakes can not be activated on cylinders Number 4, 5, and 6 (for six-level engine brake harness), or engine brakes can not be activated on cylinders Number 1, 4, 5, and 6 (for three-level engine brake harness).
Engine Brake Relay Supply Circuit

Circuit Description

The ECM enables the engine brake by sending a signal directly to the engine brakes. The ECM will only enable the engine brakes under certain operating conditions.

Component Location

The engine brakes are located under the valve cover.

Shop Talk

Possible cause for this fault code:

  • ECM engine brake circuit 3 has a short circuit to ground.
Refer to Troubleshooting Fault Code t05-393.


Actuator Circuit

FAULT CODE 394

Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 394 PID: S020 SPN: 635 FMI: 5/5 LAMP: Yellow SRT: | Low current or open circuit detected at front timing actuator circuit. | Engine is run using only the rear three cylinders.
Front Timing Actuator Circuit

Circuit Description

The timing actuators are actuated by the electronic control module (ECM) to control fuel metering. Each timing actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the timing actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front timing actuator is mounted on the fuel delivery housing. It is the second actuator from the front of the engine.

Shop Talk

The possible failure modes are open circuit, short circuit to ground, high actuator resistance, and loss of boost voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-394.


Actuator Circuit

FAULT CODE 395

Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 395 PID: S020 SPN: 635 FMI: 6/6 LAMP: Yellow SRT: | High current detected at front timing actuator circuit. | Engine is run using only the rear three cylinders.
Front Timing Actuator Circuit

Circuit Description

The timing actuators are actuated by the electronic control module (ECM) to control fuel timing. Each timing actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the timing actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front timing actuator is mounted on the fuel delivery housing. It is the second actuator from the front of the engine.

Shop Talk

The possible failure modes are short circuit to battery, low actuator resistance, or short circuit between supply and return wires.

Refer to Troubleshooting Fault Code t05-395.


Actuator Circuit

FAULT CODE 396

Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 396 PID: S083 SPN: 1244 FMI: 5/5 LAMP: Yellow SRT: | Low current or open circuit detected at rear fueling actuator circuit. | Engine will run using only the front three cylinders.
Rear Fueling Actuator Circuit

Circuit Description

The fuel actuators are actuated by the electronic control module (ECM) to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear fueling actuator is mounted on the fuel delivery housing. It is the actuator closest to the rear of the engine.

Shop Talk

The possible failure modes are an open circuit, short to ground, and high actuator resistance.

Refer to Troubleshooting Fault Code t05-396.


Actuator Circuit

FAULT CODE 397

Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 397 PID: S083 SPN: 1244 FMI: 6/6 LAMP: Yellow SRT: | High current detected at rear fueling actuator circuit. | Engine will run using only the front three cylinders.
Rear Fueling Actuator Circuit

Circuit Description

The fuel actuators are actuated by the electronic control module (ECM) to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear fueling actuator is mounted on the fuel delivery housing. It is the actuator closest to the rear of the engine.

Shop Talk

The possible failure modes are short circuit to battery, low actuator resistance, or short circuit between supply and return.

Refer to Troubleshooting Fault Code t05-397.


Actuator Circuit

FAULT CODE 398

Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 398 PID: S084 SPN: 1245 FMI: 5/5 LAMP: Yellow SRT: | Low current or open circuit detected at rear timing actuator circuit. | Engine is run using only the front three cylinders.
Rear Timing Actuator Circuit

Circuit Description

The timing actuators are actuated by the electronic control module (ECM) to control fuel metering. Each timing actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the timing actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear timing actuator is mounted on the fuel delivery housing. It is the third actuator from the front of the engine.

Shop Talk

The possible failure modes are an open circuit, a short circuit to ground, high actuator resistance, and loss of boost voltage inside of ECM.

Refer to Troubleshooting Fault Code t05-398.


Actuator Circuit

FAULT CODE 399

Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 399 PID: S084 SPN: 1245 FMI: 6/6 LAMP: Yellow SRT: | High current detected at rear timing actuator circuit. | Engine is run using only the front three cylinders.
Rear Timing Actuator Circuit

Circuit Description

The timing actuators are actuated by the electronic control module (ECM) to control fuel timing. Each timing actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the timing actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear timing actuator is mounted on the fuel delivery housing. It is the third actuator from the front of the engine.

Shop Talk

The possible failure modes are short circuit to battery, low actuator resistance, or short circuit between supply and return.

Refer to Troubleshooting Fault Code t05-399.


Engine Oil Pressure Low - Critical

FAULT CODE 415

Engine Oil Pressure Low - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Pressure Low - Critical. Engine oil pressure signal indicates engine oil pressure below the engine protection critical limit. | Progressive engine speed derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red Stop lamp starts flashing.
Engine Oil Pressure

Circuit Description

The engine oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM) through the engine harness. If the oil pressure becomes too low, based on engine speed, it will cause a derate condition. If the engine protection shutdown is enabled, the engine will shut down 30 seconds after the red stop lamp starts flashing.

Component Location

The engine oil pressure sensor is located on the left side of the engine block, below and to the rear of the integrated fuel system module (IFSM). Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The engine oil pressure sensor measures the pressure of the oil in the oil rifle on the left-hand side of the engine block.

Possible causes of this fault code include:

  • Mechanical failures such as lubricating oil pump, lubricating oil high pressure relief valve, loose lubricating oil filter
  • Breakdown or contamination of lubricating oil
  • Plugged lubricating oil filter.
Refer to Troubleshooting Fault Code t05-415.


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
Water In Fuel (WIF) Sensor Circuit

Circuit Description

The Water in Fuel sensor is attached to the fuel filter. The Water in Fuel sensor is used to indicate high water accumulation in the fuel filter.

Component Location

The Water in Fuel sensor is installed in the fuel filter and is located on the side of the head, approximately mid-engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that water in the fuel filter is above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM will turn off the flashing amber MAINTENANCE light immediately after the water has been drained from the fuel filter.

Conditions for Clearing the Fault Code

The ECM will turn off the flashing amber MAINTENANCE light immediately after the water has been drained from the fuel filter.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water in Fuel sensor is a likely cause.

Refer to Troubleshooting Fault Code t05-418.

Last Modified: 12-Jun-2017


Intake Manifold Pressure Sensor

FAULT CODE 419

Intake Manifold Pressure Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 419 PID: P102 SPN: 1319 FMI: 2 LAMP: Yellow SRT: | An error in the intake manifold pressure sensor signal was detected by the ECM. | Engine is derated to no-air setting.

Component Location

The intake manifold pressure sensor is located in the air intake manifold toward the front of the engine.

Shop Talk

At key-on, the readings for ambient pressure from the ambient air pressure sensor, intake manifold pressure sensor, and oil pressure sensor are compared. This fault code occurs if the intake manifold pressure sensor reading is different from the other two.

Refer to Troubleshooting Fault Code t05-419.


Coolant Level Sensor Circuit

FAULT CODE 422

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2/2 LAMP: Yellow SRT: | Voltage detected simultaneously on both the coolant level high and low signal circuits or no voltage detected on both circuits. | No engine protection for coolant level.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the sensor harness. This sensor is very complex. Do not use a multimeter to check the coolant level sensor. If the radiator coolant level drops below a certain level, a power derate will occur and become greater as time goes by.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

Possible causes for this fault code include:

  • Open circuit
  • Short circuit to ground
  • Short circuit to another wire.
Refer to Troubleshooting Fault Code t05-422.


J1939 Datalink Communication

FAULT CODE 426

J1939 Datalink Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | Communication between the electronic control module (ECM) and another device on the J1939 datalink has been lost. | None on performance. J1939 devices possibly do not operate.
J1939 Datalink Circuit

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and VECUs can communicate with the ECM over the J1939 datalink. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the J1939 datalink.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 datalink wiring and the J1939 devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the J1939 datalink and then can no longer transmit on the datalink. Possible causes could be the following: Unplugging an electronic service tool before keying off the ECM, the J1939 datalink having an intermittent electrical problem, the ECM (or another J1939 device) tying up communications by an electrical problem, or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-426.


Water-In-Fuel (WIF) Sensor Circuit

FAULT CODE 428

Water-In-Fuel (WIF) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at water-in-fuel (WIF) sensor circuit. | None on performance.
Water-In-Fuel (WIF) Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The water-in-fuel sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contain two wires: A return ground (pin 10) and a signal wire (pin 9).

Component Location

The water-in-fuel sensor is installed in the fuel filter and is located on the side of the head, approximately midengine.

Shop Talk

Possible causes for this fault code include:Short circuit to a (+) 5-VDC supply wire.

Refer to Troubleshooting Fault Code t05-428.


Water-In-Fuel (WIF) Sensor Circuit

FAULT CODE 429

Water-In-Fuel (WIF) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at water-in-fuel (WIF) sensor circuit. | None on performance.
Water-In-Fuel (WIF) Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The water-in-fuel sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires: A return ground (pin 10) and a signal wire (pin 9).

Component Location

The water-in-fuel sensor is installed in the fuel filter and is located on the side of the head approximately midengine.

Shop Talk

The water-in-fuel sensor uses the same internal ECM power supply as sensors on engine harness. If Fault Code 352 is also active, use that troubleshooting logic and tree.

Refer to Troubleshooting Fault Code t05-429.


Fault Code Path Selection

FAULT CODE 72-fc431
Fault Code Path Selection

Do you have an NISS throttle pedal? | Go to 72-fc431niss
Do you have an ISS throttle pedal? | Go to 72-fc431iss
Do you have an SSS throttle pedal? | Go to 72-fc431sss

Last Modified: 25-Feb-2005


Idle Validation Switch Circuit

FAULT CODE 431

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle signal pins. | None on performance.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired idle validation switch.
  • The integrated sensor switch (ISS) has a different idle validation switch (IVS) resistance specification (125 ohms) as compared to nonintegrated sensor switch (NISS) (10 ohms).
Refer to Troubleshooting Fault Code t05-431iss.


Idle Validation Switch Circuit

FAULT CODE 431

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: P091 SPN: 91 FMI: 2/2 LAMP: Yellow SRT: | Voltage detected simultaneously on both the idle validation off-idle and on-idle signal pins. | None on performance.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The nonintegrated sensor switch (NISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired idle validation switch.
  • The integrated sensor switch (ISS) has a different idle validation switch (IVS) resistance specification (125 ohms) as compared to the nonintegrated sensor switch (NISS) (10 ohms).
Refer to Troubleshooting Fault Code t05-431niss.

Last Modified: 21-May-2019


Idle Validation Switch Circuit

FAULT CODE 431

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: P091 SPN: 91 FMI: 2/2 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle signal pins. | None on performance.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The solid-state switch (SSS) is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired idle validation switch.

Refer to Troubleshooting Fault Code t05-431sss.


Accelerator Pedal Circuit

FAULT CODE 432

Accelerator Pedal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13/13 LAMP: Red SRT: | Voltage detected at idle validation on-idle circuit when voltage at throttle position circuit indicates the pedal is not at idle or voltage detected at idle validation off-idle circuit when voltage at throttle position circuit indicates the pedal is at rest. | Engine will only idle.
Accelerator Pedal Circuit

Circuit Description

The accelerator pedal assembly relays the accelerator percentage requested by the operator to the electronic control module (ECM).

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

Confirm that the idle validation switch (IVS) is properly calibrated. Use the accelerator pedal manufacturer's instructions for adjustment information.

Refer to Troubleshooting Fault Code t05-432.


Intake Manifold Pressure Circuit

FAULT CODE 433

Intake Manifold Pressure Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 433 PID: P102 SPN: 102 FMI: 2/2 LAMP: Yellow SRT: | Voltage signal at the intake manifold pressure circuit indicates high intake manifold pressure, but other engine characteristics indicate that intake manifold pressure must be low. | Derate to no-air setting.
Intake Manifold Pressure Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If intake manifold pressure exceeds 127 mm Hg [5 in Hg] for more than 20 seconds while the engine is under 5-percent load, it will cause a derate condition.

Component Location

The intake manifold pressure/temperature sensor is located on the cylinder head, between the air horn and the front of the engine.

Shop Talk

The ECM checks for this fault only at engine speeds up to 50 rpm above the set idle speed. If the intake manifold pressure shows too high of a value at this time, the ECM will log this fault code.

Refer to Troubleshooting Fault Code t05-433.


Unswitched Battery Supply Circuit

FAULT CODE 434

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 434 PID: S251 SPN: 627 FMI: 2/2 LAMP: Yellow SRT: | Supply voltage to the electronic control module (ECM) fell below (+) 6.2-VDC for a fraction of a second or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after keyswitch is turned off). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There are two in-line 15-ampere fuses in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire, and one 5-ampere fuse when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Use the OEM service manual.

Shop Talk

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specification and log Fault Code 434.

Refer to Troubleshooting Fault Code t05-434.


Oil Pressure Sensor

FAULT CODE 435

Oil Pressure Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2 LAMP: Yellow SRT: | An error in the oil pressure sensor signal was detected by the ECM. | None on performance; no engine protection for oil pressure.

Component Location

The oil pressure/temperature sensor is located on the engine block to the left of the fuel filter, behind the air compressor.

Shop Talk

At key-on, the readings for ambient pressure from the ambient air pressure sensor, intake manifold pressure sensor, and oil pressure sensor are compared. This fault code occurs if the oil pressure sensor reading is different from the other two.

Refer to Troubleshooting Fault Code t05-435.


Unswitched Battery Supply Circuit

FAULT CODE 441

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Yellow SRT: | Battery voltage below normal operating level. | Possible no noticeable performance effects or possible rough idle.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire of the OEM harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Use the OEM troubleshooting and repair manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Refer to Troubleshooting Fault Code t05-441.


Unswitched Battery Supply Circuit

FAULT CODE 442

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Yellow SRT: | Battery voltage above normal operating level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire to protect the OEM harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Use the OEM troubleshooting and repair manual for battery location.

Shop Talk

Disconnect all aftermarket devices from the battery supply circuit. Make sure the proper-size fuses are being used (15-amp fuses).

Refer to Troubleshooting Fault Code t05-442.


Throttle Voltage Supply

FAULT CODE 443

Throttle Voltage Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443 PID: S221 SPN: 1043 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the electronic control module (ECM) voltage supply line to the throttle(s). | Engine will only idle.
Throttle Voltage Supply Circuit

Circuit Description

The ECM supplies the accelerator and the remote throttle with 5 VDC. If the supply line to the accelerators is damaged, the accelerators will not work correctly.

Component Location

Accelerator pedal is located in the cab.

Use the OEM troubleshooting and repair manual for remote throttle location.

Shop Talk

Low voltage on the 5-VDC supply line will be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed accelerator, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-443.


High Fuel Pressure

FAULT CODE 449

High Fuel Pressure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P094 SPN: 94 FMI: 0/16 LAMP: Yellow SRT: | Excessive fuel supply pressure was detected at the fuel pressure sensor. | Engine will have black smoke and will run derated.
Hydraulic Fuel System Circuit

Circuit Description

The gear pump draws fuel from the fuel tank through the fuel filter and antidrainback valve. The gear pump develops 100 to 320 psi of fuel pressure. The fuel flows through the fuel filter screen and fuel shutoff valve to the fueling and timing actuators and the fuel pressure sensor. The 250-psi regulator controls the fuel pressure.

Component Location

Hydraulic Fuel System Circuit Callouts
1 | 320-psi Pressure Regulator | 5 | Quick-Disconnect Pressure Tap-Suction Side | 9 | Fuel Pressure Sensor | 13 | Rear Timing Actuator
2 | 36-mc Filter Screen | 6 | WIF Sensor | 10 | Quick-Disconnect Pressure Tap-Pressure Side | 14 | Rear Rail Actuator
3 | Fuel Inlet Restriction Sensor | 7 | 250-psi Pressure Regulator | 11 | Front Rail Actuator |  |
4 | Fuel Inlet | 8 | Fuel Shutoff Valve | 12 | Front Timing Actuator |  |

The 250-psi regulator controls the fuel pressure. All components are located on the fuel delivery housing on the intake side of the engine.

Shop Talk

The fuel pressure is monitored by the ECM. If the fuel pressure is outside an acceptable range, the fault code is activated. The acceptable range of the fuel pressure can be viewed as Minimum Fuel Pressure and Maximum Fuel Pressure using the INSITE™ monitor screen. The fault will log quickly for large differences and slower for small differences.

Refer to Troubleshooting Fault Code t05-449.


Front Rail Pressure Sensor Circuit

FAULT CODE 451

Front Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on the front rail pressure sensor circuit. | Engine will run derated.
Front Rail Pressure Sensor Circuit

Circuit Description

The front rail pressure sensor provides the rail pressure signal to the electronic control module (ECM).

Component Location

The front rail pressure sensor is located on the front of the fuel delivery housing.

Shop Talk

This fault could be caused by the return or signal wire that has a short circuit to (+) 5 VDC or (+) 12 VDC, an open circuit in the return wire, or a failed sensor.

Refer to Troubleshooting Fault Code t05-451.


Front Rail Pressure Sensor Circuit

FAULT CODE 452

Front Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the front rail pressure sensor circuit. | Engine will run derated.
Front Rail Pressure Sensor Circuit

Circuit Description

The front rail pressure sensor provides the rail pressure signal to the electronic control module (ECM).

Component Location

The front rail pressure sensor is located on the front of the fuel delivery housing.

Shop Talk

This fault could be caused by the signal wire having a short circuit to ground, the supply wire having a short circuit to ground, an open circuit in the supply wire, an open circuit in the signal wire, a failed sensor, or a faulty ECM power supply.

Refer to Troubleshooting Fault Code t05-452.


Wastegate Actuator Number 1 Circuit

FAULT CODE 465

Wastegate Actuator Number 1 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 465 PID: S032 SPN: 1188 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the wastegate actuator number 1 circuit when no voltage was being supplied by the engine control module (ECM). | Engine will run derated.
Wastegate Actuator Number 1 Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Component Location

The wastegate controller is located on the air inlet horn. Actuator number 1 is the rear-most solenoid on the controller.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the harness
  • An open circuit in the harness, connector, or wastegate control valve
  • Improperly mounted wastegate actuator solenoid.
Refer to Troubleshooting Fault Code t05-465.

Last Modified: 05-Jul-2012


Wastegate Actuator Number 1 Circuit

FAULT CODE 466

Wastegate Actuator Number 1 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 466 PID: S032 SPN: 1188 FMI: 4/4 LAMP: Yellow SRT: | Less than (+) 6 VDC detected at the wastegate actuator number 1 circuit when on indicates an excessive current draw from the engine control module (ECM) or faulty ECM output circuit. | Engine will run derated.
Wastegate Actuator Number 1 Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Component Location

The wastegate controller is located on the air inlet horn. Actuator number 1 is the rear-most solenoid on the controller.

Shop Talk

  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry surface.
  • Check the starter solenoid positive (+) terminal for a loose connector or accessory wiring with damaged insulation.
  • Low voltage can be caused by a short circuit to ground, a short circuit to another wire in the harness, or a shorted solenoid coil.
  • Inspect the wastegate actuator number 1 circuit for external wires that can be spliced into powering another device. Remove any extra wires that are found in the circuit.
Refer to Troubleshooting Fault Code t05-466.

Last Modified: 16-May-2012


ICON™ Cab Thermostat Circuit

FAULT CODE 469

ICON™ Cab Thermostat Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 469 PID: S215 SPN: 614 FMI: 2/2 LAMP: Yellow SRT: | The ICON™ cab thermostat has logged a fault (displayed on thermostat as E3) or cab thermostat signal to the electronic control module (ECM) is lost. | E3 will cycle the engine between 20 minutes RUN and 15 minutes OFF, or will not autostart the engine for Cab Comfort mode. ICON™ will not be disabled. Engine mode will remain active.
ICON™ Cab Thermostat Circuit

Circuit Description

The cab thermostat is used to control the cab temperature for either heating or cooling. It is required for Cab Comfort mode operation. The thermostat communicates with the ECM to command when to autostart the engine to maintain cab temperature. The thermostat is also connected to the keyswitch to detect when the ignition is turned on.

Component Location

The cab thermostat is typically mounted in the bunk area, above the bed on the wall. Use the specific, appropriate OEM manual for the exact location.

Shop Talk

E3 is an indication that one of the following has occurred:

Engine has run for more than 45 minutes and the ambient temperature is within 0 to 100°F (thermostat-adjustable trim 01 and 02) or a cab thermostat request to start the engine has been made within 10 minutes of an automatic shutdown and the ambient temperature is within 0 to 100°F. E3 can indicate potential tampering with the thermostat. For example, in the summer (78°F ambient) the user can set the thermostat to Heat mode with a set point of 75°F, but set the truck climate controls to Maximum Cooling.

The truck will only cool to some temperature below 75°F and run for 45 minutes before logging the E3. The effect of an E3 fault is adjustable via the thermostat between cycle engine on for 20 minutes and off for 15 minutes, or will not perform an autostart.

Refer to Troubleshooting Fault Code t05-469.


Crankcase Oil Level Sensor Circuit

FAULT CODE 472

Crankcase Oil Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 472 PID: S017 SPN: 1380 FMI: 2/2 LAMP: Maintenance SRT: | Either high or low voltage detected on the crankcase oil level sensor circuit by the electronic control module (ECM). | None on performance. Centinel™ system deactivated.
Crankcase Oil Level Sensor Circuit

Circuit Description

The crankcase oil level sensor is used by the ECM to monitor the lubricating oil level. The ECM monitors the voltage on the signal pin and converts this to an electronic value. The oil level value is used by the ECM for the engine protection system.

Component Location

The oil level sensor is located in the side of the oil pan on the exhaust side of the engine.

Shop Talk

Low voltage can be caused by an open circuit in the signal wire, a short circuit to ground in the signal wire, a short circuit to ground of the supply wire, an open circuit in the supply wire, or a faulty sensor.

High voltage can be caused by the signal wire shorting to another wire in the harness, an open circuit in the return wire, or a faulty sensor.

Refer to Troubleshooting Fault Code t05-472.


Starter Solenoid Lockout Relay Driver Circuit

FAULT CODE 474

Starter Solenoid Lockout Relay Driver Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 474 PID: S237 SPN: 1321 FMI: 2/2 LAMP: Yellow SRT: | Either low voltage detected when (+) 12 VDC are commanded or voltage detected when no voltage is commanded. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Solenoid Lockout Relay Circuit

Circuit Description

The starter solenoid lockout relay driver circuit is a solenoid driven by the electronic control module (ECM) that electrically isolates the starter motor relay when the engine is running.

Component Location

Use the OEM diagram for the exact location.

Refer to Troubleshooting Fault Code t05-474.


Electronic Air Compressor Governor Circuit

FAULT CODE 475

Electronic Air Compressor Governor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 475 PID: S089 SPN: 1351 FMI: 4/4 LAMP: Yellow SRT: | Low voltage was detected on the electronic air compressor circuit when high voltage was expected. | Air compressor will not shut off.
Electronic Air Compressor Governor Circuit

Circuit Description

The electronic air compressor governor is a device used by the electronic control module (ECM) to control output of the air compressor.

Component Location

The electronic air compressor governor is located on the top of the air compressor.

Shop Talk

  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.
  • Check the starter solenoid positive (+) terminal for a loose connector or accessory wiring with damaged insulation.
  • Low voltage can be caused by short circuit to ground, a short circuit to another wire in the harness, or a shorted solenoid coil.
  • Voltage is required at the electronic air compressor governor to turn the compressor off. No voltage turns the compressor on.
Refer to Troubleshooting Fault Code t05-475.


Electronic Air Compressor Governor Circuit

FAULT CODE 476

Electronic Air Compressor Governor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 476 PID: S089 SPN: 1351 FMI: 3/3 LAMP: Yellow SRT: | High voltage or an open circuit detected at the electronic air compressor governor actuator circuit. | Air compressor runs continuously or not at all.
Electronic Air Compressor Governor Circuit

Circuit Description

The electronic air compressor governor is a device used by the electronic control module (ECM) to control the output of the air compressor.

Component Location

The air compressor governor actuator is located on top of the air compressor.

Shop Talk

High voltage can be caused by a short circuit to battery or a short circuit to another wire in the harness.

Voltage is required at the electronic air compressor governor to turn the compressor off. No voltage turns the compressor on.

Refer to Troubleshooting Fault Code t05-476.


Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 482

Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 482 PID: P094 SPN: 94 FMI: 1/18 LAMP: Yellow SRT: | Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low fuel supply pressure was detected at the fuel pressure sensor. | Engine does not start, has low power, can possibly have white smoke, or runs rough.
Fuel System Circuit

Circuit Description

The gear pump draws fuel from the fuel tank through the fuel filter and antidrainback valve. The gear pump develops up to 2206 kPa [320 psi] of fuel pressure. The fuel flows through the fuel filter screen and fuel shutoff valve to the fueling and timing actuators and the fuel pressure sensor.

Component Location

The 1724 kPa [250 psi] regulator controls the fuel pressure. All components are located on the fuel delivery housing on the intake side of the engine.

Shop Talk

The fuel pressure is monitored by the Electronic Control Module (ECM). If the fuel pressure is outside an acceptable range, the fault code is activated. The acceptable range of fuel pressure can be viewed as Fuel Pressure Lower Limit and Fuel Pressure Upper Limit in the INSITE™ electronic service tool monitor screen. The fault will log quickly for large differences in pressure and slowly for small differences in pressure.

Refer to Troubleshooting Fault Code t05-482.

Last Modified: 06-Jan-2012


Rear Rail Pressure Sensor Circuit

FAULT CODE 483

Rear Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 483 PID: P129 SPN: 1349 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on the rear rail pressure sensor circuit. | Engine will run derated.
Rear Rail Pressure Sensor

Circuit Description

The rear rail pressure sensor provides the rail pressure signal to the electronic control module (ECM).

Component Location

The rear rail pressure sensor is located on the rear of the fuel delivery housing.

Shop Talk

This fault could be caused by the return or signal wire shorted to positive (+) 5 VDC or positive (+) 12 VDC, an open circuit in the return wire, or a failed sensor.

Refer to Troubleshooting Fault Code t05-483.


Rear Rail Pressure Sensor Circuit

FAULT CODE 484

Rear Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 484 PID: P129 SPN: 1349 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the rear rail pressure sensor circuit. | Engine will run derated.
Rear Rail Pressure Sensor Circuit

Circuit Description

The rear rail pressure sensor provides the rail pressure signal to the electronic control module (ECM).

Component Location

The rear rail pressure sensor is located on the fuel delivery housing below the gear pump.

Shop Talk

This fault could be caused by the signal wire shorted to ground, the supply wire shorted to ground, an open circuit in the supply wire, an open circuit in the signal wire, a failed sensor, or a faulty ECM power supply.

Refer to Troubleshooting Fault Code t05-484.


Fuel System Overfueling

FAULT CODE 485

Fuel System Overfueling

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 485 PID: P129 SPN: 1349 FMI: 0/16 LAMP: Red SRT: | Unexpectedly high rail pressure was detected on the rear three cylinders. | Engine will return to idle speed, then only idle or shut down.
Hydraulic Fuel System

Circuit Description

The electronic control module (ECM) supplies voltage to open the fueling actuators for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects this fuel into the cylinder for combustion.

Component Location

The rear fueling actuators are located on the fuel delivery housing below the air inlet horn. It is the actuator that is closest to the rear of the engine. The injectors are located in the cylinder head under the valve cover.

Shop Talk

The ECM measures the amount of fuel metered into the injector by using the rear rail pressure sensor. If the amount of fuel is above what the ECM expected, the fault code is activated.

Refer to Troubleshooting Fault Code t05-485.


Fuel System Underfueling

FAULT CODE 486

Fuel System Underfueling

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 486 PID: P129 SPN: 1349 FMI: 1/18 LAMP: Yellow SRT: | Unexpectedly low rail pressure was detected on the rear three cylinders. | Low power or rough idle.
Hydraulic Fuel System

Circuit Description

The electronic control module (ECM) supplies voltage to open the fueling actuators for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects this fuel into the cylinder for combustion.

Component Location

The rear fueling actuators are located on the fuel delivery housing below the air inlet horn. It is the actuator that is closest to the rear of the engine. The injectors are located in the cylinder head under the valve cover.

Shop Talk

The ECM measures the amount of fuel metered into the injector by using the rear rail pressure sensor. If the amount of fuel is below what the ECM expected, the fault code is activated.

Refer to Troubleshooting Fault Code t05-486.


Auxiliary Speed Input Error

FAULT CODE 489 (INDUSTRIAL)

Auxiliary Speed Input Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 489 PID: P191 SPN: 191 FMI: 1/18 LAMP: Yellow SRT: | Auxiliary speed frequency on input pin indicates the frequency is below a calibration-dependent threshold. | Engine will only idle.
Auxiliary Speed Input Circuit

Circuit Description

The auxiliary speed input is a frequency signal from an auxiliary speed or pressure pickup. It is sent to the electronic control module (ECM) and is used to control the engine speed. Auxiliary reference speed is based on the throttle position.

Component Location

The auxiliary speed or pressure pickup device location is dependent on the OEM application. Use the OEM troubleshooting and repair manual for component location.

Shop Talk

The auxiliary speed governor controls engine speed based on a measured auxiliary speed or pressure.

Refer to Troubleshooting Fault Code t05-489.


Wastegate Actuator Number 2 Circuit

FAULT CODE 491

Wastegate Actuator Number 2 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 491 PID: S088 SPN: 1189 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the wastegate actuator number 2 circuit when no voltage was being supplied by the engine control module (ECM). | Engine will run derated.
Wastegate Actuator Number 2 Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Component Location

The wastegate controller is located on the air inlet horn. Actuator number 2 is the front-most solenoid on the controller.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the harness
  • An open circuit in the harness, connector, or wastegate control valve
  • Improperly mounted wastegate actuator solenoid.
Refer to Troubleshooting Fault Code t05-491.

Last Modified: 05-Jul-2012


Wastegate Actuator Number 2 Circuit

FAULT CODE 492

Wastegate Actuator Number 2 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 492 PID: S088 SPN: 1189 FMI: 4/4 LAMP: Yellow SRT: | Less than (+) 6 VDC detected at the wastegate actuator number 2 circuit when activated indicates an excessive current draw from the engine control module (ECM) or faulty ECM output circuit. | Engine will run derated.
Wastegate Actuator Number 2 Circuit

Circuit Description

The wastegate actuators are devices used by the ECM to control boost pressure.

Component Location

The wastegate controller is located on the air inlet horn. Actuator number 2 is the front-most solenoid on the controller.

Shop Talk

  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry surface.
  • Check the starter solenoid (+) terminal for a loose connector or accessory wiring with damaged insulation.
  • Low voltage can be caused by short circuit to ground, a short circuit to another wire in the harness, or a shorted solenoid coil.
  • Inspect the wastegate actuator number 2 circuit for external wires that can be spliced into powering another device. Remove any extra wires that are found in the circuit.
Refer to Troubleshooting Fault Code t05-492.

Last Modified: 16-May-2012


Sensor Supply Voltage

FAULT CODE 496

Sensor Supply Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 496 PID: S221 SPN: 1043 FMI: 11/11 LAMP: Yellow SRT: | Incorrect voltage detected on the electronic control module (ECM) voltage supply line to the camshaft engine position sensor. | Engine does not run, is hard to start, or will run derated.
Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies the camshaft engine position with positive (+) 5 VDC. If the supply line is damaged, the sensors will not work correctly.

Component Location

The camshaft engine position sensor is located on the intake side of the engine block on the cylinder head to the right of the ECM.

Shop Talk

Low voltage on the positive (+) 5-VDC supply line will be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-496.


Switched Output A Error

FAULT CODE 527 (INDUSTRIAL)

Switched Output A Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: P40 PID: S154 SPN: 702 FMI: 3/3 LAMP: Yellow SRT: | Less than (+) 17.0 VDC detected at the switched output A signal pin of the 31-pin OEM connector. | No action taken by the electronic control module (ECM).
Switched Output A Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device, and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-527.


Switched Output B Error

FAULT CODE 528 (INDUSTRIAL)

Switched Output B Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 528 PID: P093 SPN: 93 FMI: 2/2 LAMP: Yellow SRT: | Less than (+) 17.0 VDC detected at the switch output B signal pin of the 31-pin OEM connector. | No action taken by the electronic control module (ECM).
Switched Output B Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device, and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-528.


Switched Output B Error

FAULT CODE 529 (INDUSTRIAL)

Switched Output B Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: S51 SPN: 703 FMI: 3/3 LAMP: Yellow SRT: | Less than (+) 17 VDC detected at the switched output B signal pin at the electronic control module (ECM). | No action taken by the ECM.
Switched Output B Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device, and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-529.


Autoshift Low Gear Actuator (Lockout Solenoid) Circuit

FAULT CODE 536

Autoshift Low Gear Actuator (Lockout Solenoid) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 536 PID: S044 SPN: 718 FMI: 11/11 LAMP: Yellow SRT: | Either low voltage detected on autoshift low gear actuator circuit when (+) 12 VDC are commanded or voltage detected when no voltage is commanded. | Top 2 lockout solenoid will not function properly. Transmission will not shift properly.
Top 2 Lockout Solenoid Circuit

Circuit Description

The autoshift low gear actuator is an ECM-driven solenoid that controls a Top 2 transmission.

Component Location

The autoshift low gear actuator is located on the topside of a transmission toward the back. Use the OEM diagram for a specific location.

Refer to Troubleshooting Fault Code t05-536.


Autoshift High Gear Actuator (Shift Solenoid) Circuit

FAULT CODE 537

Autoshift High Gear Actuator (Shift Solenoid) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 537 PID: S043 SPN: 717 FMI: 11/11 LAMP: Yellow SRT: | Either low voltage detected on autoshift high gear actuator circuit when (+) 12 VDC are commanded or voltage detected when no voltage is commanded. | Top 2 shift solenoid will not function properly. Transmission will not shift properly.
Top 2 Shift Solenoid Circuit

Circuit Description

The autoshift high gear actuator is an ECM-driven solenoid that controls a Top 2 transmission.

Component Location

The autoshift high gear actuator is located on the topside of the transmission toward the back. Use the OEM diagram for the specific location.

Refer to Troubleshooting Fault Code t05-537.


Autoshift Neutral Actuator

FAULT CODE 538

Autoshift Neutral Actuator

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 538 PID: S045 SPN: 719 FMI: 11/11 LAMP: Yellow SRT: | Either low voltage detected on autoshift neutral gear actuator circuit when (+) 12 VDC are commanded or voltage detected when no voltage is commanded. | Top 2 neutral actuator will not function properly. Transmission will not shift properly.
Top 2 Shift Solenoid Circuit

Circuit Description

The autoshift neutral actuator is an ECM-driven solenoid that controls a Top 2 transmission.

Component Location

The autoshift neutral actuator is located on the topside of the transmission toward the back. Use the OEM diagram for the specific location.

Refer to Troubleshooting Fault Code t05-538.


ICON™ Starter Relay/Interlock Circuit

FAULT CODE 541

ICON™ Starter Relay/Interlock Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 541 PID: S123 SPN: 615 FMI: 11/31 LAMP: Yellow SRT: | Incorrect voltage detected at the ICON™ starter relay/interlock circuit by the electronic control module (ECM). | The ICON™ idle control system will be disabled. Only mandatory shutdown will be enabled. Engine can be started normally.
ICON™ Starter Relay/Interlock Circuit

Circuit Description

The starter relay/interlock circuit controls and monitors both the starter relay coil and the ICON™ interlocks. The starter relay is used by the ICON™ feature to perform automatic starts of the engine. The interlocks are used by the ICON™ feature to monitor if the transmission is in neutral, the position of the hood/cab, and if the parking brakes are set.

Component Location

The location of the starter relay, parking brake switch, neutral position switch, and hood tilt switch vary among OEMs. Consult the specific OEM troubleshooting and repair manual for exact location.

Shop Talk

Typically, this fault code indicates a short circuit to battery, a short circuit to ground, or an open circuit.

Refer to Troubleshooting Fault Code t05-541.


Top 2 Transmission Circuit - Mechanical System Failure

FAULT CODE 544

Top 2 Transmission Circuit - Mechanical System Failure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 544 PID: S151 SPN: 611 FMI: 7/7 LAMP: Yellow SRT: | Autoshift failure; at least three shift attempts were missed. | Top 2 transmission will not be controlled correctly. Transmission remains in manual mode.
Top 2 Transmission Circuit

Circuit Description

The Top 2 transmission circuit controls a Top 2 transmission to autoshift between the Top 2 gears.

Component Location

The Top 2 shift/lockout solenoids are on the topside of the transmission, near the back. Use the OEM diagram for the exact location.

Refer to Troubleshooting Fault Code t05-544.


Fuel Pressure Sensor Circuit

FAULT CODE 546

Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: P094 SPN: 94 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on the fuel pressure sensor circuit. | Engine will run derated.
Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor provides the fuel supply pressure signal to the electronic control module (ECM).

Component Location

The fuel pressure sensor is located on the fuel delivery housing to the left of the front fueling actuator.

Shop Talk

This fault indicates that signal pin 29 on the ECM has been shorted on the circuit to at least positive (+) 5 VDC.

Refer to Troubleshooting Fault Code t05-546.


Fuel Pressure Sensor Circuit

FAULT CODE 547

Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: P094 SPN: 94 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected on the fuel pressure sensor circuit. | Engine will run derated.
Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor provides the fuel supply pressure signal to the electronic control module (ECM).

Component Location

The fuel pressure sensor is located on the fuel delivery housing to the left of the front fueling actuator.

Shop Talk

This fault indicates that voltage at signal pin 29 on the ECM has a short circuit to ground.

Refer to Troubleshooting Fault Code t05-547.


Fault Code Path Selection

FAULT CODE 72-fc551
Fault Code Path Selection

Do you have an IVS throttle pedal? | Go to 72-fc551ivs
Do you have an ISS throttle pedal? | Go to 72-fc551iss
Do you have an SSS throttle pedal? | Go to 72-fc551sss

Last Modified: 25-Feb-2005


Idle Validation Switch Circuit

FAULT CODE 551

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

Integrated Sensor Switch (ISS)

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Engine will only idle.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by a loose connection, an accelerator pedal that is not calibrated, or an idle validation switch that is wired wrong. Breakout cable, Part Number 3824892, is required to check the voltage levels of the solid state-sensor switch (SSS).
  • If all wiring and sensor checks are good, replace the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault clears, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from seeping into the cab.
  • Verify that the three idle validation switch circuit wires are twisted together.
  • The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is on.
  • With keyswitch on, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal.
Refer to Troubleshooting Fault Code t05-551iss.


Idle Validation Switch Circuit

FAULT CODE 551

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

Idle Validation Switch (IVS)

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Engine will only idle.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch (IVS) is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, an accelerator pedal that is not calibrated, or an idle validation switch that is wired wrong. Breakout cable, Part Number 3824892, is required to check the voltage levels of the solid state sensor switch.

  • If all wiring and sensor checks are good, replace the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault clears, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from seeping into the cab.
  • Check that the three idle validation switch circuit wires are twisted together.
  • The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is on.
  • With keyswitch on, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal.
Refer to Troubleshooting Fault Code t05-551ivs.


Idle Validation Switch Circuit

FAULT CODE 551

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

SSS

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Yellow SRT: | No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Engine will only idle.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch (IVS) is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. Solid-state integrated sensor switch (SSS) is an active electronic component that requires voltage to inspect the circuit.

Component Location

The solid-state sensor switch is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, an accelerator pedal that is not calibrated, or an idle validation switch that is wired wrong. Breakout cable, Part Number 3824892, is required to check the voltage levels of the solid-state sensor switch.

  • If all wiring and sensor checks are good, replace the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault clears, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from seeping into the cab.

Check that the three idle validation switch circuit wires are twisted together.

  • The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. They must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is on.
  • With keyswitch on, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This maneuver will recalibrate the ECM and accelerator pedal.
Refer to Troubleshooting Fault Code t05-551sss.


Fuel System Overfueling

FAULT CODE 553

Fuel System Overfueling

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Red SRT: | Unexpectedly high rail pressure was detected on the front three cylinders. | Engine will return to idle speed, then only idle or shut down.
Hydraulic Fuel System

Circuit Description

The electronic control module (ECM) supplies voltage to open the fueling actuators for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects this fuel into the cylinder for combustion.

Component Location

The front fueling actuators are located on the fuel delivery housing below the air inlet horn. It is the actuator that is closest to the front of the engine. The injectors are located in the cylinder head under the valve cover.

Shop Talk

The ECM measures the amount of fuel metered into the injector by using the front rail pressure sensor. If the amount of fuel is above what the ECM expected, the fault code is activated.

Refer to Troubleshooting Fault Code t05-553.


Fuel System Underfueling

FAULT CODE 559

Fuel System Underfueling

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Yellow SRT: | Unexpectedly low rail pressure was detected on the front three cylinders. | Low power or rough idle.
Hydraulic Fuel System

Circuit Description

The electronic control module (ECM) supplies voltage to open the fueling actuators for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects this fuel into the cylinder for combustion.

Component Location

The front fueling actuators are located on the fuel delivery housing below the air inlet horn. It is the actuator that is closest to the front of the engine. The injectors are located in the cylinder head under the valve cover.

Shop Talk

The ECM measures the amount of fuel metered into the injector by using the front rail pressure sensor. If the amount of fuel is below what the ECM expected, the fault code is activated.

Refer to Troubleshooting Fault Code t05-559.


Fuel Inlet Restriction Sensor Circuit

FAULT CODE 581

Fuel Inlet Restriction Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 581 PID: P015 SPN: 1381 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected on fuel inlet restriction sensor signal pin. | Fuel inlet restriction monitor deactivated.
Fuel Inlet Restriction Sensor Circuit

Circuit Description

The fuel inlet restriction sensor provides a fuel pressure signal to the electronic control module (ECM).

Component Location

The fuel inlet restriction sensor is located on the fuel filter head.

Shop Talk

This fault indicates that a short circuit of at least positive (+) 5 VDC has occurred at signal pin 28 on the actuator harness connector at the ECM.

Refer to Troubleshooting Fault Code t05-581.


Fuel Inlet Restriction Sensor Circuit

FAULT CODE 582

Fuel Inlet Restriction Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 582 PID: P015 SPN: 1381 FMI: 4/4 LAMP: Yellow SRT: | Low voltage detected at the fuel inlet restriction sensor signal pin. | Fuel inlet restriction monitor deactivated.
Fuel Inlet Restriction Sensor Circuit

Circuit Description

The fuel inlet restriction sensor provides a fuel pressure signal to the electronic control module (ECM).

Component Location

The fuel inlet restriction sensor is located on the fuel filter head.

Shop Talk

  • This fault indicates that the voltage at signal pin 28 on the ECM is out of specification.
  • The ECM provides a supply voltage of (+) 4.75 to 5.25 VDC. The sensor signal voltage to the ECM is from (+) 4.16 to 4.83 VDC.
  • A quick check to determine if the sensor is functioning is to measure the pin-to-pin resistance of the sensor.

Description | Pin-to-Pin Resistance (k ohms)
Supply voltage to ground | 13.35
Supply voltage to signal | 1.77
Signal to ground | 14.68
Refer to Troubleshooting Fault Code t05-582.


Fuel Inlet Restriction Sensor Circuit

FAULT CODE 583

Fuel Inlet Restriction Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 583 PID: P015 SPN: 1381 FMI: 1/18 LAMP: Yellow SRT: | Restriction has been detected by the fuel inlet restriction sensor. | Fuel inlet restriction monitor warning is set.
Fuel Inlet Restriction Sensor Circuit

Circuit Description

The fuel inlet restriction sensor provides a signal to the electronic control module (ECM).

Component Location

The fuel inlet restriction sensor is located on the inlet to the fuel filter head.

Shop Talk

This fault indicates that the fuel inlet restriction has exceeded 12 in Hg. Typical causes for this fault code include a plugged fuel filter and a collapsed fuel supply hose.

Refer to Troubleshooting Fault Code t05-583.


Engine Start Alarm Circuit

FAULT CODE 588

Engine Start Alarm Circuit

Printable Version Printable Version

Overview

Engine Start Alarm Circuit

CODE | REASON | EFFECT
Fault Code: 588 PID: S121 SPN: 611 FMI: 3/3 LAMP: Yellow SRT: | High voltage detected at the engine start alarm circuit when low voltage was expected by the electronic control module (ECM). | The ICON™ idle control system will be disabled. Only mandatory shutdown will be enabled. The engine start alarm can sound continuously.
Engine Start Alarm Circuit

Circuit Description

The engine start alarm circuit turns on the audible engine start alarm to warn of an automatic engine start.

Component Location

The engine start alarm is typically located in the engine compartment. Use the OEM manual for specific locations.

Shop Talk

This fault typically indicates a short circuit to battery or an open circuit. The engine must be equipped with a three-level engine braking harness and the ICON™ feature must be activated for the engine start alarm to function.

Refer to Troubleshooting Fault Code t05-588.


Engine Start Alarm Circuit

FAULT CODE 589

Engine Start Alarm Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 589 PID: S121 SPN: 611 FMI: 4/4 LAMP: Yellow SRT: | Less than (+) 6 VDC detected at the engine start alarm circuit when high voltage was expected by the ICON™ ECM. | The ICON™ idle control system will be disabled. Only mandatory shutdown will be enabled. The engine start alarm can sound continuously, or not at all.
Engine Start Alarm Circuit

Circuit Description

The engine start alarm circuit turns on the audible engine start alarm to warn of an automatic engine start.

Component Location

The engine start alarm is typically located in the engine compartment. Use the OEM manual for specific location.

Shop Talk

This fault typically indicates a short circuit to ground. The engine must be equipped with a three-level engine braking harness and the ICON™ feature must be enabled for the engine start alarm to function.

Refer to Troubleshooting Fault Code t05-589.


Turbocharger Speed High (Calculated)

FAULT CODE 595

Turbocharger Speed High (Calculated)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 16 LAMP: Amber SRT: | Turbocharger Speed High (Calculated). Turbocharger speed calculation indicates turbocharger speed is above the engine protection warning limit. | Engine will run derated.
ECM Microprocessor

Circuit Description

The electronic control module (ECM) calculates turbocharger speed based on air to fuel ratio, final timing and inputs from the intake manifold temperature and pressure (Combo) sensor, ambient air pressure sensor and the engine speed sensor. If the calculated turbocharger speed becomes too high, it will cause a derate condition.

Component Location

There is not a physical turbocharger speed sensor in the system. The turbocharger speed is a calculation of intake manifold temperature, intake manifold pressure, ambient air pressure, engine speed, air to fuel ratio, and fuel timing. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Intake manifold temperature and pressure (Combo) sensor
  • Engine speed sensor
  • Ambient air pressure sensor
  • Electronic control module (ECM) calibration.
Refer to Troubleshooting Fault Code t05-595.


Voltage Monitor - High Voltage

FAULT CODE 596

Voltage Monitor - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Yellow SRT: | High battery voltage detected by the battery voltage monitor feature. | Yellow lamp will be lit until high battery voltage condition is corrected.
Voltage Monitor Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire of the OEM harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Use the OEM troubleshooting and repair manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Overcharged batteries caused by a faulty alternator or regulator.
Refer to Troubleshooting Fault Code t05-596.


Voltage Monitor - Low Voltage

FAULT CODE 597

Voltage Monitor - Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Yellow SRT: | ICON™ has restarted the engine three times within 3 hours due to low battery voltage (automotive only) or low battery voltage detected by the battery voltage monitor feature. | Yellow lamp will be lit until low battery voltage condition is corrected. The electronic control module (ECM) can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. The engine will run continuously if ICON™ is active (automotive only).
Voltage Monitor Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the OEM harness. There are two in-line 15-ampfuses in the unswitched battery wire of the OEM harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Use the OEM troubleshooting and repair manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault:

  • Undercharged batteries caused by a faulty alternator or regulator.
  • High-current devices on the vehicle such as refrigerators, citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code t05-597.


Voltage Monitor - Very Low Voltage

FAULT CODE 598

Voltage Monitor - Very Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Very low battery voltage detected by the battery voltage monitor feature. | Red lamp lit until very low battery voltage condition is corrected. The electronic control module (ECM) can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. The engine will run continuously if ICON™ is active (automotive only).
Voltage Monitor Supply Circuit

Circuit Description

The ECM receives unswitched battery input through the OEM harness. There are two in-line 15-amp fuses in the unswitched battery wire of the OEM harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Use the OEM manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Undercharged batteries caused by a faulty alternator or regulator.
Refer to Troubleshooting Fault Code t05-598.


Engine Speed Sensor and Camshaft Position Sensor - Mechanical Misalignment Between Camshaft and Crankshaft Sensors

FAULT CODE 731

Engine Speed Sensor and Camshaft Position Sensor - Mechanical Misalignment Between Camshaft and Crankshaft Sensors

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed Sensor and Camshaft Position Sensor - Mechanical Misalignment Between Camshaft and Crankshaft Sensors. Engine position signal from the engine speed sensor and camshaft position sensor do not match. | Engine will run derated. Excessive smoke, hard start, and rough idle possible.
Engine Speed Sensor and Camshaft Position Sensor Circuit - Mechanical Misalignment Between Camshaft and Crankshaft Sensors

Circuit Description

The engine speed sensor and camshaft position sensor provide an engine speed and position signal to the electronic control module (ECM) through the engine harness.

Component Location

Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

Possible causes for this fault code include:

  • Loose, missing, or corroded grounds
  • Damaged tone wheel teeth
  • Loose crankshaft tone wheel
  • Static timing mis-set
  • Front gear train slippage
  • Misoriented engine speed or camshaft position sensor
  • Electrical noise.
Refer to Troubleshooting Fault Code t05-731.


Engine Speed Sensor Circuit

FAULT CODE 753

Engine Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 753 PID: S064 SPN: 723 FMI: 2/2 LAMP: Yellow SRT: | Engine position signal from the camshaft and crankshaft engine position sensors do not match up. | Low power, rough idle, or possible white smoke.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a solid-state sensor that provides the engine speed signal to the electronic control module (ECM) through the engine harness.

Component Location

The crankshaft engine speed sensor is located on the front cover of the gear housing. This is on the intake side of the vibration damper. The camshaft engine speed sensor is located in the cylinder head above the ECM.

Shop Talk

If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor circuit while the engine is at that particular temperature.

Refer to Troubleshooting Fault Code t05-753.


Fuel Injector

FAULT CODE 755

Fuel Injector

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 755 PID: P157 SPN: 157 FMI: 7/7 LAMP: Yellow SRT: | Incorrect fueling was detected on the front three cylinders. | Engine will misfire.
Fuel Injector

Circuit Description

The electronic control module (ECM) supplies voltage to open the fueling actuators for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects this fuel into the cylinder for combustion.

Component Location

The injectors are located in the cylinder head under the valve cover.

Shop Talk

The ECM measures the amount of fuel metered into each injector by using the front fuel rail pressure sensor. If the ECM detects that no fuel is entering an injector, the fault code is activated.

This fault can be caused by air in the fuel.

Refer to Troubleshooting Fault Code t05-755.


Fuel Injector

FAULT CODE 758

Fuel Injector

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 758 PID: P129 SPN: 1349 FMI: 7/7 LAMP: Yellow SRT: | Incorrect fueling was detected on the rear three cylinders. | Engine will misfire.
Fuel Injector

Circuit Description

The electronic control module (ECM) supplies voltage to open the fueling actuators for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects this fuel into the cylinder for combustion.

Component Location

The injectors are located in the cylinder head under the valve cover.

Shop Talk

The ECM measures the amount of fuel metered into each injector by using the rear fuel rail pressure sensor. If the ECM detects that no fuel is entering an injector, the fault code is activated.

Refer to Troubleshooting Fault Code t05-758.


Adaptive Cruise Control Circuit

FAULT CODE 784

Adaptive Cruise Control Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: SPN: 1590 FMI: 2 LAMP: Amber SRT: | Adaptive Cruise Control Circuit Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
Adaptive Cruise Control Circuit

Circuit Description

The adaptive cruise control unit communicates with the electronic control module (ECM) sending and receiving vehicle speed control messages through the SAE J1939 data link.

Component Location

The location of the adaptive cruise control unit will vary by OEM. Use the OEM service manual for specific location.

Shop Talk

This fault is set active if the ECM does not receive the Heartbeat message from the adaptive cruise control unit on the SAE J1939 data link.

Refer to Troubleshooting Fault Code t05-784.


Cylinder Power Imbalance

FAULT CODE 951

Cylinder Power Imbalance

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 951 PID: P166 SPN: 166 FMI: 2/2 LAMP: None SRT: | A power imbalance between cylinders was detected by the electronic control module (ECM). | Engine can have rough idle or misfire.
Cylinder Power Imbalance

Circuit Description

The ECM calculates the power output of each cylinder at engine idle speeds.

Component Location

The ECM is located on the intake side of the engine between the intake air horn and the front of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

At engine idle speeds, the ECM measures the instantaneous acceleration of each cylinder as it fires to determine the cylinder's power. The ECM adjusts fueling to individual cylinders if the imbalance is within pre-defined limits. If the imbalance is greater than the pre-defined limits, Fault Code 951 will be set active.

Refer to Troubleshooting Fault Code t05-951.


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 418 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 428 or 429 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for Fault Code 418. | Fault Code 418 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 or 429 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Drain the water from the fuel filter.

If Fault Code 418 remains active, a malfunction in the sensor and/or connector may have occurred. Repair or replace the sensor and/or connector, as necessary.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 27-Nov-2018


NO TITLE

Information Fault Codes

NOTE: - Information fault codes have simple, corrective actions and no fault code troubleshooting tree.
- SRT 00-394 applies to all of the information fault codes listed below.
- After correcting the condition that caused the fault, let the engine warm up; then let the engine run for 1 minute to inactivate the fault code. Then, use INSITE™ to clear the fault code.

CODE: 143
LAMP: Yellow
REASON: Oil pressure signal indicates oil pressure is below the low oil pressure engine protection limit.
EFFECT: Progressive power and speed derate with increasing time after alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the Low Oil Pressure symptom troubleshooting procedure in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239.
CODE: 151
LAMP: Red
REASON: Coolant temperature signal indicates temperature is above 104°C [220°F].
EFFECT: Progressive power derate with increasing time after alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the High Coolant Temperature symptom troubleshooting procedure in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239.
CODE: 155
LAMP: Red
REASON: Intake manifold temperature signal indicates temperature is above 93.3°C [200°F].
EFFECT: Progressive power derate with increasing time after alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the High Intake Manifold Temperature symptom troubleshooting procedure in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239.
CODE: 211
LAMP: None
REASON: Additional OEM or vehicle diagnostic codes have been logged. Check other ECMs for diagnostic codes.
EFFECT: None on engine performance.
ACTION: Refer to the appropriate OEM manual for assistance in troubleshooting this fault.
CODE: 214
LAMP: Red
REASON: Oil temperature signal indicates oil temperature above 123.9°C [255°F].
EFFECT: Progressive power derate with increasing time after alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the High Oil Temperature symptom troubleshooting procedure in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239.
CODE: 219
LAMP: Maintenance
REASON: Low oil level was detected in the Centinel™ makeup oil tank.
EFFECT: None on performance. Centinel™ system deactivated.
ACTION: Add engine oil to the Centinel™ makeup oil tank. If fault remains active with a full oil tank, remove and clean the oil level sensor.
CODE: 287
LAMP: Red
REASON: The OEM vehicle electronic control unit (VECU) detected a fault with its throttle pedal.
EFFECT: The engine will only idle.
ACTION: Refer to the OEM troubleshooting and repair manual. Troubleshoot the accelerator pedal connected to the OEM-supplied vehicle electronic control unit (VECU).
CODE: 288
LAMP: Red
REASON: The OEM vehicle electronic control unit (VECU) detected a fault with its remote throttle.
EFFECT: The engine will NOT respond to the remote throttle.
ACTION: Refer to the OEM troubleshooting and repair manual. Troubleshoot the remote throttle pedal connected to the OEM-supplied vehicle electronic control unit (VECU).
CODE: 295
LAMP: Yellow
REASON: An error in the ambient air pressure sensor signal was detected by the ECM.
EFFECT: Engine is derated to no-air setting.
ACTION: Verify ambient air pressure value is from 635.0 mm Hg [25.0 in Hg] to 774.7 mm Hg [30.5 in Hg] using INSITE™. Replace ambient air pressure sensor if necessary.
CODE: 299
LAMP: Yellow
REASON: The engine was shut down by a device other than the keyswitch before proper engine cooldown, resulting in a filtered load factor above the maximum shutdown threshold.
EFFECT: No action taken by the ECM.
ACTION:
CODE: 415
LAMP: Red
REASON: Oil pressure signal indicates oil pressure below the very low oil pressure engine protection limit.
EFFECT: Progressive power derate with increasing time after alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
ACTION: Refer to the Low Oil Pressure symptom troubleshooting procedure in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239.
CODE: 418
LAMP: Maintenance
REASON: Water has been detected in the fuel filter.
EFFECT: Possible white smoke, loss of power, or hard starting.
ACTION: Drain water from fuel filter. Refer to the Water in Fuel symptom troubleshooting procedure in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239, if fault reoccurs frequently.
CODE: 419
LAMP: Yellow
REASON: An error in the intake manifold pressure sensor signal was detected by the ECM.
EFFECT: Engine is derated to no-air setting.
ACTION: Verify intake manifold pressure value is from -63.5 mm Hg [-2.5 in Hg] to 63.5 mm Hg [2.5 in Hg] using INSITE™. Replace intake manifold pressure/temperature sensor if necessary.
CODE: 435
LAMP: Yellow
REASON: An error in the oil pressure sensor signal was detected by the ECM.
EFFECT: None on performance. No engine protection for oil pressure.
ACTION: Verify oil pressure value is from 10.3 kPa [-1.5 psi] to 27.5 kPa [4.0 psi] when the engine is stopped using INSITE™. Replace oil pressure/temperature sensor if necessary.
CODE: 471
LAMP: Yellow
REASON: Low crankcase oil level was detected by the ECM.
EFFECT: None on performance. Centinel™ system is deactivated.
ACTION:
CODE: 595
LAMP: Yellow
REASON: Turbocharger overspeed protection fault. High turbocharger speed has been detected by the ECM.
EFFECT: The engine will run derated.
ACTION: Refer to the High Turbocharger Speed symptom troubleshooting procedure in the Signature Troubleshooting and Repair Manual, Bulletin No. 3666239.
CODE: 611
LAMP: None
REASON: Engine shutdown by operator before the proper engine cooldown.
EFFECT: No action taken by the ECM.
ACTION: Refer to the Hot Shutdown symptom troubleshooting procedures.
CODE: 775
LAMP: Maintenance
REASON: A slow leak has been detected in the air system.
EFFECT: None on performance.
ACTION: Check the vehicle air system for leaks. Refer to Procedure 012-019 in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239.
CODE: 776
LAMP: Yellow
REASON: A fast leak has been detected in the air system.
EFFECT: None on performance.
ACTION: Check the vehicle air system for leaks. Refer to Section 012-019 in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239.
CODE: 951
LAMP: None
REASON: A power imbalance between cylinders was detected by the ECM.
EFFECT: Engine can have rough idle or misfire.
ACTION: Check fuel quality. Check for air being ingested into the fuel. It is normal to have an inactive Fault Code 951 after a service procedure introduced air into the fuel system, such as a filter change. Perform Cylinder Performance Test to determine if a particular cylinder or bank of cylinders is high or low on power. Refer to Procedure 014-008, Cylinder Performance Test, in the Signature, ISX and QSX15 Engines Troubleshooting and Repair Manual, Bulletin No. 3666239.

Last Modified: 06-Nov-2003


FAULT CODE 111 - Engine Control Module (ECM) Microprocessor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn keyswitch OFF and wait five seconds.
  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 111 inactive

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.
OK NOT OK

Less than 3 counts

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for at least one minute.
  • Use INSITE™ to verify Fault Code 111 is inactive.
OK NOT OK

Fault Code 111 inactive

Return to the troubleshooting steps or contact a local Cummins™ Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test leadPart Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the camshaft engine position sensor. |
 | STEP 1A. Inspect the camshaft engine position sensor and engine harness connectors. | No damaged pins
 | STEP 1B. Check for a signal from the camshaft engine position sensor. | Signal present
 | STEP 1B-1. Check the camshaft engine position sensor supply voltage. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 115 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the camshaft engine position sensor.

Guided Step 1A - Inspect the camshaft engine position sensor and the engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the camshaft engine speed sensor.
  • Connect the engine harness to the ECM.

Action

Inspect the camshaft engine position sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins, use the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the camshaft engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a signal from the camshaft engine position sensor.

Conditions

  • Install the breakout cable, Part Number 3824775, between the camshaft engine position sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for a signal from the camshaft engine position sensor.

  • Measure the voltage from pin C (or YELLOW) to pin B (or BLACK) on the breakout cable while barring the engine over.
OK NOT OK

Signal present; signal should change from (+) 4.0-5.0 VDC to 0.5-2.3 VDC and back again 7 times for every 360 degrees of crankshaft rotation.

Does not meet specifications

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Check the camshaft engine position sensor supply voltage.

Conditions

  • Disconnect the engine harness from the camshaft engine position sensor.
  • Turn keyswitch ON.

Action

Check the engine position sensor supply voltage.

  • Measure the voltage from pin A (or 1) to pin B (or 2) on the harness side of the camshaft engine position sensor connector.
OK NOT OK

(+) 4.75 to 5.25-VDC

Replace the camshaft engine position sensor.

Refer to Procedure 019-038 in Section 19.

Does not meet specifications

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for pre-authorization. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the camshaft engine position sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 of the sensor harness connector to pin A (or 1) on the harness side of the camshaft engine position sensor connector.
  • Measure the resistance from pin 21 of the sensor harness connector to pin B (or 2) on the harness side of the camshaft engine position sensor connector.
  • Measure the resistance from pin 50 of the sensor harness connector to pin C (or 3) on the harness side of the camshaft engine position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the camshaft engine position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 11 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 50 of the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the camshaft engine position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 50 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Call for pre-authorization. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 115 is inactive.
OK NOT OK

Fault Code 115 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test leadPart Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the crankshaft engine position sensor. |
 | STEP 1A. Inspect the crankshaft engine position sensor and engine harness connectors. | Dirty or damaged pins?
 | STEP 1B. Check for signal from the crankshaft engine position sensor. | Signal present?
 | STEP 1B-1. Check the crankshaft engine position sensor supply voltage. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | Damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the crankshaft engine position sensor.

Guided Step 1A - Inspect the crankshaft engine position sensor and the engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the crankshaft engine position sensor.
  • Connect the sensor harness connector to the ECM.

Action

Inspect the crankshaft engine position sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the crankshaft engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for signal from the crankshaft engine position sensor.

Conditions

  • Install the breakout cable, Part Number 3824775, between the crankshaft engine position sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for signal from the crankshaft engine position sensor.

  • Measure the voltage from pin C (or YELLOW) to pin B (or BLACK) on the breakout cable while barring the engine over.
OK NOT OK

Signal present; signal should change from (+) 4 to 5-VDC to 0.5 to 2.3-VDC and back about every 60 degrees of crankshaft rotation.

Does not meet specifications.

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Check the crankshaft engine position sensor supply voltage.

Conditions

  • Disconnect the engine harness from the crankshaft engine position sensor.
  • Turn keyswitch ON.

Action

Check the crankshaft engine position sensor supply voltage.

  • Measure the voltage from pin A (or 1) to pin B (or 2) on the harness side of the crankshaft engine position sensor connector.
OK NOT OK

(+) 4.75 to 5.25-VDC

Replace the crankshaft engine position sensor.

Refer to Procedure 019-038 in Section 19.

  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the crankshaft engine position sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 41 of the sensor harness connector to pin A (or 1) on the harness side of the crankshaft engine position sensor connector.
  • Measure the resistance from pin 32 of the sensor harness connector to pin B (or 2) on the harness side of the crankshaft engine position sensor connector.
  • Measure the resistance from pin 47 of the sensor harness connector to pin C (or 3) on the harness side of the crankshaft engine position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the crankshaft engine position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 41 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 47 of the sensor harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the crankshaft engine position sensor.

Action

Check for a short circuit from pin to pin in the (+) 5-VDC supply wire and the signal wire.

  • Measure the resistance from pin 32 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 41 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 47 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms

  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Mar-2012


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure/temperature sensor. |
 | STEP 1A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 122 inactive?
 | STEP 1C. Check the intake manifold pressure/temperature sensor supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the intake manifold pressure/temperature sensor signal voltage. | (+) 0.42 to 0.58-VDC?
STEP 2. | Check the engine harness and the ECM. |
 | STEP 2A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 122 inactive?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the return wire. | Less than 10 ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 122 inactive and Fault Code 123 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold pressure/temperature sensor.

Guided Step 1A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Flush and clean the connector pins. Use electronic contact cleaner, Part Number 3824510.

Action

Inspect the intake manifold pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 122 inactive

Fault Code 122 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the intake manifold pressure/temperature sensor supply voltage.

Conditions

  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure/temperature sensor supply voltage.

  • Use a multimeter to measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25-VDC

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage out of the ECM from pin 40 to pin 37 at the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check the intake manifold pressure/temperature sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure/temperature sensor signal voltage.

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 0.42 to 0.58-VDC

Does not meet specifications.

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness and the ECM.

Guided Step 2A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins. Use electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 inactive

Fault Code 122 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 40 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 39 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 38 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 37 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from ECM.
  • Disconnect the intake manifold pressure/temperature sensor from sensor harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from pin 40 of the sensor harness connector at the ECM to pin 2 (or B) of the sensor harness connector, at the sensor end of the harness.
OK NOT OK

Less than 10 ohms?

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 4A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 inactive and Fault Code 123 active

Fault Code 122 active

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 122 is inactive.
OK NOT OK

Fault Code 122 inactive

Return to troubleshooting steps or contact a local Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 222, 352, and 452 are not active?
STEP 2. | Check for mechanical malfunction. |
 | STEP 2A. Check for proper operation of the turbocharger. | Positive intake manifold pressure from the turbocharger?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 123 inactive?
 | STEP 3C. Check the ECM intake manifold pressure/temperature sensor supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 3C-1. Measure the voltage from the ECM. |
 | STEP 3D. Check the ECM intake manifold pressure/temperature sensor signal voltage. | (+) 0.42 to 0.58-VDC?
 | STEP 3D-1. Check for a short circuit to ground. |
 | STEP 3D-2. Check for a short circuit from pin-to-pin. |
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 123 inactive?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check for an ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 123 inactive and Fault Code 122 active?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 222, 352, and 452 are not active

Possible sensor failure, short circuit to ground in sensor (+) 5-VDC common supply, or short circuit from pin to pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check for mechanical malfunction.

Guided Step 2A - Check for proper operation of the turbocharger.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check for proper operation of the turbocharger.

  • Check for positive intake manifold pressure.
OK NOT OK

Positive intake manifold pressure from the turbocharger

Low intake manifold pressure

Correct the base engine malfunction causing low intake manifold pressure.

Use the Signature™, ISX, and QSX15 Service Manual, Bulletin Number 3666239.

Go to 3A

Go to 6A

Guided Step 3 - Check the intake manifold pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the intake manifold pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 inactive

Fault Code 123 active.

Go to 6B

Go to 3C

Guided Step 3C - Check the ECM intake manifold pressure/temperature sensor supply voltage.

Conditions

  • Install the intake manifold pressure/temperature sensor breakout cable, Part Number 31262898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the ECM intake manifold pressure/temperature sensor supply voltage.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25-VDC

Does not meet specifications.

Go to 3D

Go to 3C-1

Guided Step 3C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage at the ECM from pin 37 to pin 40 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 3D - Check the ECM intake manifold pressure/temperature sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3162898, between the intake manifold pressure/temperature sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the ECM intake manifold pressure/temperature sensor signal voltage.

  • Measure the signal voltage from pin B (or BLACK) to pin C (or YELLOW) of the breakout cable.
OK NOT OK

(+) 0.42 to 0.58-VDC

Does not meet specifications.

Go to 3D-1

Go to 4A

Guided Step 3D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 39 of the sensor harness connector to chassis ground.
OK NOT OK

More than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3D-2

Go to 6A

Guided Step 3D-2 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 39 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 in Section 19.

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 inactive

Fault Code 123 active.

Go to 6B

Go to 4C

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 39 of the sensor harness connector to pin C (or 3) of the intake manifold pressure/temperature sensor connector, harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for an ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire between ECM sensor port pin 37 and pin 39.
OK NOT OK

Fault Code 123 inactive and Fault Code 122 active

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ to verify Fault Code 123 is inactive.
OK NOT OK

Fault Code 123 inactive

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


FAULT CODE 131 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the harness and the accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the accelerator position sensor resistance. | 250 to 3000 ohms?
 | STEP 1C. Check the resistance between sensor pins. Take the measurement when the pedal is depressed and released. | Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms; Released resistance must be at least 1000 ohms more than depressed resistance?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance between the (+) 5-VDC SUPPLY and RETURN wires. | 2000 to 3000 ohms?
 | STEP 2C. Check for a short between the (+) 5-VDC SUPPLY wire and the SIGNAL wire in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit between the accelerator position SIGNAL wire and RETURN wire in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit between the accelerator position SIGNAL wire and another SIGNAL wire or the switch SUPPLY wire. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit between the accelerator position SIGNAL wire and the wires connected to the stop lamp, warning lamp, and maintenance lamp. | Greater than 100k ohms?
 | STEP 2G. Check for a short circuit between the accelerator position SIGNAL wire and all other wires in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the accelerator position sensor. Use the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the (+) 5 VDC supply and the accelerator position sensor return on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch, a 6-pin repair connector, Part Number 3824910, for integrated sensor switch, and the breakout cable, Part Number 3824892, for solid state switch if needed.

OK NOT OK

250 to 3000 ohms?

Replace the accelerator position sensor

Use the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Take the measurement when the pedal is depressed and released.

  • Measure the resistance between the (+) 5-VDC SUPPLY and the SIGNAL wire on the sensor side of the accelerator position sensor.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch, a 6-pin repair connector, Part Number 3824910, for integrated sensor switch, and the breakout cable, Part Number 3824892, for solid state switch if needed.

OK NOT OK

Released: 1500 to 3000 ohms

Depressed: 250 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor

Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness, bulkhead connector, and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the resistance between the (+) 5-VDC SUPPLY and RETURN wires.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance between the (+) 5-VDC SUPPLY and RETURN wires.

  • Measure the resistance between pin 48 and pin 49 in the OEM harness when the accelerator pedal is up or down.
OK NOT OK

2000 to 3000 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short between the (+) 5-VDC SUPPLY wire and the SIGNAL wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance in the (+) 5-VDC SUPPLY wire and the SIGNAL wire circuit.

  • Measure the resistance between pin 48 and pin 47 when the accelerator pedal is released and when it is depressed.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit between the accelerator position SIGNAL wire and RETURN wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and RETURN wire in the OEM harness.

  • Measure the resistance from pin 47 to pin 49 in the OEM harness connector.

Turn all cab switches to the OFF or NEUTRAL position. Use the trailer handbrake to set the service brake. Disconnect the clutch switch and the idle validation switch.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit between the accelerator position SIGNAL wire and another SIGNAL wire or the switch SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the clutch and brake switches.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and another SIGNAL wire or the switch SUPPLY wire.

  • Measure the resistance between pin 47 and pins 1, 2, 3, and 13 of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit between the accelerator position SIGNAL wire and the wires connected to the stop lamp, warning lamp, and maintenance lamp.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and the wires connected to the stop lamp, warning lamp, and maintenance lamp.

  • Measure the resistance between pin 47 and pins 5, 6, and 16.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2G

Go to 3A

Guided Step 2G - Check for a short circuit between the accelerator position SIGNAL wire and all other wires in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and all other wires in the OEM harness.

  • Measure the resistance between pin 47 and all other pins in the OEM harness.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and depress the accelerator pedal to full position 3 times. Release the pedal and turn the keyswitch OFF.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive?

Return to troubleshooting steps or contact a Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 24-May-2012


Fault Code 132 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect the harness and the accelerator position sensor connector pins. | No damaged pins
 | STEP 1B. Check the accelerator position sensor resistance. | 2000 to 3000 ohms
 | STEP 1C. Check for a short circuit to ground of the sensor (+) 5-VDC supply. | More than 100k ohms
 | STEP 1D. Check for a short circuit to ground of the sensor signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply or signal wires of the OEM harness. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground in the accelerator position sensor (+) 5-VDC supply circuit. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground in the accelerator position sensor signal circuit. | More than 100k ohms
 | STEP 2E. Check for a short circuit between the (+) 5-VDC supply wire and any other wire in the OEM harness. | More than 100k ohms
 | STEP 2F. Check for a short circuit between the accelerator position signal wire and any other wire in the OEM harness. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 132 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the accelerator position sensor.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the accelerator position sensor resistance.

  • Measure the resistance between the (+) 5-VDC supply and the accelerator position sensor return on the sensor side of the accelerator position sensor connector, when the accelerator pedal is released.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch, a 6-pin repair connector, Part Number 3824910, for integrated sensor switch, and the breakout cable, Part Number 3824892, for solid state switch if needed.

OK NOT OK

2000 to 3000 ohms

Replace the accelerator position sensor

Refer to the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground of the sensor (+) 5-VDC supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground of the sensor (+) 5-VDC supply.

  • Measure the resistance from the (+) 5-VDC supply on the sensor side of the accelerator position sensor to chassis ground.
OK NOT OK

More than 100k ohms

Replace the accelerator position sensor

Refer to the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground of the sensor signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground of the sensor signal wire.

  • Measure the resistance from the SIGNAL pin of the accelerator position sensor to chassis ground.
OK NOT OK

More than 100k ohms

Replace the accelerator position sensor

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the ECM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the supply or signal wires of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the supply or signal wires of the OEM harness.

  • Measure the resistance between pin 47 of the OEM harness connector and the signal wire on the harness side of the accelerator sensor.
  • Measure the resistance between pin 48 of the OEM harness connector and the (+) 5-VDC supply on the harness side of the accelerator position sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground in the accelerator position sensor (+) 5-VDC supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the accelerator position sensor (+) 5-VDC supply circuit.

  • Measure the resistance between pin 48 of the OEM harness and the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the accelerator position sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the accelerator position sensor signal circuit.

  • Measure the resistance from pin 47 of the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit between the (+) 5-VDC supply wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit between the (+) 5-VDC supply wire and any other wire in the OEM harness.

  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit between the accelerator position signal wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit between the accelerator position signal wire and any other wire in the OEM harness.

  • Measure the resistance between pin 47 of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and depress the accelerator pedal to full position four times. Release the pedal and turn the keyswitch OFF.
  • Use INSITE™ to verify Fault Code 132 is inactive.
OK NOT OK

Fault Code 132 inactive

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jun-2012


Fault Code 133 - Remote Throttle Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Isolate the remote throttle position sensor circuit. |
 | STEP 1A. Inspect the OEM harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check for active fault codes. | Fault Codes 131, 132, and 352 are active
 | STEP 1C. Disconnect the remote throttle connector; check if fault code deactivates. | Fault Code 133 active
STEP 2. | Check the remote throttle position sensor. |
 | STEP 2A. Inspect the harness and the remote throttle position sensor connector pins. | No damaged pins
 | STEP 2B. Check the remote throttle position resistance. | 250 to 3000 ohms
 | STEP 2C. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms; Released resistance must be at least 1000 ohms more than depressed resistance
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit between the (+) 5-VDC supply and return wires. | 2000 to 3000 ohms
 | STEP 3C. Check for an open circuit in the return wire. | More than 100k ohms
 | STEP 3D. Check the resistance in the (+) 5-VDC supply wire and the signal wire circuit. | Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms
 | STEP 3E. Check for a short circuit between the remote throttle position signal wire and the supply wire in the OEM harness. | More than 100k ohms
 | STEP 3F. Check for a short circuit between the remote throttle position signal and supply wire to all other wires in the OEM harness connector. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Isolate the remote throttle position sensor circuit.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the remote throttle position sensor. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to check for active fault codes.
OK NOT OK

Fault Codes 131, 132, and 352 are active

Fault Code 131 inactive.

Go to 1C

Go to 4A

Guided Step 1C - Disconnect the remote throttle connector; check if fault code deactivates.

Conditions

  • Disconnect the remote throttle connector.

Action

Check if fault code deactivates.

  • Use INSITE™ electronic service tool to check for inactive fault codes.
OK NOT OK

Fault Code 133 active

Fault Code 133 inactive

Replace the remote throttle position sensor.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the remote throttle position sensor.

Guided Step 2A - Inspect the harness and the remote throttle position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the remote throttle position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the remote throttle position sensor. Refer to the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the remote throttle position resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check the remote throttle position resistance.

  • Measure the resistance between the (+) 5-VDC supply and the remote throttle position sensor return on the sensor side of the remote throttle position sensor when the remote throttle is released and when it is depressed.
OK NOT OK

250 to 3000 ohms

Replace the remote throttle position sensor

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check the resistance between sensor pins.

Take the measurement when the pedal is depressed and released.

  • Measure the resistance between the (+) 5-VDC supply and the signal wire on the sensor side of the remote throttle position sensor.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the remote throttle position sensor

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the remote throttle.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the short circuit between the (+) 5-VDC supply and return wires.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the remote throttle position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the short circuit between the (+) 5-VDC supply and return wires.

  • Measure the resistance between pin 48 and pin 49 in the OEM harness when the remote throttle pedal is up or down.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from pin 49 of the OEM harness connector to pin C (or 3) of the remote throttle position sensor connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance in the (+) 5-VDC supply wire and the signal wire circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the remote throttle position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance in the (+) 5-VDC supply wire and the signal wire circuit.

  • Measure the resistance between pin 48 and pin 21 of the OEM harness connector when the remote throttle is released and when it is depressed.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit between the remote throttle position signal wire and the supply wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit between the remote throttle position signal wire and the supply wire in the OEM harness.

  • Measure the resistance from pin 48 of the OEM harness connector to pin B (or 2) of the remote throttle position sensor connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit between the remote throttle position signal and supply wire to all other wires in the OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the negative battery terminal.

Action

Check for a short circuit between the remote throttle position signal and supply wire to all other wires in the OEM harness connector.

  • Measure the resistance from pin 21 and pin 48 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and depress the remote throttle to full position three times. Release the remote throttle and turn the keyswitch to OFF.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 133 is inactive.
OK NOT OK

Fault Code 133 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jun-2012


Fault Code 134 - Remote Throttle Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Isolate the remote throttle position sensor circuit. |
 | STEP 1A. Inspect the OEM harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check for active fault codes. | Fault Code 132 active
 | STEP 1C. Disconnect the remote throttle connector; check if fault code deactivates. | Fault Code 134 active
STEP 2. | Check the remote throttle position sensor. |
 | STEP 2A. Inspect the harness and the remote throttle position sensor connector pins. | No damaged pins
 | STEP 2B. Check the remote throttle position sensor resistance. | 2000 to 3000 ohms
 | STEP 2C. Check for a short circuit to ground on the remote throttle position sensor (+) 5-VDC supply wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground on the remote throttle position sensor signal wire. | More than 100k ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit in the supply or signal wires of the OEM harness. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground in the remote throttle position sensor (+) 5-VDC supply circuit. | More than 100k ohms
 | STEP 3D. Check for a short circuit to ground in the remote throttle position sensor signal circuit. | More than 100k ohms
 | STEP 3E. Check for a short circuit between the remote throttle position sensor (+) 5-VDC supply wire and any other wire in the OEM harness. | More than 100k ohms
 | STEP 3F. Check for a short circuit between the remote throttle position sensor signal wire and any other wire in the OEM harness. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Isolate the remote throttle position sensor circuit.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.
  • Replace the remote throttle position sensor. Use the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to check for active fault codes.
OK NOT OK

Fault Code 132 active

Fault Code 132 inactive.

Go to 1C

Go to 4A

Guided Step 1C - Disconnect the remote throttle connector; check if fault code deactivates.

Conditions

  • Disconnect the remote throttle connector.

Action

Check for deactivation of fault codes.

  • Check for inactive fault codes using INSITE™.
OK NOT OK

Fault Code 134 active

Fault Code 134 inactive

Replace the remote throttle position sensor.

Use the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the remote throttle position sensor.

Guided Step 2A - Inspect the harness and the remote throttle position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the remote throttle position sensor connector pins for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.
  • Replace the remote throttle position sensor. Use the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the remote throttle position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check the remote throttle position sensor resistance.

  • Measure the resistance between the (+) 5-VDC supply and the remote throttle position sensor return on the sensor side of the remote throttle position sensor when the remote throttle is released.
OK NOT OK

2000 to 3000 ohms

Replace the remote throttle position sensor

Use the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground on the remote throttle position sensor (+) 5-VDC supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for a short circuit to ground on the remote throttle position sensor (+) 5-VDC supply.

  • Measure the resistance between the (+) 5-VDC supply on the sensor side of the remote throttle position sensor and the chassis ground.
OK NOT OK

More than 100k ohms

Replace the remote throttle position sensor

Use the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground on the remote throttle position sensor signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Check for a short circuit to ground on the remote throttle position sensor signal wire.

  • Measure the resistance between the signal wire on the sensor side of the remote throttle position sensor and the chassis ground.
OK NOT OK

More than 100k ohms

Replace the remote throttle position sensor

Use the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the remote throttle position sensor.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the supply or signal wires of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the supply or signal wires of the OEM harness.

  • Measure the resistance between pin 48 of the OEM harness connector and the (+) 5-VDC supply on the harness side of the remote throttle position sensor.
  • Measure the resistance between pin 21 of the OEM harness connector and the signal wire on the harness side of the remote throttle position sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the remote throttle position sensor (+) 5-VDC supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the remote throttle position sensor (+) 5-VDC supply circuit.

  • Measure the resistance between pin 48 of the OEM harness connector and the chassis ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the remote throttle position sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the remote throttle position sensor signal circuit.

  • Measure the resistance between pin 21 of the OEM harness connector and the chassis ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit between the remote throttle position sensor (+) 5-VDC supply wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM negative (-) battery terminal.

Action

Check for a short circuit between the remote throttle position sensor (+) 5-VDC supply wire and any other wire in the OEM harness.

  • Measure the resistance between pin 48 of the OEM harness connector and all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit between the remote throttle position sensor signal wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote throttle position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM negative (-) battery terminal.

Action

Check for a short circuit between the remote throttle position sensor signal wire and any other wire in the OEM harness.

  • Measure the resistance between pin 21 of the OEM harness connector and all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and depress the remote throttle to full position three times. Release the remote throttle and turn the keyswitch OFF.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 134 is inactive.
OK NOT OK

Fault Code 134 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jul-2012


Fault Code 135 - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure/temperature sensor. |
 | STEP 1A. Inspect the oil pressure/temperature sensor and the engine harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 135 inactive
 | STEP 1C. Check the oil pressure/temperature sensor supply voltage. | (+) 4.75 to 5.25-VDC
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the oil pressure/temperature sensor signal voltage. | (+) 0.50 to 1.40-VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 135 inactive
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit in the return wire. | Less than 10 ohms
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 135 inactive; Fault Code 141 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the oil pressure/temperature sensor.

Guided Step 1A - Inspect the oil pressure/temperature sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the oil pressure/temperature sensor and the engine harness connector pins for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 inactive

Fault Code 135 active

Go to 4B

Go to 1C

Guided Step 1C - Check the oil pressure/temperature sensor supply voltage.

Conditions

  • Install breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the oil pressure/temperature sensor supply voltage.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25-VDC

Does not meet specifications

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage at the ECM from pin 45 to pin 43 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM

Refer to Procedure 019-031 in Section 19

Go to 4A

Go to 4A

Guided Step 1D - Check the oil pressure/temperature sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the oil pressure/temperature sensor signal voltage.

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

0.50 to 1.40-VDC

Does not meet specifications

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 inactive

Fault Code 135 active

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 44 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from pin 43 of the sensor harness connector to pin B (or 2) on the harness side of the oil pressure/temperature sensor connector.
OK NOT OK

Less than 10 ohms

Replace the oil pressure/temperature sensor.

Refer to Procedure 019-155 in Section 19

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Disconnect the sensor harness connector from the ECM.
  • Use INSITE™ electronic service tool to check for the appropriate ECM response.
OK NOT OK

Fault Code 135 inactive; Fault Code 141 active

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 135 is inactive.
OK NOT OK

Fault Code 135 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jun-2012


Fault Code 141 - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 452, and 484 not active
STEP 2. | Check the oil pressure/temperature sensor. |
 | STEP 2A. Inspect the oil pressure/temperature sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 141 inactive
 | STEP 2C. Check the oil pressure/temperature sensor supply voltage. | (+) 4.75 to 5.25-VDC
 | STEP 2C-1. Check the voltage from the ECM. |
 | STEP 2D. Check the oil pressure/temperature sensor signal voltage. | (+) 0.50 to 1.40-VDC
 | STEP 2D-1. Check for a short circuit to ground. |
 | STEP 2D-2. Check for a short circuit from pin to pin. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector for damaged pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 141 inactive
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 141 inactive and Fault Code 135 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 141 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 452, and 484 not active

Possible sensor malfunction, a short circuit to ground in the sensor (+) 5-VDC common supply, or a short circuit from pin to pin.

Go to 2A

Fault Code 187

Guided Step 2 - Check the oil pressure/temperature sensor.

Guided Step 2A - Inspect the oil pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the oil pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 inactive

Fault Code 141 active

Go to 5B

Go to 2C

Guided Step 2C - Check the oil pressure/temperature sensor supply voltage.

Conditions

  • Disconnect the engine harness from the oil pressure sensor.
  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the oil pressure/temperature sensor supply voltage.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) on the harness side of the oil pressure sensor.
OK NOT OK

(+) 4.75 to 5.25-VDC

Does not meet specifications

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Set the multimeter to the voltage function and connect the two test leads to the multimeter.
  • Turn keyswitch ON.

Action

Disconnect the sensor harness connector from the ECM.

  • Measure the voltage from pin 45 to pin 43 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Check the oil pressure/temperature sensor signal voltage.

Conditions

  • Disconnect the oil pressure/temperature sensor from the engine harness.
  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the oil pressure/temperature sensor signal voltage.

  • Measure the voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 0.50 to 1.40-VDC

Does not meet specifications

Go to 2D-1

Go to 3A

Guided Step 2D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 44 (or pressure signal) of the sensor harness connector to chassis ground.
OK NOT OK

More than 100k ohms

Replace the engine harness

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 44 (or pressure signal) of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the oil pressure sensor.

Refer to Procedure 019-155 in Section 19.

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the engine harness and ECM connector for damaged pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 inactive

Fault Code 141 active

Go to 5B

Go to 3C

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 44 (or pressure signal) of the sensor harness connector to pin C (or 3) of the oil pressure sensor connector, harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire between the ECM sensor port pin 44, the pressure signal and pin 45, the (+) 5-VDC supply.
OK NOT OK

Fault Code 141 inactive and Fault Code 135 active

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 141 is inactive and did not reoccur.
OK NOT OK

Fault Code 141 inactive

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jun-2012


FAULT CODE 143 - Engine Oil Pressure Low - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES | NO
No Repair | No Repair

Use Lubricating Oil Pressure Low troubleshooting symptom tree in the TS section of the service manual.

Repair complete

Last Modified: 09-Sep-2013


Fault Code 144 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the coolant temperature sensor and sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 144 inactive
 | STEP 1C. Check the resistance of the coolant temperature sensor. | 300 ohms to 90k ohms
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 144 inactive
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 144 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant temperature sensor.

Guided Step 1A - Inspect the coolant temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.

Action

Inspect the coolant temperature sensor and sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 144 inactive

Fault Code 144 active

Go to 3B

Go to 1C

Guided Step 1C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the coolant temperature sensor.
OK NOT OK

300 ohms to 90k ohms

Replace the coolant temperature sensor

Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Useelectrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 144 inactive

Fault Code 144 active

Go to 3B

Go to 2C

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the sensor harness connector to all other pins.
  • Measure the resistance from pin 13 of the sensor harness connector to all other pins.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 of the sensor harness connector to pin B (or 2) of the coolant temperature sensor connector.
  • Measure the resistance from pin 13 of the sensor harness connector to pin A (or 1) of the coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 144 is inactive.
OK NOT OK

Fault Code 144 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jun-2012


Fault Code 145 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack test lead and Part Number 3823256 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the coolant temperature sensor and sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 145 inactive
 | STEP 1C. Check the resistance of the coolant temperature sensor. | 300 ohms to 90k ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 145 inactive
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 145 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant temperature sensor.

Guided Step 1A - Inspect the coolant temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.

Action

Inspect the coolant temperature sensor and sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the sensor harness, or replace the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 inactive

Fault Code 145 active

Go to 3B

Go to 1C

Guided Step 1C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the coolant temperature sensor.
OK NOT OK

300 ohms to 90k ohms

Replace the coolant temperature sensor

Refer to Procedure 019-019 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A (or 1) of the coolant temperature sensor to engine block ground.
  • Measure the resistance from pin B (or 2) of the coolant temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor

Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 inactive

Fault Code 145 active

Go to 3B

Go to 2C

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 13 of the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 145 is inactive.
OK NOT OK

Fault Code 145 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jun-2012


Fault Code 147 (INDUSTRIAL) - Frequency Throttle Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and the actuator harness connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 147 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and the actuator harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.

Action

Inspect the OEM harness and the actuator harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the actuator harness at the 31-pin connector.
  • Connect the frequency throttle to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 22 of the OEM 31-pin connector to engine block ground.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM engine harness from the frequency throttle.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 22 of the OEM 31-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM engine harness from the frequency throttle.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 22 of the OEM engine harness 31-pin connector to all other pins in the connector, except pin 21.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the actuator harness at the 31 pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 30 of the actuator harness connector to pin 22 of the engine harness 31 pin OEM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the actuator harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 30 of the actuator harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the actuator harness at the 31 pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 30 of the actuator harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 147 is inactive.
OK NOT OK

Fault Code 147 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


Fault Code 148 (INDUSTRIAL) - Frequency Throttle Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and the actuator harness connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 148 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 148 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and the actuator harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness from the actuator harness at the 31-pin connector.

Action

Inspect the OEM harness and the actuator harness connectors for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the frequency throttle from the OEM harness at the 2-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 22 to pin B of the frequency throttle connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19, or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Connect the frequency throttle to the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 22 of the OEM harness 31-pin connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the frequency throttle from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 22 of the OEM harness 31-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connectors for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31 pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 30 of the actuator harness connector to pin 22 of the 31 pin connector on the actuator side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 30 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 30 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 148 inactive

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 148 is inactive.
OK NOT OK

Fault Code 148 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure/temperature sensor. |
 | STEP 1A. Inspect the intake manifold pressure/temperature sensor and the sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 153 inactive
 | STEP 1C. Check the resistance of the intake manifold pressure/temperature sensor. | 300 ohms to 90k ohms
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 153 inactive
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 153 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the intake manifold pressure/temperature sensor.

Guided Step 1A - Inspect the intake manifold pressure/temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 153 inactive

Fault Code 153 active

Go to 3B

Go to 1C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1C - Check the resistance of the intake manifold pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

–

  • Measure the resistance from pin 4 (or D) to pin 2 (or B) of the intake manifold pressure/temperature sensor.
OK NOT OK

300 ohms to 90k ohms

Replace the intake manifold pressure/temperature sensor

Refer to Procedure 019-159.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 153 inactive

Fault Code 153 active

Go to 3B

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 40 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 38 to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 40 of the sensor harness connector to pin 2 (or B) of the intake manifold pressure/temperature sensor connector, harness side.
  • Measure the resistance from pin 38 of the sensor harness connector to pin 4 (or D) of the intake manifold pressure/temperature sensor connector, harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-204, or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 153 is inactive.
OK NOT OK

Fault Code 153 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 145 and 213 not active
STEP 2. | Check the intake manifold pressure/temperature sensor. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and the sensor harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 154 inactive
 | STEP 2C. Check the resistance of the intake manifold pressure/temperature sensor. | 300 ohms to 90k ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 154 inactive
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 145 and 213 not active

Fault Code 145 or 213 active

Go to 2A

Fault Code 352

Guided Step 2 - Check the intake manifold pressure/temperature sensor.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 154 inactive

Fault Code 154 active

Go to 4B

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 2C - Check the resistance of the intake manifold pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

–

  • Measure the resistance from pin 4 (or D) to pin 2 (or B) of the intake manifold pressure/temperature sensor.
OK NOT OK

300 ohms to 90k ohms

Replace the intake manifold pressure/temperature sensor

Refer to Procedure 019-159.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

–

  • Measure the resistance from pin 4 (or D) of the intake manifold pressure/temperature sensor to the engine block.
OK NOT OK

More than 100k ohms

Replace the intake manifold pressure/temperature sensor

Refer to Procedure 019-159.

Go to 3A

Go to 4A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 154 inactive

Fault Code 154 active

Go to 4B

Go to 3C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 37 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 38 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to the ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 37 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 38 of the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 154 is inactive.
OK NOT OK

Fault Code 154 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor the intake manifold air temperature reading. |
 | STEP 1A. Monitor the intake manifold air temperature reading. | The temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?

Guided Step 1 - Monitor the intake manifold air temperature reading.

Guided Step 1A - Monitor the intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.
OK NOT OK

The temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge.

Reference the Intake Manifold Air Temperature Above Specification symptom tree.

  • Reference Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS of the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

The temperature sensor reading with INSITE™ electronic service tool does not correlate to a known value or a mechanical gauge?

Replace the intake manifold air temperature sensor.

Refer to Procedure 019-159 in Section 19.

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 24-May-2012


FAULT CODE 187 - Sensor Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for the failed sensors. |
 | STEP 1A. Check the oil pressure/temperature sensor. | Less than + 4.5-VDC?
 | STEP 1B. Check the front fuel rail pressure sensor. | Less than + 4.5-VDC?
 | STEP 1C. Check the rear fuel rail pressure sensor. | Less than + 4.5-VDC?
 | STEP 1D. Check the fuel inlet restriction sensor. | Less than + 4.5-VDC?
 | STEP 1E. Check the wet tank pressure sensor. | Less than + 4.5-VDC?
 | STEP 1F. Check the coolant level sensor. | Less than + 4.5-VDC?
 | STEP 1G. Check the Top 2 transmission position sensor. | Less than + 4.5-VDC?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the supply voltage from the ECM. | + 4.75 to 5.25-VDC?
 | STEP 2C. Check for a short circuit to ground in the sensor supply lines. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for the failed sensors.

Guided Step 1A - Check the oil pressure/temperature sensor.

Conditions

  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the oil pressure/temperature sensor.

  • Measure the voltage from pin 1 (or A) to pin 2 (or B) on the oil pressure/temperature sensor connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the oil pressure/temperature sensor.

Refer to Procedure 019-155 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the front fuel rail pressure sensor.

Conditions

  • Disconnect the engine harness from the front fuel rail pressure sensor.
  • Turn keyswitch ON.

Action

Check the front fuel rail pressure sensor.

  • Measure the voltage from pin 1 (or A) to pin 2 (or B) on the front fuel rail pressure sensor connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the front fuel rail pressure sensor.

Refer to Procedure 019-115 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the rear fuel rail pressure sensor.

Conditions

  • Disconnect the engine harness from the rear fuel rail pressure sensor.
  • Turn keyswitch ON.

Action

Check the rear fuel rail pressure sensor.

  • Measure the voltage from pin 1 (or A) to pin 2 (or B) on the rear fuel rail pressure sensor connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the rear fuel rail pressure sensor.

Refer to Procedure 019-115 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check the fuel inlet restriction sensor.

Conditions

  • OPTIONAL EQUIPMENT; check vehicle to see if so equipped.
  • If not equipped, go to Step 1E.
  • Disconnect the engine harness from the fuel inlet restriction sensor.
  • Turn keyswitch ON.

Action

Check the fuel inlet restriction sensor.

  • Measure the voltage from pin 1 (or A) to pin 2 (or B) on the fuel inlet restriction sensor connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the fuel inlet restriction sensor.

Refer to Procedure 019-128 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check the wet tank pressure sensor.

Conditions

  • OPTIONAL EQUIPMENT; check vehicle to see if so equipped.
  • If not equipped, go to Step 1F.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Turn keyswitch ON.

Action

Check the wet tank pressure sensor.

  • Measure the voltage from pin 1 (or A) to pin 2 (or B) on the wet tank pressure sensor connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the wet tank pressure sensor/governor assembly.

Use the OEM troubleshooting and repair manual.

Go to 1F

Go to 3A

Guided Step 1F - Check the coolant level sensor.

Conditions

  • Disconnect the engine harness from the coolant level sensor.
  • Turn keyswitch ON.

Action

Check the coolant level sensor.

  • Measure the voltage from supply pin 3 (or C) to return pin 2 (or B) on the coolant level sensor connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the coolant level sensor.

Refer to Procedure 019-017 in Section 19.

Go to 1G

Go to 3A

Guided Step 1G - Check the Top 2 transmission position sensor.

Conditions

  • OPTIONAL EQUIPMENT; check vehicle to see if so equipped.
  • Following step only applies if vehicle has Spicer Top 2 transmission.
  • If not equipped, go to Step 2A.
  • Disconnect the engine harness from the Top 2 transmission position sensor.
  • Turn keyswitch ON.

Action

Check the Top 2 transmission position sensor.

  • Measure the voltage from pin 1 (or A) to pin 2 (or B) on the Top 2 transmission position connector.
OK NOT OK

Less than + 4.5-VDC?

Replace the Top 2 transmission position sensor.

Use the OEM troubleshooting and repair manual for proper procedure.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the supply voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage from the ECM.

  • Measure the supply voltage out of the ECM sensor harness connector port from pins 5, 18, 25, 35, and 45 to ground.
  • Measure the supply voltage out of the ECM actuator harness connector port from pins 19 and 29 to ground.
OK NOT OK

+ 4.75 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground in the sensor supply lines.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground in the sensor supply lines.

  • Measure the resistance from pins 5, 18, 25, 35, and 45 in the sensor harness connector to engine block ground.
  • Measure the resistance from pins 19 and 29 in the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness and actuator harness connectors from the ECM.
  • Disconnect the oil pressure/temperature sensor from the engine harness.
  • Disconnect the front fuel rail pressure sensor from the engine harness.
  • Disconnect the rear fuel rail pressure sensor from the engine harness.
  • Disconnect the fuel inlet restriction sensor from the engine harness.
  • Disconnect the wet tank pressure sensor from the engine harness.
  • Disconnect the coolant level sensor from the engine harness.
  • Disconnect the Top 2 transmission position sensor (if equipped) from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 5 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 18 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 25 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 35 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 45 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 19 to all other pins in the actuator harness connector.
  • Measure the resistance from pin 29 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 187 is inactive.
OK NOT OK

Fault Code 187 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 198 - ICON™ Lamp Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM wiring harness. |
 | STEP 1A. Check the OEM wiring harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to the battery. | Less than (+) 1.5 VDC
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 198 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM wiring harness.

Guided Step 1A - Check the OEM wiring harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for a short circuit to the battery.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Remove the bulb from the ICON™ lamp holder.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage from pin 4 in the OEM harness connector at the ECM to ground.
OK NOT OK

Less than (+) 1.5 VDC

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Remove the bulb from the ICON™ lamp holder.
  • Turn keyswitch OFF.

Action

–

  • Measure the resistance from pin 4 in the OEM harness connector at the ECM to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

–

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 198 is inactive.
OK NOT OK

Fault Code 198 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 199 - ICON™ Lamp Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ICON™ lamp. |
 | STEP 1A. Check the bulb for continuity. | Less than 10 ohms
 | STEP 1B. Check for voltage to ICON™ lamp. | More than (+) 6 VDC
STEP 2. | Check the OEM wiring harness. |
 | STEP 2A. Check the OEM wiring harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 199 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ICON™ lamp bulb.

Guided Step 1A - Check the bulb for continuity.

Conditions

  • Turn keyswitch OFF.
  • Remove the ICON™ lamp bulb from the bulb holder.
  • Apply one test lead to a bulb contact; apply other test lead to the other contact.

Action

–

  • Use a multimeter to check the resistance of the bulb.
OK NOT OK

Less than 10 ohms

Replace the bulb

Go to 1B

Go to 3A

Guided Step 1B - Check for voltage to ICON™ lamp.

Conditions

  • Remove the ICON™ lamp bulb from holder.
  • Turn keyswitch ON.

Action

–

  • Use a multimeter to measure the voltage at the lamp bulb holder keyswitch side (power side) to chassis ground.
OK NOT OK

More than (+) 6 VDC

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM wiring harness.

Guided Step 2A - Check the OEM wiring harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Remove the ICON™ lamp bulb from the bulb holder.

Action

–

  • Measure the resistance from pin 4 of the OEM harness connector at the ECM to the return side (ECM side) of the ICON™ lamp bulb holder.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the ICON™ lamp bulb from bulb holder.
  • Disconnect the OEM harness connector from the ECM.

Action

–

  • Measure the resistance from pin 4 of the OEM harness connector at the ECM to ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Remove the ICON™ lamp bulb from the bulb holder.
  • Disconnect the OEM harness connector from the ECM.

Action

–

  • Measure the resistance from pin 4 of the OEM harness connector at the ECM to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

–

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 199 is inactive.
OK NOT OK

Fault Code 199 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 212 - Oil Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure/temperature sensor. |
 | STEP 1A. Inspect the oil pressure/temperature sensor and sensor harness connector pins. | Dirty damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 212 inactive?
 | STEP 1C. Check the resistance of the oil pressure/temperature sensor. | 300 ohms to 90k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 212 inactive
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the oil pressure/temperature sensor.

Guided Step 1A - Inspect the oil pressure/temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the oil pressure/temperature sensor and sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-155 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 inactive

Fault Code 212 active

Go to 3B

Go to 1C

Guided Step 1C - Check the resistance of the oil pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check the resistance of the oil pressure/temperature sensor.

  • Measure the resistance from pin 4 (or D) to pin 2 (or B) of the oil pressure/temperature sensor.
OK NOT OK

300 ohms to 90k ohms?

Replace the oil pressure/temperature sensor.

Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 inactive

Fault Code 212 active

Go to 3B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 42 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 43 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 42 of the sensor harness connector to pin 4 (or D) of the oil pressure/temperature sensor.
  • Measure the resistance from pin 43 of the sensor harness connector to pin 2 (or B) of the oil pressure/temperature sensor.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 212 is inactive.
OK NOT OK

Fault Code 212 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 145 and 154 not active
STEP 2. | Check the oil pressure/temperature sensor. |
 | STEP 2A. Inspect the oil pressure/temperature sensor and the sensor harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 213 inactive
 | STEP 2C. Check the resistance of the oil pressure/temperature sensor. | 300 ohms to 90k ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 213 inactive
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 145 and 154 and are not active

Does not meet specifications

Go to 2A

Fault Code 187

Guided Step 2 - Check the oil pressure/temperature sensor.

Guided Step 2A - Inspect the oil pressure/temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 orRefer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the oil pressure/temperature sensor. Refer to Procedure 019-155.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 213 inactive

Fault Code 213 active

Go to 4B

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the resistance of the oil pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

–

  • Measure the resistance from pin 4 (or D) to pin 2 (or B) of the oil pressure/temperature sensor.
OK NOT OK

300 ohms to 90k ohms

Replace the oil pressure/temperature sensor

Refer to Procedure 019-155.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

–

  • Measure the resistance from pin 4 (or D) of the oil pressure/temperature sensor to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the oil pressure/temperature sensor

Refer to Procedure 019-155.

Go to 3A

Go to 4A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 213 inactive

Fault Code 213 active

Go to 4B

Go to 3C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 42 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 43 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 42 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 43 of the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 213 is inactive.
OK NOT OK

Fault Code 213 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


FAULT CODE 214 - Engine Oil Temperature High - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Active or inactive counts of Fault Code 214?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 214?
YES | NO
No Repair | No Repair

Use the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Repair complete

Last Modified: 25-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wet tank pressure sensor. |
 | STEP 1A. Inspect the sensor harness and sensor connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 216 inactive
 | STEP 1C. Check the supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 1C-1. Measure the voltage from the ECM. |
STEP 2. | Check the sensor harness and the ECM. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 216 inactive
 | STEP 2C. Check for a short circuit from the signal wire to all other wires in the engine harness. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 216 inactive and Fault Code 217 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 216 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the wet tank pressure sensor.

Guided Step 1A - Inspect the sensor harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wet tank pressure sensor from the engine harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 or Refer to Procedure 019-207.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the air compressor governor assembly. Refer to Procedure 019-169.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 216 inactive

Fault Code 216 active

Go to 4B

Go to 1C

CAUTION

To reduce the possibility of pin and harness damage use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check the supply voltage.

Conditions

  • Disconnect the engine harness from the wet tank pressure sensor.
  • Turn keyswitch ON.

Action

–

  • Measure the supply voltage from pin 1 (or A) to pin 2 (or B) of the wet tank pressure sensor connector, engine harness side.
OK NOT OK

(+) 4.75 to 5.25 VDC

Does not meet specifications

Go to 2A

Go to 1C-1

CAUTION

To reduce the possibility of damaging the ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the wet tank pressure sensor from the sensor harness.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage at the ECM from pin 18 to pin 20 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Replace the ECM

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 2 - Check the sensor harness and the ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the wet tank pressure sensor from the engine harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 216 inactive

Fault Code 216 active

Go to 4B

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from the signal wire to all other wires in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 19 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 19 in the sensor harness connector to all pins in the actuator harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 20 of the sensor harness connector to pin 2 of the wet tank pressure sensor harness connector, engine harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204, Refer to Procedure 019-205, or Refer to Procedure 019-207.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Use INSITE™ to check for the appropriate ECM response.
OK NOT OK

Fault Code 216 inactive and Fault Code 217 active

Replace the air compressor governor assembly

Refer to Procedure 019-169.

Replace the ECM

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 216 is inactive.
OK NOT OK

Fault Code 216 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location, if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 inactive
STEP 2. | Check the wet tank pressure sensor. |
 | STEP 2A. Inspect the sensor harness and sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 217 inactive
 | STEP 2C. Check the supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 2C-1. Measure the voltage from the ECM. |
STEP 3. | Check the sensor harness and the ECM. |
 | STEP 3A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 217 inactive
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 216 inactive and Fault Code 217 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 217 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 187 inactive

Possible sensor failure, short circuit to ground in sensor (+) 5 VDC common supply, or short circuit from pin to pin.

Go to 2A

Fault Code 187

Guided Step 2 - Check the wet tank pressure sensor.

Guided Step 2A - Inspect the sensor harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wet tank pressure sensor from the engine harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 or Refer to Procedure 019-207.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the electronic air compressor governor assembly. Refer to Procedure 019-169.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 217 inactive

Fault Code 217 active

Go to 5B

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the supply voltage.

Conditions

  • Disconnect the engine harness from the wet tank pressure sensor.
  • Turn keyswitch ON.

Action

–

  • Measure the supply voltage from pin 1 (or A) to pin 2 (or B) on the wet tank pressure sensor, engine harness side.
OK NOT OK

(+) 4.75 to 5.25 VDC

Does not meet specifications

Go to 3A

Go to 2C-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the wet tank pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage at the ECM from pin 18 to pin 20 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Replace the ECM

Refer to Procedure 019-031.

Go to 5A

Go to 5A

Guided Step 3 - Check the sensor harness and the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the wet tank pressure sensor from the engine harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 217 inactive

Fault Code 217 active

Go to 5B

Go to 3C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 19 of the sensor harness connector to pin 3 (or C) of the wet tank pressure sensor harness connector, engine harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204, Refer to Procedure 019-205, or Refer to Procedure 019-207.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 19 of the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3E

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wet tank pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 19 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Install a jumper wire between the ECM sensor port pin 18 and pin 19.
OK NOT OK

Fault Code 217 inactive and Fault Code 216 active

Replace the electronic air compressor governor assembly.

Refer to Procedure 019-169.

Replace the ECM

Refer to Procedure 019-031.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 217 is inactive.
OK NOT OK

Fault Code 217 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location, if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 218 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

–

  • Connect a mechanical pressure gauge to the wet tank.
  • Connect INSITE™ to the vehicle datalink.
  • Start engine and compare the service tool monitor screen to reading on mechanical pressure gauge.
OK NOT OK

Sensor reading is correct

Use the Air Compressor troubleshooting symptom trees in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239.

Replace the electronic air compressor governor

Refer to Procedure 019-169.

Troubleshooting symptom trees

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 218 is inactive.
OK NOT OK

Fault Code 218 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes with INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ambient air pressure sensor. |
 | STEP 1A. Inspect the ambient air pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 221 inactive
 | STEP 1C. Check the ECM ambient air pressure sensor supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the ECM ambient air pressure sensor signal voltage. | Altitude (ft) Voltage (VDC); 0 (sea level) - (+) 3.40 to 4.50; 3000 - (+) 2.80 to 3.80; 6000 - (+) 2.20 to 3.25; 9000 - (+) 1.70 to 2.70; 12000 - (+) 1.20 to 2.20
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector for damaged pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 221 inactive
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit in the return wire. | Less than 10 ohms
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 221 inactive and Fault Code 222 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ambient air pressure sensor.

Guided Step 1A - Inspect the ambient air pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 221 inactive

Fault Code 221 active

Go to 4B

Go to 1C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check the ECM ambient air pressure sensor supply voltage.

Conditions

  • Install breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Turn keyswitch ON.

Action

–

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25 VDC

Does not meet specifications

Go to 1D

Go to 1C-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage at the ECM from pin 17 to pin 31 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Replace the ECM

Refer to Procedure 019-031.

Go to 4A

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3824774 - breakout cable.
Guided Step 1D - Check the ECM ambient air pressure sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Turn keyswitch ON.

Action

–

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

Altitude (ft) Voltage (VDC)

0 (sea level) - (+) 3.40 to 4.50

3000 - (+) 2.80 to 3.80

6000 - (+) 2.20 to 3.25

9000 - (+) 1.70 to 2.70

12000 - (+) 1.20 to 2.20

Does not meet specifications

Go to 3A

Go to 2A

Guided Step 2 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 221 inactive

Fault Code 221 active

Go to 4B

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 6 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

–

  • Measure the resistance from pin 31 of the sensor harness connector to the engine block ground.
OK NOT OK

Less than 10 ohms

Replace the ambient air pressure sensor.

Refer to Procedure 019-004.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Disconnect the sensor harness connector from the ECM.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 221 inactive and Fault Code 222 active

Replace the ECM

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 221 is inactive.
OK NOT OK

Fault Code 221 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


FAULT CODE 222 - Ambient Air Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 123 inactive?
STEP 2. | Check the ambient air pressure sensor. |
 | STEP 2A. Inspect the ambient air pressure sensor and sensor harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 222 inactive?
 | STEP 2C. Check the ECM ambient air pressure supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 2D. Check the ECM ambient air pressure signal voltage. | Altitude meters [ft] - Voltage (VDC); 0 (sea level) - (+) 3.40 to 4.50; 914 meters [3000 ft] - (+) 2.80 to 3.80; 1829 meters [6000 ft] - (+) 2.20 to 3.25; 2743 meters [9000 ft] - (+) 1.70 to 2.70; 3658 meters [12000 ft] - (+) 1.20 to 2.20?
 | STEP 2D-1. Check for a short circuit to ground. |
 | STEP 2D-2. Check for a short circuit from pin-to-pin. |
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 222 inactive?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 222 inactive and Fault Code 221 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 inactive?

Does not meet specifications.

Go to 2A

Fault Code 352

Guided Step 2 - Check the ambient air pressure sensor.

Guided Step 2A - Inspect the ambient air pressure sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Inspect the ambient air pressure sensor and sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the ECM ambient air pressure supply voltage.

Conditions

  • Install the breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure supply voltage.

  • Use a multimeter to measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Does not meet specifications.

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage at the ECM from pin 17 to pin 31 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Check the ECM ambient air pressure signal voltage.

Conditions

  • Install the breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure signal voltage.

  • Measure the signal voltage from pin B (or BLACK) to pin C (or YELLOW) of the breakout cable.
OK NOT OK

Altitude meters [ft] - Voltage (VDC)

0 (sea level) - (+) 3.40 to 4.50

914 meters [3000 ft] - (+) 2.80 to 3.80

1829 meters [6000 ft] - (+) 2.20 to 3.25

2743 meters [9000 ft] - (+) 1.70 to 2.70

3658 meters [12000 ft] - (+) 1.20 to 2.20

Does not meet specifications?

Go to 2D-1

Go to 3A

Guided Step 2D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from sensor harness connector pin 6 to the chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms.

Replace the ambient air pressure sensor.

Refer to Procedure 019-004 in Section 19.

Replace the engine harness.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit in the ambient air pressure signal wire.

  • Measure the resistance from sensor harness connector pin 6 to the ambient air pressure sensor signal pin C (or 3).
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire between ECM sensor port pin 6 and pin 17.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive and Fault Code 221 active?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 222 is inactive.
OK NOT OK

Fault Code 222 inactive?

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the burn valve solenoid. |
 | STEP 1A. Verify the burn valve solenoid is connected to the engine harness. | Solenoid is connected
 | STEP 1B. Inspect the burn valve solenoid and the solenoid connector on the engine harness. | No damaged pins
 | STEP 1C. Check the burn valve solenoid for an open circuit. | Less than 120 ohms
 | STEP 1D. Check the burn valve solenoid for a short circuit. | More than 80 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2B-1. Check for an open circuit in the Centinel™ jumper harness. |
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C-1. Check for a short circuit to ground in the Centinel™ jumper harness. |
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 223 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the burn valve solenoid.

Guided Step 1A - Verify the burn valve solenoid is connected to the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

–

  • Verify the burn valve solenoid is connected to the engine harness.
OK NOT OK

Solenoid is connected

Connect the solenoid to the engine harness.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the burn valve solenoid and the solenoid connector on the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the burn valve solenoid.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or replace the burn valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the burn valve solenoid. Use the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check the burn valve solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the engine harness.

Action

–

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the burn valve solenoid connector.
OK NOT OK

Less than 120 ohms

Replace the burn valve solenoid

Use the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check the burn valve solenoid for a short circuit.

Conditions

  • Disconnect the engine harness from the burn valve solenoid.

Action

–

  • Measure the resistance from pin A (or 1) of the burn valve solenoid to engine block ground.
OK NOT OK

More than 80 ohms

Replace the burn valve solenoid

Use the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 34 of the actuator harness connector to pin 5 of the burn valve solenoid, harness side.
  • Measure the resistance from pin 43 of the actuator harness connector to pin 6 of the burn valve solenoid, harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204, Refer to Procedure 019-205, or Refer to Procedure 019-207.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2B-1

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B-1 - Check for an open circuit in the Centinel™ jumper harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the jumper harness from the burn valve solenoid.
  • Disconnect the jumper harness from the engine harness.

Action

–

  • Measure the resistance from the signal pin of the 2-pin connector end of the Centinel™ jumper harness to pin 5 of the 6-pin connector end of the harness.
  • Measure the resistance from the return pin of the 2-pin connector end of the Centinel™ jumper harness to pin 6 of the 6-pin connector end of the harness.
OK NOT OK

Less than 10 ohms

Repair or replace the Centinel™ jumper harness

Use the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 34 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 43 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C-1

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C-1 - Check for a short circuit to ground in the Centinel™ jumper harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the jumper harness from the burn valve solenoid.
  • Disconnect the jumper harness from the engine harness.

Action

–

  • Measure the resistance from pin A (or 1) of the 2-pin jumper harness connector to engine block ground.
  • Measure the resistance from pin B (or 2) of the 2-pin jumper harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the Centinel™ jumper harness

Use the Centinel™ Master Repair Manual, Bulletin 3666231.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking measurements:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the burn valve solenoid.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 31-pin OEM connector.

Action

–

  • Measure the resistance from pin 34 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 43 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 223 is inactive.
OK NOT OK

Fault Code 223 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor and actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check the supply voltage from the ECM. | (+) 4.75 to 5.25 VDC
 | STEP 1C. Check for a short circuit to battery in the sensor supply lines. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 227 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor and actuator harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check the supply voltage from the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the supply voltage out of the ECM sensor harness port from pins 5, 25, 35, 18, and 45 to ground.
  • Measure the supply voltage out of the ECM actuator harness port from pins 19 and 29 to ground.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM

Refer to Procedure 019-031.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to battery in the sensor supply lines.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness connector from the ECM.

Action

–

  • Measure the resistance from pins 5, 25, 35, 18, and 45 in the sensor harness connector to pin 7 in the OEM harness connector.
  • Measure the resistance from pins 19 and 29 in the actuator harness connector to pin 7 in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pins 5, 25, 35, 18, and 45 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pins 19 and 29 in the actuator connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 227 is inactive.
OK NOT OK

Fault Code 227 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury and property damage, the engine must be shut off immediately if the engine speed stays above 2650 rpm.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Not motoring downhill
 | STEP 1B. Check for an alternate fuel source. | No alternate fuel source
 | STEP 1C. Check the engine rpm with the monitor mode. | Correct rpm reading
 | STEP 1D. Check the injector overhead settings. | Correct injector overhead settings
 | STEP 1E. Check for an active fault at low engine rpm. | Inactive fault at low rpm
 | STEP 1F. Test the vehicle. | Inactive fault
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

–

  • Check if the engine was motoring downhill when the fault was logged.
OK NOT OK

Not motoring downhill

Check the engine for damage

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

–

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 2650 rpm, followed by moderate deceleration to 2000 rpm.
OK NOT OK

No alternate fuel source

Locate the alternative fuel source

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

Go to 1C

Go to 2A

WARNING

To reduce the possibility of personal injury and property damage, the engine must be shut off immediately if the engine speed stays above 2650 rpm.
Guided Step 1C - Check the engine rpm with the monitor mode.

Conditions

  • Turn keyswitch ON.

Action

–

  • Monitor the engine rpm using INSITE™.
OK NOT OK

Correct rpm reading

Inspect the engine position sensor

Check the engine position sensor as outlined for Fault Codes 115 and 121.

Go to 1D

Fault Codes 115 and 121

Guided Step 1D - Check the injector overhead settings.

Conditions

  • Turn keyswitch OFF.

Action

–

  • Check for correct injector overhead settings. Refer to Procedure 003-004 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239.
OK NOT OK

Correct injector overhead settings

Reset the overhead

Reset the overhead using the outer base circle method. Inspect the base engine for damage due to overspeed condition.

Go to 1E

Go to 2A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

–

  • Check for active Fault Code 234 when the engine is not running above 2650 rpm.
OK NOT OK

Inactive fault at the low rpm

Replace the ECM

Refer to Procedure 019-031.

Go to 1F

Go to 2A

WARNING

To reduce the possibility of personal injury and property damage, the engine must be shut off immediately if the engine speed stays above 2650 rpm.
Guided Step 1F - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

–

  • Check if the overspeed condition is still present.
OK NOT OK

Inactive fault

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 234 is inactive.
OK NOT OK

Fault Code 234 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes with INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


FAULT CODE 235 - Engine Coolant Level - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

Do not add cold coolant to a hot engine. Wait until the engine temperature is below 50°C [120°F] before adding coolant or castings can be damaged.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

Do not add cold coolant to a hot engine. Wait until the engine temperature is below 50°C [120°F] before adding coolant or castings can be damaged.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the coolant level. |
 | STEP 1A. Check the coolant level. | Coolant level is normal
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault is still active with the engine running. | Fault Code 235 still active
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, 31-pin OEM connector, and ECM connector. | No damaged pins
 | STEP 3B. Check the sensor supply voltage. | (+) 4.5 to 5.5 VDC
 | STEP 3B-1. Measure the voltage from the ECM. |
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness, coolant level sensor, and the ECM connector. | No damaged pins
 | STEP 4B. Check the sensor supply voltage. | (+) 4.5 to 5.5 VDC
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 235 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify the coolant level.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

Do not add cold coolant to a hot engine. Wait until the engine temperature is below 50°C [120°F] before adding coolant or castings can be damaged.
Guided Step 1A - Check the coolant level.

Conditions

  • Allow engine to cool. See CAUTION statement above.

Action

–

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level is normal

Add coolant to the radiator

Make sure the coolant has the proper ratio of antifreeze and water.

Go to 2A

Go to 5A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Confirm the fault is still active with the engine running.

Conditions

  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for at least one minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 235 still active

Fault Code 235 inactive

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the engine harness, 31-pin OEM connector, and ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the engine harness, or replace the coolant level sensor or the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the coolant level sensor. Refer to Procedure 019-017.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check the sensor supply voltage.

Conditions

  • Disconnect the engine harness from the 31 pin OEM connector.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage from pin 7 of the 31 pin OEM connector, engine harness side, to engine block ground.
OK NOT OK

(+) 4.5 to 5.5 VDC

Does not meet specifications

Go to 3C

Go to 3B-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor from the 31-pin OEM connector.
  • Disconnect the sensor connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage from pin 25 to pin 23 of the ECM sensor port.
OK NOT OK

(+) 4.5 to 5.5 VDC

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Replace the ECM

Refer to Procedure 019-031.

Go to 5A

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the 31 pin OEM connector at the engine harness.

Action

–

  • Measure the resistance from pin 19 on the sensor harness side of the 31 pin OEM connector to pin 23 of the sensor harness connector at the ECM.
  • Measure the resistance from pin 6 on the sensor harness side of the 31 pin OEM connector to pin 22 of the sensor harness connector at the ECM.
  • Measure the resistance from pin 5 on the sensor harness side of the 31 pin OEM connector to pin 24 of the sensor harness connector at the ECM.
  • Measure the resistance from pin 7 on the sensor harness side of the 31 pin OEM connector to pin 25 of the sensor harness connector at the ECM.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the OEM harness, coolant level sensor, and the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the 31-pin OEM connector.
  • Disconnect the OEM harness from the coolant level sensor.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the coolant level sensor or the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-204, or Refer to Procedure 019-205.
  • Replace the OEM harness. Refer to Procedure 019-071.
  • Replace the coolant level sensor. Refer to Procedure 019-017.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4B - Check the sensor supply voltage.

Conditions

  • Disconnect the OEM harness from the coolant level sensor.
  • Connect the engine harness to the 31-pin OEM connector.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage from supply, pin C (or 3) of the sensor connector, engine harness side to engine block ground.
OK NOT OK

(+) 4.5 to 5.5 VDC

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 or Refer to Procedure 019-205.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the 31-pin OEM connector.
  • Disconnect the OEM harness from the coolant level sensor.

Action

–

  • Measure the resistance from pin D (or 4) on the OEM harness side of the coolant level sensor connector to pin 5 of the OEM 31 pin connector, OEM harness side.
  • Measure the resistance from pin A (or 1) on the OEM harness side of the coolant level sensor connector to pin 6 of the OEM 31 pin connector, OEM harness side.
  • Measure the resistance from pin C (or 3) on the OEM harness side of the coolant level sensor connector to pin 7 of the OEM 31 pin connector, OEM harness side.
  • Measure the resistance from pin B (or 2) on the OEM harness side of the coolant level sensor connector to pin 19 of the OEM 31 pin connector, OEM harness side.
OK NOT OK

Less than 10 ohms

Replace the coolant level sensor.

Refer to Procedure 019-017.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-205, or Refer to Procedure 019-208.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 235 is inactive.
OK NOT OK

Fault Code 235 inactive

Return to the troubleshooting steps, or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-Jun-2017


FAULT CODE 241 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle speed sensor. |
 | STEP 1A. Inspect the harness and the sensor connector pins. | No damaged pins?
 | STEP 1B. Check the vehicle speed sensor for proper adjustment. | 1/2 to 3/4 of a turn out from the gear?
 | STEP 1C. Check the vehicle speed sensor for the correct resistance. | 750 to 1500 ohms?
 | STEP 1D. Check the vehicle speed sensor for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1E. Check the vehicle speed sensor for a short circuit between coils. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins?
 | STEP 2B. Check for the correct circuit resistance. | 750 to 1500 ohms?
 | STEP 2C. Check the harness for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM components. |
 | STEP 3A. Check for an external recording device. | No external device?
 | STEP 3B. Check for a gear slipping on the shaft. | Gear attached properly?
 | STEP 3C. Check for interference on the OEM harness. | Fault Code 241 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the vehicle speed sensor.

Guided Step 1A - Inspect the harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect the OEM 31-pin Deutsch connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205, or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the vehicle speed sensor. Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the vehicle speed sensor for the proper adjustment.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor.

  • Check the vehicle speed sensor for the proper adjustment.
OK NOT OK

1/2 to 3/4 of a turn out from the gear?

Adjust the vehicle speed sensor.

Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check the vehicle speed sensor for the correct resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for the correct resistance.

  • Measure the resistance from pin-A (or 1) to pin-B (or 2) for each vehicle speed sensor connector on the sensor side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

750 to 1500 ohms?

Replace the vehicle speed sensor.

Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check the vehicle speed sensor for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for a short circuit to ground.

  • Measure the resistance between pin-A (or 1) on the sensor side of one of the vehicle speed sensor connectors and the chassis ground.
  • Measure the resistance between pin-A (or 1) on the sensor side of the other vehicle speed sensor connector and the chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the vehicle speed sensor.

Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 1E

Go to 4A

Guided Step 1E - Check the vehicle speed sensor for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for a short circuit between coils.

  • Measure the resistance between pin-A (or 1) on the sensor side of one of the vehicle speed sensor connectors and pin A of the other connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the vehicle speed sensor.

Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for the correct circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Connect the actuator harness to the vehicle speed sensor.

Action

Check for the correct circuit resistance.

  • Check for the proper resistance from pin-30 to pin-40 of the actuator harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

750 to 1500 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the vehicle speed sensor.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the harness for a short circuit to ground.

  • Measure the resistance from pin-30 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin-40 of the actuator harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM components.

Guided Step 3A - Check for an external recording device.

Action

Check for an external recording device.

  • Check for an external recording device or similar devices attached to this circuit.
OK NOT OK

No external device?

Disconnect the device from the circuit.

Go to 3B

Go to 4A

Guided Step 3B - Check for a gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Vehicle speed sensor removed.

Action

Check for the gear slipping on the shaft.

  • Check to make sure the transmission gear inside the sensor mounting is not slipping on the shaft. Try to spin the gear with a standard screwdriver.
OK NOT OK

Gear attached properly?

Repair transmission gear.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for interference on the OEM harness.

Conditions

  • Connect all components.

Action

Check for interference on the oem harness.

  • Install a pair of twisted jumper wires from the vehicle speed sensor to the ECM. Connect the wires from pin-A (or 1) to pin-21 of the OEM 31-pin connector and from pin-B (or 2) to pin-22 of the OEM 31-pin connector.
  • Disconnect the speedometer connector at the vehicle speed sensor.
  • Drive the vehicle. The vehicle speed must exceed 10 mph.
OK NOT OK

Fault Code 241 inactive?

There is interference on the OEM harness.

Locate and remove the source of interference.

Replace the vehicle speed sensor.

Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 241 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


FAULT CODE 242 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the feature settings are set correctly (automotive only). |
 | STEP 1A. Verify the customer wants vehicle speed sensor antitampering (Fault Code 242) enabled. | Customer wants vehicle speed sensor antitampering (Fault Code 242) enabled?
 | STEP 1B. Verify the vehicle speed sensor type is set correctly for the application. | Vehicle speed sensor type is set correctly?
 | STEP 1C. Verify the transmission type is set correctly for the application. | Transmission type is set correctly?
STEP 2. | Look for signs of tampering (automotive only). |
 | STEP 2A. Inspect the vehicle speed sensor. | No signs of tampering detected at or with the vehicle speed sensor?
 | STEP 2B. Inspect the OEM vehicle speed sensor circuit. | No signs of tampering detected with the vehicle speed sensor leads or the OEM harness?
 | STEP 2C. Inspect the keyswitch circuit. | No signs of tampering detected with the keyswitch circuit?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and the sensor connector pins. | No damaged pins?
 | STEP 3B. Check for an open circuit in the signal wire. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the signal wire. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground from the signal wire to all other wires. | Greater than 100k ohms?
STEP 4. | Check the actuator harness. |
 | STEP 4A. Inspect the harness and the ECM connector. | No damaged pins?
 | STEP 4B. Check for an open circuit in the signal wire. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the signal wire. | Greater than 100 ohms?
STEP 5. | Check the vehicle speed reporting. |
 | STEP 5A. Monitor the vehicle speed. | The electronic service tool displays the correct speed?
 | STEP 5B. Verify the vehicle speed. | Vehicle speed is accurate for the present gear?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 242 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the feature settings are set correctly (automotive only).

Guided Step 1A - Verify the customer wants vehicle speed sensor antitampering (Fault Code 242) enabled.

Action

Verify the customer wants vehicle speed sensor antitampering (Fault Code 242) enabled.

  • Talk to the owner of the vehicle to see if this feature is required for the application of this vehicle.
OK NOT OK

Customer wants vehicle speed sensor antitampering (Fault Code 242) enabled?

Use INSITE™ electronic service tool to adjust the feature setting to its correct value.

Go to 1B

Go to 6A

Guided Step 1B - Verify the vehicle speed sensor type is set correctly for the application.

Conditions

  • Connect the INSITE™ service tool.

Action

Verify the vehicle speed sensor type is set correctly for the application.

  • Use INSITE™ to verify this feature setting is set correctly for the application in which this vehicle is used.
OK NOT OK

Vehicle speed sensor type is set correctly?

Use INSITE™ electronic service tool to adjust the feature setting to its correct value.

Go to 1C

Go to 6A

Guided Step 1C - Verify the Transmission Type is set correctly for the application.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Verify that transmission type is set correctly for the application.

  • Use INSITE™ to verify this feature setting is set correctly for the application in which this vehicle is used.
OK NOT OK

Transmission Type is set correctly?

Use INSITE™ electronic service tool to adjust the feature setting to its correct value.

Go to 2A

Go to 6A

Guided Step 2 - Look for signs of tampering (automotive only).

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to OEM harness
  • Other external device connected in place of vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.
OK NOT OK

No signs of tampering detected at or with the vehicle speed sensor?

Vehicle speed sensor is improperly installed, connected, or has been tampered with.

  • Correctly install and connect the vehicle speed sensor to the OEM harness.
  • Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.
  • Remove any tampering device.

Go to 2B

Go to 6A

Guided Step 2B - Inspect the OEM vehicle speed sensor circuit.

Action

Inspect the OEM vehicle speed sensor circuit for the following:

  • Broken, cut, or incorrect routing of the vehicle speed sensor wires
  • Any devices connected in series or parallel with the vehicle speed sensor
  • Any other wires added to the vehicle speed sensor circuit
  • Any evidence that tampering with the vehicle speed sensor circuit has taken place.
OK NOT OK

No signs of tampering detected with the vehicle speed sensor leads or the OEM harness?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Inspect the keyswitch circuit.

Action

Inspect the keyswitch circuit for the following:

  • Broken, cut, or incorrect routing of the keyswitch wires
  • Any devices connected in series or parallel with the keyswitch
  • Any other wires added to the keyswitch circuit
  • Any evidence that tampering with the keyswitch circuit has taken place.
OK NOT OK

No signs of tampering detected with the keyswitch circuit?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect the engine harness from the OEM harness at the Deutsch™ 31-pin connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or replace the sensor, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-204, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the vehicle speed sensor. Refer to Procedure 019-091 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit in the signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect the engine harness from the OEM harness at the Deutsch™ 31-pin connector.

Action

Check for an open circuit in the SIGNAL wire.

  • Measure the resistance from pin-A (or 1) of the vehicle speed sensor connector to pin-21 of the Deutsch 31-pin connector.
  • Measure the resistance from pin-B (or 2) of the vehicle speed sensor connector to pin-22 of the Deutsch 31-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-204, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground in the signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect the engine harness from the OEM harness at the Deutsch 31-pin connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin-A (or 1) of the vehicle speed sensor connector to chassis ground.
  • Measure the resistance from pin-B (or 2) of the vehicle speed sensor connector to chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the vehicle speed sensor.

Refer to Procedure 019-091 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground from the SIGNAL wire to all other wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect the engine harness from the OEM harness at the Deutsch™ 31-pin connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin-21 of the vehicle speed sensor connector to all other pins in the Deutsch™ 31-pin connector, actuator harness side.
  • Measure the resistance from pin-22 of the vehicle speed sensor connector to all other pins in the Deutsch™ 31-pin connector, actuator harness side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the actuator harness.

Guided Step 4A - Inspect the harness and the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the Deutsch™ 31-pin connector.

Action

Inspect the harness and the ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the Deutsch™ 31-pin connector.

Action

Check for an open circuit in the SIGNAL wire.

  • Measure the resistance from pin-40 of the actuator connector at the ECM to pin-21 of the Deutsch™ 31-pin connector.
  • Measure the resistance from pin-30 of the actuator connector at the ECM to pin-22 of the Deutsch™ 31-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the Deutsch™ 31-pin connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin-40 of the actuator harness connector to the engine block ground.
  • Measure the resistance from pin-30 of the actuator harness connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the vehicle speed reporting.

Guided Step 5A - Monitor the vehicle speed.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Use INSITE electronic service tool to check the vehicle speed.

  • Verify the vehicle speed is zero when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed read by INSITE™ electronic service tool to the speedometer on the dash.

If the dash is an electronic dash that uses the ECM to obtain vehicle speed, perform a road test and use a stopwatch and road mile markers to determine the true vehicle speed.

OK NOT OK

INSITE™ electronic service tool displays correct speed?

INSITE™ electronic service tool and speedometer do not match

Verify the vehicle speed sensor parameters are adjusted correctly in the ECM. Check the vehicle speed sensor and the OEM harness in Steps 2A and 2B above. Repair any problems found.

Go to 5B

Go to 6A

Guided Step 5B - Verify the vehicle speed.

Conditions

  • Connect the INSITE™ service tool.

Action

Verify the speed reported by the INSITE™ electronic service tool is accurate or reasonable for the present gear.

  • For example: 40 mph in top gear is probably inaccurate data.
OK NOT OK

The vehicle speed is accurate for present gear?

The vehicle speed read by electronic service tool is inaccurate

Verify vehicle speed sensor parameters are adjusted correctly in the ECM. Check the vehicle speed sensor and OEM harness in Steps 2A and 2B above. Repair any problems found.

Fault Code 241

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 242 inactive?

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshooting any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2012


FAULT CODE - Engine Fan Clutch Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the fan clutch connector pins. | No damaged pins?
 | STEP 1B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the 31-pin Deutsch™ connector pins. | No damaged pins?
 | STEP 2B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 245 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and the fan clutch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin-12 of the OEM 31-pin connector, engine harness side, to pin-5 of the actuator harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM 31-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-5 in the actuator harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-5 in the actuator harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the 31-pin Deutsch™ connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin Deutsch connector.
  • Disconnect the actuator harness from the 31-pin Deutsch connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or the OEM harness, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM 31-pin connector.
  • Disconnect the OEM harness connector from the fan clutch solenoid.

Action

Check for an open circuit.

  • Measure the resistance from pin-12 of the OEM 31-pin connector to pin-A (or 1) of the fan clutch solenoid connector.
  • Measure the resistance from pin-13 of the OEM 31-pin connector to pin-B (or 2) of the fan clutch solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-204, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness from the 31-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-12 of the 31-pin connector, OEM harness side, to engine block ground.
  • Measure the resistance from pin-13 of the 31-pin connector, OEM harness side, to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness from the 31-pin connector.

Action

Check for a short circuit from pin-to-pin in the OEM harness.

  • Measure the resistance from pin-12 of the 31-pin connector, OEM harness side, to all other pins in the connector.
  • Measure the resistance from pin-13 of the 31-pin connector, OEM harness side, to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 245 inactive?

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2012


FAULT CODE - Ambient Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ambient air temperature sensor. |
 | STEP 1A. Inspect the ambient air temperature sensor and the sensor harness connector pins. | No damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 249 inactive?
 | STEP 1C. Check the resistance of the ambient air temperature sensor. | 175 ohms to 244k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 249 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and the 31-pin connector pins. | No damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 249 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ambient air temperature sensor.

Guided Step 1A - Inspect the ambient air temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Inspect the ambient air temperature sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ambient air temperature sensor, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-204, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air temperature sensor. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 249 inactive?

Fault Code 249 active?

Go to 4B

Go to 1C

Guided Step 1C - Check the resistance of the ambient air temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Check the resistance of the ambient air temperature sensor.

  • Measure the resistance from pin-A (or 1) to pin-B (or 2) of the ambient air temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

175 ohms to 244k ohms?

Replace the ambient air temperature sensor.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 249 inactive?

Fault Code 249 active?

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin (non-ICON™ equipped vehicles only). For ICON™ equipped vehicles, refer to the OEM service manual.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-12 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin-37 of the actuator harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the OEM 31-pin connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin-12 of the sensor harness connector to pin-4 of the OEM 31-pin connector, engine harness side.
  • Measure the resistance from pin-37 of the actuator harness connector to pin-3 of the OEM 31-pin connector, engine harness side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the 31-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the engine harness or OEM harness, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM harness from the ambient air temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-3 of the OEM 31-pin connector, OEM harness side, to all other pins in the connector.
  • Measure the resistance from pin-4 of the OEM 31-pin connector, OEM harness side, to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM harness from the ambient air temperature sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin-4 of the OEM 31-pin connector, OEM harness side, to the SIGNAL pin in the 2-pin sensor harness connector.
  • Measure the resistance from pin-3 of the OEM 31-pin connector, OEM harness side, to the RETURN pin in the 2-pin sensor harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-204, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19..

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 249 inactive?

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2012


FAULT CODE 254 - Fuel Shutoff Valve Solenoid Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff valve solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff valve solenoid post. | No extra wires?
 | STEP 1B. Check for corrosion on the solenoid post. | No corrosion found?
 | STEP 1C. Check the supply voltage at the fuel shutoff valve solenoid. | Greater than (+) 6 VDC?
 | STEP 1C-1. Check the actuator harness and the ECM connector pins. |
 | STEP 1C-2. Check for an open circuit. |
 | STEP 1C-3. Check for a short circuit from pin-to-pin. |
 | STEP 1C-4. Measure the voltage from the ECM. |
 | STEP 1D. Check the fuel shutoff valve solenoid resistance. | 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 254 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel shutoff valve solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff valve solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires.

  • Check for extra wires on the fuel shutoff valve solenoid post.
OK NOT OK

No extra wires?

Remove extra wires and connect to (+) 12-VDC supply.

Go to 1B

Go to 2A

Guided Step 1B - Check for corrosion on the solenoid post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff control wire from the fuel shutoff valve solenoid.

Action

Check for corrosion.

  • Check for corrosion on the solenoid post.
OK NOT OK

No corrosion found?

Clean the solenoid post and the wiring terminal

Refer to Procedure 019-050 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check the supply voltage at the fuel shutoff valve solenoid.

Conditions

  • Disconnect the actuator harness from the fuel shutoff valve solenoid.
  • Turn keyswitch ON.

Action

Check the supply voltage at the fuel shutoff valve solenoid.

  • Measure the voltage from the fuel shutoff control wire connectors on the harness side to engine block ground.
OK NOT OK

Greater than (+) 6 VDC?

Does not meet specifications

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the actuator harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1C-2

Go to 2A

Guided Step 1C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff valve solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 33 of the actuator harness to the fuel shutoff control wire.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C-3

Go to 2A

Guided Step 1C-3 - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff valve solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the actuator harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C-4

Go to 2A

Guided Step 1C-4 - Measure the voltage from the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage at the ECM from pin 33 of the actuator harness connector port to engine block ground.
OK NOT OK

Greater than (+) 6 VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 1D - Check the fuel shutoff valve solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff valve solenoid.

Action

Check the fuel shutoff valve solenoid resistance.

  • Measure the resistance from the fuel shutoff valve solenoid to engine block ground.
OK NOT OK

1 to 5 ohms for 6-VDC solenoids

6 to 15 ohms for 12-VDC solenoids

24 to 50 ohms for 24-VDC solenoids

42 to 80 ohms for 32-VDC solenoids

46 to 87 ohms for 36-VDC solenoids

92 to 145 ohms for 48-VDC solenoids

315 to 375 ohms for 74-VDC solenoids

645 to 735 ohms for 115-VAC solenoids

Replace the fuel shutoff valve solenoid

Refer to Procedure 019-050 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 254 is inactive.
OK NOT OK

Fault Code 254 inactive?

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 255 - Engine Fuel Shutoff Valve Drive Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 255 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | Is resistance 1 to 5 Ohms for 6-VDC solenoids, 6 to 15 Ohms for 12-VDC solenoids, 24 to 50 Ohms for 24-VDC solenoids, 42 to 80 Ohms for 32-VDC solenoids, 46 to 87 Ohms for 36-VDC solenoids, 92 to 145 Ohms for 48-VDC solenoids, 315 to 375 Ohms for 74-VDC solenoids, 645 to 735 Ohms for 115-VAC solenoids?
 | STEP 2C. Check the fuel shutoff valve diagnostic supply voltage and signal circuit. | Greater than 5.0 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 255 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES NO
No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance between the fuel shutoff valve ring terminal stud and engine block ground.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance:

  • 1 to 5 Ohms for 6-VDC solenoids
  • 6 to 15 Ohms for 12-VDC solenoids
  • 24 to 50 Ohms for 24-VDC solenoids
  • 42 to 80 Ohms for 32-VDC solenoids
  • 46 to 87 Ohms for 36-VDC solenoids
  • 92 to 145 Ohms for 48-VDC solenoids
  • 315 to 375 Ohms for 74-VDC solenoids
  • 645 to 735 Ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve.

Refer to Procedure 019-050 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the fuel shutoff valve diagnostic supply voltage.

  • Measure the voltage from the actuator harness fuel shutoff valve SIGNAL ring terminal to engine block ground.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve supply voltage.

  • Measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for circuit continuity.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness fuel shutoff valve connector and the fuel shutoff valve SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 255 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-May-2012


FAULT CODE 256 - Ambient Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - female Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ambient air temperature sensor. |
 | STEP 1A. Inspect the ambient air temperature sensor and the sensor harness connector pins. | No damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 256 inactive?
 | STEP 1C. Check the resistance of the ambient air temperature sensor. | 175 ohms to 244k ohms?
 | STEP 1D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 256 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and the 31-pin connector pins. | No damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ambient air temperature sensor.

Guided Step 1A - Inspect the ambient air temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Inspect the ambient air temperature sensor and the sensor harness connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ambient air temperature sensor, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air temperature sensor. Refer to Procedure 019-135 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 256 inactive?

Fault Code 256 active?

Go to 4B

Go to 1C

Guided Step 1C - Check the resistance of the ambient air temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Check the resistance of the ambient air temperature sensor.

  • Measure the resistance from pin-A (or 1) to pin-B (or 2) of the ambient air temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

175 ohms to 244k ohms?

Replace the ambient air temperature sensor.

Refer to Procedure 019-135 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-A (or 1) of the ambient air temperature sensor to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the ambient air temperature sensor.

Refer to Procedure 019-135 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 256 inactive?

Fault Code 256 active?

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin (non-ICON™ equipped vehicles only). For ICON™ equipped vehicles, refer to the OEM service manual.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-12 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin-37 of the actuator harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-12 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin-37 of the actuator harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the 31-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the 31-pin connector.

Action

Inspect the OEM harness and the 31-pin connector for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin connector.
  • Disconnect the OEM harness from the ambient air temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-3 of the 31-pin connector to all other pins in the connector.
  • Measure the resistance from pin-4 of the 31-pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin connector.
  • Disconnect the OEM harness from the ambient air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-3 of the OEM 31-pin connector to engine block ground.
  • Measure the resistance from pin-4 of the OEM 31-pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 256 is inactive.
OK NOT OK

Fault Code 256 inactive?

Return to troubleshooting steps or contact a Cummin®s Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


FAULT CODE 259 - Fuel Shutoff Valve

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault status. |
 | STEP 1A. Check for active Fault Code 255 or high inactive counts. | Fault Code 255 not active?
STEP 2. | Check for extra wires. |
 | STEP 2A. Check for extra wires attached to the fuel shutoff valve solenoid. | No extra wires?
STEP 3. | Check the fuel pressure sensor accuracy. |
 | STEP 3A. Check the fuel pressure sensor accuracy with the keyswitch ON. | Fuel pressure greater than 10 psi?
 | STEP 3B. Check the fuel pressure sensor accuracy with at idle. | Fuel pressure difference not greater than 69 kPa [10 psi]?
STEP 4. | Check for proper fuel shutoff valve circuit operation. |
 | STEP 4A. Check for proper fuel shutoff valve circuit operation. | Voltage available at the fuel shutoff valve is greater than 11-VDC with the keyswitch ON and less than 0.5-VDC with the keyswitch OFF?
STEP 5. | Check the fuel shutoff valve actuator disc. |
 | STEP 5A. Check the fuel shutoff valve actuator disc. | No debris or damage found on the valve disc, valve seat, or actuator disc?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 259 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault status.

Guided Step 1A - Check for active Fault Code 255 or high inactive counts.

Conditions

  • All the components connected.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 255 not active?

Fault Code 255 active.

Go to 2A

Use Fault Code 255

Guided Step 2 - Check for extra wires.

Guided Step 2A - Check for extra wires attached to the fuel shutoff valve solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires.

  • Check for extra wires attached to the fuel shutoff valve solenoid.
OK NOT OK

No extra wires?

Remove extra wires attached to the fuel shutoff valve solenoid.

Go to 3A

Go to 6A

Guided Step 3 - Check the fuel pressure sensor accuracy.

Guided Step 3A - Check the fuel pressure sensor accuracy with the keyswitch ON.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pressure gauge on the Compuchek™ fitting on the IFSM.
  • Disconnect the fuel lift pump.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check fuel pressure sensor accuracy with keyswitch ON.

  • Verify the fuel pressure on the gauge and in INSITE™ electronic service tool are both less than 69 kPa [10 psi].
OK NOT OK

Fuel pressure less than 69 kPa [10 psi]?

Fuel pressure greater than 69 kPa [10 psi]?

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel pressure sensor accuracy with at idle.

Conditions

  • Turn keyswitch ON.
  • Fuel pressure gauge connected on the Compuchek™ fitting on the IFSM.
  • All components connected.
  • INSITE™ electronic service tool connected.

Action

Check the fuel pressure sensor accuracy with the engine running.

  • Start the engine.
  • Allow the idle to stabilize.
  • Verify the fuel pump pressure meets specification.
  • Fuel pump pressure greater than 1448 kPa [210 psi] at idle.
  • Verify the fuel pressure on the gauge and INSITE™ electronic service tool are no greater than 69 kPa [10 psi] different.
OK NOT OK

Fuel pressure difference not greater than 69 kPa [10 psi]?

Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the fuel shutoff valve circuit operation.

Guided Step 4A - Check the fuel shutoff valve circuit operation.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve circuit operation.

  • Verify the voltage available at the fuel shutoff valve is greater than 11-VDC.
  • Turn keyswitch OFF.
  • Verify the voltage available at the fuel shutoff valve is less than 0.5-VDC.
OK NOT OK

Voltage available at the fuel shutoff valve is greater than 11-VDC with the keyswitch ON and less than 0.5-VDC with the keyswitch OFF.

Troubleshoot the fuel shutoff valve electrical circuit.

Use the following procedure to diagnose the fuel shutoff valve circuit. Reference the ECM - No Communication Troubleshooting Tree in Section TT in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Go to 5A

Go to 6A

Guided Step 5 - Check the fuel shutoff valve actuator disc.

Guided Step 5A - Check the fuel shutoff valve actuator disc.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check the fuel shutoff valve actuator disc.

  • Check the housing, valve disc, valve seat, and actuator disc for dirt, debris, metal parts, bonding separation, corrosion, cracks, or wear.
OK NOT OK

No debris or damage found on the valve disc, valve seat, or actuator disc?

Assemble the fuel shutoff valve.

Replace the damaged fuel shutoff valve component. Refer to Procedure 019-050 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Turn keyswitch OFF for 30 seconds.
  • Use INSITE™ electronic service tool to verify Fault Code 259 is inactive.
OK NOT OK

Fault Code 259 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 284 - Sensor Supply Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824775 - breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917- female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for a signal from the crankshaft engine position sensor. |
 | STEP 1A. Check the crankshaft engine position sensor. | Signal present?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins?
 | STEP 2B. Check the supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C. Check for a short circuit to ground in the sensor SUPPLY wire. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 284 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for a signal from the crankshaft engine position sensor.

Guided Step 1A - Check the crankshaft engine position sensor.

Conditions

  • Disconnect the engine harness from the crankshaft engine position sensor.
  • Turn keyswitch ON.

Action

Check for a signal from the crankshaft engine position sensor.

  • Measure the voltage from pin-C (or YELLOW) to pin-B (or BLACK) on the breakout cable while barring the engine over.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Signal present; signal should change from (+) 4 - 5-VDC to (+) 0.5 - 2.3-VDC and back about every 60 degrees of crankshaft rotation

Replace the crankshaft engine position sensor.

Refer to Procedure 019-038 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ecm connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the supply voltage.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage from the ECM sensor port pin-47 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground in the sensor supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground in the sensor SUPPLY wire.

  • Measure the resistance from pin-41 of the sensor harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-32 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin-41 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin-47 of the sensor harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 284 inactive?

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


FAULT CODE 285 - J1939 Data Link Multiplexing

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for proper multiplexing configuration. |
 | STEP 1A. Determine which vehicle inputs (throttle, switches, lamps, sensors) are multiplexed over the J1939 data link. | Devices in step 1A must match devices in step 1B?
 | STEP 1B. Use INSITE™ electronic service tool to verify the proper devices are set to be multiplexed in the ECM. | INSITE™ electronic service tool readout matches ECM settings for devices (devices in step 1A match step 1B)?
 | STEP 1B-1. Change the ECM settings to match the vehicle's multiplexed devices. |
STEP 2. | Inspect the J1939 connectors on the backbone harness and engine harness connectors. |
 | STEP 2A. Inspect the ECM, OEM harness, and 3-pin connectors. | No damaged pins?
 | STEP 2B. Inspect the VECU 3-pin and associated connectors. | No damaged pins?
STEP 3. | Inspect the SAE J1939 backbone harness and engine harness connectors. |
 | STEP 3A. Check for an open circuit in the SUPPLY wire. | Less than 10 ohms?
 | STEP 3B. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the SHIELD wire. | Less than 10 ohms?
 | STEP 3D. Check the resistance value of the J1939 harness. | 55 to 65 ohms?
 | STEP 3E. Check for a short circuit to power in the SUPPLY wire. | Less than (+) 1.5-VDC?
 | STEP 3F. Check for a short circuit to power in the RETURN wire. | Less than (+) 1.5-VDC?
 | STEP 3G. Check for a short circuit to ground in the SUPPLY wire. | Greater than 100k ohms?
 | STEP 3H. Check for a short circuit to ground in the RETURN wire. | Greater than 100k ohms?
 | STEP 3I. Check for a short circuit pin-to-pin in the OEM connector. | Greater than 100k ohms?
STEP 4. | Check for proper communication with the J1939 devices. |
 | STEP 4A. Check communication with the ECM. | Established communication by monitoring engine speed?
 | STEP 4B. Check communication with the VECU(s). | Proper communication between multiplexing devices and VECU(s)?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for proper multiplexing configuration.

Guided Step 1A - Determine which vehicle inputs (throttle, switches, lamps, sensors) are multiplexed over the J1939 data link.

Conditions

  • Install the INLINE™ 2 data link adapter.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check that the vehicle inputs are multiplexed over the J1939 data link.

  • Read the devices that are sending input information with INSITE™ electronic service tool.
OK NOT OK

Devices in step 1A must match devices in step 1B

Devices in step 1A must match devices in step 1B

Go to 1B

Go to 1B

Guided Step 1B - Use INSITE™ electronic service tool to verify the proper devices are set to be multiplexed in the ECM.

Conditions

  • Install the INLINE™ 2 data link adapter.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

ECM settings match devices installed on vehicle.

  • Use INSITE electronic servicet tool to read the ECM settings for devices.
OK NOT OK

INSITE™ electronic service tool readout matches ECM settings for devices (devices in step 1A match step 1B).

Configure ECM to match vehicle devices.

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Change the ECM settings to match the vehicle's multiplexed devices.

Conditions

  • Install the INLINE™ 2 datalink adapter.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Match the multiplexed devices to the ECM.

  • Use INSITE™ electronic service tool to configure the ECM to work with the multiplexed devices.
OK NOT OK

ECM matches multiplex devices?

ECM does not match multiplex devices.

Go to 2A

Go to 5A

Guided Step 2 - Inspect the J1939 connectors on the backbone harness and engine harness connectors.

Guided Step 2A - Inspect the ECM, OEM harness, and 3-pin connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connector.
  • Disconnect the OEM harness.
  • Disconnect the multiplexed devices.

Action

Inspect the ECM, OEM harness, j1939 connectors, and multiplexed devices for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, J1939 backbone harness, or the multiplexed device(s), or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the backbone harness J1939 connector(s). Refer to Procedure 019-201 in Section 19.
  • Repair or replace the backbone harness J1939 connector(s). Refer to Procedure 019-202 in Section 19.
  • Repair or replace the backbone harness J1939 connector(s). Refer to Procedure 019-205 in Section 19.
  • Repair or replace the multiplexed devices. Use the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239, for specific device.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the VECU 3-pin and associated connectors.

Conditions

  • Disconnect the VECU(s) from the J1939 backbone harness.
  • Disconnect the multiplexed devices from the VECU(s).

Action

Inspect the vecu(s), 3-pin, and multiplexed devices connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the VECU(s), 3-pin connector, or multiplexed devices, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the VECU(s). Use the OEM troubleshooting and repair manual for repair procedure.
  • Repair the 3-pin connector. Refer to Procedure 019-201 in Section 19.
  • Repair the 3-pin connector. Refer to Procedure 019-202 in Section 19.
  • Repair the 3-pin connector. Refer to Procedure 019-205 in Section 19.
  • Repair or replace the multiplexed devices. Reference the Service Manual, Signature™, ISX and QSX15 Engines, Bulletin 3666239.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the SAE J1939 backbone harness and engine harness connectors.

Guided Step 3A - Check for an open circuit in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 connector from the VECU(s).

Action

Check continuity in the SUPPLY wire.

  • Measure resistance from SUPPLY pin-46 at the OEM harness connector to pin-A at the data link connector at the VECU(s).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin-37 at the OEM connector to pin-B at the VECU(s).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit in the SHIELD wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for an open circuit in the SHIELD wire.

  • Measure the resistance from pin-36 at the OEM connector to pin-C at the VECU(s).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the resistance value of the J1939 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the engine harness from the J1939 backbone harness.

Action

Check the resistance value of the J1939 harness.

  • Measure the resistance from pin-A to pin-B of the J1939 harness connector on the OEM side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

55 to 65 ohms?

J1939 backbone termination resistors missing or damaged

Replace the termination resistors.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to power in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to power in the SUPPLY wire.

  • Measure the voltage from pin-46 at the ECM to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Less than (+) 1.5-VDC

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check for a short circuit to power in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to power in the RETURN wire.

  • Measure the voltage from pin-37 at the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Less than (+) 1.5-VDC

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 5A

Guided Step 3G - Check for a short circuit to ground in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short circuit to ground in the SUPPLY wire.

  • Measure the resistance from pin-46 in the OEM harness connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3H

Go to 5A

Guided Step 3H - Check for a short circuit to ground in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short circuit to ground in the RETURN wire.

  • Measure the resistance from pin-37 in the OEM harness connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3I

Go to 5A

Guided Step 3I - Check for a short circuit from pin-to-pin in the OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the engine harness from the J1939 backbone harness.

Action

Check for a short circuit from pin-to-pin in the OEM connector.

  • Measure the resistance from pin-46 in the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin-36 in the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin-37 in the OEM harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for proper communication with the J1939 devices.

Guided Step 4A - Check communication with the ECM.

Conditions

  • Install INLINE™ 2 data link adapter.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check communication with ECM.

  • Set up INSITE™ electronic service tool to use the J1939 data link. Reference the INSITE™ manual for details.
OK NOT OK

Established communication by monitoring engine speed?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check communication with the VECU(s).

Conditions

  • Install the OEM service tool software.
  • Turn keyswitch ON.

Action

Check communication with the VECU(S).

  • Use the OEM service tool software to confirm communication between VECU(s) and multiplexing devices.
OK NOT OK

Proper communication between multiplexing devices and VECU(s)?

Replace the VECU(s).

Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 285 inactive?

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


FAULT CODE 286 - J1939 Data Link Multiplexing

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the VECU(s) and ECM have matching settings. |
 | STEP 1A. Consult OEM information and/or use OEM service tool to verify which input parameters are wired to VECU(s). | Physical input devices to VECU match VECU configuration?
 | STEP 1B. Determine which parameters are set to be received over the J1939 data link. Look at the menu: Adjustments — Features and Parameters 2. | INSITE™ electronic service tool to readout matches ECM setting for devices (devices in step 1B match step 1A)?
STEP 2. | Change the settings. |
 | STEP 2A. ECM is set up to receive parameters that the VECU(s) is not transmitting. | ECM setting now matches VECU configuration?
 | STEP 2B. The VECU(s) is not set up to transmit information from all of the multiplex devices. | VECU(s) parameters match all input devices that are wired to VECU(s)?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the VECU(s) and ECM have matching settings.

Guided Step 1A - Consult OEM information and/or use OEM service tool to verify which input parameters are wired to VECU(s).

Conditions

  • Turn keyswitch ON.
  • Connect to the vehicle VECU with OEM service tool.

Action

Check that the vehicle inputs are multiplexed.

  • Determine which input devices (throttle, cruise switches, clutch switch, etc.) are wired to the vehicle's VECU(s).
  • Use the OEM service tool to verify the VECU is configured properly.
OK NOT OK

Physical input devices to VECU match VECU configuration?

Change multiplex settings.

Go to 1B

Go to 2B

Guided Step 1B - Determine which parameters are set to be received over the J1939 data link. Look at the menu: Adjustments - Features and Parameters 2.

Conditions

  • Install the INLINE™ 2 data link adapter to the engine and PC.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

ECM settings match devices installed on vehicle.

  • Read the ECM settings for devices using INSITE™.
  • Information for settings in menu: Adjustments - Features and Parameters 2.
OK NOT OK

INSITE™ electronic service tool to readout matches ECM settings for devices (devices in step 1B match step 1A)?

INSITE™ electronic service tool configuration does not match the VECU configuration.

Go to 3A

Go to 2A

Guided Step 2 - Change the settings.

Guided Step 2A - ECM is set up to receive parameters that the VECU(s) is not transmitting.

Conditions

  • Start INSITE™ and connect to ECM.

Action

Change ECM setting to match VECU configuration.

  • If the ECM is set up to receive any of the parameters that the VECU(s) is not transmitting over the data link, turn off multiplexing for those parameters in the ECM using INSITE™ electronic service tool.
OK NOT OK

ECM setting now matches VECU configuration?

Check OEM multiplex settings.

Go to 3A

Go to 1A

Guided Step 2B - The VECU(s) is not set up to transmit all of the information from all of the multiplex devices.

Conditions

  • Install OEM service tool.
  • Turn keyswitch ON.

Action

Change the setting of the VECU(S) to transmit all information.

  • VECU(s) is not set up to transmit information from all of the devices connected to it. Change the setting in the VECU(s). Refer to the OEM service manual.
OK NOT OK

VECU(s) parameters match all input devices that are wired to VECU(s)?

Check OEM multiplex settings.

Go to 3A

Go to 1A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 286 inactive?

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


FAULT CODE 293 (INDUSTRIAL) - OEM Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM temperature sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | No damaged pins?
 | STEP 1B. Check the resistance of the OEM temperature sensor. | Refer to the OEM service manual?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | No damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connectors and the ECM connector pins. | No damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the proper ECM response. | Fault Code 293 inactive; Fault Code 294 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 293 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM temperature sensor.

Guided Step 1A - Inspect the OEM harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM temperature sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, the OEM harness, or the OEM temperature sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Repair or replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the OEM temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM temperature sensor.

Action

Check the resistance.

  • Check the resistance of the OEM temperature sensor.
OK NOT OK

Refer to the OEM service manual?

Replace the OEM temperature sensor.

Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the engine harness and the ecmconnector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the OEM temperature sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance from pin-4 of the 31-pin connector, OEM harness side, to the SIGNAL pin of the temperature sensor connector, harness side.
  • Measure the resistance from pin-3 of the 31-pin connector, OEM harness side, to the RETURN pin of the temperature sensor connector, harness side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the OEM temperature sensor from the harness.

Action

Check for a short circuit from the SIGNAL pin and the RETURN pin to all other pins.

  • Measure the resistance from pin-4 of the 31-pin connector, OEM harness side, to all other pins in the connector.
  • Measure the resistance from pin-3 of the 31-pin connector, OEM harness side, to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19..

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connectors and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine harness and the ecmconnector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-12 of the sensor harness connector at the ECM to pin-4 of the 31-pin connector, engine harness side.
  • Measure the resistance from pin-37 of the actuator harness connector at the ECM to pin-3 of the 31-pin connector, engine harness side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL pin to all other pins in the connector

  • Measure the resistance from pin-12 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin-12 of the sensor harness connector to all pins in the actuator harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the proper ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for the proper ECM response.

  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 293 inactive; Fault Code 294 active?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 293 is inactive.
OK NOT OK

Fault Code 293 inactive?

Return to troubleshooting steps or contact a Cummin®s Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2012


FAULT CODE 294 (INDUSTRIAL) - OEM Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM temperature sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | No damaged pins?
 | STEP 1B. Check the resistance of the OEM temperature sensor. | Refer to the OEM service manual?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness connector pins. | No damaged pins?
 | STEP 2B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | No damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the proper ECM response. | Fault Code 294 inactive; Fault Code 293 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 294 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM temperature sensor.

Guided Step 1A - Inspect the OEM harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Inspect the OEM harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or the OEM temperature sensor, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the OEM temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check the resistance of the OEM temperature sensor.

  • Refer to the OEM service manual.
OK NOT OK

Refer to the OEM service manual?

Replace the OEM temperature sensor.

Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or the engine harness, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the OEM temperature sensor from the harness.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin-4 of the 31-pin connector, OEM harness side, to the SIGNAL pin of the temperature sensor connector, harness side.
  • Measure the resistance from pin-3 of the 31-pin connector, OEM harness side, to the RETURN pin of the temperature sensor connector, harness side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.
  • Disconnect the OEM temperature sensor from the harness.

Action

Check for a short circuit from the SIGNAL pin to all other pins.

  • Measure the resistance from pin-4 of the 31-pin connector, OEM harness side, to all other pins in the connector.
  • Measure the resistance from pin-3 of the 31-pin connector, OEM harness side, to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness 31-pin connector.
  • Disconnect the OEM temperature sensor from the harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-4 of the 31-pin connector, OEM harness side, to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine harness and the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin-4 of the 31-pin connector, engine harness side, to pin-12 of the sensor harness connector.
  • Measure the resistance from pin-3 of the 31-pin connector, engine harness side, to pin-37 of the actuator harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-12 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin-12 of the sensor harness connector all pins in the actuator harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-12 of the sensor harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the proper ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Install a jumper wire, Part Number 3822917, to pin-12 at the sensor port.
  • Disconnect the actuator harness connector from the ECM.
  • Install a jumper wire, Part Number 3822917, to pin-13 at the actuator port.
  • Connect the two jumper wires.

Action

Check for proper ECM response.

  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 294 inactive; Fault Code 293 active?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 294 inactive?

Return to troubleshooting steps or contact a Cummin®s Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2012


FAULT CODE 295 - Ambient Air Pressure Sensor

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 115. |
 | STEP 1A. Check to see if Fault Code 115 is active at engine start-up. | Fault Code 115 inactive?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for a valid fault code. | Fault Code 295 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 295 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for Fault Code 115.

Guided Step 1A - Check to see if Fault Code 115 is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if fault code 115 is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 115 inactive?

Troubleshoot Fault Code 115 first.

Go to 2A

Fault Code 115 inactive?

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for a valid fault code.

Conditions

  • Make certain that the oil temperature is greater than 4°C [40°F].
  • Turn keyswitch OFF.

Action

Check for a valid fault code.

  • Wait 30 seconds.
  • Turn keyswitch ON, and wait 15 seconds.
OK NOT OK

Fault Code 295 inactive?

Replace the sensor.

Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 295 inactive?

Return to the troubleshooting steps or contact the Cummin®s Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2012


FAULT CODE 297 - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the fluid temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM pressure sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the OEM pressure sensor. | Refer to the OEM troubleshooting and repair manual.
 | STEP 1C. Check the supply voltage from the ECM. | (+) 4.75 to 5.25 VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the sensor signal voltage. | (+) 0.42 to 0.58 VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 297 active?
 | STEP 2C. Check for an open circuit in the SIGNAL wire. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from the SIGNAL and RETURN pins to all other pins. | Greater than 100k ohms?
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 297 active?
 | STEP 3C. Check for an open circuit in the SIGNAL wire. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from the SIGNAL and RETURN pins to all other pins. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the proper ECM response. | Fault Code 297 inactive and Fault Code 298 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 297 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM pressure sensor.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or the OEM pressure sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM pressure sensor. Refer to the OEM troubleshooting and repair manual for procedure.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the OEM pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the resistance of the OEM pressure sensor.

  • Refer to the OEM troubleshooting and repair manual for test procedure.
OK NOT OK

Refer to the OEM troubleshooting and repair manual

Replace the OEM pressure sensor

Use the OEM troubleshooting and repair manual for procedure.

Go to 1C

Go to 5A

Guided Step 1C - Check the supply voltage from the ECM.

Conditions

  • Install breakout cable, Part Number 3162898, between the sensor and the sensor harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage from the ECM.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Does not meet specifications

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the ECM.

  • Measure the voltage at the ECM from the SUPPLY pin to the RETURN pin in the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 1D - Check the sensor signal voltage.

Conditions

  • Install breakout cable, Part Number 3162898, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the signal voltage by installing the breakout cable's SIGNAL pin connector (C or YELLOW) and RETURN pin connector (B or BLACK) into the multimeter.
OK NOT OK

(+) 0.42 to 0.58-VDC?

Does not meet specifications

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and 31-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM connector.

Action

Inspect the OEM harness and OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 active?

Repair complete

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the connector.

Action

Check for an open in the signal wire.

  • Measure the resistance from the RETURN pin of the OEM connector, OEM harness side, to the SIGNAL pin of the OEM harness, pressure sensor connector side.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM connector.

Action

Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

  • Measure the resistance from the SIGNAL pin of the OEM connector to all other pins in the connector.
  • Measure the resistance from the RETURN pin of the OEM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness at the OEM connector.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 active?

Repair complete

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness at the OEM connector.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit in the SIGNAL wire.

  • Measure the resistance from the SIGNAL pin of the sensor harness connector to the SIGNAL pin of the OEM connector, sensor harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL and RETURN pins to all other pins.

  • Measure the resistance from the SIGNAL pin of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from the RETURN pin of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the proper ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for appropriate ECM response.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 inactive and Fault Code 298 active?

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 297 is inactive.
OK NOT OK

Fault Code 297 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Jun-2017


FAULT CODE 298 - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the fluid temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM pressure sensor. |
 | STEP 1A. Inspect the OEM harness and the sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the OEM pressure sensor. | Refer to the OEM troubleshooting and repair manual.
 | STEP 1C. Check the supply voltage from the ECM. | (+) 4.75 to 5.25-VDC?
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the sensor signal voltage. | (+) 0.42 to 0.58-VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and 31-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 298 active?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from the SIGNAL pin to all other pins. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100k ohms?
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 298 active
 | STEP 3C. Check for an open circuit in the sensor harness. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from the SIGNAL pin to all other pins. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground in the SIGNAL wire. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the proper ECM response. | Fault Code 298 inactive and Fault Code 297 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 298 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM pressure sensor.

Guided Step 1A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or the OEM pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM troubleshooting and repair manual for procedure.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM pressure sensor. Refer to the OEM troubleshooting and repair manual for procedure.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the OEM pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the resistance of the OEM pressure sensor.

  • Refer to the OEM troubleshooting and repair manual for procedure.
OK NOT OK

Refer to the OEM troubleshooting and repair manual

Replace the OEM pressure sensor

Refer to the OEM troubleshooting and repair manual for procedure.

Go to 1C

Go to 5A

Guided Step 1C - Check the supply voltage from the ECM.

Conditions

  • Install the breakout cable, Part Number 3162898, between the sensor and the sensor harness.
  • Turn keyswitch ON.

Action

Check the supply voltage from the ECM.

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Does not meet specifications?

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn the keyswitch ON.

Action

Use a multimeter to measure the voltage from the ECM.

  • Measure the voltage at the ECM from the SIGNAL pin to the RETURN pin of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 1D - Check the sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3162898, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor signal voltage.

  • Measure the signal voltage from pin B (or BLACK) to pin C (or YELLOW) of the breakout cable.
OK NOT OK

(+) 0.42 to 0.58-VDC?

Replace the OEM pressure sensor

Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and 31-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the 31-pin OEM connector.

Action

Inspect the OEM harness and 31-pin OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active?

Repair complete

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM 31-pin connector.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from the SUPPLY pin of the OEM 31-pin connector, OEM harness side, to the SIGNAL pin of the OEM sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from the SIGNAL pin to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the 31-pin OEM connector.

Action

Check for a short circuit from the SIGNAL pin to all other pins.

  • Measure the resistance from the SIGNAL pin of the 31-pin OEM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the 31-pin OEM connector.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from the SIGNAL pin of the 31-pin OEM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active?

Repair complete

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from the SIGNAL pin of the OEM connector, actuator side, to the SIGNAL pin of the sensor harness connector at the ECM.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from the SIGNAL pin to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from the SIGNAL pin to all other pins.

  • Measure the resistance from the SIGNAL pin of the sensor harness connector at the ECM to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to ground in the SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from the SIGNAL pin of the sensor harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.

Action

Check for appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, between the OEM connector SIGNAL pin and SUPPLY pin.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 inactive and Fault Code 297 active?

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 298 inactive.
OK NOT OK

Fault Code 298 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 319 - Real-Time Clock Power Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery backup module. |
 | STEP 1A. Inspect the ECM and actuator harness connectors. | No damaged pins?
 | STEP 1B. Check the battery backup voltage at the ECM actuator connector. | (+) 3.3 to 3.6-VDC?
 | STEP 1B-1. Inspect the battery backup module harness and actuator harness connector pins. |
 | STEP 1B-2. Check the battery backup voltage at the battery module connector. |
STEP 2. | Check the battery backup module harness. |
 | STEP 2A. Check for an open circuit in the SUPPLY wire. | Less than 10 ohms?
 | STEP 2B. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 319 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery backup module.

Guided Step 1A - Inspect the ECM and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the ECM and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery backup voltage at the ECM actuator connector.

Conditions

  • Engine equipped with optional real-time clock battery backup module.
  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the battery backup voltage at the ECM connector.

  • Measure battery voltage from pin-20 to pin-22 at the ECM connector.
  • Gently flex the harness when checking the voltage to check for internally broken or frayed wires.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 3.3 to 3.6-VDC?

Does not meet specifications?

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the battery backup module and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery backup module from the actuator harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the battery backup module and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 3A

Guided Step 1B-2 - Check the battery backup voltage at the battery module connector.

Conditions

  • Engine equipped with optional real-time clock battery backup module.
  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the battery backup module.

Action

Check the battery backup voltage at the battery module connector.

  • Measure the battery voltage from battery supply (+) to battery return (-) at the battery module connector, battery module side.
  • Gently flex the harness when checking the voltage to check for internally broken or frayed wires.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 3.3 to 3.6-VDC?

Does not meet specifications?

Replace the battery backup module.

Refer to Procedure 019-311 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery backup module harness.

Guided Step 2A - Check for an open circuit in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery backup module from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect for continuity in the SUPPLY wire.

  • Measure the resistance from pin-20 at the actuator harness connector to pin-A (or 1) at the engine harness connector at the battery backup module.
  • Gently flex the harness when checking the resistance to check for internally broken or frayed wires.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201, Procedure Refer to Procedure 019-202, Procedure Refer to Procedure 019-204, or Procedure Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery backup module from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect for continuity in the RETURN wire.

  • Measure the resistance from pin-22 at the actuator harness connector to pin-B (or 2) at the engine harness connector at the battery backup module.
  • Gently flex the harness when checking the resistance to check for internally broken or frayed wires.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the battery backup module from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-20 of the actuator harness connector to all the other pins in the connector.
  • Gently flex the harness when checking the resistance to check for internally broken or frayed wires.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the battery backup module from the engine harness.

Action

Check for a short circuit to ground in the battery backup module harness.

  • Measure the resistance from pin-20 in the actuator harness connector to engine block ground.
  • Gently flex the harness when checking the resistance to check for internally broken or frayed wires.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to set real-time clock to correct time.
  • Use INSITE™ electronic service tool to verify Fault Code 319 is inactive.

It is necessary to set the real-time clock with the INSITE™ electronic service tool to make Fault Code 319 go inactive.
OK NOT OK

Fault Code 319 inactive?

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2012


FAULT CODE 338 - Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:in Section 19Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the idle shutdown vehicle accessory/ignition bus relay. |
 | STEP 1A. Perform the ignition bus relay test. | Dashboard or blowers turn on
 | STEP 1B. Inspect the idle shutdown vehicle accessory/ignition bus relay connector pins. | No damaged pins
 | STEP 1C. Check the idle shutdown vehicle accessory relay resistance. | Use the OEM troubleshooting and repair manual for specifications
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to the battery. | Less than (+) 1.5 VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 338 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the idle shutdown vehicle accessory/ignition bus relay.

Guided Step 1A - Perform the ignition bus relay test.

Conditions

  • Refer to Procedure 019-308.

Action

Use INSITE™ electronic service tool to perform the ignition bus relay test.

  • Refer to Procedure 019-308 in Section 19.
OK NOT OK

Dashboard or blowers turn on

Does not meet specifications

Go to 3A

Go to 1B

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1B - Inspect the idle shutdown vehicle accessory/ignition bus relay connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check the OEM harness and the idle shutdown vehicle accessory relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the idle shutdown vehicle accessory relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check the idle shutdown vehicle accessory/ignition relay resistance.

  • Measure the resistance of the idle shutdown vehicle accessory/ignition relay coil.
OK NOT OK

Use the OEM troubleshooting and repair manual for specifications

Replace the idle shutdown vehicle accessory/ignition bus relay

Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check for an open circuit.

  • Measure the resistance from pin 35 of the OEM harness connector at the ECM to the idle shutdown vehicle accessory/ignition bus relay connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to the battery.

Conditions

  • Connect the OEM harness connector to the ECM.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory relay.
  • Turn keyswitch ON.

Action

Check the actuator resistance.

  • Measure the voltage from pin A (or 1) of the idle shutdown vehicle accessory/ignition bus relay to engine block ground.
OK NOT OK

Less than (+) 1.5 VDC

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codee.from

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 338 is inactive.
OK NOT OK

Fault Code 338 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-Jun-2017


FAULT CODE 339 - Idle Shutdown Vehicle Accessory/Ignition Bus Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the idle shutdown vehicle accessory/ignition bus relay. |
 | STEP 1A. Perform the ignition bus relay test. | Dashboard or blowers turn on
 | STEP 1B. Inspect the idle shutdown vehicle accessory/ignition bus relay connector pins. | No damaged pins
 | STEP 1C. Check the idle shutdown vehicle accessory relay resistance. | Use the OEM troubleshooting and repair manual for specifications
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 339 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the idle shutdown vehicle accessory/ignition bus relay.

Guided Step 1A - Perform the ignition bus relay test.

Conditions

  • Refer to Procedure 019-308 in Section 19.

Action

Use INSITE™ electronic service tool to perform the ignition bus relay test.

  • Refer to Procedure 019-308 in Section 19.
OK NOT OK

Dashboard or blowers turn on

Does not meet specifications

Go to 3A

Go to 1B

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1B - Inspect the idle shutdown vehicle accessory/ignition bus relay connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check the OEM harness and the idle shutdown vehicle accessory relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the idle shutdown vehicle accessory relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check the idle shutdown vehicle accessory/ignition releay resistance.

  • Measure the resistance of the idle shutdown vehicle accessory/ignition relay coil.
OK NOT OK

Use the OEM troubleshooting and repair manual for specifications

Replace the idle shutdown vehicle accessory/ignition bus relay

Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-204
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector to the ECM.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory relay.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 35 (or idle shutdown) of the OEM harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the idle shutdown vehicle accessory/ignition bus relay.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 339 is inactive.
OK NOT OK

Fault Code 339 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 341 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | No other active fault codes
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the resistance of the battery supply circuit. | Less than 10 ohms
 | STEP 2B. Check the battery voltage. | Normal conditions: at least (+) 12 VDC; During cranking: at least (+) 6.2 VDC
 | STEP 2C. Check the battery connections. | Connections are tight and corrosion-free
STEP 3. | Check the two 15-amp fuses. |
 | STEP 3A. Verify that the two 15-amp fuses are installed correctly. | Fuses installed correctly
 | STEP 3B. Verify that the two 15-amp fuses are not blown. | Fuses not blown
STEP 4. | Check the OEM harness. |
 | STEP 4A. Check the add-on or the accessory wiring at (+) terminal of the battery. | No damaged wires
STEP 5. | Calibrate the ECM. |
 | STEP 5A. Calibrate the ECM. | Fault Code 341 inactive
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 341 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read the fault codes using INSITE™.
OK NOT OK

No other active fault codes

Troubleshoot the active fault codes

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 2A - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance of the battery suuply circuit.

  • Measure the resistance from pin 7 of the OEM harness connector to the positive (+) battery terminal.
  • Measure the resistance from pin 8 of the OEM harness connector to the positive (+) battery terminal.
  • Measure the resistance from pin 17 of the OEM harness connector to the positive (+) battery terminal.
  • Measure the resistance from pin 18 of the OEM harness connector to the positive (+) battery terminal.
  • Measure the resistance from pin 28 of the OEM harness connector to the positive (+) battery terminal.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place positive (+) probe of the multimeter on the positive battery terminal and touch negative (-) probe to the negative battery terminal while trying to start engine.
OK NOT OK

Normal conditions: at least (+) 12 VDC; During cranking: at least (+) 6.2 VDC

Charge or replace the battery

Use the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Inspect the battery terminal connections.
OK NOT OK

Connections are tight and corrosion-free

Tighten the connections

Tighten the loose connections and clean the terminals.

Use the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the two 15-amp fuses.

Guided Step 3A - Verify that the two 15-amp fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the two 15-amp fuses are installed correctly.

  • Inspect the two 15 AMP fuses for correct installation.
OK NOT OK

Fuses installed correctly

Install the fuses correctly

Refer to Procedure 019-198.

Go to 3B

Go to 5A

Guided Step 3B - Verify that the two 15-amp fuses are not blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the two 15-amp fuses are not blown.

  • Inspect the two 15 AMP fuses to see if they are blown.
OK NOT OK

Fuses not blown

Locate the short circuit

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Check the add-on or the accessory wiring at (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

No damaged wires

Repair or replace the damaged wiring

Go to 5A

Go to 5A

Guided Step 5 - Calibrate the ECM.

Guided Step 5A - Calibrate the ECM.

Conditions

Connect all components.

Action

Calibrate the ECM.

  • Use electronic software and database network (ESDN) to calibrate the ECM.
OK NOT OK

Fault Code 341 inactive

Fault Code 341 active

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 341 is inactive.
OK NOT OK

Fault Code 341 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than three inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During cranking: At least (+) 6.2-VDC?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the harness and the engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the original equipment manufacturer (OEM) fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Recalibrate the ECM. |
 | STEP 4A. Recalibrate the ECM. | Fault Code 343 active after recalibrating the ECM?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During cranking: At least (+) 6.2-VDC?
YES NO
No Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Recalibrate the ECM.

Guided Step 4A - Recalibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 343 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Jan-2014


FAULT CODE 349 (INDUSTRIAL) - Auxiliary Speed Governor

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check frequency input signal sending unit. |
 | STEP 1A. Verify frequency input signal sending unit accuracy. | Frequency input signal sending unit output is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 349 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check frequency input signal sending unit.

Guided Step 1A - Verify frequency input signal sending unit accuracy.

Conditions

  • Turn keyswitch ON.

Action

Verify frequency input signal sending unit accuracy.

  • Use the OEM troubleshooting and repair manual for testing procedures.
OK NOT OK

Frequency input signal sending unit output is correct

Does not meet specifications

Repair or replace the OEM frequency input signal sending unit. Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.

If the fault was at a particular rpm, run engine at that rpm to verify the problem is corrected.
OK NOT OK

Fault Code 349 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes with INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Jul-2012


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | Signature™ ISX and QSX15 | 3666259
Engine Control Module (ECM) | Refer to Procedure 019-031 | Signature™ ISX and QSX15 | 3666259
Engine Wiring Harness | Refer to Procedure 019-043 | Signature™ ISX and QSX15 | 3666259
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Signature™ ISX and QSX15 | 3666259
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Signature™ ISX and QSX15 | 3666259

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and circuit connected to the sensor. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the ambient air pressure sensor and circuit connected to the sensor. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the fuel pressure sensor and circuit connected to the sensor. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and circuit connected to the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the ambient air pressure sensor and circuit connected to the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.

Action

Inspect the engine harness and the exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the ambient air pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the fuel pressure sensor and circuit connected to the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas recirculation (EGR) valve position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Oct-2012


FAULT CODE 359 - ICON™ Idle Control System

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Attempt to manually start the engine. |
 | STEP 1A. Check the ECM for active fault codes. | No active fault codes
 | STEP 1B. Manually start the engine. | Engine starts
STEP 2. | Activate ICON™, then check the ECM for active fault codes. |
 | STEP 2A. Check the ECM for active fault codes. | No active fault codes
STEP 3. | Check the starter relay contacts. |
 | STEP 3A. Perform the starter relay and interlocks test. | Starter engages
 | STEP 3B. Check for an open circuit in the ICON™ starter relay coil. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 359 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Attempt to manually start the engine.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the ECM for active fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

No active fault codes

Active fault codes present

Go to 1B

Troubleshoot active fault codes

Guided Step 1B - Manually start the engine.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Connect all components.

  • Use the keyswitch to start the engine.
OK NOT OK

Engine starts

Engine does not start

Use the Engine Will Not Start Symptom Procedure in the Troubleshooting and Repair Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239.

Go to 2A

Go to 4A

Guided Step 2 - Activate ICON™, then check the ECM for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Start and run engine.
  • Activate ICON™.

Action

Check the ECM for active fault codes.

  • When ICON™ shuts down the engine, read the fault codes using INSITE™.
OK NOT OK

No active fault codes

Active fault codes present

Go to 3A

Troubleshoot active fault codes

Guided Step 3 - Check the starter relay contacts.

Guided Step 3A - Perform the starter relay and interlocks test.

Conditions

  • Deactivate ICON™.
  • Shut OFF the engine.
  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Perform the starter relay and interlocks test.

  • Perform the starter relay and interlocks test using INSITE™. Use the INSITE™ User's Manual, Bulletin 3396837.
OK NOT OK

Starter engages

Starter does not engage

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in ICON™ starter relay coil

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ starter relay.

Action

Check for an open circuit in ICON™ starter relay coil.

  • Measure the resistance between the starter relay coil contacts.
OK NOT OK

Less than 10 ohms

Does not meet specifications

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 359 is inactive.
OK NOT OK

Fault Code 359 inactive

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Jul-2012


FAULT CODE 378 - Actuator Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™. Metri-Pack™, test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 1B-1. Inspect the actuator harness and connector pins. |
 | STEP 1B-2. Check for an open circuit in the actuator harness. |
 | STEP 1B-3. Check the resistance of the actuator solenoid. |
 | STEP 1C. Check for a short circuit from pin to pin in the ECM connector. | More than 100k ohms
 | STEP 1D. Check for a short circuit to ground in the actuator solenoid. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 378 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins with electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™. Metri-Pack™, test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the resistance of the whole circuit.

  • Measure the resistance from pin 9 to pin 10 of the actuator harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1B-1

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1B-1 - Inspect the actuator harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Inspect the harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins with electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-204 in Section 19, or Refer to Procedure in Section 19019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B-2

Go to 2A™

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™. Metri-Pack™, test lead.
Guided Step 1B-2 - Check for an open circuit in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 9 of the actuator harness connector to pin 1 (or A) of the actuator solenoid connector.
  • Measure the resistance from pin 10 of the actuator harness connector to pin 2 (or B) of the actuator solenoid connector.
OK NOT OK

Less than 5 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-204, or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1B-3

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B-3 - Check the resistance of the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the actuator solenoid.
OK NOT OK

0.5 to 1.5 ohms

Replace the actuator solenoid

Refer to Procedure 019-110.

Go to 1C

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin in the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 9 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 10 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1D

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check for a short circuit to ground in the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check for a short circuit to ground in the actuator solenoid.

  • Measure the resistance between both actuator solenoid pins to chassis ground.
OK NOT OK

More than 100k ohms

Replace the actuator solenoid

Refer to Procedure 019-110.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test the vehicle for at least one mile.
  • Use INSITE™ to verify Fault Code 378 is inactive.
OK NOT OK

Fault Code 378 inactive

Fault Code 378 active

Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 379 - Actuator Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™/ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 1B-1. Inspect the actuator harness and connector pins. |
 | STEP 1B-2. Check the resistance of the actuator solenoid. |
 | STEP 1C. Check for a short circuit to battery in the circuit. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin in the ECM connector. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 379 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the resistance of the whole circuit.

  • Measure the resistance from pin 9 to pin 10 of the actuator harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-1

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1B-1 - Inspect the actuator harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Inspect the actuator harness and connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1B-2 - Check the resistance of the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the actuator solenoid.
OK NOT OK

0.5 to 1.5 ohms

Replace the actuator solenoid

Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1C - Check for a short circuit to battery in the circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for a short circuit to battery in the circuit.

  • Measure the resistance between connector pin 9 of the actuator harness connector to pin 7 of the OEM harness connector.
  • Measure the resistance between connector pin 10 of the actuator harness connector to pin 7 of the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1D - Check for a short circuit from pin to pin in the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 9 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 10 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test vehicle for at least one mile.
  • Use INSITE™ to verify Fault Code 379 is inactive.
OK NOT OK

Fault Code 379 inactive

Fault Code 379 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 386 - Sensor Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check the supply voltage. | (+) 4.75 to 5.25-VDC
 | STEP 1C. Check for a short circuit to the battery. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 386 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from each sensor.

Action

Inspect the harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-204, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check the supply voltage.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage from pin 37 to pin 40 in the sensor port of the ECM.
  • Measure the voltage from pin 17 to pin 31 in the sensor port of the ECM.
  • Measure the voltage from pin 27 to pin 30 in the sensor port of the ECM.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to the battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for a short circuit to the battery.

  • Measure the resistance from pin 17 of the sensor harness connector to pin 7 of the OEM harness connector.
  • Measure the resistance from pin 37 of the sensor harness connector to pin 7 of the OEM harness connector.
  • Measure the resistance from pin 27 of the sensor harness connector to pin 7 of the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 37 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 40 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 31 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 27 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 30 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ to verify Fault Code 386 is inactive.
OK NOT OK

Fault Code 386 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 387 - Throttle Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM
CAUTION

To reduce the possibility of pin and harness damage use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMPin Section 19/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check the supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 1C. Check for a short circuit to battery. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin-to-pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 387 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM
CAUTION

To reduce the possibility of pin and harness damage use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMPin Section 19/Metri-Pack test lead.
Guided Step 1B - Check the supply voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the supply voltage out of the ECM OEM harness connector port at pin 48 to ground.
OK NOT OK

(+) 4.75 to 5.25 VDC

Replace the ECM

Refer to Procedure 019-031in Section 19 .

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1C - Check for a short circuit to battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to battery.

  • Measure the resistance from pin 7 to pin 48 in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the throttle sensor and the remote throttle sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 48 to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 387 is inactive.
OK NOT OK

Fault Code 387 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 388 - Engine Brake Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™AMP™Metri-Pack™test lead and Part Number 3162991 - engine brake breakout cable, male eight-way pass-through (ITT/Cannon) test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the engine brake connector. |
 | STEP 2A. Inspect the engine brake connector. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for actuator resistance. | 9.5 to 11.5 ohms (Operating Temperature Below 82°C [180°F]); 11.5 to 14 ohms (Operating Temperature Above 82°C [180°F])?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 388 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 8-pin engine brake connector.

Action

Inspect the engine harness, ECM connector pins, and the 8-pin engine brake connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 8-pin engine brake connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 25 to all other pins in the actuator harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 8-pin engine brake connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 25 in the actuator harness connector to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine brake connector.

Guided Step 2A - Inspect the engine brake connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector.

Action

Inspect the 8-pin engine brake connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or engine brake harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the internal engine brake harness. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-015 in Section 20.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector.
  • Install the engine brake breakout cable, Part Number 3162991, to the 8-pin engine brake connector.
  • Do not connect the engine brake breakout cable to the engine brake actuators.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 8, engine brake harness side, of the 8-pin engine brake connector to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the internal engine brake harness

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-015 in Section 20.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector.
  • Remove the valve cover.
  • Disconnect the engine brake solenoid leads on the forward-most engine brake solenoid.
  • Install the engine brake breakout cable, Part Number 3162991, to the 8-pin engine brake connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure resistance from pin 8, engine brake harness side, to all other pins in the 8-pin engine brake connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine brake harness

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-015 in Section 20.

Go to 2D

Go to 3A

Guided Step 2D - Check for actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid leads on the forward-most engine brake solenoid.

Action

Check for actuator resistance.

  • Measure the resistance between the two electrical terminals on the engine brake solenoid.
OK NOT OK

  • 9.5 to 11.5 ohms (Operating Temperature Below 82°C [180°F])
  • 11.5 to 14 ohms (Operating Temperature Above 82°C [180°F])

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Replace engine brake solenoid number 1

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-004 in Section 20.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 388 is inactive.
OK NOT OK

Fault Code 388 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?1

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 392 - Engine Brake Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3162991 - engine brake breakout cable - male eight-way pass-through (ITT/Cannon) test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3162991 - engine brake breakout cable - male eight-way pass-through (ITT/Cannon) test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3162991 - engine brake breakout cable - male eight-way pass-through (ITT/Cannon) test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the engine brake connector. |
 | STEP 2A. Inspect the engine brake connector. | No damaged pins
 | STEP 2B. Check for a short circuit to chassis ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for actuator resistance. | 9.5 to 11.5 ohms (cold); 11.5 to 14 ohms (hot)
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 392 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 8-pin engine brake connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 44 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 8-pin engine brake connector.

Action

Check for a short circuit to ground.

  • Measure resistance from pin 44 in the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine brake connector.

Guided Step 2A - Inspect the 8-pin engine brake connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector.

Action

Inspect the 8-pin engine brake connector for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or engine brake harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine brake harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 020-015 in Section 20 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3162991 - engine brake breakout cable - male eight-way pass-through (ITT/Cannon) test lead.
Guided Step 2B - Check for a short circuit to chassis ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector
  • Install the engine brake breakout cable, Part Number 3162991, to the engine brake connector.
  • Do not connect the engine brake breakout cable to the engine brake actuators.

Action

Check for a short circuit to chassis ground.

  • Measure the resistance from pin 1 of the engine brake breakout cable to chassis ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine brake harness

  • Repair the engine brake harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 020-015 in Section 20 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3162991 - engine brake breakout cable - male eight-way pass-through (ITT/Cannon) test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector.
  • Remove the valve cover.
  • Disconnect the engine brake solenoid leads on the engine brake solenoid controlling cylinders number 2 and 3.
  • Install the engine brake breakout cable, Part Number 3162991, to the 8-pin engine brake connector.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 1 to all other pins in the 8-pin engine brake connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine brake harness

  • Repair the engine brake harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 020-015 in Section 20 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2D - Check for actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.
  • Disconnect the engine brake solenoid leads on the on the engine brake solenoid controlling cylinders number 2 and 3.

Action

Check for actuator resistance.

  • Measure resistance between the two electrical terminals on the engine brake solenoid.
OK NOT OK

9.5 to 11.5 ohms (cold); 11.5 to 14 ohms (hot)

Replace the ECM. Refer to Procedure 019-031in Section 19 .

Replace engine brake actuator number 2

Use the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Code 392 is inactive.
OK NOT OK

Fault Code 392 inactive

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic servivce tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 393 - Engine Brake Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3162991 - engine brake breakout cable - male eight-way pass-through (ITT/Cannon™) test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the engine brake connector. |
 | STEP 2A. Inspect the engine brake connector. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to chassis ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check actuator resistance. | 9.5 to 11.5 ohms (cold) 11.5 to 14 ohms (hot)?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 393 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connecator
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 15 of the actuator harness connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 8-pin engine brake connector.

Action

Check for a short circuit to ground.

  • Measure resistance from pin 15 of the actuator harness connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine brake connector.

Guided Step 2A - Inspect the engine brake connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake connector from the engine harness.

Action

Inspect the engine brake connector pins for the following:

  • Loose connecator
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or engine brake harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-209 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine brake harness. Refer to Procedure 019-209 in Section 19.
  • Replace the engine brake harness. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-015 in Section 20.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to chassis ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector.
  • Install the engine brake breakout cable, Part Number 3162991, to the engine brake connector.
  • Do not connect the engine brake breakout cable to the engine brake actuators.

Action

Check for a short circuit to chassis ground.

  • Measure the resistance from pin 5 of the engine brake breakout cable to chassis ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine brake harness.

  • Repair the engine brake harness. Refer to Procedure 019-209 in Section 19.
  • Replace the engine brake harness. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-015 in Section 20.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake connector.
  • Remove the valve cover.
  • Disconnect the engine brake solenoid leads on the rear-most engine brake solenoid.
  • Install the engine brake breakout cable, Part Number 3162991, to the 8-pin engine brake connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 5 to all other pins in the engine brake breakout cable.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine brake harness

  • Repair the engine brake harness. Refer to Procedure 019-209 in Section 19.
  • Replace the engine brake harness. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-015 in Section 20.

Go to 2D

Go to 3A

Guided Step 2D - Check actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.
  • Disconnect the engine brake solenoid leads on the forward-most engine brake solenoid.

Action

Check for actuator resistance.

  • Measure resistance between the two electrical terminals on the engine brake solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

9.5 to 11.5 ohms (cold)

11.5 to 14 ohms (hot)

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace engine brake actuator 3. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-012 in Section 20.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 393 is inactive.
OK NOT OK

Fault Code 393 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 394 - Actuator Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 1B-1. Inspect the actuator harness and connector pins. |
 | STEP 1B-2. Check for an open circuit in the actuator harness. |
 | STEP 1B-3. Check the resistance of the actuator solenoid. |
 | STEP 1C. Check for a short circuit from pin-to-pin in the ECM connector. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit to ground in the actuator solenoid. | Greater than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 394 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the resistance of the whole circuit.

  • Measure the resistance from pin 7 to pin 8 of the actuator harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-1

Go to 2A

Guided Step 1B-1 - Inspect the actuator harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Inspect the harness and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 2A

Guided Step 1B-2 - Check for an open circuit in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 7 of the actuator harness connector to pin 1 (or A) of the actuator solenoid connector.
  • Measure the resistance from pin 8 of the actuator harness connector to pin 2 (or B) of the actuator solenoid connector.
OK NOT OK

Less than 5 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-3

Go to 2A

Guided Step 1B-3 - Check the resistance of the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the actuator solenoid.
OK NOT OK

0.87 ohms at -17°C (0°F) to 1.73 ohms at 54°C (130°F)

1.10 ohms at 38°C (100°F) to 1.97 ohms at 93°C (200°F)

Replace the actuator solenoid. Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit from pin-to-pin in the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check for short circuit from pin-to-pin.

  • Measure the resistance from pin 7 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 8 in the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground in the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check for short circuit to ground in the actuator solenoid.

  • Measure the resistance between both actuator solenoid pins to the actuator body.
OK NOT OK

Greater than 100k ohms?

Replace the actuator solenoid. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test vehicle for 1 mile.
  • Use INSITE™ electronic service tool to verify Fault Code 394 is inactive.
OK NOT OK

Fault Code 394 inactive?

Fault Code 394 active.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 395 - Actuator Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 1B-1. Inspect the actuator harness and connector pins. |
 | STEP 1B-2. Check the resistance of the actuator solenoid. |
 | STEP 1C. Check for a short circuit to battery in the circuit. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin in the ECM connector. | Greater than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 395 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the resistance of the actuator harness.

  • Measure the resistance from pin 7 to pin 8 of the actuator harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-1

Go to 2A

Guided Step 1B-1 - Inspect the actuator harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the timing actuator solenoid.

Action

Inspect the actuator harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 2A

Guided Step 1B-2 - Check the resistance of the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the timing actuator solenoid.

Action

Check the resistance of the timing actuator solenoid.

  • Measure the resistance across the two terminals on the timing actuator solenoid.
OK NOT OK

0.87 ohms at -17°C (0°F) to 1.73 ohms at 54°C (130°F)

1.10 ohms at 38°C (100°F) to 1.97 ohms at 93°C (200°F)

Replace the timing actuator solenoid. Refer to Procedure 019-111 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit to battery in the circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the timing actuator solenoid.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery in the timing actuator solenoid.

  • Measure the resistance between the timing actuator harness connector pins 7 and 8 to pin 7 of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit from pin-to-pin in the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the timing actuator solenoid.

Action

Check for short circuit from pin-to-pin.

  • Measure the resistance from pin 7 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 8 in the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 395 is inactive.
OK NOT OK

Fault Code 395 inactive?

Fault Code 395 active.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 396 - Actuator Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 1B-1. Inspect the actuator harness and connector pins. |
 | STEP 1B-2. Check for an open circuit in the actuator harness. |
 | STEP 1B-3. Check the resistance of the actuator solenoid. |
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1D. Check for a short circuit to ground in the actuator solenoid. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 396 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins.

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the resistance of the actuator harness.

  • Measure the resistance from pin 6 to pin 16 of the actuator harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-1

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1B-1 - Inspect the actuator harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Inspect the actuator harness and connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1B-2 - Check for an open circuit in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 6 of the actuator harness connector to pin 2 (or B) of the actuator solenoid connector.
  • Measure the resistance from pin 16 of the actuator harness connector to pin 1 (or A) of the actuator solenoid connector.
OK NOT OK

Less than 5 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205, or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-3

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B-3 - Check the resistance of the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the actuator solenoid.
OK NOT OK

0.5 to 1.5 ohms

Replace the rear fueling actuator solenoid. Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 16 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1D - Check for a short circuit to ground in the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the actuator solenoid.

Action

Check for a short circuit to ground in the actuator solenoid.

  • Measure the resistance between pin 1 (or A) on the actuator connector to the actuator body.
  • Measure the resistance between pin 2 (or B) on the actuator connector to the actuator body.
OK NOT OK

More than 100k ohms

Replace the rear fueling actuator solenoid. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test vehicle for at least 1 mile.
  • Use INSITE™ electronic service tool to verify that Fault Code 396 is inactive.
OK NOT OK

Fault Code 396 inactive

Fault Code 396 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 397 - Actuator Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 1B-1. Inspect the actuator harness and connector pins. |
 | STEP 1B-2. Check the resistance of the actuator solenoid. |
 | STEP 1C. Check for a short circuit to battery in the circuit. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin in the ECM connector. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 397 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the resistance of the whole circuit.

  • Measure the resistance from pin 6 to pin 16 of the actuator harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-1

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1B-1 - Inspect the actuator harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Inspect the harness and actuator connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-205, Refer to Procedure 019-202, or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1B-2 - Check the resistance of the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the actuator solenoid.
OK NOT OK

0.5 to 1.5 ohms

Replace the rear fueling actuator solenoid. Refer to Procedure 019-110 in Section.

Go to 1C

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1C - Check for a short circuit to battery in the circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for a short circuit to battery in the actuator solenoid.

  • Measure the resistance between pins 6 and 16 in the actuator harness connector to pin 7 of the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 1D - Check for a short circuit from pin to pin in the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 16 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and test drive the vehicle for at least 1 mile.
  • Use INSITE™ electronic service tool to verify that Fault Code 397 is inactive.
OK NOT OK

Fault Code 397 inactive

Fault Code 397 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


Fault Code 398 - Actuator Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 1B-1. Inspect the actuator harness and connector pins. |
 | STEP 1B-2. Check for an open circuit in the actuator harness. |
 | STEP 1B-3. Check the resistance of the actuator solenoid. |
 | STEP 1C. Check for a short circuit from pin to pin in the ECM connector. | More than 100k ohms?
 | STEP 1D. Check for a short circuit to ground in the actuator solenoid. | More than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 398 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 1B

Go to 2A

Guided Step 1B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the resistance of the whole circuit.

  • Measure the resistance from pin 26 to pin 36 of the actuator harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-1

Go to 2A

Guided Step 1B-1 - Inspect the actuator harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Inspect the actuator harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 2A

Guided Step 1B-2 - Check for an open circuit in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 26 of the actuator harness connector to pin 2 (or B) of the actuator solenoid connector.
  • Measure the resistance from pin 36 of the actuator harness connector to pin 1 (or A) of the actuator solenoid connector.
OK NOT OK

Less than 5 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-3

Go to 2A

Guided Step 1B-3 - Check the resistance of the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the actuator solenoid.
OK NOT OK

0.87 ohm at -17°C [0°F] to 1.73 ohms at 54°C [130°F]?

1.10 ohms at 38°C [100°F] to 1.97 ohms at 93°C [200°F]?

Replace the rear timing actuator solenoid. Refer to Procedure 019-111 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit from pin-to-pin in the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the actuator solenoid.

Action

check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 26 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 36 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground in the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the actuator solenoid.

Action

Check for a short circuit to ground in the actuator solenoid.

  • Measure the resistance between each of the actuator solenoid pins to the actuator body.
OK NOT OK

More than 100k ohms?

Replace the rear timing actuator solenoid. Refer to Procedure 019-111 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test the vehicle for at least one mile.
  • Use INSITE™ electronic service tool to verify that Fault Code 398 is inactive.
OK NOT OK

Fault Code 398 inactive?

Fault Code 398 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Jun-2012


Fault Code 399 - Actuator Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 1B-1. Inspect the actuator harness and connector pins. |
 | STEP 1B-2. Check the resistance of the actuator solenoid. |
 | STEP 1C. Check for a short circuit to battery in the circuit. | More than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin in the ECM connector. | More than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 399 is inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the actuator harness.

Guided Step 1A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the resistance of the whole circuit.

  • Measure the resistance from pin 26 to pin 36 of the actuator harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-1

Go to 2A

Guided Step 1B-1 - Inspect the actuator harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the timing actuator solenoid.

Action

Inspect the actuator harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 2A

Guided Step 1B-2 - Check the resistance of the actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the timing actuator solenoid.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the timing actuator solenoid.
OK NOT OK

0.87 ohm at -17°C [0°F] to 1.73 ohms at 54°C [130°F]?

1.10 ohms at 38°C [100°] to 1.97 ohms at 93°C [200°F]?

Replace the rear timing actuator solenoid. Refer to Procedure 019-111 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit to battery in the circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the timing actuator solenoid.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for a short circuit to battery in the circuit.

  • Measure the resistance between actuator harness connector pins 26 and 36 to pin 7 of the OEM harness connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit from pin-to-pin in the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the timing actuator solenoid.

Action

Check for short circuit from pin-to-pin in the ECM connector.

  • Measure the resistance from pin 26 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 36 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test it for at least 1 mile.
  • Use INSITE™ electronic service tool to verify that Fault Code 399 is inactive.
OK NOT OK

Fault Code 399 inactive

Fault Code 399 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Jun-2012


FAULT CODE 415 - Engine Oil Pressure Low - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 415. | Active or inactive counts of Fault Code 415?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 415.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ to read the fault codes.

Active or inactive counts of Fault Code 415?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Repair complete

Last Modified: 25-May-2012


FAULT CODE 419 - Intake Manifold Pressure Sensor

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 115. |
 | STEP 1A. Check to see if Fault Code 115 is active at engine start-up. | Fault Code 115 inactive?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for a valid fault code. | Fault Code 419 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 419 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for Fault Code 115.

Guided Step 1A - Check to see if Fault Code 115 is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if Fault Code 115 is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 115 inactive?

Troubleshoot Fault Code 115 first.

Go to 2A

Fault Code 115

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for a valid fault code.

Conditions

  • Make certain that the oil temperature is greater than 4°C [40°F].
  • Turn keyswitch OFF.

Action

Check for a valid fault code.

  • Wait 30 seconds.
  • Turn keyswitch ON and wait 15 seconds.
OK NOT OK

Fault Code 419 inactive?

Replace the sensor. Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 419 is inactive.
OK NOT OK

Fault Code 419 inactive?

Return to the troubleshooting steps, or contact the local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


Fault Code 422 - Coolant Level Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [122°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™; test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™; test lead Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes and the presence of the coolant level sensor. |
 | STEP 1A. Read the fault codes. | Fault Code 187 inactive?
 | STEP 1B. Check if vehicle has a coolant level sensor. | Coolant level sensor present?
 | STEP 1B-1. Check if a shorting plug is installed in place of the coolant level sensor harness connection. |
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Inspect the harness and coolant level sensor connectors. | Dirty or damaged pins?
 | STEP 2B. Inspect the harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the coolant level sensor circuit. | Less than 10 ohms?
 | STEP 2C-1. Inspect the 31-pin Deutsch™ connector pins. |
 | STEP 2C-2. Check for an open circuit in the engine harness. |
 | STEP 2C-3. Check for an open circuit in the OEM harness. |
STEP 3. | Check for a short circuit to ground in the signal wires. |
 | STEP 3A. Check for a short circuit to ground in the coolant level SIGNAL wires. | More than 100k ohms?
 | STEP 3A-1. Check for a short circuit to ground in the engine harness. |
 | STEP 3A-2. Check for a short circuit to ground in the OEM harness. |
STEP 4. | Check for a short circuit between the signal wires and any other wires in the engine harness or OEM harness. |
 | STEP 4A. Check for a short circuit between the signal wires and any other wires in the engine harness or OEM harness. | More than 100k ohms?
 | STEP 4A-1. Check for a short circuit in the engine harness. |
 | STEP 4A-2. Check for a short circuit in the OEM harness. |
STEP 5. | Check for a short circuit to ground in the supply wires. |
 | STEP 5A. Check for a short circuit to ground in the supply wires. | More than 100k ohms?
 | STEP 5A-1. Check for a short circuit in the engine harness. |
 | STEP 5A-2. Check for a short circuit in the OEM harness. |
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 422 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes and the presence of the coolant level sensor.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the active fault codes.

  • Read fault codes using INSITE™.
OK NOT OK

Fault Code 187 inactive?

Fault Code 187 active.

Go to 1B

Fault Code 187

Guided Step 1B - Check if vehicle has a coolant level sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check if vehicle has a coolant level sensor.

Check if vehicle has a coolant level sensor.
OK NOT OK

Coolant level sensor present?

Coolant level sensor not present.

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Check if a shorting plug is installed in place of the coolant level sensor harness connection.

Conditions

  • Turn keyswitch OFF.

Action

Check if a shorting plug is installed in place of the coolant level sensor harness connection.

Check the OEM wiring from the shorting plug to the engine harness connection for problems. Use the OEM and the engine harness wiring diagrams.

OK NOT OK

Shorting plug installed

Install the shorting plug

Go to 2A

Go to 6A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Inspect the harness and the coolant level sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Inspect the harness and the coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the coolant level sensor, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

Repair the OEM harness.

  • Refer to Procedure 019-204 in Section 19.
  • or Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Inspect the harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit in the coolant level sensor circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for an open circuit in the coolant level sensor circuit.

  • Measure the resistance from pin 25 in the sensor harness connector to pin C (or 3) on the harness side of the coolant level sensor connector.
  • Measure the resistance from pin 23 in the sensor harness connector to pin B (or 2) on the harness side of the coolant level sensor connector.
  • Measure the resistance from pin 24 in the sensor harness connector to pin D (or 4) on the harness side of the coolant level sensor connector.
  • Measure the resistance from pin 22 in the sensor harness connector to pin A (or 1) on the harness side of the coolant level sensor connector.
OK NOT OK

Less than 10 ohms?

–

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Inspect the 31 pin Deutsch™ connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness from the OEM harness at the Deutsch™ 31 pin connector.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C-2

Go to 6A

Guided Step 2C-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness from the OEM harness at the Deutsch™ 31 pin connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin 22 in the sensor harness connector to pin 6 on the engine harness side of the 31 pin connector.
  • Measure the resistance from pin 23 in the sensor harness connector to pin 19 on the engine harness side of the 31 pin connector.
  • Measure the resistance from pin 24 in the sensor harness connector to pin 5 on the engine harness side of the 31 pin connector.
  • Measure the resistance from pin 25 in the sensor harness connector to pin 7 on the engine harness side of the 31 pin connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C-3

Go to 6A

Guided Step 2C-3 - Check for an open circuit in OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the Deutsch™ 31 pin connector.
  • Disconnect the OEM harness at the Weather-Pack™ four-way connector.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 6 on the OEM wiring harness side of the 31 pin connector to pin A (or 1) on the OEM harness side of the 4 pin connector.
  • Measure the resistance from pin 19 on the OEM wiring harness side of the 31 pin connector to pin B (or 2) on the OEM harness side of the 4 pin connector.
  • Measure the resistance from pin 7 on the OEM wiring harness side of the 31 pin connector to pin C (or 3) on the OEM harness side of the 4 pin connector.
  • Measure the resistance from pin 5 on the OEM wiring harness side of the 31 pin connector to pin D (or 4) on the OEM harness side of the 4 pin connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check for a short circuit to ground in the signal wires.

Guided Step 3A - Check for a short circuit to ground in the coolant level sensor signal wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit to ground in the coolant level sensor signal wires.

  • Measure the resistance from pin 22 to engine block ground.
  • Measure the resistance from pin 24 to engine block ground.
  • Measure the resistance from pin 25 to engine block ground.
OK NOT OK

More than 100k ohms?

Does not meet specifications.

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness from the OEM harness at the Deutsch™ 31 pin connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance from pin 22 in the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 24 in the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 25 in the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness from the OEM harness at the 31 pin Deutsch™ connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin A (or 1) on the OEM harness side of the 4 pin connector to engine block ground.
  • Measure the resistance from pin C (or 3) on the OEM harness side of the 4 pin connector to engine block ground.
  • Measure the resistance from pin D (or 4) on the OEM harness side of the 4 pin connector to engine block ground.
OK NOT OK

More than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for a short circuit between the signal wires and any other wires in the engine harness or OEM harness.

Guided Step 4A - Check for a short circuit between the signal wires and any other wires in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM connector from the coolant level sensor.

Action

Check for a short circuit between the signal wires and any other wires in the OEM harness or engine harness.

  • Measure the resistance from pin 22 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 24 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Less than 100k ohms

Go to 6A

Go to 4A-1

Guided Step 4A-1 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM connector from the coolant level sensor.
  • Disconnect the engine harness from the OEM harness at the 31 pin Deutsch™ connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance from pin 22 in the sensor harness connector to pins 24, 23, and 25.
  • Measure the resistance from pin 24 in the sensor harness connector to pins 22, 23, and 25.
OK NOT OK

More than 100k ohms?

Repair or replace the engine or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Use the OEM service manual.
  • Replace the OEM harness. Use the OEM service manual.

Go to 4A-2

Go to 6A

Guided Step 4A-2 - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM harness at the OEM side of the Deutsch™ 31 pin connector.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin A (or 1) in the OEM harness connector to pins B (or 2), C (or 3), and D (or 4).
  • Measure the resistance from pin D (or 4) in the OEM harness connector to pins A (or 1), B (or 2), and C (or 3).
OK NOT OK

More than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 5A

Go to 6A

Guided Step 5 - Check for a short circuit to ground in the supply wires.

Guided Step 5A - Check for a short circuit to ground in the supply wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit between the supply wire and ground.

  • Measure the resistance from pin 25 in the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A-1

Go to 6A

Guided Step 5A-1 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the sensor harness from the OEM harness at the Deutsch™ 31 pin connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance from pin 25 in the sensor harness connector to pins 22, 23, and 24.
OK NOT OK

More than 100k ohms

Repair or replace the engine or OEM harnesses.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Use the OEM service manual.
  • Replace the OEM harness. Use the OEM service manual.

Go to 5A-2

Go to 6A

Guided Step 5A-2 - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the sensor harness from the OEM harness at the Deutsch™ 31 pin connector.
  • Disconnect the OEM harness at the Weather-Pack™ four-way connector.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin C (or 3) in the OEM harness connector to pins A (or 1), B (or 2), and D (or 4).
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Use the OEM service manual.
  • Replace the OEM harness. Use the OEM service manual.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 422 is inactive.
OK NOT OK

Fault Code 422 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


Fault Code 426 - J1939 Datalink Communication

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for proper multiplexing configuration. |
 | STEP 1A. Verify that the proper devices are set. | INSITE™ electronic service tool readout matches ECM settings for devices?
 | STEP 1B. Check data link output by reading INSITE™ electronic service tool. | Fault Code 426 inactive?
STEP 2. | Inspect the SAE J1939 connectors on the backbone harness and engine harness connectors. |
 | STEP 2A. Inspect the ECM connectors. | Diry or damaged pins?
 | STEP 2B. Inspect the connectors on any other device connected to the J1939 data link. | Dirty or damaged pins?
STEP 3. | Inspect the SAE J1939 backbone harness. |
 | STEP 3A. Check for an open circuit in the SUPPLY wire. | Less than 10 ohms?
 | STEP 3B. Check for an open circuit in the RETURN wire. | Less than 10 ohms
 | STEP 3C. Check the resistance value in the J1939 harness. | 55 to 65 ohms?
 | STEP 3D. Check for an open circuit in the SHIELD wire. | Less than 10 ohms?
 | STEP 3E. Check for a short circuit to power in the SUPPLY wire. | Less than (+) 1.5-VDC?
 | STEP 3F. Check for a short circuit to power in the RETURN wire. | Less than (+) 1.5-VDC?
 | STEP 3G. Check for a short circuit to ground in the SUPPLY wire. | More than 100k ohms?
 | STEP 3H. Check for a short circuit to ground in the RETURN wire. | More than 100k ohms?
 | STEP 3I. Check for a short circuit from pin-to-pin in the OEM connector. | More than 100k ohms?
STEP 4. | Check for malfunctioning J1939 devices. |
 | STEP 4A. Check communication between the ECM and the multiplex devices. | Established communication?
 | STEP 4A-1. Check for malfunctioning J1939 devices. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for proper multiplexing configuration.

Guided Step 1A - Verify that the proper devices are set.

Conditions

  • Install INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check that the vehicle inputs are multiplexed over the J1939 data link.

  • Read the devices that are sending input information with INSITE™ electronic service tool.
  • Information for settings are in menu: Adjustable Features and Parameters - J1939 Multiplexing.
OK NOT OK

INSITE™ electronic service tool read out matches ECM settings for devices.

Configure the ECM to match the multiplexing devices

Go to 1B

Go to 5A

Guided Step 1B - Check data link output by reading INSITE™ electronic service tool.

Conditions

  • Install the INLINE™ data link adapter.
  • Install INSITE™ electronic service tool. Use the INSITE™ electronic service tool manual for details.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the engine speed.
  • Check for any active fault codes.
OK NOT OK

Fault Code 426 inactive?

–

Go to 5A

Go to 2A

Guided Step 2 - Inspect the SAE J1939 connectors on the backbone harness and engine harness connectors.

Guided Step 2A - Inspect the ECM connectors.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the multiplexed devices.

Action

Inspect the ECM, OEM harness, J1939 connectors, and multiplexed devices for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness, J1939, 3 pin, or multiplexed devices, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the 3-pin connectors. Refer to Procedure 019-205 in Section 19.
  • Use the Signature, ISX and QSX15 Troubleshooting and Repair Manual, Bulletin 3666239, for specific multiplexed device.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the connectors on any other device connected to the J1939 data link.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VECU(s) from the J1939 backbone harness.
  • Disconnect the multiplexed devices from the VECU(s).

Action

Inspect the connectors on the VECU(s), 3 pin, and multiplexed devices connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the VECU(s), 3 pin connector, or multiplexed devices, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the VECU(s). Use the OEM service manual for repair procedure.
  • Repair the 3-pin connector. Refer to Procedure 019-205 in Section 19.
  • Repair or replace the multiplexed devices. Use the Signature, ISX and QSX15 Troubleshooting and Repair Manual, Bulletin 3666239.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the SAE J1939 backbone harness.

Guided Step 3A - Check for an open circuit in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 connector from the VECU(s).

Action

Check for an open circuit in the SUPPLY wire.

  • Measure resistance from supply pin 46 at the OEM harness connector to pin A at the data link connector at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 37 at the OEM connector to pin B at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the resistance value in the J1939 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness form the VECU(s).
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance value of the J1939 harness.

  • Measure from pin 46 in the OEM harness connector to pin 37 in the OEM harness connector.
OK NOT OK

55 to 65 ohms?

J1939 backbone termination resistors missing or damaged. Replace both termination resistors.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the SHIELD wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for an open circuit in the SHIELD wire.

  • Measure the resistance from pin 36 at the OEM harness connector at the ECM to pin C at the VECU(s).
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to power in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short to power in the SUPPLY wire.

  • Measure the voltage from pin 46 at the ECM to ground at the J1939 connector.
OK NOT OK

Less than (+) 1.5-VDC?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check for a short circuit to power in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to power in the RETURN wire.

  • Measure the voltage from pin 37 at the OEM harness connector to ground at the VECU(s) connector.
OK NOT OK

Less than (+) 1.5-VDC?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 5A

Guided Step 3G - Check for a short circuit to ground in the SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for short to ground in the SUPPLY wire.

  • Measure the resistance from pin 46 in the OEM harness connector to ground.
OK NOT OK

More than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3H

Go to 5A

Guided Step 3H - Check for a short circuit to ground in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short to ground in the RETURN wire.

  • Measure the resistance from pin 37 in the OEM harness connector to ground.
OK NOT OK

More than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3I

Go to 5A

Guided Step 3I - Check for a short circuit from pin-to-pin in the OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short from pin-to-pin in the OEM connector.

  • Measure the resistance from pin 46 in the OEM harness connector to all other pins in the connector, except pins 36 and 37.
  • Measure the resistance from pin 36 in the OEM harness connector to all other pins in the connector, except pins 46 and 37.
  • Measure the resistance from pin 37 in the OEM harness connector to all other pins in the connector, except pins 36 and 46.
OK NOT OK

More than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for malfunctioning J1939 devices.

Guided Step 4A - Check communication between the ECM and the multiplex devices.

Conditions

  • Install INSITE™ electronic service tool.
  • Install INLINE™ electronic service tool data link adapter.
  • Disconnect all J1939 devices from the J1939 data link.
  • Turn keyswitch ON.

Action

Check communication with ECM using INSITE™ electronic service tool over J1939.

  • Use INSITE™ electronic service tool top confirm communication between ECM and multiplexing devices.
OK NOT OK

Established communication?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Check for malfunctioning J1939 devices.

Conditions

  • Install INSITE™ electronic service tool.
  • Install INLINE ™ electronic service tool data link adapter.
  • Turn keyswitch ON.

Action

Check for malfunctioning J1939 devices.

  • Disconnect J1939 devices from the J1939 backbone one-by-one until communication can be established using INSITE™ electronic service tool.

BEFORE disconnecting J1939 devices, remember to turn keyswitch OFF, so ECM will not register fault code.

OK NOT OK

Proper communication between J1939 devices and J1939 backbone?

Replace malfunctioning J1939 device. Use the OEM service manual for repair procedures.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 426 is inactive.
OK NOT OK

Fault Code 426 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 428 - Water-In-Fuel (WIF) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check engine harness. |
 | STEP 1A. Inspect the engine harness, water-in-fuel sensor, and ECM connectors. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1C. Check sensor supply voltage. | (+) 4.75 to 5.25 VDC?
 | STEP 1D. Measure the voltage from the ECM. | (+) 4.75 to 5.25 VDC?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 428 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check engine harness.

Guided Step 1A - Inspect the engine harness, sensor, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness, water-in-fuel sensor, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM or water-in-fuel sensor, or whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the water-in-fuel sensor. Refer to Procedure 019-127.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 9 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 10 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check sensor supply voltage.

Conditions

  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check sensor supply voltage.

  • Measure the voltage from pin B (or 2) on the harness side of the water-in-fuel sensor connector to engine block ground.
OK NOT OK

(+) 4.75 to 5.25 VDC

  • Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

Above or below 4.75 to 5.25 VDC

Go to 2A

Go to 1D

Guided Step 1D - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage out of the ECM from pins 9 to pin 10 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the Fault Code 428 is inactive.
OK NOT OK

Fault Code 428 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 429 - Water-In-Fuel (WIF) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check engine harness. |
 | STEP 1A. Inspect the engine harness, water-in-fuel sensor, and ECM connectors. | No damaged pins
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1C. Check for a short circuit from pin-to-pin. | More than 100k ohms
 | STEP 1D. Check sensor supply voltage. | (+) 4.75 to 5.25 VDC?
 | STEP 1E. Measure supply voltage from the ECM. | (+) 4.75 to 5.25 VDC?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 429 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check engine harness.

Guided Step 1A - Inspect the engine harness, water-in-fuel sensor, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness, water-in-fuel sensor, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, or replace the water-in-fuel sensor or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 9 of the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 9 in the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check sensor supply voltage.

Conditions

  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check sensor supply voltage.

  • Measure the voltage from pin B (or 2) on the harness side of the water-in-fuel sensor connector to engine block ground.
OK NOT OK

(+) 4.75 to 5.25 VDC?

  • Replace water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

Does not meet specifications.

Go to 2A

Go to 1E

Guided Step 1E - Measure supply voltage from the ECM.

Conditions

  • Disconnect the sensor harness from the water-in-fuel sensor.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure supply voltage from the ECM.

  • Measure the voltage from pin 9 to pin 10 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 429 is inactive.
OK NOT OK

Fault Code 429 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 434 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the integrated sensor switch. |
 | STEP 1A. Verify the integrated sensor switch is connected to the OEM harness. | Integrated sensor switch is connected?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 inactive?
 | STEP 1C. Inspect the harness and integrated sensor switch connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an open circuit. | Less than 125 ohms
 | STEP 1E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C. Check for an open circuit. | Less than 125 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the integrated sensor switch.

Guided Step 1A - Verify the integrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the integrated sensor switch is connected to the OEM harness.

  • Inspect the integrated sensor switch connection.
OK NOT OK

Integrated sensor switch is connected?

Connect the integrated sensor switch.

  • Connect the OEM harness to the integrated sensor switch. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 inactive?

Fault Code 431 active?

Go to 3A

Go to 1C

Guided Step 1C - Inspect the harness and integrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.

Action

Inspect the harness and integrated sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins

Repair or replace the integrated sensor switch or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the integrated sensor switch if the connector pins are damaged. Refer to the OEM troubleshooting and repair manual.
  • Replace the integrated sensor switch connector if it is oversized or damaged. Refer to the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.

Action

Check for an open circuit.

  • Measure the resistance from the idle SIGNAL pin to the RETURN wire pin on the integrated sensor switch with the pedal released.
  • Measure the resistance from the off-idle SIGNAL pin to the RETURN wire pin on the integrated sensor switch with the pedal depressed.
OK NOT OK

Less than 125 ohms?

Replace the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the idle SIGNAL pin to the off-idle SIGNAL pin on the integrated sensor switch with the pedal released and depressed.
OK NOT OK

Greater than 100k ohms?

Replace the integrated sensor switch. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins

Repair or replace the OEM harness, repair the OEM bulkhead connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Repair the bulkhead connector. Refer to the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the ECM supply voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM supply voltage.

  • Measure the voltage from pin 3 of the ECM OEM port to the engine block ground.
  • Measure the voltage from pin 13 of the ECM OEM port to the engine block ground.
OK NOT OK

(+) 4.75 to 5.25 VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the integrated sensor switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 of the OEM harness connector to pin 19 of the OEM harness connector with the accelerator pedal released.
  • Measure the resistance from pin 13 of the OEM harness connector to pin 19 of the OEM harness connector with the accelerator pedal depressed.
OK NOT OK

Less than 125 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the integrated sensor switch.
  • All cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch to the OFF position for 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic to verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 431 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the nonintegrated sensor switch. |
 | STEP 1A. Verify the nonintegrated sensor switch is connected to the OEM harness. | Nonintegrated sensor switch is connected?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 inactive?
 | STEP 1C. Inspect the harness and nonintegrated sensor switch connector pins. | No damaged pins?
 | STEP 1D. Check for an open circuit. | Less than 10 ohms?
 | STEP 1E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | No damaged pins?
 | STEP 2B. Check the ECM supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C. Check for an open circuit. | Less than 125 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the nonintegrated sensor switch.

Guided Step 1A - Verify the nonintegrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the nonintegrated sensor switch is connected to the OEM harness.

Verify the nonintegrated sensor switch is connected to the OEM harness.
OK NOT OK

Nonintegrated sensor switch is connected?

Connect the nonintegrated sensor switch

  • Connect the OEM harness to the nonintegrated sensor switch. Use the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 inactive?

Fault Code 431 active

Go to 1C

Go to 3A

Guided Step 1C - Inspect the harness and nonintegrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the nonintegrated sensor switch.

Action

Inspect the harness and nonintegrated sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

  • Corroded pins
OK NOT OK

No damaged pins?

Repair damaged pins

Repair or replace the nonintegrated sensor switch or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the nonintegrated sensor switch if the connector pins are damaged. Use the OEM service manual.
  • Replace the nonintegrated sensor switch connector if it is oversize or damaged. Use the OEM service manual.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the nonintegrated sensor switch.

Action

Check for an open circuit.

  • Measure the resistance from the idle SIGNAL pin to the RETURN wire pin on the nonintegrated sensor switch with the pedal released.
  • Measure the resistance from the off-idle SIGNAL pin to the RETURN wire pin on the nonintegrated sensor switch with the pedal depressed.
OK NOT OK

Less than 10 ohms?

Replace the nonintegrated sensor switch. Use the OEM service manual.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the nonintegrated sensor switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the idle SIGNAL pin to the off-idle SIGNAL pin on the nonintegrated sensor switch with the pedal released and depressed.
OK NOT OK

More than 100k ohms?

Replace the nonintegrated sensor switch. Use the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair damaged pins

Repair or replace the OEM harness, repair the OEM bulkhead connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.
  • Repair the bulkhead connector. Use the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the ECM supply voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM supply voltage.

  • Measure the voltage from pin 3 of the ECM OEM port to the engine block ground.
  • Measure the voltage from pin 13 of the ECM OEM port to the engine block ground.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the nonintegrated sensor switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the OEM harness connector to pin 19 (or applicable cab common RETURN pin) of the OEM harness connector with the accelerator pedal released.
  • Measure the resistance from pin 3 of the OEM harness connector to pin 19 (or applicable cab common RETURN pin) of the OEM harness connector with the accelerator pedal depressed.

Pin 9, 10, 19, or 20 can be used as cab common returns depending on the OEM configuration.
OK NOT OK

Less than 125 ohms?

Repair or replace the OEM harness. Use the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the nonintegrated sensor switch.
  • All cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms?

Repair or replace the OEM harness. Use the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch to the OFF position for 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Jul-2012


FAULT CODE 431 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solid-state switch. |
 | STEP 1A. Verify the solid-state switch is connected to the OEM harness. | Solid-state switch is connected?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 inactive?
 | STEP 1C. Inspect the harness and solid-state switch connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an open circuit. | Less than 125 ohms
 | STEP 1E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C. Check for an open circuit. | Less than 125 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solid-state switch.

Guided Step 1A - Verify the solid-state switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the solid-state switch is connected to the OEM harness.

  • Inspect the solid-state switch connection.
OK NOT OK

Solid-state switch is connected?

Connect the solid-state switch

  • Connect the OEM harness to the solid-state switch. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 inactive?

Fault Code 431 active

Go to 1C

Go to 3A

Guided Step 1C - Inspect the harness and solid-state switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solid-state switch.

Action

Inspect the harness and solid-state switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins

Repair or replace the solid-state switch or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the solid-state switch if the connector pins are damaged. Refer to the OEM troubleshooting and repair manual.
  • Replace the solid-state switch connector if it is oversized or damaged. Refer to the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solid-state switch.

Action

Check for an open circuit.

  • Measure the resistance from the idle SIGNAL pin to the RETURN wire pin on the solid-state switch with the pedal released.
  • Measure the resistance from the off-idle SIGNAL pin to the RETURN wire pin on the solid-state switch with the pedal depressed.
OK NOT OK

Less than 125 ohms?

Replace the solid-state switch. Refer to the OEM troubleshooting and repair manual.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solid-state switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the idle SIGNAL pin to the off-idle pin on the solid-state switch with the pedal released and depressed.
OK NOT OK

Greater than 100k ohms?

Replace the solid-state switch. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins

Repair or replace the OEM harness, repair the OEM bulkhead connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.
  • Repair the bulkhead connector. Use the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the ECM supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the ECM supply voltage.

  • Measure the voltage from pin 3 of the ECM OEM port to the engine block ground.
  • Measure the voltage from pin 13 of the ECM OEM port to the engine block ground.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the solid-state switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 of the OEM harness connector to pin 19 (or applicable cab common RETURN pin) of the OEM harness connector with the accelerator pedal released.
  • Measure the resistance from pin 13 of the OEM harness connector to pin 19 (or applicable cab common RETURN pin) of the OEM harness connector with the accelerator pedal depressed.

Pin 9, 10, 19, or 20 can be used as cab common returns depending on the OEM configuration.
OK NOT OK

Less than 125 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the solid-state switch.
  • All cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch to ON and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch to OFF for 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Jun-2012


FAULT CODE 432 - Accelerator Pedal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Perform the fault code disable procedure. | Fault Code 432 still active?
 | STEP 1B. Check for idle validation fault codes. | Fault Codes 131 and 551 inactive?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | No damaged pins?
 | STEP 2B. Check the resistance. | 1500 to 3000 ohms (released)? 250 to 1500 ohms (depressed)?
 | STEP 2B-1. Check the resistance of the accelerator position sensor. |
 | STEP 2B-2. Check the resistance in the OEM harness. |
 | STEP 2C. Check for a short circuit from pin to pin in the OEM harness. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 432 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Perform the fault code disable procedure.

Conditions

  • All components connected.
  • Turn keyswitch ON.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal to the full-fuel position and release it completely three times.
  • Use INSITE™ electronic service tool to read the inactive fault codes.
OK NOT OK

Fault Code 432 still active?

Replace the accelerator pedal assembly. Use the equipment manufacturer's service manual.

Go to 1B

Go to 3A

Guided Step 1B - Check for idle validation fault codes.

Conditions

  • All the components connected.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 131 and 551 inactive?

Fault Codes 131 or 551 active

Go to 2A

Fault Code 131 or 551

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance.

  • Measure the resistance from pin 47 to pin 48 of the OEM harness connector with the accelerator pedal in the released (idle) position.
  • Repeat the measurement with the accelerator pedal in the depressed (full-fuel) position.

Resistance with the pedal released must be at least 1000 ohms greater than when it is depressed.

OK NOT OK

1500 to 3000 ohms (released)?

250 to 1500 ohms (depressed)?

Released value must be at least 1000 ohms greater than depressed value.

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the resistance of the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance of the accelerator position sensor.

  • Measure the resistance from pin C (or 3) to pin B (or 2) on the sensor side of the accelerator position sensor connector with the accelerator pedal in the released (idle) position.
  • Repeat the above measurement with the accelerator pedal in the depressed (full-fuel) position.

Resistance when the pedal is released must be at least 1000 ohms greater than when it is depressed.

OK NOT OK

1500 to 3000 ohms (released)?

250 to 1500 ohms (depressed)?

Released value must be at least 1000 ohms greater than depressed value.

Replace the accelerator pedal assembly. Use the equipment manufacturer's service manual.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check the resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance in the OEM harness.

  • Measure the resistance from pin 47 of the OEM harness connector to pin C (or 3) on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 48 of the OEM harness connector to pin B (or 2) on the harness side of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit from pin-to-pin in the OEM harness.

  • Measure the resistance from pin 47 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 49 of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Depress the accelerator pedal to the full-fuel position and release it completely, three times.
  • Start the engine and let it idle for 1 minute.
  • Drive the vehicle.
  • Use INSITE™ electronic service tool to verify Fault Code 432 is inactive.
OK NOT OK

Fault Code 432 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Jul-2012


FAULT CODE 433 - Intake Manifold Pressure Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metripack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure/temperature sensor. |
 | STEP 1A. Inspect the sensor circuit for tampering. | No tampering?
 | STEP 1B. Inspect the harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 1C. Check intake manifold temperature/pressure sensor supply voltage. | 4.75-VDC to 5.25-VDC?
 | STEP 1C-1. Measure voltage from the ECM. | 4.75-VDC to 5.25-VDC?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2E. Check the ambient air pressure. | 635 to 774.7 mm Hg [25.0 to 30.5 in Hg]?
 | STEP 2F. Check the intake manifold pressure. | Less than 127 mm Hg [5 in Hg]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 433 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold pressure/temperature sensor.

Guided Step 1A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure/temperature sensor and the sensor harness for external wires or damaged harness braiding.
OK NOT OK

No tampering?

Remove and document tampering

  • If tampering has occurred, repair the circuit and document the tampering.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the intake manifold temperature/pressure sensor supply voltage.

Conditions

  • Install breakout cable, Part Number 3162898, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure/temperature sensor supply voltage.

  • Measure the supply voltage from pin A (or RED) to pin B. (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Does not meet specifications

Go to 2A

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage at the ECM from pin 37 to pin 40 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit in the return line.

  • Measure the resistance from pin 40 of the sensor harness connector to pin 2 (or B) of the intake manifold pressure/temperature sensor connector on the harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-202 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 39 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Disconnect the sensor harness from the intake manifold pressure/temperature sensor.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 39 in the sensor harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the ambient air pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the ambient air pressure.

  • Use INSITE™ electronic service tool to monitor the ambient air pressure.
OK NOT OK

635 to 774.7 mm Hg [25.0 to 30.5 in Hg]?

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the intake manifold pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the intake manifold pressure.

  • Use INSITE™ electronic service tool to monitor the intake manifold pressure.
OK NOT OK

Less than 127 mm Hg [5 in Hg]?

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 433 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


Fault Code 434 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuator or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack ™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | No active or inactive actuator fault codes?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the resistance of the battery supply circuit. | Less than 10 ohms?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC. During cranking: At least (+) 6.2-VDC
 | STEP 2C. Check the battery connections. | Connections are tight and corrosion-free?
STEP 3. | Check the fuses. |
 | STEP 3A. Check if the two 15-ampere fuses are installed correctly. | Fuses installed correctly?
 | STEP 3B. Check if the two 15-ampere fuses are blown. | Fuses not blown?
 | STEP 3C. Check if the 5-ampere fuse is installed correctly. | Fuse installed correctly?
 | STEP 3D. Check if the 5-ampere fuse is blown. | Fuse not blown?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the battery power circuits. | (+) 10 to 15-VDC
 | STEP 4C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 4D. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
 | STEP 4E. Check all engine brake spade connectors. | No loose connections or evidence of arcing?
 | STEP 4F. Check all metering and timing actuator connectors. | No loose connections or evidence of arcing?
 | STEP 4G. Check the keyswitch input-to-ECM wire. | Keyswitch input wire is uninterrupted?
 | STEP 4H. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 434 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No active or inactive actuator fault codes?

Troubleshoot the actuator fault codes. Use the appropriate actuator fault code tree.

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect both positive and negative terminals from the battery.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance from pins 7, 8, 17, 18, and 28 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pins 29, 30, 39, 40, and 50 of the OEM harness connector to the negative (-) battery terminal connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.
OK NOT OK

Normal conditions: At least (+) 12-VDC

During cranking: At least (+) 6.2-VDC

Charge or replace the battery. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.
OK NOT OK

Connections are tight and corrosion-free?

Tighten the connections?

  • Tighten the loose connections, and clean the terminals. Refer the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the fuses.

Guided Step 3A - Check if the two 15-ampere fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Check if the two 15-amp fuses are installed correctly.

  • Inspect the two 15-ampere fuses for correct installation.
OK NOT OK

Fuses installed correctly

Install the fuses correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check if the two 15-ampere fuses are blown.

Conditions

  • Turn keyswitch OFF.

Action

Check if the two 15-amp fuses are blown.

  • Inspect the two 15-ampere fuses to see if they are blown.
OK NOT OK

Fuses not blown

Locate the short circuit

  • Replace the OEM harness. Use the OEM service manual.
  • Replace the blown fuse(s).

Go to 3C

Go to 5A

Guided Step 3C - Check if the 5-ampere fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Check if the 5-amp fuse is installed correctly in the vehicle keyswitch wire.

  • Inspect the 5-ampere fuse for correct installation.
OK NOT OK

Fuse installed correctly

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check if the 5-ampere fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Check if the 5-amp fuse is blown.

  • Inspect the 5-ampere fuse to see if it is blown.
OK NOT OK

Fuse not blown

Locate the short circuit

  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the blown fuse.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins with electrical contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage from pin 7 to pin 29 of the OEM harness connector.
  • Measure the voltage from pin 8 to pin 30 of the OEM harness connector.
  • Measure the voltage from pin 17 to pin 39 of the OEM harness connector.
  • Measure the voltage from pin 18 to pin 40 of the OEM harness connector.
  • Measure the voltage from pin 28 to pin 50 of the OEM harness connector.
OK NOT OK

(+) 10 to 15-VDC?

Repair or replace the engine harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect both positive (+) and negative (-) terminals from the battery.

Action

Check for a short circuit.

  • Measure the resistance from pin 7 of the OEM harness connector to all other pins in the connector except pins 5, 6, 8, 16, 17, 18, 28, and 38.
  • Measure the resistance from pin 8 of the OEM harness connector to all other pins in the connector except pins 5, 6, 7, 16, 17, 18, 28, and 38.
  • Measure the resistance from pin 17 of the OEM harness connector to all other pins in the connector except pins 5, 6, 7, 8, 16, 18, 28, and 38.
  • Measure the resistance from pin 18 of the OEM harness connector to all other pins in the connector except pins 5, 6, 7, 8, 16, 17, 28, and 38.
  • Measure the resistance from pin 28 of the OEM harness connector to all other pins in the connector except pins 5, 6, 7, 8, 16, 17, 18, and 38.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4D

Go to 5A

Guided Step 4D - Check the add-on or the accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair or replace the damaged wiring

Go to 4E

Go to 5A

Guided Step 4E - Check all engine brake spade connectors.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure for information on removal of the rocker lever cover in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-011 in Section 3.

Action

Check all engine brake spade connectors for the following:

  • Loose connections
  • Arcing.
OK NOT OK

No loose connections or evidence of arcing?

Clean and tighten the spade connectors

Go to 4F

Go to 5A

Guided Step 4F - Check all metering and timing actuator connectors.

Conditions

  • Turn keyswitch OFF.

Action

Check all metering and timing connectors for the following:

  • Loose connections
  • Arcing.
OK NOT OK

No loose connections or evidence of arcing?

Clean and tighten the connectors

Go to 4G

Go to 5A

Guided Step 4G - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

OK NOT OK

Keyswitch input wire is uninterrupted?

Correct the wiring so the wire is uninterrupted.

Go to 4H

Go to 5A

Guided Step 4H - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to pin 38 of the OEM harness connector.
OK NOT OK

Less than 5 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn the keyswitch to the OFF position for 30 seconds.
  • Turn the keyswitch ON.
  • Use INSITE™ to verify Fault Code 434 is inactive.

For Fault Code 434 to become inactive, the ECM must go through one complete shutdown.

OK NOT OK

Fault Code 434 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 435 - Oil Pressure Sensor

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 115. |
 | STEP 1A. Check to see if Fault Code 115 is active at engine start-up. | Fault Code 115 inactive?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for a valid fault code. | Fault Code 435 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 435 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for Fault Code 115.

Guided Step 1A - Check to see if Fault Code 115 is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if Fault Code 115 is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 115 inactive?

Troubleshoot Fault Code 115 first.

Go to 2A

Fault Code 115

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for a valid fault code.

Conditions

  • Make certain that the oil temperature is greater than 4°C [40°F].
  • Turn keyswitch OFF.

Action

Check for a valid fault code.

  • Wait 30 seconds.
  • Turn keyswitch ON and wait 15 seconds.
OK NOT OK

Fault Code 435 inactive?

Replace the sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 435 is inactive.
OK NOT OK

Fault Code 435 inactive?

Return to the troubleshooting steps, or contact the local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 441 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections?
 | STEP 1B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC? During cranking: At least (+) 6.2-VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the fuse connections. | Fuses installed correctly?
 | STEP 2B. Check the fuses. | Fuses not blown?
 | STEP 2C. Inspect the OEM harness and ECM connector pins. | No damaged pins?
 | STEP 2D. Check for an open circuit in the battery power circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit. | More than 100k ohms?
 | STEP 2F. Check the add-on or the accessory wiring at positive (+) terminal of the battery. | No damaged wires?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

No damaged connections?

Repair the damaged connections

  • Tighten the battery connections and clean the battery terminals. Use the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.
OK NOT OK

Normal conditions:At least (+) 12-VDC?

During cranking: At least (+) 6.2-VDC?

Charge or replace the battery. Use the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 15-amp fuses from the OEM harness.

Action

Inspect the fuse connections.

Check if the two 15-amp fuses are installed correctly.
OK NOT OK

Fuses installed correctly?

Install fuses correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 15-amp fuses from the OEM harness.

Action

Check the fuses.

Check if the two 15-amp fuses are blown.
OK NOT OK

Fuses not blown?

Replace the fuses. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Replace the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit in the battery power circuit.

  • Measure the resistance from pin 7 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 8 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 17 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 18 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 28 of the OEM harness connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit.

  • Measure the resistance from pin 7 to all other pins in the OEM harness connector except for pins 8, 17, 18, and 28.
  • Measure the resistance from pin 8 to all other pins in the OEM harness connector except for pins 7, 17, 18, and 28.
  • Measure the resistance from pin 17 to all other pins in the OEM harness connector except for pins 7, 8, 18, and 28.
  • Measure the resistance from pin 18 to all other pins in the OEM harness connector except for pins 7, 8, 17, and 28.
  • Measure the resistance from pin 28 to all other pins in the OEM harness connector except for pins 7, 8, 17, and 18.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause the SUPPLY wire to have a short circuit to the engine block.
OK NOT OK

No damaged wires?

Repair the damaged wiring

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 441 is inactive.
OK NOT OK

Fault Code 441 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Jul-2012


FAULT CODE 442 - Unswitched Battery Supply Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check the battery voltage. | Normal conditions: At least (+) 12-VDC? During cranking: At least (+) 6.2-VDC?
 | STEP 1B. Check the alternator. | Alternator functioning normally?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while cranking the engine.
OK NOT OK

Normal conditions: At least (+) 12-VDC?

During cranking: At least (+) 6.2-VDC?

Charge or replace the battery. Use the OEM service manual.

Go to 1B

Go to 2A

Guided Step 1B - Check the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator for normal operation.

Use the OEM service manual for procedure.
OK NOT OK

Alternator functioning normally?

Repair the alternator. Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 442 is inactive.
OK NOT OK

Fault Code 442 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Jul-2012


FAULT CODE 443 - Throttle Voltage Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Check the accelerator position sensor. | Fault Code 443 active?
 | STEP 1B. Check the remote throttle position sensor. | Fault Code 443 active?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 443 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Check the accelerator position sensor.

Conditions

  • Disconnect the sensor harness from the accelerator position sensor.

Action

Check the accelerator position sensor.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 443 is still active.
OK NOT OK

Fault Code 443 active?

Replace the accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the remote throttle position sensor.

Conditions

  • Connect the accelerator position sensor to sensor harness.
  • Disconnect the sensor harness from the remote throttle position sensor.

Not all vehicles have a remote throttle position sensor.

If not, go to Step 2A.

Action

Check the remote throttle sensor.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 443 is still active.
OK NOT OK

Fault Code 443 active?

Replace the remote throttle position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire or insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A devective connection has been detected in the harness or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 48 of the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 48 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 443 is inactive.
OK NOT OK

Fault Code 443 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-May-2012


FAULT CODE 449 - High Fuel Pressure

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fuel restriction. |
 | STEP 1A. Check for fuel restriction in the drain line. | Restriction below 4.0 in Hg?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical gauge. | Gauge and sensor pressures are within 10 psi?
STEP 3. | Replace fuel regulator. |
 | STEP 3A. Replace the 250-psi fuel regulator. | Fault Code 449 goes inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 449 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for fuel restriction.

Guided Step 1A - Check for fuel restriction in the drain line.

Conditions

  • Turn keyswitch OFF.

Action

Check for fuel restriction in the drain line.

  • Install restriction gauge in fuel return line.
OK NOT OK

Restriction below 4.0 in Hg?

Correct drain line restriction

Use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy.

  • Connect a mechanical fuel pressure gauge to the pressure-side Compuchek™ fitting.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Start the engine and compare the fuel pressure reading on the service tool monitor screen to the reading on the mechanical fuel pressure gauge.
OK NOT OK

Gauge and sensor pressures are within 10 psi?

Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Replace the fuel regulator.

Guided Step 3A - Replace the 250-psi regulator.

Conditions

  • Turn keyswitch OFF.

Action

Replace the 250-psi regulator.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.
OK NOT OK

Fault Code 449 inactive?

Fault Code 449 active

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 449 is inactive.
OK NOT OK

Fault Code 449 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Jul-2012


FAULT CODE 451 - Front Rail Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the front rail pressure sensor. |
 | STEP 1A. Inspect the sensor harness and sensor connector pins. | No damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 451 inactive?
 | STEP 1C. Check the supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the front rail pressure sensor signal voltage. | (+) 0.5 to 4.7-VDC?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness connector pins and the ECM for damage. | No damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 451 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2D. Check for open circuit in the return wire. | Less than 10 ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 451 inactive and Fault Code 452 active?
STEP 4. | Clear fault code. |
 | STEP 4A. Disable fault code. | Fault Code 451 inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the front rail pressure sensor.

Guided Step 1A - Inspect the sensor harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front rail pressure sensor from the engine harness.

Action

Inspect the sensor harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Replace the 3-pin Metri-Pack™ connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the 3-pin Metri-Pack™ connector. Refer to Procedure 019-202 in Section 19.
  • Replace the front rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 451 inactive?

Fault Code 451 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the supply voltage.

Conditions

  • Install breakout cable between the sensor and the harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage by installing the breakout cable's SUPPLY pin A (or RED) and RETURN pin B (or BLACK) leads into the multimeter.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage at the ECM from pin 5 to pin 3 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check the front rail pressure sensor signal voltage.

Conditions

  • Install breakout cable between the sensor and the harness connector.
  • Turn keyswitch ON.

Action

Check the front rail pressure sensor signal voltage.

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 0.5 to 4.7-VDC?

Does not meet specifications.

Go to 3A

Go to 2A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness connector pins and the ECM for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the sensor harness connector pins and the ECM for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 451 inactive?

Fault Code 451 active.

Go to 4A

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the front rail pressure sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 4 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the front rail pressure sensor from the sensor harness.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin 3 of the ECM sensor harness connector to pin B (or 2) of the front rail pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Replace the front rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 451 inactive and Fault Code 452 active?

Fault Code 451 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear fault code.

Guided Step 4A - Disable fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 451 inactive.
OK NOT OK

Fault Code 451 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic servic etool to clear all inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Jul-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3854774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 inactive
STEP 2. | Check the front rail pressure sensor. |
 | STEP 2A. Inspect the sensor harness and sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 452 inactive
 | STEP 2C. Check the supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 2D. Check the front rail pressure sensor signal voltage. | (+) 0.5 to 4.7 VDC
 | STEP 2D-1. Check for a short circuit to ground. |
 | STEP 2D-2. Check for a short circuit from pin to pin. |
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness connector pins and the ECM for damage. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 452 inactive
 | STEP 3C. Check for an open circuit in the signal wire. | Less than 10 ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 452 inactive and Fault Code 451 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 452 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read active fault codes using INSITE™.
OK NOT OK

Fault Code 187 inactive

Possible sensor failure, short circuit to ground in the sensor, or in the sensor (+) 5 VDC common supply.

Go to 2A

Fault Code 187

Guided Step 2 - Check the front rail pressure sensor.

Guided Step 2A - Inspect the sensor harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front rail pressure sensor from the sensor harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the connector, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the front rail pressure sensor. Refer to Procedure 019-115.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 452 inactive

Fault Code 452 active.

Go to 5B

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824774, between the sensor and the harness connector.
  • Turn keyswitch ON.

Action

–

  • Measure the supply voltage by installing the breakout cable's supply pin A (or RED) and return pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 4.75 to 5.25 VDC

Does not meet specifications.

Go to 2D

Go to 2C-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage at the ECM from pin 5 to pin 3 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Replace the ECM. Refer to Procedure 019-031.

Go to 5A

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3854774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check the front rail pressure sensor signal voltage.

Conditions

  • Install breakout cable between the sensor and the harness connector.
  • Turn keyswitch ON.

Action

–

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 0.5 to 4.7 VDC

Does not meet specifications.

Go to 2D-1

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front rail pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 4 of the sensor harness connector to ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043.

Go to 2D-2

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-2 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the front rail pressure sensor from the sensor harness

Action

–

  • Measure the resistance from pin 4 of the sensor harness connector at the ECM to all other pins in the connector.
OK NOT OK

More than 100k ohms

  • Replace the front rail pressure sensor. Refer to Procedure 019-115.

Replace the engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the sensor harness connector pins and the ECM for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes, using INSITE™.
OK NOT OK

Fault Code 452 inactive

Fault Code 452 active.

Go to 5B

Go to 3C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit in the signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the front rail pressure sensor from the sensor harness.

Action

–

  • Measure the resistance from pin 4 of the sensor harness connector to pin C (or 3) of the fuel rail pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Install a jumper wire between ECM sensor port pin 4 and pin 5.
OK NOT OK

Fault Code 452 inactive and Fault Code 451 active

Fault Code 452 active

  • Replace the ECM. Refer to Procedure 019-031.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™, verify that Fault Code 452 is inactive.
OK NOT OK

Fault Code 452 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location, if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Use INSITE™ to clear all inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


FAULT CODE 465 - Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wiring harness. |
 | STEP 1A. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to the battery. | Less than (+) 1.5-VDC?
STEP 2. | Check the wastegate actuator. |
 | STEP 2A. Inspect the wastegate actuator connector. | Dirty or damaged pins?
 | STEP 2B. Check the actuator solenoid post for corrosion. | Corrosion found?
 | STEP 2C. Check the wastegate actuator resistance. | Resistance from 7 to 8 ohms for 12-VDC solenoids and 28 to 32 ohms for 24-VDC solenoids?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 465 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the wiring harness.

Guided Step 1A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 1.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins.
  • Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-032 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the actuator harness connector from the ECM
  • Disconnect the engine harness from the wastegate actuator 1.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from pin 24 in the actuator harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to the battery.

Conditions

  • Turn keyswitch OFF
  • Disconnect the actuator harness connector from the ECM
  • Disconnect the engine harness from the wastegate actuator 1.

Action

Check for a short circuit to the battery.

  • Measure the voltage from pin 1 of the wastegate actuator connector to engine block ground.
  • Measure the voltage from pin 24 of the actuator harness connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Less than (+) 1.5-VDC?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the wastegate actuator.

Guided Step 2A - Inspect the wastegate actuator connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the wastegate actuator 1.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the wastegate actuator connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the actuator connector terminal.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if is is damaged or missing.
  • Repair the actuator connector. Refer to Procedure 019-197 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the actuator solenoid post for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Check the solenoid post for corrosion.

Corrosion found on solenoid post?
YES NO

Clean the solenoid post.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Resistance from 7 to 8 ohms for 12-VDC solenoids and 28 to 32 for 24-VDC solenoids?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the actuator solenoid.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 465 is inactive.

Fault Code 465 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Troubleshoot any remaining active fault codes.

Last Modified: 01-Nov-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness and ECM connector pins. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for an open circuit. | Less than 10 ohms
STEP 2. | Check the wastegate actuator. |
 | STEP 2A. Inspect the wastegate actuator connector for damaged pins. | No damaged pins
 | STEP 2B. Check the actuator post for corrosion. | No corrosion
 | STEP 2C. Check the wastegate actuator resistance. | 7 to 8 ohms for (+) 12-VDC solenoids. 28 to 32 ohms for (+) 24-VDC solenoids
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 466 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness and ECM connector pins.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

–

  • Measure the resistance from pin 24 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

–

  • Measure the resistance from pin 24 of the actuator harness connector to ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 1.

Action

–

  • Measure the resistance from pin 24 of the actuator harness connector to the wastegate actuator number 1 wire.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

Guided Step 2 - Check the wastegate actuator.

Guided Step 2A - Inspect the wastegate actuator connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 1.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Check the wastegate actuator connector for damaged pins.
OK NOT OK

No damaged pins

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2B

Go to 3A

Guided Step 2B - Check the actuator post for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

–

  • Check the solenoid post for corrosion.
OK NOT OK

No corrosion

Clean the solenoid post.

Go to 2C

Go to 3A

Guided Step 2C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate actuator from the engine harness.

Action

–

  • Measure the resistance from the wastegate actuator number 1 to engine block ground.
OK NOT OK

7 to 8 ohms for (+) 12-VDC solenoids

28 to 32 ohms for (+) 24-VDC solenoids

Replace the actuator solenoid. Refer to Procedure 010-109 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin Number 3666239.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™, verify that Fault Code 466 is inactive.
OK NOT OK

Fault Code 466 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Clear the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the cab thermostat display for a fault code. |
 | STEP 1A. Check the cab thermostat display for an active fault code. | No active fault codes
STEP 2. | Check the cab thermostat output signal. |
 | STEP 2A. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for thermostat communication with the ECM. | Cab Comfort mode operates
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 469 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the cab thermostat display for a fault code.

Guided Step 1A - Check the cab thermostat display for an active fault.

Conditions

  • Turn cab thermostat ON.
  • Turn keyswitch ON.

Action

–

  • Check for an active fault code on the cab thermostat display.
OK NOT OK

No active fault codes

E1: Replace the thermostat.

E2: Check for an open circuit, short to battery, short to ground on the ambient air sensor circuit; check connector pins, too.

E3: See Shop Talk for explanations.

Go to 2A

Go to 3A

Guided Step 2 - Check the cab thermostat output signal.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2A - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the cab thermostat.

Action

–

  • Measure the resistance from pin 3 of the OEM harness cab thermostat connector to ground.
OK NOT OK

More than 100k ohms

Repair or replace OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the cab thermostat.

Action

–

  • Measure the resistance from pin 3 of the OEM harness cab thermostat connector to pin 32 of the OEM harness connector at the ECM.
OK NOT OK

Less than 10 ohms

Repair or replace OEM harness

  • Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for thermostat communication with the ECM.

Conditions

  • Turn cab thermostat ON.
  • Turn keyswitch ON.

Action

–

  • Check to see that the Cab Comfort mode is functioning.
OK NOT OK

Cab Comfort mode operates

Replace the cab thermostat. Use the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™, verify that Fault Code 469 is inactive.
OK NOT OK

Fault Code 469 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3827258 - male Deutsch/AMP/Metri-Pack test leadPart Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 141, 187, and 227 are not active
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the oil level sensor and the engine harness connector pins. | No damaged pins
 | STEP 2B. Check the oil level sensor supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 2D. Check the oil level sensor signal voltage. | (+) 0.4 to 4.5 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector for damaged pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin in the actuator harness. | More than 100k ohms
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 472 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 135, 141, 187, and 227 are not active

Fault Codes 135, 141, 187, and 227 active.

Go to 2A

Fault Code 135, 141, 187, and 227

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the oil level sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil level sensor.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the oil level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the oil level sensor. Use the Master Repair Manual, Centinel™, Bulletin 3666231.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
Guided Step 2B - Check the oil level sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from the ECM.
  • Disconnect sensor harness from the oil level sensor.
  • Install the breakout cable, Part Number 3824775, between the sensor and the harness connector.

Action

–

  • Measure the supply voltage from pin A (or RED) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 4.75 to 5.25 VDC

Above or below (+) 4.75 to 5.25 VDC

Go to 2C

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Disconnect sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the resistance from pin 26 of the ECM sensor harness connector to pin 2 (or B) of the oil level sensor connector.
OK NOT OK

Less than 10 ohms

Does not meet specifications.

Go to 2C-1

Go to 2C-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Turn keyswitch ON.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the voltage out of the ECM from pin 45 to pin 26 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Replace the ECM. Refer to Procedure 019-031.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3824775 - breakout cable.
Guided Step 2D - Check the oil level sensor signal voltage.

Conditions

  • Install the breakout cable, Part Number 3824775, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

–

  • Measure the signal voltage from pin C (or YELLOW) to pin B (or BLACK) of the breakout cable.
OK NOT OK

(+) 0.4 to 4.5 VDC

Replace the oil level sensor. Use the Master Repair Manual, Centinel™, Bulletin 3666231.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the engine harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 7 of the sensor harness connector to pin 3 (or C) of the oil level sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 7 of the sensor harness connector to chassis ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the oil level sensor.

Action

–

  • Measure the resistance from pin 7 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the oil level sensor.

Action

–

  • Measure the resistance from pin 7 of the sensor harness connector to all pins in the actuator harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™, verify Fault Code 472 is inactive.
OK NOT OK

Fault Code 472 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the starter solenoid lockout relay. |
 | STEP 1A. Inspect the starter lockout relay and solenoid harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the starter lockout relay. | Use the OEM specifications for resistance value
 | STEP 1C. Check for a short circuit to ground in the starter lockout relay. | More than 100k ohms
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and 31-pin connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin in the OEM harness. | More than 100k ohms
 | STEP 3C. Check for a short circuit to ground in the OEM harness. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 474 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the starter solenoid lockout relay.

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
Guided Step 1A - Inspect the starter lockout relay and solenoid harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the solenoid harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair damaged pins

  • Replace the starter lockout relay. Use the OEM troubleshooting and repair manual.
  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 1B

Go to 4A

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the solenoid harness connector.

Action

–

  • Measure the resistance between starter lockout relay connector pins.
OK NOT OK

Use the OEM specifications for resistance value

Replace the starter lockout relay. Use the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to ground in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the solenoid harness.

Action

–

  • Measure the resistance from the starter lockout relay connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the starter lockout relay. Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 46 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 46 in the actuator harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and 31-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair or replace the OEM harness

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check for a short circuit from pin to pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM harness from the starter lockout relay.

Action

–

  • Measure the resistance from pin 20 on the OEM harness side of the 31-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Does not meet specifications

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM harness from the starter lockout relay.

Action

–

  • Measure the resistance from pin 20 on the OEM harness side of the 31-pin connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 474 is inactive.
OK NOT OK

Fault Code 474 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Check the engine harness and ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the electronic air compressor governor. |
 | STEP 2A. Check the engine harness and electronic air compressor governor connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 475 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the air compressor governor solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 14 of the ECM actuator harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the air compressor governor solenoid.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 14 of the actuator harness connector to all other wires in the connector.
  • Measure the resistance from pin 14 of the actuator harness connector to all other wires in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

Guided Step 2 - Check the electronic air compressor governor.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the engine harness and electronic air compressor governor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic air compressor governor.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness at the 6-pin air compressor governor solenoid harness.
  • Disconnect the engine harness from the air compressor governor solenoid.

Action

–

  • Measure the resistance from pin 5 of the electronic air compressor governor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness at the 6-pin air compressor governor solenoid harness connector.

Action

–

  • Measure the resistance from pin 5 of the electronic air compressor governor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, or Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™, verify Fault Code 475 is inactive.
OK NOT OK

Fault Code 475 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wiring harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1D. Check for a short circuit to battery. | Less than (+) 1.5 VDC
 | STEP 1E. Check for an open circuit. | Less than 10 ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 476 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the wiring harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect actuator and sensor harness connectors from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the air compressor governor solenoid.

Action

–

  • Measure the resistance from pin 14 of the ECM actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the air compressor governor solenoid.

Action

–

  • Measure the resistance from pin 14 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check for a short circuit to battery.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the air compressor governor solenoid.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage from pin 14 of the actuator harness connector to engine block ground.
OK NOT OK

Less than (+) 1.5 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1E

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness at the 6-pin connector air compressor governor solenoid connector.

Action

–

  • Measure the resistance from pin 14 in the actuator harness connector to pin 5 of the 6-pin connector.
  • Measure the resistance from pin 11 in the actuator harness connector to pin 6 of the 6-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205, or Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™, verify Fault Code 476 is inactive.
OK NOT OK

Fault Code 476 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


FAULT CODE 482 - Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the fuel supply. |
 | STEP 2A. Check the vehicle fuel tanks for fuel. | Fuel in the fuel tanks?
 | STEP 2B. Verify the fuel system has been primed. | Fuel system properly primed?
 | STEP 2C. Check for fuel leaks. | Any fuel leaks in the tanks or the fuel supply lines?
 | STEP 2D. Check for fuel inlet restriction. | Fuel inlet restriction less than the specifications listed?
STEP 3. | Check the engine operation. |
 | STEP 3A. Crank the engine to see if it starts. | Engine start?
STEP 4. | Check the fuel lift pump operation. |
 | STEP 4A. Check the fuel lift pump for activation at keyswitch ON. | Fuel lift pump operates when the keyswitch is turned ON?
 | STEP 4B. Check the fuel lift pump pressure. | Positive fuel pressure greater than 64 kPa [10psi] present when the lift pump is operating?
STEP 5. | Check fuel shutoff valve operation. |
 | STEP 5A. Check the fuel shutoff valve electrical operation. | Fuel shutoff valve operate and 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
 | STEP 5B. Check for a mechanical restriction of the fuel shutoff valve. | Debris present in the fuel shutoff valve or signs the fuel shutoff valve is restricting flow?
STEP 6. | Check the 1724 kPa [250 psi] fuel pressure regulator. |
 | STEP 6A. Inspect the 1724 kPa [250 psi] fuel pressure regulator. | An debris that can stick the regulator open?
STEP 7. | Check the 2206 kPa [320 psi] pressure regulator. |
 | STEP 7A. Inspect the 2206 kPa [320 psi] pressure regulator. | More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?
STEP 8. | Check the fuel pump (gear pump) pressure. |
 | STEP 8A. Measure the fuel pump (gear pump) pressure while cranking. | Fuel pump (gear pump) pressure less than 2413 kPa [350 psi] cranking at 130 rpm for at least 15 seconds?
STEP 9. | Check the fuel pressure. |
 | STEP 9A. Measure the rail fuel pressure. | Rail fuel pressure at least 1448 kPa [210 psi] at idle?
 | STEP 9B. Measure the fuel pump (gear pump) pressure, engine operating. | Fuel pump (gear pump) pressure 1758 kPa [255 psi] to 2000 kPa [290 psi] at 2100 rpm?
STEP 10. | Check for air in the pressure-side fuel. |
 | STEP 10A. Check for air in the pressure-side fuel. | Air present in the pressure-side fuel?
STEP 11. | Check the fuel inlet restriction. |
 | STEP 11A. Measure the fuel inlet restriction. | Fuel inlet restriction less than the specification?
STEP 12. | Check the fuel shutoff valve. |
 | STEP 12A. Check for a mechanical restriction of the fuel shutoff valve. | Debris present in the fuel shutoff valve or signs the fuel shutoff valve is restricting flow?
STEP 13. | Check the 1724 kPa [250 psi] fuel pressure regulator. |
 | STEP 13A. Inspect the 1724 kPa [250 psi] fuel pressure regulator. | Any debris that can stick the regulator open?
STEP 14. | Check the 2206 kPa [320 psi] pressure regulator. |
 | STEP 14A. Inspect the 2206 kPa [320 psi] pressure regulator. | More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?
STEP 15. | Check the fuel pressure sensor for accuracy. |
 | STEP 15A. Verify the fuel pressure sensor for accuracy. | INSITE™ electronic service tool reading and pressure gauge reading match within 138 kPa [20 psi]?
STEP 16. | Clear the fault codes. |
 | STEP 16A. Disable the fault code. | Fault Code 482 inactive?
 | STEP 16B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 482 is active or inactive, attempt to clear fault. If fault remains active or inactive, continue through tree.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227

Go to 2A

Guided Step 2 - Check the fuel supply.

Guided Step 2A - Check the vehicle fuel tanks for fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle fuel tanks for fuel.

Fuel in the fuel tanks?
YES NO
No Repair

Fill the fuel tanks.

Go to 2C

Go to 16A

Guided Step 2B - Verify the fuel system has been primed.

Conditions

  • Turn keyswitch OFF.

Action

If entering this tree after a component has been replaced in the fuel system, or after the engine was emptied of fuel, verify the fuel system has been properly primed before proceeding.

  • Verify the fuel system has been properly primed.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-015 in Section 6.

Fuel system properly primed?
YES NO
No Repair

Prime the fuel system.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-015 in Section 6.

Go to 2C

Go to 16A

Guided Step 2C - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel tanks, lines, and related components for leaks.

  • Inspect for fuel leaks.

Any fuel leaks in the tanks or the fuel supply lines?
YES NO

Locate and repair the source of the fuel leak by checking all the engine and OEM supply lines, fittings, suction-side fuel filter head, and fuel tank stand pipes, ECM cooling plate, and ECM cooling plate fuel supply and return lines.

No Repair

Go to 16A

Go to 2D

Guided Step 2D - Check for fuel inlet restriction.

Conditions

  • Connect the vacuum gauge to the suction side Compuchek™ fitting.
  • Turn keyswitch ON.
  • Operate engine at high idle (engine cranking if troubleshooting No-Start).

Action

If the engine uses a priming pump, wait until the priming pump has turned off and observe the reading on the vacuum gauge.

  • Check the fuel inlet restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specifications listed?
YES NO

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 018-016 in Section V.

Locate the cause of high fuel inlet restriction.

Check the suction-side fuel filter and fuel supply lines.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

Go to 3A

Repair complete

Guided Step 3 - Check the engine operation.

Guided Step 3A - Crank the engine to see if it starts.

Conditions

  • Turn keyswitch ON.

Action

Crank the engine to see if it starts.

  • Start the engine.

Engine start?
YES | NO
No Repair | No Repair

Go to 9A

Go to 4A

Guided Step 4 - Check the fuel lift pump operation.

Guided Step 4A - Check the fuel lift pump, if equipped, for activation at keyswitch ON.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel lift pump for activation at keyswitch ON.

  • Verify the fuel lift pump operates when the vehicle keyswitch is turned ON.

Fuel lift pump operates when the keyswitch is turned ON?
YES NO
No Repair

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-045 in Section 5.

Go to 4B

Go to 16A

Guided Step 4B - Check the fuel lift pump pressure, if equipped.

Conditions

  • Turn keyswitch ON.
  • Connect a pressure gauge on the gear pump inlet Compuchek™ fitting.

If the engine is not equipped with a fuel lift pump, skip to Step 5A

Action

Check the fuel lift pump pressure.

  • Verify there is a positive fuel pressure greater than 64 kPa [10 psi] when the fuel lift pump is operating.

Erratic fuel lift pump pressure can indicate air in the fuel.

Positive fuel pressure greater than 64 kPa [10 psi] present when the lift pump is operating?
YES NO
No Repair

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-045 in Section 5.

Go to 5A

Go to 16A

Guided Step 5 - Check the fuel shutoff valve.

Guided Step 5A - Check the fuel shutoff valve electrical operation.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel shutoff valve for activation at keyswitch ON.

  • Verify the fuel shutoff operates and there is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON.

Fuel shutoff valve operate and is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
YES NO
No Repair

  • Check the fuel shutoff valve. Refer to Procedure 019-049 in Section 19.

Go to 5B

Go to 16A

Guided Step 5B - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch ON.

Action

Check for a mechanical restriction of the fuel shutoff valve.

  • Remove and inspect the fuel shutoff valve for a mechanical restriction or damage.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Debris present in the fuel shutoff valve or signs the fuel shutoff valve is restricting flow?
YES NO

  • Use the following procedure to check the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 16A

Go to 6A

Guided Step 6 - Check the 1724 kPa [250 psi] pressure regulator.

Guided Step 6A - Inspect the 1724 kPa [250 psi] pressure regulator.

Conditions

  • Turn keyswitch OFF.

Action

Remove and inspect the 1724 kPa [250 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

Any debris that can stick the regulator open?
YES NO

Replace the regulator.

 No Repair

Go to 16A

Go to 7A

Guided Step 7 - Check the 2206 kPa [320 psi] pressure regulator.

Guided Step 7A - Inspect the 2206 kPa [320 psi] pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 2206 kPa [320 psi] pressure regulator.

  • Disconnect the OEM drain line connection at the integrated fuel system module (IFSM).
  • Install a short piece of hose and place the end of the hose into a bucket.
  • Disconnect the wiring harness from the fueling and timing actuators.
  • Turn keyswitch ON and wait until the lift pump stops operating.
  • Crank the engine for 15 seconds and measure the fuel from the integrated fuel system module (IFSM) drain.

More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 2206 kPa [320 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 16A

Go to 8A

Guided Step 8 - Check the fuel pump (gear pump) pressure.

Guided Step 8A - Measure the fuel pump (gear pump) pressure while cranking.

Conditions

  • Connect a pressure gauge to the Compuchek™ fitting on the back of the fuel pump (gear pump).
  • Turn keyswitch ON.
  • Disconnect the wire at the fuel shutoff valve.

Action

Measure the fuel pump (gear pump) pressure while cranking.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after the keyswitch is turned ON or disconnect the 2-pin power supply from the lift pump.

The engine wiring harness must be disconnected from the fuel shutoff valve during this step.

  • Measure the fuel pump (gear pump) pressure while cranking the engine.

Do not crank the engine for 30 seconds continuously. Crank the engine in 15 second intervals with a 15 second pause between intervals. This reduces the possibly of overheating the starting motor

Fuel pump (gear pump) pressure less than 2413 kPa [350 psi] cranking at 130 rpm for at least 15 seconds?
YES NO

Repair or replace the fuel pump (gear pump).

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-016 in Section 5.

No Repair

Go to 16A

Go to 16A

Guided Step 9 - Check the fuel pressure.

Guided Step 9A - Measure the fuel pump (gear pump) pressure at idle.

Conditions

  • Connect all components.
  • Connect pressure gauge, Part Number 3375932, or equivalent, onto the Compuchek™ fitting.
  • Operate engine at idle.

Action

Measure the fuel pump (gear pump) pressure at idle.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.

Measure the fuel pump (gear pump) pressure.

  • With the engine operating at idle, use a pressure gauge attached to the rail pressure Compuchek™ fitting on the IFSM to measure the fuel pump (gear pump) pressure.

Fuel pump (gear pump) pressure at least 1448 kPa [210 psi] at idle?
YES | NO
No Repair | No Repair

Go to 9B

Go to 12A

Guided Step 9B - Measure the fuel pump (gear pump) pressure at high idle.

Conditions

  • Connect all components.
  • Connect pressure gauge, Part Number 3375932, or equivalent, onto the Compuchek™ fitting (as shown).
  • Turn keyswitch ON.
  • Operate engine at idle.

Action

Measure the fuel pump (gear pump) pressure at high idle.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.
  • Measure the fuel pump (gear pump) pressure with the engine operating at high idle and no load.
  • With the engine operating at idle, use a pressure gauge attached to the rail pressure Compuchek™ fitting on the IFSM to measure the fuel pump (gear pump) pressure.

Fuel pump (gear pump) pressure 1758 kPa [255 psi] to 2000 kPa [290 psi] at 2100 rpm?
YES | NO
No Repair | No Repair

Go to 15A

Go to 10A

Guided Step 10 - Check the air in the pressure-side fuel.

Guided Step 10A - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Possible sources of air in the pressure-side fuel are leaks in:

  • OEM supply lines
  • Fittings
  • Suction-side fuel filter head
  • Fuel tank stand-pipes

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-003 in Section 6.

Air present in the pressure-side fuel?
YES NO

Locate and repair the source of the air leak by checking all the OEM supply lines and fittings, suction-side fuel filter head, fuel tank stand pipes, ECM cooling plate, and fuel supply and return lines.

No Repair

Go to 16A

Go to 11A

Guided Step 11 - Check the fuel inlet restriction.

Guided Step 11A - Measure the fuel inlet restriction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start the engine.

Action

Measure the fuel inlet restriction.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.
  • Check the fuel inlet restriction.

Maximum without remote fuel filter: 76 mm-Hg [3 in-Hg]

Maximum with remote fuel filter: 254 mm-Hg [10 in-Hg]

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specification?
YES NO
No Repair

Replace the suction-side fuel filter or repair the cause of high inlet restriction.

Go to 12A

Go to 16A

Guided Step 12 - Check the fuel shutoff valve.

Guided Step 12A - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check for a mechanical restriction of the fuel shutoff valve.

  • Remove and inspect the fuel shutoff valve for a mechanical restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Debris present in the fuel shutoff valve or signs the fuel shutoff valve is restricting flow?
YES NO

Repair or replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 16A

Go to 13A

Guided Step 13 - Check the 1724 kPa [250 psi] fuel pressure regulator.

Guided Step 13A - Inspect the 1724 kPa [250 psi] fuel pressure regulator.

Conditions

  • Turn keyswitch OFF.

Action

Remove and inspect the 1724 kPa [250 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

Any debris that can stick the regulator open?
YES NO

Replace the regulator.

 No Repair

Go to 16A

Go to 14A

Guided Step 14 - Check the 2206 kPa [320 psi] fuel pressure regulator.

Guided Step 14A - Inspect the 2206 kPa [320 psi] fuel pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 2206 kPa [320 psi] fuel pressure regulator.

  • Disconnect the OEM drain line connection at the IFSM.
  • Install a short piece of hose and place the end of the hose in the bucket.
  • Disconnect the wiring harness from the fueling and timing actuators.
  • Turn the keyswitch ON and wait until the lift pump stops operating.
  • Crank the engine for 15 seconds and measure the fuel from the integrated fuel system module (IFSM).

More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?

YES NO

  • Remove and inspect the 2206 kPa [320 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.
  • Replace the regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 16A

Go to 15A

Guided Step 15 - Check the fuel pressure sensor for accuracy.

Guided Step 15A - Verify the accuracy of the rail fuel pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Install a pressure gauge on the rail fuel pressure Compuchek™ fitting.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the readings agree.

  • Verify the pressure gauge and INSITE™ electronic service tool reading for the rail fuel pressure sensor agree.

INSITE™ electronic service tool reading and pressure gauge reading match within 138 kPa [20 psi]?
YES NO

Repair or replace the fuel pump (gear pump). Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-016 in Section 5.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 16A

Go to 16A

Guided Step 16 - Clear the fault codes.

Guided Step 16A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 482 is inactive.

Fault Code 482 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 16B

Go to 1A

Guided Step 16B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-May-2014


FAULT CODE 483 - Rear Rail Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rear rail pressure sensor. |
 | STEP 1A. Inspect the engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 483 inactive
 | STEP 1C. Check the supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the signal voltage. | (+) 0.5 to 4.7 VDC
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness connector pins and the ECM for damage. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 483 inactive
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit in the return wire. | Less than 10 ohms
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 483 inactive and Fault Code 484 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 483 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults codes cleared

Guided Step 1 - Check the rear rail pressure sensor.

Guided Step 1A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rear rail pressure sensor from the engine harness.

Action

–

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Replace the 3-pin Metri-Pack connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the 3-pin Metri-Pack™ connector. Refer to Procedure 019-202 in Section 19.
  • Replace the rear rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 483 inactive

Fault Code 483 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

–

  • Measure the supply voltage by installing the breakout cable's supply pin A (or RED) and return pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 4.75 to 5.25 VDC

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage at the ECM from pin 35 to pin 33 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check the signal voltage.

Conditions

  • Install breakout cable, Part Number 3824774, between the engine harness connector and the rear rail pressure sensor.
  • Turn keyswitch ON.

Action

–

  • Measure the signal voltage by installing the breakout cable's signal pin C (or YELLOW) and return pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 0.5 to 4.7 VDC

Does not meet specifications.

Go to 3A

Go to 2A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness connector pins and the ECM for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 483 inactive

Fault Code 483 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the rear rail pressure sensor from the sensor harness.

Action

–

  • Measure the resistance between pin 35 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance between pin 34 in the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the rear rail pressure sensor from the sensor harness.

Action

–

  • Measure the resistance from pin 33 on the ECM sensor harness connector to pin B (or 2) on the rear rail pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the rear rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedure.
  • Refer to Procedure 019-201 in Section 19
  • Refer to Procedure 019-202 in Section 192
  • Refer to Procedure 019-205 in Section 195
  • Refer to Procedure 019-204 in Section 194.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 483 inactive and Fault Code 484 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 483 inactive

Return to the troubleshooting steps or contactal Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

–

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 inactive
STEP 2. | Check the rear rail pressure sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 484 inactive
 | STEP 2C. Check the supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 2C-1. Measure the voltage from the ECM. |
 | STEP 2D. Check the signal voltage. | (+) 0.5 to 4.7 VDC
 | STEP 2D-1. Check for a short circuit to ground. |
 | STEP 2D-2. Check for a short circuit from pin to pin. |
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness connector pins and the ECM for damage. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 484 inactive
 | STEP 3C. Check for an open circuit in the signal wire. | Less than 10 ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 484 inactive and Fault Code 483 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 484 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Using INSITE™, read the fault codes.
OK NOT OK

Fault Code 187 inactive

Fault Code 187 active.

Go to 2A

Fault Code 187

Guided Step 2 - Check the rear rail pressure sensor.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the rear rail pressure sensor from the engine harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205, or Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 484 inactive

Fault Code 484 active.

Go to 5B

Go to 2C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

–

  • Measure the supply voltage by installing the breakout cable's supply, pin A (or RED) and return, pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 4.75 to 5.25 VDC

Does not meet specifications.

Go to 2D

Go to 2C-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

–

  • Measure the voltage at the ECM from pin 35 to pin 33 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Replace the ECM. Refer to Procedure 019-031.

Go to 5A

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check the signal voltage.

Conditions

  • Disconnect the rear rail pressure sensor from the engine harness.
  • Install the breakout cable, Part Number 3824774, between the engine harness and the rear rail pressure sensor.
  • Turn keyswitch ON.

Action

–

  • Measure the signal voltage by installing the breakout cable's signal pin C (or YELLOW) and return pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 0.5 to 4.7 VDC

Does not meet specifications.

Go to 2D-1

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rear rail pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

–

  • Measure the resistance from pin 34 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 35 of the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043.

Go to 2D-2

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-2 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the rear rail pressure sensor.

Action

–

  • Measure the resistance from pin 34 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 35 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the rear rail pressure sensor. Refer to Procedure 019-115.

Replace the engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the sensor harness connector pins and the ECM for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the rear rail pressure sensor from the engine harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205, or Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 484 inactive

Fault Code 484 active.

Go to 5B

Go to 3C

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit in the signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the rear rail pressure sensor.

Action

–

  • Measure the resistance from pin 34 of the sensor harness connector to pin C (or 3) of the rear rail pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the rear rail pressure sensor. Refer to Procedure 019-115.

Repair or replace the sensor harness

  • Repair the sensor harness. Refer to Procedure 019-204.
  • Replace the sensor harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch ON.

Action

–

  • Install Part Number 3822917 as a jumper wire between pin 35 and pin 34 in the ECM sensor harness port.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 484 inactive and Fault Code 483 active

Replace the ECM. Refer to Procedure 019-031.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Using INSITE™, verify that Fault Code 484 is inactive.
OK NOT OK

Fault Code 484 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Using INSITE™, clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Inspect for Fault Code 449 or high inactive counts. | Fault Code 449 inactive
 | STEP 1A-1. Check for air in the pressure-side fuel. |
 | STEP 1A-2. Measure for drain line restriction. |
STEP 2. | Check the rear fueling actuators. |
 | STEP 2A. Inspect the rear fueling actuators. | Fault Code 485 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 485 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Inspect for Fault Code 449 or high inactive counts.

Conditions

  • Turn keyswitch ON.

Action

–

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 449 inactive

Fault Code 449 active.

Go to 1A-1

Fault Code 449

Guided Step 1A-1 - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

–

Inspect for air in the pressure-side fuel.
OK NOT OK

No air in fuel

Air in fuel. Refer to Procedure 006-003 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin No. 3666239.

Go to 1A-2

Go to 3A

Guided Step 1A-2 - Measure for drain line restriction

Conditions

  • Turn keyswitch OFF.

Action

–

Measure for drain line restriction.
OK NOT OK

Less than 4.0 in Hg

More than 4.0 in Hg. Refer to Procedure 006-012 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin No. 3666239.

Go to 2A

Go to 3A

Guided Step 2 - Check the rear fueling actuators.

Guided Step 2A - Inspect the rear fueling actuators.

Conditions

  • Turn keyswitch OFF.

Action

–

Replace the rear fueling actuators.
OK NOT OK

Fault Code 485 inactive

Reinstall the original rear fueling actuators. Refer to Procedure 019-110.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and run above 1000 rpm for 1 minute.
  • Using INSITE™, verify Fault Code 485 inactive
OK NOT OK

Fault Code 485 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Inspect for Fault Codes 396, 397, and 482 or high inactive counts. | Fault Codes 396, 397, and 482 are not active
STEP 2. | Check for air in the pressure-side fuel. |
 | STEP 2A. Inspect for air in the pressure-side fuel. | No air in fuel
STEP 3. | Check the rear fueling actuators. |
 | STEP 3A. Inspect the rear fueling actuators. | Fault Code 486 goes inactive
STEP 4. | Check the injector o-rings. |
 | STEP 4A. Inspect the bottom two injector o-rings on the rear three cylinders. | The o-rings are OK
STEP 5. | Check the fuel passages in the head. |
 | STEP 5A. Inspect the fuel passages in the rear of the head. | No leaks to the drain passage, crankcase, cylinders, or coolant system
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 486 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Inspect for Fault Codes 396, 397, and 482 or high inactive counts.

Conditions

  • Turn keyswitch ON.

Action

–

Check for active or high counts of inactive fault codes.
OK NOT OK

Fault Codes 396, 397, and 482 are not active

Fault Codes 396, 397, and 482 are active.

Go to 2A

Use Fault Codes 396, 397, and 482

Guided Step 2 - Check for air in the pressure-side fuel.

Guided Step 2A - Inspect for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

–

Check for air in the pressure-side fuel.
OK NOT OK

No air in fuel

Air in fuel. Refer to Procedure 006-003 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin No. 3666239.

Go to 3A

Go to 6A

Guided Step 3 - Check the rear fueling actuators.

Guided Step 3A - Inspect the rear fueling actuators.

Conditions

  • Turn keyswitch OFF.

Action

–

  • Refer to Procedure 019-110.
  • Check that Fault Code 486 goes inactive.
OK NOT OK

Fault Code 486 goes inactive

Reinstall the rear fueling actuator. Refer to Procedure 019-110.

Go to 6A

Go to 4A

Guided Step 4 - Check the injector o-rings.

Guided Step 4A - Inspect the bottom two injector o-rings on the rear three cylinders.

Conditions

  • Turn keyswitch OFF.

Action

–

  • Check that o-rings are in good condition.
OK NOT OK

The o-rings are OK

Replace the o-rings. Refer to Procedure 005-016 in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines Bulletin 3666239.

Go to 5A

Go to 6A

Guided Step 5 - Check the fuel passages in the head.

Guided Step 5A - Inspect the fuel passages in the rear of the head.

Conditions

  • Turn keyswitch OFF.

Action

–

Inspect the rear of the head for leaks or obstructions.
OK NOT OK

No leaks to the drain passage, crankcase, cylinders, or coolant system

Correct the problem. Use the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Start the engine and let it run above 1000 rpm for at least 1 minute.
  • Using INSITE™, verify Fault Code 486 is inactive
OK NOT OK

Fault Code 486 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

–

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and the actuator harness connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 489 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and the actuator harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connectors pins.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the OEM harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

–

  • Measure the resistance from pin 21 of the 31-pin OEM harness connector to pin A (or 1) of the OEM harness connector at the frequency input signal sending unit.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205or Refer to Procedure 019-208.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

–

  • Measure the resistance from pin 21 of the 31-pin OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

–

  • Measure the resistance from pin 21 of the 31-pin OEM harness connector to all other pins in the connector, except pin 22.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the actuator harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connectors pins.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the actuator harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if it is damaged or missing.
  • Repair the actuator harness. Refer to Procedure 019-204.
  • Replace the actuator harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 40 of the actuator harness connector to pin 21 of the 31-pin actuator harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 or Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 40 of the 50-pin actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Disconnect the actuator harness connector from the ECM.

Action

–

  • Measure the resistance from pin 40 of the 50-pin actuator harness connector to all other pins in the connector, except pin 30.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

–

  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 489 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

–

  • Erase any inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


FAULT CODE 491 - Turbocharger 2 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wiring harness. |
 | STEP 1A. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to the battery. | Less than (+) 1.5-VDC?
STEP 2. | Check the wastegate actuator. |
 | STEP 2A. Inspect the wastegate actuator connector. | Dirty or damaged pins?
 | STEP 2B. Check the actuator solenoid post for corrosion. | Corrosion found?
 | STEP 2C. Check the wastegate actuator resistance. | Resistance from 7 to 8 ohms for (+) 12-VDC solenoids and 28 to 32 ohms for (+) 24-VDC solenoids?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 491 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the wiring harness.

Guided Step 1A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 2.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the actuator harness connector from the ECM
  • Disconnect the engine harness from the wastegate actuator 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from pin 23 in the actuator harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to the battery.

Conditions

  • Turn keyswitch ON
  • Disconnect the actuator harness connector from the ECM
  • Disconnect the engine harness from the wastegate actuator 2.

Action

Check for a short circuit to the battery.

  • Measure the voltage from pin 2 (or B) on the wastegate actuator connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Less than (+) 1.5-VDC?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the wastegate actuator.

Guided Step 2A - Inspect the wastegate actuator connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the wastegate actuator 2
  • Disconnect the actuator harness connector from the ECM.

Action

Check the wastegate actuator connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the actuator connector terminal.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if is is damaged or missing.
  • Repair the actuator connector. Refer to Procedure 019-197 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the actuator solenoid post for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Check the solenoid post for corrosion.

Corrosion found on solenoid post?
YES NO

Clean the solenoid post.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator number 2 to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Resistance from 7 to 8 ohms for (+) 12-VDC solenoids and 28 to 32 for (+) 24-VDC solenoids?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the actuator solenoid.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 491 is inactive.

Fault Code 491 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Troubleshoot any remaining active fault codes.

Last Modified: 05-Jul-2012


FAULT CODE 492 - Wastegate Actuator Number 2 Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness and ECM connector pins. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Check for an open circuit. | Less than 10 ohms?
STEP 2. | Check the wastegate actuator. |
 | STEP 2A. Inspect the wastegate actuator connector. | No damage?
 | STEP 2B. Check the actuator solenoid post for corrosion. | No corrosion?
 | STEP 2C. Check the wastegate actuator resistance. | 7 to 8 ohms for (+) 12-VDC solenoids. 28 to 32 ohms for (+) 24-VDC solenoids?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 492 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness and ECM connector pins.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 23 to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 23 of the engine harness connector to ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine harness from the wastegate actuator number 2.

Action

Check for an open circuit.

  • Measure the resistance from pin 23 of the actuator harness connector to the wastegate actuator number 2 wire.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the wastegate actuator.

Guided Step 2A - Inspect the wastegate actuator connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the wastegate actuator number 2.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the wastegate actuator connector.

  • Check the wastegate actuator connector for damage.
OK NOT OK

No damage?

Repair the damage

Repair the actuator connector terminal.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the connector. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the actuator solenoid post for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator solenoid post.

  • Check the solenoid post for corrosion.
OK NOT OK

No corrosion?

Clean the solenoid post.

Go to 2C

Go to 3A

Guided Step 2C - Check the wastegate actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate actuator from the engine harness.

Action

Check the wastegate actuator resistance.

  • Measure the resistance from the wastegate actuator number 2 to engine block ground.
OK NOT OK

7 to 8 ohms for (+) 12-VDC solenoids?

28 to 32 ohms for (+) 24-VDC solenoids?

Replace the actuator solenoid

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 492 is inactive.
OK NOT OK

Fault Code 492 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2012


FAULT CODE 496 - Sensor Supply Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™test lead, Part Number 3822917 - female Deutsch™AMP™Metri-Pack™test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the failed sensor. |
 | STEP 1A. Check the camshaft engine position sensor. | Fault Code 496 active?
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | (+) 4.75 to 5.25 VDC?
 | STEP 2B-1. Check the voltage from the ECM. |
 | STEP 2C. Check for a short circuit to ground in the sensor SUPPLY wire. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the camshaft engine position sensor. |
 | STEP 3A. Check for a signal from the camshaft engine position sensor. | Signal present?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 496 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the failed sensor.

Guided Step 1A - Check the camshaft engine position sensor.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the camshaft engine position sensor.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 496 is still active.
OK NOT OK

Fault Code 496 active?

Replace the camshaft engine position sensor. Refer to Procedure 019-038 in Section 19

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the sensor harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from pin A (or 1) to pin B (or 2) on the engine harness connector side of the camshaft engine sensor.
OK NOT OK

(+) 4.75 to 5.25 VDC?

Does not meet specifications.

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the voltage from the ECM.

Conditions

  • Disconnect the camshaft engine speed sensor from the sensor harness.
  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage from the ECM.

  • Measure the voltage at the ECM from pin 11 to pin 21 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the sensor SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground in the sensor SUPPLY wire.

  • Measure the resistance from pin 11 in the sensor harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 11 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 21 in the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the camshaft engine position sensor.

Guided Step 3A - Check for a signal from the camshaft engine position sensor.

Conditions

  • Install breakout cable, Part Number 3824775, between the camshaft engine position sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for a signal from the camshaft engine position sensor.

  • Measure the voltage from the signal, pin C (or YELLOW) to the return, pin B (or BLACK) on the breakout cable, while barring the engine over.
OK NOT OK

Signal present: signal should change from positive (+) 4 to 5 VDC to positive (+) 0.5 to 2.3 VDC and back about every 60° of crankshaft rotation.

Replace camshaft engine position sensor. Refer to Procedure 019-038.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 496 is inactive.
OK NOT OK

Fault Code 496 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jun-2012


FAULT CODE 527 (INDUSTRIAL) - Switched Output A Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires?
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean?
 | STEP 1C. Check the solenoid resistance. | 7 to 8 ohms for (+) 12-VDC systems. 28 to 32 ohms for (+) 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the OEM harness to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Check the actuator harness. |
 | STEP 3A. Check the ECM and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage from the ECM. | Greater than (+) 5 VDC for 12-VDC systems? Greater than (+) 17 VDC for 24-VDC systems?
 | STEP 3C. Check for a short circuit in the solenoid SUPPLY wire to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 527 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

Check for extra wires on the solenoid post.
OK NOT OK

No extra wires?

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean?

Repair ring terminal or replace the solenoid

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

7 to 8 ohms for (+) 12-VDC systems?

28 to 32 ohms for (+) 24-VDC systems?

Replace the solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.

Action

Check the OEM harness and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, OEM harness, or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit in the OEM harness to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit in the OEM harness to ground.

  • Measure the resistance from the solenoid supply wire to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between pin 27 in the OEM harness 31-pin connector and all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Check the ECM and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the ECM and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage from the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Connect the male end of jumper wire, Part Number 3822758, to pin 14 of the ECM actuator connector.
  • Attach the clip end of the jumper wire, Part Number 3822758, to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.
  • Dual output A supply voltage is turned ON.

Action

Check the supply voltage from the ECM.

  • Measure the voltage from pin 14 in the actuator harness connector ECM port to engine block ground.
OK NOT OK

Greater than (+) 5 VDC for 12-VDC systems?

Greater than (+) 17 VDC for 24-VDC systems?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the solenoid SUPPLY wire to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness at the 6-pin connector.

Action

Check for a short circuit in the solenoid SUPPLY wire to ground.

  • Measure the resistance from pin 14 in the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 6-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 14 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 527 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jun-2012


FAULT CODE 528 (INDUSTRIAL) - Switched Output B Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires?
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean?
 | STEP 1C. Check the solenoid resistance. | 7 to 8 ohms for (+) 12-VDC systems? 28 to 32 ohms for (+) 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the OEM harness to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Check the actuator harness. |
 | STEP 3A. Check the ECM and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage at the ECM. | Greater than (+) 5 VDC for 12-VDC systems? Greater than (+) 7 VDC for 24-VDC systems?
 | STEP 3C. Check for a short circuit in the solenoid SUPPLY wire to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 528 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.
OK NOT OK

No extra wires?

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean?

Repair ring terminal or replace the solenoid

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

7 to 8 ohms for (+) 12-VDC systems?

28 to 32 ohms for (+) 24-VDC systems?

Replace the solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.

Action

Check the actuator harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, OEM harness, or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit in the OEM harness to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit in the OEM harness to ground.

  • Measure the resistance from the solenoid SUPPLY wire to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM harness connector from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 8 in the 31-pin OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Check the ECM and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the ECM and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Connect the male end of jumper wire, Part Number 3822758, to pin 45 of the ECM actuator connector.
  • Attach the clip end of the jumper wire, Part Number 3822758, to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.
  • Dual output B supply voltage is turned ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from pin 45 on the ECM actuator port to engine block ground.
OK NOT OK

Greater than (+) 5 VDC for (+) 12-VDC systems?

Greater than (+) 7 VDC for (+) 24-VDC systems?

Replace the ECM. Refer to Procedure 019-031 in Section 19

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the solenoid SUPPLY wire to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness at the 31-pin OEM connector.

Action

Check for a short circuit in the solenoid SUPPLY wire to ground.

  • Measure the resistance from pin 45 in the actuator harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 31-pin OEM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 45 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 528 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jun-2012


FAULT CODE 529 (INDUSTRIAL) - Switched Output B Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires?
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean?
 | STEP 1C. Check the solenoid resistance. | 7 to 8 ohms for (+) 12-VDC systems? 28 to 32 ohms for (+) 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the actuator harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the OEM harness to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the actuator harness. |
 | STEP 3A. Check the ECM and actuator harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage at the ECM. | Greater than (+) 5 VDC for 12-VDC systems? Greater than (+) 7 VDC for 24-VDC systems?
 | STEP 3C. Check for a short circuit in the solenoid SUPPLY wire to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

Check for extra wires on the solenoid post.
OK NOT OK

No extra wires?

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean?

Repair ring terminal or replace the solenoid

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Refer to the OEM troubleshooting and repair manual for procedure.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

7 to 8 ohms for (+) 12-VDC systems?

28 to 32 ohms for (+) 24-VDC systems?

Replace the solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.

Action

Check the actuator and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, OEM harness, or OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit in the OEM harness to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit in the OEM harness to ground.

  • Measure the resistance from the solenoid supply wire to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between pin 8 in the OEM harness 31-pin connector and all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Check the ECM and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the ECM and actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.
  • Connect the male end of jumper wire, Part Number 3822758, to pin 45 of the ECM actuator connector.
  • Connect the clip end of the jumper wire, Part Number 3822758, to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from pin 45 in the ECM actuator port to engine block ground.
OK NOT OK

Greater than (+) 5 VDC for (+) 12-VDC systems?

Greater than (+) 7 VDC for (+) 24-VDC systems?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the solenoid SUPPLY wire to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the OEM harness from the actuator harness at the 31-pin connector.

Action

Check for a short circuit in the solenoid SUPPLY wire to ground.

  • Measure the resistance from pin 45 to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 of the actuator harness connector to all other wires in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 529 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jun-2012


FAULT CODE 536 - Autoshift Low Gear Actuator (Lockout Solenoid) Circuit

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the autoshift low gear actuator (lockout solenoid). |
 | STEP 1A. Inspect the lockout solenoid and solenoid harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the lockout solenoid. | 14 to 34 ohms?
 | STEP 1C. Check for a short circuit to ground in the lockout solenoid. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin in the lockout solenoid. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2B-1. Inspect the 31-pin Deutsch connector pins. |
 | STEP 2B-2. Check for a short circuit in the OEM harness. |
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C-1. Check for a short circuit to ground in the OEM harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 536 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the autoshift low gear actuator (lockout solenoid).

Guided Step 1A - Inspect the lockout solenoid and solenoid harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lockout solenoid from the solenoid harness connector pins.

Action

Inspect the lockout solenoid and solenoid harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or lockout solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the lockout solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the lockout solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lockout solenoid from the solenoid harness connector pins.

Action

Measure the resistance of the lockout solenoid.

  • Measure the resistance between solenoid connector pins B (or 2) and A (or 1).
OK NOT OK

14 to 34 ohms?

Replace the lockout solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground in the lockout solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lockout solenoid from the solenoid harness.

Action

Check for a short circuit to ground in the lockout solenoid.

  • Measure the resistance from pin A (or 1) of the lockout solenoid to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the lockout solenoid. Refer to the OEM troubleshooting and repair manual for repair procedure.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin in the lockout solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lockout solenoid harness from the actuator harness.

Action

Check for a short circuit from pin to pin in the lockout solenoid.

  • Measure the resistance from pin A (or 1) to pin C (or 3) of the lockout solenoid.
OK NOT OK

Greater than 100k ohms?

Replace the lockout solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the lockout solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Does not meet specifications.

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Inspect the 31-pin Deutsch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.

Action

Inspect the 31-pin Deutsch connector pins that connect the actuator harness to the OEM harness for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the 31-pin Deutsch connector. Refer to Procedure 019-208 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the OEM harness from the lockout solenoid.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin 9 on the OEM harness side of the 31-pin connector to all other pins in the 31-pin connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the lockout solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 35 in the actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-1

Go to 3A

Guided Step 2C-1 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the OEM harness from the lockout solenoid.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 8 on the OEM harness side of the 31-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 536 is inactive.
OK NOT OK

Fault Code 536 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jun-2012


FAULT CODE 537 - Autoshift High Gear Actuator (Shift Solenoid) Circuit

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the autoshift high gear actuator (shift solenoid). |
 | STEP 1A. Inspect the shift solenoid and solenoid harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the shift solenoid. | 14 to 34 ohms?
 | STEP 1C. Check for a short circuit to ground in the shift solenoid. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin in the shift solenoid. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit pin to pin. | Greater than 100k ohms?
 | STEP ?2B-1. Inspect the 31-pin Deutsch connector pins. |
 | STEP 2B-2. Check for a short circuit in the OEM harness. |
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C-1. Check for a short circuit to ground in the OEM harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 537 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the autoshift high gear actuator (shift solenoid).

Guided Step 1A - Inspect the shift solenoid and solenoid harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the shift solenoid from the solenoid harness connector.

Action

Inspect the shift solenoid and solenoid harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or shift solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the shift solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the shift solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the shift solenoid from the solenoid harness connector.

Action

Measure the resistance of the shift solenoid.

  • Measure the resistance between solenoid connector pins B (or 2) and C (or 3).
OK NOT OK

14 to 34 ohms?

Replace the shift solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground in the shift solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the shift solenoid from the solenoid harness.

Action

Check for a short circuit to ground in the shift solenoid.

  • Measure the resistance from pin C (or 3) of the shift solenoid to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the shift solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin in the shift solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the shift solenoid harness from the actuator harness.

Action

Check for a short circuit from pin to pin in the shift solenoid.

  • Measure the resistance from pins A (or 1) to C (or 3) of the shift solenoid.
OK NOT OK

Greater than 100k ohms?

Replace the shift solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the shift solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Does not meet specifications

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Inspect the 31-pin Deutsch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.

Action

Inspect the 31-pin Deutsch connector pins which connect the actuator harness to the OEM harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the 31-pin Deutsch connector. Refer to Procedure 019-208 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the OEM harness from the shift solenoid.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin 8 on the OEM harness side of the 31-pin connector to all other pins in the 31-pin connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the shift solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 45 in the actuator harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-1

Go to 3A

Guided Step 2C-1 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the OEM harness from the shift solenoid.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 8 on the OEM harness side of the 31-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 537 is inactive.
OK NOT OK

Fault Code 537 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jun-2012


FAULT CODE 538 - Autoshift Neutral Actuator

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the autoshift neutral actuator. |
 | STEP 1A. Inspect the neutral actuator and solenoid harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the neutral actuator. | 14 to 34 ohms?
 | STEP 1C. Check for a short circuit to ground in the neutral actuator. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin in the neutral actuator. | Greater than 100k ohms?
STEP 2. | Check the actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the 31-pin Deutsch™ connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 538 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the autoshift neutral actuator.

Guided Step 1A - Inspect the neutral actuator and solenoid harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral actuator from the solenoid harness connector pins.

Action

Inspect the neutral actuator and solenoid harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or neutral actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the neutral actuator. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the neutral actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral actuator from the solenoid harness connector pins.

Action

Measure the resistance of the neutral actuator.

  • Measure the resistance across the solenoid connector pins.
OK NOT OK

14 to 34 ohms?

Replace the neutral actuator. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to ground in the neutral actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral actuator from the solenoid harness.

Action

Check for a short circuit to ground in the neutral actuator.

  • Measure the resistance from pin C (or 3) of the neutral actuator to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the shift solenoid. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin in the neutral actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral actuator harness from the actuator harness.

Action

Check for a short circuit from pin to pin in the neutral actuator.

  • Measure the resistance from neutral actuator SUPPLY pin to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the neutral actuator. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.

Action

Check for a short circuit between the pins.

  • Measure the resistance from pin 34 to all other pins in the actuator harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 34 in the actuator harness to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the 31-pin Deutsch™ connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.

Action

Inspect the 31-pin Deutsch™ connector pins that connect the actuator harness to the OEM harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the 31-pin Deutsch connector. Refer to Procedure 019-208 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the OEM harness from the shift solenoid.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure the resistance from pin 10 on the OEM harness side of the 31-pin connector to all other pins in the 31-pin connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch connector.
  • Disconnect the OEM harness from the shift solenoid.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 10 on the OEM harness side of the 31-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 538 is inactive.
OK NOT OK

Fault Code 538 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jun-2012


FAULT CODE 541 - ICON™ Starter Relay/Interlock Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Perform the starter relay/interlock test. |
 | STEP 1A. Perform the starter relay/interlock test. | Starter relay engages starter?
STEP 2. | Check the starter relay coil. |
 | STEP 2A. Check the continuity of the starter relay coil. | Greater than 6 ohms and less than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the ICON™ shorting plug. |
 | STEP 3D. Check for a short circuit to battery voltage. | Less than (+) 1.5-VDC?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check the OEM engine harness. |
 | STEP 4A. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to battery voltage. | Less than (+) 1.5-VDC?
 | STEP 4D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 5. | Check the ICON™ interlock switches. |
 | STEP 5A. Check the neutral position switch for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5B. Check the hood tilt switch for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5C. Check parking brake switch for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5D. Check the optional OEM interlock switches for a short circuit to ground. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 541 is inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Perform the starter relay/interlock test.

Guided Step 1A - Perform the starter relay/interlock test.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE electronic service tool to perform the starter relay/interlock test.

  • Use INSITE™ electronic service tool to perform the starter relay/interlock test.
OK NOT OK

Starter relay engages starter?

Starter relay does not engage starter.

Go to 4A

Go to 2A

Guided Step 2 - Check the starter relay coil.

Guided Step 2A - Check the continuity of the starter relay coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the starter relay.

Action

Check the continuity of the starter relay coil.

  • Measure the resistance from the coil's positive (+) pin to the negative (-) pin.
OK NOT OK

Greater than 6 ohms and less than 100k ohms?

Replace the ICON™ starter relay. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin connector from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair the engine harness or OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin connector from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.
  • Check that the ICON™ shorting plug is connected to the 6-pin engine harness connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 14 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 46 of the actuator harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin connector from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.
  • Check that the ICON™ shorting plug is connected to the 6-pin engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 of the 31-pin OEM connector, engine harness side, to pin 14 of the actuator harness connector at the ECM.
OK NOT OK

Less than 10 ohms?

Does not meet specifications.

Go to 3D

Go to 3C-1

Guided Step 3C-1 - Check for an open circuit in the ICON™ shorting plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ shorting plug from the 6-pin engine harness connector.

Action

Check for an open circuit in the ICON™ shorting plug.

  • Measure the resistance from pin 4 to pin 5 of the ICON™ shorting plug.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 orRefer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Does not meet specifications

  • Replace the shorting plug. Use the OEM troubleshooting and repair manual.

Go to 6A

Go to 6A

Guided Step 3D - Check for a short circuit to battery voltage.

Conditions

  • Disconnect the 31-pin connector from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.
  • Check that the ICON™ shorting plug is connected to the 6-pin engine harness connector.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery.

  • Measure the voltage from pin 14 of the actuator harness connector at the ECM to engine block ground.
  • Measure the voltage from pin 46 of the actuator harness connector at the ECM to engine block ground.
OK NOT OK

Less than (+) 1.5-VDC?

Does not meet specifications

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 31-pin OEM connector.
  • Check that the ICON™ shorting plug is connected to the 6-pin engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 14 on the actuator harness connector to ground.
  • Measure the resistance from pin 46 on the actuator harness connector to ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the OEM engine harness.

Guided Step 4A - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin connector from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 33 of the OEM connector at the ECM to all other pins in the connector.
OK NOT OK

Greater than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin connector from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the ICON™ starter relay connector from the OEM harness.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 27 of the OEM 31-pin connector, OEM side, to the ICON™ starter relay pin, OEM 31-pin connector side of the relay.
  • Measure the resistance from pin 33 of the OEM ECM connector, OEM side, to the ICON™ starter relay pin, OEM harness connector at the ECM side of the relay.
OK NOT OK

Less than 10 ohms?

Does not meet specifications. Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit to battery voltage.

Conditions

  • Disconnect the 31-pin connector from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the ICON™ starter relay connector from the OEM harness.
  • Check that the neutral position switch, hood tilt switch, parking brake switch, and any other OEM-optional interlock switches are closed.
  • Turn keyswitch ON.

Action

Check for a short circuit to the battery.

  • Measure the voltage from pin 33 of the OEM connector at the ECM, to engine block ground.
  • Measure the voltage from pin 27 of the OEM 31-pin connector, OEM harness side, to engine block ground.
  • Measure the voltage from pin 20 of the OEM 31-pin connector, OEM harness side, to engine block ground.
OK NOT OK

Less than (+) 1.5-VDC?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit to ground.

Conditions

  • Disconnect the 31-pin OEM connector.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the ICON™ starter relay connector from the OEM harness.
  • Check that the neutral position switch, hood tilt switch, parking brake switch, and any other OEM-optional interlock switches are closed.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 20 of the 31-pin OEM connector, OEM harness side, to the engine block ground.
  • Measure the resistance from pin 33 of the OEM harness connector, OEM harness side, to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Does not meet specifications

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 5A

Go to 6A

Guided Step 5 - Check the ICON™ interlock switches.

Guided Step 5A - Check the neutral position switch for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the neutral position switch from the OEM harness.

Action

Check the neutral position switch for a short circuit to ground.

  • Measure the resistance from neutral position switch connector pin A (or 1), switch side of connector, to engine block ground.
  • Measure the resistance from neutral position switch connector pin B (or 2), switch side of connector, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the neutral position switch. Refer to the OEM troubleshooting and repair manual.

Go to 5B

Go to 6A

Guided Step 5B - Check the hood tilt switch for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the hood tilt switch from the OEM harness.

Action

Check the hood tilt switch for a short circuit to ground.

  • Measure the resistance from hood tilt switch connector pin A (or 1), switch side of connector, to engine block ground.
  • Measure the resistance from hood tilt switch connector pin B (or 2), switch side of connector, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the hood tilt switch. Refer to the OEM troubleshooting and repair manual.

Go to 5C

Go to 6A

Guided Step 5C - Check the parking brake switch for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the parking brake switch from the OEM harness.

Action

Check the parking brake switch for a short circuit to ground.

  • Measure the resistance from parking brake switch connector pin A (or 1), switch side of connector, to engine block ground.
  • Measure the resistance from parking brake switch connector pin B (or 2), switch side of connector, to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the parking brake switch. Refer to the OEM troubleshooting and repair manual.

Go to 5D

Go to 6A

Guided Step 5D - Check the optional OEM interlock switches for a short circuit to ground.

Conditions

  • Disconnect any optional OEM interlock switches from the OEM harness.
  • Turn the keyswitch OFF.

Action

Check the optional OEM interlock switches for a short circuit to ground.

  • Measure the resistance from OEM optional interlock switch connector pin A (or 1) to engine block ground.
  • Measure the resistance from OEM optional interlock switch connector pin B (or 2) to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the OEM optional interlock switch. Refer to the OEM troubleshooting and repair manual.

6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one 1 minute.
  • Verify that Fault Code 541 is inactive.
OK NOT OK

Fault Code 541 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Jul-2012


FAULT CODE 544 - Top 2 Transmission Circuit - Mechanical System Failure

Associated Procedures

Cautions and Warnings

WARNING

The solenoid harness connector pins receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the solenoid harness connector pins when the engine is operating.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 536 and 537 inactive?
STEP 2. | Check the lockout solenoid. |
 | STEP 2A. Perform the lockout solenoid click test. | Lockout solenoid clicks?
 | STEP 2B. Check for an open circuit. | (+) 12-VDC?
 | STEP 2C. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2D. Inspect the 31-pin Deutsch™ connector pins. | Dirty or damaged pins?
 | STEP 2E. Read the fault codes. | Fault Code 544 inactive?
 | STEP 2F. Check the resistance of the actuator harness. | Less than 10 ohms?
 | STEP 2G. Check the resistance of the OEM harness. | Less than 10 ohms?
STEP 3. | Check the shift solenoid. |
 | STEP 3A. Perform the shift solenoid click test. | Shift solenoid clicks?
 | STEP 3B. Check for an open circuit. | (+) 12-VDC?
 | STEP 3C. Inspect the actuator harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the resistance of the actuator harness. | Less than 10 ohms?
 | STEP 3E. Check the resistance of the OEM harness. | Less than 10 ohms?
STEP 4. | Check the transmission. |
 | STEP 4A. Inspect the transmission. | Transmission functions properly?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 544 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool to read the fault codes.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tools to read the fault codes.
OK NOT OK

Fault Codes 536 and 537 inactive?

Possibility of short circuit in Top 2 solenoid circuit.

Go to 2A

Fault Codes 536 and 537

Guided Step 2 - Check the lockout solenoid.

Guided Step 2A - Perform the lockout solenoid click test.

Conditions

  • Connect all components.
  • Install INSITE™ electronic service tool to perform the click test.
  • Install INLINE II™ datalink adapter.

Action

Perform the lockout solenoid click test.

  • Use the INSITE™ electronic service tool user's manual for click test procedure.
OK NOT OK

Lockout solenoid clicks?

Lockout solenoid does not click.

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Disconnect the OEM connector from the lockout solenoid.
  • Install INSITE™ electronic service tool to perform the click test.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure for (+) 12-VDC at the OEM connector while performing the click test.
  • Use the INSITE™ electronic service tool user's manual for the click test procedure.
OK NOT OK

(+) 12-VDC?

  • Replace the lockout solenoid. Refer to the OEM troubleshooting and repair manual.

Above or below (+) 12-VDC?

Go to 5A

Go to 2C

Guided Step 2C - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Inspect the 31-pin Deutsch™ connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.

Action

Inspect the 31-pin Deutsch™ connector pins which connect the actuator harness to the OEM harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the 31-pin Deutsch™ connector.

  • Repair the 31-pin Deutsch™ connector. Refer to Procedure 019-208 in Section 19.
  • Replace the 31-pin Deutsch™ connector. Refer to the OEM troubleshooting and repair manual.

Go to 2E

Go to 5A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 544 is inactive.
OK NOT OK

Fault Code 544 inactive?

Fault Code 544 active.

Go to 5B

Go to 2F

Guided Step 2F - Check the resistance of the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 45 of the actuator harness connector to pin 8 of the 31-pin Deutsch connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2G

Go to 5A

Guided Step 2G - Check the resistance of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness connector from the lockout solenoid.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 8 of the OEM harness side of the 31-pin connector to pin A (or 1) of the lockout solenoid.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Sectio 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the shift solenoid.

Guided Step 3A - Perform the shift solenoid click test.

Conditions

  • Install INSITE™ electronic service tool.
  • Connect all components.
  • Turn keyswitch ON.

Action

Perform the shift solenoid click test.

  • Use INSITE™ electronic service tool to perform the click test.
  • Use INSITE™ electronic service tool user's manual for procedure.
OK NOT OK

Shift solenoid clicks?

Shift solenoid does not click.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Install INSITE™ electronic service tool.
  • Disconnect the OEM connector from the shift solenoid.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure for (+) 12-VDC at the OEM connector while performing the click test.
OK NOT OK

(+)-12 VDC?

  • Replace the shift solenoid. Refer to the OEM troubleshooting and repair manual.

Above or below (+) 12-VDC

Go to 5A

Go to 3C

Guided Step 3C - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the resistance of the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the actuator harness.

  • Measure the resistance from pin 45 of the actuator harness to pin 8 in the 31-pin Deutsch™ connector.
  • Measure the resistance from pin 35 of the actuator harness to pin 9 in the 31-pin Deutsch™ connector.
  • Measure the resistance from pin 34 of the actuator harness to pin 10 in the 31-pin Deutsch™ connector.
  • Measure the resistance from pin 43 of the actuator harness to pin 11 in the 31-pin Deutsch™ connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check the resistance of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the OEM harness at the 31-pin Deutsch™ connector.
  • Disconnect the OEM harness from the autoshift transmission solenoid connectors.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 10 of the OEM harness side of the 31-pin connector to pin C (or 3) of the shift solenoid connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 5A

Go to 5A

Guided Step 4 - Check the transmission.

Guided Step 4A - Inspect the transmission.

Conditions

  • Connect all the components.

Action

Inspect the transmission.

Inspect the transmission.
OK NOT OK

Transmission functions properly?

Refer to the transmission OEM troubleshooting and repair manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™ electronic service tool to verify Fault Code 544 is inactive.
OK NOT OK

Fault Code 544 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Jul-2012


FAULT CODE 546 - Fuel Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pressure sensor. |
 | STEP 1A. Inspect the sensor harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 546 inactive?
 | STEP 1C. Check the supply voltage. | (+) 4.75 to 5.25 VDC?
 | STEP 1C-1. Check the voltage from the ECM. |
 | STEP 1D. Check the signal voltage. | (+) 0.4 to 4.5 VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connector pins for damage. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 546 inactive?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the RETURN wire. | Less than 10 ohms?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 546 inactive and Fault Code 547 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 546 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel pressure sensor.

Guided Step 1A - Inspect the sensor harness and sensor connector pins.

Conditions

  • Disconnect the fuel pressure sensor from the sensor harness.
  • Turn keyswitch ON.

Action

Inspect the sensor harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Replace the sensor connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the sensor connector. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 546 inactive?

Fault Code 546 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824775, between the fuel pressure sensor and the harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage at SUPPLY, pin A (or RED) and RETURN, pin B (or BLACK) connectors with the multimeter.
OK NOT OK

(+) 4.75 to 5.25 VDC?

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Connect test lead, Part Number 3822917, to ECM sensor port pins 27 and 30.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage at the ECM from pin 27 to pin 30 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25 VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check the signal voltage.

Conditions

  • Turn keyswitch ON.
  • Install breakout cable, Part Number 3824775, between the fuel pressure sensor and the engine harness.

Action

Check the signal voltage.

  • Measure the signal voltage by installing the breakout cable's SIGNAL, pin C (or YELLOW) and RETURN, pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 0.4 to 4.5 VDC?

Does not meet specifications.

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connector pins for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 546 inactive?

Fault Code 546 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between pin 29 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 30 of the sensor harness connector to pin B on the engine harness side of the fuel pressure sensor connector.
OK NOT OK

Less than 10 ohms?

  • Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 546 inactive and Fault Code 547 active?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 546 is inactive.
OK NOT OK

Fault Code 546 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jun-2017


FAULT CODE 547 - Fuel Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 not active?
STEP 2. | Check the fuel pressure sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 547 inactive?
 | STEP 2C. Check the supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the voltage from the ECM. |
 | STEP 2D. Check the signal voltage. | (+) 0.4 to 4.5-VDC?
 | STEP 2D-1. Check for a short circuit to ground. |
 | STEP 2D-2. Check for a short circuit from pin-to-pin. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 547 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 547 inactive and Fault Code 546 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 547 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.
OK NOT OK

Fault Code 352 not active?

Fault Code 352 active

Go to 2A

Fault Code 352

Guided Step 2 - Check the fuel pressure sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Replace the sensor connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the sensor connector. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 547 inactive?

Fault Code 547 active

Go to 5B

Go to 2C

Guided Step 2C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824775, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage at supply, pin A (or RED) and return, pin B (or BLACK) connectors with the multimeter.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Does not meet specifications

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage from the ECM.

  • Measure the voltage at the ECM from pin 27 to pin 30 of the ECM sensor port.
OK NOT OK

(+) 4.75 to 5.25-VDC?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Check the signal voltage.

Conditions

  • Install breakout cable, Part Number 3824775, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the signal voltage by installing the break out cable's signal, pin C (or YELLOW) and return, pin B (or BLACK) into the multimeter.
OK NOT OK

(+) 0.4 to 4.5-VDC?

Does not meet specifications

Go to 2D-1

Go to 3A

Guided Step 2D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 29 of the sensor harness connector to chassis ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 27 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 29 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 30 of the sensor harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

  • Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 547 inactive?

Fault Code 547 active

Go to 5B

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin 27 of the sensor harness connector to pin A (or 1) on the engine harness side of the fuel pressure sensor connector.
  • Measure the resistance from pin 29 of the sensor harness connector to pin C (or 3) on the engine harness side of the fuel pressure sensor connector.
  • Measure the resistance from pin 30 of the sensor harness connector to pin B (or 2) on the engine harness side of the fuel pressure sensor connector.
OK NOT OK

Less than 10 ohms?

Correct the pin to pin wiring or open circuit

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Install a jumper wire, Part Number 3822917, between pin 27 and 29 at the ECM sensor port.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 546 active and Fault Code 547 inactive?

Fault Code 547 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 547 is inactive.
OK NOT OK

Fault Code 547 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location, if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ to clear all inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Jul-2012


FAULT CODE 551 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead and Part Number 3824910 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Check the integrated sensor switch connector for lubricant. | No lubricant?
 | STEP 1B. Inspect the OEM harness and integrated sensor switch connector pins. | Dirty or damaged pins?
 | STEP 1C. Measure off-idle and idle resistance value. | Less than 125 ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check the idle validation switch SIGNAL and SUPPLY pins. | (+) 3.80 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Check the integrated sensor switch connector for lubricant.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch connector from the accelerator pedal.

Action

Check the integrated sensor switch connector for lubricant.

Check the integrated sensor switch connector for lubricant.
OK NOT OK

No lubricant?

Contact the OEM for technical support.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the OEM harness and integrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.

Action

Inspect the OEM harness and ISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the integrated sensor switch or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the integrated sensor switch. Refer to the OEM troubleshooting and repair manual.
  • Replace the switch connector. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Measure off-idle and idle resistance value.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.

Action

Measure off-idle and idle resistance value.

  • Measure the resistance from the RETURN wire pin to the off-idle SIGNAL pin on the switch side of the idle validation switch connector after slowly actuating the pedal past the on-idle zone until the pedal is fully depressed.
  • Measure the resistance from the RETURN wire pin to the idle SIGNAL pin on the switch side of the idle validation switch connector with the accelerator pedal in the released (idle) position.

There is a switch transition state between on-idle and off-idle when you can expect higher resistance values. Be sure not to reject pedals due to these transition state values. The ECM will not log a fault during these transition states.

OK NOT OK

Less than 125 ohms?

Replace the integrated sensor switch. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.

Action

Check for a short circuit from pin-to-pin.

  • With the accelerator pedal released, measure the resistance from the off-idle pin to the on-idle pin at the switch side of the connector.
  • With the accelerator pedal released, measure the resistance from the off-idle pin to the switch common return at the switch side of the connector.
  • With the accelerator pedal depressed, measure the resistance from the on-idle pin to the switch common RETURN pin at the switch side of the connector.

Connect a mating connector with short lead extensions to the idle validation switch connector. This will allow the electrical leads of the idle validation switch to be softly flexed to check for damaged or partially broken wire strands under the insulation.

OK NOT OK

Greater than 100k ohms?

Replace the integrated sensor switch. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, OEM bulkhead connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Repair the OEM harness bulkhead connector. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • All cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins of the OEM harness connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect integrated sensor switch from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the resistance from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the idle validation switch SIGNAL and SUPPLY pins.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Connect a jumper wire, Part Number 3822917, from pin 3 of the ECM OEM port to the throttle supply at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 13 of the ECM OEM port to the throttle return at the accelerator pedal.
  • Turn keyswitch ON.

Action

Check idle validation switch SIGNAL and SUPPLY pins.

  • Measure the voltage from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the voltage from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

(+) 3.80 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal four to five times.
  • Turn the keyswitch OFF for 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.
OK NOT OK

Fault Code 551 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Jun-2012


FAULT CODE 551 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead and Part Number 3824910 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the harness and idle validation switch connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check idle validation switch SIGNAL and SUPPLY pins. | (+) 3.80 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the harness and idle validation switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the harness and idle validation switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins

Repair or replace the idle validation switch or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the idle validation switch if the connector pins are damaged. Use the OEM troubleshooting and repair manual.
  • Replace the switch connector if damaged. Refer to the OEM troubleshooting and repair manual.
  • Install the appropriate connector seal if it is damaged or missing. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin-to-pin.

  • With the accelerator pedal released, measure the resistance from the off-idle pin to the on-idle pin at the switch side of the connector.
  • With the accelerator pedal released, measure the resistance from the off-idle pin to the switch common return at the switch side of the connector.
  • With the accelerator pedal depressed, measure the resistance from the on-idle pin to the switch common return pin at the switch side of the connector.

Connect a mating connector with short lead extensions to the idle validation switch connector. This will allow the electrical leads of the idle validation switch to be softly flexed to check for damaged or partially broken wire strands under the insulation.

OK NOT OK

Greater than 100k ohms?

Replace the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins

Repair or replace the OEM harness, OEM bulkhead connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Repair the OEM bulkhead connector. Refer to Procedure 019-208 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.
  • Turn cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the AC pressure switch.
  • Diagnostic switch should not be in the diagnostic mode.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the idle validation switch from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the resistance from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check idle validation switch SIGNAL and SUPPLY pins.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Connect a jumper wire, Part Number 3822917, from pin 3 of the ECM OEM port to throttle supply at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 13 of the ECM OEM port to throttle return at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 10 of the ECM OEM port to switch common ground at the accelerator pedal.
  • Turn keyswitch ON.

Action

Check the idle validation switch SIGNAL and SUPPLY pins at the ECM.

  • Measure the voltage from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the voltage from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

(+) 3.80 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch OFF for 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.
OK NOT OK

Fault Code 551 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-Jun-2012


FAULT CODE 551 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Vehicle movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead and Part Number 3824892 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the OEM harness and solid-state sensor switch connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the idle resistance value. | Correct resistance value?
 | STEP 1C. Check for proper idle validation switch signal. | Correct voltage reading?
 | STEP 1C-1. Check the voltage at the sensor. |
 | STEP 1C-2. Check the voltage at the ECM. |
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check the idle validation switch SIGNAL and SUPPLY pins. | (+) 3.80 to 5.25-VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the OEM harness and solid-state sensor switch connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solid-state sensor switch.

Action

Inspect the OEM harness and the solid-state sensor switch connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the solid-state sensor switch or the OEM harness, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to the OEM troubleshooting and repair manual.
  • Replace the solid-state sensor switch. Refer to the OEM troubleshooting and repair manual.
  • Replace the switch connector. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the idle resistance value.

Conditions

  • Turn keyswitch OFF.
  • Install the breakout cable, Part Number 3824892, to the solid-state sensor switch.
  • Do not connect the breakout cable to the OEM harness.

Action

Measure the idle resistance value.

  • With the accelerator pedal released (on-idle), measure the resistance from pin 3 (accelerator position sensor signal) to pin 4 (accelerator position sensor return) on the breakout cable.

Resistance value should be the same as the idle resistance value stamped on the solid-state sensor switch cover, ±20 ohms.
OK NOT OK

Correct resistance value

Replace the solid-state sensor switch. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check for proper idle validation switch signal.

Conditions

  • Connect breakout cable, Part Number 3824892, between the OEM harness and the solid-state sensor switch.
  • Connect the OEM harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check for proper idle validation switch signal.

  • Measure the voltage from pin 1 (idle validation switch return) to pin 2 (idle validation switch off-idle) on the breakout cable with the accelerator pedal depressed and released.
  • Measure the resistance from pin 1 (idle validation switch return) to pin 6 (idle validation switch on-idle) on the breakout cable with the accelerator pedal released and depressed.
OK NOT OK

Correct voltage reading

Pedal released: Pin 1 to pin 2 > (+) 3.8-VDC. Pin 1 to pin 6 < (+) 0.8-VDC.

Pedal depressed: Pin 1 to pin 6 > (+) 3.8-VDC. Pin 1 to pin 2 < (+) 0.8-VDC.

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the voltage at the sensor.

Conditions

  • Connect the breakout cable, Part Number 3824892, to the OEM solid-state sensor switch harness.
  • Do not connect the solid-state sensor switch on accelerator pedal to the breakout cable.
  • Connect the OEM harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check for the proper solid-state sensor switch signal.

  • Measure the voltage from pin 1 (idle validation switch) return to pin 2 (idle validation switch off-idle) on the breakout cable with the accelerator pedal depressed and released.
  • Measure the voltage from pin 1 (idle validation switch) return to pin 6 (idle validation switch idle) on the breakout cable with the accelerator pedal released and depressed.
OK NOT OK

Meets specifications

Replace the solid-state sensor switch

Correct voltage reading

Pedal released: Pin 1 to pin 2 > (+) 3.8-VDC. Pin 1 to pin 6 < (+) 0.8-VDC.

Pedal depressed: Pin 1 to pin 6 > (+) 3.8-VDC. Pin 1 to pin 2 < (+) 0.8-VDC.

Does not meet specifications.

Go to 4A

Go to 1C-2

Guided Step 1C-2 - Check the voltage at the ECM.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Connect a jumper wire, Part Number 3822917, between pin 18 of the ECM OEM port and pin 18 of the ECM OEM harness connector.
  • Connect a jumper wire, Part Number 3822917, between pin 10 of the ECM OEM port and pin 10 of the ECM OEM harness connector.
  • Turn keyswitch ON.

Action

Check the idle validation switch output from the ECM for proper voltage.

  • Measure the voltage from pin 6 of the OEM harness connector to pin 10.
  • Measure the voltage from pin 9 of the OEM harness connector to pin 10.
OK NOT OK

(+) 3.80 to 5.25-VDC

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Connect breakout cable, Part Number 3824892, to solid-state sensor switch.
  • Do not connect the breakout cable to the OEM harness.
  • Connect multimeter to breakout cable.
  • Accelerator pedal released.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 2 (off-idle) to pin 6 (idle validation switch on-idle) on the breakout cable.
OK NOT OK

Greater than 100k ohms?

Replace the solid-state sensor switch. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness, OEM bulkhead connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM connector. Refer to Procedure 019-204 in Section 19.
  • Repair the bulkhead connector. Refer to Procedure 019-208 in Section 19.
  • Replace the bulkhead connector. Refer to the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the breakout cable from the solid-state sensor switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 at OEM harness connector at ECM to pin 2 (or D) [idle validation switch off-idle] of the breakout cable.
  • Measure the resistance from pin 13 at OEM harness connector at ECM to pin 6 (or E) [idle validation switch on-idle] of the breakout cable.
  • Measure the resistance from pin 10 at OEM harness connector at ECM to pin 1 (or F) [idle validation switch return] of the breakout cable.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the breakout cable from the solid-state sensor switch.
  • Turn cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness connector to all other pins of the OEM harness connector.
  • Measure the resistance from pin 13 of the OEM harness connector to all other pins of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect solid-state sensor switch from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the resistance from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the idle validation switch SIGNAL and SUPPLY pins.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Connect a jumper wire, Part Number 3822917, from pin 3 of the ECM OEM port to throttle supply at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 13 of the ECM OEM port to throttle return at the accelerator pedal.
  • Connect a jumper wire, Part Number 3822917, from pin 10 of the ECM OEM port to switch common return at the accelerator pedal.
  • Turn keyswitch ON.

Action

Check the idle validation switch signal and supply pins.

  • Measure the voltage from pin 3 of the OEM harness connector to the engine block ground.
  • Measure the voltage from pin 13 of the OEM harness connector to the engine block ground.
OK NOT OK

(+) 3.80 to 5.25-VDC

  • Replace the solid-state sensor switch. Refer to the OEM troubleshooting and repair manual.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch OFF for 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.
OK NOT OK

Fault Code 551 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-May-2012


FAULT CODE 553 - Fuel System Overfueling

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Inspect for Fault Code 449 or high inactive counts. | Fault Code 449 is not active
 | STEP 1A-1. Check for air in pressure-side fuel. |
 | STEP 1A-2. Measure for drain line restriction |
STEP 2. | Check the front fueling actuators. |
 | STEP 2A. Inspect the front fueling actuators. | Fault Code 553 goes inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 553 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Inspect for Fault Code 449 or high inactive counts.

Conditions

  • Turn keyswitch ON.

Action

Check for air in pressure-side fuel.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 449 is not active

Fault Code 449 active.

Go to 1A-1

Use Fault Code 449

Guided Step 1A-1 - Check for air in pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.
OK NOT OK

No air in fuel

Air in fuel

  • Refer to Procedure 006-003 in Section 6.

Go to 1A-2

Go to 3A

Guided Step 1A-2 - Measure for drain line restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the drain line.

  • Measure for drain line restriction.
OK NOT OK

Less than 4.0 in Hg

More than 4.0 in Hg

Refer to Procedure 006-012 in Section 6.

Go to 2A

Go to 3A

Guided Step 2 - Check the front fueling actuators.

Guided Step 2A - Inspect the front fueling actuators.

Conditions

  • Turn keyswitch OFF.

Action

Replace the front fueling actuators.

Replace the front fueling actuators.
OK NOT OK

Fault Code 553 goes inactive

Replace the front fueling actuators. Refer to Procedure 019-110 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

Fault Code 553 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 559 - Fuel system Underfueling

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Inspect for Fault Codes 378, 379 or 482, or high inactive counts. | Fault Codes 378, 379 or 482 are not active
STEP 2. | Check for air in the pressure-side fuel. |
 | STEP 2A. Inspect for air in the pressure-side fuel. | No air in fuel
STEP 3. | Check the front fueling actuators. |
 | STEP 3A. Inspect the front fueling actuators. | Fault Code 559 goes inactive
STEP 4. | Check the injector o-rings. |
 | STEP 4A. Inspect the bottom two injector o-rings on the rear three cylinders. | O-rings are OK
STEP 5. | Check the fuel passages in the head. |
 | STEP 5A. Inspect the fuel passages in the front of the head. | No leaks to the drain passage, crankcase, cylinders, or coolant system
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 559 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Inspect for Fault Codes 378, 379 or 482, or high inactive counts.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes or high inactivecounts.ck for active fault codes or high inactive counts.
OK NOT OK

Fault Codes 378, 379 or 482 are not active

Fault Codes 378, 379 or 482 active.

Go to 2A

Applicable Fault Codes 378, 379, and 482

Guided Step 2 - Check for air in the pressure-side fuel.

Guided Step 2A - Inspect for air in the pressure-side fuel.

Conditions

Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Check for air in the pressure-side fuel.
OK NOT OK

No air in fuel

Air in fuel

  • Refer to Procedure 006-003 in Section 6.

Go to 3A

Go to 6A

Guided Step 3 - Check the front fueling actuators.

Guided Step 3A - Inspect the front fueling actuators.

Conditions

  • Turn keyswitch OFF.

Action

Replace the front fueling actuators.

  • Check that Fault Code 559 goes inactive.
OK NOT OK

Fault Code 559 goes inactive

Replace the front fueling actuators. Refer to Procedure 019-110 in Section 19.

Go to 6A

Go to 4A

Guided Step 4 - Check the injector o-rings.

Guided Step 4A - Inspect the bottom two injector o-rings on the rear three cylinders.

Conditions

Turn keyswitch OFF.

Action

inspect for nicks or tears on the bottom two orings.I

  • Check that o-rings are in good condition.
OK NOT OK

O-rings are OK

Replace the o-rings

Refer to Procedure 006-026 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the fuel passages in the head.

Guided Step 5A - Inspect the fuel passages in the front of the head.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the front of the head for leaks orobstructions.

Inspect the front of the head for leaks or obstructions.
OK NOT OK

No leaks to the drain passage, crankcase, cylinders, or coolant system

Correct the problem. Use the Signature, ISX and QSX15 Troubleshooting and Repair Manual, Bulletin Number 3666239.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code-

  • Start the engine and run it above 1000 rpm for more than 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 559 inactive

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 581 - Fuel Inlet Restriction Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel inlet restriction sensor. |
 | STEP 1A. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 581 inactive
 | STEP 1C. Check the supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the signal voltage. | (+) 0.5 to 4.16 VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 581 inactive
 | STEP 2C. Check for an open circuit in the return wire. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to ground in the supply, signal, and return wires. | More than 100k ohms
 | STEP 2E. Check for a short circuit from the supply, signal, and return wires to all other wires in the engine harness. | More than 100k ohms
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 581 inactive, Fault Code 582 active.
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 581 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel inlet restriction sensor.

Guided Step 1A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Inspect fuel inlet restriction sensor and engineharness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the 3-pin Metri-Pack™ connector. Refer to Procedure 019-202 in Section 19.
  • Replace the fuel inlet restriction sensor. Refer to Procedure 019-128 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 581 inactive

Fault Code 582 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824775, between the sensor and the harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply pin A (or RED) and return pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 4.75 to 5.25 VDC

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the ECM output voltage.

  • Measure the voltage from pin 29 to pin 27 at the actuator port of the ECM.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check the signal voltage.

Conditions

  • Install breakout cable, Part Number 3824775, between the sensor and the harness connector.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal pin C (or YELLOW) and return pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 0.5 to 4.16 VDC

Does not meet specifications.

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

inspect the ECM and engine harness connectorsfor the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 581 inactive

Fault Code 581 active.

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from pin 27 of the actuator harness connector to pin B (or 2) of the 3-pin connector at the sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Sexction 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the supply, signal, and return wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for a short circuit to ground in the supply,signal, and return wires.

  • Measure the resistance from pin 27 in the actuator harness connector to the engine block ground.
  • Measure the resistance from pin 28 in the actuator harness connector to the engine block ground.
  • Measure the resistance from pin 29 in the actuator harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from the supply, signal, and return wires to all other wires in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for a short circuit from the supply, signal,and return wires to all other wires in the engineharness.

  • Measure the resistance from pin 27 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 27 in the actuator harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from pin 28 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 28 in the actuator harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from pin 29 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 29 in the actuator harness connector to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

  • Replace the fuel inlet restriction sensor. Refer to Procedure 019-128 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ecm response.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 581 inactive

Fault Code 582 active

Fault Code 581 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 581 inactive

Return to troubleshooting steps, or contact a Cummin®s Authorized Repair Location, if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 582 - Fuel Inlet Restriction Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel inlet restriction sensor. |
 | STEP 1A. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 582 inactive
 | STEP 1C. Check the supply voltage. | (+) 4.75 to 5.25 VDC
 | STEP 1C-1. Measure the voltage from the ECM. |
 | STEP 1D. Check the signal voltage. | (+) 0.5 to 4.16 VDC
 | STEP 1D-1. Check for a short circuit to ground in the supply and signal wires. |
 | STEP 1D-2. Check for a short circuit from the supply and signal wires to all other wires in the engine harness. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 582 inactive
 | STEP 2C. Check for an open circuit in the supply and signal wires. | Less than 10 ohms
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 582 inactive.Fault Code 581 active.
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 582 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel inlet restriction sensor.

Guided Step 1A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Inspect the fuel inlet restriction sensor andengine harness connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the 3-pin Metri-Pack™ connector. Refer to Procedure 019-202 in Section 19.
  • Replace the fuel inlet restriction sensor. Refer to Procedure 019-128 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 582 inactive

Fault Code 581 active.

Go to 4B

Go to 1C

Guided Step 1C - Check the supply voltage.

Conditions

  • Install breakout cable, Part Number 3824776, between the sensor and the engine harness sensor connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage by install the breakout cable's supply pin A (or RED) and return pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 4.75 to 5.25 VDC

Does not meet specifications.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the ECM output voltage.

  • Measure the voltage from pin 29 to pin 27 at the actuator port of the ECM.
OK NOT OK

(+) 4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 1D - Check the signal voltage.

Conditions

  • Install breakout cable, Part Number 3824776, between the sensor and the engine harness sensor connector.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the supply voltage by installing the breakout cable's signal pin C (or YELLOW) and return pin B (or BLACK) connectors into the multimeter.
OK NOT OK

(+) 0.5 to 4.16 VDC

Does not meet specifications.

Go to 2A

Go to 1D-1

Guided Step 1D-1 - Check for a short circuit to ground in the supply and signal wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 50-pin actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for a short circuit to ground in the supplyand signal wires.

  • Measure the resistance from pin 28 in the actuator harness connector to the engine block ground.
  • Measure the resistance from pin 29 in the actuator harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-2

Go to 4A

Guided Step 1D-2 - Check for a short circuit from the supply and signal wires to all other wires in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for a short circuit from the supply andsignal wires to all other wires in the engineharness.

  • Measure the resistance from pin 28 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 29 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

  • Replace the fuel inlet restriction sensor. Refer to Procedure 019-128 in Section 19.

Replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine harness and ECM connectorpins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 582 inactive

Fault Code 582 active.

Go to 4B

Go to 2C

Guided Step 2C - Check for an open circuit in the supply and signal wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the fuel inlet restriction sensor from the engine harness.

Action

Check for an open circuit in the supply and signalwires.

  • Measure the resistance from pin 29 of the actuator harness connector to pin A (or 1) of the 3-pin connector.
  • Measure the resistance from pin 28 of the actuator harness connector to pin C (or 3) of the 3-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Install a jumper wire, Part Number 3822917, from pin 28 to pin 29 at the ECM actuator port.
  • Turn keyswitch ON.

Action

Check for the appropriate ecm response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 582 inactive

Fault Code 581 active

Fault Code 582 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

disabel the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 582 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 583 - Fuel Inlet Restriction Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Measure the fuel inlet restriction. |
 | STEP 1A. Measure the fuel inlet restriction. | Less than 12 in Hg
 | STEP 1A-1. Recheck the fuel inlet restriction. |
STEP 2. | Inspect the fuel lines or fuel hoses. |
 | STEP 2A. Inspect the metal fuel lines. | No damage
 | STEP 2B. Inspect the fuel hoses. | No damage
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 583 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Measure the fuel inlet restriction.

Guided Step 1A - Measure the fuel inlet restriction.

Conditions

  • Turn keyswitch OFF.

Action

Measure the fuel inlet restriction.

  • Remove the fuel supply hose from the gear pump and install a manometer.
  • Hold the manometer at the same level as the gear pump connection.
  • Operate the engine at rated speed and no load.
  • Observe the fuel inlet restriction reading on the manometer.
OK NOT OK

Less than 12 in Hg

Replace the fuel filter

Go to 3A

Go to 1A-1

Guided Step 1A-1 - Recheck the fuel inlet restriction.

Conditions

  • Turn keyswitch OFF.

Action

Measure the fuel inlet restriction.

  • Remove the fuel supply hose to the gear pump and install a manometer.
  • Hold the manometer at the same level as the gear pump connection.
  • Operate the engine at rated speed and no load.
  • Observe the fuel inlet restriction reading on the manometer.
OK NOT OK

Less than 6 in Hg

Does not meet specifications.

Go to 3A

Go to 2A

Guided Step 2 - Inspect the fuel lines or fuel hoses.

Guided Step 2A - Inspect the metal fuel lines.

Conditions

Action

Inspect the metal fuel lines for these conditions:

  • Sharp bends, which can cause a pressure restriction.
OK NOT OK

No damage

Replace the damaged line(s)

Go to 2B

Go to 3A

Guided Step 2B - Inspect the fuel hoses.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel hoses.

  • Check fuel hoses for separation of the inner lining from the center of the hose, which can cause restriction.
OK NOT OK

No damage

Replace the damaged hose

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 583 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all troubleshooting steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 588 - Engine Start Alarm Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine start alarm. |
 | STEP 1A. Perform the ICON™ alarm test. | Alarm sounds
 | STEP 1B. Check the alarm connector for damaged pins. | No damaged pins
 | STEP 1C. Check the alarm resistance from pin to pin. | More than 6 and less than 12k ohms
 | STEP 1D. Check the alarm resistance to engine block ground. | More than 100k ohms
STEP 2. | Check the engine wiring harness. |
 | STEP 2A. Inspect the engine wiring harness and the alarm connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to battery voltage. | Less than (+) 1.5 VDC
 | STEP 2B-1. Check for a short circuit to battery voltage in the OEM harness. |
 | STEP 2B-2. Check for a short circuit to battery voltage in the engine harness. |
 | STEP 2B-3. Check for a short circuit to battery voltage in the engine brake harness. |
 | STEP 2B-4. Check for a short circuit from pin to pin in the engine brake harness. |
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2C-1. Check for an open circuit in the OEM harness. |
 | STEP 2C-2. Check for an open circuit in the engine brake harness. |
 | STEP 2C-3. Check for an open circuit in the engine harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 588 inactive
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared

Guided Step 1 - Check the ICON™ engine start alarm.

Guided Step 1A - Perform the ICON™ alarm test.

Conditions

  • Connect the INSITE™ electronic service tool to the engine.
  • Turn keyswitch ON.

Action

Perform the icon alarm test.

  • Us INSITE™ electronic service tool to perform the ICON™ alarm test.
OK NOT OK

Alarm sounds

Alarm does not sound.

Go to 3A

Go to 1B

Guided Step 1B - Check the alarm connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the OEM harness.

Action

inspect the engine start alarm connectors for thefollowing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine start alarm connector.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine start alarm connector. Refer to Procedure 019-202 in Section 19.
  • Replace the engine start alarm. Use the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the alarm resistance from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Check the alarm resistance from pin to pin.

  • Measure the resistance from pin A (or 1) of the alarm connector to pin B (or 2) of the alarm connector.
OK NOT OK

More than 6 and less than 12k ohms

Replace the engine start alarm. Use the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check the alarm resistance to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Check the engine start alarm resistance toground.

  • Measure the resistance from pin A (or 1) of the engine start alarm connector to engine block ground.
  • Measure the resistance from pin B (or 2) of the engine start alarm connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine start alarm. Use the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine wiring harness.

Guided Step 2A - Inspect the engine wiring harness and the alarm connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the engine start alarm and the actuatorharness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine start alarm connector.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine start alarm connector. Refer to Procedure 019-202 in Section 19.
  • Replace the engine start alarm. Use the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to battery voltage.

Conditions

  • Disconnect the ICON™ alarm from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery voltage.

  • Measure the voltage from pin 25 on the actuator harness connector at the ECM to ground.
OK NOT OK

Less than (+) 1.5 VDC

Does not meet specifications.

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check for a short circuit to battery voltage in the OEM harness.

Conditions

  • Disconnect the OEM 31-pin connector.
  • Disconnect the ICON™ alarm from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery voltage in theoem harness.

  • Measure the voltage from pin 29 of the 31-pin OEM connector, OEM harness side to ground.
OK NOT OK

Less than (+) 1.5 VDC.

Does not meet specifications.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a short circuit to battery voltage in the engine harness.

Conditions

  • Disconnect the 31-pin OEM connector.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 8-pin pass-through connector on the engine brake harness, at the cylinder head.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery voltage in theengine harness.

  • Measure the voltage from pin 25 of the actuator harness connector to ground.
  • Measure the voltage from pin 7 of the engine brake pass-through 8-pin connector, engine harness side to ground.
OK NOT OK

Less than (+) 1.5 VDC

Does not meet specifications.

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-3

Go to 3A

Guided Step 2B-3 - Check for a short circuit to battery voltage in the engine brake harness.

Conditions

  • Disconnect the 31-pin OEM connector.
  • Disconnect the 8-pin engine brake pass-through harness at the cylinder head.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery voltage in theengine brake harness.

  • Measure the voltage from pin 8 in the 8-pin engine brake harness pass-through connector, engine brake harness side, to ground.
OK NOT OK

Less than (+) 1.5 VDC.

Does not meet specifications.

  • Repair or replace the engine brake harness, inside the cylinder head. Refer to Procedure 020-015 in Section 20.

Go to 2B-4

Go to 3A

Guided Step 2B-4 - Check for a short circuit from pin to pin in the engine brake harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake pass-through connector on the cylinder head.

Action

Check for a short circuit from pin to pin in theengine brake harness.

  • Measure the resistance from pin 8 of the 8-pin engine brake pass-through connector, engine brake harness side, to all other pins in the connector, except pin 7.

Pins 7 and 8 of the engine brake pass-through connector, engine brake side, are tied together when an ICON™ engine brake harness is installed.

OK NOT OK

More than 100k ohms

Does not meet specifications.

Repair or replace the engine brake harness

  • Repair the engine brake harness. Refer to Procedure 019-209 in Section 19.
  • Repair the engine brake harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 020-015 in Section 20.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ engine start alarm from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 25 of the actuator harness connector to pin B (or 2) of the ICON™ alarm connector.
OK NOT OK

Less than 10 ohms

Does not meet specifications.

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin connector from the engine harness.
  • Disconnect the ICON™ alarm from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 29 of the 31-pin harness connector, OEM side, to pin B (or 2) of the ICON™ alarm connector.
OK NOT OK

Less than 10 ohms

Does not meet specifications.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 2C-2

Go to 3A

Guided Step 2C-2 - Check for an open circuit in the engine brake harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 8-pin engine brake pass-through connector from the engine harness.

Action

check for an open circuit.

  • Measure the resistance from pin 7 to pin 8 of the engine brake pass-through connector on the engine brake side of the engine brake connector.
OK NOT OK

Less than 10 ohms.

Does not meet specifications

Repair or replace the engine brake harness

  • Repair the engine brake harness. Refer to Procedure 019-209 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 020-015 in Section 20.

Go to 2C-3

Go to 3A

Guided Step 2C-3 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 31-pin connector on the engine harness.
  • Disconnect the 8-pin engine brake pass-through connector, at the cylinder head.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin 7 of the 8-pin engine brake connector, engine harness side, to pin 29 of the 31-pin OEM harness connector, engine harness side.
  • Measure the resistance from pin 25 of the actuator harness connector to pin 8 of the 8-pin engine brake connector, engine harness side.
OK NOT OK

Less than 10 ohms.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 588 inactive

Return to the troubleshooting steps or contact a Cummins®Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 589 - Engine Start Alarm Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine start alarm. |
 | STEP 1A. Perform the ICON™ alarm test. | Alarm sounds
 | STEP 1B. Check the engine start alarm connector for damaged pins. | No damaged pins
 | STEP 1C. Check the alarm resistance from pin to pin. | More than 6 and less than 12k ohms
 | STEP 1D. Check the alarm resistance to engine block ground. | More than 100k ohms
STEP 2. | Check the engine wiring harness. |
 | STEP 2A. Inspect the engine wiring harness and the alarm connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2B-1. Check for a short circuit to ground in the OEM harness. |
 | STEP 2B-2. Check for a short circuit to ground in the engine harness. |
 | STEP 2B-3. Check for a short circuit to ground in the engine brake harness. |
 | STEP 2B-4. Check for a short circuit from pin to pin in the engine brake harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 589 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine start alarm.

Guided Step 1A - Perform the ICON™ alarm test.

Conditions

  • Connect the INSITE™ electronic service tool to the engine.
  • Turn keyswitch ON.

Action

Perform the icon™ alarm test.

  • Use INSITE™ electronic service tool to perform the ICON™ alarm test.
OK NOT OK

Alarm sounds

Alarm does not sound.

Go to 3A

Go to 1B

Guided Step 1B - Check the engine start alarm connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the OEM harness.

Action

Inspect the engine start alarm connector for thefollowing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the damaged pins

Repair the engine start alarm connector, or replace the engine start alarm, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine start alarm connector. Refer to Procedure 019-202 in Section 19.
  • Replace the engine start alarm. Use the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the alarm resistance from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Check the engine start alarm resistance from pinto pin.

  • Measure the resistance from pin A (or 1) to pin B (or 2) of the alarm connector.
OK NOT OK

More than 6 and less than 12k ohms

Replace the engine start alarm. Use the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check the alarm resistance to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.

Action

Check the engine start alarm resistance to engineblock ground.

  • Measure the resistance from pin A (or 1) of the engine start alarm connector to engine block ground.
  • Measure the resistance from pin B (or 2) of the engine start alarm connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine start alarm. Use the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine wiring harness.

Guided Step 2A - Inspect the engine wiring harness and the alarm connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine start alarm from the engine harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and engine startalarm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the engine harness or the engine start alarm

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the engine start alarm. Use the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICON™ engine start alarm from the OEM harness.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 25 of the actuator harness connector to ground.
OK NOT OK

More than 100k ohms

Does not meet specifications.

Go to 3A

Go to 2B-1

Guided Step 2B-1 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector.
  • Disconnect the ICON™ engine start alarm from the OEM harness.

Action

Check for a short circuit to ground in the oemharness.

  • Measure the resistance from pin 29 of the 31-pin OEM connector, OEM harness side, to ground.
OK NOT OK

More than 100k ohms

Does not meet specifications.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine brake harness pass-through 8-pin connector at the cylinder head.

Action

Check for a short circuit to ground in the engineharness.

  • Measure the resistance from pin 25 of the actuator harness connector to ground.
  • Measure the resistance from pin 7 of the engine brake pass-through 8-pin connector, engine harness side, to ground.
OK NOT OK

More than 100k ohms

Does not meet specifications.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-3

Go to 3A

Guided Step 2B-3 - Check for a short circuit to ground in the engine brake harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 31-pin OEM connector.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 8-pin engine brake harness pass-through connector at the cylinder head.

Action

Check for a short circuit to ground in the enginebrake harness.

Measure the resistance from pin 8 in the 8-pin connector, engine brake harness side of the harness, to ground.
OK NOT OK

More than 100k ohms.

Does not meet specifications.

Repair or replace the engine brake harness

  • Repair the engine brake harness. Refer to Procedure 019-209 Section 19.
  • Replace the engine brake harness. Refer to Procedure 020-015 in Section 20.

Go to 2B-4

Go to 3A

Guided Step 2B-4 - Check for a short circuit from pin to pin in the engine brake harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake pass-through 8-pin connector at the cylinder head.

Action

Check for a short circuit from pin to pin in theengine brake harness.

  • Measure the voltage from pin 8 of the 8-pin engine brake pass-through connector, engine brake harness side, to all other pins in the connector, except pin 7.

Pin 7 and 8 of the engine brake harness pass-through connector, engine brake side, are tied together when an ICON™ engine brake harness is installed.

OK NOT OK

More than 100k ohms

Does not meet specifications.

Repair or replace the engine brake harness

  • Repair the engine brake harness. Refer to Procedure 019-209 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 020-015 in Section 20.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Diaable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 589 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 595 - Turbocharger Speed High (Calculated)

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | No fault codes, other than Fault Code 595, active or inactive, with more than one count?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Check ECM calibration. | ECM has a release date of August 1999 or later?
STEP 3. | Check the turbocharger. |
 | STEP 3A. Check the turbocharger part number. | The turbocharger part number matches the turbocharger part number listed for the CPL?
 | STEP 3B. Check the turbocharger wastegate. | The turbocharger wastegate actuator rod travel is between 0.356 mm [0.014 in] and 3.810 mm [0.150 in]?
STEP 4. | Check the intake manifold temperature and pressure (Combo) sensor. |
 | STEP 4A. Check the intake manifold pressure. | The pressure reading in INSITE™ electronic service tool is within ± 127 mmHg [5 inHg] of the actual intake manifold pressure?
 | STEP 4B. Check the barometric air pressure sensor. | The pressure reading on INSITE™ electronic service tool is within ± 25 mmHg [1 inHg] of the actual barometric air pressure?
STEP 5. | Disable the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 595 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Troubleshoot fault codes, other than Fault Code 595, starting with any active codes or if no codes are active start with the inactive fault code containing the highest number of counts.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No fault codes, other than Fault Code 595, active or inactive with more than one count?

Troubleshoot the fault codes, other than Fault Code 595, starting with any active fault codes or, if no fault codes are active, start with the inactive fault code containing the highest number of counts.

Go to 2A

Appropriate troubleshooting step

Guided Step 2 - Check the engine control module (ECM).

Guided Step 2A - Check ECM calibration.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the ECM calibration.

  • Use INSITE™ electronic service tool to determine the present ECM calibration.
  • The ECM calibration can be checked in INSITE™ electronic service tool, under Features and Parameters. Expand the selection for System ID and Dataplate and go to Calibration Information. If the calibration is earlier than August 1999, calibrate the ECM using the most recent release of the INCAL™ DVD.
OK NOT OK

ECM has a release date of August 1999 or later?

Calibrate the ECM with the most recent release of the INCAL™ DVD.

Refer to Procedure 019-032 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the turbocharger.

Guided Step 3A - Check the turbocharger part number.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger part number and compare it to the Control Parts List (CPL), Bulletin Number 3379133.

  • Replace the turbocharger, if necessary. Use the following procedure. Refer to Procedure 010-033 in Section 10.
OK NOT OK

The turbocharger part number match the turbocharger part number listed for the CPL?

Replace the turbocharger if the part number does not match the engine CPL.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Go to 3B

Go to 5A

Guided Step 3B - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate.

  • Check the wastegate hose for cracks and kinks.
  • Measure the actuator rod travel.

Check the wastegate for correct operation. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-050 in Section 10.

OK NOT OK

The turbocharger wastegate actuator rod travel is between 0.356 mm [0.014 in] and 3.810 mm [0.150 in]?

Adjust the turbocharger wastegate.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-050 in Section 10.

Go to 4A

Go to 5A

Guided Step 4 - Check the intake manifold temperature and pressure (Combo) sensor.

Guided Step 4A - Check the intake manifold pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure, use INSITE™ electronic service tool and confirm that the pressure reading matches the actual intake manifold pressure.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-057 in Section 10.

OK NOT OK

The pressure reading in INSITE™ electronic service tool is within ± 127 mmHg [5 inHg] of the actual intake manifold pressure?

Replace the intake manifold pressure and temperature (Combo) sensor.

Refer to Procedure 019-159 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the barometric air pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric air pressure sensor.

  • Check the barometric air pressure, use INSITE™ electronic service tool and the Barometric Pressure at Altitude table in the following procedure to confirm that the pressure reading matches the actual barometric air pressure. Refer to Procedure 018-028 in Section V.
OK NOT OK

The pressure reading on INSITE™ electronic service tool is within ± 25 mmHg [1 inHg] of the actual barometric air pressure?

Replace the barometric air pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Disable the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and allow it to idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 595 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared.

No repair.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2017


FAULT CODE 596 - Voltage Monitor - High Voltage

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | Normal conditions: At least + 12 VDC. During cranking: At least + 6.2 VDC.
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 596 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternatorconnections for the following:

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections

  • Tighten the battery connections and clean the battery terminals. Use the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.
OK NOT OK

Normal conditions: At least + 12 VDC

During cranking: At least + 6.2 VDC

Charge or replace the battery. Use the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

Start the engine and check the alternator's charging rate (amps).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.
OK NOT OK

Alternator charging within OEM specifications

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator. Use the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 6 minutes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 596 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 597 - Voltage Monitor - Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | Normal conditions: At least + 12 VDC. During cranking: At least + 6.2 VDC
STEP 2. | Check the alternator and OEM harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications
 | STEP 2B. Inspect the battery power connector. | No damaged pins
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit. | More than 100k ohms
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 597 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternatorconnections for the following:

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections

  • Tighten the battery connections and clean the battery terminals. Use the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.
OK NOT OK

Normal conditions: At least + 12 VDC

During cranking: At least + 6.2 VDC

Charge or replace the battery. Use the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Check the alternator and OEM harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

Start the engine and check the alternator's charging rate (amps).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.
OK NOT OK

Alternator charging within OEM specifications

Repair or replace the alternator and/or OEM wiring to the alternator. Use the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the battery at the power connector.

Action

Inspect the battery power connector on both thebattery side and the harness side for thefollowing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the battery power connector. Use the OEM service manual for location and procedure.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine control module (ECM).

Action

Check for an open circuit in the unswitchedbattery supply circuit.

  • Measure the resistance between pin 7 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 8 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 17 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 18 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 28 of the OEM harness connector and the positive (+) terminal of the battery.
OK NOT OK

Less than 10 ohms

Repair or replace the battery harness. Use the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM
  • Disconnect the OEM harness at the battery power connector.

Action

Check for a short circuit.

  • Measure the resistance from pin 7 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 8 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 17 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 18 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 28 of the OEM harness connector to all other pins in the OEM harness connector.

Pin 7, 8, 17, 18, and 28 must have continuity.

OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at thepositive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause a short circuit in the supply wire to the engine block.
OK NOT OK

No damaged wires

Repair the damaged wiring

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 6 minutes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 597 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 598 - Voltage Monitor - Very Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | Normal conditions: At least + 12 VDC. During cranking: At least + 6.2 VDC
STEP 2. | Check the alternator and OEM harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications
 | STEP 2B. Inspect the battery power connector. | No damaged pins
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit. | More than 100k ohms
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 598 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternatorconnections for the following:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections

  • Tighten the battery connections and clean the battery terminals. Use the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.
OK NOT OK

Normal conditions: At least + 12 VDC

During cranking: At least + 6.2 VDC

Charge or replace the battery. Use the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Check the alternator and OEM harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

Start the engine and check the alternator's charging rate (amps).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.
OK NOT OK

Alternator charging within OEM specifications

Repair or replace the alternator and/or OEM wiring to the alternator. Use the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the battery at the power connector.

Action

Inspect the battery power connector on both thebattery side and the harness side for thefollowing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the battery power connector. Use the OEM troubleshooting and repair manual for location and procedure.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine control module (ECM).

Action

Check for an open circuit in the unswitchedbattery supply circuit.

  • Measure the resistance between pin 7 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 8 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 17 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 18 of the OEM harness connector and the positive (+) terminal of the battery.
  • Measure the resistance between pin 28 of the OEM harness connector and the positive (+) terminal of the battery.
OK NOT OK

Less than 10 ohms

Repair or replace the battery harness. Use the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness at the battery power connector.

Action

–

  • Measure the resistance from pin 7 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 8 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 17 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 18 of the OEM harness connector to all other pins in the OEM harness connector.
  • Measure the resistance from pin 28 of the OEM harness connector to all other pins in the OEM harness connector.

Pin 7, 8, 17, 18, and 28 must have continuity.

OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check for a short circuit.

Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause a short circuit at supply wire to the engine block ground.

OK NOT OK

No damaged wires

Repair the damaged wiring.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the add-on or accessory wiring at thepositive (+) terminal of the battery.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 598 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 731 - Engine Speed Sensor and Camshaft Position Sensor - Mechanical Misalignment Between Camshaft and Crankshaft Sensors

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the speed/position sensors and tone wheels. |
 | STEP 1A. Inspect the engine speed and position sensors for defects. | Any defects?
 | STEP 1B. Inspect the tone wheels for any defects. | Any defects?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Does the proper wedge fit easily between the flat on the injector camshaft and the groove in the cylinder head?
 | STEP 2B. Inspect the gear train. | Any defects?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | Are all grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Inspect the speed/position sensors and tone wheels.

Guided Step 1A - Inspect the engine speed and position sensors for defects.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and position sensors for defects.

If either sensor has physical damage, do not replace the sensor until the source of the damage is identified.

The locking tab on the sensor must point towards the capscrew hole on the engine brackets.

Any defects?
YES NO

Repair or replace the speed or position sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any defects.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for defects.

  • Use a screwdriver to gently pry on the crankshaft tone wheel
  • Verify the tone wheel is not loose.

Are any defects found or is the crankshaft tone wheel loose?
YES NO

Replace the crankshaft or injector camshaft, whichever has failed. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 002-025 in Section 2.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check for correct engine static timing

Guided Step 2A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Rotate the engine to the insert pin mark on the damper.
  • Install the injector camshaft timing wedge.

Action

Inspect the engine static timing.

Does the proper wedge fit easily between the flat on the injector camshaft and the groove in the cylinder head?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the upper and lower front gear covers.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 001-079 in Section 1 and Refer to Procedure 001-080 in Section 1.

  • Inspect the gear train for damage that would lead to slippage.

Any defects?
YES NO

Reference the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

Keyswitch OFF.

Action

Inspect the engine and vehicle grounding

  • Check all engine, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

Are all grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 731 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-May-2012


FAULT CODE 753 - Engine Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the camshaft engine speed sensor. |
 | STEP 1A. Inspect the camshaft engine speed sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Inspect the camshaft engine speed sensor. | No damaged engine speed sensor?
 | STEP 1C. Check the camshaft engine speed sensor operation. | Positive (+ 4.0 to 5.0 -VDC to + 0.2 to 2.3 -VDC) and back about every 360° of rotation?
 | STEP 1C-1. Check the engine speed sensor supply voltage. |
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the crankshaft engine speed sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft engine speed sensor. | No damaged engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor operation. | Positive (+ 4.0 to + 5.0 -VDC to + 0.2 to + 2.3 -VDC) and back about every 60° of rotation?
 | STEP 2C-1. Check the engine speed sensor supply voltage. |
STEP 3. | Check the engine harness for both circuits. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 753 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 4C. Should the fault code return. | All fault codes cleared and timing checked?

Guided Step 1 - Check the camshaft engine speed sensor.

Guided Step 1A - Inspect the camshaft engine speed sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the engine harness or replace the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the camshaft engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.
OK NOT OK

No damaged engine speed sensor?

Replace the engine speed sensor. Refer to Procedure 019-038 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check the camshaft engine speed sensor operation.

Conditions

  • Install wiring breakout cable.
  • Turn keyswitch ON.

Action

Check for a signal from engine speed sensor.

  • Measure the voltage from pin B (or BLACK) to pin C (or YELLOW) at the breakout cable, while barring the engine over.
OK NOT OK

Positive (+ 4.0 to + 5.0 -VDC to + 0.2 to + 2.3 -VDC) and back again about every 360° of rotation?

Replace the engine speed sensor. Refer to Procedure 019-038 in Section 19.

Go to 1C-1

Go to 4A

Guided Step 1C-1 - Check the engine speed sensor supply voltage.

Conditions

  • Disconnect the engine harness from the engine speed sensor.
  • Turn keyswitch ON.

Action

Check the engine speed sensor supply voltage.

  • Measure the voltage from pin A (or RED) to pin B (or BLACK) on the harness side of the engine speed sensor connector.
OK NOT OK

+ 4.75 to + 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the crankshaft engine speed sensor.

Guided Step 2A - Inspect the crankshaft engine speed sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the engine harness or replace the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-038 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the crankshaft engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by crankshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.
OK NOT OK

No damaged engine speed sensor?

Replace the engine speed sensor. Refer to Procedure 019-038 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the crankshaft engine speed sensor operation.

Conditions

  • Install wiring breakout cable, Part Number 3824775 between the crankshaft engine speed sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for a signal from the engine speed sensor.

  • Measure the voltage from pin B (or BLACK) to pin C (or YELLOW) at the breakout cable, while barring the engine over.
OK NOT OK

Positive (+ 4.0 to + 5.0 -VDC to + 0.2 to + 2.3 -VDC) and back again about every 60° of rotation?

Replace the engine speed sensor. Refer to Procedure 019-038 in Section 19.

Go to 2C-1

Go to 4A

Guided Step 2C-1 - Check the engine speed sensor supply voltage

Conditions

  • Disconnect the engine harness from the engine speed sensor.
  • Turn keyswitch ON.

Action

Check the engine speed sensor supply voltage.

  • Measure the voltage from pin A (or RED) to pin B (or BLACK) on the harness side of the engine speed sensor connector.
OK NOT OK

+ 4.75 to + 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness for both circuits.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the engine harness or replace the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Connect the engine harness to the engine speed sensor.

Action

Check for open circuit.

  • Measure resistance from pin 50 of the sensor harness ECM connector to pin C (or 3) at the camshaft position sensor connector.
  • Measure resistance from pin 21 of the sensor harness ECM connector to pin B (or 2) at the camshaft position sensor connector.
  • Measure resistance from pin 11 of the sensor harness ECM connector to pin A (or 1) at the camshaft position sensor connector.
  • Measure resistance from pin 47 of the sensor harness ECM connector to pin C (or 3) at the crankshaft position sensor connector.
  • Measure resistance from pin 32 of the sensor harness ECM connector to pin B (or 2) at the crankshaft position sensor connector.
  • Measure resistance from pin 41 of the sensor harness ECM connector to pin A (or 1) at the crankshaft position sensor connector.
OK NOT OK

Less than 10 ohms?

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for short circuit to ground.

  • Measure the resistance from pin 50 of the sensor harness ECM connector to the engine block ground.
  • Measure the resistance from pin 11 of the sensor harness ECM connector to the engine block ground.
  • Measure the resistance from pin 47 of the sensor harness ECM connector to the engine block ground.
  • Measure the resistance from pin 41 of the sensor harness ECM connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for short circuit from pin to pin

  • Measure resistance from pin 50 to all other pins of the sensor harness ECM connector.
  • Measure resistance from pin 21 to all other pins of the sensor harness ECM connector.
  • Measure resistance from pin 11 to all other pins of the sensor harness ECM connector.
  • Measure resistance from pin 47 to all other pins of the sensor harness ECM connector.
  • Measure resistance from pin 32 to all other pins of the sensor harness ECM connector.
  • Measure resistance from pin 41 to all other pins of the sensor harness ECM connector.
OK NOT OK

Greater than 100k ohms?

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool, verify that Fault Code 753 is inactive.
OK NOT OK

Fault Code 753 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Go to 4C

Guided Step 4C - Should the fault code return.

Conditions

  • Complete all steps above and check again.

Action

Check the static timing of the injector camshaft.

  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-004 in Section 3.
OK NOT OK

All fault codes cleared?

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


FAULT CODE 755 - Fuel Injector

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel system. |
 | STEP 1A. Measure the drain line restriction. | Less than 4.0 in Hg
 | STEP 1B. Check for air in the pressure-side fuel. | No air in fuel
STEP 2. | Perform the cylinder performance test. |
 | STEP 2A. Inspect for front cylinder performance. | Cylinder contribution above 70 percent
STEP 3. | Check the front fuel injectors. |
 | STEP 3A. Inspect the front fuel injectors. | Fault Code 755 goes inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 755 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel system.

Guided Step 1A - Measure the drain line restriction.

Conditions

  • Turn keyswitch OFF.

Action

Measure the drain line restriction.

Measure the drain line restriction.
OK NOT OK

Less than 4.0 in Hg

More than 4.0 in Hg. Refer to Procedure 006-012 in Section 6 in the Signature, ISX and QSX15 Troubleshooting and Repair Manual, Bulletin Number 3666239.

Go to 1B

Go to 4A

Guided Step 1B - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Check for air in the pressure-side fuel.
OK NOT OK

No air in fuel

Air in fuel. Refer to Procedure 006-003 in Section 6.

Go to 2A

Go to 4A

Guided Step 2 - Perform the cylinder performance test.

Guided Step 2A - Inspect for front cylinder performance.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test on frontcylinders.

  • Use INSITE™ to determine cylinder with lowest power.
  • It is normal for next cylinder in firing order of the front bank of three cylinders to have high power; above 125 percent is acceptable.
OK NOT OK

Cylinder contribution above 70 percent

Cylinder contribution below 70 percent

Go to 4A

Go to 3A

Guided Step 3 - Check the front fuel injectors.

Guided Step 3A - Inspect the front fuel injectors.

Conditions

  • Turn keyswitch OFF.

Action

Replace the appropriate fuel injector in the frontbank.

  • Replace the fuel injector at the cylinder with the lowest power output.
OK NOT OK

Fault Code 755 goes inactive

Replace the appropriate fuel injector. Refer to Procedure 006-026 in Section 6.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and run it above 1000 rpm for at least 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 755 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 758 - Fuel Injector

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel system. |
 | STEP 1A. Measure the drain line restriction. | Less than 4.0 in Hg
 | STEP 1B. Check for air in the pressure-side fuel. | No air in fuel
STEP 2. | Perform the cylinder performance test. |
 | STEP 2A. Inspect for rear cylinder performance. | Cylinder contribution above 70 percent
STEP 3. | Check the rear fuel injectors. |
 | STEP 3A. Inspect the rear fuel injectors. | Fault Code 758 goes inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 758 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel system.

Guided Step 1A - Measure the drain line restriction.

Conditions

  • Turn keyswitch OFF.

Action

Measure the drain line restriction.

Measure the drain line restriction.
OK NOT OK

Less than 4.0 in Hg

More than 4.0 in Hg. Refer to Procedure 006-012 in Section 6.

Go to 1B

Go to 4A

Guided Step 1B - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Check for air in the pressure-side fuel.
OK NOT OK

No air in fuel

Air in fuel. Refer to Procedure 006-003 in Section 6.

Go to 2A

Go to 4A

Guided Step 2 - Perform the cylinder performance test.

Guided Step 2A - Inspect for rear cylinder performance.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test on rearcylinders.

  • Use INSITE™ to determine cylinder with lowest power.
  • It is normal for next cylinder in firing order of the rear bank of three cylinders to have high power; above 125 percent is acceptable.
OK NOT OK

Cylinder contribution above 70 percent

Cylinder contribution below 70 percent

Go to 4A

Go to 3A

Guided Step 3 - Check the rear fuel injectors.

Guided Step 3A - Inspect the rear fuel injectors.

Conditions

  • Turn keyswitch OFF.

Action

Replace the appropriate fuel injector in the rearbank.

  • Replace the fuel injector at the cylinder with the lowest power output.
OK NOT OK

Fault Code 758 goes inactive

Replace the appropriate fuel injector. Refer to Procedure 006-026 in Section 6.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and run it above 1000 rpm for at least 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 758 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Jul-2012


FAULT CODE 784 - Adaptive Cruise Control Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the adaptive cruise control hardware |
 | STEP 1A. Check for installed adaptive cruise control hardware | Adaptive cruise control hardware installed on vehicle?
STEP 2. | Check SAE J1939 communication |
 | STEP 2A. Check for ECM communication with INSITE™ | INSITE™ communicate with engine control module (ECM)?s
 | STEP 2B. Inspect the OEM harness and ECM connector pins | Dirty or damaged pins?
 | STEP 2C. Check ECM communication with the ECM bench calibration harness | INSITE™ communicates with ECM?
STEP 3. | Clear the fault code |
 | STEP 3A. Disable the fault code | Fault Code 784 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the adaptive cruise control hardware

Guided Step 1A - Check for install adaptive cruise control hardware.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle for installed adaptive cruisecontrol hardware.

Adaptive cruise control hardware installed on vehicle?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Adaptive Cruise feature.

Go to 2A

Go to 3A

Guided Step 2 - Check SAE J1939 communications

Guided Step 2A - Check for ECM communication with INSITE™

Conditions

  • Turn keyswitch ON.
  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and attempt tocommunicate with the ecm.

  • Start INSITE™.
  • Select INLINE™ II (J1939) ECM connection.

INSITE™ communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

Use the OEM Troubleshooting and Repair Manual for information on troubleshooting the adaptive cruise control unit and the vehicle SAE J1939 network.

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the oem harness and ecm connector pinsfor the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damage harness connector or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter to the ECM bench calibration harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and attempt tocommunicate with the ecm.

  • Start INSITE™ and connect to the ECM with an INLINE™ II (J1939) ECM connection.

INSITE™ communicates with the ECM?
YES NO

INSITE™ is able to communicate with the ECM. This indicates that the ECM SAE J1939 data link circuit is functioning properly.

 No Repair

Use the OEM service Manual for troubleshooting the vehicle SAE J1939 circuit and devices.

Use the Communication Error - Electronic Service Tool or Control Device Symptom Troubleshooting Tree

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 784 inactive?
YES NO
No Repair

Return to the troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 23-Jun-2017


FAULT CODE 951 - Cylinder Power Imbalance

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 951. | Active or inactive counts of Fault Code 951?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 951.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 951?
YES NO

Check fuel quality. Check for air being ingested into the fuel. It is normal to have an inactive Fault Code 951 after a service procedure introduced air into the fuel system, such as a filter change. Perform the Cylinder Performance Test to determine if a particular cylinder or bank of cylinders is high or low on power. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-008 in Section 14.

No Repair

Repair complete

Repair complete

Last Modified: 31-May-2012


INDEX
72-ifctbl.htm

72-fc111.htm

72-t05-111.htm

72-fc115.htm

72-t05-115.htm

72-fc121.htm

72-t05-121.htm

72-fc122.htm

72-t05-122.htm

72-fc123.htm

72-t05-123.htm

72-fc131.htm

72-t05-131.htm

72-fc132.htm

72-t05-132.htm

72-fc133.htm

72-t05-133.htm

72-fc134.htm

72-t05-134.htm

72-fc135.htm

72-t05-135.htm

72-fc141.htm

72-t05-141.htm

72-fc143.htm

72-t05-143.htm

72-fc144.htm

72-t05-144.htm

72-fc145.htm

72-t05-145.htm

72-fc147.htm

72-t05-147.htm

72-fc148.htm

72-t05-148.htm

72-fc153.htm

72-t05-153.htm

72-fc154.htm

72-t05-154.htm

72-fc155.htm

72-t05-155.htm

72-fc187.htm

72-t05-187.htm

72-fc198.htm

72-t05-198.htm

72-fc199.htm

72-t05-199.htm

72-fc212.htm

72-t05-212.htm

72-fc213.htm

72-t05-213.htm

72-fc214.htm

72-t05-214.htm

72-fc216.htm

72-t05-216.htm

72-fc217.htm

72-t05-217.htm

72-fc218.htm

72-t05-218.htm

72-fc221.htm

72-t05-221.htm

72-fc222.htm

72-t05-222.htm

72-fc223.htm

72-t05-223.htm

72-fc227.htm

72-t05-227.htm

72-fc234.htm

72-t05-234.htm

72-fc235.htm

72-t05-235.htm

72-fc241.htm

72-t05-241.htm

72-fc242.htm

72-t05-242.htm

72-fc245.htm

72-t05-245.htm

72-fc249.htm

72-t05-249.htm

72-fc254.htm

72-t05-254.htm

72-fc255.htm

72-t05-255.htm

72-fc256.htm

72-t05-256.htm

72-fc259.htm

72-t05-259.htm

72-fc284.htm

72-t05-284.htm

72-fc285.htm

72-t05-285.htm

72-fc286.htm

72-t05-286.htm

72-fc293.htm

72-t05-293.htm

72-fc294.htm

72-t05-294.htm

72-fc295.htm

72-t05-295.htm

72-fc297.htm

72-t05-297.htm

72-fc298.htm

72-t05-298.htm

72-fc319.htm

72-t05-319.htm

72-fc338.htm

72-t05-338.htm

72-fc339.htm

72-t05-339.htm

72-fc341.htm

72-t05-341.htm

72-fc343.htm

72-t05-343.htm

72-fc349.htm

72-t05-349.htm

72-fc352.htm

72-t05-352.htm

72-fc359.htm

72-t05-359.htm

72-fc378.htm

72-t05-378.htm

72-fc379.htm

72-t05-379.htm

72-fc386.htm

72-t05-386.htm

72-fc387.htm

72-t05-387.htm

72-fc388.htm

72-t05-388.htm

72-fc392.htm

72-t05-392.htm

72-fc393.htm

72-t05-393.htm

72-fc394.htm

72-t05-394.htm

72-fc395.htm

72-t05-395.htm

72-fc396.htm

72-t05-396.htm

72-fc397.htm

72-t05-397.htm

72-fc398.htm

72-t05-398.htm

72-fc399.htm

72-t05-399.htm

72-fc415.htm

72-t05-415.htm

72-fc418.htm

00-t05-418.htm

72-fc419.htm

72-t05-419.htm

72-fc422.htm

72-t05-422.htm

72-fc426.htm

72-t05-426.htm

72-fc428.htm

72-t05-428.htm

72-fc429.htm

72-t05-429.htm

72-fc431.htm

72-fc431iss.htm

72-t05-431iss.htm

72-fc431niss.htm

72-t05-431niss.htm

72-fc431sss.htm

72-t05-431sss.htm

72-fc432.htm

72-t05-432.htm

72-fc433.htm

72-t05-433.htm

72-fc434.htm

72-t05-434.htm

72-fc435.htm

72-t05-435.htm

72-fc441.htm

72-t05-441.htm

72-fc442.htm

72-t05-442.htm

72-fc443.htm

72-t05-443.htm

72-fc449.htm

72-t05-449.htm

72-fc451.htm

72-t05-451.htm

72-fc452.htm

72-t05-452.htm

72-fc465.htm

72-t05-465.htm

72-fc466.htm

72-t05-466.htm

72-fc469.htm

72-t05-469.htm

72-fc472.htm

72-t05-472.htm

72-fc474.htm

72-t05-474.htm

72-fc475.htm

72-t05-475.htm

72-fc476.htm

72-t05-476.htm

72-fc482.htm

72-t05-482.htm

72-fc483.htm

72-t05-483.htm

72-fc484.htm

72-t05-484.htm

72-fc485.htm

72-t05-485.htm

72-fc486.htm

72-t05-486.htm

72-fc489.htm

72-t05-489.htm

72-fc491.htm

72-t05-491.htm

72-fc492.htm

72-t05-492.htm

72-fc496.htm

72-t05-496.htm

72-fc527.htm

72-t05-527.htm

72-fc528.htm

72-t05-528.htm

72-fc529.htm

72-t05-529.htm

72-fc536.htm

72-t05-536.htm

72-fc537.htm

72-t05-537.htm

72-fc538.htm

72-t05-538.htm

72-fc541.htm

72-t05-541.htm

72-fc544.htm

72-t05-544.htm

72-fc546.htm

72-t05-546.htm

72-fc547.htm

72-t05-547.htm

72-fc551.htm

72-fc551iss.htm

72-t05-551iss.htm

72-fc551ivs.htm

72-t05-551ivs.htm

72-fc551sss.htm

72-t05-551sss.htm

72-fc553.htm

72-t05-553.htm

72-fc559.htm

72-t05-559.htm

72-fc581.htm

72-t05-581.htm

72-fc582.htm

72-t05-582.htm

72-fc583.htm

72-t05-583.htm

72-fc588.htm

72-t05-588.htm

72-fc589.htm

72-t05-589.htm

72-fc595.htm

72-t05-595.htm

72-fc596.htm

72-t05-596.htm

72-fc597.htm

72-t05-597.htm

72-fc598.htm

72-t05-598.htm

72-fc731.htm

72-t05-731.htm

72-fc753.htm

72-t05-753.htm

72-fc755.htm

72-t05-755.htm

72-fc758.htm

72-t05-758.htm

72-fc784.htm

72-t05-784.htm

72-fc951.htm

72-t05-951.htm