QST30

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module Microprocessor

FAULT CODE 111

Electronic Control Module Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Red SRT: | Error internal to the ECM, related to the memory hardware failures or internal microprocessor communication failures. | Engine will not start.
ECM

Circuit Description

The CM 552 ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

Two ECMs are on board the QST30 engine, one on each side, in front of the fuel pumps.

Shop Talk

This fault code can only be caused by an internal ECM problem. There are no repairs possible for the module in the field.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 29-Jul-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Sleeve Actuator Circuit

FAULT CODE 113

Sleeve Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 113 PID: S020 SPN: 635 FMI: 3 LAMP: Yellow SRT: | More than 6.2 amps detected at timing sleeve actuator circuit pin 6 of the engine harness. | No action by the electronic control module (ECM) is taken. The engine can have low-power outputs, loud combustion noise, and produce black smoke.
Sleeve Actuator Circuit

Circuit Description

The sleeve actuator circuit is used to control the start of injection through pin 6 of the engine harness. The ECM monitors the current on pin 6 and expects to see the amperage vary between 1.0 and 6.2 amps during normal engine operation. Amperage above 6.2 amps on pin 6 will trip Fault Code 113.

Component Location

The sleeve actuator circuit is an integral part of the RP39 fuel pump.

Shop Talk

This fault can be caused by an internal ECM problem or an alternate power source. There are no repairs possible for the module in the field.

Refer to Troubleshooting Fault Code t05-113

Last Modified: 29-Jul-2010


Sleeve Actuator Circuit

FAULT CODE 114

Sleeve Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 114 PID: S020 SPN: 635 FMI: 4 LAMP: Yellow SRT: | Less than 1.0 amp is detected at the sleeve actuator circuit pin 6 of the engine harness. | No action by the electronic control module (ECM) is taken. Engine emits white smoke and loses power.
Sleeve Actuator Circuit

Circuit Description

The sleeve actuator circuit is used to control the start of injection through pin 6 of the engine harness. The ECM monitors the current on pin 6 and expects to see the amperage vary between 1.0 and 6.2 amps during normal engine operation. Amperage below 1.0 amp on pin 6 will trip Fault Code 114.

Component Location

The sleeve actuator circuit is an integral part of the RP39 fuel pump.

Shop Talk

This fault can be caused by an internal ECM problem or a open circuit in the wiring. There are no repairs possible for the module in the field.

Refer to Troubleshooting Fault Code t05-114

Last Modified: 29-Jul-2010


Engine Speed Sensor Circuit

FAULT CODE 115

Engine Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 FMI: 2 LAMP: Red SRT: | No engine speed signal detected at pin 17 of the engine harness. | Engine will run on backup speed signal provided by engine position sensor on pin 9 of the engine harness.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor provides the engine speed signal to the electronic control module (ECM) through the engine harness. The sensor must be powered by a positive (+) 5 VDC power source to operate. The sensor generates a signal by sensing the movement of the target teeth of the flywheel. The sensor signal is 0 to 2.3 VDC between the flywheel teeth, and 4 to 5 VDC when a tooth is aligned with the sensor. A breakout cable should be used to check the engine speed sensor circuit.

Component Location

The engine speed sensor and the engine position sensor are located in the flywheel housing.

Shop Talk

The engine speed sensor provides the main engine speed signal to the ECM through the engine harness. The engine position sensor provides the backup engine speed signal to the ECM in the event of a failed engine speed sensor. The engine speed signal is generated when the engine speed sensor detects teeth on the ring gear. The engine position signal is generated by holes in the flywheel. The ECM determines the engine speed by counting the number of voltage switches for a given period of time.

Refer to Troubleshooting Fault Code t05-115

Last Modified: 29-Jul-2010


Engine Position Sensor Circuit

FAULT CODE 121

Engine Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 FMI: 10 LAMP: Yellow SRT: | No engine position signal detected at pin 9 of the engine harness. | Loss of backup engine position sensor. No action is taken by the electronic control module (ECM).
Engine Position Sensor Circuit

Circuit Description

The engine position sensor provides the engine position signal to the ECM through the engine harness as well as a backup engine speed signal. The sensor must be powered by a positive (+) 5 VDC power source to operate. The sensor generates a signal by sensing the movement of the target holes of the flywheel. The sensor signal is 4 to 5 VDC between the holes of the flywheel, and 0 to 2.3 VDC when a hole is aligned with the sensor. A breakout cable should be used to check the engine position sensor circuit.

Component Location

The engine speed sensor and the engine position sensor are located in the flywheel housing.

Shop Talk

The engine speed sensor provides the main engine position signal to the ECM through the engine harness. The engine position sensor provides the backup engine position signal to the ECM in the event of a failed engine speed sensor. The engine speed signal is generated when the engine speed sensor detects teeth on the ring gear. The engine position signal is generated by holes in the flywheel. The ECM determines engine position by detecting a special pattern of the signal. It also determines engine speed by counting the number of voltage switches for a given period of time.

Refer to Troubleshooting Fault Code t05-121

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Yellow SRT: | More than 4.72 VDC detected at the intake manifold air pressure sensor signal pin 45 of the engine harness. | Engine power derate to no-air setting.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the electronic control module (ECM) through pin 45 of the engine harness. The ECM monitors the voltage on pin 45 and expects to see the voltage vary between 0.5 and 4.5 VDC during normal engine operation. Voltage above 4.72 VDC on pin 45 will trip Fault Code 122.

Component Location

Two intake manifold pressure sensors are found on the QST30 industrial engines, one on each side. They are located in the intake manifold in front of each ECM.

Shop Talk

  • The intake manifold pressure sensor measures gauge pressure. Confirm that the sensor is reading properly by comparing the reading seen in the ECM with a reading taken with a mechanical gauge. The sensor should read -1.5 to +1.5 in Hg using INSITE™, with the keyswitch turned to the ON position, but the engine not running.
  • Determine if the engine is being overfueled.
  • Confirm that the correct intake manifold pressure sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air can be the cause of the high intake manifold pressure, test the engine while feeding it warm intake air.
  • Inspect the intake manifold pressure sensor circuit for signs of tampering. Remove any extra wires from the circuit.
Refer to Troubleshooting Fault Code t05-122

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Yellow SRT: | Less than 0.33 VDC detected at the intake manifold air pressure sensor signal pin 45 of the engine harness. | Engine power derate to no-air setting.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the electronic control module (ECM) through pin 45 of the engine harness.

The ECM monitors the voltage on pin 45 and expects to see the voltage vary between 0.5 and 4.5 VDC during normal engine operation.

Voltage below 0.33 VDC on pin 45 will result in Fault Code 123.

Component Location

Two intake manifold pressure sensors are found on the QST30 industrial engine, one on each side. They are located either in the intake manifold or in front of each ECM.

Shop Talk

  • The intake manifold pressure sensor measures gauge pressure. Confirm that the sensor is reading properly by comparing the reading seen in the ECM with a reading taken with a mechanical gauge. The sensor should read -1.5 to +1.5 in Hg using INSITE™, with the keyswitch turned to the ON position, but the engine not running.
  • Check for high restriction in the intake air manifold due to clogged air filters or a shutdown device in the manifold (if the vehicle is equipped with one). Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.
  • Make sure the turbocharger is working correctly. Check for a positive intake manifold pressure.
Refer to Troubleshooting Fault Code t05-123

Last Modified: 29-Jul-2010


Accelerator Position Sensor

FAULT CODE 131

Accelerator Position Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 091 FMI: 3 LAMP: Red SRT: | Excessive voltage detected at the accelerator position signal pin 30 of the OEM interface harness. | Calibration-dependent power and speed derate.
Accelerator Position Sensor

Circuit Description

The accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command for the RP39 fuel pump rack.

Component Location

The accelerator pedal location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follow:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, Depressed = 200 to 1500 ohms.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 29-Jul-2010


Accelerator Position Sensor

FAULT CODE 132

Accelerator Position Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 091 FMI: 4 LAMP: Red SRT: | Low voltage detected at the accelerator position signal pin 30 of the OEM interface harness. | Calibration-dependent power and speed derate.
Accelerator Position Sensor

Circuit Description

The accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command for the RP39 fuel pump rack.

Component Location

The accelerator pedal location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follow:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, Depressed = 200 to 1500 ohms.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 29-Jul-2010


Remote Accelerator Position Sensor

FAULT CODE 133

Remote Accelerator Position Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 029 FMI: 3 LAMP: Red SRT: | Excessive voltage detected at the remote accelerator position signal pin 9 of the original equipment manufacturer's (OEM) interface harness. | Calibration-dependent power and speed derate.
Remote Accelerator Position Sensor

Circuit Description

The remote accelerator pedal provides a second accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal in place of the primary accelerator to determine the fueling command for the RP39 fuel pump rack.

Component Location

The remote accelerator pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

The remote accelerator is used in place of the primary accelerator when the operator signals the ECM by grounding pin 45 on the OEM harness. The remote accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follow:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, Depressed = 200 to 1500 ohms.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Refer to Troubleshooting Fault Code t05-133

Last Modified: 29-Jul-2010


Remote Accelerator Position Sensor (Remote Accelerator)

FAULT CODE 134

Remote Accelerator Position Sensor (Remote Accelerator)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 029 FMI: 4 LAMP: Red SRT: | Low voltage detected at the remote accelerator position signal pin 9 of the original equipment manufacturer's (OEM) interface harness. | Calibration-dependent power and speed derate.
Remote Accelerator Position Sensor

Circuit Description

The remote accelerator pedal provides a second accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal in place of the primary accelerator to determine the fueling command for the RP39 fuel pump rack.

Component Location

The remote accelerator pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

The remote accelerator is used in place of the primary accelerator when the operator signals the ECM by grounding pin 45 on the OEM harness. The accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follow:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, Depressed = 200 to 1500 ohms.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Refer to Troubleshooting Fault Code t05-134

Last Modified: 29-Jul-2010


Oil Pressure Sensor Circuit

FAULT CODE 135

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Yellow SRT: | More than 4.88 VDC detected at the oil pressure sensor signal pin 33 of the engine harness. | Engine protection for oil pressure is disabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM) through pin 33 of the engine harness.

The ECM monitors the voltage on pin 33 and expects to see the voltage vary between 0.5 and 4.5 VDC during normal engine operation.

Voltage above 4.88 VDC on pin 33 will trip Fault Code 135 and can be caused by short circuits in the supply, signal or return wires, an open in the return wire, or a failed sensor.

Component Location

The oil pressure sensor is located on the left side of the engine block to the rear of the fuel pump.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.
  • If Fault Code 143 or 415 is not present, the problem is not base engine related.
Refer to Troubleshooting Fault Code t05-135

Last Modified: 29-Jul-2010


Oil Pressure Sensor Circuit

FAULT CODE 141

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: | Less than 0.31 VDC detected at the oil pressure sensor signal pin 33 of the engine harness. | Engine protection for oil pressure is disabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM) through pin 33 of the engine harness.

The ECM monitors the voltage on pin 33 and expects to see the voltage vary between 0.5 and 4.5 VDC during normal engine operation.

Voltage below 0.31 VDC on pin 33 will trip Fault Code 141 and can be caused by short circuits in the supply, signal or return wires, an open in the supply or signal wires, low supply voltage from the ECM, or a failed sensor.

Component Location

The oil pressure sensor is located on the left side of the engine block to the rear of the fuel pump.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.
  • If Fault Code 143 or 415 is not present, the problem is not base engine related.
Refer to Troubleshooting Fault Code t05-141

Last Modified: 29-Jul-2010


Oil Pressure - Engine Protection

FAULT CODE 143

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1 LAMP: Engine Protection SRT: | Low oil pressure has been detected. Voltage signal at oil pressure signal pin 33 of the engine harness indicates oil pressure lower than 41 kPa [6 psi] at engine speeds less than 600 rpm; 69 kPa [10 psi] at 800 rpm; 241 kPa [35 psi] at engine speeds greater than 1600 rpm. | Depending on calibration, progressive power derate and engine shutdown with increasing time after alert.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this signal voltage to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left bank of the engine block to the rear of the fuel pump.

Shop Talk

  • Confirm that the oil pressure sensor supply voltage is between 4.75 and 5.25 VDC at the sensor. Refer to Fault Code 141.
  • Verify with the driver at what engine speed the fault occurs. If the engine is being operated at too low of a speed under load (lugging), the oil pressure can drop below the engine protection limits because of oil temperature.
  • Oil pressure is a function of engine speed, oil level, and regulator function. Operating the engine at a low speed under load will not cause the oil pressure to be low unless oil is hot, at a low level, regulator has malfunctioned, or a loss is occurring somewhere in the system.

Note: The number of fault lamps could be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains a yellow lamp.

Refer to Troubleshooting Fault Code t05-143

Last Modified: 29-Jul-2010


Coolant Temperature Sensor Circuit

FAULT CODE 144

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Yellow SRT: | More than 4.95 VDC detected at the coolant temperature signal pin 23 of the engine harness. | Possible white smoke. Engine protection for coolant temperature is disabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

The ECM monitors the voltage on pin 23. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC. If the voltage is above 4.95 VDC, then the ECM will log Fault Code 144.

Voltage above 4.95 VDC on pin 23 can be caused by opens in the signal or return wires, or voltage short circuits to the signal or return wires, or a failed open sensor.

Component Location

The coolant temperature sensor is located on the left side of the engine in the thermostat housing.

Shop Talk

The resistance of the sensor varies with the temperature. The reading you observe will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-144

Last Modified: 29-Jul-2010


Coolant Temperature Sensor Circuit

FAULT CODE 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Yellow SRT: | Less than 0.21 VDC detected at the coolant temperature signal pin 23 of the engine harness. | Engine protection for coolant temperature is disabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

The ECM monitors the voltage on pin 23. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC. If the voltage is below 0.21 VDC for more than 2 seconds, then the ECM will log Fault Code 145.

Voltage below 0.21 VDC on pin 23 can be caused by short circuits to ground on the supply or return wires, or an internally grounded, failed sensor.

Component Location

The coolant temperature sensor is located on the left side of the engine in the thermostat housing.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the temperature. The reading you observe will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145

Last Modified: 29-Jul-2010


Frequency Accelerator Circuit

FAULT CODE 147

Frequency Accelerator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 147 PID: P091 SPN: 091 FMI: 8 LAMP: Red SRT: | An excessively low frequency has been detected at frequency accelerator signal pin 14 of the engine harness. | Calibration-dependent power and speed derate.
Frequency Accelerator Circuit

Circuit Description

The accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command for the rack position actuator.

Component Location

The accelerator pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

The frequency accelerator can be used either in conjunction with a voltage accelerator or by itself. The QST30 industrial left-bank engine harness contains a small triangular connector that contains a diode and resistor, Part Number 3659399, which is located about 1 foot from the left-bank ECM. The purpose of this component is for applications that use a frequency accelerator. This component is used in all QST30 industrial left-bank engine harnesses, whether or not the application uses a frequency accelerator.

The frequency accelerator supply signal is generated by the same OEM device, and that signal is sent to the accelerator and/or ECM on pin 14 of the engine harness. Troubleshoot the frequency signal supply device to be sure that the signal is being supplied correctly to the accelerator/ECM.

Refer to Troubleshooting Fault Code t05-147

Last Modified: 29-Jul-2010


Frequency Accelerator Circuit

FAULT CODE 148

Frequency Accelerator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 148 PID: P091 SPN: 091 FMI: 8 LAMP: Red SRT: | An excessively high frequency has been detected at frequency accelerator signal pin 14 of the engine harness. | Calibration-dependent power and speed derate.
Frequency Accelerator Circuit

Circuit Description

The accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command for the rack position actuator.

Component Location

The accelerator pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

The frequency accelerator can be used either in conjunction with a voltage accelerator or by itself. The QST30 industrial left-bank engine harness contains a small triangular connector that contains a diode and resistor, Part Number 3659399, which is located about 1 foot from the left-bank ECM. The purpose of this component is for applications that use a frequency accelerator. This component is used in all QST30 industrial left-bank engine harnesses, whether or not the application uses a frequency accelerator.

The frequency accelerator supply signal is generated by the same OEM device, and that signal is sent to the accelerator and/or ECM on pin 14 of the engine harness. Troubleshoot the frequency signal supply device to be sure that the signal is being supplied correctly to the accelerator/ECM.

Refer to Troubleshooting Fault Code t05-148

Last Modified: 29-Jul-2010


Coolant Temperature - Engine Protection

FAULT CODE 151

Coolant Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Engine Protection SRT: | High coolant temperature has been detected. Voltage signal at coolant temperature signal pin 23 indicates the coolant temperature is above the calibrated value 100°C [212°F]. | Calibration-dependent progressive power and speed derate and engine shutdown as temperature increases over thresholds.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

The ECM monitors the voltage on pin 23. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC.

Component Location

The coolant temperature sensor is located on the left side of the engine in the thermostat housing.

Shop Talk

The signal voltage varies between 0.5 and 4.5 VDC as the internal resistance of the sensor changes due to changing coolant temperature. When the sensor signal voltage indicates a temperature exceeding a set limit, Fault Code 151 is logged.

  • Make sure the airflow through the radiator is not obstructed.
  • The resistance of all the temperature sensors varies with the temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Note: The number of fault lamps could be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains a yellow lamp.

Refer to Troubleshooting Fault Code t05-151

Last Modified: 29-Jul-2010


Intake Manifold Temperature Sensor Circuit

FAULT CODE 153

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Yellow SRT: | More than 4.95 VDC detected at the intake manifold temperature sensor signal pin 34 of the engine harness electronic control module (ECM) connector. | Engine protection for intake manifold air temperature is disabled.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control.

The ECM monitors the voltage on pin 34. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC. If the voltage is above 4.95 VDC, the ECM will log Fault Code 153.

Voltage above 4.95 VDC on pin 34 can be caused by opens in the signal or return wires, voltage short circuits to the signal or return wires, or a failed open sensor.

Component Location

Two intake manifold temperature sensors are used on the QST30 industrial engine, one on each side. The sensors are located in the intake manifold at the rear of the engine.

Shop Talk

The resistance of all the temperature sensors varies with the temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153

Last Modified: 29-Jul-2010


Intake Manifold Temperature Sensor Circuit

FAULT CODE 154

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 FMI: 4 LAMP: Yellow SRT: | Less than 0.05 VDC detected at the intake manifold temperature sensor signal pin 34 of the engine harness electronic control module (ECM) connector. | Engine protection for the intake manifold air temperature is disabled.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold downstream of the aftercooler element. The intake manifold temperature sensor is used by the ECM for the engine protection system and timing and fueling control.

The ECM monitors the voltage on pin 34. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC. If the voltage is below 0.05 VDC, the ECM will log Fault Code 154.

Voltage below 0.05 VDC on pin 34 can be caused by short circuits to ground on the supply or return wires, or an internally grounded, failed sensor.

Component Location

Two intake manifold temperature sensors are used on the QST30 industrial engine, one on each side. The sensors are located in the intake manifold at the rear of the engine.

Shop Talk

The resistance of the sensor varies with the temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154

Last Modified: 29-Jul-2010


Intake Manifold Temperature Sensor - Engine Protection

FAULT CODE 155

Intake Manifold Temperature Sensor - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Engine Protection SRT: | High intake air manifold temperature has been detected. Voltage signal at intake manifold air temperature sensor signal pin 34 indicates intake manifold air temperature above the calibrated value 104°C [219°F]. | Depending on the calibration, a progressive power and speed derate and engine shutdown as the temperature increases over thresholds.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on pin 34. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC.

Component Location

Two intake manifold temperature sensors are used on the QST30 industrial engine, one on each side. The sensors are located in the intake manifold at the rear of the engine.

Shop Talk

The signal voltage varies between 0.5 and 4.5 VDC as the internal resistance of the sensor changes due to changing coolant temperature. When the sensor signal voltage indicates a temperature exceeding a set limit, Fault Code 155 is logged.

The following chart shows resistance of the intake manifold temperature sensor at various temperature readings.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

Note: The number of fault lamps could be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains a yellow lamp.

Refer to Troubleshooting Fault Code t05-155

Last Modified: 29-Jul-2010


Rack Actuator Circuit

FAULT CODE 166

Rack Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 166 PID: S024 SPN: 733 FMI: 3 LAMP: Yellow SRT: | The rack actuator feedback, measured by the electronic control module (ECM), is greater than the calibrated value. | No action is taken by the ECM.
Rack Actuator Circuit

Circuit Description

The rack actuator is supplied with a varying current source from the ECM. The rack actuator uses this current to change the position of the control rack, which regulates the amount of fuel delivered from the fuel pump. The rack position feedback sensor relays the actuator rack position back to the ECM.

Component Location

The rack actuator is an integral part of the RP39 fuel pump.

Shop Talk

  • Confirm that the actuator connector is firmly in place.
  • When there is no power to the actuator, the actuator closes and fuel flow stops.
Refer to Troubleshooting Fault Code t05-166

Last Modified: 29-Jul-2010


Fuel Control Rack Stuck

FAULT CODE 172

Fuel Control Rack Stuck

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 172 PID: S023 SPN: 638 FMI: 7 LAMP: Red SRT: | Fuel control rack is stuck in a position commanding excessive fueling to the engine. | Engine shutdown.
Rack Actuator Circuit

Circuit Description

The fuel control rack and solenoid determine the quantity of fuel metered to the engine.

Component Location

The fuel control rack and solenoid are integral parts of the RP39 fuel pump.

Shop Talk

  • Confirm that the actuator connector is firmly in place.
Refer to Troubleshooting Fault Code t05-172

Last Modified: 19-Feb-2018


Fuel Control Rack Stuck

FAULT CODE 173

Fuel Control Rack Stuck

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 173 PID: S023 SPN: 638 FMI: 7 LAMP: Yellow SRT: | Fuel control rack is stuck in a position providing adequate or less-than-adequate fueling to the engine. | No action is taken by the electronic control module (ECM).
Rack Actuator Circuit

Circuit Description

The fuel control rack and solenoid determine the quantity of fuel metered to the engine.

Component Location

The fuel control rack and solenoid are integral parts of the RP39 fuel pump.

Shop Talk

  • Confirm that the actuator connector is firmly in place.
Refer to Troubleshooting Fault Code t05-173

Last Modified: 29-Jul-2010


Primary/Secondary Electronic Control Modules (ECM) Identification Error

FAULT CODE 184

Primary/Secondary Electronic Control Modules (ECM) Identification Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 184 PID: S233 SPN: 609 FMI: 2 LAMP: Red SRT: | Primary and/or secondary ECM identification error. | Module identification at power-up will fail; both modules will run as secondary ECMs. Possible loss of performance.
Primary/Secondary ECM Identification Error

Circuit Description

The QST30 control system utilizes two ECMs, one primary and one secondary.

Component Location

One ECM is located on both sides of the engine in front of the fuel pumps.

Shop Talk

Identification between primary and secondary modules is done at key-on through the harness. Pins 47 and 48 of the engine harness for each bank provide the determination of primary or secondary. Reference the following table for primary/secondary identification:

ECM Identification | VDC at Pin 47 | VDC at Pin 48
Primary | +5 VDC | 0 VDC
Secondary | 0 VDC | +5 VDC
Refer to Troubleshooting Fault Code t05-184

Last Modified: 29-Jul-2010


Primary Electronic Control Module/Secondary Electronic Control Module (ECM) Communication

FAULT CODE 185

Primary Electronic Control Module/Secondary Electronic Control Module (ECM) Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 185 PID: 231 SPN: 639 FMI: 2 LAMP: Yellow SRT: | Communication between the primary electronic control module (ECM) and secondary ECM has been interrupted. | Engine can only run on the left or right bank. Possible loss of performance.
J1939 Backbone Harness Circuit Diagram

Circuit Description

The QST30 electronic control system utilizes an SAE J1939 backbone harness for communication between the primary and secondary ECMs. If this backbone fails, communication between the ECMs will stop, causing the engine to run poorly.

Component Location

The primary ECM is located on the left bank of the engine, in front of the fuel pump. The secondary ECM is located on the right bank of the engine. The SAE J1939 backbone harness is a separate, three-wire harness located on the engine.

Shop Talk

The secondary ECM receives its fueling and timing commands from the primary ECM.

Refer to Troubleshooting Fault Code t05-185

Last Modified: 27-Jul-2016


Oil Temperature Sensor Circuit

FAULT CODE 212

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the oil temperature signal pin 35 of the engine harness. | No action is taken by the electronic control module (ECM).
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor monitors oil temperature and passes the information to the ECM through the engine harness.

Component Location

The oil temperature sensor is located in the oil pan on the left side of the engine. The oil temperature sensor is only on engines with CENSE™.

Shop Talk

The resistance of the sensor varies with the temperature. Compare the reading that you observe to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-212

Last Modified: 29-Jul-2010


Oil Temperature Sensor Circuit

FAULT CODE 213

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the oil temperature signal pin 35 of the engine harness. | No action is taken by the electronic control module (ECM).
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor monitors oil temperature and passes information to the ECM through the engine harness.

Component Location

The oil temperature sensor is located in the oil pan on the left side of the engine. The oil temperature sensor is only present on engines with CENSE™.

Shop Talk

The resistance of the sensor varies with the temperature. Compare the reading you observe to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-213

Last Modified: 29-Jul-2010


Engine Oil Temperature High - Critical

FAULT CODE 214

Engine Oil Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: FMI: LAMP: Shutdown SRT: | Engine oil temperature has exceeded the alarm (shutdown) threshold for high oil temperature. | Engine will shut down.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the ECM to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition will be incurred, possibly leading to shutdown.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-214

Last Modified: 29-Jul-2010


Low Oil Level Detected in Centinel™ Make Up Tank

FAULT CODE 219

Low Oil Level Detected in Centinel™ Make Up Tank

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 219 PID: P17 SPN: 1380 FMI: LAMP: Warning SRT: | Engine oil level 2 (remote) low - maintenance. Low oil level is detected in the remote oil reservoir used in the Centinel™ system. | Centinel™ system is deactivated.
ECM

Circuit Description

The oil make up tank provides clean oil to the make up valve of the Centinel™ system to replenish oil that was burned by the Centinel™ system.

Component Location

Varies by installation. Refer to Centinel™ Master Repair Manual 3666231 for further information.

Shop Talk

This fault indicates that the oil is low in the makeup tank.

Refer to Troubleshooting Fault Code t05-219

Last Modified: 29-Jul-2010


Ambient Air Pressure Sensor Circuit

FAULT CODE 221

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3 LAMP: Yellow SRT: | More than 4.69 VDC detected at the ambient air pressure sensor signal pin 32 of the engine harness. | No action is taken by the electronic control module (ECM).
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor provides the ambient air pressure signal to the ECM, through the engine harness. The ECM uses the ambient air pressure sensor to adjust fueling based on the altitude.

Component Location

The ambient air pressure sensor is located on the left-hand side of the engine, on the ECM bracket.

Shop Talk

Monitor the ambient air pressure reading with an electronic service tool to confirm that the pressure reading matches the actual air pressure.

Refer to Troubleshooting Fault Code t05-221

Last Modified: 29-Jul-2010


Ambient Air Pressure Sensor Circuit

FAULT CODE 222

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4 LAMP: Yellow SRT: | Less than 0.20 VDC detected at the ambient air pressure sensor signal pin 32 of the engine harness. | No action is taken by the electronic control module (ECM).
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor provides the ambient air pressure signal to the ECM through the engine harness. The ECM uses the ambient air pressure sensor to adjust fueling based on the altitude.

Component Location

The ambient air pressure sensor is located on the left-hand side of the engine, on the ECM bracket.

Shop Talk

Monitor the ambient air pressure reading with an electronic service tool to confirm that the pressure reading matches the actual air pressure.

Refer to Troubleshooting Fault Code t05-222

Last Modified: 29-Jul-2010


Centinel™ Burn Valve Solenoid Circuit - Voltage Incorrect

FAULT CODE 223

Centinel™ Burn Valve Solenoid Circuit - Voltage Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S85 SPN: 1265 FMI: 4 LAMP: Yellow SRT: | The Centinel™ burn valve solenoid circuit is open or shorted. Less than 18.0 VDC detected at the Centinel™ burn valve solenoid supply pin of the engine harness or resistance of the solenoid has dropped below 80 ohms. | ECM turns off the burn valve supply voltage and the Centinel™ system is disabled.
Burn Valve Solenoid Circuit

Circuit Description

The burn valve solenoid controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The burn valve solenoid is located on top of the oil control valve.

Refer to Troubleshooting Fault Code t05-223

Last Modified: 29-Jul-2010


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: SPN: 1075 FMI: 3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source. High voltage or open detected at the fuel lift pump signal circuit. | Engine can be difficult to start.
Electric Lift Pump for Engine Fuel Supply Circuit

Circuit Description

The circuit is a 24 volt high side driver in the ECM that controls the electric lift pump relay for engine fuel supply.

Component Location

The electric lift pump is located on the right bank rear high position or on the left bank front high position.

Shop Talk

  • This fault becomes active if the ECM detects an open circuit at key-on. The cause of this fault code is an open circuit in the electric lift pump for engine fuel supply circuit between the Engine Fuel Supply Signal relay and the ECM connector.
  • If the fault code is intermittent, look for the cause of an intermittent open circuit, such as loose pins or bad connections.
Refer to Troubleshooting Fault Code t05-2265

Last Modified: 29-Jul-2010


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: 73 SPN: 1075 FMI: 4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open detected at the fuel lift pump circuit. | Engine can be difficult to start.
Electric Lift Pump for Engine Fuel Supply Circuit

Circuit Description

The circuit is a 24 volt high side driver in the ECM that controls the electric lift pump relay for engine fuel supply. The lift pump is grounded in the ECM and runs at 100-percent duty cycle for approximately 30 seconds following key-on. The lift pump also runs during start-up and while the engine is running.

Component Location

The electric lift pump is normally located on the right bank rear high position or on the left bank front high position.

Shop Talk

This fault code becomes active if the ECM detects a short circuit to ground or high current in the electric lift pump circuit. Causes for this fault code are a short circuit to ground or low resistance (relay partially shorted).

Refer to Troubleshooting Fault Code t05-2266

Last Modified: 29-Jul-2010


Coolant Pressure Sensor Circuit

FAULT CODE 231

Coolant Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: P109 SPN: 109 FMI: 3 LAMP: Yellow SRT: | More than 4.69 VDC detected at the coolant pressure sensor signal pin 24 of the engine harness. | Engine protection for coolant pressure is disabled.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor monitors coolant pressure and passes information to the electronic control module (ECM) through pin 24 of the engine harness. The ECM monitors the voltage on pin 24 and expects to see the voltage vary between 0.5 and 4.5 VDC during normal engine operation. Voltage above 4.69 VDC on pin 24 will trip Fault Code 231 and can be caused by short circuits in the supply, signal, or return wires, an open in the return wire, or a failed sensor. Voltage below 0.30 VDC on pin 24 will trip Fault Code 232.

Component Location

The coolant pressure sensor is located on the left side of the engine in the thermostat housing.

Shop Talk

  • Confirm that the radiator cap is installed correctly.
  • Check the radiator cap for proper operation.
Refer to Troubleshooting Fault Code t05-231

Last Modified: 29-Jul-2010


Coolant Pressure Sensor Circuit

FAULT CODE 232

Coolant Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: P102 SPN: 102 FMI: 4 LAMP: Yellow SRT: | Less than 0.30 VDC detected at the coolant pressure sensor signal pin 24 of the engine harness. | Engine protection for coolant pressure is disabled.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor monitors coolant pressure and passes information to the electronic control module (ECM) through pin 24 of the engine harness. The ECM monitors the voltage on pin 24 and expects to see the voltage vary between 0.5 and 4.5 VDC during normal engine operation. Voltage below 0.30 VDC on pin 24 will result in Fault Code 232.

Component Location

The coolant pressure sensor is located on the left side of the engine in the thermostat housing.

Shop Talk

  • Confirm that the radiator cap is installed correctly.
  • Check the radiator cap for proper operation.
Refer to Troubleshooting Fault Code t05-232

Last Modified: 29-Jul-2010


Coolant Pressure - Engine Protection

FAULT CODE 233

Coolant Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 233 PID: P109 SPN: 109 FMI: 1 LAMP: Engine Protection SRT: | Low coolant pressure has been detected. Voltage signal at coolant pressure signal pin 24 of the engine harness indicates coolant pressure lower than 28 kPa [4 psi] at 800 rpm; 41 kPa [6 psi] at 1300 rpm; 76 kPa [11 psi] at 1800 rpm; 96 kPa [14 psi] at 2000 rpm; and 103 kPa [15 psi] at 2100 rpm. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the electronic control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The coolant pressure value is used by the ECM for the engine protection system.

Component Location

The coolant pressure sensor is located on the left side of the engine in the thermostat housing.

Shop Talk

  • Confirm that the coolant pressure sensor supply voltage is between 4.75 and 5.25 VDC at the sensor. Refer to Fault Code 232.
  • Verify with the operator at what engine speed the fault occurs. If the engine is being operated at too low a speed under load, the coolant pressure can drop below the engine protection limits.

Note: The number of fault lamps could be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains a yellow lamp.

Refer to Troubleshooting Fault Code t05-233

Last Modified: 29-Jul-2010


Engine Overspeed

FAULT CODE 234

Engine Overspeed

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0 LAMP: Red SRT: | Engine speed signal on pin 17 and/or pin 9 of the engine harness indicated engine speed is greater than the calibrated value (2650 rpm). | The EHAB (fuel shutoff valve) is de-energized (closed). The EHAB (fuel shutoff valve) is reenergized (opened) when engine speed falls below the calibrated value (2130 rpm).
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor monitors the engine position and the engine speed and passes this information to the electronic control module (ECM) through the engine harness.

Component Location

The engine speed sensor and the engine position sensor are located in the flywheel housing.

Shop Talk

  • Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks.
  • Inspect the engine speed sensor for signs of damage or tampering.
Refer to Troubleshooting Fault Code t05-234

Last Modified: 29-Jul-2010


Engine Coolant Level - Engine Protection

FAULT CODE 235

Engine Coolant Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1 LAMP: Engine Protection SRT: | Low coolant level has been detected. Voltage signal on the coolant level signal pin 37 of the engine harness indicates low radiator coolant level on the vehicle. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and will vary in sensor location.

  • When the coolant level drops below a certain level, a power derate, speed derate, or shutdown will be activated.
  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the 4-pin Weather-Pack connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle turns a corner.

Note: The number of fault lamps could be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains a yellow lamp.

Refer to Troubleshooting Fault Code t05-235

Last Modified: 29-Jul-2010


EHAB (Fuel Shutoff Valve) Circuit

FAULT CODE 254

EHAB (Fuel Shutoff Valve) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4 LAMP: Red SRT: | Less than 16.5 VDC detected at fuel shutoff solenoid supply pin 43 of the engine harness. | No action is taken by the electronic control module (ECM). Low voltage to the EHAB will cause it to stop fuel flow to the corresponding pump and shut down that engine bank.
Electrohydraulic Shutoff Device (EHAB) Circuit

Circuit Description

The EHAB (fuel shutoff valve) is a device used by the ECM to stop the fuel supply into the injection pump. The ECM can shut down the engine by cutting off the power to the EHAB (fuel shutoff valve).

Component Location

The EHAB (fuel shutoff valve) is integral to the RP39 fuel pump.

Shop Talk

  • The EHAB (fuel shutoff valve) only stops fuel to the RP39 fuel pump.
  • Inspect the EHAB (fuel shutoff valve) circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit.
  • If there is an external shutdown system on the vehicle that uses the EHAB (fuel shutoff valve) for engine shutdown, make sure it has not failed and lowered the voltage on the EHAB (fuel shutoff valve).
  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry surface.
  • Check the starter solenoid "+" terminal for a loose connector and/or accessory wiring with damaged insulation.
  • Check the module grounding to the block.
  • Using the service tool, Part Number 3163531 (EHAB breakout cable), can be helpful for measuring closed circuit voltages. The EHAB valve requires 16.5 VDC to open.
Refer to Troubleshooting Fault Code t05-254

Last Modified: 29-Jul-2010


EHAB (Fuel Shutoff Valve) Circuit

FAULT CODE 259

EHAB (Fuel Shutoff Valve) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 259 PID: S17 SPN: 632 FMI: 7 LAMP: Red SRT: | EHAB (fuel shutoff valve) is open and will not close. | ECM commands rack position to zero, which stops fueling corresponding engine bank.
Electrohydraulic Shutoff Device (EHAB) Circuit

Circuit Description

The EHAB (fuel shutoff valve) is a device used by the ECM to stop the fuel supply into the injection pump. The ECM can shut down the engine by cutting off the power to the fuel shutoff valve.

Component Location

The EHAB (fuel shutoff valve) solenoid is integral to the RP39 fuel pump.

Shop Talk

  • The EHAB (fuel shutoff valve) solenoid only stops fuel to the RP39 fuel pump.
  • Inspect the EHAB (fuel shutoff valve) supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit.
  • If there is an external shutdown system on the vehicle that uses the EHAB (fuel shutoff valve) for engine shutdown, make sure it has not failed and lowered the voltage on the EHAB (fuel shutoff valve) circuit.
  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry surface.
  • Check the starter solenoid "+" terminal for a loose connector and/or accessory wiring with damaged insulation.
  • Check the module grounding to the block.
Refer to Troubleshooting Fault Code t05-259

Last Modified: 29-Jul-2010


Fuel Temperature High - Warning

FAULT CODE 261

Fuel Temperature High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: FMI: LAMP: Warning SRT: | Engine fuel temperature has exceeded the warning threshold for high fuel temperature. | Calibration-dependent no action is taken by the ECM, or engine shutdown as temperature increases over thresholds.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-261

Last Modified: 29-Jul-2010


Fuel Temperature Sensor Circuit - Shorted High

FAULT CODE 263

Fuel Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: FMI: LAMP: Warning SRT: | Engine fuel temperature sensor signal is shorted high. | No engine protection for fuel temperature. No effect on performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is high, the ECM will log Fault Code 263. High voltage can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-263

Last Modified: 29-Jul-2010


Fuel Temperature Sensor Circuit - Shorted Low

FAULT CODE 265

Fuel Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: FMI: LAMP: Warning SRT: | Engine fuel temperature sensor signal is shorted low. | No engine protection for fuel temperature. No effect on performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low, the ECM will log Fault Code 265. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded, failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-265

Last Modified: 29-Jul-2010


Auxiliary Temperature Sensor Input 1 - Voltage Above Normal, or Shorted to High Source

FAULT CODE 293

Auxiliary Temperature Sensor Input 1 - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 293 PID: P441 SPN: 441 FMI: 3/3 LAMP: Amber SRT: | Voltage detected at the original equipment manufacturer (OEM) auxiliary temperature sensor supply pin of the left bank OEM interface wiring harness indicates the sensor has failed high. | None on performance.
Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The OEM auxiliary temperature sensor supply is used by the engine control module (ECM) to monitor OEM auxiliary temperature. An OEM auxiliary temperature sensor that has failed low can be caused by shorts to ground or opens in the supply and return wires, or an internally grounded sensor.

Component Location

The component location will vary depending on the OEM. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the OEM temperature signal circuit is out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-293

Last Modified: 28-Jan-2020


Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 294

Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 294 PID: P441 SPN: 441 FMI: 4 LAMP: Amber SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source. Voltage detected at the original equipment manufacturer (OEM) auxiliary temperature sensor supply pin of the left bank OEM interface wiring harness indicates the sensor has failed low. | None on performance.
OEM Auxiliary Temperature Sensor Circuit

Circuit Description

The OEM auxiliary temperature sensor supply is used by the engine control module (ECM) to monitor OEM auxiliary temperature. An OEM auxiliary temperature sensor that has failed low can be caused by shorts to ground or opens in the supply and return wires, or an internally grounded sensor.

Component Location

The component location will vary depending on the OEM. See equipment manufacturer service information.

Shop Talk

The resistance of all temperature sensors varies with the temperature. Check the temperature thresholds using INSITE™ electronic service tool for QST Series engines.

Refer to Troubleshooting Fault Code t05-294

Last Modified: 09-Aug-2018


Calibration Match Error

FAULT CODE 342

Calibration Match Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: S253 SPN: 630 FMI: 13 LAMP: Red SRT: | The primary and secondary ECM calibrations do not match. | The engine will not start.
Electronic Control Module (ECM)

Circuit Description

Fault Code 342 indicates that the calibrations in the primary and secondary ECMs are not the same.

Component Location

Two ECMs are aboard the QST30 engine, one on each side.

Shop Talk

This fault code can occur by changing or calibrating a single ECM. Single module calibration is not supported by INSITE™ electronic service tool for CM552 modules on QST30 Industrial engines. Both modules must be calibrated together. Refer to Procedure 019-032 in Section 19.

Refer to Troubleshooting Fault Code t05-342.

Last Modified: 18-Mar-2011


Electronic Control Module (ECM) Internal Communication Error

FAULT CODE 343

Electronic Control Module (ECM) Internal Communication Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | Microprocessor communication error internal to the ECM. | Variable; performance will or will not be affected.
Electronic Control Module (ECM)

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

An ECM is located on both sides of the engine in front of the fuel pump.

Shop Talk

This is a fault with the internal circuitry of the ECM. There are no repairs possible for the module in the field.

Refer to Troubleshooting Fault Code t05-343

Last Modified: 29-Jul-2010


Electronic Control Module (ECM) Power-down Error

FAULT CODE 346

Electronic Control Module (ECM) Power-down Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12 LAMP: Yellow SRT: | ECM power-down internal data store error. | Power-down data (which include maintenance monitoring, present ECM and engine delta times, past fault data) are lost.
Battery Power and Ground Circuit

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

An ECM is located on both sides of the engine in front of the fuel pump.

Shop Talk

  • This is a fault with the internal memory of the ECM. This fault can be caused by a power interruption to the ECM or a loss of battery power.
  • An OEM master disconnect switch can cause this fault if the operator is using the master disconnect to shut the machine off or if the operator is not waiting 30 seconds from key-off until turning the master disconnect switch off. The ECM must go through an internal shutdown sequence before unswitched battery power is removed.
Refer to Troubleshooting Fault Code t05-346

Last Modified: 29-Jul-2010


Oil Pressure - Engine Protection

FAULT CODE 415

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Engine Protection SRT: | Low oil pressure has been detected. Voltage signal at oil pressure signal pin 33 of the engine harness indicates the oil pressure is lower than calibrated limits (less than 34 kPa [5 psi] at engine speeds less than 600 rpm; 207 kPa [30 psi] at engine speeds greater than 1600 rpm). | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after the alert.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left-hand side of the engine block, behind the fuel pump.

Shop Talk

  • Confirm that the oil pressure sensor supply voltage is between 4.75 and 5.25 VDC at the sensor. Refer to Fault Code 141.
  • Verify with the driver at what engine speed the fault occurs. If the engine is being operated at too low a speed under load (lugging), the oil pressure can drop below the engine protection limits because of the oil temperature.
  • Oil pressure is a function of the engine speed, oil level, and regulator function. Operating the engine at a low speed under load will not cause the oil pressure to be low unless the oil is hot at a low level, regulator has malfunctioned, or a loss is occurring somewhere in the system.

Note: The number of fault lamps could be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains a yellow lamp.

Refer to Troubleshooting Fault Code t05-415

Last Modified: 29-Jul-2010


Coolant Level Sensor Circuit

FAULT CODE 422

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2 LAMP: Yellow SRT: | Voltage detected simultaneously on both the coolant level high and low signal pins 27 and 37 of the engine harness, or no voltage detected on either pin. | Engine protection for coolant level is disabled.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and will vary in sensor location.

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the 4-pin Weather-Pack connector and the coolant level sensor for damage.
Refer to Troubleshooting Fault Code t05-422

Last Modified: 29-Jul-2010


Sleeve Actuator Circuit

FAULT CODE 423

Sleeve Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 423 PID: 156 SPN: 156 FMI: 2 LAMP: Yellow SRT: | Unable to achieve the requested pump timing. This fault can be caused by incorrect static pump timing, clogged fuel filters or inlet screen, a stuck timing sleeve, air in the fuel lines, or calibration errors. | No action is taken by the electronic control module. Power output can be low and engine can produce white or black smoke.
Sleeve Actuator Circuit

Circuit Description

The sleeve actuator circuit is used to control the start of injection through pin 6 of the engine harness. The electronic control module monitors the current on pin 6 and expects the amperage to vary between 1.0 and 6.2 amperes during normal engine operation.

Component Location

The sleeve actuator circuit is an integral part of the RP39 fuel pump.

Shop Talk

Increasing the current supplied to the sleeve actuator circuit increases the timing advancement of injection.

A stuck timing sleeve can be the result of fuel contamination.

High fuel inlet restriction and/or low fuel level may cause a low power condition.

Refer to Troubleshooting Fault Code t05-423

Last Modified: 29-Jul-2010


Idle Validation Circuit

FAULT CODE 431

Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: P91 SPN: 091, 607 FMI: 2 or 4 LAMP: Yellow or Red SRT: | Voltage detected simultaneously on both the idle validation off-idle and idle-signal pins 25 and 26 of the OEM interface harness. | None on performance.
Idle Validation Circuit

Circuit Description

The idle validation signal is a feature that disables accelerator control while an improper validation signal is detected by the electronic control module (ECM). The idle validation switch provides an on-idle and off-idle validation signal to the ECM through the OEM harness and OEM interface harness.

Component Location

The accelerator pedal or lever location varies with each OEM. Refer to the OEM manual.

Shop Talk

This fault code is usually caused by the improper wiring of the harnesses and idle validation switch.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (keyswitch in the ON position) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Refer to Troubleshooting Fault Code t05-431

Last Modified: 29-Jul-2010


Accelerator Pedal/Idle Validation Switch Circuit

FAULT CODE 432

Accelerator Pedal/Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: P091 SPN: 091 FMI: 13 LAMP: Red SRT: | Voltage detected at the idle validation on-idle signal pin 26 of the OEM harness when voltage at the accelerator position signal pin 30 of the OEM harness indicates the pedal is not at idle, or voltage detected at idle validation off-idle signal pin 25 of the OEM harness when voltage at accelerator position signal pin 30 of the OEM harness indicates pedal is at rest. | Engine will not respond to accelerator. Engine will idle only.
Accelerator Pedal Circuit

Circuit Description

The accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command for the fuel pump.

Component Location

The accelerator pedal location varies with each OEM. Refer to the OEM manual.

Shop Talk

This fault code is usually caused by the improper wiring of the accelerator circuit, the idle validation circuit, or the OEM harness.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 29-Jul-2010


Unswitched Battery Supply Circuit

FAULT CODE 441

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1 LAMP: Yellow SRT: | Less than 9.0-VDC battery voltage detected at the electronic control module (ECM). | ECM voltage supply approaching a level at which unpredictable operation will occur.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery voltage through the OEM harness and the engine harness. There is an in-line 15-amp fuse in the unswitched battery wires of the engine harness to protect the ECM. The battery return wires in the engine harness are connected to the engine block ground.

Component Location

The location of the battery will vary with the OEM. Refer to the OEM manual for the battery location.

Shop Talk

This fault is usually caused by loose or corroded battery connections.

Refer to Troubleshooting Fault Code t05-441

Last Modified: 29-Jul-2010


Unswitched Battery Supply Circuit

FAULT CODE 442

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0 LAMP: Yellow SRT: | More than 35.0-VDC battery voltage detected at the electronic control module (ECM). | ECM damage will occur.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery voltage through the OEM harness and engine harness. There is an in-line 15-amp fuse in the unswitched battery wire of the OEM interface harness to protect the ECM. The battery return wires in the engine harness are connected to the engine block ground.

Component Location

The location of the battery will vary with the OEM. Refer to the OEM manual for the battery location.

Shop Talk

This fault is usually caused by improper wiring of the battery circuit.

Refer to Troubleshooting Fault Code t05-442

Last Modified: 29-Jul-2010


Alternate Droop Switch Circuit

FAULT CODE 524

Alternate Droop Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 524 PID: P113 SPN: 113 FMI: 2 LAMP: Yellow SRT: | Electronic control module (ECM) has detected an invalid droop selection switch on pin 22 of the engine harness, indicating the value is out of range. | Droop selection is disabled. Droop setting defaults to switch position 1 (or normal) preprogrammed droop governor values.
Alternate Droop Switch Circuit

Circuit Description

The alternate droop switch circuit allows the operator to select from three preprogrammed droop values using a tristate switch.

Component Location

The location of the alternate droop switch circuit varies with each OEM and equipment model. Refer to the OEM manual.

Shop Talk

The switch should be monitored for proper operation on INSITE™. If the switch is changing state correctly on the service tool, then the problem is not in the switch circuit. The switch has three states:

  • Position 1 - open
  • Position 2 - closed
  • Position 3 - 1500-ohm resistance.
Refer to Troubleshooting Fault Code t05-524

Last Modified: 29-Jul-2010


Solenoid A Error

FAULT CODE 527

Solenoid A Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: S040 SPN: P02 FMI: 3 LAMP: Yellow SRT: | Less than 17 VDC detected at solenoid A supply pin 41 of the engine harness. | No action is taken by the electronic control module (ECM).
Solenoid A Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions like a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-527

Last Modified: 29-Jul-2010


Alternate Torque Curve Select Switch Circuit

FAULT CODE 528

Alternate Torque Curve Select Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 528 PID: P093 SPN: 093 FMI: 2 LAMP: Yellow SRT: | The electronic control module (ECM) has detected an invalid value from the alternate torque selection switch at pin 39 of the OEM interface harness, indicating the value is out of range. | Alternate torque selection is disabled. Torque curve setting defaults to switch position 2 (or lowest) preprogrammed torque curve.
Alternate Torque Curve Select Switch Signal Circuit

Circuit Description

The torque curve switch circuit allows the operator to select from three preprogrammed torque curves using a tristate switch.

Component Location

The location of the torque curve switch circuit varies with each OEM and equipment model. Refer to the OEM manual.

Shop Talk

The switch should be monitored for proper operation in INSITE™. If the switch is changing state correctly on the service tool, then the problem is not in the switch circuit. The tristate switch has three states:

  • Position 1 - open
  • Position 2 - closed
  • Position 3 - 1500-ohm resistance.
Refer to Troubleshooting Fault Code t05-528

Last Modified: 29-Jul-2010


Solenoid B Error

FAULT CODE 529

Solenoid B Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: S051 SPN: P02 FMI: 703 LAMP: Yellow SRT: | Less than 17 VDC detected at solenoid B supply pin 21 of the engine harness. | No action is taken by the electronic control module (ECM).
Solenoid B Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, an intake grid heater, an air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device, and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-529

Last Modified: 29-Jul-2010


Idle Validation Circuit

FAULT CODE 551

Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: P91 SPN: 607 FMI: 4 LAMP: Red SRT: | No voltage detected simultaneously on both the idle validation off-idle and idle signal pins 25 and 26 of the OEM harness. | Engine will default to 0 percent throttle.
Idle Validation Circuit

Circuit Description

The idle validation signal is a feature that disables accelerator control while an improper validation signal is detected by the electronic control module (ECM). The idle validation switch provides an on-idle and off-idle validation signal to the ECM through the OEM harness and OEM interface harness.

Component Location

The accelerator pedal or lever location varies with each OEM. Refer to the OEM manual.

Shop Talk

This fault code is usually caused by the improper wiring of the harnesses and idle validation switch. Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Refer to Troubleshooting Fault Code t05-551

Last Modified: 29-Jul-2010


Crankcase Blowby Pressure - Engine Protection

FAULT CODE 555

Crankcase Blowby Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: 101 SPN: 101 FMI: 0 LAMP: Engine Protection SRT: | High crankcase blowby pressure has been detected. Voltage signal at blowby pressure signal pin 25 indicates blowby pressure above 368 mm H2O [14.5 in H2O]. | Calibration-dependent progressive power, speed derate, and engine shutdown as pressure increases over thresholds.
Crankcase Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor is used by the electronic control module (ECM) to monitor the engine crankcase pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The blowby pressure value is used by the ECM for the engine protection system.

Component Location

The blowby pressure sensor is located in the gear case on the left side of the engine.

Shop Talk

  • Confirm that the crankcase breathers and breather tubes are not obstructed.
  • The crankcase blowby pressure sensor is used in conjunction with the CENSE™ engine monitoring system.

Note: The number of fault lamps could be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains a yellow lamp.

Refer to Troubleshooting Fault Code t05-555

Last Modified: 29-Jul-2010


Fuel Supply Pressure Sensor Circuit - Shorted High

FAULT CODE 581

Fuel Supply Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 581 PID: FMI: LAMP: Warning SRT: | Fuel supply pressure sensor circuit - shorted high. | No action taken by the ECM. Possible loss of performance.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The fuel supply pressure sensor provides the fuel pressure supply signal to the electronic control module (ECM). This fault indicates that the signal pin on the ECM has been shorted to at least 5 VDC.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-581

Last Modified: 29-Jul-2010


Fuel Supply Pressure Sensor Circuit - Shorted Low

FAULT CODE 582

Fuel Supply Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 582 PID: FMI: LAMP: Warning SRT: | Fuel supply pressure sensor circuit - shorted low. | No action taken by the ECM. Possible loss of performance.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The fuel supply pressure sensor provides the fuel pressure supply signal to the electronic control module (ECM). This fault indicates that the signal pin on the ECM has been shorted to ground.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-582

Last Modified: 29-Jul-2010


Fuel Pressure Sensor Circuit

FAULT CODE 583

Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 583 PID: P015 FMI: 1/18 LAMP: Yellow SRT: | Fuel Pressure Sensor Circuit. Post filter pressure low - Data valid but below operational range. | Possible hard start, no start, or low power.
Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor provides a signal to the electronic control module (ECM) to monitor fuel delivery pressure directly after the fuel filter, and before it is supplied to the fuel injection pump. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The fuel pressure sensor is located on the outlet of the fuel filter head and before the fuel injection pump on QST30 industrial engines with electric fuel lift pumps. Use the following procedure in Service Manual, QST30, Bulletin 4021539 for fuel pressure sensor location. Refer to Procedure 100-002 in Section E.

Shop Talk

Fault Code 583 only applies to QST30 industrial engines with electric fuel lift pumps and a one-piece wiring harness. The fault code becomes active if fuel pressure at the sensors drops below 103 kPa [15 psi] for 35 seconds.

Low filtered fuel pressure can be caused by one of the following possible causes:

  • High fuel filter restriction (plugged fuel filter)
  • High fuel pre-filter restriction (plugged pre-filter)
  • High fuel supply hose restriction
  • Damaged or malfunctioning fuel lift pump(s)
  • Air in fuel.
Refer to Troubleshooting Fault Code t05-583

Last Modified: 27-Jun-2011


Change Lubricating Oil and Filter

FAULT CODE 649

Change Lubricating Oil and Filter

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: SPN: FMI: LAMP: Warning SRT: | Change lubricating oil and filter. The Centinel system has not been able to replace old oil with new. The condition has persisted long enough that the oil quality warrants a full change out. | No action is taken by the ECM. Possible damage to engine can occur.

Circuit Description

The oil make up tank provides clean oil to the make up valve of the Centinel system to replenish oil that was burned by the Centinel system.

Component Location

Varies by installation. Refer to Centinel Master Repair Manual 3666231 for further information.

Shop Talk

This fault indicates that the old oil has not been replenished with new oil.

Refer to Troubleshooting Fault Code t05-649

Last Modified: 29-Jul-2010


Crankcase Blowby Pressure Sensor Circuit

FAULT CODE 719

Crankcase Blowby Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 719 PID: P101 SPN: 101 FMI: 3 LAMP: Yellow SRT: | More than 4.77 VDC detected at the crankcase blowby pressure sensor signal pin 25 of the engine harness. | Engine protection for crankcase blowby pressure is disabled.
Crankcase Blowby Pressure Sensor Circuit

Circuit Description

The crankcase blowby pressure sensor monitors blowby pressure and passes this information to the electronic control module (ECM) through pin 25 of the engine harness.

The ECM monitors the voltage on pin 25 and expects the voltage to vary between 0.5 and 4.5 VDC during normal engine operation.

Component Location

The blowby pressure sensor is located in the gear case on the left side of the engine.

Shop Talk

  • Confirm that the blowby sensor, crankcase breathers, and breather tubes are not obstructed.
  • The crankcase blowby pressure sensor is used in conjunction with the CENSE™ engine monitoring system.
Refer to Troubleshooting Fault Code t05-719

Last Modified: 29-Jul-2010


Crankcase Blowby Pressure Sensor Circuit

FAULT CODE 729

Crankcase Blowby Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 729 PID: P030 SPN: 101 FMI: 4 LAMP: Yellow SRT: | Less than 0.34 VDC detected at the crankcase blowby pressure sensor signal pin 25 of the engine harness. | Engine protection for crankcase blowby pressure is disabled.
Crankcase Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor monitors blowby pressure and passes this information to the electronic control module (ECM) through pin 25 of the engine harness.

The ECM monitors the voltage on pin 25 and expects to see the voltage vary between 0.5 and 4.5 VDC during normal engine operation.

Voltage below 0.34 VDC on pin 25 will trip Fault Code 729 and can be caused by short circuits in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

The blowby pressure sensor is located in the gear case on the left side of the engine.

Shop Talk

  • Confirm that the blowby sensor, crankcase breathers, and breather tubes are not obstructed.
  • The crankcase blowby pressure sensor is used in conjunction with CENSE™ engine monitoring system.
Refer to Troubleshooting Fault Code t05-729

Last Modified: 29-Jul-2010


Left Bank Needle Lift Sensor Reading Is Not Being Detected or Is Out of Range.

FAULT CODE 772

Left Bank Needle Lift Sensor Reading Is Not Being Detected or Is Out of Range.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 772 PID: S118 SPN: 1657 FMI: 11 LAMP: None SRT: | Left Bank Needle Lift Sensor Reading Is Not Being Detected or Is Out of Range. | No action is taken by the engine control module. Power output can be low and engine can produce white smoke.
Left Bank Needle Lift Sensor

Circuit Description

The needle lift sensor is used to sense the start of injection. The engine control module (ECM) monitors the pulses from the sensor to determine when injection occurs in the cycle. The ECM monitors the pulses on pin 11.

Component Location

The needle lift sensor is an integral part of the NBF injectors (number 1 left bank and number 1 right bank injectors).

Shop Talk

A common cause of a needle lift sensor fault is a loose connection.

The fault code will not become active at engine speed less than 800 RPM.

If the engine is showing either Fault Code 772 or 773 (but not both), then exchange the needle lift injector from the left bank number 1 with the right bank number 1 and see if the fault code follows the damaged injector.

Calibration revisions older than July 2011 will display an amber warning lamp.

Refer to Troubleshooting Fault Code t05-772

Last Modified: 27-Jul-2016


Right Bank Needle Lift Sensor Reading Is Not Being Detected or Is Out of Range.

FAULT CODE 773

Right Bank Needle Lift Sensor Reading Is Not Being Detected or Is Out of Range.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 773 PID: S118 FMI: 11 LAMP: None SRT: | Right Bank Needle Lift Sensor Reading Is Not Being Detected or Is Out of Range. | No action is taken by the engine control module. Power output can be low and engine can produce white smoke.
Right Bank Needle Lift Sensor

Circuit Description

The needle lift sensor is used to sense the start of injection. The engine control module (ECM) monitors the pulses from the sensor to determine when injection occurs in the cycle. The ECM monitors the pulses on pin 11.

Component Location

The needle lift sensor is an integral part of the NBF injectors (number 1 left bank and number 1 right bank injector).

Shop Talk

A common cause of a damaged needle lift sensor is a loose connection.

The fault code will not become active at engine speeds less than 800 rpm.

If the engine is showing either Fault Code 772 or 773 (but not both), then exchange the needle lift injectors from left bank Number 1 with right bank number 1 and see if the fault code follows the damaged injector.

Calibration revisions older than July 2011 will display an amber warning lamp.

Refer to Troubleshooting Fault Code t05-773.

Last Modified: 30-Apr-2012


Multiple Fault Codes on the Engine Harness

FAULT CODE Multiple

Multiple Fault Codes on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple PID: FMI: LAMP: SRT: | Multiple fault codes generated due to a common supply or a return wire failure in the engine harness. | Multiple fault codes.

Multiple Fault Code Circuit

Circuit Description

The electronic control module (ECM) supplies all of the engine pressure sensors on the engine harness with +5 VDC from pin 10. The ECM has common returns for all of the engine pressure sensors and temperature sensors on pin 19. A failure on either of these wires will cause multiple fault codes.

Component Location

Consult the engine diagrams.

Shop Talk

Look for an open circuit in the common supply and return wires and short circuits from battery or ground to the supply and return wires or defective ECM power supply.

A failed pressure sensor can cause multiple fault codes.

A failed pressure sensor can cause multiple active fault codes to go inactive once the engine has been started.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine the set of multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 221, and 719 are not active
 | STEP 1B. Read the fault codes. | Fault Codes 122, 135, 221, 231, and 719 are not active
 | STEP 1C. Read the fault codes. | Fault Codes 123, 141, 145, 154, 213, 222, 232, and 729 are not active
 | STEP 1D. Read the fault codes. | Fault Codes 123, 141, 222, 232, and 729 are not active
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connectors. | No damaged pins
 | STEP 3B. Check for an open circuit. | More than 100k ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connectors. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4E. Check the battery supply voltage. | 17.0 to 35.0 VDC
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the ECM and engine harness connectors. | No damaged pins
 | STEP 5B. Check for an open circuit. | Less than 10 ohms
 | STEP 5C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5E. Check the battery supply voltage. | 17.0 to 35.0 VDC
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Multiple fault codes inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Determine the set of multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, and 719 are not active

Fault Code 122, 135, 144, 153, 221, or 719 is active

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 122, 135, 221, and 719 not active

Fault Code 122, 135, 221, or 719 is active

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 123, 141, 145, 154, 222, 232, and 729 not active

Fault Code 123, 141, 145, 154, 222, 232, or 729 is active

Go to 1D

Go to 4A

Guided Step 1D - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 123, 141, 222, 232, and 729 not active

Fault Code 123, 141, 222, 232, or 729 is active

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.
  • Dry the connector by using an electrical contact cleaner, Part Number 3824510.

Go to 2B

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from the sensor.

Action

  • Measure the resistance from pin 19 in the engine harness connector to pin B on the engine wiring harness side of all sensors with active fault codes.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 or 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the sensors.

Action

  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 6A

Go to 6A

Guided Step 3 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 3A - Inspect the ECM and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the sensors.

Action

  • Measure the resistance from pin 19 of the engine harness connector to pin B of the harness side of all sensors with active fault codes.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 6A

Go to 6A

Guided Step 4 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 4A - Inspect the ECM and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the pressure sensors.

Action

  • Measure the resistance from pin 10 in the engine harness connector to pin A on the engine wiring harness side of a pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4C

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the sensors.

Action

  • Measure the resistance from pin 10 of the engine harness connector to the engine block ground.
  • Measure the resistance from pin 23 of the engine harness connector to the engine block ground.
  • Measure the resistance from pin 34 of the engine harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4D

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the sensors.

Action

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4E

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 4E - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the sensors.

Action

  • Measure the voltage from pin 50 of the engine harness connector to engine block ground.
OK NOT OK

17.0 to 35.0 VDC

Correct battery supply voltage problem.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 5A - Inspect the ECM and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 5B

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 5B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the pressure sensors.

Action

  • Measure the resistance from pin 10 in the engine harness connector to pin A on the engine wiring harness side of all pressure sensors with active fault codes.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 5C

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 5C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the sensors.

Action

  • Measure the resistance from pin 10 of the engine harness connector to the engine block ground.
  • Measure the resistance from pin 23 of the engine harness connector to the engine block ground.
  • Measure the resistance from pin 34 of the engine harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 5D

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the sensors.

Action

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 5E

Go to 6A

Guided Step 5E - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness in the multiple fault code circuit from all the sensors.

Action

  • Measure the voltage from pin 50 of the engine harness connector to engine block ground.
OK NOT OK

17.0 to 35.0 VDC

Correct battery supply voltage problem.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

  • Start the engine and let it idle for 1 minute.
  • Verify that multiple fault codes are inactive.
OK NOT OK

Multiple fault codes inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Oct-2003


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module (ECM) Microprocessor

Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 111 inactive

Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Less than three counts

Replace the ECM. Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 111 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Jul-2012


FAULT CODE 113 - Sleeve Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 113 active
 | STEP 1C. Check for a short circuit between the supply and return wires. | More than 100k ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D-1. Check for a short circuit to ground. |
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 113 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 113 active

Repair complete.

Go to 1C

Go to 2B

Guided Step 1C - Check for a short circuit between the supply and return wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit between the supply and return wires.

  • Measure the resistance from pin 6 to pin 7 of the engine harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 7 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Go to 1E

Go to 1D-1

Guided Step 1D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 7 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel pump.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 7 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 113 is inactive.
OK NOT OK

Fault Code 113 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 114 - Sleeve Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 114 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1C-1. Check for an open circuit. |
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 114 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 114 active

Repair complete.

Go to 1C

Go to 2B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from pin 6 to pin 7 of the engine harness connector.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 1C-1

Guided Step 1C-1 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from pin 6 of the engine harness connector to pin C of the engine harness fuel pump connector.
  • Measure the resistance from pin 7 of the engine harness connector to pin D of the engine harness fuel pump connector.
OK NOT OK

Less than 10 ohms

Replace the fuel pump. Refer to Procedure 005-012 in Section 5 in the Troubleshooting and Repair Manual, QST30 Series Engine, Bulletin 3666217.

Replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 114 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 115 - Engine Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test lead, Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 115 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the engine speed sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 115 active
 | STEP 2C. Check the engine speed sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2D. Check for a signal from the engine speed sensor. | Signal present. Signal should change from 4 to 5 VDC to 0.5 to 2.3 VDC and back every 2.5 degrees of crankshaft rotation
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 115 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 115 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit in the +5-VDC supply wire, signal wire, and return wire.

  • Measure the resistance from pin 8 of the engine harness connector to pin A on the harness side of the engine speed sensor connector.
  • Measure the resistance from pin 18 of the engine harness connector to pin B on the harness side of the engine speed sensor connector.
  • Measure the resistance from pin 17 of the engine harness connector to pin C on the harness side of the engine speed sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Ude the following procedures. Refer to Procedure 019-201 in Section 19
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 8 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 17 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204. in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 8 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 17 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 18 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the engine speed sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Connect the engine harness to the ECM.

Action

Inspect the engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 115 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check the engine speed sensor supply voltage.

Conditions

  • Disconnect the engine harness from the engine speed sensor.
  • Turn keyswitch ON.

Action

Check the engine speed sensor supply voltage.

  • Measure the voltage from pin A to pin B on the harness side of the engine speed sensor connector.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a signal from the engine speed sensor.

Conditions

  • Install breakout cable, Part Number 3824775, between the engine speed sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for a signal from the engine speed sensor.

  • Measure the voltage from pin C to pin B on the breakout cable while barring the engine over.
OK NOT OK

Signal present

Signal should change from 4 to 5 VDC to 0.5 to 2.3 VDC and back every 2.5 degrees of crankshaft rotation.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 115 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jul-2012


FAULT CODE 121 - Engine Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test lead, Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 121 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the engine position sensor. |
 | STEP 2A. Inspect the engine position sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 121 active
 | STEP 2C. Check the engine position sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2D. Check for a signal from the engine position sensor. | Signal present Signal should change from 4 to 5 VDC to 0.5 to 2.3 VDC and back every 60 degrees of crankshaft rotation
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 121 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A on the harness side of the engine position sensor connector.
  • Measure the resistance from pin 19 of the engine harness connector to pin B on the harness side of the engine position sensor connector.
  • Measure the resistance from pin 9 of the engine harness connector to pin C on the harness side of the engine position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Ue the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 9 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 9 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine position sensor.

Guided Step 2A - Inspect the engine position sensor and engine harness connectors.

Conditions

  • Keyswitch in OFF position.
  • Disconnect the engine harness from the engine position sensor.
  • Connect the engine harness to the ECM.

Action

Inspect the engine position sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 121 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check the engine position sensor supply voltage.

Conditions

  • Disconnect the engine harness from the engine position sensor.
  • Turn keyswitch ON.

Action

Check the engine position sensor supply voltage.

  • Measure the voltage from pin A to pin B on the harness side of the engine position sensor connector.
OK NOT OK

4.75 to 5.25 VDC

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a signal from the engine position sensor.

Conditions

  • Install breakout cable, Part Number 3824775, between the engine position sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for a signal from the engine position sensor.

  • Measure the voltage from pin C to pin B on the breakout cable while barring the engine over.
OK NOT OK

Signal present

Signal should change from 4 to 5 VDC to 0.5 to 2.3 VDC and back every 60 degrees of crankshaft rotation

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 121 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jul-2012


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 144, 153, 221, 422, and 719 are not active
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the intake manifold pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 122 active
 | STEP 2C. Check the intake manifold pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the intake manifold pressure sensor supply voltage. |
 | STEP 2C-2. Check for an external voltage source. |
 | STEP 2D. Check the intake manifold pressure sensor signal voltage. | 0.36 to 0.65 VDC
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for an open circuit. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 122 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check the ECM response. | Fault Code 122 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 135, 144, 153, 221, 422, and 719 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the intake manifold pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active

Repair complete.

Go to 2C

4B

Guided Step 2C - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Disconnect the intake manifold pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an external voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an external voltage source.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the intake manifold pressure sensor signal voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor signal voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.36 to 0.65 VDC

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness connector to pin B of the intake manifold pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active

Repair complete.

Go to 3C

4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness connector to pin B on the harness side of the intake manifold pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 45 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM response.

Conditions

  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Turn keyswitch ON.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 123 can become active with the engine harness disconnected.
OK NOT OK

Fault Code 122 inactive

Fault Code 122 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 122 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jul-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 141, 145, 154, 222, 232, and 729 are not active
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the intake manifold pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 123 active
 | STEP 2C. Check the intake manifold pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the intake manifold pressure sensor supply voltage. |
 | STEP 2C-2. Check for an open circuit. |
 | STEP 2C-3. Check for a short circuit to ground. |
 | STEP 2C-4. Check for a short circuit from pin to pin. |
 | STEP 2D. Check the intake manifold pressure sensor signal voltage. | 0.36 to 0.65 VDC
 | STEP 2D-1. Check for a short circuit to ground. |
 | STEP 2D-2. Check for a short circuit from pin to pin. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 123 active
 | STEP 3C. Check for a short circuit to ground. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 141, 145, 154, 222, 232, and 729 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the intake manifold pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B on the intake manifold pressure sensor breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Disconnect the intake manifold pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B on the intake manifold pressure sensor breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A of the intake manifold pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness.Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-3

Go to 4A

Guided Step 2C-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the intake manifold pressure sensor signal voltage.

Conditions

  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor signal voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin C to pin B on the intake manifold pressure sensor breakout cable.
OK NOT OK

0.36 to 0.65 VDC

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 45 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 45 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 45 of the engine harness connector to pin C on the harness side of the intake manifold pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the followng procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 45 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 45 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 123 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jul-2012


FAULT CODE 131 - Accelerator Position Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and accelerator position sensor connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 131 active
 | STEP 1C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 1D. Check for a short circuit. | Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM interface harness and OEM harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 131 active
 | STEP 2C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2D. Check for a short circuit. | Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 131 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check the supply voltage. | 4.75 to 5.25 VDC
 | STEP 3F. Read the fault codes. | Fault Code 131 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and accelerator position sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Inspect the OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal, or the OEM harness, whichever has the damaged pins.

  • Repair the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 131 active

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin C of the accelerator position sensor.

Note: Measure the resistance when the pedal is released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal

Refer to the OEM service manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit.

  • Measure the resistance from pin A to pin B of the accelerator position sensor.

Note: Measure the resistance when the pedal is depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms

Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal

Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM interface harness and OEM harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 131 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin R to pin T of the 21-pin OEM interface harness connector.

Note: Measure the resistance with the accelerator pedal released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the accelerator pedal.

Action

Check for a short circuit.

  • Measure the resistance from pin R to pin S of the 21-pin OEM interface harness connector.

Note: Measure the resistance with the accelerator pedal released and depressed.
OK NOT OK

Released: 1500 to 3000 ohms

Depressed: 200 to 1500 ohms

Repair or replace the OEM harness

Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin R of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors, except pins S and T.
  • Measure the resistance from pin S of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors, except pins R and T.
  • Measure the resistance from pin T of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors, except pins R and S.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 131 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the 50-pin OEM harness connector to pin T of the 21-pin OEM interface harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19 orRefer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Connect the OEM harness to the OEM interface harness at the 21-pin connector.
  • Connect the accelerator position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 29 of the OEM harness connector to all other pins in the connector, except pins 19 and 30, and to all pins in the engine harness connector.
  • Measure the resistance from pin 30 of the OEM harness connector to all other pins in the connector, except pins 19 and 29, and to all pins in the engine harness connector.
  • Measure the resistance from pin 19 of the OEM harness connector to all other pins in the connector, except pins 29 and 30, and to all pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the supply voltage.

Conditions

  • Disconnect the OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage from pin 29 of the OEM harness connector ECM port to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Turn keyswitch ON.

Action

Verify Fault Code 131 is still inactive.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 132 can become active with the 21-pin connector disconnected.
OK NOT OK

Fault Code 131 inactive

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 131 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 132 - Accelerator Position Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and accelerator position sensor connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 132 active
 | STEP 1C. Check for a short circuit. | 2000 to 3000 ohms
 | STEP 1D. Check for an open circuit. | Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM interface harness and OEM harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 132 active
 | STEP 2C. Check for a short circuit. | 2000 to 3000 ohms
 | STEP 2D. Check for an open circuit. | Released: 1500 to 3000 ohmsDepressed: 200 to 1500 ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 132 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and accelerator position sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Inspect the OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

  • Repair the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 132 active

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit.

  • Measure the resistance from pin A to pin C of the accelerator position sensor.

Note: Measure the resistance with the pedal released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 1D

Go to 4A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin B of the accelerator position sensor.

Note: Measure the resistance with the pedal depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.

Repair or replace the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM interface harness and OEM harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 132 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal.

Action

Check for a short circuit.

  • Measure the resistance from pin R to pin T of the 21-pin OEM interface harness connector.

Note: Measure the resistance with the accelerator pedal released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin R to pin S of the 21-pin OEM interface harness connector.

Note: Measure the resistance with the pedal released and depressed.
OK NOT OK

Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin R of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors.
  • Measure the resistance from pin S of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors.
  • Measure the resistance from pin T of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes..
OK NOT OK

Fault Code 132 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the 50-pin OEM harness connector to pin T of the 21-pin OEM interface harness connector, interface harness side.
  • Measure the resistance from pin 29 of the 50-pin OEM harness connector to pin R of the 21-pin OEM interface harness connector, interface harness side.
  • Measure the resistance from pin 30 of the 50-pin OEM harness connector to pin S of the 21-pin OEM interface harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 29 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 30 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 19 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the accelerator pedal harness connector (the connector on the pedal) to engine block ground.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 132 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 133 - Remote Accelerator Position Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and remote accelerator position sensor connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 133 active
 | STEP 1C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 1D. Check for a short circuit. | Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM interface harness and OEM harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 133 active
 | STEP 2C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2D. Check for a short circuit. | Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 133 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check the supply voltage. | 4.75 to 5.25 VDC
 | STEP 3F. Read the fault codes. | Fault Code 133 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the remote accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and remote accelerator position sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator pedal.

Action

Inspect the OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 133 active

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin C of the accelerator position sensor.

Note: Measure the resistance with the pedal released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit.

  • Measure the resistance from pin A to pin B of the accelerator position sensor.

Note: Measure the resistance with the pedal depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms

Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM interface harness and OEM harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 133 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin K to pin M of the 21-pin OEM interface harness connector, interface harness side.

Note: Measure the resistance with the pedal released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal.

Action

Check for a short circuit.

  • Measure the resistance from pin K to pin L of the 21-pin OEM interface harness connector, interface harness side.

Note: Measure the resistance with the pedal released and depressed.
OK NOT OK

Released: 1500 to 3000 ohms

Depressed: 200 to 1500 ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin K of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors.
  • Measure the resistance from pin L of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors.
  • Measure the resistance from pin M of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 133 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 9 of the 50-pin OEM harness connector to pin L of the 21-pin OEM interface harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the OEM harness connector to all other pins in the connector, except pins 9 and 20, and to all pins in the engine harness connector.
  • Measure the resistance from pin 9 of the OEM harness connector to all other pins in the connector, except pins 10 and 20, and to all pins in the engine harness connector.
  • Measure the resistance from pin 20 of the OEM harness connector to all other pins in the connector, except pins 9 and 10, and to all pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the supply voltage.

Conditions

  • Disconnect the OEM interface harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the resistance from pin 10 of the OEM harness connector ECM port to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM Refer to Procedure 019-031 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Turn keyswitch ON.

Action

Verify Fault Code 133 is still inactive.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 134 can become active with the 21-pin connector disconnected.
OK NOT OK

Fault Code 133 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 133 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 134 - Remote Accelerator Position Sensor (Remote Accelerator)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and remote accelerator position sensor connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 134 active
 | STEP 1C. Check for a short circuit. | 2000 to 3000 ohms
 | STEP 1D. Check for an open circuit. | Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM interface harness and OEM harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 134 active
 | STEP 2C. Check for a short circuit. | 2000 to 3000 ohms
 | STEP 2D. Check for an open circuit. | Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms.
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 134 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the remote accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and remote accelerator position sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator pedal.

Action

Inspect the OEM harness and remote accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Repair the OEM harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 134 active

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit.

  • Measure the resistance from pin A to pin C of the accelerator position sensor.

Note: Measure the resistance with the pedal released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 1D

Go to 4A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin B of the accelerator position sensor.

Note: Measure the resistance with the pedal depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms

Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM interface harness and OEM harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 134 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal.

Action

Check for a short circuit.

  • Measure the resistance from pin K to pin M of the 21-pin OEM interface harness connector, interface harness side.

Note: Measure the resistance with the pedal released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin K to pin L of the 21-pin OEM interface harness connector, interface harness side.

Note: Measure the resistance with the pedal released and depressed.
OK NOT OK

Released: 1500 to 3000 ohms

Depressed: 200 to 1500 ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin K of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors, interface harness side.
  • Measure the resistance from pin L of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors, interface harness side.
  • Measure the resistance from pin M of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors, interface harness side.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness connector from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 134 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 9 of the 50-pin OEM harness connector to pin L of the 21-pin OEM interface harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19or Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 9 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 20 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the accelerator pedal.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the OEM harness accelerator pedal connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 134 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 135 - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 144, 153, 422, and 719 are not active
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the oil pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 135 active
 | STEP 2C. Check the oil pressure supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the oil pressure supply voltage. |
 | STEP 2C-2. Check for an external voltage source. |
 | STEP 2D. Check the oil pressure signal voltage. | 0.36 to 0.65 VDC
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for an open circuit. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3C. Read the fault codes. | Fault Code 135 active
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
 | STEP 3E. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3F. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 144, 153, 422, and 719 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the oil pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Inspect the oil pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19..

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 active

Repair complete.

Go to 2C

4B

Guided Step 2C - Check the oil pressure supply voltage.

Conditions

  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the oil pressure supply voltage.

  • Install the oil pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the oil pressure supply voltage.

Conditions

  • Disconnect the oil pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the oil pressure supply voltage.

  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an external voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an external voltage source.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the oil pressure signal voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the oil pressure signal voltage.

  • Install the oil pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.36 to 0.65 VDC

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the OEM connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness connector to pin B of the oil pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19
  • Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes
OK NOT OK

Fault Code 135 active

Repair complete.

Go to 3C

4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A of the oil pressure sensor connector, harness side.
  • Measure the resistance from pin 19 of the engine harness connector to pin B of the oil pressure sensor connector, harness side.
  • Measure the resistance from pin 33 of the engine harness connector to pin C of the oil pressure sensor connector, harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19
  • Refer to Procedure 019-202 in Section 19
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 33 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness connector to engine block ground
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 135 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jul-2012


FAULT CODE 141 - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/™AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 145, 154, 213, 222, 232, and 729 are not active
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the oil pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 141 active
 | STEP 2C. Check the oil pressure supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the oil pressure supply voltage. |
 | STEP 2C-2. Check for an open circuit. |
 | STEP 2C-3. Check for a short circuit to ground. |
 | STEP 2C-4. Check for a short circuit from pin to pin. |
 | STEP 2D. Check the oil pressure signal voltage. | 0.35 to 0.65 VDC
 | STEP 2D-1. Check for a short circuit to ground. |
 | STEP 2D-2. Check for a short circuit from pin to pin. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3C. Read the fault codes. | Fault Code 141 active
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
 | STEP 3E. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3F. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 145, 154, 213, 222, 232, and 729 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the oil pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Inspect the oil pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 active

Repair complete.

Go to 2C

4B

Guided Step 2C - Check the oil pressure supply voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the oil pressure supply voltage.

  • Install the oil pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the oil pressure supply voltage.

Conditions

  • Disconnect the oil pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the oil pressure supply voltage.

  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A of the oil pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202, or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-3

Go to 4A

Guided Step 2C-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the oil pressure signal voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the oil pressure signal voltage.

  • Install the oil pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.36 to 0.65 VDC

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 33 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 active

Repair complete.

Go to 3C

4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 33 of the engine harness connector to pin C of the oil pressure sensor connector, harness side.
  • Measure the resistance from pin 10 of the engine harness connector to pin A of the oil pressure sensor connector, harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 33 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness connector to engine block ground
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 141 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-May-2012


FAULT CODE 143 - Oil Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 143 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ to the vehicle datalink.
  • Start engine and compare the oil pressure reading on the INSITE™ monitor screen to the reading on mechanical oil pressure gauge.

Note: Increase the engine rpm to make it easier to see differences in the readings.
OK NOT OK

Sensor reading is correct. Reference to the Troubleshooting and Repair Manual, QST30 Series Engine, Bulletin 3666217, for correct specification.

Go to 2A

Fault Code 141

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Note: If the fault occurred at a particular rpm, run engine at that rpm to verify the problem is corrected.
OK NOT OK

Fault Code 143 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jul-2012


FAULT CODE 144 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 153, 221, 422, and 719 are not active
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the engine harness and the coolant temperature sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 144 active
 | STEP 2C. Check the resistance of the coolant temperature sensor. | 600 ohms to 36k ohms. Refer to the temperature/resistance table under Shop Talk for correct value
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 144 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 153, 221, 422, and 719 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine harness and coolant temperature sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 144 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance between the two pins on the sensor side of the coolant temperature sensor connection.
OK NOT OK

600 ohms to 36k ohms

Refer to the temperature/resistance table under Shop Talk for correct value

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes
OK NOT OK

Fault Code 144 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness connector to pin A of the coolant temperature sensor connector, engine harness side.
  • Measure the resistance from pin 23 of the engine harness connector to pin B of the coolant temperature sensor connector, engine harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 23 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 144 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Jul-2012


FAULT CODE 145 -Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the engine harness and the coolant temperature sensor connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 145 active
 | STEP 1C. Check the resistance of the coolant temperature sensor. | 600 ohms to 36k ohmsRefer to the temperature/resistance table under Shop Talk for correct value
 | STEP 1D. Check for a short circuit to ground in the coolant temperature sensor. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 145 active
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 145 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant temperature sensor.

Guided Step 1A - Inspect the engine harness and coolant temperature sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance between the two pins on the sensor side of the coolant temperature sensor connector.
OK NOT OK

600 ohms to 36k ohms

Refer to the temperature/resistance table under Shop Talk for correct value

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground in the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to ground in the coolant temperature sensor.

  • Measure the resistance from either pin of the coolant temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor

Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 23 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 23 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 145 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 147 - Frequency Accelerator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and the OEM interface harness connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 147 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 147 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the diode resistor. |
 | STEP 3A. Check the internal resistor resistance. | 950 to 1050 ohms
 | STEP 3B. Perform diode test for a diode resistor. | Less than 0.7 VDC
 | STEP 3C. Perform diode test for a diode resistor. | OL or Open
 | STEP 3D. Perform diode test for a diode resistor. | B to C = OL or Open. C to B = Less than 0.7 VDC.
STEP 4. | Check the OEM frequency signal supply device(s). |
 | STEP 4A. Troubleshoot the OEM frequency signal supply device(s). | Frequency signal supply OK
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 147 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and OEM interface harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 147 active

Repair complete.

Go to 1C

Go to 5B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Connect the frequency accelerator to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the 31-pin OEM harness connector to the corresponding pin of the frequency accelerator connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the 31-pin OEM interface harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 5A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 of the 31-pin OEM interface harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 147 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 14 of the engine harness connector to pin 1 of the 31-pin OEM interface harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 14 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 14 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the diode resistor.

Guided Step 3A - Check the internal resistor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diode resistor, Part Number 3659399, from the left-bank engine harness.

Action

Check the internal resistor resistance.

  • Measure the resistance from pin A to pin B of the diode resistor.
OK NOT OK

950 to 1050 ohms

Replace the diode resistor

Connect new diode resistor to left-bank harness

Go to 3B

Go to 5A

Guided Step 3B - Perform diode test for a diode resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diode resistor, Part Number 3659399, from the left-bank engine harness.

Action

Perform diode test for a diode resistor.

  • Turn the multimeter rotary switch to diode.
  • Insert the negative test lead into pin B.
  • Insert the positive test lead into pin C.
OK NOT OK

Less than 0.7 VDC

Replace the diode resistor

Connect new diode resistor to left-bank harness

Go to 3C

Go to 5A

Guided Step 3C - Perform diode test for a diode resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diode resistor, Part Number 3659399, from the left-bank engine harness.

Action

Perform diode test for a diode resistor.

  • Turn the multimeter rotary switch to diode.
  • Insert the positive test lead into pin B.
  • Insert the negative test lead into pin C.
OK NOT OK

OL or Open

Replace the diode resistor

Connect new diode resistor to left-bank harness

Go to 3D

Go to 5A

Guided Step 3D - Perform diode test for a diode resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diode resistor, Part Number 3659399, from the left-bank engine harness.

Action

Perform diode test for a diode resistor.

  • Turn the multimeter rotary switch to diode.
  • Reversing the position of the test leads from pin B to pin C, and then from pin C to pin B, yields different results.
OK NOT OK

B to C = OL or Open. C to B = Less than 0.7 VDC.

Replace the diode resistor

Connect new diode resistor to left-bank harness

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM frequency signal supply device(s).

Guided Step 4A - Troubleshoot the OEM frequency signal supply device(s).

Conditions

  • Turn keyswitch OFF.

Action

Troubleshoot the OEM frequency signal supply device(s).

Refer to the OEM service manual.
OK NOT OK

Replace the ECM. Refer to Procedure 019-031.

Repair or replace the OEM frequency signal supply device(s). Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 147 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 148 - Frequency Accelerator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a newengine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and OEM interface harness connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 148 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 148 active
 | STEP 2C. Check for an open circuit. | 950 to 1050 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the diode resistor. |
 | STEP 3A. Check the internal resistor resistance. | Less than 10 ohms
 | STEP 3B. Perform diode test for a diode resistor. | Less than 0.7 VDC
 | STEP 3C. Perform diode test for a diode resistor. | OL or “Open”
 | STEP 3D. Perform diode test for a diode resistor. | B to C = OL or “Open”. C to B = Less than 0.7 VDC.
STEP 4. | Check the OEM frequency signal supply device(s). |
 | STEP 4A. Troubleshoot the OEM frequency signal supply device(s). | Frequency signal supply OK
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 148 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and OEM interface harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM harness and the OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 148 active

Repair complete.

Go to 1C

Go to 5B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Connect the frequency accelerator to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the 31-pin OEM harness connector to the corresponding pin of the frequency accelerator connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the 31-pin OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 5A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 of the 31-pin OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 148 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 14 of the engine harness connector to pin 1 of the 31-pin OEM interface harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 14 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 14 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the diode resistor.

Guided Step 3A - Check the internal resistor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diode resistor, Part Number 3659399, from the left-bank engine harness.

Action

Check the internal resistor resistance.

  • Measure the resistance from pin A to pin B of the diode resistor.
OK NOT OK

Less than 10 ohms

Replace the diode resistor

Connect new diode resistor to left-bank harness

Go to 3B

Go to 5A

Guided Step 3B - Perform diode test for a diode resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diode resistor, Part Number 3659399, from the left-bank engine harness.

Action

Perform diode test for a diode resistor.

  • Turn the multimeter rotary switch to diode.
  • Insert the negative test lead into pin B.
  • Insert the positive test lead into pin C.
OK NOT OK

Less than 0.7 VDC

Replace the diode resistor

Connect new diode resistor to left-bank harness

Go to 3C

Go to 5A

Guided Step 3C - Perform diode test for a diode resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diode resistor, Part Number 3659399, from the left-bank engine harness.

Action

Perform diode test for a diode resistor.

  • Turn the multimeter rotary switch to diode.
  • Insert the positive test lead into pin B.
  • Insert the negative test lead into pin C.
OK NOT OK

OL or “Open”

Replace the diode resistor

Connect new diode resistor to left-bank harness

Go to 3D

Go to 5A

Guided Step 3D - Perform diode test for a diode resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diode resistor, Part Number 3659399, from the left-bank engine harness.

Action

Perform diode test for a diode resistor.

  • Turn the multimeter rotary switch to diode.
  • Reversing the position of the test leads from pin B to pin C, and then from pin C to pin B, yields different results.
OK NOT OK

B to C = OL or “Open”. C to B = Less than 0.7 VDC.

Replace the diode resistor

Connect new diode resistor to left-bank harness

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM frequency signal supply device(s).

Guided Step 4A - Troubleshoot the OEM frequency signal supply device(s).

Conditions

  • Turn keyswitch OFF.

Action

Troubleshoot the OEM frequency signal supply device(s).

  • Refer to the OEM service manual.
OK NOT OK

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM frequency signal supply device(s). Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 148 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 151 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ to the vehicle datalink.
  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, then answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 145

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 151 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Jul-2010


FAULT CODE 153 - Intake Manifold Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 221, 422, and 719 are inactive
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the engine harness and intake manifold temperature sensor connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 153 active
 | STEP 2C. Check the resistance of the intake manifold temperature sensor. | 600 ohms to 36k ohms. Refer to the temperature/resistance table under Shop Talk for correct value
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 153 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 221, 422, and 719 are inactive

Fault Code 122, 135, 144, 221, 422, or 719 are active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the harness and intake manifold temperature sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and intake manifold sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 153 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance from pin A to pin B on the sensor side of the intake manifold temperature sensor connection.
OK NOT OK

600 ohms to 36k ohms. Refer to the temperature/resistance table under Shop Talk for correct value

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

in Section 194A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 153 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for an open in the signal and return wires.

  • Measure the resistance from pin 19 of the engine harness connector to pin A of the intake manifold temperature sensor connector, engine harness side.
  • Measure the resistance from pin 34 of the engine harness connector to pin B of the intake manifold temperature sensor connector, engine harness side.
OK NOT OK

Less than 10 ohms

Repair or replace engine harness

  • Repair the engine harness. Use the following procedures.Refer to Procedure 019-201 in Section 19
  • .Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 34 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault
OK NOT OK

Fault Code 153 inactive

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 154 - Intake Manifold Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold temperature sensor. |
 | STEP 1A. Inspect the engine harness and sensor connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 154 active
 | STEP 1C. Check the resistance of the intake manifold temperature sensor. | 600 to 36k ohms. Refer to the temperature/resistance table under Shop Talk for correct value
 | STEP 1D. Check for a short circuit to ground in the intake manifold temperature sensor. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 154 active
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 154 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the intake manifold temperature sensor.

Guided Step 1A - Inspect the engine harness and the sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 154 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance from pin A to pin B on the sensor side of the intake manifold temperature sensor connector.
OK NOT OK

600 to 36k ohms. Refer to the temperature/resistance table under Shop Talk for correct value

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground in the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to ground in the intake manifold temperature sensor.

  • Measure the resistance from either pin of the intake manifold temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 154 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 34 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 34 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 154 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 155 - Intake Manifold Temperature Sensor - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 155 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold temperature sensor.

Note: The probe must extend into the airflow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ to the vehicle datalink.
  • Compare the intake manifold temperature sensor reading on the service tool monitor screen to the reading from temperature probe.

Note: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 154

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it warm up to normal operating temperature to verify that the fault has gone inactive.
OK NOT OK

Fault Code 155 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 166 - Rack Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823254 - male 3-way Metri-Pack™ connector test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rack actuator. |
 | STEP 1A. Inspect the fuel pump and engine harness connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 166 active
 | STEP 1C. Check the rack actuator coil resistance. | 0.7 to 0.9 ohms
 | STEP 1D. Check for a short circuit from pin to pin in the fuel pump harness. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 166 active
 | STEP 2C. Check for an open circuit. | Less than 20 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2F. Check for a short circuit from the return wire to the power supply. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 166 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel pump.

Guided Step 1A - Inspect the fuel pump and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Inspect the fuel pump and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the fuel pump, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Use the following procedures.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the fuel pump connector. Refer to Procedure 005-012 in Section .

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 166 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check the rack actuator coil resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check the rack actuator coil resistance.

  • Measure the resistance from pin G to pin B of the fuel pump connector.
OK NOT OK

0.7 to 0.9 ohms

Replace the fuel pump. Refer to Procedure 005-012 in Section.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin in the fuel pump harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to pin in the fuel pump rack actuator coil.

  • Measure the resistance from pin G of the fuel pump connector to all other pins of the connector, except B.
  • Measure the resistance from pin B of the fuel pump connector to all other pins of the connector, except G.
OK NOT OK

More than 100k ohms

Replace the fuel pump. Refer to Procedure 005-012 in Section 5.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing. Use the following procedures.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 166 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from pin 16 to pin 36 of the engine harness connector.
  • Measure the resistance from pin 26 to pin 36 of the engine harness connector.
  • Measure the resistance from pin 16 to pin 46 of the engine harness connector.
  • Measure the resistance from pin 26 to pin 46 of the engine harness connector.
OK NOT OK

Less than 20 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 36 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 46 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 16 of the engine harness connector to all other pins in the connector, except pin 26, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 26 of the engine harness connector to all other pins in the connector, except pin 16, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 36 of the engine harness connector to all other pins in the connector, except pin 46, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 46 of the engine harness connector to all other pins in the connector, except pin 36, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit from the return wire to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from the return wire to the power supply.

  • Measure the resistance from pin 16 to pin 36 of the engine harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault
OK NOT OK

Fault Code 166 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 172 - Fuel Control Rack Stuck

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 166 active
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 172 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 166 active

Replace the fuel pump. Refer to Procedure 005-012 in Section 5..

Fault Code 166

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault
OK NOT OK

Fault Code 172 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 173 - Fuel Control Rack Stuck

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 166 active
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 173 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 166 active

Replace the fuel pump. Refer to Procedure 005-012 in Section 5.

Fault Code 166

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault.
OK NOT OK

Fault Code 173 inactive

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 2B

Escalate or call for assistance.

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Aug-2018


FAULT CODE 184 - Primary/Secondary Engine Control Modules (ECM) Identification Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a newengine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness at each bank. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 184 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 184 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness at each bank.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 184 active

Repair complete.

Go to 1C

Go to 2B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 47 to pin 10 of the engine harness connector.
  • Measure the resistance from pin 48 to pin 19 of the engine harness connector.

Note: These pin callouts are for the left-bank harness only.

OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 47 of the engine harness connector to engine block ground.

Note: These pin callouts are for the left-bank harness only.

OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 48 of the engine harness connector to all other pins in the connector, except pin 19, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 47 of the engine harness connector to all other pins in the connector, except pin 10, and to all pins in the OEM harness connector.

Note: These pin callouts are for the left-bank harness only.

OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault
OK NOT OK

Fault Code 184 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 185 - Primary Electronic Control Module/Secondary Engine Control Module (ECM) Communication

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the connectors on the primary and secondary ECMs, J1939 backbone harness, and primary and secondary engine harnesses. |
 | STEP 1A. Inspect the primary ECM, primary engine harness, and J1939 backbone harness connectors. | No damaged pins
 | STEP 1B. Inspect the secondary ECM, secondary engine harness, and J1939 backbone harness connectors. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault Code 185 active
STEP 2. | Check the 15-amp fuses in the primary and secondary engine harnesses. |
 | STEP 2A. Inspect the 15-amp fuse in the primary engine harness. | Less than 10 ohms
 | STEP 2B. Inspect the 15-amp fuse in the secondary engine harness. | Less than 10 ohms
STEP 3. | Inspect the SAE J1939 backbone harness. |
 | STEP 3A. Check for an open circuit in the datalink wire. | Less than 10 ohms
 | STEP 3B. Check for an open circuit in the datalink wire. | Less than 10 ohms
 | STEP 3C. Check for proper termination of the harness. | 55 to 65 ohms
 | STEP 3C-1. Check the individual termination connectors. |
 | STEP 3D. Check for an open circuit in the shield wire. | Less than 10 ohms
 | STEP 3E. Check for a short circuit in the datalink wire. | Less than 8.0 VDC
 | STEP 3F. Check for a short circuit in the datalink wire. | Less than 8.0 VDC
 | STEP 3G. Check for a short circuit to ground in the datalink wire. | More than 100k ohms
 | STEP 3H. Check for a short circuit to ground in the datalink wire. | More than 100k ohms
 | STEP 3I. Check for a short circuit from pin to pin in the datalink wire. | More than 100k ohms
STEP 4. | Check primary and secondary ECM communication. |
 | STEP 4A. Check communication with the primary ECM. | Communication established
 | STEP 4B. Check communication with the secondary ECM. | Communication established
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 185 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Inspect the connectors on the primary and secondary ECMs, J1939 backbone harness, and primary and secondary engine harnesses.

Guided Step 1A - Inspect the primary ECM, primary engine harness, and J1939 backbone harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the primary ECM.

Action

Inspect the primary ECM, primary engine harness, and J1939 backbone harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or the J1939 backbone harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the J1939 backbone harness. Refer to Procedure 019-205 in Section 19.
  • Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Inspect the secondary ECM, secondary engine harness, and J1939 backbone harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine harness from the secondary ECM.

Action

Inspect the secondary ECM, secondary engine harness, and J1939 backbone harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or the J1939 backbone harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the J1939 backbone harness. Refer to Procedure 019-205 in Section 19.
  • Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1C

Go to 5A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 185 active

Repair complete.

Go to 2A

Go to 5B

Guided Step 2 - Inspect the 15-amp fuses in the primary and secondary engine harnesses.

Guided Step 2A - Inspect the 15-amp fuse in the primary engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the primary ECM.

Action

Inspect the 15-amp fuse in the primary engine harness.

  • Measure the fuse resistance.
OK NOT OK

Less than 10 ohms

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the 15-amp fuse in the secondary engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine harness from the secondary ECM.

Action

Inspect the 15-amp fuse in the secondary engine harness.

  • Measure the fuse resistance.
OK NOT OK

Less than 10 ohms

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the SAE J1939 backbone harness.

Guided Step 3A - Check for an open circuit in the datalink wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the primary ECM.
  • Disconnect the secondary engine harness from the secondary ECM.

Action

Check the datalink wire resistance.

  • Measure the resistance from pin A of the primary ECM interface connector to pin A of the secondary ECM interface connector.
OK NOT OK

Less than 10 ohms

Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the datalink wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the primary ECM.
  • Disconnect the secondary engine harness from the secondary ECM.

Action

Check the datalink wire resistance.

  • Measure the resistance from pin B of the primary ECM interface connector to pin B of the secondary ECM interface connector.
OK NOT OK

Less than 10 ohms

Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for proper termination of the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the primary ECM.
  • Disconnect the secondary engine harness from the secondary ECM.

Action

Check for proper termination of the harness.

  • Check the resistance across pins A and B in the J1939 backbone harness.
OK NOT OK

55 to 65 ohms

Go to 3D

Go to 3C-1

Guided Step 3C-1 - Check the individual termination connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the primary ECM.
  • Disconnect the secondary engine harness from the secondary ECM.
  • Remove the caps on the termination resistors on the J1939 backbone harness.

Action

Check the individual termination connectors.

  • Measure the resistance across pins A and B on each exposed termination resistor.
OK NOT OK

110 to 130 ohms

Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.

Replace the end cap, Part Number 3163051

Go to 5A

Go to 5A

Guided Step 3D - Check for an open circuit in the shield wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all modules from the J1939 backbone harness.

Action

Check for an open circuit in the shield wire.

  • Measure the resistance from pin C of the J1939 backbone harness to ground.
OK NOT OK

Less than 10 ohms

Inspect the ground on the harness

If the backbone harness is grounded properly to the engine, replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit in the datalink wire.

Conditions

  • Connect the engine harnesses to the primary and secondary ECMs.
  • Turn keyswitch ON.

Action

Check for a short circuit in the datalink wire.

  • Measure the voltage between pin A and pin C of the J1939 backbone harness at the service tool interface.
OK NOT OK

Less than 8.0 VDC

Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check for a short circuit in the datalink wire.

Conditions

  • Connect the engine harnesses to the primary and secondary ECMs.
  • Turn keyswitch ON.

Action

Check for a short circuit in the datalink wire.

  • Measure the voltage between pin B and pin C of the J1939 backbone harness.
OK NOT OK

Less than 8.0 VDC

Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.

Go to 3G

Go to 5A

Guided Step 3G - Check for a short circuit to ground in the datalink wire.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harnesses to the primary and secondary ECMs.

Action

Check for a short circuit to ground in the datalink wire.

  • Measure the resistance from pin A to pin C of the J1939 backbone harness.
OK NOT OK

More than 100k ohms

Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.

Go to 3H

Go to 5A

Guided Step 3H - Check for a short circuit to ground in the datalink wire.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harnesses to the primary and secondary ECMs.

Action

Check for a short circuit to ground in the datalink wire.

  • Measure the resistance from pin B to pin C of the J1939 backbone harness.
OK NOT OK

More than 100k ohms

Replace the J1939 backbone harness. Refer to Procedure 019-174 in Section 19.

Go to 3I

Go to 5A

Guided Step 3I - Check for a short circuit from pin to pin in the datalink wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnesses from the primary and secondary ECMs.
  • Disconnect the engine harness from the J1939 backbone harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 to all other pins of the engine harness connector.
  • Measure the resistance from pin 12 to all other pins of the engine harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check primary and secondary ECM communication.

Guided Step 4A - Check communication with the primary ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check communication with the primary ECM.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to monitor ECM Time .
OK NOT OK

Communication established

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check communication with the secondary ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check communication with the secondary ECM.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to monitor ECM Time, Right-Bank.
OK NOT OK

Communication established

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault
OK NOT OK

Fault Code 185 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 212 - Oil Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 221, 422, and 719 are not active
STEP 2. | Check the oil temperature sensor. |
 | STEP 2A. Inspect the oil temperature sensor and CENSE™ harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 212 active
 | STEP 2C. Check the resistance of the oil temperature sensor. | 600 to 36k ohms
STEP 3. | Check the CENSE™ harness. |
 | STEP 3A. Inspect the CENSE™ harness and engine harness connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 212 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 4B. Read the fault codes. | Fault Code 212 active
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 212 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, 422, and 719 are not active

Go to 2A

Multiple fault code troubleshooting procedure

Guided Step 2 - Check the oil temperature sensor.

Guided Step 2A - Inspect the oil temperature sensor and CENSE™ harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor.

Action

Inspect the oil temperature sensor and CENSE™ harness connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Replace the sensor harness connector or the oil temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the harness connector. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the resistance of the oil temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor.

Action

Check the resistance of the oil temperature sensor.

  • Measure the resistance from pin A and pin B of the oil temperature sensor.
OK NOT OK

600 to 36k ohms

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the CENSE™ harness.

Guided Step 3A - Inspect the CENSE™ harness and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the CENSE™ connector and the engine harness connector.

Action

Inspect the CENSE™ harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 active

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the CENSE™ connector.
  • Disconnect the CENSE™ harness from the oil temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the CENSE™ harness connector to pin A of the oil temperature sensor connector.
  • Measure the resistance from pin 2 of the CENSE™ harness connector to pin B of the oil temperature sensor connector.
OK NOT OK

Less than 10 ohms

Replace the CENSE™ harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the CENSE™ connector.
  • Disconnect the CENSE™ harness from the oil temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 of the CENSE™ harness connector to all other pins in the connector.
  • Measure the resistance from pin 2 of the CENSE™ harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the CENSE™ harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 active

Repair complete.

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for an open circuit in the oil temperature sensor signal and return wires.

  • Measure the resistance from pin 19 of the engine harness connector to pin 2 of the CENSE™ connector.
  • Measure the resistance from pin 35 of the engine harness connector to pin 1 of the CENSE™ connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 212 is inactive.
OK NOT OK

Fault Code 212 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

All faults codes cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 213 - Oil Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new exhaust gas recirculation (EGR, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil temperature sensor. |
 | STEP 1A. Inspect the oil temperature sensor and CENSE™ harness connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 213 active
 | STEP 1C. Check the resistance of the oil temperature sensor. | 600 to 36k ohms
 | STEP 1D. Check for a short circuit to ground in the oil temperature sensor. |
STEP 2. | Check the CENSE™ harness. |
 | STEP 2A. Inspect the CENSE™ and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 213 active
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 213 active
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the oil temperature sensor.

Guided Step 1A - Inspect the oil temperature sensor and CENSE™ harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor.

Action

Inspect the oil temperature sensor and CENSE™ harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Replace the harness connector or oil temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the harness connector. Use the following proceduresRefer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202.
  • Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 213 active

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check the resistance of the oil temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor.

Action

Check the resistance of the oil temperature sensor.

  • Measure the resistance from pin A and pin B of the oil temperature sensor.
OK NOT OK

600 to 36k ohms

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to ground in the oil temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor.

Action

Check for a short circuit to ground in the oil temperature sensor.

  • Measure the resistance from either pin of the oil temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the CENSE™ harness.

Guided Step 2A - Inspect the CENSE™ harness and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the CENSE™ connector and the engine harness connector.

Action

Inspect the CENSE™ connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 213 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the CENSE™ connector.
  • Disconnect the CENSE™ harness from the oil temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the CENSE™ harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the CENSE™ harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the CENSE™ connector.
  • Disconnect the CENSE™ harness from the oil temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 of the CENSE™ harness connector to all other pins in the connector.
  • Measure the resistance from pin 2 of the CENSE™ harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the CENSE™ harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 213 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 35 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 213 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 214 - Engine Oil Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 214 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the temperature probe to the engine near the oil temperature sensor.
  • Connect the electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the oil temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Sensor reading is incorrect

Go to 2A

Fault Code 212

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the electronic service tool.

Action

Read the ECM sensor value.

  • Verify that the fault simulation is not enabled for the oil temperature sensor by connecting to the ECM via the electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 3A

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool, verify that Fault Simulation is not enabled for the oil temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference to Section TS, symptom tree, Lubricating Oil Temperature Above Specification in the Troubleshooting and Repair Manual QSX15, ISX, Signature Base Engine, Bulletin 3666239, Troubleshooting and Repair Manual QSK23 Series Engines, Bulletin 4021375, Troubleshooting and Repair Manual QST30 Series Engines, Bulletin 3666217, Troubleshooting and Repair Manual QSK45 and QSK60 Series Engines, Bulletin 3666261, or Troubleshooting and Repair Manual QSK78 Series Engines, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Run/Stop switch in the Run position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 214 inactive

Return to the troubleshooting steps or contact the nearest authorized repair location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 25-Jul-2012


FAULT CODE 219 - Low Oil Level Detected in Centinel™ Make Up Tank

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

Action

Verify oil level in makeup tank.

Reference the Centinel™ Master Repair Manual, Bulletin 3666231.
OK NOT OK

Oil level is OK.

  • Add oil to the Centinel™ Oil Makeup tank.
  • If the fault remains active with a full Centinel™ Oil Makeup tank, remove and clean the oil level sensor.

Repair Complete

Repair Complete

Last Modified: 25-Jul-2012


FAULT CODE 221 - Ambient Air Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 221, 135, 144, 153, 422, and 719 are not active
STEP 2. | Check the ambient air pressure sensor. |
 | STEP 2A. Inspect the ambient air pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 221 active
 | STEP 2C. Check the ambient air pressure supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the ambient air pressure supply voltage. |
 | STEP 2C-2. Check for an external voltage source. |
 | STEP 2D. Check the ambient air pressure sensor signal voltage. | Altitude [ft] - voltage (VDC): [0] (sea level) - 4.00 to 4.58; [3000] - 3.60 to 4.40; [6000] - 3.20 to 4.00; [9000] - 3.00 to 3.80; [12,000] - 2.60 to 3.40
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for an open circuit. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 221 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 221, 135, 144, 153, 422, and 719 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the ambient air pressure sensor.

Guided Step 2A - Inspect the ambient air pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Inspect the ambient air pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ambient air pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 active

Repair complete.

Go to 2C

4B

Guided Step 2C - Check the ambient air pressure sensor supply voltage.

Conditions

  • Disconnect the engine harness from the ambient air pressure sensor.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor supply voltage.

  • Install the ambient air pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ambient air pressure supply voltage.

Conditions

  • Disconnect the ambient air pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an external voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an external voltage source.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the ambient air pressure sensor signal voltage.

Conditions

  • Disconnect the engine harness from the ambient air pressure sensor.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor signal voltage.

  • Install the ambient air pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

Altitude [ft] - voltage (VDC): [0] (sea level) - 4.00 to 4.58; [3000] - 3.60 to 4.40; [6000] - 3.20 to 4.00; [9000] - 3.00 to 3.80; [12,000] - 2.60 to 3.40.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 32 of the engine harness ECM connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness connector to pin B of the ambient air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 active

Repair complete.

Go to 3C

4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A on the harness side of the sensor connector.
  • Measure the resistance from pin 32 of the engine harness connector to pin C on the harness side of the sensor connector.
  • Measure the resistance from pin 19 of the engine harness connector to pin B on the harness side of the sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 32 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-May-2012


FAULT CODE 222 - Ambient Air Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 154, 213, 232, and 729 are not active
STEP 2. | Check the ambient air pressure sensor. |
 | STEP 2A. Inspect the ambient air pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 222 active
 | STEP 2C. Check the ambient air pressure supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the ambient air pressure supply voltage. |
 | STEP 2C-2. Check for an open circuit. |
 | STEP 2C-3. Check for a short circuit to ground. |
 | STEP 2C-4. Check for a short circuit from pin to pin. |
 | STEP 2D. Check the ambient air pressure sensor signal voltage. | Altitude [ft] - voltage (VDC)0 (sea level) - 4.00 to 4.583000 - 3.60 to 4.406000 - 3.20 to 4.009000 - 3.00 to 3.8012,000 - 2.60 to 3.40
 | STEP 2D-1. Check for an open circuit. |
 | STEP 2D-2. Check for a short circuit to ground. |
 | STEP 2D-3. Check for a short circuit from pin to pin. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 222 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 145, 154, 213, 232, and 729 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the ambient air pressure sensor.

Guided Step 2A - Inspect the ambient air pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Inspect the ambient air pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ambient air pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 active

Repair complete.

Go to 2C

4B

Guided Step 2C - Check the ambient air pressure sensor supply voltage.

Conditions

  • Disconnect the engine harness from the ambient air pressure sensor.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor supply voltage.

  • Install the ambient air pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ambient air pressure supply voltage.

Conditions

  • Disconnect the ambient air pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A of the ambient air pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-3

Go to 4A

Guided Step 2C-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the ambient air pressure sensor signal voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor signal voltage.

  • Install the ambient air pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

Altitude [ft] - voltage (VDC): [0] (sea level) - 4.00 to 4.58; [3000] - 3.60 to 4.40; [6000] - 3.20 to 4.00; [9000] - 3.00 to 3.80; [12,000] - 2.60 to 3.40

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 32 of the engine harness connector to pin C of the ambient air pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 32 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 4A

Guided Step 2D-3 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 32 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 active

Repair complete.

Go to 3C

4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A on the harness side of the sensor connector.
  • Measure the resistance from pin 32 of the engine harness connector to pin C on the harness side of the sensor connector.
  • Measure the resistance from pin 19 of the engine harness connector to pin B on the harness side of the sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 32 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 32 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-May-2012


FAULT CODE 223 - Centinel™ Burn Valve Solenoid Circuit - Voltage Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead Part Number 3823995 - male Weather-Pack™ test lead Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the burn valve solenoid. |
 | STEP 1A. Verify the burn valve solenoid is connected to the engine harness. | Solenoid is connected
 | STEP 1B. Inspect the burn valve solenoid and harness connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | Less than 120 ohms
 | STEP 1D. Check short circuit to engine block ground. | More than 80 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and extension harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and engine control module (ECM) connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 225 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the burn valve solenoid.

Guided Step 1A - Verify the burn valve solenoid is connected to the engine harness.

Conditions

  • Run/Stop switch in the Stop position.

Action

Verify the burn valve solenoid is connected to the engine harness.
OK NOT OK

Solenoid is connected

Connect the solenoid to the engine harness

Go to 1B

Go to 4A

Guided Step 1B - Inspect the burn valve solenoid and harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the burn valve solenoid.

Action

Inspect the burn valve solenoid and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the burn valve solenoid from the engine harness.

Action

Check for an open circuit in the burn valve solenoid.

  • Measure the resistance from pin A to pin B of the burn valve solenoid connector.
OK NOT OK

Less than 120 ohms

Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to engine block ground.

Conditions

  • Disconnect the engine harness from the burn solenoid valve.

Action

Check for a short circuit to ground in the burn valve solenoid.

  • Measure the resistance from pin A of the burn solenoid connector to engine block ground.
OK NOT OK

More than 80 ohms

Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and extension harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the burn valve solenoid from the engine harness.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit in the burn valve solenoid circuit.

  • Measure the resistance from the Centinel™ actuator +5 VDC supply pin on the engine harness inline connector to the Centinel™ actuator +5 VDC supply pin at the engine harness solenoid connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the burn valve solenoid from the engine harness.
  • Disconnect the engine harness from the extension harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the Centinel™ actuator +5 VDC supply pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the burn valve solenoid.
  • Disconnect the engine harness from the extension harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Centinel™ actuator +5 VDC supply pin on the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and ECM connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the ECM.

Action

Check for an open circuit in the burn valve solenoid circuit.

  • Measure the resistance from the Centinel™ actuator +5 VDC supply pin on the extension harness ECM connector to the Centinel™ actuator +5 VDC supply pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the Centinel™ actuator +5 VDC supply pin on the extension harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Centinel™ actuator +5 VDC supply pin on the extension harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Run/Stop switch in the Run position.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 223 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Run/Stop switch in the Run position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 231 - Coolant Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 221, 422, and 719 are not active
STEP 2. | Check the coolant pressure sensor. |
 | STEP 2A. Inspect the coolant pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 122 active
 | STEP 2C. Check the coolant pressure supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the coolant pressure supply voltage. |
 | STEP 2C-2. Check for an external voltage source. |
 | STEP 2D. Check the coolant pressure sensor signal voltage. | 0.32 to 0.69 VDC
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for an open circuit. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 122 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 231 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, 422, and 719 are not active

Fault Code 122, 135, 144, 153, 221, 422, or 719 are active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the coolant pressure sensor.

Guided Step 2A - Inspect the coolant pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Inspect the coolant pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active

Repair complete.

Go to 2C

4B

Guided Step 2C - Check the coolant pressure supply voltage.

Conditions

  • Disconnect the engine harness from the coolant pressure sensor.
  • Turn keyswitch ON.

Action

Check the coolant pressure sensor supply voltage.

  • Install the coolant pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Above or below 4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the coolant pressure supply voltage.

Conditions

  • Disconnect the coolant pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the coolant pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Above or below 4.75 to 5.25 VDC

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an external voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an external voltage source.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the coolant pressure sensor signal voltage.

Conditions

  • Disconnect the engine harness from the coolant pressure sensor.
  • Turn keyswitch ON.

Action

Check the coolant pressure sensor signal voltage.

  • Install the coolant pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.32 to 0.69 VDC

Above or below 0.32 to 0.69 VDC

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 24 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness connector to pin B of the coolant pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active

Repair complete.

Go to 3C

4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness connector to pin B of the coolant pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 24 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 231 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

All faults codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 232 - Coolant Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 422, and 719 are not active
STEP 2. | Check the coolant pressure sensor. |
 | STEP 2A. Inspect the coolant pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 232 active
 | STEP 2C. Check the coolant pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the coolant pressure sensor supply voltage. |
 | STEP 2C-2. Check for an open circuit. |
 | STEP 2C-3. Check for a short circuit to ground. |
 | STEP 2C-4. Check for a short circuit from pin to pin. |
 | STEP 2D. Check the coolant pressure sensor signal voltage. | 0.36 to 0.65 VDC
 | STEP 2D-1. Check for an open circuit. |
 | STEP 2D-2. Check for a short circuit to ground. |
 | STEP 2D-3. Check for a short circuit from pin to pin. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 232 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 232 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 422, and 719 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the coolant pressure sensor.

Guided Step 2A - Inspect the coolant pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Inspect the coolant pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins.

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 232 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check the coolant pressure sensor supply voltage.

Conditions

  • Disconnect the engine harness from the coolant pressure sensor.
  • Turn keyswitch ON.

Action

Check the coolant pressure sensor supply voltage.

  • Install the coolant pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B on the coolant pressure sensor breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the coolant pressure sensor supply voltage.

Conditions

  • Disconnect the coolant pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the coolant pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B on the coolant pressure sensor breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A of the coolant pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-3

Go to 4A

Guided Step 2C-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the coolant pressure sensor signal voltage.

Conditions

  • Disconnect the engine harness from the coolant pressure sensor.
  • Turn keyswitch ON.

Action

Check the coolant pressure sensor signal voltage.

  • Install the coolant pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the from pin C to pin B on the coolant pressure sensor breakout cable.
OK NOT OK

0.36 to 0.65 VDC

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 24 of the engine harness connector to pin C of the coolant pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 24 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 4A

Guided Step 2D-3 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 24 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the coolant pressure sensor. Refer to Procedure 019-016.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 232 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 24 of the engine harness connector to pin C of the coolant pressure sensor harness connector.
  • Measure the resistance from pin 10 of the engine harness connector to pin A of the coolant pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 24 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 24 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 232 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 233 - Coolant Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 233 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify sensor accuracy with a mechanical gauge.

  • Connect a mechanical pressure gauge to the engine.
  • Connect INSITE™ to the vehicle datalink.
  • Start engine and compare the coolant pressure reading on service tool monitor screen to reading on mechanical pressure gauge.

Note: Rev up the engine to make it easier to see differences in the readings.
OK NOT OK

Sensor reading is correct. Reference the Troubleshooting and Repair Manual, QST30 Series Engine, Bulletin 3666217.

Go to 2A

Fault Code 232

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

Note: If fault occurred at a particular speed, run engine at that speed to verify problem is corrected.
OK NOT OK

Fault Code 233 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 234 - Engine Overspeed

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2650 rpm, the engine must be shut off immediately. The engine will be damaged.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Not motoring downhill
 | STEP 1B. Check for an alternate fuel source. | No alternate fuel source
 | STEP 1C. Check the engine rpm with the monitor mode. | Correct rpm reading
 | STEP 1D. Check for an active fault code at low engine rpm. | Inactive fault at low rpm
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.
OK NOT OK

Not motoring downhill

Check the engine for damage

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check with the operator to see if he reported a fuel-controlled event where the engine rapidly accelerated to or past 2650 rpm, followed by moderate deceleration to 2130 rpm.
OK NOT OK

No alternate fuel source

Locate the alternate fuel source

  • Locate and remove any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

Go to 1C

Go to 2A

Guided Step 1C - Check the engine rpm with the monitor mode.

Conditions

  • Turn keyswitch ON.

Action

Check the engine rpm with the monitor mode.

  • Monitor the engine rpm using INSITE™.
OK NOT OK

Correct rpm reading

Inspect engine speed sensor

  • Check the engine speed sensor as outlined for Fault Codes 115 and 121.

Go to 1D

Fault Codes 115 and 121

Guided Step 1D - Check for an active fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active fault code at low engine rpm.

  • Check for active Fault Code 234 when the engine is not running above 2650 rpm.
OK NOT OK

Inactive fault at the low rpm

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle.

  • Check if the overspeed condition is still present.
OK NOT OK

Fault Code 234 inactive

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 234 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 235 - Engine Coolant Level - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

Do not add cold coolant to a hot engine. Castings can be damaged. Allow engine to cool to below 50°C [120°F] before adding coolant.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the coolant is low. |
 | STEP 1A. Check the coolant level. | Coolant level is normal
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault code is still active with engine running. | Fault Code 235 active
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 235 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify that the coolant is low.

Guided Step 1A - Check the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level is normal

Add coolant to the radiator. Refer to Procedure 008-018 in Section 8.

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Confirm the fault code is still active with the engine running.

Conditions

  • Turn keyswitch ON.

Action

Confirm the fault code is still active with the engine running.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 235 active

Replace coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 235 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 254 - EHAB (Fuel Shutoff Valve) Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3163531 - EHAB breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EHAB (fuel shutoff valve). |
 | STEP 1A. Check for extra wires spliced into the EHAB circuit. | No extra wires
 | STEP 1B. Inspect the engine harness and EHAB (fuel shutoff valve) connectors. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault Code 254 active
 | STEP 1D. Check the EHAB (fuel shutoff valve) supply voltage. | More than 16.5 VDC
 | STEP 1E. Check the EHAB (fuel shutoff valve) supply voltage. | More than 16.5 VDC
 | STEP 1E-1. Check for an open circuit. |
 | STEP 1E-2. Check for a short circuit to ground. |
 | STEP 1E-3. Check for a short circuit from pin to pin. |
 | STEP 1E-4. Check the ECM output voltage of pin 43. |
 | STEP 1F. Check the EHAB (fuel shutoff valve) resistance. | 38.5 to 43.5 ohms for 24-VDC solenoids
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 254 active
 | STEP 2C. Check the supply voltage to the ECM. | More than 17.0 VDC
 | STEP 2C-1. Check the in-line fuse. |
 | STEP 2C-2. Check for an open circuit. |
 | STEP 2C-3. Check for a short circuit to ground. |
 | STEP 2C-4. Check for a short circuit from pin to pin. |
 | STEP 2D. Check the keyswitch voltage at the ECM. | More than 17.0 VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 254 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the EHAB (fuel shutoff valve).

Guided Step 1A - Check for extra wires spliced into the EHAB circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires spliced into the EHAB circuit.
OK NOT OK

No extra wires

Remove the extra wires

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine harness and EHAB (fuel shutoff valve) connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Inspect the engine harness and EHAB (fuel shutoff valve) connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the EHAB, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the EHAB (fuel shutoff valve). Refer to Procedure 005-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 254 active

Repair complete.

Go to 1D

Go to 3B

Guided Step 1D - Check the EHAB (fuel shutoff valve) supply voltage.

Conditions

  • Disconnect the engine harness from the EHAB (fuel shutoff valve).
  • Turn keyswitch ON.

Action

Check the EHAB (fuel shutoff valve) supply voltage.

  • Install breakout cable, Part Number 3163531, between the EHAB (fuel shutoff valve) and the engine harness.
  • Measure the voltage from the red test lead of the breakout cable to the black test lead.
OK NOT OK

More than 16.5 VDC

Less than 16.5 VDC.

Go to 1F

Go to 1E

Guided Step 1E - Check the EHAB (fuel shutoff valve) supply voltage.

Conditions

  • Disconnect the engine harness from the EHAB (fuel shutoff valve).
  • Disconnect breakout cable, Part Number 3163531, from the EHAB (fuel shutoff valve) and engine harness.
  • Turn keyswitch ON.

Action

Check the EHAB (fuel shutoff valve) supply voltage.

  • Measure the voltage from pin 2 of the engine harness EHAB (fuel shutoff valve) connector to engine block ground.
OK NOT OK

More than 16.5 VDC

Replace the EHAB (fuel shutoff valve). Refer to Procedure 005-043 in Section 5.

Go to 4A

Go to 1E-1

Guided Step 1E-1 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Check for an open circuit.

  • Measure the resistance from pin 2 of the engine harness EHAB (fuel shutoff valve) connector to pin 43 of the engine harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E-2

Go to 3A

Guided Step 1E-2 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 43 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E-3

Go to 3A

Guided Step 1E-3 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the original equipment manufacturer (OEM) harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 43 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E-4

Go to 3A

Guided Step 1E-4 - Verify ECM output voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM output voltage of pin 43.

  • Measure the voltage form ECM pin 43 to engine block ground.
OK NOT OK

  • More than 16.5 VDC.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1F

Go to 3A

Guided Step 1F - Check the EHAB (fuel shutoff valve) resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Check the EHAB (fuel shutoff valve) resistance.

  • Measure the resistance from pin 2 to pin 1 on the sensor side of the connector.
OK NOT OK

38.5 to 43.5 ohms for 24-VDC solenoids

Replace the EHAB (fuel shutoff valve).

Refer to Procedure 005-043 in Section 5..

Go to 3A

Go to 2A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 254 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check the supply voltage to the ECM.

Conditions

  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).
  • Turn keyswitch ON.

Action

Check the supply voltage to the ECM.

  • Measure the voltage from pin 38 of the engine harness connector ECM port to engine block ground.
OK NOT OK

More than 17.0 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the in-line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the in-line fuse from the engine harness.

Action

Check the in-line fuse.

  • Measure the resistance across the fuse.
OK NOT OK

Less than 10 ohms

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C-2

Go to 3A

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 38 of the engine harness connector to pin G of the 21-pin OEM harness connector.
  • Measure the resistance from pin 39 of the engine harness connector to pin G of the 21-pin OEM harness connector.
  • Measure the resistance from pin 40 of the engine harness connector to pin G of the 21-pin OEM harness connector.
  • Measure the resistance from pin 50 of the engine harness connector to pin G of the 21-pin OEM harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-208 in Section 19 .
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-3

Go to 3A

Guided Step 2C-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 38 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-4

Go to 3A

Guided Step 2C-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 38 of the engine harness connector to all other pins in the connector, except pins 39, 40, and 50.
  • Measure the resistance from pin 38 of the engine harness connector to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Correct OEM power supply.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 2D - Check the keyswitch voltage at the ECM.

Conditions

  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).
  • Turn keyswitch ON.

Action

Check the keyswitch voltage at the ECM.

  • Measure the voltage from pin 5 of the engine harness connector to engine block ground.
OK NOT OK

More than 17.0 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Check the OEM keyswitch circuit

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 254 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 259 - EHAB (Fuel Shutoff Valve) Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3163531 - EHAB breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EHAB (fuel shutoff valve). |
 | STEP 1A. Check for extra wires spliced into the EHAB circuit. | No extra wires
 | STEP 1B. Inspect the engine harness and EHAB (fuel shutoff valve) connectors. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault Code 259 active
 | STEP 1D. Check the EHAB (fuel shutoff valve) supply voltage. | More than 16.5 VDC
 | STEP 1E. Check the EHAB (fuel shutoff valve) supply voltage. | More than 16.5 VDC
 | STEP 1E-1. Check for an open circuit. |
 | STEP 1E-2. Check for a short circuit to ground. |
 | STEP 1E-3. Check for a short circuit from pin to pin. |
 | STEP 1F. Check the EHAB (fuel shutoff valve) resistance. | 38.5 to 43.5 ohms for 24-VDC solenoids
 | STEP 1G. Check the operation of the EHAB (fuel shutoff valve). | Click heard
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 259 active
 | STEP 2C. Check the supply voltage to the ECM. | More than 17.0 VDC
 | STEP 2C-1. Check the in-line fuse. |
 | STEP 2C-2. Check for an open circuit. |
 | STEP 2C-3. Check for a short circuit to ground. |
 | STEP 2C-4. Check for a short circuit from pin to pin. |
 | STEP 2D. Check the keyswitch voltage at the ECM. | More than 17.0 VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 259 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the EHAB (fuel shutoff valve).

Guided Step 1A - Check for extra wires spliced into the EHAB circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires spliced into the EHAB circuit.
OK NOT OK

No extra wires

Remove the extra wires

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine harness and EHAB (fuel shutoff valve) connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Inspect the engine harness and EHAB (fuel shutoff valve) connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the EHAB, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the EHAB (fuel shutoff valve). Refer to Procedure 005-043 in Section 5.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 259 active

Repair complete.

Go to 1D

Go to 3B

Guided Step 1D - Check the EHAB (fuel shutoff valve) supply voltage.

Conditions

  • Disconnect the engine harness from the EHAB (fuel shutoff valve).
  • Turn keyswitch ON.

Action

Check the EHAB (fuel shutoff valve) supply voltage.

  • Install breakout cable, Part Number 3163531, between the EHAB (fuel shutoff valve) and the engine harness.
  • Measure the voltage from the red test lead of the breakout cable to the black test lead.
OK NOT OK

More than 16.5 VDC

Less than 16.5 VDC.

Go to 1F

Go to 1E

Guided Step 1E - Check the EHAB (fuel shutoff valve) supply voltage.

Conditions

  • Disconnect the engine harness from the EHAB (fuel shutoff valve).
  • Disconnect breakout cable, Part Number 3163531, from the EHAB (fuel shutoff valve) and engine harness.
  • Turn keyswitch ON.

Action

Check the EHAB (fuel shutoff valve) supply voltage.

  • Measure the voltage from pin 2 of the engine harness EHAB (fuel shutoff valve) connector to engine block ground.
OK NOT OK

More than 16.5 VDC

Replace the EHAB (fuel shutoff valve). Refer to Procedure 005-043 in Section 5.

Go to 3A

Go to 1E-1

Guided Step 1E-1 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Check for an open circuit.

  • Measure the resistance from pin 2 of the engine harness EHAB (fuel shutoff valve) connector to pin 43 of the engine harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E-2

Go to 3A

Guided Step 1E-2 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 43 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E-3

Go to 3A

Guided Step 1E-3 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 43 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 1F - Check the EHAB (fuel shutoff valve) resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).

Action

Check the EHAB (fuel shutoff valve) resistance.

  • Measure the resistance from pin 2 to pin 1 on the sensor side of the connector.
OK NOT OK

38.5 to 43.5 ohms for 24-VDC solenoids

Replace the EHAB (fuel shutoff valve)

Refer to Procedure 005-043 in Section 5.

Go to 1G

Go to 3A

Guided Step 1G - Check the operation of the EHAB (fuel shutoff valve).

Conditions

  • Turn the keyswitch OFF.

Action

Perform the EHAB click test to check the operation of the EHAB.

  • Refer to Procedure 005-083 in Section 5
OK NOT OK

Click heard

Replace the EHAB (fuel shutoff valve)

Refer to Procedure 005-043 in Section 5.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes
OK NOT OK

Fault Code 259 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check the supply voltage to the ECM.

Conditions

  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).
  • Turn keyswitch ON.

Action

Check the supply voltage to the ECM.

  • Measure the voltage from pin 38 of the engine harness connector ECM port to engine block ground.
OK NOT OK

More than 17.0 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the in-line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the in-line fuse from the engine harness.

Action

Check the in-ine fuse.

  • Measure the resistance across the fuse.
OK NOT OK

Less than 10 ohms

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C-2

Go to 3A

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 38 of the engine harness connector to pin G of the 21-pin OEM harness connector.
  • Measure the resistance from pin 39 of the engine harness connector to pin G of the 21-pin OEM harness connector.
  • Measure the resistance from pin 40 of the engine harness connector to pin G of the 21-pin OEM harness connector.
  • Measure the resistance from pin 50 of the engine harness connector to pin G of the 21-pin OEM harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-3

Go to 3A

Guided Step 2C-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 38 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-4

Go to 3A

Guided Step 2C-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 38 of the engine harness connector to all other pins in the connector, except pins 39, 40, and 50.
  • Measure the resistance from pin 38 of the engine harness connector to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Correct OEM power supply.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 2D - Check the keyswitch voltage at the ECM.

Conditions

  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EHAB (fuel shutoff valve).
  • Turn keyswitch ON.

Action

Check the keyswitch voltage at the ECM.

  • Measure the voltage from pin 5 of the engine harness connector to engine block ground.
OK NOT OK

More than 17.0 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Check the OEM keyswitch circuit

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 259 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 261 - Fuel Temperature High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 261 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect the electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the fuel temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 263

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the electronic service tool.

Action

Read the ECM sensor value.

  • Verify that the fault simulation is not enabled for the fuel temperature sensor by connecting to the ECM via the electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the electronic service tool.

Action

Read the ECM.

  • Using the electronic service tool, verify that Fault Simulation is not enabled for the fuel temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference the Section TS, symptom tree T057 in the Troubleshooting and Repair Manual QSX15, ISX, Signature Base Engine, Bulletin 3666239, Troubleshooting and Repair Manual QSK23 Series Engines, Bulletin 4021375, Troubleshooting and Repair Manual QST30 Series Engines, Bulletin 3666217, Troubleshooting and Repair Manual QSK45 and QSK60 Series Engines, Bulletin 3666261, or Troubleshooting and Repair Manual QSK78 Series Engines, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Run/Stop switch in the Run position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 261 inactive

Return to the troubleshooting steps or contact a Cummins ®Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 25-Jul-2012


FAULT CODE 263 - Fuel Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a newengine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 263 inactive, Fault Code 265 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable Fault Code. | Fault Code 263 inactive
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel temperature sensor.
OK NOT OK

No other fault codes are active

Multiple fault codes are active

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures.Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature signal pin and the fuel temperature return pin.
OK NOT OK

600 ohms to 36k ohms

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel temperature return pin on the engine harness inline connector to the fuel temperature return pin at the engine harness sensor connector.
  • Measure the resistance from the fuel temperature signal pin on the engine harness inline connector to the fuel temperature signal pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature return pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel temperature signal pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel temperature return pin on the extension harness connector to the fuel temperature return pin at the extension harness inline connector.
  • Measure the resistance from the fuel temperature signal pin on the extension harness connector to the fuel temperature signal pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature return pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel temperature signal pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the fuel temperature signal pin and the fuel temperature return pin on the breakout box.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response.

  • Using the electrical service tool, verify the fault codes.
OK NOT OK

Fault Code 263 inactive, Fault Code 265 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 263 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 25-Jul-2012


FAULT CODE 265 -Fuel Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 265 inactive, Fault Code 263 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 265 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for a multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the fuel temperature sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness connector from the fuel temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature signal pin and the fuel temperature pin.
OK NOT OK

600 ohms to 36k ohms

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the fuel temperature sensor connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect engine harness from fuel temperature sensor.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel temperature signal pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel temperature return pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature return pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel temperature signal pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect extension harness from ECM.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel temperature signal pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel temperature return pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature return pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel temperature signal pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the fuel temperature signal pin and the fuel temperature supply pin on the breakout box.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 265 inactive, Fault Code 263 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 265 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Aug-2012


FAULT CODE 293 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Codes 133 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) wiring harness. |
 | STEP 2A. Inspect the OEM wiring harness and OEM interface wiring harness connector and pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) voltage. |
 | STEP 3A. Check the voltage from the ECM. | Voltage between 4.75 and 5.25 volts direct current (VDC)?
STEP 4. | OEM auxiliary temperature sensor is malfunctioning. |
 | STEP 4A. A malfunctioning OEM auxiliary temperature sensor has been detected. | All other troubleshooting procedures have been completed, and the fault code is still active or inactive with more than one count within the last 25 engine hours?
STEP 5. | Check the ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?
 | STEP . |

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault code.

Fault Codes 133 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropiate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the original equipment manufacturer (OEM) wiring harness.

Guided Step 2A - Inspect the OEM wiring harness and the left bank OEM interface wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins.
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.

Action

  • Measure the resistance from the OEM auxiliary temperature sensor SUPPLY pin of the OEM auxiliary temperature sensor OEM wiring harness connector to the OEM auxiliary temperature sensor SUPPLY pin of the left bank OEM interface wiring harness ECM connector.
  • Measure the resistance from the OEM auxiliary temperature sensor RETURN pin of the OEM auxiliary temperature sensor OEM wiring harness connector to the OEM auxiliary temperature sensor RETURN pin of the left bank OEM interface wiring harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the OEM wiring harness has been detected.

  • Troubleshoot the OEM wiring harness and all interconnects.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.

Action

  • Measure the resistance from the OEM auxiliary temperature sensor SUPPLY pin in the OEM auxiliary temperature sensor connector to all other pins in the left bank OEM interface wiring harness ECM connector.
  • Measure the resistance from the OEM auxiliary temperature sensor RETURN pin in the OEM auxiliary temperature sensor connector to all other pins in the left bank OEM interface wiring harness ECM connector.

More than 100k ohms?
YES NO
No Repair

A short circuit in the OEM wiring harness has been detected.

  • Troubleshoot the OEM wiring harness and all interconnects.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.

Action

  • Measure the resistance from the OEM auxiliary sensor SUPPLY pin in the OEM auxiliary temperature sensor connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

A short circuit in the OEM wiring harness has been detected.

  • Troubleshoot the OEM wiring harness and all interconnects.

Go to 3A

Go to 5A
Go to
Go to

Guided Step 3 - Check the ECM voltage.

Guided Step 3A - Check the voltage from the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.
  • Turn the keyswitch ON.

Action

  • Measure the Voltage between the OEM auxiliary temperature sensor ECM SUPPLY pin at the ECM connector and the OEM auxiliary temperature sensor ECM RETURN pin at the ECM connector.

Voltage between 4.75 and 5.25 VDC?
YES NO
No Repair

A malfunctioning ECM has been detected.

  • Refer to Procedure 019-031 in Section 19.

Go to 4A

Repair complete

Guided Step 4 - OEM auxiliary temperature sensor is malfunctioning.

Guided Step 4A - A malfunctioning OEM auxiliary temperature sensor has been detected.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.

Action

  • Verify that all preceding solution verifications, for this fault code, have been performed.

All other troubleshooting procedures have been completed, and the fault code is still active or inactive with more than one count within the last 25 engine hours?

YES NO

A malfunctioning OEM auxiliary temperature sensor has been detected.

  • Replace the OEM auxiliary temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to
Escalate or call for assistance
Go to

Last Modified: 28-Jan-2020


FAULT CODE 294 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Codes 133, 422, and 431 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the OEM wiring harness. |
 | STEP 2A. Inspect the OEM wiring harness and OEM interface wiring harness connector and pins. | Dirty or damage pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the ECM voltage. |
 | STEP 3A. Check the voltage from the ECM. | Voltage between 4.75 and 5.25 volts direct current (VDC)?
STEP 4. | OEM auxiliary temperature sensor is malfunctioning. |
 | STEP 4A. A malfunctioning OEM auxiliary temperature sensor has been detected. | All other troubleshooting procedures have been completed, and the fault code is still active or inactive with more than one count within the last 25 engine hours?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault code.

Fault Codes 133, 422, and 431 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the OEM wiring harness.

Guided Step 2A - Inspect the OEM wiring harness and the left bank OEM interface wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.

Action

Inspect the pins and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM wiring harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.

Action

  • Measure the resistance from the OEM auxiliary temperature sensor SUPPLY pin of the OEM auxiliary temperature sensor OEM wiring harness connector to the OEM auxiliary temperature sensor SUPPLY pin of the left bank OEM interface wiring harness ECM connector.
  • Measure the resistance from the OEM auxiliary temperature sensor RETURN pin of the OEM auxiliary temperature sensor OEM wiring harness connector to the OEM auxiliary temperature sensor RETURN pin of the left bank OEM interface wiring harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the OEM wiring harness has been detected.

  • Troubleshoot the OEM wiring harness and all interconnects.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.

Action

  • Measure the resistance from the OEM auxiliary temperature sensor SUPPLY pin in the OEM auxiliary temperature sensor connector to all other pins in the left bank OEM interface wiring harness ECM connector.
  • Measure the resistance from the OEM auxiliary temperature sensor RETURN pin in the OEM auxiliary temperature sensor connector to all other pins in the left bank OEM interface wiring harness ECM connector.

More than 100k ohms?
YES NO
No Repair

A short circuit in the OEM wiring harness has been detected.

  • Troubleshoot the OEM wiring harness and all interconnects.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.

Action

  • Measure the resistance from the OEM auxiliary sensor SUPPLY pin in the OEM auxiliary temperature sensor connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

A short circuit in the OEM wiring harness has been detected.

  • Troubleshoot the OEM wiring harness and all interconnects.

Go to 3A

Go to 5A

Guided Step 3 - Check the ECM voltage.

Guided Step 3A - Check the voltage from the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the left bank OEM interface wiring harness connector from the ECM.
  • Turn Keyswitch ON.

Action

  • Measure the Voltage between the OEM auxiliary temperature sensor ECM SUPPLY pin at the ECM connector and the OEM auxiliary temperature sensor ECM RETURN pin at the ECM connector.

Voltage between 4.75 and 5.25 VDC?
YES NO
No Repair

A malfunctioning ECM has been detected.

  • Refer to Procedure 019-031 in Section 19.

Go to 4A

Repair complete

Guided Step 4 - OEM auxiliary temperature sensor is malfunctioning.

Guided Step 4A - A malfunctioning OEM auxiliary temperature sensor has been detected.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the OEM auxiliary temperature sensor.

Action

  • Verify that all preceding solution verifications, for this fault code, have been performed.

All other troubleshooting procedures have been completed, and the fault code is still active or inactive with more than one count within the last 25 engine hours?

YES NO

A malfunctioning OEM auxiliary temperature sensor has been detected.

  • Replace the OEM auxiliary temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Escalate or call for assistance

Last Modified: 07-Aug-2018


FAULT CODE 342 - Calibration Match Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Calibrate the primary and secondary engine control module (ECMs). |
 | STEP 1A. Calibrate the primary and secondary ECMs. | ECMs recalibrated
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Multiple fault codes inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Recalibrate the primary and secondary ECMs.

Guided Step 1A - Recalibrate the primary and secondary ECMs.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the primary and secondary ECMs.

Refer to Procedure 019-032 in Section 19.

OK NOT OK

ECMs calibrated

ECMs not calibrated

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON, but do not start the engine at this point.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Multiple fault codes inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Aug-2012


FAULT CODE 346 - Electronic Control Module (ECM) Power-down Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 343 inactive
 | STEP 1B. Disconnect the power to the ECM. | Fault Code 343 inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Action

Check for active Fault Code 343.

  • Turn keyswitch OFF and wait at least 5 seconds.
  • Turn keyswitch ON.
  • Start the engine and let it idle for 1 minute.
  • Check for inactive Fault Code 343 using INSITE™.
OK NOT OK

Fault Code 343 inactive

Fault Code 343 active

Go to 2A

Go to 1B

Guided Step 1B - Disconnect the power to the ECM.

Action

Disconnect power to the ECM.

  • Turn keyswitch OFF.
  • Disconnect the electronic service tool, INSITE™, from the datalink.
  • Disconnect the power to the ECM at the battery.
  • Wait 1 minute.
  • Connect the power to the ECM at the battery.
  • Turn keyswitch ON.
  • Connect the electronic service tool, INSITE™, to the datalink.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 343 inactive

Replace the ECM. Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
OK NOT OK

Fault Code 343 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 346 - Electronic Control Module (ECM) Power-down Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 VDC
STEP 2. | Check the OEM interface harness. (The following steps have been constructed for generic troubleshooting of the OEM circuit. Refer to the OEM manual for more details.) |
 | STEP 2A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 346 active
 | STEP 2C. Check unswitched battery voltage. | 17.0 to 35.0 VDC
 | STEP 2D. Check unswitched battery voltage (key-off). | 17.0 to 35.0 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness ground connection. | No damaged connections
 | STEP 3B. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3C. Read the fault codes. | Fault Code 346 active
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3F. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 346 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared
STEP 5. | Download the calibration. |
 | STEP 5A. Download the calibration. | Calibration download successful
 | STEP 5B. Cycle the keyswitch three times. | Fault Code 346 inactive

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

No damaged connections

Repair the damaged connections

  • Repair or replace the battery connections. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.
OK NOT OK

17.3 to 34.7 VDC

Reference the Battery Voltage Low symptom tree in the Troubleshooting and Repair Manual, QST30 Series Engine, Bulletin 3666217.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM interface harness. (The following steps have been constructed for generic troubleshooting of the OEM circuit. Refer to the OEM servcie manual for more details.)

Guided Step 2A - Inspect the OEM harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 346 active

Repair complete.

Go to 2C

Go to 4A

Guided Step 2C - Check unswitched battery voltage.

Conditions

  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disable the master disconnect switch.
  • Turn keyswitch ON.

Action

Check unswitched battery voltage.

  • Measure the voltage from pin D of the 21-pin OEM harness connector, OEM side, to engine block ground.
  • Measure the voltage from pin G of the 21-pin OEM harness connector, OEM side, to engine block ground.
OK NOT OK

17.0 to 35.0 VDC

Check the OEM fuses

Repair or replace the OEM harness or OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check unswitched battery voltage (key-off).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disable the master disconnect switch.

Action

Check unswitched battery voltage (key-off).

  • Measure the voltage from pin D of the 21-pin OEM harness connector, OEM side, to engine block ground.
  • Measure the voltage from pin G of the 21-pin OEM harness connector, OEM side, to engine block ground.
OK NOT OK

17.0 to 35.0 VDC

Correct unswitched battery supply

Check keyswitch wiring. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine block at the ground connection.

Action

Check the engine harness ground connection for the following:

  • Loose connections
  • Broken connections
  • Corroded connections
  • Excessive paint, oil, or dirt.
OK NOT OK

No damaged connections

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-197 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 346 active

Repair complete.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Measure the resistance from pins 20, 28, 29, and 30 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pins 38, 39, 40, and 50 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM interface harness from the battery.

Action

Check for a short circuit from pin to pin in the unswitched battery supply.

  • Measure the resistance from pin 20 of the engine harness connector to all other pins in the connector, except pins 28, 29, and 30.
  • Measure the resistance from pin 20 of the engine harness connector to all pins in the 50-pin OEM harness connector.
  • Measure the resistance from pin 38 of the engine harness connector to all other pins in the connector, except pins 39, 40, and 50.
  • Measure the resistance from pin 38 of the engine harness connector to all pins in the 50-pin OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the block ground circuit.

  • Measure the resistance from pin 20 of the engine harness connector to the engine block ground connection on the engine harness.
  • Measure the resistance from pin 28 of the engine harness connector to the engine block ground connection on the engine harness.
  • Measure the resistance from pin 29 of the engine harness connector to the engine block ground connection on the engine harness
  • Measure the resistance from pin 30 of the engine harness connector to the engine block ground connection on the engine harness.
OK NOT OK

Less than 10 ohms

Repair or replace engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-197 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Cycle the keyswitch three times.
  • Start the engine and let it idle for 1 minute.

Note: Wait 15 seconds after each key-off to let the ECMs complete their power-down cycle.
OK NOT OK

Fault Code 346 inactive

Recalibrate primary and secondary ECMs.

Go to 4B

Go to 5A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Guided Step 5 - Download the calibration.

Guided Step 5A - Download the calibration.

Conditions

  • Connect all components.

Action

Download the calibration.
OK NOT OK

Calibration download successful

Check communication connections and retry download.

Repair complete

Go to 5B

Guided Step 5B - Cycle the keyswitch three times.

Conditions

  • Connect all components.

Action

Cycle the keyswitch three times.

Note: Wait 15 seconds after each key-off to let the ECMs complete their power-down cycle.
OK NOT OK

Fault Code 346 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair complete

Repair complete

Last Modified: 19-Aug-2012


FAULT CODE 415 - Oil Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 415 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Start the engine and compare the oil pressure reading on the monitor screen to the reading on the mechanical oil pressure gauge.

Note: Increase the engine speed to make it easier to see the differences in the readings.

OK NOT OK

Sensor reading is correct. Reference the QST30 Service Manual, Bulletin 4021539, for specifications.

Sensor reading is not correct. Reference the QST30 Service Manual, Bulletin 4021539, for specifications.

Go to 2A

Fault Code 141

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

Note: If the fault occurred at a particular speed, run engine at that speed to verify problem is corrected.

OK NOT OK

Fault Code 415 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 422 - Coolant Level Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes and presence of a coolant level switch. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 144, 153, and 221 inactive
 | STEP 1B. Read the fault codes. | Fault Codes 141, 145, 154, 222, and 223 active
 | STEP 1C. Check if the vehicle has a coolant level switch. | Coolant level switch present
 | STEP 1D. Check if a shorting plug is installed. | Shorting plug installed
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Inspect the coolant level sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 422 active
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 422 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check for the proper ECM response. |
 | STEP 4A. Check for the proper ECM response. | Fault Code 422 inactive
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 422 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes and presence of coolant level switch.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 135, 144, 153, and 221 inactive

Multiple fault code tree

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 141, 145, 154, 222, and 223 active

Multiple fault code tree

Go to 1C

Guided Step 1C - Check if the vehicle has a coolant level switch.

Conditions

  • Turn keyswitch OFF.

Action

Check if the vehicle has a coolant level switch.
OK NOT OK

Coolant level switch present

Shorting plug installed.

Go to 2A

Go to 1D

Guided Step 1D - Check if a shorting plug is installed.

Conditions

  • Turn keyswitch OFF.

Action

Check if a shorting plug is installed in place of the coolant level switch harness connection.

Note: Check the OEM wiring from the shorting plug to the engine harness connection for problems. Refer to the OEM and the engine harness wiring diagrams.

OK NOT OK

Shorting plug installed

Install shorting plug.

Go to 2A

Go to 5A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Inspect the coolant level sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant level sensor.

Action

Inspect the coolant level sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect the engine harness to the coolant level sensor.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 422 active

  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Repair complete.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect the engine harness to the coolant level sensor.
  • Connect the engine harness connector to the ECM.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 422 active

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin Deutsch connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 8 of the engine harness connector to pin 27 of the 31-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 9 of the engine harness connector to pin 37 of the 31-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 10 of the engine harness connector to pin 20 of the 31-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 21 of the engine harness connector to pin 19 of the 31-pin OEM harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine or OEM interface harness

  • Repair the harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin Deutsch connector.
  • Disconnect the engine harness from the ECM.
  • Disconnect all sensors, including coolant level sensor or shorting plug.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 37 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 27 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin Deutsch connector.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect all sensors, including coolant level sensor or shorting plug.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 27 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 37 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the proper ECM response.

Guided Step 4A - Check for the proper ECM response.

Conditions

  • Connect the engine harness to the ECM.
  • Connect a jumper wire from pin 8 to pin 20 on the 31-pin connector. Use Part Number 3823994.
  • Connect a jumper wire from pin 9 to pin 21 on the 31-pin connector. Use Part Number 3823994.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Read Shop Talk concerning OEM wiring from coolant level sensor to the 31-pin Deutsch connector.

OK NOT OK

Fault Code 422 inactive

Check the OEM wiring from coolant level sensor to the OEM 31-pin connector for proper pinout, continuity, and short circuits from pin to pin and to ground. Refer to the OEM wiring diagrams.

Fault Code 422 active.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 422 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 423 - Sleeve Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 113 or 114 inactive?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness and connectors. | Dirty or damaged pins?
STEP 3. | Check the calibration revision. |
 | STEP 3A. Check if an ECM calibration update is available. | Present calibration the most recent revision?
STEP 4. | Measure the fuel inlet restriction. |
 | STEP 4A. Measure restriction. | Fuel inlet restriction meets specifications?
STEP 5. | Check for a mechanical malfunction of the pump. |
 | STEP 5A. Check the sleeve current. | Sleeve current changing?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 423 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 113 or 114 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to the appropriate troubleshooting tree.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check for inactive counts of Fault Code 423 and inspect the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the injection pump connections.

Action

Read the fault codes and inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on th connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replaced the needle lift sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Calibration Check

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Present calibration the most recent revision?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Measure the fuel inlet restriction.

Guided Step 4A - Measure the fuel inlet restriction.

Conditions

  • Turn keyswitch ON
  • Operate the engine and let it idle.

Action

Measure the fuel inlet restriction.

  • Use the following procedure in the QST30 Service Manual, Bulletin 4021539. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction specifications met?
YES NO
No Repair

High fuel restrictions were detected.

Use the following procedure in the QST30 Service Manual, Bulletin 4021539. Refer to Procedure 006-020 in Section 6.

Go to 5A

Go to the appropriate troubleshooting tree.

Guided Step 5 - Check for a mechanical malfunction of the pump.

Guided Step 5A - Check the sleeve current.

Conditions

  • Turn keyswitch ON
  • Operate the engine and let it idle.

Action

Check the sleeve current.

  • Use INSITE™ electronic service tool to monitor the sleeve current while varying the engine rpm.

Sleeve current changing?
YES NO

The sleeve current is changing.

Repair or replace the fuel pump. Use the following procedure in the QST30 Service Manual, Bulletin 4021539. Refer to Procedure 005-012 in Section 5.

Sleeve current is not changing.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 423 inactive?
YES NO
No Repair

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting tree.

Last Modified: 20-Jan-2014


FAULT CODE 431 - Idle Validation Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the idle validation switch. |
 | STEP 1A. Verify that the idle validation switch is connected to the OEM harness. | Idle validation switch connected
 | STEP 1B. Inspect the idle validation switch and OEM harness connectors. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault Code 431 active
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit.) |
 | STEP 2A. Inspect the OEM and OEM interface harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 431 active
 | STEP 2C. Check for an open circuit. | Less than 125 ohms
 | STEP 2D. Check for a short circuit across the switch. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 431 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 431 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the idle validation switch.

Guided Step 1A - Verify that the idle validation switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the idle validation switch is connected to the OEM harness.

Verify that the idle validation switch is connected to the OEM harness.
OK NOT OK

Idle validation switch connected

Connect the idle validation switch. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the idle validation switch and OEM harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the idle validation switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit.)

Guided Step 2A - Inspect the OEM and OEM interface harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the idle validation switch to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin U of the 21-pin OEM interface harness connector to engine block ground.
  • Measure the resistance from pin V of the 21-pin OEM interface harness connector to engine block ground.
OK NOT OK

Less than 125 ohms

Repair or replace the OEM harness or accelerator, whichever has the open circuit

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Repair the accelerator. Refer to the OEM service manual.
  • Replace the accelerator. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit across the switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit across the switch.

  • Measure the resistance from pin U of the 21-pin OEM interface harness connector to pin V of the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or accelerator, whichever has the short circuit

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Repair the accelerator. Refer to the OEM service manual.
  • Replace the accelerator. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin U of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors.
  • Measure the resistance from pin V of the 21-pin OEM interface harness connector to all other pins in the 21-pin and 31-pin OEM interface harness connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or accelerator, whichever has the open circuit

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Repair the accelerator. Refer to the OEM service manual.
  • Replace the accelerator. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 26 of the 50-pin OEM harness connector to pin U of the 21-pin OEM interface harness connector.
  • Measure the resistance from pin 25 of the 50-pin OEM harness connector to pin V of the 21-pin OEM interface harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 25 of the 50-pin OEM harness connector to engine block ground.
  • Measure the resistance from pin 26 of the 50-pin OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 25 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 26 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 431 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 432 - Accelerator Pedal/Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 431 not logged
STEP 2. | Check the accelerator position sensor. |
 | STEP 2A. Inspect the OEM harness and accelerator position sensor connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 432 active
 | STEP 2C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic troubleshooting of the OEM circuit. Refer to the OEM manual for more details.) |
 | STEP 3A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 432 active
 | STEP 3C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check the idle validation switch response. | Switch functions properly
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness and ECM connectors. | No damaged pins
 | STEP 4B. Read the fault codes. | Fault Code 432 active
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 432 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 not logged

Fault Code 431 active.

Go to 2A

Fault Code 431

Guided Step 2 - Check the accelerator position sensor.

Guided Step 2A - Inspect the OEM harness and accelerator position sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Inspect OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair accelerator pedal. Refer to the OEM service manual.
  • Replace the accelerator pedal. Refer to the OEM service manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

2B

5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 432 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for open circuit.

  • Measure the resistance from pin A to pin C of the accelerator position sensor.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal. Refer to the OEM manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (keyswitch in the ON position) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

2D

Go to 5A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the accelerator position sensor to pin C of the accelerator position sensor.

Note: Measure the resistance when the pedal is depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms, Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal. Refer to the OEM service manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (keyswitch in the ON position) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

3A

5A

Guided Step 3 - Check OEM harness. (The following steps have been constructed for generic troubleshooting of the OEM circuit. Refer to the OEM manual for more details.)

Guided Step 3A - Inspect OEM interface harness and OEM harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.

3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 432 active

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal.

Action

Check for an open circuit.

  • Measure the resistance from pin S to pin T of the 21-pin OEM harness connector, interface harness side.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

3D

5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin S of the 21-pin OEM harness connector to all other pins in the 21-pin and 31-pin OEM harness connectors.
  • Measure the resistance from pin T of the 21-pin OEM harness connector to all other pins in the 21-pin and 31-pin OEM harness connectors.
  • Measure the resistance from pin U of the 21-pin OEM harness connector to all other pins in the 21-pin and 31-pin OEM harness connectors.
  • Measure the resistance from pin V of the 21-pin OEM harness connector to all other pins in the 21-pin and 31-pin OEM harness connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3E

5A

Guided Step 3E - Check the idle validation switch response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check the idle validation switch response.

  • Measure the resistance from pin U of the 21-pin OEM harness connector, interface harness side, to engine block ground when pedal is depressed and released.
  • Measure the resistance from pin V of the 21-pin OEM harness connector, interface harness side, to engine block ground when pedal is depressed and released.
OK NOT OK

Switch functions properly

For pin U:

Pedal depressed: More than 100k ohms.

Pedal released: Less than 125 ohms.

For pin V:

Pedal depressed: Less than 125 ohms.

Pedal released: More than 100k ohms.

Repair or replace the accelerator pedal. Refer to the OEM manual.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (keyswitch in the ON position) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

5A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 432 active

Repair complete.

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the 50-pin OEM harness connector to pin T of the 21-pin OEM interface harness connector, engine harness side.
  • Measure the resistance from pin 26 of the 50-pin OEM harness connector to pin U of the 21-pin OEM interface harness connector, engine harness side.
  • Measure the resistance from pin 25 of the 50-pin OEM harness connector to pin V of the 21-pin OEM interface harness connector, engine harness side.
  • Measure the resistance from pin 29 of the 50-pin OEM harness connector to pin R of the 21-pin OEM interface harness connector, engine harness side.
  • Measure the resistance from pin 30 of the 50-pin OEM harness connector to pin S of the 21-pin OEM interface harness connector, engine harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness or OEM interface harness

  • Repair the OEM harness or interface harness. Use the following procedures.Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 25 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 26 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 29 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 30 of the OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 432 inactive

Return to troubleshooting steps or contacta Cummins® Authorized Repair Location if all steps have been completed and checked again.

5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 38223994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 17.0 to 35.0 VDC
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more details.) |
 | STEP 2A. Inspect the OEM harness and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 441 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness fuse connections. | No damaged connections
 | STEP 3B. Check the engine harness fuses. | Less than 10 ohms
 | STEP 3C. Check the engine harness ground connection. | No damaged connections
 | STEP 3D. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3E. Read the fault codes. | Fault Code 441 active
 | STEP 3F. Check for an open circuit in the positive (+) wire. | Less than 10 ohms
 | STEP 3G. Check for an open circuit in the negative (-) wire. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

No damaged connections

Repair or replace the damaged connections. Refer to the OEM manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.
OK NOT OK

17.0 to 35.0 VDC

Replace the battery. Refer to the OEM manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more details.)

Guided Step 2A - Inspect the OEM harness and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair or replace the OEM harness

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204.
  • Replace the OEM harness. Refer to the OEM manual.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault code using INSITE™.
OK NOT OK

Fault Code 441 active

Repair complete.

Go to 2C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 38223994 - female Deutsch test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin D of the 21-pin OEM harness connector, OEM side, to the positive (+) battery post.
  • Measure the resistance from pin G of the 21-pin OEM harness connector, OEM side, to the positive (+) battery post.
  • Measure the resistance from pin B of the 21-pin OEM harness connector, OEM side, to the negative (-) battery post.
  • Measure the resistance from pin E of the 21-pin OEM harness connector, OEM side, to the negative (-) battery post.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for a short circuit from pin to pin in the unswitched battery supply circuit.

  • Measure the resistance from pin B of the 21-pin OEM harness connector, OEM side, to all other pins in the connector, except pin E.
  • Measure the resistance from pin D of the 21-pin OEM harness connector, OEM side, to all other pins in the connector, except pin G.
  • Measure the resistance from pin E of the 21-pin OEM harness connector, OEM side, to all other pins in the connector, except pin B.
  • Measure the resistance from pin G of the 21-pin OEM harness connector, OEM side, to all other pins in the connector, except pin D.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 15-amp fuse from the engine harness.

Action

Inspect the engine harness fuse connections for the following:

  • Corroded fuse
  • Loose fuse.
OK NOT OK

No damaged connections

Repair or replace the damaged connections

  • Replace the fuse. Refer to Procedure 019-198.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3B

Go to 4A

Guided Step 3B - Check the engine harness fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two 15-amp fuses from the engine harness.

Action

Check the engine harness fuses.

  • Measure the resistance of the fuse(s).
OK NOT OK

Less than 10 ohms

Replace the fuse(s). Refer to Procedure 019-198.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine block at the ground connection.

Action

Check the engine harness ground connection for the following:

  • Broken connections
  • Corroded connections
  • Loose connections.
OK NOT OK

No damaged connections

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-197.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3D - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3E

Go to 4A

Guided Step 3E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault code using INSITE™.
OK NOT OK

Fault Code 441 active

Repair complete.

Go to 3F

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3F - Check for an open circuit in the positive (+) wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the positive (+) wire.

  • Measure the resistance from pin 38 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 39 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 40 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 50 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 or Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3G

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3G - Check for an open circuit in the negative (-) wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the negative (-) wire.

  • Measure the resistance from pin 20 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 28 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 29 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 30 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 or Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 441 is inactive.
OK NOT OK

Fault Code 441 inactive

Return to the troubleshooting step or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 442 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check the battery voltage. | 17.0 to 35.0 VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Check the engine harness ground connection. | No damaged connections
 | STEP 2B. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2C. Read the fault codes. | Fault Code 442 active
 | STEP 2D. Check for an open circuit in the positive (+) wire. | Less than 10 ohms
 | STEP 2E. Check for an open circuit in the negative (-) wire. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 442 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.
OK NOT OK

17.0 to 35.0 VDC

Repair or replace the damaged connections

  • Repair the battery connections. Refer to the OEM service manual.
  • Replace the battery connections. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Check the engine harness ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine block at the ground connection.

Action

Check the engine harness ground connection for the following:

  • Broken connections
  • Corroded connections
  • Loose connections.
OK NOT OK

No damaged connections

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-197 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 442 active

Repair complete.

Go to 2D

Go to 3B

Guided Step 2D - Check for an open circuit in the positive (+) wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the positive (+) wire.

  • Measure the resistance from pin 38 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 39 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 40 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 50 of the engine harness connector to pin G of the 21-pin OEM harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit in the negative (-) wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the negative (-) wire.

  • Measure the resistance from pin 20 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 28 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 29 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
  • Measure the resistance from pin 30 of the engine harness connector to pin B of the 21-pin OEM harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 442 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 524 - Alternate Droop Switch Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM and engine harness connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 524 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 524 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 524 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 524 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the alternate droop and high-speed governor droop select switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the 31-pin OEM harness connector, OEM side, to pin A of the high-speed governor switch connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the alternate droop and high-speed governor droop select switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 17 of the 31-pin OEM harness connector, OEM side, to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness connector from the OEM interface harness connector at the 31-pin connector.
  • Disconnect the OEM harness from the high-speed governor droop select switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 17 of the 31-pin OEM harness connector, OEM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 524 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 22 of the engine harness connector to pin 17 of the 31-pin OEM harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 22 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 22 of the engine harness connector to all other pins in the connector, and to all pins in the 50-pin OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 524 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 527 - Solenoid A Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean
 | STEP 1C. Check the solenoid resistance. | Solenoid is within OEM specification
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the engine harness and OEM harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 527 active
 | STEP 2C. Check for a short circuit to ground in the solenoid supply wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the ECM and engine harness connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 527 active
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 527 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.
OK NOT OK

No extra wires

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean

Repair ring terminal or replace the solenoid

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the shutoff solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

Solenoid is within OEM specification

Replace the solenoid. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the engine harness and OEM harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check the engine harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner. Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 527 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit to ground in the solenoid supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit to ground in the solenoid supply wire.

  • Measure the resistance from the solenoid supply wire to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin C of the 21-pin OEM harness connector, OEM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the ECM and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner. Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer Procedure Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 527 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 41 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 41 of the engine harness connector to all other pins in the connector, and to all pins in the 50-pin OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer Procedure Refer to Procedure 019-031 in Section 19.

Go to 3E

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 527 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 528 - Alternate Torque Curve Select Switch Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM and OEM interface harness connectors. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 528 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM interface harness. |
 | STEP 2A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 528 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 528 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and OEM interface harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 528 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the torque curve select switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 16 of the 31-pin OEM harness connector, OEM side, to pin A of the high-speed governor switch connector, harness side.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the torque curve select switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 16 of the 31-pin OEM harness connector, OEM side, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the torque curve select switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 16 of the 31-pin OEM harness connector, OEM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM interface harness.

Guided Step 2A - Inspect the OEM interface harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 528 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 39 of the 50-pin OEM interface harness connector to pin 16 of the 31-pin OEM interface harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 39 of the OEM interface harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 39 of the 50-pin OEM interface harness connector to all other pins in the connector, and to all pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 528 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 529 - Solenoid B Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean
 | STEP 1C. Check the solenoid resistance. | Solenoid is within OEM specifications
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 529 active
 | STEP 2C. Check for a short circuit to ground in the solenoid supply wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 529 active
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 529 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

Check for extra wires on the solenoid post.
OK NOT OK

No extra wires

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean

Repair the ring terminal or replace the solenoid

  • Repair the ring terminal. Refer to Procedure 019-197.
  • Replace the solenoid. Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the shutoff solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

Solenoid is within OEM specifications

Replace the solenoid. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness from the engine harness at the 21-pin connector.

Action

Check the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner. Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 529 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit to ground in the solenoid supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit to ground in the solenoid supply wire.

  • Measure the resistance from the solenoid supply wire to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin F in the 21-pin OEM harness connector, OEM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer Procedure Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 529 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 21 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 21 of the engine harness connector to all other pins in the connector, and to all pins in the 50-pin OEM connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 529 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Aug-2018


FAULT CODE 551 - Idle Validation Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the idle validation switch. |
 | STEP 1A. Verify that the idle validation switch is connected to the OEM harness. | Idle validation switch is connected
 | STEP 1B. Inspect the idle validation switch and OEM harness connectors. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault Code 551 active
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual for more details.) |
 | STEP 2A. Inspect the OEM harness and OEM interface harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 551 active
 | STEP 2C. Check for an open circuit. | Pin U released and pin V depressed = Less than 125 ohms. Pin U depressed and pin V released = More than 100k ohms.
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 551 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the idle validation switch.

Guided Step 1A - Verify that the idle validation switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the idle validation switch is connected to the OEM harness.

Verify that the idle validation switch is connected to the OEM harness.
OK NOT OK

Idle validation switch is connected

Connect the idle validation switch. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the idle validation switch and OEM harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the idle validation switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

Note: If the accelerator or accelerator position sensor is changed, or after a calibration download, cycle the accelerator pedal (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 551 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual for more details.)

Guided Step 2A - Inspect the OEM harness and OEM interface harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM srvice manual.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 551 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for an open circuit.

  • Measure the resistance from pin U of the 21-pin OEM harness connector, interface harness side, to engine block ground, with the pedal depressed and released.
  • Measure the resistance from pin V of the 21-pin OEM harness connector, interface harness side, to engine block ground, with the pedal depressed and released.
OK NOT OK

Pin U released and pin V depressed = Less than 125 ohms.

Pin U depressed and pin V released = More than 100k ohms

Repair or replace the OEM harness or accelerator, whichever has the open circuit

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Repair the accelerator. Refer to the OEM service manual.
  • Replace the accelerator. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin U of the 21-pin OEM harness connector to all other pins in the 21-pin and 31-pin OEM harness connectors, interface harness side.
  • Measure the resistance from pin V of the 21-pin OEM harness connector to all other pins in the 21-pin and 31-pin OEM harness connectors, interface harness side.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or accelerator, whichever has the open circuit

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM srvice manual.
  • Repair the accelerator. Refer to the OEM service manual.
  • Replace the accelerator. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Inspect the ?????? connector pins for the following:
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 551 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 26 of the 50-pin OEM harness connector to pin U of the 21-pin OEM interface harness connector, interface harness side.
  • Measure the resistance from pin 25 of the 50-pin OEM harness connector to pin V of the 21-pin OEM interface harness connector, interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness or OEM interface harness

  • Repair the OEM harness or OEM interface harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 25 of the 50-pin OEM harness connector to engine block ground.
  • Measure the resistance from pin 26 of the 50-pin OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness or OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 25 of the 50-pin OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
  • Measure the resistance from pin 26 of the 50-pin OEM harness connector to all other pins in the connector, and to all pins in the engine harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031.

Repair or replace the OEM harness

  • Repair the OEM harness or OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 551 inactive

Return to the troubleshooting steps or contact a Cummins®Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 555 - Crankcase Blowby Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 555 inactive
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify sensor accuracy with a mechanical gauge.

  • Connect a water manometer gauge to the engine. Use the following procedure in the QST30 Service Manual, Bulletin 4021539. Refer to Procedure 014-005 in Section 14.
  • Connect INSITE™ to the vehicle datalink.
  • Start the engine and compare the blowby pressure reading on service tool monitor screen to reading on water manometer gauge.

Note: Operate the engine at rated rpm and full load (wide-open throttle) until a steady reading is obtained.
OK NOT OK

Sensor reading is correct. Reference to the QST30 Service Manual, Bulletin 4021539.

Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

Note: If fault occurred at a particular speed, run engine at that speed to verify problem is corrected.

OK NOT OK

Fault Code 555 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch AMP/Metri-Pack test leadPart Number 3822758 - male Deutsch AMP/Metri-Pack test leadPart Number 3824774 - Pressure sensor breakout cablePart Number 3824776 - Pressure sensor breakout cablePart Number 3163594 - ECM connector breakout boxPart Number 3164752 - Danfoss™ pressure sensor breakout cablePart Number 3164132 - Deutsch socket pin test leadPart Number 3164133 - Deutsch pin test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824774 - Pressure sensor breakout cablePart Number 3824776 - Pressure sensor breakout cablePart Number 3164752 - Danfoss™ pressure sensor breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch AMP/Metri-Pack test leadPart Number 3164132 - Deutsch socket pin test leadPart Number 3164133 - Deutsch pin test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To perform the procedure, the following item must be used:Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel supply pressure sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56 VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 581 inactive, Fault Code 582 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 581 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel supply pressure sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness connector from the fuel supply pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205 or Refer to Procedure 019-219.
  • Replace the fuel supply pressure sensor. Refer to Procedure 019-115.

Go to 1B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824774 - Pressure sensor breakout cablePart Number 3824776 - Pressure sensor breakout cablePart Number 3164752 - Danfoss™ pressure sensor breakout cable.
Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Run/Stop switch in the Stop position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the fuel supply pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824774 - Pressure sensor breakout cablePart Number 3824776 - Pressure sensor breakout cablePart Number 3164752 - Danfoss™ pressure sensor breakout cable.
Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Run/Stop switch in the Stop position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the fuel supply pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56 VDC

Replace the fuel supply pressure sensor. Refer to Procedure 019-115.

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Repair the extension harness. Refer to Procedure 019-208.
  • Replace the extension harness. Refer to Procedure 019-175.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch AMP/Metri-Pack test leadPart Number 3164132 - Deutsch socket pin test leadPart Number 3164133 - Deutsch pin test lead.
Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel supply pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure +5 VDC supply pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel supply pressure return pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel supply pressure signal pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch AMP/Metri-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel supply pressure +5 VDC supply pin on the engine harness inline connector to the fuel supply pressure +5 VDC supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel supply pressure signal pin on the engine harness inline connector to the fuel supply pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the fuel supply pressure return pin on the engine harness inline connector to the fuel supply pressure return pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175.
  • Replace the ECM. Call for authorization.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch AMP/Metri-Pack test lead.
Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure +5 VDC supply pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel supply pressure return pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel supply pressure signal pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch AMP/Metri-Pack test leadPart Number 3164132 - Deutsch socket pin test leadPart Number 3164133 - Deutsch pin test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel supply pressure +5 VDC supply pin on the extension harness connector to the fuel supply pressure +5 VDC supply pin on the extension harness inline connector.
  • Measure the resistance from the fuel supply pressure signal pin on the extension harness connector to the fuel supply pressure signal pin on the extension harness inline connector.
  • Measure the resistance from the fuel supply pressure return pin on the extension harness connector to the fuel supply pressure return pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM response.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To perform the procedure, the following item must be used:Part Number 3163594 - ECM connector breakout box.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the fuel supply pressure signal pin and the fuel supply pressure return pin on the breakout box.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response.

  • Using the electronic service tool, verify the fault codes.
OK NOT OK

Fault Code 581 inactive, Fault Code 582 active

Replace the ECM. Call for authorization.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Verify that Fault Code 581 is inactive.
OK NOT OK

Fault Code 581 inactive

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Jul-2010


FAULT CODE 581 - Fuel Supply Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/ AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - ECM connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes active
STEP 2. | Check the fuel supply pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 582 inactive, Fault Code 581 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 582 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel supply pressure sensor.
OK NOT OK

No other fault codes active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel supply pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness connector from the fuel supply pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-219 in Section 19.
  • Replace the fuel supply pressure sensor. Refer to Procedure 019-115.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the fuel supply pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

4.75 to 5.25 VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the fuel supply pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56 VDC

Replace the fuel supply pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel supply pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure return pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel supply pressure signal pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel supply pressure signal pin on the engine harness inline connector to the fuel supply pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the fuel supply pressure return pin on the engine harness inline connector to the fuel supply pressure return pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel supply pressure signal pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel supply pressure return pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure return pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel supply pressure signal pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel supply pressure signal pin on the extension harness connector to the fuel supply pressure signal pin on the extension harness inline connector.
  • Measure the resistance from the fuel supply pressure return pin on the extension harness connector to the fuel supply pressure return pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel supply pressure signal pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel supply pressure return pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the fuel supply pressure signal pin and the fuel supply pressure +5 VDC supply pin on the breakout box.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 582 inactive, Fault Code 581 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 582 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Aug-2012


FAULT CODE 583 - Fuel Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fuel pressure sensor and engine harness connector. |
 | STEP 1A. Inspect the fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the fuel pressure sensor resistance. | Greater than 800k ohms?
STEP 2. | Check if engine will not start or engine starts and dies. |
 | STEP 2A. Attempt to start engine. | Engine starts and continues running?
STEP 3. | Check the low pressure side of the fuel system. |
 | STEP 3A. Check for external fuel leaks. | Fuel leaking externally?
 | STEP 3B. Check fuel inlet restriction. | Is the fuel restriction at the lift pump inlet greater than the maximum fuel inlet restriction specifications?
 | STEP 3C. Check for air in fuel. | Air present in the fuel flow?
 | STEP 3D. Measure the resistance across the fuel lift pumps. | Does the resistance indicate a short or open circuit?
 | STEP 3E. Check the fuel lift pumps individually. | Does fuel flow from both lift pumps meet specification?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 583 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel pressure sensor and engine harness connector.

Guided Step 1A - Inspect the fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the fuel pressure sensor connector.

Action

Inspect the engine harness connector and fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins. Use the following procedures.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the fuel pressure sensor.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the fuel pressure sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor connector from the engine wiring harness connector.

Action

Check the fuel pressure sensor resistance.

  • Measure the resistance between the fuel pressure SIGNAL pin and the fuel pressure RETURN pin at the fuel pressure sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?

YES NO

Replace the fuel pressure sensor.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check if engine will not start or engine starts and dies.

Guided Step 2A - Attempt to start engine.

Conditions

  • Start engine.

Action

Try to start the engine.

Check if engine will not start or engine starts and dies.

Engine starts and continues running?

YES | NO
No Repair | No Repair

Go to 3A

Reference troubleshooting symptom trees Engine Difficult to Start or Will Not Start and Engine Will Starts But Will Not Keep Running in Section TS.

Guided Step 3 - Check the low pressure side of the fuel system.

Guided Step 3A - Check for external fuel leaks.

Conditions

  • Engine running.

Action

Start the engine and check for external fuel leaks.

Check for external fuel leaks.

Fuel leaking externally?
YES NO

Repair all fuel leaks.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch OFF.
  • Install a quick connecting fitting and vacuum gauge.

Action

Measure the fuel restriction at the fuel lift pump inlet.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 006-020 in Section 6.

Fuel restriction at the lift pump inlet greater than the maximum fuel inlet restriction specifications?

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 006-020 in Section 6.

YES NO

Tighten loose connections, check OEM suction side of system for damage or debris, check OEM fuel tank for debris or damage, clean screens, replace plugged fuel pre-filter.

  • Refer to the OEM service manual.
  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 006-020 in Section 6.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for air in fuel.

Conditions

  • Install a sight glass at the fuel filter outlet.
  • Operate the engine at high idle.

Action

Check for air in fuel.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow?
YES NO

Tighten loose connections and check OEM suction side of system for damage or debris.

Replace plugged fuel filter.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 006-015 in Section 6.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Measure resistance across the fuel lift pumps.

Conditions

  • Turn keyswitch OFF.

Action

Unplug both fuel lift pumps and measure the resistance across the pins.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 005-045 in Section 5.

Does the resistance indicate a short or open circuit?

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 005-045 in Section 5.

YES NO

Replace the damaged fuel lift pump.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 005-045 in Section 5.

Remove both electric fuel lift pumps from the engine.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 005-045 in Section 5.

Go to 4A

Go to 3E

Guided Step 3E - Check the fuel lift pumps individually.

Conditions

  • Turn keyswitch OFF.

Action

Remove electric lift pumps from engine and measure fuel pumping capability.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 005-045 in Section 5.

Does fuel flow from each lift pump meet specification?

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 005-045 in Section 5.

YES NO
No Repair

Replace the damaged fuel lift pump.

  • Use the following procedure in Service Manual, QST30, Bulletin 4021539. Refer to Procedure 005-045 in Section 5.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 583 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Aug-2012


FAULT CODE 649 - Change Lubricating Oil and Filter

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

  • Run/Stop switch in the Stop position.

Action

Change lubricating oil.

Using the electronic service tool set the “Oil Changed” parameter in the Adjustments - Features - Maintenance Monitor group to YES.

OK NOT OK

Repair Complete

Repair Complete

Last Modified: 19-Aug-2012


FAULT CODE 719 - Crankcase Blowby Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 221, and 422 are not active
STEP 2. | Check the blowby pressure sensor. |
 | STEP 2A. Inspect the blowby pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 719 active
 | STEP 2C. Check the blowby pressure supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the blowby pressure supply voltage. |
 | STEP 2C-2. Check for an external voltage source. |
 | STEP 2D. Check the blowby pressure signal voltage. | 0.36 to 0.65 VDC
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for an open circuit. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 719 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check the ECM response. | Fault Code 719 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 719 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, and 422 not active

Fault Code 122, 135, 144, 153, 221, or422 is active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the blowby pressure sensor.

Guided Step 2A - Inspect the blowby pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Inspect the blowby pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 719 active

Repair complete.

Go to 2C

4B

Guided Step 2C - Check the blowby pressure supply voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the blowby pressure supply voltage.

  • Install the blowby pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Above or below 4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the blowby pressure supply voltage.

Conditions

  • Disconnect the blowby pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the blowby pressure supply voltage.

  • Measure the voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Above or below 4.75 to 5.25 VDC

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an external voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an external voltage source.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the blowby pressure signal voltage.

Conditions

  • Disconnect the engine harness from the blowby pressure sensor.
  • Turn keyswitch ON.

Action

Check the blowby pressure signal voltage.

  • Install the blowby pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.36 to 0.65 VDC

Above or below 0.36 to 0.65 VDC

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 25 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 25 of the engine harness connector to pin C of the blowby pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 719 active

Repair complete.

Go to 3C

4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness connector to pin B of the blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the blowby temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 25 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM response.

Conditions

  • Disconnect the engine harness from the blowby pressure sensor.
  • Turn keyswitch ON.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 729 can become active when sensor is disconnected.
OK NOT OK

Fault Code 719 inactive

Fault Code 719 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 719 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 729 - Crankcase Blowby Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 141, 145, 154, 222, 232, and 729 are not active
STEP 2. | Check the crankcase blowby pressure sensor. |
 | STEP 2A. Inspect the crankcase blowby pressure sensor and engine harness connectors. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 729 active
 | STEP 2C. Check the crankcase blowby pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the crankcase blowby pressure sensor supply voltage. |
 | STEP 2C-2. Check for an open circuit. |
 | STEP 2C-3. Check for a short circuit to ground. |
 | STEP 2C-4. Check for a short circuit from pin to pin. |
 | STEP 2D. Check the crankcase blowby pressure sensor signal voltage. | 0.36 to 0.65 VDC
 | STEP 2D-1. Check for an open circuit. |
 | STEP 2D-2. Check for a short circuit to ground. |
 | STEP 2D-3. Check for a short circuit from pin to pin. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 729 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 729 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 141, 145, 154, 222, 232, and 729 not active

Fault Code 141, 145, 154, 222, 232, or729 is active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the crankcase blowby pressure sensor.

Guided Step 2A - Inspect the crankcase blowby pressure sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Inspect the crankcase blowby pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins.

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the crankcase blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 729 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check the crankcase blowby pressure sensor supply voltage.

Conditions

  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Turn keyswitch ON.

Action

Check the crankcase blowby pressure sensor supply voltage.

  • Install the crankcase blowby pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the voltage from pin A to pin B on the crankcase blowby pressure sensor breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Above or below 4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the crankcase blowby pressure sensor supply voltage.

Conditions

  • Disconnect the crankcase blowby pressure sensor breakout cable from the sensor.
  • Turn keyswitch ON.

Action

Check the crankcase blowby pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B on the crankcase blowby pressure sensor breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Above or below 4.75 to 5.25 VDC

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness connector to pin A of the crankcase blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-3

Go to 4A

Guided Step 2C-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 2D - Check the crankcase blowby pressure sensor signal voltage.

Conditions

  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor signal voltage.

  • Install the crankcase blowby pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness connector.
  • Measure the from pin C to pin B on the crankcase blowby pressure sensor breakout cable.
OK NOT OK

0.36 to 0.65 VDC

Above or below 0.36 to 0.65 VDC

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 25 of the engine harness connector to pin C of the crankcase blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 25 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 4A

Guided Step 2C-3 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 25 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 729 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 25 of the engine harness connector to pin C of the crankcase blowby pressure sensor harness connector.
  • Measure the resistance from pin 10 of the engine harness connector to pin A of the crankcase blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 25 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 19 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from pin 25 of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 729 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2012


FAULT CODE 772 - Left Bank Needle Lift Sensor Reading Is Not Being Detected or Is Out of Range

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 115 and 121 active?
STEP 2. | Check the needle lift sensor. |
 | STEP 2A. Inspect the engine harness and the needle lift sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Resistance greater than 100K ohms?
 | STEP 3C. Check for a short circuit. | Resistance less than 10 ohms?
STEP 4. | Check if an ECM calibration update is availablet. |
 | STEP 4A. Check if an ECM calibration update is available. | Present calibration the most recent revision?
STEP 5. | Check the fuel pump. |
 | STEP 5A. Inspect the fuel line between the fuel pump and the needle lift valve. | Fuel line restriction?
 | STEP 5B. Check the fuel pump timing. | Timing specified matches fuel pump code on the dataplate?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault codes. | Fault Code 772 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 115 and 121 active?
YES NO

Troubleshoot Fault Code 115 and Fault Code 121

 No Repair

Multiple fault code tree

Go to 2A

Guided Step 2 - Check the needle lift injector

Guided Step 2A - Inspect the engine harness and the needle lift sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the needle lift sensor.

Action

Read the fault codes and inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the number 1 injector on the left bank. Use the following procedure in the QST30 Service Manual, Bulletin 4021539. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the needle lift sensor.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin of the engine harness connector to the SIGNAL pin of the needle lift sensor connector, engine harness side.
  • Measure the resistance from the RETURN pin of the engine harness connector to the RETURN pin of the needle lift sensor, engine harness side.

Resistance greater than 100k ohms?
YES NO

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the needle lift sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the SIGNAL pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from the RETURN pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.

Resistance less than 10 ohms?
YES NO

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the calibration software phase.

Guided Step 4A - Verify the current calibration software phase.

Conditions

  • Turn keyswitch ON.

Action

Confirm the current calibration software phase.

  • Use INSITE™ electronic service tool to verify the current calibration software phase.

Current calibration software phase 5.1.0.5 (0501005) or greater?
YES | NO
No Repair | No Repair

Go to 5A

Go to 6A

Guided Step 4 - Check calibration software phase.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Is the present calibration the most recent revision?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the fuel pump.

Guided Step 5A - Inspect the fuel line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel line between the fuel pump and number 1 left bank injector for the following:

  • Obstructions
  • Debris
  • Crimped tube.

Fuel line restriction?
YES NO

Replace the fuel line.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check fuel injection pump timing.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump timing.

  • Use the following procedure in QST30 Service Manual, Bulletin 4021539. Refer to Procedure 005-012 in Section 5.

Does the timing specified match the fuel pump code on the dataplate?
YES NO
No Repair

Set the fuel pump timing as specified in the following procedure in QST30 Service Manual, Bulletin 4021539. Refer to Procedure 005-012 in Section 5.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • With the 5.1.0.5 software phase, operate the engine above 1000 rpm for 1 minute.
  • Verify Fault Code 772 is inactive.

Fault Code 772 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 09-Aug-2018


FAULT CODE 773 - Right Bank Needle Lift Sensor Reading Is Not Being Detected or Is Out of Range.

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 115 and 121 active?
STEP 2. | Check the needle lift sensor. |
 | STEP 2A. Inspect the engine harness and the needle lift sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Resistance greater than 100K ohms?
 | STEP 3C. Check for a short circuit. | Resistance less than 10 ohms?
STEP 4. | Check the calibration revision. |
 | STEP 4A. Verify the present calibration revision. | Is the present calibration the most recent revision?
STEP 5. | Check the fuel pump. |
 | STEP 5A. Inspect the fuel line between the fuel pump and the needle lift valve. | Fuel line restriction?
 | STEP 5B. Check the fuel pump timing. | Does the timing specified match the fuel pump code on the dataplate?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault codes. | Fault Code 773 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 115 and 121 active?
YES NO

Troubleshoot Fault Code 115 and Fault Code 121

 No Repair

Multiple fault code tree

Go to 2A

Guided Step 2 - Check the needle lift injector

Guided Step 2A - Inspect the engine harness and the needle lift sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the needle lift sensor.

Action

Read the fault codes and inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures. Refer to Procedure 019-201 in Section 19..
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the number 1 injector on the left bank. Use the following procedure in the QST30 Service Manual, Bulletin 4021539. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the needle lift sensor.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin of the engine harness connector to the SIGNAL pin of the needle lift sensor connector, engine harness side.
  • Measure the resistance from the RETURN pin of the engine harness connector to the RETURN pin of the needle lift sensor, engine harness side.

Resistance greater than 100k ohms?
YES NO

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the needle lift sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the CENSE™ connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the SIGNAL pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.
  • Measure the resistance from the RETURN pin of the engine harness connector to all other pins in the connector, and to all pins in the OEM harness connector.

Resistance less than 10 ohms?
YES NO

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the calibration software phase.

Guided Step 4A - Verify the present calibration software phase.

Conditions

  • Turn keyswitch ON.

Action

Confirm the present calibration software phase.

  • Use INSITE™ electronic service tool to verify the present calibration software.

Present calibration software phase 5.1.0.5 (0501005) or greater?
YES | NO
No Repair | No Repair

Go to 5A

Go to 6A

Guided Step 4 - Check calibration software phase.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Is the present calibration the most recent revision?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the fuel pump.

Guided Step 5A - Inspect the fuel line

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel line between the fuel pump and number 1 left bank injector for the following:

  • Obstructions
  • Debris
  • Crimped tube.

Fuel line restriction?
YES NO

Replace the fuel line.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check fuel injection pump timing.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump timing.

  • Use the following procedure in QST30 Service Manual, Bulletin 4021539. Refer to Procedure 005-012 in Section 5.

Timing specified match the fuel pump code on the dataplate?
YES NO
No Repair

Set the fuel pump timing as specified in the following procedure in QST30 Service Manual, Bulletin 4021539. Refer to Procedure 005-012 in Section 5.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • With the 5.1.0.5 software phase, operate the engine above 1000 rpm for 1 minute.
  • Verify Fault Code 773 is inactive.

Fault code 773 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 22-Feb-2017


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electric lift pump for engine fuel supply relay. |
 | STEP 1A. Inspect the engine harness connector and fuel control electric lift pump for engine fuel supply relay pins. | No damage.
 | STEP 1B. Check for an open circuit in the electric lift pump for engine fuel supply relay. | Less than 20 ohms.
 | STEP 1C. Check the electric lift pump for engine fuel supply diagnostic supply voltage and return circuit. | Voltage greater than 18.0-VDC.
 | STEP 1D. Check for an open circuit in the electric lift pump for engine fuel supply return circuit. | Less than 10 ohms.
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | No damage.
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms.
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms.
 | STEP 2D. Check for an active fault code. | Fault code inactive.
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code 2265 inactive.
 | STEP 3B. Clear the inactive fault codes. | Fault codes cleared.

Guided Step 1 - Check the electric lift pump for engine fuel supply relay.

Guided Step 1A - Inspect the engine harness connector and fuel control electric lift pump for engine fuel supply relay pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electric lift pump relay.

Action

Inspect the relay and relay connector pins on the engine harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Clean the connector pins.

Replace the damaged section of the harness or replace the relay.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit in the electric lift pump for engine fuel supply relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the relay.

Action

Check for an open circuit in the relay.

  • Measure the resistance between the relay SIGNAL pin and the relay RETURN pin at the relay.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 1.

OK NOT OK

Less than 20 ohms

Replace the relay.

Go to 1C

Go to 3A

Guided Step 1C - Check the electric lift pump for engine fuel supply diagnostic supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the relay.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine harness connector SUPPLY pin and the engine harness connector RETURN pin at the relay connector of the engine harness.
OK NOT OK

Voltage is greater than 18.0-VDC

Go to 2C

Go to 1D

Guided Step 1D - Check for an open circuit in the electric lift pump for engine fuel supply return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the relay connector from the engine harness connector.

Action

Measure the resistance between the relay RETURN pin and ground.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Troubleshoot each harness connected in series to determine which contains the open circuit.

Refer to the wiring diagram for connector pin identification.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the right bank ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-204 in Section 19.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the right bank ECM 50-pin connector.
  • Disconnect the lift pump relay from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the SIGNAL pin at the engine harness lift pump relay connector and the fuel lift pump SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section1.

OK NOT OK

Less than 10 ohms

Troubleshoot each harness connected in series to determine which contains the open circuit.

Refer to the wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the right bank ECM 50-pin connector.
  • Disconnect the electric lift pump for engine fuel supply from the relay.

Action

Check for a pin to pin short circuit.

  • Measure the resistance between the lift pump SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to the wiring diagram or circuit diagram for connector pin identification. Refer to Procedure 019-360 in Section 1m.

OK NOT OK

Greater than 100k ohms.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Go to 2D

Go to 3A

Guided Step 2D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault code inactive

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 2265 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

Fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Aug-2012


FAULT CODE 2266 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electric lift pump for engine fuel supply relay. |
 | STEP 1A. Inspect the engine harness and electric lift pump for engine fuel supply relay pins. | No damage.
 | STEP 1B. Check the nominal resistance in the electric lift pump for engine fuel supply relay. | Greater than 1k ohms or less than 50 ohms.
 | STEP 1C. Check the fault codes and verify electric lift pump for engine fuel supply condition. | Fault code 2266 inactive.
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | No damage.
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms.
 | STEP 2C. Check for a pin short to ground. | Greater than 100k ohms.
 | STEP 2D. Check for an active fault code. | Fault code 2266 inactive.
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code 2265 inactive.
 | STEP 3B. Clear the inactive fault codes. | Fault codes cleared.

Guided Step 1 - Check the electric lift pump for engine fuel supply relay.

Guided Step 1A - Inspect the engine harness and electric lift pump for engine fuel supply relay pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electric lift pump relay.

Action

Inspect the relay and relay connector pins on the engine harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Clean the connector and pins.

Replace the damaged section of the harness or damaged lift pump connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the nominal resistance in the electric lift pump for engine fuel supply relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric lift pump for engine fuel supply relay from the engine harness connector.

Action

Check the resistance between the two pins of the relay.

  • Measure the resistance between the two pins of the relay.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 1k ohms or less than 50 ohms.

Replace the relay.

Go to 1C

Go to 3A

Guided Step 1C - Check the fault codes and verify electric lift pump for engine fuel supply condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the electric lift pump relay to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault code 2266 inactive.

Removal and installation of the connector corrected the fault.

A damaged electric lift pump for engine fuel supply has been detected.

Replace the electric lift pump relay.

Refer to Procedure 005-045 in Section 5.

Go to 3A

Go to 3A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the right bank ECM 50-pin engine connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Clean the connector pins.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-204 in Section 19.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Go to 2B

Go to 3A

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the right bank ECM 50-pin engine connector.
  • Disconnect the electric lift pump for engine fuel supply from the relay.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the lift pump SIGNAL pin in the engine harness ECM connector and all other pins in the harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the wiring diagram or circuit diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms.

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short circuit.

Refer to the wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the right bank ECM 50-pin engine connector.
  • Disconnect the electric lift pump for engine fuel supply from the relay.

Action

Check for a pin to ground short.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to the wiring diagram or circuit diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms.

A pin-to-ground short circuit on the SUPPLY wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-ground short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault code 2266 inactive.

The removal and installation of the connector corrected the fault.

Return the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been checked and checked a second time.

Go to 3A

Go to 1A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 2266 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

Fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2018


INDEX
87-fc111.htm

87-t05-111.htm

87-fc113.htm

87-t05-113.htm

87-fc114.htm

87-t05-114.htm

87-fc115.htm

87-t05-115.htm

87-fc121.htm

87-t05-121.htm

87-fc122.htm

87-t05-122.htm

87-fc123.htm

87-t05-123.htm

87-fc131.htm

87-t05-131.htm

87-fc132.htm

87-t05-132.htm

87-fc133.htm

87-t05-133.htm

87-fc134.htm

87-t05-134.htm

87-fc135.htm

87-t05-135.htm

87-fc141.htm

87-t05-141.htm

87-fc143.htm

87-t05-143.htm

87-fc144.htm

87-t05-144.htm

87-fc145.htm

87-t05-145.htm

87-fc147.htm

87-t05-147.htm

87-fc148.htm

87-t05-148.htm

87-fc151.htm

87-t05-151.htm

87-fc153.htm

87-t05-153.htm

87-fc154.htm

87-t05-154.htm

87-fc155.htm

87-t05-155.htm

87-fc166.htm

87-t05-166.htm

87-fc172.htm

87-t05-172.htm

87-fc173.htm

87-t05-173.htm

87-fc184.htm

87-t05-184.htm

87-fc185.htm

87-t05-185.htm

87-fc212.htm

87-t05-212.htm

87-fc213.htm

87-t05-213.htm

87-fc214.htm

87-t05-214.htm

87-fc219.htm

87-t05-219.htm

87-fc221.htm

87-t05-221.htm

87-fc222.htm

87-t05-222.htm

87-fc223.htm

87-t05-223.htm

87-fc231.htm

87-t05-231.htm

87-fc232.htm

87-t05-232.htm

87-fc233.htm

87-t05-233.htm

87-fc234.htm

87-t05-234.htm

87-fc235.htm

87-t05-235.htm

87-fc254.htm

87-t05-254.htm

87-fc259.htm

87-t05-259.htm

87-fc261.htm

87-t05-261.htm

87-fc263.htm

87-t05-263.htm

87-fc265.htm

87-t05-265.htm

87-fc293.htm

87-t05-293.htm

87-fc294.htm

87-t05-294.htm

87-fc342.htm

87-t05-342.htm

87-fc343.htm

87-t05-343.htm

87-fc346.htm

87-t05-346.htm

87-fc415.htm

87-t05-415.htm

87-fc422.htm

87-t05-422.htm

87-fc423.htm

87-t05-423.htm

87-fc431.htm

87-t05-431.htm

87-fc432.htm

87-t05-432.htm

87-fc441.htm

87-t05-441.htm

87-fc442.htm

87-t05-442.htm

87-fc524.htm

87-t05-524.htm

87-fc527.htm

87-t05-527.htm

87-fc528.htm

87-t05-528.htm

87-fc529.htm

87-t05-529.htm

87-fc551.htm

87-t05-551.htm

87-fc555.htm

87-t05-555.htm

87-fc581.htm

87-t05-581.htm

87-fc582.htm

87-t05-582.htm

87-fc583.htm

87-t05-583.htm

87-fc649.htm

87-t05-649.htm

87-fc719.htm

87-t05-719.htm

87-fc729.htm

87-t05-729.htm

87-fc772.htm

87-t05-772.htm

87-fc773.htm

87-t05-773.htm

87-fc2265.htm

87-t05-2265.htm

87-fc2266.htm

87-t05-2266.htm

87-fcmulti.htm