B5.9G, L10G, C8.3G,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Accelerator Pedal Position Sensor (APPS) Circuit

FAULT CODE 18

Accelerator Pedal Position Sensor (APPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 18 PID: P091 FMI: 4 LAMP: Flash SRT: 00-586 | Invalid voltage detected at the accelerator pedal position pin 16 of the governor control module J2 white connector. | Engine will idle. Override functionality is the limp home mode.

Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator pedal position sensor is attached to the accelerator pedal. The accelerator pedal position sensor sends a signal to the Electronic Control Module (ECM) when the driver pushes on the accelerator pedal.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

  • Make sure there are no external circuits hooked into the accelerator pedal position sensor circuit and that there are no signs of tampering in the circuit.
  • If all the wiring and the sensor checks look good, replace the accelerator pedal position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness.
  • Check that the three accelerator pedal position sensor circuit wires are twisted together. Check that the three idle validation switch circuit wires are twisted together.

Cautions and Warnings

WARNING

Exhaust gas, fuel fumes and engine cooling air can be toxic and cause severe personal injury. Seal openings in the bulkhead around the connector and the wires to prevent toxic and noxious fumes from entering the operator area.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.
Part Number 3823996 - female Weather- Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead.

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.
Part Number 3823995 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal position sensor. |
 | STEP 1A. Inspect the harness and the accelerator pedal position sensor connector pins. | No damaged pins
 | STEP 1B. Check the accelerator pedal position sensor resistance. | 2000 to 3000 ohms
 | STEP 1C. Check for a short circuit to ground of the sensor +5VDC supply. | More than 100k ohms
 | STEP 1D. Check for a short circuit to ground of the sensor signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the governor control module connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply or signal wires of the OEM harness. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground of the accelerator pedal position sensor +5VDC supply circuit. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground of the accelerator pedal position sensor signal circuit. | More than 100k ohms
 | STEP 2E. Check for a short circuit between +5VDC supply wire and any other wire in the OEM harness. | More than 100k ohms
 | STEP 2F. Check for a short circuit between the accelerator pedal position wire and any other wire in the OEM harness. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 18 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the accelerator pedal position sensor.

Guided Step 1A - Inspect the harness and the accelerator pedal position sensor connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or sensor, whichever has the damaged pins.

  • Replace the Weather-Pack connector on the harness. Refer to Procedure 019-201.
  • Replace the OEM harness. Refer to the vehicle manufacturer's instructions.
  • Replace the accelerator pedal position sensor. Refer to the vehicle manufacturer's instructions.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead.

Guided Step 1B - Check for a short circuit between the pins on the sensor.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin C and pin B on the sensor side of the accelerator pedal position sensor connector, when the accelerator pedal is released.

Note: Install the 3-pin repair connector, Part Number 3823255, into the accelerator pedal position sensor.
OK NOT OK

1500 to 3000 ohms

Replace the accelerator pedal position sensor. Refer to the vehicle manufacturer's instructions.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead.

Guided Step 1C - Check for a short circuit to ground of the sensor +5VDC supply.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin C on the sensor side of the accelerator pedal position sensor and the engine block.
OK NOT OK

More than 100k ohms

Replace the accelerator pedal position sensor. Refer to vehicle manufacturer's instructions.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead.

Guided Step 1D - Check for a short circuit to ground of the sensor signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin B on the sensor side of the accelerator pedal position sensor and the engine block.
OK NOT OK

More than 100k ohms

Replace the accelerator pedal position sensor. Refer to the vehicle manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from governor control module.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or governor control module, whichever has the damaged pins.

  • Replace the OEM harness. Refer the vehicle manufacturer's instructions.
  • Replace the governor control module. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.
Part Number 3823995 - male Weather-Pack test lead.

Guided Step 2B - Check for an open circuit in the supply or signal wires of the OEM harness.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance between pin 16 of the governor control module J2 connector and pin C on the harness side of the accelerator pedal position sensor connector.
  • Measure the resistance between pin 3 of the governor control module J2 connector and pin B on the harness side of to accelerator pedal position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to the vehicle manufacturer's instructions.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2C - Check for a short circuit to ground of the accelerator pedal position sensor supply circuit.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the governor control module.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin 16 of the governor control module J2 connector and the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to vehicle manufacturer's instructions.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2D - Check for a short circuit to the ground of the accelerator pedal position sensor signal circuit.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the governor control module.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin 3 of the governor control module J2 connector and the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to vehicle manufacturer's instructions.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2E - Check for a short circuit between the +5V supply wire and any other wire in the OEM harness.

Conditions

  • Key switch in the "OFF" position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure resistance between pin 16 of the governor control module J2 connector and all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to vehicle manufacturer's instructions.

Go to 2F

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Guided Step 2F - Check for a short circuit between the accelerator pedal position signal wire and any other wire in the OEM harness.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the governor control module.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin 3 of the governor control module J2 connector and all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to vehicle manufacturer's instructions.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Connect all the components.
  • Turn the key switch ON and depress the accelerator pedal to full position. Release the pedal and turn the key switch to the OFF position.
  • Verify Fault Code 18 is inactive.
OK NOT OK

Fault Code 18 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Idle Validation Switch (IVS) Circuit

FAULT CODE 21

Idle Validation Switch (IVS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 21 PID: P091 FMI: 13 LAMP: On SRT: 00-587 | Voltage detected simultaneously on both the idle validation off-idle and idle pins 13 and 20 of the governor control module J2 white connector. | No effect on performance.

Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Shop Talk

Make sure that the three idle validation switch circuit wires are twisted together.

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
WARNING

Set the service brake using the trailer hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the governor control module.

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823995 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male AMP/ Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the harness and the idle validation switch connector pins. | No damaged pins
 | STEP 1B. Inspect the harness and the governor control module connection pins. | No damaged pins
 | STEP 1C. Check the supply voltage. | 10V to 15V
 | STEP 1D. Check for an open circuit. | Less than 10 ohms
 | STEP 1E. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1FCheckforashortcircuitfrompintopin.. More than 100k ohms | More than 100k ohms?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault codes inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the harness and the idle validation switch connector pins.

Conditions

  • Key switch in the OFF position.
  • Connect the OEM harness to the idle validation switch.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or sensor, whichever has the damaged pins.

  • Replace the Weather-Pack connector on the harness. Refer to Procedure 019-201.
  • Replace OEM harness. Refer to the OEM Troubleshooting and Repair Manual.
  • Replace idle validation switch. Refer to OEM Troubleshooting and Repair Manual.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

Guided Step 1B - Inspect the harness and the governor control module connector pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the governor control module.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or governor control module, whichever has the damaged pins.

  • Repair or replace AMP connector on the harness. Refer to Procedure 019-203.
  • Replace OEM harness. Refer to the OEM Troubleshooting and Repair Manual.
  • Replace the governor control module. Refer to Procedure 019-094.

Go to 1F

Go to 2A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823995 - male Weather-Pack test lead.

Guided Step 1C - Check the supply voltage.

Conditions

  • Key switch is in the ON position.
  • Disconnect the OEM harness from the idle validation switch.

Action

  • Measure the voltage between pin A on the harness side of the 3 pin idle validation switch connector to the engine block.
OK NOT OK

10 to 15 VDC

Repair the OEM Harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1D

Go to 2A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Weather-Pack test lead.

Guided Step 1D - Check for an open circuit.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the idle validation switch.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 20 in the governor control module J2 connector to pin C in the harness of the idle validation switch connector.
  • Measure the resistance from pin 13 in the governor control module J2 connector to pin B in the harness of the idle validation switch connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1E

Go to 2A

WARNING

Set the service brake using the trailer hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 1E - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness to the idle validation switch.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 20 in the governor control module J2 connector to the engine block.
  • Measure the resistance from pin 13 in the governor control module J2 connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the Idle Validation Switch. Refer to the vehicle Manufacturer's instructions.

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2A

Go to 2A

WARNING

Set the service brake using the trailer hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male AMP/ Metri-Pack test lead.

Guided Step 1F - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the idle validation switch.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 20 in the governor control module J2 connector to all other pins in the governor control module J2 connector.
  • Measure the resistance from pin 13 in the governor control module J2 connector to all other Pins in the governor control module J2 connector.
OK NOT OK

More than 100k ohms

Replace the idle validation switch. Refer to the vehicle manufacturer's instructions.

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

Disable the fault code.

  • Connect all the components.

Action

  • Connect all the components.
  • Turn the key switch ON and completely depress and release the throttle pedal four to five times.
  • Verify fault codes are inactive.
OK NOT OK

Fault codes inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase inactive codes using INSITE™.
OK NOT OK

All fault cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Idle Validation Switch (IVS) Circuit

FAULT CODE 22

Idle Validation Switch (IVS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 22 PID: P091 FMI: 2 LAMP: Flash SRT: 00-588 | No voltage detected simultaneously on both the idle validation off-idle and on-idle pins 13 and 20 of the governor control module J2 white connector. | Engine will only idle.

Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Shop Talk

Make sure that the three idle validation switch circuit wires are twisted together.

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
WARNING

Set the service brake using the trailer hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the governor control module.

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823995 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male AMP/ Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the harness and the idle validation switch connector pins. | No damaged pins
 | STEP 1B. Inspect the harness and the governor control module connection pins. | No damaged pins
 | STEP 1C. Check the supply voltage. | 10V to 15V
 | STEP 1D. Check for an open circuit. | Less than 10 ohms
 | STEP 1E. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1FCheckforashortcircuitfrompintopin.. More than 100k ohms |
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault codes inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the harness and the idle validation switch connector pins.

Conditions

  • Key switch in the OFF position.
  • Connect the OEM harness to the idle validation switch.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins.

Repair the damaged pins

Repair or replace the OEM harness, connector, or sensor, whichever has the damaged pins.

  • Replace the Weather-Pack connector on the harness. Refer to Procedure 019-201.
  • Replace OEM harness. Refer to the OEM Troubleshooting and Repair Manual.
  • Replace idle validation switch. Refer to OEM Troubleshooting and Repair Manual.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

Guided Step 1B - Inspect the harness and the governor control module connector pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the governor control module.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins.

Repair the damaged pins

Repair or replace the OEM harness, connector, or governor control module, whichever has the damaged pins.

  • Repair or replace AMP connector on the harness. Refer to Procedure 019-203.
  • Replace OEM harness. Refer to the OEM Troubleshooting and Repair Manual.
  • Replace the governor control module. Refer to Procedure 019-094.

Go to 1C

Go to 2A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823995 - male Weather-Pack test lead.

Guided Step 1C - Check the supply voltage.

Conditions

  • Key switch is in the ON position.
  • Disconnect the OEM harness from the idle validation switch.

Action

  • Measure the voltage between pin A on the harness side of the 3 pin idle validation switch connector to the engine block.
OK NOT OK

10 to 15 VDC

Repair the OEM Harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1D

Go to 2A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Weather-Pack test lead.

Guided Step 1D - Check for an open circuit.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the idle validation switch.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 20 in the governor control module J2 connector to pin C in the harness of the idle validation switch connector.
  • Measure the resistance from pin 13 in the governor control module J2 connector to pin B in the harness of the idle validation switch connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1E

Go to 2A

WARNING

Set the service brake using the trailer hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 1E - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness to the idle validation switch.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 20 in the governor control module J2 connector to the engine block.
  • Measure the resistance from pin 13 in the governor control module J2 connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the Idle Validation Switch. Refer to the vehicle Manufacturer's instructions.

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2A

Go to 2A

WARNING

Set the service brake using the trailer hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male AMP/ Metri-Pack test lead.

Guided Step 1F - Check for a short circuit from pin to pin.

Conditions

  • Key in the OFF position.
  • Disconnect the OEM harness from the idle validation switch.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 20 in the governor control module J2 connector to all other pins in the governor control module J2 connector.
  • Measure the resistance from pin 13 in the governor control module J2 connector to all other Pins in the governor control module J2 connector.
OK NOT OK

More than 100k ohms

Replace the idle validation switch. Refer to the vehicle manufacturer's instructions.

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

Disable the fault code.

  • Connect all the components.

Action

  • Connect all the components.
  • Turn the key switch ON and completely depress and release the throttle pedal four to five times.
  • Verify fault codes are inactive.
OK NOT OK

Fault codes inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase inactive codes using INSITE™.
OK NOT OK

All fault cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Accelerator Pedal Position Sensor (APPS) Circuit

FAULT CODE 23

Accelerator Pedal Position Sensor (APPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 23 PID: P091 FMI: 3 LAMP: Flash SRT: 00-589 | High voltage detected at accelerator pedal position sensor pins 3 and 17 of the governor control module J2 white connector. | The engine will only idle. Override functionality is in the limp home mode.

Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator pedal position sensor is attached to the accelerator pedal. The accelerator pedal position sensor sensor sends a signal to the Electronic Control Module (ECM) when the driver pushes on the accelerator pedal.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

  • Make sure there are no external circuits hooked into the accelerator pedal position sensor circuit and that there are no signs of tampering in the circuit.
  • If all the wiring and the sensor checks look good, replace the accelerator pedal position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness.
  • Check that the three accelerator pedal position sensor circuit wires are twisted together. Check that the three idle validation switch circuit wires are twisted together.

Cautions and Warnings

WARNING

Exhaust gas, fuel fumes and engine cooling air can be toxic and cause severe personal injury. Seal openings in the bulkhead around the connector and the wires to prevent toxic and noxious fumes from entering the operator area.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather - pack test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather- Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather- Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal position sensor. |
 | STEP 1A. Inspect the harness and the accelerator pedal position sensor connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground on the accelerator pedal position sensor signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the governor control module connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply or signal wires of the OEM harness. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground on the accelerator pedal position sensor supply or signal wire. | More than 100k ohms
 | STEP 2D. Check for a short from pin to pin on the supply and the signal wire. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault codes inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the accelerator pedal position sensor.

Guided Step 1A - Inspect the harness and the accelerator pedal position sensor connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or sensor, whichever has the damaged pins.

  • Replace the Weather-Pack connector on the harness. Refer to Procedure019-201.
  • Replace the OEM harness. Refer to the vehicle manufacturer's instructions.
  • Replace the accelerator pedal position sensor. Refer to the vehicle manufacturer's instructions.

Go to 2A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead.

Guided Step 1B - Check for a short circuit to ground on the accelerator pedal position sensor signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin B on the sensor side of the accelerator pedal position sensor and the engine block.
OK NOT OK

More than 100k ohms

Replace the throttle position sensor. Refer to the vehicle manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the harness and governor control module connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from governor control module.
  • Disconnect the OEM harness from the throttle position sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or ECM whichever has the damaged pins.

  • Repair or replace the 23 pin AMP connector on harness. Refer to Procedure 019-203.
  • Replace the OEM harness. Refer to the vehicle manufacturer's instructions.
  • Replace the governor control module. Refer to Procedure 019-094.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather- Pack test lead.

Guided Step 2B - Check for an open circuit in the supply or signal wires of the OEM harness.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance between pin 16 of the governor control module J2 connector and pin C on the harness side of the accelerator pedal position sensor connector.
  • Measure the resistance between pin 3 of the governor control module J2 connector and pin B on the harness side of the accelerator pedal position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to the vehicle manufacturer's instructions.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2C - Check for a short circuit to ground on the accelerator pedal position sensor supply or signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from governor control module.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin 16 of the governor control module J2 connector and the engine block.
  • Measure the resistance between pin 3 of the governor control module J2 connector and the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to vehicle manufacturer's instructions.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2D - Check for a short circuit from pin to pin on the supply or signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance between pin 16 and all other pins in the governor control module J2 connector.
  • Measure the resistance between pin 3 and all other pins in the governor control module J2 connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to vehicle manufacturer's instructions.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Connect all the components.
  • Turn the key switch ON and depress the throttle pedal to full position. Release the pedal and turn the key switch to the OFF position.
  • Verify Fault codes are inactive.
OK NOT OK

Fault codes inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Accelerator Pedal Position Sensor (APPS) Circuit

FAULT CODE 24

Accelerator Pedal Position Sensor (APPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 24 PID: P091 FMI: 4 LAMP: Flash SRT: 00-590 | Low voltage detected at pins 3 and 17 of the governor control module J2 white connector. | The engine will only idle. Override functionality is in the limp home mode.

Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator pedal position sensor is attached to the accelerator pedal. The accelerator pedal position sensor sensor sends a signal to the Electronic Control Module (ECM) when the driver pushes on the accelerator pedal.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

  • Make sure there are no external circuits hooked into the accelerator pedal position sensor circuit and that there are no signs of tampering in the circuit.
  • If all the wiring and the sensor checks look good, replace the accelerator pedal position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness.
  • Check that the three accelerator pedal position sensor circuit wires are twisted together. Check that the three idle validation switch circuit wires are twisted together.

Cautions and Warnings

WARNING

Exhaust gas, fuel fumes and engine cooling air can be toxic and cause severe personal injury. Seal openings in the bulkhead around the connector and the wires to prevent toxic and noxious fumes from entering the operator area.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather- Pack test lead
Part Number 3823996 - female Weather - pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather- Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal position sensor. |
 | STEP 1A. Inspect the harness and the accelerator pedal position sensor connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground on the accelerator pedal position sensor signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the governor control module connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply or signal wires of the OEM harness. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground on the accelerator pedal position sensor supply or signal wire. | More than 100k ohms
 | STEP 2D. Check for a short from pin to pin on the supply and the signal wire. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault codes inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the accelerator pedal position sensor.

Guided Step 1A - Inspect the harness and the accelerator pedal position sensor connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or sensor, whichever has the damaged pins.

  • Replace the Weather-Pack connector on the harness. Refer to Procedure 019-201.
  • Replace the OEM harness. Refer to the vehicle manufacturer's instructions.
  • Replace the accelerator pedal position sensor. Refer to the vehicle manufacturer's instructions.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead.

Guided Step 1B - Check for a short circuit to ground on the accelerator pedal position sensor signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin B on the sensor side of the accelerator pedal position sensor and the engine block.
OK NOT OK

More than 100k ohms

Replace the throttle position sensor. Refer to the vehicle manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the harness and governor control module connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from governor control module.
  • Disconnect the OEM harness from the throttle position sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or ECM whichever has the damaged pins.

  • Repair or replace the 23 pin AMP connector on harness. Refer to Procedure 019-203.
  • Replace the OEM harness. Refer to the vehicle manufacturer's instructions.
  • Replace the governor control module. Refer to Procedure 019-094.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather- Pack test lead.

Guided Step 2B - Check for an open circuit in the supply or signal wires of the OEM harness.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance between pin 16 of the governor control module J2 connector and pin C on the harness side of the accelerator pedal position sensor connector.
  • Measure the resistance between pin 3 of the governor control module J2 connector and pin B on the harness side of the accelerator pedal position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to the vehicle manufacturer's instructions.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2C - Check for a short circuit to ground on the accelerator pedal position sensor supply or signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from governor control module.
  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance between pin 16 of the governor control module J2 connector and the engine block.
  • Measure the resistance between pin 3 of the governor control module J2 connector and the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to vehicle manufacturer's instructions.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2D - Check for a short circuit from pin to pin on the supply or signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance between pin 16 and all other pins in the governor control module J2 connector.
  • Measure the resistance between pin 3 and all other pins in the governor control module J2 connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to vehicle manufacturer's instructions.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Connect all the components.
  • Turn the key switch ON and depress the throttle pedal to full position. Release the pedal and turn the key switch to the OFF position.
  • Verify Fault codes are inactive.
OK NOT OK

Fault codes inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Accelerator Pedal Position Sensor (APPS) Circuit

FAULT CODE 25

Accelerator Pedal Position Sensor (APPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 25 PID: P091 FMI: 11 LAMP: Flash SRT: 00-591 | The accelerator pedal position sensor and the idle validation contacts do not agree. | Engine will idle. Override functionality is in the limp home mode.

Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator pedal assembly relays the throttle percentage needed to the Electronic Control Module (ECM).

Component Location

The accelerator pedal position sensor is located on the throttle pedal.

Shop Talk

Confirm that the idle validation switch is properly calibrated. Refer to the manufacturer's instructions for adjustment information.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather-Pack test lead
Part Number 3823996 - female Weather-Pack test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather-Pack test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the governor control module harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check the resistance. | 1500 to 3000 ohms (released), 250 to 1500 ohms (depressed).
 | STEP 1B-1. Check the resistance in the accelerator pedal position sensor. | 1500 to 3000 ohms (released), 250 to 1500 ohms (depressed).
 | STEP 1B-2. Check the resistance in the OEM harness. | Less than 10 omhs
 | STEP 1C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 1C-1. Check for an open circuit of the accelerator pedal position sensor supply and return circuit. | 2000 to 3000 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D-1. Check for a short circuit to ground in the accelerator pedal position sensor. | More than 100k ohms
 | STEP 1D-2. Check for a short circuit to ground in the OEM harness. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin in the OEM harness. | More than 100k ohms
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 25 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the governor control module harness and the ECM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the governor control module.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector or governor control module, whichever has the damaged pins. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather-Pack test lead

Guided Step 1B - Check the resistance.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 16 to pin 3 of the governor control module J2 connector with the throttle pedal in the released (idle) position.
  • Repeat the measurement with the throttle pedal in the depressed (full fuel) position. Note: Resistance with the pedal released must be at least 1000 ohms greater than when it is depressed.
OK NOT OK

1500 to 3000 ohms (released)

250 to 1500 ohms (depressed)

Not within specification

Go to 1C

Go to 1B-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

Guided Step 1B-1 - Check the resistance of the accelerator pedal position sensor.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin C to pin B on the sensor side of the accelerator pedal position sensor connector with the throttle pedal in the released (idle) position.
  • Repeat the above measurement with the throttle pedal in the depressed (full fuel) position.
  • Note: Resistance when the pedal is released must be at least 1000 ohms greater than when it is depressed.
OK NOT OK

1500 to 3000 ohms (released)

250 to 1500 ohms (depressed)

Replace the accelerator pedal assembly. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1B-2

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823995 - male Weather-Pack test lead

Guided Step 1B-2 - Check the resistance in the OEM harness.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 16 of the governor control module J2 connector to pin C on the harness side of the accelerator pedal position sensor.
  • Measure the resistance from pin 3 of the governor control module J2 connector to pin B on the harness side of the accelerator pedal position sensor connector.
OK NOT OK

Less than 10 ohms

Greater than 10 ohms

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

Guided Step 1C - Check for an open circuit.

Conditions

  • Key switch in the OFF position.
  • Connect the OEM harness to the accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 16 to pin 17 in the governor control module J2 connector (the accelerator pedal can either be released or depressed).
OK NOT OK

2000 to 3000 ohms

Not within specifiction

Go to 1D

Go to 1C-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

Guided Step 1C-1 - Check for an open circuit of the accelerator pedal position sensor supply and return circuit.

Conditions

  • Disconnect the OEM harness from the accelerator pedal position sensor.

Action

  • Measure the resistance from pin A to pin C on the sensor of the accelerator pedal position sensor (the accelerator pedal can be either released or depressed).
OK NOT OK

2000 to 3000 ohms

Replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Replace the accelerator pedal assembly. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2A

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Connect the OEM harness to the accelerator pedal position sensor.
  • Disconnect the OEM harness from governor control module.

Action

  • Measure the resistance from pin 16 in the governor control module J2 connector to the engine block.
  • Measure the resistance from pin 3 in the governor control module J2 connector to the engine block.
OK NOT OK

More than 100k ohms

Less than 100k ohms

Go to 1D

Go to 1D-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

Guided Step 1D-1 - Check for a short circuit to ground in the accelerator pedal position sensor.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin B on the sensor side of the accelerator pedal position sensor connector to the engine block.
  • Measure the resistance from pin C on the sensor side of the accelerator pedal position sensor connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the accelerator pedal assembly. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1D-2

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Guided Step 1D-2 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 16 of the governor control module J2 connector to the engine block.
  • Measure the resistance from pin 3 of the governor control module J2 connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Guided Step 1E - Check for a short circuit from pin to pin in the OEM harness.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the accelerator pedal position sensor.
  • Disconnect the OEM harness from the governor control module.

Action

  • Measure the resistance from pin 16 in the governor control module J2 connector to all other pins in the connector, except pins 3 and 17.
  • Measure the resistance from pin 3 in the governor control module J2 connector to all other pins in the connector, except pins 16 and 17.
  • Measure the resistance from pin 17 in the governor control module J2 connector to all other pins in the connector, except pins 16 and 3.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Refer to the Troubleshooting and Repair Manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Connect all the components.
  • Start the engine and let idle for one minute.
  • Verify Fault Code 25 is inactive.
OK NOT OK

Fault Code 25 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Engine Speed Sensor Circuit (ESS)

FAULT CODE 34

Engine Speed Sensor Circuit (ESS)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 34 PID: P190 FMI: 2 LAMP: Flash SRT: 00-593 | No engine speed signal detected on pins 16 and 17 of the governor control module J1 black connector. | The throttle plate will close causing the engine to die. Override functionality limits the accelerator pedal authority.

Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor monitors engine speed. The engine speed sensor passes this information to the Governor Control Module through the sensor harness.

Component Location

The engine speed sensor is located on the flywheel housing.

Shop Talk

  • If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor circuit while the engine is at that particular temperature.

Cautions and Warnings

CAUTION

This fault code will become active when the key switch is left in the ON position for more than 30 seconds without starting the engine. If Fault Code 34 logs under these conditions, the faults can be ignored. This behavior is normal.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking measurements.
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823993 - female Deutsch test lead
Part Number 3823994 - male Deutsch test lead
Part Number 3823996 - female Weather- Pack test lead
To reduce the possibility of damaging the new governor control module all other active fault codes must be investigated prior to replacing the governor control module.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking measurements.
Part Number 3823996 - female Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823996 - female Weather-Pack test lead when taking a measurement.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - female AMP/Cannon test lead when taking a measurement.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new governor control module, all other fault codes must be investigated prior to replacing the governor control module.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the harness and the engine speed sensor connectors. | No damaged pins
 | STEP 1B. Inspect the engine speed sensor. | No damage found
 | STEP 1C. Check the engine speed sensor for proper adjustment. | 1/2 to 3/4 of a turn out from the gear
 | STEP 1D. Check the resistance of the engine speed sensor. | 100 to 1500 ohms
 | STEP 1E. Check for a short circuit to ground. | More than 10M ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and the OEM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | More than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 10M ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 10M ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and governor control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 10M ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 10M ohms
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 34 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the harness and the engine speed sensor connectors.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the engine speed sensor.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.

Note: This fault code will log when the key is left in the ON position for more than 30 seconds without starting the engine. If Fault Code 34 logs under those conditions, the faults can be ignored. This behavior is normal.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or the engine speed sensor, whichever has the damaged pins.

  • Repair the 2-pin Weather-pack connector. Refer to Procedure 019-201.
  • Replace the engine wiring harness. Refer to Procedure 019-043.
  • Replace the engine speed sensor. Refer to Procedure 019-042.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

  • metal debris on end of sensor
  • damage on the end of sensor
  • oil leaking or insulation problems such as swelling
  • damaged electrical potting in sensing end of sensor.
OK NOT OK

No damage found

Replace the engine speed sensor. Refer to Procedure 019-042.

Go to 1C

Go to 4A

Guided Step 1C - Check the engine speed sensor for the proper adjustment.

Conditions

  • Key in the OFF position.
  • Disconnect the OEM harness from the engine speed sensor.
OK NOT OK

1/2 to 3/4 of a turn out from the gear

Adjust the engine speed sensor. Refer to Procedure 019-090 or 019-091.

Go to 1D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking measurements.
Part Number 3823996 - female Weather-Pack test lead.

Guided Step 1D - Check the resistance of the engine speed sensor.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the engine position sensor.

Action

  • Measure the resistance from pin A to pin B of the engine speed sensor.
OK NOT OK

100 to 1500 ohms

Replace the engine position sensor. Refer to Procedure 019-038.

Go to 1E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823996 - female Weather-Pack test lead when taking a measurement.

Guided Step 1E - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the engine speed sensor.

Action

  • Measure the resistance from pin A on the sensor side of the engine speed sensor to the engine block.
OK NOT OK

More than 10M ohms

Replace the engine speed sensor. Refer to Procedure 019-042.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the harness and the OEM connector pins.

Conditions

  • Key in the OFF position.
  • Disconnect the 21 pin OEM connector.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the OEM connector, whichever has the damaged pins

  • Repair or replace the 21 pin Deutsch connector. Refer to Procedure 019-208.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2B - Check for an open circuit.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the 21 pin OEM connector.
  • Disconnect the harness from the engine speed sensor.

Action

  • Measure the resistance from pin A on the harness side of the 2 pin Weather-Pack connector to pin J of the 21 pin Deutsch connector.
  • Measure the resistance from pin B on the harness side of the 2 pin Weather-Pack connector to pin H of the 21 pin Deutsch connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-201 or 019-208.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the 21 pin OEM connector.
  • Disconnect the harness from the engine speed sensor.

Action

  • Measure the resistance from pin J on the engine harness side of the OEM connector to the engine block.
  • Measure the resistance from pin H on the engine harness side of the OEM connector to the engine block.
OK NOT OK

More than 10M ohms

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-208.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the ECM.
  • Disconnect the engine speed sensor.

Action

  • Measure the resistance from pin J on the engine harness side of the OEM connector to all other pins in the OEM connector.
  • Measure the resistance from pin H on the engine harness side of the OEM connector to all other pins in the OEM connector.
OK NOT OK

More than 10M ohms

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-208.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging the new governor control module, all other fault codes must be investigated prior to replacing the governor control module.

Guided Step 3A - Inspect the harness and the governor control module connector pins.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the governor control module.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.
  • Replace the governor control module. Refer to Procedure 019-094.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.
Guided Step 3B - Check for an open circuit.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the governor control module.
  • Disconnect the 21 pin OEM connector.

Action

  • Measure the resistance between pin 17 in the governor control module J1 - black connector and pin H in the OEM side of the 21 pin OEM connector.
  • Measure the resistance between pin 16 in the governor control module J1 - black connector and pin J in the 21 pin OEM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the governor control module.
  • Disconnect the 21 pin OEM connector.

Action

  • Measure the resistance between pin 16 in the governor control module J1 - black connector to the engine block.
  • Measure the resistance between pin 17 in the governor control module J1 - black connector to the engine block.
OK NOT OK

More than 10M ohms

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.
Guided Step 3D - Check from a short circuit from pin to pin.

Conditions

  • Key in the OFF position.
  • Disconnect the harness from the ECM.
  • Disconnect the 21 pin OEM connector.

Action

  • Measure the resistance between pin 16 in the governor control module J1 - black connector to all other pins in the governor control module J1 - black connector.
  • Measure the resistance between pin 17 in the governor control module J1 - black connector to all other pins in the governor control module J1 - black connector.
OK NOT OK

More than 10M ohms

Repair or replace the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

Connect all components.

Action

  • Connect all components.
  • Start the engine and let idle for 1 minute.
OK NOT OK

Fault Code 34 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Return to appropriate troubleshooting charts for any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


Vehicle Speed Sensor (VSS) Circuit

FAULT CODE 35

Vehicle Speed Sensor (VSS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 35 PID: P084 FMI: 2 LAMP: On SRT: 00-594 | Invalid vehicle speed signal detected on pins 23 of the governor control module J2 white connector. | Maximum engine speed is limited to the value set for maximum engine speed without VSS. Cruise control and road speed governing will not work.

VSS Circuit

Circuit Description

The vehicle speed sensor (VSS) uses two separate coils of wire to count gear teeth as they pass in front of the sensor. One coil is used by the governor control module to sense vehicle speed. The other coil is sometimes used by the OEM to send a vehicle speed signal to the speedometer.

Component Location

The VSS is installed in the rear of the transmission.

Shop Talk

  • Disconnect the VSS connector that connects to the OEM speedometer, or trip recorder, and move the truck. If the fault goes inactive, there is probably electrical noise being fed into the VSS circuit from the OEM device.
  • Verify the VSS wires in the OEM harness are twisted pairs.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead
Part Number 3823996 - female Weather-Pack test lead

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the VSS. |
 | STEP 1A. Inspect the harness and the sensor connector pins. | No damaged pins
 | STEP 1B. Check the VSS for proper adjustment. | 1/2 to 3/4 turn out from gear
 | STEP 1C. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1D. Check the VSS for the correct resistance. | 750 to 1500 ohms
 | STEP 1E. Check the VSS for a short circuit to ground. | More than 10M ohms
 | STEP 1F. Check the VSS for a short circuit between coils. | More than 10M ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check for the correct circuit resistance. | 750 to 1500 ohms
 | STEP 2B. Check the harness for a short circuit to ground. | More than 10M ohms
 | STEP 2C. Check the harness for a short circuit to the switch supply wire. | More than 10M ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 35 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the VSS.

Guided Step 1A - Inspect the harness and the sensor connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the VSS.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness, connector, or sensor, whichever has the damaged pins.

  • Replace the Weather-Pack connectors on the harness. Refer to Procedure 019-201.
  • Replace the VSS. Refer to Procedure 019-090 or 019-091.

Go to 1B

Go to 3A

Guided Step 1B - Check the VSS for the proper adjustment.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the VSS.

Action

Check the VSS for the proper adjustment.
OK NOT OK

1/2 to 3/4 of a turn out from the gear

Adjust the VSS. Refer to Procedure 019-090 or 019-091.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the harness and the ECM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 23 pin J2 connector from the governor control module.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness, connector, or governor control module, whichever has the damaged pins.

  • Repair the OEM harness. Refer to the OEM Troubleshooting and Repair Manual.
  • Replace the governor control module. Refer to Procedure 019-094.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

Guided Step 1D - Check the VSS for the correct resistance.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the VSS.

Action

  • Measure the resistance from pin A to pin B or each VSS connector on the sensor side.
OK NOT OK

750 to 1500 ohms

Replace the VSS. Refer to Procedure 019-090 or 019-091.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

Guided Step 1E - Check the VSS for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

  • Measure the resistance between pin A on the sensor side of one of the VSS connectors and the engine block.
  • Measure the resistance between pin A on the sensor side of the other VSS connector and the engine block.
OK NOT OK

More than 10M ohms

Replace the VSS. Refer to Procedure 019-090 or 019-091.

Go to 1F

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823996 - female Weather-Pack test lead

Guided Step 1F - Check the VSS for a short circuit between coils.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM harness from the VSS.

Action

  • Measure the resistance between pin A on the sensor side of one of the VSS connectors and pin A of the other connector.
OK NOT OK

More than 10M ohms

Replace the VSS. Refer to Procedure 019-090 or 019-091.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Guided Step 2A - Check for the correct circuit resistance.

Conditions

  • Key switch in the OFF position.
  • Disconnect the J2 connector from the governor control module.
  • Connect the harness from the VSS.

Action

  • Check the harness for the proper resistance between pin 22 and pin 23 of the governor control module J2 connector.
OK NOT OK

750 to 1500 ohms

Repair the harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Guided Step 2B - Check the harness for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the VSS.
  • Disconnect the J2 connector from the governor control module.

Action

  • Measure the resistance from pin 22 of the harness connector to the engine block.
  • Measure the resistance from pin 23 of the harness connector to the engine block.
OK NOT OK

More than 10M ohms

Repair the harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823993 - male Deutsch test lead

Guided Step 2C - Check the harness for a short from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the VSS.
  • Disconnect the J2 connector from the governor control module.

Action

  • Measure the resistance from pins 3 and 7 to all other pins in the J2 connector.
OK NOT OK

More than 10M ohms

Repair the harness. Refer to the OEM Troubleshooting and Repair Manual.

Go to 2D

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Connect all the components.
  • Drive the vehicle. The vehicle speed must exceed 10 mph.
OK NOT OK

Fault Code 35 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Throttle Plate Actuator (TPA) Circuit

FAULT CODE 41

Throttle Plate Actuator (TPA) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 41 PID: S24 FMI: 4 LAMP: Flash SRT: 00-595 | High voltage detected on throttle plate actuator 12 and 14 of the governor control module J1 black connector. | The throttle plate will close causing the engine to die. Override functionality is to ignore the fault.

Throttle Plate Actuator Circuit

Circuit Description

The throttle plate actuator sends the ECM a voltage signal that is proportional to the throttle plate position.

Component Location

The throttle plate actuator is mounted on the intake manifold.

Shop Talk

The C8.3G and L10G have a throttle plate actuator. The B5.9G does not have one. The B5.9G throttle plate is mechanically connected to the vehicle accelerator pedal.

Check the 10A throttle plate actuator fuse.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823996 - Female Weather - Pack test lead
Part Number 3823998 - male Deutsch test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823993 - Female Deutsch test lead
Part Number 3822996 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822758 female AMP/Cannon test leads when taking a measurement.

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823994 - male Deutsch test lead
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the throttle plate actuator. |
 | STEP 1A. Inspect engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Inspect the OEM connector. | No damaged pins
 | STEP 1C. Check for an open circuit in the signal wire. | Less than 10 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1E. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the governor control module and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the signal wire. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable fault code. | Fault codes inactive
 | STEP 3B. Clear inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect engine harness and sensor connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the throttle plate actuator.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair the harness or throttle plate actuator, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 21 pin OEM connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-208.

Go to 1D

3A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823993 - Female Deutsch test lead
Part Number 3822996 - male Weather-Pack test lead.

Guided Step 1C - Check for an open circuit in the signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 21 pin Deutsch connector.
  • Disconnect the engine harness from the throttle plate actuator.

Action

  • Measure the resistance from pin R of the 21 pin OEM connector to pin F on the harness side of the throttle plate actuator connector.
OK NOT OK

Less than 10 ohms

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-208.
  • Repair the 6 pin Weather-Pack connector. Refer to Procedure 019-201.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823993 - Female Deutsch test lead
Part Number 3822996 - male Weather-Pack test lead.

Guided Step 1D - Check for short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 21 pin OEM connector.
  • Disconnect the engine harness from the throttle plate actuator.

Action

  • Measure the resistance from pin R on the engine side of the OEM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-208.
  • Repair the 6 pin Weather-Pack connector. Refer to Procedure 019-201.

2A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822758 female AMP/Cannon test leads when taking a measurement.

Guided Step 1E - Check for a short circuit to ground in the Signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 21 pin OEM connector.
  • Disconnect the engine harness from the throttle plate actuator.

Action

  • Measure the resistance from pin R on the engine side of the OEM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-208.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

Guided Step 2A - Inspect governor control module and harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the governor control module.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace or repair the harness or governor control module, whichever has the damaged pins.

  • Replace the 23 pin governor control module connector. Refer to the OEM Troubleshooting and Repair Manual.
  • Replace the governor control module. Refer to Procedure 019-094.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823994 - male Deutsch test lead
Part Number 3823993 - male Deutsch test lead.

Guided Step 2B - Check for an open circuit in the signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the governor control module.
  • Disconnect the 21 OEM connector.

Action

  • Measure the resistance from pin R on the OEM side of the 21 pin OEM connector to pin 12 of the governor control module J1 connector.
OK NOT OK

Less than 10 ohms

  • Repair the harness.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the governor control module.
  • Disconnect the 21 pin OEM connector.

Action

  • Measure the resistance from pin 12 in the governor control module J1 connector to all other pins in the governor control module J1 connector.
OK NOT OK

More than 100k ohms

  • Replace the throttle plate actuator. Refer to Procedure 019-097.

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-203.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.
Guided Step 2D - Check for a short circuit to ground in the signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the governor control module.
  • Disconnect the 21 pin OEM connector.

Action

  • Measure the resistance from pin 12 of the governor control module J1 connector to the engine block.
OK NOT OK

More than 100k ohms

  • Replace the throttle plate actuator. Refer to Procedure 019-097.

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-203.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear fault codes.

Guided Step 3A - Disable fault code.

Conditions

  • Reconnect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase inactive codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Go to appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Throttle Plate Actuator (TPA) Circuit

FAULT CODE 43

Throttle Plate Actuator (TPA) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 43 PID: S24 FMI: 4 LAMP: Flash SRT: 00-596 | Low voltage detected on throttle plate actuator pins 12 and 14 of the governor control module J1 black connector. | The throttle plate will close causing the engine to die. Override functionality id to ignore the fault.

Throttle Plate Actuator Circuit

Circuit Description

The throttle plate actuator sends the ECM a voltage signal that is proportional to the throttle plate position.

Component Location

The throttle plate actuator is mounted on the intake manifold.

Shop Talk

The C8.3G and L10G have a throttle plate actuator. The B5.9G does not have one. The B5.9G throttle plate is mechanically connected to the vehicle accelerator pedal.

Check the 10A throttle plate actuator fuse.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823996 - Female Weather - Pack test lead
Part Number 3823998 - male Deutsch test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823993 - Female Deutsch test lead
Part Number 3822996 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822758 female AMP/Cannon test leads when taking a measurement.

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823994 - male Deutsch test lead
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the throttle plate actuator. |
 | STEP 1A. Inspect engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Inspect the OEM connector. | No damaged pins
 | STEP 1C. Check for an open circuit in the signal wire. | Less than 10 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1E. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the governor control module and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the signal wire. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable fault code. | Fault codes inactive
 | STEP 3B. Clear inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect engine harness and sensor connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the throttle plate actuator.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair the harness or throttle plate actuator, whichever has the damaged pins.

  • Repair the 6 pin Weather-Pack connector. Refer to Procedure 019-201.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 21 pin OEM connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-208.

Go to 1C

3A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823993 - Female Deutsch test lead
Part Number 3822996 - male Weather-Pack test lead.

Guided Step 1C - Check for an open circuit in the signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 21 pin Deutsch connector.
  • Disconnect the engine harness from the throttle plate actuator.

Action

  • Measure the resistance from pin R of the 21 pin OEM connector to pin F on the harness side of the throttle plate actuator connector.
OK NOT OK

Less than 10 ohms

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-208.
  • Repair the 6 pin Weather-Pack connector. Refer to Procedure 019-201.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823993 - Female Deutsch test lead
Part Number 3822996 - male Weather-Pack test lead.

Guided Step 1D - Check for short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 21 pin OEM connector.
  • Disconnect the engine harness from the throttle plate actuator.

Action

  • Measure the resistance from pin R on the engine side of the OEM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-208.
  • Repair the 6 pin Weather-Pack connector. Refer to Procedure 019-201.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822758 female AMP/Cannon test leads when taking a measurement.

Guided Step 1E - Check for a short circuit to ground in the Signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the 21 pin OEM connector.
  • Disconnect the engine harness from the throttle plate actuator.

Action

  • Measure the resistance from pin R on the engine side of the OEM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-208.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging the new governor control module, all other active fault codes must be investigated prior to replacing the governor control module.

Guided Step 2A - Inspect governor control module and harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the governor control module.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace or repair the harness or governor control module, whichever has the damaged pins.

  • Replace the 23 pin governor control module connector. Refer to the OEM Troubleshooting and Repair Manual.
  • Replace the governor control module. Refer to Procedure 019-094.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823994 - male Deutsch test lead
Part Number 3823993 - male Deutsch test lead.

Guided Step 2B - Check for an open circuit in the signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the governor control module.
  • Disconnect the 21 OEM connector.

Action

  • Measure the resistance from pin R on the OEM side of the 21 pin OEM connector to pin 12 of the governor control module J1 connector.
OK NOT OK

Less than 10 ohms

  • Repair the harness. Refer to Procedure 019-203 or 019-208.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the governor control module.
  • Disconnect the 21 pin OEM connector.

Action

  • Measure the resistance from pin 12 in the governor control module J1 connector to all other pins in the governor control module J1 connector.
OK NOT OK

More than 100k ohms

  • Replace the throttle plate actuator. Refer to Procedure 019-097.

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-203.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

2D for 43
3A for 41

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823993 - male Deutsch test lead when taking a measurement.
Guided Step 2D - Check for a short circuit to ground in the signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the governor control module.
  • Disconnect the 21 pin OEM connector.

Action

  • Measure the resistance from pin 12 of the governor control module J1 connector to the engine block.
OK NOT OK

More than 100k ohms

  • Replace the throttle plate actuator. Refer to Procedure 019-097.

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-203.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear fault codes.

Guided Step 3A - Disable fault code.

Conditions

  • Reconnect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase inactive codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Go to appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Internal Electronic Control Module (ECM) Error

FAULT CODE 111

Internal Electronic Control Module (ECM) Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 FMI: 12 LAMP: Flash SRT: 00-301 | Internal electronic control module (ECM) failure or no calibration in the ECM. | Engine will not start or run.

Circuit Description

The ECM is a computer that is responsible for engine control and diagnostics.

Component Location

B5.9G and C8.3G: The ECM is installed on the left side of the engine behind the Ignition Control Module (ICM).

L10G: The ECM is installed on the left side of the engine beside the Ignition Control Module (ICM).

Shop Talk

This fault involves the internal circuitry of the ECM. The ECM can not be repaired in the field.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault code. |
 | STEP 1A. Check for active fault code. | Fault code inactive
 | STEP 1A-1. Check for active fault code. |
STEP 2. | Clear fault code. |
 | STEP 2A. Clear fault code. | All faults cleared

Guided Step 1 - Check for active fault code.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Check for active fault code.

Action

  • Turn the vehicle key switch OFF and wait at least five seconds.
  • Turn vehicle key switch ON.
  • Idle engine for at least one minute (if the engine will run).
  • Check whether the fault code is active or inactive.
OK NOT OK

Fault code inactive

Calibrate the ECM

Go to 2A

Go to 1A-1

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A-1 - Check for active fault code.

Action

  • Turn vehicle key switch OFF and wait at least five seconds.
  • Turn vehicle key switch ON.
  • Idle engine for at least one minute (if the engine will run).
  • Check whether the fault code is active or inactive.
OK NOT OK

Fault code inactive

Replace the ECM

The ECM has failed.

  • Replace the ECM. Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear fault code.

Guided Step 2A - Clear fault code.

Conditions

  • Reconnect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Engine Position Sensor (EPS) Circuit

FAULT CODE 121

Engine Position Sensor (EPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 FMI: 10 LAMP: Flash SRT: 00-302 | Invalid engine speed signal detected on pin 4 and 17 of the ECM connector. | Engine can die. Engine will not start.

EPS Circuit

Circuit Description

The EPS monitors engine position and engine speed. The EPS passes this information to the Electronic Control Module (ECM) through the harness.

Component Location

The EPS is located on the back side of the gear housing.

Shop Talk

  • If the problem occurs only at a certain engine temperature, be sure to check the EPS circuit while the engine is at that particular temperature.
  • Check the camshaft end play to make sure that the camshaft gear is not moving too far away from the end of the EPS.
  • This fault is triggered when the ECM does not detect engine speed when the manifold absolute pressure sensor is reading a vacuum.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking measurements.
Part Number 3822917 - female AMP/Cannon test lead
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin damage use the mating connector when taking a measurement.
CAUTION

To reduce the possibility of pin damage use the Part Number 3823995 - male Weather-Pack test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

CAUTION

To reduce the possibility of pin and harness damage use the following when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EPS. |
 | STEP 1A. Inspect the harness and the EPS connectors. | No damaged pins
 | STEP 1B. Inspect the EPS. | No damage found
 | STEP 1C. Check the resistance of the EPS. | 1000 to 2000 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 10M ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in EPS and harness circuit. | 1000 to 2000 ohms
 | STEP 2B1. Check for an open circuit in EPS circuit. |
 | STEP 2C. Check for a short circuit to ground. | More than 10M ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 10M ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the EPS.

Guided Step 1A - Inspect the harness and the EPS connector.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the EPS.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or the EPS, whichever has the damaged pins.

  • Repair the 4-Pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the engine wiring harness. Refer to Procedure 019-043.
  • Replace EPS. Refer to Procedure 019-038.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the EPS.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the EPS.
  • Remove the EPS using installation tool, Part Number 3822747.

Action

  • metal debris on end of sensor
  • damage to end of sensor caused by the camshaft gear
  • oil leakage or insulation problems such as swelling
  • damaged electrical potting in sensing end of sensor.
OK NOT OK

No damage found

Replace the EPS

  • Replace the EPS. Refer to Procedure 019-038.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin damage use the mating connector when taking a measurement.
Guided Step 1C - Check the resistance of EPS.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the EPS.
  • Install the EPS. Refer to Procedure 019-038.

Action

  • Measure the resistance from pin B to pin C of the EPS.
  • Note: Install a mating connector with short test leads to the sensor connector. While testing the sensor, electrical leads from the sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.
OK NOT OK

1000 to 2000 ohms

Replace the EPS. Refer to Procedure 019-038.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin damage use the Part Number 3823995 - male Weather-Pack test lead when taking a measurement.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the EPS.

Action

  • Measure the resistance from pin B on the sensor side of the EPS to the engine block.
  • Note: Install a mating connector with short test leads to the sensor connector. While testing the sensor, electrical leads from the sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.
OK NOT OK

More than 10M ohms

Repair or replace the EPS

  • Replace the EPS. Refer to Procedure 019-038.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace the engine wiring harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

CAUTION

To reduce the possibility of pin and harness damage use the following when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead

Guided Step 2B - Check for an open circuit in the EPS and the harness circuit.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.
  • Connect the harness to the EPS.

Action

  • Measure the resistance from pin 4 to pin 17 on the harness side of the ECM connector.
OK NOT OK

1000 to 2000 ohms

Greater than 2000 ohms.

Go to 2C

Go to 2B-1

CAUTION

To reduce the possibility of pin and harness damage use the following when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead

Guided Step 2B1 - Check for an open circuit in the EPS circuit.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.
  • Disconnect the harness from the EPS.

Action

  • Measure the resistance from pin 4 to pin B on the harness side of the ECM connector.
  • Measure the resistance from pin 17 on the harness side of the ECM connector to pin C on the harness side of the sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-201 or 019-203.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.
  • Connect the harness to the EPS.

Action

  • Measure the resistance from pin 4 to the engine block.
  • Measure the resistance from pin 17 to the engine block.
OK NOT OK

More than 10M ohms

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-203.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2D - Check for short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.
  • Connect the harness to the EPS.

Action

  • Measure resistance from pin 4 and pin 17 of the ECM connector to all other pins in the connector. Note: Do not measure from pin 4 to pin 17.
OK NOT OK

More than 10M ohms

Repair or replace the engine wiring harness

  • Repair the engine wiring harness. Refer to Procedure 019-203.
  • Replace the engine wiring harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let idle for 1 minute.
OK NOT OK

Fault Code 121 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Refer to appropriate troubleshooting charts for any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Mixer Inlet Pressure Sensor (MIPS) Circuit

FAULT CODE 122

Mixer Inlet Pressure Sensor (MIPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 FMI: 3 LAMP: On SRT: 00-303 | High voltage detected at the MIPS pin 15 of the ECM connector. | Possible reduced performance.

MIPS Circuit

Circuit Description

This sensor measures the mixer inlet air pressure. The pressure at the mixer inlet is the same as the pressure at the turbocharger compressor outlet, or the boost pressure. The electronic control module (ECM) uses the value of mixer inlet pressure for controlling the wastegate. If mixer inlet pressure (boost) becomes too high, the engine will shut off fuel while the pressure is above normal; normal fueling will start when the mixer inlet pressure drops to normal operating levels.

Component Location

B5.9G: The MIPS is installed immediately upstream of the mixer.

C8.3G: The MIPS is installed on the air inlet on the left side of the engine.

L10G: The MIPS is installed on the air inlet above the fuel control valves.

Shop Talk

If the MIPS is disconnected, the engine can continue operating by using the throttle plate position and the manifold absolute pressure to estimate the mixer inlet pressure.

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To avoid damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the Part Number 3822917-female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the MIPS. |
 | STEP 1A. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the supply voltage. | 4.75 to 5.25V
 | STEP 1C. Check the signal voltage. | 1.62 to 1.74V
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit between the sensor signal and supply wire and other wires in the harness. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear inactive fault codes. | All faults cleared

Guided Step 1 - Check the MIPS.

Guided Step 1A - Inspect the harness and sensor connector pins.

Conditions

  • Key switch in the "OFF" position.
  • Disconnect the harness connector from the ECM.
  • Disconnect the harness from the MIPS.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or replace the MIPS, whichever has the damaged pins.

  • Replace the 3-pin Metric-pack connector. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the MIPS. Refer to Procedure 019-099.

Go to 1B

Go to 3A

Guided Step 1B - Check the supply voltage.

Conditions

  • Key switch in the "ON" position.

Action

  • Install breakout cable between the sensor and the harness connector.
  • Measure the supply voltage by installing the breakout cable supply pin A and return pin B connectors into the volt ohm meter.
OK NOT OK

4.75 to 5.25V

Repair or replace the engine harness

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 3A

Guided Step 1C - Check the signal voltage.

Conditions

  • Key switch in the "ON" position.

Action

  • Measure the signal voltage by installing the breakout cable signal pin C and return connector pin B into the volt ohm meter.
OK NOT OK

1.62 to 1.74

Replace the MIPS

  • Refer to Procedure 019-099.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To avoid damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Key switch in the "OFF" position.
  • Disconnect the harness connector from the ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins
Repair the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To avoid pin and harness damage, use the Part Number 3822917-female AMP/Cannon test lead when taking a measurement.
Guided Step 2B - Check for a short circuit between the sensor signal and supply wire and other wires in the harness.

Conditions

  • Key switch in the "OFF" position.
  • Disconnect the harness connector from the ECM.
  • Disconnect the harness from the MIPS.

Action

  • Measure the resistance between ECM connector pin 15 and all other pins in the ECM connector
  • Measure the resistance between the ECM connector pin 18 and all other pins in the ECM connector.
OK NOT OK

More than 100k ohms.

  • Replace the MIPS. Refer to Procedure 019-099.

Repair or replace the harness

  • Repair the harness.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all the components
  • Start engine and let idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Apr-2003


Mixer Inlet Pressure Sensor (MIPS) Circuit

FAULT CODE 123

Mixer Inlet Pressure Sensor (MIPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 FMI: 4 LAMP: On SRT: 00-304 | Low voltage detected at the MIPS 15 of the ECM connector. | Possible reduced performance.

MIPS Circuit

Circuit Description

This sensor measures the mixer inlet air pressure. The pressure at the mixer inlet is the same as the pressure at the turbocharger compressor outlet, or the boost pressure. The electronic control module (ECM) uses the value of mixer inlet pressure for controlling the wastegate. If mixer inlet pressure (boost) becomes too high, the engine will shut off fuel while the pressure is above normal; normal fueling will start when the mixer inlet pressure drops to normal operating levels.

Component Location

B5.9G: The MIPS is installed immediately upstream of the mixer.

C8.3G: The MIPS is installed on the air inlet on the left side of the engine.

L10G: The MIPS is installed on the air inlet above the fuel control valves.

Shop Talk

If the MIPS is disconnected, the engine can continue operating by using the throttle plate position and the manifold absolute pressure to estimate the mixer inlet pressure.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the Part Number 3822917-female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the MIPS. |
 | STEP 1A. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the supply voltage. | 4.75 to 5.25V
 | STEP 1C. Check the signal voltage. | 1.62 to 1.74V
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit between the sensor signal and supply wire and other wires in the harness. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear inactive fault codes. | All faults cleared

Guided Step 1 - Check the MIPS.

Guided Step 1A - Inspect the harness and sensor connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness connector from the ECM.
  • Disconnect the harness from the MIPS.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or replace the MIPS, whichever has the damaged pins.

  • Replace the 3-pin Metric-pack connector. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the MIPS. Refer to Procedure 019-099.

Go to 1B

Go to 3A

Guided Step 1B - Check the supply voltage.

Conditions

  • Key switch in the ON position.

Action

  • Install breakout cable between the sensor and the harness connector.
  • Measure the supply voltage by installing the breakout cable supply pin A and return pin B connectors into the volt ohm meter.
OK NOT OK

4.75 to 5.25V

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 or 019-203.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 3A

Guided Step 1C - Check the signal voltage.

Conditions

  • Key switch in the ON position.

Action

  • Measure the signal voltage by installing the breakout cable signal pin C and return connector pin B into the volt ohm meter.
OK NOT OK

1.62 to 1.74

Replace the MIPS. Refer to Procedure 019-099.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness connector from the ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the Part Number 3822917-female AMP/Cannon test lead when taking a measurement.

Guided Step 2B - Check for a short circuit between the sensor signal and supply wire and other wires in the harness.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness connector from the ECM.
  • Disconnect the harness from the MIPS.

Action

  • Measure the resistance between ECM connector pin 15 and all other pins in the ECM connector
  • Measure the resistance between the ECM connector pin 18 and all other pins in the ECM connector.
OK NOT OK

More than 100k ohms

  • Replace the MIPS. Refer to Procedure 019-099.

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all the components
  • Start engine and let idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Coolant Temperature Sensor Circuit

FAULT CODE 144

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 FMI: 3 LAMP: On SRT: 00-306 | Open circuit or high voltage detected at coolant temperature pin 5 of the ECM connector. | Possible reduced performance. No engine protection for coolant temperature (if enabled).

Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the Electronic Control Module (ECM) to monitor the temperature of the engine coolant. The ECM uses the coolant temperature signal for the coolant overheat engine protection feature and to determine whether to use the hot or cold idle speed.

Component Location

B5.9G, C8.3G and L10G: The coolant temperature sensor is installed in a port on the lower edge of the head the left side of the engine.

Shop Talk

All Temperature Sensors:

  • The resistance of the sensor varies with temperature. The reading that you observe should compare to the following table if the sensor is functioning properly.
Temperature | Temperature | Resistance
(°C) | (°F) | (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault can log in extremely cold weather.

Cautions and Warnings

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822758 - male AMP/Cannon test lead
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823256, 2-Way Metric-Pack connector test lead.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823256 - 2-way Metric-Pack connector test lead when taking a measurement.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the harness and the sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the coolant temperature sensor. | 175 ohms to 244k ohms
 | STEP 1C. Check for a short circuit to ground in the coolant temperature sensor. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Clear the inactive fault codes. | All faults cleared
 | STEP 3B. Clear inactive fault codes. | All faults cleared

Guided Step 1 - Check the coolant temperature sensor.

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
Guided Step 1A - Inspect the harness and the sensor connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from coolant temperature sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pin
  • Corroded pins
  • Moisture in or on connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness, connector, or sensor, whichever has the damaged pins.

  • Replace the 2-Pin Metri-Pack connector. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019.

Go to 1B

Go to 3A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3823256, 2-Way Metric-Pack connector test lead.

Guided Step 1B - Check the resistance of the coolant temperature sensor.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the coolant temperature sensor.

Action

  • Measure the resistance between the two pins on the sensor side of the coolant temperature sensor connector.
OK NOT OK

175 ohms to 244k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019.

Go to 2A

Go to 3A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3823256 - 2-way Metric-Pack connector test lead when taking a measurement.

Guided Step 1C - Check for a short circuit to ground in the sensor

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the coolant temperature sensor.

Action

  • Measure the resistance from one of the pins on the sensor side of the coolant temperature sensor connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the coolant temperature sensor.
  • Disconnect the harness from the ECM.
  • Disconnect the harness from the throttle plate position sensor (B5.9G only).
  • Disconnect the harness from the intake manifold temperature sensor.
  • Disconnect the harness from the manifold absolute pressure sensor.
  • Disconnect the harness from the mixer inlet pressure sensor.
  • Disconnect the harness from the gas mass flow sensor.
  • Disconnect the harness from the ignition control module.

Action

  • Measure the resistance between pin 5 in the ECM connector and all of the other pins in the connector
  • Measure the resistance between pin 27 in the ECM connector and all of the other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure019-203.
  • Replace the harness. Refer to Procedure019-043 .

Go to 2C

Go to 3A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2C - Check for an open circuit.

Conditions

  • Key switch in the OFF position.
  • Disconnect the coolant temperature sensor.
  • Disconnect the ECM.

Action

  • Measure the resistance between pin 27 of the ECM connector and pin B on the harness side of the coolant temperature sensor connector
  • Measure the resistance between pin 5 of the ECM connector and pin A of the harness side of the coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-202 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

WARNING

Wait until the coolant temperature is below 50°C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Steam or heated coolant spray can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2D - Check for a short circuit to ground in the signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect harness from the coolant temperature sensor.
  • Disconnect harness from ECM.

Action

Measure resistance from pin 5 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable fault code.

Conditions

  • Connect all components.

Action

  • Connect all components
  • Start the engine and let idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3A - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Coolant Temperature Sensor Circuit

FAULT CODE 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 FMI: 4 LAMP: On SRT: 00-307 | Short to ground detected at coolant temperature pin 5 of the ECM connector. | May increase idle speed. No engine protection for coolant temperature (if enabled).

Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the Electronic Control Module (ECM) to monitor the temperature of the engine coolant. The ECM uses the coolant temperature signal for the coolant overheat engine protection feature and to determine whether to use the hot or cold idle speed.

Component Location

B5.9G, C8.3G and L10G: The coolant temperature sensor is installed in a port on the lower edge of the head the left side of the engine.

Shop Talk

All Temperature Sensors:

  • The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault can log in extremely cold weather.

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male AMP/Cannon test lead
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-Way Metri-Pack connector test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-way Metri-Pack connector test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the harness and the sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the coolant temperature sensor. | 175 ohms to 244k ohms
 | STEP 1C. Check for a short circuit to ground in the coolant temperature sensor. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant temperature sensor.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
Guided Step 1A - Inspect the harness and the sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from coolant temperature sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness, connector, or sensor, whichever has the damaged pins.

  • Replace the 2-Pin Metri-Pack connector. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019.

Go to 1B

Go to 3A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-Way Metri-Pack connector test lead.

Guided Step 1B - Check the resistance of the coolant temperature sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from coolant temperature sensor.

Action

  • Measure the resistance between the two pins on the sensor side of the coolant temperature sensor connector.
OK NOT OK

175 ohms to 244k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019.

Go to 1C

Go to 3A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-way Metri-Pack connector test lead.

Guided Step 1C - Check for a short circuit to ground in the sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from coolant temperature sensor.

Action

  • Measure the resistance from one of the pins on the sensor side of the coolant temperature sensor connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.
Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from coolant temperature sensor.
  • Disconnect harness from ECM.
  • Disconnect harness from throttle plate position sensor (B5.9G only).
  • Disconnect harness from intake manifold temperature sensor.
  • Disconnect harness from manifold absolute pressure sensor.
  • Disconnect harness from mixer inlet pressure sensor (MIPS).
  • Disconnect harness from gas mass flow sensor.
  • Disconnect harness from ignition control module (ICM).

Action

  • Measure the resistance between pin 5 in the ECM connector and all of the other pins in the connector
  • Measure the resistance between pin 27 in the ECM connector and all of the other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect coolant temperature sensor.
  • Disconnect ECM.

Action

  • Measure the resistance between pin 27 of the ECM connector and pin B on the harness side of the coolant temperature sensor connector
  • Measure the resistance between pin 5 of the ECM connector and pin A on the harness side of the coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-202 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit to ground in the signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from coolant temperature sensor.
  • Disconnect harness from ECM.

Action

Measure resistance from pin 5 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3A - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Intake Manifold Temperature Sensor Circuit

FAULT CODE 153

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 FMI: 3 LAMP: On SRT: 00-309 | Open circuit or high voltage detected at intake manifold temperature sensor pin 28 of the ECM connector. | Possible reduced performance. No engine protection for intake manifold temperature (if enabled).

Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel/manifold mixture in the intake manifold. The ECM uses intake manifold temperature to control the engine and for the intake manifold overheat engine protection feature.

Component Location

B5.9G: The intake manifold temperature sensor is installed immediately downstream of the throttle plate next to the manifold absolute pressure sensor.

C8.3G: The intake manifold temperature sensor is installed on the intake manifold below the manifold absolute pressure sensor.

L10G: The intake manifold temperature sensor is installed on the intake manifold next to the manifold absolute pressure sensor.

Shop Talk

All Temperature Sensors

  • The resistance of the sensor varies with temperature. The reading that you observe should compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault may log in extremely cold weather.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-way Metri-Pack connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold temperature sensor. |
 | STEP 1A. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the intake manifold temperature sensor. | 175 ohms to 244k ohms
 | STEP 1C. Check for a short circuit to ground in the intake manifold temperature sensor. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the intake manifold temperature sensor.

Guided Step 1A - Inspect the harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or the intake manifold temperature sensor, whichever has the damaged pins.

  • Replace the 2-pin Metri-Pack connector. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-way Metri-Pack connector test lead.

Guided Step 1B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.

Action

  • Measure the resistance between the two pins on the sensor side of the intake manifold temperature sensor connector.
OK NOT OK

175k ohms to 244k ohms

Replace the intake manifold temperature sensor

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059.

Go to 2A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-way Metri-Pack connector test lead.

Guided Step 1C - Check for a short circuit to ground in the intake manifold temperature sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.

Action

  • Measure the resistance from one of the pins on the sensor side of the intake manifold temperature sensor connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the intake manifold temperature sensor

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.
  • Disconnect harness from ECM.
  • Disconnect harness from throttle plate position sensor.
  • Disconnect harness from coolant temperature sensor.
  • Disconnect harness from manifold absolute pressure sensor.
  • Disconnect harness from mixer inlet pressure sensor (MIPS).
  • Disconnect harness from gas mass flow sensor.
  • Disconnect harness from ignition control module (ICM).

Action

  • Measure the resistance from pin 27 of the ECM connector to all other pins in connector.
  • Measure resistance from pin 28 of the ECM connector to all of the other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect intake manifold temperature sensor.
  • Disconnect ECM.

Action

  • Measure the resistance between pin 27 of the ECM connector and pin B on the harness side of the intake manifold temperature sensor connector.
  • Measure the resistance between pin 28 of the ECM connector and pin A on the harness side of the intake manifold temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-202 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit to ground in the signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.
  • Disconnect harness from ECM.

Action

  • Measure the resistance from pin 28 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Intake Manifold Temperature Sensor Circuit

FAULT CODE 154

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 FMI: 4 LAMP: On SRT: 00-310 | Short to ground detected at the intake manifold temperature sensor pin 28 of the ECM connector. | Possible reduced performance. No engine protection for intake manifold temperature (if enabled).

Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel/manifold mixture in the intake manifold. The ECM uses intake manifold temperature to control the engine and for the intake manifold overheat engine protection feature.

Component Location

B5.9G: The intake manifold temperature sensor is installed immediately downstream of the throttle plate next to the manifold absolute pressure sensor.

C8.3G: The intake manifold temperature sensor is installed on the intake manifold below the manifold absolute pressure sensor.

L10G: The intake manifold temperature sensor is installed on the intake manifold next to the manifold absolute pressure sensor.

Shop Talk

All Temperature Sensors

  • The resistance of the sensor varies with temperature. The reading that you observe should compare to the following table if the sensor is functioning properly.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault may log in extremely cold weather.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2 way Metri-Pack connector test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-way Metri-Pack connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold temperature sensor. |
 | STEP 1A. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the intake manifold temperature sensor. | 175 ohms to 244k ohms
 | STEP 1C. Check for a short circuit to ground in the intake manifold temperature sensor. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the intake manifold temperature sensor.

Guided Step 1A - Inspect the harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or the intake manifold temperature sensor, whichever has the damaged pins.

  • Replace the 2-pin Metri-Pack connector. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2 way Metri-Pack connector test lead.

Guided Step 1B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.

Action

  • Measure the resistance between the two pins on the sensor side of the intake manifold temperature sensor connector.
OK NOT OK

175k ohms to 244k ohms

Replace the intake manifold temperature sensor

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823256 - 2-way Metri-Pack connector test lead.

Guided Step 1C - Check for a short circuit to ground in the intake manifold temperature sensor.

Conditions

  • Keyswitch OFF position.
  • Disconnect harness from intake manifold temperature sensor.

Action

  • Measure the resistance from one of the pins on the sensor side of the intake manifold temperature sensor connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the intake manifold temperature sensor

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.
  • Disconnect harness from ECM.
  • Disconnect harness from throttle plate position sensor.
  • Disconnect harness from coolant temperature sensor.
  • Disconnect harness from manifold absolute pressure sensor.
  • Disconnect harness from mixer inlet pressure sensor (MIPS).
  • Disconnect harness from gas mass flow sensor.
  • Disconnect harness from ignition control module (ICM).

Action

  • Measure the resistance from pin 27 of the ECM connector to all other pins in connector.
  • Measure resistance from pin 28 of the ECM connector to all of the other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect intake manifold temperature sensor.
  • Disconnect ECM.

Action

  • Measure the resistance between pin 27 of the ECM connector and pin B on the harness side of the intake manifold temperature sensor connector.
  • Measure the resistance between pin 28 of the ECM connector and pin A on the harness side of the intake manifold temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-202 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit to ground in the signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from intake manifold temperature sensor.
  • Disconnect harness from ECM.

Action

  • Measure the resistance from pin 28 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Fault Code Path Selection

FAULT CODE 244
Fault Code Path Selection

Select for B5.9G | Go to 76-fc244b
Select for C8.3G and L10G | Go to 76-fc244cl

Last Modified: 27-Oct-2003


Fuel Shutoff Valve Circuit

FAULT CODE 254

Fuel Shutoff Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 FMI: 4 LAMP: Flash SRT: 00-314 | Short to ground on fuel shutoff valve pin 2 of the ECM connector. | Fuel shutoff valve closes. Engine will not start or run.

Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a solenoid that is used to shut off the flow of gas to the engine. The electronic control module (ECM) controls the fuel shutoff valve.

Component Location

B5.9G: The fuel shutoff valve is installed above the engine position sensor on the left side of the engine.

C8.3G: The fuel shutoff valve is installed above the air compressor, on the left side of the engine.

L10G: The fuel shutoff valve is installed above the ECM on the left side of the engine.

Shop Talk

  • The B5.9LPG has its fuel shutoff valve built into the LPG Vaporizer unit. If the fuel shutoff valve fails, the entire LPG Vaporizor unit must be replaced.
  • The fuel shutoff valve opens when the ECM detects engine speed.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short to battery voltage or +5 VDC on the supply wire. | Less than 1.5 VDC
 | STEP 1C. Check for a short circuit to ground. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the harness and the valve connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the fuel shutoff valve. | 12 to 20 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1B - Check for a short to battery voltage or +5 VDC on the supply wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from pin 2 in the ECM connector to the engine block.
OK NOT OK

Less than 1.5 VDC

Remove the wire that is shorted into the fuel shutoff valve supply wire.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from pin 2 in the ECM connector to pin C on the harness side of the fuel shutoff valve connector.
  • Measure the resistance from pin 25 in the ECM connector to pin B on the harness side of the fuel shutoff valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-205 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from pin 2 in the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the fuel shutoff valve. Refer to Procedure 019-050.

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the harness and the valve connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from fuel shutoff valve.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or the fuel shutoff valve, whichever has the damaged pins.

  • Repair the 3-pin Deutsch connector. Refer to Procedure 019-205.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the fuel shutoff valve connector. Refer to Procedure 019-205.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 2B - Check the resistance of the fuel shutoff valve.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from pin B to pin C of the fuel shutoff valve.
OK NOT OK

12 to 20 ohms

Replace the fuel shutoff valve. Refer to Procedure 019-050.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from fuel shutoff valve pin C to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-205 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 27-Oct-2003


Fuel Shutoff Valve Circuit

FAULT CODE 255

Fuel Shutoff Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S17 FMI: 3 LAMP: On SRT: 00-315 | Open circuit, short to battery voltage, or short to 5 volts detected at fuel shutoff valve pin 2 of the ECM connector. | If there is an open circuit, the valve will not open and the engine will not run. If there is a short to the battery or 5 volts, then the valve will not close and there is no effect on performance.

Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a solenoid that is used to shut off the flow of gas to the engine. The electronic control module (ECM) controls the fuel shutoff valve.

Component Location

B5.9G: The fuel shutoff valve is installed above the engine position sensor on the left side of the engine.

C8.3G: The fuel shutoff valve is installed above the air compressor, on the left side of the engine.

L10G: The fuel shutoff valve is installed above the ECM on the left side of the engine.

Shop Talk

  • The B5.9LPG has its fuel shutoff valve built into the LPG Vaporizer unit. If the fuel shutoff valve fails, the entire LPG Vaporizor unit must be replaced.
  • The fuel shutoff valve opens when the ECM detects engine speed.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short to battery voltage or +5 VDC on the supply wire. | Less than 1.5 VDC
 | STEP 1C. Check for a short circuit to ground. | Less than 10 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the harness and the valve connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the fuel shutoff valve. | 12 to 20 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1B - Check for a short to battery voltage or +5 VDC on the supply wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from pin 2 in the ECM connector to the engine block.
OK NOT OK

Less than 1.5 VDC

Remove the wire that is shorted into the fuel shutoff valve supply wire.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from pin 2 in the ECM connector to pin C on the harness side of the fuel shutoff valve connector.
  • Measure the resistance from pin 25 in the ECM connector to pin B on the harness side of the fuel shutoff valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-205 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from pin 2 in the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Replace the fuel shutoff valve. Refer to Procedure 019-050.

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the harness and the valve connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from fuel shutoff valve.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or the fuel shutoff valve, whichever has the damaged pins.

  • Repair the 3-pin Deutsch connector. Refer to Procedure 019-205.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the fuel shutoff valve connector. Refer to Procedure 019-205.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 2B - Check the resistance of the fuel shutoff valve.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from pin B to pin C of the fuel shutoff valve.
OK NOT OK

12 to 20 ohms

Replace the fuel shutoff valve. Refer to Procedure 019-050.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823993 - male Deutsch test lead.

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from ECM.
  • Disconnect harness from fuel shutoff valve.

Action

  • Measure the resistance from fuel shutoff valve pin C to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-205.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components
  • Start the engine and let idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 27-Oct-2003


Idle Speed Control Valve Circuit

FAULT CODE 336

Idle Speed Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 336 PID: S19 FMI: 3 LAMP: On SRT: 00-316 | High voltage detected at the idle speed control valve pin 1 of the ECM connector. | Short to 12 volts causes surging. Engine will die and not start on a short to 5 volts.

Idle Speed Control Valve Circuit

Circuit Description

The idle speed control valve is a bypass valve that is used to control idle speed under certain load conditions by the electronic control module (ECM). The ECM uses this valve to regulate the air/fuel mixture flow at idle condition.

Component Location

The idle speed control valve is located on the side of the throttle body.

Shop Talk

The idle speed control valve only operates at idle conditions.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon connector test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the idle speed control valve. |
 | STEP 1A. Inspect the engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the idle speed control valve. | 6 to 14 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply and signal wires. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground in supply and signal wire. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the idle speed control valve.

Guided Step 1A - Inspect engine harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from idle speed control valve.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the harness or the sensor, which ever has the damaged pins.

  • Replace the 2-pin Ford connector. Refer to Procedure 019-212.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the idle speed control valve. Refer to Procedure 019-104.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the idle speed control valve.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from idle speed control valve.

Action

  • Measure the resistance from pin A to pin B of the idle speed control valve.
OK NOT OK

6 to 14 ohms

Replace the idle speed control valve. Refer to Procedure 019-104.

Go to 2A

Go to 3A

Guided Step 2 - Check engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or the ECM

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon connector test lead.

Guided Step 2B - Check for an open circuit in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Measure the resistance from pin 1 of the ECM connector to pin A on the harness side of the idle speed control valve connector.
  • Measure the resistance from pin 25 of the ECM connector to pin B on the harness side of the idle speed control valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Replace the harness. Refer to Procedure 019-212 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from idle speed control valve.

Action

  • Measure resistance from pin 1 of the ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Replace the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2D

3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit to ground in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from idle speed control valve.

Action

  • Measure resistance from pin 1 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Replace the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Reconnect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Idle Speed Control Valve Circuit

FAULT CODE 337

Idle Speed Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 337 PID: S19 FMI: 4 LAMP: On SRT: 00-317 | Low voltage detected at the idle speed control valve pin 1 of the ECM connector. | Low idle speed will be lower than normal. Engine may die.

Idle Speed Control Valve Circuit

Circuit Description

The idle speed control valve is a bypass valve that is used to control idle speed under certain load conditions by the electronic control module (ECM). The ECM uses this valve to regulate the air/fuel mixture flow at idle condition.

Component Location

The idle speed control valve is located on the side of the throttle body.

Shop Talk

The idle speed control valve only operates at idle conditions.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon connector test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the idle speed control valve. |
 | STEP 1A. Inspect the engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the idle speed control valve. | 6 to 14 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply and signal wires. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground in supply and signal wire. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the idle speed control valve.

Guided Step 1A - Inspect engine harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from idle speed control valve.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the harness or the sensor, which ever has the damaged pins.

  • Replace the 2-pin Ford connector. Refer to Procedure 019-212.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the idle speed control valve. Refer to Procedure 019-104.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the idle speed control valve.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from idle speed control valve.

Action

  • Measure the resistance from pin A to pin B of the idle speed control valve.
OK NOT OK

6 to 14 ohms

Replace the idle speed control valve. Refer to Procedure 019-104.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or the ECM.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon connector test lead.

Guided Step 2B - Check for an open circuit in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect the engine harness connector from the ECM.

Action

  • Measure the resistance from pin 1 of the ECM connector to pin A on the harness side of the idle speed control valve connector.
  • Measure the resistance from pin 25 of the ECM connector to pin B on the harness side of the idle speed control valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-212 or 019-204.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from idle speed control valve.

Action

  • Measure resistance from pin 1 of the ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-204.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2D

3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit to ground in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from idle speed control valve.

Action

  • Measure resistance from pin 1 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Reconnect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Internal Electronic Control Module (ECM) Error

FAULT CODE 342

Internal Electronic Control Module (ECM) Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: S254 FMI: 12 LAMP: Flash SRT: 00-301 | Internal electronic control module (ECM) failure or no calibration in the ECM. | Engine will not start or run.

Circuit Description

The ECM is a computer that is responsible for engine control and diagnostics.

Component Location

B5.9G and C8.3G: The ECM is installed on the left side of the engine behind the Ignition Control Module (ICM).

L10G: The ECM is installed on the left side of the engine beside the Ignition Control Module (ICM).

Shop Talk

This fault involves the internal circuitry of the ECM. The ECM can not be repaired in the field.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault code. |
 | STEP 1A. Check for active fault code. | Fault code inactive
 | STEP 1A-1. Check for active fault code. |
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault code.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Check for active fault code.

Action

  • Turn the vehicle keyswitch OFF and wait at least five seconds.
  • Turn vehicle keyswitch ON.
  • Idle engine for at least one minute (if the engine will run).
  • Check whether the fault code is active or inactive.
OK NOT OK

Fault code inactive

Calibrate the ECM

Go to 2A

Go to 1A-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A-1 - Check for active fault code.

Action

  • Turn vehicle keyswitch OFF and wait at least five seconds.
  • Turn vehicle keyswitch ON.
  • Idle engine for at least one minute (if the engine will run).
  • Check whether the fault code is active or inactive.
OK NOT OK

Fault code inactive

Replace the ECM

The ECM has failed.

  • Replace the ECM. Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Internal Electronic Control Module (ECM) Error

FAULT CODE 343

Internal Electronic Control Module (ECM) Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 FMI: 12 LAMP: On SRT: 00-301 | Internal electronic control module (ECM) failure or no calibration in the ECM. | Engine will not start or run.

Circuit Description

The ECM is a computer that is responsible for engine control and diagnostics.

Component Location

B5.9G and C8.3G: The ECM is installed on the left side of the engine behind the Ignition Control Module (ICM).

L10G: The ECM is installed on the left side of the engine beside the Ignition Control Module (ICM).

Shop Talk

This fault involves the internal circuitry of the ECM. The ECM can not be repaired in the field.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault code. |
 | STEP 1A. Check for active fault code. | Fault code inactive
 | STEP 1A-1. Check for active fault code. |
STEP 2. | Clear the fault code. |
 | STEP 2A. Clear the fault code. | All fault codes cleared

Guided Step 1 - Check for active fault code.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Check for active fault code.

Action

  • Turn the vehicle keyswitch OFF and wait at least five seconds.
  • Turn vehicle key switch ON.
  • Idle engine for at least one minute (if the engine will run).
  • Check whether the fault code is active or inactive.
OK NOT OK

Fault code inactive

Calibrate the ECM

Go to 2A

Go to 1A-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A-1 - Check for active fault code.

Action

  • Turn vehicle keyswitch OFF and wait at least five seconds.
  • Turn vehicle keyswitch ON.
  • Idle engine for at least one minute (if the engine will run).
  • Check whether the fault code is active or inactive.
OK NOT OK

Fault code inactive

Replace the ECM

The ECM has failed.

  • Replace the ECM. Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Clear the fault code.

Conditions

  • Reconnect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Pressure Sensor Power Supply

FAULT CODE 352

Pressure Sensor Power Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S254 FMI: 4 LAMP: On SRT: 00-318 | Pressure sensor power supply shorted to ground. | Engine will not start or run.

Pressure Sensor Circuits

Circuit Description

The pressure sensor power supply provides power to the manifold absolute pressure sensor and the mixer inlet pressure sensor.

Component Location

  • The manifold absolute pressure sensor is located downstream of the throttle plate on the intake manifold.
  • The mixer inlet pressure sensor (MIPS) is located upstream of the throttle plate.

Shop Talk

The engine will run if only one of the pressure sensors has failed, but the engine can not run if both pressure sensors fail. If this fault code is active, the electronic control module (ECM) can not read the pressure sensors because the pressure sensors do not have power.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the Part No. 3822917 - female AMP/Cannon test lead when taking a measurement.
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the Part No. 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Inspect the harness and pressure sensor connector pins. | No damaged pins
 | STEP 1C. Check for a short to ground. | More than 100k ohms
STEP 2. | Check the pressure sensors. |
 | STEP 2A. Check for a short to ground. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 352 inactive
 | STEP 3B. Clear any inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the harness and ECM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-204.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the harness and pressure sensor connector pins

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the MIPS.
  • Disconnect the harness from the manifold absolute pressure sensor.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the harness, the MIPS, or the manifold absolute pressure sensor, whichever has the damaged pins.

  • Replace the 3-pin Metri-Pack connector. Refer to Procedure 019-202.
  • Replace the MIPS. Refer to Procedure 019-098.
  • Replace the manifold absolute pressure sensor. Refer to Procedure 019-099.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the Part No. 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 1C - Check for a short to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.
  • Disconnect the harness from the MIPS.
  • Disconnect the harness from the manifold absolute pressure sensor.

Action

  • measure the resistance from pin 18 in the ECM connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-204.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

Guided Step 2 - Check the pressure sensors.

Guided Step 2A - Check for a short to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.
  • Disconnect the harness from the MIPS.
  • Disconnect the harness from the manifold absolute pressure sensor.

Action

  • measure the resistance from pin A on the MIPS to engine block ground
  • measure the resistance from pin A on the manifold absolute pressure sensor to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • connect all components
  • start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 352 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear all inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Manifold Absolute Pressure Sensor Circuit

FAULT CODE 354

Manifold Absolute Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: P106 FMI: 3, LAMP: On SRT: 00-319 | High voltage detected at manifold absolute pressure pin 14 of the Electronic Control Module (ECM) connector. | No effect on performance.

Manifold Absolute Pressure Sensor Circuit

Circuit Description

This sensor measures the manifold absolute pressure. The manifold absolute pressure is the pressure of the fuel/air mixture after the throttle plate, or just before it enters the cylinder. The electronic control module (ECM) uses the value of manifold absolute pressure for engine control.

Component Location

B5.96: The manifold absolute pressure sensor is installed immediately downstream of the throttle plate on the left side of the engine.

C8.36: The manifold absolute pressure sensor is installed on the intake side manifold above the intake manifold temperature sensor.

L106: The manifold absolute pressure sensor is installed on the intake manifold next to the intake manifold temperature sensor.

Shop Talk

If the manifold absolute pressure sensor is disconnected, the engine can continue operating by using the throttle plate position and the mixer inlet pressure to estimate the manifold absolute pressure.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the manifold absolute pressure sensor. |
 | STEP 1A. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the supply voltage. | 4.75 to 5.25 VDC
 | STEP 1C. Check the signal voltage. | 1.62 to 1.74 VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for short circuit between the sensor signal and supply wire and other wires in the harness. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 354 inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the manifold absolute pressure sensor.

Guided Step 1A - Inspect harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from manifold absolute pressure sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the harness or replace the manifold absolute pressure sensor, whichever has the damaged pins.

  • Replace the 3-pin Metri-Pack connector. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the manifold absolute pressure sensor. Refer to Procedure 019-099.

Go to 1B

Go to 3A

Guided Step 1B - Check the supply voltage.

Conditions

  • Keyswitch in ON position.

Action

  • Install break out cable between the sensor and the harness connector.
  • Measure the supply voltage by installing the break out cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 or 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 3A

Guided Step 1C - Check the signal voltage.

Conditions

  • Keyswitch in ON position.

Action

  • Measure the signal voltage by installing the break out cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

1.62 to 1.74 VDC

Replace the manifold absolute pressure sensor Refer to Procedure 019-099.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect harness and ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from manifold absolute pressure sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2B - Check for short circuit between the sensor signal and supply wire and other wires in the harness.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from MIPS.
  • Disconnect harness from manifold absolute pressure sensor.

Action

  • Measure the resistance from ECM connector pin 15 to all other pins in the harness connector.
  • Measure the resistance from ECM connector pin 18 to all other pins in the harness connector.
OK NOT OK

More than 100k ohms

  • Replace manifold absolute pressure sensor. Refer to Procedure 019-099.

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-204.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

Reconnect all components.

Action

  • Connect all components.
  • Starts engine and let idle for one minute.
OK NOT OK

Fault Code 354 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

Reconnect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair completed

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Manifold Absolute Pressure Sensor Circuit

FAULT CODE 355

Manifold Absolute Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 FMI: 4 LAMP: ON SRT: 00-320 | Low voltage detected at manifold absolute pressure pin 14 of the ECM connector. | No effect on performance.

Manifold Absolute Pressure Sensor circuit

Circuit Description

This sensor measures the manifold absolute pressure. The manifold absolute pressure is the pressure of the fuel/air mixture after the throttle plate, or just before it enters the cylinder. The electronic control module (ECM) uses the value of manifold absolute pressure for engine control.

Component Location

B5.96: The manifold absolute pressure sensor is installed immediately downstream of the throttle plate on the left side of the engine.

C8.36: The manifold absolute pressure sensor is installed on the intake side manifold above the intake manifold temperature sensor.

L106: The manifold absolute pressure sensor is installed on the intake manifold next to the intake manifold temperature sensor.

Shop Talk

If the manifold absolute pressure sensor is disconnected, the engine can continue operating by using the throttle plate position and the mixer inlet pressure to estimate the manifold absolute pressure.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the manifold absolute pressure sensor. |
 | STEP 1A. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the supply voltage. | 4.75 to 5.25 VDC
 | STEP 1C. Check the signal voltage. | 1.62 to 1.74 VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for short circuit between the sensor signal and supply wire and other wires in the harness. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 355 inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the manifold absolute pressure sensor.

Guided Step 1A - Inspect the harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness from manifold absolute pressure sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the harness or replace the manifold absolute pressure sensor, whichever has the damaged pins.

  • Replace the 3-pin Metri-Pack connector. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the manifold absolute pressure sensor. Refer to Procedure 019-099.

Go to 1B

Go to 3A

Guided Step 1B - Check the supply voltage.

Conditions

  • Keyswitch in ON position.

Action

  • Install break out cable between the sensor and the harness connector.
  • Measure the supply voltage by installing the break out cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-202 or 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 3A

Guided Step 1C - Check the signal voltage.

Conditions

  • Keyswitch in ON position.

Action

  • Measure the signal voltage by installing the break out cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

1.62 to 1.74 VDC

Replace the manifold absolute pressure sensor. Refer to Procedure 019-099.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the harness and ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect the harness from the manifold absolute pressure sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2B - Check for short circuit between the sensor signal and supply wire and other wires in the harness.

Conditions

  • Keyswitch in OFF position.
  • Disconnect the harness connector from the ECM.
  • Disconnect the harness from the MIPS.
  • Disconnect the harness from the manifold absolute pressure sensor.

Action

  • Measure the resistance from ECM connector pin 15 to all other pins in the harness connector.
  • Measure the resistance from ECM connector pin 18 to all other pins in the harness connector.
OK NOT OK

More than 100k ohms

  • Replace manifold absolute pressure sensor. Refer to Procedure 019-099.

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-204.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

Reconnect all components.

Action

  • Connect all components.
  • Starts engine and let idle for one minute.
OK NOT OK

Fault Code 355 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

Reconnect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Fault Code Path Selection

FAULT CODE 412
Fault Code Path Selection

Select for B5.9G | Go to 76-fc412b
Select for C8.3G and L10G | Go to 76-fc412cl

Last Modified: 27-Oct-2003


Switched Battery Voltage Circuit

FAULT CODE 441

Switched Battery Voltage Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 FMI: 4 LAMP: On SRT: 00-322 | Low current flow detected at the fuel control valve pin 11 of the ECM connector indicating low battery voltage. | Can be difficult to start the engine due to the low battery voltage.

Circuit Description

The electronic control module (ECM) measured the battery voltage by measuring the current feedback from the fuel control valve.

Component Location

The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM manual for the battery location.

Shop Talk

Check to make sure the fuel control valve is working properly.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female Amp/Cannon test lead
Part Number 3823993 - male Deustch test lead
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female Amp/Cannon test leads when taking a measurement.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female Amp/Cannon test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female Amp/Cannon test lead
Part Number 3823993 - male Deustch test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector. | No damaged pins or loose connections
 | STEP 1B. Check the supply voltage. | 10 to 15 VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the switched battery power. | 10 to 15 VDC
 | STEP 2C. Check for a short to ground. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 441 is inactive
 | STEP 3B. Clear the inactive fault code. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness connector from the OEM connector.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on connector.
OK NOT OK

No damaged pins or loose connections

Repair the damaged pins

Repair the harness.

  • Repair the 9-pin Deutsch connector. Refer to Procedure 019-207.
  • Repair the 21-pin Deutsch connector. Refer to Procedure 019-208.

Go to 1B

Go to 3A

Guided Step 1B - Check the supply voltage.

Conditions

  • Keyswitch in the ON position.
  • Disconnect the engine harness connector from the OEM harness.

Action

  • B5.9G - measure the voltage between pin C and pin D on the OEM side of the 6-pin Deutsch OEM connector.
  • C8.3G and L10G - measure the voltage between pin D and pin V of the 21-pin Deutsch OEM connector.
OK NOT OK

10 to 15 VDC

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to manufacturer's instructions.
  • Replace the OEM harness. Refer to manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female Amp/Cannon test leads when taking a measurement.

Guided Step 2B - Check for an open circuit in the switched battery power.

Conditions

  • Keyswitch in the ON position.
  • Disconnect the engine harness from the ECM.

Action

  • Measure the voltage from ECM connector pin 20 to the engine block.
  • Measure the voltage from ECM connector pin 21 to the engine block.
OK NOT OK

10 to 15 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female Amp/Cannon test lead when taking a measurement.
Guided Step 2C - Check for a short to ground.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness connector from the ECM.
  • Disconnect the harness from the fuel control valve.

Action

  • Measure the resistance from ECM connector pin 10 to the engine block.
  • Measure the resistance from ECM connector pin 11 to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female Amp/Cannon test lead
Part Number 3823993 - male Deustch test lead

Guided Step 2D - Check for an open circuit.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the harness from the fuel control valve.

Action

  • Measure the resistance from pin ECM connector pin 10 to pin C of the fuel control valve connector on the harness.
  • Measure the resistance from ECM connector pin 11 to pin A on the harness side of the fuel control valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-201, 019-202, or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Connect all the components.
  • Start the engine and let it idle for one minute.
OK NOT OK

Fault Code 441 is inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3A

Go to 3A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all the components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 28-Oct-2003


Switched Battery Voltage Circuit

FAULT CODE 442

Switched Battery Voltage Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 FMI: 3 LAMP: On SRT: 00-323 | High current flow detected at fuel control valve pin 11 of the electronic control module (ECM) connector indicating high battery voltage. | No effect on performance.

Circuit Description

The ECM monitors battery voltage by measuring the current feedback from the fuel control valve.

Component Location

The location of the battery will vary by original equipment manufacturer (OEM). Refer to the OEM manual for battery location.

Shop Talk

  • Check to make sure the fuel control valve is working properly.
  • This fault code is only active while the system voltage is above normal. The fault code will be inactive when the engine is not running.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the Part Number 3823994 - female Deutsch test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine electrical system. |
 | STEP 1A. Check the charging system. | Proper charging system performance
 | STEP 1B. Check the fuel control value pins. | No damaged pins
 | STEP 1C. Check for short to 12 VDC. | Less than 5.0 VDC
STEP 2. | Clear the fault code. |
 | STEP 2A. Clear the fault code. | All faults cleared

Guided Step 1 - Check the engine electrical system.

Guided Step 1A - Check the charging system.

Action

Refer to Group 013 in the appropriate base engine Troubleshooting and Repair Manual for information on troubleshooting the engine electrical system.

OK NOT OK

Proper charging system performance

Repair the charging system. Refer to Group 013 in the appropriate base engine Troubleshooting and Repair Manual.

Go to 1B

Go to 2A

Guided Step 1B - Check the fuel control valve pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect harness from the fuel control valve.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the harness or the fuel control valve, whichever has the damaged pins.

  • Repair the 3-pin Deutsch connector. Refer to Procedure 019-207.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the Part Number 3823994 - female Deutsch test lead when taking a measurement.

Guided Step 1C - Check for short to 12 VDC.

Conditions

  • Key switch in the ON position.
  • Disconnect fuel control valve connector.

Action

  • Measure the voltage between pin A on the harness side of the fuel control valve connector and the engine block.
  • Measure the voltage between pin C on the harness side of the fuel control valve connector and the engine block.
OK NOT OK

Less than 5.0 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Clear the fault code.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 28-Oct-2003


Gas Mass Flow Sensor Circuit

FAULT CODE 453

Gas Mass Flow Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 453 PID: P183 FMI: 3 LAMP: On SRT: 00-324 | High voltage detected at the gas mass flow sensor pin 16 of the ECM connector. | Engine can die at idle.

Gas Mass Flow Sensor Circuit

Circuit Description

The gas mass flow sensor is used by the electronic control module (ECM) to measure the amount of gas being delivered to the engine from the fuel supply line. The gas mass flow sensor is powered by battery voltage.

Component Location

B5.9G: The gas mass flow sensor is installed in the back of the gas block.

C8.3G: The gas mass flow sensor is installed beside the fuel control valve on the left side of the engine.

L10G: The gas mass flow sensor is installed on the left side of the engine downstream of the pressure regulator.

Shop Talk

Make sure that the screen in the gas mass flow sensor is free of debris and oil.

Check the 10A gas mass flow sensor/heated oxygen sensor fuse.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the gas mass flow sensor connector pins. | No damaged pins
 | STEP 1B. Check the voltage supply to the gas mass flow sensor. | 8.0 to 15.0 VDC
 | STEP 1C. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 1D. Check for an open circuit in the gas mass flow sensor ground wire. | Less than 10 ohms
 | STEP 1E. Check for an open circuit in the gas mass flow sensor signal. | Less than 10 ohms
 | STEP 1F. Check for a short circuit from the signal wire to the ground. | More than 100k ohms
 | STEP 1G. Check for a short circuit between the gas mass flow sensor signal wire and the other wires in the ECM connector. | More than 100k ohms
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault code inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and the gas mass flow sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from gas mass flow sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Repair the 4-pin Ford connector. Refer to Procedure 019-212.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male AMP/Cannon test lead.

Guided Step 1B - Check the voltage supply to the gas mass flow sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ECM.

Action

  • Measure the voltage between pin A and pin B on the harness side of the gas mass flow sensor connector.
OK NOT OK

8.0 to 15.0 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-212.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1C - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1G

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for an open circuit in the gas mass flow sensor ground wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from gas mass flow sensor.

Action

  • Measure the resistance from the ECM connector pin 27 to pin C on the harness side of the gas mass flow sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-212 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead
Part Number 3822917 - female AMP test lead.

Guided Step 1E - Check for an open circuit in the gas mass flow sensor signal.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from gas mass flow sensor.

Action

  • Measure the resistance from pin 16 of the ECM connector to pin D of the gas mass flow sensor connector on the harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-212 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1F

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1F - Check for a short circuit from the signal wire to the ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from gas mass flow sensor.

Action

  • Measure the resistance from the ECM connector pin 16 to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1G

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1G - Check for a short circuit between the gas mass flow sensor signal wire and the other wires in the ECM connector.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from gas mass flow sensor.

Action

  • Measure the resistance from the ECM connector pin 16 to all other pins.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let it idle for one minute.
OK NOT OK

Fault code inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Refer to the appropriate troubleshooting charts for any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Gas Mass Flow Sensor Circuit

FAULT CODE 454

Gas Mass Flow Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 454 PID: P183 FMI: 4 LAMP: On SRT: 00-325 | Low voltage detected at gas mass flow sensor pin 16 of the ECM connector. | Engine can die at idle. Engine will not start.

Gas Mass Flow Sensor Circuit

Circuit Description

The gas mass flow sensor is used by the electronic control module (ECM) to measure the amount of gas being delivered to the engine from the fuel supply line. The gas mass flow sensor is powered by battery voltage.

Component Location

B5.9G: The gas mass flow sensor is installed in the back of the gas block.

C8.3G: The gas mass flow sensor is installed beside the fuel control valve on the left side of the engine.

L10G: The gas mass flow sensor is installed on the left side of the engine downstream of the pressure regulator.

Shop Talk

Make sure that the screen in the gas mass flow sensor is free of debris and oil.

Check the 10A gas mass flow sensor/HOS fuse.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the gas mass flow sensor connector pins. | No damaged pins
 | STEP 1B. Check the voltage supply to the gas mass flow sensor. | 8.0 to 15.0 VDC
 | STEP 1C. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 1D. Check for an open circuit in the gas mass flow sensor ground wire. | Less than 10 ohms
 | STEP 1E. Check for an open circuit in the gas mass flow sensor signal. | Less than 10 ohms
 | STEP 1F. Check for a short circuit from the signal wire to the ground. | More than 100k ohms
 | STEP 1G. Check for a short circuit between the gas mass flow sensor signal wire and the other wires in the ECM connector. | More than 100k ohms
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault code inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and the gas mass flow sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from gas mass flow sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Repair the 4-pin Ford connector. Refer to Procedure 019-212.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822758 - male AMP/Cannon test lead.

Guided Step 1B - Check the voltage supply to the gas mass flow sensor.

Conditions

  • Keyswitch in ON position.
  • Disconnect engine harness from ECM.

Action

  • Measure the voltage between pin A and pin B on the harness side of the gas mass flow sensor connector.
OK NOT OK

8.0 to 15.0 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1C - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for an open circuit in the gas mass flow sensor ground wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from gas mass flow sensor.

Action

  • Measure the resistance from the ECM connector pin 27 to pin C on the harness side of the gas mass flow sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure019-212 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead
Part Number 3822917 - female AMP test lead.

Guided Step 1E - Check for an open circuit in the gas mass flow sensor signal.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from gas mass flow sensor.

Action

  • Measure the resistance from pin 16 of the ECM connector to pin D of the gas mass flow sensor connector on the harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure019-212 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1F

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1F - Check for a short circuit from the signal wire to the ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from gas mass flow sensor.

Action

  • Measure the resistance from the ECM connector pin 16 to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1G

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1G - Check for a short circuit between the gas mass flow sensor signal wire and the other wires in the ECM connector.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from gas mass flow sensor.

Action

  • Measure the resistance from the ECM connector pin 16 to all other pins.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let it idle for one minute.
OK NOT OK

Fault code inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Refer to the appropriate troubleshooting charts for any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Fuel Control Valve Circuit

FAULT CODE 455

Fuel Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: S18 FMI: 3 LAMP: Flash SRT: 00-326 | Short to high voltage detected at fuel control valve pin 11 of the ECM connector. | Engine will not start or run.

Fuel Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the opening of this valve to regulate the correct amount of fuel entering the mixer.

Component Location

B5.9G and C8.3G: The fuel control valve's are installed under the mixer on the left side of the engine.

L10G: The fuel control valve's are installed on the mixer on the right side of the engine.

Shop Talk

This valve is a normally closed valve.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/ Cannon test lead
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fuel control valve. |
 | STEP 1A. Inspect engine harness and the fuel control valve. | No damaged pins
 | STEP 1B. Check resistance of fuel control valve. | 3 to 5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply and signal wire. | More than 10k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground in the supply and signal wire. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault codes inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel control valve.

Guided Step 1A - Inspect engine harness and valve connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from fuel control valve.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace harness or fuel control valve, whichever has the damaged pins.

  • Repair the 3-pin Deutsch connector. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the valve. Refer to Procedure 019-102.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 1B - Check resistance of fuel control valve.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from fuel control valve.

Action

  • Measure the resistance from pin A to pin B of the fuel control valve.
OK NOT OK

2 to 5 ohms

Replace the fuel control valve. Refer to Procedure 019-102.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

2B for 511
2D for 455

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/ Cannon test lead
Part Number 3823993 - male Deutsch test lead.

Guided Step 2B - Check for an open circuit in the supply and signal wires.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Measure the resistance from pin 11 of the ECM connector to pin A on the harness side of the fuel control valve connector
  • Measure the resistance from pin 10 of the ECM connector to pin C on the harness side of the fuel control valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-207 or 019-203.
  • Replace the harness. Refer to procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect harness from fuel control valve.

Action

  • Measure the resistance from pin 10 of the ECM connector to all other pins in the connector
  • Measure resistance from pin 11 of ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2D - Check for a short circuit to ground in the supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect harness from fuel control valve.

Action

  • Measure the resistance from pin 10 of the ECM connector to the engine block.
  • Measure resistance from pin 11 of ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components

Action

  • Connect all components
  • Start the engine and idle for one minute.
OK NOT OK

Fault codes inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Fault Code Path Selection

FAULT CODE 458
Fault Code Path Selection

Select for B5.9G | Go to 76-fc458b
Select for C8.3G and L10G | Go to 76-fc458cl

Last Modified: 28-Oct-2003


Fault Code Path Selection

FAULT CODE 459
Fault Code Path Selection

Select for B5.9G | Go to 76-fc459b
Select for C8.3G and L10G | Go to 76-fc459cl

Last Modified: 16-May-2003


Fault Code Path Selection

FAULT CODE 461
Fault Code Path Selection

Select for B5.9G | Go to 76-fc461b
Select for C8.3G and L10G | Go to 76-fc461cl

Last Modified: 16-May-2003


Fault Code Path Selection

FAULT CODE 462
Fault Code Path Selection

Select for B5.9G | Go to 76-fc462b
Select for C8.3G and L10G | Go to 76-fc462cl

Last Modified: 16-May-2003


Pressure Sensor Signal

FAULT CODE 463

Pressure Sensor Signal

View Related Topic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 463 PID: P106 FMI: 2 LAMP: On SRT: | Manifold absolute pressure is greater than mixer inlet pressure. | Engine does not start. Possible reduced performance.

Manifold Absolute Pressure Signal and Mixer Inlet Pressure Signal Circuit

Circuit Description

The manifold absolute pressure sensor (MAP) provides signal to the Electronic Control Module (ECM) and the mixer inlet pressure sensor (MIP) provides signal to the ECM.

Component Location

  • The manifold absolute pressure sensor (MAP) is located downstream of the throttle plate on the intake manifold.
  • The mixer inlet pressure sensor (MIP) is located upstream of the throttle plate.

Shop Talk

Atmospheric pressure is used to calculate base fueling to the engine.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 463 is active
STEP 2. | Check sensor's pressure readings. |
 | STEP 2A. Check the pressure readings of the mixer inlet pressure sensor and the manifold absolute pressure sensor. | Pressure for both sensors is approximately 96.53 kPa [14 psi] or 723.90 mm Hg [28.5 in Hg] (atmospheric pressure)
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code 463 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 463 is active.

Step 2A

Go to 3B

Guided Step 2 - Check the sensor's pressure readings.

Guided Step 2A - Check the pressure readings of the mixer inlet pressure sensor and the manifold absolute pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Do not start the engine.

Action

  • Turn the keyswitch ON, but do not start the engine.
  • Use INSITE™ electronic service tool to check the mixer inlet pressure, intake manifold pressure, and exhaust back pressure.
OK NOT OK

Pressure for both sensors is approximately 96.53 kPa [14 psi] or 723.90 mm Hg [28.5 in Hg] (atmospheric pressure)

One or both pressures do not meet specification.

Troubleshoot appropriate sensor circuit:

  • Troubleshoot the mixer inlet pressure sensor circuit. Refer to Fault Code 123.
  • Troubleshoot the manifold absolute pressure sensor circuit. Refer to Fault Code 354.

Go to 3A

Appropriate fault codes.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 463 inactive.
OK NOT OK

Fault code 463 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to erase inactive faults.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 23-Sep-2004


Heated Oxygen Sensor

FAULT CODE 464

Heated Oxygen Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 464 PID: S65 FMI: 4 LAMP: FLASH SRT: | Heated oxygen sensor out of range low. | Possible reduced performance. No closed-loop operation.

Heated Oxygen Sensor Circuit

Circuit Description

The heated oxygen circuit is used by the ECM to measure the air-to-fuel ratio at which the engine is operating.

Shop Talk

  • Check the fuse holder for moisture intrusion.
  • Double-check all connectors. (At the Bosch® connector and ECM, a loose connection on the power supplies or signal circuit will cause an intermittent fault.)
  • For B Series Natural Gas engines check the calibration revision level. Version .02 and above required.
  • For 90-degree exhaust adapters on B Series Natural Gas and LPG engines. Check for the correct sensor orientation.

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor. Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check for fuel control valve and gas mass flow fault codes. | Fault Codes 453, 454, 455, 511, 514, 751, and 752 are not active
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the heated oxygen sensor and the sensor harness connector pins. | No damaged pins
 | STEP 2B. Check the security of the resistor in the oxygen sensor connector. | Resistor secure
STEP 3. | Check the heated oxygen sensor interface module. |
 | STEP 3A. Inspect the interface module fuse holder and connector pins. | No damaged pins
 | STEP 3B. Inspect the interface module fuse. | Less than 10 ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | No damaged pins
 | STEP 4B. Check the interface module voltage supply and ground. | 11.0 to 14.0 VDC
 | STEP 4C. Check for an open circuit in the signal and return wires. | Less than 2 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 464 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check for fuel control valve and gas mass flow fault codes.

Conditions

  • Turn keyswitch ON.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 453, 454, 455, 511, 514, 751, and 752 are not active

Troubleshoot the active fault codes.

Go to 2A

5A

Guided Step 2 - Check the heated oxygen sensor.

WARNING

Do not touch the heated oxygen sensor. Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
Guided Step 2A - Inspect the heated oxygen sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the interface module harness from the heated oxygen sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Replace the heated oxygen sensor or the interface module, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the heated oxygen sensor interface module. Refer to Procedure 019-353.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100.

Go to 2B

Go to 5A

WARNING

Do not touch the heated oxygen sensor. Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
Guided Step 2B - Check the security of the resistor in the oxygen sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the interface module harness from the heated oxygen sensor.

Action

  • The resistor should be secure in the connector. The resistance will vary, as it automatically sets the offset in the interface module.
OK NOT OK

Resistor secure

Replace the heated oxygen sensor. Refer to Procedure 019-100.

Go to 3A

Go to 5A

Guided Step 3 - Check the heated oxygen sensor interface module.

Guided Step 3A - Inspect the interface module fuse holder and connector pins.

Conditions

  • Turn keyswitch OFF.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Replace the interface module fuse holder or the heated oxygen sensor interface module.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the interface module fuse holder. Refer to Procedure 019-051.
  • Replace the heated oxygen sensor interface module. Refer to Procedure 019-353.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
Guided Step 3B - Inspect the interface module fuse.

Conditions

  • Turn keyswitch OFF.
  • Remove the interface module fuse from the holder.

Action

  • Measure the resistance of the fuse.
OK NOT OK

Less than 10 ohms

Replace the fuse. Refer to Procedure 019-198.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor interface module.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace ECM, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
Guided Step 4B - Check the interface module voltage supply and ground.

Conditions

  • Disconnect the engine harness from the heated oxygen sensor interface module.
  • Turn keyswitch ON.

Action

  • Measure the voltage between pin A1 and pin A2 on the engine harness side of the interface module connector.
OK NOT OK

11.0 to 14.0 VDC

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, 019-202, or 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
Guided Step 4C - Check for an open circuit in the signal and return wire.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor interface module.

Action

  • Measure the resistance from the engine harness ECM connector pin 22 to interface module signal pin B1 on the engine harness side of the connector.
  • Measure the resistance from the engine harness ECM connector pin 23 to interface module signal pin B2 on the engine harness side of the connector.
OK NOT OK

Less than 2 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201, 019-202, 019-205, or 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor interface module.

Action

  • Measure the resistance between pin 23 in the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 464 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 31-Oct-2003


Wastegate Control Valve Circuit

FAULT CODE 465

Wastegate Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 465 PID: S32 FMI: 3 LAMP: On SRT: 00-331 | High voltage detected at wastegate control valve pin 12 of the ECM connector. | Possible reduced performance. Engine will die on a short to 5 VDC.

Wastegate Control Valve Circuit

Circuit Description

The ECM controls the opening of the wastegate control valve to achieve the desired mixer inlet pressure (boost). This will produce the desired torque output under certain load conditions.

Component Location

B5.9G: The wastegate control valve is installed beside the mixer inlet pressure (MIP) sensor.

C8.36G: The wastegate control valve is installed above the mixer on the left side of the engine.

L10G: The wastegate control valve is installed above the fuel control valves.

Shop Talk

This fault is caused by an electrical problem. Mechanical problems will not cause this fault to log.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check wastegate control valve. |
 | STEP 1A. Inspect the harness and wastegate control valve connector pins. | No damaged pins
 | STEP 1B. Check the resistance of wastegate control valve. | 2 to 6 ohms
STEP 2. | Check engine harness. |
 | STEP 2A. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in supply and signal wire. | Less than 10 ohms
 | STEP 2C. Check for short circuit to ground in supply and signal wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the wastegate control valve.

Guided Step 1A - Inspect the harness and wastegate control valve connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from wastegate control valve.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the harness or wastegate control valve, whichever has the damaged pins.

  • Repair the 3-pin Deutsch connector. Refer to Procedure 019-205.
  • Replace the wastegate control valve. Refer to Procedure 019-103.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 1B - Check resistance of wastegate control valve.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from wastegate control valve.

Action

  • Measure the resistance from pin A to pin B of the wastegate control valve.
OK NOT OK

2 to 6 ohms

Replace the wastegate control valve. Refer to Procedure 019-103.

Go to 2A

Go to 3A

Guided Step 2 - Check engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

Guided Step 2B - Check for an open circuit in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect the engine harness from the wastegate control valve.
  • Disconnect the engine harness connector from the ECM.

Action

  • Measure resistance from pin 12 of ECM connector to pin A of harness side of wastegate control valve connector.
  • Measure resistance from pin 25 of ECM connector to pin B of harness side of wastegate control valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-205 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for short circuit to ground in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from wastegate control valve.

Action

  • Measure the resistance from pin 12 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from wastegate control valve.

Action

  • Measure the resistance from pin 12 of the ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

Connect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase inactive faults using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Wastegate Control Valve Circuit

FAULT CODE 466

Wastegate Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 466 PID: S32 FMI: 4 LAMP: On SRT: 00-332 | Low voltage detected at the wastegate control valve pin 12 of the electronic control module (ECM) connector. | Possible reduced performance above 1500 RPM.

Wastegate Control Valve Circuit

Circuit Description

The ECM controls the opening of the wastegate control valve to achieve the desired mixer inlet pressure (boost). This will produce the desired torque output under certain load conditions.

Component Location

B5.9G: The wastegate control valve is installed beside the mixer inlet pressure (MIP) sensor.

C8.36G: The wastegate control valve is installed above the mixer on the left side of the engine.

L10G: The wastegate control valve is installed above the fuel control valves.

Shop Talk

This fault is caused by an electrical problem. Mechanical problems will not cause this fault to log.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wastegate control valve. |
 | STEP 1A. Inspect harness and wastegate control valve connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the wastegate control valve. | 2 to 6 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply and signal wire. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground in the supply and signal wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the wastegate control valve.

Guided Step 1A - Inspect the harness and wastegate control valve connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from wastegate control valve.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace the harness or wastegate control valve, whichever has the damaged pins.

  • Repair the 3-pin Deutsch connector. Refer to Procedure 019-205.
  • Replace the wastegate control valve. Refer to Procedure 019-103.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 1B - Check the resistance of the wastegate control valve.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from wastegate control valve.

Action

  • Measure the resistance from pin A to pin B of the wastegate control valve.
OK NOT OK

2 to 6 ohms

Replace the wastegate control valve. Refer to Procedure 019-103.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

Guided Step 2B - Check for an open circuit in the supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from wastegate control valve.
  • Disconnect engine harness connector from ECM.

Action

  • Measure resistance from pin 12 of ECM connector to pin A of harness side of the wastegate control valve connector.
  • Measure resistance from pin 25 of ECM connector to pin B of harness side of the wastegate control valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-205 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for a short circuit to ground in the supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from wastegate control valve.

Action

  • Measure the resistance from pin 12 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from wastegate control valve.

Action

  • Measure the resistance from pin 12 of the ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

Connect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase inactive faults using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Fuel Control Valve Circuit

FAULT CODE 511

Fuel Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 511 PID: S18 FMI: 4 LAMP: Flash SRT: 00-333 | Low voltage detected at fuel control valve pin 11 of the ECM connector. | Engine will not start or run.

Fuel Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the opening of this valve to regulate the correct amount of fuel entering the mixer.

Component Location

B5.9G and C8.3G: The fuel control valve's are installed under the mixer on the left side of the engine.

L10G: The fuel control valve's are installed on the mixer on the right side of the engine.

Shop Talk

This valve is a normally closed valve.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel control valve. |
 | STEP 1A. Inspect the engine harness and the fuel control valve. | No damaged pins
 | STEP 1B. Check the resistance of the fuel control valve. | 3 to 5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply and signal wire. | More than 10k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground in the supply and signal wire. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel control valve.

Guided Step 1A - Inspect the engine harness and valve connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from fuel control valve.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair or replace harness or fuel control valve, whichever has the damaged pins.

  • Repair the 3-pin Deutsch connector. Refer to Procedure 019-205.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the valve. Refer to Procedure 019-102.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 1B - Check the resistance of the fuel control valve.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from fuel control valve.

Action

  • Measure the resistance from pin A to pin B of the fuel control valve.
OK NOT OK

2 to 5 ohms

Replace the fuel control valve

  • Replace the fuel control valve. Refer to Procedure 019-102.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 511

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.

Guided Step 2B - Check for an open circuit in the supply and signal wires.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Measure the resistance from pin 11 of the ECM connector to pin A on the harness side of the fuel control valve connector
  • Measure the resistance from pin 10 of the ECM connector to pin C on the harness side of the fuel control valve connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-205 or 019-203.
  • Replace the harness. Refer to procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for a short circuit from pin to pin

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect harness from fuel control valve.

Action

  • Measure the resistance from pin 10 of the ECM connector to all other pins in the connector
  • Measure the resistance from pin 11 of the ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit to ground in the supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect harness from fuel control valve.

Action

  • Measure the resistance from pin 10 of the ECM connector to the engine block.
  • Measure resistance from pin 11 of ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components

Action

  • Connect all components
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Fault Code Path Selection

FAULT CODE 512
Fault Code Path Selection

Select for B5.9G | Go to 76-fc512b
Select for C8.3G and L10G | Go to 76-fc512cl

Last Modified: 16-May-2003


Fault Code Path Selection

FAULT CODE 513
Fault Code Path Selection

Select for B5.9G | Go to 76-fc513b
Select for C8.3G and L10G | Go to 76-fc513cl

Last Modified: 16-May-2003


Secondary Fuel Control Valve (SFCV) Circuit

FAULT CODE 557 or 558

Secondary Fuel Control Valve (SFCV) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 557 or 558 PID: S18 FMI: 3, 4 LAMP: Flash, Flash SRT: 00-598,00-559 | FC 557: Short to high voltage detected at secondary fuel control valve pin 11 of the ECM connector. FC 558: Low voltage detected at secondary fuel control valve pin 11 of the ECM connector. | Engine will not start or run.

Secondary Fuel Control Valve (SFCV) Circuit

Circuit Description

The electronic control module (ECM) controls the opening of this valve to regulate the amount of fuel entering the mixer.

Component Location

L10G: The fuel control valves are installed on the right side of the engine.

Shop Talk

  • The primary fuel control valve and the secondary fuel control valve are identical.
  • The engine wiring harness allows the fuel control valve connections to be interchanged between the fuel control valve and the secondary fuel control valve. The secondary fuel control valve can be identified by checking for continuity between pin A at the secondary fuel control valve connector and pin 1 in the ECM connector.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female Amp/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3823994 - female Deutsch test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female Amp/Cannon test lead
Part Number 3823993 - male Deutsch test lead

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the secondary fuel control valve. |
 | STEP 1A. Inspect the harness and the secondary fuel control valve connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the secondary fuel control valve. | 2 to 5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the supply and signal wire. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground in the supply and signal wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the secondary fuel control valve.

Guided Step 1A - Inspect harness and secondary fuel control valve connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the secondary fuel control valve.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or secondary fuel control valve, whichever has the damaged pins.

  • Repair the 3-pin Deutsch connector. Refer to Procedure 019-205.
  • Replace the secondary fuel control valve. Refer to Procedure 019-102.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3823994 - female Deutsch test lead when taking a measurement.
Guided Step 1B - Check the resistance of secondary fuel control valve.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness from the secondary fuel control valve.

Action

  • measure the resistance from pin A to pin B of the secondary fuel control valve.
OK NOT OK

2 to 5 ohms

Replace the secondary fuel control valve

  • Replace the secondary fuel control valve. Refer to Procedure 019-102.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

2D for 557
2B for 558

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female Amp/Cannon test lead
Part Number 3823993 - male Deutsch test lead

Guided Step 2B - Check for an open circuit in supply and signal wire.

Conditions

  • Key switch in the OFF position.
  • Disconnect the engine harness connector from the ECM.

Action

  • measure the resistance from pin 1 of the ECM connector to pin A on the harness side of the secondary fuel control valve connector pins
  • measure the resistance from the engine block to pin C on the harness side of the secondary fuel control valve connector pins.
OK NOT OK

Less than 10 ohms

Repair the harness
Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-205 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2C - Check for a short circuit to ground in the supply and signal wire.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the secondary fuel control valve.

Action

  • measure the resistance from pin 1 of the ECM connector to the engine block
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the secondary fuel control valve.

Action

  • measure the resistance from pin 1 of the ECM connector to all other pins in the connector
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • connect all components
  • start the engine and idle for 1 minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


Gas Mass Flow Sensor (GMFS) Circuit

FAULT CODE 751

Gas Mass Flow Sensor (GMFS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 751 PID: P183 FMI: 2 LAMP: On SRT: 00-338 | Invalid signal detected at gas mass flow sensor pin 16 of the ECM connector. | Possible reduced performance.

Gas Mass Flow Sensor (GMFS) Circuit

Circuit Description

The gas mass flow sensor is used by the electronic control module (ECM) to measure the amount of gas being delivered to the engine from the fuel supply line. The gas mass flow sensor is powered by battery voltage.

Component Location

B5.9G - The gas mass flow sensor is installed in the back of the gas block.
C8.3G - The gas mass flow sensor is installed beside the fuel control valve on the left side of the engine.

L10G - The gas mass flow sensor is installed on the left side of the engine downstream of the pressure regulator.

Shop Talk

By comparing the desired gas mass flow signal with the sensed gas mass flow signal, a problem with the sensor or fuel flow path can be detected. Check for sufficient fuel in the fuel tank and or contaminated gas mass flow sensor.

Check the 10A gas mass flow sensor/heated oxygen sensor fuse.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel system. |
 | STEP 1A. Check for active 455, 511 and 514 fault codes. | Fault Codes 455, 511 and or 514 are not active
 | STEP 1B. Check the fuel supply. | Fuel supply is OK
 | STEP 1C. Check the battery voltage. | Above 11.0 VDC
 | STEP 1D. Check the pressure at the fuel inlet. | 90 to 110 PSIG
 | STEP 1E. Check for oil in the gas block. | No oil in the gas block
 | STEP 1F. Check for deposits on the sensor element or the screen. | No deposits
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 751 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the fuel system.

Guided Step 1A - Check for active 455, 511 and 514 fault codes.

Conditions

  • Keyswitch in the ON position.

Action

Use INSITE™ to read the fault codes.
OK NOT OK

Fault Codes 455, 511 and or 514 are not active

Troubleshoot the fuel control fault code first.

Go to 1B

Go to 2A

Guided Step 1B - Check the fuel supply.

Conditions

  • Keyswitch in the OFF position.

Action

  • Verify that there is sufficient fuel in the fuel tank.
OK NOT OK

Fuel supply is OK

Refuel the vehicle.

Go to 1C

Go to 2A

Guided Step 1C - Check the battery voltage.

Conditions

  • Keyswitch in the OFF position.

Action

Check the voltage at the vehicle battery.
OK NOT OK

Above 11.0 VDC

Repair the charging system

  • Repair the vehicle charging system. Refer to the troubleshooting and repair manual provided by the vehicle OEM.

Go to 1D

Go to 2A

Guided Step 1D - Check the pressure at the fuel inlet.

Conditions

  • Keyswitch in the OFF position.

Action

  • measure the fuel pressure between the primary gas regulator and the engine.
OK NOT OK

90 to 110 PSIG

Replace the primary regulator

  • Replace the primary gas regulator. Refer to the troubleshooting and repair manual provided by the vehicle OEM.

Go to 1E

Go to 2A

Guided Step 1E - Check for oil in the gas block.

Conditions

  • Keyswitch in the OFF position.

Action

  • remove the gas mass flow sensor
  • check for compressor station oil contaminating the gas mass flow sensor.
OK NOT OK

No oil in the gas block

Clean the gas mass flow sensor and the gas block.

Go to 1F

Go to 2A

Guided Step 1F - Check for deposits on the sensor element or the screen.

Conditions

  • Keyswitch in the OFF position.

Action

  • remove the gas mass flow sensor
  • check for compressor station oil contaminating the gas mass flow sensor.
OK NOT OK

No deposits

Replace the sensor

  • Replace the gas mass flow sensor. Refer to Procedure 019-101.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • connect all components
  • start the engine and idle for 1 minute.
OK NOT OK

Fault Code 751 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


Heated Oxygen Sensor (HOS) Circuit

FAULT CODE 752

Heated Oxygen Sensor (HOS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 752 PID: S65 FMI: 2 LAMP: On SRT: 00-339 | The sensed air/fuel ratio is at least five air/fuel ratios greater than the commanded air/fuel ratio. | Possible reduced performance.

Heated Oxygen Sensor (HOS) Circuit

Circuit Description

The heated oxygen sensor is used by the electronic control module (ECM) to measure the air to fuel ratio at which the engine is operating.

Component Location

The heated oxygen sensor is located in the turbocharger exhaust outlet.

Shop Talk

  • The sensor offset valve in the ECM has to agree with the tag on the sensor for this sensor to function properly.
  • Any grease in the electrical connectors can cause the sensor to fail.
  • Only use Cummins approved anti-seize and lubricating compound on the sensor mounting threads.
  • Reference air flows through the heated oxygen sensor wires - the engine will not perform well if the supply of air is obstructed.
  • Check the 10A heated oxygen sensor/gas mass flow sensor fuse.

Cautions and Warnings

WARNING

Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
WARNING

Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
CAUTION

Do not use any grease in the heated oxygen sensor connector. The heated oxygen sensor will not perform correctly with grease in the connector.
To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon test lead.
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

Do not use any grease in the heated oxygen sensor connector. The heated oxygen sensor will not perform correctly with grease in the connector.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822758 - male AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Check fuel control valve or gas mass flow sensor fault codes. | Fault Codes 453, 454, 455, 511, 514, and 751 are not active
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Check the offset value. | Offset value agree
 | STEP 2B. Inspect the harness and the sensor connector pins. | No damaged pins
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the heater supply voltage. | 11.0 to 14.0V
 | STEP 3B. Inspect the ECM and the engine harness connector pins. | No damaged pins
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit in the supply and signal wire. | Less than 2 ohms
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 752 is inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

WARNING

Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
Guided Step 1A - Check the fuel control valve or gas mass flow sensor fault codes.

Conditions

  • Keyswitch in the ON position.

Action

Use the INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 453, 454, 455, 511, 514, and 751 are not active

Troubleshoot the active codes.

Go to 2A

Troubleshooting procedure for Fault Code 453, 454, 455, 511, 514, or 751

Guided Step 2 - Check the heated oxygen sensor.

WARNING

Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
Guided Step 2A - Check the offset value.

Conditions

  • Keyswitch in the ON position.

Action

Use the INSITE™ electronic service tool to read the offset value in the ECM and compare it with the tag on the sensor.
OK NOT OK

Offset value agree

Use the INSITE™ electronic service tool to change offset value to match the number on the sensor tag. Refer to the INSITE™ Users Manual.

Go to 2B

Go to 4A

WARNING

Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
CAUTION

Do not use any grease in the heated oxygen sensor connector. The heated oxygen sensor will not perform correctly with grease in the connector.

Guided Step 2B - Inspect the harness and the sensor connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the heated oxygen sensor, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822758 - male AMP/Cannon test lead.

Guided Step 3A - Check the heater supply voltage.

Conditions

  • Disconnect the heated oxygen sensor heater connector.
  • Keyswitch in the ON position.

Action

Measure the voltage between pin A1 and pin A2 on the harness side of the heated oxygen sensor.
OK NOT OK

11.0 to 14.0VDC

Repair or replace harness.

  • Repair the harness. Refer to Procedure 019-214.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 3B - Inspect the ECM and the engine harness connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Measure the resistance between from pin 23 in the ECM connector and all of the other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 3D - Check for an open circuit in the signal and return wire.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

  • Measure the resistance from the ECM connector pin 22 to heated oxygen sensor signal pin B1 on the harness side of the sensor connector.
  • Measure the resistance from the ECM connector pin 23 to heated oxygen sensor signal pin B2 on the harness side of the sensor connector.
OK NOT OK

Less than 2 ohms

Refer to the appropriate symptom troubleshooting procedure to troubleshoot the existing performance problem.

Repair the damaged pins

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-214 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • connect all components
  • start the engine and let idle for 1 minute.
OK NOT OK

Fault Code 752 is inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


Throttle Plate Position Sensor (TPPS) Circuit

FAULT CODE 754

Throttle Plate Position Sensor (TPPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 754 PID: S254 FMI: 4 LAMP: On SRT: 00-340 | Throttle plate position sensor power supply shorted to ground. | Possible reduced performance.

Throttle Plate Position Sensor (TPPS) Circuit

Circuit Description

The throttle plate position sensor is used by the electronic control module (ECM) to measure the percentage of throttle plate opening.

Component Location

The throttle plate position sensor is located on top of the throttle body.

Shop Talk

The engine can operate without the throttle plate position sensor. Whenever there is an active throttle plate position sensor fault code, the ECM estimates the throttle plate opening using the measured mixer inlet pressure and manifold absolute pressure.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:

Part Number 3822917 - female AMP/Cannon test lead
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check engine harness. |
 | STEP 1A. Inspect harness and ECM connector pins. | No damaged pins
 | STEP 1B. Inspect harness and throttle plate position sensor connector pins. | No damaged pins
 | STEP 1C. Check for short to ground. | More than 100k ohms
STEP 2. | Check throttle plate position sensor. |
 | STEP 2A. Check for a short to ground. | More than 100k ohms
STEP 3. | Clear fault code. |
 | STEP 3A. Disable fault code. | Fault Code 754 inactive
 | STEP 3B. Clear inactive fault codes. | All faults cleared

Guided Step 1 - Check engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect harness and ECM connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

Guided Step 1B - Inspect harness and throttle plate position sensor connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness from the throttle plate position sensor.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair the harness or the throttle plate position sensor, whichever has the damaged pins.

  • Replace the 3-pin Ford connector. Refer to Procedure 019-212.
  • Replace the throttle plate position sensor. Refer to Procedure 019-085.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 1C - Check for short to ground.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect harness from the ECM.
  • Disconnect harness from the throttle plate position sensor.

Action

  • Measure the resistance from pin 13 in the ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

Guided Step 2 - Check throttle plate position sensor.

Guided Step 2A - Check for short to ground.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect harness from the throttle plate position sensor.

Action

  • Measure the resistance from pin C in the throttle plate position sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the throttle plate position sensor. Refer to Procedure 019-085.

Go to 3A

Go to 3A

Guided Step 3 - Clear fault code.

Guided Step 3A - Disable fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start engine and let idle for 1 minute.
OK NOT OK

Fault Code 754 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


ECM Diagnostic Lamp Circuit

FAULT CODE 244 - B5.9G

ECM Diagnostic Lamp Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 244 PID: S238 FMI: 4 LAMP: None SRT: 00-313 | Short to ground detected on diagnostic lamp pin 3 of the ECM connector. | No effect on performance. Loss of diagnostic lamp.

ECM Diagnostic Lamp Circuit

Circuit Description

The Electronic Control Module (ECM) uses the diagnostic lamp to flash out active fault codes.

Component Location

The diagnostic lamp is an original equipment manufacturer (OEM) component that is located on the vehicle dashboard.

Shop Talk

Proper diagnostic lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the vehicle is started.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823994 - female Deutsch test lead
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use Part Number 3823994 - female Deutsch test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 244 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

  • bent or broken pins
  • pushed back or expanded pin
  • corroded pins
  • moisture in or on connector
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Repair the 9-pin Deutsch connector. Refer to Procedure 019-207.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use Part Number 3823994 - female Deutsch test lead when taking a measurement.
Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

  • Measure the resistance from pin F on the OEM connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Repair the OEM harness. Refer to manufacturer's instructions.
  • Replace the OEM harness. Refer to manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

  • Measure the resistance from pin 3 in the ECM connector to all of the other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

  • Measure the resistance from pin 3 in the ECM connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let idle for 1 minute.
OK NOT OK

Fault Code 244 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


ECM Diagnostic Lamp Circuit

FAULT CODE 244 - C8.3G, L10G

ECM Diagnostic Lamp Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 244 PID: S238 FMI: 4 LAMP: None SRT: 00-313 | Short to ground detected on diagnostic lamp pin 3 of the ECM connector. | No effect on performance. Loss of diagnostic lamp.

ECM Diagnostic Lamp Circuit

Circuit Description

The Electronic Control Module (ECM) uses the diagnostic lamp to flash out active fault codes.

Component Location

The diagnostic lamp is an original equipment manufacturer (OEM) component that is located on the vehicle dashboard.

Shop Talk

Proper diagnostic lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the vehicle is started.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:
Part No. 3822917 - female AMP/Cannon test lead
Part No. 3823994 - female Deutsch test lead
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use Part No. 3823994 - female Deutsch test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage use the Part No. 3822917 - female AMP/Cannon test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 244 Inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

  • bent or broken pins
  • pushed back or expanded pin
  • corroded pins
  • moisture in or on connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Repair the 21 pin Deutsch connector. Refer to Procedure 019-207 (C8.3G and L10G only).

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use Part No. 3823994 - female Deutsch test lead when taking a measurement.
Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

  • measure the resistance from pin L on the OEM connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Repair the OEM harness. Refer to manufacturer's instructions.
  • Replace the OEM harness. Refer to manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part No. 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

  • measure the resistance from pin 3 in the ECM connector to all of the other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage use the Part No. 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.
  • Disconnect the harness from ECM.

Action

  • measure the resistance from pin 3 in the ECM connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Connect all components.
  • Start the engine and let idle for 1 minute.
OK NOT OK

Fault Code 244 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2003


Data Link Circuit

FAULT CODE 412 - B5.9G

Data Link Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 FMI: 3 LAMP: On SRT: 00-321 | Data transmission error on data link pins 6 and 8 of the electronic control module (ECM) connector. | Electronic service tools can not communicate with the ECM.

Vehicle Data Link Circuit

Circuit Description

The vehicle data link allows electronic service tools to communicate with the ECM.

Component Location

The vehicle data link connector is located on the engine wiring harness. There can be another vehicle data link connection in the vehicle cab.

Shop Talk

The B5.9G data link will communicate with the industry-standard J1587 diagnostic scan tools.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead.
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3823995 - male Weather-Pack test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead.
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead
To reduce the possibility of damaging the new ECM, all active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle items. |
 | STEP 1A. Turn OFF the possible interference sources. | Fault Code 412 active
 | STEP 1B. Inspect the 2-pin vehicle data link connectors. | No damaged pins
 | STEP 1C. Check the other devices on the data link. | Fault Code 412 active
 | STEP 1D. Check the OEM wiring. | Fault Code 412 active
STEP 2. | Check the harness. |
 | STEP 2A. Check for reversed wires. | Pin A: 4.0 to 5.0 VDC. Pin B: 0.0 to 1.0 VDC
 | STEP 2A1. Inspect the harness and the ECM connector pins. |
 | STEP 2A2. Check for an open circuit in the data link wires. |
 | STEP 2B. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2C. Inspect the OEM connector pins. | No damaged pins
 | STEP 2D. Check for a short circuit in the vehicle data link circuit and any other wires in the harness. | More than 100k ohms
 | STEP 2E. Check for a short circuit to the ground. | More than 100k ohms
 | STEP 2F. Check for an open circuit in the vehicle data link circuit. | Less than 10 ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 412
 | STEP 3B. Clear inactive fault codes. | All faults cleared

Guided Step 1 - Check the vehicle items.

Guided Step 1A - Turn OFF the possible interference sources.

Conditions

  • Keyswitch in the ON position.

Action

  • Turn OFF the CB or other radio devices.
  • Note: Make sure that the power and the ground lines of the radio devices are isolated from the engine electrical system.
OK NOT OK

Fault Code 412 active

Remove the interference

  • Remove all sources of interference.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the 2-pin vehicle data link connectors.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness from the service tool at the vehicle data link.

Action

Inspect the connector on both the tool side and the harness side for the following:

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the data link connector.

  • Repair the 2-pin Weather-Pack connector. Refer to Procedure 019-201.

Go to 1C

Go to 3A

Guided Step 1C - Check the other devices on the data link.

Conditions

  • Keyswitch in the OFF position.

Action

  • Disconnect any on-board electronic devices such as the electronic dashboard, trip recorders, etc., connected to the data link.
OK NOT OK

Fault Code 412 active

Disconnect the devices

  • Disconnect all the devices on the data link.

Go to 1D

Go to 3A

Guided Step 1D - Check the OEM wiring.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Refer to the OEM wiring diagram or the OEM manuals.
OK NOT OK

Fault Code 412 active

Repair the OEM wiring. Refer to vehicle manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 2 - Check the harness.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3823995 - male Weather-Pack test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead.
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Check for reversed wires.

Conditions

  • Keyswitch in the ON position.
  • Disconnect the 9-pin OEM connector.

Action

  • Measure the voltage from pin A on the harness side to the engine block.
  • Measure the voltage from pin B on the harness side to the engine block.
OK NOT OK

Pin A: 4.0 to 5.0 VDC

Pin B: 0.0 to 1.0 VDC

If out of specification, go to Step 2A-1.

If the voltages are opposite of the specification, reverse the wires and go to Step 3A.

Go to 2B

Go to

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A-1 - Inspect the harness and the ECM connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or replace the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2A-2

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead.
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A-2 - Check for an open circuit in the data link wires.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness form the ECM.

Action

  • Measure the resistance from ECM connector pin 6 and pin A on the harness side of the engine data link connector.
  • Measure the resistance from ECM connector pin 8 and pin B on the harness side of the engine data link connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness.Refer to Procedure 019-207 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2B - Inspect the harness and the ECM connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the OEM connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the OEM connector.

Action

  • bent or broken pins
  • pushed back or expanded pin
  • corroded pins
  • moisture in or on connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Repair the 9-pin Deutsch connector. Refer to Procedure 019-207.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2D - Check for a short circuit in the vehicle data link circuit and any other wires in the harness.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • Measure the resistance from ECM connector pin 6 to all other wires in the ECM connection.
  • Measure the resistance from ECM connector pin 8 to all other wires in the ECM connection.
OK NOT OK

More than 100k ohms

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019&ndash;203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead.
Guided Step 2E - Check for a short circuit to the ground.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect harness from the ECM.
  • Disconnect the OEM harness from the vehicle data link circuit.

Action

  • Measure the resistance from ECM connector pin 6 to the engine block.
  • Measure the resistance from ECM connector pin 8 to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2F

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 female AMP/Cannon test lead
Part Number 3823995 - male Weather-Pack test lead
To reduce the possibility of damaging the new ECM, all active fault codes must be investigated prior to replacing the ECM.

Guided Step 2F - Check for an open circuit in the vehicle data link circuit.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect harness from the ECM.
  • Disconnect the OEM harness from the vehicle data link circuit.

Action

  • Measure the resistance from ECM connector pin 6 to pin A on the harness side of the data link connector.
  • Measure the resistance from ECM connector pin 8 to pin B on the harness side of the data link connector.
OK NOT OK

Less than 10 ohms

  • Replace the ECM. Refer to Procedure 019-031.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-207 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Connect all components.
OK NOT OK

Fault Code 412

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 28-Oct-2003


Data Link Circuit

FAULT CODE 412 - C8.3G, L10G

Data Link Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 FMI: 3 LAMP: On SRT: 00-321 | Data transmission error on data link pins 6 and 8 of the electronic control module (ECM) connector. | Electronic service tools can not communicate with the ECM.

Vehicle Data Link Circuit

Circuit Description

The vehicle data link allows electronic service tools to communicate with the ECM.

Component Location

The vehicle data link connector is located on the engine wiring harness. There can be another vehicle data link connection in the vehicle cab.

Shop Talk

The data link will communicate with industry-standard J1587 diagnostic scan tools.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead.
To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3823993 - male Deutsch test lead when taking a measurement.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
To reduce the possibility of damaging the new ECM, all active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle items. |
 | STEP 1A. Turn OFF the possible interference sources. | Fault Code 412 active
 | STEP 1B. Inspect the vehicle data link connectors. | No damaged pins
 | STEP 1C. Check the other devices on the data link. | Fault Code 412 active
 | STEP 1D. Check the OEM wiring. | Fault Code 412 active
STEP 2. | Check the harness. |
 | STEP 2A. Check for reversed wires. | Pin A: 4.0 to 5.0 VDC. Pin B: 0.0 to 1.0 VDC
 | STEP 2B. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2C. Inspect the OEM connector pins. | No damaged pins
 | STEP 2D. Check for a short circuit in the vehicle data link circuit and any other wires in the harness. | More than 100k ohms
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2F. Check for an open circuit in the vehicle data link circuit. | Less than 10 ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 412
 | STEP 3B. Clear inactive fault codes | All faults cleared

Guided Step 1 - Check the vehicle items.

Guided Step 1A - Turn OFF the possible interference sources.

Conditions

  • Keyswitch in the ON position.

Action

  • Turn OFF the CB or other radio devices.
  • Note: Make sure that the power and the ground lines of the radio devices are isolated from the engine electrical system.
OK NOT OK

Fault Code 412 active

Remove the interference

  • Remove all sources of interference.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the vehicle data link connectors.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness from the service tool at the vehicle data link.

Action

Inspect the connector on both the tool side and the harness side for the following:

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the data link connector.

  • Repair the 6-pin Deutsch connector. Refer to Procedure 019-207.

Go to 1C

Go to 3A

Guided Step 1C - Check the other devices on the data link.

Conditions

  • Keyswitch in the OFF position.

Action

  • Disconnect any on-board electronic devices such as the electronic dashboard, trip recorders, etc., connected to the data link.
OK NOT OK

Fault Code 412 active

Disconnect the devices

  • Disconnect all the devices on the data link.

Go to 1D

Go to 3A

Guided Step 1D - Check the OEM wiring.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the OEM harness from the ECM.

Action

Refer to the OEM wiring diagram or the OEM manuals.
OK NOT OK

Fault Code 412 active

Repair the OEM wiring. Refer to vehicle manufacturer's instructions.

Go to 2A

Go to 3A

Guided Step 2 - Check the harness.

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3823993 - male Deutsch test lead when taking a measurement.
Guided Step 2A - Check for reversed wires.

Conditions

  • Keyswitch in the ON position.
  • Disconnect the OEM connector.

Action

  • Measure the voltage from pin A on the harness side to the engine block.
  • Measure the voltage from pin B on the harness side to the engine block.
OK NOT OK

Pin A: 4.0 to 5.0 VDC

Pin B: 0.0 to 1.0 VDC

Repair the wiring harness. Refer to Procedure 019-207 or 019-203.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2B - Inspect the harness and the ECM connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the OEM connector pins.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the OEM connector.

Action

  • bent or broken pins
  • pushed back or expanded pin
  • corroded pins
  • moisture in or on connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or the OEM harness, whichever has the damaged pins.

  • Repair the 21-pin Deutsch connector. Refer to Procedure 019-208.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead when taking a measurement.
Guided Step 2D - Check for a short circuit in the vehicle data link circuit and any other wires in the harness.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect the harness from the ECM.

Action

  • Measure the resistance from ECM connector pin 6 to all other wires in the ECM connection.
  • Measure the resistance from ECM connector pin 8 to all other wires in the ECM connection.
OK NOT OK

More than 100k ohms

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use Part Number 3822917 - female AMP/Cannon test lead.
Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect harness from the ECM.
  • Disconnect the OEM harness from the vehicle data link circuit.

Action

  • Measure the resistance from ECM connector pin 6 to the engine block.
  • Measure the resistance from ECM connector pin 8 to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2F

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
To reduce the possibility of damaging the new ECM, all active fault codes must be investigated prior to replacing the ECM.

Guided Step 2F - Check for an open circuit in the vehicle data link circuit.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect harness from the ECM.
  • Disconnect the OEM harness from the vehicle data link circuit.

Action

  • Measure the resistance from ECM connector pin 6 to pin A on the harness side of the data link connector.
  • Measure the resistance from ECM connector pin 8 to pin B on the harness side of the data link connector.
OK NOT OK

Less than 10 ohms

  • Replace the ECM. Refer to Procedure 019-031.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

  • Connect all components.
OK NOT OK

Fault code 412

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 28-Oct-2003


Ignition Timing Signal Circuit

FAULT CODE 458 B5.9G

Ignition Timing Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 458 PID: S67 FMI: 3 LAMP: Flash SRT: 00-327 | High voltage detected at spark timing pin 7 of the ECM connector. | Engine will not start or run.

Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located on the engine outboard of the ECM.

Shop Talk

The ECM can not detect if there is a misfire or a bad spark plug.

Cautions and Warnings

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead.
Part Number 3822917 - female AMP/Cannon test lead.
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins.
 | STEP 1B. Inspect the engine harness and the ICM connector pins. | No damaged pins.
 | STEP 1C. Check for an open circuit. | Less than 10 ohms.
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms.
 | STEP 1F. Inspect the 9-pin connector pins. | No damaged pins.
 | STEP 1G. Check for voltage supply at the ICM. | 8.0 to 15.0 VDC.
 | STEP 1H. Check the ICM fuse. | Fuse is okay.
STEP 2. | Check the ICM. |
 | STEP 2A. Check the ECM for active fault codes. | Fault code inactive.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the engine harness.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1B - Inspect the engine harness and the ICM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ICM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the harness or the ICM, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the ICM. Refer to Procedure 019-105.

Go to 1C

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead.
Part Number 3822917 - female AMP/Cannon test lead.
Part Number 3823995 - male Weather Pack test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM to pin F of the ICM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1F - Inspect the 9-pin connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect 9-pin connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the 9-pin Deutsch connector. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the OEM harness. Refer to OEM service literature.

Go to 1G

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 1G - Check for voltage supply at the ICM.

Conditions

  • Keyswitch in ON position.
  • Disconnect harness connector from OEM 9-pin connector.

Action

  • Measure the voltage from pin E to pin D in the OEM side of 9-pin connector.
OK NOT OK

8.0 to 15.0 VDC

Repair the harness

  • Repair the harness. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1H

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1H - Check the 10A fuse.

Conditions

  • Keyswitch in OFF position.

Action

  • Inspect the fuse or use a voltmeter to check for continuity.
OK NOT OK

Fuse is okay

Replace the 10A fuse.

Go to 2A

Go to 3A

Guided Step 2 - Check the ICM.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Keyswitch in ON position.
  • Connect all components.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault code inactive

The ICM has failed

  • Replace the ICM. Refer to Procedure 019-105.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Turn the vehicle keyswitch OFF and wait five seconds
  • Turn the vehicle keyswitch ON idle engine for at least one minute.
OK NOT OK

Fault code is inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase the fault codes using INSITE™.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Ignition Timing Signal Circuit

FAULT CODE 458 C8.3G, L10G

Ignition Timing Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 458 PID: S67 FMI: 3 LAMP: Flash, SRT: 00-327 | High voltage detected at spark timing pin 7 of the ECM connector. | Engine will not start or run.

Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

C8.3G: The ICM is installed on the left rear position of the engine below the intake manifold.

L10G: The ICM is installed on the left side of the engine beside the ECM.

Shop Talk

The ECM can not detect if there is a misfire or a bad spark plug.

Cautions and Warnings

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead.
Part Number 3822917 - female AMP/Cannon test lead.
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins.
 | STEP 1B. Inspect the engine harness and the ICM connector pins. | No damaged pins.
 | STEP 1C. Check for an open circuit. | Less than 10 ohms.
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms.
 | STEP 1F. Inspect the connector pins. | No damaged pins.
 | STEP 1G. Check for voltage supply at the ICM. | 8.0 to 15.0 VDC.
 | STEP 1H. Check the ICM fuse. | Fuse is OK.
STEP 2. | Check the ICM. |
 | STEP 2A. Check the ECM for active fault codes. | Fault code inactive.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the engine harness.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1B - Inspect the engine harness and the ICM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ICM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the harness or the ICM, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the ICM. Refer to Procedure 019-105.

Go to 1C

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead.
Part Number 3822917 - female AMP/Cannon test lead.
Part Number 3823995 - male Weather Pack test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM to pin F of the ICM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1F - Inspect the connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect 21-pin connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the 21-pin Deutsch connector. Refer to Procedure 019-208.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the OEM harness. Refer to OEM service literature.

Go to 1G

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 1G - Check for voltage supply at the ICM.

Conditions

  • Keyswitch in ON position.
  • Disconnect harness connector from OEM 21-pin connector.

Action

  • Measure the voltage from pin G to pin V in the OEM side of 21-pin connector.
OK NOT OK

8.0 to 15.0 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-208.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1H

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1H - Check the ICM fuse.

Conditions

  • Keyswitch in OFF position.

Action

  • Inspect the fuse or use a voltmeter to check for continuity.
OK NOT OK

Fuse is OK

Replace the ICM fuse.

Go to 2A

Go to 3A

Guided Step 2 - Check the ICM.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Keyswitch in ON position.
  • Connect all components.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault code inactive

The ICM has failed.

  • Replace the ICM. Refer to Procedure 019-105.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Turn the vehicle keyswitch OFF and wait five seconds
  • Turn the vehicle keyswitch ON idle engine for at least one minute.
OK NOT OK

Fault code is inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart.

Last Modified: 28-Oct-2003


Ignition Timing Signal Circuit

FAULT CODE 459 B5.9G

Ignition Timing Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 459 PID: S67 FMI: 4 LAMP: Flash SRT: 00-328 | Low voltage detected at spark timing pin 7 of the ECM connector. | Engine will not start or run.

Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located on the engine outboard of the ECM.

Shop Talk

The ECM can not detect if there is a misfire or a bad spark plug.

Cautions and Warnings

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead.
Part Number 3822917 - female AMP/Cannon test lead.
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins.
 | STEP 1B. Inspect the engine harness and the ICM connector pins. | No damaged pins.
 | STEP 1C. Check for an open circuit. | Less than 10 ohms.
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms.
 | STEP 1F. Inspect the 9-pin connector pins. | No damaged pins.
 | STEP 1G. Check for voltage supply at the ICM. | 8.0 to 15.0 VDC.
 | STEP 1H. Check the ICM fuse. | Fuse is OK.
STEP 2. | Check the ICM. |
 | STEP 2A. Check the ECM for active fault codes. | Fault code inactive.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the engine harness.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1B - Inspect the engine harness and the ICM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ICM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the harness or the ICM, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the ICM. Refer to Procedure 019-105.

Go to 1C

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead.
Part Number 3822917 - female AMP/Cannon test lead.
Part Number 3823995 - male Weather Pack test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM to pin F of the ICM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1D

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness Refer to Procedure 019-043.

Go to 1F

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1F - Inspect the 9-pin connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect 9-pin connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the 9-pin Deutsch connector. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the OEM harness. Refer to OEM service literature.

Go to 1G

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 1G - Check for voltage supply at the ICM.

Conditions

  • Keyswitch in ON position.
  • Disconnect harness connector from OEM 9-pin connector.

Action

  • Measure the voltage from pin E to pin D in the OEM side of 9-pin connector.
OK NOT OK

8.0 to 15.0 VDC

Repair the harness

  • Repair the harness. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1H

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1H - Check the 10A fuse.

Conditions

  • Keyswitch in OFF position.

Action

  • Inspect the fuse or use a voltmeter to check for continuity.
OK NOT OK

Fuse is OK

Replace the 10A fuse.

Go to 2A

Go to 3A

Guided Step 2 - Check the ICM.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Keyswitch in ON position.
  • Connect all components.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault code inactive

The ICM has failed.

  • Replace the ICM. Refer to Procedure 019-105.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Turn the vehicle keyswitch OFF and wait five seconds
  • Turn the vehicle keyswitch ON idle engine for at least one minute.
OK NOT OK

Fault code is inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Ignition Timing Signal Circuit

FAULT CODE 459 C8.3G, L10G

Ignition Timing Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 459 PID: S67 FMI: 4 LAMP: Flash SRT: 00-328 | Low voltage detected at spark timing pin 7 of the ECM connector. | Engine will not start or run.

Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

C8.3G: The ICM is installed on the left rear position of the engine below the intake manifold.

L10G: The ICM is installed on the left side of the engine beside the ECM.

Shop Talk

The ECM can not detect if there is a misfire or a bad spark plug.

Cautions and Warnings

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead.
Part Number 3822917 - female AMP/Cannon test lead.
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins.
 | STEP 1B. Inspect the engine harness and the ICM connector pins. | No damaged pins.
 | STEP 1C. Check for an open circuit. | Less than 10 ohms.
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms.
 | STEP 1F. Inspect the connector pins. | No damaged pins.
 | STEP 1G. Check for voltage supply at the ICM. | 8.0 to 15.0 VDC.
 | STEP 1H. Check the ICM fuse. | Fuse is okay.
STEP 2. | Check the ICM. |
 | STEP 2A. Check the ECM for active fault codes. | Fault code inactive.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the engine harness.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace the harness or the ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1B - Inspect the engine harness and the ICM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ICM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the harness or the ICM, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the ICM. Refer to Procedure 019-105.

Go to 1C

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3922758 - male AMP test lead.
Part Number 3822917 - female AMP/Cannon test lead.
Part Number 3823995 - male Weather Pack test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM to pin F of the ICM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1D

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in the OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 7 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1F

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1F - Inspect the connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect 21-pin connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the 21-pin Deutsch connector. Refer to Procedure 019-208.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the OEM harness. Refer to OEM service literature.

Go to 1G

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Guided Step 1G - Check for voltage supply at the ICM.

Conditions

  • Keyswitch in ON position.
  • Disconnect harness connector from OEM 21-pin connector.

Action

  • Measure the voltage from pin G to pin V in the OEM side of 21-pin connector.
OK NOT OK

8.0 to 15.0 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-208.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1H

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1H - Check the ICM fuse.

Conditions

  • Keyswitch in OFF position.

Action

  • Inspect the fuse or use a voltmeter to check for continuity.
OK NOT OK

Fuse is okay

Replace the ICM fuse.

Go to 2A

Go to 3A

Guided Step 2 - Check the ICM.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Keyswitch in ON position.
  • Connect all components.

Action

  • Read the fault codes using INSITE™.
OK NOT OK

Fault code inactive

The ICM has failed

  • Replace the ICM. Refer to Procedure 019-105.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Turn the vehicle keyswitch OFF and wait five seconds
  • Turn the vehicle keyswitch ON idle engine for at least one minute.
OK NOT OK

Fault code is inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

Connect all components.

Action

  • Erase fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart.

Last Modified: 28-Oct-2003


Ignition Reference Signal Circuit

FAULT CODE 461 B5.9G

Ignition Reference Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 461 PID: S66 FMI: 3 LAMP: Flash SRT: 00-329 | High voltage detected at spark reference pin 9 of the ECM connector. | Engine will not start or run

Ignition Reference Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers a low voltage to the spark plugs. The Electronic Control Module (ECM) controls the ICM by providing ignition timing information.

Component Location

B5.9G: The ICM is located on the engine outboard of the ECM.

Shop Talk

The ECM can not detect if there is a misfire or a bad spark plug.

Cautions and Warnings

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823996 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins.
 | STEP 1B. Inspect the engine harness and the ICM connector pins. | No damaged pins.
 | STEP 1C. Check for an open circuit. | Less than 10 ohms.
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms.
 | STEP 1F. Inspect the OEM connector pins. | No damaged pins.
 | STEP 1G. Check for the voltage supply to the ICM. | 8 to 15 VDC.
 | STEP 1H. Check the 10A fuse. | Fuse is OK.
STEP 2. | Check the ICM. |
 | STEP 2A. Check the ECM for active fault codes. | Fault code inactive.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the engine harness.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1B - Inspect the engine harness and the ICM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ICM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or ICM, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the ICM. Refer to Procedure 019-105.

Go to 1C

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823996 - male Weather-Pack test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to pin E on the harness side of the ICM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1F - Inspect the OEM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect 9-pin OEM connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the 9-pin Deutsch connector. Refer to Procedure 019-207.

Go to 1G

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.
Guided Step 1G - Check for the voltage supply to the ICM.

Conditions

  • Keyswitch in ON position.
  • Disconnect harness connector from OEM 9-Pin connector.

Action

  • Measure the voltage from pin E to pin D on the vehicle side of the OEM connector.
OK NOT OK

8 to 15 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1H

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1H - Check the 10 A fuse.

Conditions

  • Keyswitch in OFF position.

Action

  • Inspect the fuse or use voltmeter check for continuity test.
OK NOT OK

Fuse is OK

Replace the 10 A fuse.

Go to 2A

Go to 3A

Guided Step 2 - Check the ICM.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Keyswitch in ON position.

Action

  • Read fault codes using INSITE™.
OK NOT OK

Fault Code 461 inactive

The ICM has failed

  • Replace the ICM. Refer to Procedure 01901-105.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Turn the vehicle keyswitch OFF and wait five seconds.
  • Turn the vehicle keyswitch ON.
  • Idle the engine for at least one minute.
OK NOT OK

Fault code is inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


Ignition Reference Signal Circuit

FAULT CODE 461 C8.3G, L10G

Ignition Reference Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 461 PID: S66 FMI: 3 LAMP: Flash SRT: 00-329 | High voltage detected at spark reference pin 9 of the ECM connector. | Engine will not start or run

Ignition Reference Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers a low voltage to the spark plugs. The Electronic Control Module (ECM) controls the ICM by providing ignition timing information.

Component Location

C8.3G: The ICM is installed on the left rear portion of the engine below the intake manifold.

L10G: The ICM is installed on the left side of the engine beside the ECM.

Shop Talk

The ECM can not detect if there is a misfire or a bad spark plug.

Cautions and Warnings

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
Part Number 3823995 - male Weather- Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823996 - male Weather-pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins.
 | STEP 1B. Inspect the engine harness and the ICM connector pins. | No damaged pins.
 | STEP 1C. Check for an open circuit. | Less than 10 ohms.
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms.
 | STEP 1F. Inspect the OEM connector pins. | No damaged pins.
 | STEP 1G. Check for the voltage supply to the ICM. | 8 to 15 VDC.
 | STEP 1H. Check the ICM fuse. | Fuse is okay.
STEP 2. | Check the ICM. |
 | STEP 2A. Check the ECM for active fault codes. | Fault code inactive.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the engine harness.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1B - Inspect the engine harness and the ICM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ICM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damage pins

Repair or replace the harness or ICM, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the ICM. Refer to Procedure 019-105.

Go to 1C

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823996 - male Weather-pack test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to pin E on the harness side of the ICM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-201 or019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1F - Inspect the OEM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect 9-pin OEM connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the 21-pin Deutsch connector. Refer to Procedure 019-208.

Go to 1G

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.
Guided Step 1G - Check for the voltage supply to the ICM.

Conditions

  • Keyswitch in ON position.
  • Disconnect harness connector from OEM 9-Pin connector.

Action

  • Measure the voltage from pin E to pin D on the vehicle side of the OEM connector.
OK NOT OK

8 to 15 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1H

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1H - Check the ICM fuse.

Conditions

  • Keyswitch in OFF position.

Action

  • Inspect the fuse or use voltmeter check for continuity test.
OK NOT OK

Fuse is okay

Replace the 10 A fuse.

Go to 2A

Go to 3A

Guided Step 2 - Check the ICM.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Keyswitch in ON position.

Action

  • Use INSITE™ to read any active fault codes.
OK NOT OK

Fault Code 461 inactive

The ICM has failed

  • Replace the ICM. Refer to Procedure 019-105.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Turn the vehicle keyswitch OFF and wait five seconds.
  • Turn the vehicle keyswitch ON.
  • Idle the engine for at least one minute.
OK NOT OK

Fault code is inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart.

Last Modified: 07-Nov-2003


Ignition Reference Signal Circuit

FAULT CODE 462 B5.9G

Ignition Reference Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 462 PID: S66 FMI: 4 LAMP: Flash SRT: 00-330 | Low voltage detected at spark reference pin 9 of the ECM connector. | Engine will not start or run

Ignition Reference Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers a low voltage to the spark plugs. The Electronic Control Module (ECM) controls the ICM by providing ignition timing information.

Component Location

B5.9G: The ICM is located on the engine outboard of the ECM.

Shop Talk

The ECM can not detect if there is a misfire or a bad spark plug.

Cautions and Warnings

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
Part Number 3823995 - male Weather Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823996 - male Weather-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins.
 | STEP 1B. Inspect the engine harness and the ICM connector pins. | No damaged pins.
 | STEP 1C. Check for an open circuit. | Less than 10 ohms.
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms.
 | STEP 1F. Inspect the OEM connector pins. | No damaged pins.
 | STEP 1G. Check for the voltage supply to the ICM. | 8 to 15 VDC.
 | STEP 1H. Check the 10A fuse. | Fuse is okay.
STEP 2. | Check the ICM. |
 | STEP 2A. Check the ECM for active fault codes. | Fault code inactive.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the engine harness.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1B - Inspect the engine harness and the ICM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ICM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the harness or ICM, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the ICM. Refer to Procedure 019-105.

Go to 1C

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823996 - male Weather-Pack test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to pin E on the harness side of the ICM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1D

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect connector from ECM.
  • Disconnect the harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1F

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1F - Inspect the OEM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect 9-pin OEM connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the 9-pin Deutsch connector. Refer to Procedure 019-207.

Go to 1G

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.
Guided Step 1G - Check for the voltage supply to the ICM.

Conditions

  • Keyswitch in ON position.
  • Disconnect harness connector from OEM 9-pin connector.

Action

  • Measure the voltage from pin E to pin D on the vehicle side of the OEM connector.
OK NOT OK

8 to 15 VDC

Repair the harness

  • Repair the harness. Refer to Procedure 019-207.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1H

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1H - Check the 10 A fuse.

Conditions

  • Keyswitch in OFF position.

Action

  • Inspect the fuse or use voltmeter check for continuity test.
OK NOT OK

Fuse is okay

Replace the 10 A fuse.

Go to 2A

Go to 3A

Guided Step 2 - Check the ICM.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Keyswitch in ON position.

Action

  • Read fault codes using INSITE™.
OK NOT OK

Fault Code 462 inactive

The ICM has failed

  • Replace the ICM. Refer to Procedure 019-105.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Turn the vehicle keyswitch OFF and wait five seconds.
  • Turn the vehicle keyswitch ON.
  • Idle the engine for at least one minute.
OK NOT OK

Fault code is inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 28-Oct-2003


Ignition Reference Signal Circuit

FAULT CODE 462 C8.3G, L10G

Ignition Reference Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 462 PID: S66 FMI: 4 LAMP: Flash SRT: 00-330 | Low voltage detected at spark reference pin 9 of the ECM connector. | Engine will not start or run

Ignition Reference Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers a low voltage to the spark plugs. The Electronic Control Module (ECM) controls the ICM by providing ignition timing information.

Component Location

C8.3G: The ICM is installed on the left rear portion of the engine below the intake manifold.

L10G: The ICM is installed on the left side of the engine beside the ECM.

Shop Talk

The ECM can not detect if there is a misfire or a bad spark plug.

Cautions and Warnings

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823993 - male Deutsch test lead
Part Number 3823994 - female Deutsch test lead
Part Number 3823995 - male Weather- Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823996 - male Weather-pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

CAUTION

To reduce the possibility of pin and harness damage use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins.
 | STEP 1B. Inspect the engine harness and the ICM connector pins. | No damaged pins.
 | STEP 1C. Check for an open circuit. | Less than 10 ohms.
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms.
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms.
 | STEP 1F. Inspect the OEM connector pins. | No damaged pins.
 | STEP 1G. Check for the voltage supply to the ICM. | 8 to 15 VDC.
 | STEP 1H. Check the ICM fuse. | Fuse is okay.
STEP 2. | Check the ICM. |
 | STEP 2A. Check the ECM for active fault codes. | Fault code inactive.
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault code inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the engine harness.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Replace harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1B - Inspect the engine harness and the ICM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ICM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damage pins

Repair or replace the harness or ICM, whichever has the damaged pins.

  • Repair the 6-pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the ICM. Refer to Procedure 019-105.

Go to 1C

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3823996 - male Weather-pack test lead.

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to pin E on the harness side of the ICM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1D

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP test lead.

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect harness connector from ECM.
  • Disconnect harness from ICM.

Action

  • Measure the resistance from pin 9 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1F

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1F - Inspect the OEM connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect 9-pin OEM connector.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins

Repair the engine harness or OEM harness, whichever has the damaged pins.

  • Repair the 21-pin Deutsch connector. Refer to Procedure 019-208.

Go to 1G

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of pin and harness damage use the following test lead when taking a measurement:
Part Number 3823994 - female Deutsch test lead.
Guided Step 1G - Check for the voltage supply to the ICM.

Conditions

  • Keyswitch in ON position.
  • Disconnect the harness connector from the OEM 9-Pin connector.

Action

  • Measure the voltage from pin E to pin D on the vehicle side of the OEM connector.
OK NOT OK

8 to 15 VDC

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-208.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1H

Go to 3A

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
Guided Step 1H - Check the ICM fuse.

Conditions

  • Keyswitch in OFF position.

Action

  • Inspect the fuse or use voltmeter check for continuity test.
OK NOT OK

Fuse is okay

Replace the 10 A fuse.

Go to 2A

Go to 3A

Guided Step 2 - Check the ICM.

WARNING

Extremely high voltage. Do not touch any ignition wiring or component while the engine is operating unless a insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Keyswitch in ON position.

Action

  • Use INSITE™ to read any active fault codes.
OK NOT OK

Fault Code 462 inactive

The ICM has failed

  • Replace the ICM. Refer to Procedure 019-105.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Turn the vehicle keyswitch OFF and wait five seconds.
  • Turn the vehicle keyswitch ON.
  • Idle the engine for at least one minute.
OK NOT OK

Fault code is inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair location if steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart.

Last Modified: 28-Oct-2003


Throttle Plate Position Sensor (TPPS) Circuit

FAULT CODE 512 B5.9G

Throttle Plate Position Sensor (TPPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 FMI: 3 LAMP: On SRT: 00-334 | High voltage detected at the throttle plate position sensor pin 19 of the ECM connector. | Possible reduced performance.

Throttle Plate Position Sensor (TPPS) Circuit

Circuit Description

The throttle plate position sensor is used by the electronic control module (ECM) to measure the percentage of throttle plate opening.

Component Location

The throttle plate position sensor is installed on top of the throttle body.

Shop Talk

Check to make sure that throttle linkage moves smoothly and freely.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the throttle plate position sensor. |
 | STEP 1A. Inspect engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the throttle plate position sensor. | Less than 4800 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in supply and signal wire. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground in supply and signal wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the throttle plate position sensor.

Guided Step 1A - Inspect engine harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from throttle plate position sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair the harness or throttle plate position sensor, whichever has the damaged pins.

  • Replace the 3-pin Ford connector. Refer to Procedure 019-212.
  • Replace the throttle plate position sensor. Refer to Procedure 019-085.

Go to 1B

Go to 3A

Guided Step 1B - Check resistance of throttle plate position sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from throttle plate position sensor.

Action

  • Measure the resistance from pin A to pin B of the throttle plate position sensor.
  • Note: The resistance from pin A to pin B should increase smoothly as the throttle is opened.
OK NOT OK

Less than 4800 ohms

Replace the throttle plate position sensor. Refer to Procedure 019-085.

Go to 2A

3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon test lead.

Guided Step 2B - Check for an open circuit in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate position sensor.

Action

  • Measure the resistance from pin 13 of the ECM connector to pin C on the harness side of the throttle plate position sensor connector pins.
  • Measure the resistance from pin 19 of the ECM connector to pin B on the harness side of the throttle plate position sensor connector.
OK NOT OK

Less than 10 ohms

  • Repair the harness. Refer to Procedure 019-212 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for a short circuit to ground in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate position sensor.

Action

  • Measure the resistance from pin 13 of the ECM connector to the engine block.
  • Measure the resistance from pin 19 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate position sensor.

Action

  • Measure the resistance from pin 19 of the ECM connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Reconnect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


Throttle Plate Actuator (TPA) Circuit

FAULT CODE 512 C8.3G, L10G

Throttle Plate Actuator (TPA) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 FMI: 3 LAMP: On SRT: 00-334 | High voltage detected at the throttle plate actuator pin 19 of the ECM connector. | Possible reduced performance.

Throttle Plate Actuator (TPA) Circuit

Circuit Description

The throttle plate actuator sends the ECM a voltage signal that is proportional to the throttle plate position.

Component Location

The throttle plate actuator is mounted on the intake manifold.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822996 - female Weather-Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit in the signal wire. | Less than 10 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1E. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault code inactive
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect engine harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from throttle plate actuator.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair the harness or throttle plate actuator, whichever has the damaged pins.

  • Replace the 6 pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the throttle plate actuator. Refer to Procedure 019-097.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1B - Inspect ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1D

2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822996 - female Weather-Pack test lead.

Guided Step 1C - Check for open circuit in the signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate actuator.

Action

  • Measure the resistance from pin 19 of the ECM connector to pin F on the harness side of the throttle plate actuator connector.
OK NOT OK

Less than 10 ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1D - Check for short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate actuator.

Action

  • Measure the resistance from pin 19 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1E - Check for a short circuit to ground in the signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate actuator.

Action

  • Measure the resistance from pin 19 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

  • Replace the throttle plate actuator. Refer to Procedure 019-097.

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Reconnect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault codes inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


Throttle Plate Position Sensor (TPPS) Circuit

FAULT CODE 513 B5.9G

Throttle Plate Position Sensor (TPPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 FMI: 4 LAMP: On SRT: 00-335 | Low voltage detected at throttle plate actuator pin 19 of the ECM connector. | Possible reduced performance.

Throttle Plate Position Sensor (TPPS) Circuit

Circuit Description

The throttle plate position sensor is used by the electronic control module (ECM) to measure the percentage of throttle plate opening.

Component Location

The throttle plate position sensor is installed on top of the throttle body.

Shop Talk

Check to make sure that throttle linkage moves smoothly and freely.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the throttle plate position sensor. |
 | STEP 1A. Inspect engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the throttle plate position sensor. | Less than 4800 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in supply and signal wire. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground in supply and signal wire. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the throttle plate position sensor.

Guided Step 1A - Inspect engine harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from throttle plate position sensor.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair the harness or throttle plate position sensor, whichever has the damaged pins.

  • Replace the 3-pin Ford connector. Refer to Procedure 019-212.
  • Replace sensor. Refer to Procedure 019-085.

Go to 1B

Go to 3A

Guided Step 1B - Check resistance of throttle plate position sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from throttle plate position sensor.

Action

  • Measure the resistance from pin A to pin B of the throttle plate position sensor.
  • Note: The resistance from pin A to pin B should increase smoothly as the throttle is opened.
OK NOT OK

Less than 4800 ohms

Replace the throttle plate position sensor. Refer to Procedure 019-085.

Go to 2A

3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 2A - Inspect ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822758 - male AMP/Cannon test lead.

Guided Step 2B - Check for an open circuit in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate position sensor.

Action

  • Measure the resistance from pin 13 of the ECM connector to pin C on the harness side of the throttle plate position sensor connector pins.
  • Measure the resistance from pin 19 of the ECM connector to pin B on the harness side of the throttle plate position sensor connector.
OK NOT OK

Less than 10 ohms

  • Repair the harness. Refer to Procedure 019-212 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2C - Check for a short circuit to ground in supply and signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate position sensor.

Action

  • Measure the resistance from pin 13 of the ECM connector to the engine block.
  • Measure the resistance from pin 19 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate position sensor.

Action

  • Measure the resistance from pin 19 of the ECM connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Reconnect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault code inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


Throttle Plate Actuator (TPA) Circuit

FAULT CODE 513 C8.3G, L10G

Throttle Plate Actuator (TPA) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 FMI: 4 LAMP: On SRT: 00-335 | Low voltage detected at throttle plate actuator pin 19 of the ECM connector. | Possible reduced performance.

Throttle Plate Actuator (TPA) Circuit

Circuit Description

The throttle plate actuator sends the ECM a voltage signal that is proportional to the throttle plate position.

Component Location

The throttle plate actuator is mounted on the intake manifold.

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822996 - female Weather-Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect engine harness and sensor connector pins. | No damaged pins
 | STEP 1B. Inspect ECM and harness connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit in the signal wire. | Less than 10 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1E. Check for a short circuit to ground in the signal wire. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault code inactive
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect engine harness and sensor connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from throttle plate actuator.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Repair the harness or throttle plate actuator, whichever has the damaged pins.

  • Replace the 6 pin Weather-Pack connector. Refer to Procedure 019-201.
  • Replace the throttle plate actuator. Refer to Procedure 019-097.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 1B - Inspect ECM and harness connector pins.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness from ECM.

Action

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector.
OK NOT OK

No damaged pins

Repair damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1C

2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead
Part Number 3822996 - female Weather-Pack test lead.

Guided Step 1C - Check for open circuit in the signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate actuator.

Action

  • Measure the resistance from pin 19 of the ECM connector to pin F on the harness side of the throttle plate actuator connector.
OK NOT OK

Less than 10 ohms

  • Repair the harness. Refer to Procedure 019-201 or 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1D - Check for short circuit from pin to pin.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate actuator.

Action

  • Measure the resistance from pin 19 of the ECM connector to all other pins in connector.
OK NOT OK

More than 100k ohms

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 1E

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:
Part Number 3822917 - female AMP/Cannon test lead.

Guided Step 1E - Check for a short circuit to ground in the signal wire.

Conditions

  • Keyswitch in OFF position.
  • Disconnect engine harness connector from ECM.
  • Disconnect engine harness from throttle plate actuator.

Action

  • Measure the resistance from pin 19 of the ECM connector to the engine block.
OK NOT OK

More than 100k ohms

  • Replace the throttle plate actuator. Refer to Procedure 019-097.

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203.
  • Replace the harness. Refer to Procedure 019-043.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Reconnect all components.

Action

  • Connect all components.
  • Start the engine and idle for one minute.
OK NOT OK

Fault codes inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear inactive fault codes.

Conditions

  • Reconnect all components.

Action

  • Erase inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Go to appropriate troubleshooting chart

Last Modified: 31-Oct-2003


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


NO TITLE

Information Fault Codes

NOTE: - After correcting the condition that caused the fault, let the engine run for one minute to inactivate the fault
code. Then, use INSITE™ to clear the fault code.

CODE: 32
LAMP: Flash
REASON: Engine speed above normal operating range.
EFFECT: Engine will only idle.
ACTION: Clear the fault. No other action required.
CODE: 45
LAMP: Flash
REASON: The throttle plate actuator has moved unexpectedly.
EFFECT: The engine will shut down.
ACTION: Check the throttle plate for an obstruction. If no obstruction is found, replace the throttle plate actuator. After correcting the condition that caused the fault, let the engine idle for one minute to inactivate the fault. Then use INSITE™ to clear the Fault Code.
CODE: 47
LAMP: Flash
REASON: The throttle plate actuator is not responding properly.
EFFECT: Engine will shut down.
ACTION: Check the throttle plate for obstruction. If no obstruction is found, replace the throttle plate actuator.
CODE: 124
LAMP: Flash
REASON: Mixer inlet pressure is above the normal operating range (overboost).
EFFECT: Fuel shut off while mixer inlet pressure is above normal engine operating range. Normal operation resumes when mixer inlet pressure drops to normal levels.
ACTION: Inspect the turbocharger for tampering or mechanical problems. Refer to appropriate base engine Troubleshooting and Repair Manual.
CODE: 151
LAMP: Flash
REASON: Coolant Temperature is above the normal operating range (overheat).
EFFECT: Engine will shut down if the overheat shutdown feature is enabled.
ACTION: Refer to the appropriate High Coolant Temperature symptom troubleshooting procedure.
CODE: 155
LAMP: Flash
REASON: Intake Manifold Temperature is above the normal operating range.
EFFECT: Engine will shut down if the overheat shutdown feature is enabled. Engine will restart after keyoff if the intake manifold temperature is in normal range.
ACTION: Verify the Intake Manifold Temperature with a temperature probe. Refer to the appropriate base engine Troubleshooting and Repair Manual.
CODE: 234
LAMP: Flash
REASON: Engine Speed is above the normal operating range.
EFFECT: Fuel and spark are disabled until engine speed falls into normal operating range.
ACTION: Clear the fault. No other action required.
CODE: 414
LAMP: Flash or On
REASON: The throttle plate actuator has moved unexpectedly or there is a datalink failure between the ECM and GCM.
EFFECT: The engine may shut down or may be derated by reducing boost pressure.
ACTION: If Fault Code 45 is also active, follow the steps for Fault Code 45. If the engine still runs, the ECM is not receiving necessary information from the GCM over the datalink. Check the continuity of the datalink wiring between the ECM and GCM, check the power supply to the GCM and then follow the steps for Fault Code 412. After correcting the condition that caused the fault, let the engine idle for one minute to inactivate the fault. Then use INSITE™ to clear the Fault Code.
CODE: 514
LAMP: Flash
REASON: Fuel control valve mechanically stuck open.
EFFECT: Reduced performance due to rich air/fuel ratio.
ACTION: Check the fuel control valve(s) for obstruction. Clean or replace the fuel control valve(s).
CODE: 545
LAMP: On
REASON: Wastegate control valve mechanically stuck open.
EFFECT: Possible reduced performance.
ACTION: Check the wastegate control valve for an obstruction. Clean or replace the wastegate control valve.
CODE: 558
LAMP: On
REASON: Low fuel pressure detected by the fuel pressure switch on the B5.9G.
EFFECT: Engine may not start, engine may die, or engine power derated by limited boost pressure.
ACTION: If the engine will not start, refer to Engine Difficult to Start or Will Not Start symptom tree in Section TS. Is the engine will start, measure the fuel pressure at the fuel control valve housing (while the engine is running). Refer to the Base Engine T&R, Procedure No. xxx-xxx. If the fuel pressure is above 17.5 psig (32.5 psi absolute), refer to the Engine Difficult to Start or Will Not Start symptom tree in Section TS. If the fuel pressure is above 17.5 psig (32,5 psi absolute), measure the resistance between pin A and C of the fuel pressure switch (while the engine is running). Be sure to use a female AMP/Cannon test leads, Part No. 3822917. If the resistance is above 100 ohms replace the fuel pressure switch. If the resistance is below 100 ohms, check that pin A of the fuel pressure switch connector is connected to ground. Check for continuity of pin C of the fuel pressure switch connector to pin 24 of the ECM connector. Check the ECM connector for any bent pins.

Last Modified: 02-Apr-2003


INDEX
76-ifctable.htm

76-fc18.htm

76-fc21.htm

76-fc22.htm

76-fc23.htm

76-fc24.htm

76-fc25.htm

76-fc34.htm

76-fc35.htm

76-fc41.htm

76-fc43.htm

76-fc111.htm

76-fc121.htm

76-fc122.htm

76-fc123.htm

76-fc144.htm

76-fc145.htm

76-fc153.htm

76-fc154.htm

76-fc244.htm

76-fc244b.htm

76-fc244cl.htm

76-fc254.htm

76-fc255.htm

76-fc336.htm

76-fc337.htm

76-fc342.htm

76-fc343.htm

76-fc352.htm

76-fc354.htm

76-fc355.htm

76-fc412.htm

76-fc412b.htm

76-fc412cl.htm

76-fc441.htm

76-fc442.htm

76-fc453.htm

76-fc454.htm

76-fc455.htm

76-fc458.htm

76-fc458b.htm

76-fc458cl.htm

76-fc459.htm

76-fc459b.htm

76-fc459cl.htm

76-fc461.htm

76-fc461b.htm

76-fc461cl.htm

76-fc462.htm

76-fc462b.htm

76-fc462cl.htm

76-fc463.htm

76-fc464.htm

76-fc465.htm

76-fc466.htm

76-fc511.htm

76-fc512.htm

76-fc512b.htm

76-fc512cl.htm

76-fc513.htm

76-fc513b.htm

76-fc513cl.htm

76-fc557.htm

76-fc751.htm

76-fc752.htm

76-fc754.htm