QSK19/23/45/60/78

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module (ECM) Microprocessor

FAULT CODE 111

Electronic Control Module (ECM) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Red SRT: 00-606 | Error internal to the ECM related to memory hardware failures or internal processor communication failures. | Mission-disabling failure. Engine not allowed to start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the electronic control valve assembly on the intake side of the engine.

Shop Talk

This fault code can only be caused by an internal ECM problem. It is impossible to repair an ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 01-Mar-2011
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Timing Fueling Flow Mismatch

FAULT CODE 112

Timing Fueling Flow Mismatch

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 112 PID: S20 SPN: 635 FMI: 7 LAMP: Red SRT: 00-342 | The error between estimated timing fueling and desired timing fueling is outside acceptable limits. | Depending on the calibration, the engine will shut down or speed-derate or no action by the ECM is taken.
Fuel System Flow Schematic

Circuit Description

The electronic control module (ECM) uses the timing pressure signal and engine speed to estimate the actual timing the engine is receiving and then constantly compares this value to the desired timing for the given speed and load. When there is too large an error in these values for too long a time, this fault is logged.

Component Location

The timing actuator is located on the top of the control valve body, toward the front of the engine and behind the ECM.

Shop Talk

The estimated timing fueling and the desired timing fueling parameters can be monitored on INSITE™ electronic service tool. This fault is a check on the ECM's control of the timing actuator and subsequent fuel flow. If the desired timing fueling can not be met by commanding more current to the actuator or if the desired timing fueling is being exceeded and can not be reduced by reducing the current to the actuator, this fault is logged.

This fault is not logged when:

  • Coolant temperature is below 0°C [32°F].
  • Fault Code 116 or 117 is active.
  • Once the keyswitch is cycled, this fault becomes inactive.
Refer to Troubleshooting Fault Code t05-112

Last Modified: 01-Mar-2011


Timing Actuator Circuit

FAULT CODE 113

Timing Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 113 PID: S20 SPN: 635 FMI: 3 LAMP: Yellow SRT: 00-343 | Timing actuator circuit is open, or supply pin 1 is shorted to ground, or return pin 20 is shorted to battery voltage. | No action by the ECM is taken. Actuator is closed or partially closed. Engine exhausts white smoke and loses power. Fault Code 112 can possibly be logged.
Timing Actuator Circuit

Circuit Description

The timing actuator circuit supplies current to the timing actuator. The ECM commands a varying amount of current to the timing actuator to control the amount of timing pressure to the injectors.

Component Location

The timing actuator is located on the top of the control valve body, toward the front of the engine and behind the ECM.

Shop Talk

  • Confirm that the actuator connector is firmly in place.
  • When there is no power to the actuator, the actuator closes and timing flow stops. This can cause Fault Code 112, timing fueling flow mismatch.
Refer to Troubleshooting Fault Code t05-113

Last Modified: 01-Mar-2011


Engine Speed Sensor Circuit

FAULT CODE 115

Engine Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Red SRT: 00-345 | No engine speed signal detected at pins 27, 28, 37, and 38 of the engine harness. | Engine is shut down and can not be run.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual-coil circuit that provides the engine speed signal to the ECM through the engine harness.

Component Location

The engine speed sensor is located above the accessory drive.

Shop Talk

  • If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor (engine speed sensor) circuit while the engine is at that particular temperature.
  • Check camshaft end play to make sure that the camshaft gear is not moving too far away from the end of the engine speed sensor.
Refer to Troubleshooting Fault Code t05-115

Last Modified: 01-Mar-2011


Timing Pressure Sensor Circuit

FAULT CODE 116

Timing Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 116 PID: P156 SPN: 156 FMI: 3 LAMP: Red SRT: 00-346 | More than 4.78 VDC detected at timing pressure sensor signal pin 33 of the engine harness. | Depending on the calibration, the engine will shut down or speed-derate, or no action by the ECM is taken.
Timing Pressure Sensor Circuit

Circuit Description

The timing pressure sensor provides the timing pressure sensor signal to the ECM through the engine harness. The ECM uses the timing pressure sensor signal to monitor the timing fuel pressure going to the injector's timing chamber from the control valve body.

Component Location

The timing pressure sensor is located on the right side of the control valve body.

Shop Talk

The following chart shows the output voltage of the timing pressure sensor at various pressure readings.

Pressure Sensor Output Voltage:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.48 to 0.53
103.42 | 15 | 30.54 | 0.63 to 0.67
345 | 50 | 101.8 | 0.98 to 1.13
1034 | 150 | 305.4 | 1.98 to 2.33
1724 | 250 | 509 | 2.97 to 3.55
2585 | 375 | 763.5 | 4.18 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, reference the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-116

Last Modified: 01-Mar-2011


Timing Pressure Sensor Circuit

FAULT CODE 117

Timing Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 117 PID: P156 SPN: 156 FMI: 4 LAMP: Red SRT: 00-347 | Less than 0.15 VDC detected at timing pressure sensor signal pin 33 of the engine harness. | Depending on the calibration, the engine will shut down or speed-derate, or no action by the ECM is taken.
Timing Pressure Sensor Circuit

Circuit Description

The timing pressure sensor provides the timing pressure sensor signal to the ECM through the engine harness. The ECM uses the timing pressure sensor signal to monitor the timing fuel pressure going to the injector's timing chamber from the control valve body.

Component Location

The timing pressure sensor is located on the upper right side of the control valve body.

Shop Talk

The following chart shows the output voltage of the timing pressure sensor at various pressure readings.

Pressure Sensor Output Voltage:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.48 to 0.53
103.42 | 15 | 30.54 | 0.63 to 0.67
345 | 50 | 101.8 | 0.98 to 1.13
1034 | 150 | 305.4 | 1.98 to 2.33
1724 | 250 | 509 | 2.97 to 3.55
2585 | 375 | 763.5 | 4.18 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-117

Last Modified: 01-Mar-2011


Fuel Pump Pressure Sensor Circuit

FAULT CODE 118

Fuel Pump Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 118 PID: P135 SPN: 135 FMI: 3 LAMP: Yellow SRT: 00-383 | More than 4.78-VDC detected at fuel pump pressure sensor signal pin 32 of the engine harness. | No action by the ECM is taken.
Fuel Pump Pressure Sensor Circuit

Circuit Description

The fuel pump pressure sensor provides the fuel pump pressure sensor signal to the ECM through the engine harness. The ECM uses the fuel pump pressure signal to monitor the fuel pump pressure going to the control valve body.

Component Location

The fuel pump pressure sensor is located on the fuel pump.

Shop Talk

The following chart shows the output voltage of the fuel pump pressure sensor at various pressure readings:

Pressure Sensor Output Voltage

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.48 to 0.53
103.42 | 15 | 30.54 | 0.63 to 0.67
345 | 50 | 101.8 | 0.98 to 1.13
1034 | 150 | 305.4 | 1.98 to 2.33
1724 | 250 | 509 | 2.97 to 3.55
2585 | 375 | 763.5 | 4.18 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-118

Last Modified: 01-Mar-2011


Fuel Pump Pressure Sensor Circuit

FAULT CODE 119

Fuel Pump Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 119 PID: P135 SPN: 135 FMI: 4 LAMP: Yellow SRT: 00-384 | Less than 0.30-VDC detected at fuel pump pressure sensor signal pin 32 of the engine harness. | No action by the ECM is taken.
Fuel Pump Pressure Sensor Circuit

Circuit Description

The fuel pump pressure sensor provides the fuel pump pressure sensor signal to the ECM through the engine harness. The ECM uses the fuel pump pressure signal to monitor the fuel pump pressure going to the control valve body.

Component Location

The fuel pump pressure sensor is located on the fuel pump.

Shop Talk

The following chart shows the output voltage of the fuel pump pressure sensor at various pressure readings:

Pressure Sensor Output Voltage

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.48 to 0.53
103.42 | 15 | 30.54 | 0.63 to 0.67
345 | 50 | 101.8 | 0.98 to 1.13
1034 | 150 | 305.4 | 1.98 to 2.33
1724 | 250 | 509 | 2.97 to 3.55
2585 | 375 | 763.5 | 4.18 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-119

Last Modified: 01-Mar-2011


Engine Speed Sensor Circuit

FAULT CODE 121

Engine Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Yellow SRT: 00-345 | Engine Speed Sensor Circuit. No engine speed signal detected at one pair of pins, either pin 27, 28, 37, or 38 of the engine harness. | No action by the engine control module (ECM) is taken.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual-coil circuit that provides the engine speed signal to the ECM through the engine harness.

Component Location

The engine speed sensor is located above the accessory drive.

Shop Talk

  • If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor circuit while the engine is at that particular temperature.
  • Measure camshaft end clearance to make sure that camshaft gear is not moving too far away from the end of the engine speed sensor.
Refer to Troubleshooting Fault Code t05-121

Last Modified: 10-Dec-2015


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Off SRT: 00-348 | More than 4.72-VDC detected at the intake manifold air pressure sensor signal pin 35 of the engine harness. | Engine power derate to no-air setting.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the ECM through pin 35 of the engine harness. The ECM monitors the voltage on pin 35 and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation. Voltage above 4.72-VDC on pin 35 will trip Fault Code 122 and can be caused by shorts in the supply, signal, or return wires, an open circuit in the return wire, or a malfunctioning sensor.

Component Location

The intake manifold pressure sensor is located on the middle lower edge of the air intake manifold.

Shop Talk

  • Determine if the engine is being overfueled.
  • Confirm that the correct intake manifold pressure sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air can be the cause of the high intake manifold pressure, test the engine while feeding it warm intake air.
  • Inspect the intake manifold pressure sensor circuit for signs of tampering. Remove any extra wires from the circuit.

The following chart shows the output voltage of the intake manifold pressure sensor at various pressure readings for the QSK19 and QSK23 engines. Note: The pressure measurements are gauge pressures.

QSK19 and QSK23 Pressure/Voltage Readings
Pressure | Pressure | Pressure | Voltage
kPa | psig | in Hg | VDC
0 | 0 | 0 | 0.22 to 0.80
69 | 10 | 20.36 | 1.23 to 1.40
138 | 20 | 40.72 | 1.97 to 2.27
207 | 30 | 61.08 | 2.71 to 3.16
276 | 40 | 81.44 | 3.45 to 4.04
345 | 50 | 101.8 | 4.20 to 4.92

The following chart shows the output voltage of the intake manifold pressure sensor at various pressure readings for the QSK45, QSK60, and QSK78 engines. Note: The pressure measurements are absolute pressures.

QSK45, QSK60, and QSK78 Pressure/Voltage Readings
Pressure | Pressure | Pressure | Voltage
kPa | psia | in Hg | VDC
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.23 to 1.40
207 | 30 | 61.08 | 1.97 to 2.27
310 | 45 | 91.62 | 2.71 to 3.16
414 | 60 | 122.16 | 3.45 to 4.04
517 | 75 | 152.7 | 4.20 to 4.92

For absolute pressure sensors, the pressure will change with altitude. Determine the correct pressure and voltage reading for the altitude at which the engine is in operation. Refer to Procedure 018-028 in Section V.

Older engine models will use the Packard™-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard™ connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard™-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard™ | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-122

Last Modified: 01-Mar-2011


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: None SRT: 00-349 | Less than 0.33-VDC detected at the intake manifold air pressure sensor signal pin 35 of the engine harness. | Engine power derate to no-air setting.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the ECM through pin 35 of the engine harness. The ECM monitors the voltage on pin 35 and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation. Voltage below 0.33-VDC on pin 35 can be caused by shorts in the supply, signal, or return wires, an open circuit in the supply or signal wires, low supply voltage from the ECM, or a failed sensor.

Component Location

The intake manifold pressure sensor is located on the middle lower edge of the air intake manifold.

Shop Talk

  • Check for high restriction in the intake air manifold due to clogged air filters or a shutdown device in the manifold (if the vehicle is equipped with one). Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.
  • Make sure the turbocharger is working correctly. Check for a positive intake manifold pressure.

The following chart shows the output voltage of the intake manifold pressure sensor at various pressure readings for the QSK19 and QSK23 engines. Note: The pressure measurements are gauge pressures.

QSK19 and QSK23 Pressure/Voltage Readings
Pressure | Pressure | Pressure | Voltage
kPa | psig | in Hg | VDC
0 | 0 | 0 | 0.22 to 0.80
69 | 10 | 20.36 | 1.23 to 1.40
138 | 20 | 40.72 | 1.97 to 2.27
207 | 30 | 61.08 | 2.71 to 3.16
276 | 40 | 81.44 | 3.45 to 4.04
345 | 50 | 101.8 | 4.20 to 4.92

The following chart shows the output voltage of the intake manifold pressure sensor at various pressure readings for the QSK45, QSK60, and QSK78 engines. Note: The pressure measurements are absolute pressures.

QSK45, QSK60, and QSK78 Pressure/Voltage Readings
Pressure | Pressure | Pressure | Voltage
kPa | psia | in Hg | VDC
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.23 to 1.40
207 | 30 | 61.08 | 1.97 to 2.27
310 | 45 | 91.62 | 2.71 to 3.16
414 | 60 | 122.16 | 3.45 to 4.04
517 | 75 | 152.7 | 4.20 to 4.92

For absolute pressure sensors, the pressure will change with altitude. Determine the correct pressure and voltage reading for the altitude at which the engine is in operation. Refer to Procedure 018-028 in Section V.

Older engine models will use the Packard™-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard™ connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard™-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard™ | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-123

Last Modified: 01-Mar-2011


Intake Manifold Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 127

Intake Manifold Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 127 PID: P102 SPN: 102 FMI: 4 LAMP: None SRT: 00-349 | Intake Manifold Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Less than 0.33 VDC detected at the intake manifold air pressure sensor signal pin 35 of the engine harness. | Engine power derate to no-air setting.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the engine control module (ECM).

Component Location

The intake manifold pressure sensor is located on the middle lower edge of the air intake manifold.

Shop Talk

  • Check for high restriction in the intake air manifold due to clogged air filters or a shutdown device in the manifold, if the vehicle is equipped with one. Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.
  • Make sure the turbocharger is working correctly. Check for a positive intake manifold pressure.
Refer to Troubleshooting Fault Code 127.

Last Modified: 11-Apr-2017


Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

FAULT CODE 131

Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P91 SPN: 091 FMI: 3 LAMP: Red SRT: 00-350 | More than 4.20 VDC detected at the accelerator pedal or lever position signal pin 29 of the OEM interface harness. | Calibration-dependent power and speed derate.
Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Circuit Description

The accelerator pedal or lever provides the operator's accelerator pedal or lever command to the ECM through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command for the fuel rail actuator valve.

Component Location

The accelerator pedal or lever location or lever varies with each OEM. Refer to the OEM manual.

Shop Talk

The accelerator pedal or lever position sensor is a potentiometer. The resistance specifications of the accelerator pedal or lever position sensor are the following:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms. Depressed = 200 to 1500 ohms.

Note: If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 01-Mar-2011


Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

FAULT CODE 132

Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P91 SPN: 091 FMI: 4 LAMP: Red SRT: 00-351 | Less than 0.13 VDC detected at the accelerator pedal or lever position signal pin 29 of the OEM interface harness ECM connector. | Calibration-dependent power and speed derate.
Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Circuit Description

The accelerator pedal or lever provides the operator's accelerator pedal or lever command to the ECM through the OEM harness and OEM interface harness. The ECM uses this signal to determine the fueling command for the fuel rail actuator valve.

Component Location

The accelerator pedal or lever location varies with each OEM. Refer to the OEM manual.

Shop Talk

The accelerator pedal or lever position sensor is a potentiometer. The resistance specifications of the accelerator pedal or lever position sensor are the following:

  • Between the supply and the return = 2000 to 3000 ohms
  • Between the supply and the signal: Released = 1500 to 3000 ohms. Depressed = 200 to 1500 ohms.

Note: If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 01-Mar-2011


Remote Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

FAULT CODE 133

Remote Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P29 SPN: 029 FMI: 3 LAMP: Red SRT: 00-385 | More than 4.82 VDC detected at the remote throttle position signal pin 30 of the OEM interface harness. | Calibration-dependent power and speed derate.
Remote Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Circuit Description

The remote accelerator pedal or lever provides the operator's accelerator pedal or lever command to the ECM through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command for the fuel rail actuator valve.

Component Location

The accelerator pedal or lever location varies with each OEM. Refer to the OEM manual.

Shop Talk

The accelerator pedal or lever position sensor is a potentiometer. The resistance specifications of the accelerator pedal or lever position sensor are the following:

  • Between supply and return = 2000 to 3000 ohms.
  • Between supply and signal: Released = 1500 to 3000 ohms; Depressed = 200 to 1500 ohms.

Note: If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Refer to Troubleshooting Fault Code t05-133

Last Modified: 01-Mar-2011


Remote Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

FAULT CODE 134

Remote Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P29 SPN: 029 FMI: 4 LAMP: Red SRT: 00-386 | Less than 0.12 VDC detected at the remote accelerator pedal or lever position signal pin 30 of the OEM interface harness. | Calibration-dependent power and speed derate.
Remote Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Circuit Description

The remote accelerator pedal or lever provides the operator's accelerator command to the ECM through the OEM harness and OEM interface harness. The ECM uses this signal to determine the fueling command for the fuel rail actuator valve.

Component Location

The accelerator pedal or lever location varies with each OEM. Refer to the OEM manual.

Shop Talk

The remote accelerator pedal or lever position sensor is a potentiometer. The resistance specifications of the remote accelerator pedal or lever position sensor are the following:

  • Between the supply and the return = 2000 to 3000 ohms
  • Between the supply and the signal: Released = 1500 to 3000 ohms. Depressed = 200 to 1500 ohms.

Note: If the accelerator pedal or lever or remote accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel 3 times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Refer to Troubleshooting Fault Code t05-134

Last Modified: 01-Mar-2011


Engine Oil Pressure Sensor Circuit

FAULT CODE 135

Engine Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Yellow SRT: 00-352 | More than 4.88-VDC detected at the engine oil pressure sensor signal pin 24 of the engine harness. | No engine protection for oil pressure. Centinel™ system is disabled.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor monitors oil pressure and passes information to the ECM through pin 24 of the engine harness. The ECM monitors the voltage on pin 24 and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation. Voltage above 4.88-VDC on pin 24 will trip Fault Code 135 and can be caused by shorts in the supply, signal, or return wires, an open circuit in the return wire, or a failed sensor.

Component Location

The engine oil pressure sensor is located on the engine block to the upper left of the ECM.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.

The following chart shows the output voltage of the engine oil pressure sensor at various pressure readings:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.00 to 1.20
172 | 25 | 50.9 | 1.33 to 1.68
345 | 50 | 101.8 | 2.17 to 2.83
517 | 75 | 152.7 | 3.09 to 3.91
689 | 100 | 203.6 | 4.10 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-135

Last Modified: 01-Mar-2011


Engine Oil Pressure Sensor Circuit

FAULT CODE 141

Engine Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: 00-353 | Less than 0.31-VDC detected at the engine oil pressure sensor signal pin 24 of the engine harness. | No engine protection for oil pressure. Centinel™ system is disabled.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor monitors oil pressure and passes information to the ECM through pin 24 of the engine harness. The ECM monitors the voltage on pin 24 and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation. Voltage below 0.31-VDC on pin 24 will trip Fault Code 141 and can be caused by shorts in the supply, signal, or return wires, an open in the supply or signal wires, low supply voltage from the ECM, or a failed sensor.

Component Location

The engine oil pressure sensor is located on the engine block to the upper left of the ECM.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not base engine related.

The following chart shows the output voltage of the engine oil pressure sensor at various pressure readings:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.00 to 1.20
172 | 25 | 50.9 | 1.33 to 1.68
345 | 50 | 101.8 | 2.17 to 2.83
517 | 75 | 152.7 | 3.09 to 3.91
689 | 100 | 203.6 | 4.10 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-141

Last Modified: 01-Mar-2011


Oil Pressure - Engine Protection

FAULT CODE 143

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1 LAMP: Engine Protection SRT: 00-354 | Low oil pressure has been detected. Voltage signal at oil pressure signal pin 24 of the engine harness indicates oil pressure lower than 103 kPa [15 psi] at 600 rpm, 131 kPa [19 psi] at 800 rpm, 165 kPa [24 psi] at 1500 rpm, and 207 kPa [30 psi] above 2100 rpm. | Calibration-dependent progressive power derate and engine shutdown with increasing time after alert. Centinel™ system is disabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, toward the front of the ECM.

Shop Talk

  • Confirm that the oil pressure sensor supply voltage is between 4.75 and 5.25-VDC at the sensor. See Fault Code 141.
  • Verify with the driver at what engine speed the fault occurs. If the engine is being operated at too low of a speed under load (lugging), the oil pressure can drop below the engine protection limits because of oil temperature.
  • Oil pressure is a function of engine speed, oil level, and regulator function. Operating the engine at a low speed under load will not cause the oil pressure to be low, unless the oil is hot, or is at a low level, the regulator has malfunctioned, or a loss is occurring somewhere in the system.

The following chart shows the output voltage of the oil pressure sensor at various pressure readings:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.00 to 1.20
172 | 25 | 50.9 | 1.33 to 1.68
345 | 50 | 101.8 | 2.17 to 2.83
517 | 75 | 152.7 | 3.09 to 3.91
689 | 100 | 203.6 | 4.10 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, see the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-143

Last Modified: 01-Mar-2011


Coolant Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Coolant Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Yellow SRT: 00-355 | Coolant Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible white smoke. No engine protection for coolant temperature. Centinel system may be disabled.
Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The engine coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

Refer to Section E for a detailed component location view.

Shop Talk

All temperature sensors:

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

The resistance of the sensor varies with temperature. The reading that you observe will compare to the table is the sensor is functioning properly.

Fault Code 144 can be caused by the following:

  • Open in the signal or return wires
  • Voltage short in the signal or return wires
  • Failed temperature sensor.
Refer to Troubleshooting Fault Code t05-144

Last Modified: 19-Aug-2010


Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Yellow SRT: 00-356 | Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible white smoke. No engine protection for coolant temperature. Centinel system may be disabled.
Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The engine coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located on the side of the thermostat housing on most applications. Refer to Section E for a detailed component location view.

Shop Talk

All temperature sensors:

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

The resistance of the sensor varies with temperature. The reading that you observe will compare to the table is the sensor is functioning properly.

Fault Code 145 can be caused by the following:

  • Open voltage line
  • Signal line shorted to ground
  • Shorted sensor.
Refer to Troubleshooting Fault Code t05-145

Last Modified: 19-Aug-2010


Frequency Accelerator Circuit

FAULT CODE 147

Frequency Accelerator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 147 PID: P91 SPN: 091 FMI: 8 LAMP: Red SRT: | A frequency of less than 100 Hz has been detected at frequency accelerator signal pin 17 of the OEM interface harness. | Calibration-dependent power and speed derate.
Frequency Accelerator Circuit

Circuit Description

The frequency accelerator provides the driver's accelerator command to the ECM through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

Accelerator location varies with each OEM. Refer to the OEM manual.

Shop Talk

The frequency accelerator can either be used in conjunction with a voltage accelerator or by itself.

Refer to Troubleshooting Fault Code t05-147

Last Modified: 19-Aug-2010


Frequency Accelerator Circuit

FAULT CODE 148

Frequency Accelerator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 148 PID: P91 SPN: 091 FMI: 8 LAMP: Red SRT: | A frequency of more than 1500 Hz has been detected at the frequency accelerator signal pin 17 of the OEM interface harness. | Calibration-dependent power and speed derate.
Frequency Accelerator Circuit

Circuit Description

The frequency accelerator provides the driver's accelerator command to the ECM through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

Accelerator location varies with each OEM. Refer to the OEM manual.

Shop Talk

The frequency accelerator can be used either in conjunction with a voltage accelerator or by itself.

Refer to Troubleshooting Fault Code t05-148

Last Modified: 01-Mar-2011


Coolant Temperature - Engine Protection

FAULT CODE 151

Coolant Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Engine Protection SRT: 00-357 | High coolant temperature has been detected. Voltage signal at coolant temperature signal pin 22 indicates the coolant temperature is above 100°C [212°F]. | Calibration-dependent progressive power and speed derate and engine shutdown as temperature increases over thresholds. Centinel™ system is disabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on pin 22. The ECM expects to see the voltage vary between 0.21 and 4.95 VDC. If the voltage is below 0.21 VDC for more than 2 seconds, then the ECM will log Fault Code 151. Voltage below 0.21 VDC on pin 22 can be caused by a cooling system failure or an in-range sensor failure.

Component Location

QSK19 series engines - The coolant temperature sensor is located on the side of the thermostat housing on most applications.

Shop Talk

  • Make sure the airflow through the radiator is not obstructed.
  • The resistance of all the temperature sensors varies with the temperature. The reading that you observe could possibly compare to the following table if the sensor is functioning properly.

Temperature(°C) | Temperature[°F] | Resistance(ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-151

Last Modified: 01-Mar-2011


Intake Manifold Temperature Sensor Circuit

FAULT CODE 153

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Yellow SRT: 00-358 | More than 4.88 VDC detected at the intake manifold temperature sensor signal pin 23 of the engine harness ECM connector. | No engine protection for the intake manifold air temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on pin 23. The ECM expects to see the voltage vary between 0.5 and 4.88 VDC. If the voltage is above 4.88 VDC, the ECM will log Fault Code 153. Voltage above 4.88 VDC on pin 23 can be caused by openings in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

QSK19 series engines - The intake manifold temperature sensor is located above the fuel pump, next to the intake manifold pressure sensor.

Shop Talk

  • The resistance of all the temperature sensors varies with the temperature. The reading that you observe could possibly compare to the following table if the sensor is functioning properly.

Temperature(°C) | Temperature[°F] | Resistance(ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153

Last Modified: 01-Mar-2011


Intake Manifold Temperature Sensor Circuit

FAULT CODE 154

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Yellow SRT: 00-359 | Less than 0.08 VDC detected at the intake manifold air temperature signal pin 23 of the engine harness. | No engine protection for the intake manifold air temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold downstream of the aftercooler element. The intake manifold temperature sensor is used by the ECM for the engine protection system and timing and fueling control. The ECM monitors the voltage on pin 23. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC. If the voltage is below 0.08 VDC, then the ECM will log Fault Code 154. Voltage below 0.08 VDC on pin 23 can be caused by shorts to ground on the supply or return wires, or an internally grounded, failed sensor.

Component Location

QSK19 series engines - The intake manifold temperature sensor is located above the fuel pump, next to the intake manifold pressure sensor.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the temperature. The reading that you observe could possibly compare to the following table if the sensor is functioning properly.

Temperature(°C) | Temperature[°F] | Resistance(ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154

Last Modified: 01-Mar-2011


Intake Manifold Temperature Sensor - Engine Protection

FAULT CODE 155

Intake Manifold Temperature Sensor - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Engine Protection SRT: 00-360 | High intake air manifold temperature has been detected. Voltage signal at intake manifold air temperature signal pin 23 indicates intake manifold air temperature above 104°C [219°F]. | Calibration-dependent progressive power and speed derate and engine shutdown as the temperature increases over thresholds.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on pin 23. The ECM expects to see the voltage vary between 0.5 and 4.5-VDC. If the voltage is below 0.5-VDC, the ECM will log Fault Code 155. Voltage below 0.5-VDC on pin 23 can be caused by a cooling system malfunction or an in-range sensor malfunction.

Component Location

QSK19 series engines - The intake manifold temperature sensor is located above the fuel pump, next to the intake manifold pressure sensor.

Shop Talk

The following chart shows resistance of the intake manifold temperature sensor at various temperature readings.

Temperature(°C) | Temperature[°F] | Resistance(ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 155.

Last Modified: 01-Aug-2010


Make-Up Tank Oil Level Low Fault

FAULT CODE 219

Make-Up Tank Oil Level Low Fault

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 219 PID: S153 SPN: 1380 FMI: 1 LAMP: Engine Protection SRT: | Low oil level detected in the remote oil reservoir used in the Centinel™ system. | Centinel™ system is disabled.
Make-up Tank Oil Level Low Sensor

Circuit Description

The make-up tank oil level low sensor monitors the oil level in the make-up oil tank and reports to the ECM when the oil drops below the specified level.

Component Location

The make-up tank oil level low sensor is located on the lower portion of the Centinel™ system make-up oil tank.

Shop Talk

Verify that the make-up tank has the appropriate level of oil.

Refer to Troubleshooting Fault Code t05-219

Last Modified: 01-Mar-2011


Ambient Air Pressure Sensor Circuit

FAULT CODE 221

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3 LAMP: Yellow SRT: 00-361 | More than 4.78-VDC detected at the ambient air pressure sensor signal pin 34 of the engine harness. | Derate in power output of the engine.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor provides the ambient air pressure signal to the ECM through the engine harness. The ECM uses the ambient air pressure sensor to adjust fueling based on the altitude.

Component Location

The ambient air pressure sensor is located below the ECM on the control valve body.

Shop Talk

  • Monitor the ambient air pressure reading with an electronic service tool to confirm that the pressure reading matches the actual air pressure.

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.32 to 0.69
34.47 | 5 | 10.18 | 1.58 to 2.09
68.95 | 10 | 20.36 | 2.89 to 3.45
103.42 | 15 | 30.54 | 4.12 to 4.85
Refer to Troubleshooting Fault Code t05-221

Last Modified: 01-Mar-2011


Ambient Air Pressure Sensor Circuit

FAULT CODE 222

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4 LAMP: Yellow SRT: 00-362 | Less than 0.20-VDC detected at the ambient air pressure sensor signal pin 34 of the engine harness. | Derate in power output of the engine.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor provides the ambient air pressure signal to the ECM through the engine harness. The ECM uses the ambient air pressure sensor to adjust fueling based on the altitude.

Component Location

The ambient air pressure sensor is located below the ECM on the control valve body.

Shop Talk

  • Monitor the ambient air pressure reading with an electronic service tool to confirm that the pressure reading matches the actual air pressure.

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.32 to 0.69
34.47 | 5 | 10.18 | 1.58 to 2.09
68.95 | 10 | 20.36 | 2.89 to 3.45
103.42 | 15 | 30.54 | 4.12 to 4.85
Refer to Troubleshooting Fault Code t05-222

Last Modified: 01-Mar-2011


Burn Valve Solenoid Circuit

FAULT CODE 223

Burn Valve Solenoid Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S85 SPN: 1265 FMI: 4 LAMP: Yellow SRT: | The Centinel™ burn valve solenoid circuit is open or shorted. Less than 18.0 VDC detected at the Centinel™ burn valve solenoid supply pin 8 of the OEM interface harness or resistance of the solenoid has dropped below 80 ohms. | ECM turns off the burn valve supply voltage and the Centinel™ system is disabled.
Burn Valve Solenoid Circuit

Circuit Description

The burn valve solenoid controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The burn valve solenoid is located on top of the oil control valve.

Refer to Troubleshooting Fault Code t05-223

Last Modified: 01-Mar-2011


Make-Up Valve Solenoid Circuit

FAULT CODE 225

Make-Up Valve Solenoid Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 225 PID: S85 SPN: 1266 FMI: 4 LAMP: Yellow SRT: | The Centinel™ make-up valve solenoid circuit is open or shorted. Less than 18.0 VDC detected at Centinel™ make-up valve solenoid supply pin 2 of the engine harness or resistance of the solenoid has dropped below 80 ohms. | ECM turns off the Centinel™ make-up valve supply voltage and the Centinel™ system is disabled.
Make-Up Valve Solenoid Circuit

Circuit Description

The make-up valve solenoid controls the flow of oil within the oil control valve during the make-up cycle.

Component Location

The make-up valve solenoid is located on top of the oil control valve.

Refer to Troubleshooting Fault Code t05-225

Last Modified: 01-Mar-2011


Coolant Pressure Sensor Circuit

FAULT CODE 231

Coolant Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: P109 SPN: 109 FMI: 3 LAMP: Yellow SRT: 00-387 | More than 4.72-VDC detected at the coolant pressure sensor signal pin 16 of the engine harness. | No engine protection for coolant pressure.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor monitors coolant pressure and passes information to the ECM through pin 16 of the engine harness. The ECM monitors the voltage on pin 16 and expects to see the voltage vary between 0.5 and 4.5-VDC during normal operation. Voltage above 4.72-VDC on pin 16 will trip Fault Code 231 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

The coolant pressure sensor is located on the exhaust side of the engine, below the oil cooler.

Shop Talk

  • Confirm the radiator cap is installed correctly.
  • Check the radiator cap for proper operation.

The following chart shows the output voltage of the coolant pressure sensor at various pressure readings:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.23 to 1.40
207 | 30 | 61.08 | 1.97 to 2.27
310 | 45 | 91.62 | 2.71 to 3.16
414 | 60 | 122.16 | 3.45 to 4.04
517 | 75 | 152.7 | 4.20 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in the fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-231

Last Modified: 01-Mar-2011


Coolant Pressure Sensor Circuit

FAULT CODE 232

Coolant Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: P109 SPN: 109 FMI: 4 LAMP: Yellow SRT: 00-388 | Less than 0.33-VDC detected at the coolant pressure sensor signal pin 16 of the engine harness. | No engine protection for coolant pressure.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor monitors coolant pressure and passes information to the ECM through pin 16 of the engine harness. The ECM monitors the voltage on pin 16 and expects to see voltage vary between 0.5 and 4.5 VDC during normal operation. Voltage below 0.33-VDC on pin 16 will trip Fault Code 232 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

The coolant pressure sensor is located on the exhaust side of the engine, below the oil cooler.

Shop Talk

  • Confirm the radiator cap is installed correctly.
  • Check the radiator cap for proper operation.

The following chart shows the output voltage of the coolant pressure sensor at various pressure readings:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.23 to 1.40
207 | 30 | 61.08 | 1.97 to 2.27
310 | 45 | 91.62 | 2.71 to 3.16
414 | 60 | 122.16 | 3.45 to 4.04
517 | 75 | 152.7 | 4.20 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in the fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-232

Last Modified: 01-Mar-2011


Coolant Pressure - Engine Protection

FAULT CODE 233

Coolant Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 233 PID: P109 SPN: 109 FMI: 1 LAMP: Engine Protection SRT: 00-389 | Low coolant pressure has been detected. Voltage signal at coolant pressure signal pin 16 of the engine harness indicates coolant pressure lower than 28 kPa [4 psi] at 800 rpm, 41 kPa [6 psi] at 1300 rpm, 76 kPa [11 psi] at 1800 rpm, 96 kPa [14 psi] at 2000 rpm, and 103 kPa [15 psi] above 2100 rpm. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the ECM to monitor the coolant pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The coolant pressure value is used by the ECM for the engine protection system.

Component Location

The coolant pressure sensor is located on the exhaust side of the engine, below the oil cooler.

Shop Talk

  • Confirm that the coolant pressure sensor supply voltage is between 4.75 and 5.25 VDC at the sensor. Refer to Fault Code 232.
  • Verify with the driver at what engine speed the fault occurs. If the engine is being operated at too low a speed under load, the coolant pressure can drop below the engine protection limits.

The following chart shows the output voltage of the coolant pressure sensor at various pressure readings:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.23 to 1.40
207 | 30 | 61.08 | 1.97 to 2.27
310 | 45 | 91.62 | 2.71 to 3.16
414 | 60 | 122.16 | 3.45 to 4.04
517 | 75 | 152.7 | 4.20 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-233

Last Modified: 01-Mar-2011


Engine Overspeed

FAULT CODE 234

Engine Overspeed

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0 LAMP: Red SRT: 00-363 | Engine speed signal on pin 27 and pin 28 and/or pin 37 and pin 38 of the engine harness indicates an engine speed greater than the safe operation rpm limit. The limit is 2450 rpm for the QSK19 and 2190 rpm for the QSK60. | Fuel shutoff valve de-energizes (valve closes). The valve reenergizes (fuel shutoff valve opens) when engine speed falls below its upper rpm threshold.
Engine Overspeed

Circuit Description

The engine position sensor monitors the engine position and the engine speed. It then passes this information to the ECM through the engine harness.

Component Location

The engine position sensor is located above the accessory drive.

Shop Talk

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks.

  • Inspect the engine position sensor for signs of damage or tampering.
Refer to Troubleshooting Fault Code t05-234

Last Modified: 01-Mar-2011


Engine Coolant Level - Engine Protection

FAULT CODE 235

Engine Coolant Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1 LAMP: Engine Protection SRT: 00-364 | Low coolant level has been detected. Voltage signal on the coolant level signal pin 23 of the OEM harness indicates low radiator coolant level on the vehicle. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
Engine Coolant Level - Engine Protection

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the ECM through the OEM harness.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and will vary in sensor location.

  • When the coolant level drops below a certain level, a power derate will be activated, which will decrease the power output by 50 percent over a 30-second period.
  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the four-way Weather-Pack connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank, rather than off to one side where the coolant level can change when the vehicle turns a corner.
Refer to Troubleshooting Fault Code t05-235

Last Modified: 01-Mar-2011


Engine Cold Start Aid - Condition Exists

FAULT CODE 2364

Engine Cold Start Aid - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2364 PID: SPN: 854 FMI: 11/31 LAMP: Red SRT: | An open or short circuit has been detected on the ether injection circuit. | Ether start functionality will be disabled. Engine may not start or may be difficult to start.
Ether Injection Start Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation. The ether injection circuit utilizes a Pulse Width Modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit pulse width modulated (PWM) signal voltage was greater than 0-VDC when the PWM signal was turned OFF by the ECM.

The ether injection circuit pulse width modulated (PWM) signal was not at system voltage when the PWM signal was turned ON.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open signal or return circuit in the solenoid or harness.
  • Signal circuit shorted to voltage source.
  • Short circuit to ground in the harness or solenoid.
Refer to Troubleshooting Fault Code t05-384

Last Modified: 27-Jan-2020


Multiple-Unit Synchronization

FAULT CODE 237

Multiple-Unit Synchronization

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 237 PID: S30 SPN: 644 FMI: 2 LAMP: Yellow SRT: 00-395 | Duty cycle of input throttle signal pin 17 of the OEM interface harness is less than 3 percent or more than 97 percent. | The primary engine and secondary engines are shut down with increasing time after alert if hard-coupled. Only the secondary engines are shut down with increasing time after alert if soft-coupled.
Multiple-Unit Synchronization Circuits: Soft-Coupled, Hard-Coupled, and Soft-Coupled Marine

Circuit Description

The primary engine outputs a throttle duty cycle signal on pin 24. This signal is received by the secondary engine(s) and is used as the throttle input. To complete this circuit, a +5-VDC supply is provided by the OEM and connected to pin 18 of the secondary engine.

Component Location

The PWM output supply is located in the OEM interface harness.

Shop Talk

The secondary engine expects to see a duty cycle signal that varies between 3 and 97 percent. A signal less than 3 percent or greater than 97 percent will generate Fault Code 237 in the secondary engine.

Refer to Troubleshooting Fault Code t05-237

Last Modified: 01-Mar-2011


Oil Level Sensor Circuit

FAULT CODE 252

Oil Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 252 PID: P98 SPN: 098 FMI: 2 LAMP: Yellow SRT: | Oil level sensor error. | No engine protection for low oil level. Centinel™ system is disabled.
Oil Level Sensor Circuit

Circuit Description

The lubricating oil level sensor is used by the ECM to monitor the amount of oil in the engine. Low oil level detected at pin 12 can cause the engine protection system to derate and shut down the engine.

Component Location

The lubricating oil level sensor is in the engine oil pan.

Refer to Troubleshooting Fault Code t05-252

Last Modified: 01-Mar-2011


Oil Level - Engine Protection

FAULT CODE 253

Oil Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 253 PID: P98 SPN: 098 FMI: 1 LAMP: Engine Protection SRT: | Low oil level has been detected. Voltage signal on the oil level signal pin 12 of the engine harness indicates low oil level in the engine. | Calibration-dependent progressive power derate and engine shutdown with increasing time after alert.
Oil Level Sensor

Circuit Description

The oil level sensor is used by the ECM to monitor the amount of oil in the engine. Low oil level detected at pin 12 can cause the engine not to start.

Component Location

The oil level sensor is located in the oil pan on the left side of the engine.

Refer to Troubleshooting Fault Code t05-253

Last Modified: 01-Mar-2011


Fuel Shutoff Solenoid Supply Circuit

FAULT CODE 254

Fuel Shutoff Solenoid Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4 LAMP: None SRT: 00-365 | The fuel shutoff valve solenoid circuit is open or shorted. Less than 6.0 VDC detected at fuel shutoff valve solenoid supply pin 30 of the engine harness or resistance of the solenoid has dropped below 20 ohms. | Engine control module (ECM) turns off fuel shutoff valve supply voltages. The engine dies.
QSK19, QSK45, and QSK78 - Fuel Shutoff Solenoid Circuit
QSK23 - Fuel Shutoff Solenoid Circuit

Circuit Description

The fuel shutoff solenoid is a device used by the ECM to control the fuel supply to the rail fueling circuit. The ECM can shut down the engine by cutting off the power to the fuel shutoff solenoid.

Component Location

The fuel shutoff solenoid is located between the rail and timing actuators on the control valve body behind the ECM.

Shop Talk

  • The fuel shutoff solenoid only stops fuel to the rail circuit; the timing circuit bypasses the fuel shutoff solenoid.
  • Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit.
  • If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not malfunctioned and lowered the voltage on the fuel shutoff circuit.
  • Inspect the engine block-to-chassis ground wire to make sure it is securely fastened to a clean, dry surface.
  • Check the starter solenoid positive (+) terminal for a loose connector and/or accessory wiring with damaged insulation.
  • The engine will have to be cranked before any voltage is present at the fuel shutoff valve terminals. Once the ECM has received the 50-rpm signal, the voltage will remain supplied to the fuel shutoff valve until the keyswitch is cycled to the OFF position.

Note: This calibration feature is in effect for only QSK19 engines manufactured after September 1999, but is included for all QSK23, QSK45, QSK60, and QSK78 engines.

Refer to Troubleshooting Fault Code t05-254

Last Modified: 02-Jan-2017


Fuel Shutoff Valve Stuck Open

FAULT CODE 259

Fuel Shutoff Valve Stuck Open

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 259 PID: S17 SPN: 632 FMI: 7 LAMP: Red SRT: 00-396 | Fuel shutoff valve is open and will not close. | No action by the engine control module (ECM) is taken.
QSK19, QSK45, and QSK78 - Fuel Shutoff Solenoid Circuit
QSK23 - Fuel Shutoff Solenoid Circuit

Circuit Description

The fuel shutoff solenoid is a device used by the ECM to control the fuel supply to the rail fueling circuit. The ECM can shut down the engine by cutting off the power to the fuel shutoff solenoid.

Component Location

The fuel shutoff solenoid is located between the rail and timing actuators on the control valve body behind the ECM.

Shop Talk

  • The fuel shutoff solenoid only stops fuel to the rail circuit; the timing circuit bypasses the fuel shutoff solenoid.
  • Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit.
  • If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and lowered the voltage on the fuel shutoff circuit.
  • Inspect the engine block-to-chassis ground wire to make sure it is securely fastened to a clean, dry surface.
  • Check the starter solenoid positive (+) terminal for a loose connector and/or accessory wiring with damaged insulation.
Refer to Troubleshooting Fault Code t05-259

Last Modified: 02-Jan-2017


Fuel Temperature - Engine Protection

FAULT CODE 261

Fuel Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: P174 SPN: 174 FMI: 0 LAMP: Engine Protection SRT: 00-397 | High fuel temperature has been detected. Voltage signal at fuel temperature signal pin 26 of engine harness indicates fuel temperature above 71°C [160°F]. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the ECM to monitor the temperature of the fuel. The ECM monitors the voltage on pin 26 and converts this voltage to a temperature value. The fuel temperature value is used by the ECM for the engine protection system.

Component Location

QSK19 Series engines - The fuel temperature sensor is located on the left side of the control valve body, above the fuel shutoff valve. QSK45 and QSK60 Series engines - The fuel temperature sensor is located on the right side of the electronic control valve assembly between the rail and timing pressure sensors. QSK78 Series engines - The fuel temperature sensor is located on the right side of the electronic control valve assembly between the rail and timing pressure sensors.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the temperature. The reading that you observe could possibly compare to the following table if the sensor is functioning properly.

Temperature(°C) | Temperature[°F] | Resistance(ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-261

Last Modified: 01-Mar-2011


Fuel Temperature Sensor Circuit (QSK45, QSK60, and QSK78 Only)

FAULT CODE 263

Fuel Temperature Sensor Circuit (QSK45, QSK60, and QSK78 Only)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3 LAMP: Yellow SRT: 00-398 | More than 4.95 VDC detected at the fuel temperature signal pin 26 of the engine harness. | No engine protection for fuel temperature.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the ECM to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on pin 26. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC. If the voltage is above 4.95 VDC, then the ECM will log Fault Code 263. Voltage above 4.95 VDC on pin 26 can be caused by an open in the signal or return wires, or voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

QSK19 series engines - The fuel temperature sensor is located on the left side of the control valve body, above the fuel shutoff valve.

QSK45 and QSK60 series engines - The fuel temperature sensor is located on the right side of the electronic control valve assembly between the rail and timing pressure sensors.

QSK78 series engines - The fuel temperature sensor is located on the right side of the electronic control valve assembly between the rail and timing pressure sensors.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the temperature. The reading that you observe could possibly compare to the following table if the sensor is functioning properly.

Temperature(°C) | Temperature[°F] | Resistance(ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-263

Last Modified: 01-Mar-2011


Fuel Temperature Sensor Circuit (QSK45, QSK60, and QSK78 only)

FAULT CODE 265

Fuel Temperature Sensor Circuit (QSK45, QSK60, and QSK78 only)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4 LAMP: Yellow SRT: 00-399 | Less than 0.21 VDC detected at the fuel temperature signal pin 26 of the engine harness. | No engine protection for fuel temperature.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the ECM to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on pin 26. The ECM expects to see the voltage vary between 0.5 and 4.5 VDC. If the voltage is below 0.21 VDC, then the ECM will log Fault Code 265. Voltage below 0.21 VDC on pin 26 can be caused by shorts to ground on the supply or return wires or an internally grounded, failed sensor.

Component Location

QSK19 series engines - The fuel temperature sensor is located on the left side of the control valve body, above the fuel shutoff valve.

QSK45 and QSK60 series engines - The fuel temperature sensor is located on the right side of the electronic control valve assembly between the rail and timing pressure sensors.

QSK78 series engines - The fuel temperature sensor is located on the right side of the electronic control valve assembly between the rail and timing pressure sensors.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the temperature. The reading that you observe could possibly compare to the following table if the sensor is functioning properly.

Temperature(°C) | Temperature[°F] | Resistance(ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-265

Last Modified: 01-Mar-2011


OEM Temperature - Engine Protection

FAULT CODE 292

OEM Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 292 PID: P223 SPN: 1083 FMI: 14 LAMP: Engine Protection SRT: | OEM temperature out-of-range has been detected. Voltage signal at OEM temperature signal pin 27 indicates OEM temperature beyond the OEM-specified threshold. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
OEM Temperature Circuit

Circuit Description

The OEM resistive signal is used by the ECM to monitor an OEM temperature. The OEM temperature is used by the ECM for the engine protection system.

Component Location

The location varies with the OEM. Refer to the OEM manual.

Shop Talk

The resistance of all temperature sensors varies with the ambient temperature.

Refer to Troubleshooting Fault Code t05-292

Last Modified: 01-Mar-2011


OEM Temperature Sensor Circuit

FAULT CODE 293

OEM Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 293 PID: P223 SPN: 1083 FMI: 3 LAMP: Yellow SRT: | VDC detected at the OEM temperature sensor signal pin 27 of the OEM interface harness indicates the sensor has failed high. | No engine protection for OEM temperature.
OEM Temperature Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM temperature. The OEM temperature is used by the ECM for the engine protection system. A sensor that has failed high can be caused by opens in the signal or return wire, voltage shorts in the signal or return wire, or a faulty sensor.

Component Location

The location varies with the OEM. Refer to the OEM manual.

Shop Talk

The resistance of all temperature sensors varies with the ambient temperature.

Refer to Troubleshooting Fault Code t05-293

Last Modified: 01-Mar-2011


OEM Temperature Sensor Circuit

FAULT CODE 294

OEM Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 294 PID: P223 SPN: 1083 FMI: 4 LAMP: Yellow SRT: | VDC detected at the OEM temperature sensor signal pin 27 of the OEM interface harness indicates the sensor has failed low. | No engine protection for OEM temperature.
OEM Temperature Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM temperature. The OEM temperature is used by the ECM for the engine protection system. A sensor that has failed low can be caused by shorts to ground on the supply and return wires, or an internally grounded (faulty) sensor.

Component Location

The location varies with the OEM. Refer to the OEM manual.

Shop Talk

The resistance of all temperature sensors varies with the temperature. Check the temperature thresholds using INSITE™ for QSK Series engines.

Refer to Troubleshooting Fault Code t05-294

Last Modified: 01-Mar-2011


OEM Pressure - Engine Protection

FAULT CODE 296

OEM Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 296 PID: P223 SPN: 1084 FMI: 14 LAMP: Engine Protection SRT: | OEM Pressure - Engine Protection - OEM pressure out-of-range has been detected. Voltage signal at OEM pressure signal pin 15 indicates OEM pressure beyond OEM-specified threshold. | OEM and calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
OEM Pressure Circuit

Circuit Description

The OEM pressure sensor monitors a pressure based on the application needs. OEM pressure readings are sent through pin 15 of the OEM interface harness to the ECM (electronic control module). The ECM expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation.

Component Location

The location varies with OEM. Refer to the OEM service manual.

Shop Talk

If Fault Code 296 occurs during cold weather, allow the OEM fluid to warm up to operating temperature, turn the engine OFF, and restart. If the fault code remains active, troubleshoot the fault code.

Refer to Troubleshooting Fault Code 296.

Last Modified: 25-Aug-2010


OEM Pressure Sensor Circuit

FAULT CODE 297

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 297 PID: P223 SPN: 1084 FMI: 3 LAMP: Yellow SRT: | VDC detected at the OEM pressure sensor signal pin 15 of the OEM interface harness indicates the sensor has failed high. | No engine protection for OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM pressure. The OEM pressure is used by the ECM for the engine protection system. A sensor that has failed high can be caused by an open circuit in the signal or return wire, voltage shorts in the signal or return wire, or a faulty sensor.

Component Location

The location varies with the OEM. Refer to the OEM manual.

Shop Talk

The sensor voltage signal is the responsibility of the OEM. Refer to the OEM manual for specifications.

Refer to Troubleshooting Fault Code t05-297

Last Modified: 01-Mar-2011


OEM Pressure Sensor Circuit

FAULT CODE 298

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 298 PID: P223 SPN: 1084 FMI: 4 LAMP: Yellow SRT: | VDC detected at the OEM pressure sensor signal pin 15 of the OEM interface harness indicates the sensor has failed low. | No engine protection for OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM sensor signal is used by the ECM to monitor the OEM pressure. The OEM pressure is used by the ECM for the engine protection system. A sensor that has failed low can be caused by short circuits to ground on the signal wire or by an internally grounded (faulty) sensor.

Component Location

The location varies with the OEM. Refer to the OEM manual.

Shop Talk

The resistance of all pressure sensors varies with the pressure. Refer to the OEM manual for specifications.

Refer to Troubleshooting Fault Code t05-298

Last Modified: 01-Mar-2011


Non-Keyswitch Hot Shutdown

FAULT CODE 299

Non-Keyswitch Hot Shutdown

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 299 PID: FMI: LAMP: None SRT: | The engine was shut down by a device other than the keyswitch before proper engine cooldown, resulting in a load factor above the maximum shutdown threshold. Fault Code 299 will be logged if the engine is shut down while hot by the engine protection feature or other OEM devices. | No action is taken by the ECM.

Circuit Description

nonapplicable for this fault code

Component Location

nonapplicable for this fault code

Last Modified: 01-Mar-2011


Fuel Pump Actuator Circuit

FAULT CODE 316

Fuel Pump Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 316 PID: S78 SPN: 931 FMI: 3 LAMP: Yellow SRT: 00-670 | Fuel pump actuator circuit is open, or supply pin 11 is shorted to battery voltage or ground, or return pin 40 is shorted to battery voltage or ground in the engine harness. | No action by the ECM is taken. Actuator is open or closed, or partially closed.
Fuel Pump Actuator Circuit

Circuit Description

The fuel pump actuator circuit supplies current to the fuel pump actuator. The ECM commands a varying amount of current to the fuel pump actuator to control the fuel pump output pressure to the control valve assembly.

Component Location

The fuel pump actuator is located on the fuel pump.

Shop Talk

  • Confirm that the actuator connector is firmly in place.
  • When there is no power to the actuator, the actuator closes and fuel flow continues.
Refer to Troubleshooting Fault Code t05-316

Last Modified: 01-Mar-2011


Fuel Pump Fueling Flow Mismatch

FAULT CODE 318

Fuel Pump Fueling Flow Mismatch

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 318 PID: S78 SPN: 931 FMI: 7 LAMP: Yellow SRT: 00-671 | The error between estimated fuel pump pressure and desired fuel pump pressure is outside acceptable limits. | No action is taken by the ECM.
Fuel Flow Signal Circuit - QSK19 Industrial
Fuel Flow Signal Circuit - QSK23 Industrial
Fuel Flow Signal Circuit - QSK23 Generator Drive
Fuel Flow Signal Circuit - QSK45 and QSK60
Fuel Flow Signal Circuit - QSK60
Fuel Flow Signal Circuit - QSK78

Circuit Description

The electronic control module (ECM) uses the fuel pump pressure signal and engine speed to estimate the actual fueling the engine is receiving, and then constantly compares this value to the desired fueling for the given speed and load. When there is too large an error in these values for too long a time, Fault Code 318 is logged.

Component Location

The fuel pump actuator is located on the fuel pump.

Shop Talk

This fault is a check on the ECM's control of the fuel pump actuator and subsequent fuel flow. If the desired fueling can not be met by commanding more current to the actuator, or if the desired fueling is being exceeded and can not be reduced by reducing the current to the actuator, then Fault Code 318 is logged. Fault Code 318 is not logged for the following:

  • The coolant temperature is below 0°C [32°F].
Refer to Troubleshooting Fault Code t05-318

Last Modified: 01-Mar-2011


Electronic Control Module (ECM) Internal Communication Error

FAULT CODE 343

Electronic Control Module (ECM) Internal Communication Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12 LAMP: Yellow SRT: 00-341 | Microprocessor communication error internal to the ECM. | Variable; performance will or will not be affected.
Electronic Control Module

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the control valve body on the left side of the engine.

Shop Talk

  • This is a fault with the internal circuitry of the ECM. There are no repairs possible for the module in the field.
Refer to Troubleshooting Fault Code t05-343

Last Modified: 01-Mar-2011


Electronic Control Module (ECM) Powerdown Error

FAULT CODE 346

Electronic Control Module (ECM) Powerdown Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12 LAMP: Yellow SRT: 00-366 | ECM powerdown internal data store error. | Powerdown data are lost. Powerdown data include maintenance monitoring, present ECM and engine delta times, and past fault data.
Battery Power and Ground Circuit

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the control valve body on the left side of the engine.

Shop Talk

  • This is a fault with the internal memory of the ECM. This fault can be caused by a power interruption to the ECM or a total loss of battery power.
  • Fault Code 346 can be caused by not following the correct engine shutdown procedure. If a master disconnect switch is being used, you must turn the keyswitch OFF, wait 30 seconds, then disconnect the batteries using the master disconnect switch. If the operator does not wait 30 seconds before disconnecting the batteries, Fault Code 346 will be logged.
  • If Fault Code 346 is active, turn the keyswitch ON, then turn it to OFF and wait 30 seconds. Repeat this step three times with a 30-second delay between each key cycle.
Refer to Troubleshooting Fault Code t05-346

Last Modified: 01-Mar-2011


Frequency Accelerator Circuit

FAULT CODE 349

Frequency Accelerator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 349 PID: P91 SPN: 191 FMI: 0 LAMP: Yellow SRT: | A frequency of greater than a calibrated threshold has been detected at frequency accelerator signal pin 17 of the OEM interface harness. | Calibration-dependent power and speed derate.
Frequency Accelerator Circuit

Circuit Description

The frequency accelerator provides the driver's accelerator command to the ECM through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

Accelerator location varies with each OEM. Refer to the OEM manual.

Shop Talk

The frequency accelerator can be used either in conjunction with a voltage accelerator or by itself.

Refer to Troubleshooting Fault Code t05-349

Last Modified: 01-Mar-2011


Ether Injection Circuit

FAULT CODE 384

Ether Injection Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 384 PID: S237 SPN: 626 FMI: 11 LAMP: Yellow SRT: 00-365 | The ether injection solenoid circuit is open or shorted at pin 2 of the engine harness. | Ether injection feature is disabled.
Ether Injection Solenoid Circuit

Circuit Description

The ether injection solenoid is a device used by the ECM to control the ether injection system during cold starts.

Component Location

The ether injection solenoid location is dependent on the OEM. Refer to the OEM manual.

Refer to Troubleshooting Fault Code t05-384

Last Modified: 01-Mar-2011


Oil Pressure - Engine Protection

FAULT CODE 415

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Engine Protection SRT: 00-367 | Very low oil pressure has been detected. Voltage signal at oil pressure signal pin 24 of the engine harness indicates oil pressure lower than 83 kPa [12 psi] at 600 rpm, 110 kPa [16 psi] at 800 rpm, 138 kPa [20 psi] at 1500 rpm, and 172 kPa [25 psi] above 2100 rpm. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after the alert.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, toward the front of the ECM.

Shop Talk

  • Confirm that the oil pressure sensor supply voltage is between 4.75 and 5.25-VDC at the sensor. See Fault Code 141.
  • Verify with the driver at what engine speed the fault occurs. If the engine is being operated at too low a speed under load (lugging), the oil pressure can drop below the engine protection limits because of the oil temperature.
  • Oil pressure is a function of the engine speed, oil level, and regulator function. Operating the engine at a low speed under load will not cause the oil pressure to be low, unless the oil is hot or at a low level, the regulator has malfunctioned, or a loss is occurring somewhere in the system.

The following chart shows the output voltage of the oil pressure sensor at various pressure readings:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.22 to 0.80
103 | 15 | 30.54 | 1.00 to 1.20
172 | 25 | 50.9 | 1.33 to 1.68
345 | 50 | 101.8 | 2.17 to 2.83
517 | 75 | 152.7 | 3.09 to 3.91
689 | 100 | 203.6 | 4.10 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, see the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-415

Last Modified: 01-Mar-2011


Coolant Level Sensor Circuit

FAULT CODE 422

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2 LAMP: Yellow SRT: 00-368 | Voltage detected simultaneously on both the coolant level high and low signal pins 14 and 23 of the OEM interface harness, or no voltage detected on either pin. | No engine protection for coolant level.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the ECM through the OEM harness.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and will vary in sensor location.

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the Weather-Pack four-way connector and the coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle makes a turn.

There is an optional configuration of the coolant level sensor circuit that includes a water-in-fuel sensor. This optional configuration is illustrated above.

Refer to Troubleshooting Fault Code t05-422

Last Modified: 01-Mar-2011


Timing Pressure Sensor In-Range Error

FAULT CODE 423

Timing Pressure Sensor In-Range Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 423 PID: P156 SPN: 156 FMI: 2 LAMP: Yellow SRT: 00-369 | More than 1.83 VDC detected at the timing pressure signal pin 33 of the engine harness at engine key on. | Calibration-dependent power and speed derate.
Timing Pressure Sensor Circuit

Circuit Description

The timing pressure sensor provides a signal to the ECM through the engine harness. The ECM uses the timing pressure sensor signal to monitor the amount of fuel going to the injector's timing chamber from the control valve body.

Component Location

The timing pressure sensor is located on the upper right side of the control valve body.

Shop Talk

The following charts show the output voltage of the timing rail pressure sensor at various pressure readings.

Pressure Sensor Output Voltage:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
0 | 0 | 0 | 0.48 to 0.53
103.42 | 15 | 30.54 | 0.63 to 0.67
345 | 50 | 101.8 | 0.98 to 1.13
1034 | 150 | 305.4 | 1.98 to 2.33
1724 | 250 | 509 | 2.97 to 3.55
2585 | 375 | 763.5 | 4.18 to 4.92

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-423

Last Modified: 18-Aug-2010


J1939 Datalink No Communication

FAULT CODE 426

J1939 Datalink No Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: SPN: FMI: LAMP: Yellow SRT: | ECM can not transmit on J1939 datalink. | No action is taken by ECM.

Circuit Description

nonapplicable for this fault code

Component Location

nonapplicable for this fault code

Last Modified: 01-Mar-2011


J1939 Datalink Slow Communication

FAULT CODE 427

J1939 Datalink Slow Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: SPN: FMI: LAMP: Yellow SRT: | ECM can not transmit on J1939 datalink at acceptable rate. | No action is taken by ECM.

Circuit Description

nonapplicable for this fault code

Component Location

nonapplicable for this fault code

Last Modified: 01-Mar-2011


Idle Validation Circuit

FAULT CODE 431

Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: P91 SPN: 091 FMI: 2 LAMP: Yellow SRT: 00-370 | Voltage detected simultaneously on both the idle validation off-idle and idle signal pins 12 and 13 of the OEM harness, or no voltage detected on either pin. | None on performance.
Idle Validation Circuit

Circuit Description

The idle validation signal is a safety feature that disables accelerator control while an improper validation signal is detected by the ECM. The idle validation switch provides on-idle and off-idle validation signals to the ECM through the OEM harness and OEM interface harness.

Component Location

The accelerator pedal or lever location varies with each OEM. Refer to the OEM manual.

Shop Talk

This fault code is usually caused by the improper wiring of the harnesses and idle validation switch.

Note:If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Refer to Troubleshooting Fault Code t05-431

Last Modified: 01-Mar-2011


CELECT™-Type Accelerator Pedal or Lever

FAULT CODE 432

CELECT™-Type Accelerator Pedal or Lever

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: P91 SPN: 091 FMI: 13 LAMP: Red SRT: 00-371 | Voltage detected at the idle validation on idle signal pin 13 of the OEM harness when voltage at accelerator position signal pin 29 of the OEM harness indicates pedal is not at idle or voltage detected at idle validation off-idle signal pin 12 of the OEM harness when voltage at accelerator position signal pin 29 of the OEM harness indicates pedal is at rest. | Engine will default to 0-percent accelerator.
CELECT™-Type Accelerator Pedal or Lever

Circuit Description

The accelerator pedal or lever provides the driver's accelerator command to the ECM through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command for the fuel rail actuator valve.

Component Location

The accelerator pedal or lever location varies with each OEM. Refer to the OEM manual.

Shop Talk

  • This fault code is usually caused by the improper wiring of the accelerator circuit, the idle validation circuit, or the OEM harness.

Note: If the accelerator or accelerator position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 01-Mar-2011


Unswitched Battery Supply Circuit

FAULT CODE 441

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1 LAMP: None SRT: 00-372 | Less than 12.0-VDC battery voltage detected at the ECM. | ECM voltage supply approaching a level at which unpredictable operation will occur.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery voltage through the OEM harness and the engine harness. There are two in-line 10-amp fuses in the unswitched battery wires of the OEM interface harness to protect the ECM. The battery return wires in the engine harness are connected to the engine block ground.

Component Location

The location of the battery will vary with the OEM. Refer to the OEM manual for the battery location.

Shop Talk

This fault is usually caused by loose or corroded battery connections.

Refer to Troubleshooting Fault Code t05-441

Last Modified: 01-Mar-2011


Unswitched Battery Supply Circuit

FAULT CODE 442

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0 LAMP: Yellow SRT: 00-373 | More than 38.0-VDC battery voltage detected at the ECM. | ECM damage will occur.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery voltage through the OEM harness and engine harness. There are two in-line 10-amp fuses in the unswitched battery wire of the OEM interface harness to protect the ECM. The battery return wires in the engine harness are connected to the engine block ground.

Component Location

The location of the battery will vary with the OEM. Refer to the OEM manual for the battery location.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-442

Last Modified: 01-Mar-2011


Rail Pressure Sensor Circuit

FAULT CODE 451

Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3 LAMP: Red SRT: 00-374 | More than 4.78-VDC detected at the rail pressure sensor signal pin 31 of the engine harness. | Depending on the calibration, the engine will shut down or power-derate, or no action is taken by the ECM.
Rail Pressure Sensor Circuit

Circuit Description

The rail pressure sensor provides a signal to the ECM, through the engine harness. The ECM uses the rail pressure sensor signal to monitor the amount of fuel going to the injector's metering chamber from the control valve body.

Component Location

The rail pressure sensor is located on the lower right side of the control valve body.

Shop Talk

The following charts show the output voltage of the rail pressure sensor at various pressure readings.

Pressure Sensor Output Voltage:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
103 | 15 | 30.54 | 0.48 to 0.52
345 | 50 | 101.8 | 1.03 to 1.17
689 | 100 | 203.6 | 1.81 to 2.09
1034 | 150 | 305.4 | 2.59 to 3.00
1379 | 200 | 407.2 | 3.38 to 3.93
1724 | 250 | 509 | 4.17 to 4.84

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-451

Last Modified: 01-Mar-2011


Rail Pressure Sensor Circuit

FAULT CODE 452

Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: 157 SPN: 157 FMI: 4 LAMP: Red SRT: 00-375 | Less than 0.15-VDC detected at the rail pressure sensor signal pin 31 of the engine harness. | Depending on the calibration, the engine will shut down or power-derate, or no action is taken by the ECM.
Rail Pressure Sensor Circuit

Circuit Description

The rail pressure sensor provides a signal to the ECM through the engine harness. The ECM uses the rail pressure sensor signal to monitor the amount of fuel going to the injector's metering chamber from the control valve body.

Component Location

The rail pressure sensor is located on the lower right side of the control valve body.

Shop Talk

The following charts show the output voltage of the rail pressure sensor at various pressure readings.

Pressure Sensor Output Voltage:

Pressure | Pressure | Pressure | Voltage
(kPa) | (psia) | (inHg) | (VDC)
103 | 15 | 30.54 | 0.48 to 0.52
345 | 50 | 101.8 | 1.03 to 1.17
689 | 100 | 203.6 | 1.81 to 2.09
1034 | 150 | 305.4 | 2.59 to 3.00
1379 | 200 | 407.2 | 3.38 to 3.93
1724 | 250 | 509 | 4.17 to 4.84

Older engine models will use the Packard-type connector on this pressure sensor, and newer models will use the DIN-type connector. The Packard connector pin designators are alpha and the DIN connector pin designators are numeric. The steps depicted in this fault code show the Packard-type connector with alpha pin numbers. If your engine uses the DIN-type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Type | Supply | Return | Signal
Packard | A | B | C
DIN | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-452

Last Modified: 01-Mar-2011


Rail Actuator Circuit

FAULT CODE 455

Rail Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: S18 SPN: 633 FMI: 3 LAMP: Red SRT: 00-376 | Rail actuator circuit is open, or supply pin 3 is shorted to battery voltage or ground, or return pin 10 is shorted to battery voltage or ground in the engine harness. | No action by the ECM is taken. Actuator is closed, or partially closed. Engine will not run, or runs at one speed. Fault Code 514 can be logged.
Rail Actuator Circuit

Circuit Description

The rail actuator circuit supplies current to the rail actuator. The ECM commands a varying amount of current to the rail actuator to control the amount of rail pressure to the injectors.

Component Location

The rail actuator is located on the bottom of the control valve body, toward the front of the engine, behind the ECM.

Shop Talk

  • Confirm that the actuator connector is firmly in place.
  • When there is no power to the actuator, the actuator closes and fuel flow stops. This will cause Fault Code 514, fueling flow mismatch.
  • When there is shorted power to the actuator, the actuator opens and fuel flow is uncontrolled. This will cause Fault Code 234, engine overspeed, or Fault Code 514, fueling flow mismatch.
Refer to Troubleshooting Fault Code t05-455

Last Modified: 01-Mar-2011


Timing Current Offset Error

FAULT CODE 467

Timing Current Offset Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 467 PID: S20 SPN: 635 FMI: 2 LAMP: Yellow SRT: 00-672 | The timing current offset, used to adjust timing flow, has reached the maximum or minimum threshold. | No action taken by the ECM.
Fuel System Flow Schematic

Circuit Description

The ECM uses the timing pressure signal and engine speed to estimate the actual timing the engine is receiving and then constantly compares this value to the desired timing for the given speed and load. When there is an error in these values, the current offset is adjusted to minimize the error. If the offset can not compensate to eliminate the error, it will reach its maximum/minimum threshold and Fault Code 467 is logged.

Component Location

The timing actuator is located on the top of the control valve body, toward the front of the engine, behind the ECM.

Shop Talk

The estimated timing and the desired timing parameters can be monitored on INSITE™. This fault is a check on the ECM's control of the timing actuator and timing current offset. If the desired timing can not be met by commanding more current to the actuator or if the desired timing is being exceeded and can not be reduced by reducing the current to the actuator, then Fault Code 467 is logged.

Refer to Troubleshooting Fault Code t05-467

Last Modified: 01-Mar-2011


Rail Current Offset Error

FAULT CODE 468

Rail Current Offset Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 468 PID: S18 SPN: 633 FMI: 2 LAMP: Yellow SRT: 00-673 | The rail current offset, used to adjust fueling flow, has reached the maximum or minimum threshold. | No action taken by the ECM.
Fuel System Flow Schematic

Circuit Description

The ECM uses the rail pressure signal and the engine speed to estimate the actual fueling that the engine is receiving and then constantly compares this value to the desired fueling for the given speed and load. When there is an error in these values, the current offset is adjusted to minimize the error. If the offset can not compensate to eliminate the error, it will reach its maximum/minimum threshold and Fault Code 468 is logged.

Component Location

The rail actuator is located on the bottom of the control valve body, toward the engine front, behind the ECM.

Shop Talk

The estimated rail fueling and the desired rail fueling parameters can be monitored on INSITE™. This fault is a check on the ECM's control of the rail actuator and rail current offset. If the desired rail fueling can not be met by commanding more current to the actuator or if the desired rail fueling is being exceeded and can not be reduced by reducing the current to the actuator, then Fault Code 468 is logged.

Refer to Troubleshooting Fault Code t05-468

Last Modified: 01-Mar-2011


Very Low Oil Level - Engine Protection

FAULT CODE 471

Very Low Oil Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 471 PID: S98 SPN: 098 FMI: 1/17 LAMP: Maintenance SRT: QU-471 | Very Low Oil Level - Engine Protection. Very low oil level is detected. Voltage signal on the oil level signal pin 12 of the engine harness indicates very low oil level in the engine. | Calibration-dependent progressive power derate and engine shutdown with increasing time after alert. Centinel™ feature is disabled.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor is used by the engine control module (ECM) to monitor the amount of oil in the engine.

Component Location

The oil level sensor is located in the oil pan on the left side of the engine.

Refer to Troubleshooting Fault Code t05-471.

Last Modified: 27-Oct-2015


Ether System Empty

FAULT CODE 487

Ether System Empty

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 487 PID: SPN: FMI: LAMP: White SRT: | The ether bottle for the ether injection system is empty. | The ether injection system is disabled.

Circuit Description

nonapplicable for this fault code

Component Location

nonapplicable for this fault code

Last Modified: 01-Mar-2011


Auxiliary Speed Input Error

FAULT CODE 489

Auxiliary Speed Input Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 489 PID: P191 SPN: 191 FMI: 1 LAMP: Yellow SRT: | Auxiliary speed frequency on input pin 17 indicates the frequency is below a calibration-dependent threshold. | Engine will go to idle.
Auxiliary Speed Input Circuit

Circuit Description

The auxiliary speed input is a frequency signal from an auxiliary speed or pressure pickup. It is sent to the ECM and is used to control the engine speed. Auxiliary reference speed is based on the accelerator position.

Component Location

The auxiliary speed or pressure pickup device location is dependent on the OEM application. Refer to OEM manual for component location.

Shop Talk

The auxiliary speed governor controls engine speed based on a measured auxiliary speed or pressure.

Refer to Troubleshooting Fault Code t05-489

Last Modified: 01-Mar-2011


MultiUnit Synchronous Switch Error

FAULT CODE 497

MultiUnit Synchronous Switch Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 497 PID: S114 SPN: 1377 FMI: 2 LAMP: Yellow SRT: | Multiunit synchronous on/off switch and multiunit synchronous complimentary on/off switch have different values at the ECM. | Multiunit synchronous feature is disabled.
MultiUnit Synchronous Switch Circuit

Circuit Description

The multiunit synchronous uses a complimentary switch to provide two opposite signals into the ECM.

Component Location

The multiunit synchronous switch is cab-mounted. Refer to the OEM manual for specific location.

Refer to Troubleshooting Fault Code t05-497

Last Modified: 01-Mar-2011


Oil Level Sensor Circuit

FAULT CODE 498

Oil Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 498 PID: FMI: LAMP: Warning SRT: | Engine oil level #1 sensor circuit - shorted high. | No engine protection for low oil level. Centinel system is disabled.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor is used by the electronic control module (ECM) to monitor the lubricating oil level. The ECM monitors the voltage on the oil level signal pin and converts this to an electronic value. The oil level value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

High voltage can be caused by the signal wire shorting to another wire in the harness, an open circuit in the return wire, or a faulty sensor.

Refer to Troubleshooting Fault Code t05-498

Last Modified: 01-Mar-2011


Oil Level Sensor Circuit

FAULT CODE 499

Oil Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 499 PID: FMI: LAMP: Warning SRT: | Engine oil level #1 sensor signal - shorted low. | No engine protection for oil level. Centinel system is disabled.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor is used by the electronic control module (ECM) to monitor the lubricating oil level. The ECM monitors the voltage on the oil level signal pin and converts this to an electronic value. The oil level value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

Low voltage can be caused by an open circuit in the signal wire, a short to ground in the signal wire, a short to ground in the supply wire, an open circuit in the supply wire, or a faulty sensor.

A 4-pin oil level sensor will not trigger Fault Code 499.

Refer to Troubleshooting Fault Code t05-499

Last Modified: 01-Mar-2011


Rail Fueling Flow Mismatch

FAULT CODE 514

Rail Fueling Flow Mismatch

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 514 PID: S18 SPN: 633 FMI: 7 LAMP: Red SRT: 00-378 | The error between the estimated rail fueling and the desired rail fueling is outside the acceptable limits. | Calibration-dependent engine shutdown or power derate or no action by the ECM is taken. Engine will overspeed, or run at one speed or not run.
Fuel System Flow Schematic

Circuit Description

The electronic control module (ECM) uses the rail pressure signal and the engine speed to estimate the actual fueling that the engine is receiving and then constantly compares this value to the desired fueling for the given speed and load. When there is too large an error in these values for too long a time, this fault is logged.

Component Location

The rail actuator is located on the bottom of the control valve body, toward the engine front, behind the ECM.

Shop Talk

The estimated rail fueling and the desired rail fueling parameters can be monitored on INSITE™ electronic service tool. This fault is a check on the ECM's control of the rail actuator and subsequent fuel flow. If the desired rail fueling can not be met by commanding more current to the actuator, or if the desired fuel railing is being exceeded and can not be reduced by reducing the current to the actuator, this fault is logged.

This fault is not logged when:

  • Engine speed is below 1200 rpm
  • Coolant temperature is below 0°C [32°F]
  • Fault Code 451 or 452 is active. Once the keyswitch is cycled, the fault becomes inactive.
Refer to Troubleshooting Fault Code t05-514

Last Modified: 01-Mar-2011


Solenoid A Error

FAULT CODE 527

Solenoid A Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: S40 SPN: 702 FMI: 3 LAMP: Yellow SRT: | The dual output A signal pin 1 of the OEM interface harness indicates an open or short circuit. | OEM-dependent.
Solenoid A Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-527

Last Modified: 01-Mar-2011


Solenoid B Error

FAULT CODE 529

Solenoid B Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: S51 SPN: 703 FMI: 3 LAMP: Yellow SRT: | The dual output B signal pin 9 of the OEM interface harness indicates an open or short circuit. | OEM-dependent.
Solenoid B Circuit

Circuit Description

The solenoid driver will control engine and vehicle functions by closing or opening a switched solenoid output, based on 11 selected engine parameters. The solenoid output will control functions such as a fan clutch, intake grid heater, air cleaner restriction indicator, or an oil filter differential pressure indicator.

Component Location

The solenoid driver is an OEM device and the location of the solenoid is dependent upon the OEM.

Refer to Troubleshooting Fault Code t05-529

Last Modified: 01-Mar-2011


Idle Validation Circuit

FAULT CODE 551

Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: P91 SPN: 091 FMI: 4 LAMP: Red SRT: 00-675 | No voltage detected simultaneously on both the idle validation off-idle and idle signal pins 12 and 13 of the OEM interface harness. | Engine will default to 0-percent accelerator.
Idle Validation Circuit

Circuit Description

The idle validation signal is a safety feature that disables accelerator pedal or lever control while an improper validation signal is detected by the ECM. The idle validation switch provides on-idle and off-idle validation signals to the ECM through the OEM harness and OEM interface harness.

Component Location

The accelerator pedal or lever location varies with each OEM. Refer to the OEM manual.

Shop Talk

This fault code is usually caused by the improper wiring of the harnesses and idle validation switch.

Note: If the accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Refer to Troubleshooting Fault Code t05-551

Last Modified: 01-Mar-2011


Rail Pressure Over Limits

FAULT CODE 553

Rail Pressure Over Limits

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0 LAMP: Red SRT: 00-382 | Rail pressure exceeds a normal limit. | Fuel shutoff valve de-energized (valve closes). The valve reenergizes (valve opens) when rail pressure falls below acceptable limit for present engine speed.
ECM

Circuit Description

The ECM secondary processor monitors the rail pressure. When it senses a pressure above the torque curve, with the accelerator off-idle, or a pressure above 103 kPa [15 psi], with the accelerator on-idle, and engine speed is above idle, it will shut the engine down. A problem in the ECM is the most likely cause of this situation.

Component Location

The ECM is mounted on the control valve body.

Shop Talk

If Fault Code 514 is logged but the engine is not shut down, an overpressure situation will develop, causing Fault Code 553 to be logged. If this is the case, the actuator has failed to open; investigate Fault Code 514 first.

Refer to Troubleshooting Fault Code t05-553

Last Modified: 01-Mar-2011


Rail Pressure In-Range Error

FAULT CODE 554

Rail Pressure In-Range Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 554 PID: P157 SPN: 157 FMI: 2 LAMP: Yellow SRT: | More than 0.67 VDC detected at the rail pressure signal pin 31 of the engine harness at engine key-on. | Calibration-dependent engine derate.
Rail Pressure Sensor Circuit

Circuit Description

The rail pressure sensor provides a signal to the ECM through the engine harness. The ECM uses the rail pressure sensor signal to monitor the pressure going to the injectors from the control valve body. At start-up, the ECM expects to see the voltage on signal pin 31 between 0.40 and 4.60 VDC. If the voltage is other than the specified range on start-up, the ECM will log this fault.

Component Location

The rail pressure sensor is located in the control valve body.

Shop Talk

The following charts show the output voltage of the rail pressure sensor at various pressure readings. Some engines could possibly use the Danfoss™ absolute pressure sensors. Refer to the table below that matches the sensor on the engine.

Pressure Sensor Output Voltage:

Pressure | Pressure | Voltage
(kPa) | (psi) | (VDC)
0 | 0 | 0.475 to 0.525
344.7 | 50 | 0.977 to 1.127
1034.1 | 150 | 1.976 to 2.334
1723.5 | 250 | 2.967 to 3.551
2585.3 | 375 | 4.625 to 5.102

Danfoss™ Absolute Pressure Sensor Output Voltage:

Pressure | Pressure | Voltage
(kPa) | (psia) | (VDC)
41.4 | 0 | 0.5
206.8 | 30 | 1.5
413.7 | 60 | 2.5
620.5 | 90 | 3.5
827.4 | 120 | 4.5

Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin numbers. If your engine uses the Danfoss™ type connector, refer to the following table to determine the equivalent pin designations for that type connector.

Connector Brand | Supply | Signal | Return
Metri-Pack | A | B | C
Danfoss™ | 1 | 2 | 3
Refer to Troubleshooting Fault Code t05-554

Last Modified: 01-Mar-2011


Blowby Pressure - Engine Protection

FAULT CODE 555

Blowby Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 1264 FMI: 0 LAMP: Engine Protection SRT: 00-676 | High blowby pressure has been detected. Voltage signal at blowby pressure signal pin 25 indicates blowby pressure above 368 mm H2O [14.5 in H2O]. | Calibration-dependent. Progressive power and speed derate and engine shutdown as pressure increases over thresholds.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor is used by the ECM to monitor the engine crankcase pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The blowby pressure value is used by the ECM for the engine protection system.

Component Location

The blowby pressure sensor is located on the exhaust side of the engine, below the water pump on the QSK19 series engines. See engine component views in Section E for location information for the QSK23, QSK45, QSK60, and QSK78 series engines.

Shop Talk

  • Confirm that the crankcase breathers and breather tubes are not obstructed.
Refer to Troubleshooting Fault Code t05-555

Last Modified: 01-Mar-2011


Keyswitch Hot Shutdown

FAULT CODE 611

Keyswitch Hot Shutdown

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 611 PID: SPN: FMI: LAMP: None SRT: | Engine shut down with the keywswitch before proper engine cooldown. | No action is taken by ECM. Load factor above the maximum shutdown threshold. Fault code will be logged.

Circuit Description

nonapplicable for this fault code

Component Location

nonapplicable for this fault code

Last Modified: 01-Mar-2011


Maintenance Interval Reached

FAULT CODE 649

Maintenance Interval Reached

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: SPN: FMI: LAMP: Red SRT: | The maintenance interval has been reached. | No action is taken by ECM.

Circuit Description

nonapplicable for this fault code

Component Location

nonapplicable for this fault code

Shop Talk

Perform standard oil change maintenance. The fault code can be cleared with the service tool during the maintenance procedure. Manually clearing the fault code can be accomplished through the accelerator pedal on applications with an accelerator pedal, or through the diagnostic switch on installations without an accelerator pedal.

The following procedure must be completed in 20 seconds or less. If the fault code is cleared successfully, the maintenance lamp will respond with a series of flashes. If the procedure is unsuccessful, turn the keyswitch to the OFF position and restart the procedure.

With the accelerator pedal:

  • Turn the keyswitch ON, the diganostic switch ON, and the engine OFF.
  • Depress the accelerator pedall 100 percent for a minimum of 3 seconds and then release.
  • Depress the accelerator pedal 100 percent briefly two more times and release.
  • Depress the accelerator pedal 100 percent once more for a minimum of 3 seconds and release.

With the diagnostic switch only:

  • Turn the keyswitch ON and the engine OFF.
  • Turn the diagnostic swtich ON for a minimum of 3 seconds and then turn it OFF.
  • Turn the diagnost switch ON briefly two more times and then OFF.
  • Turn the diagnostic switch ON once more for a minimum of 3 seconds and then OFF.

Last Modified: 01-Mar-2011


Blowby Pressure Sensor Circuit

FAULT CODE 719

Blowby Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 719 PID: P22 SPN: 1264 FMI: 3 LAMP: Yellow SRT: 00-677 | More than 4.94-VDC detected at the blowby pressure sensor SIGNAL pin 25 of the engine harness. | No engine protection for blowby pressure.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor monitors blowby pressure and passes information to the engine control module (ECM) through pin 25 of the engine harness. The ECM monitors the voltage on pin 25 and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation. Voltage above 4.94-VDC on pin 25 will trip Fault Code 719 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the return wire circuit, or a malfunctioning sensor.

Component Location

The blowby pressure sensor is located on the exhaust side of the engine, below the water pump on QSK19 series engines. Refer to Procedure 100-002 (Engine Diagrams) in Section E for component location for QSK23, QSK45, QSK60, and QSK78 Series engines.

Shop Talk

Confirm that the crankcase breathers, breather tubes, and blowby sensor are not obstructed.

Refer to Troubleshooting Fault Code t05-719

Last Modified: 15-Apr-2013


Blowby Pressure Sensor Circuit

FAULT CODE 729

Blowby Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 729 PID: P22 SPN: 1264 FMI: 4 LAMP: Yellow SRT: 00-678 | Less than 0.29-VDC detected at the blowby pressure sensor SIGNAL pin 25 of the engine harness. | No engine protection for blowby pressure.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor monitors blowby pressure and passes this information to the engine control module (ECM) through pin 25 of the engine harness. The ECM monitors the voltage on pin 25 and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation. Voltage below 0.29-VDC on pin 25 will trip Fault Code 729 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the RETURN wire, or a malfunctioning sensor.

Component Location

The blowby pressure sensor is located on the exhaust side of the engine, below the water pump on the QSK19 fuel systems. Refer to Procedure 100-002 (Engine Diagrams) in Section E for component location for QSK23, QSK45, QSK60, and QSK78 Series engines.

Shop Talk

Confirm that the crankcase breathers, breather tubes, and blowby sensor are not obstructed.

Refer to Troubleshooting Fault Code t05-729

Last Modified: 15-Apr-2013


Engine Speed Sensor Circuit

FAULT CODE 753

Engine Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 753 PID: S64 SPN: 723 FMI: 2 LAMP: Off SRT: 00-679 | The engine speed signals detected on pins 27, 28, 37, and 38 of the ECM do not match. | No action by the ECM is taken.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual-coil circuit that provides the engine speed signal to the ECM through the engine harness.

Component Location

The engine speed sensor is located above the accessory drive.

Shop Talk

  • If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor circuit while the engine is at that particular temperature.
  • Measure camshaft end play to make sure that camshaft gear is not moving too far away from the end of the engine speed sensor.
Refer to Troubleshooting Fault Code t05-753

Last Modified: 18-Aug-2010


Turbocharger Air Inlet Temperature - Engine Protection

FAULT CODE 777

Turbocharger Air Inlet Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 777 PID: SPN: FMI: LAMP: Yellow SRT: | The turbocharger inlet air temperature has exceeded the standard ambient air temperature limit. | The engine will go into a derate mode until the turbocharger inlet air temperature drops to a normal level.

Circuit Description

nonapplicable for this fault code

Component Location

nonapplicable for this fault code

Shop Talk

Inspect the air intake for blockage, proximity to any heating elements, or proximity to the exhaust system.

Last Modified: 01-Mar-2011


Multiple Fault Code A on the Engine Harness

FAULT CODE Multiple A

Multiple Fault Code A on the Engine Harness

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: Multiple A
PID:
FMI:
LAMP:
SRT: 00-381

On engines without an electronic fuel pump, the supply voltage from pin 5 of the engine harness has:

  • Failed internally in the ECM
  • Been shorted to ground
  • An open circuit external to the ECM.

Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc00

Last Modified: 19-Aug-2010


Multiple Fault Code B on the Engine Harness

FAULT CODE Multiple B

Multiple Fault Code B on the Engine Harness

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: Multiple B
PID:
FMI:
LAMP:
SRT: 00-381

On engines with an electronic fuel pump, the supply voltage from pin 5 of the engine harness has:

  • Failed internally in the ECM
  • Been shorted to ground
  • An open circuit external to the ECM.

Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc01

Last Modified: 19-Aug-2010


Multiple Fault Code C on the Engine Harness

FAULT CODE Multiple C

Multiple Fault Code C on the Engine Harness

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: Multiple C
PID:
FMI:
LAMP:
SRT: 00-381

On engines without CENSE™, the supply voltage from pin 6 of the engine harness has:

  • Failed internally in the ECM
  • Been shorted to ground
  • An open circuit external to the ECM.

Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor or temperature sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc02

Last Modified: 19-Aug-2010


Multiple Fault Code D on the Engine Harness

FAULT CODE Multiple D

Multiple Fault Code D on the Engine Harness

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: Multiple D
PID:
FMI:
LAMP:
SRT: 00-381

On engines with CENSE™, the supply voltage from pin 6 of the engine harness has:

  • Failed internally in the ECM
  • Been shorted to ground
  • An open circuit external to the ECM.

Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor or temperature sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc03

Last Modified: 19-Aug-2010


Multiple Fault Code E on the Engine Harness

FAULT CODE Multiple E

Multiple Fault Code E on the Engine Harness

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: Multiple E
PID:
FMI:
LAMP:
SRT: 00-381

The supply voltage from pin 16 of the OEM interface harness has:

  • Failed internally in the ECM
  • Been shorted to ground
  • An open circuit external in the ECM.

Multiple fault codes.

Circuit Description

The ECM supplies the coolant level sensor and the remote accelerator position sensor with +5 VDC from pin 16. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on pin 21. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc04

Last Modified: 19-Aug-2010


Multiple Fault Code F on the Engine Harness

FAULT CODE Multiple F

Multiple Fault Code F on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple F PID: FMI: LAMP: SRT: 00-381 | On engines without CENSE™, the common return fails internal to the ECM, affecting pins 17 and 18 on the engine harness, and pins 11 and 21 on the OEM interface harness. | Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc05

Last Modified: 19-Aug-2010


Multiple Fault Code G on the Engine Harness

FAULT CODE Multiple G

Multiple Fault Code G on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple G PID: FMI: LAMP: SRT: 00-381 | On engines with CENSE™, the common return fails internal to the ECM, affecting pins 17 and 18 on the engine harness, and pins 11 and 21 on the OEM interface harness. | Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc06

Last Modified: 19-Aug-2010


Multiple Fault Code H on the Engine Harness

FAULT CODE Multiple H

Multiple Fault Code H on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple H PID: FMI: LAMP: SRT: 00-381 | On engines without CENSE™, the common return from pin 17 of the engine harness has an open circuit external to the ECM. | Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc07

Last Modified: 19-Aug-2010


Multiple Fault Code I on the Engine Harness

FAULT CODE Multiple I

Multiple Fault Code I on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple I PID: FMI: LAMP: SRT: 00-381 | On engines with CENSE™, the common return from pin 17 of the engine harness has an open circuit external to the ECM. | Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc08

Last Modified: 19-Aug-2010


Multiple Fault Code J on the Engine Harness

FAULT CODE Multiple J

Multiple Fault Code J on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple J PID: FMI: LAMP: SRT: 00-381 | On engines without electronic fuel pump, the common return from pin 18 of the engine harness has an open circuit external to the ECM. | Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc09

Last Modified: 19-Aug-2010


Multiple Fault Code K on the Engine Harness

FAULT CODE Multiple K

Multiple Fault Code K on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple K PID: FMI: LAMP: SRT: 00-381 | On engines with an electronic fuel pump, the common return from pin 18 of the engine harness has an open circuit external to the ECM. | Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc10

Last Modified: 19-Aug-2010


Multiple Fault Code L on the Engine Harness

FAULT CODE Multiple L

Multiple Fault Code L on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple L PID: FMI: LAMP: SRT: 00-381 | The common return from pin 21 of the OEM interface harness has an open circuit external to the ECM. | Multiple fault codes.

Circuit Description

The ECM supplies all of the engine pressure sensors on the engine harness with +5 VDC from either pin 5 or pin 6. The ECM has common returns for all of the engine pressure sensors and all of the temperature sensors on either pin 17 or pin 18. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to the engine diagrams.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes.

Refer to Troubleshooting Fault Code t05-mfc11

Last Modified: 19-Aug-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Electronic Control Module (ECM) Microprocessor

Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Check the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Check the ECM.

  • Turn the vehicle keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 111 inactive

Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Less than 3 counts

Replace the ECM. Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for at least 1 minute.
  • Verify that Fault Code 111 is inactive.
OK NOT OK

Fault Code 111 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Apr-2012


FAULT CODE 112- Timing Fueling Flow Mismatch

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the complaint. |
 | STEP 1A. Check for active fault codes other than Fault Code 112. | Fault codes active?
 | STEP 1B. Interview the driver for engine symptoms present. | Symptoms present?
 | STEP 1C. Monitor the timing parameters for over-pressurization of the timing fuel. | Timing fuel over-pressurized?
STEP 2. | Check the inlet side of the fuel system. |
 | STEP 2A. Check the fuel tank level. | Fuel in tank?
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | Broken lines, loose fittings or fuel leaks?
 | STEP 2C. Check the fuel inlet restriction. | Greater than 203 mm Hg [8 in Hg]?
 | STEP 2D. Check for air in the fuel. | Air in fuel?
STEP 3. | Check the fuel system components. |
 | STEP 3A. Check the fuel pump output pressure. | Fuel pump output pressure correct?
 | STEP 3A-1. Check the injector o-rings. |
 | STEP 3A-2. Check for fuel in the oil or coolant. |
 | STEP 3B. Inspect the actuator screen for debris. | Debris on inlet actuator screen?
 | STEP 3C. Inspect the actuator for corrosion. | Corrosion on actuator?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 112 inactive?
 | STEP 4B. Clear the inactive fault codes. | Fault codes cleared?

Guided Step 1 - Verify the complaint.

Guided Step 1A - Check for active fault codes other than Fault Code 112.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes other than Fault Code 112.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes active?
YES NO

Investigate other fault codes first.

 No Repair

Appropriate fault code procedure

Go to 1B

Guided Step 1B - Interview the driver for engine symptoms present.

Conditions

  • Turn keyswitch ON.

Action

Interview the driver for the following:

  • Ask the operator if specific symptoms or shutdowns/derates due to Fault Code 112 are present.

Symptoms present?
YES NO
No Repair

Clear the fault code. Inactive faults have been logged. Since the customer is not experiencing a problem, clear the fault code.

Go to 1C

Go to 4B

Guided Step 1C - Monitor the timing parameters for over-pressurization of the timing fuel.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the timing parameters for over-pressurization of the timing fuel.

  • Use INSITE™ electronic service tool to monitor the desired timing fueling and the estimated timing fueling parameters.
  • Is the estimated timing fueling consistently higher than the desired timing fueling? If it is higher, it is over-pressurizing the timing fueling.

Timing fuel over-pressurized?
YES NO

Replace the timing actuator. Refer to Procedure 019-339 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the inlet side of the fuel system.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank level for the following:

  • Fuel in the tank?

Fuel in tank?
YES NO
No Repair

Fill the fuel tank.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.

Broken lines, loose fittings or fuel leaks?
YES NO

Repair the leak. Tighten or replace the leaking fitting or fuel line.

  • Replace the fuel line. Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet restriction as follows:

  • Measure the inlet restriction.
  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Greater than 203 mm Hg [8 in Hg]?
YES NO

Find the cause of restriction and remove restriction. Check for clogged fuel filters, debris in the fuel tank, fuel tank vents clogged, collapsed or faulty fuel lines, or faulty check valves.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Check for air in the fuel system.
  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Air in fuel?
YES NO

Find the cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings, loose or broken fittings, and broken lines.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel system components.

Guided Step 3A - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the Compuchek™ fitting.
  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Fuel pump output pressure correct?
YES NO

Minimum Output Pressure for QSK19:

  • Minimum 379 kPa [55 psi] @ 600 rpm
  • Minimum 1207 kPa [175 psi] @ 1300 rpm
  • Minimum 1724 kPa [250 psi] @ 2100 rpm
  • Minimum 1827 kPa [265 psi] @ 2350 rpm.

Minimum Output Pressure for QSK23:

  • Minimum 689 kPa [100 psi] @ 600 rpm
  • Minimum 910 kPa [132 psi] @ 1000 rpm
  • Minimum 1207 kPa [175 psi] @ 1400 rpm
  • Minimum 1434 kPa [208 psi] @1500 rpm
  • Minimum 1779 kPa [258 psi] @ 1800 rpm
  • Minimum 1999 kPa [290 psi] @ 2100 rpm.

Minimum Output Pressure for QSK45 and QSK60:

  • Minimum 758 kPa [110 psi] @ 600 rpm
  • Minimum 1379 kPa [200 psi] @ 1300 rpm
  • Minimum 1724 kPa [250 psi] @ 1900 rpm
  • Minimum 1793 kPa [260 psi] @ 2300 rpm.

Minimum Output Pressure for QSK78:

  • Minimum 793 kPa [115 psi] @ 600 rpm
  • Minimum 1689 kPa [245 psi] @ 1300 rpm
  • Minimum 2068 kPa [300 psi] @ 1900 rpm
  • Minimum 2482 kPa [360 psi] @ 2300 rpm.

Continue troubleshooting.

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Check the injector o-rings.

Conditions

  • Turn keyswitch ON.

Action

Check the injector o-rings.

The o-rings can be checked by observing the drain output of the front three versus the rear three cylinders on the QSK19 series engines and by observing the drain output of the left bank of cylinders versus the right bank of cylinders on the QSK45 and QSK60 series engines.

  • Disconnect the drain lines at the T-junction.
  • Place each half into separate, equal-size buckets.
  • Operate the engine at rated speed for enough time to determine if output is equal from each half.

Drain output equal from front and rear halves?
YES NO
No Repair

Replace the injector o-rings on the faulty bank.

Replace the injector.

  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-026 in Section 6.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for fuel in the oil or coolant.

Conditions

  • Turn keyswitch OFF.

Action

Check for fuel in the oil or coolant.

  • Investigate for fuel or oil in coolant.

Fuel in oil or coolant?
YES NO

Replace the timing actuator. Refer to Procedure 019-339 in Section 19.

No Repair

Appropriate troubleshooting symptom tree

Go to 4A

Guided Step 3B - Inspect the actuator screen for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator screen for debris.

  • Remove the timing actuator to inspect the screen for debris. Refer to Procedure 019-339 in Section 19.

Debris on inlet actuator screen?
YES NO

Replace the timing actuator screen.

  • Refer to Procedure 019-112 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the actuator for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator for corrosion.

  • Remove the timing actuator to inspect for corrosion. Refer to Procedure 019-339 in Section 19.

Corrosion on actuator?
YES NO

Replace the timing actuator.

  • Refer to Procedure 019-112 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and run throughout the operating range to verify that Fault Code 112 stays inactive.

Fault Code 112 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault codes cleared?
YES NO

Troubleshoot any remaining active fault codes.

 No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Dec-2014


FAULT CODE 113 - Timing Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823254 - male three-way Metri-Pack™ connector test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823254 - male three-way Metri-Pack connector test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823254 - male three-way Metri-Pack™ connector test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator. |
 | STEP 1A. Inspect the timing actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the timing actuator. | 7.0 to 9.0 ohms
 | STEP 1C. Check for a short circuit from supply to ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 20 ohms
 | STEP 2C. Check for a short circuit from supply to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from supply to all pins. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 113 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing actuator.

Guided Step 1A - Inspect the timing actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Inspect the timing actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the timing actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel Syste QSK19 Series Engine, Bulletin 3666113. Refer to Procedure 019-201 in Section 19.
  • Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel Syste QSK19 Series Engine, Bulletin 3666113. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-043 in Section 19.
  • Replace the timing actuator. Use the following prcedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-339 in Section 19.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823254 - male three-way Metri-Pack connector test lead.
Guided Step 1B - Check the coil resistance of the timing actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Check the coil resistance of the timing actuator.

  • Measure the resistance from pin A to pin C of the timing actuator connector.
OK NOT OK

7.0 to 9.0 ohms

Replace the timing actuator. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-339 in Section 19.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823254 - male three-way Metri-Pack™ connector test lead.
Guided Step 1C - Check for a short circuit from supply to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Check for a short circuit from supply to ground.

  • Measure the resistance from pin A of the timing actuator connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the timing actuator. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-339 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the timing actuator.

Action

Check for an open circuit in the timing actuator circuit.

  • Measure the resistance from pin 1 to pin 20 of the engine harness ECM connector.
OK NOT OK

Less than 20 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from supply to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing actuator.

Action

Check for a short circuit from supply to ground.

  • Measure the resistance from pin 1 of the engine harness ECM connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 2D - Check for a short circuit from supply to all pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing actuator.

Action

Check for a short circuit from supply to all pins.

  • Measure the resistance from pin 1 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 20 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 113 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 115 - Engine Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:P art Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the engine speed sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Inspect the engine speed sensor. | No damage
 | STEP 1C. Check for an open circuit in the engine speed sensor. | 1000 to 2000 ohms
 | STEP 1D. Check for a short circuit to engine block ground. | More than 10M ohms
 | STEP 1E. Check for a short circuit between coils. | More than 10M ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 2000 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 115 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the engine speed sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine speed sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-042 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear
  • Oil leakage or insulation problems such as swelling
  • Electrical potting extruded out of the sensor housing
  • Damaged electrical potting in sensing end of sensor.
OK NOT OK

No damage

Replace the engine speed sensor. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-042 in Section 19.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:P art Number 3823996 - female Weather-Pack™ test lead.
Guided Step 1C - Check for an open circuit in the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit in the engine speed sensor.

  • Measure the resistance from pin A to pin D of the engine speed sensor connector.
  • Measure the resistance from pin B to pin C of the engine speed sensor connector.

Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

1000 to 2000 ohms

Replace the engine speed sensor. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-042 in Section 19.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.
Guided Step 1D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the engine speed sensor connector to engine block ground.
  • Measure the resistance from pin B of the engine speed sensor connector to engine block ground.

Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

More than 10M ohms

Replace the engine speed sensor. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-042 in Section 19.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.
Guided Step 1E - Check for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance from pin A to pin B of the engine speed sensor connector.
  • Measure the resistance from pin C to pin D of the engine speed sensor connector.

Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

More than 10M ohms

Replace the engine speed sensor. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Use the following procedure in the Troubleshooting and Repair Manual QSK Fuel System QSK19 Series Engines, Bulletin 3666113. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 of the engine harness ECM connector to pin 28 of the connector.
  • Measure the resistance from pin 37 of the engine harness ECM connector to pin 38 of the connector.
OK NOT OK

Less than 2000 ohms

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 27 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 28 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 37 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 38 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 27 of the engine harness ECM connector to all other pins of the connector.
  • Measure the resistance from pin 28 of the engine harness ECM connector to all other pins of the connector.
  • Measure the resistance from pin 37 of the engine harness ECM connector to all other pins of the connector.
  • Measure the resistance from pin 38 of the engine harness ECM connector to all other pins of the connector.
OK NOT OK

More than 100k ohms

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 115 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 116 - Timing Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Packard™ breakout cable, Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 118 and 451 are not active?
STEP 2. | Check the timing pressure sensor. |
 | STEP 2A. Inspect the timing pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 116 active?
 | STEP 2C. Check the timing pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the ECM timing pressure supply voltage. |
 | STEP 2D. Check the timing pressure signal voltage. | 0.42 to 0.58-VDC with the engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 116 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 116 inactive; Fault Code 117 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 116 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 118 and 451 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the timing pressure sensor.

Guided Step 2A - Inspect the timing pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the timing pressure sensor.

Action

Inspect the timing pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the timing pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 116 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the timing pressure supply voltage.

Conditions

  • Disconnect the timing pressure sensor from the engine harness
  • Install the appropriate timing pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the timing pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ECM timing pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the ECM timing pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the timing pressure signal voltage.

Conditions

  • Disconnect the timing pressure sensor from the engine harness
  • Install the appropriate timing pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the timing pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specification.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect timing pressure sensor from the engine harness
  • Disconnect rail pressure sensor from the engine harness
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 to all other pins in the engine harness ECM connector.
  • Measure the resistance from pin 33 to all other pins in the engine harness ECM connector.
  • Measure the resistance from pin 18 to all other pins in the engine harness ECM connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the timing pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the timing pressure sensor connector.
  • Measure the resistance from pin 33 of the engine harness ECM connector to pin C of the timing pressure sensor connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the timing pressure sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 116 inactive; Fault Code 117 active?

Fault Code 116 active.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 33 (signal) to pin 5 (supply) in the engine harness ECM connector port.
OK NOT OK

More than 35k ohms?

Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the timing pressure sensor from the engine harness
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 116 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the timing pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness connector to pin B of the timing pressure sensor harness connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the timing pressure sensor
  • Disconnect the engine harness from the rail pressure sensor
  • Disconnect the engine harness from the fuel pump pressure sensor (if equipped).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 33 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness connector to all other pins in the connector.

Look for short circuits from battery or sensor voltage to pin 5, 33, or 18.
OK NOT OK

More than 100k ohms?

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 116 inactive; Fault Code 117 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 116 is inactive.
OK NOT OK

Fault Code 116 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 117 - Timing Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Packard™ breakout cable, Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 119 and 452 are not active?
STEP 2. | Check the timing pressure sensor. |
 | STEP 2A. Inspect the timing pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 117 active?
 | STEP 2C. Check the timing pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the ECM timing pressure supply voltage. |
 | STEP 2D. Check the timing pressure signal voltage. | 0.42 to 0.58-VDC with the engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to return pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 117 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3E. Check for a short circuit to the engine block ground. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 117 inactive; Fault Code 116 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 117 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 119 and 452 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the timing pressure sensor.

Guided Step 2A - Inspect the timing pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the timing pressure sensor.

Action

Inspect the timing pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the timing pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 117 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the timing pressure supply voltage.

Conditions

  • Disconnect the timing pressure sensor from the engine harness
  • Install the appropriate timing pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the timing pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ECM timing pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the ECM timing pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the timing pressure signal voltage.

Conditions

  • Disconnect the timing pressure sensor from the engine harness
  • Install the appropriate timing pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the timing pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specification.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect timing pressure sensor from the engine harness
  • Disconnect rail pressure sensor from the engine harness
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the ECM harness connector to all other pins in the connector.
  • Measure the resistance from pin 33 of the ECM harness connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the ECM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the timing pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the timing pressure sensor connector.
  • Measure the resistance from pin 33 of the engine harness ECM connector to pin C of the timing pressure sensor connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the timing pressure sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedure. Refer to Procedure 019-203 in Section 19.
  • Use the following procedure. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 33 to pin 5 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 117 inactive; Fault Code 116 active?

Fault Code 117 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to return pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Check the resistance from signal pin to return pin in the ECM port.

  • Measure the resistance from pin 33 (signal) to pin 18 (return) in the engine harness ECM connector port.
OK NOT OK

More than 35k ohms?

Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the timing pressure sensor from the engine harness
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 117 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the timing pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the engine harness connector to pin A of the timing pressure sensor harness connector, engine harness side.
  • Measure the resistance from pin 33 of the engine harness connector to pin C of the timing pressure sensor harness connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedure. Refer to Procedure 019-203 in Section 19. Use the following procedure. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the timing pressure sensor
  • Disconnect the engine harness from the rail pressure sensor
  • Disconnect the engine harness from the fuel pump pressure sensor, if equipped.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 33 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace engine harness

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the timing pressure sensor

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 5 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 33 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 18 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace engine harness

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 33 to pin 6 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 117 inactive; Fault Code 116 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 117 is inactive.
OK NOT OK

Fault Code 117 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Feb-2015


FAULT CODE 118 - Fuel Pump Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Packard™ breakout cable Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 116 and 451 are not active?
STEP 2. | Check the fuel pump pressure sensor. |
 | STEP 2A. Inspect the fuel pump pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 118 active?
 | STEP 2C. Check the fuel pump pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the fuel pump pressure supply voltage. |
 | STEP 2D. Check the fuel pump pressure signal voltage. | 0.42 to 0.58-VDC engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 118 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 118 inactive; Fault Code 119 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 118 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 116 and 451 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the fuel pump pressure sensor.

Guided Step 2A - Inspect the fuel pump pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Inspect fuel pump pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the fuel pump pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.
  • Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 118 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the fuel pump pressure supply voltage.

Conditions

  • Disconnect the fuel pump pressure sensor from the engine harness
  • Install the appropriate fuel pump pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the fuel pump pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the fuel pump pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the fuel pump pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the fuel pump pressure signal voltage.

Conditions

  • Disconnect the fuel pump pressure sensor from the engine harness
  • Install the appropriate fuel pump pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON
  • Engine not running.

Action

Check the fuel pump pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specification.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect fuel pump pressure sensor from the engine harness
  • Disconnect rail pressure sensor from the engine harness
  • Disconnect the timing pressure sensor from the engine harness
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 32 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the fuel pump pressure sensor connector.
  • Measure the resistance from pin 32 of the engine harness ECM connector to pin C of the fuel pump pressure sensor connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the fuel pump pressure sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 118 inactive; Fault Code 119 active?

Fault Code 118 active.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 32 (signal) to pin 5 (supply) in the ECM engine harness connector port.
OK NOT OK

More than 35 ohms?

  • Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 118 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness connector to pin B of the fuel pump pressure sensor harness connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the timing pressure sensor
  • Disconnect the engine harness from the rail pressure sensor
  • Disconnect the engine harness from the fuel pump pressure sensor
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 32 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness connector to all other pins in the connector.

Look for short circuits from battery or sensor voltage to pin 5, 32, or 18.
OK NOT OK

More than 100k ohms?

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 118 inactive; Fault Code 119 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 116 is inactive.
OK NOT OK

Fault Code 118 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Sep-2014


FAULT CODE 119 - Fuel Pump Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Packard™ breakout cable, Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 117 and 452 are not active?
STEP 2. | Check the fuel pump pressure sensor. |
 | STEP 2A. Inspect the fuel pump pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 119 active?
 | STEP 2C. Check the fuel pump pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the fuel pump pressure supply voltage. |
 | STEP 2D. Check the fuel pump pressure signal voltage. | 0.42 to 0.58-VDC engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check for the appropriate ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 119 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3E. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 119 inactive; Fault Code 118 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 119 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 117 and 452 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the fuel pump pressure sensor.

Guided Step 2A - Inspect the fuel pump pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Inspect fuel pump pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the fuel pump pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pump pressure sensor. Refer to Procedure 019-119 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 119 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the fuel pump pressure supply voltage.

Conditions

  • Disconnect the fuel pump pressure sensor from the engine harness
  • Install the appropriate fuel pump pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the fuel pump pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the fuel pump pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the fuel pump pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the fuel pump pressure signal voltage.

Conditions

  • Disconnect the fuel pump pressure sensor from the engine harness
  • Install the appropriate fuel pump pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the fuel pump pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specification.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect fuel pump pressure sensor from the engine harness
  • Disconnect rail pressure sensor from the engine harness
  • Disconnect the timing pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 32 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the fuel pump pressure sensor connector.
  • Measure the resistance from pin 32 of the engine harness ECM connector to pin C of the fuel pump pressure sensor connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the fuel pump pressure sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 32 to pin 5 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 119 inactive; Fault Code 118 active?

Fault Code 118 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 32 (signal) to pin 18 (return) in the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 119 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the engine harness connector to pin A of the fuel pump pressure sensor harness connector, engine harness side.
  • Measure the resistance from pin 32 of the engine harness connector to pin C of the fuel pump pressure sensor harness connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the fuel pump pressure sensor
  • Disconnect the engine harness from the rail pressure sensor
  • Disconnect the engine harness from the timing pressure sensor.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 32 of the engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from pin 5 of the engine harness connector to the engine block ground.
  • Measure the resistance from pin 32 of the engine harness connector to the engine block ground.
  • Measure the resistance from pin 18 of the engine harness connector to the engine block ground.
OK NOT OK

More than 100k ohms?

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 32 to pin 5 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 119 inactive; Fault Code 118 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 119 is inactive.
OK NOT OK

Fault Code 119 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the engine speed sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Inspect the engine speed sensor. | No damage
 | STEP 1C. Check for open circuit in the engine speed sensor. | 1000 to 2000 ohms
 | STEP 1D. Check for short circuit to engine block ground. | More than 10M ohms
 | STEP 1E. Check for short circuit between coils. | More than 10M ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 1000 to 2000 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the engine speed sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Electrical potting extruded from sensor housing
  • Damaged electrical potting in sensing end of sensor.
OK NOT OK

No damage

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1C - Check for an open circuit in the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit in the engine speed sensor.

  • Measure the resistance from pin A to pin D (outside pins) of the sensor connector.
  • Measure the resistance from pin B to pin C (inside pins) of the sensor connector.

Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.

OK NOT OK

1000 to 2000 ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the sensor connector to engine block ground.
  • Measure the resistance from pin B of the sensor connector to engine block ground.

Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.

OK NOT OK

More than 10M ohms

Replace the engine speed sensor. Refer to Procedure 019-042 inSection 19.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.
Guided Step 1E - Check for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance from pin A to pin B of the sensor connector.
  • Measure the resistance from pin C to pin D of the sensor connector.

Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.

OK NOT OK

More than 10M ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 to pin 28 of the engine harness ECM connector.
  • Measure the resistance from pin 37 to pin 38 of the engine harness ECM connector.
OK NOT OK

1000 to 2000 ohms

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 27 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 28 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 37 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 38 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 27 of the engine harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 28 of the engine harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 37 of the engine harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 38 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - Packard™ breakout cable, Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 144, 153, 221, 231, 263, and 719 are not active?
 | STEP 1B. Read the fault codes. | Fault Codes 135, 144, 153, and 221 are not active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the intake manifold pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 122 active?
 | STEP 2C. Check the intake manifold pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the intake manifold pressure supply voltage. |
 | STEP 2D. Check the intake manifold pressure signal voltage. | For QSK19 or QSK23: 0.42 to 0.58-VDC; For QSK45, QSK60, or QSK78: at sea level, 1.23 to 1.48-VDC?, for higher altitudes, use the tables in Shop Talk to determine the correct pressure and corresponding voltage
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 122 active?
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3D. Check for an open circuit in the return wire. | Less than 10 ohms”
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 122 inactive; Fault Code 123 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 135, 144, 153, 221, 231, 263, and 719 are not active?

Go to 1B

Multiple fault code tree

Guided Step 1B - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 135, 144, 153, and 221 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the intake manifold pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the intake manifold pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use general inspection techniques to inspect the connectors. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the intake manifold pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the intake manifold pressure supply voltage.

Conditions

  • Disconnect the intake manifold pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the intake manifold pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the intake manifold pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the intake manifold pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the intake manifold pressure signal voltage.

Conditions

  • Disconnect the intake manifold pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the intake manifold pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

For QSK19 or QSK23: 0.42 to 0.58-VDC; For QSK45, QSK60, or QSK78: at sea level, 1.23 to 1.48-VDC?, for higher altitudes, use the tables in Shop Talk to determine the correct pressure and corresponding voltage

Does not meet specification.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.

Use general measurement techniques to measure resistance. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the intake manifold pressure sensor harness connector.
  • Measure the resistance from pin 35 of the engine harness ECM connector to pin C of the intake manifold pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the intake manifold pressure sensor harness connector.

Use general measurement techniques to measure resistance. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 inactive; Fault Code 123 active?

Fault Code 122 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 35 (signal) to pin 6 (supply) of the ECM engine harness connector port.

Use general measurement techniques to measure resistance. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 35k ohms?

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use general inspection techniques to inspect the connectors. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 35 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.

Use general measurement techniques to measure resistance. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the intake manifold pressure sensor harness connector.

Use general measurement techniques to measure resistance. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 24 to pin 6 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 inactive; Fault Code 123 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 122 is inactive.
OK NOT OK

Fault Code 122 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824776 - Packard™ breakout cable, Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 141, 145, 154, 222, 232, 265, and 729 are not active?
 | STEP 1B. Read the fault codes. | Fault Codes 141, and 222 are not active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the intake manifold pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 123 active?
 | STEP 2C. Check the intake manifold pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the intake manifold pressure supply voltage. |
 | STEP 2D. Check the intake manifold pressure signal voltage. | For QSK19 or QSK23: 0.42 to 0.58-VDC; For QSK45, QSK60, or QSK78: at sea level, 1.23 to 1.48-VDC?, for higher altitudes, use the tables in Shop Talk to determine the correct pressure and corresponding voltage
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check for the appropriate ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to return pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 123 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 123 inactive; Fault Code 122 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 141, 222, 232, 252, and 729 are not active?

Go to 1B

Multiple fault code tree

Guided Step 1B - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 141, and 222 are not active?

Go to 2A

Multiple fault code tree.

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the intake manifold pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use general inspection techniques to inspect the connectors. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the intake manifold pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the intake manifold pressure supply voltage.

Conditions

  • Disconnect the intake manifold pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the intake manifold pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return connectors (pin B) into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the intake manifold pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the intake manifold pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the intake manifold pressure signal voltage.

Conditions

  • Disconnect the intake manifold pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the intake manifold pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return connectors (pin B) into the multimeter.
OK NOT OK

For QSK19 or QSK23: 0.42 to 0.58-VDC; For QSK45, QSK60, or QSK78: at sea level, 1.23 to 1.48-VDC?, for higher altitudes, use the tables in Shop Talk to determine the correct pressure and corresponding voltage

Does not meet specification.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 35 of the engine harness ECM connector to all other pins in the connector.

Use general measurement techniques to measure resistance. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the ECM engine harness ECM connector to pin A of the intake manifold pressure sensor harness connector.
  • Measure the resistance from pin 35 of the ECM engine harness ECM connector to pin C of the intake manifold pressure sensor harness connector.
  • Measure the resistance from pin 17 of the ECM engine harness ECM connector to pin B of the intake manifold pressure sensor harness connector.

Use general measurement techniques to measure resistance. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 35 to pin 6 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 inactive; Fault Code 122 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to return pin in the ECM port.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to return pin in the ECM port.

  • Measure the resistance from pin 35 (signal) to pin 17 (return) of the ECM engine harness connector port.

Use general measurement techniques to measure resistance. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 35k ohms?

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Less than 35k ohms?

  • Replace the ECM.Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use general inspection techniques to inspect the connectors. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit in the signal and +5-VDC supply wires.

  • Measure the resistance from pin 35 of the engine harness ECM connector to pin C (signal) of the intake manifold pressure sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A (+5-VDC supply) of the intake manifold pressure sensor harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit from signal, return, and +5-VDC supply wires to engine block ground.

  • Measure the resistance from pin 35 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 6 of the engine harness ECM connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from signal, return, +5-VDC supply wires, and all other wires in the engine harness connector.

  • Measure the resistance from pin 35 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 35 to pin 6 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 inactive; Fault Code 122 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 123 is inactive.
OK NOT OK

Fault Code 123 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 127 - Intake Manifold Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK78 | 3666727
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK23 | 4021375
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK45 and QSK60 | 4021530
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK19 and QSK19 CM850 | 4021592
Air Intake Restriction | Refer to Procedure 010-031 | QSK78 | 3666727
Air Intake Restriction | Refer to Procedure 010-031 | QSK23 | 4021375
Air Intake Restriction | Refer to Procedure 010-031 | QSK45 and QSK60 | 4021530
Air Intake Restriction | Refer to Procedure 010-031 | QSK19 and QSK19 CM850 | 4021592
Turbocharger | Refer to Procedure 010-033 | QSK78 | 3666727
Turbocharger | Refer to Procedure 010-033 | QSK23 | 4021375
Turbocharger | Refer to Procedure 010-033 | QSK45 and QSK60 | 4021530
Turbocharger | Refer to Procedure 010-033 | QSK19 and QSK19 CM850 | 4021592

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the air intake system. |
 | STEP 1A. Check air intake restriction. | Air intake restriction within specification?
 | STEP 1B. Check for leaks in the air intake system. | Leaks found in air intake system?
 | STEP 1C. Check the turbocharger. | Turbocharger functioning properly?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 127 inactive?
 | STEP 2B. Clear the inactive fault codes. | Fault codes cleared?

Guided Step 1 - Check the air intake system.

Guided Step 1A - Check air intake restriction

Conditions

  • Turn keyswitch OFF.
  • Install a vacuum gauge or water manometer in the air intake piping.

Action

Install a vacuum gauge into the air intake system.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO

Air intake restriction is within specification.

Clean or replace the air filter element. See equipment manufacturer service information.

Go to 1B

Go to 2A

Guided Step 1B - Check for leaks in the air intake system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air intake system for air leaks.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Check all air compressor plumbing, intake plumbing, aftercooler, and gaskets for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leaks found in air intake system?
YES NO

Repair or replace the air intake component causing the air leak. See equipment manufacturer service information.

 No Repair

Go to 2A

1C

Guided Step 1C - Check the turbocharger.

Conditions

  • Turn engine OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Check the following:

  • Check compressor wheel retaining nut for signs of dust ingestion.
  • Check the turbocharger compressor and turbine blades for damage or wear.
  • Measure the radial and axial clearance of the turbocharger wheel. Refer to Procedure 010-033 in the Associated Procedures Table.

Turbocharger functioning properly?
YES NO
No Repair

  • Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.
  • Check the air filter and air intake system for leaks allowing dirt and dust to enter the turbocharger.

Go to 2A

Go to 2A

Guided Step 2 - Clear fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Start the engine and let it idle for 1 minute.

  • Verify that Fault Code 127 is inactive.

Fault Code 127 inactive?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Apr-2017


FAULT CODE 131 - Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal or lever position sensor. |
 | STEP 1A. Inspect the OEM harness and accelerator pedal or lever position sensor connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 1C. Check for a short circuit from pin to pin. | Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM interface harness and OEM harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Verify that Fault Code 131 is still active. | Fault Code 131 active
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 131 inactive; Fault Code 132 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 131 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal or lever position sensor.

Guided Step 1A - Inspect the OEM harness and accelerator pedal or lever position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Inspect the OEM harness and accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or lever, or repair or replace the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.
  • Repair the OEM harness. Refer to the OEM manual.
  • Replace the OEM harness. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 1B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the accelerator pedal or lever position sensor to pin C of the accelerator pedal or lever position sensor.

Measure the resistance when the pedal is released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 1C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the accelerator pedal or lever position sensor to pin C of the accelerator pedal or lever position sensor.

Measure the resistance when the pedal is depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms. Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM interface harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Connect the OEM harness to the accelerator pedal or lever.

Action

Check for an open circuit.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector to pin 6 of the OEM harness 31-pin connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector to all other pins in the OEM harness 31-pin and 21-pin connectors.
  • Measure the resistance from pin 5 of the OEM harness 31-pin connector to all other pins in the OEM harness 31-pin and 21-pin connectors.
  • Measure the resistance from pin 6 of the OEM harness 31-pin connector to all other pins in the OEM harness 31-pin and 21-pin connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2D

Go to 5A

Guided Step 2D - Verify that Fault Code 131 is still active.

Conditions

  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Turn keyswitch ON.

Action

Verify that Fault Code 131 is still active.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 131 active

Remove the external voltage source

  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM interface harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 of the OEM interface harness ECM connector to pin 6 of the OEM interface harness 31-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Use the following procedures. Refer to Procedure 019-208 in Section 19.Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 26 of the OEM interface harness ECM connector to all other pins in the OEM interface harness ECM connector.
  • Measure the resistance from pin 29 of the OEM interface harness ECM connector to all other pins in the OEM interface harness ECM connector.
  • Measure the resistance from pin 11 of the OEM interface harness ECM connector to all other pins in the OEM interface harness ECM connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness from the accelerator pedal or lever.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 131 inactive; Fault Code 132 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 131 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 132 - Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal or lever position sensor. |
 | STEP 1A. Verify that the accelerator pedal or lever position sensor is connected to the OEM harness. | Accelerator pedal or lever position sensor connected
 | STEP 1B. Inspect the OEM harness and accelerator pedal or lever position sensor connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal or lever position sensor.

Guided Step 1A - Verify that the accelerator pedal or lever position sensor is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the accelerator pedal or lever position sensor is connected to the OEM harness.

Verify that the accelerator pedal or lever position sensor is connected to the OEM harness.
OK NOT OK

Accelerator pedal or lever position sensor connected

Connect the accelerator pedal or lever position sensor. Connect the accelerator pedal or lever position sensor to the OEM harness connector.

Go to 1B

Go to 4A

Guided Step 1B - Inspect OEM harness and accelerator pedal or lever position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Inspect the OEM harness and accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the accelerator pedal or lever, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM manual.
  • Replace the OEM harness. Refer to the OEM manual.
  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

1C

4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin C of the accelerator pedal or lever position sensor.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 1D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the accelerator pedal or lever position sensor to pin C of the accelerator pedal or lever position sensor.

Measure when the pedal or lever is depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19..

2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Connect the accelerator pedal or lever to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector to pin 6 of the OEM harness 31-pin connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from the OEM harness 31-pin connector to engine block ground.

  • Measure the resistance from pin 5 of the OEM harness 31-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin and 21-pin connectors.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector to all other pins in the OEM harness 31-pin and 21-pin connectors.
  • Measure the resistance from pin 5 of the OEM harness 31-pin connector to all other pins in the OEM harness 31-pin and 21-pin connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 26 of the OEM interface harness ECM connector to pin 4 of the OEM interface harness 31-pin connector.
  • Measure the resistance from pin 29 of the OEM interface harness ECM connector to pin 5 of the OEM interface harness 31-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in section 19.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin and 21-pin connectors.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 26 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 29 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin and 21-pin connectors.
  • Disconnect the OEM interface harness from the ECM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 26 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 29 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 132 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 133 - Remote Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote accelerator pedal or lever position sensor. |
 | STEP 1A. Inspect the OEM harness and remote accelerator pedal or lever position sensor connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 1C. Check for a short circuit from pin to pin. | Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM interface harness and OEM harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Verify that Fault Code 133 is still active. | Fault Code 133 active
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 133 active; Fault Code 134 inactive
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 133 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the remote accelerator pedal or lever position sensor.

Guided Step 1A - Inspect the OEM harness and remote accelerator pedal or lever position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator pedal or lever.

Action

Inspect the OEM harness and remote accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or lever or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in section 19.

Go to 1B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the accelerator pedal or lever position sensor to pin C of the accelerator pedal or lever position sensor.

Measure the resistance when the pedal is released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 1C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823255 - female Metri-Pack™ test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the accelerator pedal or lever position sensor to pin C of the accelerator pedal or lever position sensor.

Measure the resistance when the accelerator pedal or lever is depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM interface harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.

Action

Inspect the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 insection 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823993 - male Deutsch™ test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the OEM harness to the accelerator pedal or lever.

Action

Check for an open circuit.

  • Measure the resistance from pin X of the OEM harness 21-pin connector to pin P of the OEM harness 21-pin connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin X of the OEM harness 21-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
  • Measure the resistance from pin N of the OEM harness 21-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
  • Measure the resistance from pin P of the OEM harness 21-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Verify that Fault Code 131 is still active.

Conditions

  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Turn keyswitch ON.

Action

Verify that Fault Code 133 is still active.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 133 active

Remove the external voltage source. Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM interface harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 of the OEM interface harness ECM connector to pin X of the OEM interface harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 21 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 30 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness from the remote accelerator pedal or lever.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 133 inactive; Fault Code 134 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 133 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 18-Apr-2012


FAULT CODE 134 - Remote Accelerator Position Sensor: CELECT™-Type Accelerator Pedal or Lever

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote accelerator pedal or lever position sensor. |
 | STEP 1A. Verify that the remote accelerator pedal or lever position sensor is connected to the OEM harness. | Remote accelerator pedal or lever position sensor connected
 | STEP 1B. Inspect the OEM harness and accelerator pedal or lever position sensor connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the remote accelerator pedal or lever position sensor.

Guided Step 1A - Verify that the remote accelerator pedal or lever position sensor is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the remote accelerator pedal or lever position sensor is connected to the OEM harness.

Verify that the remote accelerator peday or lever position sensor is connected to the OEM harness.
OK NOT OK

Remote accelerator pedal or lever position sensor connected

Connect the remote accelerator pedal or lever position sensor. .Connect the remote accelerator pedal or lever position sensor to the OEM harness connector.

Go to 1B

Go to 4A

Guided Step 1B - Inspect OEM harness and remote accelerator pedal or lever position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Inspect the OEM harness and remote accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the accelerator pedal or lever, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM manual.
  • Replace the OEM harness. Refer to the OEM manual.
  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel 3 times. This procedure calibrates the new accelerator pedal or lever with the ECM.

1C

Go to 4A

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin C of the accelerator pedal or lever position sensor.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel 3 times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the accelerator pedal or lever position sensor to pin C of the accelerator pedal or lever position sensor.

Measure when the pedal is depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.
  • Repair the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or position sensor is changed, or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel 3 times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.Replace the OEM harness. Refer to Procedure 019-072 in Section 19..

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the accelerator pedal or lever to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin X of the OEM harness 21-pin connector to pin P of the OEM harness 21-pin connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from the OEM harness 21-pin connector to engine block ground.

  • Measure the resistance from pin N of the OEM harness 21-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin and 21-pin connectors.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin P of the OEM harness 21-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
  • Measure the resistance from pin N of the OEM harness 21-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-072 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to pin P of the OEM interface harness 21-pin connector.
  • Measure the resistance from pin 30 of the OEM interface harness ECM connector to pin N of the OEM interface harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin and 21-pin connectors.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 30 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness.

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin and 21-pin connectors.
  • Disconnect the OEM interface harness from the ECM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 30 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness.

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 134 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 18-Apr-2012


FAULT CODE 135 - Engine Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824775 - Packard™ breakout cable, and Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 144, 153, 221, 231, 263, and 719 are not active?
 | STEP 1B. Read the fault codes. | Fault Codes 122, 144, 153, and 221 are not active?
STEP 2. | Check the engine oil pressure sensor. |
 | STEP 2A. Inspect the engine oil pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 135 active?
 | STEP 2C. Check the engine oil pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the engine oil pressure supply voltage. |
 | STEP 2D. Check the oil pressure signal voltage. | 0.42 to 0.58-VDC engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 135 active?
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3D. Check for an open circuit in the return wire. | Less than 10 ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 135 inactive; Fault Code 141 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 144, 153, 221, 231, 263, and 719 are not active?

Go to 1B

Multiple fault code tree

Guided Step 1B - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 144, 153, and 221 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the engine oil pressure sensor.

Guided Step 2A - Inspect the engine oil pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine oil pressure sensor.

Action

Inspect the oil pressure sensor connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the engine oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the oil pressure supply voltage.

Conditions

  • Disconnect the engine oil pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the sensor harness connector
  • Turn keyswitch ON.

Action

Check the oil pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the oil pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the oil pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the oil pressure signal voltage.

Conditions

  • Disconnect the engine oil pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the sensor harness connector
  • Turn keyswitch ON.

Action

Check the oil pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specifications.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the engine oil pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 24 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the intake manifold pressure sensor harness connector.
  • Measure the resistance from pin 24 of the engine harness ECM connector to pin C of the intake manifold pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the intake manifold pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Use the bench calibration parent cable, Part Number 3163151 and the CM500 adapter harness, Part Number 4918142, to connect to the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 inactive; Fault Code 141 active?

Fault Code 135 active.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 24 (signal) to pin 6 (supply) of the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the engine oil pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 24 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the return wire.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the engine oil pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from pin 17 of the engine harness connector to pin B of the engine oil pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 inactive; Fault Code 141 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 135 is inactive.
OK NOT OK

Fault Code 135 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 11-May-2012


FAULT CODE 141 - Engine Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824775 - Packard™ breakout cable, and Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 222, 232, and 729 are not active?
 | STEP 1B. Read the fault codes. | Fault Codes 123, and 222 are not active?
STEP 2. | Check the engine oil pressure sensor. |
 | STEP 2A. Inspect the engine oil pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 141 active?
 | STEP 2C. Check the engine oil pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the engine oil pressure supply voltage. |
 | STEP 2D. Check the oil pressure signal voltage. | 0.42 to 0.58-VDC engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 141 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 141 inactive; Fault Code 135 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 222, 232, and 729 are not active?

Go to 1B

Multiple fault code tree

Guided Step 1B - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 145, 154, and 265 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the engine oil pressure sensor.

Guided Step 2A - Inspect the engine oil pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine oil pressure sensor.

Action

Inspect the oil pressure sensor connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the engine oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the oil pressure supply voltage.

Conditions

  • Disconnect the engine oil pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the sensor harness connector
  • Turn keyswitch ON.

Action

Check the oil pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the oil pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the oil pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the oil pressure signal voltage.

Conditions

  • Disconnect the engine oil pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the sensor harness connector
  • Turn keyswitch ON.

Action

Check the oil pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specifications.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the engine oil pressure sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 24 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the oil pressure sensor harness connector.
  • Measure the resistance from pin 24 of the engine harness ECM connector to pin C of the oil pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the oil pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Use the bench calibration parent cable, Part Number 3163151 and the CM500 adapter harness, Part Number 4918142, to connect to the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 inactive; Fault Code 135 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to return pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 24 (signal) to pin 17 (return) of the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the engine oil pressure sensor.

Action

Check for an open circuit in the oil pressure signal and +5-VDC SUPPLY wire.

  • Measure the resistance from pin 24 of the engine harness ECM connector to pin C (signal) of the oil pressure sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A (supply) of the oil pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the engine oil pressure sensor.

Action

Check for a short circuit from the signal, return, and +5-VDC supply wires to engine block ground.

  • Measure the resistance from pin 24 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 6 of the engine harness ECM connector to engine block ground.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the engine oil pressure sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for a short circuit from the signal, return, and +5-VDC supply wires to all other wires in the engine harness connector.

  • Measure the resistance from pin 24 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 inactive; Fault Code 135 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 141 is inactive.
OK NOT OK

Fault Code 141 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 18-Apr-2012


FAULT CODE 143 - Oil Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct.
STEP 2. | Check the oil level in the oil pan. |
 | STEP 2A. Check the oil level. | Oil level is correct.
 | STEP 2B. Check for external oil leaks. | No oil leaks evident.
STEP 3. | Check if the oil filters are plugged. |
 | STEP 3A. Measure the oil pressure differential across the filters. | Oil filter head pressure differential is within specification.
STEP 4. | Check the oil. |
 | STEP 4A. Confirm the correct lubricating oil was used. | Lubricating oil meets specifications.
 | STEP 4B. Check for fuel and coolant dilution. | Lubricating oil is not contaminated with coolant or fuel.
 | STEP 4C. Check for oil aeration. | Oil aeration levels acceptable.
 | STEP 4D. Check for high oil temperatures. | Oil temperature within specification.
STEP 5. | Check for loss of pressure before sensor. |
 | STEP 5A. Check the main oil rifle pressure regulator. | Main oil rifle pressure regulator is not broken or worn.
 | STEP 5B. Check the piston cooling nozzle. | Piston cooling nozzle meets specifications.
STEP 6. | Inspect the lubricating pump, lubricating pump plumbing, and high pressure relief valve. |
 | STEP 6A. Check the lubricating oil suction tube. | Lubricating oil suction tube meets specifications.
 | STEP 6B. Check the lubricating oil suction tube for blockage. | Lubricating oil suction tube meets specifications.
 | STEP 6C. Check the oil transfer plumbing. | Oil transfer plumbing meets specifications.
 | STEP 6D. Check the oil pump. | Oil pump meets specifications.
 | STEP 6E. Check the lubricating pump high pressure regulator. | Lubricating pump high pressure relief valve meets specifications.
STEP 7. | Check for system restriction. |
 | STEP 7A. Check the piston cooling nozzle pressure regulators. | Piston cooling nozzles pressure regulator meets specifications.
 | STEP 7B. Inspect engine for internal damage. | No internal engine damage found.
 | STEP 7C. Check the engine bearings and bushings for excessive clearances. | Main bearing, rod bearing, and camshaft bushing clearances meet specifications.
 | STEP 7D. Check the oil coolers for blockage. | Oil cooler element meets specifications.
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 143 inactive.
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ electronic service tool to the vehicle datalink.
  • Start the engine and compare the oil pressure reading on the INSITE™ electronic service tool monitor screen to the reading on the mechanical oil pressure gauge.

If the oil pressure sensor and the mechanical gauge readings are zero within 3 seconds after the engine is started, the engine should be turned off immediately to prevent extended damage.

OK NOT OK

Sensor reading is correct.

Replace the sensors.

Go to 2A

Go to 8A

Guided Step 2 - Check the oil level in the oil pan.

Guided Step 2A - Check the oil level.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil level.
OK NOT OK

Oil level is correct.

Fill the system to the specified level.

Verify oil pan capacity and dipstick calibration.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-009 in Section 7.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-025 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-009 in Section 7.Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-009 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-009 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-025 in Section 7.

Go to 2B

Go to 8A

Guided Step 2B - Check for external oil leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine for external oil leaks.
OK NOT OK

No oil leaks evident.

External leaks found.

Tighten capscrews, pipe plugs, and fittings.

Replace the gaskets, if necessary. Reference Section V in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 3A

Go to 8A

Guided Step 3 - Check if the oil filters are plugged.

Guided Step 3A - Measure the oil pressure differential across the filters.

Conditions

  • Turn keyswitch ON.

Action

Verify oil filter head pressure differential.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-013 in Section 7.

Oil filter head pressure differential is within specification.
YES | NO
No Repair | No Repair

Go to 4A

Go to 8A

Guided Step 4 - Check the oil.

Guided Step 4A - Confirm the correct lubrication oil was used.

Conditions

  • Turn keyswitch OFF.

Action

Verify the lubricating oil meets specification for operating conditions.

Reference the Cummins® Engine Oil Recommendations, Bulletin 3810340.
OK NOT OK

Lubricating oil meets specifications.

Lubricating oil does not meet specifications.

Change oil and filters.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-013 in Section 7..

Use the recommended oil type specified in Cummins® Engine Oil Recommendations, Bulletin 3810340.

Go to 4B

Go to 8A

Guided Step 4B - Check for fuel and coolant dilution.

Conditions

  • Turn keyswitch OFF.

Action

Verify if oil is contaminated with coolant or fuel.

  • Cut one filter to inspect for debris or if equipped with an eliminator, open and inspect for debris.
  • Reference the Cummins® Engine Oil Recommendations, Bulletin 3810340.

Lubricating oil is not contaminated with coolant or fuel.

YES | NO
No Repair | No Repair

Go to 4C

Go to 8A

Guided Step 4C - Check for oil aeration.

Conditions

Turn keyswitch OFF.

Action

Verify oil aeration/foaming is acceptable.
OK NOT OK

Lubrication oil aeration level meets specifications. High oil aeration will cause a temporary increase in the engine oil level.

Lubrication oil aeration level does not meet specifications. High oil aeration will cause a temporary increase in the engine oil level.

Check engine oil level and engine angularity.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-013 in Section 7..

For angularity, see Application Engineering Bulletin AEB 46.02.

Go to 4D

Go to 8A

Guided Step 4D - Check for high oil temperatures.

Conditions

  • Turn keyswitch OFF.

Action

Verify lubricating oil operating temperature meets the specification for the operating conditions.

Reference Section V in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

OK NOT OK

Lubricating oil meets temperature specifications.

Lubricating oil does not meet temperature specifications.

Reference the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727 for diagnosing high oil temperature issues.

Go to 5A

Go to 8A

Guided Step 5 - Check for loss of pressure before sensor.

Guided Step 5A - Check the main oil rifle pressure regulator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the spring, housing plugs, and o-rings for damage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 402153. Refer to Procedure 007-029 in Section 7.

Use the following procedue in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-029 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-029 in Section 7.

OK NOT OK

Main oil rifle pressure regulator is not broken or worn.

Main oil rifle pressure regulator does not meet specifications.

Replace necessary parts. Reference the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 5B

Go to 8A

Guided Step 5B - Check the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

Do not remove the nozzle at this time as it can not be reused.

OK NOT OK

Piston cooling nozzle meets specifications.

Piston cooling nozzle does not meet specifications.

Replace necessary parts. Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 001-046 in Section 1.

Use the following procedue in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 001-046 in Section 1.

Use following procedue in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 001-046 in Section 1.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-046 in Section 1.

Go to 6A

Go to 8A

Guided Step 6 - Inspect the lubricating pump, lubricating pump plumbing, and high pressure relief valve.

Guided Step 6A - Check the lubricating oil suction tube.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the lubricating oil suction tube for damage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-046 in Section 1.

OK NOT OK

Lubricating oil suction tube meets specifications.

Lubricating oil suction tube does not meet specifications.

Replace necessary parts.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-046 in Section 1.

Go to 6B

Go to 8A

Guided Step 6B - Check the lubricating oil suction tube for blockage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the lubricating oil suction tube for blockage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-046 in Section 1.

OK NOT OK

Lubricating oil suction tube meets specifications.

Lubricating oil suction tube does not meet specifications.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedue in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-046 in Section 1.

Go to 6C

Go to 8A

Guided Step 6C - Check the oil transfer plumbing.

Conditions

  • Turn keyswitch OFF.

Action

Verify the oil transfer plumbing is not cracked and the o-rings and gaskets are not leaking.

007-040 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

OK NOT OK

Oil transfer plumbing meets specifications.

Oil transfer plumbing does not meet specifications.

Replace necessary parts. Reference the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 6D

Go to 8A

Guided Step 6D - Check the oil pump.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the oil pump for damage or wear.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-031 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-031 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-031 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-031 in Section 7.

OK NOT OK

Oil pump meets specifications.

Oil pump does not meet specifications.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-031 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-031 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-031 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-031 in Section 7.

Go to 6E

Go to 8A

Guided Step 6E - Check the lubricating pump high pressure regulator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the lubricating pump high pressure regulator for damage.

Reference the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

OK NOT OK

Lubricating pump high pressure relief valve meets specifications.

Lubricating pump high pressure relief valve does not meet specifications.

Replace necessary parts. Reference Section 7 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 7A

Go to 8A

Guided Step 7 - Check for system restriction.

Guided Step 7A - Check the piston cooling nozzle pressure regulators.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the piston cooling nozzle pressure regulator for damage.

Reference Section 7 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

OK NOT OK

Piston cooling nozzles pressure regulator meets specifications.

Piston cooling nozzle pressure regulator does not meet specifications.

Replace necessary parts. Reference Section 7 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 7B

Go to 8A

Guided Step 7B - Inspect engine for internal damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine for internal damage.

Reference Section 7 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

OK NOT OK

No internal engine damage found.

Internal damage found on block.

Repair the damage. Reference Section 7 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 7C

Go to 8A

Guided Step 7C - Check the engine bearings and bushings for excessive clearances.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the main and rod bearings and camshaft bushings for excessive clearance.

Reference Section 1 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

OK NOT OK

Main bearing, rod bearing, and camshaft bushing clearances meet specifications.

Main bearing, rod bearing, and camshaft bushing clearances do not meet specifications.

Replace necessary parts. Reference Section 1 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 7D

Go to 8A

Guided Step 7D - Check the oil coolers for blockage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the oil cooler element for blockage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-007 in Section 7.

Use the following prcedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-007 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-007 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-007 in Section 7.

OK NOT OK

Oil cooler element meets specifications.

Oil cooler element does not meet specifications.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-007 in Section 7.

Use the following prcedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-007 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-007 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-007 in Section 7.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

If the fault occurred at a particular speed, run the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 143 inactive.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 144 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823256 - Metri-Pack™ two-way connector test lead. Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 300 ohms to 36k ohms?
STEP 3. | Check the ECM and engine control harness. |
 | STEP 3A. Inspect the ECM and engine control harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine control harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine control harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code, Refer to Procedure 019-362 in Section 19..

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine control harness.

Action

Inspect the engine control harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19..

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19..

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine control harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature SIGNAL pin and engine coolant temperature RETURN pin at the engine coolant temperature sensor connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

300 ohms to 36k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine control harness.

Guided Step 3A - Inspect the ECM and engine control harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine control harness from the engine control module A connector.

Action

Inspect the engine control harness and engine control module A connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damagede connection has been detected in the engine control module or engine control harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine control harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine control harness from the engine control module A connector.
  • Disconnect the coolant temperature sensor from the engine control harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine control harness, the engine control module A connector, the engine coolant temperature SUPPLY pin and the engine control harness coolant temperature sensor connector engine coolant temperature SUPPLY pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Refer to the wiring diagram or circuit diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine control harness.

Troubleshoot each harness connected in series to determine which contains the open supply circuit.

Repair or replace the engine control harness.

Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine control harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine control harness from the engine control module A connector.
  • Disconnect the coolant temperature sensor from the engine control harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine control harness, the engine control module A connector engine coolant temperature SIGNAL pin and the engine control harness coolant temperature sensor connector engine coolant temperature SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine control harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the engine control harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine control harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine control harness from the engine control module A connector.
  • Disconnect the engine coolant temperature sensor from the engine control harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine control harness engine control module A connector and all other pins in the A and B connectors.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine control harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine control harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Apr-2012


Coolant Temperature Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823256 - Metri-Pack two-way connector test lead.Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine control harness. |
 | STEP 3A. Inspect the ECM and engine control harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine control harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code, Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine control harness.

Action

Inspect the engine control harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine control harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine control harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor.

Refer to Procedure 019-019 in Section 19.

None. The removal and reinstallation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine control harness.

Guided Step 3A - Inspect the ECM and engine control harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine control harness from the engine control module A connector.

Action

Inspect the engine control harness and engine control module A connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module or engine control harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine control harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine control harness from the engine control module A connector.
  • Disconnect the engine coolant temperature sensor from the engine control harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine control harness engine control module A connector and all other pins in the A and B connectors.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine control harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine control harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OF.
  • Disconnect the engine control harness from the engine control module A connector.
  • Disconnect the coolant temperature sensor from the engine control harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin and the engine control harness engine control module a connector and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine control harness.

Troubleshoot each harness connected in series to determine which contains the open supply circuit.

Repair or replace the engine control harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Apr-2012


FAULT CODE 147 - Frequency Accelerator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM interface harness. |
 | STEP 2A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for OEM device(s) frequency signal supply. | Correct OEM frequency signal
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 147 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the frequency accelerator to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin L to pin M of the OEM harness connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin L of the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to all other pins in the connector except pin M.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM interface harness.

Guided Step 2A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to pin L of the OEM interface harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the OEM devices for frequency signal supply.

Conditions

  • Turn keyswitch ON.

Action

Check the frequency signal of the OEM device(s).

Refer to the OEM service manual.
OK NOT OK

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM device. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 147 is inactive.
OK NOT OK

Fault Code 147 inactive

Return to the troubleshooting steps or a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 148 - Frequency Accelerator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM interface harness. |
 | STEP 2A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for OEM device(s) frequency signal supply. | Correct OEM frequency signal
STEP 3. | Check for the ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 148 is inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 148 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the frequency accelerator from the OEM harness at the 21-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to pin A of the accelerator frequency connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the frequency accelerator to the OEM harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the frequency accelerator to the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM interface harness.

Guided Step 2A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to pin L of the OEM interface harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check the OEM devices for frequency signal supply.

Conditions

  • Turn keyswitch ON.

Action

Check the frequency signal of the OEM device(s).

Refer to the OEM servicce manual.
OK NOT OK

Replace the ECM. Refer to Procedure 019-031 in Sectopm 19.

Repair or replace the OEM device. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM interface harness from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 148 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 148 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 151 - Coolant Temperature - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 151 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, then answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 145

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault code has gone inactive.
OK NOT OK

Fault Code 151 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 153 - Intake Manifold Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 221, 231, 263, and 719 are not active
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 153 active
 | STEP 2C. Check the resistance of the intake manifold temperature sensor. | 600 ohms to 36k ohms. Refer to the temperature and resistance table under Shop Talk for correct value
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 153 inactive; Fault Code 154 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 153 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 221, 231, 263, and 719 are not active

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 153 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the two pins on the sensor side of the intake manifold temperature sensor connector.
OK NOT OK

600 ohms to 36k ohms. Reference the temperature/resistance table under Shop Talk for correct value.

Replace the intake manifold temperature sensor.. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Sectio 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the intake manifold temperature sensor connector, engine harness side.
  • Measure the resistance from pin 23 of the engine harness ECM connector to pin A of the intake manifold temperature sensor connector, engine harness side.
OK NOT OK

Less than 10 ohms

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202.
  • Refer to Procedure 019-204 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 23 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 153 inactive; Fault Code 154 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 153 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 153 - Intake Manifold Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 222, 232, 265, and 729 are not active
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 154 active
 | STEP 2C. Check the resistance of the intake manifold temperature sensor. | 600 to 36k ohms. Refer to the temperature/resistance table under Shop Talk for correct value
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 154 inactive; Fault Code 153 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 154 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 145, 222, 232, 265, and 729 are not active

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 154 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the two pins on the sensor side of the intake manifold temperature sensor connector.
OK NOT OK

600 to 36k ohms. Reference the temperature and resistance table under Shop Talk for correct value

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2D

Go to

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from either pin A or B on the sensor side of the intake manifold temperature sensor connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin to pin

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 23 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance from pin 17 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 23 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms. Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 23 to pin 6 of the ECM engine harness connector port.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 154 inactive; Fault Code 153 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 154 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 155 - Intake Manifold Temperature Sensor - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct?
STEP 2. | Check the operation of the thermostat. |
 | STEP 2A. Verify that the thermostat opens and closes within guideline temperatures. | Thermostat operation normal?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disasble the fault code. | Fault Code 155 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Connect a temperature probe of known quality and accuracy to the engine near the intake manifold temperature sensor.

The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the vehicle datalink.
  • Compare the intake manifold temperature sensor reading on the service tool monitor screen to the reading from temperature probe.

If no temperature measuring device is available, answer "Yes" to this step.

Sensor reading correct?
YES | NO
No Repair | No Repair

Go to 2A

Fault Code 154

Guided Step 2 - Check the operation of the thermostat.

Guided Step 2A - Verify that the thermostat opens and closes within guideline temperatures.

Conditions

  • Turn keyswitch OFF.

Action

Check for correct operation of the thermostat.

  • Use the following procedure in the Service Manual, QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS in Bulletin Number 4021592. Refer to Procedure 008-013 in Section 8.

Note: Test the LTA thermostat.

Thermostat operation normal?
YES NO
No Repair

Replace the thermostat. Use the following procedure in the Service Manual, QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS in Bulletin Number 4021592. Refer to Procedure 008-013 in Section 8.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Start the engine and allow it to warm up to normal operating temperature to verify that the fault code has gone inactive.

Fault Code 155 inactive?
YES NO
No Repair

Return to the troubleshooting steps. Use the Intake Manifold Air Temperature Above Specification Symptom Tree, in Section TS in Service Manual, QSK19,QSK19 CM850 MCRS, QSK19 CM2150 MCRS, Bulletin 4021592 or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 219 - Make-Up Tank Oil Level Low Fault

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking ameasurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the make-up tank oil level low sensor. |
 | STEP 1A. Inspect the make-up tank oil level low sensor and OEM harness connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
STEP 2. | Check the OEM interface harness. |
 | STEP 2A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 219 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the make-up tank oil level low sensor.

Guided Step 1A - Inspect the make-up tank oil level low sensor and OEM harness connector pins.

Conditions

  • Make-up oil tank is full.
  • Turn keyswitch OFF.
  • Disconnect the make-up tank oil level low sensor from the OEM harness.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the make-up tank oil level low sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the make-up tank oil level low sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the make-up tank oil level low sensor. Refer to Procedure 019-056 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Make-up oil tank is full.
  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness at the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 23 of the 31-pin OEM harness connector, OEM harness side, to engine block ground, while the sensor is covered with oil.
OK NOT OK

Less than 10 ohms

Replace the make-up tank oil level low sensor. Refer to Procedure 019-056 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM interface harness.

Guided Step 2A - Inspect the OEM interface harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the make-up oil tank sensor from the OEM interface harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 28 of the OEM interface harness ECM connector to engine block ground, while the sensor is covered with oil.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the make-up tank oil level low sensor.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 28 of the OEM interface harness ECM connector to all other pins in the connector, except pins 11 and 21.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 219 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 221 - Ambient Air Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - breakout cable

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 231, 263, and 719 are not active?
 | STEP 1B. Read the fault codes. | Fault Codes 122, 135, 144, and 153 are not active?
STEP 2. | Check the ambient air pressure sensor. |
 | STEP 2A. Inspect the ambient air pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 221 active?
 | STEP 2C. Check the ambient air pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the ambient air pressure supply voltage. |
 | STEP 2D. Check the ECM ambient air pressure signal voltage. | Altitude (feet) - Voltage, 0 (sea level) - 4.00 to 4.58, 3000 - 3.60 to 4.40, 6000 - 3.20 to 4.00, 9000 - 3.00 to 3.80, 12,000 - 2.60 to 3.40. 018-028 (Barometric Pressure at Altitude) in Section V.
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 221 active?
 | STEP 3C. Check for an open circuit. | Less than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 10 ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 221 inactive; Fault Code 222 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 231, 263, and 719 are not active?

Go to 1B

Multiple fault code tree

Guided Step 1B - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, and 153 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the ambient air pressure sensor.

Guided Step 2A - Inspect the ambient air pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ambient air pressure sensor.

Action

Inspect the ambient air pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ambient air pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the ambient air pressure supply voltage.

Conditions

  • Disconnect the ambient air pressure sensor from the engine harness
  • Install the pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector
  • Turn keyswitch ON.

Action

Check the ambient air pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ECM ambient air pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the ambient air pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the ECM ambient air pressure signal voltage.

Conditions

  • Disconnect the ambient air pressure sensor from the engine harness
  • Install the pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin C) connectors into the multimeter.
OK NOT OK

Altitude (feet) - Voltage, 0 (sea level) - 4.00 to 4.58, 3000 - 3.60 to 4.40, 6000 - 3.20 to 4.00, 9000 - 3.00 to 3.80, 12,000 - 2.60 to 3.40. Refer to Procedure 018-028 in Section V.

Does not meet specifications.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the coolant level sensor or disconnect the shorting plug.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 34 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the ambient air pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the ambient air pressure sensor harness connector.
  • Measure the resistance from pin 34 of the engine harness ECM connector to pin C of the ambient air pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the ambient air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 inactive; Fault Code 222 active?

Fault Code 221 active.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 34 (signal) to pin 6 (supply) of the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness connector to pin B of the ambient air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 34 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 221 inactive; Fault Code 222 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 221 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 222 - Ambient Air Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - breakout cable

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 232, 265, 477, and 729 are not active?
 | STEP 1B. Read the fault codes. | Fault Codes 123, and 141 are not active?
STEP 2. | Check the ambient air pressure sensor. |
 | STEP 2A. Inspect the ambient air pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 222 active?
 | STEP 2C. Check the ambient air pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the ambient air pressure supply voltage. |
 | STEP 2D. Check the ECM ambient air pressure signal voltage. | Altitude (feet) - Voltage, 0 (sea level) - 4.00 to 4.58, 3000 - 3.60 to 4.40, 6000 - 3.20 to 4.00, 9000 - 3.00 to 3.80, 12,000 - 2.60 to 3.40. 018-028 (Barometric Pressure at Altitude) in Section V.
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check for the appropriate ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 222 active?
 | STEP 3C. Check for an open circuit. | Less than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 10 ohms?
 | STEP 3E. Check for a short circuit to the engine block ground. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 222 inactive; Fault Code 221 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 232, 265, 477, and 729 are not active?

Go to 1B

Multiple fault code tree

Guided Step 1B - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, and 141 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the ambient air pressure sensor.

Guided Step 2A - Inspect the ambient air pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ambient air pressure sensor.

Action

Inspect the ambient air pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ambient air pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the ambient air pressure supply voltage.

Conditions

  • Disconnect the ambient air pressure sensor from the engine harness
  • Install the pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector
  • Turn keyswitch ON.

Action

Check the ambient air pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ECM ambient air pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the ambient air pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the ECM ambient air pressure signal voltage.

Conditions

  • Disconnect the ambient air pressure sensor from the engine harness
  • Install the pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin C) connectors into the multimeter.
OK NOT OK

Altitude (feet) - Voltage, 0 (sea level) - 4.00 to 4.58, 3000 - 3.60 to 4.40, 6000 - 3.20 to 4.00, 9000 - 3.00 to 3.80, 12,000 - 2.60 to 3.40. Refer to Procedure 018-028 in Section V.

Does not meet specifications.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the coolant level sensor, or disconnect the shorting plug.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 34 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the ambient air pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the ambient air pressure sensor harness connector.
  • Measure the resistance from pin 34 of the engine harness ECM connector to pin C of the ambient air pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the ambient air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 34 to pin 6 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive; Fault Code 221 active?

Fault Code 222 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to return pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to return pin in the ECM port.

  • Measure the resistance from pin 34 (signal) to pin 17 (return) of the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 6 of the engine harness connector to pin A of the ambient air pressure sensor harness connector.
  • Measure the resistance from pin 34 of the engine harness connector to pin C of the ambient air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 34 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to the engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor.

Action

Check for a short circuit the the engine ground.

  • Measure the resistance from pin 6 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 34 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 222 inactive; Fault Code 221 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 222 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 223 - Burn Valve Solenoid Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the burn valve solenoid. |
 | STEP 1A. Verify the burn valve solenoid is connected to the engine harness. | Solenoid is connected
 | STEP 1B. Inspect the burn valve solenoid and harness connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | Less than 120 ohms
 | STEP 1D. Check short circuit to engine block ground. | More than 80 ohms
STEP 2. | Check the OEM interface harness. |
 | STEP 2A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 225 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the burn valve solenoid.

Guided Step 1A - Verify the burn valve solenoid is connected to the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the burn valve solenoid is connected to the engine harness.

Verify the burn valve solenoid is connected to the engine harness.
OK NOT OK

Solenoid is connected

Connect the solenoid to the engine harness

Go to 1B

Go to 3A

Guided Step 1B - Inspect the burn valve solenoid and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the burn valve solenoid.

Action

Inspect the burn valve solenoid and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the burn valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the OEM interface harness.

Action

Check for an open circuit in the burn valve solenoid.

  • Measure the resistance from pin A to pin B of the burn valve solenoid connector.
OK NOT OK

Less than 120 ohms

Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to engine block ground.

Conditions

  • Disconnect the OEM interface harness from the burn solenoid valve.

Action

Check for a short circuit to ground in the burn valve solenoid.

  • Measure the resistance from pin A of the burn solenoid connector to engine block ground.
OK NOT OK

More than 80 ohms

Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM interface harness.

Guided Step 2A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the OEM interface harness.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the burn valve solenoid circuit.

  • Measure the resistance from pin 8 of the OEM interface harness ECM connector to pin A of the burn valve solenoid connector, harness side.
  • Measure the resistance from pin 8 of the engine harness ECM connector to pin B of the burn valve solenoid connector, harness side.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the burn valve solenoid from the OEM interface harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 8 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 21 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the burn valve solenoid.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 8 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 8 of the OEM interface harness ECM connector to all pins in the engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 223 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 225 - Make-Up Valve Solenoid Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead Part Number 3823995 - male Weather-Pack™ test lead Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the make-up valve solenoid. |
 | STEP 1A. Verify the make-up valve solenoid is connected to the engine harness. | Solenoid is connected
 | STEP 1B. Inspect the make-up valve solenoid and engine harness connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | Less than 120 ohms
 | STEP 1D. Check for a short circuit to engine block ground. | More than 80 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 225 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the make-up valve solenoid.

Guided Step 1A - Verify the make-up valve solenoid is connected to the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the make-up valve solenoid is connected to the engine harness.

Verify ther make-up valve solenoid is connected to the engine harness.
OK NOT OK

Solenoid is connected

Connect the solenoid to the engine harness

Go to 1B

Go to 3A

Guided Step 1B - Inspect the make-up valve solenoid and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the make-up valve solenoid.

Action

Inspect the make-up valve solenoid and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the make-up valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the make-up valve solenoid. Refer to Procedure 019-172 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the make-up valve solenoid from the engine harness.

Action

Check for an open circuit in the make-up valve solenoid.

  • Measure the resistance from pin A to pin B of the make-up valve solenoid connector.
OK NOT OK

Less than 120 ohms

Replace the make-up valve solenoid. Refer to Procedure 019-172 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the make-up solenoid valve.

Action

Check for a short circuit to ground in the make-up valve solenoid.

  • Measure the resistance from pin A of the make-up solenoid to engine block ground.
OK NOT OK

More than 80 ohms

Replace the make-up valve solenoid. Refer to Procedure 019-172 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the make-up valve solenoid from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the make-up valve solenoid circuit.

  • Measure the resistance from pin 2 of the engine harness ECM connector to pin A of the make-up valve solenoid harness connector, engine harness side.
  • Measure the resistance from pin 8 of the engine harness ECM connector to pin B of the make-up valve solenoid, engine harness side.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section .

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the make-up valve solenoid from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground in the make-up valve solenoid circuit.

  • Measure the resistance from pin 2 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 8 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the make-up valve solenoid.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the engine harness ECM connector to all other pins in the connector, except pins 7, 8, 17, and 18.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 225 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 231 - Coolant Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead. Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead. Part Number 3824776 - Packard™ breakout cable.Part Number 3822752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | One or more of Fault Codes 122, 135, 144, 153, 221, 263, and 719 are not active?
STEP 2. | Check the coolant pressure sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 231 active?
 | STEP 2C. Check the coolant pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the coolant pressure supply voltage. |
 | STEP 2D. Check the coolant pressure signal voltage. | 0.42 to 0.58-VDC?
 | STEP 2D-1. Check for a short from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 231 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check the ECM for the appropriate response. | Fault Code 231 inactive; Fault Code 232 active?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 231 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 231, 263, and 719 are not active?

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the coolant pressure sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the coolant pressure sensor.

Action

Inspect the coolant pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the coolant pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 231 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the coolant pressure supply voltage.

Conditions

  • Disconnect the coolant pressure sensor from the engine harness
  • Install the pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the coolant pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the coolant pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the cooolant pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the coolant pressure signal voltage.

Conditions

  • Disconnect the coolant pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the engine harness connector
  • Disconnect all pressure and temperature sensors and the coolant level sensor, or disconnect the shorting plug
  • Connect the engine harness to the ECM
  • Turn keyswitch ON.

Action

Check the coolant pressure signal voltage.

  • Measure the supply voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors to the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specifications.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the coolant level sensor or disconnect the shorting plug.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 16 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the coolant pressure sensor harness connector.
  • Measure the resistance from pin 16 of the engine harness ECM connector to pin C of the coolant pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the coolant pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 231 inactive; Fault Code 232 active?

Fault Code 231 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 16 (signal) to pin 6 (supply) of the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 231 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness connector to pin B of the coolant pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the engine coolant temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 16 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 231 inactive; Fault Code 232 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 231 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 232 - Coolant Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead. Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead. Part Number 3824776 - Packard™ breakout cable.Part Number 3822752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | One or more of Fault Codes 123, 141, 222, and 729 are not active?
STEP 2. | Check the coolant pressure sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 232 active?
 | STEP 2C. Check the coolant pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the coolant pressure supply voltage. |
 | STEP 2D. Check the coolant pressure signal voltage. | 0.42 to 0.58-VDC?
 | STEP 2D-1. Check for a short from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check for the appropriate ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to return pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 232 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check the ECM for the appropriate response. | Fault Code 232 inactive; Fault Code 231 active?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 232 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, and 729 are not active?

Possible open circuit in the sensor common return wire.

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the coolant pressure sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the coolant pressure sensor.

Action

Inspect the coolant pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the coolant pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 232 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the coolant pressure supply voltage.

Conditions

  • Disconnect the coolant pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the coolant pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the coolant pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the cooolant pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the coolant pressure signal voltage.

Conditions

  • Disconnect the coolant pressure sensor from the engine harness
  • Install the appropriate pressure sensor breakout cable between the sensor and the engine harness connector
  • Disconnect all pressure and temperature sensors and the coolant level sensor, or disconnect the shorting plug
  • Connect the engine harness to the ECM
  • Turn keyswitch ON.

Action

Check the coolant pressure signal voltage.

  • Measure the supply voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors to the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specifications.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the coolant level sensor or disconnect the shorting plug.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 16 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the coolant pressure sensor harness connector.
  • Measure the resistance from pin 16 of the engine harness ECM connector to pin C of the coolant pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the coolant pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 232 inactive; Fault Code 231 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to return pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to return pin in the ECM port.

  • Measure the resistance from pin 16 (signal) to pin 17 (return) of the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 232 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 16 of the engine harness ECM connector to pin C of the coolant pressure sensor connector, engine harness side.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the coolant pressure sensor connector, engine harness side.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the engine coolant temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 16 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 16 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 6 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 232 inactive; Fault Code 231 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 232 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 233 - Coolant Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 233 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical pressure gauge to the engine.
  • Connect INSITE™ to the vehicle datalink.
  • Start the engine and compare the coolant pressure reading on the service tool monitor screen to the reading on the mechanical pressure gauge.

Rev up the engine in order to make it easier to see differences in the readings.
OK NOT OK

Sensor reading is correct. Reference the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261, and the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727, for the correct specifications.

Go to 2A

Fault Code 232

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

If the fault code occurred at a particular speed, run engine at that speed to verify that the problem is corrected.
OK NOT OK

Fault Code 233 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 234 - Engine Overspeed

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2450 rpm, shut off the engine immediately or the engine will be damaged.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Not motoring downhill
 | STEP 1B. Check for an alternate fuel source. | No alternate fuel source
 | STEP 1C. Check the engine rpm with the monitor mode. | Correct rpm reading
 | STEP 1D. Check the injector overhead settings. | Correct injector overhead settings
 | STEP 1E. Check for an active fault code at low engine rpm. | Inactive fault code at low rpm
 | STEP 1F. Test vehicle. | Inactive fault code
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault code was logged.
OK NOT OK

Not motoring downhill

Check the engine for damage

  • Electronics are functional.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past the maximum rpm threshold for the engine, followed by moderate deceleration.
OK NOT OK

No alternate fuel source

Locate the alternate fuel source

  • Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, and so forth.

Go to 1C

Go to 2A

Guided Step 1C - Check the engine rpm with the monitor mode.

Conditions

  • Turn keyswitch ON.

Action

Check the engine rpm with the monitor mode.

  • Monitor the engine rpm using INSITE™.
OK NOT OK

Correct rpm reading

Inspect engine position sensor

  • Check the engine position sensor as outlined for Fault Codes 115 and 121.

Go to 1D

Fault Codes 115 and 121

Guided Step 1D - Check the injector overhead settings.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector overhead settings.

  • Check for correct injector overhead settings. Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261 Refer to Procedure 003-006
  • Use the following procedure in the Troubleshooting and Repair Use the following procedure Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 003-006.
OK NOT OK

Correct injector overhead settings

Reset the overhead

  • Reset the overhead according to the outer base circle method. Inspect the base engine for damage due to overspeed condition.

Go to 1E

Go to 2A

Guided Step 1E - Check for an active fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active fault code at low engine rpm.

  • Check for active Fault Code 234 when the engine is not running above the maximum rpm threshold for the engine.
OK NOT OK

Inactive fault code at low rpm

Replace the ECM. Refer to Procedure 019-031.

Go to 1F

Go to 2A

Guided Step 1F - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle.

  • Check if the overspeed condition is still present.
OK NOT OK

Inactive fault code

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
OK NOT OK

Fault Code 234 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 235 - Engine Coolant Level - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

Do not add cold coolant to a hot engine. Castings can be damaged. Allow engine to cool to below 50°C [120°F] before adding coolant.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 422 inactive
STEP 2. | Verify that the coolant is low. |
 | STEP 2A. Check the coolant level. | Coolant level normal
STEP 3. | Check the coolant level sensor. |
 | STEP 3A. Confirm the fault code is still active with the engine running. | Fault code still active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 235 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 422 inactive

Go to 2A

Multiple fault code trees

Guided Step 2 - Verify that the coolant is low.

Guided Step 2A - Check the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level normal

Add coolant to the radiator

Make sure coolant has proper amount of antifreeze, diesel coolant additive, and water.

Go to 3A

Go to 4A

Guided Step 3 - Check the coolant level sensor.

Guided Step 3A - Confirm the fault code is still active with the engine running.

Conditions

  • Turn keyswitch ON.

Action

Confirm fault is still active with engine running.

  • Use INSITE™ electronic service tool to confirm that the fault code is still active while the engine is running.
OK NOT OK

Fault code still active. Replace coolant level sensor. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 235 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 237 - Multiple-Unit Synchronization

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.Part Number 3823993 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine which engine is shutting down. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 426, 427, and 497 inactive
 | STEP 1B. Determine which engine is shutting down. | Secondary engine is shutting down
STEP 2. | Check the secondary OEM interface harness. |
 | STEP 2A. Inspect the OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check the output driver supply voltage. | 11.75 to 12.25 VDC
 | STEP 2C. Check the +5-VDC supply. | 4.75 to 5.25 VDC
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2F. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the primary OEM harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check the OEM interface harness. |
 | STEP 4A. Inspect the OEM interface harness connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 237 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Determine which engine is shutting down.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 426, 427, and 429 inactive

Go to 1B

Multiple fault code trees

Guided Step 1B - Determine which engine is shutting down.

Conditions

  • Turn keyswitch ON.

Action

Determine which engine is shutting down.

  • Is the secondary engine shutting down or is the primary engine shutting down? Use INSITE™ to monitor the secondary or primary engine.
OK NOT OK

Secondary engine is shutting down

Primary engine is shutting down.

  • Determine why primary engine is shutting down. Go to the appropriate fault code tree.

Go to 2A

Appropriate fault code tree

Guided Step 2 - Check the secondary OEM interface harness.

Guided Step 2A - Inspect the OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check the output driver supply voltage.

Conditions

  • Disconnect the secondary engine OEM interface harness from the ECM.
  • Turn keyswitch ON.

Action

Check the output driver supply voltage.

  • Measure the voltage from pin 17 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

11.75 to 12.25 VDC

Go to 2C

Go to 2D

Guided Step 2C - Check the +5-VDC supply.

Conditions

  • Disconnect the secondary engine OEM interface harness from the ECM.
  • Turn keyswitch ON.

Action

Check the +5-VDC supply.

  • Measure the voltage from pin 18 of the OEM interface harness connector to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Go to 5A

Go to 2D

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.Part Number 3823993 - female Deutsch test lead.
Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine OEM interface harness from the ECM.
  • Disconnect the secondary engine OEM interface harness from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to pin L of the OEM interface harness 21-pin connector.
  • Measure the resistance from pin 18 of the OEM interface harness ECM connector to pin M of the OEM interface harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF.
  • Disconnect the secondary engine OEM interface harness from the ECM.
  • Disconnect the secondary engine OEM interface harness from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine OEM interface harness from the ECM.
  • Disconnect the secondary engine OEM interface harness from the OEM harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 18 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the primary OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine OEM interface harness from the OEM harness.
  • Disconnect the primary engine OEM interface harness from the OEM harness.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Refer to Procedure 019-072 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary engine OEM interface harness.
  • Disconnect the OEM harness from the secondary engine OEM interface harness.

Action

Check for an open circuit.

  • Measure the resistance from position pin W of the OEM harness primary-engine-side 21-pin connector to pin L of the OEM harness secondary-engine-side 21-pin connector.
  • Measure the resistance from the OEM-provided +5-VDC supply line to pin M of the OEM harness secondary-engine-side 21-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary engine OEM interface harness.
  • Disconnect the OEM harness from the secondary engine OEM interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin W of the OEM harness primary-engine-side 21-pin connector to all other pins in the OEM harness primary engine side of the 21-pin connector.
  • Measure the resistance from the OEM-provided +5-VDC supply line to all other pins in the OEM harness primary engine side of the 21-pin connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary engine OEM interface harness.
  • Disconnect the OEM harness from the secondary engine OEM interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin W of the OEM harness primary-engine-side 21-pin connector to engine block ground.
  • Measure the resistance from the OEM-provided +5-VDC supply line to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM interface harness.

Guided Step 4A - Inspect the OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary engine OEM interface harness.
  • Disconnect the primary engine OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary engine OEM interface harness.
  • Disconnect the primary engine OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 24 of the OEM interface harness ECM connector to pin W of the 21-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary engine OEM interface harness.
  • Disconnect the primary engine OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 24 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary engine OEM interface harness.
  • Disconnect the primary engine OEM interface harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 24 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 237 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Apr-2012


FAULT CODE 252 - Oil Level Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 222, 232, and 729 are not active
STEP 2. | Check the lubricating oil level sensor. |
 | STEP 2A. Inspect the engine harness and lubricating oil level sensor connector pins. | No damaged pins
 | STEP 2B. Check the supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 252 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, 232, and 729 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the lubricating oil level sensor.

Guided Step 2A - Inspect the engine harness and lubricating oil level sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lubricating oil level sensor.

Action

Inspect the engine harness and lubricating oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the lubricating oil level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the lubricating oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
Guided Step 2B - Check the lubricating oil level sensor supply voltage.

Conditions

  • Disconnect the engine harness from the lubricating oil level sensor.
  • Install breakout cable, Part Number 3824776, between the lubricating oil level sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the oil level sensor supply voltage.

  • Measure the voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Disconnect the engine harness from the lubricating oil level sensor.
  • Install breakout cable, Part Number 3824776, between the lubricating oil level sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the oil level sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.46 to 4.56 VDC

Replace the sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the lubricating oil level sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 12 of the engine harness ECM connector to pin C of the lubricating oil level sensor connector, engine harness side.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the lubricating oil level sensor connector, engine harness side.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the lubricating oil level sensor connector, engine harness side.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the lubricating oil level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 12 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 6 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 12 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector, except pins 7, 8, and 18.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 252 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 253 - Oil Level - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 252 inactive?
STEP 2. | Check the oil level. |
 | STEP 2A. Verify the oil level. | Oil level correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 253 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 252 not active?

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the oil level.

Guided Step 2A - Verify the oil level.

Conditions

  • Turn keyswitch OFF.

Action

Verify the oil level using the oil dipstick.
OK NOT OK

Oil level correct?

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Fill the engine lubricating oil to the appropriate level.

Reference the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098, the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 253 is inactive.
OK NOT OK

Fault Code 253 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 254 - Fuel Shutoff Solenoid Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff solenoid post(s). | No extra wires
 | STEP 1B. Clean the solenoid post(s) and the wiring terminal. | Solenoid post(s) clean
 | STEP 1C. Check the supply voltage at the fuel shutoff solenoid. | More than 17.0 VDC
 | STEP 1C-1. Check the engine harness and ECM connector pins. |
 | STEP 1C-2. Check for a short circuit to ground in the fuel shutoff solenoid supply wire. |
 | STEP 1C-3. Check for a short circuit from pin to pin. |
 | STEP 1C-4. Check the supply voltage at the ECM. |
 | STEP 1D. Check the fuel shutoff solenoid resistance. | 1 to 5 ohms for 6-VDC solenoids6 to 15 ohms for 12-VDC solenoids24 to 50 ohms for 24-VDC solenoids42 to 80 ohms for 32-VDC solenoids46 to 87 ohms for 36-VDC solenoids92 to 145 ohms for 48-VDC solenoids315 to 375 ohms for 74-VDC solenoids645 to 735 ohms for 115-VAC solenoids
 | STEP 1E. Check for a short circuit to ground in the fuel shutoff solenoid. | More than 100k ohms
 | STEP 1F. Check the OEM keyswitch circuit. | More than 17 VDC
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 254 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel shutoff solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff solenoid post(s).

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the fuel shutoff solenoid post(s).

Check for extra wires on the fuel shutoff solenoid post(s).
OK NOT OK

No extra wires

Remove the extra wires and connect the wires removed to a proper 24-volt supply.

Go to 1B

Go to 2A

Guided Step 1B - Clean the solenoid post(s) and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff control wire attached to the fuel shutoff solenoid.

Action

Clean the solenoid post(s) and the wiring terminal.

  • Clean the fuel shutoff solenoid post(s) and the fuel shutoff solenoid control wire terminal of the engine harness.
OK NOT OK

Solenoid post(s) clean

Repair ring terminal or replace the fuel shutoff solenoid

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the fuel shutoff solenoid. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-043 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-043 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-043 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 366672. Refer to Procedure 005-043 in Section 5.

Go to 1C

Go to 2A

Guided Step 1C - Check the supply voltage at the fuel shutoff solenoid.

Conditions

  • Disconnect the engine harness power supply lead from the fuel shutoff solenoid.
  • Turn keyswitch ON.
  • Crank the engine until speed exceeds 50 rpm.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff control wire connector on the harness side to engine block ground.

Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

More than 17.0 VDC

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1C-2

Go to 2A

Guided Step 1C-2 - Check for a short circuit to ground in the fuel shutoff solenoid supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff solenoid.

Action

Check for a short circuit to ground in the fuel shutoff solenoid supply wire.

  • Measure the resistance from the fuel shutoff supply wire to the engine block ground.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness.Refer to Procedure 019-197 in Section 19. Refer to Procedure 019-198 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C-3

Go to 2A

Guided Step 1C-3 - Check for a short circuit between pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 30 of the engine harness ECM connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness.Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.

Go to 1C-4

Go to 2A

Guided Step 1C-4 - Check the supply voltage at the ECM.

Conditions

  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff solenoid.
  • Connect one end of a jumper wire, Part Number 3822917, to pin 7 or 8 of the engine harness ECM connector port and touch the other end of the jumper wire to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

Check the supply voltage at the ECM.

  • With the grounding circuit in place (jumper wire attached from pin 7 or 8 of the engine harness ECM connector port to ground), measure the voltage from pin 30 of the engine harness ECM connector port to engine block ground.

Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

More than 17.0 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check the fuel shutoff solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel shutoff solenoid.

Action

Check the fuel shutoff solenoid resistance.

  • Measure the resistance from the fuel shutoff solenoid supply post to the fuel shutoff solenoid ground post.

Use the following Procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

1 to 5 ohms for 6-VDC solenoids

6 to 15 ohms for 12-VDC solenoids

24 to 50 ohms for 24-VDC solenoids

42 to 80 ohms for 32-VDC solenoids

46 to 87 ohms for 36-VDC solenoids

92 to 145 ohms for 48-VDC solenoids

315 to 375 ohms for 74-VDC solenoids

645 to 735 ohms for 115-VAC solenoids

Replace the fuel shutoff solenoid. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 366609. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Go to 1E

Go to 2A

Guided Step 1E - Check for a short circuit to ground in the fuel shutoff solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel shutoff solenoid.

Action

Check for a short circuit to ground in the fuel shutoff solenoid.

  • Measure the resistance from the solenoid coil to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the fuel shutoff solenoid. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Go to 1F

Go to 1F

Guided Step 1F - Check the OEM keyswitch circuit.

Conditions

  • Turn the keyswitch ON.
  • Engine harness connected to the ECM.
  • Engine harness connected to the fuel shutoff solenoid.

Action

Check the OEM keyswitch circuit.

  • Measure the voltage from the fuel shutoff solenoid terminal to the engine block ground.

Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

More than 17 VDC

Repair or replace the OEM wiring harness. Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 254 is inactive.
OK NOT OK

Fault Code 254 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-May-2012


FAULT CODE 259 - Fuel Shutoff Valve Stuck Open

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff solenoid post(s). | No extra wires
 | STEP 1B. Check the supply voltage at the fuel shutoff solenoid. | Less than 1.5 VDC
 | STEP 1B-1. Inspect the engine harness and ECM connector pins. |
 | STEP 1B-2. Check for a short circuit from pin to pin. |
 | STEP 1B-3. Check the supply voltage at the ECM. |
 | STEP 1C. Inspect the fuel shutoff solenoid for excessive wear. | No excessive wear
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 259 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel shutoff solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff solenoid post(s).

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the fuel shutoff solenoid post(s).

Check for extra wires on the fuel shutoff solenoid post(s).
OK NOT OK

No extra wires

Remove the extra wires and connect them to a 24-VDC power supply

Go to 1B

Go to 2A

Guided Step 1B - Check the supply voltage at the fuel shutoff solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness (ring terminal connector) from the fuel shutoff solenoid.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff ring terminal harness connector to engine block ground.
OK NOT OK

Less than 1.5 VDC

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B-2

Go to 2A

Guided Step 1B-2 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 30 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1B-3

Go to 2A

Guided Step 1B-3 - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel shutoff solenoid.
  • Install the female end of a jumper wire, Part Number 3822917, to pin 7 or 8 of the ECM engine harness connector port and touch the clip end of the jumper wire to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

Check the supply voltage at the ECM.

  • Measure the voltage from pin 30 of the ECM engine harness connector port to engine block ground.
OK NOT OK

Less than 1.5 VDC. Repair or replace the fuel shutoff valve. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-043 in Section 5

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Inspect the fuel shutoff solenoid for excessive wear.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel shutoff solenoid for excessive wear.

  • Repair or replace the fuel shutoff valve. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-043 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-043 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-043 in Section 5.
  • Use the following procedurethe Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.
OK NOT OK

No excessive wear

Repair or replace the fuel shutoff valve. Use the following procedeure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-043.

Ue the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-043 in Section 19.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-043 in Section 19.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727 Refer to Procedure 005-043 in Section 5.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 259 is inactive.
OK NOT OK

Fault Code 259 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 261 - Fuel Temperature - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 261 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the bottom side of the control valve body nearest the fuel temperature sensor.
  • Connect INSITE™ to the vehicle data link.
  • Compare the fuel temperature reading on the service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, then answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 263

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it warm up to normal operating temperature.
  • Verify that Fault Code 261 is inactive.
OK NOT OK

Fault Code 261 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 263 - Fuel Temperature Sensor Circuit (QSK45, QSK60, and QSK78 Only)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 151, 153, 221, 231, and 719 are not active
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 263 active
 | STEP 2C. Check the resistance of the fuel temperature sensor. | 600 ohms to 36k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 263 inactive; Fault Code 265 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 263 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 151, 153, 221, 231, and 719 are not active

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the engine harness and sensor connector pins for the folloiwng:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the fuel temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedure. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 263 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the resistance of the fuel temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the two pins on the sensor side of the fuel temperature sensor connector.
OK NOT OK

600 ohms to 36k ohms

Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the fuel temperature sensor connector, engine harness side.
  • Measure the resistance from pin 26 of the engine harness ECM connector to pin A of the fuel temperature sensor connector, engine harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 26 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 263 inactive; Fault Code 265 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 263 is inactive.
OK NOT OK

Fault Code 263 inactive

Return to the troubleshooting steps or contact at Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 265 - Fuel Temperature Sensor Circuit (QSK45, QSK60, and QSK78 only)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 154, 222, 232, and 719 are not active
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 265 active
 | STEP 2B. Check the resistance of the fuel temperature sensor. | 600 ohms to 36k ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 265 inactive; Fault Code 263 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 265 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 145, 154, 222, 232, and 719 are not active

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the fuel temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 265 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the resistance of the fuel temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the two pins on the sensor side of the fuel temperature sensor connector.
OK NOT OK

600 ohms to 36k ohms

Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2D

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the fuel temperature sensor connector, sensor side, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 26 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 17 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 26 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms. Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the ECM.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 26 to pin 6 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 265 inactive; Fault Code 263 active

Replace the ECM . Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 265 is inactive.
OK NOT OK

Fault Code 265 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 292 - OEM Temperature - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 293 and 294 are not active
STEP 2. | Check the OEM temperature sensor. |
 | STEP 2A. Check the OEM temperature | Sensor reading equals actual temperature
 | STEP 2B. Check the OEM temperature threshold | Sensor readings show temperature thresholds are neither greater nor less than OEM temperature thresholds
 | STEP 2C. Inspect the OEM temperature sensor connector pins. | No damaged pins
 | STEP 2D. Check the resistance of the OEM temperature sensor. | Refer to OEM service manual for specifications
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 292 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 293 and 294 are not active.

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the OEM temperature sensor.

Guided Step 2A - Check the OEM temperature.

Conditions

  • Turn keyswitch ON.

Action

Check the OEM temperature.

  • Use a thermocouple or similar temperature probe to verify the actual temperature. Refer to OEM service manual.
  • Use INSITE™ electronic service tool to check the temperature.
OK NOT OK

Sensor reading equals actual temperature

Replace OEM temperature sensor. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the OEM temperature threshold.

Conditions

  • Turn keyswitch ON.

Action

Check the OEM temperature thresholds.

  • Refer to the OEM service manual.
  • Use INSITE™ electronic service tool to check the temperature thresholds.
OK NOT OK

Sensor readings show temperature thresholds are neither greater nor less than OEM temperature thresholds

Replace OEM temperature sensor. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the OEM temperature sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check the OEM temperature sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the OEM temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Check the resistance of the OEM temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check the resistance of the OEM temperature sensor.

Check the resistance of the OEM temperature sensor.
OK NOT OK

Refer to OEM service manual.

Replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 292 is inactive.
OK NOT OK

Fault Code 292 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 134, 422, and 432 are not active
STEP 2. | Check the OEM temperature sensor. |
 | STEP 2A. Inspect the OEM harness and sensor connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the OEM temperature sensor. | Refer to OEM manual for specifications
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the OEM interface harness. |
 | STEP 4A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check for an ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 293 inactive; Fault Code 294 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 293 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 134, 422, and 432 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the OEM temperature sensor.

Guided Step 2A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the OEM temperature sensor.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the OEM temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check the resistance of the OEM temperature sensor.

Check the resistance of the OEM temperature sensor.
OK NOT OK

Refer to OEM manual for specifications

Replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the OEM interface harness.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the OEM interface harness.

Action

Check for an open circuit.

  • Measure the resistance from pin K of the OEM harness connector to pin A of the temperature sensor connector, harness side.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the OEM interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin K of the OEM harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the OEM interface harness.

Guided Step 4A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 of the OEM interface harness, ECM side, to pin K of the OEM interface harness, OEM harness side.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 27 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for an ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper ECM response.

  • Disconnect the OEM interface harness connector from the ECM.
  • Remove pin 27 from the OEM interface harness ECM connector.
  • Connect the OEM interface harness connector to the ECM.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 293 inactive; Fault Code 294 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 293 is inactive.
OK NOT OK

Fault Code 293 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 294 - OEM Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 133, 422, and 431 are not active
STEP 2. | Check the OEM temperature sensor. |
 | STEP 2A. Inspect the OEM harness and sensor connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the OEM temperature sensor. | Refer to OEM manual for specifications
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check the OEM interface harness. |
 | STEP 4A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 5. | Check for an ECM response. |
 | STEP 5A. Check the ECM for proper response. | Fault Code 294 inactive; Fault Code 293 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 294 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 133, 422, and 431 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the OEM temperature sensor.

Guided Step 2A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the OEM temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service maual.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the OEM temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check the resistance of the OEM temperature sensor.

Check the resistance of the OEM temperature sensor.
OK NOT OK

Refer to OEM manual for specifications

Replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the OEM interface harness.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin K of the OEM harness 21-pin connector to the corresponding pin of the OEM temperature sensor connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin K of the OEM harness 21-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin K of the OEM harness 21-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the OEM interface harness.

Guided Step 4A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin K of the OEM interface harness connector, OEM harness side, to pin 27 of the OEM interface harness connector, ECM side.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 27 of the OEM interface harness connector, ECM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 27 of the OEM interface harness connector, ECM side, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for an ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.

Action

Check for the appropriate ECM response.

  • Disconnect the OEM interface harness connector from the ECM.
  • Install a jumper wire, Part Number 3822917, from pin 27 to pin 16 of the ECM OEM interface harness connector port.
  • Connect the OEM interface harness connector to the ECM.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 294 inactive; Fault Code 293 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 294 is inactive.
OK NOT OK

Fault Code 294 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 296 - OEM Pressure - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Wait until the fluid temperature is below 50°C [120°F] before working on the OEM system. Failure to do so can cause personal injury from heated liquid spray.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 297 and 298 are not active.
STEP 2. | Check the OEM pressure sensor. |
 | STEP 2A. Use INSITE™ to check the OEM pressure threshold. | Pressure reading is neither greater nor less than the threshold specification.
 | STEP 2B. Inspect the OEM harness and OEM pressure sensor connector pins. | No damaged pins.
 | STEP 2C. Check the resistance of the OEM pressure sensor. | Refer to OEM service manual for specifications.
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 296 inactive.
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 297 and 298 are not active

Fault Codes 297 and 298 are not active

Go to 2A

Multiple fault code tree

Guided Step 2 - Check the OEM pressure sensor.

Guided Step 2A - Use INSITE® to check the OEM pressure threshold.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM pressure threshold.

  • Use a suitable pressure probe to verify the actual pressure. Refer to the OEM service manual.
  • Use INSITE™ electronic service tool to check the pressure.
OK NOT OK

Pressure reading is neither greater nor less than the threshold specification

Replace OEM pressure sensor. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the OEM harness and OEM pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the OEM harness and OEM pressure sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM pressure sensor. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check the resistance of the OEM pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the resistance of the OEM pressure sensor.

Check the resistance of the OEM pressure sensor.
OK NOT OK

Refer to OEM service manual.

Replace the OEM pressure sensor. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 296 is inactive.
OK NOT OK

Fault Code 296 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 297 - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Wait until the fluid temperature is below 50°C [120°F] before working on the OEM system. Failure to do so can cause personal injury from heated liquid spray.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM pressure sensor. |
 | STEP 1A. Inspect the OEM harness and OEM pressure sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the OEM pressure sensor. | Refer to OEM manual for specifications
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 297 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 297 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 297 inactive; Fault Code 298 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 297 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM pressure sensor.

Guided Step 1A - Inspect the OEM harness and OEM pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM pressure sensor. Refer to the OEM service manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the OEM pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the resistance of the OEM pressure sensor.

Check the resistance of the OEM pressure sensor.
OK NOT OK

Refer to OEM manual for specifications

Replace the OEM pressure sensor. Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
OK NOT OK

Fault Code 297 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin F of the OEM harness, OEM interface harness side, to pin A of the OEM harness, pressure sensor side.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin F of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 active

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 15 of the OEM interface harness connector, ECM side, to pin F of the OEM interface harness connector, OEM harness side.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 15 of the OEM interface harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Sectio 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.

Action

Check for the appropriate ECM response.

  • Disconnect the OEM interface harness from the ECM.
  • Remove pin 15 from the OEM interface harness connector.
  • Connect the OEM interface harness to the ECM.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 inactive; Fault Code 298 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 297 is inactive.
OK NOT OK

Fault Code 297 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 298 - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Wait until the fluid temperature is below 50°C [120°F] before working on the OEM system. Failure to do so can cause personal injury from heated liquid spray.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM pressure sensor. |
 | STEP 1A. Inspect the OEM harness and OEM pressure sensor connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the OEM pressure sensor. | Refer to OEM manual for specifications
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 298 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 298 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 298 inactive; Fault Code 297 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 298 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM pressure sensor.

Guided Step 1A - Inspect the OEM harness and OEM pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the OEM pressure sensor. Refer to the OEM service manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the OEM pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check the resistance of the OEM pressure sensor.

Check the resistance of the OEM pressure sensor.
OK NOT OK

Refer to OEM manual for specifications

Replace the OEM pressure sensor. Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM interface harness.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin F of the OEM harness connector, OEM interface harness side, to pin A of the OEM harness connector, OEM pressure sensor side.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin F of the OEM harness 21-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the OEM interface harness 21-pin connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin F of the OEM harness 21-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin F of the OEM interface harness, OEM harness side, to pin 15 of the OEM interface harness, ECM side.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 15 of the OEM interface harness connector, ECM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 15 of the OEM interface harness, ECM side, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch OFF.

Action

Check for the appropriate ECM response.

  • Disconnect the OEM interface harness from the ECM.
  • Install a jumper wire, Part Number 3822917, from pin 15 to pin 16 of the ECM OEM interface harness connector port.
  • Remove pin 15 and pin 16 from the OEM interface harness connector.
  • Connect the OEM interface harness to the ECM.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 inactive; Fault Code 297 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 298 is inactive.
OK NOT OK

Fault Code 298 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 316 - Fuel Pump Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823254 - Metri-Pack™ three-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pump actuator. |
 | STEP 1A. Inspect the fuel pump actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the fuel pump actuator. | 7.0 to 9.0 ohms
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 20 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 316 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel pump actuator.

Guided Step 1A - Inspect the fuel pump actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Inspect the fuel pump actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the fuel pump actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the coil resistance of the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check the coil resistance of the fuel pump actuator.

  • Connect the test lead connector to the fuel pump actuator.
  • Measure the resistance from pin A to pin C of the test lead connector.
OK NOT OK

7.0 to 9.0 ohms

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin C of the test lead connector to engine block ground.
  • Measure the resistance from pin A of the test lead connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the fuel pump actuator.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 to pin 40 of the engine harness ECM connector.
OK NOT OK

Less than 20 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 11 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 40 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 40 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 316 is inactive.
OK NOT OK

Fault Code 316 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 318 - Fuel Pump Fueling Flow Mismatch

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | No other active fault codes
 | STEP 1B. Interview the driver to determine if engine symptoms are present. | Symptoms are present
STEP 2. | Check the fuel supply. |
 | STEP 2A. Check the vehicle fuel tanks for fuel. | Fuel in tank
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | No leaks, broken lines, faulty o-rings, maintenance issues, improper repairs, or loose fittings
STEP 3. | Check the fuel shutoff valve. |
 | STEP 3A. Check for a mechanical restriction of the fuel shutoff valve. | Debris is not present in the fuel shutoff valve and there are not any signs the fuel shutoff valve is restricting flow.
STEP 4. | Check the fuel pressure sensor for accuracy. |
 | STEP 4A. Verify the accuracy of the rail fuel pressure sensor. | INSITE™ electronic service tool reading and pressure gauge reading match within 138 kPa [20 psi]
STEP 5. | Check the engine operation. |
 | STEP 5A. Crank the engine to see if it starts. | The engine will start.
STEP 6. | Check the fuel pump pressure. |
 | STEP 6A. Measure the fuel pump pressure while cranking. | The fuel pressure is greater than the minimum pressure for the engine listed.
 | STEP 6B. Measure the fuel pump pressure while cranking with new fuel supply. | The fuel pressure is greater than the minimum pressure for the engine listed.
STEP 7. | Check the fuel rail pressure regulator. |
 | STEP 7A. Inspect the fuel rail pressure regulator. | There is not any debris or the o-rings are not cut or missing
STEP 8. | Check the fuel pump. |
 | STEP 8A. Inspect the fuel pump for damage. | There are not any visible wear or damage marks
STEP 9. | Check for air in the fuel. |
 | STEP 9A. Check for air in the fuel. | There is not air in the fuel
STEP 10. | Check the fuel pump pressure at high idle. |
 | STEP 10A. Measure the fuel pump pressure at high idle. | The fuel pump pressure is greater than the minimum specification at the respective RPM.
STEP 11. | Check the fuel inlet restriction. |
 | STEP 11A. Check the fuel inlet restriction. | The fuel inlet restriction is less than the specification listed in Procedure 006-020 in Section 6.
STEP 12. | Check for cut injector o-rings. |
 | STEP 12A. Check for cut injector o-rings. | O-rings are not cut or damaged.
STEP 13. | Clear the fault codes. |
 | STEP 13A. Disable the fault code. | Fault Code 318 inactive
STEP 14. | Replace the fuel pump. |
 | STEP 14A. Replace fuel pump. | Fault Code 318 inactive
 | STEP 14B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: If Fault Code 318 is active or inactive, attempt to clear the fault. If the fault remains active or inactive, continue through the tree.

Other active fault codes present?
YES | NO
No Repair | No Repair

Go to 1B

Appropriate fault tree

Guided Step 1B - Interview the driver to determine if engine symptoms are present.

Conditions

  • Turn keyswitch ON.

Action

Interview the driver for the following:

  • Present engine symptoms.
  • Driver complaints about specific symptoms or shutdowns/derates due to Fault Code 318.
  • When is the issue present?
  • When did the symptoms first occur?

Symptoms are present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 13A

Guided Step 2 - Check the fuel supply.

Guided Step 2A - Check the vehicle fuel tanks for fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank level for the following:

  • Fuel in the tank.
OK NOT OK

Fuel in tank

Fill the tank with fuel

Check the condition of the fuel injectors (mechanically actuated injectors only) for the possibility of having been run dry without fuel.

  • For QSK19, use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.
  • For QSK23, use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-026 in Section 6.
  • For QSK45 and QSK60, use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
  • For QSK78, use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-026 in Section 6.

Go to 2B

Go to 13A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings
  • Bent lines
  • Fuel filter maintenance records
  • Improper fittings or repairs previously performed.
OK NOT OK

No leaks, broken lines, faulty o-rings, maintenance issues, improper repairs, or loose fittings

The correct filters are installed and the filters are installed within the application engineering guidelines.

Repair the leak. Tighten or replace the leaking fitting or fuel line.

  • For QSK19, use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.
  • For QSK23, use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-024 in Section 6.
  • For QSK45 and QSK60, use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-024 in in Section 6.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 3A

Go to 13A

Guided Step 3 - Check the fuel shutoff valve.

Guided Step 3A - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch ON.

Action

Remove and inspect the fuel shutoff valve for a mechanical restriction.

  • For QSK19, use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-043 in Section 5.
  • For QSK45 and QSK60, use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 005-043 in Section 5.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.
OK NOT OK

Debris is not present in the fuel shutoff valve and there are not any signs the fuel shutoff valve is restricting flow.

Debris is present in the fuel shutoff valve and there are signs the fuel shutoff valve is restricting flow.

Repair or replace the fuel shutoff valve.

  • For QSK19, use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-043 in Section 5.
  • For QSK45 and QSK60, use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 005-043 in Section 5.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Go to 4A

Go to 13A

Guided Step 4 - Check the fuel pressure sensor for accuracy.

Guided Step 4A - Verify the accuracy of the rail fuel pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Install a pressure gauge on the rail fuel pressure Compuchek™ fitting.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the readings agree.

  • Verify the pressure gauge and INSITE™ electronic service tool reading for the rail fuel pressure sensor agree.
OK NOT OK

INSITE™ electronic service tool reading and pressure gauge reading match within 138 kPa [20 psi]

INSITE™ electronic service tool reading and pressure gauge reading do not match within 138 kPa [20 psi]

Replace the rail fuel pressure sensor.

Go to 5A

Go to 13A

Guided Step 5 - Check the engine operation.

Guided Step 5A - Crank the engine to see if it starts.

Conditions

  • Turn keyswitch ON.

Action

Crank the engine.

  • Start the engine.
OK NOT OK

The engine will start.

The engine will not start.

Go to 9A

Go to 6A

Guided Step 6 - Check the fuel pump pressure.

Guided Step 6A - Measure the fuel pump pressure while cranking.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start the engine.

Action

Verify that the readings agree.

  • For QSK19,use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • For QSK23, use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • For QSK45 and QSK60, use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.
  • Verify INSITE™ electronic service tool pressure reading for the rail fuel is above the pressure listed below.
OK NOT OK

The fuel pressure is greater than the minimum pressure for the engine listed.

QSK19

  • 150 RPM, 172 kPa [25 psi]

QSK23

  • 150 RPM, 379 kPa [55 psi]

QSK45/60/78

  • 175 RPM, 241 kPa [35 psi]

The fuel pressure is not greater than the minimum pressure for the engine listed.

QSK19

  • 150 RPM, 172 kPa [25 psi]

QSK23

  • 150 RPM, 379 kPa [55 psi]

QSK45/60/78

  • 175 RPM, 241 kPa [35 psi]

Go to 11A

Go to 6B

Guided Step 6B - Measure the fuel pump pressure while cranking with new fuel supply.

Conditions

  • Disconnect the fuel pump inlet.
  • Run a new fuel pump inlet line from a clean bucket to the fuel pump inlet.
  • Crank the engine.

Action

Verify the readings agree.

  • Verify INSITE™ electronic service tool pressure reading for the rail fuel is above the pressure listed.
  • For QSK19,use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • For QSK23, use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • For QSK45 and QSK60, use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.
  • Verify INSITE™ electronic service tool pressure reading for the rail fuel is above the pressure listed below.
OK NOT OK

The fuel pressure is greater than the minimum pressure for the engine listed.

QSK19

  • 150 RPM, 172 kPa [25 psi]

QSK23

  • 150 RPM, 379 kPa [55 psi]

QSK45/60/78

  • 175 RPM, 241 kPa [35 psi]

Locate and repair any collapsed or bent fuel lines, checking all the OEM supply lines and fittings, suction-side fuel filter head, fuel tank stand pipes, fuel supply and return lines, correct filter installation, or incorrect fuel drain location in the fuel tank.

The fuel pressure is not greater than the minimum pressure for the engine listed.

QSK19

  • 150 RPM, 172 kPa [25 psi]

QSK23

  • 150 RPM, 379 kPa [55 psi]

QSK45/60/78

  • 175 RPM, 241 kPa [35 psi]

Go to 13A

Go to 7A

Guided Step 7 - Check the fuel rail pressure regulator.

Guided Step 7A - Inspect the fuel rail pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Remove and inspect the rail pressure regulator for debris that would stick the regulator open and for cut or missing o-rings.

If the regulator is in question, disconnect the fuel return line and run it into a clean bucket.
OK NOT OK

There is not any debris or the o-rings are not cut or missing

There is debris, or the o-rings are cut or missing

Replace the regulator. Make sure the electronic control valve assembly and fuel lines between the electronic control valve assembly and fuel filters are clean.

Go to 8A

Go to 13A

Guided Step 8 - Check the fuel pump.

Guided Step 8A - Inspect the fuel pump for damage.

Conditions

  • Turn keyswitch OFF.

Action

Remove the fuel pump.

Note: Do not disassemble the fuel pump. Only inspect the exterior gear for wear or damage.

  • For QSK19,use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • For QSK23, use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • For QSK45 and QSK60, use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.
  • Verify INSITE™ electronic service tool pressure reading for the rail fuel is above the pressure listed below.
OK NOT OK

There are not any visible wear or damage marks

There is visible wear or damage marks

Repair or replace the fuel pump.

  • For QSK19,use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • For QSK23, use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • For QSK45 and QSK60, use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.
  • Verify INSITE™ electronic service tool pressure reading for the rail fuel is above the pressure listed below.

Go to 9A

Go to 13A

Guided Step 9 - Check for air in the fuel.

Guided Step 9A - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • For QSK19, use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-003 in Section 6.
  • For QSK23, use the following procedure in Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-003 in Section 6.
  • For QSK45 and QSK60, use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-003 in Section 6.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-003 in Section 6.
OK NOT OK

There is not air in the fuel

There is air in the fuel

Locate and repair the source of the air leak by checking all the OEM supply lines and fittings, suction-side fuel filter head, fuel tank stand pipes, fuel supply and return lines, correct filter installation, or incorrect fuel drain location in the fuel tank.

Go to 10A

Go to 13A

Guided Step 10 - Check the fuel pump pressure at high idle.

Guided Step 10A - Measure the fuel pump pressure at high idle.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Verify the readings agree.

  • Verify INSITE™ electronic service tool pressure reading for the rail fuel is above the pressure listed.
  • For QSK19,use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • For QSK23, use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • For QSK45 and QSK60, use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.
  • Verify the INSITE™ electronic service tool pressure reading for the rail fuel is above the pressure listed below.
OK NOT OK

The fuel pump pressure is greater than the minimum specification at the respective RPM.

QSK19

  • 1500 rpm (50 Hz) MIN 1344 kPa [195 psi]
  • 1800 rpm (60 Hz) MIN 1551 kPa [225 psi]
  • 2100 rpm MIN 1724 kPa [250 psi]
  • 2350 rpm MIN 1827 kPa [265 psi]

QSK23

  • 1500 rpm (50 Hz) MIN 1779 kPa [258 psi]
  • 1800 rpm (60 Hz) MIN 2117 kPa [307 psi]
  • 2100 rpm MIN 2344 kPa [340 psi]

QSK45/60/78

  • 1500 rpm (50 Hz) MIN 1572 kPa [228 psi]
  • 1800 rpm (60 Hz) MIN 1820 kPa [264 psi]
  • 2100 rpm MIN 1896 kPa [275 psi]
  • 2350 rpm MIN 1896 kPa [275 psi]

The fuel pump pressure is less than the minimum specification at the respective RPM.

QSK19

  • 1500 rpm (50 Hz) MIN 1344 kPa [195 psi]
  • 1800 rpm (60 Hz) MIN 1551 kPa [225 psi]
  • 2100 rpm MIN 1724 kPa [250 psi]
  • 2350 rpm MIN 1827 kPa [265 psi]

QSK23

  • 1500 rpm (50 Hz) MIN 1779 kPa [258 psi]
  • 1800 rpm (60 Hz) MIN 2117 kPa [307 psi]
  • 2100 rpm MIN 2344 kPa [340 psi]

QSK45/60/78

  • 1500 rpm (50 Hz) MIN 1572 kPa [228 psi]
  • 1800 rpm (60 Hz) MIN 1820 kPa [264 psi]
  • 2100 rpm MIN 1896 kPa [275 psi]
  • 2350 rpm MIN 1896 kPa [275 psi]

Go to 13A

Go to 11A

Guided Step 11 - Check the fuel inlet restriction.

Guided Step 11A - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Measure the fuel inlet restriction.

  • For QSK19 use the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-020 in Section 6.
  • For QSK23 use the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-020 in Section 6.
  • For QSK45 and QSK60 in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-020 in Section 6.
  • For QSK78 in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-020 in Section 6.
OK NOT OK

The fuel inlet restriction is less than the specification listed in Procedure 006-020.

The fuel inlet restriction is greater than the specification listed in Procedure 006-020.

  • Check for clogged fuel filters, incorrect filter installation, debris in the fuel tank or fuel lines, clogged fuel tank vents, collapsed or faulty fuel lines, faulty check valves, previous repairs, or incorrectly sized fittings.

Go to 12A

Go to 13A

Guided Step 12 - Check for cut injector o-rings.

Guided Step 12A - Check for cut injector o-rings.

Conditions

  • Turn keyswitch OFF.

Action

Remove the injectors and inspect the o-rings.

  • For QSK19, use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.
  • For QSK23, use the following procedure in Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-026 in Section 6.
  • For QSK45 and QSK60, use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-026 in Section 6.
OK NOT OK

O-rings are not cut or damaged.

O-rings are cut or damaged.

Replace the injector o-rings.

  • For QSK19, use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.
  • For QSK23, use the following procedure in Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-026 in Section 6.
  • For QSK45 and QSK60, use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.
  • Refer to Procedure 006-026 in Section 6.

Go to 13A

Go to 13A

Guided Step 13 - Clear the fault codes.

Guided Step 13A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch on.™
  • Connect INSITE™ electronic service tool

Action

Disable the fault code.

  • Start the engine and run throughout the operating range to verify that Fault Code 318 stays inactive.
OK NOT OK

Fault Code 318 inactive

Replace the fuel pump.

Go to 14B

Go to 14A
Go to

Guided Step 14 - Replace the fuel pump.

Guided Step 14A - Replace Fuel Pump.

Conditions

For replacement of the fuel pump.

  • Turn keyswitch OFF.

After fuel pump replacement:

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

See the following procedures:

  • For QSK19, use the following procedure in Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • For QSK23, use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • For QSK45 and QSK60, use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • For QSK78, use the following procedure in Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Clear the fault code.

Run the engine at high idle for 1 or 2 minutes.

Check for Fault Code 318.
OK NOT OK

Fault Code 318 inactive

Return to Troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 14B

Go to 1A

Guided Step 14B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Apr-2012


FAULT CODE 343 - Engine Control Module (ECM) Internal Communication Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active Fault Code 343. |
 | STEP 1A. Check for active Fault Code 343. | Fault Code 343 inactive
 | STEP 1B. Disconnect the power to the ECM. | Fault Code 343 inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active Fault Code 343.

Guided Step 1A - Check for active Fault Code 343.

Conditions

  • Turn keyswitch OFF.

Action

Check for active Fault Code 343.

  • Turn keyswitch OFF and wait at least 5 seconds.
  • Turn keyswitch ON.
  • Idle the engine for at least 1 minute.
  • Use INSITE™ electronic service tool to check for inactive fault code.
OK NOT OK

Fault Code 343 inactive

Fault Code 343 active.

Go to 2B

Go to 1B

Guided Step 1B - Disconnect the power to the ECM.

Conditions

  • Turn keyswitch OFF.

Action

Disconnect power to the ECM.

  • Turn keyswitch OFF.
  • Disconnect the electronic service tool INSITE™ from the data link.
  • Disconnect the power to the ECM at the battery.
  • Wait 1 minute.
  • Connect the power to the ECM at the battery.
  • Turn keyswitch ON.
  • Connect the electronic service tool INSITE™ to the data link.
  • Idle the engine for at least 1 minute.
  • Use INSITE™ electronic service tool to check for inactive fault code.
OK NOT OK

Fault Code 343 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 343 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Apr-2012


FAULT CODE 346 - Engine Control Module (ECM) Powerdown Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 VDC (24-VDC system)
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual.) |
 | STEP 2A. Inspect the OEM harness fuse connections. | No damaged connections
 | STEP 2B. Check the OEM harness fuse. | Less than 10 ohms
 | STEP 2C. Inspect the OEM harness and ECM connector pins. | No damaged pins
 | STEP 2D. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms
 | STEP 2E. Check for a short circuit from pin to pin in the unswitched battery supply circuit. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness ground connection. | No damaged connections
 | STEP 3B. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3C. Check for an open circuit in the block ground circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 346 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared
STEP 5. | Download calibration. |
 | STEP 5A. Download calibration. | Download successful
 | STEP 5B. Cycle keyswitch three times. | Fault Code 346 inactive
 | STEP 5C. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage as follows:

  • Measure the battery voltage with a multimeter.
OK NOT OK

17.3 to 34.7 VDC (24-VDC system)

Use the following procedure for unswitch batter supply circuid. Refer to Procedure 019-087 in Section 19.

Reference the Battery Voltage Low troubleshooting symptom tree in Section TS in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098, the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375,the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual.)

Guided Step 2A - Inspect the OEM harness fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two 10-amp fuses from the OEM interface harness.

Action

Inspect the OEM harness fuse connections for the following:

  • Corroded fuses
  • Loose fuses.
OK NOT OK

No damaged connections

Repair damaged connections

  • Repair the OEM interface harness. Refer to Procedure 019-195 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the OEM harness fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two 10-amp fuses from the OEM interface harness.

Action

Check the OEM interface harness fuses.

  • Measure the resistance of the fuses.
OK NOT OK

Less than 10 ohms

Replace the fuses. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in section 19

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Measure the resistance from pin 3 of the OEM interface harness ECM connector to the battery connection (ring terminal) on the OEM harness.
  • Measure the resistance from pin 4 of the OEM interface harness ECM connector to the battery connection (ring terminal) on the OEM harness.
  • Measure the resistance from pin 5 of the OEM interface harness ECM connector to the battery connection (ring terminal) on the OEM harness.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the battery.

Action

Check for a short circuit from pin to pin in the unswitched battery supply as follows:

  • Measure the resistance from pin 3 of the OEM interface harness ECM connector to all other pins in the connector, except pins 4 and 5.
  • Measure the resistance from pin 4 of the OEM interface harness ECM connector to all other pins in the connector, except pins 3 and 5.
  • Measure the resistance from pin 5 of the OEM interface harness ECM connector to all other pins in the connector, except pins 3 and 4.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine block at the ground connection.

Action

Check the engine harness ground connection for the following:

  • Broken connections
  • Corroded connections
  • Loose connections
  • Excessive paint, oil, or dirt.
OK NOT OK

No damaged connections

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-197 in Section 19.Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the block ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the block ground circuit.

  • Measure the resistance from pin 7 of the engine harness ECM connector to the engine block ground connection on the engine harness.
  • Measure the resistance from pin 8 of the engine harness ECM connector to the engine block ground connection on the engine harness.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-197 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Cycle the keyswitch three times.
  • Start engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 346 inactive

Download the correct calibration.

Go to 4B

Go to 5A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Guided Step 5 - Download calibration.

Guided Step 5A - Download calibration.

Conditions

  • Connect all components.

Action

Download calibration.

Refer to Procedure 019-032 in Section 19.

OK NOT OK

Download successful

Check communication connections and retry download

Repair complete

Go to 5B

Guided Step 5B - Cycle keyswitch three times.

Conditions

  • Connect all components.

Action

Cycle keyswitch three times.

Cycle keyswitch three times.
OK NOT OK

Fault Code 346 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5C

Go to 5A

Guided Step 5C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-May-2012


FAULT CODE 349 - Frequency Accelerator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM interface harness. |
 | STEP 2A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for OEM device(s) frequency signal supply. | Correct OEM frequency signal
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 349 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the frequency accelerator to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pins L to M of the OEM harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to all other pins in the connector except pin M.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM interface harness.

Guided Step 2A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to pin L of the OEM interface harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2E

3A

Guided Step 2E - Check the OEM devices for frequency signal supply.

Conditions

  • Turn keyswitch ON.

Action

Check the frequency signal of the OEM device(s).

Refer to the OEM service manual.
OK NOT OK

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM device. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 349 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Apr-2012


FAULT CODE 384 - Ether Injection Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ether injection solenoid. |
 | STEP 1A. Inspect the injector solenoid connector post and OEM harness connector. | No damage to post or connector
 | STEP 1B. Check the supply voltage at the ether injection solenoid. | More than 17.0 VDC
 | STEP 1C. Check the resistance of the ether injection solenoid. | Refer to OEM manual for specification
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector and ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the supply voltage at the ECM. |
 | STEP 4A. Check the supply voltage at the ECM. | More than 17.0 VDC
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 384 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ether injection solenoid.

Guided Step 1A - Inspect the injector solenoid connector post and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Inspect the injector solenoid connector post and OEM harness connector for the following:

  • Bent or broken OEM harness connector terminal
  • Corroded terminal post on the solenoid
  • Multiple wires on the terminal post
  • Moisture in or on the connector.
OK NOT OK

No damage to post or connector

Repair the damaged connection. Flush the dirt, debris, or moisture from the connector post and ring terminal. Repair or replace the ether injection solenoid or the OEM harness, whichever has the damaged part.

  • Flush the dirt, debris, or moisture from the connector post and ring terminal using electronic contact cleaner, Part Number 3824510.
  • Remove any additional wires connected to the solenoid terminal post.
  • Replace the damaged solenoid. Refer to the OEM manual for procedure.
  • Repair the OEM harness ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the supply voltage at the ether injection solenoid.

Conditions

  • Disconnect the ether injection solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ether injection solenoid.

  • Measure the voltage from the OEM wiring harness connector to engine block ground.
OK NOT OK

More than 17.0 VDC. Replace the ether injection solenoid. Refer to the OEM service manual.

Go to 5A

Go to 1C

Guided Step 1C - Check the resistance of the ether injection solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check the resistance of the ether injection solenoid.

  • Measure the resistance from the connector post to engine block ground.
OK NOT OK

Refer to OEM manual for specification

Replace the ether injection solenoid. Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ether injection solenoid.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.

Action

Inspect the OEM harness and OEM interface harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ether injection solenoid.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.

Action

Check for a short to ground in the OEM harness.

  • Measure the resistance from the ether solenoid harness connector (ring terminal) to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ether injection solenoid.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 26 of the OEM 31-pin connector, engine harness side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ether injection solenoid.
  • Disconnect the OEM harness from the engine harness at the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from the OEM harness solenoid connector (ring terminal) to pin 26 of the OEM harness 31-pin connector, OEM side.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 2 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from pin 26 of the 31-pin OEM harness connector to pin 2 of the engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the supply voltage at the ECM.

Guided Step 4A - Check the supply voltage at the ECM.

Conditions

  • Ether injection system enabled.
  • Coolant temperature below the ECM-calibrated threshold.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

  • Measure the supply voltage from pin 2 of the ECM engine harness connector port to engine block ground.
OK NOT OK

More than 17.0 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine.

This must be a cold start.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 384 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Apr-2012


FAULT CODE 415 - Oil Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct.
STEP 2. | Check the oil level. |
 | STEP 2A. Check the oil level in the oil pan. | Oil level is correct.
 | STEP 2B. Check for external oil leaks. | No oil leaks evident.
STEP 3. | Check if the oil filters are plugged. |
 | STEP 3A. Measure the oil pressure differential across the filters. | Pressure differential is correct.
STEP 4. | Check the oil. |
 | STEP 4A. Confirm the correct oil was used. | Specified oil was used.
 | STEP 4B. Check for fuel and coolant dilution. | No fuel or coolant contamination evident.
 | STEP 4C. Check for oil aeration. | Oil aeration levels acceptable.
 | STEP 4D. Check for high oil temperatures. | Oil temperature within specification.
STEP 5. | Check for loss of pressure before sensor. |
 | STEP 5A. Check the main oil rifle pressure regulator. | Main oil rifle pressure regulator is not broken or worn.
 | STEP 5B. Check the piston cooling nozzle. | Piston cooling nozzle is not broken or misassembled.
STEP 6. | Inspect the lubricating pump, lubricating pump plumbing, and high pressure relief valve. |
 | STEP 6A. Check the lubricating suction tube. | Lubricating suction tube is not broken or misassembled.
 | STEP 6B. Check the oil suction tube for blockage. | Oil suction tube is not blocked.
 | STEP 6C. Check the oil transfer plumbing. | Oil transfer plumbing is not broken or misassembled.
 | STEP 6D. Check the oil pump. | Oil pump is not broken or worn.
 | STEP 6E. Check the lubricating pump high pressure regulator. | Lubricating pump high pressure regulator is not broken or misassembled.
STEP 7. | Check for system restriction. |
 | STEP 7A. Check the piston cooling nozzle pressure regulator. | Piston cooling nozzles pressure regulator is not broken or misassembled.
 | STEP 7B. Inspect engine for internal damage. | No internal engine damage found.
 | STEP 7C. Check the engine bearings and bushings for excessive clearances. | Bearing and bushing clearances are within specifications.
 | STEP 7D. Check the oil coolers for blockage. | Oil coolers are not plugged.
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 415 inactive.
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ electronic service tool to the vehicle datalink.
  • Start the engine and compare the oil pressure reading on the monitor screen to the reading on the mechanical oil pressure gauge.

If oil pressure sensor and mechanical gauge readings are zero within 3 seconds after the engine is started, it should be turned off immediately to prevent extended damage.

OK NOT OK

Sensor reading is correct.

Replace the sensors.

Go to 2A

Go to 8A

Guided Step 2 - Check the oil level.

Guided Step 2A - Check the oil level in the oil pan.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil level.
OK NOT OK

Oil level is correct.

Fill the system to the specified level.

Verify the oil pan capacity and dipstick calibration. Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-009 in Section 7.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-025 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-009 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-025 in Section 7.

Use the following procdure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-009 in Section 7.

Use the following procdure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-025 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-009 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-025 in Section 7.

Go to 2B

Go to 8A

Guided Step 2B - Check for external oil leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine for external oil leaks.
OK NOT OK

No oil leaks evident.

Oil leaks found.

Tighten the capscrews, pipe plugs, and fittings. Replace the gaskets if necessary. Reference Section V in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592 the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 3A

Go to 8A

Guided Step 3 - Check if the oil filters are plugged.

Guided Step 3A - Measure the oil pressure differential across the filters.

Conditions

  • Turn keyswitch ON.

Action

Oil filter head pressure differential is within specification.
OK NOT OK

Oil filter head pressure differential is within specification.

Oil filter head pressure differential is above specification. Lubrication filter is plugged.

Replace the oil filters.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-013 in Section 7.

Use the following procdure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-013 in Section 7.

Go to 4A

Go to 8A

Guided Step 4 - Check the oil.

Guided Step 4A - Confirm the correct oil was used.

Conditions

  • Turn keyswitch OFF.

Action

Verify the lubrication oil meets the specification for operating conditions.

  • Reference the Cummins® Engine Oil Recommendations, Service Bulletin 3810340.
OK NOT OK

Lubricating oil meets specifications.

Lubricating oil does not meet specifications.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-013 in Section 7.

Use the following procdure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-013 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-013 in Section 7.

Use the oil type recommended in the Cummins® Engine Oil Recommendations, Service Bulletin 3810340.

Go to 4B

Go to 8A

Guided Step 4B - Check for fuel and coolant dilution.

Conditions

  • Turn keyswitch OFF.

Action

Verify if the oil is contaminated with coolant or fuel.

  • Cut one filter to inspect for debris, or if equipped with an eliminator, open and inspect it for debris.
  • Reference the Cummins® Engine Oil Recommendations, Service Bulletin 3810340.
OK NOT OK

Lubricating oil is not contaminated with coolant or fuel.

Lubricating oil is contaminated with fuel or coolant.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-044 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-044 in Section 7.

Use the following procdure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-044 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-044 in Section 7.

Go to 4C

Go to 8A

Guided Step 4C - Check for oil aeration.

Conditions

  • Turn keyswitch OFF.

Action

Verify the oil aeration/foaming is acceptable.
OK NOT OK

Lubricating oil aeration level meets specifications.

High oil aeration will cause a temporary increase in the engine oil level.

Lubricating oil aeration level does not meet specifications. High oil aeration will cause a temporary increase in the engine oil level.

Check the engine oil level and engine angularity. Change oil and filters.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-037 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-037 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-037 in Section 7.

Ue the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-002 in Section 7.

Use the oil type recommended in the Cummins® Engine Oil Recommendations, Service Bulletin 3810340.

For angularity, see Application Engineering Bulletin AEB 46.02.

Go to 4D

Go to 8A

Guided Step 4D - Check for high oil temperatures.

Conditions

  • Turn keyswitch OFF.

Action

Verify lubricating oil operating temperature meets specification for operating conditions.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 018-017 in Section V.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 018-017 in Section V.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 018-017 in Section V.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 018-017 in Section V.

OK NOT OK

Lubricating oil temperature meets specification.

Lubricating oil does not meet temperature specifications.

Reference Symptom Tree T107 in Section TS, in the following manuals: the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375,and the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 5A

Go to 8A

Guided Step 5 - Check for loss of pressure before sensor.

Guided Step 5A - Check the main oil rifle pressure regulator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the spring, housing, plugs, and o-rings for damage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, bulletin 4021530. Refer to Procedure 007-029 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-029 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-029 in Section 7.

OK NOT OK

Main oil rifle pressure regulator meets specifications.

Main oil rifle pressure regulator does not meet specifications. Replace the necessary parts.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-029 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-029 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-029 in Section 7.

Go to 5B

Go to 8A

Guided Step 5B - Check the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 001-046 in Section 1.

Use the follwoing procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 001-046 in Section 1.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 001-046 in Section 1.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-046 in Section 1.

Do not remove the nozzle at this time, as it can not be reused.

OK NOT OK

Piston cooling nozzle meets specifications.

Piston cooling nozzle does not meet specifications. Replace the necessary parts.

Go to 6A

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 001-046 in Section 1.
Use the follwoing procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 001-046 in Section 1.
Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 001-046 in Section 1.
Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-046 in Section 1.
Go to 8A

Guided Step 6 - Inspect the lubricating pump, lubricating pump plumbing, and high pressure relief valve.

Guided Step 6A - Lubricating suction tube is not broken or misassembled.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the lubricating suction tube for damage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

OK NOT OK

Lubricating suction tube meets specifications.

Lubricating suction tube does not meet specifications.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

Go to 6B

Go to 8A

Guided Step 6B - Check the oil suction tube for blockage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the lubricating suction tube for blockage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

OK NOT OK

Lubricating suction tube meets specifications.

Lubricating suction tube does not meet specifications.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-035 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-035 in Section 7.

Go to 6C

Go to 8A

Guided Step 6C - Check the oil transfer plumbing.

Conditions

  • Turn keyswitch OFF.

Action

Verify the oil transfer plumbing is not cracked and the o-rings and gaskets are not leaking.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-040 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Referto the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-040 in Section 7.

OK NOT OK

Oil transfer plumbing meets specifications.

Oil transfer plumbing does not meet specifications. Replace the necessary parts.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-040 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Referto the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-040 in Section 7.

Go to 6D

Go to 8A

Guided Step 6D - Check the oil pump.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the pump for damage or wear.

Use the following in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-031 in Section 7.

Use the following in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-031 in Section 7.

Use the following in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-031 in Section 7.

Use the following in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-031 in Section 7.

OK NOT OK

Oil pump meets specifications.

Oil pump does not meet specifications. Replace the necessary parts.

Use the following in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-031 in Section 7.

Use the following in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-031 in Section 7.

Use the following in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-031 in Section 7.

Use the following in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-031 in Section 7.

Go to 6E

Go to 8A

Guided Step 6E - Check the lubricating pump high pressure regulator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the lubricating pump high pressure regulator for damage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 402153. Refer to Procedure 007-021 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-029 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-021 in Section 7.

OK NOT OK

Lubricating pump high pressure regulator is not broken or misassembled.

Lubricating pump high pressure relief valve does not meet specifications. Replace the necessary parts.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 402153. Refer to Procedure 007-021 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-029 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-021 in Section 7.

Go to 7A

Go to 8A

Guided Step 7 - Check for system restriction.

Guided Step 7A - Check the piston cooling nozzle pressure regulator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the piston cooling nozzle pressure regulator for damage.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-030 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to the OEM service manual.

OK NOT OK

Piston cooling nozzle pressure regulator meets specifications.

Piston cooling nozzle pressure regulator does not meet specifications.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-030 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to the OEM service manual.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to the OEM service manual

Go to 7B

Go to 8A

Guided Step 7B - Inspect engine for internal damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine for internal damage.

Reference Section 7 of the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

OK NOT OK

No engine damage found.

Internal damage found on block.

Repair the damage.

Reference Section 7 of the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592, or the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Go to 7C

Go to 8A

Guided Step 7C - Check the engine bearings and bushings for excessive clearances.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the main and rod bearings and camshaft bushings for excessive clearances.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 001-005 in Section 1.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 001-005 in Section 1.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 001-005 in Section 1.

Use tthe following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-005 in Section 1.

OK NOT OK

Main bearing, rod bearing, and camshaft bushing clearances meet specifications.

Main bearing, rod bearing, and camshaft bushing clearances do not meet specifications. Replace the necessary parts.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 001-005 in Section 1.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 001-005 in Section 1.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 001-005 in Section 1.

Use tthe following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 001-005 in Section 1.

Go to 7D

Go to 8A

Guided Step 7D - Check the oil coolers for blockage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the oil cooler element for blockage.

  • Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-007 in Section 7.
  • Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-007 in Section 7.
  • Use the following procedure the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-007 in Section 7.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-007 in Section 7.
OK NOT OK

Oil cooler element meets specifications.

Oil cooler element does not meet specifications. Replace the necessary part.

Use the following procedure in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 007-007 in Section 7.

Use the following procedure in the Service Manual, QSK19 and QSK19 CM850 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 007-007 in Section 7.

Use the following procedure the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 007-007 in Section 7.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 007-007 in Section 7.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

If the fault occurred at a particular speed, run the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 415 inactive.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Apr-2012


FAULT CODE 422 - Coolant Level Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for the presence of the coolant level sensor. |
 | STEP 1A. Check if vehicle has a coolant level sensor. | Coolant level sensor present
 | STEP 1A-1. Check if shorting plug is installed in place of the coolant level sensor harness connection. |
STEP 2. | Check for an open circuit in the coolant level sensor circuit. |
 | STEP 2A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 2B. Inspect the harness and sensor connector pins. | No damaged pins
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2C-1. Inspect the 21-pin OEM connector pins. |
 | STEP 2C-2. Check for open circuit. |
 | STEP 2C-3. Inspect the 4-pin Weather-Pack connector pins. |
 | STEP 2C-4. Check for an open circuit. |
 | STEP 2C-5. Check for an open circuit. |
STEP 3. | Check for a short circuit to engine block ground. |
 | STEP 3A. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3A-1. Inspect the harness and sensor connector pins. |
 | STEP 3A-2. Check for a short circuit to ground. |
 | STEP 3A-3. Inspect the harness and sensor connector pins. |
 | STEP 3A-4. Check for a short circuit to ground. |
 | STEP 3A-5. Check for an open circuit. |
STEP 4. | Check for a short circuit from pin to pin. |
 | STEP 4A. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4A-1. Inspect the 21-pin OEM connector pins. |
 | STEP 4A-2. Check for a short circuit from pin to pin. |
 | STEP 4A-3. Inspect the four-way Weather-Pack connector pins. |
 | STEP 4A-4. Check for a short circuit from pin to pin. |
 | STEP 4A-5. Check for a short circuit from pin to pin. |
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 422 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for the presence of the coolant level sensor.

Guided Step 1A - Check if vehicle has a coolant level sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check if vehicle has a coolant level sensor.

Check if vehicle has a coolant level sensor.
OK NOT OK

Coolant level sensor present

No coolant level sensor present

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Check if a shorting plug is installed in place of the coolant level sensor harness connection.

Conditions

  • Turn keyswitch OFF.

Action

Check if a shorting plug is installed in place of the coolant level sensor harness connection.

Check the OEM wiring from the shorting plug to the engine harness connection for problems. Refer to the OEM service manual.
OK NOT OK

Shorting plug installed

Install the shorting plug

Go to 2A

Go to 5A

Guided Step 2 - Check for an open circuit in the coolant level sensor circuit.

Guided Step 2A - Inspect the harness and engine control module (ECM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in section 19.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Inspect the harness and sensor connector pins for the following:

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the coolant level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-071 in section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 14 of the OEM interface harness ECM connector to pin D of the coolant level sensor connector, harness side.
  • Measure the resistance from pin 23 of the OEM interface harness ECM connector to pin A of the coolant level sensor connector, harness side.
  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to pin C of the coolant level sensor connector, harness side.
  • Measure the resistance from pin 21 of the OEM interface harness ECM connector to pin B of the coolant level sensor connector, harness side.
OK NOT OK

Less than 10 ohms

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Inspect the 21-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.

Action

Inspect the harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19 .

Go to 2C-2

Go to 5A

Guided Step 2C-2 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to pin U of the 21-pin connector, OEM interface harness side.
  • Measure the resistance from pin 21 of the OEM interface harness ECM connector to pin V of the 21-pin connector, OEM interface harness side.
  • Measure the resistance from pin 23 of the OEM interface harness ECM connector to pin T of the 21-pin connector, OEM interface harness side.
  • Measure the resistance from pin 14 of the OEM interface harness ECM connector to pin S of the 21-pin connector, OEM interface harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface or OEM harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C-3

Go to 5A

Guided Step 2C-3 - Inspect the 4-pin Weather-Pack connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack 4-way connector.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C-4

Go to 5A

Guided Step 2C-4 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack 4-way connector.

Action

Check for an open circuit.

  • Measure the resistance from pin T of the 21-pin connector, OEM harness side, to pin A of the 4-pin connector, OEM harness side.
  • Measure the resistance from pin V of the 21-pin connector, OEM harness side, to pin B of the 4-pin connector, OEM harness side.
  • Measure the resistance from pin U of the 21-pin connector, OEM harness side, to pin C of the 4-pin connector, OEM harness side.
  • Measure the resistance from pin S of the 21-pin connector, OEM harness side, to pin D of the 4-pin connector, OEM harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C-5

Go to 5A

Guided Step 2C-5 - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM harness at the Weather-Pack 4-way connector.

Action

Check for an open circuit.

  • Measure the resistance from pin D of the 4-pin connector, OEM harness side, to pin D of the coolant level sensor connector, OEM harness side.
  • Measure the resistance from pin A on the OEM wiring harness side of the 4-pin connector to pin A on the OEM harness side of the coolant level sensor connector.
  • Measure the resistance from pin C of the 4-pin connector, OEM harness side, to pin C of the coolant level sensor connector, OEM harness side.
  • Measure the resistance from pin B of the 4-pin connector, OEM harness side, to pin B of the coolant level sensor connector, OEM harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check for a short circuit to engine block ground.

Guided Step 3A - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 23 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 14 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Inspect the harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.

Action

Inspect the Weather-Pack 4-way connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 23 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 14 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in section 19.

Go to 3A-3

Go to 5A

Guided Step 3A-3 - Inspect the harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack 4-way connector.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-4

Go to 5A

Guided Step 3A-4 - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack 4-way connector.

Action

Check for a short circuit to engine blcok ground.

  • Measure the resistance from pin A of the 4-pin connector, OEM harness side, to engine block ground.
  • Measure the resistance from pin C of the 4-pin connector, OEM harness side, to engine block ground.
  • Measure the resistance from pin D of the 4-pin connector, OEM harness side, to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM. Refer to Procedure 019-071 in Section 19.

Go to 3A-5

Go to 5A

Guided Step 3A-5 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack 4-way connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin C of the 21-pin OEM harness connector to engine block ground.
  • Measure the resistance from pin D of the 21-pin OEM harness connector to engine block ground.
  • Measure the resistance from pin A of the 21-pin OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a short circuit from pin to pin.

Guided Step 4A - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 14 of the OEM interface harness ECM connector to all other pins in the connector.

If there is a short from pin 14 to pin 23, 21, or 16, the short circuit is in the coolant level sensor circuit.

  • Measure the resistance from pin 23 of the OEM interface harness ECM connector to all other pins in the connector.

If there is a short from pin 23 to pin 21, 16, or 14, the short circuit is in the coolant level sensor circuit.

  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to pins 23, 21, and 14 of the connector.
OK NOT OK

More than 100k ohms. Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 5A

Go to 4A-1

Guided Step 4A-1 - Inspect the 21-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the coolant level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 14 of the OEM interface harness ECM connector to pins 23, 21, and 16 of the connector.
  • Measure the resistance from pin 23 of the OEM interface harness ECM connector to pins 21, 16, and 14 of the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface or OEM harnesses

  • Repair the OEM interface harness. Refer to Procedure 019-204 in section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Inspect the four-way Weather-Pack connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack four-way connector.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the coolant level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 4A-4

Go to 5A

Guided Step 4A-4 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack four-way connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin S of the 21-pin OEM harness connector to pins T, V, and U of the connector.
  • Measure the resistance from pin T of the 21-pin OEM harness connector to pins V, U, and S of the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A-5

Go to 5A

Guided Step 4A-5 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin OEM connector.
  • Disconnect the OEM harness at the Weather-Pack four-way connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the Weather-Pack four-way connector, harness side, to pins A, B, and C of the connector.
  • Measure the resistance from pin A of the Weather-Pack four-way connector, harness side, to pins B, C, and D of the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let idle it for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 422 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Apr-2012


FAULT CODE 423 - Timing Pressure Sensor In-Range Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™ Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3824774 - Packard™ breakout cable, Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 221 and 222 are not active
STEP 2. | Check the timing pressure sensor. |
 | STEP 2A. Inspect the timing pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 423 active
 | STEP 2C. Check the ECM timing pressure supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the ECM timing pressure supply voltage. |
 | STEP 2D. Check the ECM timing pressure signal voltage. | 0.42 to 0.58 VDC engine stopped
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check for sensor accuracy. |
 | STEP 4A. Compare timing, rail, and ambient air pressure sensors. | Timing pressure approximately equal to rail pressure. Timing pressure approximately equal to half of the ambient air pressure
STEP 5. | Check for drain line restriction. |
 | STEP 5A. Check for drain line restriction. | No restriction in drain line
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 423 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 221 and 222 are not active

Go to 2A

Multiple fault code trees

Guided Step 2 - Check timing pressure sensor.

Guided Step 2A - Inspect the timing pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing pressure sensor.

Action

Inspect the timing pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the timing pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19Refer to Procedure 019-202 in section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 423 active

Repair complete.

Go to 2C

Go to 6B

Guided Step 2C - Check the engine control module (ECM) timing pressure supply voltage.

Conditions

  • Disconnect the timing pressure sensor from the engine harness.
  • Install the appropriate pressure sensor breakout cable between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the timing pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return connectors (pin B) into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ECM timing pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the ECM timing pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC. Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 6A

Go to 3A

Guided Step 2D - Check the ECM timing pressure signal voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the ECM timing pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return connectors (pin B) into the multimeter.
OK NOT OK

0.42 to 0.58 VDC

Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the timing pressure sensor harness connector.
  • Measure the resistance from pin 33 of the engine harness ECM connector to pin C of the timing pressure sensor harness connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the timing pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing pressure sensor.
  • Disconnect the engine harness from the rail pressure sensor.
  • Disconnect the engine harness from the fuel pump pressure sensor (if equipped).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 33 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing pressure sensor.
  • Disconnect the engine harness from the rail pressure sensor.
  • Disconnect the engine harness from the fuel pump pressure sensor (if equipped).

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 5 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 33 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 18 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for sensor accuracy.

Guided Step 4A - Compare timing, rail, and ambient air pressure sensors.

Conditions

  • Turn keyswitch ON.

Action

Compare timing, rail, and ambient air pressure sensors.

  • Use INSITE™ electronic service tool to measure the timing, rail, and ambient air pressure.
OK NOT OK

Timing pressure approximately equal to rail pressure.

Timing pressure approximately equal to half of the ambient air pressure.

Repair or replace the timing pressure sensor

  • Repair the timing pressure sensor. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for drain line restriction.

Guided Step 5A - Check for restriction in drain line.

Conditions

  • Turn keyswitch OFF.

Action

Check for drain line restriction.

  • Check for a drain line restriction.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 006-012 in Section 6
  • Use the following prcedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure Refer to Procedure 006-012 in Section 6
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 006-012 in Section 6
  • Use the foollowing procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-012 in Section 6.
OK NOT OK

No restriction in drain line

Remove and inspect the fuel drain lines.

Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 006-013 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-013 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 006-013 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-013 in Section 6.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 423 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Apr-2012


FAULT CODE 431 - Idle Validation Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the idle validation switch. |
 | STEP 1A. Verify that the idle validation switch is connected to the OEM harness. | Idle validation switch is connected
 | STEP 1B. Inspect the idle validation switch and OEM harness connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | Less than 125 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual) |
 | STEP 2A. Inspect the OEM and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 125 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 431 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the idle validation switch.

Guided Step 1A - Verify that the idle validation switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the idle validation switch is connected to the OEM harness.

Verify that the idle validation switch is connected to the OEM harness.
OK NOT OK

Idle validation switch is connected

Connect the idle validation switch. Connect the idle validation switch to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the idle validation switch and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the idle validation switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or lever or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the accelerator pedal or lever. Refer to the OEM service manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.Refer to Procedure 019-202 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for an open circuit.

  • Measure the resistance from pin C of the idle validation switch to pin A of the idle validation switch with the accelerator pedal or lever depressed.
  • Measure the resistance from pin B of the idle validation switch to pin A of the idle validation switch with the accelerator pedal or lever released.
OK NOT OK

Less than 125 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the idle validation switch to pin C of the idle validation switch with the accelerator pedal or lever both depressed and released.
  • Measure the resistance from pin A of the idle validation switch to pin B of the idle validation switch with the accelerator pedal or lever depressed.
  • Measure the resistance from pin A of the idle validation switch to pin C of the idle validation switch with the accelerator pedal or lever released.
OK NOT OK

More than 100k ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal pedal or lever (keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever or accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manuals.)

Guided Step 2A - Inspect the OEM and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Connect the idle validation switch to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 7 of the OEM harness 31-pin connector to pin 31 of the OEM harness 31-pin connector with the accelerator pedal or lever depressed.
  • Measure the resistance from pin 8 of the OEM harness 31-pin connector to pin 31 of the OEM harness 31-pin connector with the accelerator pedal pedal or lever released.
OK NOT OK

Less than 125 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 7 of the OEM harness 31-pin connector to engine block ground.
  • Measure the resistance from pin 8 of the OEM harness 31-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 7 of the OEM harness 31-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
  • Measure the resistance from pin 8 of the OEM harness 31-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 12 of the OEM interface harness ECM connector to pin 7 of the OEM interface harness 31-pin connector.
  • Measure the resistance from pin 13 of the OEM interface harness ECM connector to pin 8 of the OEM interface harness 31-pin connector.
  • Measure the resistance from pin 21 of the OEM interface harness ECM connector to pin 31 of the OEM interface harness 31-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to the ground.

  • Measure the resistance from pin 12 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 13 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 12 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Depress the accelerator pedal or lever to the full-fuel position.
  • Release the accelerator pedal or lever.
  • Repeat this procedure twice more.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Apr-2012


FAULT CODE 432 - CELECT™-Type Accelerator Pedal or Lever

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 431 not logged
STEP 2. | Check the accelerator position sensor. |
 | STEP 2A. Inspect the OEM harness and accelerator position sensor connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual.) |
 | STEP 3A. Inspect the OEM interface harness and OEM harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the OEM interface harness. |
 | STEP 4A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 432 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 not logged

Troubleshoot Fault Code 431

Go to 2A

Fault Code 431

Guided Step 2 - Check the accelerator position sensor.

Guided Step 2A - Inspect the OEM harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Inspect OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the OEM harness or accelerator pedal or lever. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the accelerator pedal or lever, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair accelerator pedal or lever. Refer to the OEM manual.

If the accelerator or accelerator position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Replace the accelerator pedal or level. Refer to the OEM manual.

If the accelerator or accelerator position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

2B

5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.
  • Install the test connector, Part Number 3823255, onto the sensor on the accelerator pedal or lever.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin C of the sensor test connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator or accelerator position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator or accelerator position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

2C

5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal or lever.
  • Install the test connector, Part Number 3823255, onto the sensor on the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the sensor test connector to pin C of the sensor test connector.

Measure the resistance when the pedal is depressed and released.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator or accelerator position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator or accelerator position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

3A

5A

Guided Step 3 - Check OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manuals.)

Guided Step 3A - Inspect the OEM interface harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Connect the OEM harness to the accelerator pedal or lever.

Action

Check for an open circuit.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector to pin 6 of the connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM harness from the accelerator pedal or lever.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 4 of the OEM harness 31-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
  • Measure the resistance from pin 5 of the OEM harness 31-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

4A

5A

Guided Step 4 - Check the OEM interface harness.

Guided Step 4A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM Interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 ion section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 26 of the OEM interface harness ECM connector to pin 4 of the OEM interface harness 31-pin connector.
  • Measure the resistance from pin 29 of the OEM interface harness ECM connector to pin 5 of the OEM interface harness 31-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 26 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 29 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Depress the accelerator pedal or lever to the full-fuel position.
  • Release the accelerator pedal or lever.
  • Repeat this procedure twice more.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 432 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Apr-2012


FAULT CODE 441 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuses. |
 | STEP 1A. Check for blown fuses. | No blown fuses
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections
 | STEP 2B. Check the battery voltage. | 17.3 to 34.7 VDC; (24-VDC system)
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the OEM interface harness. |
 | STEP 4A. Inspect the OEM interface harness fuse connections. | No damaged connections
 | STEP 4B. Check the OEM interface harness fuse. | Less than 10 ohms
 | STEP 4C. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 4D. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms
 | STEP 4E. Check for a short circuit from pin to pin in the unswitched battery supply. | More than 100K ohms
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the engine harness ground connection. | No damage
 | STEP 5B. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 5C. Check for an open circuit in the block ground circuit. | Less than 10 ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 441 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuses.

Guided Step 1A - Check for blown fuses.

Conditions

  • Turn keyswitch OFF.

Action

Check for blown fuses.

  • Inspect the two 10-amp battery-to-ECM supply voltage fuses on the OEM interface harness. Refer to Procedure 019-198 in Section 19.
OK NOT OK

No blown fuses

Replace the fuses. Refer to Procedure 019-198 in Section 19.

Go to 2A

Go to 6A

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

No damaged connections

Repair or replace the damaged connections

  • Repair the battery connections. Refer to the OEM manual.
  • Replace the battery connections. Refer to the OEM manual.

Go to 2B

Go to 6A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.
OK NOT OK

17.3 to 34.7 VDC (24-VDC system)

Replace the battery. Refer to the OEM manual.

Go to 4A

Go to 6A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair the OEM harness or OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the frequency accelerator to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin L to pin M of the OEM harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to all other pins in the connector except pin M.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the OEM interface harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual.)

Guided Step 4A - Inspect the OEM harness fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two 10-amp fuses from the OEM interface harness.

Action

Inspect the OEM harness fuse connections for the following:

  • Corroded fuses
  • Loose fuses.
OK NOT OK

No damaged connections

Repair or replace the damaged connections

  • Replace the fuses. Refer to Procedure 019-198 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-195 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4B

Go to 5B

Guided Step 4B - Check the OEM interface harness fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two 10-amp fuses from the OEM interface harness.

Action

Check the OEM interface harness fuses.

  • Measure the resistance of the fuses.
OK NOT OK

Less than 10 ohms

Replace the fuses. Refer to Procedure 019-198 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the OEM interface harness. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Measure the resistance from pin 3 of the OEM interface harness ECM connector to the battery connection on the OEM harness.
  • Measure the resistance from pin 4 of the OEM interface harness ECM connector to the battery connection on the OEM harness.
  • Measure the resistance from pin 5 of the OEM interface harness ECM connector to the battery connection on the OEM harness.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness or the OEM harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19..
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for a short circuit from pin to pin in the unswitched battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the battery.

Action

Check for a short circuit from pin to pin in the unswitched battery supply.

  • Measure the resistance from pin 3 of the OEM interface harness ECM connector to all other pins in the connector, except pins 4 and 5.
  • Measure the resistance from pin 4 of the OEM interface harness ECM connector to all other pins in the connector, except pins 3 and 5.
  • Measure the resistance from pin 5 of the OEM interface harness ECM connector to all other pins in the connector, except pins 3 and 4.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Check the engine harness ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine block at the ground connection.

Action

Check the engine harness ground connection.

  • Broken connection
  • Corroded connection
  • Loose connection.
OK NOT OK

No damage

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-197 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for an open circuit in the block ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the block ground circuit.

  • Measure the resistance from pin 7 of the engine harness ECM connector to the engine block ground connection on the engine harness.
  • Measure the resistance from pin 8 of the engine harness ECM connector to the engine block ground connection on the engine harness.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 441 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 2A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Apr-2012


FAULT CODE 442 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 VDC (24-VDC system)
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness fuse connections. | No damaged connections
 | STEP 3B. Check the OEM interface harness fuse. | Less than 10 ohms
 | STEP 3C. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3D. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms
 | STEP 3E. Check for a short circuit from pin to pin in the unswitched battery supply. | More than 100k ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Check the engine harness ground connection. | No damage
 | STEP 4B. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 4C. Check for an open circuit in the block ground circuit. | Less than 10 ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

No damaged connections

Repair or replace the damaged connections

  • Repair the battery connections. Refer to the OEM service manual.
  • Replace the battery connections. Refer to the OEM service manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.
OK NOT OK

17.3 to 34.7 VDC (24-VDC system)

Replace the battery. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair the OEM harness or OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Connect the frequency accelerator to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin L to pin M of the OEM harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the frequency accelerator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to all other pins in the connector except pin M.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM interface harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more details.)

Guided Step 3A - Inspect the OEM harness fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two 10-amp fuses from the OEM interface harness.

Action

Inspect the OEM harness fuse connections for the following:

  • Corroded fuses
  • Loose fuses.
OK NOT OK

No damaged connections

Repair or replace the damaged connections

  • Replace the fuses. Refer to Procedure 019-198 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-195 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3B

Go to 4B

Guided Step 3B - Check the OEM interface harness fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the two 10-amp fuses from the OEM interface harness.

Action

Check the OEM interface harness fuses.

  • Measure the resistance of the fuses.
OK NOT OK

Less than 10 ohms

Replace the fuses. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the OEM interface harness. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19..
  • Replace the ECM. Refer to Procedure 019-031in Section 19..

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Measure the resistance from pin 3 of the OEM interface harness ECM connector to the battery connection on the OEM harness.
  • Measure the resistance from pin 4 of the OEM interface harness ECM connector to the battery connection on the OEM harness.
  • Measure the resistance from pin 5 of the OEM interface harness ECM connector to the battery connection on the OEM harness.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness or the OEM harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin in the unswitched battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the battery.

Action

Check for a short circuit from pin to pin in the unswitched battery supply.

  • Measure the resistance from pin 3 of the OEM interface harness ECM connector to all other pins in the connector, except pins 4 and 5.
  • Measure the resistance from pin 4 of the OEM interface harness ECM connector to all other pins in the connector, except pins 3 and 5.
  • Measure the resistance from pin 5 of the OEM interface harness ECM connector to all other pins in the connector, except pins 3 and 4.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Check the engine harness ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine block at the ground connection.

Action

Check the engine harness ground connection.

  • Broken connection
  • Corroded connection
  • Loose connection.
OK NOT OK

No damage

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-197 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in section 19.Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit in the block ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the battery.

Action

Check for an open circuit in the block ground circuit.

  • Measure the resistance from pin 7 of the engine harness ECM connector to the engine block ground connection on the engine harness.
  • Measure the resistance from pin 8 of the engine harness ECM connector to the engine block ground connection on the engine harness.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 442 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 29-Apr-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Packard™ breakout cable, Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 116 and 118 are not active?
STEP 2. | Check the rail pressure sensor. |
 | STEP 2A. Inspect the rail pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 451 active?
 | STEP 2C. Check the ECM rail pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the ECM rail pressure supply voltage. |
 | STEP 2D. Check the ECM rail pressure signal voltage. | 0.42 to 0.58-VDC engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 451 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 451 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 451 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 116 and 118 are not active?

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the rail pressure sensor.

Guided Step 2A - Inspect the rail pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the rail pressure sensor.

Action

Inspect the rail pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the engine control module (ECM) engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 451 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the ECM rail pressure supply voltage.

Conditions

  • Disconnect the rail pressure sensor from the engine harness
  • Install the appropriate rail pressure sensor breakout cable between the sensor and the engine harness
  • Turn keyswitch ON.

Action

Check the ECM rail pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ECM rail pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the ECM rail pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the ECM rail pressure signal voltage.

Conditions

  • Disconnect the rail pressure sensor from the engine harness.
  • Install the appropriate rail pressure sensor breakout cable between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the ECM rail pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specification.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect timing pressure sensor from the engine harness
  • Disconnect rail pressure sensor from the engine harness
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 31 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the rail pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the rail pressure sensor connector.
  • Measure the resistance from pin 31 of the engine harness ECM connector to pin C of the rail pressure sensor connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the rail pressure sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 451 inactive; Fault Code 452 active?

Fault Code 451 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 31 (signal) to pin 5 (supply) in the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the rail pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 451 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the rail pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the rail pressure sensor
  • Disconnect the engine harness from the timing pressure sensor
  • Disconnect the engine harness from the fuel pump pressure sensor (if equipped).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 31 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to all other pins in the connector.

Look for short circuits from battery or sensor voltage to pin 5, 31, or 18.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 451 inactive?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 451 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 30-Apr-2012


FAULT CODE 452 -- Rail Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Packard™ breakout cable, Part Number 3164752 - DIN breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 117 and 119 are not active?
STEP 2. | Check the rail pressure sensor. |
 | STEP 2A. Inspect the rail pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 452 active?
 | STEP 2C. Check the ECM rail pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check the ECM rail pressure supply voltage. |
 | STEP 2D. Check the ECM rail pressure signal voltage. | 0.42 to 0.58-VDC engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check for the appropriate ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to return pin in the engine control module (ECM) port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 452 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3E. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 452 inactive; Fault Code 451 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 452 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 117 and 119 are not active?

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the rail pressure sensor.

Guided Step 2A - Inspect the rail pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the rail pressure sensor.

Action

Inspect the rail pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 452 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the ECM rail pressure supply voltage.

Conditions

  • Disconnect the rail pressure sensor from the engine harness
  • Install the appropriate rail pressure sensor breakout cable between the sensor and the engine harness
  • Turn keyswitch ON.

Action

Check the ECM rail pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ECM rail pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the ECM rail pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check the ECM rail pressure signal voltage.

Conditions

  • Disconnect the rail pressure sensor from the engine harness
  • Install the rail pressure sensor breakout cable between the sensor and the engine harness
  • Turn keyswitch ON.

Action

Check the ECM rail pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return connectors (pin B) into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 3A

Go to 5A

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect timing pressure sensor from the engine harness
  • Disconnect rail pressure sensor from the engine harness
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the ECM engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 31 of the ECM engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the ECM engine harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the rail pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 5 of the ECM engine harness connector to pin A of the rail pressure sensor harness connector.
  • Measure the resistance from pin 31 of the ECM engine harness connector to pin C of the rail pressure sensor harness connector.
  • Measure the resistance from pin 18 of the ECM engine harness connector to pin B of the rail pressure sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 31 to pin 5 of the ECM engine harness connector port.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 452 inactive; Fault Code 451 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to return pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM.

Action

Check the resistance from signal pin to return pin in the ECM port.

  • Measure the resistance from pin 31 (signal) to pin 18 (return) in the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the rail pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 452 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the rail pressure sensor harness connector.
  • Measure the resistance from pin 31 of the engine harness ECM connector to pin C of the rail pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the rail pressure sensor
  • Disconnect the engine harness from the timing pressure sensor
  • Disconnect the engine harness from the fuel pump pressure sensor (if equipped).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 31 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the rail pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 5 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 31 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 18 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire, Part Number 3822917, from pin 31 to pin 5 of the ECM engine harness connector port
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 452 inactive; Fault Code 451 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 452 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 30-Apr-2012


FAULT CODE 455 - Rail Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823254 - Metri-Pack™ 3-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rail actuator. |
 | STEP 1A. Inspect the rail actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the rail actuator. | 7.0 to 9.0 ohms
 | STEP 1C. Check for a short circuit to ground in the actuator supply wire. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and engine control module (ECM) connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 20 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for a short circuit to power supply. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 455 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the rail actuator.

Guided Step 1A - Inspect the rail actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the rail actuator.

Action

Inspect the rail actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the rail actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the rail actuator. Refer to Procedure 019-337 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the coil resistance of the rail actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the rail actuator.

Action

Check the coil resistance of the rail actuator.

  • Measure the resistance from pin A to pin C of the actuator coil.
OK NOT OK

7.0 to 9.0 ohms

Replace the rail actuator. Refer to Procedure 019-337 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to engine block ground in the actuator supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the rail actuator.

Action

Check for a short circuit to engine block ground in the actuator supply wire.

  • Measure the resistance from pin C of the actuator harness connector to engine block ground.
  • Measure the resistance from pin A of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the rail actuator. Refer to Procedure 019-337 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the rail actuator.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 to pin 10 of the engine harness ECM connector.
OK NOT OK

Less than 20 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the rail actuator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 3 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 10 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the rail actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 10 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Sectio 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the rail actuator.

Action

Check for a short circuit to power supply.

  • Measure the resistance from pin 3 of the engine harness ECM connector to pins 1 and 30 of the connector.
  • Measure the resistance from pin 10 of the engine harness ECM connector to pins 1 and 30 of the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 455 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 30-Apr-2012


FAULT CODE 467 - Timing Current Offset Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823254 - male 3-way Metri-Pack™ connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator. |
 | STEP 1A. Inspect the timing actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the timing actuator. | 7.0 to 9.0 ohms
 | STEP 1C. Check for a short circuit from supply to ground. | More than 100k ohms
STEP 2. | Check the inlet side of the fuel system. |
 | STEP 2A. Check the fuel tank level. | Fuel in tank
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | No leaks, broken lines, or loose fittings
 | STEP 2C. Check the fuel inlet restriction. | Less than 203 mm Hg [8 in Hg]
 | STEP 2D. Check for air in the fuel. | Minimal air in the fuel
STEP 3. | Check the fuel system components. |
 | STEP 3A. Check the fuel pump output pressure. | For QSK19: Minimum 55 psi @ 600 rpm; Minimum 175 psi @ 1300 rpm; Minimum 250 psi @ 2100 rpm; Minimum 265 psi @ 2350 rpm. For QSK45/60: Minimum 110 psi @ 600 rpm; Minimum 200 psi @ 1300 rpm; Minimum 250 psi @ 1900 rpm; Minimum 260 psi @ 2300 rpm. For QSK78: Minimum 115 psi @ 600 rpm; Minimum 245 psi @ 1300 rpm; Minimum 300 psi @ 1900 rpm; Minimum 360 psi @ 2300 rpm
 | STEP 3A-1. Check the injector o-rings. |
 | STEP 3A-2. Check for fuel in the oil or coolant. |
 | STEP 3B. Inspect the actuator screen for debris. | No debris
 | STEP 3C. Inspect the actuator for corrosion. | No corrosion
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 467 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing actuator.

Guided Step 1A - Inspect the timing actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Inspect the timing actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the timing actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing actuator. Refer to Procedure 019-339 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the coil resistance of the timing actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Check the coil resistance of the timing actuator.

  • Measure the resistance from pin A to pin C of the timing actuator connector.
OK NOT OK

7.0 to 9.0 ohms

Replace the timing actuator. Refer to Procedure 019-339 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit from supply to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Check for a short circuit from supply to ground.

  • Measure the resistance from pin A of the timing actuator connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the timing actuator. Refer to Procedure 019-339 in section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the inlet side of the fuel system.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank level for the following:

  • Fuel in the tank.
OK NOT OK

Fuel in tank

Fill tank with fuel

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.
OK NOT OK

No leaks, broken lines, or loose fittings

Repair the leak. Tighten or replace the leaking fitting or fuel line.

  • Replace the fuel line. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet restriction.

  • Measure the fuel inlet restriction. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.Refer to Procedure 005-016 in Section 5.
OK NOT OK

Less than 203 mm Hg [8 in Hg]

Find cause of restriction and remove restriction. Check for clogged fuel filters, debris in the fuel tank, clogged fuel tank vents, collapsed or faulty fuel lines, or faulty check valves.

Go to 2D

Go to 4A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Check for air in the fuel system. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 19.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-016 in Section 19.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 19.
OK NOT OK

Minimal air in the fuel

Find cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel system components.

Guided Step 3A - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the Compuchek® fitting.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 19.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-016 in Section 19.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 19.
OK NOT OK

For QSK19: Minimum 55 psi @ 600 rpm; Minimum 175 psi @ 1300 rpm; Minimum 250 psi @ 2100 rpm; Minimum 265 psi @ 2350 rpm. For QSK45/60: Minimum 110 psi @ 600 rpm; Minimum 200 psi @ 1300 rpm; Minimum 250 psi @ 1900 rpm; Minimum 260 psi @ 2300 rpm. For QSK78:Minimum 115 psi @ 600 rpm; Minimum 245 psi @ 1300 rpm; Minimum 300 psi @ 1900 rpm; Minimum 360 psi @ 2300 rpm

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Check the injector o-rings.

Conditions

  • Turn keyswitch ON.

Action

Check the injector o-rings.

The o-rings can be checked by observing the drain output of the front three versus the rear three cylinders on the QSK19 series engines and by observing the drain output of the left bank of cylinders versus the right bank of cylinders on the QSK45 and QSK60 series engines.

  • Disconnect the drain lines at the T-junction.
  • Place each half into separate, equal-size buckets.
  • Run the engine at rated for enough time to determine if output is equal from each half.
OK NOT OK

Drain output equal from front and rear halves

Replace the injector o-rings on faulty bank. Replace the injector.

Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098 Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 006-026 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-026 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 006-026

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-026 in Section 6.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for fuel in the oil or coolant.

Conditions

  • Turn keyswitch OFF.

Action

Check for fuel in the oil or coolant.

Check for fuel in the oil or coolant.
OK NOT OK

No fuel in the oil or coolant. Replace the timing actuator. Refer to Procedure 019-339 in Section 19.

Go to 4A

Appropriate troubleshooting symptom tree

Guided Step 3B - Inspect the actuator screen for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator screen for debris.

  • Remove the timing actuator to inspect the screen for debris. Refer to Procedure 019-339 in Section 19.
OK NOT OK

No debris

Replace the timing actuator screen. Refer to Procedure 019-112 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the actuator for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator for corrosion.

  • Remove the timing actuator to inspect for corrosion. Refer to Procedure 019-339 in Section 19.
OK NOT OK

No corrosion

Replace the timing actuator. Refer to Procedure 019-339 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 467 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 30-Apr-2012


FAULT CODE 468 - Rail Current Offset Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823254 - male three-way Metri-Pack™ connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rail actuator. |
 | STEP 1A. Inspect the rail actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the railg actuator. | 7.0 to 9.0 ohms
 | STEP 1C. Check for a short circuit from supply to ground. | More than 100k ohms
STEP 2. | Check the inlet side of the fuel system. |
 | STEP 2A. Check the fuel tank level. | Fuel in tank
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | No leaks, broken lines, or loose fittings
 | STEP 2C. Check the fuel inlet restriction. | Less than 203 mm Hg [8 in Hg]
 | STEP 2D. Check for air in the fuel. | Minimal air in the fuel
STEP 3. | Check the fuel system components. |
 | STEP 3A. Check the fuel pump output pressure. | For QSK19: Minimum 55 psi @ 600 rpm; Minimum 175 psi @ 1300 rpm; Minimum 250 psi @ 2100 rpm; Minimum 265 psi @ 2350 rpm. For QSK45/60: Minimum 110 psi @ 600 rpm; Minimum 200 psi @ 1300 rpm; Minimum 250 psi @ 1900 rpm; Minimum 260 psi @ 2300 rpm. For QSK78: Minimum 115 psi @ 600 rpm; Minimum 245 psi @ 1300 rpm; Minimum 300 psi @ 1900 rpm; Minimum 360 psi @ 2300 rpm
 | STEP 3A-1. Check the injector o-rings. |
 | STEP 3A-2. Check for fuel in the oil or coolant. |
 | STEP 3B. Inspect the actuator screen for debris. | No debris
 | STEP 3C. Inspect the actuator for corrosion. | No corrosion
 | STEP 3D. Inspect the fuel shutoff solenoid for excessive wear. | No excessive wear
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 468 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the rail actuator.

Guided Step 1A - Inspect the rail actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the rail actuator.

Action

Inspect the rail actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the rail actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing actuator. Refer to Procedure 019-339 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the coil resistance of the rail actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the rail actuator.

Action

Check the coil resistance of the rail actuator.

  • Measure the resistance from pin A to pin C of the rail actuator connector.
OK NOT OK

7.0 to 9.0 ohms

Replace the rail actuator. Refer to Procedure 019-339 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit from supply to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the rail actuator.

Action

Check for a short circuit from supply to ground.

  • Measure the resistance from pin A of the rail actuator connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the rail actuator. Refer to Procedure 019-339 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the inlet side of the fuel system.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank level for the following:

  • Fuel in the tank.
OK NOT OK

Fuel in tank

Fill tank with fuel

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.
OK NOT OK

No leaks, broken lines, or loose fittings

Repair the leak. Tighten or replace the leaking fitting or fuel line.

  • Replace the fuel line. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-024 in section 6.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet restriction.

  • Measure the fuel inlet restriction. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in section 6.
OK NOT OK

Less than 203 mm Hg [8 in Hg]

Find cause of restriction and remove restriction. Check for clogged fuel filters, debris in the fuel tank, clogged fuel tank vents, collapsed or faulty fuel lines, or faulty check valves.

Go to 2D

Go to 4A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Check for air in the fuel system. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.
OK NOT OK

Minimal air in the fuel

Find cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel system components.

Guided Step 3A - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the Compuchek® fitting. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-016 in Section 5.
  • Use the following procedur in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-016 in Section 5.
  • Use the following procedue in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.Refer to Procedure 005-016 in Section 5.
OK NOT OK

For QSK19: Minimum 55 psi @ 600 rpm; Minimum 175 psi @ 1300 rpm; Minimum 250 psi @ 2100 rpm; Minimum 265 psi @ 2350 rpm. For QSK45/60: Minimum 110 psi @ 600 rpm; Minimum 200 psi @ 1300 rpm; Minimum 250 psi @ 1900 rpm; Minimum 260 psi @ 2300 rpm. For QSK78: Minimum 115 psi @ 600 rpm; Minimum 245 psi @ 1300 rpm; Minimum 300 psi @ 1900 rpm; Minimum 360 psi @ 2300 rpm

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Check the injector o-rings.

Conditions

  • Turn keyswitch ON.

Action

Check the injector o-rings.

The o-rings can be checked by observing the drain output of the front three versus the rear three cylinders on the QSK19 Series engines and by observing the drain output of the left bank of cylinders versus the right bank of cylinders on the QSK45 and QSK60 Series engines.

  • Disconnect the drain lines at the T-junction.
  • Place each half into separate, equal-size buckets.
  • Run the engine at rated for enough time to determine if output is equal from each half.
OK NOT OK

Drain output equal from front and rear halves

Replace the injector o-rings on faulty bank. Replace the injector. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 006-026 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-026 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 006-026 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-026 in Section 6.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for fuel in the oil or coolant.

Conditions

  • Turn keyswitch OFF.

Action

Check for fuel in the oil or coolant.

Check for fuel in the oil or coolant.
OK NOT OK

No fuel in the oil or coolant. Replace the rail actuator. Refer to Procedure 019-339 in Section 19.

Go to 4A

Appropriate troubleshooting symptom tree

Guided Step 3B - Inspect the actuator screen for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator screen for debris.

  • Remove the rail actuator to inspect the screen for debris. Refer to Procedure 019-339 in Section 19.
OK NOT OK

No debris

Replace the rail actuator screen. Refer to Procedure 019-112 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the actuator for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator for corrosion.

  • Remove the rail actuator to inspect for corrosion. Refer to Procedure 019-339 in Section 19.
OK NOT OK

No corrosion

Replace the rail actuator. Refer to Procedure 019-339 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the fuel shutoff solenoid for excessive wear.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel shutoff solenoid for excessive wear.

  • Remove the fuel shutoff solenoid and inspect the spacer for excessive wear.
  • Reference the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098, the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.
  • Inspect the fuel shutoff solenoid spacer for excessive wear.
OK NOT OK

No excessive wear

Repair or replace the fuel shutoff valve. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 005-043 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and run throughout the operating range to verify that Fault Code 468 stays inactive.
OK NOT OK

Fault Code 468 inactive

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 471 - Very Low Oil Level - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil level. |
 | STEP 1A. Verify the oil level. | Oil level is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 471 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the oil level.

Guided Step 1A - Verify the oil level.

Conditions

  • Turn keyswitch OFF.

Action

Verify the oil level using the oil dipstick.

Verify the oil level using the oil dispstick.
OK NOT OK

Oil level is correct

Fill the engine lubricating oil to the appropriate level. Reference to Section V in the Operation and Maintenance Manual, QSK45 and QSK60 Series Engines, Bulletin 3666260.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 471 is inactive.
OK NOT OK

Fault Code 471 inactive

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 489 - Auxiliary Speed Input Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the new ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and OEM interface harness connectors. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM interface harness. |
 | STEP 2A. Inspect the OEM interface harness and ECM connectors. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 489 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and OEM interface harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness.

Action

Inspect the OEM harness and OEM interface harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from OEM interface harness.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

Check for an open circuit.

  • Measure the resistance from pin L of the OEM harness 21-pin connector, OEM interface harness side, to pin A of the OEM harness, frequency input signal sending unit side.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness.
  • Disconnect the OEM harness from the frequency input signal sending unit.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin L of the OEM harness 21-pin connector to all other pins in the connector, except pin M.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM interface harness.

Guided Step 2A - Inspect the OEM interface harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the OEM interface harness ECM connector to pin L of the OEM interface harness 21-pin connector.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 17 of the OEM interface harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 17 of the OEM interface harness to all other pins in the connector, except pin 18.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 489 inactive

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 497 - MultiUnit Synchronous Switch Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the switch. |
 | STEP 1A. Check the resistance from pin 11 to engine block ground. | Less than 10 ohms
 | STEP 1B. Check the resistance from pin 27 to engine block ground. | More than 100k ohms
 | STEP 1C. Check the resistance from pin 11 to engine block ground. | More than 100k ohms
 | STEP 1D. Check the resistance from pin 27 to engine block ground. | Less than 10 ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 497 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the switch.

Guided Step 1A - Check the resistance from pin 11 to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiunit synchronous switch ON.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

temp

  • Measure the resistance from pin 11 of the OEM harness 31-pin connector to engine block ground.
OK NOT OK

Less than 10 ohms

Replace the OEM harness/multiunit synchronous switch. Refer to the OEM service manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance from pin 27 to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiunit synchronous switch ON.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Check the resistance from pin 27 to engine block ground.

  • Measure the resistance from pin 27 of the OEM harness 31-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness/multiunit synchronous switch. Refer to the OEM service manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the resistance from pin 11 to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiunit synchronous switch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Check the resistance from pin 11 to engine block ground.

  • Measure the resistance from pin 11 of the OEM harness 31-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness/multiunit synchronous switch. Refer to the OEM service manual.

Go to 1D

Go to 5A

Guided Step 1D - Check the resistance from pin 27 to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiunit synchronous switch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Check the resistance from pin 27 to engine block ground.

  • Measure the resistance from pin 27 of the OEM harness to engine block ground.
OK NOT OK

Less than 10 ohms

Replace the OEM harness/multiunit synchronous switch. Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM harness and OEM interface harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multiunit synchronous switch from the OEM harness.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the OEM interface harness at the 14-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 of the OEM harness 21-pin connector, OEM interface harness side, to pin K of the OEM harness 14-pin connector, multi-unit sync switch side.
  • Measure the resistance from pin 27 of the OEM harness 21-pin connector, OEM interface harness side, to pin R of the OEM harness 14-pin connector, dashboard fan clutch switch side.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multiunit synchronous switch from the OEM harness.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 11 of the OEM harness 31-pin connector to engine block ground.
  • Measure the resistance from pin 27 of the OEM harness 31-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multiunit synchronous switch from the OEM harness.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the OEM harness 31-pin connector to all other pins in the connector.
  • Measure the resistance from pin 27 of the OEM harness 31-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 of the OEM interface harness 31-pin connector to pin 34 of the OEM interface harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 34 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM interface harness from the OEM harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 34 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine harness 5-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness at the ECM. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine harness 5-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 of the engine harness 31-pin connector to pin 5 of the engine harness 5-pin connector.
  • Measure the resistance from pin 5 of the engine harness 5-pin connector to pin 13 of the engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine harness 5-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 5 of the engine harness 5-pin connector, OEM harness side, to engine block ground.
  • Measure the resistance from pin 5 of the engine harness 5-pin connector, ECM side, to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine harness 5-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness 5-pin connector, OEM harness side, to all other pins in the connector.
  • Measure the resistance from pin 5 of the engine harness 5-pin connector, ECM side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 497 inactive

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 498 - Oil Level Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable,Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack test lead, Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit in the sensor harness. | Less than 10 ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit in the engine harness. | Less than 10 ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5C. Check for an open circuit in the extension harness. | Less than 10 ohms
STEP 6. | Check the ECM response. |
 | STEP 6A. Check for the appropriate ECM response. | Fault Code 498 inactive; Fault Code 499 active
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 498 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil level sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the sensor harness connector from the oil level sensor.

Action

Inspect the sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins.Repair or replace the sensor harness or the oil level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Use the following procedures.
  • Refer to Procedure 019-201 in Section 19
  • Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 2B

Go to 7A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the oil level sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the oil level sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the oil level sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.46 to 4.56 VDC

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 3A

Go to 7A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the engine harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the sensor harness from the engine harness.

Action

Inspect the sensor harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins.Repair or replace the sensor harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Use the following procedures.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level supply pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the oil level return pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the oil level signal pin on the sensor harness connector to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

3C

Go to 7A

Guided Step 3C - Check for an open circuit in the sensor harness.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the oil level return pin on the sensor harness connector to the oil level return pin on the sensor harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level supply pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil level return pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil level signal pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4C

Go to 7A

Guided Step 4C - Check for an open circuit in the engine harness.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the oil level return pin on the engine harness inline connector to the oil level return pin on the sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the extension harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 5B

Go to 7A

Guided Step 5B - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level supply pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level return pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level signal pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for an open circuit in the extension harness.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the oil level return pin on the extension harness connector to the oil level return pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the ECM response.

Guided Step 6A - Check for the appropriate ECM response.

Conditions

  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the oil level signal pin and the oil level return pin on the breakout box.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 498 inactive; Fault Code 499 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 498 inactive

Return to troubleshooting steps or contact a Cummins™ Authorized Repair Lcation if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2012


FAULT CODE 499 - Oil Level Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes active
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit in the sensor harness. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 5B. Check for an open circuit in the extension harness. | Less than 10 ohms
 | STEP 5C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Check the ECM response. |
 | STEP 6A. Check for the appropriate ECM response. | Fault Code 499 inactive; Fault Code 498 active
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 499 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the oil level sensor.
OK NOT OK

No other fault codes active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness connector from the oil level sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins.Repair or replace the engine harness or the oil level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedures.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 2B

Go to 7A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the oil level sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the oil level sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.46 to 4.56 VDC

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 3A

Go to 7A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the engine harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the sensor harness from the engine harness.

Action

Inspect the sensor harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins.Repair or replace the sensor harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Use the following procedures.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 7A

Guided Step 3B - Check for an open circuit in the sensor harness.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the oil level signal pin on the sensor harness connector to the oil level signal pin on the sensor harness sensor connector.
  • Measure the resistance from the oil level supply pin on the sensor harness connector to the oil level supply pin on the sensor harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness

  • Repair the sensor harness. Use the following procedures.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level signal pin on the sensor harness connector to engine block ground.
  • Measure the resistance from the oil level return pin on the sensor harness connector to engine block ground.
  • Measure the resistance from the oil level supply pin on the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness. Use the following procedures.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level supply pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the oil level return pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the oil level signal pin on the sensor harness connector to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness. Use the following procedures.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins.Repair or replace the engine harness or extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check for an open circuit in the engine harness.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the oil level signal pin on the engine harness inline connector to the oil level signal pin on the sensor harness connector.
  • Measure the resistance from the oil level supply pin on the engine harness inline connector to the oil level supply pin on the sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level signal pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the oil level return pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the oil level supply pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level supply pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the oil level return pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the oil level signal pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins.Repair or replace the extension harness or the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check for an open circuit in the extension harness.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the oil level signal pin on the extension harness connector to the oil level signal pin on the extension harness inline connector.
  • Measure the resistance from the oil level supply pin on the extension harness connector to the oil level supply pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level signal pin on the extension harness connector to engine block ground.
  • Measure the resistance from the oil level return pin on the extension harness connector to engine block ground.
  • Measure the resistance from the oil level supply pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5D

Go to 7A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level supply pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level return pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level signal pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the ECM response.

Guided Step 6A - Check for the appropriate ECM response.

Conditions

  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the oil level signal pin and the oil level supply pin on the breakout box.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response.

  • Using the electronic service tool, verify the fault codes.
OK NOT OK

Fault Code 499 inactive; Fault Code 498 active

Replace the ECM. Refer to Procedure 019-031 in section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive..
OK NOT OK

Fault Code 499 inactive

Return to troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2012


FAULT CODE 514 - Rail Fueling Flow Mismatch

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the complaint. |
 | STEP 1A. Check for active fault codes other than Fault Code 514. | Fault codes active?
 | STEP 1B. Interview the driver for engine symptoms present. | Symptoms present?
 | STEP 1C. Monitor the rail parameters for over-pressurization of the rail fuel. | Over-pressurizing the rail fuel?
STEP 2. | Check the inlet side of the fuel system. |
 | STEP 2A. Check the fuel tank level. | Fuel in tank?
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | Broken lines, loose fittings or fuel leaks?
 | STEP 2C. Check the fuel inlet restriction. | Greater than 203 mm Hg [8 in Hg]?
 | STEP 2D. Check for air in the fuel. | Air in fuel?
 | STEP 2E. Inspect the fuel shutoff solenoid for excessive wear. | Excessive wear?
STEP 3. | Check the fuel system components. |
 | STEP 3A. Check the fuel pump output pressure. | Fuel pump output pressure correct?
 | STEP 3A-1. Check the injector o-rings. |
 | STEP 3A-2. Check for fuel in the oil or coolant. |
 | STEP 3B. Inspect the actuator screen for debris. | Debris on inlet actuator screen?
 | STEP 3C. Inspect the actuator for corrosion. | Corrosion on actuator?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 514 inactive?
 | STEP 4B. Clear the inactive fault codes. | Fault codes cleared?

Guided Step 1 - Verify the complaint.

Guided Step 1A - Check for active fault codes other than Fault Code 514.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes other than Fault Code 514.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes active?
YES NO

Investigate other fault codes first.

 No Repair

Appropriate fault code procedure

Go to 1B

Guided Step 1B - Interview the driver for engine symptoms present.

Conditions

  • Turn keyswitch ON.

Action

Interview the driver for the following:

  • Ask the operator if specific symptoms or shutdowns/derates due to Fault Code 112 are present.

Symptoms present?
YES NO
No Repair

Clear the fault code. Inactive faults have been logged. Since the customer is not experiencing a problem, clear the fault code.

Go to 1C

Go to 4B

Guided Step 1C - Monitor the rail parameters for over-pressurization of the rail fuel.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the rail parameters for over-pressurization of the rail fuel.

  • Use INSITE™ electronic service tool to monitor the desired timing fueling and the estimated rail fueling parameters.
  • Is the estimated rail fueling consistently higher than the desired rail fueling? If it is higher, it is over-pressurizing the rail fueling.

Rail fuel over-pressurized?
YES NO

Replace the rail actuator. Refer to Procedure 019-339 in Section 19.

No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the inlet side of the fuel system.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank level for the following:

  • Fuel in the tank?

Fuel in tank?
YES NO
No Repair

Fill the fuel tank.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.

Broken lines, loose fittings, or fuel leaks?
YES NO

Repair the leak. Tighten or replace the leaking fitting or fuel line.

  • Replace the fuel line. Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet restriction as follows:

  • Measure the inlet restriction.
  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Greater than 203 mm Hg [8 in Hg]?
YES NO

Find the cause of restriction and remove restriction. Check for clogged fuel filters, debris in the fuel tank, fuel tank vents clogged, collapsed or faulty fuel lines, or faulty check valves.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Check for air in the fuel system.
  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Air in fuel?
YES NO

Find the cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings, loose or broken fittings, and broken lines.

No Repair

Go to 4A

Go to 3A

Guided Step 2E - Inspect the fuel shutoff solenoid for excessive wear.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel shutoff solenoid for excessive wear.

  • Remove the fuel shutoff solenoid and inspect the spacer for excessive wear. Refer to Procedure 019-050 in Section 19.

Excessive wear?
YES NO

Repair or replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the fuel system components.

Guided Step 3A - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the Compuchek™ fitting.
  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Fuel pump output pressure correct?
YES NO

Minimum Output Pressure for QSK19:

  • Minimum 379 kPa [55 psi] @ 600 rpm
  • Minimum 1207 kPa [175 psi] @ 1300 rpm
  • Minimum 1724 kPa [250 psi] @ 2100 rpm
  • Minimum 1827 kPa [265 psi] @ 2350 rpm.

Minimum Output Pressure for QSK23:

  • Minimum 689 kPa [100 psi] @ 600 rpm
  • Minimum 910 kPa [132 psi] @ 1000 rpm
  • Minimum 1207 kPa [175 psi] @ 1400 rpm
  • Minimum 1434 kPa [208 psi] @1500 rpm
  • Minimum 1779 kPa [258 psi] @ 1800 rpm
  • Minimum 1999 kPa [290 psi] @ 2100 rpm.

Minimum Output Pressure for QSK45 and QSK60:

  • Minimum 758 kPa [110 psi] @ 600 rpm
  • Minimum 1379 kPa [200 psi] @ 1300 rpm
  • Minimum 1724 kPa [250 psi] @ 1900 rpm
  • Minimum 1793 kPa [260 psi] @ 2300 rpm.

Minimum Output Pressure for QSK78:

  • Minimum 793 kPa [115 psi] @ 600 rpm
  • Minimum 1689 kPa [245 psi] @ 1300 rpm
  • Minimum 2068 kPa [300 psi] @ 1900 rpm
  • Minimum 2482 kPa [360 psi] @ 2300 rpm.

Continue troubleshooting.

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Check the injector o-rings.

Conditions

  • Turn keyswitch ON.

Action

Check the injector o-rings.

The o-rings can be checked by observing the drain output of the front three versus the rear three cylinders on the QSK19 series engines and by observing the drain output of the left bank of cylinders versus the right bank of cylinders on the QSK45 and QSK60 series engines.

  • Disconnect the drain lines at the T-junction.
  • Place each half into separate, equal-size buckets.
  • Operate the engine at rated speed for enough time to determine if output is equal from each half.

Drain output equal from front and rear halves?
YES NO
No Repair

Replace the injector o-rings on faulty bank.

Replace the injector.

  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-026 in Section 6.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for fuel in the oil or coolant.

Conditions

  • Turn keyswitch OFF.

Action

Check for fuel in the oil or coolant.

  • Investigate for fuel or oil in coolant.

Fuel in oil or coolant?
YES NO

Replace the rail actuator. Refer to Procedure 019-339 in Section 19.

No Repair

Appropriate troubleshooting symptom tree

Go to 4A

Guided Step 3B - Inspect the actuator screen for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator screen for debris

  • Remove the rail actuator to inspect the screen for debris. Refer to Procedure 019-339 in Section 19.

Debris on inlet actuator screen?
YES NO

Replace the rail actuator screen.

  • Refer to Procedure 019-112 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the actuator for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator for corrosion.

  • Remove the rail actuator to inspect for corrosion. Refer to Procedure 019-339 in Section 19.

Corrosion on actuator?
YES NO

Replace the rail actuator.

  • Refer to Procedure 019-112 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and run throughout the operating range to verify that Fault Code 514 stays inactive.

Fault Code 514 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault codes cleared?
YES NO

Troubleshoot any remaining active fault codes.

 No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Dec-2014


FAULT CODE 527 - Solenoid A Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean
 | STEP 1C. Check the solenoid resistance. | 28 to 32 ohms for 24-VDC systems
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM interface harness and OEM harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Check the ECM and OEM interface harness connector pins. | No damaged pins
 | STEP 3B. Check the supply voltage at the ECM. | More than 17.0 VDC
 | STEP 3C. Check for a short in the solenoid supply wire to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 527 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

Check for extra wires on the solenoid post.
OK NOT OK

No extra wires

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean

Repair ring terminal or replace the solenoid

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

28 to 32 ohms for 24-VDC solenoids

Replace the solenoid. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM interface harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from OEM interface harness.

Action

Check the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the solenoid supply wire to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the OEM harness 21-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Check OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Check the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Confirm dual output A supply voltage is turned on.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.
  • Connect the female end of jumper wire, Part Number 3822917, to pin 1 in the ECM connector port.
  • Attach the clip end of the jumper wire, Part Number 3822917, to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from pin 1 of the ECM side of the OEM harness connector (ECM connector port) to engine block ground.
OK NOT OK

More than 17.0 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 1 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 527 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Sep-2012


FAULT CODE 529 - Solenoid B Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | No extra wires
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean
 | STEP 1C. Check the solenoid resistance. | 28 to 32 ohms for 24-VDC systems
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM interface harness and OEM harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check the supply voltage at the ECM. | More than 17.0 VDC
 | STEP 3C. Check for a short circuit to engine block ground in the solenoid supply wire. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 529 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

Check for extra wires on the solenoid post.
OK NOT OK

No extra wires

Remove the extra wires

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.
OK NOT OK

Solenoid post clean

Repair ring terminal or replace the solenoid

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the solenoid. Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.
OK NOT OK

28 to 32 ohms for 24-VDC solenoids

Replace the solenoid. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM interface harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness.

Action

Inspect the OEM interface harness and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair the OEM harness or the OEM interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the solenoid supply wire to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 inSection 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.
  • Disconnect the OEM harness from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin C of the OEM harness 21-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 inSection 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-204 inSection 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.
  • Connect the female end of jumper wire, Part Number 3822917, to pin 9 in the ECM connector port.
  • Connect the clip end of the jumper wire, Part Number 3822917, to the ECM housing for completion of the ground circuit.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from pin 9 of the ECM side of the OEM harness connector (ECM connector port) to engine block ground.
OK NOT OK

More than 17.0 VDC

Replace the ECM. Refer to Procedure 019-031 in Section.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 9 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM interface harness from the OEM harness at the 21-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 9 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 529 is inactive.
OK NOT OK

Fault Code 529 inactive

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 551 - Idle Validation Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the idle validation switch. |
 | STEP 1A. Verify that the idle validation switch is connected to the OEM harness. | Idle validation switch is connected
 | STEP 1B. Inspect the idle validation switch and OEM harness connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | Less than 125 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more details.) |
 | STEP 2A. Inspect the OEM and OEM interface harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 125 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM interface harness. |
 | STEP 3A. Inspect the OEM interface harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the idle validation switch.

Guided Step 1A - Verify that the idle validation switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the idle validation switch is connected to the OEM harness.

Verify that the idle validation switch is connected to the OEM harness.
OK NOT OK

Idle validation switch is connected

Connect the idle validation switch to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the idle validation switch and the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the idle validation switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the accelerator pedal or lever or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the accelerator pedal or lever. Refer to the OEM manual.

Note: If the accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Repair the OEM harness. Use the following procedure. Refer to Procedure 019-201 in Section 19.
  • Use the following procedure. Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for an open circuit.

  • Measure the resistance from pin C of the idle validation switch to pin A of the idle validation switch with the accelerator pedal or lever depressed.
  • Measure the resistance from pin B of the idle validation switch to pin A of the idle validation switch with the accelerator pedal or lever released.
OK NOT OK

Less than 125 ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the idle validation switch to pin C of the idle validation switch with the accelerator pedal or lever both depressed and released.
  • Measure the resistance from pin A of the idle validation switch to pin B of the idle validation switch with the accelerator pedal or lever depressed.
  • Measure the resistance from pin A of the idle validation switch to pin C of the idle validation switch with the accelerator pedal or lever released.
OK NOT OK

More than 100k ohms

Repair or replace the accelerator pedal or lever

  • Repair the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

  • Replace the accelerator pedal or lever. Refer to the OEM manual.

If the accelerator pedal or lever position sensor is changed or after a calibration download, cycle the accelerator pedal or lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal or lever with the ECM.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more details.)

Guided Step 2A - Inspect the OEM and OEM interface harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.

Action

Inspect the OEM and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the OEM interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section.
  • Repair the OEM harness. Refer to Procedure 019-208 Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 Section 19.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Connect the idle validation switch to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 7 of the OEM harness 31-pin connector to pin 31 of the OEM harness 31-pin connector with the accelerator pedal or lever depressed.
  • Measure the resistance from pin 8 of the OEM harness 31-pin connector to pin 31 of the OEM harness 31-pin connector with the accelerator pedal or lever released.
OK NOT OK

Less than 125 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 7 of the OEM harness 31-pin connector to the engine block ground.
  • Measure the resistance from pin 8 of the OEM harness 31-pin connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 7 of the OEM harness 31-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
  • Measure the resistance from pin 8 of the OEM harness 31-pin connector to all other pins in the OEM harness 21-pin and 31-pin connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM interface harness.

Guided Step 3A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the OEM interface harness. Refer to Procedure 019-204 in Secgtion 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 12 of the OEM interface harness ECM connector to pin 7 of the OEM interface harness 31-pin connector.
  • Measure the resistance from pin 13 of the OEM interface harness ECM connector to pin 8 of the OEM interface harness 31-pin connector.
  • Measure the resistance from pin 21 of the OEM interface harness ECM connector to pin 31 of the OEM interface harness 31-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Use the following procedure. Refer to Procedure 019-208 in Section 19.
  • Use the following procedure. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 31-pin connector.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 12 of the OEM interface harness ECM connector to engine block ground.
  • Measure the resistance from pin 13 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM interface harness

  • Repair the OEM interface harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin and 31-pin connectors.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 12 of the OEM interface harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Depress the accelerator pedal or lever to the full-fuel position.
  • Release the accelerator pedal or lever.
  • Repeat this procedure twice more.
  • Read the fault codes using INSITE™.
  • Verify that Fault Code 551 is inactive.
OK NOT OK

Fault Code 551 inactive

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 553 - Rail Pressure Over Limits

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 514. |
 | STEP 1A. Check for active or inactive counts of 514. | Counts of Fault Code 514
 | STEP 1B. Check for shutdown when Fault Code 514 is active. | Shutdown is enabled
STEP 2. | Check the rail pressure sensor. |
 | STEP 2A. Check the rail pressure sensor accuracy. | 0.40 to 0.61 VDC engine stopped
STEP 3. | Check the ECM. |
 | STEP 3A. Disconnect the power from the ECM and then connect power and run engine. | Fault Code 553 not logged
 | STEP 3B. Calibrate the ECM again and run engine. | Fault Code 553 not logged
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 553 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for Fault Code 514.

Guided Step 1A - Check for active or inactive counts of Fault Code 514.

Conditions

  • Turn keyswitch ON.

Action

Check for active or inactive counts of Fault Code 514.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Counts of Fault Code 514

No counts of Fault Code 514

Go to 1B

Go to 3A

Guided Step 1B - Check for shutdown when Fault Code 514 is active.

Conditions

  • Turn keyswitch ON.

Action

Check for shutdown when Fault Code 514 is active.

  • Verify that the engine shuts down when Fault Code 514 is active. If this information is not available, assume that it does.
OK NOT OK

Shutdown is enabled

Go to 2A

Fault Code 514

Guided Step 2 - Check the rail pressure sensor.

Guided Step 2A - Check the rail pressure sensor accuracy.

Conditions

  • Disconnect the rail pressure sensor from the engine harness.
  • Install the pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the rail pressure sensor accuracy.

  • Measure the signal voltage by connecting the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.40 to 0.61 VDC

Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19..

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Disconnect the power from the ECM and then connect power and run engine.

Conditions

  • Turn keyswitch OFF.

Action

Disconnect the power from the ECM and then connect power and run engine.

  • Turn keyswitch OFF.
  • Disconnect the power to the ECM at the battery.
  • Disconnect INSITE™ electronic service tool.
  • Wait 1 minute.
  • Connect the power to the ECM at the battery.
  • Connect INSITE™.
  • Turn keyswitch ON.
  • Start the engine and let it idle for at least 1 minute.
  • Run engine throughout speed and power range to verify that Fault Code 553 stays inactive.
OK NOT OK

Fault Code 553 not logged

Go to 4A

Go to 3B

Guided Step 3B - Calibrate the ECM again and run engine.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the ECM and run engine.

  • Calibrate the ECM.
  • Start the engine and let it idle for at least 1 minute.
  • Run engine throughout speed range to verify that Fault Code 553 stays inactive.
OK NOT OK

Fault Code 553 not logged

Replace the ECM. Refer to Procedure 019-031 in section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 553 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 554 - Rail Pressure In-Range Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 221 and 222 are not active
STEP 2. | Check the rail pressure sensor. |
 | STEP 2A. Inspect the rail pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes | Fault Code 554 active
 | STEP 2C. Check the ECM rail pressure supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the ECM rail pressure supply voltage. |
 | STEP 2D. Check the ECM rail pressure signal voltage. | 0.42 to 0.58 VDC engine stopped
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check for sensor accuracy. |
 | STEP 4A. Compare timing, rail, and ambient air pressure sensors. | Timing pressure approximately equal to rail pressure. Timing pressure approximately equal to half of the ambient air pressure
STEP 5. | Check for drain line restriction. |
 | STEP 5A. Check for drain line restriction. | No restriction in drain line
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 554 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 221 and 222 are not active

Go to 2A

Multiple fault code trees

Guided Step 2 - Check rail pressure sensor.

Guided Step 2A - Inspect the rail pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the rail pressure sensor.

Action

Inspect the rail pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Use the following procedure. Refer to Procedure 019-201 inSection 19.
  • Use the following procedure. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in section 19.
  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 554 active

Repair complete.

Go to 2C

Go to 6B

Guided Step 2C - Check the ECM rail pressure supply voltage.

Conditions

  • Disconnect the rail pressure sensor from the engine harness.
  • Install the rail pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the rail pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return connectors (pin B) into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the ECM rail pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor (leave breakout cable connected to the engine harness).
  • Turn keyswitch ON.

Action

Check the ECM rail pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25 VDC. Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 6A

Go to 3A

Guided Step 2D - Check the ECM rail pressure signal voltage.

Conditions

  • Disconnect the rail pressure sensor from the engine harness.
  • Install the rail pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the ECM rail pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return connectors (pin B) into the multimeter.
OK NOT OK

0.42 to 0.58 VDC

Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the rail pressure sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the 3-pin sensor connector, engine harness side.
  • Measure the resistance from pin 31 of the engine harness ECM connector to pin C of the 3-pin sensor connector, engine harness side.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the 3-pin sensor connector, engine harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Use the following procedure. Refer to Procedure 019-201 in Section 19.
  • Use the following procedure. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing pressure sensor.
  • Disconnect the engine harness from the rail pressure sensor.
  • Disconnect the engine harness from the fuel pump pressure sensor (if equipped).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 31 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the rail pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 5 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 31 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 18 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for sensor accuracy.

Guided Step 4A - Read the pressure sensor.

Conditions

  • Turn keyswitch ON.

Action

Read the pressure sensor.

  • Use INSITE™ electronic service tool to measure the timing, rail, and ambient air pressure.
OK NOT OK

Timing pressure approximately equal to rail pressure. Timing pressure approximately equal to half of the ambient air pressure

Repair or replace the sensor. Refer to Procedure 019-338 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for drain line restriction.

Guided Step 5A - Check for restriction in drain line.

Conditions

  • Turn keyswitch OFF.

Action

Check for drain line restriction.

  • Check for a drain line restriction. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 006-012 in Section 6..
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-012 in Section 6.
OK NOT OK

No restriction in drain line

Remove and inspect the fuel drain lines. Use the following procedure in the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098. Refer to Procedure 006-013 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375. Refer to Procedure 006-013 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK45 and QSK60 Series Engines, Bulletin 3666261. Refer to Procedure 006-013 in Section 6.

Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 006-013 in Section 6.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 554 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 555 - Blowby Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 555 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify sensor accuracy with a mechanical gauge.

  • Connect a water manometer gauge to the engine.
  • Connect INSITE™ to the vehicle data link.
  • Start engine and compare the blowby pressure reading on service tool monitor screen to reading on water manometer gauge.

Operate the engine at rated rpm and full load (wide-open throttle) until a steady reading is obtained.
OK NOT OK

Sensor reading is correct. Reference the Troubleshooting and Repair Manual, QSK19 Series Engines, Bulletin 3666098, the Troubleshooting and Repair Manual, QSK23 Series Engines, Bulletin 4021375, the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727, for correct specifications.

Go to 2A

Fault Code 719

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

If the fault occurred at a particular speed, run the engine at that speed to verify problem is corrected.

  • Verify that Fault Code 555 is inactive.
OK NOT OK

Fault Code 555 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 719 - Blowby Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test leadPart Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122, 135, 144, 153, 221, and 231 are not active?
STEP 2. | Check the blowby pressure sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 719 active?
 | STEP 2C. Check ECM blowby pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check ECM blowby pressure supply voltage. |
 | STEP 2D. Check ECM blowby pressure signal voltage. | 0.42 to 0.58-VDC engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the ECM response. |
 | STEP 2D-4. Check the resistance from signal pin to supply pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 719 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 719 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 719 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, and 231 are not active?

Possible open circuit in the sensor common return wire.

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the blowby pressure sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 719 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check ECM blowby pressure supply voltage.

Conditions

  • Disconnect the blowby pressure sensor from the engine harness
  • Install the blowby pressure sensor breakout cable, Part Number 3824774, between the sensor and engine harness connector
  • Turn keyswitch ON.

Action

Check the ECM blowby pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return connectors (pin B) into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check ECM blowby pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check ECM blowby pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 5A

Go to 3A

Guided Step 2D - Check ECM blowby pressure signal voltage.

Conditions

  • Disconnect the blowby pressure sensor from the engine harness
  • Install the blowby pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check ECM blowby pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return connectors (pin B) into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specification.

Go to 3A

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect blowby pressure sensor from the engine harness
  • Disconnect rail pressure sensor from the engine harness
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 25 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the blowby pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the blowby pressure sensor harness connector.
  • Measure the resistance from pin 25 of the engine harness ECM connector to pin C of the blowby pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 719 inactive; Fault Code 729 active?

Fault Code 719 active?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

Guided Step 2D-4 - Check the resistance from signal pin to supply pin in the ECM port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Check the resistance from signal pin to supply pin in the ECM port.

  • Measure the resistance from pin 25 (signal) to pin 6 (supply) in the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 719 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the blowby pressure sensor
  • Disconnect the engine harness from the intake manifold air temperature sensor
  • Disconnect the engine harness from the ambient air pressure sensor
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the fuel temperature sensor
  • Disconnect the engine harness from the oil pressure sensor
  • Disconnect the engine harness from the coolant pressure sensor
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 25 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for an ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the ECM
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 719 inactive?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 719 is inactive.
OK NOT OK

Fault Code 719 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 729 - Blowby Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 222, 232, 265, and 471 are not active?
STEP 2. | Check the blowby pressure sensor. |
 | STEP 2A. Inspect the blowby pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 729 active?
 | STEP 2C. Check ECM blowby pressure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check ECM blowby pressure supply voltage. |
 | STEP 2D. Check ECM blowby pressure signal voltage. | 0.42 to 0.58-VDC engine stopped?
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the engine harness. |
 | STEP 2D-3. Check the resistance from SIGNAL pin to RETURN pin in the ECM port. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 729 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3E. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 729 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, 232, 265, and 471 are not active?

Possible open circuit in the sensor common supply wire.

Go to 2A

Multiple fault code trees

Guided Step 2 - Check the blowby pressure sensor.

Guided Step 2A - Inspect the blowby pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Inspect the blowby pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 729 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check ECM blowby pressure supply voltage.

Conditions

  • Disconnect the blowby pressure sensor from the engine harness.
  • Install the blowby pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check ECM blowby pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return connectors (pin B) into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check ECM blowby pressure supply voltage.

Conditions

  • Disconnect the breakout cable from the sensor. (Leave breakout cable connected to the engine harness.)
  • Turn keyswitch ON.

Action

Check the ECM blowby pressure supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC?

  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 4A

Go to 3A

Guided Step 2D - Check ECM blowby pressure signal voltage.

Conditions

  • Disconnect the blowby pressure sensor from the engine harness.
  • Install the blowby pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector.
  • Turn keyswitch ON.

Action

Check the ECM blowby pressure signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return connectors (pin B) into the multimeter.
OK NOT OK

0.42 to 0.58-VDC?

Does not meet specification.

Go to 3A

Go to 4A

Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect blowby pressure sensor from the engine harness.
  • Disconnect rail pressure sensor from the engine harness.
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 25 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

Guided Step 2D-2 - Check for continuity in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the blowby pressure sensor from the engine harness.

Action

Check for continuity in the engine harness.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the blowby pressure sensor harness connector.
  • Measure the resistance from pin 25 of the engine harness ECM connector to pin C of the blowby pressure sensor harness connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

Guided Step 2D-3 - Check the resistance from signal pin to return pin in the ECM port.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the resistance from signal pin to return pin in the ECM port.

  • Measure the resistance from pin 25 (signal) to pin 17 (return) in the ECM engine harness connector port.
OK NOT OK

More than 35k ohms?

  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Less than 35k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 729 active?

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 25 of the engine harness ECM connector to pin C of the blowby pressure harness sensor connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A (+5-VDC supply) of the blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ambient air pressure sensor.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 25 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 25 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 6 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms?

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 729 is inactive.
OK NOT OK

Fault Code 729 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Apr-2013


FAULT CODE 753 - Engine Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the engine speed sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Inspect the engine speed sensor. | No damaged engine speed sensor
 | STEP 1C. Check for an open circuit in the engine speed sensor. | 1000 to 2000 ohms
 | STEP 1D. Check for a short circuit to engine block ground. | More than 10M ohms
 | STEP 1E. Check for a short circuit between coils. | More than 10M ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 2000 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 10M ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 10M ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 753 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the engine speed sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor.
  • Damage to end of sensor caused by camshaft gear.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of sensor.
OK NOT OK

No damaged engine speed sensor

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for an open circuit in the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the engine speed sensor.

Action

Check for an open circuit in the engine speed sensor.

  • Measure the resistance from pin A to pin D (outside pins).
  • Measure the resistance from pin B to pin C (inside pins).

Note: Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.

OK NOT OK

1000 to 2000 ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin A to the engine block ground.
  • Measure the resistance from pin B to the engine block ground.

Note: Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.

OK NOT OK

More than 10M ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance from pin A to pin B.
  • Measure the resistance from pin C to pin D.

Note: Install mating connector with short test leads to sensor connector. While testing sensor, electrical leads from sensor to sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.

OK NOT OK

More than 10M ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 to pin 28 of the engine harness ECM connector.
  • Measure the resistance from pin 37 to pin 38 of the engine harness ECM connector.
OK NOT OK

Less than 2000 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 27 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 28 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 37 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 38 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 10M ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 27 of the engine harness ECM connector to all other pins in the connector.
  • Measure resistance between pin 28 of the engine harness ECM connector to all other pins in the connector.
  • Measure resistance between pin 37 of the engine harness ECM connector to all other pins in the connector.
  • Measure resistance between pin 38 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 10M ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 753 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 2364 - Engine Cold Start Aid - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ether injection solenoid. |
 | STEP 1A. Inspect the injector solenoid connector post and OEM wiring harness connector. | No damage to post or connector
 | STEP 1B. Check the supply voltage at the ether injection solenoid. | More than 17.0 VDC
 | STEP 1C. Check the resistance of the ether injection solenoid. | Refer to OEM manual for specification
STEP 2. | Check the OEM wiring harness. |
 | STEP 2A. Inspect the OEM wiring harness and OEM interface wiring harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness connector and ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the supply voltage at the ECM. |
 | STEP 4A. Check the supply voltage at the ECM. | More than 17.0 VDC
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2364 inactive

Guided Step 1 - Check the ether injection solenoid.

Guided Step 1A - Inspect the injector solenoid connector post and OEM wiring harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

Inspect the injector solenoid connector post and OEM wiring harness connector for the following:

  • Bent or broken OEM wiring harness connector terminal
  • Corroded terminal post on the solenoid
  • Multiple wires on the terminal post
  • Moisture in or on the connector.
OK NOT OK

No damage to post or connector

Repair the damaged connection. Flush the dirt, debris, or moisture from the connector post and ring terminal. Repair or replace the ether injection solenoid or the OEM wiring harness, whichever has the damaged part.

  • Flush the dirt, debris, or moisture from the connector post and ring terminal using electronic contact cleaner, Part Number 3824510.
  • Remove any additional wires connected to the solenoid terminal post.
  • Replace the damaged solenoid. Refer to the OEM manual for procedure.
  • Repair the OEM wiring harness ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the supply voltage at the ether injection solenoid.

Conditions

  • Disconnect the ether injection solenoid from the OEM wiring harness.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ether injection solenoid.

  • Measure the voltage from the OEM wiring harness connector to engine block ground.
OK NOT OK

More than 17.0 VDC. Replace the ether injection solenoid. Refer to the OEM service manual.

Go to 5A

Go to 1C

Guided Step 1C - Check the resistance of the ether injection solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

Check the resistance of the ether injection solenoid.

  • Measure the resistance from the connector post to engine block ground.
OK NOT OK

Refer to OEM manual for specification

Replace the ether injection solenoid. Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM wiring harness and OEM interface wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the ether injection solenoid.
  • Disconnect the OEM wiring harness from the engine wiring harness at the 31-pin connector.

Action

Inspect the OEM wiring harness and OEM interface wiring harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM wiring harness or the OEM wiring interface harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM wiring harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Repair the OEM wiring interface harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM wiring interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the ether injection solenoid.
  • Disconnect the OEM wiring harness from the engine wiring harness at the 31-pin connector.

Action

Check for a short to ground in the OEM wiring harness.

  • Measure the resistance from the ether solenoid harness connector (ring terminal) to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM wiring harness. Refer to Procedure 019-071 in section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the ether injection solenoid.
  • Disconnect the OEM wiring harness from the engine wiring harness at the 31-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 26 of the OEM 31-pin connector, engine wiring harness side, to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the ether injection solenoid.
  • Disconnect the OEM wiring harness from the engine wiring harness at the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from the OEM wiring harness solenoid connector (ring terminal) to pin 26 of the OEM wiring harness 31-pin connector, OEM side.
OK NOT OK

Less than 10 ohms

Replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM harness at the 31-pin connector.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine wiring harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness at the 31-pin connector.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 2 of the engine wiring harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness at the 31-pin connector.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the engine wiring harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness at the 31-pin connector.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for an open circuit in the engine wiring harness.

  • Measure the resistance from pin 26 of the 31-pin OEM wiring harness connector to pin 2 of the engine wiring harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the supply voltage at the ECM.

Guided Step 4A - Check the supply voltage at the ECM.

Conditions

  • Ether injection system enabled.
  • Coolant temperature below the ECM-calibrated threshold.
  • Disconnect the engine wiring harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

  • Measure the supply voltage from pin 2 of the ECM engine wiring harness connector port to engine block ground.
OK NOT OK

More than 17.0 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Disable the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine.

This must be a cold start.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Code 2364 inactive

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 27-Jan-2020


FAULT CODE Multiple A - Multiple Fault Code A on the Engine Harness

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 117 and 452 active
STEP 2. | Check the timing and rail pressure sensors. |
 | STEP 2A. Inspect the timing pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Codes 117 and 452 active
 | STEP 2C. Check the timing pressure sensor. | Less than 4.5 VDC
 | STEP 2D. Inspect the rail pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2E. Read the fault codes. | Fault Codes 117 and 452 active
 | STEP 2F. Check the rail pressure sensor. | Less than 4.5 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Codes 117 and 452 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the ECM. |
 | STEP 4A. Check the supply voltage to the ECM. | 4.75 to 5.25 VDC
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Codes 117 and 452 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 117 and 452 active

Repair complete.

Go to 2A

Go to 5B

Guided Step 2 - Check the timing pressure and rail pressure sensors.

Guided Step 2A - Inspect the timing pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing pressure sensor.

Action

Inspect the timing pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the timing pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 117 and 452 active

Replace the engine harness or the timing pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check the timing pressure sensor.

Conditions

  • Disconnect the timing pressure sensor from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the timing pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the timing pressure sensor. Refer to Procedure 019-191 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Inspect the rail pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail pressure sensor from the engine harness.

Action

Inspect the rail pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 117 and 452 active

Replace the engine harness or the rail pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check the rail pressure sensor.

Conditions

  • Disconnect the rail and timing pressure sensors from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the rail pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the rail pressure sensor. Refer to Procedure 019-338 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 117 and 452 active

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the timing pressure sensor from the engine harness.
  • Disconnect the rail pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the timing pressure sensor harness connector.
  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the rail pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the timing pressure sensor from the engine harness.
  • Disconnect the rail pressure sensor from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 5 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the timing pressure sensor from the engine harness.
  • Disconnect the rail pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the voltage supply.

Conditions

  • Remove pin 6 of the 40-pin engine harness connector.
  • Connect the engine harness to the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply.

  • Measure the voltage from pin 5 of the engine harness ECM connector to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Codes 117 and 452 are inactive.
OK NOT OK

Fault Codes 117 and 452 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple B

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 117, 119, and 452 active
STEP 2. | Check the timing, rail, and fuel pump pressure sensors. |
 | STEP 2A. Inspect the timing pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Codes 117, 119, and 452 active
 | STEP 2C. Check the timing pressure sensor. | Less than 4.5 VDC
 | STEP 2D. Inspect the rail pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2E. Read the fault codes. | Fault Codes 117, 119, and 452 active
 | STEP 2F. Check the rail pressure sensor. | Less than 4.5 VDC
 | STEP 2G. Inspect the fuel pump pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2H. Read the fault codes. | Fault Codes 117, 119, and 452 active
 | STEP 2I. Check the fuel pump pressure sensor. | Less than 4.5 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Codes 117, 119, and 452 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the ECM. |
 | STEP 4A. Check the supply voltage to the ECM. | 4.75 to 5.25 VDC
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault codes. | Fault Codes 117, 119, and 452 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 117, 119, and 452 active

Repair complete.

Go to 2A

Go to 5B

Guided Step 2 - Check the timing and rail pressure sensors.

Guided Step 2A - Inspect the timing pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing pressure sensor.

Action

Inspect the timing pressure sensor and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the timing pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. 019-203.
  • Replace the engine harness. 019-043.
  • Replace the timing pressure sensor. 019-191

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 117, 119, and 452 active

Replace the engine harness or the timing pressure sensor, whichever is faulty

  • Replace the engine harness. 019-043.
  • Replace the timing pressure sensor. 019-191.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
Guided Step 2C - Check the timing pressure sensor.

Conditions

  • Disconnect the timing pressure sensor from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the timing pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the timing pressure sensor019-191.

Go to 2D

Go to 5A

Guided Step 2D - Inspect the rail pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail pressure sensor from the engine harness.

Action

Inspect the rail pressure sensor and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. 019-203.
  • Replace the engine harness. 019-043.
  • Replace the rail pressure sensor. 019-338.

Go to 2E

Go to 5A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 117, 119, and 452 active

Replace the engine harness or the rail pressure sensor, whichever is faulty

  • Replace the engine harness. 019-043.
  • Replace the rail pressure sensor. 019-338.

Go to 2F

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
Guided Step 2F - Check the rail pressure sensor.

Conditions

  • Disconnect the rail and timing pressure sensors from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the rail pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the rail pressure sensor019-338.

Go to 2G

Go to 5A

Guided Step 2G - Inspect the fuel pump pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Inspect the fuel pump pressure sensor and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. 019-203.
  • Replace the engine harness. 019-043.
  • Replace the fuel pump pressure sensor. 019-118.

Go to 2H

Go to 5A

Guided Step 2H - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 117, 119, and 452 active

Replace the engine harness or the fuel pump pressure sensor, whichever is faulty

  • Replace the engine harness. 019-043.
  • Replace the fuel pump pressure sensor. 019-118.

Go to 2I

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
Guided Step 2I - Check the fuel pump pressure sensor.

Conditions

  • Disconnect the fuel, rail, and timing pressure sensors from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel pump pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the fuel pump pressure sensor019-118.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. 019-240.
  • Replace the engine harness. 019-043.
  • Replace the ECM. 019-031.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 117, 119, and 452 active

Repair complete.

Go to 3C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the timing pressure sensor from the engine harness.
  • Disconnect the rail pressure sensor from the engine harness.
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the timing pressure sensor harness connector.
  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the rail pressure sensor harness connector.
  • Measure the resistance from pin 5 of the engine harness ECM connector to pin A of the fuel pump pressure sensor harness connnector.
OK NOT OK

Less than 10 ohms

Replace the engine harness019-043.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the timing pressure sensor from the engine harness.
  • Disconnect the rail pressure sensor from the engine harness.
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 5 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness019-043.

Go to 3E

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the timing pressure sensor from the engine harness.
  • Disconnect the rail pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4A - Check the voltage supply.

Conditions

  • Remove pin 6 of the 40-pin engine harness connector.
  • Connect the engine harness to the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply.

  • Measure the supply voltage from pin 5 of the engine harness ECM connector to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM019-031.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Codes 117, 119, and 452 are inactive.
OK NOT OK

Fault Codes 117, 119, and 452 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Aug-2010


Multiple C

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, and 222 active
STEP 2. | Check the intake manifold air pressure, oil pressure, intake manifold air temperature, and barometric air pressure sensors. |
 | STEP 2A. Inspect the intake manifold air pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Codes 123, 141, and 222 active
 | STEP 2C. Check the intake manifold air pressure sensor. | Less than 4.5 VDC
 | STEP 2D. Inspect the oil pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2E. Read the fault codes. | Fault Codes 123, 141, and 222 active
 | STEP 2F. Check the oil pressure sensor. | Less than 4.5 VDC
 | STEP 2G. Inspect the barometric air pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2H. Read the fault codes. | Fault Codes 123, 141, and 222 active
 | STEP 2I. Check the barometric air pressure sensor. | Less than 4.5 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Codes 123, 141, 222, and 253 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the ECM. |
 | STEP 4A. Check the supply voltage to the ECM. | 4.75 to 5.25 VDC
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault codes. | Fault Codes 123, 141, 222, and 265 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, and 222 active

Repair complete.

Go to 2A

Go to 5B

Guided Step 2 - Check the intake manifold air pressure, oil pressure, intake manifold air temperature, and barometric air pressure sensors.

Guided Step 2A - Inspect the intake manifold air pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold air pressure sensor.

Action

Inspect the intake manifold air pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold air pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, and 222 active

Replace the engine harness or the intake manifold air pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check the intake manifold air pressure sensor.

Conditions

  • Disconnect the intake manifold air pressure sensor from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the intake manifold air pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the intake manifold air pressure sensor Refer to Procedure 019-061 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Inspect the oil pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the oil pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or broken.
  • Repair and eplace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, and 222 active

Replace the engine harness or the oil pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check the oil pressure sensor.

Conditions

  • Disconnect the oil pressure and intake manifold pressure sensors from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the oil pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the oil pressure sensor Refer to Procedure 019-066 in Section 19.

Go to 2G

Go to 5A

Guided Step 2G - Inspect the barometric air pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the barometric air pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the barometric air pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Reparir and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the barometric air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2H

Go to 5A

Guided Step 2H - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, and 222 active

Replace the engine harness or the barometric air pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the barometric air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2L

Go to 5A

Guided Step 2I - Check the barometric air pressure sensor.

Conditions

  • Disconnect the barometric air pressure, oil pressure, and intake manifold air pressure sensors from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the barometric air pressure sensor Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Refer to Procedure 019-004 in Section 19.
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. 019-031.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, and 222 active

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air pressure sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the intake manifold air pressure sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the oil pressure sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the barometric air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 6 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air pressure sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the voltage supply.

Conditions

  • Disconnect the engine harness from the ECM.
  • Remove pin 6 of the 40-pin engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply.

  • Measure the supply voltage from pin 6 of the engine harness ECM connector to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM Refer to Procedure 019-031.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Codes 123, 141, and 222 are inactive.
OK NOT OK

Fault Codes 123, 141, 222, 253, 265, and 471 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple D

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsc™h/AMP™/Metri-Pack™ test lead, Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 222, 232, 252, and 729 active
STEP 2. | Check the intake manifold air pressure, oil pressure, oil level, intake manifold air temperature, barometric air pressure, coolant pressure, and blowby pressure sensors. |
 | STEP 2A. Inspect the intake manifold air pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Codes 123, 141, 222, 232, 252, and 729 active
 | STEP 2C. Check the intake manifold air pressure sensor. | Less than 4.5 VDC
 | STEP 2D. Inspect the oil pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2E. Read the fault codes. | Fault Codes 123, 141, 222, 232, 252, and 729 active
 | STEP 2F. Check the oil pressure sensor. | Less than 4.5 VDC
 | STEP 2G. Inspect the barometric air pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2H. Read the fault codes. | Fault Codes 123, 141, 222, 232, 252, and 729 active
 | STEP 2I. Check the barometric air pressure sensor. | Less than 4.5 VDC
 | STEP 2J. Inspect the coolant pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2K. Read the fault codes. | Fault Codes 123, 141, 222, 232, 252, and 729 active
 | STEP 2L. Check the coolant pressure sensor. | Less than 4.5 VDC
 | STEP 2M. Inspect the blowby pressure sensor and engine harness connector pins. | No damaged pins
 | STEP 2N. Read the fault codes. | Fault Codes 123, 141, 222, 232, 252, and 729 active
 | STEP 2O. Check the blowby pressure sensor. | Less than 4.5 VDC
 | STEP 2P. Inspect oil level sensor pins. | No damaged pins
 | STEP 2Q. Read the fault codes. | Fault codes 123, 141, 222, 232, 252, and 729 active
 | STEP 2R. Check the oil level sensor. | Less than 4.5 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Codes 123, 141, 222, 232, 252, 471, and 729 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the ECM. |
 | STEP 4A. Check the supply voltage to the ECM. | 4.75 to 5.25 VDC
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault codes. | Fault Codes 123, 141, 222, 232, 252, 471, and 729 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, 232, 252, and 729 active

Repair complete.

Go to 2A

Go to 5B

Guided Step 2 - Check the intake manifold air pressure, oil pressure, oil level, intake manifold air temperature, barometric air pressure, coolant pressure, and blowby pressure sensors.

Guided Step 2A - Inspect the intake manifold air pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold air pressure sensor.

Action

Inspect the intake manifold air pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold air pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and eplace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, 232, 252, 471, and 729 active

Replace the engine harness or the intake manifold air pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check the intake manifold air pressure sensor.

Conditions

  • Disconnect the intake manifold air pressure sensor from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the intake manifold air pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the intake manifold air pressure sensor Refer to Procedure 019-061 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Inspect the oil pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the oil pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil pressure sensor, whichever has the damaged pins.

  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in section 19.

Go to 2E

Go to 5A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 154, 222, 232, 252, and 729 active

Replace the engine harness or the oil pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check the oil pressure sensor.

Conditions

  • Disconnect the oil pressure sensor, and intake manifold pressure sensor from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensors and the engine harness.
  • Turn keyswitch ON.

Action

Check the intake manifold and oil pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cables.
OK NOT OK

Less than 4.5 VDC

Replace the intake manifold or oil pressure sensor Refer to Procedure 019-066 in section 19. Refer to Procedure 019-072.

Go to 2G

Go to 5A

Guided Step 2G - Inspect the barometric air pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the barometric air pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the barometric air pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the barometric air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2H

Go to 5A

Guided Step 2H - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, 232, 252, 265, 471, and 729 active

Replace the engine harness or the intake manifold air temperature sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2I

Go to 5A

Guided Step 2I - Check the barometric air pressure sensor.

Conditions

  • Disconnect the barometric air pressure sensor, intake manifold air pressure sensor, amd oil pressure sensor from the engine harness.
  • Install breakout cable, Part Number 3824774, between the barometric air pressure sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the barometric air pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the barometric air pressure sensor Refer to Procedure 019-004 in Section 19.

Go to 2J

Go to 5A

Guided Step 2J - Inspect the coolant pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Inspect the coolant pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2K

Go to 5A

Guided Step 2K - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, 232, 265, 471, and 729 active

Replace the engine harness or the barometric air pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the barometric air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2L

Go to 5A

Guided Step 2L - Check the coolant pressure sensor.

Conditions

  • Disconnect the intake manifold air pressure sensor, oil pressure sensor, barometric air pressure sensor, and coolant pressure sensor from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the coolant pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the coolant pressure sensor Refer to Procedure 019-016 in Section 19.

Go to 2M

Go to 5A

Guided Step 2M - Inspect the blowby pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the blowby pressure sensor from the engine harness.

Action

Inspect the blowby pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2N

Go to 5A

Guided Step 2N - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, 232, 265, 471, and 729 active

Replace the engine harness or the coolant pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2O

Go to 5A

Guided Step 2O - Check the blowby pressure sensor.

Conditions

  • Disconnect the blowby pressure sensor from the engine harness.
  • Install breakout cable, Part Number 3824774, between the sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check the blowby pressure sensor.

  • Measure the voltage between pin A and pin B of the breakout cable.
OK NOT OK

Less than 4.5 VDC

Replace the blowby pressure sensor Refer to Procedure 019-011 in Section 19.

Go to 2P

Go to 5A

Guided Step 2P - Inspect the oil level sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.

Action

Inspect the oil level sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil level sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil level sensor. Refer to Procedure 019-066 in Section 19.

Go to 2Q

Go to 5A

Guided Step 2Q - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 222, 232, 265, 471, and 729 active

Replace the engine harness or the blowby pressure sensor, whichever is faulty

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2R

Go to 5A

Guided Step 2R - Inspect the lubricating oil level sensor.

Conditions

  • Keyswitch in the ON position.

Action

Check the Oil Level Sensor supply voltage.

  • Install break out cable between the lubricating oil level sensor and the engine harness.
  • Measure the voltage from pin A to B on the break out cable.
OK NOT OK

Less that 4.5 VDC

Replace the lubricating oil level sensor.

  • Replace the lubricating oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or broken.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 123, 141, 154, 222, 232, 253, 265, 471, and 729 active

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air pressure sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Disconnect the oil level sensor from the engine harness.
  • Disconnect the coolant pressure sensor from the engine harness.
  • Disconnect the blowby pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the intake manifold air pressure sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the oil pressure sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the intake manifold air temperature sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the barometric air pressure sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the oil level sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the fuel temperature sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the coolant pressure sensor harness connector.
  • Measure the resistance from pin 6 of the engine harness ECM connector to pin A of the blowby pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 6 of the engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air pressure sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Disconnect the oil level sensor from the engine harness.
  • Disconnect the coolant pressure sensor from the engine harness.
  • Disconnect the blowby pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the voltage supply.

Conditions

  • Disconnect the engine harness from the ECM.
  • Remove pin 6 of the 40-pin engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply.

  • Insert a test lead into the pin 6 position of the 40-pin engine harness connector.
  • Measure the supply voltage from the pin 6 position of the engine harness ECM connector to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 123, 141, 154, 222, 232, 253, 265, 471, and 729 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple E

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 134, 235, and 422 active
STEP 2. | Check the remote accelerator position sensor. |
 | STEP 2A. Inspect the remote accelerator position sensor and OEM harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Codes 134, 235, and 422 active
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Read the fault codes. | Fault Codes 134, 235, and 422 active
STEP 3. | Check the coolant level sensor circuit. |
 | STEP 3A. Inspect the coolant level sensor and OEM harness connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Codes 134, 235, and 422 active
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Read the fault codes. | Fault Codes 134, 235, and 422 active
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness and OEM interface harness connector pins. | No damaged pins
 | STEP 4B. Read the fault codes. | Fault Codes 134, 235, and 422 active
 | STEP 4C. Read the fault codes. | Fault Codes 134, 235, and 422 are active
STEP 5. | Check the OEM interface harness. |
 | STEP 5A. Inspect the OEM harness and ECM connector pins. | No damaged pins
 | STEP 5B. Read the fault codes. | Fault Codes 134, 235, and 422 are active
 | STEP 5C. Check for an open circuit. | Less than 10 ohms
 | STEP 5D. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Check the ECM. |
 | STEP 6A. Check the supply voltage. | 4.75 to 5.25 VDC
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault codes. | Fault Codes 134, 235, and 422 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 134, 235, and 422 are active

Repair complete.

Go to 2A

Go to 7B

Guided Step 2 - Check the remote accelerator position sensor.

Guided Step 2A - Inspect the remote accelerator position sensor and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator position sensor from the sensor connector.

Action

Inspect the remote accelerator position sensor and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the sensor harness, or replace the remote accelerator position sensor, whichever has the damaged pins.

NOTE: The remote accelerator position sensor is part of the accelerator pedal assembly.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor connector. Refer to Procedure 019-043 in Section 19.
  • Replace the remote accelerator position sensor. Refer to the OEM manual.

Go to 2B

Go to 7A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 134, 235, and 422 are active

Replace the remote accelerator position sensorRefer to the OEM manual.

Go to 2C

Go to 7A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator position sensor from the sensor harness connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin A of the remote accelerator position sensor connector to engine block ground.
  • Measure the resistance from pin B of the remote accelerator position sensor connector to engine block ground.
  • Measure the resistance from pin C of the remote accelerator position sensor connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the remote accelerator position sensorRefer to the OEM manual.

Go to 2D

Go to 7A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator position sensor from the sensor harness connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the remote accelerator position sensor connector to all other pins in the sensor connector.
OK NOT OK

More than 100k ohms

Replace the remote accelerator position sensorRefer to the OEM manual.

Go to 2E

Go to 7A

Guided Step 2E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the OEM interface harness.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Read the fault codes.

  • Install a jumper wire between pin P and pin N of the 21-pin OEM interface harness connector.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 134, 235, and 422 active

Replace the remote accelerator position sensorRefer to the OEM manual.

Go to 3A

Go to 7A

Guided Step 3 - Check the coolant level sensor.

Guided Step 3A - Inspect the coolant level sensor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the sensor connector.

Action

Inspect the coolant level sensor and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the harness, or replace the coolant level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-072 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 3B

Go to 7A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 134, 235, and 422 active

Replace the coolant level sensor Refer to Procedure 019-017 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the sensor connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin A of the coolant level sensor connector to engine block ground.
  • Measure the resistance from pin B of the coolant level sensor connector to engine block ground.
  • Measure the resistance from pin C of the coolant level sensor connector to engine block ground.
  • Measure the resistance from pin D of the coolant level sensor connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the sensor connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the coolant level sensor connector to all other pins in the sensor connector.
OK NOT OK

More than 100k ohms

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 3E

Go to 7A

Guided Step 3E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the OEM interface harness.

Action

Read the fault codes.

  • Install a jumper wire between pin U and pin S of the 21-pin OEM interface harness connector.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 134, 235, and 422 active

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 3F

Go to 7A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness and OEM interface harness 21-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Inspect the OEM harness and OEM interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM interface harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM harness. Refer to the OEM manual.

Go to 4B

Go to 7A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 134, 235, and 422 active

Repair complete.

Go to 4C

Go to 7B

Guided Step 4C - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Read the fault codes.

  • Pull pin P and pin U in the OEM interface harness 21-pin connector.
  • Connect OEM interface 21-pin connector.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Reinstall pin P and pin U into the 21-pin connector after this troubleshooting step has been completed.

OK NOT OK

Fault Codes 134, 235, and 422 active

Replace the OEM harness. Refer to the OEM manual.

Go to 5A

Go to 7A

Guided Step 5 - Check the OEM interface harness.

Guided Step 5A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the OEM interface harness connector pins. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 134, 235, and 422 active

Repair complete.

Go to 5C

Go to 7B

Guided Step 5C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the remote accelerator position sensor from the OEM interface harness.
  • Disconnect the coolant level sensor from the OEM interface harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to pin U of the 21-pin OEM interface harness connector.
  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to pin P of the 21-pin OEM interface harness connector.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 5D

Go to 7A

Guided Step 5D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the remote accelerator position sensor from the OEM interface harness.
  • Disconnect the coolant level sensor from the OEM interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 5E

Go to 7A

Guided Step 5E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the remote accelerator position sensor from the OEM interface harness.
  • Disconnect the coolant level sensor from the OEM interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 16 of the OEM interface harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the ECM.

Guided Step 6A - Check the supply voltage.

Conditions

  • Disconnect the OEM interface harness from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply from the ECM.

  • Install a jumper wire from pin 3 of the OEM interface connector to pin 3 of the ECM.
  • Measure the supply voltage from pin 5 of the OEM interface harness ECM connector to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 inSection 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 134, 235, and 422 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple F

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Inspect the engine harness, OEM interface harness, and ECM connector pins. | No damaged pins
 | STEP 1B. Check the engine harness for proper ground. | Less than 10 ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Codes 116, 118, 122, 131, 133, 135, 144, 153, 221, 293, 297, 431, and 451 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

Guided Step 1A - Inspect the engine harness, OEM interface harness, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the engine harness, OEM interface harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in Sexction 19.
  • Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the engine harness for proper ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness for proper ground.

  • Measure the resistance from pin 7 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 8 of the engine harness ECM connector to engine block ground.
OK NOT OK

Less than 10 ohms. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 116, 118, 122, 131, 133, 135, 144, 153, 221, 293, 297, 431, and 451 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple G

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Inspect the engine harness, OEM interface harness, and ECM connector pins. | Fault Codes 116, 118, 122, 131, 133, 135, 144, 153, 221, 231, 263, 293, 297, 431, 451, and 719 active
 | STEP 1B. Check the engine harness for proper ground. | Less than 10 ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Codes 116, 118, 122, 131, 133, 135, 144, 153, 221, 231, 263, 293, 297, 431, 451, and 719 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

Guided Step 1A - Inspect the engine harness, OEM interface harness, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the engine harness, OEM interface harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and eplace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair and replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the engine harness for proper ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness for proper ground.

  • Measure the resistance from pin 7 of the engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 8 of the engine harness ECM connector to engine block ground.
OK NOT OK

Less than 10 ohms. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness

  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 116, 118, 122, 131, 133, 135, 153, 221, 231, 293, 431, 451, and 719 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple H

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control modure (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement :Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Codes 122, 135, 144, 153, and 221 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Codes 122, 135, 144, 153, and 221 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repir and eplace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, and 221 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the intake manifold air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 insection 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness ECM connector to pin 18 of the engine harness ECM connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin 11 of the engine harness ECM connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin 21 of the engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 122, 135, 144, 153, and 221 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple I

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Codes 122, 135, 144, 153, 221, 231, and 719 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Codes 122, 135, 144, 153, 221, 231, and 719 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, 231, and 719 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness ECM connector to pin B of the intake manifold air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness ECM connector to pin 18 of the engine harness ECM connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin 11 of the engine harness ECM connector.
  • Measure the resistance from pin 17 of the engine harness ECM connector to pin 21 of the engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 in section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 122, 135, 144, 153, 221, 231, and 719 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple J

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control manual (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Codes 116 and 451 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Codes 116 and 451 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 116 and 451 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the rail pressure sensor connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness ECM connector to pin 17 of the engine harness ECM connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin 11 of the engine harness ECM connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin 21 of the engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 inSection 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 116 and 451 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple K

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement :Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Codes 116, 118, and 451 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Codes 116, 118, and 451 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 116, 118, and 451 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness ECM connector to pin B of the intake manifold air pressure sensor harness connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Sectio 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness ECM connector to pin 17 of the engine harness ECM connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin 11 of the engine harness ECM connector.
  • Measure the resistance from pin 18 of the engine harness ECM connector to pin 21 of the engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 116, 118, and 451 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


Multiple L

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine contro module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the ECM and OEM interface harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Codes 133, 293, 422, and 431 active
 | STEP 1C. Check for an open circuit. | Less than 10 ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Codes 133, 293, 422, and 431 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM interface harness.

Guided Step 1A - Inspect the OEM interface harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Inspect the OEM interface harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM interface harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 133, 293, 422, and 431 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 21-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 of the OEM interface harness ECM connector to pin V of the 21-pin OEM connector.
OK NOT OK

Less than 10 ohms

Replace the OEM interface harness. Refer to Procedure 019-072 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM interface harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 of the engine harness ECM connector to pin 17 of the engine harness ECM connector.
  • Measure the resistance from pin 21 of the engine harness ECM connector to pin 11 of the engine harness ECM connector.
  • Measure the resistance from pin 21 of the engine harness ECM connector to pin 21 of the engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
OK NOT OK

Fault Codes 133, 293, 422, and 431 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jun-2012


INDEX
19-fcmfc00.htm

19-t05-mfc00.htm

19-fcmfc01.htm

19-t05-mfc01.htm

19-fcmfc02.htm

19-t05-mfc02.htm

19-fcmfc03.htm

19-t05-mfc03.htm

19-fcmfc04.htm

19-t05-mfc04.htm

19-fcmfc05.htm

19-t05-mfc05.htm

19-fcmfc06.htm

19-t05-mfc06.htm

19-fcmfc07.htm

19-t05-mfc07.htm

19-fcmfc08.htm

19-t05-mfc08.htm

19-fcmfc09.htm

19-t05-mfc09.htm

19-fcmfc10.htm

19-t05-mfc10.htm

19-fcmfc11.htm

19-t05-mfc11.htm

19-fc111.htm

19-t05-111.htm

19-fc112.htm

19-t05-112.htm

19-fc113.htm

19-t05-113.htm

19-fc115.htm

19-t05-115.htm

19-fc116.htm

19-t05-116.htm

19-fc117.htm

19-t05-117.htm

19-fc118.htm

19-t05-118.htm

19-fc119.htm

19-t05-119.htm

19-fc121.htm

19-t05-121.htm

19-fc122.htm

19-t05-122.htm

19-fc123.htm

19-t05-123.htm

19-fc127.htm

19-t05-127.htm

19-fc131.htm

19-t05-131.htm

19-fc132.htm

19-t05-132.htm

19-fc133.htm

19-t05-133.htm

19-fc134.htm

19-t05-134.htm

19-fc135.htm

19-t05-135.htm

19-fc141.htm

19-t05-141.htm

19-fc143.htm

19-t05-143.htm

19-fc144.htm

19-t05-144.htm

19-fc145.htm

19-t05-145.htm

19-fc147.htm

19-t05-147.htm

19-fc148.htm

19-t05-148.htm

19-fc151.htm

19-t05-151.htm

19-fc153.htm

19-t05-153.htm

19-fc154.htm

19-t05-154.htm

19-fc155.htm

19-t05-155.htm

19-fc219.htm

19-t05-219.htm

19-fc221.htm

19-t05-221.htm

19-fc222.htm

19-t05-222.htm

19-fc223.htm

19-t05-223.htm

19-fc225.htm

19-t05-225.htm

19-fc231.htm

19-t05-231.htm

19-fc232.htm

19-t05-232.htm

19-fc233.htm

19-t05-233.htm

19-fc234.htm

19-t05-234.htm

19-fc235.htm

19-t05-235.htm

19-fc237.htm

19-t05-237.htm

19-fc252.htm

19-t05-252.htm

19-fc253.htm

19-t05-253.htm

19-fc254.htm

19-t05-254.htm

19-fc259.htm

19-t05-259.htm

19-fc261.htm

19-t05-261.htm

19-fc263.htm

19-t05-263.htm

19-fc265.htm

19-t05-265.htm

19-fc292.htm

19-t05-292.htm

19-fc293.htm

19-t05-293.htm

19-fc294.htm

19-t05-294.htm

19-fc296.htm

19-t05-296.htm

19-fc297.htm

19-t05-297.htm

19-fc298.htm

19-t05-298.htm

19-fc299.htm

19-fc316.htm

19-t05-316.htm

19-fc318.htm

19-t05-318.htm

19-fc343.htm

19-t05-343.htm

19-fc346.htm

19-t05-346.htm

19-fc349.htm

19-t05-349.htm

19-fc384.htm

19-t05-384.htm

19-fc415.htm

19-t05-415.htm

19-fc422.htm

19-t05-422.htm

19-fc423.htm

19-t05-423.htm

19-fc426.htm

19-fc427.htm

19-fc431.htm

19-t05-431.htm

19-fc432.htm

19-t05-432.htm

19-fc441.htm

19-t05-441.htm

19-fc442.htm

19-t05-442.htm

19-fc451.htm

19-t05-451.htm

19-fc452.htm

19-t05-452.htm

19-fc455.htm

19-t05-455.htm

19-fc467.htm

19-t05-467.htm

19-fc468.htm

19-t05-468.htm

19-fc471.htm

19-t05-471.htm

19-fc487.htm

19-fc489.htm

19-t05-489.htm

19-fc497.htm

19-t05-497.htm

19-fc498.htm

19-t05-498.htm

19-fc499.htm

19-t05-499.htm

19-fc514.htm

19-t05-514.htm

19-fc527.htm

19-t05-527.htm

19-fc529.htm

19-t05-529.htm

19-fc551.htm

19-t05-551.htm

19-fc553.htm

19-t05-553.htm

19-fc554.htm

19-t05-554.htm

19-fc555.htm

19-t05-555.htm

19-fc611.htm

19-fc649.htm

19-fc719.htm

19-t05-719.htm

19-fc729.htm

19-t05-729.htm

19-fc753.htm

19-t05-753.htm

19-fc777.htm

19-fc2364.htm

19-t05-2364.htm