CELECT

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Position Sensor (EPS) Circuit

FAULT CODE 115

Engine Position Sensor (EPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Red SRT: 00-081 | No engine speed signal detected at both pairs of engine position sensor signal pins: 1 and 15 or 11 and 14 of the sensor harness connector. | Engine will die and not restart.
Engine Position Sensor (EPS) Circuit

Circuit Description

The engine position sensor monitors the engine position and the engine speed and passes this information to the electronic control module (ECM) through the sensor harness.

Component Location

M11 - The engine position sensor is located above the accessory drive. N14 - The engine position sensor is located at the backside of the gear housing flange on the cylinder block, just above the lubrication pump.

Shop Talk

If the fault occurs only at a certain engine temperature, check the engine position sensor circuit while the engine is at that particular temperature. Check the camshaft end play to make sure that camshaft gear is not moving too far away from the end of the engine position sensor. Check for moisture in the sensor harness connector at the ECM. If the engine runs rough, check that the engine position sensor is wired with proper polarity. Correct ECM-to-engine position circuit pin-to-pin wiring must be observed. Monitor the engine rpm while cranking the engine with an electronic service tool. No engine speed shown indicates a problem with engine position sensor circuitry.

Refer to Troubleshooting Fault Code t05-115

Last Modified: 20-Dec-2012
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Position Sensor (EPS) Circuit

FAULT CODE 121

Engine Position Sensor (EPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: 190 SPN: 190 FMI: 10 LAMP: Yellow SRT: 00-081 | No engine speed signal detected at one pair of pins, either pins 1 and 15 or pins 11 and 14 of the sensor harness. | None on performance.
Engine Position Sensor (EPS) Circuit

Circuit Description

The engine position sensor monitors the engine position and the engine speed and passes this information to the electronic control module (ECM) through the sensor harness.

Component Location

M11 - The engine position sensor is located above the accessory drive. N14 - The engine position sensor is located at the backside of the gear housing flange on the cylinder block, just above the lubrication pump.

Shop Talk

If the fault occurs only at a certain engine operating temperature, check the engine position sensor circuit while the engine is at that particular temperature. Check the camshaft end play to make sure the camshaft gear is not moving too far away from the end of the engine position sensor. Check for moisture in the sensor harness connector at the ECM. If the engine runs rough, check that the engine position sensor is wired with proper polarity. Correct ECM-to-engine position sensor pin-to-pin wiring must be observed.

Refer to Troubleshooting Fault Code t05-121

Last Modified: 20-Dec-2012


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Yellow SRT: 00-093 | High voltage detected at intake manifold pressure sensor signal pin 26 of the sensor harness connector. | Possible engine derate.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If the intake manifold pressure becomes too high, it will cause a possible derate condition.

Component Location

The intake manifold pressure sensor is located on the intake air manifold.

Shop Talk

Determine if engine is being overfueled. Confirm that the correct intake manifold pressure sensor part number is being used. Confirm that the correct turbocharger is being used. If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air. Inspect the intake manifold pressure sensor circuit for signs of tampering. Remove any extra wires from the circuit.

Refer to Troubleshooting Fault Code t05-122


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Yellow SRT: 00-093 | Low voltage detected at the intake manifold pressure sensor signal pin 26 of sensor harness connector. | Possible engine derate.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If intake manifold pressure becomes too low, it will cause a possible derate condition.

Component Location

The intake manifold pressure sensor is located on the intake air manifold.

Shop Talk

Check for high restriction in the intake air manifold because of a shutdown device in the manifold, if the vehicle is equipped with one.

Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature. Removing it can cause severe personal injury or death.

Refer to Troubleshooting Fault Code t05-123


Fault Code Path Selection

FAULT CODE 131
Fault Code Path Selection

Do you have an ISS throttle pedal? | Go to 83-fc131iss
Do you have an IVS throttle pedal? | Go to 83-fc131ivs

Last Modified: 08-Sep-2004


Fault Code Path Selection

FAULT CODE 132
Fault Code Path Selection

Do you have an ISS throttle pedal? | Go to 83-fc132iss
Do you have an IVS throttle pedal? | Go to 83-fc132ivs

Last Modified: 14-Oct-2003


Oil Pressure Sensor Circuit

FAULT CODE 135

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Yellow SRT: 00-087 | High voltage detected at oil pressure sensor signal pin 7 of the sensor harness connector. | No engine protection for high oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

M11 - The oil pressure sensor is located on the engine block to the right of the ECM. 1994 N14 - The oil pressure sensor is located on the engine block near the pan rail on the fuel pump side of the engine. 1991 N14 - The oil pressure sensor is located on the engine block above the fuel supply pump.

Shop Talk

Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.

Refer to Troubleshooting Fault Code t05-135


Oil Pressure Sensor Circuit

FAULT CODE 141

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: 00-087 | Low voltage detected at oil pressure sensor signal pin 7 of the sensor harness connector. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

M11 - The oil pressure sensor is located on the engine block to the right of the ECM. 1994 N14 - The oil pressure sensor is located on the engine block near the pan rail on the fuel pump side of the engine. 1991 N14 - The oil pressure sensor is located on the engine block above the fuel supply pump.

Shop Talk

If Fault Code 143 or 415 is not present, the problem is not base engine related.

Refer to Troubleshooting Fault Code t05-141


Oil Pressure - Engine Protection

FAULT CODE 143

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1 LAMP: Engine Protection or Red SRT: 00-057 | Low oil pressure has been detected. Voltage at oil pressure signal pin 7 of the sensor harness connector indicates oil pressure lower than 55 kPa [8 psi] at idle to 800 rpm; 55 to 173 kPa [8 to 25 psi] at 800 to 1200 rpm; 173 to 208 kPa [25 to 30 psi] at 1200 to 2400 rpm for M11; 138 to 208 kPa [20 to 30 psi] at 1200 to 2400 rpm for N14. | Progressive power and speed derate with increasing time after alert. If Engine Protection Shutdown is enabled, engine will shut down 30 seconds after the engine protection lamp or the Red lamp* starts flashing.
Oil Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the oil pressure sensor to monitor the lubricating oil pressure. The ECM converts the signal pin voltage to a pressure value. The ECM uses this value for the engine protection system.

Component Location

M11 - The oil pressure sensor is located on the engine block to the right of the ECM. 1994 N14 - The oil pressure sensor is on the engine block, near the pan rail, on the fuel pump side of the engine. 1991 N14 - The oil pressure sensor is on the engine block, above the fuel supply pump.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is operated at too low of a speed under load, oil pressure can drop below the engine protection limits. Use breakout cable, Part Number 3824775, between the oil pressure sensor and the sensor connector, keyswitch ON and oil pressure sensor connected and disconnected; confirm the supply voltage is 4.75 to 5.25 VDC. *Applies to 98N14 and 98M11 calibrations only.

Refer to Troubleshooting Fault Code t05-143


Coolant Temperature Sensor Circuit

FAULT CODE 144

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Yellow SRT: 00-088 | High voltage detected at the coolant temperature signal pin 17 of the sensor harness connector. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

M11 - The coolant temperature sensor is located in the front of the thermostat housing support on most applications. On bus applications, the coolant temperature sensor is usually located at the rear of the thermostat housing support. N14 - The coolant temperature sensor is located on the top of the thermostat housing.

Shop Talk

The resistance of the sensor varies with the temperature. Compare the reading with this table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-144


Coolant Temperature Sensor Circuit

FAULT CODE 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Yellow SRT: 00-089 | Low voltage detected at the coolant temperature signal pin 17 of the sensor harness connector. | Possible white smoke. Fan will stay on if controlled by the electronic control module (ECM). No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

M11 - The coolant temperature sensor is located in the front of the thermostat housing support on most applications. On bus applications, the coolant temperature sensor is usually located at the rear of the thermostat housing support. N14 - The coolant temperature sensor is located on the top of the thermostat housing.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your reading with this table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145


Coolant Temperature - Engine Protection

FAULT CODE 151

Coolant Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Engine Protection or Red SRT: 00-014 | Voltage at the coolant temperature signal pin 17 of the sensor harness connector indicates the coolant temperature is above 104°C [219°F]. | Progressive power and speed derate with increasing time after alert. If Engine Protection Shutdown is enabled, the engine will shut down 30 seconds after the engine protection lamp or the Red lamp* starts flashing.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system and the timing and fueling control.

Component Location

M11 - The coolant temperature sensor is located in the front of the thermostat housing support on most M11 applications. On bus applications, the sensor will usually be located at the rear on the thermostat housing support. N14 - The coolant temperature sensor is located on the top of the thermostat housing.

Shop Talk

Make sure the airflow through the radiator is not obstructed. *Applies to 98N14 and 98M11 calibrations only.

Refer to Troubleshooting Fault Code t05-151


Intake Manifold Air Temperature Sensor Circuit

FAULT CODE 153

Intake Manifold Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Yellow SRT: 00-090 | High voltage detected at the intake manifold air temperature signal pin 25 of the sensor harness connector. | Fan will stay on if controlled by the electronic control module (ECM). No engine protection for intake manifold air temperature.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is used by the ECM to monitor the temperature of the engine intake air. The intake manifold air temperature signal is used by the ECM for the engine protection system and timing and fueling control.

Component Location

M11 - The intake manifold air temperature sensor is located on the top rear half of the intake manifold. N14 - The intake manifold air temperature sensor is located on the side of the intake manifold just above the ECM.

Shop Talk

The resistance of the sensor varies with the temperature. Compare the reading with this table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153


Intake Manifold Air Temperature Sensor Circuit

FAULT CODE 154

Intake Manifold Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Yellow SRT: 00-090 | Low voltage detected at the intake manifold air temperature signal pin 25 of the sensor harness connector. | Fan clutch engaged if ECM controlled. No engine protection for intake manifold air temperature.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is used by the ECM to monitor the temperature of the engine intake air. The intake manifold air temperature signal is used by the ECM for the engine protection system, and the timing and fueling control.

Component Location

M11 - The intake manifold air temperature sensor is located on the top rear half of the intake manifold. N14 - The intake manifold air temperature sensor is located on the side of the intake manifold above the ECM.

Shop Talk

The resistance of the sensor varies with the temperature. Compare the reading with this table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154


Intake Manifold Air Temperature Sensor - Engine Protection

FAULT CODE 155

Intake Manifold Air Temperature Sensor - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Engine Protection or Yellow* SRT: None | Voltage at the intake manifold air temperature sensor signal pin 25 of the sensor harness connector indicates the intake manifold air temperature above 84°C [183°F]. | Progressive power and speed derate with increasing time after alert. If Engine Protection Shutdown is enabled, the engine will shut down 30 seconds after the engine protection lamp or the Red lamp* starts flashing.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine intake air. The intake air temperature is used by the ECM for the engine protection system, and the timing and fueling control.

Component Location

M11 - The intake manifold air temperature sensor is located on the top rear of the intake manifold next to the intake manifold pressure sensor. N14 - The intake manifold air temperature sensor is located on the side of the intake manifold just above the ECM.

Shop Talk

Make sure the engine compartment temperature does not get too high, above 93.3°C [200°F].

*Applies to 98N14 and 98M11 calibrations only.

Refer to Troubleshooting Fault Code t05-155


Oil Temperature Sensor Circuit

FAULT CODE 212

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3 LAMP: Yellow SRT: 00-093 | High voltage detected at the oil temperature signal pin 6 of the sensor harness connector. | No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor monitors oil temperature and passes the information to the electronic control module (ECM) through the sensor harness. If the oil temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

M11 - The oil temperature sensor is located on the engine block behind the ECM. N14 - The oil temperature sensor is located in the lubricating oil pump housing.

Shop Talk

The resistance of the sensor varies with the temperature. Compare the reading with this table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-212


Oil Temperature Sensor Circuit

FAULT CODE 213

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4 LAMP: Yellow SRT: 00-093 | Low voltage detected at the oil temperature signal pin 6 of the sensor harness connector. | No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor monitors oil temperature and passes information to the electronic control module (ECM) through the sensor harness. If the oil temperature becomes too high and engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

M11 - The oil temperature sensor is located on the engine block behind the ECM. N14 - The oil temperature sensor is located in the lubricating oil pump housing.

Shop Talk

The resistance of the sensor varies with the temperature. Compare your reading with this table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-213


Oil Temperature - Engine Protection

FAULT CODE 214

Oil Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0 LAMP: Engine Protection, Red, or Yellow* SRT: 00-059 | High oil temperature detected. Voltage at the oil temperature signal pin 6 of the sensor harness connector indicates the oil temperature above 123.9°C [255°F]. | Progressive power and speed derate with increasing time after alert. If Engine Protection Shutdown is enabled, the engine will shut down 30 seconds after the engine protection lamp or the Red lamp* starts flashing.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor monitors oil temperature and passes the information to the electronic control module (ECM) through the sensor harness. If the oil temperature becomes too high and engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

M11 - The oil temperature sensor is located on the engine block behind the ECM. N14 - The oil temperature sensor is located in the lubricating pump housing.

Shop Talk

Check for high restriction on both the oil and coolant sides of the oil cooler. Make sure the oil cooler thermostat is working correctly.

*Applies to 98N14 and 98M11 calibrations only.

Refer to Troubleshooting Fault Code t05-214


Ambient Air Pressure Sensor Circuit

FAULT CODE 221

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3 LAMP: Yellow SRT: 00-094 | High voltage detected at ambient air pressure sensor signal pin 27 of the sensor harness connector. | Engine power output derated by 15 percent.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor monitors atmospheric pressure and passes the information to the electronic control module (ECM) through the sensor harness.

Component Location

M11 - The ambient air pressure sensor is located on the engine block above the fuel supply pump. 1994 N14 - The ambient air pressure sensor is located on the engine block to the right of the ECM. 1991 N14 - The ambient air pressure sensor is located on the engine block to the left of the ECM.

Shop Talk

Monitor the ambient air pressure reading with a service tool to confirm that the pressure reading matches the actual air pressure.

Refer to Troubleshooting Fault Code t05-221


Ambient Air Pressure Sensor Circuit

FAULT CODE 222

Ambient Air Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4 LAMP: Yellow SRT: 00-095 | Low voltage detected at the ambient air pressure sensor signal pin 27 of the sensor harness connector. | Engine power output derated by 15 percent.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor monitors atmospheric pressure and passes information to the electronic control module (ECM) through the sensor harness.

Component Location

M11 - The ambient air pressure sensor is located on the engine block above the fuel supply pump. 1994 N14 - The ambient air pressure sensor is located on the engine block to the right of the ECM. 1991 N14 - The ambient air pressure sensor is located on the engine block to the left of the ECM.

Shop Talk

Monitor the ambient air pressure reading with a service tool to confirm that the pressure reading matches the actual air pressure.

For active Fault Code 222 after a recalibration, verify an ambient air pressure sensor is part of the Control Parts List (CPL). If not, recalibrate with “a calibration without save and restore” that does not require an ambient air pressure sensor, or install an ambient air pressure sensor.

Refer to Troubleshooting Fault Code t05-222


Engine Overspeed

FAULT CODE 234

Engine Overspeed

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0 LAMP: Red SRT: None | Engine speed signal on pins 1 and 15 and/or pins 11 and 14 of the sensor harness connector indicated engine speed is greater than 2630 rpm. | Fuel shutoff valve closed until engine speed falls to 2000 rpm.
Engine Position Sensor Circuit

Circuit Description

The engine position sensor (EPS) monitors engine position and engine speed, and passes this information to the electronic control module (ECM) through the sensor harness.

Component Location

M11 - The EPS is located above the accessory drive. N14 - The EPS is located at the back of the gear housing flange on the cylinder block, just above the lubrication pump.

Shop Talk

Inspect the engine position sensor for signs of damage or tampering.

Refer to Troubleshooting Fault Code t05-234


Engine Coolant Level - Engine Protection

FAULT CODE 235

Engine Coolant Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1 LAMP: Engine Protection, Red, or Yellow* SRT: 00-107 | Voltage on the coolant level low signal pin 9 of the coolant level sensor on the sensor harness connector indicates low radiator coolant level. | Progressive power and speed derate with increasing time after alert. If Engine Protection Shutdown is enabled, engine will shut down 30 seconds after the engine protection lamp or the Red lamp* starts flashing.
Engine Coolant Level - Engine Protection

Circuit Description

The coolant level sensor checks the coolant level in the coolant system and informs the electronic control module (ECM) through the sensor harness. The coolant level sensor is complex; do not use a multimeter to test it. If the radiator coolant drops below a certain level, a progressive power and speed derate with increasing time after the alert will occur.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Shop Talk

This is an OEM-supplied component and can vary in sensor location.

When coolant level drops, a power derate occurs, decreasing output by 50 percent over a 30-second period. If a shorting plug is used in the coolant level circuit, verify that it is wired correctly. Inspect the wiring harness between the 9-pin Deutsch connector and the coolant level sensor for damage. Verify the radiator surge tank is metal. The coolant level sensor will not work with a nonconductive tank material. The coolant level sensor location should be in the middle of the tank rather than off to one side where the coolant level can change when the vehicle turns a corner. The CELECT™ Troubleshooting and Repair Manual shows a Robert Shaw coolant level sensor. Not all vendors label their coolant level sensor this way; contact the vendor to verify the sensor pin is wired to the correct ECM pin.

*Applies to 98N14 and 98M11 calibrations only.

Refer to Troubleshooting Fault Code t05-235


Vehicle Speed Sensor (VSS) Circuit

FAULT CODE 241

Vehicle Speed Sensor (VSS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2 LAMP: Yellow SRT: 00-097 | Lost vehicle speed signal on pins 3 and 7 of the OEM harness connector or pin 7 and ground on the OEM harness connector. | Engine speed limited to “Maximum Vehicle Speed without Vehicle Speed Sensor” parameter value.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor (VSS) uses two separate coils of wire to count gear teeth as they pass in front of the sensor. One coil is used by the electronic control module (ECM) to sense vehicle speed. The other coil is sometimes used by the OEM to send a vehicle speed signal to the speedometer.

Component Location

The VSS is installed in the rear of the transmission.

Shop Talk

The vehicle must be moved before Fault Code 241 will go inactive. Not all VSS manufacturers meet the Cummins VSS specifications by using a 750-ohm to 1500-ohm coil. They can vary the resistance, number of turns, wire size, and so on to generate proper electrical parameters for the VSS. Do not replace the VSS without checking the specification for those sensors of an alternate design. The variable reluctance (magnetic pickup) style of VSS can not tolerate two loads in the same circuit. This is the reason for two coils in one sensor. One coil circuit feeds the ECM and the other feeds the speedometer. Any additional loads on a single coil will cause Fault Code 241. Check for additional loads. A single-coil VSS used in some applications, e.g., automatic transmissions, will feed a conditioning circuit that outputs a digital speed signal to ECM pin 7.

NOTE: ECM pin 3 is not used in this type of circuit and should be vacated. Again, no additional loads should be spliced into the VSS between the sensor and conditioning circuit or vehicle interface module.

The digital signal from the vehicle interface module conditioning circuit can feed multiple devices, such as the ECM and the speedometer, simultaneously, since it has been properly conditioned for this purpose. Verify the VSS wires in the OEM harness are twisted pairs. Fault Code 241 becomes active only if the ECM receives a speed signal and then loses the signal. The fault will not go active if it never received one; e.g., the VSS is unplugged. The fault will go inactive once it picks up a speed signal again. Electrical noise or drivetrain vibration can simulate a VSS signal sitting still; therefore, when the vibration or electrical noise dissipates, the fault can go active; i.e., the ECM had a valid signal but lost it.

Refer to Troubleshooting Fault Code t05-241


Vehicle Speed Sensor (VSS) Circuit

FAULT CODE 242

Vehicle Speed Sensor (VSS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 84 FMI: 10 LAMP: Yellow SRT: 00-097 | Invalid or inappropriate vehicle speed signal detected on pins 3 and 7 or pin 7 and ground of the OEM harness connector, indicating an intermittent connection or possible tampering. | Engine speed limited to “Maximum Engine Speed without Vehicle Speed Sensor” parameter value until keyswitch is OFF for 5 seconds.
Vehicle Speed Sensor Circuit

Circuit Description

The VSS uses two separate coils of wire to count gear teeth as they pass in front of the sensor. One coil is used by the ECM to sense vehicle speed. The other is sometimes used by the OEM to send a vehicle speed signal to the speedometer. (The use of dual coils can vary with OEM.)

Component Location

The VSS is installed into the transmission tailshaft housing.

Shop Talk

Verify that the feature settings for “VSS Antitampering (Fault Code 242),” “Application Type,” and “Automatic Transmission” are set correctly. If any of these are set incorrectly, Fault Code 242 could occur erroneously.

NOTE: Driving techniques, such as driving for extended periods of time in lower gears, could log Fault Code 242.

Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch. Interview the driver to discover what occurred when the fault code was logged. Explain the driver actions that can cause Fault Code 242 to be logged. When deactivating the fault, verify that the vehicle is stopped and the engine is shut down. Verify that the keyswitch has been cycled and has remained ON for 30 seconds after the invalid signal has been corrected. This fault will remain active until the keyswitch is cycled and the ECM sees zero vehicle speed and zero engine speed for 30 seconds.

Refer to Troubleshooting Fault Code t05-242


Engine Brake Supply Circuit

FAULT CODE 243

Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 243 PID: P121 SPN: 513 FMI: 4 LAMP: Yellow SRT: 00-098 | Less than 6 VDC detected at the engine brake supply pin 18 of the actuator harness connector. This indicates a current draw from the electronic control module (ECM) greater than 2 amps or a faulty ECM power supply. | The engine brake can not be activated.
Engine Brake Relay Supply Circuit

Circuit Description

The ECM enables the engine brake by sending a signal directly to the engine brakes. The ECM will only enable the engine brakes under certain operating conditions.

Component Location

Reference the OEM troubleshooting and repair manual for the location of the engine brakes.

Refer to Troubleshooting Fault Code t05-243


Engine Fan Clutch Supply Circuit

FAULT CODE 245

Engine Fan Clutch Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4 LAMP: Yellow SRT: 00-099 | Less than 6 VDC detected at fan clutch supply pin 7 of the actuator harness connector. This indicates a current draw from the electronic control module (ECM) greater than 2 amps or a faulty ECM power supply. | The fan will probably not engage. Possible engine overheat if an ECM-controlled fan is in use.
Engine Fan Clutch Supply Circuit

Circuit Description

The fan clutch solenoid is a device used by the ECM to control the engine fan by sending a signal to open or close the fan clutch solenoid.

Component Location

Reference the OEM diagram for the location of the fan clutch solenoid.

Shop Talk

The ECM supplies no voltage to the fan clutch to turn the fan on and battery voltage, 12 VDC in North America (24 VDC in industrial, U.K., and Europe), to turn the fan off.

Refer to Troubleshooting Fault Code t05-245


Fuel Shutoff Solenoid Supply Circuit

FAULT CODE 254

Fuel Shutoff Solenoid Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4 LAMP: Red SRT: 00-602 | Low voltage detected at the fuel shutoff driver pin 16 of the actuator harness connector. This indicates a current draw from the electronic control module (ECM) greater than 2 amperes or a faulty ECM power supply. | The ECM turns off the fuel shutoff valve supply voltage. The engine dies.
Fuel Shutoff Solenoid Circuit

Circuit Description

The fuel shutoff solenoid is a device used by the ECM to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel shutoff solenoid.

Component Location

The fuel shutoff solenoid is located on the top of the fuel pump.

Shop Talk

Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Removing any extra wires that are found in the circuit powering the fuel shutoff valve with another source other than from pin 16 of the actuator can damage the ECM internally, even if the source is close to battery voltage. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and pulled down the voltage on the fuel shutoff circuit. Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface. Check the starter solenoid (+) terminal for a loose connector or accessory wiring with damaged insulation.

Refer to Troubleshooting Fault Code t05-254


Fuel Shutoff, Fan Clutch, Engine Brake Supply Circuit

FAULT CODE 255

Fuel Shutoff, Fan Clutch, Engine Brake Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S026 SPN: 701 FMI: 3 LAMP: Yellow SRT: 00-603 | Externally supplied voltage detected at one of these driver pins: fuel shutoff valve pin 16, fan clutch pin 7, or engine brake pin 18 of the actuator harness connector. | Fuel shutoff valve will not close or fan will run all the time or engine brake will activate.
Fuel Shutoff Circuit

Circuit Description

If voltage is supplied externally on these supply wires, the fuel shutoff valve, fan clutch, or engine brake enable voltage will stay on.

Component Location

Reference the vehicle wiring diagram for the location of the engine brakes. Location will vary with vehicle make and model. Reference the vehicle manufacturer's publications for more information on troubleshooting and repair of the fan clutch. The fuel shutoff solenoid valve is mounted on top of the fuel supply pump on the engine. The solenoid is controlled by the ECM.

Shop Talk

If there is an external shutdown system on the vehicle, make sure it is not miswired and feeding voltage into the fuel shutoff supply circuit.

Refer to Troubleshooting Fault Code t05-255


Fault Code Path Selection

FAULT CODE 83-fc311
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc311n
Is the engine an Mll or L10? | Go to 83-fc311ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc312
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc312n
Is the engine an M11 or L10? | Go to 83-fc312ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc313
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc313n
Is the engine an M11 or L10? | Go to 83-fc313ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc314
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc314n
Is the engine an M11 or L10? | Go to 83-fc314ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc315
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc315n
Is the engine an M11 or L10? | Go to 83-fc315ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc321
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc321n
Is the engine an M11 or L10? | Go to 83-fc321ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc322
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc322n
Is the engine an M11 or L10? | Go to 83-fc322ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc323
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc323n
Is the engine an M11 or L10? | Go to 83-fc323ml

Last Modified: 08-Sep-2004


Fault Code Path Selection

FAULT CODE 83-fc324
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc324n
Is the engine an M11 or L10? | Go to 83-fc324ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc325
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc325n
Is the engine an M11 or L10? | Go to 83-fc325ml

Last Modified: 17-Nov-2003


Fault Code Path Selection

FAULT CODE 83-fc331
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc331n
Is the engine an M11 or L10? | Go to 83-fc331ml

Last Modified: 08-Sep-2004


Fault Code Path Selection

FAULT CODE 83-fc332
Fault Code Path Selection

Is the engine an N14? | Go to 83-fc332n
Is the engine an M11 or L10? | Go to 83-fc332ml

Last Modified: 17-Nov-2003


Injector Circuit

FAULT CODE 333

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 333 PID: S254 SPN: FMI: 12 LAMP: Yellow SRT: 00-606 | No voltage detected on one or more injector supply pin (01, 03, 05, 11, 13, or 15) of the actuator harness when power is commanded. | Speed derate to 1400 to 1600 rpm.
Electronic Control Module

Circuit Description

The CELECT™ electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the left side of the engine.

Shop Talk

Possible causes of this fault code could be damaged engine position sensor (EPS) coils/potting and an ECM internal failure.

Refer to Troubleshooting Fault Code t05-333


ECM RAM Memory

FAULT CODE 335

ECM RAM Memory

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 335 PID: S254 SPN: FMI: 12 LAMP: Red SRT: 00-606 | RAM memory error inside electronic control module. | Unpredictable. Possibly will not start (no power to either fuel solenoid or injectors).
Electronic Control Module

Circuit Description

The CELECT™ electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

ECM is bolted to the left side of the engine.

Shop Talk

A possible cause for this code is an ECM internal failure.

Refer to Troubleshooting Fault Code t05-335


ECM ROM Memory

FAULT CODE 341

ECM ROM Memory

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 341 PID: S254 SPN: FMI: 12 LAMP: Red SRT: 00-606 | ROM memory error inside electronic control module. | Unpredictable. Possibly will not start (no power to either fuel solenoid or injectors).
Electronic Control Module

Circuit Description

The CELECT™ electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

ECM is bolted to the left side of the engine.

Shop Talk

A possible cause for this code is an ECM internal failure.

Refer to Troubleshooting Fault Code t05-341


ECM

FAULT CODE 342

ECM

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: S253 SPN: FMI: 12 LAMP: Red SRT: 00-606 | The electronic control module was not calibrated with ESDN or there is an internal memory error. | Engine will not start (no power to fuel solenoid).
Electronic Control Module

Circuit Description

The CELECT™ electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

ECM is bolted to the left side of the engine.

Shop Talk

Possible causes of this code are an ECM internal failure and an uncalibrated ECM. If there are more than three inactive counts, replace the ECM.

Refer to Troubleshooting Fault Code t05-342


Fault Processing Computer (FPC) Chip

FAULT CODE 343

Fault Processing Computer (FPC) Chip

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12 LAMP: Yellow SRT: 00-606 | Microprocessor communication error inside ECM. | None on performance.
Electronic Control Module

Circuit Description

The CELECT electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the left side of the engine.

Shop Talk

Loose engine or chassis ground connections can cause Fault Code 343 to be logged. Pay special attention to the negative starter post connection. Complaints of an intermittent stumble are possible. Moisture in the ECM connectors can also cause the ECM to log Fault Code 343. A damaged engine position sensor can cause the ECM to log Fault Code 343 and possibly Fault Code 121 and Fault Code 115. Defective alternators occasionally cause Fault Code 343. Run the engine with the alternator belt off; if the fault code becomes inactive, replace the alternator. Intermittent battery shorts to ground can cause the fault. Intermittent shorts to ground in these circuits can cause Fault Code 343: Injector solenoids, injector harnesses, fan clutch solenoids, fan clutch wiring, engine brake solenoids, engine brake wiring, OEM-installed engine speed sensors, flywheel housing and associated wiring, datalink wiring, and fuel shutoff solenoid or wiring. Voltage on the keyswitch input to the ECM, when the key is in the OFF or ACCESSORY position, can cause Fault Code 343 due to the ECM ignoring a power-down request. To determine if conducted electrical noise through the grounds is causing Fault Code 343, unbolt the ECM, and move it away from the engine block so that it is isolated from the engine block ground. If the fault is not duplicated, troubleshoot for the source of the electrical noise.

Refer to Troubleshooting Fault Code t05-343


Injector Power Supply

FAULT CODE 351

Injector Power Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S254 SPN: FMI: 12 LAMP: Yellow SRT: 00-606 | Injector power supply below specifications inside the electronic control module. | Possibly no noticeable effects. Possible reduced performance.
Electronic Control Module

Circuit Description

The CELECT™ electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

ECM is bolted to the left side of the engine.

Shop Talk

Possible causes for this fault code include the injector pigtail rubbing against a push tube and an ECM internal failure.

Refer to Troubleshooting Fault Code t05-351


Sensor Supply Circuit

FAULT CODE 352

Sensor Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 620 FMI: 4 LAMP: Yellow SRT: 00-607 | No outgoing voltage detected at ECM switch supply pin 10 of the OEM harness or low voltage detected at the ECM sensor supply pins 2, 3, 5, 12, 21, and 22 of the sensor harness. | Engine derates to no air fueling and simultaneous logging of Fault Codes 123, 141, 145, 154, 213, 222, and 422 or cruise control/PTO engine brakes will not work, Fault Code 431 is logged, and ECM loses the signal from all cab switches.
Sensor Supply Circuit

Circuit Description

All of the sensors are powered by the same +5 VDC source in the ECM. The idle validation ON/OFF switch and all cab switches are powered by the +5 VDC switch common supply.

Component Location

The +5 VDC switch supply circuit is located in the sensor harness. The +5 VDC switch common circuit is located in the OEM harness. Reference the vehicle manufacturer's manual for the specific location.

Shop Talk

If it is determined that the problem lies in the sensor +5 VDC supply, start unplugging the pressure sensors one at a time. When the fault goes inactive, investigate that particular circuit or sensor for a problem.

If Fault Code 352 is present without multiple sensor fault codes, then the ECM has failed.

Refer to Troubleshooting Fault Code t05-352


Datalink Circuit - Control

FAULT CODE 411

Datalink Circuit - Control

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 411 PID: S249 SPN: FMI: 3 LAMP: Yellow SRT: 00-608 | Data transmission error on control datalink pins 10 and 20 of sensor harness. | Control device possibly does not work properly.
Control Datalink Circuit

Circuit Description

The purpose of the control datalink is to allow the ECM to communicate to the vehicle control-operated systems such as the transmission controllers, antilock brake system, etc.

Component Location

The control datalink circuit is located in the sensor wiring harness.

Shop Talk

Possible causes for this fault code include electromagnetic induction or radio noise (citizens band radio or linear amplifier), supply wire short to chassis ground, electromagnetic induction from control devices on the circuit, supply wire is on (also connectors), electromagnetic induction because of poor or no ECM grounding, return wire short to chassis ground, datalink wires (+, -) shorted together, reversed wires, supply wire is shorted to other wires, improper voltage on the datalink wires, and moisture is in the sensor port shorting circuit.

Refer to Troubleshooting Fault Code t05-411


Datalink Circuit - Vehicle

FAULT CODE 412

Datalink Circuit - Vehicle

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 SPN: FMI: 3 LAMP: Yellow SRT: 00-608 | Data transmission error on vehicle datalink pins 27 and 8 of OEM harness. | Electronic service tool does not work properly.
Vehicle Datalink Circuit

Circuit Description

The vehicle datalink allows the service tool to communicate with the electronic control module (ECM). The vehicle datalink can also be used to communicate electronically with other onboard electronic devices such as electronic dashboards, trip recorders, and so on using the SAE J1587 communication protocol. The vehicle datalink connector can be any one of the following: 2-pin Packard, 6-pin Deutsch, or 8-pin AMP.

Component Location

The vehicle datalink connector is located on the OEM wiring harness. Consult the OEM manual for exact location and type of connector. Connector type can be any one of the following:

2-pin Packard 6-pin Deutsch 8-pin AMP.

Shop Talk

Possible causes for this code include electromagnetic induction from control devices on circuit, supply wire on connectors, electromagnetic induction because of poor or no electromagnetic induction grounding, return wire short to chassis ground, supply wire short to chassis ground, datalink wires (+/-) shorted together, reversed wires, supply wires shorted to other wires, improper voltage on datalink wires, and moisture in OEM port shorting circuit.

Refer to Troubleshooting Fault Code t05-412


Datalink Circuit - Control

FAULT CODE 413

Datalink Circuit - Control

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 413 PID: S249 SPN: FMI: 9 LAMP: Yellow SRT: 00-608 | Data transmission error on control data link pins 10 and 20 of sensor harness. | Control device does not work properly.
Control Datalink Circuit

Circuit Description

The purpose of the control data link is to allow the ECM to communicate to the vehicle control-operated systems such as the transmission controllers, antilock brake system, etc.

Component Location

The control data link circuit is located in the sensor wiring harness.

Shop Talk

Possible causes for this code include electromagnetic induction or radio noise (citizens band radio or linear amplifiers), supply wire short to chassis ground, electromagnetic induction from control devices on the circuit, supply wire is on (also connectors), electromagnetic induction because of poor or no ECM grounding, return wire short to chassis ground, data link wires (+, -) shorted together, reversed wires, supply wire is shorted to other wires, improper voltage on the data link wires, and moisture is in the sensor port shorting circuit.

Refer to Troubleshooting Fault Code t05-413


Datalink Circuit - Vehicle

FAULT CODE 414

Datalink Circuit - Vehicle

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 414 PID: S250 SPN: FMI: 9 LAMP: Yellow SRT: 00-609 | Data transmission error on vehicle data link pins 27 and 8 of OEM harness. | Electronic service tool does not work properly.
Vehicle Datalink Circuit

Circuit Description

The vehicle data link allows the service tool to communicate with the electronic control module (ECM). The vehicle data link can also be used to communicate electronically with other onboard electronic devices such as electronic dashboards, trip recorders, and so on using the SAE J1587 communication protocol. The vehicle data link connector can be any one of the following: 2-pin Packard, 6-pin Deutsch, or 8-pin AMP.

Component Location

The vehicle data link connector is located on the OEM wiring harness. Consult the OEM manual for exact location and type of connector. Connector type can be any one of the following:

2-pin Packard 6-pin Deutsch 8-pin AMP.

Shop Talk

Possible causes for this code include electromagnetic induction from control devices on circuit, supply wire on connectors, electromagnetic induction due to poor or no electromagnetic induction grounding, return wire short to chassis ground, supply wire short to chassis ground, data link wires (+/-) shorted together, reversed wires, supply wires shorted to other wires, improper voltage on data link wires, and moisture in OEM port shorting circuit.

Refer to Troubleshooting Fault Code t05-414


Oil Pressure - Engine Protection

FAULT CODE 415

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Engine Protection or Red* SRT: 00-057 | Voltage signal at oil pressure signal pin 7 of the sensor harness connector indicates oil pressure lower than 55 kPa [8 psi] at idle to 800 rpm; 55 to 172 kPa [8 to 25 psi] at 800 to 2400 rpm. | Progressive power and speed derate with increasing time after alert. If Engine Protection Shutdown is enabled, the engine will shut down 30 seconds after the engine protection lamp or the Red lamp* begins flashing.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

M11 - The oil pressure sensor is located on the engine block to the right of the ECM. 1994 N14 - The oil pressure sensor is located on the engine block near the pan rail on the fuel pump side of the engine. 1991 N14 - The oil pressure sensor is located on the engine block above the fuel supply pump.

Shop Talk

Confirm the oil pressure sensor supply voltage is between 4.5 and 5.25 VDC at the sensor. Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low of a speed under load, the oil pressure can drop below the engine protection limits.

*Applies to 98N14 or 98M11 calibrations only.

Refer to Troubleshooting Fault Code t05-415


Coolant Level Sensor Circuit

FAULT CODE 422

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2 LAMP: Yellow SRT: 00-610 | Voltage detected simultaneously on both the coolant level high and low signal pins 18 and 9 of sensor harness connector or no voltage detected on both pins. | No engine protection for coolant level.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the sensor harness. This sensor is very complex.

Note: Do not use a multimeter to check the coolant level sensor.

If the radiator coolant level drops below a certain level, a progressive power derate with increasing time after alert will occur. The coolant level sensor is an OEM-controlled sensor. Actual OEM wiring can vary from the Robert Shaw sensor shown. Consult your OEM for specific pinouts for the OEM side of the 9-pin Deutsch connector.

Component Location

The coolant level sensor is located in the radiator top tank or surge tank.

Refer to Troubleshooting Fault Code t05-422


Fault Code Path Selection

FAULT CODE 431
Fault Code Path Selection

Do you have an ISS throttle pedal? | Go to 83-fc431iss
Do you have an IVS throttle pedal? | Go to 83-fc431ivs

Last Modified: 11-Mar-2003


Fault Code Path Selection

FAULT CODE 432
Fault Code Path Selection

Do you have an ISS throttle pedal? | Go to 83-fc432iss
Do you have an IVS throttle pedal? | Go to 83-fc432ivs

Last Modified: 11-Mar-2003


Intake Manifold Pressure Sensor Circuit

FAULT CODE 433

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 433 PID: P102 SPN: 102 FMI: 2 LAMP: Yellow SRT: 00-093 | Voltage signal at intake manifold pressure signal pin 26 of the sensor harness connector indicates high intake manifold pressure but other engine characteristics indicate that intake manifold pressure must be low. | None on performance.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located on the air intake manifold.

Shop Talk

The ECM checks for this fault only at idle speed. If the intake manifold pressure shows too high of a value at this time, the ECM will log a fault code. Use the intake manifold pressure sensor breakout cable, Part Number 3824775, between the intake manifold pressure sensor and the sensor harness sensor connector, with keyswitch ON. Check with intake manifold pressure sensor connected and disconnected. Run an automated cylinder performance test and/or single-cylinder cutout test to detect an injector problem causing the fault. Look for alternate fuel sources, such as oil-filled charge air coolers or blown seals in the turbocharger causing this fault.

Refer to Troubleshooting Fault Code t05-433


Unswitched Battery Supply Circuit

FAULT CODE 434

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 434 PID: S251 SPN: 627 FMI: 4 LAMP: Yellow SRT: 00-614 | Battery voltage at pins 20, 21, 22, and 23 of actuator harness connector (relative to return pins 9, 25, and 27 of the actuator harness connector) fell below 6.2 VDC for a fraction of a second or electronic control module (ECM) was not allowed to power down correctly (retain the battery supply voltage for 3 seconds) after keyswitch OFF. | Possibly no noticeable performance effects or possibility of the engine dying or difficulty in starting the engine.
Unswitched Battery Supply

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There are two in-line 10-amp fuses in the unswitched battery wires to protect the actuator harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the actuator harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Reference the OEM manual.

Shop Talk

Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads. If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 434. Optimally, the unswitched battery supply for the ECM will be wired directly to the battery.

Refer to Troubleshooting Fault Code t05-434


Accelerator Position Sensor Circuit

FAULT CODE 131 (ISS)

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3 LAMP: Red SRT: 00-084 | High voltage detected at accelerator position signal pin 11 of the OEM harness connector. | Severe derate (power and speed).
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: positive (+) 5 VDC supply (wire 18), return ground (wire 19), and signal (wire 11).

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensors check good, replace the accelerator position sensor circuit wires between the accelerator pedal and ECM with new wires. Run wires through, or around, the bulkhead without using the bulkhead connector. Test with these wires. If fault clears, replace the OEM harness. Seal the bulkhead openings around the wires to prevent toxic, noxious fumes from seeping into the operator area.

The ECM and accelerator pedal must be calibrated to each other for proper engine response. This is required when a new accelerator pedal is installed, replaced, an ECM is replaced, a new calibration is downloaded to the ECM, or the accelerator pedal wiring is disconnected while keyswitch is ON. With keyswitch ON, slowly push the accelerator to the floor and release. Do this three times. This recalibrates the ECM and accelerator pedal. Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 04-Apr-2013


Accelerator Position Sensor Circuit

FAULT CODE 131 (IVS)

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3 LAMP: Red SRT: 00-084 | High voltage detected at accelerator position signal pin 11 of the OEM harness connector. | Severe derate (power and speed).
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor signals the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit has three wires: positive (+) 5 VDC supply (wire 18), return ground (wire 19), and signal (wire 11).

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensors check good, replace the accelerator position sensor circuit wires between the accelerator pedal and ECM with new wires. Run them through, or around, the bulkhead without using the bulkhead connector. Test with these wires. If fault clears, replace the OEM harness. Seal the bulkhead openings around the wires to prevent toxic, noxious fumes from seeping into the operator area.

The ECM and accelerator pedal must be calibrated to each other for proper engine response. This is required when a new accelerator pedal is installed, replaced, an ECM is replaced, a new calibration is downloaded to the ECM, or the accelerator pedal wiring is disconnected while keyswitch ON. With keyswitch ON, slowly push the accelerator to the floor and release; do this three times. This recalibrates the ECM and accelerator pedal. Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 04-Apr-2013


Accelerator Position Sensor Circuit

FAULT CODE 132 (ISS)

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4 LAMP: Red SRT: 00-084 | Low voltage detected at the accelerator position signal pin-11 of the OEM harness connector. | Severe derate (power and speed).
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: positive (+) 5-VDC supply (wire 18), return (wire 19), and signal (wire 11).

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensors check good, replace the accelerator position sensor circuit wires between the accelerator pedal and ECM with new wires. Run them through, or around, the bulkhead without using the bulkhead connector. Test with these wires. If fault clears, replace the OEM harness. Seal the bulkhead openings around the wires to prevent toxic, noxious fumes from seeping into the operator area.

The ECM and accelerator pedal must be calibrated to each other for proper engine response. This is required when a new accelerator pedal is installed, replaced, an ECM is replaced, a new calibration is downloaded to the ECM, or the accelerator pedal wiring is disconnected while keyswitch ON. With keyswitch ON, slowly push the accelerator to the floor and release; do this three times. This calibrates the ECM and accelerator pedal. Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 04-Apr-2013


Accelerator Position Sensor Circuit

FAULT CODE 132 (IVS)

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4 LAMP: Red SRT: 00-084 | Low voltage detected at the accelerator position signal pin 11 of the OEM harness connector. | Severe derate (power and speed).
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: positive (+) 5 VDC supply (wire 18), return (wire 19), and signal (wire 11).

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensors check good, replace the accelerator position sensor circuit wires between the accelerator pedal and ECM with new wires. Run them through, or around, the bulkhead without using the bulkhead connector. Test with these wires. If fault clears, replace the OEM harness. Seal the bulkhead openings around the wires to prevent toxic, noxious fumes from seeping into the operator area.

The ECM and accelerator pedal must be calibrated to each other for proper engine response. This is required when a new accelerator pedal is installed, replaced, an ECM is replaced, a new calibration is downloaded to the ECM, or the accelerator pedal wiring is disconnected while keyswitch ON. With keyswitch ON, slowly push the accelerator to the floor and release; do this three times. This recalibrates the ECM and accelerator pedal. Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 04-Apr-2013


Injector Circuit - Number 1

FAULT CODE 311 M11/L10

Injector Circuit - Number 1

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 M11 PID: S001 SPN: 734 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 1 injector return pin 10 of the actuator harness connector when the voltage supply at pin 1 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600. Current to injector is shut off.
Injector Circuit - Number 1

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Refer to Troubleshooting Fault Code t05-311


Injector Circuit - Number 1

FAULT CODE 311 N14

Injector Circuit - Number 1

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 N14 PID: S001 SPN: 734 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 1 injector return pin 10 of the actuator harness connector when voltage supply at pin 1 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit - Number 1

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Refer to Troubleshooting Fault Code t05-311.

Last Modified: 14-Jan-2013


Injector Circuit - Number 5

FAULT CODE 312 M11/L10

Injector Circuit - Number 5

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 M11 PID: S005 SPN: 738 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 5 injector return pin 2 of the actuator harness connector when the voltage supply at pin 11 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit - Number 5

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Refer to Troubleshooting Fault Code t05-312

Last Modified: 04-Apr-2013


Injector Circuit - Number 5

FAULT CODE 312 N14

Injector Circuit - Number 5

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 N14 PID: S005 SPN: 738 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 5 injector return pin 2 of the actuator harness connector when voltage supply at pin 11 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit - Number 5

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Refer to Troubleshooting Fault Code t05-312

Last Modified: 04-Apr-2013


Injector Circuit - Number 3

FAULT CODE 313 M11/L10

Injector Circuit - Number 3

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 M11 PID: S003 SPN: 736 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 3 injector return pin 12 of the actuator harness connector when the voltage supply at pin 3 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit - Number 3

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Refer to Troubleshooting Fault Code t05-313

Last Modified: 04-Apr-2013


Injector Circuit - Number 3

FAULT CODE 313 N14

Injector Circuit - Number 3

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 N14 PID: S003 SPN: 736 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 3 injector return pin 12 of the actuator harness connector when voltage supply at pin 3 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit - Number 3

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Refer to Troubleshooting Fault Code t05-313

Last Modified: 04-Apr-2013


Injector Circuit - Number 6

FAULT CODE 314 M11/L10

Injector Circuit - Number 6

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 M11 PID: S006 SPN: 739 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 6 injector return pin 4 of the actuator harness connector when the voltage supply at pin 13 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to the injector is shut off.
Injector Circuit - Number 6

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Refer to Troubleshooting Fault Code t05-314

Last Modified: 04-Apr-2013


Injector Circuit - Number 6

FAULT CODE 314 N14

Injector Circuit - Number 6

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 N14 PID: S006 SPN: 739 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 6 injector return pin 4 of the actuator harness connector when voltage supply at pin 13 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit - Number 6

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Refer to Troubleshooting Fault Code t05-314

Last Modified: 04-Apr-2013


Injector Circuit - Number 2

FAULT CODE 315 M11/L10

Injector Circuit - Number 2

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 M11 PID: S002 SPN: 735 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 2 injector return pin 14 of the actuator harness connector when the voltage supply at pin 5 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to the injector is shut off.
Injector Circuit - Number 2

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Refer to Troubleshooting Fault Code t05-315

Last Modified: 04-Apr-2013


Injector Circuit - Number 2

FAULT CODE 315 N14

Injector Circuit - Number 2

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 N14 PID: S002 SPN: 735 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 2 injector return pin 14 of the actuator harness when voltage supply at pin 5 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to the injector is shut off.
Injector Circuit - Number 2

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Refer to Troubleshooting Fault Code t05-315

Last Modified: 04-Apr-2013


Injector Circuit - Number 4

FAULT CODE 321 M11/L10

Injector Circuit - Number 4

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 M11 PID: S004 SPN: 737 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 4 injector return pin 6 of the actuator harness when the voltage supply at pin 15 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit - Number 4

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Refer to Troubleshooting Fault Code t05-321

Last Modified: 05-Apr-2013


Injector Circuit - Number 4

FAULT CODE 321 N14

Injector Circuit - Number 4

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 N14 PID: S004 SPN: 737 FMI: 6 LAMP: Yellow SRT: 00-604 | Current detected at number 4 injector return pin 6 of the actuator harness when voltage supply at pin 15 of the actuator harness connector is off. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit - Number 4

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Refer to Troubleshooting Fault Code t05-321

Last Modified: 05-Apr-2013


Injector Circuit Number 1

FAULT CODE 322 M11/L10

Injector Circuit Number 1

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S001 SPN: 734 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 1 injector return pin 10 of the actuator harness connector when the voltage supply at pin 1 of the actuator harness is on. | Engine speed derates to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit Number 1

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-322

Last Modified: 09-Apr-2013


Injector Circuit Number 1

FAULT CODE 322 N14

Injector Circuit Number 1

Printable Version Printable Version

Overview

N14

CODE | REASON | EFFECT
Fault Code: 322 PID: S001 SPN: 734 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 1 injector return pin 10 of the actuator harness connector when the voltage supply at pin 1 of the actuator harness is on. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit Number 1

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-322

Last Modified: 09-Apr-2013


Injector Circuit Number 5

FAULT CODE 323 M11/L10

Injector Circuit Number 5

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S005 SPN: 738 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 5 injector return pin 2 of the actuator harness connector when the voltage supply at pin 11 of the actuator harness connector is on. | Engine speed derates to 1400 to 1600 rpm. Current to the injector is shut off.
Injector Circuit Number 5

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-323

Last Modified: 09-Apr-2013


Injector Circuit Number 5

FAULT CODE 323 N14

Injector Circuit Number 5

Printable Version Printable Version

Overview

N14

CODE | REASON | EFFECT
Fault Code: 323 PID: S005 SPN: 738 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 5 injector return pin 2 of the actuator harness connector when the voltage supply at pin 11 of the actuator harness connector is on. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit Number 5

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-323

Last Modified: 09-Apr-2013


Injector Circuit Number 3

FAULT CODE 324 M11/L10

Injector Circuit Number 3

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S003 SPN: 736 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 3 injector return pin 12 of the actuator harness connector when the voltage supply at pin 3 of the actuator harness is ON. | Engine speed derates to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit Number 3

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-324

Last Modified: 08-Mar-2013


Injector Circuit Number 3

FAULT CODE 324 N14

Injector Circuit Number 3

Printable Version Printable Version

Overview

N14

CODE | REASON | EFFECT
Fault Code: 324 PID: S003 SPN: 736 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 3 injector return pin 12 of the actuator harness connector when the voltage supply at pin 3 of the actuator harness connector is on. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit Number 3

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-324

Last Modified: 08-Mar-2013


Injector Circuit Number 6

FAULT CODE 325 M11/L10

Injector Circuit Number 6

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S006 SPN: 739 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 6 injector return pin 4 of the actuator harness connector when the voltage supply at pin 13 of the actuator harness connector is on. | Engine speed derates to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit Number 6

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-325

Last Modified: 09-Apr-2013


Injector Circuit Number 6

FAULT CODE 325 N14

Injector Circuit Number 6

Printable Version Printable Version

Overview

N14

CODE | REASON | EFFECT
Fault Code: 325 PID: S006 SPN: 739 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 6 injector return pin 4 of the actuator harness connector when the voltage supply at pin 13 of the actuator harness connector is on. | Engine speed derate to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit Number 6

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-325

Last Modified: 09-Apr-2013


Injector Circuit Number 2

FAULT CODE 331 M11/L10

Injector Circuit Number 2

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S002 SPN: 735 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 2 injector return pin 14 of the actuator harness connector when the voltage supply at pin 5 of the actuator harness connector is on. | Engine speed derates to 1400 to 1600 rpm. Current to injector is shut off.
Injector Circuit Number 2

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-331

Last Modified: 09-Apr-2013


Injector Circuit Number 2

FAULT CODE 331 N14

Injector Circuit Number 2

Printable Version Printable Version

Overview

N14

CODE | REASON | EFFECT
Fault Code: 331 PID: S002 SPN: 735 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 2 injector return pin 14 of the actuator harness connector when the voltage supply at pin 5 of the actuator harness connector is on. | Engine speed derate to 1400 to 1600 rpm. Current to the injector is shut off.
Injector Circuit Number 2

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-331

Last Modified: 09-Apr-2013


Injector Circuit Number 4

FAULT CODE 332 M11/L10

Injector Circuit Number 4

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S004 SPN: 737 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 4 injector return pin 6 of the actuator harness connector when the voltage supply at pin 15 of the actuator harness connector is on. | Engine speed derates to 1400 to 1600 rpm. Current to the injector is shut off.
Injector Circuit Number 4

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

There are two pieces to an M11 actuator harness - one internal and the other external. The external portion of the actuator harness extends from the C connector port in the ECM to the backside of the rocker lever housing. The external harness connects to the internal harness at a 12-pin connector. The internal actuator harness runs along the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-332

Last Modified: 09-Apr-2013


Injector Circuit Number 4

FAULT CODE 332 N14

Injector Circuit Number 4

Printable Version Printable Version

Overview

N14

CODE | REASON | EFFECT
Fault Code: 332 PID: S004 SPN: 737 FMI: 5 LAMP: Yellow SRT: 00-605 | No current detected at number 4 injector return pin 6 of the actuator harness connector when the voltage supply at pin 15 of the actuator harness connector is on. | Engine speed derate to 1400 to 1600 rpm. Current to the injector is shut off.
Injector Circuit Number 4

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply wire and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The N14 has an external actuator harness. It extends from the C connector port in the ECM and runs along the left side of the rocker boxes. There it attaches to the pass-through connectors mounted in the side of each rocker box. The injector pigtail connectors are attached to the internal side of the pass-through connectors.

Shop Talk

Inspect the injector pigtail wires, and make sure no wires are shorting to ground against the push rods or push tubes. Examine the injector pigtail nuts, and make sure they are tightened down to the proper torque. Confirm that the pigtail nuts and solenoid posts do not have damaged threads.

Refer to Troubleshooting Fault Code t05-332

Last Modified: 09-Apr-2013


Idle Validation Switch Circuit

FAULT CODE 431 (ISS)

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

ISS

CODE | REASON | EFFECT
Fault Code: 431 PID: P091 SPN: 91 FMI: 2 LAMP: Yellow SRT: 00-611 | Voltage detected simultaneously on both the idle validation off-idle and idle signal pins 6 and 9 of the OEM harness connector or no voltage detected at either pin. | None on performance.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The integrated sensor/switch is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, an accelerator pedal that is not calibrated, or an idle validation switch that is wired wrong. If all wiring and sensor checks are good, replace the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault clears, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from entering the cab.

Note: Verify that the three idle validation switch circuit wires are twisted together.

The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is ON. With keyswitch ON, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal.

Refer to Troubleshooting Fault Code t05-431

Last Modified: 09-Apr-2013


Idle Validation Switch Circuit

FAULT CODE 431 (IVS)

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

IVS

CODE | REASON | EFFECT
Fault Code: 431 PID: P091 SPN: 91 FMI: 2 LAMP: Yellow SRT: 00-611 | Voltage detected simultaneously on both the idle validation off-idle and idle signal pins 6 and 9 of the OEM harness or no voltage detected at either pin. | None on performance.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, an accelerator pedal that is not calibrated, or an idle validation switch that is wired wrong. If all wiring and sensor checks are good, replace the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault clears, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from seeping into the cab. Verify that the three idle validation switch circuit wires are twisted together. The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is in the ON position. With keyswitch ON, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal.

Refer to Troubleshooting Fault Code t05-431

Last Modified: 09-Apr-2013


Accelerator Pedal Circuit

FAULT CODE 432 (ISS)

Accelerator Pedal Circuit

Printable Version Printable Version

Overview

ISS

CODE | REASON | EFFECT
Fault Code: 432 PID: P091 SPN: 91 FMI: 11 LAMP: Red SRT: 00-612 | Voltage detected at idle validation on-idle signal pin 6 of the OEM harness connector when voltage at accelerator position signal pin 11 of OEM harness connector indicates pedal is not at idle or voltage detected at idle validation off-idle signal pin 9 of the OEM harness connector when voltage at accelerator position signal pin 11 of the OEM harness connector indicates pedal is at rest. | Engine will only idle.
Accelerator Pedal Circuit

Circuit Description

The accelerator pedal assembly relays the accelerator percentage needed to the electronic control module (ECM).

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

Confirm that the idle validation switch is properly calibrated. Reference the manufacturer's instructions for adjustment information.

Make sure there are no external circuits hooked into the accelerator position sensor circuit and that there are no signs of tampering in the circuit. If all of the wiring and the sensor checks out, replace the accelerator position sensor circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal openings in the bulkhead around the connector and the wires to prevent toxic and noxious fumes from entering the operator area. Check that the three accelerator position sensor circuit wires are twisted together. The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is in the ON position. With the keyswitch ON, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal. Confirm with the OEM that the throttle is within OEM specifications for accelerator position sensor voltage or resistance at idle to off-idle transition. Depressing the throttle while starting the engine is not necessary nor advised. Additional fueling is not possible until the engine reaches idle, and in older versions of software, depressing the throttle could cause Fault Code 432 in some situations.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 09-Apr-2013


Accelerator Pedal Circuit

FAULT CODE 432 (IVS)

Accelerator Pedal Circuit

Printable Version Printable Version

Overview

IVS

CODE | REASON | EFFECT
Fault Code: 432 PID: P091 SPN: 91 FMI: 11 LAMP: Red SRT: 00-612 | Voltage detected at idle validation on-idle signal pin 6 of the OEM harness when voltage at accelerator position signal pin 11 of OEM harness indicates pedal is not at idle or voltage detected at idle validation off-idle signal pin 9 of the OEM harness when voltage at accelerator position signal pin 11 of the OEM harness indicates pedal is at rest. | Engine will only idle.
Accelerator Pedal Circuit

Circuit Description

The accelerator pedal assembly relays the accelerator percentage needed to the electronic control module (ECM).

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

Confirm that the idle validation switch is properly calibrated. Reference the manufacturer's procedures for adjustment information.

Make sure there are no external circuits hooked into the accelerator position sensor circuit and that there are no signs of tampering in the circuit. If all the wiring and the sensor checks look good, replace the accelerator position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal openings in the bulkhead around the connector and the wires to prevent toxic and noxious fumes from seeping into the operator area.

Note: Verify that the three accelerator position sensor circuit wires are twisted together. Verify that the three idle validation switch circuit wires are twisted together.

The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is ON. With keyswitch ON, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal. Confirm with OEM that the throttle is within OEM specifications for accelerator position sensor voltage or resistance at idle to off-idle transition. Depressing the throttle while starting the engine is not necessary nor advised. Additional fueling is not possible until the engine reaches idle, and in older versions of software, depressing the throttle could cause Fault Code 432 in some situations.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 09-Apr-2013


Fault Code Path Selection

FAULT CODE 83-fcmfc
Fault Code Path Selection

Are the multiple Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422? | Go to 83-fcmfc1
Are the multiple Fault Codes 352 and 431? | Go to 83-fcmfc2

Last Modified: 17-Nov-2003


Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422

FAULT CODE Multiple A

Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple PID: None FMI: None LAMP: Yellow SRT: 00-615 | Low voltage detected on the internal electronic control module (ECM) supply line to the sensors. | Sensors will not operate correctly.
Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies each sensor in the sensor harness with +5 VDC. If the supply line to any sensor is damaged, the sensor will not work correctly.

Component Location

Intake manifold pressure sensor Ambient air temperature Coolant temperature Intake manifold air temperature Oil pressure Oil temperature Coolant level sensor.

Shop Talk

Low voltage on the sensor +5 VDC supply line will be caused by a short to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-mfc1


Fault Codes 352 and 431

FAULT CODE Multiple B

Fault Codes 352 and 431

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple PID: None FMI: None LAMP: Yellow SRT: 00-615 | No outgoing voltage detected at the ECM switch supply pin 10 of the OEM harness and no voltage detected at pins 9 and 6 of the OEM harness. | Cruise control/PTO and engine brakes will not work and ECM loses signal from all cab switches.
Idle Validation Circuit

Circuit Description

The idle validation ON/OFF switch and all cab switches are powered by the +5 VDC common switch supply.

Component Location

The +5 VDC switch supply circuit is located in the OEM harness. Reference the vehicle manufacturer's manual for the specification.

Shop Talk

If no voltage is detected on pin 10 of the OEM harness, no power is sent to any cab switches. These include clutch switch, brake switch, engine brake on/off, etc.

Refer to Troubleshooting Fault Code t05-mfc2


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

For ease of installation and removal, use this special tool for the engine position sensor:Part Number 3824747 - installation tool, engine position sensor.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

For ease of installation and removal, use this special tool for the engine position sensor:Part Number 3822747 - installation tool, engine position sensor.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine position circuit. |
 | STEP 1A. Inspect the engine position sensor and the sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 115 active or engine will not start
 | STEP 1C. Check for a short circuit to ground in the engine position sensor. | More than 10M ohms
 | STEP 1D. Inspect the engine position sensor. | No damaged engine position sensor
 | STEP 1E. Check the resistance of the engine position sensor. | 1000 to 2000 ohms
 | STEP 1F. Check for a short circuit between the coils. | More than 10M ohms
STEP 2. | Check the sensor harness and the ECM connector pins. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 115 active or engine will not start
 | STEP 2C. Check for proper pin-to-pin wiring between ECM and engine position sensor. | Wired correctly
 | STEP 2D. Check for pin-to-pin continuity. | Less than 10 ohms
 | STEP 2E. Check for a short circuit to the ground. | More than 100k ohms
 | STEP 2F. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2G. Check for an open circuit. | 1000 to 2000 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 115 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine position sensor.

Guided Step 1A - Inspect the engine position sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the engine position circuit.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine position sensor and the sensor harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position circuit. Refer to Procedure 019-038 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start and idle the engine 1 minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 115 active or engine does not start

Fault Code 115 inactive and engine does start.

Go to 1C

Go to 3B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1C - Check for a short circuit to ground in the engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the engine position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the engine position circuit to the engine block ground.
  • Measure the resistance from pin B of the engine position circuit to the engine block ground.
  • Measure the resistance from pin C of the engine position circuit to the engine block ground.
  • Measure the resistance from pin D of the engine position circuit to the engine block ground.

Install the mating connector with short test leads to the sensor connector. While testing the sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under insulation.

OK NOT OK

More than 10M ohms

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 1D

Go to 3A

CAUTION

For ease of installation and removal, use this special tool for the engine position sensor:Part Number 3822747 - installation tool, engine position sensor.
Guided Step 1D - Inspect the engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the engine position sensor.
  • Remove the engine position sensor using the engine position sensor installation tool.

Action

Inspect the engine position sensor for:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.
OK NOT OK

No damaged engine position sensor

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1E - Check the resistance of the engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the engine position sensor.

Action

Check for an open circuit in the engine postion sensor.

  • Measure the resistance from pin A to pin D (outside pins).
  • Measure the resistance from pin B to pin C (inside pins).

Install the mating connector with short test leads to the sensor connector. While testing the sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

1000 to 2000 ohms

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 1F

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1F - Check for a short circuit between the coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness from the engine position sensor.

Action

Check for a short circuit between the coils.

  • Measure the resistance from pin A to pin B of the engine position sensor.

Install the mating connector with short test leads to the sensor connector. While testing the sensor, the electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

A false low reading will occur if you are touching the test leads while taking the measurement.
OK NOT OK

More than 10M ohms

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness and the ECM connector pins.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start and idle the engine for 1 minute.
  • Read the fault codes using INSITE™ electronic service tool .
OK NOT OK

Fault Code 115 active or engine does not start

Fault Code 115 inactive and engine does start.

Go to 2C

Go to 3B

Guided Step 2C - Check for proper pin-to-pin wiring between ECM and engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from ECM.
  • Disconnect engine position sensor from sensor connector.

Action

Check engine position sensor for proper pinout.

  • Engine position sensor red wire to D - D to pin 14 of sensor connector.
  • Engine position sensor black wire to A - A to pin 11 of sensor connector.
  • Engine position sensor white wire to B - B to pin 15 of sensor connector.
  • Engine position sensor green wire to C - C to pin 1 of sensor connector.
OK NOT OK

Wired correctly

Correct the pinout.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for pin-to-pin continuity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor connector from engine position sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Measure the resistance from pin to pin:

  • Measure from pin D of the sensor connector to pin 14 of the sensor harness ECM connector.
  • Measure from pin A of the sensor connector to pin 11 of the sensor harness ECM connector.
  • Measure from pin B of the sensor connector to pin 15 of the sensor harness ECM connector.
  • Measure from pin C of the sensor connector to pin 1 of the sensor harness ECM connector.
OK NOT OK

Less than 10 ohms

Repair or replace harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit to the ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check for a short circuit to the ground.

  • Measure the resistance from pin 1 to the engine block ground.
  • Measure the resistance from pin 11 to the engine block ground.
  • Measure the resistance from pin 14 to the engine block ground.
  • Measure the resistance from pin 15 to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2F - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 of the sensor harness ECM connector to all other pins in the sensor harness ECM connector.
  • Measure the resistance from pin 11 of the sensor harness ECM connector to all other pins in the sensor harness ECM connector.
  • Measure the resistance from pin 14 of the sensor harness ECM connector to all other pins in the sensor harness ECM connector.
  • Measure the resistance from pin 15 of the sensor harness ECM connector to all other pins in the sensor harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2G

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2G - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Connect the engine position sensor to the sensor harness.

Action

Check for an open circuit.

  • Measure resistance from pin 11 to pin 14 at the ECM connector.
  • Measure resistance from pin 1 to pin 15 at the ECM connector.
OK NOT OK

1000 to 2000 ohms

Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 115 is inactive.
OK NOT OK

Fault Code 115 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To ease installation and removal, use this special tool for the engine position sensor:Part Number 3822747 - installation tool, engine position sensor.
CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine position sensor. |
 | STEP 1A. Inspect the engine position sensor and the sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 121 active
 | STEP 1C. Check for a short circuit to ground in the engine position sensor. | More than 10M ohms
 | STEP 1D. Inspect the engine position sensor. | No damaged engine position sensor
 | STEP 1E. Check the resistance of the engine position sensor. | 1000 to 2000 ohms
 | STEP 1F. Check for a short circuit between the coils. | More than 10M ohms
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 121 active
 | STEP 2C. Check for proper pin-to-pin wiring between ECM and engine position sensor. | Wired correctly
 | STEP 2D. Check for pin-to-pin continuity. | Less than 10 ohms
 | STEP 2E. Check for a short circuit to the ground. | More than 100k ohms
 | STEP 2F. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2G. Check for an open circuit. | 1000 to 2000 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine position sensor.

Guided Step 1A - Inspect the engine position sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the engine position sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine postion circuit and the sensor harness connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

  • Call for pre-authorization and replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start and idle the engine for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 121 active

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check for a short circuit to ground in the engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the engine position sensor.

Action

Check for a short circuit to the ground.

  • Measure the resistance from pin A of the engine position sensor to the engine block ground.
  • Measure the resistance from pin B of the engine position sensor to the engine block ground.
  • Measure the resistance from pin C of the engine position sensor to the engine block ground.
  • Measure the resistance from pin D of the engine position sensor to the engine block ground.

Install the mating connector with short test leads to the sensor connector. While testing the sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

More than 10M ohms

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19 in Section 19.

Go to 1D

Go to 3A

CAUTION

To ease installation and removal, use this special tool for the engine position sensor:Part Number 3822747 - installation tool, engine position sensor.
Guided Step 1D - Inspect the engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the engine position sensor.
  • Remove the engine position sensor using the engine position sensor installation tool, Part Number 3822747.

Action

Inspect the engine position circuit for:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.
OK NOT OK

No damaged engine position sensor

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check the resistance of the engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor connector from the engine position sensor.

Action

Check for an open circuit in the engine position circuit.

  • Measure the resistance from pin A to pin D in the sensor connector.
  • Measure the resistance from pin B to pin C in the sensor connector.

Install the mating connector with short test leads to the sensor connector. While testing the sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

1000 to 2000 ohms

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19 in Section 19.

Go to 1F

Go to 3A

Guided Step 1F - Check for a short circuit between the coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor connector from the engine position sensor.

Action

Check for a short circuit between the coils.

  • Measure the resistance from pin A to pin B of the engine position sensor.

Install the mating connector with short test leads to the sensor connector. While testing the sensor, the electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

A false low reading will occur if you are touching the test leads while taking the measurement.
OK NOT OK

More than 10M ohms

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor harness.

CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the sensor harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

  • Call for pre-authorization and replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start and idle the engine for 1 minute.
  • Read the fault codes, use INSITE™ electronic service tool.
OK NOT OK

Fault Code 121 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for proper pin-to-pin wiring between ECM and engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from ECM.
  • Disconnect engine position sensor from sensor connector.

Action

Check the engine postion circuit for proper pinout.

  • Engine position sensor red wire to pin D of sensor connector; D to pin 14 of sensor harness connector at ECM.
  • Engine position sensor black wire to pin A of sensor connector; A to pin 11 of sensor harness connector at ECM.
  • Engine position sensor white wire to pin B of sensor connector; B to pin 15 of sensor harness connector at ECM.
  • Engine position sensor green wire to pin C of sensor connector; C to pin 1 of sensor harness connector at ECM.
OK NOT OK

Wired correctly

Correct the pinout.

Go to 2D

Go to 3A

Guided Step 2D - Check for pin-to-pin continuity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect sensor connector from engine position sensor.

Action

Measure the resistance from pin to pin:

  • Measure from pin D of the sensor connector to pin 14 of the sensor harness connector of the ECM.
  • Measure from pin A of the sensor connector to pin 11 of the sensor harness connector of the ECM.
  • Measure from pin B of the sensor connector to pin 15 of the sensor harness connector of the ECM.
  • Measure from pin C of the sensor connector to pin 1 of the sensor harness connector of the ECM.
OK NOT OK

Less than 10 ohms

Repair or replace sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to the ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor connector from the engine position sensor.

Action

Check for a short circuit to the ground.

  • Measure the resistance from pin 1 to the engine block ground.
  • Measure the resistance from pin 11 to the engine block ground.
  • Measure the resistance from pin 14 to the engine block ground.
  • Measure the resistance from pin 15 to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the sensor connector from the engine position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 11 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 14 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 15 to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Connect the engine position sensor to the sensor harness.

Action

Check for an open circuit.

  • Measure resistance from pin 11 to pin 14 at the sensor harness connector.
  • Measure resistance from pin 1 to pin 15 at the sensor harness connector.
OK NOT OK

1000 to 2000 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure sensor. |
 | STEP 1A. Check the intake manifold pressure sensor. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 122 active
 | STEP 1C. Check the intake manifold pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 1C-1. Measure the voltage to the sensor. |
 | STEP 1C-2. Measure the voltage from the ECM. |
 | STEP 1D. Check the intake manifold pressure sensor signal voltage. | 0.42 to 0.58 VDC
 | STEP 1D-1. Check for a short circuit pin to pin. |
 | STEP 1D-2. Check for continuity in sensor harness. |
 | STEP 1D-3. Check ECM response. |
 | STEP 1D-4. Check signal pin to return resistance. |
STEP 2. | Check the sensor harness and the ECM. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 122 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for continuity in sensor harness. | Less than 10 ohms
STEP 3. | Check for ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 122 inactive, Fault Code 123 active
 | STEP 3B. Check ECM signal to ground resistance. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the intake manifold pressure sensor.

Guided Step 1A - Inspect the intake manifold pressure sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 122 active

Repair complete.

Go to 1C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Disconnect all pressure and temperature sensors from the sensor harness (except intake manifold pressure sensor).
  • Disconnect the coolant level sensor or shorting plug from the sensor harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 1D

Go to 1C-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
Guided Step 1C-1 - Measure the voltage to the sensor.

Conditions

  • Disconnect all pressure and temperature sensors from their connectors on the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, to the sensor harness connector. Do not connect the sensor to the breakout cable.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Does not meet specifications.

Go to 4A

Go to 1C-2

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C-2 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage out of the ECM from pin 2 to pin 4 at the ECM sensor port.
OK NOT OK

4.75 to 5.25 VDC

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check the intake manifold pressure sensor signal voltage.

Conditions

  • Disconnect all sensors from their connectors on the sensor harness, except the intake manifold pressure sensor.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor signal voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the sensor harness connector.
  • Measure the signal voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.42 to 0.58 VDC

Does not meet specifications.

Go to 2A

Go to 1D-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-1 - Check for a short circuit pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ECM.
  • Disconnect all sensors and the coolant level sensor or shorting plug from their connectors.

Action

Check for a short pin to pin.

  • Measure resistance from pin 26 of the sensor harness connector at the ECM to all other pins.
  • Measure resistance from pin 4 of the sensor harness connector at the ECM to all other pins.
  • Measure resistance from pin 2 of the sensor harness connector at the ECM to all other pins.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-2

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-2 - Check for continuity in sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the intake manifold pressure sensor from the sensor harness.

Action

Check for continuity in the sensor harness.

  • Measure the resistance from pin 2 of the sensor harness connector to pin A of the sensor connector.
  • Measure the resistance from pin 4 of the sensor harness connector to pin B of the sensor connector.
  • Measure the resistance from pin 26 of the sensor harness connector to pin C of the sensor connector.
OK NOT OK

Less than 10 ohms

Correct pin-to-pin wiring or open circuit

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-3

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-3 - Check ECM response.

Conditions

  • Disconnect sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 4 and pin 26.
  • Read the fault codes.
OK NOT OK

Fault Code 122 inactive, Fault Code 123 active

Fault Code 122 active.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D-4

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-4 - Check signal pin to return resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from the ECM.

Action

Check signal pin to return resistance.

  • Measure the resistance from pin 26 to pin 4 at the sensor port of the ECM, using Part Number 3822917.
OK NOT OK

Less than 100k ohms

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Greater than 100k ohms

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 2 - Check the sensor harness and the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 122 active

Repair complete.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all sensors from their connectors on the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 4 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 26 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for continuity in sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from ECM.
  • Disconnect intake manifold pressure sensor from sensor harness.

Action

Check for continuity in sensor harness.

  • Measure resistance from pin 26 of sensor harness connector at ECM to pin C of sensor connector.
  • Measure resistance from pin 4 of sensor harness connector at ECM to pin B of sensor connector.
  • Measure resistance from pin 2 of sensor harness connector at ECM to pin A of sensor connector.
OK NOT OK

Less than 10 ohms

Correct the pin-to-pin wiring or open circuit.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for ECM response.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 4 and pin 26.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 122 inactive, Fault Code 123 active

Fault Code 122 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check ECM signal to ground resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check ECM signal pin resistance.

  • Measure the resistance from pin 26 to pin 4 of the ECM sensor port.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 122 inactive.
OK NOT OK

Fault Code 122 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool .
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 141, 145, 154, 213, 222, 352, and 422 are not active
STEP 2. | Check for mechanical failure. |
 | STEP 2A. Verify proper operation of the turbocharger. | Positive intake manifold pressure from the turbocharger
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Inspect the intake manifold pressure sensor and sensor harness connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 123 active
 | STEP 3C. Check the intake manifold pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 3C-1. Check the intake manifold pressure sensor supply voltage. |
 | STEP 3C-2. Measure the voltage out of the ECM. |
 | STEP 3D. Check the intake manifold pressure sensor signal voltage. | 0.42 to 0.58 VDC
 | STEP 3D-1. Check for a short circuit from pin to pin. |
 | STEP 3D-2. Check for continuity in the sensor harness. |
 | STEP 3D-3. Check ECM response. |
 | STEP 3D-4. Check signal to return pin resistance. |
STEP 4. | Check the sensor harness. |
 | STEP 4A. Inspect the sensor harness and the ECM connector for damaged pins. | No damaged pins
 | STEP 4B. Read the fault codes. | Fault Code 123 active
 | STEP 4C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4E. Check for continuity in sensor harness. | Less than 10 ohms
 | STEP 4F. Clear and check the fault codes. | Fault Code 123 inactive
STEP 5. | Check for the ECM response. |
 | STEP 5A. Check for an appropriate ECM response. | Fault Code 123 inactive, Fault Code 122 active
 | STEP 5B. Check ECM signal pin resistance. | Less than 100k ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 123 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Codes 141, 145, 154, 213, 222, 352, and 422 are not active

Possible sensor failure, short circuit to ground in sensor positive (+) 5 VDC common supply, or short circuit from pin to pin.

Go to 2A

Fault Code Multiple A

Guided Step 2 - Check for mechanical failure.

Guided Step 2A - Verify proper operation of the turbocharger.

Conditions

  • Turn keyswitch ON.
  • Start engine and let idle.

Action

Verify proper operation of the turbocharger.

  • Check for positive intake manifold pressure.
OK NOT OK

Positive intake manifold pressure from the turbocharger

Low intake manifold pressure

  • Correct the base engine malfunction causing low intake manifold pressure. Reference the base engine manual.

Go to 3A

Go to 6A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Inspect the intake manifold pressure sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine harness and the sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.
  • Install the appropriate connector seal if damaged or missing. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 123 active

Repair complete.

Go to 3C

Go to 6B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3C - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Connect sensor harness connector to ECM.
  • Disconnect all pressure and temperature sensors from their connectors on the sensor harness, except for the intake manifold pressure sensor.
  • Disconnect the coolant level sensor or shorting plug from its connector.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 3D

Go to 3C-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
Guided Step 3C-1 - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Connect sensor harness connector to ECM.
  • Disconnect all pressure and temperature sensors from their connectors on the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from its connector.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, to the sensor harness connector.

Do not connect the sensor to the breakout cable.

  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Does not meet specifications.

Go to 6A

Go to 3C-2

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3C-2 - Measure the voltage out of the ECM.

Conditions

  • Turn keyswitch ON.
  • Disconnect the sensor harness connector from the ECM.

Action

Check ECM output voltage.

  • Measure the voltage out of the ECM from pin 2 to pin 4 at the ECM sensor port.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3D - Check the intake manifold pressure sensor signal voltage.

Conditions

  • Connect the sensor harness connector to the ECM.
  • Disconnect all pressure and temperature sensors from their connectors on the sensor harness.
  • Connect the intake manifold sensor to the breakout cable.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor signal voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the sensor harness connector.
  • Measure the signal voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.42 to 0.58 VDC

Does not meet specifications.

Go to 4A

Go to 3D-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
Guided Step 3D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ECM.
  • Disconnect all pressure sensors and the coolant level sensor or shorting plug from their connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 26 of the sensor harness to all other pins in the ECM connector.
  • Measure the resistance from pin 4 of the sensor harness to all other pins in the ECM connector.
  • Measure the resistance from pin 2 of the sensor harness to all other pins in the ECM connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D-2

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
Guided Step 3D-2 - Check for continuity in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect intake manifold pressure sensor from the sensor harness.

Action

Check for continuity in the sensor harness.

  • Measure the resistance from pin 2 of the sensor harness connector to pin A of the sensor connector.
  • Measure the resistance from pin 26 of the sensor harness connector to pin C of the sensor connector.
  • Measure the resistance from pin 4 of the sensor harness connector to pin B of the sensor connector.
OK NOT OK

Less than 10 ohms

Correct pin-to-pin wiring or open circuit.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D-3

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3D-3 - Check ECM response.

Conditions

  • Disconnect sensor harness connector from ECM.
  • Turn keyswitch ON.

Action

Check for appropriate ECM response.

  • Install Part Number 3822917 between ECM sensor port pin 2 and pin 26, as a jumper wire.
  • Read the faults.
OK NOT OK

Fault Code 123 inactive. Fault Code 122 active

Fault Code 123 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D-4

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3D-4 - Check signal to return pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check ECM resistance.

  • Measure the resistance from pin 26 to pin 4 in the ECM sensor port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

  • Replace the sensor. Refer to Procedure 019-061 in Section 19.

Greater than 100k ohms

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 4 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine harness and the ECM connector pins for:

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals
  • dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 123 active

Repair complete.

Go to 4C

Go to 6B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all pressure sensors from their connectors on the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 26 of the sensor harness connector to chassis ground.
  • Measure the resistance from pin 2 of the sensor harness connector to chassis ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all the pressure sensors from their connectors on the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 to all other pins of the sensor harness connector.
  • Measure the resistance from pin 4 to all other pins of the sensor harness connector.
  • Measure the resistance from pin 26 to all other pins of the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4E - Check for continuity in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the intake manifold pressure sensor from the sensor connector on the sensor harness.

Action

Check for continuity in the harness and proper pin-to-pin wiring from sensor to ECM.

  • Measure the resistance from pin 2 of the sensor harness connector at the ECM to pin A of the sensor harness.
  • Measure the resistance from pin 26 of the sensor harness connector at the ECM to pin C of the sensor harness.
  • Measure the resistance from pin 4 of the sensor harness connector at the ECM to pin B of the sensor harness.
OK NOT OK

Less than 10 ohms

Correct the pin-to-pin wiring.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 6A

Guided Step 4F - Clear and check the fault codes.

Conditions

  • Connect all the components.

Action

Clear and check the fault codes.

  • Start the engine and let it idle for one minute.
  • Snap the accelerator pedal.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 123 inactive

Fault Code 123 active

Go to 6A

Go to 5A

Guided Step 5 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 5A - Check for an appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 2 and pin 26.
  • Read the fault codes using INSITE™ electronic service tool .
OK NOT OK

Fault Code 123 inactive, Fault Code 122 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 6A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 5B - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the signal pin resistance at the ECM.

  • Measure the resistance from pin 26 to pin 4 in the ECM sensor port, using Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 123 is inactive.
OK NOT OK

Fault Code 123 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connectorPart Number 3824910 - 6-pin Metri-Pack repair connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the harness and the accelerator position sensor connector pins. | No damaged pins
 | STEP 1B. Check for continuity from ECM to accelerator position sensor. | Less than 10 ohms
 | STEP 1C. Check the accelerator position resistance. | 2000 to 3000 ohms
 | STEP 1D. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms, released resistance must be at least 1000 ohms more than depressed resistance
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness, bulkhead connector, and ECM connector pins. | No damaged pins
 | STEP 2B. Check the resistance between the positive (+) 5 VDC supply and return wires. | 2000 to 3000 ohms
 | STEP 2C. Check the resistance in the positive (+) 5 VDC supply wire and signal wire circuit. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms
 | STEP 2D. Check for a short circuit from the accelerator position signal and return wires to all other pins in the OEM harness. | More than 100k ohms
STEP 3. | Check for the ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 131 inactive, Fault Code 132 active
 | STEP 3B. Check ECM signal pin resistance. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the accelerator position sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for continuity from ECM to accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect OEM harness to bulkhead connector.
  • Disconnect OEM harness from accelerator pedal.
  • Disconnect OEM harness connector from ECM.

Action

Check for continuity from ECM to accelerator position sensor.

  • Measure the resistance from pin 11 of the ECM OEM harness connector to the signal pin of the accelerator position sensor connector.
  • Measure the resistance from pin 18 of the ECM OEM harness connector to positive (+) 5 VDC supply pin of the accelerator position sensor.
  • Measure the resistance from pin 19 of the ECM OEM harness connector to the return pin of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the accelerator position sensor wiring.

  • Repair the accelerator position sensor. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-207 in Section 19.
  • Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connectorPart Number 3824910 - 6-pin Metri-Pack repair connector.
Guided Step 1C - Check the accelerator position resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit or a short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the positive (+) 5 VDC supply wire and the accelerator position sensor return wire on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Take the measurement when the pedal is depressed and again when released.

Install a 3-pin or other applicable part repair connector, Part Number 3823255, into the accelerator position sensor for idle validation sensor; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch.

OK NOT OK

2000 to 3000 ohms

Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connectorPart Number 3824910 - 6-pin Metri-Pack repair connector.
Guided Step 1D - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

  • Measure the resistance between the positive (+) 5 VDC supply wire and the signal wire on the sensor side of the accelerator position sensor.

Take the measurement when the pedal is depressed and again when released.

Install a 3-pin or other applicable part repair connector, Part Number 3823255, into the accelerator position sensor for idle validation sensor; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch.

OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the harness, bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator pedal.
  • Disconnect the OEM harness from the bulkhead connector.
  • Clean and flush the connector with electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness, bulkhead connector, and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check the resistance between the positive (+) 5 VDC supply and return wires.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance between the positive (+) 5 VDC supply and return wires.

  • Measure the resistance between pin 18 and pin 19 in the OEM harness when the accelerator pedal is up or down.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the resistance in the positive (+) 5 VDC supply wire and the signal wire circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance in the positive (+) 5 VDC supply wire and the signal wire circuit.

  • Measure the resistance between pin 18 and pin 11 when the accelerator pedal is released and again when it is depressed.
OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Repair or replace OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from the accelerator position signal and return wires to all other pins in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from the accelerator position signal and return wires to all other pins in the OEM harness.

  • Measure the resistance from pin 11 to all other pins in the OEM harness connector.
  • Measure the resistance from pin 18 to all other pins in the OEM harness connector.
  • Measure the resistance from pin 19 to all other pins in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM OEM harness port pin 11 and pin 19.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 131 inactive, Fault Code 132 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check signal pin resistance at the ECM.

  • Measure the resistance from pin 11 to pin 19 of the ECM OEM port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that the Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917- female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the harness and the accelerator position sensor connector pins. | No damaged pins
 | STEP 1B. Check for continuity from ECM to accelerator position sensor. | Less than 10 ohms
 | STEP 1C. Check the accelerator position resistance. | 2000 to 3000 ohms
 | STEP 1D. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms. Released resistance must be at least 1000 ohms more than depressed resistance
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness, bulkhead connector, and ECM connector pins. | No damaged pins
 | STEP 2B. Check the resistance between the positive (+) 5 VDC supply and return wires. | 2000 to 3000 ohms
 | STEP 2C. Check the resistance in the positive (+) 5 VDC supply wire and signal wire circuit. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms
 | STEP 2D. Check for a short circuit from the accelerator position signal and return wires to all other pins in the OEM harness. | More than 100k ohms
STEP 3. | Check for the ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 131 inactive, Fault Code 132 active
 | STEP 3B. Check ECM signal pin resistance. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the accelerator position sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for continuity from ECM to accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect OEM harness to bulkhead connector.
  • Disconnect OEM harness from accelerator pedal.
  • Disconnect OEM harness connector from ECM.

Action

Check for continuity from the ECM to the accelerator position sensor.

  • Measure the resistance from pin 11 of the OEM ECM connector to the signal pin of the accelerator position sensor connector.
  • Measure the resistance from pin 19 of the OEM ECM connector to the return pin of the accelerator position sensor connector.
  • Measure the resistance from pin 18 of the OEM ECM connector to the voltage supply pin of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the accelerator position sensor wiring.

  • Repair the accelerator position sensor wiring. Refer to Procedure 019-203 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the accelerator position sensor wiring. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917- female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1C - Check the accelerator position resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit or a short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the positive (+) 5 VDC supply and the accelerator position sensor return on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install a 3-pin or other applicable part repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch.

OK NOT OK

2000 to 3000 ohms

Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917- female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1D - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Take the measurement when the pedal is depressed and released.

Install a 3-pin or other applicable part repair connector, Part Number 3823255, into the accelerator position sensor for idle validation sensor.

  • Measure the resistance between the positive (+) 5 VDC supply wire and the signal wire on the sensor side of the accelerator position sensor.
OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the harness, bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator pedal.
  • Disconnect the OEM harness from the bulkhead connector.
  • Clean and flush the connector with electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness, bulkhead connector, and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check the resistance between the positive (+) 5 VDC supply and return wires.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance between the positive (+) 5 VDC supply and return wires.

  • Measure the resistance between pin 18 and pin 19 in the OEM harness when the accelerator pedal is up or down.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the resistance in the positive (+) 5 VDC supply wire and the signal wire circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance in the positive (+) 5 VDC supply wire and the signal wire circuit.

  • Measure the resistance between pin 18 and pin 11 when the accelerator pedal is released and again when it is depressed.
OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Repair or replace OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from the accelerator position signal and return wires to all other pins in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from the accelerator position signal and return wires to all other pins in the OEM harness.

  • Measure the resistance from pin 11 in the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 18 in the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 19 in the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check for the ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM OEM harness port pin 11 and pin 19.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 131 inactive, Fault Code 132 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Measure the signal pin resistance.

  • Measure the resistance from pin 11 to pin 19 in the ECM OEM port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that the Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool .
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack™ test leadPart Number 3823996 - female Weather-Pack™ test leadPart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823255 - 3-pin Metri-Pack™ repair connectorPart Number 3824910 - 6-pin Metri-Pack™ repair connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the accelerator position sensor is connected to the OEM harness. | Sensor connected
 | STEP 1B. Inspect the harness and the accelerator position sensor connector pins. | No damaged pins
 | STEP 1C. Check the accelerator position resistance. | 2000 to 3000 ohms
 | STEP 1D. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms
 | STEP 1E. Check for a short circuit to ground of the sensor positive (+) 5-VDC supply. | More than 100k ohms
 | STEP 1F. Check for a short circuit to ground of the sensor signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for continuity from ECM to accelerator position sensor. | Less than 10 ohms
 | STEP 2C. Check the resistance between the positive (+) 5-VDC supply and return wires. | 2000 to 3000 ohms
 | STEP 2D. Check the resistance in the positive (+) 5-VDC supply and the signal wire. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2F. Check for a short circuit. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the accelerator position supply for proper voltage. | 4.75 to 5.25-VDC
 | STEP 3B. Check for the appropriate ECM response. | Fault Code 132 inactive, Fault Code 131 active
 | STEP 3C. Check ECM for signal pin resistance. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify that the accelerator position sensor is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the accelerator position sensor.

  • Verify the accelerator position sensor is connected to the OEM harness.
OK NOT OK

Sensor connected

Connect the OEM harness

Go to 1B

Go to 4A

Guided Step 1B - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the accelerator position sensor connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Reference the OEM service manual.
  • Replace the accelerator position sensor. Reference the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the accelerator position resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit or a short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the positive (+) 5-VDC supply and the accelerator position sensor return on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch.

OK NOT OK

2000 to 3000 ohms

Replace the accelerator position sensor. Reference the OEM service manual.

Go to 1D

Go to 4A

Guided Step 1D - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness from accelerator position sensor.

Action

Check the resistance between sensor pins.

  • Measure the resistance with the accelerator pedal depressed and again when pedal is released. Measure the resistance from the positive (+) 5-VDC supply to the signal wire on the sensor side of the accelerator position sensor connector.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch.

OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal. Reference the OEM service manual.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit to ground of the sensor positive (+) 5-VDC supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground of the sensor positive (+) 5 VDC supply.

  • Measure the resistance from the positive (+) 5-VDC supply on the sensor side of the accelerator position sensor to chassis ground.
OK NOT OK

More than 100k ohms

Replace the accelerator position sensor. Reference the OEM service manual.

Go to 1F

Go to 4A

Guided Step 1F - Check for a short circuit to ground of the sensor signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground of the sensor signal wire.

  • Measure the resistance from the signal pin of the accelerator position sensor to chassis ground.
OK NOT OK

More than 100k ohms

Replace the accelerator position sensor. Reference the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the bulkhead connector.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM service manual.
  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for continuity from ECM to accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect OEM harness to bulkhead connector.
  • Disconnect OEM harness from accelerator pedal.
  • Disconnect OEM harness connector from the ECM.

Action

Check for continuity from ECM to accelerator position sensor.

  • Measure the resistance from pin-18 of the ECM OEM harness connector to the positive (+) 5-VDC supply pin of the accelerator position sensor.
  • Measure the resistance from pin-11 of the ECM OEM harness connector to the signal pin of the accelerator position sensor.
  • Measure the resistance from pin -in of the accelerator position sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the accelerator position sensor wiring

  • Repair the accelerator position sensor wiring. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the accelerator position sensor wiring. Reference the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the resistance between the positive (+) 5-VDC supply and return wires.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the bulkhead connector.

Action

Check the resistance between the positive (+) 5 VDC supply and return wires.

  • Measure the resistance between pin-18 and pin-19 of the OEM harness connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness. Reference the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check the resistance in the positive (+) 5-VDC supply and the signal wire.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the throttle position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance between the positive (+) 5 VDC supply and the signal wire.

  • Measure the resistance from pin-18 to pin-11 when the accelerator pedal is released and again when pedal is depressed.
OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Repair or replace the OEM harness. Reference the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance between pin-18 of the OEM harness and the engine block ground.
  • Measure the resistance from pin-11 of the OEM harness to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Reference the OEM service manual.

Go to 2F

Go to 4A

Guided Step 2F - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit.

  • Measure the resistance from pin-11 to all other pins of the OEM harness connector.
  • Measure the resistance from pin-18 to all other pins of the OEM harness connector.
  • Measure the resistance from pin-19 to all other pins of the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Reference the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the accelerator position supply for proper voltage.

Conditions

  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the accelerator position supply for proper voltage.

  • Measure the voltage from pin-18 to pin-19 in the OEM port at the ECM.
OK NOT OK

4.75 to 5.25-VDC

  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Install Part Number 3822917, as a jumper wire, between pin-19 and pin-11 at the OEM ECM port.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM OEM harness port pin-11 to pin-18.
  • Use INSITE™ electronic service tool read the fault codes.
OK NOT OK

Fault Code 132 inactive, Fault Code 131 active

  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check signal pin resistance at the ECM.

  • Measure the resistance from pin-11 of the ECM OEM port to pin-19 in the ECM OEM port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

  • Call for authorization to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 132 is inactive.
OK NOT OK

Fault Code 132 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823996 - female Weather-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the accelerator position sensor is connected to the OEM harness. | Sensor connected
 | STEP 1B. Inspect the harness and the accelerator position sensor connector pins. | No damaged pins
 | STEP 1C. Check the accelerator position resistance. | 2000 to 3000 ohms
 | STEP 1D. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms
 | STEP 1E. Check for a short circuit to ground of the sensor positive (+) 5 VDC supply. | More than 100k ohms
 | STEP 1F. Check for a short circuit to ground of the sensor signal wire. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Check for continuity from the ECM to the accelerator position sensor. | Less than 10 ohms
 | STEP 2C. Check the resistance between the positive (+) 5 VDC supply and return wires. | 2000 to 3000 ohms
 | STEP 2D. Check the resistance in the positive (+) 5 VDC supply and the signal wire. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2F. Check for a short circuit. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the accelerator position supply for proper voltage. | 4.75 to 5.25 VDC
 | STEP 3B. Check for the appropriate ECM response. | Fault Code 132 inactive, Fault Code 131 active
 | STEP 3C. Check ECM signal pin resistance from signal pin to return wire. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the accelerator position sensor is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the accelerator position sensor.

  • Verify the accelerator position sensor is connected to the OEM harness.
OK NOT OK

Sensor connected

Connect the OEM harness.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the accelerator position sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1C - Check the accelerator position resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit or a short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the positive (+) 5 VDC supply and the accelerator position sensor return on the sensor side of the accelerator position sensor when the accelerator pedal is released and again when it is depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch.
OK NOT OK

2000 to 3000 ohms

Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1D - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness from accelerator position sensor.

Action

Check the resistance between sensor pins.

  • Measure the resistance with the accelerator pedal depressed and again when pedal is released. Measure the resistance from the positive (+) 5 VDC supply to the signal wire on the sensor side of the accelerator position sensor connector.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch.
OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 1E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823996 - female Weather-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1E - Check for a short circuit to ground of the sensor positive (+) 5 VDC supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground of the sensor positive (+) 5 VDC supply.

  • Measure the resistance from the positive (+) 5 VDC supply on the sensor side of the accelerator position sensor to chassis ground.
OK NOT OK

More than 100k ohms

Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 1F

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823996 - female Weather-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1F - Check for a short circuit to ground of the sensor signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground of the sensor signal wire.

  • Measure the resistance from the signal pin of the accelerator position sensor to chassis ground.
OK NOT OK

More than 100k ohms

Replace the accelerator position sensor. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from ECM.
  • Disconnect the OEM harness from the bulkhead connector.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for continuity from the ECM to the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect OEM harness to bulkhead connector.
  • Disconnect OEM harness from accelerator pedal.
  • Disconnect OEM harness connector from ECM.

Action

Check for continuity from the ECM to the accelerator position sensor.

  • Measure the resistance from pin 18 of the ECM port to positive (+) 5 VDC supply pin of the accelerator position sensor.
  • Measure the resistance from pin 11 of the ECM port to the signal pin of the accelerator position sensor.
  • Measure the resistance from pin 19 of the ECM port to the return pin of the accelerator position sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the accelerator position sensor wiring.

  • Repair the accelerator position sensor wiring. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the accelerator position sensor wiring. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the resistance between the positive (+) 5 VDC supply and return wires.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the bulkhead connector.

Action

Check the resistance between the positive (+) 5 VDC supply and return wires.

  • Measure the resistance between pin 18 and pin 19 of the OEM harness connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check the resistance in the positive (+) 5 VDC supply and the signal wire.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the throttle position sensor.
  • Connect the OEM harness to the bulkhead connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance between the positive (+) 5 VDC supply and the signal wire.

  • Measure the resistance from pin 18 to pin 11 when the accelerator pedal is released and again when pedal is depressed.
OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance between pin 18 of the OEM harness and the engine block ground.
  • Measure the resistance from pin 11 of the OEM harness to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2F

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2F - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit.

  • Measure the resistance from pin 11 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 18 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 19 of the OEM harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3A - Check the accelerator position supply for proper voltage.

Conditions

  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the accelerator position supply for proper voltage.

  • Measure the voltage from pin 18 to pin 19 in the OEM port of the ECM.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Install Part Number 3822917, as a jumper wire, between pin 11 and pin 18 of the OEM ECM port.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM OEM harness port pin 11 and pin 18.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 132 inactive, Fault Code 131 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check ECM signal pin resistance from signal pin to return wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check signal pin resistance at the ECM.

  • Measure the resistance from pin 11 of the ECM OEM port to pin 19 at the ECM OEM port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 132 is inactive.
OK NOT OK

Fault Code 132 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824775 - breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917- female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure sensor. |
 | STEP 1A. Inspect the oil pressure sensor and the sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 135 active
 | STEP 1C. Check the oil pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 1C-1. Check the oil pressure sensor supply voltage. |
 | STEP 1C-2. Measure the voltage out of the ECM. |
 | STEP 1D. Check the oil pressure sensor signal voltage. | 0.40 to 0.60 VDC
 | STEP 1D-1. Check for a short circuit from pin to pin. |
 | STEP 1D-2. Check for continuity in the sensor harness. |
 | STEP 1D-3. Check ECM response. |
 | STEP 1D-4. Check ECM pin resistance. |
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 135 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for continuity in the sensor circuit. | Less than 10 ohms
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 135 inactive, Fault Code 141 active
 | STEP 3B. Check ECM signal pin resistance. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the oil pressure sensor.

Guided Step 1A - Inspect the oil pressure sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil pressure sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the oil pressure sensor and the engine harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 135 active

Repair complete.

Go to 1C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1C - Check the oil pressure sensor supply voltage.

Conditions

  • Disconnect all pressure and temperature sensors and the coolant level sensor or shorting plug from the sensor harness.
  • Turn keyswitch ON.

Action

Check the oil pressure sensor supply voltage.

  • Install oil pressure sensor breakout cable, Part Number 3824775, between the sensor and the sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 1D

Go to 1C-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
Guided Step 1C-1 - Check the oil pressure sensor supply voltage.

Conditions

  • Disconnect all pressure and temperature sensors and the coolant level sensor from the sensor harness.
  • Connect sensor harness connector to the ECM.

Action

Check the oil pressure sensor supply voltage.

  • Install breakout cable, Part Number 3824775, to the oil pressure sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
  • Do not connect the sensor to the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Does not meet specifications.

Go to 4A

Go to 1C-2

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1C-2 - Measure the voltage out of the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Using test lead, measure the voltage from pin 22 to pin 13 at the sensor port of the ECM.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check the oil pressure sensor signal voltage.

Conditions

  • Disconnect all pressure and temperature sensors and the coolant level sensor or shorting plug from their connectors on the harness.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Check the oil pressure sensor signal voltage.

  • Install oil pressure sensor breakout cable, Part Number 3824775, between the sensor and the sensor harness connector.
  • Measure the signal voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.40 to 0.60 VDC

Does not meet specifications.

Go to 2A

Go to 1D-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-1 - Check for a short from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all pressure sensors and the coolant level sensor or shorting plug from their connectors.

Action

Check for a short from pin to pin.

  • Measure the resistance from pin 22 to all other pins in the ECM sensor connector.
  • Measure the resistance from pin 7 to all other pins in the ECM sensor connector.
  • Measure the resistance from pin 13 to all other pins in the ECM sensor connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. s Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-2

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-2 - Check for continuity in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the sensor harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for continuity in the sensor harness.

  • Measure the resistance from pin 22 of the sensor harness connector to pin A of the sensor connector.
  • Measure the resistance from pin 7 of the sensor harness connector to pin C of the sensor connector.
  • Measure the resistance from pin 13 of the sensor harness connector to pin B of the sensor connector.
OK NOT OK

Less than 10 ohms

Correct pin-to-pin wiring or an open circuit.

  • Repair the sensor harness. s Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-3

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-3 - Check ECM response.

Conditions

  • Disconnect sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 7 and pin 13.
  • Read the fault codes.
OK NOT OK

Fault Code 135 inactive, Fault Code 141 active

Fault Code 135 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D-4

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-4 - Check ECM pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from the ECM.

Action

Check ECM pin-to-pin resistance.

  • Measure the resistance from pin 7 to pin 13 in the ECM port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

  • Replace the sensor. Refer to Procedure 019-063 in Section 19.

Greater than 100k ohms

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 2 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine harness and ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 135 active

Repair complete.

Go to 2C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all pressure sensors and the coolant level sensor or shorting plug from their connectors on the harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 22 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 7 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for continuity in the sensor circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the sensor harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for continuity in the circuit.

  • Inspect wiring from ECM to oil pressure sensor.
  • Measure the resistance from pin A to pin 22.
  • Measure the resistance from pin C to pin 7.
  • Measure the resistance from pin B to pin 13.
OK NOT OK

Less than 10 ohms

Correct pin-to-pin wiring, or repair or replace sensor harness.

  • Repair sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-203 in Section 19.
  • Replace sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for an ECM response.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 7 and pin 13.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 135 inactive, Fault Code 141 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check ECM signal pin resistance.

  • Measure the resistance from pin 7 of the ECM sensor port to pin 13 of the ECM sensor port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 135 is inactive.
OK NOT OK

Fault Code 135 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 145, 154, 213, 222, 352, and 422 are not active
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the oil pressure sensor and the sensor harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 141 active
 | STEP 2C. Check the oil pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the oil pressure sensor supply voltage. |
 | STEP 2C-2. Measure the voltage out of the ECM. |
 | STEP 2D. Check the oil pressure sensor signal voltage. | 0.40 to 0.60 VDC
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the sensor harness. |
 | STEP 2D-3. Check ECM response. |
 | STEP 2D-4. Check ECM signal pin to return pin resistance. |
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the ECM connector for damaged pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 141 active
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for correct pin-to-pin wiring between sensor and ECM and for continuity between sensor and ECM. | Less than 10 ohms
 | STEP 3F. Clear and check the fault codes. | No reoccurrence of Fault Code 141
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 141 inactive, Fault Code 135 active
 | STEP 4B. Check ECM signal pin resistance. | Replace the ECM
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 141 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 123, 145, 154, 213, 222, 352, and 422 are not active

Possible sensor failure, a short circuit to ground in the sensor positive (+) 5 VDC common supply, or a short circuit from pin to pin.

Go to 2A

Fault Code Multiple A

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the oil pressure sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil pressure sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the oil pressure sensor and the sensor harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-065 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 141 active

Repair complete.

Go to 2C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check the oil pressure sensor supply voltage.

Conditions

  • Connect sensor harness connector to ECM.
  • Disconnect all pressure and temperature sensors and the coolant level sensor or shorting plug from their connector on sensor harness.
  • Turn keyswitch ON.

Action

Check the oil pressure sensor supply voltage.

  • Install the oil pressure sensor breakout cable, Part Number 3824775, between the sensor and the sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 2D

Go to 2C-1

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824775 - breakout cable.
Guided Step 2C-1 - Check the oil pressure sensor supply voltage.

Conditions

  • Connect sensor harness connector to ECM.
  • Disconnect all pressure and temperature sensors and the coolant level sensor or shorting plug from their harness connector.
  • Turn keyswitch ON.

Action

Check the oil pressure sensor supply voltage.

  • Install the oil pressure sensor breakout cable, Part Number 3824775, between the sensor and the sensor harness connector.

Do not connect the sensor to the breakout cable.

  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the oil pressure sensor. Refer to Procedure 019-065 in Section 19.

Does not meet specifications.

Go to 5A

Go to 2C-2

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C-2 - Measure the voltage out of the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage at the ECM.

  • Measure the voltage between pin 22 and pin 13 of the ECM sensor port.
OK NOT OK

4.75 to 5.25 VDC

  • Repair the sensor harness. s Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check the oil pressure sensor signal voltage.

Conditions

  • Connect sensor harness connector to ECM.
  • Disconnect all pressure sensors except the oil pressure sensor from the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from the sensor harness.
  • Turn keyswitch ON.

Action

Check the oil pressure sensor signal voltage.

  • Install the oil pressure sensor breakout cable, Part Number 3824775, between the sensor and the sensor harness connector.
  • Measure the signal voltage from pin C to pin B of the breakout cable.
OK NOT OK

0.40 to 0.60 VDC

Does not meet specifications.

Go to 3A

Go to 2D-1

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-1 - Check for a short from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all pressure sensors and the coolant level sensor or shorting plug from their connectors.

Action

Check for a short from pin to pin.

  • Measure the resistance from pin 22 to all other pins in the ECM sensor connector.
  • Measure the resistance from pin 7 to all other pins in the ECM sensor connector.
  • Measure the resistance from pin 13 to all other pins in the ECM sensor connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. s Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-2 - Check for continuity in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from the ECM.
  • Disconnect oil pressure sensor from the sensor harness.

Action

Check for continuity in sensor harness.

  • Measure the resistance from pin 22 of the sensor harness connector to pin A of the sensor connector.
  • Measure the resistance from pin 7 of the sensor harness connector to pin C of the sensor connector.
  • Measure the resistance from pin 13 of the sensor harness connector to pin B of the sensor connector.
OK NOT OK

Less than 10 ohms

Correct pin-to-pin wiring or open circuit.

  • Repair harness. Refer to Procedure 019-203 in Section 19.
  • Replace harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-3

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-3 - Check ECM response.

Conditions

  • Disconnect sensor harness connector from the ECM.
  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 22 and pin 7.
  • Turn keyswitch ON.

Action

Check for appropriate ECM response.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 141 inactive, Fault Code 135 active

Fault Code 141 active

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2D-4

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-4 - Check ECM signal pin to return pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from the ECM.

Action

Check ECM signal pin to return pin resistance.

  • Measure the resistance from pin 7 to pin 13 in the ECM sensor port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

  • Replace the sensor. Refer to Procedure 019-065 in Section 19.

More than 100k ohms

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 141 active

Repair complete.

Go to 3C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all pressure sensors and the coolant level sensor or shorting plug from the sensor harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 7 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 22 of the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all pressure sensors and the coolant level sensor or shorting plug from the sensor harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 7 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 22 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for correct pin-to-pin wiring between sensor and ECM and for continuity between sensor and ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from the ECM.
  • Disconnect oil pressure sensor from the sensor harness.

Action

Check for correct pin-to-pin wiring from sensor to ECM and continuity of harness.

  • Measure the resistance from pin 22 of the sensor harness connector at the ECM to pin A of the sensor harness.
  • Measure the resistance from pin 7 of the sensor harness connector at the ECM to pin C of the sensor harness.
  • Measure the resistance from pin 13 of the sensor harness connector at the ECM to pin B of the sensor harness.
OK NOT OK

Less than 10 ohms

Repair or replace sensor harness.

  • Repair the sensor harness. s Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Clear and check the fault codes.

Conditions

  • Connect all the components.

Action

Clear and check the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Snap the accelerator pedal.
  • Read the fault codes with the service tool.
OK NOT OK

Fault Code 141 inactive

Fault Code 141 active

Go to 5A

Go to 4A

Guided Step 4 - Check for an ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 22 and pin 7.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 141 inactive, Fault Code 135 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4B - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check ECM signal pin resistance.

  • Measure the resistance from pin 7 to pin 13 in the ECM sensor port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 141 is inactive.
OK NOT OK

Fault Code 141 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 143 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle datalink.
  • Start the engine and compare the oil pressure reading on the service tool monitor screen with the reading on the mechanical oil pressure gauge.

If necessary, increase the engine speed to make it easier to see differences in the readings.
OK NOT OK

The sensor reading is correct

  • Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.
  • Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Does not meet specifications.

Go to 2A

Fault Code 141

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute. If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.
  • Verify Fault Code 143 is inactive.
OK NOT OK

Fault Code 143 inactive

Fault Code 143 active. Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823256 - female Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the coolant temperature sensor and sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 144 active
 | STEP 1C. Check the resistance of the coolant temperature sensor. | 175 ohms to 244k ohms
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 144 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check for the ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 144 inactive, Fault Code 145 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant temperature sensor.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1A - Inspect the coolant temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the coolant temperature sensor and sensor harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start and idle the engine for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 144 active

Repair complete.

Go to 1C

Go to 4B

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 1C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin A to pin B of the coolant temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor harness.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203. in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start and idle the engine for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 144 active

Repair complete.

Go to 2C

Go to 4B

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 12 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor port pin 12 and engine ground.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 144 inactive, Fault Code 145 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 144 is inactive.
OK NOT OK

Fault Code 144 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823256 - female Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 151, 154, 213, 222, 352, and 422 are not active
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the coolant temperature sensor and sensor harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 145 active
 | STEP 2C. Check the resistance of the coolant temperature sensor. | 175 ohms to 244k ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 145 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 145 inactive, Fault Code 144 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 145 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 123, 141, 151, 154, 213, 222, 352, and 422 are not active

Possible sensor failure, short circuit to ground in the sensor positive (+) 5 VDC common supply, or short circuit from pin to pin.

Go to 2A

Fault Code Multiple A

Guided Step 2 - Check the coolant temperature sensor.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 2A - Inspect the coolant temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 145 active

Repair complete.

Go to 2C

Go to 5B

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 2C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin A to pin B of the coolant temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2D

Go to 5A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the coolant temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the sensor harness.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 145 active

Repair complete.

Go to 3C

Go to 5B

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 12 of the sensor harness connector to pin A of the coolant temperature sensor.
  • Measure the resistance from pin 17 of the sensor harness connector to pin B of the coolant temperature sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 12 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 17 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 12 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 17 of the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor port pin 12 and pin 17.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 145 inactive, Fault Code 144 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 145 is inactive.
OK NOT OK

Fault Code 145 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 151 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ to the vehicle datalink.
  • Compare the coolant temperature reading on the service tool monitor screen with the reading from the temperature probe.

If a temperature measuring device is not available, then answer "OK" to this step

OK NOT OK

Sensor reading is correct. Reference proper base engine manual.

  • Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Does not meet specifications.

Go to 2A

Fault Code 144

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 151 is inactive.
OK NOT OK

Fault Code 151 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold air temperature sensor. |
 | STEP 1A. Inspect the intake manifold air temperature sensor and the sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 153 active
 | STEP 1C. Check the resistance of the intake manifold air temperature sensor. | 175 ohms to 244k ohms
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 153 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check for the ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 153 inactive, Fault Code 154 active
 | STEP 3B. Check the signal pin resistance at the ECM. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the intake manifold air temperature sensor.

Guided Step 1A - Inspect the intake manifold air temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the intake manifold temperature sensor and the sensor harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 153 active

Repair complete.

Go to 1C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 1C - Check the resistance of the intake manifold air temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance from pin A to pin B of the intake manifold air temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 153 active

Repair complete.

Go to 2C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.
  • Disconnect the sensor harness from the oil temperature sensor.
  • Disconnect the sensor harness from the ambient air temperature sensor.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 21 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 25 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 25 and engine ground.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 153 inactive Fault Code 154 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check signal pin resistance at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the resistance of the signal pin at the ECM.

  • Measure the resistance from pin 25 of the ECM sensor port to the engine block ground, using test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 153 is inactive.
OK NOT OK

Fault Code 153 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 222, 352, and 422 are not active
STEP 2. | Check the intake manifold air temperature sensor. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and the sensor harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 154 active
 | STEP 2C. Check the resistance of the intake manifold air temperature sensor. | 175 ohms to 244k ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 154 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 154 inactive, Fault Code 153 active
 | STEP 4B. Check the ECM signal pin resistance. | Less than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 154 inactive
 | STEP 5B. Clear the inactive fault codes. | All the faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Codes 123, 141, 145, 222, 352, and 422 are not active

Possible sensor failure, short circuit to ground in the sensor positive (+) 5 VDC common supply, or short circuit from pin to pin.

Go to 2A

Fault Code Multiple A

Guided Step 2 - Check the intake manifold air temperature sensor.

Guided Step 2A - Inspect the intake manifold air temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the intake manifold temperature sensor and the sensor harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seal
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 154 active

Repair complete.

Go to 2C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 2C - Check the resistance of the intake manifold air temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance from pin A to pin B of the intake manifold air temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the intake manifold air temperature sensor to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 154 active

Repair complete.

Go to 3C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 of the sensor harness connector to pin A of the intake manifold air temperature sensor.
  • Measure the resistance from pin 25 of the sensor harness connector to pin B of the intake manifold air temperature sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.
  • Disconnect the sensor harness from the oil temperature sensor.
  • Disconnect the sensor harness from the ambient air temperature sensor.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 21 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 25 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit to the ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold air temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 21 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 25 of the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor port pin 21 and pin 25.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 154 inactive, Fault Code 153 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack.
Guided Step 4B - Check the ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the resistance of the ECM signal pin.

  • Measure the resistance from pin 25 of the ECM sensor port to the engine block ground; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 154 is inactive.
OK NOT OK

Fault Code 154 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All the fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 155 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the intake manifold air temperature sensor.
  • Connect INSITE™ to the vehicle datalink.
  • Compare the intake manifold air temperature sensor reading on the service tool monitor screen with the reading from the temperature probe.

If a temperature measuring device is not available, then answer "OK" to this step.

OK NOT OK

Sensor reading is correct. Reference base engine troubleshooting and repair manual.

  • Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139
  • Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Does not meet specifications.

Go to 2A

Fault Code 153

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 155 is inactive.
OK NOT OK

Fault Code 155 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil temperature sensor. |
 | STEP 1A. Inspect the oil temperature sensor and sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 212 active
 | STEP 1C. Check the resistance of the oil temperature sensor. | 175 ohms to 244k ohms
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 212 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check for the ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 212 inactive. Fault Code 213 active
 | STEP 3B. Check ECM signal pin resistance. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the oil temperature sensor.

Guided Step 1A - Inspect the oil temperature sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil temperature sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the oil temperature sensor and sensor harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil temperature sensor if sensor connector pins are damaged. Refer to Procedure 019-067 in Section 19.
  • Replace the sensor connector if it is oversize or damaged. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 212 active

Repair complete.

Go to 1C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 1C - Check the resistance of the oil temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil temperature sensor.

Action

Check the resistance of the oil temperature sensor.

  • Measure the resistance from pin A to pin B of the oil temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 212 active

Repair complete.

Go to 2C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil temperature sensor.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Disconnect the sensor harness from the intake manifold temperature sensor.
  • Disconnect the sensor harness from the ambient air temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Read the fault codes.

  • Measure the resistance from pin 6 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 3 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 6 and engine ground.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 212 inactive, Fault Code 213 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3B - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the resistance of the ECM signal pin.

  • Measure the resistance from pin 6 of the ECM sensor port to the engine block ground; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 212 is inactive.
OK NOT OK

Fault Code 212 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 151, 154, 222, 352, and 422 are not active
STEP 2. | Check the oil temperature sensor. |
 | STEP 2A. Inspect the oil temperature sensor and the sensor harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 213 active
 | STEP 2C. Check the resistance of the oil temperature sensor. | 175 ohms to 244k ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 213 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 213 inactive, Fault Code 212 active
 | STEP 4B. Check the ECM signal pin resistance. | Less than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 213 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Codes 123, 141, 145, 151, 154, 222, 352, and 422 are not active

Possible sensor failure, short circuit to ground in sensor positive (+) 5 VDC common supply, or short circuit from pin to pin.

Go to 2A

Fault Code Multiple A

Guided Step 2 - Check the oil temperature sensor.

Guided Step 2A - Inspect the oil temperature sensor and the sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool .
OK NOT OK

Fault Code 213 active

Repair complete.

Go to 2C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 2C - Check the resistance of the oil temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil temperature sensor.

Action

Check the resistance of the oil temperature sensor.

  • Measure the resistance from pin A to pin B of the oil temperature sensor.
OK NOT OK

175 ohms to 244k ohms

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the oil temperature sensor to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 213 active

Repair complete.

Go to 3C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 6 of the sensor harness connector to pin B of the oil temperature sensor.
  • Measure the resistance from pin 3 of the sensor harness connector to pin A of the oil temperature sensor.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil temperature sensor.
  • Disconnect the sensor harness from the coolant temperature sensor.
  • Disconnect the sensor harness from the intake manifold temperature sensor.
  • Disconnect the sensor harness from the ambient air temperature sensor, if present.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 3 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the oil temperature sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 3 of the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 6 and pin 3.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 213 inactive . Fault Code 212 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4B - Check the ECM signal pin resistance.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the resistance of the ECM signal pin.

  • Measure the resistance from pin 6 to the engine block ground; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 213 is inactive.
OK NOT OK

Fault Code 213 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 214 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the oil temperature sensor.
  • Connect INSITE™ to the vehicle datalink.
  • Compare the oil temperature reading on the service tool monitor screen with the reading from the temperature sensor.

If a temperature measuring device is not available, then answer "OK" to this step.

OK NOT OK

Sensor reading correct. Reference the proper base engine troubleshooting and repair manual.

  • N14 Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142
  • M11 Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Does not meet specifications.

Go to 2A

Fault Code 212

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 214 is inactive.
OK NOT OK

Fault Code 214 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use this breakout cable to perform the test procedure:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use this breakout cable to perform this test procedure:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ambient air pressure sensor. |
 | STEP 1A. Inspect the ambient air pressure sensor and sensor harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 221 active
 | STEP 1C. Check the ambient air pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 1C-1. Measure the ambient air pressure sensor supply voltage. |
 | STEP 1C-2. Measure the voltage from the ECM. |
 | STEP 1D. Check the ambient air pressure sensor signal voltage. | 0 m [0 ft] (sea level) - 4.00 to 4.58, 914.4 m [3000 ft] - 3.60 to 4.40, 1828.8 m [6000 ft] - 3.20 to 4.00, 2743.2 m [9000 ft] - 3.00 to 3.80, 3657.6 m [12,000 ft] - 2.60 to 3.40
 | STEP 1D-1. Check for a short circuit from pin to pin. |
 | STEP 1D-2. Check for continuity in the sensor harness. |
 | STEP 1D-3. Check ECM response. |
 | STEP 1D-4. Check ECM pin resistance. |
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the sensor harness and the ECM connector for damaged pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 221 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check for the ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 221 inactive, Fault Code 222 active
 | STEP 3B. Check ECM signal pin resistance. | Less than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ambient air pressure sensor.

Guided Step 1A - Inspect the ambient air pressure sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ambient air pressure sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the ambient air pressure sensor and sensor harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 221 active

Repair complete.

Go to 1C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use this breakout cable to perform the test procedure:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use this breakout cable to perform this test procedure:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1C - Check the ambient air pressure sensor supply voltage.

Conditions

  • Disconnect all pressure and temperature sensors, and coolant level sensor or shorting plug, from the sensor harness.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor supply voltage.

  • Install ambient air pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 1D

Go to 1C-1

CAUTION

To reduce the possibility of pin and harness damage, use this breakout cable to perform this test procedure:Part Number 3824774 - breakout cable.
Guided Step 1C-1 - Measure the ambient air pressure sensor supply voltage.

Conditions

  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Disconnect all pressure and temperature sensors, and the coolant level sensor or shorting plug, from the sensor harness.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor supply voltage.

  • Install the ambient air pressure sensor breakout cable, Part Number 3824774, to the sensor connector on the sensor harness. Do not connect the sensor to the breakout cable.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Does not meet specifications.

Go to 4A

Go to 1C-2

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1C-2 - Measure the voltage from the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage out of the ECM.

  • Measure the voltage from pin 5 to pin 23 at the ECM sensor port.
OK NOT OK

4.75 to 5.25 VDC

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use this breakout cable to perform this test procedure:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1D - Check the ambient air pressure sensor signal voltage.

Conditions

  • Disconnect all sensors from the sensor harness, including the coolant level sensor or shorting plug.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure signal voltage.

  • Install ambient air pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Measure the signal voltage from pin C to pin B of the breakout cable.
OK NOT OK

0 m [0 ft] (sea level) - 4.00 to 4.58, 914.4 m [3000 ft] - 3.60 to 4.40, 1828.8 m [6000 ft ] - 3.20 to 4.00, 2743.2 m [9000 ft] - 3.00 to 3.80, 3657.6 m [12,000 ft] - 2.60 to 3.40

Does not meet specifications.

Go to 2A

Go to 1D-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all pressure sensors and the coolant level sensor or shorting plug from their connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 to all other pins in the sensor harness connector at the ECM.
  • Measure the resistance from pin 23 to all other pins in the sensor harness connector at the ECM.
  • Measure the resistance from pin 27 to all other pins in the sensor harness connector at the ECM.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-2

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-2 - Check for continuity in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the ambient air pressure sensor from the sensor harness.

Action

Check for continuity in the sensor harness.

  • Measure the resistance from pin 5 of the sensor harness connector to pin A of the sensor connector.
  • Measure the resistance from pin 23 of the sensor harness connector to pin B of the sensor connector.
  • Measure the resistance from pin 27 of the sensor harness connector to pin C of the sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 1D-3

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1D-3 - Check ECM response.

Conditions

  • Disconnect sensor harness from ECM.
  • Turn keyswitch ON.

Action

Check for an appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor harness port pin 27 and pin 23.
  • Read the fault codes.
OK NOT OK

Fault Code 221 inactive, Fault Code 222 active

Fault Code 221 active

  • Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D-4

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1D-4 - Check ECM pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the pin resistance at the ECM.

  • Measure the resistance from pin 27 to pin 23 in the ECM; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

  • Replace the sensor. Refer to Procedure 019-004 in Section 19.

Greater than 100k ohms

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 2 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals.
  • dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 221 active

Repair complete.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all pressure sensors from the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from the sensor harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 23 of the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 27 of the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 3 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor port pin 23 and pin 27.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 221 inactive, Fault Code 222 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the resistance of the ECM signal pin.

  • Measure the resistance from pin 27 to pin 23 of the ECM sensor port; use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 221 is inactive.
OK NOT OK

Fault Code 221 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824774 - breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917- female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the breakout cable to perform this test procedure:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this breakout cable when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 38221917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 154, 213, 352, and 422 are not active
STEP 2. | Check the ambient air pressure sensor. |
 | STEP 2A. Inspect the ambient air pressure sensor and sensor harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 222 active
 | STEP 2C. Check the ECM ambient air pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C-1. Check the ambient air pressure sensor supply voltage. |
 | STEP 2C-2. Measure the voltage out of the ECM. |
 | STEP 2D. Check the ECM ambient air pressure signal voltage. | Altitude (ft) - Voltage (VDC)0 (sea level) - 4.00 to 4.583000 - 3.60 to 4.406000 - 3.20 to 4.009000 - 3.00 to 3.8012,000 - 2.60 to 3.40
 | STEP 2D-1. Check for a short circuit from pin to pin. |
 | STEP 2D-2. Check for continuity in the sensor harness. |
 | STEP 2D-3. Check ECM response. |
 | STEP 2D-4. Check ECM pin resistance. |
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the ECM connector for damaged pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 222 active
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 222 inactiveFault Code 221 active
 | STEP 4B. Check ECM signal pin resistance. | Less than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 222 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 123, 141, 145, 154, 213, 352, and 422 are not active

Possible sensor failure, short circuit to ground in the sensor +5-VDC common supply, or short circuit from pin to pin.

Go to 2A

Fault Code Multiple A

Guided Step 2 - Check the ambient air pressure sensor.

Guided Step 2A - Inspect the ambient air pressure sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ambient air pressure sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the ambient air pressure sensor and sensor harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the sensor harness or the ambient air pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness.
  • Replace the sensor harness.
  • Replace the ambient air pressure sensor.
  • Install the appropriate connector seal if damaged or missing.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 222 active

Repair complete.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the breakout cable to perform this test procedure:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2C - Check the ECM ambient air pressure sensor supply voltage.

Conditions

  • Disconnect all pressure and temperature sensors from the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from the sensor harness.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure supply voltage.

  • Install the ambient air pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 2D

Go to 2C-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824774 - breakout cable.
Guided Step 2C-1 - Check the ambient air pressure sensor supply voltage.

Conditions

  • Disconnect all pressure and temperature sensors.
  • Disconnect the coolant level sensor or the shorting plug.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor supply voltage.

  • Connect the ambient air pressure sensor breakout cable, Part Number 3824774, to the sensor harness connector.
  • Do not connect the sensor to the breakout cable.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC. Replace the ambient air pressure sensor.

Does not meet specifications.

Go to 5A

Go to 2C-2

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2C-2 - Measure the voltage out of the ECM.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin 5 to pin 23 of the ECM sensor port.
OK NOT OK

4.75 to 5.25 VDC. Repair or replace the sensor harness.

Replace the ECM.

Go to 5A

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use this breakout cable when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2D - Check the ECM ambient air pressure signal voltage.

Conditions

  • Disconnect all pressure and temperature sensors from the sensor harness.
  • Disconnect the coolant level sensor or the shorting plug.
  • Turn keyswitch ON.

Action

Check the ECM ambient air pressure signal voltage.

  • Install the ambient air pressure sensor breakout cable, Part Number 3824774, between the sensor and the sensor harness connector.
  • Measure the signal voltage from pin C to pin B of the breakout cable.
OK NOT OK

Altitude (ft) - Voltage (VDC)0 (sea level) - 4.00 to 4.583000 - 3.60 to 4.406000 - 3.20 to 4.009000 - 3.00 to 3.8012,000 - 2.60 to 3.40

Does not meet specifications.

Go to 3A

Go to 2D-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all pressure sensors and the coolant level sensor or shorting plug from their connectors.

Action

Check for a short from pin to pin.

  • Measure resistance from pin 5 to all other pins in the sensor harness connector.
  • Measure resistance from pin 23 to all other pins in the sensor harness connector.
  • Measure resistance from pin 27 to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness.
  • Replace the sensor harness.

Go to 2D-2

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D-2 - Check for continuity in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect ambient air pressure sensor from the sensor harness.

Action

Check for continuity in the sensor harness.

  • Measure the resistance from pin 5 of the sensor harness connector to pin A of the sensor connector.
  • Measure the resistance from pin 23 of the sensor harness connector to pin B of the sensor connector.
  • Measure the resistance from pin 27 of the sensor harness connector to pin C of the sensor connector.
OK NOT OK

Less than 10 ohms

Correct pin-to-pin wiring or open circuit. Repair or replace the sensor harness.

  • Repair the sensor harness.
  • Replace the sensor harness.

Go to 2D-3

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2D-3 - Check ECM response.

Conditions

  • Disconnect sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install test lead, Part Number 3822917, as a jumper wire, between ECM sensor port pin 5 and pin 27.
  • Read the fault codes.
OK NOT OK

Fault Code 222 inactiveFault Code 221 active

Fault Code 222 active. Replace the ECM.

Go to 2D-4

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2D-4 - Check ECM pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from ECM.

Action

Check pin resistance in ECM.

  • Measure the resistance from pin 23 to pin 27 in the ECM sensor port. Use test lead, Part Number 3822917.
OK NOT OK

Less than 100k ohms. Replace the sensor.

Greater than 100k ohms. Replace the ECM.

Go to 5A

Go to 5A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the sensor harness and the ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the sensor harness and the ECM connector pins for:

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals
  • dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the sensor harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness.
  • Replace the sensor harness.
  • Replace the ECM.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 222 active

Repair complete.

Go to 3C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all pressure sensors.
  • Disconnect the coolant level sensor or shorting plug.

Action

Check for a short circuit to ground.

  • Measure the resistance from sensor harness connector pin 27 to the engine block ground.
  • Measure the resistance from sensor harness connector pin 5 to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness.
  • Replace the sensor harness.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all pressure sensors.
  • Disconnect the coolant level sensor or shorting plug.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from sensor harness connector pin 5 to all other pins in the connector.
  • Measure the resistance from sensor harness connector pin 23 to all other pins in the connector.
  • Measure the resistance from sensor harness connector pin 27 to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness.
  • Replace the sensor harness.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3822917, as a jumper wire, between ECM sensor port pin 5 and pin 27.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 222 inactive Fault Code 221 active

Replace the ECM.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 38221917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4B - Check ECM signal pin resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check signal pin resistance at the ECM.

  • Measure the resistance from pin 23 to pin 27 in the ECM sensor port. Use test lead, Part Number 3822917, as a jumper wire.
OK NOT OK

Less than 100k ohms

Replace the ECM.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 222 is inactive.
OK NOT OK

Fault Code 222 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Apr-2013


Associated Procedures

Cautions and Warnings

WARNING

DO not OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 2630 rpm, the engine must be shut off immediately.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for overspeed. |
 | STEP 1A. Check for the proper operating conditions. | Correct rpm reading; no damage
 | STEP 1B. Check for an alternate fuel source. | No alternate fuel source
 | STEP 1C. Check for good vehicle grounding. | Ground connections are clean and tight
 | STEP 1D. Check for moisture in ECM and connectors. | All connectors are dry
 | STEP 1E. Inspect the harness and the sensor connector pins. | No damaged pins
 | STEP 1F. Check the EPS for damage. | No damage
 | STEP 1G. Check injector circuits and fuel shutoff solenoids for a short circuit to ground. | Greater than 100k ohms
 | STEP 1H. Check datalink wiring. | More than 100k ohms
 | STEP 1I. Check engine brake circuit for short circuit to ground. | Greater than 100k ohms and correct engine or vehicle speed on service tool
 | STEP 1J. Check OEM components for shorting to ground. | Greater than 100k ohms and correct engine or vehicle speed on service tool
 | STEP 1K. Check the alternator. | Correct engine or vehicle speed on service tool
 | STEP 1L. Check other mechanical sources. | Reset overhead; no overspeed
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Identify the reason for overspeed.

Guided Step 1A - Check for the proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for the proper operating conditions.

  • Check with the driver to determine if engine overspeeded past governed speed by more than 400 rpm.
  • Check if the engine was motoring downhill when the fault was logged.
  • Monitor the engine rpm using INSITE™ electronic service tool, while increasing speed to wide-open throttle slowly.
  • Look at the snapshot data.
OK NOT OK

Correct rpm reading; no damage

Engine overspeed

Check the engine for damage

Check the base engine for damage due to overspeed condition. Reference the L10, M11, and N14 Engine Overspeed Manual, Bulletin 3666107, and repair.

Go to 1C

Go to 1B

WARNING

DO not OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 2630 rpm, the engine must be shut off immediately.
Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 2600 rpm, followed by moderate deceleration to 2000 rpm.
  • Check the intake manifold for sources of flammable vapors and check the turbocharger seals to verify there are no oil leaks.
OK NOT OK

No alternate fuel source

Remove alternate fuel sources

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, and so forth.

Go to 1C

Go to 2A

Guided Step 1C - Check for good vehicle grounding.

Conditions

  • Turn keyswitch OFF.

Action

Check for good ground wires and connections.

  • Check from negative (-) battery post to block ground.
  • Check from block ground to negative (-) starter post ground.
  • Check block to frame ground.
  • Check block to cab ground.
  • Frame to (-) battery.
  • Cab to (-) battery.
OK NOT OK

Ground connections are clean and tight

Must measure within OEM specifications for voltage drop under electrical load

Correct vehicle grounds.

Go to 1D

Go to 2A

Guided Step 1D - Check for moisture in ECM and connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for moisture in the electrical connectors.

  • Check for moisture in the ECM connectors.
  • Check for moisture in the J1587 or J1922 datalink connectors.
  • Typically, dash lamps will flash, injector solenoids will click, and the ECM will not communicate.
OK NOT OK

All connectors are dry

Dry the connectors.

  • Dry the connectors by using electrical contact cleaner, Part Number 3824510.
  • Replace the connector seal. Refer to Procedure 019-203 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Inspect the harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the vehicle speed sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the vehicle speed sensor. Refer to Procedure 019-091 in Section 19.

Go to 1F

Go to 2A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
Guided Step 1F - Check the EPS for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the EPS.
  • Disconnect the sensor harness connector from the ECM.

Action

Remove and inspect the EPS for:

  • Electrical potting cracking
  • Metal shavings on end of sensor
  • Oil leakage or swelling or insulation
  • Damage to sensor from camshaft gear or flywheel.
OK NOT OK

No damage

Replace the EPS.

Refer to Procedure 019-038 in Section 19.

Go to 1G

Go to 2A

Guided Step 1G - Check injector circuits and fuel shutoff solenoids for a short circuit to ground.

Conditions

  • Connect all components.
  • Disconnect actuator harness connector at the ECM.

Action

Check the following:

  • Check injector circuits for short circuit to ground.
  • Check fuel shutoff solenoid and associated circuits for a short circuit to ground.
OK NOT OK

Greater than 100k ohms

Correct engine or vehicle speed on service tool

Less than 100k ohms

Incorrect engine or vehicle speed on service tool

Repair or replace component that failed.

Go to 1H

Go to 2A

Guided Step 1H - Check datalink wiring.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor and OEM ECM connectors from ECM.

Action

Check for short to ground in datalink wiring.

  • Measure from pin 8 of the OEM connector at the ECM to engine block ground.
  • Measure from pin 27 of the OEM connector at the ECM to engine block ground.
  • Measure from pin 10 of the sensor connector at the ECM to engine block ground.
  • Measure from pin 20 of the sensor connector at the ECM to engine block ground.
  • Check OEM datalink power for shorts to ground, also.
OK NOT OK

More than 100k ohms

Less than 100k ohms

Repair or replace datalink wiring

  • Repair the datalink wiring. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Reference the OEM manual for procedure.

Go to 1I

Go to 2A

Guided Step 1I - Check engine brake circuit for short circuit to ground.

Conditions

  • Disconnect engine brake connector from engine harness.
  • Turn keyswitch ON.

Action

Check engine brake circuit for a short circuit to ground.

  • Start engine.
  • Read service tool.
OK NOT OK

Greater than 100k ohms and correct engine or vehicle speed on service tool

Repair or replace engine brake solenoids or engine brake harness

  • Repair the engine brake harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine brake harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine brake solenoid. Reference the base engine troubleshooting and repair manual.

Go to 1J

Go to 2A

Guided Step 1J - Check OEM components for shorting to ground.

Conditions

  • Reconnect all components.

Action

Check OEM components for shorting to ground.

  • Disable or unplug OEM components that can intermittently short to ground, such as fan clutch relays, keyswitch, engine speed sensors in the flywheel, tachographs, engine brakes, datalinks, OEM relays, vehicle speed sensors, or the alternator.
OK NOT OK

Greater than 100k ohms and correct engine or vehicle speed on service tool

Repair or replace the OEM component

Reference the OEM manual for procedures.

Go to 1K

Go to 2A

Guided Step 1K - Check the alternator.

Conditions

  • Remove the alternator belt.
  • Connect the sensor harness to the ECM.

Action

Alternator check.

  • Check vehicle speed or engine speed.
  • Start engine and let idle.
OK NOT OK

Correct engine or vehicle speed on service tool

Repair or replace the alternator

A capacitor across alternator output (observe proper polarity of capacitor) can help alternator-induced voltage spikes.

See manufacturer for specifications.

Go to 1L

Go to 2A

Guided Step 1L - Check other mechanical sources.

Conditions

  • Turn keyswitch OFF.

Action

Check other mechanical sources, such as:

  • Broken injector bias springs
  • Loose injector captive nuts
  • Plugged fuel tank vents
  • 12 VDC shorted to injectors.

Run the automated cylinder performance test to identify the bad injectors and single-cylinder cutout test.

Rough idle, smoke, or erratic rpm can be traced to a particular injector by taking temperature measurements on the exhaust manifold surface at each cylinder. Cylinders that are significantly higher than the cylinder adjacent to it at idle can have a malfunctioning injector. Maximum exhaust manifold surface temperature at idle is 143°C [290°F]. Tilting the exhaust manifold to identify excessive smoke in one cylinder compared to another is an additional method of locating a malfunctioning injector. Fuel knock in one cylinder caused by a malfunctioning cylinder can be picked out with the single-cylinder cutout test or by using a stethoscope.

OK NOT OK

Reset overhead; no overspeed

Repair the damaged parts

Reference the troubleshooting and repair manuals:

  • M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139, until the fault goes inactive
  • N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142, until the fault goes inactive

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 234 is inactive.
OK NOT OK

Fault Code 234 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

Do not add cold coolant to a hot engine. Castings can be damaged. Allow engine to cool to below 50°C [120°F] before adding coolant.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the coolant is low. |
 | STEP 1A. Check the coolant level. | Coolant level is normal
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault is still active with the engine running. | Fault Code 235 active
STEP 3. | Check the sensor harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms
 | STEP 3B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin in the sensor harness. | More than 100k ohms
 | STEP 3D. Check for a short from pin to pin in the actuator harness. | More than 100k ohms
STEP 4. | Check the ECM. |
 | STEP 4A. Check the ECM response. | Fault Code 235 inactive
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 235 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify the coolant is low.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

Do not add cold coolant to a hot engine. Castings can be damaged. Allow engine to cool to below 50°C [120°F] before adding coolant.
Guided Step 1A - Check the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check coolant level.

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level is normal

Add coolant to the radiatorReference the OEM troubleshooting and repair manual.

Make sure the coolant has the proper amount of antifreeze, SCA, and water.

Go to 2A

Go to 5A

Guided Step 2 - Check the coolant level sensor.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 2A - Confirm the fault is still active with the engine running.

Conditions

  • Replace radiator cap.
  • Turn keyswitch ON.

Action

Confirm the fault is still active with the engine running.

  • Start the engine and let it idle for at least 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 235 active

Fault Code 235 inactive

Go to 3A

Go to 5A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the coolant level sensor or the shorting plug at the OEM connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 of the sensor harness connector to pin A of the OEM connector.
  • Measure the resistance from pin 9 of the sensor harness connector to pin B of the OEM connector.
  • Measure the resistance from pin 13 of the sensor harness connector to pin J of the OEM connector.
  • Measure the resistance from pin 18 of the sensor harness connector to pin C of the OEM connector.

Check OEM harness from 9-pin OEM connector to the coolant level sensor for proper pin-to-pin wiring and continuity. Pin-to-pin wiring on OEM side of connector varies by OEM. See OEM wiring diagram for specific coolant level sensor wiring. Check for proper pin-to-pin wiring, continuity from pin to pin, and pin to ground shorts in shorting plug if there is no coolant level sensor. Shorting plug should be wired such that the 9-pin connector is wired A to C and B to J.

OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness

  • Repair the sensor harness.
  • Replace the sensor harness.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the coolant level sensor at the OEM connector or the shorting plug.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 9 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 13 of the sensor harness connector to engine block ground.
  • Measure the resistance from pin 18 of the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness.
  • Replace the sensor harness.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit from pin to pin in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the coolant level sensor at the OEM connector or shorting plug.
  • Disconnect all pressure sensors.

Action

Check for a short circuit from pin to pin in the sensor harness.

  • Measure the resistance from pin 3 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 9 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 13 to all other pins in the sensor harness connector.
  • Measure the resistance from pin 18 to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness.
  • Replace the sensor harness.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin in the actuator harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the coolant level sensor at the OEM connector.
  • Disconnect all pressure sensors.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 9-pin OEM connector.

Action

Check for a short circuit from pin to pin in the actuator harness.

  • Measure the resistance from pin 3 in the sensor harness to all pins in the actuator harness connector.
  • Measure the resistance from pin 9 in the sensor harness to all pins in the actuator harness connector.
  • Measure the resistance from pin 13 in the sensor harness to all pins in the actuator harness connector.
  • Measure the resistance from pin 18 in the sensor harness to all pins in the actuator harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness

  • Repair the sensor harness.
  • Replace the sensor harness.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check the ECM response.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM response.

  • Install Part Number 3822917, as a jumper wire, from pin 13 to pin 9 in the ECM sensor port.
  • Read the fault codes.
OK NOT OK

Fault Code 235 inactive. Replace the coolant level sensor.

Replace the ECM 019-031.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 235 is inactive.
OK NOT OK

Fault Code 235 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the VSS. |
 | STEP 1A. Inspect the harness and the sensor connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 241 active
 | STEP 1C. Check the VSS for proper adjustment. | 1/2 to 3/4 of a turn out from the gear
 | STEP 1D. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1E. Read the fault codes. | Fault Code 241 active
 | STEP 1F. Check the VSS for the correct resistance. | 750 to 1500 ohms or meets OEM specification
 | STEP 1G. Check the VSS for a short circuit to ground. | More than 100k ohms
 | STEP 1H. Check the VSS for a short circuit between coils. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the harness for a short circuit to ground. | More than 100k ohms
 | STEP 2B. Check the harness for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM components. |
 | STEP 3A. Check for an external recording device. | No external device
 | STEP 3B. Check for a gear slipping on the shaft. | Gear attached properly
STEP 4. | Check for electrical interference. |
 | STEP 4A. Check vehicle speed. | No vehicle speed; vehicle parked
 | STEP 4B. Check for good vehicle grounding. | Ground connections are clean and tight
 | STEP 4C. Check vehicle speed with the ECM away from the engine block. | No vehicle speed on electronic service tool
 | STEP 4D. Check alternator. | No vehicle speed on electronic service tool
 | STEP 4E. Check other OEM components for shorting to ground. | No vehicle speed on the electronic service tool
 | STEP 4F. Check engine brake circuit. | No vehicle speed on the electronic service tool
 | STEP 4G. Check datalink wiring for short circuit to ground. | More than 100k ohms
 | STEP 4H. Check injector circuits and fuel shutoff solenoids for short circuit to ground. | More than 100k ohms and no vehicle speed on the electronic service tool
 | STEP 4I. Check for EMI noise or feedback from another device on VSS circuit. | Vehicle parked; no vehicle speed on service tool
 | STEP 4J. Check for vehicle speed with VSS disconnected. | Vehicle parked; no vehicle speed
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 241 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the VSS.

Guided Step 1A - Inspect the harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the VSS.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and move the vehicle.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 241 active

Repair complete.

Go to 1C

Go to 5A

Guided Step 1C - Check the VSS for proper adjustment.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Inspect the VSS.

  • Check the VSS for proper adjustment.

This can vary for a VSS that is designed to have a different resistance value than shown in this tree and on the wiring diagram. Check with the OEM.

OK NOT OK

1/2 to 3/4 of a turn out from the gear

Adjust the VSS 019-090 or 019-091.

Go to 1D

Go to 5A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1D - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing.

Go to 1E

Go to 5A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and move the vehicle.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 241 active

Repair complete.

Go to 1F

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1F - Check the VSS for the correct resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for the correct resistance.

  • Measure the resistance from pin A to pin B for each VSS connector on the sensor side.

See the OEM for the required resistance of a VSS designed outside of Cummins recommendations.
OK NOT OK

750 to 1500 ohms or meets OEM specification

Replace the VSS 019-090 or 019-091.

Go to 1G

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1G - Check the VSS for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the VSS for a short circuit to ground.

  • Measure the resistance between pin A on the sensor side of one of the VSS connectors and the engine block ground.
  • Measure the resistance between pin A on the sensor side of the other VSS connector and the engine block ground.
OK NOT OK

More than 100k ohms

Replace the VSS 019-090 or 019-091.

Go to 1H

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1H - Check the VSS for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.

Action

Check the VSS for a short circuit between coils.

  • Measure the resistance between pin B on the sensor side of one of the VSS connectors and pin B of the other connector.
OK NOT OK

More than 100k ohms

Replace the VSS 019-090.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2A - Check the harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the harness for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness connector to engine block ground.
  • Measure the resistance from pin 7 of the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harnessReference the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check the harness for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the VSS.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the harness for a short circuit from pin to pin.

  • Measure the resistance from pins 3 and 7 to every other pin in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness 019-071.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM components.

Guided Step 3A - Check for an external recording device.

Conditions

Turn keyswitch OFF.

Action

Check for an external device or similar devices attached to the VSS circuit between the sensor and ECM wired to pin 3 or pin 7.

Some applications, i.e., automatic transmissions, condition the signal and supply the conditioned signal to pin 7 as a digital vehicle speed signal. This type of signal should not feed pin 3. No splices should exist between the VSS and conditioning circuit to include another device.

The variable reluctance (magnetic pickup) VSS does not source enough power to allow more than one device to exist between the ECM or conditioning circuit and the vehicle speed sensor.

OK NOT OK

No external device

Disconnect device from circuit

Go to 3B

Go to 5A

Guided Step 3B - Check for a gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the VSS.

Action

Check for the gear slipping on the shaft.

  • Check to make sure the transmission gear inside the sensor mounting is not slipping on the shaft. Do this by trying to spin the gear with a standard screwdriver.
OK NOT OK

Gear attached properly

Repair transmission gearReference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check for electrical interference.

Guided Step 4A - Check vehicle speed.

Conditions

  • Connect all components.

Action

Verify vehicle speed.

  • Check the vehicle speed with these conditions:
  • Turn keyswitch ON, vehicle not running.
  • Cranking engine with starter.
  • Vehicle parked, engine idling, with electronic service tool.
OK NOT OK

No vehicle speed; vehicle parked

Vehicle speed registers; vehicle parked.

Go to 5A

Go to 4B

Guided Step 4B - Check for good vehicle grounding.

Conditions

  • Turn keyswitch OFF.

Action

Check for good ground wires and connections.

  • Check from negative (-) battery post to engine block ground.
  • Check from block ground to negative (-) starter post ground.
  • Check block to frame ground.
  • Check block to cab ground.
  • Check from frame to (-) battery ground.
  • Check from cab to (-) battery ground.
OK NOT OK

Ground connections are clean and tightMeasure within OEM specifications for voltage drop under electrical load

Correct vehicle grounds.

Go to 4C

Go to 5A

Guided Step 4C - Check vehicle speed with the ECM away from the engine block.

Conditions

  • Turn keyswitch OFF.
  • Connect all electrical components.

Action

Monitor for electrical or mechanical noise on engine block.

Monitor vehicle speed with these conditions:

  • Turn keyswitch ON, engine not running.
  • Turn keyswitch ON, engine cranking with starter motor.
  • The engine is idling, vehicle parked, and electronic service tool connected.
OK NOT OK

No vehicle speed on electronic service tool

Vehicle speed on electronic service tool.

Go to 5A

Go to 4D

Guided Step 4D - Check the alternator.

Conditions

  • Remove the alternator belt.
  • Connect the engine harness connector to the ECM.

Action

Check for vehicle speed.

  • Start engine and let idle.
  • Read vehicle speed with electronic service tool.
OK NOT OK

No vehicle speed on electronic service tool

Vehicle speed registers on electronic service toolRepair or replace alternatorA capacitor across alternator output (observe proper polarity of capacitor) can help alternator-induced voltage spikes. See OEM manual for specifications.

Go to 5A

Go to 4E

Guided Step 4E - Check other OEM components for shorting to ground.

Conditions

  • Reconnect all components.
  • Start engine and allow it to idle.

Action

Check OEM components for short circuits to ground.

  • Disable or unplug OEM components that possibly will intermittently short to ground, such as fan clutch relays, engine speed sensors in the flywheel, tachographs, engine brakes, OEM relays, vehicle speed sensors, or the alternator.
  • Route alternator power for keyswitch to ECM and isolate OEM keyswitch.
OK NOT OK

No vehicle speed on the electronic service tool

Vehicle parked; electronic service tool displays a vehicle speed.

Go to 5A

Go to 4F

Guided Step 4F - Check engine brake circuit.

Conditions

  • Disconnect engine brake connector from the engine harness.
  • Turn keyswitch ON.

Action

Check engine brake circuit.

  • Start engine.
OK NOT OK

No vehicle speed on the electronic service tool

Electronic service tool registers vehicle speed while vehicle is parkedRepair or replace engine brake solenoids or engine brake harness.

Go to 5A

Go to 4G

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4G - Check datalink wiring for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness and OEM harness connectors from the ECM.

Action

Check for a short circuit to ground in the datalink wiring.

  • Measure from pin 8 of the OEM connector at the ECM to the engine block ground.
  • Measure from pin 27 of the OEM connector at the ECM to the engine block ground.
  • Measure from pin 10 of the sensor connector at the ECM to the engine block ground.
  • Measure from pin 20 of the sensor connector at the ECM to the engine block ground.
  • Check OEM datalink power for short circuit to ground, also.

After checking for datalink shorts to ground, monitor for vehicle speed, with the vehicle parked, keyswitch ON, engine not running, while starting the engine, and while the engine is idling.

OK NOT OK

More than 100k ohmsVehicle speed on service tool, vehicle parked

Service tool shows no vehicle speed, while vehicle is parkedLess than 100k ohmsRepair or replace datalink wiring.

  • Repair the datalink wiring.
  • Replace engine harness.
  • Replace the OEM harness. Reference the OEM manual for procedure.

Go to 4H

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4H - Check injector circuits and fuel shutoff solenoids for short circuit to ground.

Conditions

  • Connect all components.
  • Disconnect actuator harness connector at the ECM.

Action

Check for short circuits to ground.

  • Check injector circuits for short circuits to ground.
  • Check fuel shutoff solenoid and associated circuits for short circuits to ground.
OK NOT OK

More than 100k ohms and no vehicle speed on the electronic service toolRepair or replace the component that failed.

Less than 100k ohms and vehicle parked; electronic service tool registers vehicle speed.

Go to 5A

Go to 4I

Guided Step 4I - Check for EMI noise or feedback from another device on VSS circuit.

Conditions

  • Disconnect speedometer feed from VSS or any other devices wired to the second coil on the dual-coil VSS. Do not disconnect ECM side of the dual-coil VSS.
  • Disconnect any other devices sharing output signal (signal out of vehicle interface module) with the ECM digital VSS input such as a speedometer, tachograph, etc. Typically, this would be a single-coil VSS application used, for instance, in an electronic Allison transmission.
  • Connect all other components.

Action

Check for electrical noise or feedback.

Monitor vehicle speed during:

  • Turn keyswitch ON, engine not running.
  • Crank engine over with the starter motor.
  • Vehicle parked; engine idling, with an electronic service tool.
OK NOT OK

Vehicle parked; no vehicle speed on service toolRepair or replace OEM component causing noise on the VSS.

Vehicle parked; vehicle speed on service tool.

Go to 5A

Go to 4J

Guided Step 4J - Check for vehicle speed with VSS disconnected.

Conditions

  • Disconnect VSS from the OEM harness.
  • Install electronic service tool.

Action

Verify vehicle speed with electronic service tool.

Monitor vehicle speed with service tool:

  • Turn keyswitch ON, engine not running.
  • Crank engine with starter motor.
  • Vehicle parked; engine idling.

Perform all steps with vehicle parked.
OK NOT OK

Vehicle parked; no vehicle speedDrivetrain vibration, loose pickup gear, or VSS sensitivity issueCorrect the issue

Vehicle parked; vehicle speed registered by electronic service tool.Replace OEM wiring with shielded, twisted pair cable and ground one end of the shield to negative (-) battery.Do not ground both ends of the shield. Ground loop noise can be induced into the VSS.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Drive the vehicle. The vehicle speed must exceed 10 mph.
OK NOT OK

Fault Code 241 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are set correctly. |
 | STEP 1A. Verify that the customer wants “VSS Antitampering (Fault Code 242)” enabled. | Customer wants “VSS Antitampering (Fault Code 242)” enabled
 | STEP 1B. Verify that “Automatic Transmission” is set correctly for application. | “Automatic Transmission” is set correctly
 | STEP 1C. Verify that “Application Type” is set correctly for application. | “Application Type” is set correctly
STEP 2. | Look for signs of tampering. |
 | STEP 2A. Inspect the VSS. | No signs of tampering detected at or with the vehicle speed sensor
 | STEP 2B. Inspect the OEM VSS circuit. | No signs of tampering detected with the VSS leads or the OEM harness
 | STEP 2C. Monitor the vehicle speed. | Electronic service tool displays correct speed
 | STEP 2C-1. Verify the vehicle speed. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 242 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify that the feature settings are set correctly.

Guided Step 1A - Verify that the customer wants “VSS Antitampering (Fault Code 242)” enabled.

Conditions

Action

Verify that the customer wants VSS Anti-Tampering (Fault Code 242) enabled.

  • Talk to the owner of the vehicle to see if this feature is required for the application of this vehicle.
OK NOT OK

Customer wants “VSS Antitampering (Fault Code 242)” enabled

Adjust the feature setting to its correct value using INSITE™.

Go to 1B

Go to 3A

Guided Step 1B - Verify that “Automatic Transmission” is set correctly for application.

Conditions

Action

Verify that Automatic Transmission is set correctly for application.

  • Verify that this feature is activated if an automatic transmission is used, or deactivated if a manual transmission is used, using INSITE™.
OK NOT OK

“Automatic Transmission” is set correctly

Adjust the feature setting to its correct value using INSITE™.

Go to 1C

Go to 3A

Guided Step 1C - Verify that “Application Type” is set correctly for application.

Action

Verify that Application Type is set correctly for application.

  • Verify that this feature setting is set correctly for the application in which this vehicle is used, using INSITE™.

Driving for extended periods of time in lower gears is considered an ON/OFF highway application.
OK NOT OK

“Application Type” is set correctly

Adjust the feature setting to its correct value using INSITE™.

Go to 2A

Go to 3A

Guided Step 2 - Look for signs of tampering.

Guided Step 2A - Inspect the VSS.

Conditions

Turn keyswitch OFF.

Action

Inspect the VSS for:

  • Improper mounting of the VSS
  • VSS improperly connected to OEM harness
  • Other external device connected in place of VSS
  • Any evidence that tampering with the VSS has taken place.
OK NOT OK

No signs of tampering detected at or with the vehicle speed sensor

VSS has been tampered with or is improperly installed or connectedCorrectly install and connect the VSS to the OEM harness. 019-090 or 019-091.Remove any tampering device.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the OEM VSS circuit.

Action

Inspect the OEM VSS circuit for:

  • Broken, cut, or incorrect routing of the VSS wires
  • Any devices connected in series or parallel with the VSS
  • Any other wires added to the VSS circuit
  • Any evidence that tampering with the VSS circuit has taken place.

The variable reluctance (magnetic pickup) style of VSS can not tolerate two loads in the same circuit. Any additional loads between the sensor and conditioning circuit or the control module should be removed. Once the signal has been conditioned, other devices can share the speed signal.

OK NOT OK

No signs of tampering detected with the VSS leads or the OEM harness

Repair or replace the OEM harness

  • Repair the OEM harness.
  • Replace the OEM harness.

Go to 2C

Go to 3A

Guided Step 2C - Monitor the vehicle speed.

Conditions

  • Install appropriate electronic service tool, preferably INSITE™.
  • Turn keyswitch ON.

Action

To check the vehicle speed, use the electronic service tool.

  • Verify that the vehicle speed is zero when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed read by the electronic service tool with the speedometer on the dash.

If the dash is an electronic dash that uses the ECM to obtain vehicle speed, perform a road test, and use a stopwatch and road mile markers to determine the true vehicle speed.

OK NOT OK

Electronic service tool displays correct speed

Electronic service tool and speedometer do not matchVerify that the VSS parameters are adjusted correctly in the ECM. Check the VSS and the OEM harness in Steps 2A and 2B above. Repair any problems found.

Go to 2C-1

Go to 3A

Guided Step 2C-1 - Verify the vehicle speed.

Conditions

Action

Verify that the speed reported by the electronic service tool is accurate or reasonable for the present gear.

(For example: 40 mph in top gear is probably inaccurate data.)
OK NOT OK

Vehicle speed is accurate for present gear

Vehicle speed read by electronic service tool is inaccurate.Verify VSS parameters are adjusted correctly in the ECM. Check VSS and OEM harness in Steps 2A and 2B above. Repair any problems found.

Fault Code 241

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Turn keyswitch OFF.
  • Turn keyswitch ON. (Do not start engine.)

Vehicle speed and engine speed must be zero for at least 30 seconds to disable the fault code.

OK NOT OK

Fault Code 242 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake solenoids. |
 | STEP 1A. Inspect the engine brake solenoid and brake harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 243 active
 | STEP 1C. Read the fault codes with brake solenoids disconnected. | Fault Code 243 active
STEP 2. | Check the engine brake harness. |
 | STEP 2A. Inspect the engine brake harness and engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 243 active
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 243 active
 | STEP 3C. Check for a short circuit between pins. | More than 100k ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 243 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine brake solenoids.

Guided Step 1A - Inspect the engine brake solenoid and brake harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake harness from the engine brake solenoid.
  • Flush and clean the connectors using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine brake solenoid and brake harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine brake solenoid or engine brake harness, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine brake harness.
  • Replace the engine brake harness.
  • Replace the engine brake solenoid. Reference the base engine troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect the brake harness to the brake solenoids.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and activate the engine brakes.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 243 active

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Read the fault codes with brake solenoids disconnected.

Conditions

  • Disconnect the brake harness from the brake solenoids.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine, run above 1000 rpm, and activate the engine brakes.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 243 active

Replace the engine brake solenoid(s) or repair the engine brake wiring harness between connector and solenoid. Reference the base engine troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine brake harness.

Guided Step 2A - Inspect the engine brake harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from the engine harness.
  • Flush and clean the connectors using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine brake harness and engine harness connector pins for:

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals
  • dirt or debris in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or engine brake harness, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine brake harness.
  • Replace the engine brake harness.
  • Repair the engine harness.
  • Replace the engine harness.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect the engine brake harness to the engine harness.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine, run above 1000 rpm, and activate the engine brakes.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 243 active

Fault Code 243 inactiveRepair complete.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from the engine harness.
  • Disconnect the engine brake harness from the engine brake solenoids.

Action

Read the fault codes.

  • Measure the resistance from pin A of the engine brake harness to engine block ground.
  • Measure the resistance from pin B of the engine brake harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine brake harness 019-043.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pinsRepair or replace the actuator harness or ECM, whichever has the damaged pins.

  • Repair the actuator harness.
  • Replace the actuator harness.
  • Replace the ECM.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 243 active

Fault Code 243 inactiveRepair complete.

Go to 3C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit between pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the engine brake solenoids from the engine brake harness.

Action

Check for a short circuit between pins.

  • Measure the resistance from pin 18 to all other pins in the actuator harness connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the brake harness.

Action

Check for a short circuit to ground.

  • Measure resistance from pin 18 in the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohmsReplace the ECM 019-031.

Replace the actuator harness 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 243 is inactive.
OK NOT OK

Fault Code 243 inactive

Replace the ECM 019-031.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fan clutch solenoid. |
 | STEP 1A. Check for extra wires on the fan clutch solenoid post. | No extra wires
 | STEP 1B. Check for shorted fan clutch circuit on OEM side. | Fault Code 245 active
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the 9-pin Deutsch connector for damaged pins. | No damaged pins
 | STEP 2B. Check for a short circuit in the OEM harness. | More than 100k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit between pins. | More than 100k ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Check the ECM fan clutch supply voltage. |
 | STEP 4A. Check the supply voltage at the ECM. | At least 6 VDC
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 245 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fan clutch solenoid.

Guided Step 1A - Check for extra wires on the fan clutch solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the fan clutch solenoid.

  • Inspect the fan clutch solenoid post or the fan clutch relay coil.
OK NOT OK

No extra wires

Remove extra wiresA single wire should exist from relay/solenoid back to pin 7 in the actuator connector at the ECM.

Go to 1B

Go to 5A

Guided Step 1B - Check for shorted fan clutch circuit on OEM side.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 9-pin OEM connector.
  • Jump the keyswitch across the 9-pin OEM connector from pin A to pin A.

Action

Check for short in fan clutch circuit.

  • Start the engine.
OK NOT OK

Fault Code 245 active

Fault Code 245 inactiveRepair or replace defective OEM component causing the short.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the 9-pin Deutsch connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 9-pin Deutsch connector.
  • Disconnect the actuator harness from the 9-pin Deutsch connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the 9-pin Deutsch connector for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the 9-pin connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the actuator harness.
  • Replace the actuator harness.
  • Replace the 9-pin connector.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness from the 9-pin connector.

Action

Check for a short circuit in the OEM harness.

  • Measure the resistance from pin E of the 9-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harnessReference the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness from the 9-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E in the OEM harness to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harnessReference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the actuator harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the actuator harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness.
  • Replace the actuator harness.
  • Replace the ECM.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check for a short circuit between pins.

Conditions

  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit between the pins.

  • Measure the resistance from pin 7 to all other pins in the actuator harness connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness 019-043.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Disconnect the OEM harness from the fan clutch solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 7 in the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness

  • Repair the actuator harness.
  • Replace the actuator harness.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM fan clutch supply voltage.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check the supply voltage at the ECM.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Be sure the fan is OFF.
  • Insert jumper wire from pin 23 of actuator harness connector to pin 23 of ECM actuator port.
  • Insert jumper wire from pin 27 of actuator harness connector to pin 27 of ECM actuator port.
  • Turn keyswitch ON.

Action

Check the voltage at the ECM.

  • Measure the voltage from pin 7 at the ECM actuator port to ground.
OK NOT OK

At least 6 VDC

Replace the ECM 019-031.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 245 is inactive.
OK NOT OK

Fault Code 245 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff solenoid post. | No extra wires
 | STEP 1B. Check for corrosion on the solenoid post. | No corrosion found
 | STEP 1C. Check the fuel shutoff solenoid resistance. | 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids
STEP 2. | Check the actuator harness. |
 | STEP 2A. Check the actuator harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 254 active
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check the continuity of the wire to the fuel shutoff valve. | Less than 10 ohms
 | STEP 2F. Check the ECM response. | Fault Code 254 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 254 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel shutoff solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the fuel shutoff solenoid post.

Powering the fuel shutoff valve with another source other than pin 16 of the actuator can damage the ECM internally, even if source is close to battery voltage.

OK NOT OK

No extra wires

Remove any extra wires except for the single wire from pin 16 of actuator harness.

Go to 1B

Go to 3A

Guided Step 1B - Check for corrosion on the solenoid post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff control wire from the fuel shutoff solenoid.

Action

Check for corrosion.

Check for corrosion on the solenoid post.
OK NOT OK

No corrosion found

Clean the solenoid post and the wiring terminal.

Refer to Procedure 019-050 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the fuel shutoff solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the shutoff solenoid.

Action

Check the fuel shutoff solenoid resistance.

  • Measure the resistance from the fuel shutoff solenoid to engine block ground.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

1 to 5 ohms for 6-VDC solenoids

6 to 15 ohms for 12-VDC solenoids

24 to 50 ohms for 24-VDC solenoids

42 to 80 ohms for 32-VDC solenoids

46 to 87 ohms for 36-VDC solenoids

92 to 145 ohms for 48-VDC solenoids

315 to 375 ohms for 74-VDC solenoids

645 to 735 ohms for 115-VAC solenoids

Replace the fuel shutoff solenoid.

Refer to Procedure 019-050 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the actuator harness.

Guided Step 2A - Check the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins, use electronic contact cleaner, Part Number 3824510.

Action

Check the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the actuator harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine connector or harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the active fault codes.
OK NOT OK

Fault Code 254 active

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 16 of the actuator harness connector to engine block ground.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 16 of the actuator harness connector to all other pins in the connector.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the continuity of the wire to the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff solenoid.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for continuity to fuel shutoff valve.

  • Measure the resistance from pin 16 of the ECM actuator connector to fuel shutoff valve ring connector on actuator harness.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
OK NOT OK

Less than 10 ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the ECM response.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Connect jumper wire pin 27 of actuator harness connector to pin 27 of ECM actuator port.
  • Connect jumper wire pin 23 of actuator harness connector to pin 23 of ECM actuator port.
  • Connect jumper wire pin 26 of actuator harness connector to pin 26 of ECM actuator port.
  • Turn keyswitch ON.

Action

Check the ECM response.

  • Wire a 1k-ohm resistor from pin 16 to pin 9 of the actuator port of the ECM.
OK NOT OK

Fault Code 254 inactive

Fault Code 254 active.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 254 is inactive.
OK NOT OK

Fault Code 254 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check for the external voltage source. | Less than 1.5 VDC
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 255 inactive
 | STEP 2B. Clear the fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Check the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Check the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the actuator harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness.
  • Replace the actuator harness.
  • Replace the ECM.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check for the external voltage source.

Conditions

  • Disconnect the actuator harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the external voltage source.

  • Measure voltage from pins 7, 16, and 18 in actuator harness connector to engine block ground.

Internal ECM damage can result from external power sources connected to these actuator pins.
OK NOT OK

Less than 1.5 VDC

Remove the external voltage sourceThere is an external source connected to the wire at which more than 1.5 VDC was measured. Find the voltage source, and remove it from the circuit.

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the fuel shutoff solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 16 to all other pins in actuator harness connector, except pins 9, 25, and 27.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness

  • Repair the actuator harness.
  • Replace the actuator harness.

Go to 1D

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the 9-pin OEM harness connector from the OEM harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 7 to all other pins in the actuator harness connector, except 9, 25, and 27.
  • Measure resistance from pin 7 in the actuator harness connector to all pins in the sensor harness connector.

It is necessary to do pin-to-pin checks on the OEM side of the 9-pin connector. See the OEM manual for specific connectors/wires that are in common with the fan clutch wiring.

OK NOT OK

More than 100k ohms

Repair or replace the actuator harness

  • Repair the actuator harness.
  • Replace the actuator harness.

Go to 1E

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 18 to all other pins in the actuator harness connector, except pins 9, 25, and 27.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness

  • Repair the actuator harness.
  • Replace the actuator harness.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 255 is inactive.
OK NOT OK

Fault Code 255 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all the components.

Action

Clear the fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the internal actuator harness. |
 | STEP 1A. Inspect the internal and external actuator harness pass-through connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 311 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the external actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 311 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the ECM response. | Fault Code 311 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 311 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the internal and external actuator harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator harness from the 12-pin connector.
  • Disconnect the internal actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 311 active

Repair complete.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness 12-pin connector from the actuator harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the 12-pin connector to all other pins in the connector, except pin B.
  • Measure the resistance from pin B of the 12-pin connector to all other pins in the connector, except pin A.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the external actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 311 active

Repair complete.

Go to 2C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the external actuator harness from the 12-pin connector of the internal actuator harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 10 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 1 and 10 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 311 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 311 is inactive.
OK NOT OK

Fault Code 311 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 311 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check the ECM response. | Fault Code 311 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 311 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 311 active

Repair complete.

Go to 1C

Go to 3B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector for cylinder 1.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 1 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 10 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 1 and 10 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 311 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 311 is inactive.
OK NOT OK

Fault Code 311 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the internal actuator harness. |
 | STEP 1A. Inspect the internal and external actuator harness pass-through connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 312 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the external actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 312 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the ECM response. | Fault Code 312 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 312 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the internal and external actuator harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator harness from the 12-pin connector.
  • Disconnect the internal actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 312 active

Repair complete.

Go to 1C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin C of the 12-pin connector to all other pins in the connector, except pin D.
  • Measure the resistance from pin D of the 12-pin connector to all other pins in the connector, except pin C.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the external actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 312 active

Repair complete.

Go to 2C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 2 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 2 and 11 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 312 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 312 is inactive.
OK NOT OK

Fault Code 312 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 312 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check the ECM response. | Fault Code 312 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 312 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 312 active

Repair complete.

Go to 1C

Go to 3B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 11 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 2 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 11 and 2 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 312 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 312 is inactive.
OK NOT OK

Fault Code 312 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the internal actuator harness. |
 | STEP 1A. Inspect the internal and external actuator harness pass-through connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 313 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the external actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 313 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the ECM response. | Fault Code 313 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 313 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the internal and external actuator harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator harness from the 12-pin connector.
  • Disconnect the internal actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 313 active

Repair complete.

Go to 1C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin E of the 12-pin connector to all other pins in the connector, except pin F.
  • Measure the resistance from pin F of the 12-pin connector to all other pins in the connector, except pin E.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the external actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 313 active

Repair complete.

Go to 2C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 12 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 3 and 12 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 313 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 313 inactive.
OK NOT OK

Fault Code 313 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 313 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check the ECM response. | Fault Code 313 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 313 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 313 active

Repair complete.

Go to 1C

Go to 3B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 3 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 12 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 3 and 12 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 313 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 313 is inactive.
OK NOT OK

Fault Code 313 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the internal actuator harness. |
 | STEP 1A. Inspect the internal and external actuator harness pass-through connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 314 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the external actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 314 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the ECM response. | Fault Code 314 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 314 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the internal and external actuator harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator harness from the 12-pin connector.
  • Disconnect the internal actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 314 active

Repair complete.

Go to 1C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin G of the 12-pin connector to all other pins in the connector, except pin H.
  • Measure the resistance from pin H of the 12-pin connector to all other pins in the connector, except pin G.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the external actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 314 active

Repair complete.

Go to 2C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 4 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 4 and 13 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 314 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 314 is inactive.
OK NOT OK

Fault Code 314 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 314 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check the ECM response. | Fault Code 314 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 314 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 314 active

Repair complete.

Go to 1C

Go to 3B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 13 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 4 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 13 and 4 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 314 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 314 is inactive.
OK NOT OK

Fault Code 314 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the internal actuator harness. |
 | STEP 1A. Inspect the internal and external actuator harness pass-through connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 315 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the external actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 315 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the ECM response. | Fault Code 315 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 315 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the internal and external actuator harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator harness from the 12-pin connector.
  • Disconnect the internal actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 315 active

Repair complete.

Go to 1C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin J of the 12-pin connector to all other pins in the connector, except pin K.
  • Measure the resistance from pin K of the 12-pin connector to all other pins in the connector, except pin J.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the external actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 315 active

Repair complete.

Go to 2C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 14 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 5 and 14 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 315 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 315 is inactive.
OK NOT OK

Fault Code 315 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 315 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check the ECM response. | Fault Code 315 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 315 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 315 active

Repair complete.

Go to 1C

Go to 3B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 5 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 14 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 5 and 14 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 315 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 315 is inactive.
OK NOT OK

Fault Code 315 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the internal actuator harness. |
 | STEP 1A. Inspect the internal and external actuator harness pass-through connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 321 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the external actuator harness. |
 | STEP 2A. Inspect the actuator harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 321 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the ECM response. | Fault Code 321 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 321 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the internal and external actuator harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator harness from the 12-pin connector.
  • Disconnect the internal actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 321 active

Repair complete.

Go to 1C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin L of the 12-pin connector to all other pins in the connector, except pin M.
  • Measure the resistance from pin M of the 12-pin connector to all other pins in the connector, except pin L.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the external actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the actuator harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 321 active

Repair complete.

Go to 2C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 15 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 6 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 6 and 15 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 321 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 321 is inactive.
OK NOT OK

Fault Code 321 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the actuator harness. |
 | STEP 1A. Inspect the harness and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 321 active
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the ECM. |
 | STEP 2A. Check the ECM response. | Fault Code 321 inactive
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 321 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 321 active

Repair complete.

Go to 1C

Go to 3B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 15 in the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 6 in the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect pins 15 and 6 of the actuator harness connector from the ECM.

Action

Check the ECM response.

  • Start the engine and let it idle for 1 minute.
  • Read the active fault codes using INSITE™.
OK NOT OK

Fault Code 321 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 321 is inactive.
OK NOT OK

Fault Code 321 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and internal actuator harness pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 322 active
STEP 2. | Check the internal actuator harness. |
 | STEP 2A. Inspect the internal and external actuator harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Read the fault codes. | Fault Code 322 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 322 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 322 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and internal actuator harness pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator connector from the internal actuator connector at the 12-pin connector.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Inspect the injector solenoid wire and internal actuator harness pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Repair or replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness and the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 322 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the internal and external actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness 12-pin connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Connect the injector to the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 1 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin B on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 1 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A on the internal harness side of the actuator harness 12-pin connector to engine block ground.
  • Measure the resistance from pin B on the internal harness side of the actuator harness 12-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
  • Measure the resistance from pin B on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 322 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 322 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness 12-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the actuator harness connector to pin A on the external harness side of the actuator harness 12-pin connector.
  • Measure the resistance from pin 10 of the actuator harness connector to pin B on the external harness side of the actuator harness 12-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 10 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 10 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault codes.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 322 is inactive.
OK NOT OK

Fault Code 322 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and pass-through connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 322 active
STEP 2. | Check the pass-through connector. |
 | STEP 2A. Inspect the pass-through connector and actuator harness connector pins. | No damaged pins
 | STEP 2B. Check the pass-through connector for damage. | No connector damage
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Read the fault codes. | Fault Code 322 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 322 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 322 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector.

Action

Inspect the injector solenoid wire and pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector and the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 322 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the pass-through connector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the pass-through connector and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.

Action

Inspect the pass-through connector and actuator harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check the pass-through connector for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check the pass-through connector for damage.

  • Remove the injector pass-through connector.
  • Check for a cracked or broken connector.
OK NOT OK

No connector damage

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check for an open circuit in the pass-through connector.

  • Measure the resistance from pin 1 on both sides of the pass-through connector.
  • Measure the resistance from pin 2 on both sides of the pass-through connector.
OK NOT OK

Less than 10 ohms

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 322 active

Repair complete.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 322 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the actuator harness connector to pin 1 on the harness side of the 2-pin connector.
  • Measure the resistance from pin 10 of the actuator harness connector to pin 2 on the harness side of the 2-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 10 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit from pin to pin in the external actuator harness.

  • Measure the resistance from pin 1 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 10 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 322 is inactive.
OK NOT OK

Fault Code 322 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and internal actuator harness pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 323 active
STEP 2. | Check the internal actuator harness. |
 | STEP 2A. Inspect the internal and external actuator harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Read the fault codes. | Fault Code 323 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 323 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 323 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and internal actuator harness pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator connector from the internal actuator connector at the 12-pin connector.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Inspect the injector solenoid wire and internal actuator harness pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Repair or replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract lead resistance of the multimeter to get true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract lead resistance of the multimeter to get true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 323 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the internal and external actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Connect the injector to the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from pin C on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 5 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin D on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 5 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin C on the internal harness side of the actuator harness 12-pin connector to engine block ground.
  • Measure the resistance from pin D on the internal harness side of the actuator harness 12-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin C on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
  • Measure the resistance from pin D on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 323 active

Repair complete.

Go to 3A

Go to 4A

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool .
OK NOT OK

Fault Code 323 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness 12-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 of the actuator harness connector to pin C on the external harness side of the actuator harness 12-pin connector.
  • Measure the resistance from pin 2 of the actuator harness connector to pin D on the external harness side of the actuator harness 12-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness 12-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 11 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 2 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 2 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault codes.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 323 is inactive.
OK NOT OK

Fault Code 323 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and pass-through connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 323 active
STEP 2. | Check the pass-through connector. |
 | STEP 2A. Inspect the pass-through connector and actuator harness connector pins. | No damaged pins
 | STEP 2B. Check the pass-through connector for damage. | No connector damage
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Read the fault codes. | Fault Code 323 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 323 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 323 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

Guided Step 1A - Inspect the injector solenoid wire and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector.

Action

Inspect the injector solenoid wire and pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector and the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract lead resistance of multimeter to get true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract lead resistance of multimeter to get true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 323 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the pass-through connector.

Guided Step 2A - Inspect the pass-through connector and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.

Action

Inspect the pass-through connector and actuator harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the pass-through connector for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check the pass-through connector for damage.

  • Remove the injector pass-through connector.
  • Check for a cracked or broken connector.
OK NOT OK

No connector damage

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check for an open circuit in the pass-through connector.

  • Measure the resistance from pin 1 on both sides of the pass-through connector.
  • Measure the resistance from pin 2 on both sides of the pass-through connector.
OK NOT OK

Less than 10 ohms

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 323 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 323 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 of the actuator harness connector to pin 1 on the harness side of the 2-pin connector.
  • Measure the resistance from pin 2 of the actuator harness connector to pin 2 on the harness side of the 2-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 11 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit from pin to pin in the external actuator harness.

  • Measure the resistance from pin 2 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 11 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 323 is inactive.
OK NOT OK

Fault Code 323 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-Apr-2013


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and internal actuator harness pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 324 active
STEP 2. | Check the internal actuator harness. |
 | STEP 2A. Inspect the internal actuator harness and actuator harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Read the fault codes. | Fault Code 324 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 324 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 324 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and internal actuator harness pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Inspect the injector solenoid wire and internal actuator harness pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Repair or replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF .
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract lead resistance of multimeter to get true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract lead resistance of multimeter to get true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 324 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the internal actuator and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness 12-pin connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Connect the injector to the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from pin E on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 3 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin F on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 3 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E on the internal harness side of the actuator harness 12-pin connector to engine block ground.
  • Measure the resistance from pin F on the internal harness side of the actuator harness 12-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin E on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
  • Measure the resistance from pin F on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 324 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 324 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness 12-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 of the actuator harness connector to pin E on the external harness side of the actuator harness 12-pin connector.
  • Measure the resistance from pin 12 of the actuator harness connector to pin F on the external harness side of the actuator harness 12-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 12 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 12 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 324 is inactive.
OK NOT OK

Fault Code 324 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and pass-through connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 324 active
STEP 2. | Check the pass-through connector. |
 | STEP 2A. Inspect the pass-through connector and actuator harness connector pins. | No damaged pins
 | STEP 2B. Check the pass-through connector for damage. | No damaged connector
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Read the fault codes. | Fault Code 324 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 324 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 324 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector.

Action

Inspect the injector solenoid wire and pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector and the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract the lead resistance of the multimeter to get true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract the lead resistance of the multimeter to get true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 324 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the pass-through connector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the pass-through connector and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.

Action

Inspect the pass-through connector and actuator harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Repair the actuator harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check the pass-through connector for damage.

Conditions

  • Turn keyswitch OFF;
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check the pass-through connector for damage.

  • Remove the injector pass-through connector.
  • Check for a cracked or broken connector.
OK NOT OK

No damaged connector

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check for an open circuit in the pass-through connector.

  • Measure the resistance from pin 1 on both sides of the pass-through connector.
  • Measure the resistance from pin 2 on both sides of the pass-through connector.
OK NOT OK

Less than 10 ohms

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 324 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 324 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 of the actuator harness connector to pin 1 on the harness side of the 2-pin connector.
  • Measure the resistance from pin 12 of the actuator harness connector to pin 2 on the harness side of the 2-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 12 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit from pin to pin in the external actuator harness.

  • Measure the resistance from pin 3 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 12 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 324 is inactive.
OK NOT OK

Fault Code 324 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and internal actuator harness pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 325 active
STEP 2. | Check the internal actuator harness. |
 | STEP 2A. Inspect the internal actuator harness and actuator harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Read the fault codes. | Fault Code 325 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 325 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 325 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and internal actuator harness pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Inspect the injector solenoid wire and internal actuator harness pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Repair or replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract the lead resistance of the multimeter to get true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract the lead resistance of the multimeter to get true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 325 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the internal actuator harness and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness 12-pin connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Connect the injector to the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from pin G on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 6 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin H on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 6 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin G on the internal harness side of the actuator harness 12-pin connector to engine block ground.
  • Measure the resistance from pin H on the internal harness side of the actuator harness 12-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin G on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
  • Measure the resistance from pin H on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 325 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 325 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness 12-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the actuator harness connector to pin G on the external harness side of the actuator harness 12-pin connector.
  • Measure the resistance from pin 4 of the actuator harness connector to pin H on the external harness side of the actuator harness 12-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 4 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 4 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for on (1) minute.
  • Verify Fault Code 325 is inactive.
OK NOT OK

Fault Code 325 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and pass-through connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 325 active
STEP 2. | Check the pass-through connector. |
 | STEP 2A. Inspect the pass-through connector and actuator harness connector pins. | No damaged pins
 | STEP 2B. Check the pass-through connector for damage. | No damaged connector
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Read the fault codes. | Fault Code 325 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 325 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 325 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector.

Action

Inspect the injector solenoid wire and pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector and the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 325 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the pass-through connector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the pass-through connector and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.

Action

Inspect the pass-through connector and actuator harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check the pass-through connector for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check the pass-through connector for damage.

  • Remove the injector pass-through connector.
  • Check for a cracked or broken connector.
OK NOT OK

No damaged connector

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check for an open circuit in the pass-through connector.

  • Measure the resistance from pin 1 on both sides of the pass-through connector.
  • Measure the resistance from pin 2 on both sides of the pass-through connector.
OK NOT OK

Less than 10 ohms

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 325 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 325 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the actuator harness connector to pin 1 on the harness side of the 2-pin connector.
  • Measure the resistance from pin 4 of the actuator harness connector to pin 2 on the harness side of the 2-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 4 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit from pin to pin in the external actuator harness.

  • Measure the resistance from pin 13 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 4 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 325 is inactive.
OK NOT OK

Fault Code 325 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and internal actuator harness pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 331 active
STEP 2. | Check the internal actuator harness. |
 | STEP 2A. Inspect the internal and external actuator harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Read the fault codes. | Fault Code 331 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 331 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 331 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and internal actuator harness pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Inspect the injector solenoid wire and internal actuator harness pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Repair or replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 331 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the internal and external actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness 12-pin connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Connect the injector to the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from pin J on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 2 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin K on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 2 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin J on the internal harness side of the actuator harness 12-pin connector to engine block ground.
  • Measure the resistance from pin K on the internal harness side of the actuator harness 12-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin J on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
  • Measure the resistance from pin K on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 331 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 331 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness 12-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the actuator harness connector to pin J on the external harness side of the actuator harness 12-pin connector.
  • Measure the resistance from pin 14 of the actuator harness connector to pin K on the external harness side of the actuator harness 12-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 5 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 14 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 14 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 331 is inactive.
OK NOT OK

Fault Code 331 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and pass-through connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 331 active
STEP 2. | Check the pass-through connector. |
 | STEP 2A. Inspect the pass-through connector and actuator harness connector pins. | No damaged pins
 | STEP 2B. Check the pass-through connector for damage. | No damaged connector
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Read the fault codes. | Fault Code 331 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 331 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 331 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector.

Action

Inspect the injector solenoid wire and pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector and the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

N0te: Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 331 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the pass-through connector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the pass-through connector and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.

Action

Inspect the pass-through connector and actuator harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check the pass-through connector for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check the pass-through connector for damage.

  • Remove the injector pass-through connector.
  • Check for a cracked or broken connector.
OK NOT OK

No damaged connector

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check for an open circuit in the pass-through connector.

  • Measure the resistance from pin 1 on both sides of the pass-through connector.
  • Measure the resistance from pin 2 on both sides of the pass-through connector.
OK NOT OK

Less than 10 ohms

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 331 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 331 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the actuator harness connector to pin 1 on the harness side of the 2-pin connector.
  • Measure the resistance from pin 14 of the actuator harness connector to pin 2 on the harness side of the 2-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 5 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 14 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit from pin to pin in the external actuator harness.

  • Measure the resistance from pin 5 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 14 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 331 is inactive.
OK NOT OK

Fault Code 331 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and internal actuator harness pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 332 active
STEP 2. | Check the internal actuator harness. |
 | STEP 2A. Inspect the internal and external actuator harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Read the fault codes. | Fault Code 332 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 332 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 332 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and internal actuator harness pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Inspect the injector solenoid wire and internal actuator harness pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Repair or replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.

Go to 1E

Go to 4A

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 332 active

Repair complete.

Go to 2A

Go to 4B

Guided Step 2 - Check the internal actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the internal and external actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Disconnect the external actuator harness from the 12-pin connector.

Action

Inspect the internal and external actuator harness 12-pin connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the internal actuator harness from the 12-pin connector.
  • Connect the injector to the internal actuator harness.

Action

Check for an open circuit.

  • Measure the resistance from pin L on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 4 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin M on the internal harness side of the actuator harness 12-pin connector to each injector pigtail nut that connects to number 4 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin L on the internal harness side of the actuator harness 12-pin connector to engine block ground.
  • Measure the resistance from pin M on the internal harness side of the actuator harness 12-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the external actuator 12-pin connector.
  • Disconnect the injector from the internal actuator harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin L on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
  • Measure the resistance from pin M on the internal harness side of the actuator harness 12-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the internal actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 332 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 332 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness 12-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 15 of the actuator harness connector to pin L on the external harness side of the actuator harness 12-pin connector.
  • Measure the resistance from pin 6 of the actuator harness connector to pin M on the external harness side of the actuator harness 12-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 15 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 6 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the 12-pin connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 15 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 332 is inactive.
OK NOT OK

Fault Code 332 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the injector solenoid wire and pass-through connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for an open circuit in the solenoid. | 0.5 to 1.5 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Read the fault codes. | Fault Code 332 active
STEP 2. | Check the pass-through connector. |
 | STEP 2A. Inspect the pass-through connector and actuator harness connector pins. | No damaged pins
 | STEP 2B. Check the pass-through connector for damage. | No damaged connector
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Read the fault codes. | Fault Code 332 active
STEP 3. | Check the actuator harness. |
 | STEP 3A. Inspect the actuator harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 332 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 332 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the injector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1A - Inspect the injector solenoid wire and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector.

Action

Inspect the injector solenoid wire and pass-through connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Replace the injector solenoid wire. Refer to Procedure 019-058 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 1B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid wires from the pass-through connector and the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance from each pin on the injector solenoid wire and its corresponding captive nut assembly.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

Less than 10 ohms

Replace the injector solenoid wires. Refer to Procedure 019-058 in Section 19.

Go to 1C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1C - Check for an open circuit in the solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for an open circuit in the solenoid.

  • Measure the resistance of the multimeter probes by touching them together and noting the resistance value.
  • Measure the resistance between the two solenoid posts on the injector.

Subtract the lead resistance of the multimeter to get the true solenoid resistance.
OK NOT OK

0.5 to 1.5 ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1D

Go to 2A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector pigtail connector from the solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from one of the solenoid posts to engine block ground.
OK NOT OK

More than 100k ohms

Replace the injector. Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 1E

Go to 4B

Guided Step 1E - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 332 active

Repair complete.

Go to 2A

Go to 4A

Guided Step 2 - Check the pass-through connector.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 2A - Inspect the pass-through connector and actuator harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.

Action

Inspect the pass-through connector and actuator harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2B

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check the pass-through connector for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check the pass-through connector for damage.

  • Remove the injector pass-through connector.
  • Check for a cracked or broken connector.
OK NOT OK

No damaged connector

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2C

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the pass-through connector.
  • Disconnect the injector from the pass-through connector.

Action

Check for an open circuit in the pass-through connector.

  • Measure the resistance from pin 1 on both sides of the pass-through connector.
  • Measure the resistance from pin 2 on both sides of the pass-through connector.
OK NOT OK

Less than 10 ohms

Replace the pass-through connector. Refer to Procedure 019-200 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 332 active

Repair complete.

Go to 3A

Go to 4B

Guided Step 3 - Check the actuator harness.

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the actuator harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the actuator harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 332 active

Repair complete.

Go to 3C

Go to 4B

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 15 of the actuator harness connector to pin 1 on the harness side of the 2-pin connector.
  • Measure the resistance from pin 6 of the actuator harness connector to pin 2 on the harness side of the 2-pin connector.
OK NOT OK

Less than 10 ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 15 of the actuator harness connector to engine block ground.
  • Measure the resistance from pin 6 of the actuator harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the actuator harness from the pass-through connector.

Action

Check for a short circuit from pin to pin in the external actuator harness.

  • Measure the resistance from pin 15 of the actuator harness connector to all other pins in the connector.
  • Measure the resistance from pin 6 of the actuator harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 332 is inactive.
OK NOT OK

Fault Code 332 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check external ECM components. |
 | STEP 1A. Confirm fault code is still active. | Fault Code 333 active
 | STEP 1B. Examine the EPS. | EPS works correctly
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 333 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check external ECM components.

Guided Step 1A - Confirm fault code is still active.

Conditions

  • Connect all the components.

Action

Confirm fault code is still active.

  • Cycle the keyswitch from ON to OFF for five seconds, then back ON. Start the engine and idle for at least one minute.
OK NOT OK

Fault Code 333 active

Fault Code 333 inactive

Go to 1B

Go to 2B

Guided Step 1B - Examine the EPS.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the EPS.
  • Remove the EPS using the EPS installation tool, Part Number 3822747.

Action

Examine the EPS.

  • Examine the EPS for physical damage, cracked potting material, and incorrect seating in the engine.
OK NOT OK

EPS works correctly

Replace the EPS

Refer to Procedure 019-038 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 333 is inactive.
OK NOT OK

Fault Code 333 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 335 inactive
 | STEP 1A-1. Check the new ECM. |
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn vehicle keyswitch OFF and wait five seconds.
  • Turn vehicle keyswitch ON and idle engine for at least one minute.
OK NOT OK

Fault Code 335 inactive

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Check the new ECM.

Conditions

  • Connect all components.

Action

Check the new ECM.

  • Start the engine and let idle for one minute.
  • Verify Fault Code 335 is inactive.
OK NOT OK

Fault Code 335 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 341 inactive
 | STEP 1A-1. Check the new ECM. |
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn vehicle keyswitch OFF and wait five seconds.
  • Turn vehicle keyswitch ON and idle engine for at least one minute.
OK NOT OK

Fault Code 341 inactive

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Check the new ECM.

Conditions

  • Connect all components.

Action

Check the new ECM.

  • Start the engine and let idle for one minute.
  • Verify Fault Code 341 is inactive.
OK NOT OK

Fault Code 341 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check if ECM has been calibrated. | Calibrated ECM
 | STEP 1B. Check ECM for active Fault Code 342. | Fault Code 342 inactive
 | STEP 1C. Check for inactive counts of Fault Code 342. | Two or fewer inactive counts of Fault Code 342
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

Guided Step 1A - Check if ECM has been calibrated.

Conditions

  • Connect all the components.

Action

Check if ECM has been calibrated.

  • Check if calibration has been downloaded into the ECM.
  • Fault Code 342 will be recorded if new ECM has not been calibrated.
OK NOT OK

Calibrated ECM

ECM needs calibration

Refer to Procedure 019-032 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check ECM for active Fault Code 342.

Conditions

  • Connect all components.

Action

Check ECM for active Fault Code 342.

  • Turn vehicle keyswitch OFF and wait five seconds.
  • Start engine and let idle for one minute.
OK NOT OK

Fault Code 342 inactive

Fault Code 342 active

Go to 1C

Go to 2A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1C - Check for inactive counts of Fault Code 342.

Conditions

  • Turn keyswitch ON.

Action

Check for inactive counts of Fault Code 342.

  • Check if there are two or fewer inactive counts of Fault Code 342.
OK NOT OK

Two or fewer inactive counts of Fault Code 342.

Three of more inactive counts of Fault Code 342

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - female AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 343 active
STEP 2. | Check the power and ground connections. |
 | STEP 2A. Check all engine and chassis power and ground connections. | Clean and tight
 | STEP 2B. Check all power and ground resistances. | Less than 10 ohms
 | STEP 2C. Check battery grounds. | Meets OEM specifications
STEP 3. | Check for moisture in the ECM connectors. |
 | STEP 3A. Check for moisture in the ECM connectors. | All connectors dry
STEP 4. | Check the engine position sensor (EPS). |
 | STEP 4A. Check the engine position sensor for damage. | No damage
 | STEP 4B. Check the engine position sensor polarity. | Correct polarity
 | STEP 4C. Check for alternator-induced Fault Code 343. | Fault Code 343 inactive
 | STEP 4D. Check engine brake circuit. | Fault Code 343 inactive
 | STEP 4E. Check datalink wiring. | Fault Code 343 inactive
 | STEP 4F. Check OEM-installed components. | Fault Code 343 inactive
 | STEP 4G. Check injector circuits for intermittent shorts. | Fault Code 343 inactive
 | STEP 4H. Check fuel shutoff solenoid for shorts. | Fault Code 343 inactive
 | STEP 4I. Check fuel shutoff solenoid for open circuit. | Fault Code 343 inactive
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 343 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 343 active

Fault Code 343 inactive

Go to 2A

Go to 5A

Guided Step 2 - Check the power and ground connections.

Guided Step 2A - Check all engine and chassis power and ground connections.

Conditions

Turn keyswitch OFF.

Action

Check all engine and vehicle power and ground connections for:

  • Corrosion
  • Loose connections.
OK NOT OK

Clean and tight. Measure within OEM specifications for voltage drop under electrical load

Repair damaged connections

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check all power and ground resistances.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.
  • Disconnect the unswitched battery 3-pin Weather-Pack connector.

Action

Check all power and ground resistances.

  • Measure the resistance from pin 22 of actuator harness connector to pin C of the battery connector.
  • Measure the resistance from pin 23 of actuator harness connector to pin C of the battery connector.
  • Measure the resistance from pin 20 of actuator harness connector to pin A of the battery connector.
  • Measure the resistance from pin 21 of actuator harness connector to pin A of the battery connector.
  • Measure the resistance from pin 9 of actuator harness connector to pin B of the battery connector.
  • Measure the resistance from pin 25 of actuator harness connector to pin B of the battery connector.
  • Measure the resistance from pin 27 of actuator harness connector to pin B of the battery connector.
OK NOT OK

Less than 10 ohms

Replace or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for good vehicle grounding.

Conditions

  • Turn keyswitch OFF.

Action

Check for good ground wires and connections:

  • Check from negative (-) battery post to block ground
  • Check from block ground to negative (-) starter post ground
  • Check block to frame ground
  • Check block to cab ground.
OK NOT OK

Meets OEM specifications for voltage test under electrical load

Correct the vehicle grounds

Go to 3A

Go to 3A

Guided Step 3 - Check for moisture in the ECM connectors.

Guided Step 3A - Check for moisture in the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.

Action

Check the harness connectors to the ECM for moisture.
OK NOT OK

All connectors dry

Dry the connectors

  • Dry the connector by using electrical contact cleaner, Part Number 3824510.
  • Replace the connector seal. Refer to Procedure 019-203 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine position sensor.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Check the engine position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the engine position sensor.
  • Disconnect the sensor harness connector from ECM.

Action

Remove the engine position sensor and check for damage.
OK NOT OK

No damage

Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - female AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4B - Check the engine position sensor polarity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the engine position sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check the engine position sensor for correct polarity.

  • Check for continuity between pin 11 of the sensor harness connector and pin A of the engine position sensor connector, harness side.
  • Check for continuity between pin 15 of the sensor harness connector and pin B of the engine position sensor connector, harness side.
  • Check for continuity between pin 1 of the sensor harness connector and pin C of the engine position sensor connector, harness side.
  • Check for continuity between pin 14 of the sensor harness connector and pin D of the engine position sensor connector, harness side.
OK NOT OK

Less than 10 ohms

Correct the polarity by switching the necessary wires.

Go to 4C

Go to 5A

Guided Step 4C - Check alternator.

Conditions

  • Remove alternator belt.
  • Connect engine harness to ECM.

Action

Check for Fault Code 343.

  • Start engine.
OK NOT OK

Fault Code 343 inactive, repair or replace alternator. See manufacturing specifications.

A capacitor across the alternator output (observe proper polarity of capacitor), can help alternator-induced voltage spikes. Reference the OEM manufacturer for electrical specifications.

Fault Code 343 active

Go to 5A

Go to 4D

Guided Step 4D - Check engine brake circuit.

Conditions

  • Disconnect engine brake connector from engine harness.
  • Turn keyswitch ON.

Action

Check engine brake circuit.

  • Start engine.
OK NOT OK

Fault Code 343 goes inactive.

  • Replace engine brake harness. Refer to Procedure 019-043 in Section 19.
  • Replace engine brake solenoid. 020-001 in either the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139, or Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Fault Code 343 active

Go to 5A

Go to 4E

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4E - Check datalink wiring.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor and OEM ECM connectors from ECM.

Action

Check for short to ground in datalink wiring.

  • Measure from pin 27 of OEM connector at the ECM to engine block ground.
  • Measure from pin 8 of OEM connector at the ECM to engine block ground.
  • Measure from pin 10 of sensor connector at the ECM to engine block ground.
  • Measure from pin 20 of sensor connector at the ECM to engine block ground.
OK NOT OK

Fault Code 343 inactive

Less than 100k ohms

  • Repair or replace datalink wiring. Refer to Procedure 019-165 in Section 19. or Refer to Procedure 019-166 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check OEM components for shorting to ground.

Conditions

  • Turn keyswitch OFF.

Action

Check OEM components for shorting to ground.

  • Disable or unplug OEM components that intermittently short to ground, such as fan clutch relays, the keyswitch, engine speed sensors in the flywheel, tachographs, engine brakes, vehicle speed sensors, the starter, datalinks, or the alternator.
OK NOT OK

Fault Code 343 inactive

  • Repair or replace that OEM component. Reference the OEM manual for procedures.

Fault Code 343 active

Go to 5A

Go to 4G

Guided Step 4G - Check injector circuits for short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect actuator harness connector at the ECM.

Action

Check injector circuits for shorts to ground.

  • Follow Procedure Refer to Procedure 019-058 in Section 19.
OK NOT OK

Fault Code 343 inactive

  • Repair or replace injector component that failed.

Fault Code 343 active

Go to 5A

Go to 4H

Guided Step 4H - Check fuel shutoff solenoid for short to ground or open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect fuel shutoff solenoid wire from fuel shutoff valve.
  • Disconnect the actuator harness connector at the ECM.

Action

Check fuel shutoff solenoid for short to ground or open circuit.

  • Measure the resistance from pin 16 of the actuator harness to the fuel shutoff valve wire at the fuel shutoff valve solenoid.
OK NOT OK

Fault Code 343 inactive

  • Replace fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Fault Code 343 active

Go to 5A

Go to 4I

Guided Step 4I - Check the fuel shutoff solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff solenoid wire from the fuel shutoff valve.
  • Disconnect the actuator harness connector from the ECM.

Action

Check the fuel shutoff valve for an open circuit.

  • Measure from pin 16 at the actuator harness connector to all other pins in the connector.
OK NOT OK

Fault Code 343 inactive

Fault Code 343 active

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify Fault Code 343 is inactive.
OK NOT OK

Fault Code 343 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19. Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 351 inactive
 | STEP 1A-1. Check the new ECM. |
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn vehicle keyswitch OFF and wait five seconds.
  • Turn vehicle keyswitch ON and idle engine for at least one minute.
OK NOT OK

Fault Code 351 inactive

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Check the new ECM.

Conditions

  • Connect all components.

Action

Check the new ECM.

  • Start the engine and let idle for one minute.
  • Verify Fault Code 351 is inactive.
OK NOT OK

Fault Code 351 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 154, 213, 222, and 422 are active or Fault Code 431 is active
 | STEP 1B. Read the fault codes. | Fault Codes 123, 141, 145, 154, 213, 222, and 422 are active

Guided Step 1 - Check the fault codes.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Codes 123, 141, 145, 154, 213, 222, and 422 are active or Fault Code 431 is active

Fault Code 352 without multiple sensor faults

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 1B

Repair complete

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Codes 123, 141, 145, 154, 213, 222, and 422 are active

Fault Code 431 is active

Fault Code Multiple A

Fault Code Multiple B

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking measurement:Part Number 3822758 - male AMP test leadPart Number 3822917 - female AMP test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check vehicle items. |
 | STEP 1A. Check for possible sources of interference. | Fault Code 411 active
 | STEP 1B. Inspect 2-pin control datalink connector on both sensor side and harness side. | No damaged pins
 | STEP 1C. Check for any control devices connected to control data link. | Fault Code 411 active
STEP 2. | Check sensor harness and ECM. |
 | STEP 2A. Check for reversed wires. | Pin A: 4 to 5 VDC, Pin B: 0 to 1 VDC
 | STEP 2A-1. Inspect the sensor harness and the ECM connector pins. |
 | STEP 2A-2. Check voltage at ECM receptacle. |
 | STEP 2B. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2C. Check for short circuit between control data link circuit and any other wires in sensor harness. | More than 100k ohms
 | STEP 2D. Check for short circuit to ground. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 411 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check vehicle items.

Guided Step 1A - Check for possible sources of interference.

Conditions

  • Turn keyswitch OFF.

Action

Check for possible sources of interference.

  • Turn off citizens band radio or other radio devices and make sure that ground lines are isolated from the CELECT™ system.
OK NOT OK

Fault Code 411 active

Fault Code 411 inactive.

Go to 1B

Go to 3A

Guided Step 1B - Inspect 2-pin control data link connector on both sensor side and harness side.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the 2-pin control data link connector.

Action

Inspect 2-pin control data link connector on both data link side and harness side for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness connector. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the OEM harness. Reference the OEM manufacturer.

Go to 1C

Go to 3A

Guided Step 1C - Check for any control devices connected to control data link.

Conditions

  • Turn keyswitch OFF.

Action

Check for any control devices connected to control data link, such as:

  • Transmission electronic controller.
OK NOT OK

Fault Code 411 active

Fault Code 411 inactive.

Go to 2A

Go to 3A

Guided Step 2 - Check sensor harness and ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check for reversed wires.

Conditions

  • Disconnect sensor harness from the control data link connector.
  • Turn keyswitch ON.

Action

Check for reversed wires.

  • Measure voltage from pin A on sensor harness side to engine block ground.
  • Measure voltage from pin B on sensor harness side to engine block ground.
OK NOT OK

Pin A: 4 to 5 VDC, Pin B: 0 to 1 VDC

Out of specifications.

Go to 2B

Go to 2A-1

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A-1 - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins,

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness connector. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A-2

Go to 3A

Guided Step 2A-2 - Check voltage at ECM receptacle.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ECM.

Action

Check voltage at ECM receptacle.

  • Measure voltage from pin 10 to engine block ground.
  • Measure voltage from pin 20 to engine block ground.
OK NOT OK

Pin 10: 4 to 5 VDC, Pin 20: 0 to 1 VDC

Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2B - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness connector. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit between control data link circuit and any other wires in sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ECM.
  • Disconnect the sensor harness from the control data link circuit.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 to any other wires in the sensor harness connector.
  • Measure the resistance from pin 20 to any other wires in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ECM.
  • Disconnect the sensor harness from the control data link circuit.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 to engine block ground.
  • Measure the resistance from pin 20 to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 411 is inactive.
OK NOT OK

Fault Code 411 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

The vehicle datalink does not broadcast SAE J1587 communication protocol and mustnot be used for the Compulink™ unit or the Echek™ unit.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP test leadPart Number 3822917 - female AMP test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check vehicle items. |
 | STEP 1A. Check for possible sources of interference. | Fault Code 412 active
 | STEP 1B. Inspect 2-pin vehicle datalink connector on both sensor side and harness side. | No damaged pins
 | STEP 1C. Check for any control devices connected to vehicle datalink. | Fault Code 412 active
 | STEP 1D. Check OEM wiring. | Fault Code 412 active
STEP 2. | Check OEM harness and ECM. |
 | STEP 2A. Check for reversed wires. | Pin A: 4 to 5 VDC, Pin B: 0 to 1 VDC
 | STEP 2A-1. Check voltage at ECM receptacle. |
 | STEP 2B. Inspect the OEM harness and the ECM connector pins. | No damaged pins
 | STEP 2C. Check for short circuit between vehicle datalink circuit and any other wires in OEM harness. | More than 100k ohms
 | STEP 2D. Check for short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for open circuit in the vehicle datalink circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 412 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check vehicle items.

Guided Step 1A - Check for possible sources of interference.

Conditions

  • Turn keyswitch OFF.

Action

Check for possible sources of interference.

  • Turn off CB or other radio devices and make sure that ground lines are isolated from the CELECT™ system.

Make sure that the power and ground lines of the radio devices are isolated from the CELECT™ system.
OK NOT OK

Fault Code 412 active

Fault Code 412 inactive.

Go to 1B

Go to 3A

Guided Step 1B - Inspect 2-pin vehicle datalink connector on both sensor side and harness side.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 2-pin vehicle datalink connector.

Action

Inspect 2-pin vehicle data link connector on both data link side and harness side for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness connector. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace or repair OEM harness. Reference the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for any control devices connected to vehicle datalink.

Conditions

  • Turn keyswitch OFF.

Action

Check control devices.

  • Disconnect any onboard electronic devices, such as electronic dashboard, trip recorders, etc., connected to the datalink.
OK NOT OK

Fault Code 412 active

Fault Code 412 inactive.

Go to 1D

Go to 3A

Guided Step 1D - Check OEM wiring.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check OEM wiring.

  • Connect a “Dyno Controller,” Part Number 3823948, to the OEM port of the ECM.
  • Connect INSITE™.
  • Start engine and monitor fault codes.

If a “Dyno Controller” is not available, install two jumper wires with 2-pin Weather- Pack plug on one end to the corresponding pins in the ECM: Pin A to pin 27 and pin B to pin 8 on the OEM harness.

OK NOT OK

Fault Code 412 active

Fault Code 412 inactive.

Go to 2A

Go to 3A

Guided Step 2 - Check OEM harness and ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check for reversed wires.

Conditions

  • Disconnect OEM harness from the vehicle datalink connector.
  • Turn keyswitch ON.

Action

Check for reversed wires.

  • Measure voltage from pin A on OEM harness side to engine block ground.
  • Measure voltage from pin B on OEM harness side to engine block ground.
OK NOT OK

Pin A: 4 to 5 VDC, Pin B: 0 to 1 VDC

Out of specifications.

Go to 2B

Go to 2A-1

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A-1 - Check voltage at ECM receptacle.

Conditions

  • Disconnect the OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check voltage at ECM receptacle.

  • Measure voltage from pin 27 to engine block ground.
  • Measure voltage from pin 8 to engine block ground.
OK NOT OK

Pin 27: 4 to 5 VDC, Pin 8: 0 to 1 VDC

Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2B - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness connector. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit between vehicle datalink circuit and any other wires in OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle datalink circuit.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 27 to any other wires in the OEM harness connector.
  • Measure the resistance from pin 8 to any other wires in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle datalink circuit.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 27 to engine block ground.
  • Measure the resistance from pin 8 to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for open circuit in the vehicle datalink circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle datalink circuit.

Action

Check for an open circuit.

  • Measure resistance from pin 27 of the AMP connector on the harness side to pin A of the vehicle datalink connector on the harness side.
  • Measure resistance from pin 08 of the AMP connector on the harness side to pin B of the vehicle datalink connector on the harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 412 is inactive.
OK NOT OK

Fault Code 412 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP test leadPart Number 3822917 - female AMP test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check vehicle items. |
 | STEP 1A. Check for possible sources of interference. | Fault Code 413 active
 | STEP 1B. Inspect 2-pin control data link connector on both sensor side and harness side. | No damaged pins
 | STEP 1C. Check for any control devices connected to control data link. | Fault Code 413 active
STEP 2. | Check sensor harness and ECM. |
 | STEP 2A. Check for reversed wires. | Pin A: 4 to 5 VDC, Pin B: 0 to 1 VDC
 | STEP 2A-1. Inspect the sensor harness and the ECM connector pins. |
 | STEP 2A-2. Check voltage at ECM receptacle. |
 | STEP 2B. Inspect the sensor harness and the ECM connector pins. | No damaged pins
 | STEP 2C. Check for short circuit between control data link circuit and any other wires in sensor harness. | More than 100k ohms
 | STEP 2D. Check for short circuit to ground. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 413 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check vehicle items.

Guided Step 1A - Check for possible sources of interference.

Conditions

  • Turn keyswitch OFF.

Action

Check for possible sources of interference.

  • Turn off citizens band radio or other radio devices and make sure that ground lines are isolated from the CELECT™ system.
OK NOT OK

Fault Code 413 active

Fault Code 413 inactive.

Go to 1B

Go to 3A

Guided Step 1B - Inspect 2-pin control data link connector on both sensor side and harness side.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the 2-pin control data link connector.

Action

Inspect 2-pin control data link connector on both data link side and harness side for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness connector. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace or repair the OEM harness. Reference the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for any control devices connected to control data link.

Conditions

  • Turn keyswitch OFF.

Action

Check for any control devices connected to control data link, such as:

  • Transmission electronic controller.
OK NOT OK

Fault Code 413 active

Fault Code 413 inactive.

Go to 2A

Go to 3A

Guided Step 2 - Check sensor harness and ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check for reversed wires.

Conditions

  • Disconnect sensor harness from the control data link connector.
  • Turn keyswitch ON.

Action

Check for reversed wires.

  • Measure voltage from pin A on sensor harness side to engine block ground.
  • Measure voltage from pin B on sensor harness side to engine block ground.
OK NOT OK

Pin A: 4 to 5 VDC, Pin B: 0 to 1 VDC

Out of specifications.

Go to 2B

Go to 2A-1

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A-1 - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness connector. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A-2

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A-2 - Check voltage at ECM receptacle.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ECM.

Action

Check voltage at ECM receptacle.

  • Measure voltage from pin 10 to engine block ground.
  • Measure voltage from pin 20 to engine block ground.
OK NOT OK

Pin 10: 4 to 5 VDC, Pin 20: 0 to 1 VDC

Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2B - Inspect the sensor harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness connector. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit between control data link circuit and any other wires in sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ECM.
  • Disconnect the sensor harness from the control data link circuit.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 to any other wires in the sensor harness connector.
  • Measure the resistance from pin 20 to any other wires in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the ECM.
  • Disconnect the sensor harness from the control data link circuit.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 to engine block ground.
  • Measure the resistance from pin 20 to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 413 is inactive.
OK NOT OK

Fault Code 413 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

The vehicle data link does not broadcast SAE J1587 communication protocol and must no be used for the Compulink™ unit or the Echeck™ unit.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male AMP test leadPart Number 3822917 - female AMP test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check vehicle items. |
 | STEP 1A. Check for possible sources of interference. | Fault Code 414 active
 | STEP 1B. Inspect 2-pin vehicle data link connector on both sensor side and harness side. | No damaged pins
 | STEP 1C. Check for any control devices connected to vehicle data link. | Fault Code 414 active
 | STEP 1D. Check OEM wiring. | Fault Code 414 active
STEP 2. | Check OEM harness and ECM. |
 | STEP 2A. Check for reversed wires. | Pin A: 4 to 5 VDC, Pin B: 0 to 1 VDC
 | STEP 2A-1. Check voltage at ECM receptacle. |
 | STEP 2B. Inspect the OEM harness and the ECM connector pins. | No damaged pins
 | STEP 2C. Check for short circuit between vehicle data link circuit and any other wires in OEM harness. | More than 100k ohms
 | STEP 2D. Check for short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for open circuit in the vehicle data link circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 414 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check vehicle items.

Guided Step 1A - Check for possible sources of interference.

Conditions

  • Turn keyswitch OFF.

Action

Check for possible sources of interference.

  • Turn off citizens band radio or other radio devices and make sure that ground lines are isolated from the CELECT™ system.

Make sure that the power and ground lines of the radio devices are isolated from the CELECT™ system.
OK NOT OK

Fault Code 414 active

Fault Code 414 inactive.

Go to 1B

Go to 3A

Guided Step 1B - Inspect 2-pin vehicle data link connector on both sensor side and harness side.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 2-pin vehicle data link connector.

Action

Inspect 2-pin vehicle data link connector on both data link side and harness side for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness connector. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace or repair the OEM harness. Reference the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for any control devices connected to vehicle data link.

Conditions

  • Turn keyswitch OFF.

Action

Check control devices.

  • Disconnect any onboard electronic devices, such as electronic dashboard, trip recorders, and so on, connected to the data link.
OK NOT OK

Fault Code 414 active

Fault Code 414 inactive.

Go to 1D

Go to 3A

Guided Step 1D - Check OEM wiring.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check OEM wiring.

  • Connect a “Dyno Controller,” Part Number 3823948, to the OEM port of the ECM.
  • Connect INSITE™.
  • Start engine and monitor fault codes.

If a “Dyno Controller” is not available, install two jumper wires with 2-pin Weather-Pack plug on one end to the corresponding pins in the ECM: Pin A to pin 27 and pin B to pin 8 on the OEM harness.

OK NOT OK

Fault Code 414 active

Go to 2A

Go to 3A

Guided Step 2 - Check OEM harness and ECM.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Check for reversed wires.

Conditions

  • Disconnect OEM harness from the vehicle data link connector.
  • Turn keyswitch ON.

Action

Check for reversed wires.

  • Measure voltage from pin A on OEM harness side to engine block ground.
  • Measure voltage from pin B on OEM harness side to engine block ground.
OK NOT OK

Pin A: 4 to 5 VDC, Pin B: 0 to 1 VDC

Out of specifications.

Go to 2B

Go to 2A-1

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A-1 - Check voltage at ECM receptacle.

Conditions

  • Disconnect the OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check voltage at ECM receptacle.

  • Measure voltage from pin 27 to engine block ground.
  • Measure voltage from pin 8 to engine block ground.
OK NOT OK

Pin 27: 4 to 5 VDC, Pin 8: 0 to 1 VDC

Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2B - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness connector. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit between vehicle data link circuit and any other wires in OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle data link circuit.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 27 to any other wires in the OEM harness connector.
  • Measure the resistance from pin 8 to any other wires in the OEM harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle data link circuit.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 27 to engine block ground.
  • Measure the resistance from pin 8 to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for open circuit in the vehicle data link circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle data link circuit.

Action

Check for an open circuit.

  • Measure resistance from pin 27 of the AMP connector on the harness side to pin A of the vehicle data link connector on the harness side.
  • Measure resistance from pin 08 of the AMP connector on the harness side to pin B of the vehicle data link connector on the harness side.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 414 is inactive.
OK NOT OK

Fault Code 414 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 415 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle datalink.
  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge.

The engine must be revved up to make it easier to see differences in readings.

OK NOT OK

Sensor reading is correct

Reference the proper base engine manual

  • Reference the Troubleshooting and Repair Manual, M11 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666139.
  • Reference the Troubleshooting and Repair Manual, N14 Series Engines (STC, CELECT™, CELECT™ Plus models), Bulletin 3666142.

Go to 2A

Fault Code 141

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 415 is inactive.
OK NOT OK

Fault Code 415 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes and presence of coolant level switch. |
 | STEP 1A. Read the fault codes. | Fault Codes 123, 141, 145, 154, 222, and 352 inactive
 | STEP 1B. Check if the vehicle has a coolant level switch. | Coolant level switch present
 | STEP 1C. Check if a shorting plug is installed. | Shorting plug installed
STEP 2. | Check for proper ECM response. |
 | STEP 2A. Check ECM response. | Fault Code 422 inactive
 | STEP 2B. Check for proper ECM response. | Fault Code 422 inactive
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 422 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the coolant level sensor. |
 | STEP 4A. Inspect the coolant level sensor and the OEM harness connector pins. | No damaged pins
 | STEP 4B. Read the fault codes. | Fault Code 422 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 422 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes and presence of coolant level switch.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 123, 141, 145, 154, 222, and 352 inactive

Fault Codes 123, 141, 145, 154, 222, and 352 active.

Go to 1B

Fault Code Multiple A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1B - Check if the vehicle has a coolant level switch.

Conditions

  • Turn keyswitch OFF.

Action

Check if the vehicle has a coolant level switch.

Make sure the vehicle has a coolant level switch.
OK NOT OK

Coolant level switch present

Shorting plug installed.

Go to 2A

Go to 1C

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1C - Check if a shorting plug is installed.

Conditions

  • Turn keyswitch OFF.

Action

Check if a shorting plug is installed in place of the coolant level switch harness connection.

Check the OEM wiring from the shorting plug to the sensor harness connection for problems. Reference the OEM and the sensor harness wiring diagrams.

OK NOT OK

Shorting plug installed

Install shorting plug.

Go to 2A

Go to 5A

Guided Step 2 - Check for proper ECM response.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch test lead.
Guided Step 2A - Check ECM response.

Conditions

  • Disconnect sensor harness connector from ECM.
  • Connect jumper wire from pin 3 to pin 18 of the ECM sensor port. Use Part Number 3822917.
  • Connect jumper wire from pin 13 to pin 9 of the ECM sensor port. Use Part Number 3822917.
  • Turn keyswitch ON.

Action

Read fault codes.

  • Using electronic service tool, read the fault codes.
OK NOT OK

Fault Code 422 inactive

Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check for proper ECM response.

Conditions

  • Connect sensor harness connector to ECM.
  • Connect jumper wire from A to C on 9-pin connector. Use Part Number 3823994.
  • Connect jumper wire from B to J on 9-pin connector. Use Part Number 3823994.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Using an electronic service tool, read the fault codes.

Read Shop Talk concerning OEM wiring from coolant level sensor to 9-pin Deutsch connector.
OK NOT OK

Fault Code 422 inactive. Check OEM wiring from coolant level sensor to OEM 9-pin connector for proper pinout, continuity, and shorts from pin to pin and to ground.

Reference the OEM wiring diagrams.

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 5A

Go to 3A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the sensor harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 5A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 3B - Read the fault codes.

Conditions

  • Connect the OEM harness to the coolant level sensor.
  • Connect the OEM harness to the sensor harness.
  • Connect the sensor harness connector to the ECM.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 422 active

Repair complete.

Go to 3C

Go to 5B

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 9-pin Deutsch connector.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 in the sensor harness connector to pin C on the sensor wiring harness side of the 9-pin connector.
  • Measure the resistance from pin 9 in the sensor harness connector to pin B on the sensor wiring harness side of the 9-pin connector.
  • Measure the resistance from pin 3 in the sensor harness connector to pin A on the sensor wiring harness side of the 9-pin connector.
  • Measure the resistance from pin 13 in the sensor harness connector to pin J on the sensor wiring harness side of the 9-pin connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 9-pin Deutsch.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all sensors, including coolant level sensor or shorting plug.

Action

Check for a short circuit to ground in the coolant level sensor signal wires.

  • Measure the resistance from pin 3 to engine block ground.
  • Measure the resistance from pin 9 to engine block ground.
  • Measure the resistance from pin 13 to engine block ground.
  • Measure the resistance from pin 18 to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 9-pin Deutsch connector.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all sensors, including coolant level sensor or shorting plug.

Action

Check for a short circuit pin to pin.

  • Measure the resistance from pin 3 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 9 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 13 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 18 in the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the coolant level sensor.

Guided Step 4A - Inspect the coolant level sensor and the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the coolant level sensor and the OEM harness connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Reference the OEM troubleshooting and repair manual.

Go to 4B

Go to 5A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 4B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the OEM harness to the coolant level sensor.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 422 active. Replace the coolant level sensor.

Repair complete.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 422 is inactive.
OK NOT OK

Fault Code 422 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the integrated sensor switch is connected to the OEM harness. | Integrated sensor switch connected
 | STEP 1B. Inspect the harness and integrated sensor switch connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | Less than 125 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 125 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM response. |
 | STEP 3A. Verify ECM response. | Fault Code 431 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 431 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the integrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the integrated sensor switch is connected to the OEM harness.

Verify the integrated sensor switch is connected to the OEM harness.
OK NOT OK

Integrated sensor switch connected

Integrated sensor switch disconnected from pedal. Connect the OEM harness to the integrated sensor switch. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the harness and integrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and integrated sensor switch connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.
OK NOT OK

No damaged pins

Repair damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the integrated sensor switch if the connector pins are damaged. Reference the OEM troubleshooting and repair manual.
  • Replace the integrated sensor switch connector if it is oversize or damaged. Reference the OEM troubleshooting and repair manual.
  • Install the appropriate connector seal if it is damaged or missing. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.

Action

Check for an open circuit.

  • Measure the resistance from the idle signal pin to the return wire pin on the integrated sensor switch with the pedal released.
  • Measure the resistance from the off-idle signal pin to the return wire pin on the integrated sensor switch with the pedal depressed.
OK NOT OK

Less than 125 ohms

Replace the integrated sensor switch. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the integrated sensor switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the idle signal pin to the off-idle signal pin on the integrated sensor switch with the pedal released and depressed.
OK NOT OK

More than 100k ohms

Replace the integrated sensor switch. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.
OK NOT OK

No damaged pins

Repair damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the bulkhead connector. Refer to Procedure 019-208 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the integrated sensor switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 6 of the OEM harness to pin 10 of the OEM harness with the accelerator pedal released.
  • Measure the resistance from pin 9 of the OEM harness to pin 10 of the OEM harness with the accelerator pedal depressed.
OK NOT OK

Less than 125 ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the integrated sensor switch.
  • Set cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the AC pressure switch.
  • Diagnostic switch not in diagnostic mode.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the OEM harness to all other pins of the OEM harness.
  • Measure the resistance from pin 9 of the OEM harness to all other pins of the OEM harness.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM response.

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Verify ECM response.

Conditions

  • Disconnect the OEM harness connector to the ECM.

Action

Verify ECM response.

  • Use Part Number 3822917, as a jumper wire, from pin 10 to pin 6 in the OEM port of the ECM.
  • Turn keyswitch ON.
OK NOT OK

Fault Code 431 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch OFF for 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack testPart Number 3822917 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the idle validation switch is connected to the OEM harness. | Idle validation switch is connected
 | STEP 1B. Inspect the harness and idle validation switch connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | Less than 125 ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 125 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM response. |
 | STEP 3A. Verify the ECM response. | Fault Code 431 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 431 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the idle validation switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the idle validation switch is connected to the OEM harness.

Verify the idle validation switch is connected to the OEM harness.
OK NOT OK

Idle validation switch connected

Connect the OEM harness to the idle validation switch. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the harness and idle validation switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and idle validation switch connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the idle validation switch if the connector pins are damaged. Reference the OEM troubleshooting and repair manual.
  • Replace the switch connector if it is oversize or damaged. Reference the OEM troubleshooting and repair manual.
  • Install the appropriate connector seal if it is damaged or missing. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for an open circuit.

  • Measure the resistance from the idle signal pin to the return wire pin on the idle validation switch with the pedal released.
  • Measure the resistance from the off-idle signal pin to the return wire pin on the idle validation switch with the pedal depressed.
OK NOT OK

Less than 125 ohms

Replace the idle validation switch. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the idle signal pin to the off-idle signal pin on the idle validation switch with the pedal released and depressed.
OK NOT OK

More than 100k ohms

Replace the idle validation switch. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness, OEM bulkhead connector, and ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM manual.
  • Repair or replace the OEM bulkhead connector. Refer to Procedure 019-208 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Connect the OEM harness to the idle validation switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 6 of the OEM harness to pin 10 of the OEM harness with the accelerator pedal released.
  • Measure the resistance from pin 9 of the OEM harness to pin 10 of the OEM harness with the accelerator pedal depressed.
OK NOT OK

Less than 125 ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.
  • Set all cab switches to the NEUTRAL or OFF position.
  • Set the service brake.
  • Disconnect the clutch switch from the OEM harness.
  • Disconnect the AC pressure switch.
  • Diagnostic switch not in diagnostic mode.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the OEM harness to all other pins of the OEM harness.
  • Measure the resistance from pin 9 of the OEM harness to all other pins of the OEM harness.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM response.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3A - Verify the ECM response.

Conditions

  • Disconnect the OEM harness connector to the ECM.
  • Use Part Number 3822917, as a jumper wire from pin 10 to pin 6 in the OEM port of the ECM.
  • Turn keyswitch ON.

Action

Verify ECM response.

  • Read the fault code.
OK NOT OK

Fault Code 431 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal three times.
  • Turn the keyswitch OFF for 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather Pack™ test leadPart Number 3823996 - female Weather Pack™ test leadPart Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™™ test leadPart Number 3823255 - 3-pin Metri-Pack™ repair connectorPart Number 3824910 - 6-pin Metri-Pack™ repair connector.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the accelerator connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the accelerator position sensor. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms
 | STEP 1C. Check for an open circuit of the accelerator position sensor supply and return circuit. | 2000 to 3000 ohms
 | STEP 1D. Check for a short circuit to ground in the accelerator position sensor. | More than 100k ohms
 | STEP 1E. Check percentage of accelerator pedal. | 3 to 10 percent
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness, bulkhead connector, and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the OEM harness. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the voltage supply. | 4.75 to 5.25-VDC
 | STEP 3B. Measure the accelerator position signal voltage. | Less than 1-VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 432 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the accelerator connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the accelerator connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 (Component Connector and Pin Inspection) in Section. in Section 19.

OK NOT OK

No damaged pins

Repair or replace the accelerator pedal assembly.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair or replace the accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance of the accelerator position sensor.

  • Measure the resistance from the +5 VDC supply pin to the signal pin on the sensor side of the accelerator position sensor connector with the pedal in the released (idle) position.
  • Measure the resistance from the +5 VDC supply pin to the signal pin on the sensor side of the accelerator position sensor connector with the pedal in the depressed (full fuel) position.

Resistance when the pedal is released must be at least 1000 ohms greater than when it is depressed.

Install a 3-pin repair connector, Part Number 3829255, into the accelerator position sensor for idle validation switch and a 6-pin repair connector, Part Number 3824910, for integrated sensor switch.

OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Replace the accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check for an open circuit of the accelerator position sensor supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit of the accelerator position sensor supply and return.

  • Measure the resistance from the +5 VDC supply pin to the return on the sensor side of the accelerator position sensor connector. (The pedal can be either released or depressed.)

Install a 3-pin repair connector, Part Number 3829255, into the accelerator position sensor for the idle validation switch and a 6-pin repair connector, Part Number 3824910, for the integrated sensor switch.

OK NOT OK

2000 to 3000 ohms

Replace the accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to ground in the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the accelerator position sensor.

  • Measure the resistance from the +5-VDC supply pin on the sensor side of the accelerator position sensor connector to chassis ground.
  • Measure the resistance from the signal pin on the sensor side of the accelerator position sensor connector to chassis ground.

Install a 3-pin repair connector, Part Number 3829255, into the accelerator position sensor for the idle validation switch and a 6-pin repair connector, Part Number 3824910, for the integrated sensor switch.

OK NOT OK

More than 100k ohms

Replace the accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 1E

Go to 4A

Guided Step 1E - Check percentage of accelerator pedal.

Conditions

  • Disconnect the accelerator position sensor at the accelerator pedal.
  • Turn keyswitch ON.

Action

Check for percentage change of accelerator position sensor, at the accelerator pedal, during switch transition from idle to off-idle to verify within specifications.

  • Check the pedal. Refer to Procedure 019-086 (Accelerator Pedal or Lever Position Sensor Circuit) in Section 19.
OK NOT OK

3 to 10 percent

Replace accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the OEM harness, bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Flush and clean the connectors, use electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness, bulkhead connector, and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 (component Connector and Pin Inspection) in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, useelectronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-203 ( AMP Connector Series) in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 (Electronic Control Module (ECM)) in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 (AMP Connector Series) in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 18 of the OEM harness connector to pin C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 11 of the OEM harness connector to pin B on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 19 of the OEM harness connector to pin A on the harness side of the accelerator position sensor connector.

The accelerator position sensor uses either a 3-pin or 6-pin connector. Use the same pin numbers and letters to troubleshoot either of the connectors.

OK NOT OK

Less than 10 ohms

Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness connector from ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 18 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 11 in the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 18 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 11 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 19 in the OEM harness to all other pins in the connector.
  • Set all switches in cab to OFF or NEUTRAL position - open service brake switch, AC pressure switch, and clutch switch, or unplug them.
  • Diagnostic switch not in diagnostic mode.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the voltage supply.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply at the ECM.

  • Measure the voltage from pin 18 to pin 19 of the ECM's OEM port.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Measure the accelerator position signal voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the accelerator position signal voltage.

  • Measure the voltage from pin 11 to pin 19 of the ECM's OEM port.
OK NOT OK

Less than 1 VDC

  • Replace the ECM.
  • Call for pre-authorization.
  • Refer to Procedure 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect all the components.

Action

Disable the fault code.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure twice.
  • Use INSITE™ electronic service tool to read the active fault codes.
OK NOT OK

Fault Code 432 inactive

Fault Code 432 active.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917- female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Inspect the accelerator connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the accelerator position sensor. | Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms
 | STEP 1C. Check for an open circuit of the accelerator position sensor supply and return circuits. | 2000 to 3000 ohms
 | STEP 1D. Check for a short circuit to ground in the accelerator position sensor. | More than 100k ohms
 | STEP 1E. Check percentage of accelerator pedal. | 3 to 10 percent
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness, bulkhead connector, and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit in the OEM harness. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the ECM. |
 | STEP 3A. Check the voltage supply. | 4.75 to 5.25 VDC
 | STEP 3B. Measure the accelerator position signal voltage. | Less than 1 VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 432 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Inspect the accelerator connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the accelerator connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair or replace the accelerator pedal assembly.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair or replace the accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917- female Deutsch/AMP/Metri-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1B - Check the resistance of the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance of the accelerator position sensor.

  • Measure the resistance from the +5 VDC supply pin to the signal pin on the sensor side of the accelerator position sensor connector with the pedal in the released (idle) position.
  • Measure the resistance from the +5 VDC supply pin to the signal pin on the sensor side of the accelerator position sensor connector with the pedal in the depressed (full-fuel) position.

Resistance when the pedal is released must be at least 1000 ohms greater than when it is depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch.
OK NOT OK

Released: 1500 to 3000 ohms, depressed: 200 to 1500 ohms

Replace the accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1C - Check for an open circuit of the accelerator position sensor supply and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit of the accelerator position sensor supply and return.

  • Measure the resistance from the +5 VDC supply pin to the return on the sensor side of the accelerator position sensor connector. (The pedal can be either released or depressed.)

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch.
OK NOT OK

2000 to 3000 ohms

Replace the accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 1D - Check for a short circuit to ground in the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the accelerator position sensor.

  • Measure the resistance from the +5 VDC supply pin on the sensor side of the accelerator position sensor connector to chassis ground.
  • Measure the resistance from the signal pin on the sensor side of the accelerator position sensor connector to chassis ground.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch.
OK NOT OK

More than 100k ohms

Replace the accelerator pedal assembly. Reference the OEM troubleshooting and repair manual.

Go to 1E

Go to 4A

Guided Step 1E - Check percentage of accelerator pedal.

Conditions

  • Disconnect the accelerator position sensor at the throttle pedal.
  • Turn keyswitch ON.

Action

Check for percentage change of accelerator position sensor, at accelerator pedal, during switch transition from idle to off-idle to verify within specifications.

  • Check the pedal. Refer to Procedure 019-086 in Section 19.
OK NOT OK

3 to 10 percent

Replace accelerator pedal assembly. Reference the OEM manufacturer for repair procedures.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the OEM harness, bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Flush and clean the connectors using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness, bulkhead connector, and ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack test leadPart Number 3823996 - female Weather-Pack test leadPart Number 3823255 - 3-pin Metri-Pack repair connector.
Guided Step 2B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 18 of the OEM harness connector to pin C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 11 of the OEM harness connector to pin B on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin 19 of the OEM harness connector to pin A on the harness side of the accelerator position sensor connector.
OK NOT OK

Less than 10 ohms

Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 18 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 11 in the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Set all switches in cab to OFF or NEUTRAL position - open service brake switch, AC pressure switch, and clutch switch or unplug them.
  • Verify diagnostic switch is not in diagnostic mode.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 18 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 11 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 19 in the OEM harness to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3A - Check the voltage supply.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply at the ECM.

  • Measure the voltage from pin 18 to pin 19 of the ECM's OEM port.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Measure the accelerator position signal voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the accelerator position signal voltage.

  • Measure the voltage from pin 11 to pin 19 of the ECM's OEM port.
OK NOT OK

Less than 1 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure twice.
  • Read the active fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 432 inactive

Fault Code 432 active.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™ electronicl service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824776 - breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure sensor. |
 | STEP 1A. Inspect the sensor circuit for tampering. | No tampering
 | STEP 1B. Inspect the harness and the sensor connector pins. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault Code 433 active
 | STEP 1D. Check the intake manifold pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 1D-1. Measure the voltage to the sensor. |
 | STEP 1D-2. Measure the voltage from the ECM. |
 | STEP 1E. Check the intake manifold pressure signal. | 0.42 to 0.58 VDC
 | STEP 1E-1. Check for a short circuit from pin to pin. |
 | STEP 1E-2. Check for continuity in sensor harness. |
 | STEP 1E-3. Check for alternate fuel sources. |
 | STEP 1E-4. Check for injectors out of specification. |
STEP 2. | Check the sensor harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 433 active
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for proper wiring and continuity. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 433 inactive
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared

Guided Step 1 - Check the intake manifold pressure sensor.

Guided Step 1A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure sensor and the sensor harness for external wires or damaged harness braiding.
OK NOT OK

No tampering

Remove and record tampering. If tampering has occurred, repair the circuit, and record the tampering.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the harness and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the sensor connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 433 active

Repair complete.

Go to 1D

Go to 3B

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Disconnect all pressure sensors from their connectors on the sensor harness, except the intake manifold pressure sensor.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the sensor harness connector.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 1E

Go to 1D-1

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824776 - breakout cable.
Guided Step 1D-1 - Measure the voltage to the sensor.

Conditions

  • Disconnect all pressure sensors from their connectors on the sensor harness.
  • Disconnect the coolant level sensor or shorting plug from its connector on the sensor harness.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor supply voltage.

  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, to the sensor harness connector. Do not connect the sensor to the breakout cable.
  • Measure the supply voltage from pin A to pin B of the breakout cable.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Does not meet specifications.

Go to 3B

Go to 1D-2

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D-2 - Measure the voltage from the ECM.

Conditions

  • Turn keyswitch ON.
  • Disconnect the sensor harness connector from the ECM.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin 2 to pin 4 of the ECM sensor port.
OK NOT OK

4.75 to 5.25 VDC

  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3824776 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1E - Check the intake manifold pressure signal.

Conditions

  • Disconnect pin 26 of the sensor harness connector from the ECM.
  • Install the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the sensor harness connector.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure signal.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.42 to 0.58 VDC

Does not meet specifications.

Go to 2A

Go to 1E-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 1E-1 - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all sensors and the coolant level sensor or shorting plug from their connectors.

Action

Check for a short from pin to pin.

  • Measure the resistance from pin 2 of the sensor harness connector at the ECM to all other pins.
  • Measure the resistance from pin 4 of the sensor harness connector at the ECM to all other pins.
  • Measure the resistance from pin 26 of the sensor harness connector at the ECM to all other pins.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 1E-2

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1E-2 - Check for continuity in sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect the intake manifold pressure sensor from the sensor harness.

Action

Check for continuity in the sensor harness.

  • Measure the resistance from pin 2 of the sensor harness connector at the ECM to pin A of the sensor connector on the sensor harness.
  • Measure the resistance from pin 4 of the sensor harness connector at the ECM to pin B of the sensor connector on the sensor harness.
  • Measure the resistance from pin 26 of the sensor harness connector at the ECM to pin C of the sensor connector on the sensor harness.
OK NOT OK

Less than 10 ohms

Correct pin-to-pin wiring or open circuit.

  • Repair or replace sensor harness. Refer to Procedure 019-043 in Section 19. or Refer to Procedure 019-203 in Section 19.

Go to 1E-3

Go to 3A

Guided Step 1E-3 - Check for alternate fuel sources.

Conditions

  • Turn keyswitch OFF.

Action

Check for alternate fuel sources.

Look for alternate fuel sources creating extra boost:

  • Charge air cooler filled with oil
  • Blown or leaking turbo seals
  • Ether bottles
  • Sources external to engine, vapors, etc.
OK NOT OK

No alternate sources

Remove alternate fuel sources.

Go to 1E-4

Go to 3A

Guided Step 1E-4 - Check for injectors out of specification.

Conditions

  • Connect electronic service tool.
  • Turn keyswitch ON.

Action

Check injectors for compliance with specifications.

  • Run cylinder diagnostics with service tool.

Depending on symptoms, different tests will be required. See guidelines for recommended diagnostics tests. If diagnostics are inconclusive, consider cylinders with higher exhaust temperatures or excessive smoke or fuel knock.

OK NOT OK

Injectors within specifications

Proceed with troubleshooting conclusions from injector diagnostic testing.

Go to 3A

Go to 3A

Guided Step 2 - Check the sensor harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 433 active

Repair complete.

Go to 2C

Go to 3B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from all pressure sensors and the coolant level sensor or coolant level sensor shorting plug from harness.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 26 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 4 in the sensor harness connector to all other pins in the connector.
  • Measure the resistance from pin 2 in the sensor harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use this test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 in the sensor harness connector to the engine block ground.
  • Measure the resistance from pin 26 in the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for proper wiring and continuity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect sensor harness connector from ECM.
  • Disconnect intake manifold pressure sensor from sensor harness.

Action

Check continuity of harness wiring.

  • Measure the resistance from pin 2 of the sensor harness connector to pin A of the sensor connector.
  • Measure the resistance from pin 4 of the sensor harness connector to pin B of the sensor connector.
  • Measure the resistance from pin 26 of the sensor harness connector to pin C of the sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-203 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 433 is inactive.
OK NOT OK

Fault Code 433 inactive

Return to the troubleshooting steps, or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault code. | No active or inactive injector fault codes
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Inspect the 3-pin power connector. | No damaged pins or loose connections
 | STEP 2B. Check the resistance of the battery supply circuit. | Less than 10 ohms
 | STEP 2C. Check the battery voltage. | Normal conditions: At least 12 VDC, during cranking: minimum 6.2 VDC
 | STEP 2D. Check the battery. | Connections are tight and corrosion free
STEP 3. | Check the two 10-amp fuses. |
 | STEP 3A. Check if the two 10-amp fuses are installed correctly. | Fuses installed correctly
 | STEP 3B. Check if the two 10-amp fuses are blown. | Fuses not blown
STEP 4. | Check the actuator harness. |
 | STEP 4A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit in the battery power circuits. | 10 to 15 VDC
 | STEP 4C. Check for a short circuit in the battery return wires. | More than 100k ohms
 | STEP 4D. Check the add-on or the accessory wiring at positive (+) terminal of the battery. | No damaged wires
 | STEP 4E. Check for good vehicle grounds. | Meets OEM specifications for voltage drop under electrical load
 | STEP 4F. Check the injector solenoid captive nuts for proper torque. | Captive nuts are correctly tightened
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 434 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

No active or inactive injector fault codes

Troubleshoot the injector fault codes. Reference the appropriate injector fault code tree.

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Inspect the 3-pin power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the battery at the 3-pin connector.

Action

Inspect the 3-pin power connector for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins or loose connections

Repair the 3-pin connector. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-202 in Section 19.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
Guided Step 2B - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the battery at the 3-pin connector.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance from pin A to the positive (+) battery terminal.
  • Measure the resistance from pin C to the positive (+) battery terminal.
  • Measure the resistance from pin B to the negative (-) battery terminal.
OK NOT OK

Less than 10 ohms

Repair or replace the power harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place positive (+) probe of the multimeter on the positive battery terminal, and touch negative (-) probe to the negative battery terminal while trying to start engine.
OK NOT OK

Normal conditions: 12 VDC, during cranking: minimum 6.2 VDC

Charge or replace the battery. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 5A

Guided Step 2D - Check the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.
OK NOT OK

Connections are tight and corrosion free

Tighten the loose connections, and clean the terminals. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the two 10-amp fuses.

Guided Step 3A - Check if the two 10-amp fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Check if the two 10-amp fuses are installed correctly.

  • Inspect the two 10-amp fuses for correct installation.
OK NOT OK

Fuses installed correctly

Install the fuses correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check if the two 10-amp fuses are blown.

Conditions

  • Turn keyswitch OFF.

Action

Check if the two 10-amp fuses are blown.

  • Inspect the two 10-amp fuses to see if they are blown.
OK NOT OK

Fuses not blown

Locate the short circuit.

  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blown fuse(s).

Go to 4A

Go to 5A

Guided Step 4 - Check the actuator harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage from pin 20 to pin 9 of the actuator harness.
  • Measure the voltage from pin 21 to pin 25 of the actuator harness.
  • Measure the voltage from pin 22 to pin 27 of the actuator harness.
  • Measure the voltage from pin 23 to pin 9 of the actuator harness.
OK NOT OK

10 to 15 VDC

Repair or replace the actuator harness.

  • Repair the actuator harness. Refer to Procedure 019-203 in Section 19.
  • Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit in the battery return wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness to the 3-pin battery connector.
  • Disconnect the actuator harness connector from the ECM.

Action

Check for a short circuit.

  • Measure the resistance from pin 20 of the actuator harness connector to all the other pins in the connector, except pin 21.
  • Measure the resistance from pin 21 of the actuator harness connector to all the other pins in the connector, except pin 20.
  • Measure the resistance from pin 22 of the actuator harness connector to all the other pins in the connector, except pin 23.
  • Measure the resistance from pin 23 of the actuator harness connector to all the other pins in the connector, except pin 22.
OK NOT OK

More than 100k ohms

Replace the actuator harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check the add-on or accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal of the battery, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

No damaged wires

Repair or replace the damaged wiring.

Go to 4E

Go to 5A

Guided Step 4E - Check for good vehicle grounds.

Conditions

  • Turn keyswitch OFF.

Action

Check for good ground wires and connections.

  • Check from negative (-) battery post to block ground.
  • Check from block ground to negative (-) starter post ground.
  • Check block to frame ground.
  • Check block to cab ground.
OK NOT OK

Meets OEM specifications for voltage drop under electrical load

Repair vehicle grounds.

Go to 4F

Go to 5A

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
Guided Step 4F - Check the injector solenoid captive nuts for proper torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector solenoid captive nuts for proper torque.

  • Remove the valve covers and check the injector solenoid captive nuts for proper torque.
OK NOT OK

Captive nuts are correctly tightened

Tighten the captive nuts. Replace the valve covers.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 434 is inactive.
OK NOT OK

Fault Code 434 inactive

Return to the troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for the failed sensors. |
 | STEP 1A. Check the coolant temperature sensor. | Fault Code 352 active
 | STEP 1B. Check the intake manifold pressure sensor. | Less than 4.5 VDC
 | STEP 1C. Check the oil pressure sensor. | Less than 4.5 VDC
 | STEP 1D. Check the ambient air pressure sensor. | Less than 4.5 VDC
 | STEP 1E. Check the intake manifold temperature sensor. | Less than 4.5 VDC
 | STEP 1F. Check the oil temperature sensor. | Less than 4.5 VDC
STEP 2. | Check the coolant level sensor circuit. |
 | STEP 2A. Inspect the coolant level sensor and the OEM harness connector pins. | No damaged pins
 | STEP 2B. Inspect the OEM harness and engine harness 9-pin connector. | No damaged pins
 | STEP 2C. Read the fault codes. | Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422 are active
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422 are active
 | STEP 3C. Check the supply voltage. | 4.75 to 5.25 VDC
 | STEP 3D. Check for a short circuit to ground in the sensor supply lines. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for the failed sensors.

Guided Step 1A - Check the coolant temperature sensor.

Conditions

  • Disconnect the sensor harness from the coolant temperature sensor.

Action

Check the coolant temperature sensor.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 352 is still active.
OK NOT OK

Fault Code 352 active

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check the intake manifold pressure sensor.

Conditions

  • Disconnect the sensor harness from the intake manifold pressure sensor.
  • Turn keyswitch ON.

Action

Check the intake manifold pressure sensor.

  • Measure the voltage from pin A to pin B on the intake manifold pressure sensor connector.
OK NOT OK

Less than 4.5 VDC

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 1C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check the oil pressure sensor.

Conditions

  • Disconnect the sensor harness from the coolant level sensor.
  • Disconnect the sensor harness from the oil pressure sensor.
  • Connect the sensor harness to the intake manifold pressure sensor.
  • Turn keyswitch ON.

Action

Check the oil pressure sensor.

  • Measure the voltage from pin A to pin B on the oil pressure sensor connector.
OK NOT OK

Less than 4.5 VDC

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 1D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1D - Check the ambient air pressure sensor.

Conditions

  • Disconnect the sensor harness from the ambient air pressure sensor.
  • Turn keyswitch ON.

Action

Check the ambient air pressure sensor.

  • Measure the voltage from pin A to pin B on the ambient air pressure sensor connector.
OK NOT OK

Less than 4.5 VDC

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 1E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1E - Check the intake manifold temperature sensor.

Conditions

  • Disconnect the sensor harness from the intake manifold temperature sensor.
  • Turn keyswitch ON.

Action

Check the intake manifold temperature sensor.

  • Measure the voltage from pin A to pin B on the intake manifold temperature sensor connector.
OK NOT OK

Less than 4.5 VDC

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 1F

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1F - Check the oil temperature sensor.

Conditions

  • Disconnect the sensor harness from the coolant level sensor.
  • Disconnect the sensor harness from the oil temperature sensor.
  • Turn keyswitch ON.

Action

Check the oil temperature sensor.

  • Measure the voltage from pin A to pin B on the oil temperature sensor connector.
OK NOT OK

Less than 4.5 VDC

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the coolant level sensor circuit.

Guided Step 2A - Inspect the coolant level sensor and the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the coolant level sensor and the OEM harness connector pins.

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the coolant level sensor. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the OEM harness and engine harness 9-pin connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness from the OEM harness at the 9-pin Deutsch connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and engine harness 9-pin connector pins.

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins or replace the damaged harness.

  • Repair the damaged pins. Refer to Procedure 019-207 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 2C - Read the fault codes.

Conditions

  • Disconnect the OEM harness from the engine harness 9-pin connector.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Remove pins A, J, C, and B of the OEM harness 9-pin connector.
  • Install a jumper wire between pins A and C of the OEM harness 9-pin connector.
  • Install a jumper wire between pins J and B of the OEM harness 9-pin connector.
  • Connect the OEM harness to the engine harness at the 9-pin connector.
  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422 are active

Repair or replace the OEM harness, coolant level sensor, or shorting plug, whichever is faulty. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the sensor harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the harness and the ECM connector pins for:

  • Bent pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422 are active

Repair complete.

Go to 3C

Go to 4B

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check the supply voltage.

Conditions

  • Disconnect the sensor harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage from the ECM sensor port pins 2, 3, 5, 12, 21, and 22 to ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground in the sensor supply lines.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for a short circuit to ground in the sensor supply lines.

  • Measure the resistance from pins 2, 3, 5, 12, 21, and 22 in the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.
  • Disconnect all sensors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pins 2, 3, 5, 12, 21, and 22 to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422 are inactive.
OK NOT OK

Fault Codes 123, 141, 145, 154, 213, 222, 352, and 422 inactive

Return to the troubleshooting steps, or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

Erase the inactive fault codes using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness, bulkhead connector, and ECM connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 431 active
 | STEP 1C. Check the supply voltage. | 4.75 to 5.25 VDC
STEP 2. | Check switch circuits. |
 | STEP 2A. Check cruise control on/off switch for short circuit to ground. | More than 100k ohms
 | STEP 2B. Check engine brake on/off switch for short circuit to ground. | More than 100k ohms
 | STEP 2C. Check idle validation switch for short circuit to ground. | More than 100k ohms
 | STEP 2D. Check remote PTO switch for short circuit to ground. | More than 100k ohms
 | STEP 2E. Check cruise control select switch for short circuit to ground. | More than 100k ohms
 | STEP 2F. Check service brake pressure switch for short to ground. | More than 100k ohms
 | STEP 2G. Check idle adjust switch for short circuit to ground. | More than 100k ohms
 | STEP 2H. Check diagnostic switch for short circuit to ground. | More than 100k ohms
 | STEP 2I. Check clutch switch for short circuit to ground. | More than 100k ohms
STEP 3. | Check signal wires. |
 | STEP 3A. Check pins 2, 4, 5, 6, 9, 12, 13, 14, 21, 22, and 23 for short circuit to ground. | More than 100k ohms
 | STEP 3B. Check pin 10 for short circuit to ground. | More than 100k ohms
STEP 4. | Check for a short circuit from pin to pin. |
 | STEP 4A. Measure resistance from signal pins 2, 4, 5, 6, 9, 10, 12, 13, 14, 15, 21, 22, and 23 to pins 7, 19, 24, and 26 in the OEM connector. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Codes 352 and 431 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness, bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Flush and clean the connectors using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness, bulkhead connector, and ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Reference the OEM Troubleshooting and Repair Manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the o-ring on the 28-pin connector if it is damaged or missing. Refer to Procedure 019-203 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes using INSITE™ electronic service tool.
OK NOT OK

Fault Code 431 active

Repair complete.

Go to 1C

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1C - Check the supply voltage.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the supply voltage from the ECM OEM port pin 10 to ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check switch circuits.

Guided Step 2A - Check cruise control on/off switch for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cruise control on/off switch from the OEM harness.

Action

Check for short circuit to ground in cruise control switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-021 in Section 19.
OK NOT OK

More than 100k ohms

Replace cruise control on/off switch. Reference the OEM repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Check engine brake on/off switch for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake on/off switch from the OEM harness.

Action

Check for short circuit to ground in engine brake switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-034 in Section 19.
OK NOT OK

More than 100k ohms

Replace engine brake on/off switch. Reference the OEM repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Check idle validation switch for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle validation switch from the OEM harness.

Action

Check for short circuit to ground in idle validation switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-054 in Section 19.
OK NOT OK

More than 100k ohms

Replace idle validation switch. Reference the OEM repair manual.

Go to 2D

Go to 5A

Guided Step 2D - Check remote PTO switch for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote PTO switch from the OEM harness.

Action

Check for short circuit to ground in remote PTO switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-080 in Section 19.
OK NOT OK

More than 100k ohms

Replace remote PTO switch. Reference the OEM repair manual.

Go to 2E

Go to 5A

Guided Step 2E - Check cruise control select switch for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cruise control select switch from the OEM harness.

Action

Check for short circuit to ground in cruise control select switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-023 in Section 19.
OK NOT OK

More than 100k ohms

Replace cruise control select switch. Reference the OEM repair manual.

Go to 2F

Go to 5A

Guided Step 2F - Check service brake pressure switch for short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the service brake pressure switch from the OEM harness.

Action

Check for short circuit to ground in service brake pressure switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-088 in Section 19.
OK NOT OK

More than 100k ohms

Replace service brake pressure switch. Reference the OEM repair manual.

Go to 2G

Go to 5A

Guided Step 2G - Check idle adjust switch for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle adjust switch from the OEM harness.

Action

Check for short circuit to ground in idle adjust switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-052 in Section 19.
OK NOT OK

More than 100k ohms

Replace idle adjust switch. Reference the OEM repair manual.

Go to 2H

Go to 5A

Guided Step 2H - Check diagnostic switch for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the diagnostic switch from the OEM harness.

Action

Check for short circuit to ground in diagnostic switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-027 in Section 19.
OK NOT OK

More than 100k ohms

Replace diagnostic switch. Reference the OEM repair manual.

Go to 2I

Go to 5A

Guided Step 2I - Check clutch switch for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the clutch switch from the OEM harness.

Action

Check for short circuit to ground in clutch switch.

  • Measure the resistance from each of the switch terminals to the engine block ground. Refer to Procedure 019-009 in Section 19.
OK NOT OK

More than 100k ohms

Replace clutch switch. Reference the OEM repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check signal wires.

Guided Step 3A - Check pins 2, 4, 5, 6, 9, 12, 13, 14, 21, 22, and 23 for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the signal lines.

  • Measure the resistance from pins 2, 4, 5, 6, 9, 12, 13, 14, 21, 22, and 23 for short circuit to ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check pin 10 for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 in the OEM harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a short circuit from pin to pin.

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.
Guided Step 4A - Measure resistance from pins 2, 4, 5, 6, 9, 10, 12, 13, 14, 15, 21, 22, and 23 to pins 7, 19, 24, and 26 in the OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect all sensors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pins 2, 4, 5, 6, 9, 10, 12, 13, 14, 15, 21, 22, and 23 to pins 7, 19, 24, and 26 in the OEM connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203. in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Codes 352 and 431 are inactive.
OK NOT OK

Fault Codes 352 and 431 inactive

Return to the troubleshooting steps, or contact your nearest Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.

Action

Clear the inactive fault codes.

Erase the inactive fault codes using INSITE™ electronic service tool.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Dec-2012


INDEX
83-fc115.htm

83-t05-115.htm

83-fc121.htm

83-t05-121.htm

83-fc122.htm

83-t05-122.htm

83-fc123.htm

83-t05-123.htm

83-fc131.htm

83-fc131iss.htm

83-t05-131iss.htm

83-fc131ivs.htm

83-t05-131ivs.htm

83-fc132.htm

83-fc132iss.htm

83-t05-132iss.htm

83-fc132ivs.htm

83-t05-132ivs.htm

83-fc135.htm

83-t05-135.htm

83-fc141.htm

83-t05-141.htm

83-fc143.htm

83-t05-143.htm

83-fc144.htm

83-t05-144.htm

83-fc145.htm

83-t05-145.htm

83-fc151.htm

83-t05-151.htm

83-fc153.htm

83-t05-153.htm

83-fc154.htm

83-t05-154.htm

83-fc155.htm

83-t05-155.htm

83-fc212.htm

83-t05-212.htm

83-fc213.htm

83-t05-213.htm

83-fc214.htm

83-t05-214.htm

83-fc221.htm

83-t05-221.htm

83-fc222.htm

83-t05-222.htm

83-fc234.htm

83-t05-234.htm

83-fc235.htm

83-t05-235.htm

83-fc241.htm

83-t05-241.htm

83-fc242.htm

83-t05-242.htm

83-fc243.htm

83-t05-243.htm

83-fc245.htm

83-t05-245.htm

83-fc254.htm

83-t05-254.htm

83-fc255.htm

83-t05-255.htm

83-fc311.htm

83-fc311n.htm

83-t05-311n.htm

83-fc311ml.htm

83-t05-311ml.htm

83-fc312.htm

83-fc312n.htm

83-t05-312n.htm

83-fc312ml.htm

83-t05-312ml.htm

83-fc313.htm

83-fc313n.htm

83-t05-313n.htm

83-fc313ml.htm

83-t05-313ml.htm

83-fc314.htm

83-fc314n.htm

83-t05-314n.htm

83-fc314ml.htm

83-t05-314ml.htm

83-fc315.htm

83-fc315n.htm

83-t05-315n.htm

83-fc315ml.htm

83-t05-315ml.htm

83-fc321.htm

83-fc321n.htm

83-t05-321n.htm

83-fc321ml.htm

83-t05-321ml.htm

83-fc322.htm

83-fc322n.htm

83-t05-322n.htm

83-fc322ml.htm

83-t05-322ml.htm

83-fc323.htm

83-fc323n.htm

83-t05-323n.htm

83-fc323ml.htm

83-t05-323ml.htm

83-fc324.htm

83-fc324n.htm

83-t05-324n.htm

83-fc324ml.htm

83-t05-324ml.htm

83-fc325.htm

83-fc325n.htm

83-t05-325n.htm

83-fc325ml.htm

83-t05-325ml.htm

83-fc331.htm

83-fc331n.htm

83-t05-331n.htm

83-fc331ml.htm

83-t05-331ml.htm

83-fc332.htm

83-fc332n.htm

83-t05-332n.htm

83-fc332ml.htm

83-t05-332ml.htm

83-fc333.htm

83-t05-333.htm

83-fc335.htm

83-t05-335.htm

83-fc341.htm

83-t05-341.htm

83-fc342.htm

83-t05-342.htm

83-fc343.htm

83-t05-343.htm

83-fc351.htm

83-t05-351.htm

83-fc352.htm

83-t05-352.htm

83-fc411.htm

83-t05-411.htm

83-fc412.htm

83-t05-412.htm

83-fc413.htm

83-t05-413.htm

83-fc414.htm

83-t05-414.htm

83-fc415.htm

83-t05-415.htm

83-fc422.htm

83-t05-422.htm

83-fc431.htm

83-fc431iss.htm

83-t05-431iss.htm

83-fc431ivs.htm

83-t05-431ivs.htm

83-fc432.htm

83-fc432iss.htm

83-t05-432iss.htm

83-fc432ivs.htm

83-t05-432ivs.htm

83-fc433.htm

83-t05-433.htm

83-fc434.htm

83-t05-434.htm

83-fcmfc.htm

83-fcmfc1.htm

83-t05-mfc1.htm

83-fcmfc2.htm

83-t05-mfc2.htm