CENTRY

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module (ECM) Microprocessor

FAULT CODE 111

Electronic Control Module (ECM) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 FMI: 12 LAMP: Flashing SRT: 00-618 | Microprocessor communication error inside the ECM. | Unpredictable: Engine can not start, or engine can die, or engine can run at a constant engine speed of low idle, high idle, or intermediate speed, or no effect on performance.
ECM Processor

Circuit Description

The CENTRY™ ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the fuel pump on the left side of the engine.

Shop Talk

This fault code can only be caused by an internal ECM problem.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 18-Dec-2012
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Electronic Step Timing Control (STC) Circuit

FAULT CODE 113

Electronic Step Timing Control (STC) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 113 PID: S20 FMI: 3 LAMP: On SRT: 00-619 | High voltage or open circuit detected at electronic step timing control (STC) driver pin 20 of the main engine harness electronic control module (ECM) connector when electronic STC is off or in normal timing. | Electronic STC valve stuck in advance and loss of engine power.
Electronic Step Timing Control (STC) Circuit

Circuit Description

The electronic STC option allows the electronic control module (ECM) to control the STC valve, through the main engine harness, determining when the engine timing moves from advance to normal timing. The ECM utilizes the rail pressure input signal or the rail pressure and engine speed sensor input signals to determine the shift point.

Component Location

The electronic STC control valve is mounted on the left side of the engine.

Shop Talk

Electronic STC valve coil resistance:

12-VDC solenoid = 6 to 10 ohms

24-VDC solenoid = 26 to 40 ohms

This fault code can be caused by a short circuit to a voltage source, broken wire, or loose connection.

Refer to Troubleshooting Fault Code t05-113


Electronic Step Timing Control (STC) Circuit

FAULT CODE 114

Electronic Step Timing Control (STC) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 114 PID: S20 FMI: 4 LAMP: On SRT: 00-620 | Low voltage detected at electronic step timing control (STC) driver pin 20 of the main engine harness electronic control module (ECM) connector when the electronic STC is on or in advanced timing. | STC valve stuck in normal. Engine will be hard to start, will misfire, and will emit white smoke.
Electronic Step Timing Control (STC) Circuit

Circuit Description

The electronic STC option allows the ECM to control the STC valve, through the main engine harness, determining when the engine timing moves from advance to normal timing. The ECM utilizes the rail pressure input signal or the rail pressure and engine speed sensor input signals to determine the shift point.

Component Location

The electronic STC control valve is mounted on the left side of the engine.

Shop Talk

Electronic STC valve coil resistance:

12-VDC solenoid = 6 to 10 ohms

24-VDC solenoid = 26 to 40 ohms

This fault code is usually caused by a short circuit to ground.

Refer to Troubleshooting Fault Code t05-114


Fault Code Path Selection

FAULT CODE 115
Fault Code Path Selection

Is the Engine Speed Sensor Circuit (with Variable Voltage Accelerator) used? | Go to 98-fc115vva
Is the Engine Speed Sensor Circuit (with Frequency Accelerator) used? | Go to 98-fc115fa

Last Modified: 27-Oct-2003


Engine Speed Sensor Circuit

FAULT CODE 121

Engine Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: 190 FMI: 10 LAMP: Flashing SRT: 00-621 | No engine speed signal detected at one pair of the engine speed sensor signal pins 4 and 17 or pins 18 and 24 of the main engine harness electronic control module (ECM) connector. | None on performance.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual coil circuit that provides the engine speed signal to the ECM through the main engine harness.

Component Location

The engine speed sensor is located on the flywheel housing.

Shop Talk

The coil resistance should be 750 to 1100 ohms for the first coil and 1100 to 1500 ohms for the second coil. The engine speed signal can not be measured accurately with any multimeter.

Refer to Troubleshooting Fault Code t05-121


Fault Code Path Selection

FAULT CODE 131
Fault Code Path Selection

Is the Accelerator Position Sensor (CELECT™ Type Accelerator Pedal) used? | Go to 98-fc131ctap
Is the Accelerator Position Sensor (Non-CELECT™ Accelerator Pedal) used? | Go to 98-fc131nctap
Is the Accelerator Position Sensor (Accelerator Switch) used? | Go to 98-fc131as
Is the Accelerator Position Sensor (Frequency Accelerator) used? | Go to 98-fc131fa

Last Modified: 27-Oct-2003


Fault Code Path Selection

FAULT CODE 132
Fault Code Path Selection

Is the Accelerator Position Sensor (CELECT™ Type Accelerator Pedal) used? | Go to 98-fc132ctap
Is the Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal) used? | Go to 98-fc132nctap
Is the Accelerator Position Sensor (Frequency Accelerator) used? | Go to 98-fc132fa

Last Modified: 27-Oct-2003


Oil Pressure Sensor Circuit

FAULT CODE 135

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 FMI: 3 LAMP: On SRT: 00-624 | More than 4.80 VDC detected at oil pressure signal pin 15 of the main engine harness electronic control module (ECM) connector. | None on performance.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor provides an oil pressure signal to the ECM through the OEM harness and the main engine harness. The oil pressure value is transmitted over the public datalink.

Component Location

The oil pressure sensor location varies with each OEM. Reference the OEM manual for the oil pressure sensor location.

Shop Talk

The oil pressure sensor is only used for monitoring purposes. Signals from the sensor are not used by the ECM to control the engine. There is no engine protection system for oil pressure on CENTRY™. The following chart shows the output voltage of the oil pressure sensor at various pressures.

Pressure (kPa) | Pressure (psi) | Voltage (VDC)
0 | 0 | 0.42 to 0.58
172.37 | 25 | 1.42 to 1.58
344.74 | 50 | 2.42 to 2.58
517.11 | 75 | 3.42 to 3.58
689.48 | 100 | 4.42 to 4.58
Refer to Troubleshooting Fault Code t05-135


Oil Pressure Sensor Circuit

FAULT CODE 141

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 FMI: 4 LAMP: On SRT: 00-625 | Less than 0.2 VDC detected at oil pressure signal pin 15 of the main engine harness electronic control module (ECM) connector. | None on performance.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor provides an oil pressure signal to the ECM through the OEM harness and the main engine harness. The oil pressure value is transmitted over the public datalink.

Component Location

The oil pressure sensor location varies with each OEM. Reference the OEM manual for the oil pressure sensor location.

Shop Talk

The oil pressure sensor is only used for monitoring purposes. Signals from the sensor are not used by the ECM to control the engine. There is no engine protection system for oil pressure on CENTRY™. The following chart shows the output voltage of the oil pressure sensor at various pressures.

Pressure (kPa) | Pressure (psi) | Voltage (VDC)
0 | 0 | 0.42 to 0.58
172.37 | 25 | 1.42 to 1.58
344.74 | 50 | 2.42 to 2.58
517.11 | 75 | 3.42 to 3.58
689.48 | 100 | 4.42 to 4.58
Refer to Troubleshooting Fault Code t05-141


Coolant Temperature Sensor Circuit

FAULT CODE 144

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 FMI: 3 LAMP: On SRT: 00-626 | More than 5.00 VDC detected at coolant temperature sensor signal pin 5 of the main engine harness electronic control module (ECM) connector. | None on performance.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor provides a coolant temperature signal to the ECM through the OEM harness and the main engine harness. The coolant temperature value is transmitted over the public datalink.

Component Location

The coolant temperature sensor location varies with each OEM. Reference the OEM manual for the coolant temperature sensor location.

Shop Talk

The coolant temperature sensor is only used for monitoring purposes. Signals from the sensor are not used by the ECM to control the engine. There is no engine protection system for coolant temperature on CENTRY™. The following chart shows the resistance of the coolant temperature sensor at various temperatures.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-144


Coolant Temperature Sensor Circuit

FAULT CODE 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 FMI: 4 LAMP: On SRT: 00-627 | Less than 0.2 VDC detected at coolant temperature sensor signal pin 5 of the main engine harness electronic control module (ECM) connector. | None on performance.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor provides a coolant temperature signal to the ECM through the OEM harness and the main engine harness. The coolant temperature value is transmitted over the public datalink.

Component Location

The coolant temperature sensor location varies with each OEM. Reference the OEM manual for the coolant temperature sensor location.

Shop Talk

The coolant temperature sensor is only used for monitoring purposes. Signals from the sensor are not used by the ECM to control the engine. There is no engine protection system for coolant temperature on CENTRY™. The following chart shows the resistance of the coolant temperature sensor at various temperatures.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145


Engine Overspeed Circuit

FAULT CODE 234

Engine Overspeed Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 FMI: 0 LAMP: Flashing SRT: 00-628 | Engine speed signal on pins 4 and 17 and/or 18 and 24 of the main engine harness electronic control module (ECM) connector indicated an engine speed overspeed. | Engine will die. Keyswitch must be turned to OFF for five seconds to restart.
Engine Overspeed Circuit

Circuit Description

The engine speed sensor is a dual coil circuit that provides the engine speed information to the ECM through the main engine harness.

Component Location

The engine speed sensor is located in the flywheel housing at the rear of the engine.

Shop Talk

  • If the engine is not equipped with a rapid restart valve, fuel flow to the injectors will not be restarted until the rail pressure drops to 138 kPa [20 psi.]
  • Inspect the intake manifold for sources of flammable vapors.
  • Inspect the turbocharger seals to verify that there are no oil leaks.
  • Verify that the fuel pump is not causing erratic pressure fluctuations.
  • Inspect the engine speed sensor for signs of damage or tampering.
Refer to Troubleshooting Fault Code t05-234


Auxiliary Shutdown Circuit

FAULT CODE 254

Auxiliary Shutdown Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 FMI: 4 LAMP: On SRT: 00-629 | Low voltage detected at auxiliary shutdown driver pin 1 of the main engine harness electronic control module (ECM) connector when the auxiliary shutdown is on. | No effect on performance, or engine can die, or engine will not start.
Auxiliary Shutdown Circuit

Circuit Description

The auxiliary shutdown driver provides switched battery voltage to the auxiliary shutdown solenoid through the main engine harness and OEM harness when the keyswitch is in the ON position.

Component Location

The location of the auxiliary shutdown solenoid varies with each OEM. Reference the OEM manual

Shop Talk

The auxiliary shutdown driver in the CENTRY™ system can be used to power auxiliary shutdown devices such as air intake flaps or additional fuel shutdown devices. It can also be used to shut off other equipment when the engine shuts down.

Refer to Troubleshooting Fault Code t05-254


Auxiliary Shutdown Circuit

FAULT CODE 255

Auxiliary Shutdown Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S17 FMI: 3 LAMP: On SRT: 00-630 | High voltage or an open circuit detected at auxiliary shutdown driver pin 1 of the main engine harness electronic control module (ECM) connector when the auxiliary shutdown is off. | No effect on performance, or engine can die, or engine will not start.
Auxiliary Shutdown Circuit

Circuit Description

The auxiliary shutdown driver provides switched battery voltage to the auxiliary shutdown solenoid through the main engine harness and OEM harness when the keyswitch is in the ON position.

Component Location

The location of the auxiliary shutdown solenoid varies with each OEM. Reference the OEM manual

Shop Talk

The auxiliary shutdown driver in the CENTRY™ system can be used to power auxiliary shutdown devices such as air intake flaps or additional fuel shutdown devices. It can also be used to shut off other equipment when the engine shuts down.

Refer to Troubleshooting Fault Code t05-255


Electronic Control Module (ECM) Memory

FAULT CODE 341

Electronic Control Module (ECM) Memory

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 341 PID: S253 FMI: 12 LAMP: Flashing SRT: 00-631 | ECM internal memory checksum error. | Unpredictable: Engine can not start, or engine can die, engine can run at a constant engine speed of low idle, high idle, or intermediate speed, or no effect on performance.
Electronic Control Module (ECM) Memory

Circuit Description

The CENTRY™ ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the fuel pump on the left side of the engine.

Shop Talk

This fault code can only be caused by an internal ECM problem.

Refer to Troubleshooting Fault Code t05-341


Electronic Control Module (ECM) Memory

FAULT CODE 342

Electronic Control Module (ECM) Memory

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: S253 FMI: 12 LAMP: On SRT: 00-631 | Erasable programmable read-only memory memory checksum error. | Unpredictable: Engine can not start, or engine can run at high idle only.
Electronic Control Module (ECM) Memory

Circuit Description

The CENTRY™ ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the fuel pump on the left side of the engine.

Shop Talk

This fault code can only be caused by an internal ECM problem.

Refer to Troubleshooting Fault Code t05-342


Electronic Control Module (ECM) Memory

FAULT CODE 353

Electronic Control Module (ECM) Memory

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 353 PID: S251 FMI: 12 LAMP: On SRT: 00-631 | Erasable programmable read-only memory memory read/write error. | None on performance. Electronic service tool can display erroneous fault code or parameter information.
Electronic Control Module (ECM) Memory

Circuit Description

The CENTRY™ ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the fuel pump on the left side of the engine.

Shop Talk

This fault code can only be caused by an internal ECM problem.

Refer to Troubleshooting Fault Code t05-353


Datalink Circuit

FAULT CODE 412

Datalink Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 FMI: 3 LAMP: On SRT: 00-632 | Data transmission error on datalink pins 6 and 8 of the main engine harness electronic control module (ECM) connector. | None on performance. No communication with electronic service tool.
Datalink Circuit

Circuit Description

The datalink allows the service tools to communicate with the ECM. The datalink can also be used to communicate electronically with other onboard electronic devices such as electronic dashboards, trip recorders, etc., using the SAE J1587 communication protocol.

Component Location

A datalink connector is located on the main engine harness and OEM harness. Reference the OEM manual for the datalink location.

Shop Talk

Datalink:

OEM C6 harness pin J to chassis ground

  • 4.0 to 5.0 VDC

OEM C6 harness pin H to chassis ground

  • 0.0 to 1.0 VDC

Engine datalink pin A to chassis ground

  • 4.0 to 5.0 VDC

Engine datalink pin B to chassis ground

  • 0.0 to 1.0 VDC
Refer to Troubleshooting Fault Code t05-412


Datalink Circuit

FAULT CODE 414

Datalink Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 414 PID: S250 FMI: 9 LAMP: On SRT: 00-632 | Data transmission error on datalink pins 6 and 8 of the main engine harness electronic control module (ECM) connector. | None on performance, no communication with electronic service tool, or possible engine stumble or surge.
Datalink Circuit

Circuit Description

The datalink allows the service tools to communicate with the ECM. The datalink can also be used to communicate electronically with other onboard electronic devices such as electronic dashboards, trip recorders, etc., using the SAE J1587 communication protocol.

Component Location

A datalink connector is located on the main engine harness and OEM harness. Reference the OEM manual for the datalink location.

Shop Talk

Datalink:

OEM C6 harness pin J to chassis ground

  • 4.0 to 5.0 VDC

OEM C6 harness pin H to chassis ground

  • 0.0 to 1.0 VDC

Engine datalink pin A to chassis ground

  • 4.0 to 5.0 VDC

Engine datalink pin B to chassis ground

  • 0.0 to 1.0 VDC

The AGCO electronic tachometer will cause Fault Code 414 to be logged when the keyswitch is turned on, and/or Compulink™, Echek™, or INSITE™ monitoring can “stumble” while electronic tachometer is connected.

Applications that require more than 50 feet of datalink wire length must use a specially wired twisted pair, shielded datalink cable to prevent logging the fault code. Reference the CENTRY™ system installation guidelines.

Refer to Troubleshooting Fault Code t05-414


Idle Validation Circuit

FAULT CODE 431

Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: P91 FMI: 2 LAMP: On SRT: 00-633 | Voltage detected simultaneously on both the idle validation off-idle signal pin 9 of the main engine harness electronic control module (ECM) connector and the idle validation on-idle signal pin 16 of the main engine harness ECM connector, or no voltage detected simultaneously on both the idle validation off-idle signal pin 9 of the main engine harness ECM connector and the idle validation on-idle signal pin 16 of the main engine harness ECM connector. | None on performance, or engine can only idle.
Idle Validation Circuit

Circuit Description

The idle validation signal is a safety feature that disables throttle control while an improper validation signal is detected by the ECM. The idle validation switch provides an on-idle and off-idle validation signal to the ECM through the OEM harness and main engine harness.

Component Location

The idle validation switch is mounted on the throttle pedal. The throttle pedal location varies with each OEM. Reference the OEM manual.

Shop Talk

This fault code is usually caused by the improper wiring of the harnesses and idle validation switch, or low battery voltage while cranking the engine.

Refer to Troubleshooting Fault Code t05-431


Fault Code Path Selection

FAULT CODE 432
Fault Code Path Selection

Is the Accelerator Position Sensor (CELECT™ Type Accelerator Pedal) used? | Go to 98-fc432ctap
Is the Accelerator Position Sensor (Non-CELECT Type Accelerator Pedal) used? | Go to 98-fc432nctap

Last Modified: 27-Oct-2003


Switched Battery Supply Circuit

FAULT CODE 441

Switched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: S168 FMI: 4 LAMP: On SRT: 00-635 | Low battery supply voltage between (+) pins 22 or 23 and (-) pins 25 or 26 for more than 10 seconds while engine speed is above idle. | Unpredictable: Engine can die and not restart, or engine can stumble, or loss of power, or no effect on performance.
Switched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives switched battery input through the vehicle keyswitch, OEM harness, and the main engine harness when the keyswitch is in the ON position. There are two in-line 5-amp fuses in the switched battery wires of the main engine harness to protect the ECM. The battery return wires are connected to the engine block ground.

Component Location

The location of the battery will vary with the OEM. Reference the OEM manual for battery location.

Refer to Troubleshooting Fault Code t05-441


Switched Battery Supply Circuit

FAULT CODE 442

Switched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: S168 FMI: 3 LAMP: On SRT: 00-636 | Excessively high battery supply voltage detected between (+) pins 22 or 23 and (-) pins 25 or 26 for more than 5 minutes. | Engine will run at idle only.
Switched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives switched battery input through the vehicle keyswitch, OEM harness, and the main engine harness when the keyswitch is in the ON position. There are two in-line 5-amp fuses in the switched battery wires of the main engine harness to protect the ECM. The battery return wires are connected to the engine block ground.

Component Location

The location of the battery varies by OEM. Reference the OEM manual for battery location.

Refer to Troubleshooting Fault Code t05-442


Fault Code Path Selection

FAULT CODE 443
Fault Code Path Selection

Is the Accelerator Position Sensor (CELECT™ Type Accelerator Pedal) used? | Go to 98-fc443ctap
Is the Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal) used? | Go to 98-fc443nctap
Is the Accelerator Position Sensor (Accelerator Switch) used? | Go to 98-fc443as
Is the Accelerator Position Sensor (Frequency Accelerator) used? | Go to 98-fc443fa

Last Modified: 27-Oct-2003


Rail Pressure Sensor Circuit

FAULT CODE 444

Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 444 PID: S254 FMI: 4 LAMP: On SRT: 00-638 | Low voltage detected at rail pressure sensor +5-VDC supply pin 11 of the main engine harness electronic control module (ECM) connector. | Power and engine speed derate.
Rail Pressure Sensor Circuit

Circuit Description

The rail pressure sensor provides the rail pressure signal to the ECM through the main engine harness. The ECM uses the rail pressure signal to monitor the fuel pressure going to the injectors from the fuel pump. The oil pressure sensor provides an oil pressure signal to the ECM through the OEM harness and the main engine harness. The oil pressure value is transmitted over the public datalink.

Component Location

The rail pressure sensor is located in a different location for each engine family. On L10 and M11 engines, the sensor is located on the cylinder head above the main engine harness. On NT engines, the sensor is located on the fuel block that is attached to the C5 and C6 connector clips. On K19 engines, the sensor is on the fuel block just above the fuel pump. On KV engines, the sensor is located next to the fuel shutoff solenoid on the fuel block above the fuel pump. Reference the appropriate engine diagram. Reference the OEM manual for the oil pressure sensor location. The oil pressure sensor location varies with each OEM.

Shop Talk

The following chart shows the output voltage of the rail pressure sensor at various pressure readings:

Pressure (kPa) | Pressure (psi) | Voltage (VDC)
0 | 0 | 0.42 to 0.54
344.74 | 50 | 1.26 to 1.34
689.48 | 100 | 2.06 to 2.14
1034.22 | 150 | 2.85 to 2.95
1389.96 | 200 | 3.63 to 3.77
1723.70 | 250 | 4.39 to 4.62

The oil pressure sensor is only used for monitoring purposes. Signals from the sensor are not used by the ECM to control the engine. There is no engine protection system for oil pressure on CENTRY™. The following chart shows the output voltage of the oil pressure sensor at various pressures.

Pressure (kPa) | Pressure (psi) | Voltage (VDC)
0 | 0 | 0.42 to 0.58
172.37 | 25 | 1.42 to 1.58
344.74 | 50 | 2.42 to 2.58
517.11 | 75 | 3.42 to 3.58
689.48 | 100 | 4.42 to 4.58
Refer to Troubleshooting Fault Code t05-444


Intermediate-Speed/Alternate Droop Validation Signal Circuit

FAULT CODE 445

Intermediate-Speed/Alternate Droop Validation Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 445 PID: S254 FMI: 3 LAMP: On SRT: 00-639 | Low voltage detected at the intermediate-speed/alternate droop validation signal pin 2 of the main engine harness electronic control module (ECM) connector while high voltage is detected at the intermediate-speed signal pin 5 of the main engine harness ECM connector or the alternate droop signal pin 28 of the main engine harness ECM connector. | Loss of intermediate-speed and alternate droop features.
Intermediate-Speed/Alternate Droop Validation Signal Circuit

Circuit Description

The intermediate-speed/alternate droop validation signal is a safety feature that enables the intermediate-speed and alternate droop features while the validation signal is detected as a high voltage. The intermediate-speed switch and alternate droop switch provide the intermediate-speed, alternate droop, and intermediate-speed/alternate droop validation signals to the ECM through the OEM harness and the main engine harness.

Component Location

The locations of the intermediate-speed switch and the alternate droop switch vary with each OEM and equipment model. Reference the OEM manual.

Shop Talk

This fault code will not be active while the intermediate-speed or alternate droop switches are in the OFF position.

Refer to Troubleshooting Fault Code t05-445


Rail Pressure Sensor Circuit

FAULT CODE 451

Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P94 FMI: 3 LAMP: On SRT: 00-640 | More than 4.73 VDC detected at rail pressure sensor signal pin 14 of the main engine harness electronic control module (ECM) connector. | Power and engine speed derate.
Rail Pressure Sensor Circuit

Circuit Description

The rail pressure sensor provides the rail pressure signal to the ECM through the main engine harness. The ECM uses the rail pressure signal to monitor the fuel pressure going to the injectors from the fuel pump.

Component Location

The rail pressure sensor is located in a different location for each engine family. On L10 and M11 engines, the sensor is located on the cylinder head above the main engine harness. On NT engines, the sensor is located on the fuel block that is attached to the C5 and C6 connector clips. On K19 engines, the sensor is on the fuel block just above the fuel pump. On KV engines, the sensor is located next to the fuel shutoff solenoid on the fuel block above the fuel pump. Reference the appropriate engine diagram.

Shop Talk

The following chart shows the output voltage of the rail pressure sensor at various pressure readings:

Pressure (kPa) | Pressure (psi) | Voltage (VDC)
0 | 0 | 0.42 to 0.54
344.74 | 50 | 1.26 to 1.34
689.48 | 100 | 2.06 to 2.14
1034.22 | 150 | 2.85 to 2.95
1389.96 | 200 | 3.63 to 3.77
1723.70 | 250 | 4.39 to 4.62
Refer to Troubleshooting Fault Code t05-451


Rail Pressure Sensor Circuit

FAULT CODE 452

Rail Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P94 FMI: 4 LAMP: On SRT: 00-641 | Less than 0.2 VDC detected at rail pressure sensor signal pin 14 of the main engine harness electronic control module (ECM) connector. | Power and engine speed derate.
Rail Pressure Sensor Circuit

Circuit Description

The rail pressure sensor provides the rail pressure signal to the ECM through the main engine harness. The ECM uses the rail pressure signal to monitor the fuel pressure going to the injectors from the fuel pump.

Component Location

The rail pressure sensor is located in a different location for each engine family. On L10 and M11 engines, the sensor is located on the cylinder head above the main engine harness. On NT engines, the sensor is located on the fuel block that is attached to the C5 and C6 connector clips. On K19 engines, the sensor is on the fuel block just above the fuel pump. On KV engines, the sensor is located next to the fuel shutoff solenoid on the fuel block above the fuel pump. Reference the appropriate engine diagram.

Shop Talk

The following chart shows the output voltage of the rail pressure sensor at various pressure readings:

Pressure (kPa) | Pressure (psi) | Voltage (VDC)
0 | 0 | 0.42 to 0.54
344.74 | 50 | 1.26 to 1.34
689.48 | 100 | 2.06 to 2.14
1034.22 | 150 | 2.85 to 2.95
1389.96 | 200 | 3.63 to 3.77
1723.70 | 250 | 4.39 to 4.62
Refer to Troubleshooting Fault Code t05-452


Electronic Fuel Control Valve Circuit

FAULT CODE 455

Electronic Fuel Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: S18 FMI: 3 LAMP: Flashing SRT: 000-642 | High voltage detected at electronic fuel control valve supply (+) pin 21 of the main engine harness electronic control module (ECM) connector when low current is detected at electronic fuel control valve return (-) pin 10 of the main engine harness ECM connector. | Engine will die and will not start.
Electronic Fuel Control Valve Circuit

Circuit Description

The electronic fuel control valve is an actuator that is electronically controlled by the ECM through the main engine harness to control fuel flow to the injectors.

Component Location

The electronic fuel control is bolted to the fuel pump on the left side of the engine.

Shop Talk

The resistance of the coil in the electronic fuel control valve is as follows:

12-VDC coil resistance = 1.5 to 3 ohms

24-VDC coil resistance = 7 to 10 ohms

A loose connection at the electronic fuel control or an engine surge can cause this fault code to be intermittently active or inactive with high counts recorded.

Refer to Troubleshooting Fault Code t05-455


Electronic Fuel Control Valve Circuit

FAULT CODE 511

Electronic Fuel Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 511 PID: S18 FMI: 4 LAMP: Flashing SRT: 000-643 | Low current is detected at electronic fuel control valve return (-) pin 10 of the main engine harness electronic control module (ECM) connector when the electronic fuel control voltage is high and low voltage is detected at the rail pressure signal pin 14 of the main engine harness ECM connector. | Engine can die, or no effect on performance, and overspeed protection is disabled.
Electronic Fuel Control Valve Circuit

Circuit Description

The electronic fuel control valve is an actuator that is electronically controlled by the ECM through the main engine harness to control fuel flow to the injectors.

Component Location

The electronic fuel control is bolted to the fuel pump on the left side of the engine.

Shop Talk

The resistance of the coil in the electronic fuel control valve is as follows:

12-VDC coil resistance = 1.5 to 3 ohms

24-VDC coil resistance = 7 to 10 ohms

A loose connection at the electronic fuel control or an engine surge can cause this fault code to be intermittently active or inactive with high counts recorded.

Refer to Troubleshooting Fault Code t05-511


Rail Pressure Sensor Circuit or Fuel Rail Pressure High

FAULT CODE 514

Rail Pressure Sensor Circuit or Fuel Rail Pressure High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 514 PID: S18 FMI: 7 LAMP: Flashing SRT: 00-644 | High voltage detected at rail pressure sensor pin 14 of the main engine harness electronic control module (ECM) connector when there is low current at electronic fuel control return (-) pin 10 of the main engine harness ECM connector. | Engine can run at high idle only and loss of throttle control, or engine can surge. Engine will shutdown with the keyswitch.
Rail Pressure Sensor Circuit or Fuel Rail Pressure High

Circuit Description

The rail pressure sensor provides the rail pressure signal to the ECM through the main engine harness. The ECM uses the rail pressure signal to monitor the fuel pressure going to the injectors from the fuel pump.

Component Location

The rail pressure sensor is located in a different location for each engine family. On L10 and M11 engines, the sensor is located on the cylinder head above the main engine harness. On NT engines, the sensor is located on the fuel block that is attached to the C5 and C6 connector clips. On K19 engines, the sensor is located on the fuel block just above the fuel pump. On KV engines, the sensor is located next to the fuel shutoff solenoid on the fuel block above the fuel pump. Reference the appropriate engine diagram.

Shop Talk

If there are no other fault codes logged, there is a problem with the fuel supply to the injectors. Reference the appropriate engine symptom troubleshooting chart. The ECM can not control the engine speed while this fault code is active. A failed electronic fuel control valve can cause this fault code to be active. An engine surge can cause this fault code to be intermittently active.

Refer to Troubleshooting Fault Code t05-514


Auxiliary Temperature Sensor Circuit

FAULT CODE 521

Auxiliary Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 521 PID: P177 FMI: 3 LAMP: On SRT: 00-645 | More than 5.00 VDC detected at auxiliary temperature signal pin 28 of the main engine harness electronic control module (ECM) connector. | None on performance.
Auxiliary Temperature Sensor Circuit

Circuit Description

The auxiliary temperature sensor provides a temperature signal to the ECM through the OEM harness and the main engine harness. The auxiliary temperature value is transmitted over the public datalink.

Component Location

Reference the OEM manual for the auxiliary temperature sensor location.

Shop Talk

The auxiliary temperature sensor is only used for monitoring purposes. Signals from the sensor are not used by the ECM to control the engine. There is no engine protection system for auxiliary temperature on CENTRY™. The following chart shows the resistance of the auxiliary temperature sensor at various temperatures.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-521


Auxiliary Temperature Sensor Circuit

FAULT CODE 522

Auxiliary Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 522 PID: P177 FMI: 4 LAMP: On SRT: 00-646 | Less than 0.2 VDC detected at coolant temperature sensor pin 28 of the main engine harness electronic control module (ECM) connector. | None on performance.
Auxiliary Temperature Sensor Circuit

Circuit Description

The auxiliary temperature sensor provides a temperature signal to the ECM through the OEM harness and the main engine harness. The auxiliary temperature value is transmitted over the public datalink.

Component Location

Reference the OEM manual for the auxiliary temperature sensor location.

Shop Talk

The auxiliary temperature sensor is only used for monitoring purposes. Signals from the sensor are not used by the ECM to control the engine. There is no engine protection system for auxiliary temperature on CENTRY™. The following chart shows the resistance of the auxiliary temperature sensor at various temperatures.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-522


Intermediate-Speed/Alternate Droop Validation Signal Circuit

FAULT CODE 523

Intermediate-Speed/Alternate Droop Validation Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 523 PID: Pa FMI: 2 LAMP: On SRT: 00-647 | High voltage detected at the intermediate-speed/alternate droop validation signal pin 2 of the main engine harness electronic control module (ECM) connector when low voltage is detected at the intermediate-speed signal pin 5 of the main engine harness ECM connector. | Loss of intermediate-speed, or engine will run at intermediate-speed only.
Intermediate-Speed/Alternate Droop Validation Signal Circuit

Circuit Description

The intermediate-speed/alternate droop validation signal is a safety feature that disables the intermediate-speed feature while the validation signal is detected as a high voltage. The intermediate-speed switch provides the intermediate-speed and intermediate-speed/alternate droop validation signals to the ECM through the OEM harness and the main engine harness.

Component Location

The locations of the intermediate-speed switch and the alternate droop switch vary with each OEM and equipment model. Reference the OEM manual.

Refer to Troubleshooting Fault Code t05-523


Intermediate-Speed/Alternate Droop Validation Signal Circuit

FAULT CODE 524

Intermediate-Speed/Alternate Droop Validation Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 524 PID: P113 FMI: 2 LAMP: On SRT: 00-648 | High voltage detected at the intermediate-speed/alternate droop validation signal pin 2 of the main engine harness electronic control module (ECM) connector when low voltage is detected at the alternate droop signal pin 28 of the main engine harness ECM connector. | Loss of alternate droop, or engine will run in alternate droop mode only.
Intermediate-Speed/Alternate Droop Validation Signal Circuit

Circuit Description

The intermediate-speed/alternate droop validation signal is a safety feature that disables the alternate droop feature while the validation signal is detected as a high voltage. The alternate droop switch provides the alternate droop and intermediate-speed/alternate droop validation signals to the ECM through the OEM harness and the main engine harness.

Component Location

The location of the intermediate-speed switch and the alternate droop switch vary with each OEM and equipment model. Reference the OEM manual.

Refer to Troubleshooting Fault Code t05-524


Electronic Control Module (ECM) Memory

FAULT CODE 525

Electronic Control Module (ECM) Memory

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 525 PID: S254 FMI: 3 LAMP: On SRT: 00-649 | Electronic control module (ECM) not calibrated with Electronic Software and Database Network (ESDN), or ECM has failed. | Unpredictable: Engine can not start or engine can run at a constant engine speed of low idle, high idle, or intermediate-speed. Electronic service tool will only display Fault Code 525, or no communication with service tool.
ECM Memory

Circuit Description

The CENTRY™ ECM is a computer that is responsible for engine control, diagnostics, and user features. A calibration is a file that resides in the ECM and contains user features and parameters specifically for each application.

Component Location

The ECM is bolted to the fuel pump on the left side of the engine.

Shop Talk

This is a fault with the internal memory. Try to calibrate first before replacing the ECM. This fault code can be caused by a loss of communication or communication error during calibration of the ECM.

Refer to Troubleshooting Fault Code t05-525


Rail Pressure Sensor Circuit or Fuel Rail Pressure Low

FAULT CODE 552

Rail Pressure Sensor Circuit or Fuel Rail Pressure Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 552 PID: S18 FMI: 2 LAMP: On SRT: 00-650 | Low voltage detected at rail pressure sensor pin 14 of the main engine harness electronic control module (ECM) connector when there is high current at electronic fuel control return (-) pin 10 of the main engine harness ECM connector. | Limited throttle control. Low power, or engine can die, or engine can surge.
Rail Pressure Sensor Circuit or Fuel Rail Pressure Low

Circuit Description

The rail pressure sensor provides the rail pressure signal to the ECM through the main engine harness. The ECM uses the rail pressure signal to monitor the fuel pressure going to the injectors from the fuel pump.

Component Location

The rail pressure sensor is located in a different location for each engine family. On L10 and M11 engines, the sensor is located on the cylinder head above the main engine harness. On NT engines, the sensor is located on the fuel block that is attached to the C5 and C6 connector clips. On K19 engines, the sensor is on the fuel block just above the fuel pump. On KV engines, the sensor is located next to the fuel shutoff solenoid on the fuel block above the fuel pump. Reference the appropriate engine diagram.

Shop Talk

If there are no other fault codes logged, there is a problem with the fuel supply to the injectors. Reference the appropriate engine symptom troubleshooting chart. An engine surge can cause this fault code to be intermittently active.

Refer to Troubleshooting Fault Code t05-552


Rail Pressure Sensor Circuit or Fuel Rail Pressure Too High

FAULT CODE 554

Rail Pressure Sensor Circuit or Fuel Rail Pressure Too High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 554 PID: P94 FMI: 2 LAMP: On SRT: 00-651 | High or constant voltage detected at rail pressure sensor pin 14 of the main engine harness electronic control module (ECM) connector when the engine speed signal and electronic fuel control return current are low and fluctuating. | Power and engine speed derate.
Rail Pressure Sensor Circuit or Fuel Rail Pressure Too High

Circuit Description

The rail pressure sensor provides the rail pressure signal to the ECM through the main engine harness. The ECM uses the rail pressure signal to monitor the fuel pressure going to the injectors from the fuel pump.

Component Location

The rail pressure sensor is located in a different location for each engine family. On L10 and M11 engines, the sensor is located on the cylinder head above the main engine harness. On NT engines, the sensor is located on the fuel block which is attached to the C5 and C6 connector clips. On K19 engines, the sensor is on the fuel block just above the fuel pump. On KV engines, the sensor is located next to the fuel shutoff solenoid on the fuel block above the fuel pump. Reference the appropriate engine diagram.

Shop Talk

If there are no other fault codes logged, there is a problem with the rail pressure sensor or electronic fuel control valve.

Refer to Troubleshooting Fault Code t05-554


Engine Speed Sensor Circuit (with Frequency Accelerator)

FAULT CODE 115-fa

Engine Speed Sensor Circuit (with Frequency Accelerator)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115-fa PID: 190 FMI: 2 LAMP: Flashing SRT: 00-621 | No engine speed signal detected at the engine speed sensor signal pins 4 and 17 of the main engine harness electronic control module (ECM) connector. | Derate power and engine can run at high idle only.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual coil circuit that provides the engine speed signal to the ECM through the main engine harness.

Component Location

The engine speed sensor is mounted in the flywheel housing on the rear of the engine.

Shop Talk

The coil resistance should be 750 to 1100 ohms for the first coil and 1100 to 1500 ohms for the second coil. The engine speed signal can not be measured accurately with any multimeter.

Refer to Troubleshooting Fault Code t05-115

Last Modified: 04-Apr-2013


Engine Speed Sensor Circuit (with Variable Voltage Accelerator)

FAULT CODE 115-vva

Engine Speed Sensor Circuit (with Variable Voltage Accelerator)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115-vva PID: 190 FMI: 2 LAMP: Flashing SRT: 00-621 | No engine speed signal detected at both pairs of the engine speed sensor signal pins 4 and 17, and pins 18 and 24 of the main engine harness electronic control module (ECM) connector. | Engine can die or derate power and run at high idle only.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual coil circuit that provides the engine speed signal to the ECM through the main engine harness.

Component Location

The engine speed sensor is mounted in the flywheel housing on the rear of the engine.

Shop Talk

The coil resistance should be 750 to 1100 ohms for the first coil and 1100 to 1500 ohms for the second coil. The engine speed signal can not be measured accurately with any multimeter.

Refer to Troubleshooting Fault Code t05-115

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Accelerator Switch)

FAULT CODE 131-as

Accelerator Position Sensor (Accelerator Switch)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131-as PID: P91 FMI: 3 LAMP: Flashing SRT: 00-622 | More than 5.00 VDC detected at accelerator position signal pin 19 of the main engine harness electronic control module (ECM) connector. | Engine will run at high idle only.
Accelerator Position Sensor

Circuit Description

The accelerator switch provides the driver's accelerator command to the ECM through the OEM harness and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator switch location varies with each OEM. Reference the OEM manual.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 04-Apr-2013


Accelerator Position Sensor (CELECT™ Type Accelerator Pedal)

FAULT CODE 131-ctap

Accelerator Position Sensor (CELECT™ Type Accelerator Pedal)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131-ctap PID: P91 FMI: 3 LAMP: Flashing SRT: 00-622 | More than 4.71 VDC detected at accelerator position sensor pin 19 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine can only run at high idle or another constant engine speed.
Accelerator Position Sensor

Circuit Description

The accelerator position sensor provides the driver's accelerator command to the ECM through the OEM harness and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator position sensor is mounted on the accelerator pedal. The accelerator pedal location varies with each OEM. Reference the OEM manual.

Shop Talk

CELECT™-type accelerator

The accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follows:

Between supply and return

  • 2000 to 3000 ohms

Between supply and signal:

  • Released = 1500 to 3000 ohms
  • Depressed = 250 to 1500 ohms

If Fault Code 451 is also active, then check the return line fuse.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Frequency Accelerator)

FAULT CODE 131-fa

Accelerator Position Sensor (Frequency Accelerator)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131-fa PID: P91 FMI: 3 LAMP: Flashing SRT: 00-622 | High frequency detected at accelerator position signal pin 18 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine will run at 1250 rpm only.
Accelerator Position Sensor

Circuit Description

The accelerator pedal provides the driver's accelerator command to the ECM through the OEM control system, OEM harness, and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator signal generator location varies with each OEM. Reference the OEM manual.

Shop Talk

This fault code can only be caused by a problem in the OEM accelerator circuit for this application.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal)

FAULT CODE 131-nctap

Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131-nctap PID: P91 FMI: 3 LAMP: Flashing SRT: 00-622 | High voltage detected at accelerator position signal pin 19 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine can only run at low idle, high idle, or another constant engine speed.
Accelerator Position Sensor

Circuit Description

The accelerator position sensor provides the driver's accelerator command to the ECM through the OEM harness and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator position sensor is mounted on the accelerator pedal or accelerator lever. The accelerator pedal or lever location varies with each OEM. Reference the OEM manual.

Shop Talk

Non-CELECT™-type accelerator

The accelerator position sensor is a potentiometer. The John Deere 8970 has a accelerator lever potentiometer, field cruise potentiometer, and decel switch and potentiometer wired in series as a accelerator position sensor circuit. Only the accelerator lever and field cruise potentiometers are controlled by the operator. The resistance specifications of the John Deere 8970 accelerator lever position sensor are as follows, with the field cruise set to maximum and decel switch released:

Between supply and return:

  • 4000 to 6000 ohms

Between supply and signal:

  • Minimum accelerator = 3800 to 6000 ohms
  • Maximum accelerator = 380 to 900 ohms

The following table lists the maximum accelerator position voltage for each OEM and equipment types with accelerator levers or non-CELECT™-type accelerator pedals:

OEM and Equipment Type | Maximum Accelerator Position Voltage
John Deere tractor | 4.39 VDC
AGCO combine | 4.71 VDC
Komatsu-Dresser haul truck | 4.75 VDC
Unitrig haul truck | 4.75 VDC
Marathon-Letourneau | 4.71 VDC
Wiseda haul truck | 4.75 VDC
Ingersoll-Rand blast drill | 4.71 VDC

If Fault Code 451 is also active, check the return line fuse.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 04-Apr-2013


Accelerator Position Sensor (CELECT™ Type Accelerator Pedal)

FAULT CODE 132-ctap

Accelerator Position Sensor (CELECT™ Type Accelerator Pedal)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132-ctap PID: P91 FMI: 4 LAMP: Flashing SRT: 00-622 | Less than 0.14 VDC detected at accelerator position signal pin 19 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine will only run at low idle or high idle.
Accelerator Position Sensor

Circuit Description

The accelerator pedal provides the driver's accelerator command to the ECM through the OEM harness and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator position sensor is mounted on the accelerator pedal. The accelerator pedal location varies with each OEM. Reference the OEM manual.

Shop Talk

CELECT™-type accelerator

The accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follows:

Between supply and return:

  • Released: 1500 to 3000 ohms

Between supply and signal:

  • Released: 1500 to 3000 ohms
  • Depressed = 250 to 1500 ohms
Refer to Troubleshooting Fault Code t05-132

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Frequency Accelerator)

FAULT CODE 132-fa

Accelerator Position Sensor (Frequency Accelerator)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132-fa PID: P91 FMI: 4 LAMP: Flashing SRT: 00-622 | Low frequency detected at accelerator position signal pin 18 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine will only run at 1250 rpm.
Accelerator Position Sensor

Circuit Description

The accelerator signal generator provides the driver's accelerator command to the ECM through the OEM harness and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator signal generator location varies with each OEM. Reference the OEM manual.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal)

FAULT CODE 132-nctap

Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132-nctap PID: P91 FMI: 4 LAMP: Flashing SRT: 00-622 | Low voltage detected at accelerator position sensor pin 19 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine can only run at low idle, high idle, or another constant engine speed.
Accelerator Position Sensor

Circuit Description

The accelerator pedal or lever provides the driver's accelerator command to the ECM through the OEM harness and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator position sensor is mounted on the accelerator pedal or accelerator lever. The accelerator pedal or lever location varies with each OEM. Reference the OEM manual.

Shop Talk

Non-CELECT™-type accelerator.

The accelerator position sensor is a potentiometer. The John Deere 8970 has a accelerator lever potentiometer, field cruise potentiometer, and decel switch and potentiometer wired in series as a accelerator position sensor circuit. All three can be controlled by the operator. The resistance specifications of the John Deere 8970 accelerator lever position sensor are as follows, with the field cruise set to maximum and decel switch released:

Between supply and return:

  • 4000 to 6000 ohms

Between supply and signal:

  • Minimum accelerator = 3800 to 6000 ohms
  • Maximum accelerator = 380 to 900 ohms

The following table lists the maximum accelerator position voltage for each OEM and equipment types with accelerator levers or non-CELECT™-type accelerator pedals:

OEM and Equipment Type | Minimum Accelerator Position Voltage
John Deere tractor | 0.06 VDC
AGCO combine | 0.14 VDC
Komatsu-Dresser haul truck | 0.25 VDC
Unitrig haul truck | 0.25 VDC
Marathon-Letourneau | 0.10 VDC
Wiseda haul truck | 0.25 VDC
Ingersoll-Rand blast drill | 0.14 VDC
Refer to Troubleshooting Fault Code t05-132

Last Modified: 04-Apr-2013


Accelerator Position Sensor (CELECT™ Type Accelerator Pedal)

FAULT CODE 432-ctap

Accelerator Position Sensor (CELECT™ Type Accelerator Pedal)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432-ctap PID: P91 FMI: 13 LAMP: Flashing SRT: 00-622 | The idle validation signal indicates the accelerator is in the on-idle position when there is a high voltage detected at the accelerator position sensor, or the idle validation signal indicates the accelerator is in the off-idle position when there is a low voltage detected at the accelerator position sensor. | Engine will only run at low idle, high idle, or intermediate speed.
Accelerator Position Sensor

Circuit Description

The accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve. The idle validation signal is a safety feature that disables accelerator control while an improper validation signal is detected by the ECM. The idle validation switch provides an on-idle and off-idle validation signal to the ECM through the OEM harness and main engine harness.

Component Location

The idle validation switch is mounted on the accelerator pedal. The accelerator position sensor is mounted on the accelerator pedal. The accelerator pedal location varies with each OEM. Reference the OEM manual.

Shop Talk

CELECT™- type accelerator

The accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follows:

Between supply and return:

  • 2000 to 3000 ohms

Between supply and signal:

  • Released = 1500 to 3000 ohms
  • Depressed = 250 to 1500 ohms

This fault code is usually caused by the improper wiring of the accelerator circuit, the idle validation circuit, the OEM harness, or the main engine harness.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal)

FAULT CODE 432-nctap

Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432-nctap PID: P91 FMI: 13 LAMP: Flashing SRT: 00-634 | The idle validation signal indicates the accelerator is in the on-idle position when there is a high voltage detected at the accelerator position signal line, or the idle validation signal indicates the accelerator is in the off-idle position when there is a low voltage detected at the accelerator position signal line. | Engine will only run at low idle, high idle, or intermediate speed.
Accelerator Position Sensor

Circuit Description

The accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve. The idle validation signal is a safety feature that disables accelerator control while an improper validation signal is detected by the ECM. The idle validation switch provides an on-idle and off-idle validation signal to the ECM through the OEM harness and main engine harness.

Component Location

The idle validation switch is mounted on the accelerator pedal. The accelerator position sensor is mounted on the accelerator pedal. The accelerator pedal location varies with each OEM. Reference the OEM manual.

Shop Talk

Non-CELECT™-type accelerator

The accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follows:

Between supply and return:

  • 4000 to 6000 ohms

Between supply and signal:

  • Released = 3800 to 6000 ohms
  • Depressed = 380 to 900 ohms

This fault code is usually caused by the improper wiring of the accelerator circuit, the idle validation circuit, the OEM harness, or the main engine harness.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Accelerator Switch)

FAULT CODE 443-as

Accelerator Position Sensor (Accelerator Switch)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443-as PID: S254 FMI: 4 LAMP: Flashing SRT: 00-637 | Low voltage detected at accelerator position sensor positive (+) 5-VDC supply pin 13 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine will only run at low idle.
Accelerator Position Sensor

Circuit Description

The accelerator switch provides the driver's accelerator command to the ECM through the OEM harness and the main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator switch location varies with each OEM. Reference the OEM manual.

Refer to Troubleshooting Fault Code t05-443

Last Modified: 04-Apr-2013


Accelerator Position Sensor (CELECT™ Type Accelerator Pedal)

FAULT CODE 443-ctap

Accelerator Position Sensor (CELECT™ Type Accelerator Pedal)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443-ctap PID: S254 FMI: 4 LAMP: Flashing SRT: 00-637 | Low voltage detected at accelerator position sensor positive (+) 5-VDC supply pin 13 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine can only run at low idle, high idle, or another constant engine speed.
Accelerator Position Sensor

Circuit Description

The accelerator pedal provides the driver's accelerator command to the ECM through the OEM harness and the main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator position sensor is mounted on the accelerator pedal. The accelerator pedal location varies with each OEM. Reference the OEM manual.

Shop Talk

CELECT™-type accelerator

The accelerator position sensor is a potentiometer. The resistance specifications of the accelerator position sensor are as follows:

Between supply and return:

  • 2000 to 3000 ohms

Between supply and signal:

  • Released = 1500 to 3000 ohms
  • Depressed = 250 to 1500 ohms
Refer to Troubleshooting Fault Code t05-443

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Frequency Accelerator)

FAULT CODE 443-fa

Accelerator Position Sensor (Frequency Accelerator)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443-fa PID: S254 FMI: 4 LAMP: Flashing SRT: 00-637 | Low voltage detected at accelerator position sensor positive (+) 5-VDC supply pin 13 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine will run only at 1250 rpm.
Accelerator Position Sensor

Circuit Description

The accelerator pedal provides the driver's accelerator command to the ECM through the OEM control system, OEM harness, and the main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator signal generator location varies with each OEM. Reference the OEM manual.

Refer to Troubleshooting Fault Code t05-443

Last Modified: 04-Apr-2013


Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal)

FAULT CODE 443-nctap

Accelerator Position Sensor (Non-CELECT™ Type Accelerator Pedal)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443-nctap PID: S254 FMI: 4 LAMP: Flashing SRT: 00-637 | Low voltage detected at accelerator position sensor positive (+) 5-VDC supply pin 13 of the main engine harness electronic control module (ECM) connector. | Loss of accelerator control. Engine can only run at low idle, high idle, or another constant engine speed.
Accelerator Position Sensor

Circuit Description

The accelerator position sensor provides the driver's accelerator command to the ECM through the OEM harness and the main engine harness. The ECM uses this signal to determine the fueling command for the electronic fuel control valve.

Component Location

The accelerator position sensor is mounted on the accelerator pedal or accelerator lever. The accelerator pedal location varies with each OEM. Reference the OEM manual.

Shop Talk

Non-CELECT™-type accelerator

The accelerator position sensor is a potentiometer. The John Deere 8970 has a accelerator lever potentiometer, field cruise potentiometer, and decel switch and potentiometer wired in series as a accelerator position sensor circuit. Only the accelerator lever and field cruise potentiometers are controlled by the operator. The resistance specifications of the John Deere 8970 accelerator lever position sensor are as follows, with the field cruise set to maximum and decel switch released:

Between supply and return:

  • 4000 to 6000 ohms

Between supply and signal:

  • Minimum accelerator = 3800 to 6000 ohms
  • Maximum accelerator = 380 to 900 ohms

If Fault Code 451 is also active, then check the return line fuse.

Refer to Troubleshooting Fault Code t05-443

Last Modified: 04-Apr-2013


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Read the fault codes. | Fault Code 111 not logged
 | STEP 1A-1. Check the ECM code version. |
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 111 not logged

Fault Code 111 logged

Appropriate troubleshooting chart

Go to 1A-1

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A-1 - Check the ECM code version.

Conditions

  • Turn keyswitch ON.

Action

Check ECM code version.

  • Read the ECM code in the ECM dataplate using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

ECM code is Phase 3 or 4

Replace the ECM.

Calibrate the ECM with Phase 3 or 4 ECM code.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 111 is inactive.
OK NOT OK

Fault Code 111 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437 or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic STC solenoid. |
 | STEP 1A. Verify the electronic STC solenoid is connected to the main engine harness. | Electronic STC solenoid connected
 | STEP 1B. Check for jumper wires on the electronic STC solenoid. | No jumper wires
 | STEP 1C. Inspect the electronic STC solenoid and main engine harness terminals. | No damaged terminals
 | STEP 1D. Check for an open circuit. | 12-VDC solenoid = 6 to 10 ohms; 24-VDC solenoid = 26 to 40 ohms
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 113 inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the electronic STC solenoid.

Guided Step 1A - Verify the electronic STC solenoid is connected to the main engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the electronic STC solenoid.

  • Verify the electronic STC solenoid is connected to the main engine harness.
OK NOT OK

Electronic STC solenoid connected

Connect the electronic STC solenoid to the main engine harness

Reference the appropriate base engine troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check for jumper wires on the electronic STC solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for jumper wires.

  • Check for jumper wires on the electronic STC solenoid.
OK NOT OK

No jumper wires

Remove jumper wires

Remove any jumper wires from the electronic STC solenoid.

Go to 1C

Go to 3A

Guided Step 1C - Inspect electronic STC solenoid and main engine harness terminals.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic STC solenoid from the main engine harness.

Action

Inspect electronic STC solenoid and main engine harness terminals for the following:

  • Loose connections
  • Corroded terminals
  • Broken or frayed wires.
OK NOT OK

No damaged terminals

Repair the damaged terminals

Repair or replace the main engine harness or the STC solenoid, whichever has the damaged terminals.

  • Repair the main engine harness. Refer to Procedure 019-228.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the electronic STC solenoid. Reference the appropriate base engine troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic STC solenoid from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the electronic STC solenoid terminal post to engine block ground.
OK NOT OK

12-VDC solenoid = 6 to 10 ohms; 24-VDC solenoid = 26 to 40 ohms

Replace the electronic STC solenoid

Reference the appropriate base engine troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-228.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic STC solenoid from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 20 of the main engine harness ECM connector to the main engine harness electronic STC solenoid terminal.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-228.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 20 of the main engine harness ECM connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-228.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 113 is inactive.
OK NOT OK

Fault Code 113 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic STC solenoid. |
 | STEP 1A. Check for jumper wires on the STC solenoid. | No jumper wires
 | STEP 1B. Inspect the electronic STC solenoid and main engine harness terminals. | No damaged terminals
 | STEP 1C. Check for a short circuit to ground. | 6 to 10 ohms (12-VDC systems); 26 to 40 ohms (24-VDC systems)
 | STEP 1D. Verify Fault Code 114 is still active with the electronic STC solenoid disconnected. | Fault Code 114 active
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 114 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the electronic STC solenoid.

Guided Step 1A - Check for jumper wires on the STC solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for jumper wires.

  • Check for jumper wires on the electronic STC solenoid.
OK NOT OK

No jumper wires

Remove any jumper wires from the electronic STC solenoid.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the electronic STC solenoid and main engine harness terminals.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic STC solenoid from the main engine harness.

Action

Inspect the electronic STC solenoid and main engine harness terminals for the following:

  • Frayed wires
  • Corroded terminals
  • Bent or broken terminals.
OK NOT OK

No damaged terminals

Repair the damaged terminals

Repair or replace the main engine harness or the STC solenoid, whichever has the damaged terminals.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the electronic STC solenoid. Reference the appropriate base engine troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic STC solenoid from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the electronic STC solenoid terminal post to engine block ground.
OK NOT OK

6 to 10 ohms (12-VDC systems); 26 to 40 ohms (24-VDC systems)

Replace the electronic STC solenoid

Reference the appropriate base engine troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Verify Fault Code 114 is still active with the electronic STC solenoid disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the electronic STC solenoid from the main engine harness.

Action

Verify Fault Code 114 is still active with the electronic STC solenoid disconnected.

  • Start the engine and idle for one minute.
  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
  • NOTE: Fault Code 113 can be active when the electronic STC solenoid is disconnected.
OK NOT OK

Fault Code 114 active

Replace the electronic STC solenoid

Reference the appropriate base engine troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic STC solenoid from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 20 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic STC solenoid from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 20 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 114 is inactive.
OK NOT OK

Fault Code 114 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the engine speed sensor and main engine harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 115 active
 | STEP 1C. Check for an open circuit. | First coil: 750 to 1100 ohms; Second coil: 1100 to 1500 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1F. Inspect engine speed sensor. | No damaged engine speed sensor
 | STEP 1G. Verify Fault Code 115 is still active. | Fault Code 115 active
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 115 active
 | STEP 2C. Check for an open circuit. | Less than 1500 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 115 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the engine speed sensor and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine speed sensor and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the engine speed sensor. Refer to Procedure 019-201 and Refer to Procedure 019-202.
  • Replace the engine speed sensor. Refer to Procedure 019-042.

1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 115 active

Repair complete.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the first engine speed sensor coil to pin B of the first engine speed sensor coil.
  • Measure the resistance from pin A of the second engine speed sensor coil to pin B of the second engine speed sensor coil.
OK NOT OK

First coil: 750 to 1100 ohms.

Second coil: 1100 to 1500 ohms

Replace the engine speed sensor.

Refer to Procedure 019-042.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the first engine speed sensor coil to engine block ground.
  • Measure the resistance from pin A of the second engine speed sensor coil to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine speed sensor.

Refer to Procedure 019-042.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the first engine speed sensor coil to pin A of second engine speed sensor coil.
OK NOT OK

More than 100k ohms

Replace the engine speed sensor.

Refer to Procedure 019-042.

Go to 1F

Go to 3A

Guided Step 1F - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.
  • Remove the engine speed sensor from the flywheel housing.

Action

Inspect the engine speed sensor for the following:

  • Cracked potting
  • Extruded potting
  • Damage on end of sensor
  • Metal debris on the end of the sensor.
OK NOT OK

No damaged engine speed sensor

Replace the engine speed sensor.

Refer to Procedure 019-042.

Go to 1G

Go to 3A

Guided Step 1G - Verify Fault Code 115 is still active.

Conditions

  • Turn keyswitch OFF.
  • Install the engine speed sensor in the flywheel housing.
  • Connect the engine speed sensor to the main engine harness.

Action

Verify Fault Code 115 is still active.

  • Start the engine and idle for one minute.
  • Read fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 115 active

Malfunction corrected.

The engine speed sensor was improperly adjusted. Clear the fault codes.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 115 active

Repair complete.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Connect the engine speed sensor to the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to pin 17 of the main engine harness ECM connector.
OK NOT OK

Less than 1500 ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 17 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 115 is inactive.
OK NOT OK

Fault Code 115 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the engine speed sensor and main engine harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 115 active
 | STEP 1C. Check for an open circuit. | First coil: 750 to 1100 ohms; Second coil: 1100 to 1500 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1F. Inspect the engine speed sensor. | No damaged engine speed sensor
 | STEP 1G. Verify Fault Code 115 is still active. | Fault Code 115 active
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 115 active
 | STEP 2C. Check for an open circuit. | Less than 1500 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 115 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the engine speed sensor and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine speed sensor and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the engine speed sensor. Refer to Procedure 019-201 and Refer to Procedure 019-202.
  • Replace the engine speed sensor. Refer to Procedure 019-042.

1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 115 active

Repair complete.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the first engine speed sensor coil to pin B of the first engine speed sensor coil.
  • Measure the resistance from pin A of the second engine speed sensor coil to pin B of the second engine speed sensor coil.
OK NOT OK

First coil: 750 to 1100 ohms; Second coil: 1100 to 1500 ohms

Replace the engine speed sensor.

Refer to Procedure 019-042.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the first engine speed sensor coil to engine block ground.
  • Measure the resistance from pin A of the second engine speed sensor coil to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine speed sensor.

Refer to Procedure 019-042.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the first engine speed sensor coil to pin A of second engine speed sensor coil.
OK NOT OK

More than 100k ohms

Replace the engine speed sensor.

Refer to Procedure 019-042.

Go to 1F

Go to 3A

Guided Step 1F - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.
  • Remove the engine speed sensor from the flywheel housing.

Action

Inspect the engine speed sensor for the following:

  • Cracked potting
  • Extruded potting
  • Damage on end of sensor
  • Metal debris on the end of the sensor.
OK NOT OK

No damaged engine speed sensor

Replace the engine speed sensor.

Refer to Procedure 019-042.

Go to 1G

Go to 3A

Guided Step 1G - Verify Fault Code 115 is still active.

Conditions

  • Turn keyswitch OFF.
  • Install the engine speed sensor in the flywheel housing.
  • Connect the engine speed sensor to the main engine harness.

Action

Verify Fault Code 115 is still active.

  • Start the engine and idle for one minute.
  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 115 active

Malfunction corrected.

The engine speed sensor was improperly adjusted. Clear the fault codes.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 115 active

Repair complete.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Connect the engine speed sensor to the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to pin 17 of the main engine harness ECM connector.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to pin 24 of the main engine harness ECM connector.
OK NOT OK

Less than 1500 ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 24 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 17 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 24 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 115 is inactive.
OK NOT OK

Fault Code 115 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the engine speed sensor and main engine harness connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 121 active
 | STEP 1C. Check for an open circuit. | First coil: 750 to 1100 ohms; Second coil: 1100 to 1500 ohms
 | STEP 1D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1F. Inspect the engine speed sensor. | No damaged engine speed sensor
 | STEP 1G. Verify Fault Code 121 is still active. | Fault Code 121 active
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 121 active
 | STEP 2C. Check for an open circuit. | Less than 1500 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the engine speed sensor and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine speed sensor and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the engine speed sensor. Refer to Procedure 019-201 and Refer to Procedure 019-202.
  • Replace the engine speed sensor. Refer to Procedure 019-042.

1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 121 active

Repair complete.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the first engine speed sensor coil to pin B of the first engine speed sensor coil.
  • Measure the resistance from pin A of the second engine speed sensor coil to pin B of the second engine speed sensor coil.
OK NOT OK

First coil: 750 to 1100 ohms; Second coil: 1100 to 1500 ohms

Replace the engine speed sensor

Refer to Procedure 019-042.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the first engine speed sensor coil to engine block ground.
  • Measure the resistance from pin A of the second engine speed sensor coil to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine speed sensor

Refer to Procedure 019-042.

Go to 1E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823996 - female Weather-Pack test lead.
Guided Step 1E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the first engine speed sensor coil to pin A of second engine speed sensor coil.
OK NOT OK

More than 100k ohms

Replace the engine speed sensor

Refer to Procedure 019-042.

Go to 1F

Go to 3A

Guided Step 1F - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.
  • Remove the engine speed sensor from the flywheel housing.

Action

Inspect the engine speed sensor for the following:

  • Cracked potting
  • Extruded potting
  • Damage on end of sensor
  • Metal debris on the end of the sensor.
OK NOT OK

No damaged engine speed sensor

Replace the engine speed sensor

Refer to Procedure 019-042.

Go to 1G

Go to 3A

Guided Step 1G - Verify Fault Code 121 is still active.

Conditions

  • Turn keyswitch OFF.
  • Install the engine speed sensor in the flywheel housing.
  • Connect the engine speed sensor to the main engine harness.

Action

Verify Fault Code 121 is still active.

  • Start the engine and idle for one minute.
  • Read fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 121 active

Malfunction corrected

The engine speed sensor was improperly adjusted. Clear the fault codes.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 115 active

Repair complete.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Connect the engine speed sensor to the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to pin 17 of the main engine harness ECM connector.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to pin 24 of the main engine harness ECM connector.
OK NOT OK

Less than 1500 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 24 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the engine speed sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 4 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 17 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 24 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM manual for more details.) |
 | STEP 1A. Inspect the OEM harness and main engine harness connector pins. | No damaged pins
 | STEP 1B. Verify Fault Code 131 is inactive with the OEM harness disconnected. | Fault Code 131 inactive
 | STEP 1C. Check for a short from pin to pin. | More than 100k ohms
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 131 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 1A - Inspect the OEM harness and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Verify Fault Code 131 is inactive with the OEM harness disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Verify Fault Code 131 is inactive with the OEM harness disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
  • NOTE: Fault Code 132 can be active with the OEM harness disconnected at the C6 connector.
OK NOT OK

Fault Code 131 inactive

Remove the external voltage source

Repair or replace the OEM harness or accelerator switch, whichever has the external voltage source.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator switch. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator switch. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Set the accelerator switch to the IDLE position.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator switch. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator switch. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active Fault Code 451. |
 | STEP 1A. Read the fault codes. | Fault Code 451 inactive
 | STEP 1A-1. Inspect the main engine harness return line fuse. |
 | STEP 1A-2. Check the return line fuse. |
STEP 2. | Check the accelerator position sensor. |
 | STEP 2A. Inspect the OEM harness and accelerator position sensor connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the main engine harness and OEM harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 3C. Check for a short from pin to pin. | More than 100k ohms
 | STEP 3D. Verify Fault Code 131 is still active. | Fault Code 131 active
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 131 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active Fault Code 451.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 451 inactive

Check the return line fuse.

A blown return line fuse in the main engine harness can cause both Fault Codes 131 and 451 to be active.

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Inspect the main engine harness return line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the return line fuse from the main engine harness.

Action

Inspect the main engine harness return line fuse for the following:

  • Loose connections
  • Corroded connections
  • Bent or broken connections
  • Moisture in or on the connections.
OK NOT OK

No damaged connections

Repair the damaged connections.

Repair or replace the main engine harness or replace the main engine harness return line fuse, whichever has the damaged connections.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness return line fuse. Refer to Procedure 019-198.

Go to 1A-2

Go to 5A

Guided Step 1A-2 - Check the return line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the return line fuse from the main engine harness.

Action

Check the return line fuse.

  • Measure the resistance of the fuse.
OK NOT OK

Less than 10 ohms

Replace the fuse.

Refer to Procedure 019-198.

Go to 2A

Go to 5A

Guided Step 2 - Check the accelerator position sensor.

Guided Step 2A - Inspect the OEM harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and throttle position sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the accelerator position sensor to pin C of the accelerator position sensor.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal.

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the accelerator position sensor to pin C of the accelerator position sensor.
  • NOTE: Measure when pedal is depressed and again when pedal is released.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal.

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the main engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and OEM harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Connect the accelerator pedal to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C6 connector to pin B of the OEM harness C6 connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal.

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 5A

Guided Step 3D - Verify Fault Code 131 is still active.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Verify Fault Code 131 is still active.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.

NOTE: Fault Code 132 will be active with OEM harness disconnected at C6 connector.
OK NOT OK

Fault Code 131 active

Remove the external voltage source.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 of the main engine harness ECM connector to pin B of the main engine harness C6 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 27 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator circuit. |
 | STEP 1A. Read the fault codes. | Fault Code 131 not logged
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 131 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator circuit.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 131 not logged

Repair or replace the OEM accelerator circuit.

  • Repair the OEM accelerator circuit. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM accelerator circuit. Reference the OEM troubleshooting and repair manual.

Appropriate troubleshooting charts

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549, Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 451. |
 | STEP 1A. Read the fault codes. | Fault Code 451 inactive
 | STEP 1A-1. Inspect the main engine harness return line fuse. |
 | STEP 1A-2. Check the return line fuse. |
STEP 2. | Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM manual for more details.) |
 | STEP 2A. Inspect the main engine harness and OEM harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 4000 to 6000 ohms
 | STEP 2C. Check for a short circuit to supply. | More than 300 ohms
 | STEP 2D. Check for a short from pin to pin. | More than 100k ohms
 | STEP 2E. Verify Fault Code 131 is still active with the OEM harness disconnected. | Fault Code 131 active
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for Fault Code 451.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 451 inactive

Check the return line fuse.

A blown return line fuse in the main engine harness can cause both Fault Codes 131 and 451 to be active.

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Inspect the main engine harness return line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the return line fuse from the main engine harness.

Action

Inspect the main engine harness return line fuse for the following:

  • Loose connections
  • Corroded connections
  • Bent or broken connections
  • Moisture in or on the connections.
OK NOT OK

No damaged connections

Repair or replace the main engine harness or replace main engine harness return line fuse, whichever has the damaged connections.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness return line fuse. Refer to Procedure 019-198.

Go to 1A-2

Go to 4A

Guided Step 1A-2 - Check the return line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the return line fuse from the main engine harness.

Action

Check the return line fuse.

  • Measure the resistance of the fuse.
OK NOT OK

Less than 10 ohms

Replace the fuse.

Refer to Procedure 019-198.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 2A - Inspect the OEM harness and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C6 connector to pin B of the OEM harness C6 connector.
OK NOT OK

4000 to 6000 ohms

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator lever. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator lever. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to supply.

  • Measure the resistance from pin E of the OEM harness C6 connector to pin D of the OEM harness C6 connector.
OK NOT OK

More than 300 ohms

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator lever. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator lever. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal or accelerator lever from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator lever. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator lever. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

Guided Step 2E - Verify Fault Code 131 is still active with the OEM harness disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Verify Fault Code 131 is still active with the OEM harness disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.

NOTE: Fault Code 132 will be active with the OEM harness disconnected at the C6 connector.
OK NOT OK

Fault Code 131 active

Remove the external voltage source.

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the external voltage source.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator lever. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator lever. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 of the main engine harness ECM connector to pin B of the main engine harness C6 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 27 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 443 not logged
STEP 2. | Check the accelerator position sensor. |
 | STEP 2A. Verify the accelerator position sensor is connected to the OEM harness. | Accelerator position sensor connected
 | STEP 2B. Inspect the OEM harness and accelerator position sensor connector pins. | No damaged pins
 | STEP 2C. Check for an open circuit. | Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | 2000 to 3000 ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the main engine harness and OEM harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 132 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 443 not logged

Troubleshoot Fault Code 443.

Go to 2A

Fault Code 443

Guided Step 2 - Check the accelerator position sensor.

Guided Step 2A - Verify the accelerator position sensor is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the throttle position sensor.

  • Verify the throttle position sensor is connected to the OEM harness.
OK NOT OK

Accelerator position sensor connected.

Connect the accelerator position sensor to the OEM harness connector.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the OEM harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and throttle position sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the accelerator position sensor to pin B of the accelerator position sensor.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal.

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the accelerator position sensor to pin C of the accelerator position sensor.
  • NOTE: Measure when pedal is depressed and again when pedal is released.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal.

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the main engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine harness and OEM harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Connect the accelerator pedal to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C6 connector to pin D of the OEM harness C6 connector.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 250 to 1500 ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the accelerator pedal to the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin D of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to pin E of the main engine harness C6 connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to pin D of the main engine harness C6 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4D

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 132 is inactive.
OK NOT OK

Fault Code 132 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test lead Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 443 not logged
STEP 2. | Check the OEM harness and accelerator signal generator. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 2A. Inspect the OEM and main engine harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 800 to 1200 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE ™, Part Number 3824638.
OK NOT OK

Fault Code 443 not logged

Troubleshoot Fault Code 443.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the OEM harness and accelerator signal generator.(The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 2A - Inspect the OEM and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C6 connector to pin D of the OEM harness C6 connector.
OK NOT OK

800 to 1200 ohms

Repair or replace the OEM harness or the accelerator signal generator, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator signal generator. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator signal generator. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin D of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or the accelerator signal generator, whichever has the short circuit to ground.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator signal generator. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator signal generator. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test lead Part Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal or accelerator lever from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors, except pin E of the OEM harness C6 connector.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors, except pin D of the OEM harness C6 connector.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or the accelerator signal generator, whichever has the short circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator signal generator. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator signal generator. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to pin E of the main engine harness C6 connector.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to pin D of the main engine harness C6 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for short circuit to ground.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 18 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 132 is inactive.
OK NOT OK

Fault Code 132 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 443 not logged
STEP 2. | Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM manual for more details.) |
 | STEP 2A. Inspect the OEM harness and main engine harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 6000 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE ™, Part Number 3824638.
OK NOT OK

Fault Code 443 not logged

Troubleshoot Fault Code 443

See Fault Code 443 troubleshooting tree.

Go to 2A

Fault Code 443

Guided Step 2 - Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 2A - Inspect the OEM harness and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3284510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C6 connector to pin D of the OEM harness C6 connector.
OK NOT OK

Less than 6000 ohms

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator lever. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator lever. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin D of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator lever. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator lever. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal or accelerator lever from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator lever. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator lever. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to pin E of the main engine harness C6 connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to pin D of the main engine harness C6 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 132 is inactive.
OK NOT OK

Fault Code 132 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active Fault Code 135. |
 | STEP 1A. Read the fault codes. | Fault Code 451 inactive
 | STEP 1A-1. Inspect the main engine harness return line fuse. |
 | STEP 1A-2. Check the return line fuse. |
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the oil pressure sensor and OEM harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 135 active
 | STEP 2C. Verify Fault Code 135 is still active with the oil pressure sensor disconnected. | Fault Code 135 active
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 3A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 135 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for external voltage. | Less than 1.0 VDC
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Read the fault codes. | Fault Code 135 active
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 135 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active Fault Code 135.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 451 inactive

Check the return line fuse

A blown return line fuse in the main engine harness can cause both Fault Codes 135 and 451 to be active.

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Inspect the main engine harness return line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the return line fuse from the main engine harness.

Action

Inspect the main engine harness return line fuse for the following:

  • Loose connections
  • Corroded connections
  • Bent or broken connections
  • Moisture in or on the connections.
OK NOT OK

No damaged connections

Repair the damaged connections

Repair or replace the main engine harness or replace the main engine harness return line fuse, whichever has the damaged connections.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness return line fuse. Refer to Procedure 019-198.

Go to 1A-2

Go to 5A

Guided Step 1A-2 - Check the return line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the return line fuse from the main engine harness.

Action

Check the return line fuse.

  • Measure the resistance of the fuse.
OK NOT OK

Less than 10 ohms

Replace the fuse

Refer to Procedure 019-198.

Go to 2A

Go to 5A

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the oil pressure sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the oil pressure sensor and OEM harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the OEM harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the oil pressure sensor. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 135 active

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Verify Fault Code 135 is still active with the oil pressure sensor disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the oil pressure sensor from the OEM harness.

Action

Verify Fault Code 135 is still active with the oil pressure sensor disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 135 active

Replace the oil pressure sensor

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 3A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 135 active

Repair complete.

Go to 3C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the oil pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin J of the OEM harness C5 connector to pin B of the OEM harness oil pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the OEM harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the OEM harness C5 connector to all other pins of the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin B of the OEM harness C5 connector to all other pins of the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3E

Go to 5A

Guided Step 3E - Check for external voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the oil pressure sensor from the OEM harness.

Action

Check for external voltage.

  • Measure the DC voltage from pin A of the OEM harness C5 connector to engine block ground.
  • Measure the DC voltage from pin B of the OEM harness C5 connector to engine block ground.
OK NOT OK

Less than 1.0 VDC

Remove the external voltage source

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

Guided Step 4B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 135 active

Repair complete.

Go to 4C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 of the main engine harness ECM connector to pin J of the main engine harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4D

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 15 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and idle for one minute.
  • Verify Fault Code 135 is inactive.
OK NOT OK

Fault Code 135 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test leadPart Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 444 not logged
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Verify the oil pressure sensor is connected. | Oil pressure sensor is connected
 | STEP 2B. Inspect the oil pressure sensor and OEM harness connector pins. | No damaged pins
 | STEP 2C. Read the fault codes. | Fault Code 141 active
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check the supply voltage. | 4.75 to 5.25 VDC
 | STEP 2E-1. Check the supply voltage with the sensor disconnected. |
 | STEP 2F. Check the signal voltage. | 0.42 to 0.58 VDC
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 3A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 141 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Read the fault codes. | Fault Code 141 active
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 141 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 444 not logged

Fault Code 444 is active

Troubleshoot active Fault Code 444.

Go to 2A

Fault Code 444

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Verify the oil pressure sensor is connected.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil pressure sensor.

  • Verify the oil pressure sensor is connected.
OK NOT OK

Oil pressure sensor is connected

Connect the oil pressure sensor to the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the oil pressure sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the oil pressure sensor and OEM harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the OEM harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the oil pressure sensor. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 141 active

Repair complete.

Go to 2D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the oil pressure sensor to engine block ground.
  • Measure the resistance from pin B of the oil pressure sensor to engine block ground.
  • Measure the resistance from pin C of the oil pressure sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the oil pressure sensor

Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
Guided Step 2E - Check the supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the oil pressure sensor from the OEM harness.

Action

Check the supply voltage.

  • Install the breakout cable, Part Number 3824775, between the sensor and the OEM harness connector.
  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) leads into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Not 4.75 to 5.25 VDC

Go to 2F

Go to 2E-1

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
Guided Step 2E-1 - Check the supply voltage with the sensor disconnected.

Conditions

  • Turn keyswitch ON.

Action

Check the supply voltage with the sensor disconnected.

  • Install the breakout cable, Part Number 3824775, to the sensor harness. Do not connect the sensor.
  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) leads into the multimeter.
OK NOT OK

4.75 to 5.25 VDC

Replace the oil pressure sensor.

Reference the OEM troubleshooting and repair manual.

OEM harness or ECM failure

Troubleshoot the OEM harness or ECM. Reference the OEM troubleshooting and repair manual.

Go to 5A

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824775 - breakout cable.
Guided Step 2F - Check the signal voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Install the breakout cable, Part Number 3824775, between the sensor and the OEM harness connector.
  • Measure the supply voltage by installing the breakout cable's signal (pin C) and return (pin B) leads into the multimeter.
OK NOT OK

0.42 to 0.58 VDC

Replace the oil pressure sensor

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 3A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 141 active

Repair complete.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the oil pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the OEM harness C5 connector to pin A of the OEM harness oil pressure sensor connector.
  • Measure the resistance from pin B of the OEM harness C5 connector to pin C of the OEM harness oil pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the OEM harness from the oil pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the OEM harness C5 connector to engine block ground.
  • Measure the resistance from pin B of the OEM harness C5 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3E

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the OEM harness from the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the OEM harness C5 connector to all other pins of the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin B of the OEM harness C5 connector to all other pins of the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

Guided Step 4B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 141 active

Repair complete.

Go to 4C

Go to 5B

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to pin A of the main engine harness C5 connector.
  • Measure the resistance from pin 15 of the main engine harness ECM connector to pin B of the main engine harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 4D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 15 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4E

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 4E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 15 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 141 is inactive.
OK NOT OK

Fault Code 141 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Verify the coolant temperature sensor is connected. | Coolant temperature sensor is connected
 | STEP 1B. Inspect the OEM harness and coolant temperature sensor connector pins. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault Code 144 active
 | STEP 1D. Check for a short circuit. | More than 500 ohms
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.) |
 | STEP 2A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 144 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for external voltage. | Less than 1.0 VDC
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 144 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant temperature sensor.

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1A - Verify the coolant temperature sensor is connected.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant temperature sensor.

  • Verify the coolant temperature sensor is connected.
OK NOT OK

Coolant temperature sensor is connected

Connect the coolant temperature sensor to the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1B - Inspect the OEM harness and coolant temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and coolant temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Moisture in or on connector
  • Pushed back or expanded pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the OEM harness or the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the coolant temperature sensor. Reference the OEM troubleshooting and repair manual.
  • Replace the coolant temperature sensor. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 144 is active

Repair complete.

Go to 1D

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 1D - Check for a short circuit.

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor from the OEM harness.

Action

Check supply voltage.

  • Measure the resistance from pin A of the coolant temperature sensor to pin B of the coolant temperature sensor.
OK NOT OK

More than 500 ohms

Replace the coolant temperature sensor

Refer to Procedure 019-019.

Go to 2A

Go to 2A

Guided Step 2 - Check the OEM harness (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.)

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 2A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Moisture in or on connector
  • Pushed back or expanded pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 144 is active

Repair complete.

Go to 2C

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C5 connector to pin A of the OEM harness coolant temperature sensor connector.
  • Measure the resistance from pin H of the OEM harness C5 connector to pin B of the OEM harness coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin E of the OEM harness C5 connector to all other pins of the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2E - Check for external voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.

Action

Check for external voltage.

  • Measure the DC voltage from pin E of the OEM harness C5 connector to engine block ground.
OK NOT OK

Less than 1.0 VDC

Remove the external voltage source

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Moisture in or on connector
  • Pushed back or expanded pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 144 is active

Repair complete.

Go to 3C

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for an open circuit.

  • Measure the resistance from pin 5 of the main engine harness ECM connector to pin E of the main engine harness C5 connector.
  • Measure the resistance from pin 25 of the main engine harness ECM connector to pin H of the main engine harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 144 is inactive.
OK NOT OK

Fault Code 144 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the OEM harness and coolant temperature sensor connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 145 active
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.) |
 | STEP 2A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 145 active
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 145 active
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Verify Fault Code 145 is still active with the coolant temperature sensor disconnected. | Fault Code 145 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant temperature sensor.

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1A - Inspect the OEM harness and coolant temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and coolant temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Moisture in or on connector
  • Pushed back or expanded pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the OEM harness or the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the coolant temperature sensor. Reference the OEM troubleshooting and repair manual.
  • Replace the coolant temperature sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault code 145 is active

Repair complete.

Go to 1C

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the coolant temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.)

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 2A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Moisture in or on connector
  • Pushed back or expanded pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 145 is active

Repair complete.

Go to 2C

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the coolant temperature sensor from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E of the OEM harness C5 connector to engine block ground.
OK NOT OK

More than 100K ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the coolant temperature sensor from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin E of the OEM harness C5 connector to all other pins in the C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Moisture in or on connector
  • Pushed back or expanded pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 145 is active

Repair complete.

Go to 3C

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 5 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 3E - Verify Fault Code 145 is still active with the coolant temperature sensor disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor from the OEM harness.

Action

Verify Fault Code 145 is still active with the coolant temperature sensor disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549, Echek™, Part Number 3824437 or INSITE™, Part Number 3824638.

NOTE: Fault Code 144 can be active when the coolant temperature sensor is disconnected.
OK NOT OK

Fault Code 145 inactive

Replace the ECM

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 145 is inactive.
OK NOT OK

Fault Code 145 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

WARNING

Do not remove the pressure cap or coolant temperature sensor from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM code. |
 | STEP 1A. Check the ECM code. | ECM code is Phase 3 or 4
STEP 2. | Identify reason for overspeed. |
 | STEP 2A. Check for proper operating conditions. | Not motoring downhill
 | STEP 2B. Check for an alternate fuel source. | No alternate fuel source
 | STEP 2C. Inspect the main engine harness and engine speed sensor connector pins. | No damaged pins
 | STEP 2D. Read the fault codes. | Fault Code 234 active
 | STEP 2E. Check rpm with monitor mode. | Correct rpm reading
 | STEP 2F. Check for active fault at low rpm. | Fault Code 234 inactive at low rpm
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 234 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM code.

Guided Step 1A - Check the ECM code.

Conditions

  • Turn keyswitch ON.

Action

Check the ECM code.

  • Read the ECM code in the ECM data plate using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

ECM is Phase 3 or 4

Calibrate the ECM with Phase 3 or 4 ECM code

Go to 2A

Go to 3A

Guided Step 2 - Identify reason for overspeed.

Guided Step 2A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if engine was motoring downhill when fault was logged.
OK NOT OK

Not motoring downhill

Electronics are OK

Check the base engine for damage due to overspeed condition.

Go to 2B

Go to 3A

Guided Step 2B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if driver reported a fuel-controlled event where engine rapidly accelerated.
OK NOT OK

No alternate fuel source

Locate alternate fuel source

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the main engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and engine speed sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the engine speed sensor. Refer to Procedure 019-042.
  • Replace the engine speed sensor. Refer to Procedure 019-042.

Go to 2D

Go to 2D

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 234 is active

Repair complete.

Go to 2E

Go to 3A

Guided Step 2E - Check for rpm with monitor mode.

Conditions

  • Connect the engine speed sensor to the main engine harness.

Action

Check for rpm with monitor mode.

  • Start the engine and idle.
  • Monitor engine rpm using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
  • Compare the monitored engine speed with the engine speed on the tachometer.
OK NOT OK

Correct rpm reading

Repair or replace the engine speed sensor

  • Repair the engine speed sensor. Refer to Procedure 019-042.
  • Replace the engine speed sensor. Refer to Procedure 019-042.

Go to 2F

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2F - Check for active fault at low rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault at low rpm.

  • Check for active Fault Code 234 when engine is not running overspeed.
OK NOT OK

Fault Code 234 inactive at low rpm

Replace the ECM

Refer to Procedure 019-031.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 234 is inactive.
OK NOT OK

Fault Code 234 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Read the ECM dataplate. | Phase 3 calibration or later
STEP 2. | Check the auxiliary shutdown solenoid. |
 | STEP 2A. Check for jumper wires on the auxiliary shutdown solenoid. | No jumper wires
 | STEP 2B. Inspect the auxiliary shutdown solenoid and OEM harness connection. | No damaged connection
 | STEP 2C. Check for a short circuit to ground. | 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.) |
 | STEP 3A. Inspect the OEM harness and main engine harness connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 254 active
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Read the fault codes. | Fault Code 254 active
 | STEP 4C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4E. Verify Fault Code 254 is still active with the auxiliary shutdown solenoid disconnected. | Fault Code 254 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 254 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Read the ECM dataplate.

Conditions

  • Turn keyswitch ON.

Action

Check the ECM dataplate for the ECM code identifying the calibration.

NOTE: The ECM dataplate is located on the outer surface of the ECM housing.

OK NOT OK

Phase 3 calibration or later

Calibrate the ECM using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™ electronic service tool, Part Number 3824638. See the appropriate electronic service tool user's manual for detailed ECM calibration procedures.

Go to 2A

Go to 5A

Guided Step 2 - Check the auxiliary shutdown solenoid.

Guided Step 2A - Check for jumper wires on the auxiliary shutdown solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for jumper wires.

  • Check for jumper wires on the auxiliary shutdown solenoid.
OK NOT OK

No jumper wires

Remove any jumper wires from the auxiliary shutdown solenoid.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the auxiliary shutdown solenoid and OEM harness connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary shutdown solenoid from the OEM harness.

Action

Inspect the auxiliary shutdown solenoid and OEM harness connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361.
OK NOT OK

No damaged connections

Repair the damaged connections

Repair or replace the OEM harness or the auxiliary shutdown solenoid, whichever has the damaged connections.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the auxiliary shutdown solenoid. Reference the OEM troubleshooting and repair manual.
  • Replace the auxiliary shutdown solenoid. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the shutoff solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance from the fuel shutoff solenoid post to engine block ground.
OK NOT OK

1 to 5 ohms for 6-VDC solenoids

6 to 15 ohms for 12-VDC solenoids

24 to 50 ohms for 24-VDC solenoids

42 to 80 ohms for 32-VDC solenoids

46 to 87 ohms for 36-VDC solenoids

92 to 145 ohms for 48-VDC solenoids

315 to 375 ohms for 74-VDC solenoids

645 to 735 ohms for 115-VAC solenoids

Replace the fuel shutoff solenoid

Refer to Procedure 019-050.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.)

Guided Step 3A - Inspect the OEM harness and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™ electronic service tool, Part Number 3824638.
OK NOT OK

Fault Code 254 is active

Repair complete.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the auxiliary shutdown solenoid from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin F of the OEM harness C6 connector to engine block ground.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the auxiliary shutdown solenoid from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin F of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

Guided Step 4B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™ electronic service tool, Part Number 3824638.
OK NOT OK

Fault Code 254 is active

Repair complete.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the main engine harness ECM connector to engine block ground.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4D

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 1 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4E

Go to 5A

Guided Step 4E - Verify Fault Code 254 is still active with the auxiliary shutdown solenoid disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the auxiliary shutdown solenoid from the OEM harness.

Action

Verify Fault Code 254 is still active with the auxiliary shutdown solenoid disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437 or INSITE™, Part Number 3824638.

NOTE: Fault Code 255 can be active when the auxiliary shutdown solenoid is disconnected.

OK NOT OK

Replace the ECM

Refer to Procedure 019-031.

Fault Code 254 active

Replace the auxiliary shutdown solenoid.

Reference the OEM troubleshooting and repair manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 254 is inactive.
OK NOT OK

Fault Code 254 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437 or INSITE™ electronic service tool, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Read the ECM dataplate. | Phase 3 calibration or later
STEP 2. | Check the auxiliary shutdown solenoid. |
 | STEP 2A. Verify the auxiliary shutdown solenoid is connected to the OEM harness. | Auxiliary shutdown solenoid connected
 | STEP 2B. Check for jumper wires on the auxiliary shutdown solenoid. | No jumper wires
 | STEP 2C. Inspect the auxiliary shutdown solenoid and OEM harness connection. | No damaged connection
 | STEP 2D. Check for an open circuit. | 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.) |
 | STEP 3A. Inspect the OEM harness and main engine harness connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 255 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for external voltage. | Less than 1.0 VDC
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 255 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Read the ECM dataplate.

Conditions

  • Turn keyswitch ON.

Action

Check the ECM dataplate for the ECM code identifying the calibration.

NOTE: The ECM dataplate is located on the outer surface of the ECM housing.

OK NOT OK

Phase 3 calibration or later

Calibrate the ECM using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™ electronic service tool, Part Number 3824638. See the appropriate electronic service tool user's manual for detailed ECM calibration procedures.

Go to 2A

Go to 5A

Guided Step 2 - Check the auxiliary shutdown solenoid.

Guided Step 2A - Verify the auxiliary shutdown solenoid is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the auxiliary shutdown solenoid.

  • Verify the auxiliary shutdown solenoid is connected to the OEM harness.
OK NOT OK

Auxiliary shutdown solenoid connected

Connect the auxiliary shutdown solenoid to the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Check for jumper wires on the auxiliary shutdown solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for jumper wires.

  • Check for jumper wires on the auxiliary shutdown solenoid.
OK NOT OK

No jumper wires

Remove any jumper wires from the auxiliary shutdown solenoid.

Go to 2C

Go to 5A

Guided Step 2C - Inspect the auxiliary shutdown solenoid and OEM harness connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary shutdown solenoid from the OEM harness.

Action

Inspect the auxiliary shutdown solenoid and OEM harness connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361.

NOTE: Fault Code 255 can be active when the auxiliary shutdown solenoid is disconnected.

OK NOT OK

No damaged connections

Repair the damaged connections

Repair or replace the OEM harness or the auxiliary shutdown solenoid, whichever has the damaged connections.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the auxiliary shutdown solenoid. Reference the OEM troubleshooting and repair manual.
  • Replace the auxiliary shutdown solenoid. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the auxiliary shutdown solenoid.

Action

Check for an open circuit.

  • Measure the resistance from the auxiliary shutdown solenoid post to engine block ground.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

1 to 5 ohms for 6-VDC solenoids

6 to 15 ohms for 12-VDC solenoids

24 to 50 ohms for 24-VDC solenoids

42 to 80 ohms for 32-VDC solenoids

46 to 87 ohms for 36-VDC solenoids

92 to 145 ohms for 48-VDC solenoids

315 to 375 ohms for 74-VDC solenoids

645 to 735 ohms for 115-VAC solenoids

Replace the auxiliary shutdown solenoid

Refer to Procedure 019-050.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.)

Guided Step 3A - Inspect the OEM harness and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™ electronic service tool, Part Number 3824638.
OK NOT OK

Fault Code 255 active

Repair complete.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the auxiliary shutdown solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin F of the OEM harness C6 connector to auxiliary shutdown lead wire.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness or the auxiliary shutdown solenoid, whichever has the damaged connections.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the auxiliary shutdown solenoid. Reference the OEM troubleshooting and repair manual.
  • Replace the auxiliary shutdown solenoid. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the auxiliary shutdown solenoid from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin F of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3E

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3E - Check for external voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the auxiliary shutdown solenoid from the OEM harness.

Action

Check for external voltage.

  • Measure the DC voltage from pin F of the OEM harness C6 connector to engine block ground.
OK NOT OK

Less than 1.0 VDC

Remove the external voltage source

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check an for open circuit.

  • Measure the resistance from pin 1 of the main engine harness ECM connector to pin F of the main engine harness C6 connector.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 1 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.

For general resistance measurement techniques. Refer to Procedure 019-360.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 255 is inactive.
OK NOT OK

Fault Code 255 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™ electronic service tool, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damage to the new ECM, all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Read the fault codes. | Fault Code 341 not logged
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 341 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To reduce the possibility of damage to the new ECM, all other fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 341 not logged

Replace the ECM

Refer to Procedure 019-031.

Appropriate troubleshooting charts

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 341 is inactive.
OK NOT OK

Fault Code 341 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Read the ECM dataplate. | Phase 4 calibration or later
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 342 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Read the ECM dataplate.

Conditions

  • Turn keyswitch ON.

Action

Check the ECM dataplate for the ECM code identifying the calibration.

NOTE: The ECM dataplate is located on the outer surface of the ECM housing.
OK NOT OK

Phase 4 calibration or later

Calibrate the ECM

Calibrate the ECM using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638. Reference the appropriate electronic service tool user's manual for detailed ECM calibration procedures.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 342 is inactive.
OK NOT OK

Fault Code 342 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damage to the new ECM, all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Read the fault codes. | Fault Code 353 not logged
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 353 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To reduce the possibility of damage to the new ECM, all other fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 353 not logged

Replace the ECM

Refer to Procedure 019-031.

Appropriate troubleshooting charts

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 353 is inactive.
OK NOT OK

Fault Code 353 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the datalink connections. |
 | STEP 1A. Inspect the main engine harness datalink connector pins. | No damaged pins
 | STEP 1B. Turn off possible interference sources. | Fault Code 412 active
 | STEP 1C. Inspect the OEM harness datalink connector pins. | No damaged pins
 | STEP 1D. Check monitor devices (OEM datalink and engine datalink). | Fault Code 412 active
 | STEP 1D-1. Read the fault codes. |
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 2A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Verify Fault Code 412 is still active with the OEM harness disconnected. | Fault Code 412 active
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check the engine voltage on engine side of the 2-pin datalink connector. | 4.0 to 5.0 VDC from pin A; 0.0 to 0.1 from pin B
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 412 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the datalink connections.

Guided Step 1A - Inspect the main engine harness datalink connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic service tool or monitor devices from the main engine harness datalink connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness datalink connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-201 and Refer to Procedure 019-202.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 1B

Go to 4A

Guided Step 1B - Turn off possible interference sources.

Conditions

  • Connect the electronic service tool to the main engine harness datalink connector.
  • Turn keyswitch ON.

Action

Turn off possible interference sources.

  • Turn off citizens band (CB) or other radio devices.
  • Make sure the power and ground lines of the radio devices are isolated from the CENTRY™ system.
OK NOT OK

Fault Code 412 active

Remove all sources of interference.

Go to 1C

Go to 4A

Guided Step 1C - Inspect the OEM harness datalink connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic devices from the OEM datalink connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness datalink connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check monitor devices (OEM datalink and engine datalink).

Conditions

  • Connect the electronic service tool to the main engine harness datalink connector.
  • Turn keyswitch ON.

Action

Check monitor devices (OEM datalink and engine datalink).

  • Disconnect any onboard electronic devices such as electronic dashboard, hour meters, transmission controllers, trip recorders, etc., connected to the datalink.
OK NOT OK

Fault Code 412 active

Verify datalink operation

Fault Code 412 will become inactive if there is a problem with the monitor device, OEM harness, or the main engine harness.

Go to 2A

Go to 1D-1

Guided Step 1D-1 - Read the fault codes.

Conditions

  • Connect the electronic service tool to the OEM harness datalink connector.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Communication error

Disconnect monitor devices

Reference the device manufacturer's troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 2A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the electronic service tool from the OEM harness datalink connector.

Action

Check for an open circuit.

  • Measure the resistance from pin J of the OEM harness C6 connector to pin A of the OEM harness datalink connector.
  • Measure the resistance from pin H of the OEM harness C6 connector to pin B of the OEM harness datalink connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the electronic service tool from the OEM harness datalink connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin J of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin H of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the electronic service tool from the OEM harness datalink connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin J of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin H of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

Guided Step 2E - Verify Fault Code 412 is still active with the OEM harness disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Verify Fault Code 412 is still active with the OEM harness disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

No communication

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the electronic service tool from the main engine harness datalink connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin J of the OEM harness C6 connector to pin 6 of the main engine harness ECM connector.
  • Measure the resistance from pin H of the OEM harness C6 connector to pin 8 of the main engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the electronic service tool from the main engine harness datalink connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 8 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the electronic service tool from the main engine harness datalink connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 8 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3E

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check the engine voltage on engine side of the 2-pin datalink connector.

Conditions

  • Connect the ECM connector.
  • Connect the OEM connector
  • Turn keyswitch ON.

Action

Check the engine voltage on engine side of the 2-pin datalink connector.

  • Measure the voltage from pin A of the engine side of the 2-pin datalink connector to engine block ground.
  • Measure the voltage from pin B of the engine side of the 2-pin datalink connector to engine block ground.
OK NOT OK

4.0 to 5.0 VDC from pin A; 0.0 to 0.1 VDC from pin B

Replace the ECM

  • Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 412 is inactive.
OK NOT OK

Fault Code 412 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the datalink connections. |
 | STEP 1A. Inspect the main engine harness datalink connector pins. | No damaged pins
 | STEP 1B. Turn off possible interference sources. | Fault Code 414 active
 | STEP 1C. Inspect the OEM harness datalink connector pins. | No damaged pins
 | STEP 1D. Check monitor devices (OEM datalink and engine datalink). | Fault Code 414 active
 | STEP 1D-1. Read the fault codes. |
 | STEP 1E. Check the datalink circuit wire length. | Less than 50 feet
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 2A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Verify Fault Code 414 is still active with the OEM harness disconnected. | Fault Code 414 active
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check the engine voltage on engine side of the 2-pin datalink connector. | 4.0 to 5.0 VDC from pin A; 0.0 to 0.1 VDC from pin B
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 414 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the datalink connections.

Guided Step 1A - Inspect the main engine harness datalink connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic service tool or monitor devices from the main engine harness datalink connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness data link connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 1B

Go to 4A

Guided Step 1B - Turn off possible interference sources.

Conditions

  • Connect the electronic service tool to the main engine harness datalink connector.
  • Turn keyswitch ON.

Action

Turn off possible interference sources.

  • Turn off citizens band (CB) or other radio devices.
  • Make sure the power and ground lines of the radio devices are isolated from the CENTRY™ system.
OK NOT OK

Fault Code 414 active

Remove all sources of interference.

Go to 1C

Go to 4A

Guided Step 1C - Inspect the OEM harness datalink connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic devices from the OEM datalink connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness datalink connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check monitor devices (OEM datalink and engine datalink).

Conditions

  • Connect the electronic service tool to the main engine harness datalink connector.
  • Turn keyswitch ON.

Action

Check monitor devices (OEM datalink and engine datalink).

  • Disconnect any onboard electronic devices such as electronic dashboard, hour meters, transmission controllers, trip recorders, etc., connected to the datalink.
OK NOT OK

Fault Code 414 active

Verify datalink operation

Fault Code 414 will become inactive if there is a problem with the monitor device, OEM harness, or the main engine harness.

Go to 2A

Go to 1D-1

Guided Step 1D-1 - Read the fault codes.

Conditions

  • Connect the electronic service tool to the OEM harness datalink connector.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Communication error

Disconnect monitor devices

  • Reference the device manufacturer's troubleshooting and repair manual.

Go to 1E

Go to 4A

Guided Step 1E - Check the datalink circuit wire length.

Conditions

  • Turn keyswitch OFF.

Action

Verify the length of the datalink circuit.

  • Verify the length of the datalink circuit is not more than 50 feet.
OK NOT OK

Less than 50 feet

Use specially wired and shielded datalink cable

Reference the CENTRY™ System Installation Manual.

Go to 2A

Go to 2A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 2A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the electronic service tool from the OEM harness datalink connector.

Action

Check for an open circuit.

  • Measure the resistance from pin J of the OEM harness C6 connector to pin A of the OEM harness datalink connector.
  • Measure the resistance from pin H of the OEM harness C6 connector to pin B of the OEM harness datalink connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the electronic service tool from the OEM harness datalink connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin J of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin H of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the electronic service tool from the OEM harness datalink connector.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin J of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin H of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

Guided Step 2E - Verify Fault Code 414 is still active with the OEM harness disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Verify Fault Code 412 is still active with the OEM harness disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 414 active

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the electronic service tool from the main engine harness datalink connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin J of the OEM harness C6 connector to pin 6 of the main engine harness ECM connector.
  • Measure the resistance from pin H of the OEM harness C6 connector to pin 8 of the main engine harness ECM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the electronic service tool from the main engine harness datalink connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 6 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 8 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the electronic service tool from the main engine harness datalink connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 6 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 8 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3E

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check the engine voltage on engine side of the 2-pin datalink connector.

Conditions

  • Connect the ECM connector.
  • Connect the OEM connector.
  • Turn keyswitch ON.

Action

Check the engine voltage on engine side of the 2-pin datalink connector.

  • Measure the voltage from pin A of the engine side of the 2-pin datalink connector to engine block ground.
  • Measure the voltage from pin B of the engine side of the 2-pin datalink connector to engine block ground.
OK NOT OK

4.0 to 5.0 VDC from pin A; 0.0 to 0.1 VDC from pin B

Replace the ECM

  • Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 414 is inactive.
OK NOT OK

Fault Code 414 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Read the ECM dataplate. | Phase 3 calibration or later
STEP 2. | Check the idle validation switch. |
 | STEP 2A. Verify the idle validation switch is connected to the OEM harness. | Idle validation switch is connected
 | STEP 2B. Inspect the idle validation switch and OEM harness connector pins. | No damaged pins
 | STEP 2C. Check for an open circuit. | Less than 125 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 3A. Inspect the OEM harness and main engine harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 125 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 431 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Read the ECM dataplate.

Conditions

  • Turn keyswitch ON.

Action

Check the ECM dataplate for the ECM code identifying the calibration.

NOTE: The ECM dataplate is located on the outer surface of the ECM housing.
OK NOT OK

Phase 3 calibration or later

Calibrate the ECM using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638. Reference the appropriate service tool's user's manual for detailed ECM calibration procedures.

Go to 2A

Go to 2A

Guided Step 2 - Check the idle validation switch.

Guided Step 2A - Verify the idle validation switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the idle validation switch.

  • Verify the idle validation switch is connected to the OEM harness.
OK NOT OK

Idle validation switch is connected

Connect the idle validation switch to the OEM harness

Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the idle validation switch and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle validation switch from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the idle validation switch and OEM harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the throttle pedal or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the throttle pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the throttle pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle validation switch from the OEM harness.

Action

Check for open circuit.

  • Measure the resistance from pin C of the idle validation switch to pin A of the idle validation switch with the throttle pedal depressed.
  • Measure the resistance from pin B of the idle validation switch to pin A of the idle validation switch with the throttle pedal released.
OK NOT OK

Less than 125 ohms

Repair or replace the throttle pedal

  • Repair the throttle pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the throttle pedal. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823995 - male Weather-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle validation switch from the OEM harness.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin B of the idle validation switch to pin C of the idle validation switch with the throttle pedal both depressed and released.
  • Measure the resistance from pin A of the idle validation switch to pin B of the idle validation switch with the throttle pedal depressed.
  • Measure the resistance from pin A of the idle validation switch to pin C of the idle validation switch with the throttle pedal released.
OK NOT OK

More than 100K ohms

Repair or replace the throttle pedal

  • Repair the throttle pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the throttle pedal. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 3A - Inspect the OEM and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic cleaner, Part Number 3824510.

Action

Inspect the OEM and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness.
  • Connect the idle validation switch to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the OEM harness C6 connector to pin G of the OEM harness C6 connector with the throttle pedal depressed.
  • Measure the resistance from pin C of the OEM harness C6 connector to pin G of the OEM harness C6 connector with the throttle pedal released.
OK NOT OK

Less than 125 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the idle validation switch from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin C of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin G of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100K ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3D

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector and the C5 connector.
  • Disconnect the idle validation switch from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin C of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin G of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 9 of the main engine harness ECM connector to pin A of the main engine harness C6 connector.
  • Measure the resistance from pin 16 of the main engine harness ECM connector to pin C of the main engine harness C6 connector.
  • Measure the resistance from pin 25 of the main engine harness ECM connector to pin G of the main engine harness C6 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 9 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 16 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4D

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 9 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 16 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 431 not logged
STEP 2. | Check the accelerator position sensor. |
 | STEP 2A. Inspect the OEM harness and accelerator position sensor connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 3A. Inspect the main engine harness and OEM harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | 2000 to 3000 ohms
 | STEP 3C. Check for a short from pin to pin. | More than 100k ohms
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the active fault code. | Fault Code 432 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 431 not logged

Troubleshoot Fault Code 431

Go to 2A

Fault Code 431

Guided Step 2 - Check the accelerator position sensor.

Guided Step 2A - Inspect the OEM harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and throttle position sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the accelerator position sensor to pin C of the accelerator position sensor.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the accelerator position sensor to pin C of the accelerator position sensor.

NOTE: Measure when pedal is depressed and again when pedal is released.
OK NOT OK

Released: 1500 to 3000 ohms; Depressed: 200 to 1500 ohms

Repair or replace the accelerator pedal

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 3A - Inspect the main engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and OEM harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Connect the accelerator pedal to the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C6 connector to pin B of the OEM harness C6 connector.
OK NOT OK

2000 to 3000 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to pin E of the main engine harness C6 connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to pin D of the main engine harness C6 connector.
  • Measure the resistance from pin 27 of the main engine harness ECM connector to pin B of the main engine harness C6 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms, replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 432 is inactive.
OK NOT OK

Fault Code 432 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 431 not logged
STEP 2. | Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM manual for more details.) |
 | STEP 2A. Inspect the main engine harness and OEM harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 18k ohms
 | STEP 2C. Check for a short circuit. | Released 3800 to 6000 ohms; Depressed 380 to 900 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the active fault code. | Fault Code 432 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE ™, Part Number 3824638.
OK NOT OK

Fault Code 431 not logged

Troubleshoot Fault Code 431

If Fault Code 431 is active, it can cause Fault Code 432 to be active.

Go to 2A

Fault Code 431

Guided Step 2 - Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 2A - Inspect the OEM harness and main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C6 connector to pin B of the OEM harness C6 connector.
OK NOT OK

Less than 18k ohms

Repair or replace the OEM harness or accelerator pedal, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit.

  • Measure the resistance from pin D of the OEM harness C6 connector to pin E of the OEM harness C6 connector.
OK NOT OK

Released 3800 to 6000 ohms; Depressed 380 to 900 ohms

Repair or replace the OEM harness or accelerator pedal, whichever has the short circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin D of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin E of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin B of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or accelerator pedal, whichever has the short circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to pin E of the main engine harness C6 connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to pin D of the main engine harness C6 connector.
  • Measure the resistance from pin 27 of the main engine harness ECM connector to pin B of the main engine harness C6 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle one minute.
  • Verify Fault Code 432 is inactive.
OK NOT OK

Fault Code 432 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damage to new ECM, all other fault codes must be investigated prior to replacing ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female AMP/Deutsch/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 9 to 16 VDC (12-VDC system); 18 to 32 VDC (24-VDC system)
 | STEP 1C. Check the ECM part number. | ECM Part Numbers 3619026 and 3654717 = 12-VDC; ECM Part Numbers 3619027 and 3654718 = 24-VDC
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 2A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 2B. Check the supply voltage. | 9 to 16 VDC (12-VDC system); 18 to 32 VDC (24-VDC system)
STEP 3. | Check the main engine harness. |
 | STEP 3A. Check the main engine harness ground connection. | No damaged connections
 | STEP 3B. Inspect the main engine harness fuse connections. | No damaged connections
 | STEP 3C. Check the main engine harness fuses. | Less than 10 ohms
 | STEP 3D. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3E. Check for an open circuit. | Less than 10 ohms
 | STEP 3F. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3G. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

No damaged connections

Repair the damaged connections

Repair or replace the battery connections. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.
OK NOT OK

9 to 16 VDC (12-VDC system); 18 to 32 VDC (24-VDC system)

Repair or replace the battery

  • Repair the battery. Reference the OEM troubleshooting and repair manual.
  • Replace the battery. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

CAUTION

To reduce the possibility of damage to new ECM, all other fault codes must be investigated prior to replacing ECM.
Guided Step 1C - Check the ECM part number.

Conditions

  • Turn keyswitch OFF.

Action

Check part number.

  • Check the ECM part number.
OK NOT OK

ECM Part Numbers 3619026 and 3654717 = 12-VDC; ECM Part Numbers 3619027 and 3654718 = 24-VDC

Replace the ECM

Refer to Procedure 019-031.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 2A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2B - Check the supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.

Action

Check the supply voltage.

  • Measure the DC voltage from pin G of the OEM harness C5 connector to the engine block ground.
OK NOT OK

9 to 16 VDC (12-VDC system); 18 to 32 VDC (24-VDC system)

Repair or replace the switched voltage circuit

Repair or replace the OEM harness or the keyswitch, whichever has the short circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the keyswitch. Reference the OEM troubleshooting and repair manual.
  • Replace the keyswitch. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

Guided Step 3A - Check the main engine harness ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the main engine harness from the engine block at the ground connection.

Action

Check the main engine harness ground connection for the following:

  • Loose connections
  • Broken connections
  • Corroded connections.
OK NOT OK

No damaged connections

Repair the damaged connections

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3B

Go to 4A

Guided Step 3B - Inspect the main engine harness fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both 5-amp fuses from the main engine harness.

Action

Inspect the main engine harness fuse connections for the following:

  • Corroded fuses
  • Loose fuses.

NOTE: The third fuse is for the rail pressure return line.
OK NOT OK

No damaged connections

Repair the damaged connections

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check the main engine harness fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both 5-amp fuses from the main engine harness.

Action

Check the main engine harness fuses.

  • Measure the resistance of fuses.
OK NOT OK

Less than 10 ohms

Replace the fuses

Refer to Procedure 019-198.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of damage to new ECM, all other fault codes must be investigated prior to replacing ECM.
Guided Step 3D - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 22 of the main engine harness ECM connector to pin G of the C5 connector.
  • Measure the resistance from pin 23 of the main engine harness ECM connector to pin G of the C5 connector.
  • Measure the resistance from pin 25 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 26 of the main engine harness ECM connector to engine block ground.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3F

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 22 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 23 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3G

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female AMP/Deutsch/Metri-Pack test lead.
Guided Step 3G - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from pin 22 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector except pin 23.
  • Measure the resistance from pin 23 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector except pin 22.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 441 is inactive.
OK NOT OK

Fault Code 441 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damage to new ECM, all other fault codes must be investigated prior to replacing ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the ECM is compatible with the system voltage. |
 | STEP 1A. Check the ECM part number. | ECM Part Numbers 3619026 and 3654717 = 12 VDC; ECM Part Numbers 3619027 and 3654718 = 24 VDC
 | STEP 1B. Check the battery voltage. | 9 to 16 VDC (12-VDC system); 18 to 32 VDC (24-VDC system)
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 442 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify the ECM is compatible with the system voltage.

CAUTION

To reduce the possibility of damage to new ECM, all other fault codes must be investigated prior to replacing ECM.
Guided Step 1A - Check the ECM part number.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM part number.

  • Check the ECM part number.
OK NOT OK

ECM Part Numbers 3619026 and 3654717 = 12 VDC; ECM Part Numbers 3619027 and 3654718 = 24 VDC

Replace the ECM

Refer to Procedure 019-031.

Go to 1B

Go to 2A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the ECM connector.

Action

Check the battery voltage.

  • Measure the DC voltage from pin 22 of the main engine harness ECM connector to pin 25 of the main engine harness ECM connector.
OK NOT OK

9 to 16 VDC (12-VDC system); 18 to 32 VDC (24-VDC system)

Remove the high voltage source or reconfigure the battery connections. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 442 is inactive.
OK NOT OK

Fault Code 442 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details). |
 | STEP 1A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1C. Check for a short from pin to pin. | More than 100k ohms
 | STEP 1D. Verify Fault Code 443 is still active with OEM harness disconnected. | Fault Code 443 active
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable active fault code. | Fault Code 443 inactive
 | STEP 3B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 1A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and throttle position sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin D of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or accelerator switch, whichever has the short circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator switch. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator switch. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Set the accelerator switch to the IDLE position.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or accelerator switch, whichever has the short circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator switch. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator switch. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Verify Fault Code 443 is still active with the OEM harness disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Verify Fault Code 443 is still active with the OEM harness disconnected.

  • Read fault codes with a Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.

NOTE: Fault Code 132 will be active with the OEM harness disconnected at the C6 connector.
OK NOT OK

Fault Code 443 active

Repair or replace the OEM harness or accelerator switch, whichever has the short circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator switch. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator switch. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 443 is inactive.
OK NOT OK

Fault Code 443 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and accelerator position sensor connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit. | 2000 to 3000 ohms
 | STEP 1C. Check for a short circuit in supply line. | 250 to 3000 ohms
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the main engine harness and OEM harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short from pin to pin. | More than 100k ohms
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 443 inactive
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and throttle position sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the accelerator pedal or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 1B - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit.

  • Measure the resistance from pin A of the accelerator position sensor to pin C of the accelerator position sensor.
OK NOT OK

2000 to 3000 ohms

Repair or replace the accelerator pedal.

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test lead.
Guided Step 1C - Check for a short circuit in supply line.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit in the supply line.

  • Measure the resistance from pin B of the accelerator position sensor to pin C of the accelerator position sensor.
OK NOT OK

250 to 3000 ohms

Repair or replace the accelerator pedal

  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin D of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 443 is inactive.
OK NOT OK

Fault Code 443 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3822994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness and accelerator signal generator. |
 | STEP 1A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 1B. Verify Fault Code 443 is still active with the OEM harness disconnected. | Fault Code 443 active
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 443 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness and accelerator signal generator.

Guided Step 1A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Verify Fault Code 443 is still active with the OEM harness disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Verify Fault Code 443 is still active with the OEM harness disconnected.

  • Read fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.

NOTE: Fault Code 132 will be active with the OEM harness disconnected at the C6 connector.
OK NOT OK

Fault Code 443 active

Repair or replace the OEM harness or the accelerator signal generator, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator signal generator. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator signal generator. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pin using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 443 is inactive.
OK NOT OK

Fault Code 443 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM manual for more details.) |
 | STEP 1A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1D. Verify Fault Code 443 is still active with the OEM harness disconnected. | Fault Code 443 active
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 443 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness and accelerator position sensor. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 1A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Connect the accelerator pedal to the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E of the OEM harness C6 connector to engine block ground.
  • Measure the resistance from pin D of the OEM harness C6 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness, accelerator pedal, or accelerator lever, whichever has the short circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator pedal. Reference the OEM troubleshooting and repair manual.
  • Repair the accelerator lever. Reference the OEM troubleshooting and repair manual.
  • Replace the accelerator lever. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C6 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Verify Fault Code 443 is still active with the OEM harness disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Verify Fault Code 443 is still active with the OEM harness disconnected.

  • Read fault codes using Compulink™, Part Number 3823549, Echek™, Part Number 3824437, or INSITE™, Part Number 3824638.

NOTE: Fault Code 132 can be active with the OEM harness disconnected at the C6 connector.
OK NOT OK

Fault Code 443 active

Repair or replace the OEM harness.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 13 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 19 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms.

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness.

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 443 is inactive.
OK NOT OK

Fault Code 443 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rail pressure sensor. |
 | STEP 1A. Inspect the rail pressure sensor and the main engine harness connector pins. | No damaged pins
 | STEP 1B. Verify Fault Code 444 is still active with the rail pressure sensor disconnected. | Fault Code 444 active
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the oil pressure sensor and OEM harness connector pins. | No damaged pins
 | STEP 2B. Verify Fault Code 444 is still active with the oil pressure sensor disconnected. | Fault Code 444 active
STEP 3. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 3A. Inspect the main engine harness and OEM harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the main engine harness. |
 | STEP 4A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 444 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the rail pressure sensor.

Guided Step 1A - Inspect the rail pressure sensor and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the rail pressure sensor and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the OEM harness or the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the rail pressure sensor. Refer to Procedure 019-116.

Go to 1B

Go to 5A

Guided Step 1B - Verify Fault Code 444 is still active with the rail pressure sensor disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Verify Fault Code 444 is still active with the rail pressure sensor disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.

NOTE: Fault Code 452 can be active while the rail pressure sensor is disconnected.
OK NOT OK

Fault Code 444 active

Replace the rail pressure sensor

Refer to Procedure 019-116.

Go to 2A

Go to 5A

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the OEM harness and oil pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and oil pressure sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Replace the oil pressure sensor

Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Verify Fault Code 444 is still active with the oil pressure sensor disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the oil pressure sensor from the main engine harness.

Action

Verify Fault Code 444 is still active with the oil pressure sensor disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.

NOTE: Fault Code 141 can be active while the rail pressure sensor is disconnected.
OK NOT OK

Fault Code 444 active

Replace the oil pressure sensor

Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 3A - Inspect the main engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and OEM harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the oil pressure sensor from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the OEM harness C5 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3C

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the oil pressure sensor from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin A of the OEM harness C5 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 4A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 5A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4C

Go to 5A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 444 is inactive.
OK NOT OK

Fault Code 444 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 1A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 445 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 1A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Set the intermediate-speed switch to the ON position.
  • Set the alternate droop switch to the ON position.

Action

Check for an open circuit.

  • Measure the resistance from pin E of the OEM harness C5 connector to pin H of the OEM harness C5 connector.
  • Measure the resistance from pin D of the OEM harness C5 connector to pin H of the OEM harness C5 connector.
  • Measure the resistance from pin C of the OEM harness C5 connector to pin H of the OEM harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness, intermediate-speed switch, or alternate droop switch, whichever has the open circuit

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Replace the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Repair the alternate droop switch. Reference the OEM troubleshooting and repair manual.
  • Replace the alternate droop switch. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Set the intermediate-speed switch to the OFF position.
  • Set the alternate droop switch to the OFF position.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin C of the OEM harness C5 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness, intermediate-speed switch, or alternate droop switch, whichever has the open circuit

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Replace the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Repair the alternate droop switch. Reference the OEM troubleshooting and repair manual.
  • Replace the alternate droop switch. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Set the intermediate-speed switch to the OFF position.
  • Set the alternate droop switch to the OFF position.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin C of the OEM harness C5 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin D of the OEM harness C5 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin E of the OEM harness C5 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness, intermediate-speed switch, or alternate droop switch whichever has the open circuit

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Replace the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Repair the alternate droop switch. Reference the OEM troubleshooting and repair manual.
  • Replace the alternate droop switch. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 of the main engine harness ECM connector to pin C of the main engine harness C5 connector.
  • Measure the resistance from pin 5 of the main engine harness ECM connector to pin E of the main engine harness C5 connector.
  • Measure the resistance from pin 28 of the main engine harness ECM connector to pin D of the main engine harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 5 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 28 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 445 is inactive.
OK NOT OK

Fault Code 445 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the rail pressure sensor. |
 | STEP 1A. Inspect the rail pressure sensor and the main engine harness connector pins. | No damaged pins
 | STEP 1B. Verify Fault Code 451 is inactive with the rail pressure sensor disconnected. | Fault Code 451 active
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness return line fuse connections. | No damaged connections
 | STEP 2B. Check the return line fuse. | Less than 10 ohms
 | STEP 2C. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2D. Read the fault codes. | Fault Code 451 active
 | STEP 2E. Check for an open circuit. | Less than 10 ohms
 | STEP 2F. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 451 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the rail pressure sensor.

Guided Step 1A - Inspect the rail pressure sensor and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the rail pressure sensor and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the rail pressure sensor. Refer to Procedure 019-116.

Go to 1B

Go to 3A

Guided Step 1B - Verify Fault Code 451 is inactive with the rail pressure sensor disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Verify Fault Code 451 is inactive with the rail pressure sensor disconnected.

  • Read fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.

NOTE: Fault Code 452 can be active while the rail pressure sensor is disconnected.
OK NOT OK

Fault Code 451 inactive

Replace the rail pressure sensor

Refer to Procedure 019-116.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

Guided Step 2A - Inspect the main engine harness return line fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the main engine harness return line fuse from the main engine harness.

Action

Inspect the main engine harness return line fuse connections for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged connections

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the main engine harness return line fuse, whichever has the damaged connections.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the return line fuse. Refer to Procedure 019-198.

Go to 2B

Go to 3A

Guided Step 2B - Check for return line fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the main engine harness return line fuse from the main engine harness.

Action

Check for return line fuse.

  • Measure the resistance of the fuse.
OK NOT OK

Less than 10 ohms

Replace the fuse harness

Refer to Procedure 019-198.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2C - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2D

Go to 3A

Guided Step 2D - Read the fault codes.

Conditions

  • Connect all components.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 451 active

Repair complete.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 27 of the main engine harness ECM connector to pin B of the main engine harness rail pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2F

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2F - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 14 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 451 is inactive.
OK NOT OK

Fault Code 451 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823255 - female Metri-Pack test leadPart Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 444 inactive
STEP 2. | Check the rail pressure sensor. |
 | STEP 2A. Verify the rail pressure sensor is connected. | Rail pressure sensor connected
 | STEP 2B. Inspect the rail pressure sensor and the main engine harness connector pins. | No damaged pins
 | STEP 2C. Read the fault codes. | Fault Code 452 inactive
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check the supply voltage. | Between 4.75 VDC and 5.25 VDC
 | STEP 2F. Check the signal voltage. | 0.46 to 4.56 VDC
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 452 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 452 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 444 inactive

Fault Code 444 active

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the rail pressure sensor.

Guided Step 2A - Verify the rail pressure sensor is connected.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail pressure sensor from the main engine harness.

Action

Verify the rail pressure sensor.

  • Verify the rail pressure sensor is connected.
OK NOT OK

Rail pressure sensor connected

Connect the rail pressure sensor to the main engine harness.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the main engine harness and rail pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and pressure sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the rail pressure sensor. Refer to Procedure 019-115.

Go to 2C

Go to 4A

Guided Step 2C - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 452 active

Repair complete.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Connect the breakout cable, Part Number 3824774, to the rail pressure sensor and the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the rail pressure sensor to the engine block ground.
  • Measure the resistance from pin B of the rail pressure sensor to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the rail pressure sensor. Refer to Procedure 019-115.

Go to 2E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
Guided Step 2E - Check the supply voltage.

Conditions

  • Disconnect the rail pressure sensor from the main engine harness.
  • Connect the breakout cable, Part Number 3824774, to the rail pressure sensor and the main engine harness.
  • Turn keyswitch ON.

Action

Check the rail pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B on the main engine harness rail pressure sensor connector.
OK NOT OK

Between 4.75 VDC and 5.25 VDC

Troubleshoot the main engine harness.

Go to 2F

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3824774 - breakout cable.
Guided Step 2F - Check the signal voltage.

Conditions

  • Disconnect the rail pressure sensor from the main engine harness.
  • Connect the breakout cable, Part Number 3824774, to the rail pressure sensor and the main engine harness.
  • Turn keyswitch ON.

Action

Check the rail pressure sensor signal voltage.

  • Measure the voltage from pin B to pin C on the main engine harness rail pressure sensor connector.
OK NOT OK

0.46 to 4.56 VDC

Replace the rail pressure sensor

Refer to Procedure 019-115.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 452 active

Repair complete

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to pin A of the main engine harness rail pressure sensor connector.
  • Measure the resistance from pin 14 of the main engine harness ECM connector to pin C of the main engine harness rail pressure sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 14 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3E

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the rail pressure sensor from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 11 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 14 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 452 is inactive.
OK NOT OK

Fault Code 452 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549, Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control valve. |
 | STEP 1A. Verify the electronic fuel control valve is connected to the main engine harness. | Electronic fuel control valve connected
 | STEP 1B. Inspect the electronic fuel control valve terminal posts and the main engine harness connectors. | No loose or damaged connectors and terminal posts
 | STEP 1C. Read the fault codes. | Fault Code 455 active
 | STEP 1D. Check for an open circuit. | 12-VDC valve = 1.5 to 3.0 ohms; 24-VDC valve = 7 to 10 ohms
 | STEP 1E. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 455 active
 | STEP 2C. Check for an open circuit. | 12-VDC valve = 1.5 to 3.0 ohms; 24-VDC valve = 7 to 10 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codethe . |
 | STEP 3A. Disable the fault code. | Fault Code 455 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the electronic fuel control valve.

Guided Step 1A - Verify the electronic fuel control valve is connected to the main engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the electronic fuel control valve.

  • Verify the electronic fuel control valve is connected to the main engine harness.
OK NOT OK

Electronic fuel control valve connected

Connect the electronic fuel control valve to the main engine harness.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the electronic fuel control valve terminal posts and the main engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the electronic fuel control valve terminal posts and main engine harness connectors for the following:

  • Signs of arcing
  • Loose connectors
  • Corroded terminal posts or connectors
  • Bent or broken terminal posts or connectors
  • Moisture in or on the terminal posts and connectors
  • Dirt or debris in or on the terminal posts and connector pins.
OK NOT OK

No loose or damaged connectors and terminal posts

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the electronic fuel control valve. Refer to Procedure 019-030.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 455 active

Repair complete.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the terminal posts of the electronic fuel control valve.
OK NOT OK

12-VDC valve = 1.5 to 3.0 ohms; 24-VDC valve = 7 to 10 ohms

Replace the electronic fuel control valve

Refer to Procedure 019-030.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from each terminal post of the electronic fuel control to the electronic fuel control housing.
OK NOT OK

More than 100k ohms

Replace the electronic fuel control valve

Refer to Procedure 019-030.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the main engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 455 active

Repair complete

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the electronic fuel control valve to the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the main engine harness ECM connector to pin 21 of the main engine harness ECM connector.
OK NOT OK

12-VDC valve = 1.5 to 3.0 ohms; 24-VDC valve = 7 to 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 21 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 21 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify that Fault Code 455 is inactive.
OK NOT OK

Fault Code 455 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control valve. |
 | STEP 1A. Verify the electronic fuel control valve is connected to the main engine harness. | Electronic fuel control valve connected
 | STEP 1B. Inspect the electronic fuel control valve terminal posts and the main engine harness connectors. | No loose or damaged connectors and terminal posts
 | STEP 1C. Read the fault codes. | Fault Code 511 Active
 | STEP 1D. Check for an open circuit. | 12-VDC valve = 1.5 to 3.0 ohms; 24-VDC valve = 7 to 10 ohms
 | STEP 1E. Check for a short circuit to ground. | More than 100k ohms
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 511 Active
 | STEP 2C. Check for an open circuit. | 12-VDC valve = 1.5 to 3.0 ohms; 24-VDC valve = 7 to 10 ohms
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 511 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the electronic fuel control valve.

Guided Step 1A - Verify the electronic fuel control valve is connected to the main engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the electronic fuel control valve.

  • Verify the electronic fuel control valve is connected to the main engine harness.
OK NOT OK

Electronic fuel control valve connected

Connect the electronic fuel control valve to the main engine harness.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the electronic fuel control valve terminal posts and the main engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the electronic fuel control valve terminal posts and main engine harness connectors for the following:

  • Signs of arcing
  • Loose connectors
  • Corroded terminal posts or connectors
  • Dirt or debris in or on the connector pins
  • Bent or broken terminal posts or connectors
  • Moisture in or on the terminal posts and connectors.
OK NOT OK

No loose or damaged connectors and terminal posts

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the electronic fuel control valve. Refer to Procedure 019-030.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 511 active

Repair complete.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the terminal posts of the electronic fuel control valve.
OK NOT OK

12-VDC valve = 1.5 to 3.0 ohms; 24-VDC valve = 7 to 10 ohms

Replace the electronic fuel control valve

Refer to Procedure 019-030.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from each terminal post of the electronic fuel control to the electronic fuel control housing.
OK NOT OK

More than 100k ohms

Replace the electronic fuel control valve

Refer to Procedure 019-030.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 511 active

Repair complete

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the electronic fuel control valve to the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the main engine harness ECM connector to pin 21 of the main engine harness ECM connector.
OK NOT OK

12-VDC valve = 1.5 to 3.0 ohms; 24-VDC valve = 7 to 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 of the main engine harness ECM connector to engine block ground.
  • Measure the resistance from pin 21 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve from the main engine harness.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
  • Measure the resistance from pin 21 of the main engine harness ECM connector to all other pins of the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 511 is inactive.
OK NOT OK

Fault Code 511 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 451 not logged
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 514 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 451 not logged

Reference Fault Code 451 Troubleshooting Tree.

Appropriate troubleshooting charts

Fault Code 451

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 514 is inactive.
OK NOT OK

Fault Code 514 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437;, or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the auxiliary temperature sensor. |
 | STEP 1A. Verify the auxiliary temperature sensor is connected. | Auxiliary temperature sensor is connected
 | STEP 1B. Inspect the OEM harness and auxiliary temperature sensor connector pins. | No damaged pins
 | STEP 1C. Read the fault codes. | Fault Code 521 active
 | STEP 1D. Check for an open circuit. | Less than 36k ohms
 | STEP 1E. Check the supply voltage. | 4.75 VDC to 5.25 VDC
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.) |
 | STEP 2A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 521 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for external voltage. | Less than 1.0 VDC
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 521 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 521 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the auxiliary temperature sensor.

Guided Step 1A - Verify the auxiliary temperature sensor is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify the auxiliary temperature sensor.

  • Verify the auxiliary temperature sensor is connected.
OK NOT OK

Auxiliary temperature sensor is connected

Connect the auxiliary temperature sensor to the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the OEM harness and auxiliary temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor from OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and auxiliary temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the OEM harness or the auxiliary temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the auxiliary temperature sensor. Reference the OEM troubleshooting and repair manual.
  • Replace the auxiliary temperature sensor. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 511 active

Repair complete.

Go to 1D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from pin A of the auxiliary temperature sensor to pin B of the auxiliary temperature sensor.
OK NOT OK

Less than 36k ohms

Replace the auxiliary temperature sensor

Reference the OEM troubleshooting and repair manual.

Go to 1E

Go to 4A

Guided Step 1E - Check the supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the auxiliary temperature sensor from the OEM harness.

Action

Check the supply voltage.

  • Measure the DC voltage from pin A of the OEM harness auxiliary temperature sensor connector to pin B of the OEM harness auxiliary temperature sensor connector.
OK NOT OK

4.75 VDC to 5.25 VDC

Replace the auxiliary temperature sensor.

Refer to Procedure 019-019.

Not 4.75 VDC to 5.25 VDC

Go to 4A

Go to 2A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.)

Guided Step 2A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 521 active

Repair complete.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.

Action

Check for an open circuit.

  • Measure the resistance from pin D of the OEM harness C5 connector to pin A of the OEM harness auxiliary temperature sensor connector.
  • Measure the resistance from pin H of the OEM harness C5 connector to pin B of the OEM harness auxiliary temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the OEM harness C5 connector to all other pins of the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2E - Check for external voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the auxiliary temperature sensor from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.

Action

Check for external voltage.

  • Measure the DC voltage from pin D of the OEM harness C5 connector to engine block ground.
OK NOT OK

Less than 1.0 VDC

Remove the external voltage source

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 521 active

Repair complete.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for an open circuit.

  • Measure the resistance from pin 25 of the main engine harness ECM connector to pin H of the main engine harness C5 connector.
  • Measure the resistance from pin 28 of the main engine harness ECM connector to pin D of the main engine harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 28 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 521 is inactive.
OK NOT OK

Fault Code 521 active

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test leadPart Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the auxiliary temperature sensor. |
 | STEP 1A. Inspect the OEM harness and auxiliary temperature sensor connector pins. | No damaged pins
 | STEP 1B. Read the fault codes. | Fault Code 521 active
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Verify Fault Code 522 is still active with the auxiliary temperature sensor disconnected. | Fault Code 522 active
STEP 2. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.) |
 | STEP 2A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 521 active
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms
STEP 3. | Check the main engine harness. |
 | STEP 3A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 521 active
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 522 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the auxiliary temperature sensor.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
Guided Step 1A - Inspect the OEM harness and auxiliary temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor from the OEM harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and auxiliary temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the OEM harness or the auxiliary temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the auxiliary temperature sensor. Reference the OEM troubleshooting and repair manual.
  • Replace the auxiliary temperature sensor. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 522 active

Repair complete.

Go to 1C

Go to 4A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823256 - female Metri-Pack test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor from the OEM harness.

Action

Check for short circuit to ground.

  • Measure the resistance from pin A of the auxiliary temperature sensor to engine block ground.
OK NOT OK

More than 100k ohms

Replace the auxiliary temperature sensor

Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
Guided Step 1D - Verify Fault Code 522 is still active with the auxiliary temperature sensor disconnected.

Conditions

  • Turn keyswitch ON.
  • Disconnect the auxiliary temperature sensor from the OEM harness.

Action

Verify Fault Code 522 is still active with the auxiliary temperature sensor disconnected.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 522 active

Replace the auxiliary temperature sensor

Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See OEM instructions for more details.)

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
Guided Step 2A - Inspect the OEM harness and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM harness and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 522 active

Repair complete.

Go to 2C

Go to 4A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C6 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin D of the OEM harness C5 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 2D

Go to 4A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor from the OEM harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin D of the OEM harness C5 connector to all other pins of the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the main engine harness.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; or an Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 522 active

Repair complete.

Go to 3C

Go to 4A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823993 - male Deutsch test lead.
Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 28 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 28 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 522 is inactive.
OK NOT OK

Fault Code 522 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 1A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 523 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 1A - Inspect the OEM and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Set the intermediate-speed switch to the ON position.
  • Set the alternate droop switch to the OFF position.

Action

Check for an open circuit.

  • Measure the resistance from pin C of the OEM harness C5 connector to pin H of the OEM harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness or intermediate-speed switch, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Replace the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Set the intermediate-speed switch to the OFF position.
  • Set the alternate droop switch to the OFF position.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin E of the OEM harness C5 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or intermediate-speed switch, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Replace the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Set the intermediate-speed switch to the OFF position.
  • Set the alternate droop switch to the OFF position.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin E of the OEM harness C5 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin C of the OEM harness C5 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or intermediate-speed switch, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.
  • Replace the intermediate-speed switch. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 of the main engine harness ECM connector to pin C of the main engine harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 5 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 5 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 523 is inactive.
OK NOT OK

Fault Code 523 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.) |
 | STEP 1A. Inspect the OEM harness and the main engine harness connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the main engine harness. |
 | STEP 2A. Inspect the main engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 524 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the OEM harness. (The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. See the OEM manual for more details.)

Guided Step 1A - Inspect the OEM and the main engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the OEM and main engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or the OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Set the intermediate-speed switch to the OFF position.
  • Set the alternate droop switch to the ON position.

Action

Check for an open circuit.

  • Measure the resistance from pin C of the OEM harness C5 connector to pin H of the OEM harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness or alternate droop switch, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the alternate droop switch. Reference the OEM troubleshooting and repair manual.
  • Replace the alternate droop switch. Reference the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3823994 - female Deutsch test lead.
Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Set the alternate droop switch to the OFF position.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin D of the OEM harness C5 connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or alternate droop switch, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the alternate droop switch. Reference the OEM troubleshooting and repair manual.
  • Replace the alternate droop switch. Reference the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Set the intermediate-speed switch to the OFF position.
  • Set the alternate droop switch to the OFF position.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin C of the OEM harness C5 connector to all other pins in the OEM harness C5 and C6 connectors.
  • Measure the resistance from pin D of the OEM harness C5 connector to all other pins in the OEM harness C5 and C6 connectors.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness or alternate droop switch, whichever has the open circuit.

  • Repair the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Reference the OEM troubleshooting and repair manual.
  • Repair the alternate droop switch. Reference the OEM troubleshooting and repair manual.
  • Replace the alternate droop switch. Reference the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the main engine harness.

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the main engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the main engine harness.
  • Flush and clean the connector pins using electronic contact cleaner, Part Number 3824510.

Action

Inspect the main engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the main engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823993 - male Deutsch test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 of the main engine harness ECM connector to pin C of the main engine harness C5 connector.
OK NOT OK

Less than 10 ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 connector.
  • Disconnect the ECM from the main engine harness.

Action

Check for short circuit to ground.

  • Measure the resistance from pin 28 of the main engine harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.
Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the main engine harness at the C5 and C6 connectors.
  • Disconnect the ECM from the main engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
  • Measure the resistance from pin 28 of the main engine harness ECM connector to all other pins in the main engine harness ECM connector.
OK NOT OK

More than 100k ohms

Replace the ECM.

Refer to Procedure 019-031.

Repair or replace the main engine harness

  • Repair the main engine harness. Refer to Procedure 019-043.
  • Replace the main engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 524 is inactive.
OK NOT OK

Fault Code 524 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Calibrate the ECM. | Calibrated ECM
STEP 2. | Clear the fault codes. |
 | STEP 2A. Read the fault codes. | Fault Code 525 not logged
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Calibrate the ECM.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the ECM.

  • Calibrate the ECM with the appropriate ECM code using Compulink™, Part Number 3823549; or INSITE™, Part Number 3824638.
OK NOT OK

Calibrated ECM

Replace the ECM

Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
  • Verify Fault Code 525 is not logged.
OK NOT OK

Fault Code 525 not logged.

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 444, 452, or 511 not logged
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 552 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

Fault Codes 444, 452, or 511 not logged

Troubleshoot any remaining fault codes

Reference Fault Code 444, 452, or 511 troubleshooting tree.

Troubleshoot engine symptoms.
Reference the appropriate symptom list.

Appropriate troubleshooting chart

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 552 is inactive.
OK NOT OK

Fault Code 552 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault code.

Conditions

  • Connect all components.

Action

Clear the inactive fault code.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 451 not logged
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 554 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using Compulink™, Part Number 3823549, Echek™, Part Number 3824437, or INSITE™, Part Number 3824638.
OK NOT OK

Fault Code 451 not logged

Troubleshoot any remaining fault codes

Reference Fault Code 451 troubleshooting tree.

Troubleshoot engine symptoms.
Reference the appropriate symptom list.

Appropriate troubleshooting chart

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for one minute.
  • Verify Fault Code 554 is inactive.
OK NOT OK

Fault Code 554 inactive

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using Compulink™, Part Number 3823549; Echek™, Part Number 3824437; or INSITE™, Part Number 3824638.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes codes.

Repair complete

Appropriate troubleshooting chart


INDEX
98-fc111.htm

98-t05-111.htm

98-fc113.htm

98-t05-113.htm

98-fc114.htm

98-t05-114.htm

98-fc115.htm

98-fc115vva.htm

98-t05-115vva.htm

98-fc115fa.htm

98-t05-115fa.htm

98-fc121.htm

98-t05-121.htm

98-fc131.htm

98-fc131ctap.htm

98-t05-131ctap.htm

98-fc131nctap.htm

98-t05-131nctap.htm

98-fc131as.htm

98-t05-131as.htm

98-fc131fa.htm

98-t05-131fa.htm

98-fc132.htm

98-fc132ctap.htm

98-t05-132ctap.htm

98-fc132nctap.htm

98-t05-132nctap.htm

98-fc132fa.htm

98-t05-132fa.htm

98-fc135.htm

98-t05-135.htm

98-fc141.htm

98-t05-141.htm

98-fc144.htm

98-t05-144.htm

98-fc145.htm

98-t05-145.htm

98-fc234.htm

98-t05-234.htm

98-fc254.htm

98-t05-254.htm

98-fc255.htm

98-t05-255.htm

98-fc341.htm

98-t05-341.htm

98-fc342.htm

98-t05-342.htm

98-fc353.htm

98-t05-353.htm

98-fc412.htm

98-t05-412.htm

98-fc414.htm

98-t05-414.htm

98-fc431.htm

98-t05-431.htm

98-fc432.htm

98-fc432ctap.htm

98-t05-432ctap.htm

98-fc432nctap.htm

98-t05-432nctap.htm

98-fc441.htm

98-t05-441.htm

98-fc442.htm

98-t05-442.htm

98-fc443.htm

98-fc443ctap.htm

98-t05-443ctap.htm

98-fc443nctap.htm

98-t05-443nctap.htm

98-fc443as.htm

98-t05-443as.htm

98-fc443fa.htm

98-t05-443fa.htm

98-fc444.htm

98-t05-444.htm

98-fc445.htm

98-t05-445.htm

98-fc451.htm

98-t05-451.htm

98-fc452.htm

98-t05-452.htm

98-fc455.htm

98-t05-455.htm

98-fc511.htm

98-t05-511.htm

98-fc514.htm

98-t05-514.htm

98-fc521.htm

98-t05-521.htm

98-fc522.htm

98-t05-522.htm

98-fc523.htm

98-t05-523.htm

98-fc524.htm

98-t05-524.htm

98-fc525.htm

98-t05-525.htm

98-fc552.htm

98-t05-552.htm

98-fc554.htm

98-t05-554.htm