QSK 23/60/78 CM850 Power Gen Interface, QSK 23/60/78 CM500 Power Gen,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Timing Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 112

Engine Timing Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 112 PID: SPN: 635 FMI: 7 LAMP: Red SRT: | Engine Timing Actuator - Mechanical System Not Responding or Out of Adjustment. The error between the estimated timing fueling and the desired timing fueling is outside the allowable limits. | Calibration-dependent engine shutdown or no action is taken by ECM.
Fuel System Flow Schematic

Circuit Description

ECM 2 (CM500 ECM) The ECM uses the timing pressure signal and engine speed to estimate the actual timing the engine is receiving and then constantly compares this value to the desired timing for the given speed and load. When there is too large of an error in these values for too long, Fault Code 112 is logged.

Component Location

The two timing actuators are located on the left-side (top) of the electronic control valve assembly (ECVA) above the fuel shutoff valve. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is a check on ECM 2's control of the timing rail actuator and subsequent fuel pressure. If the desired timing pressure can not be met by commanding more current to the actuator or if the desired timing pressure is being exceeded and can not be reduced by reducing the current to the actuator, Fault Code 112 is logged. Air in the fuel system can also trigger this fault code.

Fault Code 112 is not logged for the following:

  • Fault Code 116 or 117 active
  • Once the keyswitch is cycled, Fault Code 112 becomes inactive.

Follow the troubleshooting steps before replacing the actuator.

Refer to Troubleshooting Fault Code t05-112.

Last Modified: 28-Apr-2011
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Timing Actuator Circuit - Shorted High

FAULT CODE 113

Engine Timing Actuator Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 113 PID: SPN: 175 FMI: 3 LAMP: Amber SRT: | Engine Timing Actuator Circuit - Shorted High. Timing actuator circuit is open, or the timing rail actuator SIGNAL pin is shorted to ground, or the timing rail actuator RETURN pin is shorted to battery. | No action by the ECM is taken. Actuator is open, closed, or partially closed. Engine power output will vary and white smoke can occur. Fault Code 112 can also be logged.
Timing Rail Actuator Circuit

Circuit Description

The timing rail actuator circuit supplies current to the timing rail actuator(s). The ECM commands a varying amount of current to the timing rail actuator to control the amount of timing pressure to the injectors.

Component Location

The timing rail actuators are located at the left side (top) of the electronic control valve assembly (ECVA).

Shop Talk

Confirm that the actuator connector is firmly in place. When there is power to the actuator(s), the actuator opens. This can cause Fault Code 112, timing flow mismatch.

Refer to Troubleshooting Fault Code t05-113.

Last Modified: 28-Apr-2011


Engine Speed/Position Sensor Circuit - Lost Both of Two Signals from the Magnetic Pickup Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Speed/Position Sensor Circuit - Lost Both of Two Signals from the Magnetic Pickup Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: SPN: 190 FMI: 2 LAMP: Red SRT: | Engine Speed/Position Sensor Circuit - Lost Both of Two Signals from the Magnetic Pickup Sensor - Data Erratic, Intermittent, or Incorrect. No engine speed signal detected from the main and backup speed sensors. | Engine is shut down and can not be operated.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual-coil circuit that provides the engine speed signal to the electronic control module (ECM) through the engine harness.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

If the problem occurs only at a certain engine temperature, make sure to check the engine speed sensor circuit while the engine is at that particular temperature. Check for correct air gap of engine speed sensor to flywheel tooth. Refer to Procedure 019-042 in Section 19.

Some speed sensors can use a single Deutsch™ harness connector instead of the two Weather Pack™ connectors.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 28-Apr-2011


Fuel Timing Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 116

Fuel Timing Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 116 PID: SPN: 156 FMI: 3 LAMP: Red SRT: | Fuel Timing Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Calibration-dependent engine shutdown occurs, or no action is taken by ECM.
Fuel Timing Rail Pressure Sensor Circuit

Circuit Description

The timing rail pressure sensor provides the timing rail pressure signal to the electronic control module (ECM) through the engine harness. The ECM uses the timing rail pressure signal to monitor the timing rail pressure going to the injector's timing chamber from the control valve body.

Component Location

The timing rail pressure sensor is located on the right-side (top) of the electronic control valve assembly (ECVA), across from the timing rail actuators.

Shop Talk

Reference specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin call outs. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-116.

Last Modified: 28-Apr-2011


Fuel Timing Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 117

Fuel Timing Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 117 PID: SPN: 156 FMI: 4 LAMP: Red SRT: | Fuel Timing Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Calibration-dependent engine shutdown occurs, or no action is taken by ECM.
Fuel Timing Rail Pressure Sensor Circuit

Circuit Description

The timing rail pressure sensor provides the timing rail pressure signal to the ECM through the engine harness. The ECM uses the timing rail pressure signal to monitor the timing rail pressure going to the injector's timing chamber from the control valve body.

Component Location

The timing rail pressure sensor is located on the right-side (top) of the electronic control valve assembly (ECVA), across from the timing rail actuators.

Shop Talk

Reference specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-117.

Last Modified: 28-Apr-2011


Fuel Pump Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 118

Fuel Pump Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 118 PID: SPN: 135 FMI: 3 LAMP: Amber SRT: | Fuel Pump Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No action is taken by the ECM. Possible loss of performance.
Fuel Pump Pressure Sensor Circuit

Circuit Description

The fuel pump pressure sensor provides the fuel pump pressure signal to the ECM, through the engine harness. The ECM uses the fuel pump pressure signal to monitor the fuel pump pressure going to the control valve body.

Component Location

The fuel pump pressure sensor is located on the fuel pump, above the fuel pump actuator.

Shop Talk

Reference specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-118.

Last Modified: 28-Apr-2011


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 119

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 119 PID: SPN: 135 FMI: 4 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No action is taken by the ECM. Possible loss of performance.
Fuel Pump Delivery Pressure Sensor Circuit

Circuit Description

The fuel pump pressure sensor provides the fuel pump pressure signal to the ECM, through the engine harness. The ECM uses the fuel pump pressure signal to monitor the fuel pump pressure going to the control valve body.

Component Location

The fuel pump pressure sensor is located on the fuel pump, above the fuel pump actuator.

Shop Talk

Reference specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-119.

Last Modified: 28-Apr-2011


Engine Speed/Position Sensor Circuit - Lost One of Two Signals from the Magnetic Pickup Sensor - Abnormal Rate of Change

FAULT CODE 121

Engine Speed/Position Sensor Circuit - Lost One of Two Signals from the Magnetic Pickup Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: SPN: 190 FMI: 10 LAMP: Amber SRT: | Engine Speed/Position Sensor Circuit - Lost One of Two Signals from the Magnetic Pickup Sensor - Abnormal Rate of Change. No engine speed signal detected from either the main or backup speed sensors. | No action by the ECM is taken. No effect on performance.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual coil circuit that provides the engine speed signal to the ECM through the engine harness.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

If the problem occurs only at a certain engine temperature, make sure to check the engine speed sensor circuit while the engine is at that particular temperature. Check for a correct air gap of engine speed sensor to flywheel tooth. Some speed sensors can use a single Deutsch™ harness connector instead of two Weather Pack™ connectors.

Refer to Troubleshooting Fault Code t05-121.

Last Modified: 28-Apr-2011


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: SPN: 102 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No action is taken by the ECM. Possible loss of performance.
Intake Manifold Pressure Sensor 1 Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the ECM. High voltage will log Fault Code 122 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the RETURN wire, or a malfunctioned sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Determine if the engine is being over fueled.

Confirm that the correct intake manifold pressure sensor part number is being used.

Confirm that the correct turbocharger is being used.

If it is suspected that cold intake air can be the cause of the high intake manifold pressure, test the engine while feeding warm intake air. Inspect the intake manifold pressure sensor circuit for signs of tampering. Remove any extra wires from the circuit. Reference specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-122.

Last Modified: 28-Apr-2011


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: SPN: 102 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit -Voltage Below Normal or Shorted to Low Source. | No action is taken by the ECM. Possible loss of performance.
Intake Manifold Pressure Sensor 1 Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the ECM. Low voltage will trip Fault Code 123 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the SUPPLY or SIGNAL wires, low supply voltage from the ECM, or a malfunctioned sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Check for high restriction in the intake air manifold due to clogged air filters or a shutdown device in the manifold. Do not remove this device if the engine is operated in a flammable atmosphere. The device is an essential safety feature.

Make sure the turbocharger is working correctly. Check for a positive intake manifold pressure.

Reference specific engine wiring diagrams for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-123.

Last Modified: 28-Apr-2011


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: SPN: 100 FMI: 3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the ECM. The ECM monitors the voltage on the oil pressure SIGNAL pin and expects to see the voltage vary between 0.46 and 4.56-VDC during normal engine operation. High voltage will trip Fault Code 135 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the RETURN wire, or a failed sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Does the fault code occur only in cold weather? If so, allow the oil to warm up and see if the fault code goes inactive.

Reference specific engine wiring diagrams for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-135.

Last Modified: 28-Apr-2011


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: SPN: 100 FMI: 4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the ECM. The ECM monitors the voltage on the oil pressure signal pin and expects to see the voltage vary between 0.46 and 4.56-VDC during normal engine operation. Low voltage will trip Fault Code 141 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the SUPPLY or SIGNAL wires, low supply voltage from the ECM, or a malfunctioned sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

If Fault Code 143 or 415 is not present, the problem is not base engine related.

Reference specific engine wiring diagrams for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-141.

Last Modified: 28-Apr-2011


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Voltage signal indicates off pressure has dropped below the warning threshold for low oil pressure. | Calibration-dependent engine shutdown occurs, or no action is taken by ECM. Pre-low oil pressure relay driver is energized.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference specific engine wiring diagrams for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-143.

Last Modified: 28-Apr-2011


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No engine protection for coolant temperature. Possible white smoke.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is high, the ECM will log Fault Code 144. High voltage can be caused by opens in the SIGNAL or RETURN wires, voltage shorts to the SIGNAL or RETURN wires, or a malfunctioned open sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-144.

Last Modified: 28-Apr-2011


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for coolant temperature. Possible white smoke.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing and fueling control. If the voltage is low for more than 2 seconds, the ECM will log Fault Code 145. Low voltage can be caused by shorts to ground on the SUPPLY or RETURN wires or an internally grounded malfunctioned sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-145.

Last Modified: 28-Apr-2011


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Sever Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Sever Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: SPN: 110 FMI: 16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Sever Level. Engine coolant temperature has exceeded the warning threshold for high coolant temperature. | Calibration dependent, no action is taken by the ECM or engine shutdown, as temperature increases over thresholds. Pre-high engine temperature relay driver is energized.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low for more than 2 seconds, the ECM will log Fault Code 146.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Make sure the airflow through the radiator is not obstructed. The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-146.

Last Modified: 28-Apr-2011


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine coolant temperature has exceeded the alarm (shutdown) threshold for high coolant temperature. | Engine will shut down. High engine temperature (HET) relay driver is energized.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low for more than 2 seconds, the ECM will log Fault Code 151.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Make sure the airflow through the radiator is not obstructed. The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-151.

Last Modified: 28-Apr-2011


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. Engine intake manifold temperature sensor signal is shorted high. | No engine protection for the intake manifold air temperature. Possible white smoke.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is high, the ECM will log Fault Code 153. Voltage high can be caused by opens in the SIGNAL or RETURN wires, voltage shorts to the SIGNAL or RETURN wires, or a malfunctioned open sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-153.

Last Modified: 28-Apr-2011


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to Low Source. Engine intake manifold temperature sensor signal is shorted low. | No engine protection for the intake manifold temperature. Possible white smoke.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold downstream of the aftercooler element. The intake manifold temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low, the ECM will log Fault Code 154. Low voltage can be caused by shorts to engine block ground on the SUPPLY or RETURN wires or an internally grounded malfunctioned sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-154.

Last Modified: 28-Apr-2011


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine intake manifold air temperature has exceeded the alarm (shutdown) threshold for high intake manifold temperature. | Engine will shut down. High engine temperature (HET) relay driver is energized.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low, the ECM will log Fault Code 155. Low voltage can be caused by a cooling system failure or an in-range sensor malfunction.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-155.

Last Modified: 28-Apr-2011


Engine Control Module Network Communication Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 185

Engine Control Module Network Communication Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 185 PID: None SPN: 639 FMI: 2 LAMP: Amber SRT: | Engine Control Module Network Communication Error - Data Erratic, Intermittent, or Incorrect. Communication between ECM1 (CM850) and ECM2 (CM500) has been interrupted. | Possible loss of performance.
Engine Control Module Network Communication Error Circuit

Circuit Description

The QSK78 electronic control system utilizes an SAE J1939 connection for communication between the primary and secondary ECMs. If this backbone fails, communication between the ECMs will stop, causing the engine to run poorly.

Component Location

The multiple ECMs are located in the generator control panel, off the engine. The SAE J1939 backbone is also located in this panel. Refer to Procedure 100-002 in Section E.

Shop Talk

This electronic control system utilizes two ECMs. The primary ECM is a CM850 and will be denoted as ECM1 (CM850) in this manual. The secondary ECM is a CM500 and will be denoted as ECM2 (CM500) in this manual. In this particular electronic control system, ECM2 (CM500) receives fueling and timing commands from ECM1 (CM850).

Possible causes of this fault code include:

  • Damaged ECM connectors on both harness and ECM
  • Damaged fuse
  • Open or short circuit in J1939 SUPPLY or RETURN
  • Open or short circuit in shield wire
  • Short circuit from pin-to-pin in J1939 Data link 1 SUPPLY and RETURN
  • Improper termination or harness
  • Improper individual termination of harness.
Refer to Troubleshooting Fault Code t05-185.

Last Modified: 25-Apr-2011


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: SPN: 3510 FMI: 4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 2 circuit. | Loss of some sensor functionality.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the ECM provides 5-VDC for the intake manifold pressure sensor, blow-by pressure sensor, coolant pressure sensor, and barometric pressure sensor.

Component Location

The sensor supply 2 is located in the ECM.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Short circuit to ground in a supply line
  • Short circuit between a supply line or return wire
  • Damaged sensor
  • ECM power supply.
Refer to Troubleshooting Fault Code t05-187.

Last Modified: 28-Apr-2011


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Coolant Level Sensor 1 Circuit

Circuit Description

The coolant level sensor 1 monitors the engine coolant level within the cooling system and passes information to the ECM through the engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Reference the OEM service manual for component location.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-195.

Last Modified: 25-Apr-2011


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: SPN: 111 FMI: 4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
Coolant Level Sensor 1 Circuit

Circuit Description

The coolant level 1 sensor monitors the engine coolant level within the cooling system and passes information to the ECM through the engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Reference the OEM service manual for location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Signal circuit shorted to ground or return in the harness, sensor, or connectors
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196.

Last Modified: 25-Apr-2011


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: SPN: 111 FMI: 18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Voltage signal indicates low radiator coolant level. | No action is taken by the ECM. Fault Codes 146, 151, 228, and/or 233 can also be logged.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM).

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

  • When the coolant level drops below a certain level, a power derate will be activated, which will decrease the power output by 50 percent over a 30-second period.
  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly. The coolant level switch high signal must be shorted to the coolant level switch supply, and the coolant level switch low signal must be shorted to the coolant level switch return.
  • Inspect the wiring harness between the four-way connector and the coolant level sensor for damage.
Refer to Troubleshooting Fault Code t05-197.

Last Modified: 13-Apr-2011


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: SPN: 175 FMI: 3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. | No engine protection for oil temperature. No effect on performance.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and the engine protection is enabled, a derate condition can be implemented, possibly leading to shutdown.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-212.

Last Modified: 13-Apr-2011


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: SPN: 175 FMI: 4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for the oil temperature. No effect on performance.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition will be implemented, possibly leading to shutdown.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-213.

Last Modified: 13-Apr-2011


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: SPN: 175 FMI: 0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine oil temperature has exceeded the alarm (shutdown) threshold for high oil temperature. | Engine will shut down.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the ECM to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition will be implemeted, possibly leading to shutdown.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-214.

Last Modified: 13-Apr-2011


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: SPN: 108 FMI: 3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No action is taken by the ECM. Possible loss of performance.
Barometric Pressure Sensor Circuit

Circuit Description

This troubleshooting tree is intended for troubleshooting absolute pressure sensors only. The barometric pressure sensor monitors barometric pressure and passes information to the electronic control module (ECM). The ECM uses the barometric pressure sensor to adjust fueling, based on the altitude.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

Monitor the barometric pressure reading with an electronic service tool to confirm that the pressure reading matches the actual air pressure.

Reference specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

The following shows the typical PSIA pressure values for the corresponding altitude values:

Altitude (ft) | PSIA
0 | 14.45
3000 | 13.17
6000 | 11.78
9000 | 10.50
12000 | 9.35
Refer to Troubleshooting Fault Code t05-221.

Last Modified: 13-Apr-2011


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: SPN: 108 FMI: 4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Barometric pressure sensor is shorted low. | No engine protection for barometric pressure. Possible loss of performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor provides the barometric air pressure signal to the electronic control module (ECM). The ECM uses the barometric pressure sensor to adjust fueling, based on the altitude.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

Monitor the barometric pressure reading with an electronic service tool to confirm that the pressure reading matches the actual air pressure.

Reference the specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-222.

Last Modified: 13-Apr-2011


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 223

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S85 SPN: 1265 FMI: 4 LAMP: Amber SRT: | Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source. Less than 18.0-VDC detected at the Centinel™ burn valve solenoid supply pin of the engine harness or resistance of the solenoid has dropped below 80 ohms. | ECM turns OFF the burn valve supply voltage and the Centinel™ system is disabled.
Burn Valve Solenoid Circuit

Circuit Description

The burn valve solenoid controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The burn valve solenoid is located on top of the oil control valve.

Refer to Troubleshooting Fault Code t05-223.

Last Modified: 13-Apr-2011


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 224

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 224 PID: SPN: 1265 FMI: 3 LAMP: Amber SRT: | Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage has been detected at the Centinel™ burn valve solenoid driver pin in the engine harness 50-pin connector or resistance of the solenoid is outside specifications. | ECM turns off the engine oil burn valve solenoid driver supply voltage and the system is disabled.
Engine Oil Burn Valve Solenoid Driver Circuit

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve is usually located on the rear left bank of the engine. Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code can be caused by the following:

  • A malfunctioning engine oil burn valve solenoid or solenoid driver
  • An open circuit in the output device driver return wire
  • A pin-to-pin short in the output device driver wire
  • Solenoid resistance falls outside the specifications.
Refer to Troubleshooting Fault Code t05-224.

Last Modified: 13-Apr-2011


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: SPN: 3510 FMI: 3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 2 circuit. | Loss of some sensor functionality.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the ECM provides 5-VDC for the intake manifold pressure sensor, blowby pressure sensor, coolant pressure sensor, and barometric pressure sensor.

Component Location

Sensor supply voltage 2 is located inside the ECM. Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the sensor supply 2 wire can be caused by a signal shorted to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code t05-227.

Last Modified: 13-Apr-2011


Engine Speed High - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Speed High - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: SPN: 190 FMI: 0 LAMP: Red SRT: | Engine Speed High - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signals indicate an engine speed greater than shutdown threshold. | Engine will shut down. Fuel shutoff valves are de-energized (valves close). Overspeed relay driver is energized.
Engine Overspeed

Circuit Description

The engine position sensor(s) monitor the engine position and the engine speed. It then passes this information to the electronic control module (ECM) through the engine harness.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include external fuel sources drawn into the intake air passage, reverse powering (motoring) of the engine, or tampering of the engine speed/position sensors. Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 03-Aug-2011


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: SPN: 111 FMI: 1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. | Engine will shut down.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the ECM.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

  • When the coolant level drops below a certain level, a power derate will be activated, which will decrease the power output by 50 percent over a 30-second period.
  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly. The coolant level switch high signal must be shorted to the coolant level switch supply and the coolant level switch low signal must be shorted to the coolant level switch return.
  • Inspect the wiring harness between the four-way connector and the coolant level sensor for damage.
Refer to Troubleshooting Fault Code t05-235.

Last Modified: 18-Nov-2016


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: SPN: 3511 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 3 circuit. | Loss of some sensor functionality. Possible hard starting and rough running.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 pin of ECM 1 (CM850) provides 5-VDC for the coolant level sensor.

Component Location

The sensor supply number 3 is located in ECM 1 (CM850).

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Low voltage on the 5 volt supply wire can be caused by:

  • A short circuit to ground in a supply wire
  • A short between a supply wire or return wire
  • A damaged engine crankshaft speed/position sensor
  • A damaged ECM power supply.
Refer to Troubleshooting Fault Code t05-238.

Last Modified: 12-Apr-2011


Engine Fuel Shutoff Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: SPN: 632 FMI: 4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the fuel shutoff valve signal pin or the resistance of the solenoid has dropped below the specified threshold. | The engine will shut down.
Fuel Shutoff Valve Solenoid Circuit

Circuit Description

The fuel shutoff valve solenoid is a device used by the electronic control module (ECM) to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel shutoff valve solenoid.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

Inspect the fuel shutoff supply circuit for external wires that might be spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and lowered the voltage on the fuel shutoff circuit. Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface. Check the starter solenoid positive (+) terminal for a loose connector or accessory wiring with damaged insulation.

Refer to Troubleshooting Fault Code t05-254.

Last Modified: 13-Apr-2011


Engine Fuel Shutoff Valve Stuck Open - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 259

Engine Fuel Shutoff Valve Stuck Open - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 259 PID: SPN: 632 FMI: 7 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Stuck Open - Mechanical System Not Responding or Out of Adjustment. | No action is taken by the electronic control module (ECM). Possible engine slow shutdown.
Fuel Shutoff Valve Solenoid Circuit

Circuit Description

Voltage is supplied to the fuel shutoff valve by the ECM while the run/stop switch is in the RUN position and engine speed is equal to crank. Upon placing the run/stop switch in the STOP position, the voltage to the fuel shutoff valve solenoid is turned off by the ECM. The fuel shutoff valve closes and stops fuel from flowing to the fueling and timing actuators.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

With the run/stop switch in the STOP position, the ECM turns off the voltage supplied to keep the fuel shutoff valve open. The ECM continues to fire the fueling and timing actuators as the engine spins down. The ECM monitors the engine speed. If the engine speed does not drop after the fuel shutoff valve solenoid is turned off, the ECM activates this fault.

Refer to Troubleshooting Fault Code t05-259.

Last Modified: 13-Apr-2011


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 261

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: SPN: 174 FMI: 16 LAMP: Amber SRT: | Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine fuel temperature has exceeded the warning threshold for high fuel temperature. | Calibration-dependent no action is taken by the ECM, or engine shutdown as temperature increases over thresholds.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature value is used by the ECM for the engine protection system.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-261.

Last Modified: 13-Apr-2011


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: SPN: 174 FMI: 3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. Engine fuel temperature sensor signal is shorted high. | No engine protection for fuel temperature. No effect on performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is high, the ECM will log Fault Code 263. High voltage can be caused by opens in the signal or return wires, voltage shorts to the signal, return wires, or a damaged open sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-263.

Last Modified: 18-Nov-2016


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: SPN: 174 FMI: 4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Engine fuel temperature sensor signal is shorted low. | No engine protection for fuel temperature. No effect on performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low, the ECM will log Fault Code 265. Low voltage can be caused by shorts to ground on the supply or return wires, or an internally grounded, damaged sensor.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-265.

Last Modified: 13-Apr-2011


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 266

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 266 PID: SPN: 174 FMI: 0 LAMP: Amber SRT: | Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine fuel temperature has exceeded the shutdown threshold for high fuel temperature. | Engine will shut down.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature value is used by the ECM for the engine protection system.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-266.

Last Modified: 13-Apr-2011


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: SPN: 639 FMI: 9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM did not receive a multiplexed message from an OEM vehicle electronic control unit within the time limit or did not receive it at all. | One or more multiplexed devices will not operate properly. One or more symptoms will occur.
SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the ECM directly through individual wires. Multiplexing allows those same components to be hard wired to a machine control unit. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the machine control unit to the ECM over the SAE J1939 data link.

Messages sent from the machine control unit are received by the ECM and used for controlling the engine. The ECM and generator control unit must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The ECMs are mounted off engine in the generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Generator control unit source address is incorrect in the ECM
  • Generator control uinit not set up to communicate with the ECM
  • Damaged J1939 datal link connection between the ECM and the generator control unit
  • Damaged connection between component and generator control unit
  • Damaged generator control unit
  • Damaged ECM.

It is possible to use INSITE™ electronic service tool to monitor the multiplexed components.

Refer to Troubleshooting Fault Code t05-285.

Last Modified: 13-Apr-2011


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: SPN: 639 FMI: 13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Multiplexing Configuration Circuit

Circuit Description

Normally, switches, accelerators and other components are connected to the ECM directly through individual wires. Multiplexing allows those same components to communicate with a generator control unit over a single data link. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the generator control unit to the ECM over the SAE J1939 data link.

Messages sent from the generator control unit are received by the ECM and used for controlling the engine. The ECM and generator control unit must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The ECMs are mounted off engine in the generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

Fault Code 286 can only go active if the electronic control module receives J1939 multiplexed data, but the data is not valid. Since the module is receiving this data from the OEM equipment, the data link must be good.

Possible cause of this fault code include:

  • Generator control unit not set up to communicate with a particular component
  • Damaged connection between component and generator control unit.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-286.

Last Modified: 13-Apr-2011


Fuel Supply Pump Actuator Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 316

Fuel Supply Pump Actuator Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 316 PID: SPN: 931 FMI: 3 LAMP: Amber SRT: | Fuel Supply Pump Actuator Circuit - Voltage Above Normal or Shorted to High Source. Fuel pump actuator circuit is open, the fuel pump actuator signal pin is shorted to battery voltage or ground, or fuel pump actuator return pin is shorted to battery voltage or ground. | No action is taken by the ECM. Possible loss of performance. Actuator is open, closed, or partially closed.
Fuel Supply Pump Actuator Circuit

Circuit Description

The fuel pump actuator circuit supplies current to the fuel pump actuator. The ECM commands a varying amount of current to the fuel pump actuator to control the fuel pump output pressure to the control valve assembly.

Component Location

The fuel pump actuator is on the fuel pump, just below the fuel pump sensor.

Shop Talk

Confirm that the actuator connector is firmly in place. When there is no power to the actuator, the actuator closes and fuel flow continues.

Refer to Troubleshooting Fault Code t05-316.

Last Modified: 13-Apr-2011


Fuel Supply Pump Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 318

Fuel Supply Pump Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 318 PID: SPN: 931 FMI: 7 LAMP: Amber SRT: | Fuel Supply Pump Actuator - Mechanical System Not Responding or Out of Adjustment. The error between the estimated fuel pump pressure and the desired fuel pump pressure is outside the allowable limits. | No action is taken by the ECM. Possible loss of performance.
Fuel Pump Actuator

Circuit Description

The ECM uses the fuel pump pressure signal and engine speed to estimate the actual fueling the engine is receiving, and constantly compares this value to the desired fueling for the given speed and load. When there is too large of an error in these values for too long of a time, Fault Code 318 is logged.

Component Location

The fuel pump actuator is on the fuel pump, just below the fuel pressure sensor.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault is a check on ECM2's (CM500 ECM) control of the fuel pump actuator and subsequent fuel flow. If the desired fueling can not be met by commanding more current to the actuator or if the desired fueling is being exceeded and can not be reduced by limiting the amount of current to the actuator, then Fault Code 318 is logged. Fault Code 318 is not logged if the coolant temperature is below 0°C [32°F].

  • Make sure that the correct calibration is loaded into the ECM.
  • Check for air in the fuel system.
  • Check for high fuel inlet restriction (plugged fuel filter, etc.)
Refer to Troubleshooting Fault Code t05-318.

Last Modified: 12-Apr-2011


Electronic Calibration Code Incompatibility - Out of Calibration

FAULT CODE 342

Electronic Calibration Code Incompatibility - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: SPN: 630 FMI: 13 LAMP: Red SRT: | Electronic Calibration Code Incompatibility - Out of Calibration. | Hard to start or no start.
Electronic Control Module (ECM)

Circuit Description

The ECMs communicate via the wiring harness.

Component Location

The ECMs are mounted off engine in the generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Both ECMs contain status information about the other ECM. At key ON, the communication status for ECM1 is set to ECM2 not accessible and then is updated when the data link messages from ECM2 are received. If there is a communication or performance calibration incompatibility between ECM1 and ECM2, this fault occurs, which may require a recalibration of the modules identified with the fault and source address. This is for incompatibilities in calibrations between the ECM1 and ECM2, and is not related to accessibility. ECM1 and ECM2 can communicate, but something in the ECM2 calibration does not match with the ECM1 calibration.

Possible causes of this fault code include:

  • Wrong or corrupt calibration
  • Wrong or damaged ECM
  • J1939 private data link terminating resistor damaged or disconnected
  • Damaged harness.
Refer to Troubleshooting Fault Code t05-342.

Last Modified: 12-Apr-2011


Engine Control Module Warning Internal Hardward Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardward Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: SPN: 629 FMI: 12 LAMP: Red SRT: | Engine Control Module Warning Internal Hardward Failure - Bad Intelligent Device or Component. Internal ECM error. | No action is taken by the ECM. Possible loss of performance.
Electronic Control Module

Circuit Description

The electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECMs are mounted off-engine in a generator control panel.

Shop Talk

This is a fault with the internal circuitry of the electronic control module (ECM). Loose engine or chassis ground connections can cause Fault Code 343 to be logged, as well as complaints of an intermittent stumble. Pay special attention to the negative starter post connection. Moisture in the ECM connectors can also cause the ECM to log Fault Code 343.

Refer to Troubleshooting Fault Code t05-343.

Last Modified: 13-Apr-2011


Engine Control Module Warning Software Error - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Warning Software Error - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: N/A SPN: 630 FMI: 12 LAMP: Amber SRT: N/A | Engine Control Module Warning Software Error - Bad Intelligent Device or Component. ECM power-down internal data store error. | Power-down data are lost. Power-down data include maintenance monitoring, present ECM and engine delta times, and past fault data.
Battery Power and Ground Circuit

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECMs are mounted off engine in the generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected.

  • This is a fault with the internal memory of the ECM. This fault can be caused by a power interruption to the ECM or a total loss of battery power.
  • Fault Code 346 can be caused by not following the correct engine shutdown procedure. If a master disconnect switch is being used, you must turn the keyswitch OFF, wait 30 seconds, then disconnect the batteries using the master disconnect switch. This allows the ECM to save information to memory. If the operator does not wait 30 seconds before disconnecting the batteries, Fault Code 346 will be logged.
  • If Fault Code 346 is active, turn the keyswitch ON, then turn it to OFF and wait 30 seconds. Repeat this step three times with a 30-second delay between each key cycle.

This fault occurs in ECM 2. Fault Code 1117 will occur in ECM 1 if the correct shutdown procedure is not followed. Field repairs to the ECMs are not possible.

Refer to Troubleshooting Fault Code t05-346.

Last Modified: 25-Apr-2011


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Loss of some sensor functionality.
Sensor Supply 1 Circuit

Circuit Description

Sensor supply number 1 voltage from ECM 1 (CM850 ECM) provides 5-VDC supply for the engine oil rifle pressure sensor and the oil level sensor.

Component Location

The sensor supply number 1 is located in ECM 1 (CM850 ECM). The supply voltage is provided to each sensor it supports.

Shop Talk

There are multiple ECMs for this engine Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Low voltage on the 5-VDC supply line can be caused by a short to ground in a SUPPLY wire, a short circuit between a SUPPLY wire and a RETURN wire, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-352.

Last Modified: 25-Apr-2011


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Loss of some sensor functionality.
Sensor Supply 1 Circuit

Circuit Description

Sensor supply number 1 voltage from ECM 1 (CM850 ECM) provides 5-VDC supply for the engine oil rifle pressure sensor and the oil level sensor.

Component Location

The sensor supply number 1 is located in ECM 1 (CM850 ECM). The supply voltage is provided to each sensor it supports.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the sensor supply can be caused by an individual sensor SUPPLY wire in the harness shorted to battery voltage or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-386

Last Modified: 25-Apr-2011


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: SPN: 100 FMI: 1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Voltage signal indicates oil pressure has dropped below the shutdown threshold for low oil pressure. | Engine will shut down. Low oil pressure relay driver is energized.
Oil Rifle Pressure Circuit

Circuit Description

The oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Confirm that the oil pressure sensor supply voltage is between 4.75 and 5.25-VDC at the sensor. See Fault Code 141. Verify with the operator at what engine speed the fault occurs. If the engine is being operated at too low of a speed under load (lugging), the oil pressure can drop below the engine protection limits because of the oil temperature. Oil pressure is a function of engine speed, oil level, and regulator function. Operating the engine at a low speed under load will not cause the oil pressure to be low unless the oil is hot, at a low level, regulator has malfunctioned, or a loss is occurring somewhere in the system.

Reference specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-415.

Last Modified: 28-Apr-2011


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: SPN: 175 FMI: 16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil temperature has exceeded the warning threshold for high oil temperature. | No action is taken by the ECM. Possible loss of performance.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition could be incurred, possibly leading to shutdown.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-421.

Last Modified: 04-May-2011


Engine Fuel Timing Pressure or Timing Actuator Stuck - Data Erratic, Intermittent, or Incorrect

FAULT CODE 423

Engine Fuel Timing Pressure or Timing Actuator Stuck - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 423 PID: SPN: 156 FMI: 2 LAMP: Amber SRT: | Engine Fuel Timing Pressure or Timing Actuator Stuck - Data Erratic, Intermittent, or Incorrect. Timing pressure sensor in-range error detected. Voltage signal indicates that the timing pressure sensor signal can possibly not be accurate. | No action taken by the ECM. Possible loss of performance.
Timing Rail Pressure Sensor Circuit

Circuit Description

The timing rail pressure sensor provides the timing rail pressure signal to the ECM through the engine harness. The ECM uses the timing rail pressure signal to monitor the timing fuel pressure going to the injector's timing chamber from the control valve body.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E. The pressure sensor is located on the right, towards the top of the electronic control valve assembly (ECVA), across from the timing rail actuator.

Shop Talk

Reference a specific engine wiring diagram for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-423.

Last Modified: 04-May-2011


SAE J1939 Data Link Number 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

SAE J1939 Data Link Number 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Data Link Number 1 - Data Erratic, Intermittent, or Incorrect. Communication between the ECM and another device on the SAE J1939 data link has been lost. | None on performance. SAE J1939 data link devices possibly do not operate.
SAE J1939 Data Link Circuit

Circuit Description

Devices such as the generator control panel, electronic displays, electronic information systems, and electronic service tools can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The ECMs are mounted off-engine in a generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code only exists in Power Generation applications using multiplexed inputs, and will only go active if ECM 1 (CM850 ECM) stops receiving Speed Bias, Alternate Frequency, or Idle/Rated information from the generator drive controller over the data link.

Refer to Troubleshooting Fault Code t05-426

Last Modified: 25-Apr-2011


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: SPN: 168 FMI: 1 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. | ECM voltage supply approaching level at which unpredictable operation will occur.
Unswitched Battery #1 Circuit

Circuit Description

The ECM receives unswitched battery input through the engine harness. There is an inline 20-ampere fuse in the unswitched positive (+) battery wire of the engine harness to protect the engine harness from overheating. The battery wires are connected to the starters. The customer connects the batteries to the starters.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to the OEM service manual for the battery location.

Shop Talk

This fault is usually caused by loose or corroded battery connections.

Refer to Troubleshooting Fault Code t05-441.

Last Modified: 03-Aug-2011


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: SPN: 168 FMI: 0 LAMP: Amber SRT: | Battery 1 Voltage High - Data Valid But Above Normal Operating Range - Moderately Severe Level. | ECM damage will occur.
Battery #1 Voltage Circuit

Circuit Description

The ECM receives unswitched battery input through the engine harness. There is an in-line 20 ampere fuse in the unswitched positive (+) battery wire of the engine harness to protect the engine harness from overheating. The battery RETURN wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to the OEM service manual for the battery location.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-442.

Last Modified: 03-Aug-2011


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. This circuit was formerly called the fuel rail pressure sensor. | Calibration-dependent engine shutdown occurs, or no action is taken by the ECM.
Injector Metering Rail #1 Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor provides the fuel rail pressure signal to the ECM, through the engine harness. The ECM uses the fuel rail pressure signal to monitor the fuel rail pressure going to the injector's metering chamber from the control valve body.

Component Location

Use the following procedure for a detail component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference specific engine wiring diagrams for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-451.

Last Modified: 03-Aug-2011


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. This was formerly called the fuel rail pressure sensor. | Calibration-dependent engine shutdown occurs, or no action is taken by the ECM.
Injector Metering Rail #1 Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor provides the fuel rail pressure signal to the ECM, through the engine harness. The ECM uses the fuel rail pressure signal to monitor the fuel rail pressure going to the injector's metering chamber from the control valve body.

Component Location

Use the following procedure for a detail component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference specific engine wiring diagams for the output voltage of the pressure sensor.

Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-452.

Last Modified: 03-Aug-2011


Electronic Fuel Control Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 455

Electronic Fuel Control Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: SPN: 633 FMI: 3 LAMP: Red SRT: | Electronic Fuel Control Valve Circuit - Voltage Above Normal or Shorted to High Source. This was formerly called the fuel rail actuator circuit. The fuel rail actuator circuit is open, the fuel rail actuator SIGNAL pin is shorted to battery voltage or ground, or the fuel rail actuator RETURN pin is shorted to battery voltage or ground. | Engine will run at one speed or will shut down. Fault Code 514 may also be logged.
Electronic Fuel Control Valve Circuit

Circuit Description

The fuel rail actuator is a device used by the ECM to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel rail actuator.

Component Location

Use the following procedure for a detail component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Confirm that the valve connector is firmly in place. When there is shorted power to the actuator, the actuator opens and fuel flow is uncontrolled. This will cause Fault Code 234, engine overspeed, or Fault Code 514, fueling flow mismatch.

Refer to Troubleshooting Fault Code t05-455.

Last Modified: 04-May-2011


Engine Timing Rail Actuator Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 467

Engine Timing Rail Actuator Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 467 PID: SPN: 635 FMI: 2 LAMP: Amber SRT: | Engine Timing Rail Actuator Circuit - Data Erratic, Intermittent, or Incorrect. The error between desired timing fueling and commanded timing fueling exceeds a normal limit. | No action taken by the ECM. Possible loss of performance.
Engine Timing Rail Actuator Circuit

Circuit Description

The ECM uses the timing pressure signal and engine speed to estimate the actual timing the engine is receiving, and then constantly compares this value to the desired timing for the given speed and load. When there is too large of an error in these values for too long, Fault Code 467 is logged.

Component Location

The timing rail actuators are located on the left side (top) of the electronic control valve assembly (ECVA).

Shop Talk

The estimated timing fueling and the desired timing fueling parameters can be monitored on the electronic service tool. This fault is a check on the ECM's control of the timing actuator and subsequent fuel flow. If the desired timing fueling can not be met by commanding more current to the actuator, or if the desired timing fueling is being exceeded and can not be reduced by limiting the amount of current to the actuator, then Fault Code 467 is logged.

Refer to Troubleshooting Fault Code t05-467.

Last Modified: 04-May-2011


Fuel Rail Actuator Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 468

Fuel Rail Actuator Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 468 PID: SPN: 633 FMI: 2 LAMP: Amber SRT: | Fuel Rail Actuator Circuit - Data Erratic, Intermittent, or Incorrect. The error between desired rail fueling and commanded rail fueling exceeds a normal limit. | No action is taken by the ECM. Possible loss of performance.
Fuel Rail Actuator Circuit

Circuit Description

The ECM uses the rail pressure signal and the engine speed to estimate the actual fueling that the engine is receiving, and then constantly compares this value to the desired fueling for the given speed and load. When there is an error too large in these values for too long, this fault is logged.

Component Location

The fuel rail actuator is located on the left side (bottom) of the electronic control valve assembly (ECVA).

Shop Talk

The estimated fuel railing and the desired fuel railing parameters can be monitored using the electronic service tool. This fault is a check on the ECM's control of the rail actuator and subsequent fuel flow. If the desired fuel railing can not be met by commanding more current to the actuator, or if the desired fuel railing is being exceeded and can not be reduced by limiting the amount of current to the actuator, then this fault is logged.

Refer to Troubleshooting Fault Code t05-468.

Last Modified: 04-May-2011


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: SPN: 105 FMI: 16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine intake manifold air temperature has exceeded the warning threshold for high intake manifold temperature. | (Calibration-dependent) (No action is taken by the ECM, or engine shut down, as temperature increases over thresholds.) Pre-HET relay driver is energized.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

Use the following procedure for a detail component location view. Refer to Procedure 100-002 in Secction E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-488.

Last Modified: 04-May-2011


Electronic Fuel Control Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 514

Electronic Fuel Control Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 514 PID: SPN: 633 FMI: 7 LAMP: Red SRT: | Electronic Fuel Control Valve - Mechanical System Not Responding or Out of Adjustment. The error between the estimated rail fueling and the desired rail fueling is outside the allowable limits. | Engine will overspeed, run at one speed, or will not run.
Quantum Fuel System Flow Schematic

Circuit Description

The ECM uses the fuel rail pressure signal and the engine speed to estimate the actual fueling that the engine is receiving, and then constantly compares this value to the desired fueling for the given speed and load. When there is an error too large in these values for too long, then Fault Code 514 is logged.

Component Location

The fuel rail actuator is located on the left-side (bottom) of the electronic control valve assembly (ECVA). Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The estimated fuel rail and the desired fuel rail parameters can be monitored using INSITE™ electronic service tool. This fault is a check on ECM 2's control of the rail actuator and subsequent fuel flow. If the desired fuel rail can not be met by commanding more current to the actuator, or if the desired fuel rail is being exceeded and can not be reduced by reducing the current to the actuator, then Fault Code 514 is logged.

This fault is not logged when:

  • Engine speed is below 1200 rpm
  • Coolant temperature is below 0°C [32°F]
  • Fault Code 451 or 452 is active. Once the run/stop switch is cycled, the fault becomes inactive.
Refer to Troubleshooting Fault Code t05-514.

Last Modified: 25-Apr-2011


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0 LAMP: Amber SRT: 00-382 | Injector Metering Rail 1 Pressure High - Data Valid But Above Normal Operating Range - Moderately Severe Level. The ECM has detected that the fuel pressure is higher than the commanded pressure. | Fuel shutoff valve de-energized (valve closes). The valve re-energizes (valve opens) when rail pressure falls below acceptable limit for present engine speed.
ECM

Circuit Description

The ECM2 (CM500 ECM) monitors the fuel rail pressure to the injectors. When it senses that fuel rail pressure has exceeded the maximum rail pressure for a particular engine speed, it will shut the engine down. A problem in the fuel rail pressure sensor or ECM2 (CM500 ECM) is the most likely cause of this situation.

Component Location

The fuel rail pressure sensor is located on the right side (bottom) of the electronic control valve assembly (ECVA). Use the following procedure for a detail component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of Fault Code 553 include:

  • Malfunctioning fuel rail pressure sensor.
  • Malfunctioning ECM2 (CM500 ECM).
  • If Fault Code 514 is logged but the engine is not shut down, an overpressure situation will develop, which will cause Fault Code 553 to be logged. If this is the case, the actuator has failed to open. If Fault Codes 514 and 553 are logged and the engine does not shut down, Fault Code 514 should be investigated first. Otherwise, Fault Code 553 should be investigated first.
Refer to Troubleshooting Fault Code t05-553.

Last Modified: 03-Aug-2011


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: SPN: 101 FMI: 0 LAMP: Red SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Crankcase breather filter requires maintenance. | Engine will shut down.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor is used by the electronic control module (ECM) to monitor the engine crankcase pressure. The ECM monitors the voltage on the SIGNAL pin and converts it to a pressure value. The blowby pressure value is used by the ECM for the engine protection system.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Confirm that the crankcase breathers and breather tubes are not obstructed.

Refer to Troubleshooting Fault Code t05-556.

Last Modified: 03-Aug-2011


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. No engine speed signal detected from the crankshaft engine speed sensor. | No action taken by the ECM. Engine will continue to operate with the camshaft engine position sensor. Possible loss of performance.
Crankshaft Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed and position information to the electronic control module (ECM). The sensor must be powered up by +5-VDC to operate. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include a damaged crankshaft engine speed sensor, open or short circuit, or a power supply voltage failure.

Refer to Troubleshooting Fault Code t05-689.

Last Modified: 25-Apr-2011


Extended Crankcase Blow-by Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 719

Extended Crankcase Blow-by Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 719 PID: SPN: 22 FMI: 3 LAMP: Amber SRT: | Extended Crankcase Blow-by Pressure Circuit - Voltage Above Normal or Shorted to High Source. Crankcase blowby pressure sensor circuit - shorted high. | No engine protection for blowby pressure.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor monitors crankcase blowby pressure and passes information to the electronic control module (ECM). High voltage will trip Fault Code 719 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a malfunctioning sensor.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Confirm that the crankcase breathers, breather tubes, and blowby sensor are not obstructed.

Refer to Troubleshooting Fault Code t05-719.

Last Modified: 03-Aug-2011


Extended Crankcase Blow-by Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 729

Extended Crankcase Blow-by Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 729 PID: SPN: 22 FMI: 4 LAMP: Amber SRT: | Extended Crankcase Blow-by Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Crankcase blowby pressure sensor circuit - shorted low. | No engine protection for blowby pressure.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor monitors blowby pressure and passes information to the electronic control module (ECM). Low voltage will trip Fault Code 729 and can be caused by shorts in the supply, signal, or return wires, an open in the return wires, or a malfunctioning sensor.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Confirm that the crankcase breathers, breather tubes, and blowby sensor are not obstructed.

Refer to Troubleshooting Fault Code t05-729.

Last Modified: 03-Aug-2011


Power Supply Lost With Keyswitch ON - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Keyswitch ON - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Keyswitch ON - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key-off). | Possible no noticeable performance effects, or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is a 20-ampere fuse in the battery 1 voltage wires to protect the harness from overheating. The ECM receives switched battery input through the ignition wire when the keyswitch is turned ON. The battery 1 voltage RETURN is connected directly to the negative (-) battery post.

Component Location

ECM1 (CM850) is connected to the battery through a 4-pin connector on the ECM harness inside the panel. The extension harness also has a 4-pin connector that provides battery power to both ECMs and the generator control panel. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.
  • Inspect the intermittent keyswitch for fast keyswitch cycling.

If a battery disconnect switch is turned OFF after the keyswitch is turned OFF, but before the ECM completely powers down (up to 30 seconds), this fault code can register.

Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.

Corrupted voltage (short interruptions or other spikes that can only be seen with an oscilloscope) on the keyswitch wire can cause this fault.

Refer to Troubleshooting Fault Code t05-1117.

Last Modified: 12-Apr-2011


Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1357

Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1357 PID: SPN: 1380 FMI: 18 LAMP: Amber SRT: | Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine oil level remote reservoir is below normal operating level. | No action taken by ECM. Possible damage to engine if left unresolved.
Engine Oil Level Remote Reservoir Circuit

Circuit Description

The engine oil level remote reservoir sensor monitors the oil level in the engine oil level remote reservoir and passes information to the ECM through the wire harness.

Component Location

The location of the engine oil level remote reservoir is dependent on the OEM. Refer the OEM service manual for a detailed component location.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Refer to Troubleshooting Fault Code t05-1357.

Last Modified: 03-Aug-2011


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1411

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1411 PID: SPN: 4182 FMI: 3 LAMP: Amber SRT: | Frequency adjust potentiometer signal is shorted high. | The frequency adjustment feature will be disabled and a default value of zero will be used. Possible loss of performance.
No Graphic Available

Circuit Description

The frequency adjust potentiometer is so the operator can adjust the break point frequency for the 100-percent 0.8 power factor load acceptance. This is the frequency at which the generator set output voltage starts to drop. The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5-VDC during normal operation. High voltage will activate Fault Code 1411 and can be caused by shorts in the signal wire, an open in the return wire, or a malfunctioning potentiometer.

Component Location

Refer the OEM service manual for location.

Shop Talk

Potentiometers are very sensitive to the environment. Clean the potentiometer and check its resistance first.

Refer to Troubleshooting Fault Code t05-1411.

Last Modified: 13-Apr-2011


Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1412

Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1412 PID: SPN: 4183 FMI: 3 LAMP: Amber SRT: | Droop adjust potentiometer signal is shorted high. | The droop adjustment feature will be disabled and a default value of zero will be used. Possible loss of performance.
No Graphic Available

Circuit Description

The droop adjust potentiometer is so the operator can adjust the amount of cross-current compensation the voltage regulator produces when paralleling. The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5-VDC during normal operation. High voltage will activate Fault Code 1412 and can be caused by shorts in the signal wire, an open in the return wire, or a malfunctioning potentiometer.

Component Location

Refer to the OEM service manual for location.

Shop Talk

Potentiometers are very sensitive to the environment. Clean the potentiometer and check its resistance first.

Refer to Troubleshooting Fault Code t05-1412.

Last Modified: 13-Apr-2011


Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1418

Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1418 PID: SPN: 4184 FMI: 3 LAMP: Amber SRT: | Gain adjust potentiometer signal is shorted high. | The gain adjustment feature will be disabled, and a default value of zero will be used. Possible loss of performance.
No Graphic Available

Circuit Description

The gain adjust potentiometer is so the operator can adjust the amplification of the difference in the value between the "desired speed" and the "actual speed" of the engine, so that the governor can respond to engine speed fluctuations. The difference between the "desired speed" and the "actual speed" is called the error signal. When the gain is increased, the error signal amplification is increased, more corrective action is taken by the governor, and its response is quicker. When the gain is reduced, the error signal amplification is reduced, less corrective action is taken by the governor, and its response is slower. If the gain is set too high, the governor can over correct the speed error signal, which will lead to engine speed surging or "hunting". The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5-VDC during normal operation. High voltage will activate Fault Code 1418 and can be caused by shorts in the signal wire, an open in the return wire, or a malfunctioning potentiometer.

Component Location

Refer to the OEM service manual for location.

Shop Talk

Potentiometers are very sensitive to the environment. Clean the potentiometer, and check its resistance first.

Refer to Troubleshooting Fault Code t05-1418.

Last Modified: 13-Apr-2011


Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

FAULT CODE 1427

Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1427 PID: SPN: 4185 FMI: 31 LAMP: Amber SRT: | Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists | The overspeed shutdown lamp will not turn on.
No Graphic Available

Circuit Description

The overspeed shutdown lamp will indicate when the engine has reached overspeed. Fault Code 1992 will trigger the overspeed shutdown lamp.

Component Location

The overspeed shutdown lamp is located on the generator control panel. Refer to the OEM service manual for the overspeed shutdown lamp location.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected.

If the ECM detects an open lamp circuit, Fault Code 1427 will go active, even in the absence of Fault Code 1992. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1427.

Possible causes of this fault code include:

  • Open signal circuit or shorted to voltage source
  • Signal circuit shorted to ground
  • Open return circuit in the generator control harness, connectors, or overspeed shutdown lamp
  • Burnt out overspeed shutdown lamp.
Refer to Troubleshooting Fault Code t05-1427.

Last Modified: 03-Aug-2011


At Least One Module Has A Most Severe Fault - Condition Exists

FAULT CODE 1517

At Least One Module Has A Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1517 PID: SPN: 1484 FMI: 31 LAMP: Red SRT: | At Least One Module Has A Most Severe Fault - Condition Exists | Dependent on particular faults from ECM 2 that triggered Fault Code 1517.
CM850 and CM500 Electronic Control Modules (ECMs) QSK78 Power Generation Engines

Circuit Description

On the QSK78 Power Generation engines ECM 1 (CM850), lights a red lamp when ECM 2 (CM500) has a Most Severe Fault.

Component Location

The ECMs are mounted off-engine in the generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected.

On the QSK78 Power Generation engine, ECM 1 (CM850) contains status information about ECM 2 (CM500). When ECM 2 has a Most Severe fault code, ECM 1 will recognize this and light a red lamp. When Fault Code 1517 is active, it means that ECM 2 has at least one Most Severe fault code. If ECM 2 has at least one Most Severe fault code, Fault Code 1517 will be active in ECM 1, not the individual fault codes that are causing Fault Code 1517. Fault Code 1517 can represent more than one Most Severe fault code. INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1517 and to troubleshoot accordingly.

Possible causes of this fault code include:

  • ECM 2 have at least one Most Severe fault code (Red).
Refer to Troubleshooting Fault Code t05-1517.

Last Modified: 07-Apr-2011


At Least One Module Has A Moderately Severe Fault - Condition Exists

FAULT CODE 1518

At Least One Module Has A Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1518 PID: SPN: 1484 FMI: 31 LAMP: Amber SRT: | At Least One Module Has A Moderately Severe Fault - Condition Exists | Dependent on particular faults from ECM 2 that triggered Fault Code 1518.
CM850 and CM500 Electronic Control Modules (ECMs) QSK78 Power Generation Engines

Circuit Description

On the QSK78 Power Generation engines ECM 1 (CM850) lights an amber lamp when ECM 2 (CM500) has a Moderately Severe Fault.

Component Location

The ECMs are mounted off-engine in the generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected.

On the QSK78 Power Generation engine, ECM 1 (CM850) contains status information about ECM 2 (CM500). When ECM 2 has a Moderately Severe fault code, ECM 1 will recognize this and light an amber lamp. When Fault Code 1518 is active, it means that ECM 2 has at least one Moderately Severe fault code. If ECM 2 has at least one Moderately Severe fault code, Fault Code 1518 will active in ECM 1, not the individual fault codes that are causing Fault Code 1518. Fault Code 1518 can represent more than one Moderately Severe fault code. INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1518 and to troubleshoot accordingly.

Possible causes of this fault code include:

  • ECM 2 has at least one Moderately Severe fault code (Amber).
Refer to Troubleshooting Fault Code t05-1518.

Last Modified: 07-Apr-2011


At Least One Module Has a Least Severe Fault - Condition Exists

FAULT CODE 1519

At Least One Module Has a Least Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1519 PID: SPN: 1484 FMI: 31 LAMP: Maintenance SRT: | At Least One Module Has a Least Severe Fault - Condition Exists | Dependent on particular faults from ECM 2 that triggered Fault Code 1519.
CM850 and CM500 Electronic Control Modules (ECMs) QSK78 Power Generation Engines

Circuit Description

On the QSK78 Power Generation engines ECM 1 lights a maintenance lamp when ECM 2 has a Least Severe fault code.

Component Location

The ECMs are mounted off-engine in the generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected.

On the QSK78 Power Generation engine, ECM 1 (CM850) contains status information about ECM 2 (CM500). When ECM 2 has a Least Severe fault code, ECM 1 will recognize this and light a maintenance lamp. When Fault Code 1519 is active, it means that ECM 2 has at least one Least Severe fault code. If ECM 2 has at least one Least Severe fault code, Fault Code 1519 will be active in ECM 1, not the individual fault codes that are causing Fault Code 1519. Fault Code 1519 can represent more than one Least Severe fault code. INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1519 and to troubleshoot accordingly.

Possible causes of the fault code include:

  • ECM 2 has at least one Least Severe fault code (Maintenance).
Refer to Troubleshooting Fault Code t05-1519.

Last Modified: 07-Apr-2011


Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 1597

Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1597 PID: SPN: 629 FMI: 12 LAMP: Maintenance SRT: | Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error Internal to the ECM related to memory hardware failures or internal ECM voltage supply circuits. | Engine will possibly not start.
CM850 and CM500 Electronic Control Modules (ECMs) QSK78 Power Generation Engines

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is mounted off-engine in the generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected.

This fault code can only be caused by an internal ECM problem. Field repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-1597.

Last Modified: 07-Apr-2011


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: SPN: 110 FMI: 14 LAMP: Red SRT: | Engine Coolant Temperature - Special Instructions. Engine coolant temperature 1 signal indicates engine coolant temperature is above the engine protection warning limit. | Power-Generation Only - Engine will be disconnected from the grid and idle only. The generator controllers will shut down the engine.
Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature 1 value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located in the thermostat housing. Refer to Procedure 100-002 in Section E for component location.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Refer to Troubleshooting Fault Code t05-1847.

Last Modified: 12-Apr-2011


Engine Oil Change Interval - Condition Exists

FAULT CODE 1891

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1891 PID: SPN: 1378 FMI: 31 LAMP: Amber SRT: | Engine Oil Change Interval - Condition Exists. | Engine oil burn valve solenoid unable to inject oil.
QSK78 Marine, Industrial, and Power Generation Engines

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve solenoid is located on the rear left side of the engine. Refer to Procedure 100-002 in Section E for a detailed component location.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected.

When the solenoid tries to inject oil and can not, it generates a miss count. When these counts reach a predefined level, Fault Code 1891 becomes active. Check for the presence of engine oil burn valve solenoid driver circuit Fault Codes 223 and 224.

Check for counts of engine oil rifle pressure sensor circuit Fault Codes 135 and 141 and coolant temperature sensor circuit Fault Codes 144 and 145. When active, these fault codes will prevent oil injection.

If an oil make-up tank is used, check for Fault Code 1357. If an oil make-up tank is not used, it is recommended to change the engine oil at the next maintenance interval.

Refer to Troubleshooting Fault Code t05-1891.

Last Modified: 12-Apr-2011


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 4222 FMI: 3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source | Engine will not synchronize with the grid if connected.
No Graphic Available

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set. Reference the OEM service manual for component location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1978.

Last Modified: 12-Apr-2011


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 4222 FMI: 4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will not synchronize with the grid if connected.
No Graphic Available

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator drive or corporate generator set. Reference the OEM service manual for component location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the OEM harness or engine harness
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-1979.

Last Modified: 12-Apr-2011


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine crankshaft speed/position signal indicates engine speed above generator set limit. | Engine shutdown.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and the engine camshaft speed/position sensor provide engine speed and position information to the ECM through the engine harness.

Component Location

Use the following procedure for the engine crankshaft speed/position sensor for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Gain adjust potentiometer not set correctly
  • Erroneous generator speed/load governing bias signal from the generator set
  • Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-1992.

Last Modified: 03-Aug-2011


Coolant Temperature 2 (LT) Sensor Circuit - Voltage Above Normal or Shorted High

FAULT CODE 2111

Coolant Temperature 2 (LT) Sensor Circuit - Voltage Above Normal or Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2111 PID: SPN: 52 FMI: 3 LAMP: Amber SRT: | Aftercooler Water Inlet Temperature Sensor - Shorted High | No engine protection for aftercooler water inlet temperature.
Aftercooler Water Inlet Temperature Sensor Circuit

Circuit Description

The aftercooler water inlet temperature sensor is used by the ECM to monitor the ability of the engine cooling system to cool down the engine coolant. The aftercooler water inlet temperature is used by the ECM for the engine protection system. The ECM monitors the voltage on the aftercooler water inlet temperature SIGNAL pin and expects to see the voltage vary between 0.5 to 4.5-VDC during normal engine operation. High voltage will activate Fault Code 2111 and can be caused by shorts in the SIGNAL or RETURN wires, an open in the RETURN wire, or a malfunctioning sensor.

Component Location

Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The possible malfunction modes are open circuit, short to battery positive (+), malfunctioning sensor, and loss of supply voltage inside the ECM. The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-2111.

Last Modified: 13-Apr-2011


Coolant Temperature 2 (LT) Sensor Circuit - Voltage Below Normal or Shorted Low

FAULT CODE 2112

Coolant Temperature 2 (LT) Sensor Circuit - Voltage Below Normal or Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2112 PID: SPN: 52 FMI: 4 LAMP: Amber SRT: | Aftercooler Water Inlet Temperature Sensor - Shorted Low | No engine protection for aftercooler water inlet temperature.
Aftercooler Water Inlet Temperature Sensor Circuit

Circuit Description

The aftercooler water inlet temperature sensor is used by the ECM to monitor the ability of the engine cooling system to cool down the engine coolant. The aftercooler water inlet temperature is used by the ECM for the engine protection system. The ECM monitors the voltage on the aftercooler water inlet temperature SIGNAL pin and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation. Low voltage will activate Fault Code 2112 and can be caused by shorts in the SIGNAL or RETURN wires, an open in the SIGNAL wire, or a malfunctioning sensor.

Component Location

Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The possible malfunction modes are open circuit, short circuit to ground, malfunctioning sensor, and loss of supply voltage inside the ECM. The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-2112.

Last Modified: 13-Apr-2011


Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2113

Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2113 PID: SPN: 52 FMI: 16 LAMP: Amber SRT: | Aftercooler Water Inlet Temperature High - Warning. Voltage signal indicates aftercooler water inlet temperature has exceeded the warning threshold for high aftercooler water inlet temperature. | Calibration-dependent. No action is taken by the ECM, or engine shutdown.
Aftercooler Water Inlet Temperature Sensor Circuit

Circuit Description

The aftercooler water inlet temperature sensor is used by the ECM to monitor the ability of the engine cooling system to cool down the engine coolant. The aftercooler water inlet temperature value is used by the ECM for the engine protection system. The ECM monitors the voltage on the aftercooler water inlet temperature SIGNAL pin and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation.

Component Location

Use the following procedure for detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Make sure that the water inlet flow is not restricted. The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-2113.

Last Modified: 13-Apr-2011


Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2114

Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2114 PID: SPN: 52 FMI: 0 LAMP: Red SRT: | Aftercooler Water Inlet Temperature High - Critical. Voltage signal indicates aftercooler water inlet temperature has exceeded the shutdown threshold for high aftercooler water inlet temperature. | Engine will shut down.
Aftercooler Water Inlet Temperature Sensor Circuit

Circuit Description

The aftercooler water inlet temperature sensor is used by the ECM to monitor the ability of the engine cooling system to cool down the engine coolant. The aftercooler water inlet temperature value is used by the ECM for the engine protection system. The ECM monitors the voltage on the aftercooler water inlet temperature SIGNAL pin and expects to see the voltage vary between 0.5 and 4.5-VDC during normal engine operation.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Make sure that the water inlet flow is not restricted. The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-2114.

Last Modified: 13-Apr-2011


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor Supply 4 circuit to the accelerator pedal or lever position sensor. | Loss of some accelerator pedal or lever position sensor functionality.
No Graphic Available

Circuit Description

The ECM supplies the accelerator pedal or lever position sensor with 5-VDC.

Component Location

The accelerator pedal or lever position assembly is located in the cab.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM senses more than 5.25-VDC on the sensor Supply 4 for the accelerator pedal or lever position wire. This can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Refer to Troubleshooting Fault Code t05-2185.

Last Modified: 12-Apr-2011


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 4 circuit. | Loss of some sensor functionality.
No Graphic Available

Circuit Description

The sensor supply number 4 circuit of the ECM provides 5-VDC for the accelerator pedal or lever position sensor. If the sensor supply 4 circuit to the accelerator is damaged, the accelerator will not work properly.

Component Location

The sensor supply 4 is located in the ECM.

Reference the OEM service manual for a detailed component location view of the accelerator pedal or lever position sensor.

Shop Talk

Low voltage on the sensor SUPPLY 4 wire can be caused by a short circuit to ground in a SUPPLY wire, a short circuit between a SUPPLY wire or a RETURN wire, a damaged accelerator, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-2186.

Last Modified: 12-Apr-2011


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2261 PID: SPN: 629 FMI: 31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | No effect on performance.
QSK78 Power Generation CM850 and CM500 ECMs

Circuit Description

Not applicable for this fault code.

Component Location

The ECMs are mounted off the engine in the generator control panel.

Shop Talk

Fault Code 2661 triggers from other Most Severe fault codes that have become active or have gone inactive. Fault Code 2661 will remain active until reset by the operator. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

This fault code is generated by red/shutdown lamp faults. This fault code is active in ECM 1 (CM850). A red/shutdown lamp fault in ECM 2 (CM500) will cause Fault Code 1517 to become active in ECM 1, which will in turn trigger Fault Code 2661. Other fault codes need to be corrected before acknowledging this fault code. This fault code will become active again after a calibrated period of time, unless the original fault codes are corrected.

Refer to Troubleshooting Fault Code t05-2661.

Last Modified: 12-Apr-2011


At Least One Unacknowledged Moderately Severe Fault - Condition Exists

FAULT CODE 2662

At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2262 PID: SPN: 629 FMI: 31 LAMP: Amber SRT: | At Least One UnacknowledgedModerately Severe Fault - Condition Exists. | No effect on performance.
QSK78 Power Generation CM850 and CM500 ECMs

Circuit Description

Not applicable for this fault code.

Component Location

The ECMs are mounted off the engine in the generator control panel.

Shop Talk

Fault Code 2662 triggers from other Moderately Severe fault codes that have become active or have gone inactive. Fault Code 2662 will remain active until reset by the operator. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

This fault code is generated by amber/warning lamp faults. This fault code is active in ECM 1 (CM850). An amber/warning lamp fault in ECM 2 (CM500) will cause Fault Code 1518 to become active in ECM 1, which will in turn trigger Fault Code 2662. Other fault codes need to be corrected before acknowledging this fault code. This fault code will become active again after a calibrated period of time, unless the original fault codes are corrected.

Refer to Troubleshooting Fault Code t05-2662.

Last Modified: 12-Apr-2011


SAE J1939 Engine Network - Abnormal Update Rate

FAULT CODE 2727

SAE J1939 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2727 PID: SPN: 1231 FMI: 9 LAMP: Maintenance SRT: | SAE J1939 Engine Network - Abnormal Update Rate. | Engine will lose power or stop running.
SAE J1939 Engine Network Circuit

Circuit Description

The SAE J1939 engine network allows communication between ECM 1 (CM850 ECM) and ECM 2 (CM500 ECM). There are critical and non-critical compatibility messages transmitted between the ECMs through the SAE J1939 engine network.

Component Location

The ECMs are mounted off-engine in a generator control panel.

Shop Talk

There are multiple ECMs for this engine. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open or short circuit on the SAE J1939 engine network harness
  • Damaged terminator resistors on the SAE J1939 engine network harness.
Refer to Troubleshooting Fault Code t05-2727.

Last Modified: 12-Apr-2011


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 112 - Engine Timing Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for other fault codes. | Other fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 112 active?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check the fuel level in the tank. | Fuel present in tank?
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | Any leaks, broken lines, or loose fittings present in the fuel system?
 | STEP 2C. Check the fuel inlet restriction. | Fuel inlet restriction less than the specification?
 | STEP 2D. Check for air in the fuel. | Air leaks present?
 | STEP 2E. Check the fuel pump output pressure. | Fuel pump output pressure less than the specification?
 | STEP 2F. Inspect the timing actuator screens for debris. | Debris present in the screen?
 | STEP 2G. Inspect the timing actuators for corrosion. | Corrosion present on actuator?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 112 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for other fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes other than Fault Code 112.

  • Use INSITE™ electronic service tool to read the fault codes.

Are other fault codes active?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 112 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check the fuel level in the tank.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank for the following:

  • Fuel in the tank.

Fuel present in fuel tank?
YES NO
No Repair

Fill the tank with fuel.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.

Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 200-001 in Section F.

Are any leaks, broken lines, or loose fittings present in the fuel system?
YES NO

Repair the leak. Tighten or replace the leaking fitting or fuel line. Replace the fuel line. Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the inlet restriction as follows:

  • Measure the inlet restriction and compare to the specification. Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-020 in Section 6.

Is the fuel inlet restriction less than the specification?
YES NO
No Repair

  • Find the cause of the restriction and remove it.
  • Check for debris in the fuel tank, fuel tank vents, and clogged or malfunctioning check valves.
  • Change the fuel filters. Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-015 in Section 6.
  • Inspect the fuel lines and replace if necessary. Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 2D

Go to 3A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for air in the fuel.

  • Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-003 in Section 6.

Air leaks present?
YES NO
No Repair

  • Find the cause of the air leak. Check the OEM fuel lines and the fuel tank drop tube for air leaks. Refer to the OEM Service Manual. Check for damaged or missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.
  • Inspect the fuel lines and replace if necessary. Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 3A

Go to 2E

Guided Step 2D - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for air in the fuel.

  • Measure the output pressure of the pump at the check fitting. Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Is the fuel pump output pressure less than the specification?
YES NO

  • Replace the fuel lift pump. Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

No Repair

Go to 3A

Go to 2F

Guided Step 2F - Inspect the timing actuator screens for debris

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the fuel.

  • Measure the output pressure of the pump at the check fitting. Use the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Debris present in the screen?
YES NO

  • Replace the timing actuator. Refer to Procedure 019-111 in Section 19.

 No Repair

Go to 3A

Go to 2G

Guided Step 2G - Inspect the timing actuators for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect both timing actuators for corrosion on surfaces that come in contact with fuel.

  • Remove the timing actuators. Refer to Procedure 019-111 in Section 19.

Corrosion present on an actuator?
YES NO

  • Replace any timing actuators that have corrosion present on surfaces that come in contact with fuel. Refer to Procedure 019-111 in Section 19.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the the fault code is inactive.

Fault Code 112 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 113 - Engine Timing Actuator Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing rail actuator. |
 | STEP 1A. Inspect the timing rail actuator and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the coil resistance of the timing rail actuator. | 7.0 to 9.0 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a return short to the power supply. | Greater than 100k ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for return short to the power supply. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 113 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the timing rail actuator.

Guided Step 1A - Inspect the timing rail actuator and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail actuator.

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing rail actuator. Refer to Procedure 019-111 in Section 19.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the coil resistance of the timing rail actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail actuator.

Action

Check the coil resistance of the timing rail actuator(s).

  • Measure the resistance from the timing rail actuator 1 SUPPLY pin to the timing rail actuator 1 RETURN pin.
  • Measure the resistance from the timing rail actuator 2 SUPPLY pin to the timing rail actuator 2 RETURN pin.

7.0 to 9.0 ohms?
YES NO
No Repair

  • Replace the timing rail actuator(s). Refer to Procedure 019-111 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the timing rail actuator.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail actuator 1 RETURN pin to the timing rail actuator 1 SUPPLY pin at the engine harness inline connector.
  • Measure the resistance from the timing rail actuator 2 RETURN pin to the timing rail actuator 2 SUPPLY pin at the engine harness inline connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness.Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail actuator.

Action

Check for a short circuit from pin-to-pin.

  • Measure resistance between the timing rail actuator 1 SUPPLY pin and all other pins of the engine harness inline connector.
  • Measure resistance between the timing rail actuator 2 SUPPLY pin and all other pins of the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness.Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a return short to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail actuator.

Action

Check for a return short to the power supply.

  • Measure the resistance from the timing rail actuator 1 RETURN pin to the timing rail actuator 1 SUPPLY pin in the engine harness inline connector.
  • Measure the resistance from the timing rail actuator 2 RETURN pin to the timing rail actuator 2 SUPPLY pin in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness.Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness.

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail actuator 1 SUPPLY pin to the timing rail actuator 1 RETURN pin at the extension harness connector.
  • Measure the resistance from the timing rail actuator 2 SUPPLY pin to the timing rail actuator 2 RETURN pin at the extension harness connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the extension harness.

Refer to Procedure 019-213 in Section 19.

  • Replace the extension harness.Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure resistance between the timing rail actuator 1 SUPPLY pin and all other pins of the extension harness connector.
  • Measure resistance between the timing rail actuator 2 SUPPLY pin and all other pins of the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the extension harness.

Refer to Procedure 019-213 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a return short to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a return short to the power supply.

  • Measure the resistance from the timing rail actuator 1 RETURN pin to the timing rail actuator 1 SUPPLY pin in the extension harness connector.
  • Measure the resistance from the timing rail actuator 2 RETURN pin to the timing rail actuator 2 SUPPLY pin in the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the extension harness.

Refer to Procedure 019-213 in Section 19.

  • Replace the extension harness.Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the the fault code is inactive.

Fault Code 113 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 115 - Engine Speed/Position Sensor Circuit - Lost Both of Two Signals from the Magnetic Pickup Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead and Part Number 3822917 - female AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Inspect the engine speed sensor. | Damage to engine speed sensor?
 | STEP 1C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 1D. Check for an open circuit. | 1k to 2k ohms?
 | STEP 1E. Check for a short circuit between coils. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 2k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the timing rail actuator.

Guided Step 1A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.

Damaged sensor?
YES NO

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine block ground.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin to the engine block ground.

While testing the sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Greater than 10M ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Less than 10 ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine speed sensor 2 SIGNAL pin.
  • Measure the resistance between the engine speed sensor 1 RETURN pin to the engine speed sensor 2 RETURN pin.

While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-208 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the engine harness inline connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine speed sensor. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the engine harness inline connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the engine harness inline connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the engine speed sensor. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine speed sensor. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the engine harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel.

Action

Inspect the extension harness and generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness.

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the generator control panel.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the extension harness to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the extension harness to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness.Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Connect the extension harness to the engine harness.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the extension harness connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the extension harness connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness.Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness.Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the the fault code is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 116 - Fuel Timing Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™ AMP™/Metri-Pack™ test lead; Part Number 3822758 - male Deutsch™ AMP™/Metri-Pack™ test lead; Part Number 3824774 - Pressure sensor breakout cable; Part Number 3824776 - Pressure sensor breakout cable; Part Number 3163594 - ECM connector breakout box; Part Number 3164752 - Danfoss™ pressure sensor breakout cable; Part Number 3164132 - Deutsch™ socket pin test lead and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active
STEP 2. | Check the timing rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 116 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the timing rail pressure sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the timing rail pressure sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.75-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the engine harness and extension harnesss connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-208 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to the timing rail pressure RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the timing rail pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engne harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the timing rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to the timing rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the timing rail pressure RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-213 in Section 19. Refer to Procedure 019-175 in Section 19

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-213 in Section 19. Refer to Procedure 019-175 in Section 19

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the the fault code is inactive.

Fault Code 116 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 117 - Fuel Timing Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™ AMP™/Metri-Pack™ test lead; Part Number 3822758 - male Deutsch™ AMP™/Metri-Pack™ test lead; Part Number 3824774 - Pressure sensor breakout cable; Part Number 3824776 - Pressure sensor breakout cable; Part Number 3163594 - ECM connector breakout box; Part Number 3164752 - Danfoss™ pressure sensor breakout cable; Part Number 3164132 - Deutsch™ socket pin test lead and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the timing rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 117 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the timing rail pressure sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the timing rail pressure sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.75-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnes and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the engine harness and extension harnesss connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-208 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to the timing rail pressure RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the timing rail pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness.

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness.

Refer to Procedure 019-175 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the timing rail pressure SUPPLY pin on the extension harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the timing rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to the timing rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the timing rail pressure RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the the fault code is inactive.

Fault Code 117 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 118 - Fuel Pump Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™ AMP™/Metri-Pack™ test lead; Part Number 3822758 - male Deutsch™ AMP™/Metri-Pack™ test lead; Part Number 3824774 - Pressure sensor breakout cable; Part Number 3824776 - Pressure sensor breakout cable; Part Number 3163594 - ECM connector breakout box; Part Number 3164752 - Danfoss™ pressure sensor breakout cable; Part Number 3164132 - Deutsch™ socket pin test lead and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the fuel pump pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 118 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel pump pressure sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the fuel pump pressure sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the fuel pump pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the fuel pump pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnes and extension harnesss connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail actuator.

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-208 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing rail actuator. Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to the fuel pump pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to the fuel pump pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the engine harness inline connector to the fuel pump pressure RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the engine harness.

Refer to Procedure 019-208 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel pump pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine harness.

Refer to Procedure 019-208 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the timing rail actuator and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail actuator.

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness.

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to the fuel pump pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to the fuel pump pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to the fuel pump pressure RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the extension harness.

Repair the extension harness. Refer to Procedure 019-213 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the extension harness.

Refer to Procedure 019-213 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 118 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 119 - Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™ AMP™/Metri-Pack™ test lead; Part Number 3822758 - male Deutsch™ AMP™/Metri-Pack™ test lead; Part Number 3824774 - Pressure sensor breakout cable; Part Number 3824776 - Pressure sensor breakout cable; Part Number 3163594 - ECM connector breakout box; Part Number 3164752 - Danfoss™ pressure sensor breakout cable; Part Number 3164132 - Deutsch™ socket pin test lead and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the fuel pump pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 119 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the fuel pump pressure sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the fuel pump pressure sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pump pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pump pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 ot 4.56-VDC?
YES NO
No Repair

  • Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnes and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump pressure RETURN pin on the engine harness inline connector to the fuel pump pressure RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel pump pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19. Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to the fuel pump pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to the fuel pump pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to the fuel pump pressure RETURN pin on the extension harness inline connector.

Less than10 ohms?
YES NO
No Repair

  • Repair or replace the engine harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the the fault code is inactive.

Fault Code 119 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 121 - Engine Speed/Position Sensor Circuit - Lost One of Two Signals from the Magnetic Pickup Sensor - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Inspect the engine speed sensor. | Damaged sensor?
 | STEP 1C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 1D. Check for an open circuit. | 1k to 2k ohms?
 | STEP 1E. Check for short circuit between coils. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 2k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.

Damaged sensor?
YES NO

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

 No Repair

Go to 4C

Go to 1C

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and the engine block ground.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and the engine block ground.

While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Greater than 10M ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin and the engine speed sensor 1 RETURN pin.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin and the engine speed sensor 2 RETURN pin.

While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Less than 10 ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1E

Go to 4A

Guided Step 1E - Check for short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for short circuit between coils.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine speed sensor 2 SIGNAL pin.
  • Measure the resistance between the engine speed sensor 1 RETURN pin to the engine speed sensor 2 RETURN pin.

While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness connector and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-208 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the engine harness inline connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the engine harness inline connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the engine harness inline connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness.

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the extension harness to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the extension harness to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the extension harness connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the extension harness connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3162898 - Pressure/Temperature sensor breakout cable; Part Number 3824774 - Pressure sensor breakout cable; Part Number 3824776 - Pressure sensor breakout cable and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the intake manifold pressure sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19. Refer to Procedure 019-159 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage

Conditions

  • Turn keyswitch OFF.
  • Install the intake manifold pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19. Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the engine harness and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-208 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 1 RETURN pin on the engine harness inline connector to the intake manifold pressure sensor 1 RETURN pin in the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • eplace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the extension harness connector to the intake manifold pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the extension harness connector to the intake manifold pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the intake manifold pressure RETURN pin on the extension harness connector to the intake manifold pressure RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3824774 - Pressure sensor breakout cable; Part Number 3824776 - Pressure sensor breakout cable; Part Number 3163594 - ECM connector breakout box; Part Number 3164752 - Danfoss™ pressure sensor breakout cable; Part Number 3164132 - Deutsch™ socket pin test lead and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical ground/return with the intake manifold pressure sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first

 No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19. Refer to Procedure 019-159 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19. Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the intake manifold pressure sensor 1, 5-VDC SUPPLY pin on the engine harness inline connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure RETURN pin on the engine harness inline connector to the intake manifold pressure RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness.Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the intake manifold pressure RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the extension harness connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness.

Refer to Procedure 019-213 in Section 19.

  • Replace the extension harness.Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the extension harness connector to the intake manifold pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the extension harness connector to the intake manifold pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the intake manifold pressure RETURN pin on the extension harness connector to the intake manifold pressure RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair the engine harness.

Refer to Procedure 019-213 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

  • Repair the engine harness.

Refer to Procedure 019-213 in Section 19.

  • Replace the extension harness.Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3162898 - Pressure/Temperature sensor breakout cable; Part Number 3824774 - Pressure sensor breakout cable; Part Number 3824776 - Pressure sensor breakout cable; Part Number 3163594 - ECM connector breakout box; Part Number 3164752 - Danfoss™ pressure sensor breakout cable; Part Number 3164132 - Deutsch™ socket pin test lead and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damage pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the oil pressure sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the oil pressure sensor.

Guided Step 1A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19. Refer to Procedure 019-155 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor signal voltage.

  • To measure the signal voltage install the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil pressure RETURN pin on the engine harness inline connector to the oil pressure RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the oil pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil pressure SUPPLY pin on the extension harness connector to the oil pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness connector to the oil pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the oil pressure RETURN pin on the extension harness connector to the oil pressure RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the oil pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5ADisablethefaultcodes. -

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5BCleartheinactivefaultcodes. -

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3162898 - Pressure/Temperature sensor breakout cable; Part Number 3824774 - Pressure sensor breakout cable; Part Number 3824776 - Pressure sensor breakout cable; Part Number 3163594 - ECM connector breakout box; Part Number 3164752 - Danfoss™ pressure sensor breakout cable; Part Number 3164132 - Deutsch™ socket pin test lead and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damage pins?
 | STEP 4B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the oil pressure sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Inspect the oil pressure sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19. Refer to Procedure 019-155 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the extension harness connector and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness inline connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil pressure RETURN pin on the engine harness inline connector to the oil pressure RETURN pin on the engine harness sensor connector.

Less than 10 0hms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the oil pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil pressure SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the oil pressure RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil pressure SUPPLY pin on the extension harness connector to the oil pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness connector to the oil pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the oil pressure RETURN pin on the extension harness connector to the oil pressure RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the oil pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure sensor accuracy. |
 | STEP 1A. Verify the oil pressure sensor accuracy with a mechanical gauge. | Mechanical gauge reading matches the sensor reading?
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the oil pressure sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the oil pressure sensor accuracy.

Guided Step 1A - Verify oil pressure sensor accuracy with a mechanical gauge.

Conditions

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ electronic service tool to the data link.
  • Turn keyswitch ON.

Action

Verify oil pressure sensor accuracy with a mechanical gauge.

  • Start engine and compare the oil pressure reading on the electronic service tool monitor screen to the reading on mechanical oil pressure gauge.

The engine rpm will need to be increased to make it easier to see differences in the readings.

Mechanical gauge reading matches the sensor reading?
YES NO

  • Replace the lubricating oil pressure regulator. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 007-029 in Section 7.

  • Go to Fault Code 141

Go to 2A

Fault Code 141

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify the fault simulation feature for the oil pressure sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify the fault simulation is not enabled for the oil pressure sensor.

Fault simulation enabled?
YES NO

Disable the fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify the fault threshold is not within the normal operating range for the oil pressure sensor.

Fault threshold set correctly?
YES NO

Reference symptom tree T105, Lubricating Oil Pressure Low Section TS in the Troubleshooting and Repair Manual QSK78, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 143 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Aug-2011


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822817 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the coolant temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-205 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the sensor resistance.

  • Measure the resistance between the coolant temperature SIGNAL pin and the coolant temperature RETURN pin.

600 to 36k ohms?
YES NO
No Repair

  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the engine harness and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the coolant temperature RETURN pin on the engine harness inline connector to the coolant temperature RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the coolant temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the coolant temperature SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the coolant temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness.

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

  • Replace the extension harness.

Refer to Procedure 019-175 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the coolant temperature SUPPLY pin on the extension harness connector to the coolant temperature SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the extension harness connector to the coolant temperature SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the coolant temperature RETURN pin on the extension harness connector to the coolant temperature RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the coolant temperature SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 600 and 36k ohms?
 | STEP 2C. Check the sensor signal voltage. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the coolant temperature sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance between the coolant temperature SIGNAL pin and the coolant temperature RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 36k ohms?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 5A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the coolant temperature sensor connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the coolant temperature SUPPLY pin on the engine harness in-line connector to the engine block ground.
  • Measure the resistance from the coolant temperature SIGNAL pin on the engine harness in-line connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the coolant temperature sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the coolant temperature sensor.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the coolant temperature SUPPLY pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the coolant temperature RETURN pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-213 in Section 19.

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the coolant temperature SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the coolant temperature RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the coolant temperature SIGNAL pin on the extension harness connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the coolant temperature SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Nov-2016


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Sever Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading match the sensor reading?
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the coolant temperature sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 146 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the coolant temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the aftercooler water inlet temperature sensor
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES NO
No Repair

Go to Fault Code 144 troubleshooting steps.

Go to 2A

Fault Code 144

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the coolant temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the coolant temperature sensor.

Fault simulation enabled?
YES NO

Disable the fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the threshold setting.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within the normal operating range for the oil pressure sensor.

Fault threshold set correctly?
YES NO

Reference the Coolant Temperature Above Normal - Gradual Overheat, t022, and Coolant Temperature Above Normal - Sudden Overheat, t023, in Section TS of the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 146 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-Aug-2011


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the coolant temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the coolant temperature sensor
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the coolant temperature reading on the service too monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES NO
No Repair

Go to Fault Code 144 troubleshooting steps.

Go to 2A

Fault Code 144

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the coolant temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the coolant temperature sensor.

Fault simulation enabled?
YES NO

Disable the fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the threshold setting.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within the normal operating range for the coolant temperature sensor.

Fault threshold set correctly?
YES NO

Reference the Coolant Temperature Above Normal - Gradual Overheat, t022, and Coolant Temperature Above Normal - Sudden Overheat, t023, in Section TS of the QSK78 Troubleshooting and Repair Manual, Bulletin 366727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive?

Fault Code 151 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 600 ohms to 36k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 5A. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing common electrical supply with the intake manifold temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting steps.

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.
  • Refer to Procedure 019-159 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and the intake manifold temperature RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 36k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.
  • Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Connect the engine harness to the intake manifold temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness in-line connector to the intake manifold temperature RETURN pin on the engine harness sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold temperature sensor.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the intake manifold temperature SUPPLY pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-213 in Section 19.

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold temperature SUPPLY pin on the extension harness connector to the intake manifold temperature SUPPLY pin on the extension harness in-line connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to the intake manifold temperature SIGNAL pin on the extension harness in-line connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the intake manifold temperature SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Nov-2016


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 600 ohms and 36k ohms?
 | STEP 2C. Check the sensor signal voltage. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the intake manifold temperature sensor.

Other fault codes active?
YES NO

Troubleshoot other active fault codes first.

 No Repair

Go to the appropriate troubleshooting steps.

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.
  • Refer to Procedure 019-159 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold sensor.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and the intake manifold temperature RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 36k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.
  • Refer to Procedure 019-159 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the intake manifold temperature sensor connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.
  • Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-208 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold temperature SUPPLY pin on the engine harness in-line connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness in-line connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from all sensor that have a shared supply or return with the intake manifold temperature sensor.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the intake manifold temperature SUPPLY pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-213 in Section 19.

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold temperature SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the intake manifold temperature SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Nov-2016


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the intake manifold temperature sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 155 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the intake manifold temperature sensor
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the intake manifold temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES NO
No Repair

Troubleshoot Fault Code 153.

Go to 2A

Go to Fault Code 153 troubleshooting steps.

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the intake manifold temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the intake manifold temperature sensor.

Fault simulation enabled?
YES NO

Disable fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the threshold setting.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within normal operating range for the intake manifold temperature sensor.

Fault threshold set correctly?
YES NO

Reference the Intake Manifold Air Temperature Above Specifications symptom tree, t096, in Section TS of the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 155 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 185 - Engine Control Module Network Communication Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the connectors on ECM1 (CM850) and ECM2 (CM500) ECM harness. |
 | STEP 1A. Inspect the primary ECM connectors. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 185 active?
STEP 2. | Inspect the 20-ampere fuses. |
 | STEP 2A. Inspect the 20-ampere fuses. | Less than 10 ohms?
STEP 3. | Inspect the SAE J1939 circuit. |
 | STEP 3A. Check for an open circuit in the data link wire. | Less than 10 ohms?
 | STEP 3B. Check for proper termination of the harness. | Between 50 and 70 ohms?
 | STEP 3B-1. Check the individual termination connectors. |
 | STEP 3C. Check for an open circuit in the shield wire. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit in the data link wire. | Less than 8.0-VDC?
 | STEP 3E. Check for a short circuit to ground in the data link wire. | Greater than 100k ohms?
 | STEP 3F. Check for a short circuit from pin-to-pin in the data link wire. | Greater than 100k ohms?
STEP 4. | Check the ECM. |
 | STEP 4A. Check communication with the ECM. | Communication established?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 185 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Inspect the connectors on ECM1 (CM850) and ECM2 (CM500) ECM harness.

Guided Step 1A - Inspect the primary ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM1 (CM850) 60-pin connector
  • Disconnect the engine harness from ECM2 (CM500) 40-pin connector B.

Action

Inspect the ECM wiring harness connectors and ECM connectors for the following damage:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or the J1939 backbone harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

eplace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 185 active?
YES NO
No Repair

Repair complete.

Go to 2A

Go to 5B

Guided Step 2 - Inspect the 20-ampere fuses.

Guided Step 2A - Inspect the 20-ampere fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM2 (CM500) 40-pin connector B.

Action

Inspect the 20-ampere fuse.

  • Measure the fuse resistance.

Less than 10 ohms?
YES NO
No Repair

Replace the harness in-line fuse. Refer to Procedure 019-198 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the SAE J1939 circuit.

Guided Step 3A - Check for an open circuit in the data link wire.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM1 (CM850) 60-pin connector
  • Disconnect the engine harness from the ECM2 (CM500) 40-pin connector B.

Action

Check for an open circuit in the data link wire between ECM1 (CM850) and ECM2 (CM500).

  • Measure the resistance from the SAE J1939 data link SUPPLY pin of the ECM1 (CM850) interface connector to SAE J1939 data link SUPPLY pin of the ECM2 (CM500).
  • Measure the resistance from the SAE J1939 data link RETURN pin of the ECM1 (CM850) interface connector to SAE J1939 data link RETURN pin of the ECM2 (CM500).

Less than 10 ohms?
YES NO
No Repair

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for proper termination of the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the primary ECM1 (CM850).

Action

Check for proper termination of the harness.

  • Check the resistance across SAE J1939 data link SUPPLY pin and the SAE J1939 data link RETURN pin.

Between 50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the individual termination connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine harness from the ECM1 (CM850) connector.

Action

Check the individual termination connectors.

  • Measure the resistance across SAE J1939 data link SUPPLY pin and the SAE J1939 data link RETURN pin.

Between 110 and 130 ohms?
YES NO

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Replace the end cap, Part Number 3163051.

Go to 5A

Go to 5A

Guided Step 3C - Check for an open circuit in the shield wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM1 (CM850) 60-pin connector from ECM1 (CM850
  • Disconnect the ECM2 (CM500) 40-pin connector from ECM2 (CM500).

Action

Check for an open circuit in the shield wire.

  • Measure the resistance from SAE J1939 data link shield pin of the J1939 to ground.

Less than 10 ohms?
YES NO
No Repair

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit in the data link wire.

Conditions

  • Connect the ECM1 (CM850) 60-pin connector to ECM1 (CM850)
  • Connect the ECM2 (CM500) 40-pin connector B to ECM2 (CM500).
  • Turn keyswitch ON.

Action

Check for a short circuit in the data link wire between ECM1 (CM850) and ECM2 (CM500).

  • Measure the voltage between SAE J1939 data link SUPPLY pin and SAE1939 data link shield pin of the J1939 service tool interface.
  • Measure the voltage between SAE J1939 data link RETURN pin and SAE 1939 data link shield pin of the J1939 service tool interface.

Less than 8-VDC?
YES NO
No Repair

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to ground in the data link wire.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM1 (CM850) 60-pin connector.
  • Connect the engine harness to the ECM2 (CM500) 40-pin connector B.

Action

Check for a short circuit to ground in the data link wire.

  • Measure the resistance from SAE J1939 data link SUPPLY pin to SAE J1939 data shield pin of the J1939 harness.
  • Measure the resistance from SAE J199 data link RETURN pin to SAE J1939 data shield pin of the J1939 harness.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 5A

Guided Step 3F - Check for a short circuit from pin-to-pin in the data link wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM1 (CM850) 60-pin connector.
  • Disconnect the engine harness from the ECM2 (CM500) 40-pin connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from SAE J1939 data link 2 engine network SUPPLY pin to all other pins of the engine harness connector.
  • Measure the resistance from SAE J1939 data link 2 engine network RETURN pin to all other pins of the engine harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check communication with the ECM1 (CM850).

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check communication with the primary ECM1 (CM850).

  • Start the engine and let it idle for 1 minute.
  • Monitor ECM Time. Use INSITE™ electronic service tool.

Communication established?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 185 is inactive.

Fault Code 185 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3822812 - female Deutsch™ test lead, Part Number 3822758- male Deutsch™/AMP™/Metric-Pack™ test lead, and Part Number 3822917- female Deutsch™/AMP™/ Metric-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2 and return. |
 | STEP 2A. Inspect the intake manifold pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 187 active?
 | STEP 2C. Inspect the blow-by pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2D. Check the circuit response. | Fault Code 187 active?
 | STEP 2E. Inspect the coolant pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2F. Check the circuit response. | Fault Code 187 active?
 | STEP 2G. Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2H. Check the circuit response. | Fault Code 187 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2 and return.

Guided Step 2A - Inspect the intake manifold pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness connector.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the intake manifold pressure sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged intake manifold pressure sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the blow-by pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the blow-by pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and blow-by pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the blow-by pressure sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged blow-by pressure sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the blow-by pressure sensor. Refer to Procedure 019-011 in Section 19.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the blow-by pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the blow-by pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the coolant pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the coolant pressure sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged coolant pressure sensor.

Reference the wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

 No Repair

Go to 4A

Go to 2F

Guided Step 2F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2G

Go to 4A

Guided Step 2G - Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the barometric pressure sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged barometric pressure sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

 No Repair

Go to 4A

Go to 2H

Guided Step 2H - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2I

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM1 (CM850) 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Reference the circuit art or wiring diagram for all engine harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM1 (CM850) 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

There is a short circuit to ground or short circuit from pin-to-pin in the engine harness.

Troubleshoot each section of the engine harness connected in series to determine which contains the short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of engine harness or damaged sensor.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and harness connector. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 800k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and harness connector.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the coolant level sensor connector.

Action

Inspect the engine harness connector and coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, or replace the coolant level sensor.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the coolant level 1 SIGNAL pin and the coolant level 1 RETURN pin at the coolant level sensor connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?
YES NO

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM1 50-pin connector
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedurefor general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the ECM.

Check all harnesses connected in series.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM1 50-pin connector
  • Disconnect the coolant level sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant level 1 RETURN pin and the harness connector coolant level 1 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot each section of the engine to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM1 50-pin connector
  • Disconnect the coolant level sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant level 1 SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the coolant level sensor 1 and harness connector. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the engine harness and ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the coolant level sensor 1 and harness connector.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, or replace the coolant level sensor, if possible.

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the coolant level sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged engine coolant level sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness, and ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM1 50-pin connector
  • Disconnect the harness connector from the sensor connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or the ECM.

Clean the connector and pins.

Replace the damaged section of the engine harness or the ECM.

Check all harnesses connected in series.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM1 50-pin connector
  • Disconnect the coolant level sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance and check for a short circuit between the coolant level 1 SIGNAL pin at the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-362 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM1 50-pin connector
  • Disconnect the coolant level sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the engine coolant level 1 SIGNAL pin at the engine harness ECM connector and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the coolant is low. |
 | STEP 1A. Check the coolant level. | Coolant level OK?
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault code is still active with the engine running. | Fault Code 197 still active?
 | STEP 2B. Check threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 197 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify that the coolant is low.

Guided Step 1A - Check the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Remove the radiator cap and inspect the coolant level.

Coolant level OK?
YES NO
No Repair

Add coolant to the radiator.

Make sure the coolant contains the proper amount of antifreeze, DCA, and water.

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Confirm the fault code is still active with the engine running.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Confirm the fault code is still active.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 197 still active?
YES NO

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

 No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the threshold setting.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read engine control module (ECM) 1 (CM850).

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the coolant level sensor.

Fault threshold set correctly?
YES NO

Reference the Coolant Loss - External symptom tree, t020, and Coolant Loss - Internal symptom tree, t021, in Section TS of the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 197 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM harness breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | Between 600 and 36k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting steps.

Go to 2A

Guided Step 2 - Check the oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the oil temperature sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the oil temperature sensor.

Action

Check the resistance of the oil temperature sensor.

  • Measure the resistance between the oil temperature SIGNAL pin and the oil temperature RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 36k ohms?
YES NO
No Repair

Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-208 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Connect the engine harness to the oil temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil temperature RETURN pin on the engine harness in-line connector to the oil temperature RETURN pin on the engine harness sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the oil temperature sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil temperature sensor.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the oil temperature SUPPLY pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the oil temperature RETURN pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-213 in Section 19.

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil temperature SUPPLY pin on the extension harness connector to the oil temperature SUPPLY pin on the extension harness in-line connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to the oil temperature SIGNAL pin on the extension harness in-line connector.
  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to the oil temperature RETURN pin on the extension harness in-line connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the oil temperature SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 212 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Nov-2016


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | Between 600 and 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a pin-to-pin short circuit. | Greater than100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 213 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting steps.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the oil temperature sensor.

Action

Check the resistance of the oil temperature sensor.

  • Measure the resistance between the oil temperature SIGNAL pin and the oil temperature RETURN pin.

Between 600 and 36k ohms?
YES NO
No Repair

Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the oil temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the oil temperature sensor connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-208 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil temperature SUPPLY pin on the engine harness in-line connector to the engine block ground.
  • Measure the resistance from the oil temperature SIGNAL pin on the engine harness in-line connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Connect the engine harness to the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil temperature RETURN pin on the engine harness in-line connector to the oil temperature RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the oil temperature SUPPLY pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the oil temperature RETURN pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-213 in Section 19.

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil temperature SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to engine block ground.
  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil temperature SUPPLY pin on the extension harness connector to the oil temperature SUPPLY pin on the extension harness in-line connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to the oil temperature SIGNAL pin on the extension harness in-line connector.
  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to the oil temperature RETURN pin on the extension harness in-line connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the oil temperature SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 213 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Nov-2016


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the oil temperature sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check the threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 214 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the intake manifold temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the oil temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the oil temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES NO
No Repair

Go to Fault Code 212.

Go to 2A

Fault Code 212

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the oil temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the oil temperature sensor.

Fault simulation enabled?
YES NO

Disable fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify thatthe fault threshold is not within the normal operating range for the oil temperature sensor.

Fault threshold set correctly?
YES NO

See the following symptom tree t107 in the TS section of the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 214 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

AppropriateTroubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | Signal voltage within specifications for the sensor at ambient air pressure?
STEP 3. | Clear the engine harness. |
 | STEP 3A. Inspect the engine harness and extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the extension harness. |
 | STEP 4A. Inspect the extension harness and and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the barometric pressure sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the barometric pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engne harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's supply and return connectors into the multimeter.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Signal voltage within specifications for the sensor at ambient air pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the barometric pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the barometric pressure RETURN pin on the engine harness inline connector to the barometric pressure RETURN pin on the engine harness sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the barometric pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the barometric pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the barometric pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the barometric pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the barometric pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module (ECM). Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Connect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the barometric pressure SUPPLY pin on the extension harness connector to the barometric pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the barometric pressure SIGNAL pin on the extension harness connector to the barometric pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the barometric pressure RETURN pin on the extension harness connector to the barometric pressure RETURN pin on the extension harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Refer to Procedure 019-213 in Section 19
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the barometric pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector
  • Measure the resistance from the barometric pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the barometric pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-213 in Section 19
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP Enginecontrolmodule(ECM)1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | Signal voltage within specifications for the sensor at ambient air pressure?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the barometric pressure sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the barometric pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engne harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's supply and return connectors into the multimeter.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Signal voltage within specifications for the sensor at ambient air pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the barometric pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the barometric pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the barometric pressure SIGNAL pin on the engine harness inline connector to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the barometric pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the barometric pressure RETURN pin on the engine harness inline connector to the barometric pressure RETURN pin on the engine harness sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the barometric pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the barometric pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the barometric pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the barometric pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the barometric pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19, Refer to Procedure 019-208 in Section 19, or Refer to Procedure 019-202 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the barometric pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the barometric pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the barometric pressure RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the barometric pressure SIGNAL pin on the engine harness inline connector to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Connect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the barometric pressure SUPPLY pin on the extension harness connector to the barometric pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the barometric pressure SIGNAL pin on the extension harness connector to the barometric pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the barometric pressure RETURN pin on the extension harness connector to the barometric pressure RETURN pin on the extension harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Refer to Procedure 019-213 in Section 19
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the barometric pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector
  • Measure the resistance from the barometric pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the barometric pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Refer to Procedure 019-213 in Section 19
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 223 - Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine oil burn valve solenoid. |
 | STEP 1A. Verify the burn valve solenoid is connected to the engine harness. | Solenoid connected to the engine harness?
 | STEP 1B. Inspect the burn valve solenoid and harness connector pins. | Dirty or damaged pins?
 | STEP 1C. Check for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 2. | Clear the engine harness. |
 | STEP 2A. Inspect the engine harness and extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the extension harness. |
 | STEP 3A. Inspect the extension harness and and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 223 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for engine oil burn valve solenoid.

Guided Step 1A - Verify the burn valve solenoid is connected to the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for engine oil burn valve solenoid.

Verify the burn valve solenoid is connected to the engine harness.

Solenoid connected to the engine harness?
YES NO
No Repair

Connect the solenoid to the engine harness.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the burn valve solenoid and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the burn valve solenoid.

Action

Inspect the burn valve solenoid and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engne harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the burn valve solenoid.

Action

Check for a short circuit to ground in the burn valve solenoid.

  • Measure the resistance from pin A of the burn solenoid connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the burn valve solenoid.

  • Refer to Procedure 019-173 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the burn valve solenoid.

Action

Check for a open circuit in the burn valve solenoid.

  • Measure the resistance from pin A to pin B of the burn valve solenoid connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the burn valve solenoid.

  • Refer to Procedure 019-173 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the burn valve solenoid from the engine harness.

Action

Check for an open circuit in the burn valve solenoid circuit.

  • Measure the resistance from the Centinel™ actuator +5-VDC SUPPLY pin on the engine harness inline connector to the Centinel™ actuator +5-VDC SUPPLY pin at the engine harness solenoid connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the burn valve solenoid from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the Centinel™ actuator +5-VDC SUPPLY pin on the engine harness inline connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the burn valve solenoid from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the Centinel™ actuator +5-VDC SUPPLY pin on the engine harness inline connector to all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19, Refer to Procedure 019-208 in Section 19, or Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the egnien control module (ECM). Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Connect the extension harness from the engine harness.

Action

Check for an open circuit in the burn valve solenoid circuit.

  • Measure the resistance from the Centinel™ actuator +5-VDC SUPPLY pin on the extension harness ECM connector to the Centinel™ actuator +5-VDC SUPPLY pin at the extension harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the extension harness.

  • Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to ground.

  • Measure the resistance from the Centinel™ actuator +5-VDC SUPPLY pin on the extension harness ECM connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the extension harness.

  • Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the Centinel™ actuator +5-VDC SUPPLY pin on the extension harness ECM connector to all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the extension harness.

  • Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 223 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 224 - Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 224 active?
STEP 2. | Check the engine oil burn valve solenoid driver. |
 | STEP 2A. Inspect the engine harness and engine oil burn valve solenoid driver. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine oil burn valve solenoid driver. | 80 to 120 ohms?
 | STEP 2C. Check the engine oil burn valve solenoid driver supply voltage and return circuit. | Greater than 6.0 VDC?
 | STEP 2D. Check for an open circuit in the engine oil burn valve solenoid driver return circuit. | Less than 10 ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the ECM engine oil burn valve solenoid driver diagnostic supply voltage. | Greater than 6.0 VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 224 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 224 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil burn valve solenoid driver.

Guided Step 2A - Inspect the engine harness and engine oil burn valve solenoid driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Inspect the engine harness and engine oil burn valve solenoid driver connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or engine oil burn valve solenoid driver.

Clean the connector and pins.

Replace the damaged section of the harness or damaged engine oil burn valve solenoid driver.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 or Refer to Procedure 019-173 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine oil burn valve solenoid driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Check for an open circuit in the engine oil burn valve solenoid driver.

  • Measure the resistance from the engine oil burn valve solenoid driver SIGNAL pin to the engine oil burn valve solenoid driver RETURN pin at the engine oil burn valve solenoid driver.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

  • 80 to 120 ohms?
YES NO
No Repair

Replace the engine oil burn valve solenoid driver.

  • Refer to Procedure 019-173 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the engine oil burn valve solenoid driver supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine oil burn valve solenoid driver SIGNAL pin and the engine oil burn valve solenoid driver RETURN pin at the engine oil burn valve solenoid driver connector of the engine harness.

Greater than 6.0-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the engine oil burn valve solenoid driver return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Check for an open circuit.

  • Measure the resistance from the engine oil burn valve solenoid driver engine harness connector RETURN pin to engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM1 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector.

Clean the connector and pins.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM1 50-pin connector.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil burn valve solenoid driver harness connector SIGNAL pin and the engine oil burn valve solenoid driver 50-pin engine harness connector SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques,. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM1 50-pin connector.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil burn valve solenoid driver SIGNAL pin in the engine harness 50-pin connector and all other pins in the connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine oil burn valve solenoid driver SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the ECM engine oil burn valve solenoid driver diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM1 50-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil burn valve solenoid driver SIGNAL pin and the engine oil burn valve solenoid driver RETURN pin at the 50-pin ECM connector port.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 6.0-VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 30 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 224 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM1 (CM850 ECM) 60-pin connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the CM850 ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM1 (CM850 ECM) 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the CM850 ECM. Refer to Procedure 019-031 in Section 19.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2050 rpm, the engine must be shut off immediately.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine just performed a load dump?
 | STEP 1B. Verify whether any fault simulation feature is enabled. | Fault simulation enabled?
 | STEP 1C. Check threshold setting. | Fault threshold is set correctly?
 | STEP 1D. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1E. Check the engine rpm with the monitor mode. | Correct rpm reading?
 | STEP 1F. Check the injector overhead settings. | Correct injector overhead settings?
 | STEP 1G. Check for an active fault at low engine rpm. | Active fault when engine is running below engine overspeed shutdown threshold?
 | STEP 1H. Test the generator. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Identify the reason for the overspeed.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

Check if the engine was just coming off a load dump when the fault was logged.

Engine just performed a load dump?
YES NO

Check the engine for damage.

  • Electronics are functional.
  • Check the base engine for damage due to overspeed condition.

 No Repair

Go to 1B

Go to 2A

Guided Step 1B - Verify whether any fault simulation feature is enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that there are no fault simulations that are enabled.

Fault simulation enabled?
YES NO

Disable fault simulation.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within the normal operating range for the engine overspeed sensor.

Fault threshold set correctly?
YES NO

Reference symptom tree T081 in Section TS of the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 1D

Go to 2A

Guided Step 1D - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the operator reported a fuel controlled event where the engine rapidly accelerated, followed by moderate deceleration.

Alternate fuel source?
YES NO

  • Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check the engine rpm with the monitor mode.

Conditions

  • Turn keyswitch ON.

Action

Check the engine RPM with the monitor mode.

  • Use INSITE™ electronic service tool to monitor the engine rpm.

Correct rpm reading?
YES NO
No Repair

Inspect the engine position sensor. Check the engine position sensor as outlined for Fault Codes 115, 121, or 689.

Go to 1F

Fault Codes 115, 121, or 689

Guided Step 1F - Check the injector overhead settings.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector overhead settings.

  • Use the following procedure for correct injector overhead setting in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 003-006 in Section 3.

Correct injector overhead settings?
YES NO
No Repair

Adjust the overhead per the outer base circle (OBC) method.

  • Refer to Procedure 003-006 in Section 3.
  • Inspect the base engine for damage due to an overspeed condition.

Go to 1G

Go to 2A

Guided Step 1G - Check for an active fault at low engine rpm.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault at low engine rpm.

  • Check for active Fault Code 234 when the engine is not running above the engine overspeed shutdown threshold.

Active fault when engine is running below engine overspeed shutdown threshold?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 2A

Go to 1H

Guided Step 1H - Test the generator.

Conditions

  • Turn keyswitch ON.

Action

Test the generator.

  • Check if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

  • Adjust the governor gain settings as outlined for Fault Code 1418.
  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

Do not add cold coolant to a hot engine. Casting can be damaged. Allow engine to cool to below 50°C [120°F] before adding coolant.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the coolant is low. |
 | STEP 1A. Check the coolant level. | Coolant level OK?
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault is still active with the engine running. | Fault code still active?
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 235 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verfiy that the coolant is low.

Guided Step 1A - Check the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Remove the radiator cap and inspect the coolant level.

N/A

Coolant level OK?
YES NO
No Repair

Add coolant to radiator.

Make sure coolant has proper amount of antifreeze, diesel coolant additive (DCA), and water.

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Confirm the fault is still active with the engine running.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code still active?
YES NO

Replace the coolant level sensor.

  • Refer to Procedure 019-017 in Section 19.

 No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module (ECM) (CM850).

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the coolant level sensor.

Fault threshold set correctly?
YES NO

Reference symptom trees T020 and T021 in Section TS of the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 235 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™//Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 3 and return. |
 | STEP 2A. Inspect the coolant level sensor connector and circuit connected to the sensor supply 3 and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM and harnesses. |
 | STEP 3A. Inspect the ECM1 (CM850) and ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the extension harness and generator control panel connector pins. | Dirty or damaged pins?
 | STEP 3C. Inspect the engine harness and INLINE connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the harnesses for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D-1. Check the engine harness for a short circuit to ground. |
 | STEP 3D-2. Check the extension harness for a short circuit to ground. |
 | STEP 3E. Check the harnesses for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3E-1. Check the engine harness for a pin-to-pin short circuit. |
 | STEP 3E-2. Check the extension harness for a pin-to-pin short circuit. |
 | STEP 3F. Check for a short circuit in the ECM battery negative (-) circuit. | Greater than 100k ohms?
 | STEP 3F-1. Check for a short circuit in the engine harness battery negative (-) circuit. |
 | STEP 3F-2. Check for short circuit in the extension harness battery negative (-) circuit. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 3 and return.

Guided Step 2A - Inspect the coolant level sensor connector and circuit connected to the sensor supply 3 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor connector from the engine harness connector.

Action

Inspect the engine harness and coolant level sensor connector pins for the following:

  • Loose connector
  • corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged coolant level sensor.

  • Refer to Procedure 019-017 or Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the coolant level sensor.

Refer to Procedure 019-017 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harnesses.

Guided Step 3A - Inspect the ECM1 (CM850 ECM) and ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM1 50-pin connector.

Action

Inspect the ECM harness and ECM1 connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

Clean the connector and pins.

Repair or replace the connector or damaged section of the ECM harness.

  • Refer to Procedure 019-204 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the extension harness and generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel 72-pin connector.

Action

Inspect the extension harness and generator control panel connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the extension harness connector.

Clean the connector and pins

Repair or replace the connector or damaged section of the extension harness.

  • Refer to Procedure 019-213 or Refer to Procedure 019-175 in Section 19.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the engine harness and INLINE™ connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the INLINE™ B connector.

Action

Inspect the extension harness and generator control panel connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the extension harness connector.

Clean the connector and pins

Repair or replace the connector or damaged section of the extension harness.

  • Refer to Procedure 019-208 or Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the harnesses for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM1 50-pin connector.
  • Disconnect the engine harness from the coolant level sensor connector.

Action

Check the harnesses for a short circuit to ground.

  • Measure the resistance between the coolant level sensor SUPPLY (sensor SUPPLY 3) pin at the ECM harness 50-pin connector and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3E

Go to 3D-1

Guided Step 3D-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness at the INLINE™ B connector.
  • Disconnect the engine harness from the coolant level sensor.

Action

Check the engine harness for a short circuit to ground.

  • Measure the resistance between the coolant level sensor SUPPLY (sensor SUPPLY 3) pin at the engine harness INLINE™ B connector and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D-2

Go to 4A

Guided Step 3D-2 - Check the extension harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel 72-pin connector.
  • Disconnect the extension harness from the engine harness at the INLINE™ B connector.

Action

Check the extension harness for a short circuit to ground.

  • Measure the resistance between the coolant level sensor supply (sensor SUPPLY 3) pin at the extension harness 72-pinconnector and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short circuit to ground has been detected in the ECM harness in the generator control panel.

Repair or replace the damaged section of the harness.

Refer to the OEM service manual.

A short circuit to ground has been detected in the extension harness.

Repair or replace the damaged section of the harness.

  • Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 3E - Check the harnesses for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM1 50-pin connector.
  • Disconnect the engine harness from the coolant level sensor connector.

Action

Check the ECM harness for a pin-to-pin short circuit.

  • Measure the resistance between the coolant level sensor SUPPLY (sensor SUPPLY 3) pin at the ECM harness 50-pin connector to all other pins in the connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3F

Go to 3E-1

Guided Step 3E-1 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the INLINE™ B connector.
  • Disconnect the engine harness from the coolant level sensor.

Action

Check the engine harness for a pin-to-pin short circuit.

  • Measure the resistance between the coolant level sensor SUPPLY (sensor SUPPLY 3) pin at the engine harness INLINE™ B connector to all other pins in the connector

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a pin-to-pin short circuit in the engine harness.

Repair or replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3E-2

Go to 4A

Guided Step 3E-2 - Check the extension harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel 72-pin connector.
  • Disconnect the extension harness from the engine harness at the INLINE™ B connector.

Action

Check the extension harness for a pin-to-pin short circuit

  • Measure the resistance between the coolant level sensor SUPPLY (sensor SUPPLY 3) pin at the extension harness 72-pin connector to all other pins in the connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

There is a pin-to-pin short circuit in the ECM harness in the generator control panel.

Repair or replace the damaged section of the harness.

  • Refer to the OEM service manual.

There is a pin-to-pin short circuit in the extension harness.

Repair or replace the damaged section of the harness.

  • Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 3F - Check for a short circuit in the ECM battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM1 50-pin connector.
  • Disconnect the ECM harness connector from the ECM1 4-pin power connector.
  • Disconnect the engine harness from the coolant level sensor connector.

Action

Check for a short circuit.

  • Measure the resistance between thecoolant level sensor SUPPLY (sensor SUPPLY 3) pin at the ECM harness 50-pin connector and the battery 1 voltage RETURN (ECM 1) pin in the ECM power connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3F-1

Guided Step 3F-1 - Check for a short circuit in the engine harness battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connectors from the generator control panel.
  • Disconnect the extension harness from the engine harness at the INLINE™ B and C connectors.

Action

Check for a short circuit.

  • Measure the resistance between the coolant level sensor SUPPLY (sensor SUPPLY 3) pin at the engine harness InlineB connector and the battery 1 voltage RETURN pin in the engine harness INLINE™ C connector

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3F-2

Go to 4A

Guided Step 3F-2 - Check for a short circuit in the extension harness battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the engine harness at the INLINE B and C connectors.
  • Disconnect the engine harness from the coolant level sensor.

Action

Check for a short circuit

  • Measure the resistance between the coolant level sensor SUPPLY (sensor SUPPLY 3) pin at the extension harness 72-pin connector and the battery 1 voltage RETURN pin in the extension harness 4-pin connector.

Use a wiring diagram for pin identification and the following procedure for general resisitance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

There is a short circuit in the ECM harness in the generator control panel.

Repair or replace the damaged section of the harness.

  • Refer to the OEM service manual.

There is a short circuit in the extension harness.

Repair or replace the damaged section of the harness.

  • Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clean the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 254 - Engine Fuel Shutoff Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff valve solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff valve solenoid post. | Extra wires attached to the solenoid post?
 | STEP 1B. Clean the solenoid posts and the wiring terminal. | Solenoid posts clean?
 | STEP 1C. Check the supply voltage at the fuel shutoff valve solenoid. | Greater than 17.0-VDC for +24-VDC fuel shutoff?
 | STEP 1D. Check the fuel shutoff solenoid resistance. | 24 to 50 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the extension harness. |
 | STEP 3A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 223 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel shutoff solenoid valve solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff valve solenoid post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for extra wires on the fuel shutoff solenoid post.

Refer to the circuit diagram for more details.

Extra wires attached to the solenoid post?
YES NO

Remove the extra wires, and connect the removed wires to a proper 24-VDC supply.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Clean the solenoid posts and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff control wire to the fuel shutoff valve solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the posts of the fuel shutoff valve solenoid and the terminal for the fuel shutoff valve solenoid control wires of the engine harness.

Solenoid posts clean?
YES NO
No Repair

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Go to 4A

Go to 1C

Guided Step 1C - Check the supply voltage at the fuel shutoff valve solenoid.

Conditions

  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Turn keyswitch ON.
  • Crank engine.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff SUPPLY wire ring terminal on the harness side to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 17.0-VDC for +24-VDC fuel shutoff?
YES | NO
No Repair | No Repair

Go to 1D

Go to 2A

Guided Step 1D - Check the fuel shutoff solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.

Action

Check the fuel shutoff solenoid resistance.

  • Measure the resistance from the fuel shutoff solenoid supply post to the fuel shutoff solenoid ground post.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

24 t0 50 ohms?
YES NO
No Repair

Replace the fuel shutoff valve solenoid.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the the engine harnes from the fuel shutoff valve solenoid.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the fuel shutoff valve signal ring terminal.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the fuel shutoff valve return ring terminal.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel shutoff valve solenoid.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19, Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module (ECM). Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the extension harness from the generator control panel.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the extension harness connector to the fuel shutoff valve SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to the fuel shutoff valve RETURN pin on the extension harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 259 - Engine Fuel Shutoff Valve Stuck Open - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff valve solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff valve solenoid post. | Extra wires attached to the solenoid post?
 | STEP 1B. Clean the solenoid posts and the wiring terminal. | Solenoid posts clean?
 | STEP 1C. Check the supply voltage at the fuel shutoff valve solenoid. | Greater than 17.0-VDC for +24-VDC fuel shutoff?
 | STEP 1D. Check the fuel shutoff solenoid resistance. | 24 to 50 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 259 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel shutoff solenoid valve solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff valve solenoid post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for extra wires on the fuel shutoff solenoid post.

Refer to the circuit diagram for more details.

Extra wires attached to the solenoid post?
YES NO

Remove the extra wires, and connect the removed wires to a proper 24-VDC supply.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Clean the solenoid posts and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff control wire to the fuel shutoff valve solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the posts of the fuel shutoff valve solenoid and the terminal for the fuel shutoff valve solenoid control wires of the engine harness.

Solenoid posts clean?
YES NO
No Repair

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check the supply voltage at the fuel shutoff valve solenoid.

Conditions

  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Turn keyswitch ON.
  • Crank engine.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff SUPPLY wire ring terminal on the harness side to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 17.0-VDC for +24-VDC fuel shutoff?
YES | NO
No Repair | No Repair

Go to 1D

Go to 2A

Guided Step 1D - Check the fuel shutoff solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.

Action

Check the fuel shutoff solenoid resistance.

  • Measure the resistance from the fuel shutoff solenoid supply post to the fuel shutoff solenoid ground post.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

24 t0 50 ohms?
YES NO
No Repair

Replace the fuel shutoff valve solenoid.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the the engine harnes from the fuel shutoff valve solenoid.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the fuel shutoff valve signal ring terminal.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the fuel shutoff valve return ring terminal.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel shutoff valve solenoid.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19, Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control moudle (ECM). Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the extension harness from the generator control panel.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the extension harness connector to the fuel shutoff valve SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to the fuel shutoff valve RETURN pin on the extension harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 259 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 261 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the fuel temperature sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 261 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the fuel temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES NO
No Repair

Go to Fault Code 263.

Go to 2A

Fault Code 263

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the fuel temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the fuel temperature sensor.

Fault simulation enabled?
YES NO

Disable fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within the normal operating range for the fuel temperature sensor.

Fault threshold set correctly?
YES NO

Reference symptom trees T057 in Section TS of the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 261 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 600 to 36k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 263 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel temperature sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engne harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature SIGNAL pin and the fuel temperature RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

600 to 36k ohms?
YES NO
No Repair

Replace the fuel temperature sensor.

  • Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the fuel temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel temperature RETURN pin on the engine harness inline connector to the fuel temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness inline connector to the fuel temperature SIGNAL pin at the engine harness sensor connector

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel temperature RETURN pin on the engine harness inline connector to all other pins inthe engine harness inline connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19, Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module (ECM). Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Connect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel temperature SIGNAL pin on the extension harness connector to the fuel temperature SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel temperature RETURN pin on the extension harness connector to the fuel temperature RETURN pin on the extension harness inline connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the extension harness.

  • Refer to Procedure 019-213 in Section 19
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair the extension harness.

  • Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 263 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted Low to Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™, test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 600 Ohms to 36k Ohms?
 | STEP 2C. Check the sensor signal voltage. | More than 100k Ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k Ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k Ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to engine block ground. | Greater than 100k Ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k Ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 265 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • UsE INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel temperature sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Use the following procedures to repair the engine harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature SIGNAL pin and the fuel temperature RETURN pin.

600 to 36k Ohms?
YES NO
No Repair

Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the fuel temperature sensor connector to the engine block ground.

More than 100k Ohms?
YES NO
No Repair

Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedures to repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel temperature RETURN pin on the engine harness inline connector to the engine block ground.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k Ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the coolant temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k Ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the extension harness. Use the following procedures to repair the extension harness.

  • Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel temperature RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel temperature SIGNAL pin on the extension harness connector to the engine block ground.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k Ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k Ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 265 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 266 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 266 /inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the fuel temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES | NO
No Repair | No Repair

Go to 2A

Fault Code 263.

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM sensor value.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the fuel temperature sensor.

Fault simulation disabled?
YES NO

Disable fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the fuel temperature sensor.

Fault threshold set correctly?
YES NO

Reference Section TS, symptom tree T057, in the Troubleshooting and Repair Manual, QSK78 Series Engines, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 266 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the generator control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which generator control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the generator control unit multiplexing configuration?
STEP 4. | Check the SAE J1939 data link harness. |
 | STEP 4A. Inspect the SAE J1939 data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the SAE J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM SAE J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM SAE J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Reference Inactive or Intermittent Fault Codes. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the generator control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which generator control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper generator control unit multiplexing configuration component enables and generator control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the generator control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the generator control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. The issue may be a generator control unit, generator control unit setup, or generator control unit to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the generator control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the SAE J1939 data link harness.

Guided Step 4A - Inspect the SAE J1939 data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link adapter connector from the 9-pin service data link connector.

Action

Inspect the SAE J1939 data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-165 in Section 19.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link adapter connector from the 9-pin service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the service data link connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the SAE J1939 data link connector or harness connection to the SAE J1939 data link backbone.

Troubleshoot harnesses connected in series to determine which contains the open or short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the malfunctioning section of the harness.

Refer to Procedure 019-165 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 50-pin connector.

Action

Inspect the ECM SAE J1939 data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the SAE J1939 data link connector or harness.

Clean the connector and pins.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 50-pin connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the appropriate ECM connection to the SAE J1939 data link harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or short circuit.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Refer to the OEM service manual.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 50-pin connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the ECM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link SUPPLY and the SAE J1939 data link RETURN pins.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Refer to the OEM service manual.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check for appropriate circuit response.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the SAE J1939 data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Reference the appropriate ECM No Communication (tt-ECM) symptom tree

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 285. | Fault Code 285 active?
 | STEP 1B. Check for Fault Code 286. | Fault Code 286 active?
STEP 2. | Check the generator control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which generator control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 285.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 285.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES NO

Troubleshoot Fault Code 285 first.

 No Repair

Fault Code 285

Go to 1B

Guided Step 1B - Check for Fault Code 286

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 286.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the generator control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which generator control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine the proper generator control unit multiplexing configuration component enables and OEM generator control unit source adddresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the generator control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the generator control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. The issue may be a generator control unit, generator control unit setup, or generator control unit to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the generator control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 286 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 316 - Fuel Supply Pump Actuator Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pump actuator. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the coil resistance of the fuel pump actuator. | 7.0 to 9.0 ohms?
 | STEP 1C. Check for a SUPPLY pin short to engine block ground. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to the power supply. | Greater than 100k ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the generator control panel connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Less than 10 ohms?
 | STEP 3E. Less than 10 ohms? | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Fault Code 316 inactive? | Fault Code 316 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel pump actuator.

Guided Step 1A - Inspect the sensor and engine harness connector pins for the following.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the fuel pump actuator.

Action

Inspect the sensor and the engine harness connector pins for the following:Loose connector

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the coil resistance of the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check the coil resistance.

  • Measure the resistance of the fuel pump actuator.

7.0 to 9.0 ohms?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check for a SUPPLY pin short to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for the SUPPLY pin short to engine block ground.

  • Measure the resistance from pin A to the engine block ground.
  • Measure the resistance from pin B to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn Keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness in-line connector to the engine block ground.
  • Measure the resistance from the fuel pump actuator SUPPLY pin on the engine harness in-line connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-208 in Section 19.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the fuel pump actuator.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump actuator SIGNAL pin on the engine harness connector to the fuel pump actuator SIGNAL pin on the engine harness actuator connector.
  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness connector to the fuel pump actuator RETURN pin on the engine harness actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel pump.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness inline connector to all other pins in the engine in-line connector.
  • Measure the resistance from the fuel pump actuator SIGNAL pin on the engine harness in-line connector to all other pins in the engine harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit from power-suply.

  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness connector to all SUPPLY pins on the engine harness in-line connector.
  • Measure the resistance from the fuel pump actuator SIGNAL pin on the engine harness in-line connector to all SUPPLY pins on the engine harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the engine harness and the generator control panel connector pins.

Conditions

  • Turn Keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn Keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the generator control panel.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to the engine block ground
  • Measure the resistance from the fuel pump actuator SUPPLY pin on the extension harness connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness. Refer to Procedure 019-208 in Section 19.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn Keyswitch OFF.
  • Disconnect the engine harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuelpump actuator SIGNAL pin on the extension harness connector to the fuel pump actuator SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to the fuel pump actuator RETURN pin on the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump actuator SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from power supply.

  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to all SUPPLY pins on the extension harness connector.
  • Measure the resistance from the fuel pump actuator SIGNAL pin on the extension harness connector to all SUPPLY pins on the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3E

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 316 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps.

Last Modified: 18-Nov-2016


FAULT CODE 318 - Fuel Supply Pump Actuator - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for other fault codes. | Other fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 318 active?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check the fuel tank level. | Fuel present in fuel tank?
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | Any leaks, broken lines, or loose fittings present in the fuel system?
 | STEP 2C. Check the fuel inlet restriction. | Fuel inlet restriction less than the specification?
 | STEP 2D. Check for air in the fuel. | Air leaks present?
 | STEP 2E. Check the fuel pump output pressure. | Fuel pump output pressure less than the specification?
 | STEP 2F. Check the injector o-rings. | Drain output from one bank within 25 ml [0.85 oz] of the drain output from the other bank?
 | STEP 2G. Check the fuel pump output pressure sensor. | Mechanical reading match the electronic sensor reading in INSITE™ electronic service tool?
 | STEP 2H. Inspect the fuel pump actuator screen for debris. | Debris present in the screen?
 | STEP 2I. Inspect the fuel pump actuator screen for debris. | Corrosion present on the actuator?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 318 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for other fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes besides Fault Code 318.

  • Use INSITE™ electronic service tool to read the fault codes.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 318 active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the uel system.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank level for the following:

  • Fuel in the tank.

Fuel present in fuel tank?
YES NO
No Repair

Fill the tank with fuel.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.

Refer to Procedure 200-001 in Section F.

Any leaks, broken lines, or loose fittings present in the fuel system?
YES NO

Repair the leak. Tighten or replace the leaking fitting or fuel line. Replace the fuel line. Use the following procedures in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Refer to Procedure 006-024 in Section 6.

Fill the tank with fuel.

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the inlet restriction as follows:

  • Measure the inlet restriction and compare to specification. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specification?
YES NO
No Repair

  • Find the cause of the restriction and remove the restriction. Check for debris in the fuel tank, fuel tank vents clogged or malfunctioning check valves.
  • Change the fuel filters. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Change the fuel filters. Refer to Procedure 006-015 in Section 6.
  • Inspect the fuel lines and replace if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Refer to Procedure 006-024 in Section 6.

Go to 2D

Go to 3A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Refer to Procedure 006-003 in Section 6.

Air leaks present?
YES NO

  • Find the cause of the air leak. Check the OEM fuel lines and the fuel tank drop tube for air leaks. Refer to the OEM Service Manual. Check for damaged or missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.
  • Change the fuel filters. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Change the fuel filters. Refer to Procedure 006-015 in Section 6.
  • Inspect the fuel lines and replace if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the check fitting. Use the following procedures in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Refer to Procedure 005-016 in Section 5.

Fuel pump output pressure less than the specification?
YES | NO
No Repair | No Repair

Go to 2F

Go to 2G

Guided Step 2F - Check the injector o-rings.

Conditions

  • Turn keyswitch ON.

Action

Check the injector o-rings. The o-rings can be checked by observing the drain output of each bank.

  • Disconnect the drain lines for each bank at the T-junction.
  • Place the drain lines for each bank into separate graduated cylinders with a capacity of at least 500 ml [17 oz].
  • Run the engine at rated speed for 1 minute to determine if output is equal from each bank.

Drain output from one bank within 25 ml [0.85 oz] of the drain output from the other bank?
YES NO

Replace the fuel pump. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Refer to Procedure 005-016 in Setion 5.

Replace the injector o-rings on the malfunctioning bank. Refer to Procedure 006-026 in Section 6.

Go to 3A

Go to 3A

Guided Step 2G - Check the fuel pump output pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pump output pressure sensor.

  • Measure the output pressure of the pump at the check fitting. Use the following procedures in the QSK78 Troubleshooting and Repair Manual, Bulletin Number 3666727. Refer to Procedure 005-016 in Section 5.
  • Compare this mechanical reading to fuel pump pressure sensor parameter. Refer to INSITE™ electronic service tool manual for the procedure to monitor this parameter.

Mechanical reading match the electronic sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 2H

Go to 3A

Guided Step 2H - Inspect the fuel pump actuator screen for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump actuator screen for debris.

  • Remove the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Debris present in the screen?
YES NO

Replace the fuel pump actuator sensor. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 3A

Go to 2I

Guided Step 2I - Inspect the fuel pump actuator for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump actuator for corrosion on surfaces that come in contact with fuel.

  • Remove the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Debris present in the screen?
YES NO

Replace the fuel pump actuator sensor. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 318 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Apr-2011


FAULT CODE 342 - Electronic Calibration Code Incompatibility - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM) and engine harness. |
 | STEP 1A. Inspect all ECM and engine harness connector pins. | Dirty or damaged pins?
STEP 2. | Inspect terminating resistor and circuit. |
 | STEP 2A. Inspect the terminating resistor. | 120 ohms?
 | STEP 2B. Inspect the data link circuit | 60 ohms?
STEP 3. | Calibrate the ECMs. |
 | STEP 3A. Calibrate ECMs. | ECMs accepted calibration?
 | STEP 3B. ROM boot ECMs. | ROM boot procedure successful?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 342 inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM and engine harness.

Guided Step 1A - Inspect all ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all of the engine harness connectors from the ECM connectors for both EMCs.

Action

Inspect the engine harness and all ECM engine connector pins for the following:

Inspect the engine harness and all ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in an ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Reference the circuit diagram or wiring diagram for connector identification.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Inspect the terminating resistor and circuit.

Guided Step 2A - Inspect the terminating resistor.

Conditions

  • Disconnect terminating resistors.

Action

Measure the resistance across SAE J1939 data link SUPPLY pin and SAE J1939 data link RETURN pin on both terminating resistors.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

120 ohms?
YES NO
No Repair

Replace the terminating resistor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the data link circuit.

Conditions

  • Disconnect all of the engine harness ECM 60-pin connectors.
  • Connect terminating resistor.

Action

Measure the resistance across SAE J1939 data link RETURN pin and SAE J1939 data link SUPPLY pin on the 60-pin connectors for all ECMs.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

60 ohms?
YES NO
No Repair

A damaged connection has been detected in an ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19..

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Calibrate the ECMs

Guided Step 3A - Calibrate the ECM.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECMs.

  • Use the following procedure and INSITE™ electronic service tool user's manual to calibrate the ECM. Refer to Procedure 019-032 in Section 19.

ECMs accepted calibration?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - ROM boot the ECMs.

Conditions

  • Turn keyswitch OFF.

Action

ROM boot the ECMs.

  • Refer to Procedure 019-427 in Section 19.

ROM boot procedure successful?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 342 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 2B

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 2B

Last Modified: 18-Nov-2016


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. .
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement : Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 343 inactive?
 | STEP 1B. Inspect the engine speed sensor. | Fault Code 343 inactive?
STEP 2. | Check the power and ground connections. |
 | STEP 2A. Check all engine and chassis power and ground connections. | Ground connections clean and firmly attached?
 | STEP 2B. Check all power resistances. | Less than 10 ohms?
 | STEP 2C. Check all ground resistances. | Less than 10 ohms?
STEP 3. | Check for moisture in the connectors. |
 | STEP 3A. Check for moisture in the extension harness connectors. | All connectors dry?
 | STEP 3B. Check for moisture in the connectors. | All connectors dry?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF and wait at least 5 seconds.
  • Connect INSITE™ electronic service tool.
  • Place idle/rated switch in the IDLE position.
  • Turn keyswitch ON and let the engine idle for 1 minute.

Action

Read the fault code.

  • Use INSITE™ electronic service tool to check for Fault Code 343.

Fault Code 343 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.

Action

Disconnect the power to the ECM.

  • Disconnect the power to the ECM at the battery.
  • Wait 1 minute.
  • Connect the power to the ECM at the battery.
  • Connect INSITE™ electronic service tool to the data link.
  • Place the idle/rated switch in the IDLE position.
  • Turn keyswitch ON and idle for 1 minute.
  • Use INSITE™ electronic service tool to check for inactive Fault Code 343.

Fault Code 343 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the power and ground connections.

Guided Step 2A - Check all engine and chassis power and ground connections.

Conditions

  • Turn keyswitch OFF.

Action

Check all engine and vehicle power and ground connections for the following:

  • Corrosion
  • Loose connections.

Ground connections clean and firmly attached?
YES NO
No Repair

Repair or replace any damaged connections.

Go to 2B

Go to 4A

Guided Step 2B - Check all power resistances.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the negative battery cable from the battery.
  • Disconnect the positive battery cable from the battery.

Action

Check all power resistances.

  • Measure the resistance from all pins connected to the positive battery terminal of the extension harness connector to the positive (+) battery terminal connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Follow the troubleshooting steps for Fault Code 441.

Go to 2C

Fault Code 441

Guided Step 2C - Check all ground resistances.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the negative battery cable from the battery.
  • Disconnect the positive battery cable from the battery.

Action

Check all ground resistances.

  • Measure the resistance from all pins connected to the negative (-) battery terminal of the extension harness connector to the negative (-) battery terminal connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Follow the troubleshooting steps for Fault Code 441.

Go to 3A

Fault Code 441

Guided Step 3 - Check for moisture in the connectors.

Guided Step 3A - Check for moisture in the extension harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Check for moisture in the connectors.

  • Check for moisture in the extension harness and generator control panel connectors.

All connectors dry?
YES NO
No Repair

Dry the connectors.

Go to 3B

Go to 4A

Guided Step 3B - Check for moisture in the engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the engine harness.

Action

Check for moisture in the connectors.

  • Check for moisture in the extension harness and the engine harness connectors.

All connectors dry?
YES NO
No Repair

  • Dry the connectors.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Turn keyswitch ON and let the engine idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 346 - Engine Control Module Warning Software Error - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is a 10 ampere fuse and is not missing, loose, or blown. | Fuse is a 10 ampere fuse and is not missing, loose, or blown?
 | STEP 2B. Inspect the engine connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the battery power circuits. | 21 to 27-VDC (24-Volt system)?
 | STEP 2D. Check the battery supply for a short circuit from pin-to-pin. | Greater than 100k Ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness ground connection. | Damaged connection?
 | STEP 3B. Check for an open circuit. | Less than 10 Ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 346 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?
STEP 5. | Download calibration. |
 | STEP 5A. Download calibration. | Calibration download successful?
 | STEP 5B. Cycle keyswitch three times. | Fault Code 346 inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connection tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals.

  • Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Normal conditions.

  • At least 24-VDC (+24-Volt systems)

During cranking:

  • At least 12-VDC (+24-Volt systems)

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Change or replace the battery.

  • Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is a 10 ampere fuse and is not missing, loose, or blown.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuse.

  • Verify that it is a 10 ampere fuse.
  • Verify that the fuse is not missing.
  • Verify that the fuse is not loose.
  • Inspect the fuse to see if it has blown.

Fuse is a 10 ampere fuse and is not missing, loose, or blown?

YES NO
No Repair

Install the fuse correctly or replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine connector from the ECM connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery 1 voltage pin in the engine connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

21 to 27-VDC (24-Volt system)?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check battery supply for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from battery 1 voltage pin in the engine connector to all other pins in the connector.
  • Measure the resistance from battery 1 voltage RETURN pin in the engine connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100 Ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine block at the ground connection.

Action

Check the engine harness ground connection for the following:

  • Loose connections
  • Broken connections
  • Corroded connections
  • Excessive paint, oil, or dirt.

Damaged connection?
YES NO

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-197 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the OEM interface harness at the 16-pin connector.
  • Disconnect the OEM interface harness from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Measure the resistance from battery 1 voltage SUPPLY pin of the engine harness connector to the battery 1 voltage SUPPLY pin of the 16-pin OEM harness connector, OEM interface harness side.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM interface harness from the battery.

Action

Check for a short circuit from pin to pin in the unswitched battery supply.

  • Measure the resistance from battery 1 voltage RETURN pin of the engine harness connector to all other pins in the connector.
  • Measure the resistance from battery 1 voltage RETURN pin of the engine harness connector to all pins in the 50-pin OEM harness connector.
  • Measure the resistance from battery 1 voltage SUPPLY pin of the engine harness connector to all other pins in the connector.
  • Measure the resistance from battery 1 voltage SUPPLY pin of the engine harness connector to all pins in the 50-pin OEM harness connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness or engine harness.

  • Repair the OEM harness or engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness or engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Cycle the keyswitch three times.
  • Start engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: Wait 30 seconds after each key-OFF to let the ECMs complete their power-down cycle.

Fault Code 346 inactive?
YES NO
No Repair

Calibrate the ECMs. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Guided Step 5 - Download calibration.

Guided Step 5A - Download calibration.

Conditions

  • Connect all components.

Action

Download the calibration.

  • Calibration download procedure.

Calibration download successful?
YES NO
No Repair

Check communication connections and try the download.

Repair complete

Go to 5B

Guided Step 5B - Cycle keyswitch three times.

Conditions

  • Connect all components

Action

Cycle the keyswitch three times.

NOTE: Wait 30 seconds after each key OFF to let the ECMs complete their power-down cycle

Fault Code 346 inactive?
YES NO
No Repair

Change or replace the battery.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair complete

Repair complete

Last Modified: 18-Nov-2016


FAULT CODE 352- Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to sensor supply 1 and return. |
 | STEP 2A. Inspect the engine oil rifle pressure sensor and circuit connected to sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 352 active?
 | STEP 2C. Inspect the oil level sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2D. Check the circuit response. | Fault Code 352 active?
STEP 3. | Check the engine control module (ECM) and harnesses. |
 | STEP 3A. Inspect the ECM1 (850 ECM) and ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the extension harness and generator control panel connector pins. | Fault Code 352 active?
 | STEP 3C. Inspect the vehicle for optional devices. | OEM devices installed?
 | STEP 3D. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the harnesses for a short to ground. | Greater than 100k ohms?
 | STEP 3D-1. Check the engine harness for a short circuit to ground. |
 | STEP 3D-2. Check the extension harness for a short circuit to ground. |
 | STEP 3E. Check the harnesses for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3E-1. Check the engine harness for a pin-to-pin short circuit. |
 | STEP 3E-2. Check the extension harness for a pin-to-pin short circuit. |
 | STEP 3F. Check for a short circuit to the ECM battery negative (-) circuit. | Greater than 100k ohms?
 | STEP 3F-1. Check for a short circuit to the engine harness battery negative (-) circuit. |
 | STEP 3F-2. Check for a short circuit to the extension harness battery negative (-) circuit. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code - Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 1 and return.

Guided Step 2A - Inspect the engine oil rifle pressure sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and oil rifle pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the engine oil rifle pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged engine oil rifle pressure sensor.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-066 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine oil rifle pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the oil level sensor and circuit connected to sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor connector from the engine harness connector.

Action

Inspect the engine harness and oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the oil level sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged oil level sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-056 in Section 19.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM responseafter 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 352 active?
YES NO
No Repair

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harnesses.

Guided Step 3A - Inspect ECM 1 (CM850 ECM) and ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 1(ECM850) harness connector from the ECM 1 60-pin connector.

Action

Inspect the ECM harness and ECM 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the ECM harness connector.

Clean the connector and pins.

Replace the connector or damaged section of the ECM harness. Refer to Procedure 019-204 in Section 19. Refer to the OEM Service Manual.

Replace the ECM. Refer to Procedure 019-031 in Section 19

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the extension harness and generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel.

Action

Inspect the extension harness and generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the extension harness connector.

Clean the connector and pins.

Replace the connector or damaged section of the extension harness. Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-175 in Section 19.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the extension harness and generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the extension harness connector.

Clean the connector and pins.

Replace the connector or damaged section of the extension harness. Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the harnesses for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 1 60-pin connector.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check the ECM harness for a short circuit to ground.

  • Measure the resistance between the sensor SUPPLY 1 pin at the ECM harness 60-pin connector and engine block ground

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3E

Go to 3D-1

Guided Step 3D-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness at the Inline B connector.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check the engine harness for a short circuit to ground.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the engine harness Inline B connector and engine block ground.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the engine harness Inline A connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short circuit to ground in the engine harness. Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D-2

Go to 4A

Guided Step 3D-2 - Check the extension harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel 72-pin connector.
  • Disconnect the extension harness from the engine harness at the inline B connector.

Action

Check the engine harness for a short circuit to ground.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and engine block ground.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

There is a short circuit to ground in the ECM harness in the generator control panel. Replace the damaged section of the harness.

Refer to the OEM Service Manual.

There is a short circuit to ground in the extension harness. Replace the damaged section of the harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 3E - Check the harnesses for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 60-pin connector.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check the ECM harness for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 1 pin at the ECM harness 60-pin connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3F

Go to 3E-1

Guided Step 3E-1 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness at the Inline B connector.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check the engine harness for a pin-to-pin short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the engine harness Inline B connector and all other pins in the connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the engine harness Inline A connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short circuit to ground in the engine harness. Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D-2

Go to 4A

Guided Step 3E-2 - Check the extension harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel EI2 72-pin connector.
  • Disconnect the extension harness from the engine harness at the inline B connector.

Action

Check the extension harness for a pin-to-pin short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and all other pins in the connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a pin-to-pin short circuit in the extension harness. Replace the damaged section of the harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 3F - Check for a short circuit to the OEM harness ECM battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 60-pin connector.
  • Disconnect the ECM harness connector from the ECM 1 4-pin power connector.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the ECM harness 60-pin connector and the battery voltage RETURN (ECM 1) pin in the ECM power connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the ECM harness 60-pin connector and the battery voltage RETURN (ECM 1) pin in the ECM power connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3F-1

Guided Step 3F-1 - Check for a short circuit to the engine harness battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check the engine harness for a pin-to-pin short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the engine harness Inline B connector and the battery voltage RETURN (ECM 1) pin in the engine harness inline C connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the engine harness Inline A connector and the battery voltage RETURN (ECM 1) pin in the engine harness inline C connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short circuit to ground in the engine harness. Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3F-2

Go to 4A

Guided Step 3F-2 - Check for a short circuit to the extension harness battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connectors from the generator control panel.
  • Disconnect the extension harness from the engine harness at the Inline B and Inline C connectors.

Action

Check for a short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and the battery voltage RETURN (ECM 1) pin in the extension harness 4-pin connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and the battery voltage RETURN (ECM 1) pin in the extension harness 4-pin connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

There is a short circuit in the ECM harness in the generator control panel. Replace the damaged section of the harness. Refer to the OEM Service Manual.

There is a short circuit in the extension harness.Replace the damaged section of the harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the engine controlmodule (ECM) and harnesses. |
 | STEP 2A. Inspect ECM 1 (CM850 ECM) and ECM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the extension harness and generator control panel connector pins. | Dirty or damaged pins?
 | STEP 2C. Inspect the engine harness and inline connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the harnesses for a pin-to-pin short circuit. | Dirty or damaged pins?
 | STEP 2D-1. Check the engine harness for a pin-to-pin short circuit. |
 | STEP 2D-2. Check the extension harness for a pin-to-pin short circuit. |
 | STEP 2E. Check for a short circuit to the ECM battery positive (+) circuit. | Greater than 100k ohms?
 | STEP 2E-1. Check for a short circuit in the engine harness battery positive (+) circuit. |
 | STEP 2E-2. Check for a short circuit to the engine harness battery positive (+) circuit. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harnesses.

Guided Step 2A - Inspect ECM 1 (CM850 ECM) and ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 60-pin connectos.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the ECM harness connector.

Clean the connector and pins.

Replace the connector or damaged section of the ECM harness.

Refer to Procedure 019-204 in Section 19.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the extension harness and generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 60-pin connectos.

Action

Inspect the extension harness and generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the extension harness connector.

Clean the connector and pins.

Replace the connector or damaged section of the extension harness

Refer to Procedure 019-213 in Section 19.

Refer to Procedure 019-175 in Section 19.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the engine harness and inline connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the extension harness connector.

Clean the connector and pins.

Replace the connector or damaged section of the extension harness

Refer to Procedure 019-208 in Section 19.

Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the harnesses for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM harness connector from the ECM 1 60-pin connector.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check the ECM harness for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 1 pin at the ECM harness 60-pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness at the inline B connector.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check the engine harness for a pin-to-pin short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the engine harness Inline B connector to all other pins in the connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the engine harness Inline A connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a pin-to-pin short circuit in the engine harness. Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 3A

Guided Step 2D-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness connector from the generator control panel 72-pin connector.
  • Disconnect the extension harness from the engine harness at the inline B connector.

Action

Check the extension harness for a pin-to-pin short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and all other pins in the connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

There is a pin-to-pin short circuit in the ECM harness in the generator control panel. Replace the damaged section of the harness. Refer to the OEM service manual.

There is a pin-to-pin short circuit in the extension harness. Replace the damaged section of the harness. Refer to Procedure 019-175 in Section 19.

Go to 3A

Go to 3A

Guided Step 2E - Check for a short circuit to the OEM harness ECM battery positive (+) circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM harness connector from the ECM 1 60-pin connector.
  • Disconnect the ECM harness connector from the ECM 1 4-pin power connector.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the ECM harness 60-pin connector and the battery voltage SUPPLY (ECM 1) pin in the ECM power connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the ECM harness 60-pin connector and the battery voltage SUPPLY (ECM 1) pin in the ECM power connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

For general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2E-1

Guided Step 2E-1 - Check for a short circuit to the engine harness battery positive (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the engine harness from the oil level sensor connector.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the engine harness inline B connector and the battery voltage SUPPLY (ECM 1) pin in the engine harness Inline C connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the engine harness Inline A connector and the battery voltage SUPPLY (ECM 1) pin in the engine harness Inline C connector.

Reference to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short circuit to ground in the engine harness. Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 2E-2

Go to 3A

Guided Step 2E-2 - Check for a short circuit to the engine harness battery positive (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connectors from the generator control panel.
  • Disconnect the extension harness from the engine harness at the Inline B and Inline C connectors.

Action

Check for a short circuit.

  • Measure the resistance between the oil level SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and the battery voltage SUPPLY (ECM 1) pin in the extension harness 4-pin connector.
  • Measure the resistance between the oil pressure SUPPLY (sensor supply 1) pin at the extension harness 72-pin connector and the battery voltage SUPPLY (ECM 1) pin in the extension harness 4-pin connector

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

There is a short circuit in the ECM harness in the generator control panel. Replace the damaged section of the harness. Refer to the OEM service manual.

There is a short circuit in the extension harness. Replace the damaged section of the harness. Refer to Procedure 019-175 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure sensor accuracy. |
 | STEP 1A. Verify oil pressure sensor accuracy with a mechanical gauge. | Does the mechanical gauge reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the oil pressure sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the oil pressure sensor accuracy.

Guided Step 1A - Verify the oil pressure sensor accuracy with a mechanical gauge.

Conditions

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Start the engine and compare the oil pressure reading on the electronic service tool monitor screen to the reading on the mechanical oil pressure gauge.

NOTE: The engine rpm will need to be increased to make it easier to see differences in the readings.

Does the mechanical gauge reading match the sensor reading?
YES NO

Replace the lubricating oil pressure regulator.

Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 007-029 in Section 7.

Go to Fault Code 141.

Go to 2A

Fault Code141

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the oil pressure sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the oil pressure sensor.

Fault simulation enabled?
YES NO

Disable fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the oil pressure sensor.

Fault threshold set correctly?
YES NO

Reference Section TS, symptom tree T105, Lubricating Oil Pressure Low, in the Troubleshooting and Repair Manual QSK78 Series Engines, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 415 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 421 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the oil temperature sensor.
  • Connect the electronic service tool to the vehicle data link.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the oil temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES NO
No Repair

Go to Fault Code 212

Go to 2A

sFault Code 212

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the oil temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the oil temperature sensor.

Fault simulation enabled?
YES NO

Disable fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the oil temperature sensor.

Fault threshold set correctly?
YES NO

Reference Section TS, symptom tree t107, Lubricating Oil Temperature Above Specification, in the Troubleshooting and Repair Manual QSK78 Series Engines, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 421 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to RepairComplete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 423 - Engine Fuel Timing Pressure or Timing Actuator Stuck - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing rail pressure sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for short circuit to engine block ground. | Greater than 100k ohms?
STEP 4. | Check for sensor accuracy. |
 | STEP 4A. Compare timing, rail, and ambient air pressure sensor readings. | Timing pressure equal to the rail pressure and half the ambient air pressure?
STEP 5. | Check for fuel drain line restriction. |
 | STEP 5A. Check for fuel drain line restriction. | Fuel drain line restriction less than the specification?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 423 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the timing rail pressure sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

 No Repair

Go to 6A

Go to 1B

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 2A

Go to 6A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the timing rail pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the timing rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to the timing rail pressure RETURN pin on the engine harness sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 6A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the timing rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to the timing rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the timing rail pressure RETURN pin on the extension harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for sensor accuracy.

Guided Step 4A - Compare timing, rail, and ambient air pressure sensor readings.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to measure timing, rail, and ambient air pressure.

  • The reading of the timing pressure should equal the reading of the rail pressure.
  • The reading of the timing pressure should be half of the ambient air pressure reading.

Timing pressure equal to the rail pressure and half the ambient air pressure?
YES NO
No Repair

Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for fuel drain line restriction.

Guided Step 5A - Check for fuel drain line restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the inlet restriction as follows:

  • Measure the drain line restriction and compare to specification. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction less than the specification?
YES NO
No Repair

  • Find the cause of the restriction and remove the restriction.
  • Inspect the drain lines and replace if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-013 in Section 6.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 423 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 426 - SAE J1939 Data Link Number 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - engine control module (ECM) Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SAE J1939 data link communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does the INSITE™ electronic service tool communicate with ECM 1 (CM850 ECM)?
 | STEP 1B. Inspect the ECM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ 5 data link adapter to the ECM 1 (CM850 ECM) SAE J1939 data link connector
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with ECM 1 (CM850 ECM).

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ 5 (J1939) ECM connection.

Does the INSITE™ electronic service tool communicate with ECM 1 (CM850 ECM)?

YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Reference the OEM service manual for information on troubleshooting the SAE J1939 data link network.

 No Repair

Reference the OEM service manual for information on troubleshooting and SAE J1939 data link network.

Go to 1B

Guided Step 1B - Inspect the ECM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM Harness from the ECM 1 (CM850 ECM) 60-pin connector.

Action

Inspect the ECM and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

  • Repair or replace the ECM harness connector pins. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the damaged section of the ECM harness. Refer to the OEM service manual.

Replace the ECM 1. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness from the ECM 1 (CM850 ECM) 60-pin connector
  • Connect the ECM bench calibration harness to the ECM 1 (CM850 ECM) 60-pin connector
  • Connect the INLINE™ 5 data link adapter
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM 1 (CM850 ECM).

  • Connect to ECM 1 (CM850 ECM) using the ECM Bench Top Calibration Harness, Part Number 3163151, and the ECM Bench Calibration Adapter Cable, Part Number 3164185.

Does INSITE™ electronic service tool communicate with the ECM 1 (CM850 ECM)?
YES NO

The INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Reference the OEM service manual for information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

Reference the OEM service manual

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TS.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that the Fault Code 426 is inactive.

Fault Code 426 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged battery cable connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC?
 | STEP 1C. Check the battery ground connection. | Less than 10 ohms?
 | STEP 1D. Check for an add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 2. | Check the Inline E Connector. |
 | STEP 2A. Inspect the OEM battery harness and the Inline E connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness fuse connection. | Fuse installed correctly?
 | STEP 3B. Check the engine harness fuse. | Fuse blown?
 | STEP 3C. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for:

  • Corrosion
  • Loose connection.

Damaged battery cable connections?
YES NO

  • Repair the damaged connections. Tighten the battery connections and clean the battery terminals. Refer to the OEM service manual.

No Repair

Go to 5A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.

17.3 to 34.7-VDC?
YES NO
No Repair

  • Charge or replace the battery. Refer to the OEM service manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the battery ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) battery terminal to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

  • Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check for an add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause supply wire to be shorted to the engine block.

Damaged wires?
YES NO

  • Repair the damaged wiring.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the Inline E Connector.

Guided Step 2A - Inspect the OEM battery harness and the Inline E connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM battery harness from the Inline E connector.

Action

Inspect the OEM battery harness and the Inline E connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the Inline E connector. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Repair the OEM battery harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Replace the OEM battery harness. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the OEM battery harness at the Inline E connector to the positive (+) battery terminal connector.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

  • Replace the OEM battery harness. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the Inline E connector to all other pins on the Inline E connector

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the OEM battery harness. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness fuse connection.

Conditions

  • Turn keyswitch OFF.

Action

Check if the 20-ampere fuse is installed correctly.

  • Check fuse for proper installation.

Fuse installed correctly?
YES NO
No Repair

  • Install fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine harness fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 20-ampere fuse from the OEM harness.

Action

Check if the 20-ampere fuse is blown.

  • Check fuse for proper installation.

Fuse blown?
YES NO

  • Install fuse correctly. Refer to Procedure 019-198 in Section 19.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the engine harness inline connector to the positive (+) battery terminal connector.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the engine harness inline connector to all other pins on the engine harness inline connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery power on the extension harness connector to the pins being supplied by unswitchable battery power at the extension harness inline connector.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the engine harness inline connector to all other pins on the engine harness inline connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate Troubleshooting Steps

Last Modified: 23-Jun-2012


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged battery cable connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC?
 | STEP 1C. Check the battery ground connection. | Less than 10 ohms?
 | STEP 1D. Check the alternator. | Alternator functioning normally?
 | STEP 1E. Check for an add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 2. | Check the Inline E Connector. |
 | STEP 2A. Inspect the OEM battery harness and the Inline E connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness fuse connection. | Fuse installed correctly?
 | STEP 3B. Check the engine harness fuse. | Fuse blown?
 | STEP 3C. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for:

  • Corrosion
  • Loose connection.

Damaged battery cable connections?
YES NO

  • Repair the damaged connections. Tighten the battery connections and clean the battery terminals. Refer to the OEM service manual.

No Repair

Go to 5A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.

17.3 to 34.7-VDC?
YES NO
No Repair

  • Charge or replace the battery. Refer to the OEM service manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the battery ground connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) battery terminal to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

  • Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator for normal operation.

  • Inspect the alternator for normal operation.

Alternator functioning normally?
YES NO
No Repair

  • Repair the alternator. Refer to the OEM service manual.

Go to 5A

Go to 1E

Guided Step 1E - Check for an add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause supply wire to be shorted to the engine block.

Damaged wires?
YES NO

  • Repair the damaged wiring.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the Inline E connector.

Guided Step 2A - Inspect the OEM battery harness and the Inline E connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM battery harness from the Inline E connector.

Action

Inspect the OEM battery harness and the Inline E connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the Inline E connector. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Repair the OEM battery harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Replace the OEM battery harness. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the OEM battery harness at the Inline E connector to the positive (+) battery terminal connector.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

  • Replace the OEM battery harness. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the Inline E connector to all other pins on the Inline E connector

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the OEM battery harness. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness fuse connection.

Conditions

  • Turn keyswitch OFF.

Action

Check if the 20-ampere fuse is installed correctly.

  • Check fuse for proper installation.

Fuse installed correctly?
YES NO
No Repair

  • Install fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine harness fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 20-ampere fuse from the OEM harness.

Action

Check if the 20-ampere fuse is blown.

  • Check fuse for proper installation.

Fuse blown?
YES NO

  • Install fuse correctly. Refer to Procedure 019-198 in Section 19.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the engine harness inline connector to the positive (+) battery terminal connector.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the engine harness inline connector to all other pinson the engine harness inline connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery power on the extension harness connector to the pins being supplied by unswitchable battery power at the extension harness inline connector.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the engine harness inline connector to all other pins on the engine harness inline connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate Troubleshooting Steps

Last Modified: 23-Jun-2012


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the fuel rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 Ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 451 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel rail pressure sensor.

Other fault codes active?
YES NO

  • Troubleshoot other fault codes first.

 No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel rail pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the fuel rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to the fuel rail pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to the fuel rail pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to the fuel rail pressure RETURN pin on the engine harness sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the engine harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the extension harness connector to the fuel rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to the fuel rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to the fuel rail pressure RETURN pin on the extension harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the engine harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 451 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the fuel rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 452 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel rail pressure sensor.

Other fault codes active?
YES NO

  • Troubleshoot other fault codes first.

 No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel rail pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the fuel rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to the fuel rail pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to the fuel rail pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to the fuel rail pressure RETURN pin on the engine harness sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the engine harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the extension harness connector to the fuel rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to the fuel rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to the fuel rail pressure RETURN pin on the extension harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the engine harness. Refer to Procedure 019-213 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 452 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 455 - Electronic Fuel Control Valve Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rail actuator. |
 | STEP 1A. Inspect the fuel rail actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the coil resistance of the fuel rail actuator. | 7.0 to 9.0 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 455 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel rail actuator.

Guided Step 1A - Inspect the fuel rail actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the timing rail actuator.

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Use the following procedures to repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the coil resistance of the fuel rail actuator.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check the coil resistance of the rail actuator.

  • Measure the coil resistance from the fuel rail SUPPLY pin to the fuel rail RETURN pin of the fuel rail actuator connector.

7.0 to 9.0 ohms?
YES NO
No Repair

Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedures to repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel rail actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel rail actuator.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the fuel rail actuator from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to the engine block ground.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the fuel rail actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to the fuel rail actuator SUPPLY pin.
  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to the fuel rail actuator RETURN pin.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Use the following procedures to repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to the engine block ground.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to the fuel rail actuator SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to the fuel rail actuator RETURN pin on the extension harness inline connector.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 455 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 467 - Engine Timing Rail Actuator Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the complaint. |
 | STEP 1A. Check for other fault codes. | Other fault codes active?
STEP 2. | Check the fuel system flow. |
 | STEP 2A. Check the fuel in the tank. | Fuel present in fuel tank?
 | STEP 2B. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 2D. Inspect the fuel system for leaks, broken lines, and loose fittings. | Are any leaks, broken lines, or loose fittings present in the fuel system?
 | STEP 2E. Check the fuel inlet restriction. | Is the fuel inlet restriction less than the specification?
 | STEP 2F. Check for air in the fuel. | Air leaks present?
 | STEP 2G. Check the fuel pump output pressure. | Is the fuel pump output pressure less than the specification?
 | STEP 2H. Inspect the fuel pump actuator screen for debris. | Debris present in the screen?
 | STEP 2I. Inspect the fuel pump actuator for corrosion. | Corrosion present on the actuator?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 467 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the complaint.

Guided Step 1A - Check for other fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes besides Fault Code 467.

  • Use INSITE™ electronic service tool to read the fault codes.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the fuel system flow.

Guided Step 2A - Check the fuel in the tank.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank for the following:

  • Fuel in the tank.

Fuel present in fuel tank?
YES NO
No Repair

Fill the tank with fuel.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedures to repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Use the following procedures to repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings
  • Use the following procedure for information for the fuel flow in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 200-001 in Section F.

Are any leaks, broken lines, or loose fittings present in the fuel system?
YES NO

Repair the leak.

  • Tighten or replace the leaking fitting or fuel line.
  • Replace the fuel line. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727 Refer to Procedure 006-024 in Section 6.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the inlet restriction as follows:

  • Measure the inlet restriction and compare to specification. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-020 in Section 6.

Is the fuel inlet restriction less than the specification?
YES NO
No Repair

Find the cause of the restriction and remove the restriction.

  • Check for debris in the fuel tank, clogged fuel tank vents, or faulty check valves.
  • Change the fuel filters. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-015 in Section 6.
  • Inspect the fuel lines. Replace if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 2F

Go to 3A

Guided Step 2F - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-003 in Section 6.

Air leaks present?
YES NO

Find the cause of the air leak.

  • Check the OEM fuel lines and the fuel tank drop tube for air leaks. Refer to the OEM service manual.
  • Check for damaged or missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.
  • Inspect the fuel lines and replace, if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 3A

Go to 2G

Guided Step 2G - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the check fitting. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Is the fuel pump output pressure less than the specification?
YES NO

  • Replace the fuel pump. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

 No Repair

Go to 3A

Go to 2H

Guided Step 2H - Inspect the fuel pump actuator screen for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump actuator screen for debris.

  • Remove the timing actuators. Refer to Procedure 019-111 in Section 19.

Debris present in the screen?
YES NO

  • Replace the timing actuators. Refer to Procedure 019-111 in Section 19.

 No Repair

Go to 3A

Go to 2I

Guided Step 2I - Inspect the fuel pump actuator for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump actuator for corrosion on surfaces that come in contact with fuel.

  • Remove the timing actuators. Refer to Procedure 019-111 in Section 19.

Corrosion present on the actuator?
YES NO

  • Replace the timing actuators. Refer to Procedure 019-111 in Section 19.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 467 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 468 - Fuel Rail Actuator Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rail actuator. |
 | STEP 1A. Inspect the fuel rail actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the coil resistance of the fuel rail actuator. | 7.0 to 9.0 ohms?
 | STEP 1C. Check for a short circuit from supply to ground. | Greater than 100k ohms?
STEP 2. | Check the fuel system flow. |
 | STEP 2A. Check the fuel level in the tank. | Fuel present in fuel tank?
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | Are any leaks, broken lines, or loose fittings present in the fuel system?
 | STEP 2C. Check the fuel inlet restriction. | Is the fuel inlet restriction less than the specification?
 | STEP 2D. Check for air in the fuel. | Air leaks present?
 | STEP 2E. Inspect the fuel shutoff valve solenoid for excessive wear. | Signs of excessive wear on the fuel shutoff valve solenoid?
 | STEP 2F. Check the fuel pump output pressure. | Is the fuel pump output pressure less than the specification?
 | STEP 2G. Inspect the fuel rail actuator screen for debris. | Debris present in the screen?
 | STEP 2H. Inspect the fuel rail actuator for corrosion. | Corrosion present on the actuator?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 468 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel rail actuator.

Guided Step 1A - Inspect the fuel rail actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the timing rail actuator.

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Use the following procedures to repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the coil resistance of the fuel rail actuator.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check the coil resistance of the rail actuator.

  • Measure the coil resistance from the fuel rail SUPPLY pin to the fuel rail RETURN pin of the fuel rail actuator connector.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

7.0 to 9.0 ohms?
YES NO
No Repair

  • Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the coil resistance of the fuel rail actuator.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check for a short circuit from supply to ground.

  • Measure the resistance from the fuel rail SUPPLY pin to the engine block ground.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system flow.

Guided Step 2A - Check the fuel level in the tank.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank for the following:

  • Fuel in the tank.

Fuel present in fuel tank?
YES NO
No Repair

Fill the tank with fuel.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings
  • Use the following procedure for information for the fuel flow in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 200-001 in Section F.

Are any leaks, broken lines, or loose fittings present in the fuel system?
YES NO

  • Repair the leak. Tighten or replace the leaking fitting or fuel line.
  • Replace the fuel line. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727 Refer to Procedure 006-024 in Section 6.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the inlet restriction as follows:

  • Measure the inlet restriction and compare to specification. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-020 in Section 6.

Is the fuel inlet restriction less than the specification?
YES NO
No Repair

Find the cause of the restriction and remove the restriction.

  • Check for debris in the fuel tank, clogged fuel tank vents, or faulty check valves.
  • Change the fuel filters. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-015 in Section 6.
  • Inspect the fuel lines. Replace if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 2D

Go to 3A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-003 in Section 6.

Air leaks present?
YES NO

Find the cause of the air leak.

  • Check the OEM fuel lines and the fuel tank drop tube for air leaks. Refer to the OEM service manual.
  • Check for damaged or missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.
  • Inspect the fuel lines and replace, if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 3A

Go to 2E

Guided Step 2E - Inspect the fuel shutoff valve solenoid for excessive wear.

Conditions

  • Turn keyswitch ON.

Action

Inspect the fuel shutoff valve solenoid for excessive wear.

  • Remove the fuel shutoff solenoid and inspect the spacer for excessive wear. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Signs of excessive wear on the fuel shutoff valve solenoid?
YES NO

  • Repair or replace the fuel shutoff valve. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

No Repair

Go to 3A

Go to 2F

Guided Step 2F - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the check fitting. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Is the fuel pump output pressure less than the specification?
YES NO

  • Replace the fuel pump. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

 No Repair

Go to 3A

Go to 2G

Guided Step 2G - Inspect the fuel rail actuator screen for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel rail actuator screen for debris.

  • Remove the fuel rail actuators. Refer to Procedure 019-110 in Section 19.

Debris present in the screen?
YES NO

  • Replace the timing actuators. Refer to Procedure 019-110 in Section 19.

 No Repair

Go to 3A

Go to 2H

Guided Step 2H - Inspect the fuel rail actuator for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel rail actuator for corrosion on surfaces that come in contact with fuel.

  • Remove the fuel rail actuators. Refer to Procedure 019-110 in Section 19.

Corrosion present on the actuator?
YES NO

  • Replace the timing actuators. Refer to Procedure 019-110 in Section 19.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 468 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Aug-2011


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the intake manifold temperature sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 488 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the intake manifold temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the intake manifold temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES NO
No Repair

  • Go to Fault Code 153.

Go to 2A

Fault Code 153

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the intake manifold temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the Fault Simulation is not enabled for the intake manifold temperature sensor.

Fault simulation enabled?
YES NO

  • Disable the fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the intake manifold temperature sensor.

Fault threshold set correctly?
YES NO

  • Use the following troubleshooting symptom tree t096, Intake Manifold Air Temperature Above Specifications in Section TS of the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

  • Determine the mean operating condition before adjusting the threshold.
  • Reset the threshold to the lowest allowable setting.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 488 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate Troubleshooting Steps

Last Modified: 23-Jun-2012


Fault Code 514 - Electronic Fuel Control Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and engine operating status. |
 | STEP 1A. Check for an active fault code. | Fault Code 514 active?
 | STEP 1B. Check for engine surges. | Does the engine speed surge?
 | STEP 1C. Engine shuts down when Fault Code 514 becomes active. | Does the engine shut down when Fault Code 514 becomes active?
 | STEP 1D. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 1E. Inspect the extension harness connector pins at the generator control panel. | Dirty or damaged pins?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check the fuel tank level. | Fuel present in tank
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | Are any leaks, broken lines, or loose fittings present in the fuel system?
 | STEP 2C. Check the fuel inlet restriction. | Is the fuel inlet restriction less than the specification?
 | STEP 2D. Check for air in the fuel. | Air leaks present?
 | STEP 2E. Inspect the fuel shutoff valve solenoid for excessive wear. | Signs of excessive wear on the fuel shutoff valve solenoid?
 | STEP 2F. Check the fuel pump output pressure. | Is the fuel pump output pressure less than the specification?
 | STEP 2G. Check the injector o-rings. | Is the drain output from one bank within 25 mL [0.85 oz] of the drain output from the other bank?
 | STEP 2H. Inspect the fuel rail actuator screen for debris. | Debris present in the screen?
 | STEP 2I. Inspect the fuel rail actuator for corrosion. | Corrosion present on the actuator?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 514 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes and engine operating status.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 514 active?
YES | NO
No Repair | No Repair

Go to 1B

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for engine surges.

Conditions

  • Turn keyswitch ON.

Action

Engine speed surges.

  • Observe engine surge.

Does the engine speed surge?
YES NO

Reference the Engine Speed Surges at Low or High Idle Symptom Tree or the Engine Speed Surges Under Load or in Operating Range Symptom Tree. Complete the tree that best describes the conditions when the surge occurs.

No Repair

Appropriate Symptom Tree

Go to 1C

Guided Step 1C - Engine shuts down when Fault Code 514 becomes active.

Conditions

  • Turn keyswitch ON.

Action

Engine shuts down when Fault Code 514 becomes active.

  • Observe when Fault Code 514 becomes active.

Does the engine shut down when Fault Code 514 becomes active?
YES NO
No Repair

  • Check the fuel shutoff circuit.
  • Check for active counts of Fault Code 254.
  • Check for an intermittent open circuit in the harness.

Go to 1D

Fault Code 254

Guided Step 1D - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

 No Repair

Go to 3A

Go to 1E

Guided Step 1E - Inspect the extension harness connector pins at the generator control panel.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Repair or replace the generator control panel connectors. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the fuel system flow.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank level for the following:

  • Fuel in the tank.

Fuel present in fuel tank?
YES NO
No Repair

Fill the tank with fuel.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.

Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727, for information on the fuel system flow. Refer to Procedure 200-001 in Section F.

Are any leaks, broken lines, or loose fittings present in the fuel system?
YES NO

Repair the leak. Tighten or replace the leaking fitting or fuel line.

  • Replace the fuel line. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the inlet restriction as follows:

  • Measure the inlet restriction and compare to specification. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-020 in Section 6.

Is the fuel inlet restriction less than the specification?
YES NO
No Repair

  • Find the cause of the restriction and remove the restriction. Check for debris in the fuel tank, fuel tank vents clogged or faulty check valves.
  • Change the fuel filters. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-015 in Section 6.
  • Inspect the fuel lines and replace if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 2D

Go to 3A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-003 in Section 6.

Air leaks present?
YES NO
No Repair

  • Find the cause of the air leak. Check the OEM fuel lines and the fuel tank drop tube for air leaks. Refer to the OEM service manual.
  • Check for damaged or missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.
  • Inspect the fuel lines and replace if necessary. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-024 in Section 6.

Go to 3A

Go to 2E

Guided Step 2E - Inspect the fuel shutoff valve solenoid for excessive wear.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel shutoff valve solenoid for excessive wear.

  • Remove the fuel shutoff solenoid and inspect the spacer for excessive wear. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

Signs of excessive wear on the fuel shutoff valve solenoid?
YES NO

  • Repair or replace the fuel shutoff valve. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-043 in Section 5.

No Repair

Go to 3A

Go to 2F

Guided Step 2F - Check the fuel pump output pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the check fitting. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

Is the fuel pump output pressure less than the specification?
YES | NO
No Repair | No Repair

Go to 2G

Go to 2H

Guided Step 2G - Check the injector o-rings.

Conditions

  • Turn keyswitch ON.

Action

Check the injector o-rings. The o-rings can be checked by observing the drain output of each bank.

  • Disconnect the drain lines for each bank at the T-junction.
  • Place the drain lines for each bank into separate graduated cylinders with a capacity of at least 500 mL [17 oz].
  • Run the engine at rated speed for 1 minute to determine if output is equal from each bank.

Is the drain output from one bank within 25 mL [0.85 oz] of the drain output from the other bank?
YES NO

  • Replace the fuel pump. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 005-016 in Section 5.

  • Replace the injector o-rings on the malfunctioning bank. Use the following procedure in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 006-026 in Section 6.

Go to 3A

Go to 3A

Guided Step 2H - Inspect the fuel rail actuator screen for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel rail actuator screen for debris.

  • Remove the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Debris present in the screen?
YES NO

Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

 No Repair

Go to 3A

Go to 2I

Guided Step 2I - Inspect the fuel rail actuator for corrosion.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel rail actuator for corrosionon surfaces that come in contact with fuel.

  • Remove the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Corrosion present on the actuator?
YES NO

Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 514 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to RepairComplete

Appropriate Troubleshooting Steps

Last Modified: 23-Jun-2012


Fault Code 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Fault Code 514. |
 | STEP 1A. Check for active or inactive counts of Fault Code 514. | Is Fault Code 514 active or inactive?
 | STEP 1B. Check for shutdown when Fault Code 514 is active. | Does the engine shut down when Fault Code 514 is active?
STEP 2. | Check the rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel rail pressure sensor accuracy. | 0.40 to 0.61-VDC?
STEP 3. | Check ECM 2 (CM500) |
 | STEP 3A. Disconnect the power from the ECM and then connect power and run the engine. | Fault Code 553 active?
 | STEP 3B. Calibrate ECM 2 (CM500) and run the engine. | Fault Code 553 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 553 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for Fault Code 514.

Guided Step 1A - Check for active or inactive counts of Fault Code 514.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool toread the fault codes.

Is Fault Code 514 active or inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for shutdown when Fault Code 514 is active.

Conditions

  • Turn keyswitch ON

Action

Check for shutdown when Fault Code 514 is active.

  • Verify that the engine shuts down when Fault Code 514 is active.

Does the engine shut down when Fault Code 514 is active?
YES NO
No Repair

Troubleshoot Fault Code 514 first.

Go to 2A

Fault Code 514

Guided Step 2 - Check the rail pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-219 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel rail pressure sensor accuracy.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel rail pressure sensor from the engine harness
  • Install the pressure sensor breakout cable, Part Number 3824774, between the sensor and the engine harness connector
  • Turn keyswitch ON.

Action

Check the fuel rail pressure sensor accuracy.

  • Measure the signal voltage by connecting the breakout cable's SIGNAL (pin C) and RETURN (pin B) connectors into the multimeter.

0.40 to 0.61-VDC?
YES NO
No Repair

  • Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check ECM 2 (CM500)

Guided Step 3A - Disconnect the power from the ECM and then connect power and run the engine.

Conditions

  • Turn keyswitch OFF.

Action

Disconnect power from ECM 2 (CM500) and then connect power and run the engine.

  • Turn keyswitch OFF
  • Disconnect the power to ECM 2 (CM500) at the battery
  • Wait 1 minute
  • Connect the power to ECM 2 (CM500) at the battery
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Start the engine and let it idle for at least 1 minute
  • Run engine throughout speed and power range to verify that Fault Code 553 stays inactive.

Fault Code 553 active?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Calibrate ECM 2 (CM500) and run the engine.

Conditions

  • Turn keyswitch ON.

Action

Calibrate ECM 2 (CM500) and operate the engine.

  • Calibrate ECM 2 (CM500)
  • Start the engine and let it idle for at least 1 minute
  • Run engine throughout speed and power range to verify that Fault Code 553 stays inactive.

Fault Code 553 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 553 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the blowby pressure sensor accuracy. |
 | STEP 1A. Verify blowby pressure sensor accuracy with a mechanical gauge. | Does the mechanical gauge reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the Fault Simulation feature for the blowby pressure sensor is not enabled. | Fault Simulation enabled?
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 556 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the blowby pressure sensor accuracy.

Guided Step 1A - Verify blowby pressure sensor accuracy with a mechanical gauge.

Conditions

  • Connect a water manometer gauge to the engine.
  • Connect INSITE™ electronic service tool and service harness to the data link connector on the engine harness.
  • Turn keyswitch OFF.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Operate the engine at rated rpm and at full load (wide-open throttle) until a steady reading is obtained.

Does the mechanical gauge reading match the sensor reading?
YES NO
No Repair

Reference Fault Code 719.

  • Check the crankcase breathers. Reference the following procedure in the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727. Refer to Procedure 003-001 in Section 3.

Go to 2A

Fault Code 719

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the Fault Simulation feature for the blowby pressure sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the blowby pressure sensor.

Fault Simulation enabled?
YES NO

Disable the Fault Simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that Fault Threshold is not within the normal operating range for the blowby pressure sensor.

Fault threshold set correctly?
YES NO

Reference Troubleshooting Symptom t027 in Section TS of the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 556 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine conttol module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 1C. Check for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the extension harness. |
 | STEP 2A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the crankshaft engine speed sensor. |
 | STEP 3A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the signal from the sensor. | Signal present?
 | STEP 3C. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Use electrical contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the engine harness inline connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the engine harness inline connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the engine harness inline connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the extension harness.

Guided Step 2A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness connector from the generator control panel.

Action

Inspect the extension harness and generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Use electrical contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the extension harness connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the engine harness.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the extension harness connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the extension harness connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins on the extension harness connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins on the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins on the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins on the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the crankshaft engine speed sensor.

Guided Step 3A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Use electrical contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the signal from the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Check the sensor signal voltage:

  • While barring the engine over, use the sensor breakout cable to measure the voltage from the SIGNAL pin to the RETURN pin. The signal must change from +4.0 through 5.0-VDC to +0.5 through 2.3-VDC and back, about every 60 degrees of crankshaft rotation.

Signal present?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check the supply voltage.

  • Measure the voltage from the crankshaft engine speed sensor SUPPLY pin to the crankshaft engine speed sensor RETURN pin on the harness side of the crankshaft engine speed sensor connector.

4.75 to 5.25 VDC?
YES NO
No Repair

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-038 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 719 - Extended Crankcase Blow-by Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control mdoule (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the blowby pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 719 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the blowby pressure sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the blowby pressure sensor.

Guided Step 2A - Inspect the sensor and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the blowby pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Use electrical contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the blowby pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable SUPPLY (pin A) and RETURN (pin B) connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the blowby pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the blowby pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable SIGNAL (pin C) and RETURN (pin B) connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Use electrical contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the blowby pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the blowby pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the sensor harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the blowby pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to the blowby pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to the blowby pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the blowby pressure RETURN pin on the engine harness inline connector to the blowby pressure RETURN pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Use electrical contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the blowby pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to the blowby pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to the blowby pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the blowby pressure RETURN pin on the extension harness connector to the blowby pressure RETURN pin on the extension harness inline connector.

Less than 10 ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 719 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 729 - Extended Crankcase Blow-by Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the blowby pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the generator control panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 729 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the blowby pressure sensor.

Other fault codes active?
YES NO

Troubleshoot other fault codes first.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the blowby pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Use electrical contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the blowby pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable SUPPLY (pin A) and RETURN (pin B) connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the blowby pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable SIGNAL (pin C) and RETURN (pin B) connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Use electrical contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the blowby pressure sensor.

Action

Check for an open circuit in the SIGNAL and SUPPLY wires.

  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to the blowby pressure SIGNAL pin on the sensor harness connector.
  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to the blowby pressure SUPPLY pin on the sensor harness connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the blowby pressure RETURN pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the blowby pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the blowby pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the extension harness from the generator control panel.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the SIGNAL and SUPPLY wires.

  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to the blowby pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to the blowby pressure SUPPLY pin on the extension harness inline connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the blowby pressure RETURN pin on the extension harness connector to engine block ground.
  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the blowby pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 729 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 1117 - Power Supply Lost With Keyswitch ON - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gasses. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery 1 voltage. | Battery 1 voltage acceptable in normal and cranking conditions?
 | STEP 1C. Check the resistance of the OEM power harness and engine harness. | Less than 10 ohms?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness and engine harness. |
 | STEP 3A. Inspect the 4-pin power connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuits. | 21 to 27-VDC (24-VDC system)?
 | STEP 3C. Check battery supply for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the add-on or accessory wiring at the positive (+) battery terminal. | Damaged wires?
 | STEP 3E. Check the keyswitch input-to-ECM wire. | Keyswitch wire uninterrupted?
 | STEP 3F. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1117 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals.

  • Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery 1 voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery 1 voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Normal conditions:

  • At least 24-VDC (+24-VDC systems).

During Cranking:

  • At least 12-VDC (+24-VDC systems).

Battery 1 voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery.

  • Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance of the OEM power harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM1 (CM850) connector.
  • Disconnect the positive terminal connector from the battery connector.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the battery voltage SUPPLY pin in the ECM connector and the positive (+) battery connector.
  • Measure the resistance between the battery voltage RETURN pin in the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuse is installed correctly.

  • Inspect the 20-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

  • Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 20-ampere fuse to see if it has blown.

Fuse blown?
YES NO

Replace the fuse.

  • Refer to Procedure 019-198 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM1 (CM850) connector.

Action

Inspect the harness and the ECM1 (CM850) connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM1 (CM850) connector.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery voltage SUPPLY pin in the 4-pin power connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

21 to 27-VDC (24-VDC system)?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check battery supply for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM1 (CM850) connector.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from battery voltage SUPPLY pin in the 4-pin power connector to all other pins in the connector.
  • Measure the resistance from a battery voltage RETURN pin in the 4-pin power connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the add-on or accessory wiring at the positive (+) battery terminal.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) battery terminal.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input-to-ECM wire.

  • Inspect the keyswitch wire from the ignition post in the ignition assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 3F

Go to 4A

Guided Step 3F - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the ignition post in the ignition assembly to ignition input SUPPLY pin of the 50-pin engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1117 is inactive.

Fault Code 1117 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Jun-2012


FAULT CODE 1357 - Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check all fault codes. |
 | STEP 1A. Check for Fault Code 1357. | Active or inactive counts of Fault Code 1357?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1357 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check all the fault codes.

Guided Step 1A - Check for Fault Code 1357.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1357?
YES NO

Fill engine oil level remote reservoir to appropriate level.

 No Repair

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1357 is inactive.

Fault Code 1357 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Apr-2011


FAULT CODE 1411 - Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the frequency adjust potentiometer. |
 | STEP 1A. Inspect the frequency adjust potentiometer assembly for damage to pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 5k ohms?
 | STEP 1C. Check the resistance range of the frequency adjust potentiometer. | Resistance varies?
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1411 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the frequency adjust potentiometer.

Guided Step 1A - Inspect the frequency adjust potentiometer assembly for damage to pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the potentiometer and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the potentiometer. Reference the OEM service manual.
  • Repair or replace the generator interface harness. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the potentiometer from the harness.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins.

Less than 5k ohms?
YES NO
No Repair

Replace the potentiometer. Reference the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the resistance range of the frequency adjust potentiometer.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the potentiometer from the harness.
  • Adjust the potentiometer throughout its entire range.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins through the full range.

Resistance varies?
YES NO
No Repair

Replace the potentiometer. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator interface harness.

Guided Step 2A - Inspect the generator interface harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness from the ECM.

Action

Inspect the potentiometer and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the generator interface harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness fromt the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the frequency adjust potentiometer SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the droop/frequency RETURN pin at the generator interface harness connector to all other pins in the generator interface harness.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator interface harness. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness from the ECM.
  • Disconnect the bulb from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the frequency adjust potentiometer SUPPLY pin at the generator interface harness connector to the frequency adjust potentiometer SUPPLY pin at the potentiometer connection.
  • Measure the resistance from the droop/frequency RETURN pin at the generator interface harness connector to the droop/frequency RETURN pin at the potentiometer connection.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator interface harness. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Place idle/rated switch in the IDLE position.
  • Operate engine at idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1411 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 1412 - Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the droop adjust potentiometer. |
 | STEP 1A. Inspect the droop adjust potentiometer assembly for damage to pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 5k ohms?
 | STEP 1C. Check the resistance range of the droop adjust potentiometer. | Resistance varies?
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1412 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the droop adjust potentiometer.

Guided Step 1A - Inspect the droop adjust potentiometer assembly for damage to pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the potentiometer and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the potentiometer. Refer to the OEM service manual.
  • Repair or replace the generator interface harness. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the potentiometer from the harness.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins through the full range.

Less than 5k ohms?
YES NO
No Repair

Replace the potentiometer. Refer to the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the resistance range of the droop adjust potentiometer.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the potentiometer from the harness.
  • Adjust the potentiometer throughout its entire range.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins.

Resistance varies?
YES NO
No Repair

Replace the potentiometer. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator interface harness.

Guided Step 2A - Inspect the generator interface harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness from the ECM.

Action

Inspect the potentiometer and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the generator interface harness. Refer to the OEM service manual.
  • eplace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the droop adjust potentiometer SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the droop/frequency RETURN pin at the generator interface harness connector to all other pins in the generator interface harness.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator interface harness. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness from the ECM.
  • Disconnect the bulb from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the droop adjust potentiometer SUPPLY pin at the generator interface harness connector to the droop adjust potentiometer pin at the potentiometer connection.
  • Measure the resistance from the droop adjust potentiometer RETURN pin at the generator interface harness connector to the droop adjust potentiometer pin at the potentiometer connection.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator interface harness. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Place idle/rated switch in the IDLE position.
  • Operat engine at idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1412 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 1418 - Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number- 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the gain adjust potentiometer. |
 | STEP 1A. Inspect the gain adjust potentiometer assembly for damaged pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 5k ohms?
 | STEP 1C. Check the resistance range of the gain adjust potentiometer. | Resistance varies?
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1418 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the gain adjust potentiometer.

Guided Step 1A - Inspect the gain adjust potentiometer assembly for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the governor gain adjust potentiometer.

Action

Inspect the harness and the potentiometer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the potentiometer. Refer to the OEM manual.
  • Repair or replace the generator interface harness. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the potentiometer from the harness.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins.

Less than 5k ohms?
YES NO
No Repair

Replace the potentiometer. Refer to the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the resistance range of the gain adjust potentiometer.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the potentiometer from the harness.
  • Adjust the potentiometer throughout its entire range.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins through the full range.

Resistance varies?
YES NO
No Repair

Replace the potentiometer. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 3 - Check the generator interface harness.

Guided Step 2A - Inspect the generator interface harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness from the ECM.

Action

Inspect the potentiometer and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the generator interface harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the governor gain adjust SIGNAL pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the governor gain adjust RETURN pin at the generator interface harness connector to all other pins in the generator interface harness.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator interface harness. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator interface harness from the ECM.
  • Disconnect the bulb from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the governor gain adjust SIGNAL pin at the generator interface harness connector to the SIGNAL pin at the potentiometer connection.
  • Measure the resistance from the governor gain adjust RETURN pin at the generator interface harness connector to the RETURN pin at the potentiometer connection.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator interface harness. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Place idle/rated switch in the IDLE position.
  • Operate engine at idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1418 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 1427 - Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1427 inactive?
STEP 2. | Check the engine harness and OEM harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1427 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1427 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine control module (ECM) connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-175 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector overspeed shutdown SIGNAL pin and the OEM harness connector overspeed shutdown SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open overspeed shutdown signal circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the overspeed shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin inspection. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO

No repair

A pin-to-pin short circuit on the overspeed shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin to short ground

  • Measure the resistance and check for a short circuit between the overspeed shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin inspection. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or lamp has been detected. Refer to the OEM service manual.

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1427 inactive?
YES NO

No repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 1517 - At Least One Module Has a Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM) for fault codes. |
 | STEP 1A. Check ECM 1 for Fault Code 1517. | Fault Code 1517 active?
 | STEP 1B. Check ECM 2 for Most Severe fault code(s). | Most Severe fault code(s) active in ECM 2?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1517 inactive?
 | STEP 2B. Clear the fault code. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes.

Guided Step 1A - Check ECM 1 for Fault Code 1517.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to ECM 1 (CM850).

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1517 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check ECM 2 for Most Severe fault code(s).

Conditions

  • Conect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to ECM 2 (CM500).

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Most Severe fault code(s) active in ECM 2?
YES NO

Go to the corresponding fault code troubleshooting steps.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1517 inactive?
YES NO

No repair.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 1518 - At Least One Module Has a Moderately Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM) for fault codes. |
 | STEP 1A. Check ECM 1 for Fault Code 1518. | Fault Code 1518 active?
 | STEP 1B. Check ECM 2 for Moderately Severe fault code(s). | Moderately Severe fault code(s) active in ECM 2?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1518 inactive?
 | STEP 2B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes

Guided Step 1A - Check ECM 1 for Fault Code 1518.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to ECM 1 (CM850).

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1518 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check ECM 2 for Moderately Severe fault code(s).

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to ECM 2 (CM500).

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Moderately Severe fault code(s) active in ECM 2?
YES NO

Go to the corresponding fault code troubleshooting steps.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1518 inactive?
YES NO

No repair.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 1519 - At Least One Module Has a Least Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for fault codes |
 | STEP 1A. Check ECM 1 for Fault Code 1519. | Fault Code 1519 active?
 | STEP 1B. Check ECM 2 for Least Severe fault code(s). | Least Severe fault code(s) active in ECM 2?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1519 inactive?
 | STEP 2B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes

Guided Step 1A - Check ECM 1 for Fault Code 1519.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to ECM 1 (CM850).

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1519 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check ECM 2 for Least Severe fault code(s).

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to ECM 2 (CM500).

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Least Severe fault code(s) active in ECM 2?
YES NO

Go to corresponding appropriate fault code troubleshooting steps

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1519 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if alls steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Apr-2011


FAULT CODE 1597 - Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check ECM1 (CM850 ECM) for response. |
 | STEP 1A. Check ECM1 (CM850 ECM) for response. | Fault Code 1597 active?
 | STEP 1B. Check the inactive counts of Fault Code 1597 | Are there fewer than 3 counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code | Fault Code 1597 inactive?
 | STEP 2B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check ECM1 (CM850 ECM) for response.

Guided Step 1A - Check ECM1 (CM850 ECM) for response.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check ECM1 (CM850 ECM) for response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1597 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 1597.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 1597.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 1597.

Are there fewer than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1597 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1847. | Active or inactive counts of Fault Code 1847?
 | STEP 1B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1847.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1847.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1847?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom trees in Section TS of the QSK78 Series Engines Troubleshooting and Repair Manual, Bulletin 3666727.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 1B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Apr-2011


FAULT CODE 1891 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1891. | Fault Code 1891 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1891 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1891.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1891.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1891 active?
YES NO

Troubleshoot any additional fault codes. If necessary change the engine oil.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to reset the Centinel™ Missed Pulse Counts monitor.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1891 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-May-2011


FAULT CODE 1978 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor supply Fault Code 2185 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1979 active and Fault Code 1978 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1978 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1978 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool, to read the fault codes.

Sensor supply Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to Fault Code 2185 troubleshooting steps.

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch ON
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active and Fault Code 1978 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 1) pin and the generator speed/load governing bias RETURN (sensor return 1) pin at the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness connector to the OEM 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active?
YES NO

A damaged generator set has been detected. Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM 50-pin connector
  • Disconnect the engine harness from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damagedconnection has been detected in the ECM connector, OEM harness, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias RETURN (sensor return 1) pin and the OEM harness connector generator speed/load governing bias RETURN (sensor return 1) pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias RETURN (sensor return 1) circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted supply circuit.

Repair or replace the OEM harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Nov-2016


FAULT CODE 1979 - Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 2186 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1978 active and Fault Code 1979 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1979 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect engine control module (ECM), OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1979 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1979 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to tool read the fault codes.

Sensor supply Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to Fault Code 2186 troubleshooting steps.

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 1) pin and the generator speed/load governing bias RETURN (sensor return 1) pin at the OEM harness connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 1) pin and the generator speed/load governing bias SIGNAL pin at the OEM 31-pin connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active and Fault Code 1979 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness connector to the OEM 31-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active?
YES NO

A damaged generator set side has been detected. Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector and 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias SIGNAL pin and the OEM 31-pin connector generator speed/load governing bias SIGNAL pin.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

Replace the OEM service manual. Refer to Procedure 019-071 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM 60-pin connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 inactive?
YES NO

The removal and reinstallation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 15 percent of rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine crankshaft speed/position sensor reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Troubleshoot Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

Reference the appropriate circuit or wiring diagram for all engine harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

  • Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine to check if the overspeed condition is still present.

  • Test the engine to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 2111 - Coolant Temperature 2 (LT) Sensor Circuit - Voltage Above Normal or Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftercooler water inlet temperature sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the sensor. | Between 600 ohms and 36k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2111 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the aftercooler water inlet temperature sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check the resistance of the aftercooler water inlet temperature sensor.

  • Measure the resistance between the aftercooler water inlet temperature SIGNAL pin and the aftercooler water inlet temperature RETURN pin.

Between 600 and 36k ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-208 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Connect the engine harness to the aftercooler water inlet temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the engine harness in-line connector to the aftercooler water inlet temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the engine harness in-line connector to the aftercooler water inlet temperature SIGNAL pin at the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the aftercooler water inlet temperature sensor.

Action

Check for a pin-to-pin short circuit

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin on the engine harness in-line connector to all other pins in the engine harness in-line connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin on the extension harness connector to the aftercooler water inlet temperature SIGNAL pin on the extension harness in-line connector.
  • Measure the resistance from the aftercooler water inlet temperature RETURN pin on the extension harness connector to the aftercooler water inlet temperature RETURN pin on the extension harness in-line connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2111 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 2112 - Coolant Temperature 2 (LT) Sensor Circuit - Voltage Below Normal or Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftercooler water inlet temperature sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the sensor. | Between 600 ohms and 36k ohms?
 | STEP 1C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2112 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the aftercooler water inlet temperature sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check the resistance of the aftercooler water inlet temperature sensor.

  • Measure the resistance between the aftercooler water inlet temperature SIGNAL pin and the aftercooler water inlet temperature RETURN pin.

Between 600 and 36k ohms?
YES NO
No Repair

Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the aftercooler water inlet temperature sensor connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-208 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the engine harness in-line connector to the engine block ground.
  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the engine harness in-line connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the aftercooler water inlet temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the engine harness in-line connector to the aftercooler water inlet temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the engine harness in-line connector to the aftercooler water inlet temperature SIGNAL pin at the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor
  • Disconnect the engine harness from all sensor that have a shared supply or return with the aftercooler water inlet temperature sensor.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness in-line connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness in-line connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and generator control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the extension harness from the generator control panel.

Action

Inspect the extension harness and the generator control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the extension harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin on the extension harness connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for an open circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the extension harness connector to the aftercooler water inlet temperature RETURN pin at the extension harness in-line connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the extension harness connector to the aftercooler water inlet temperature SIGNAL pin at the extension harness in-line connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the extension harness
  • Disconnect the extension harness from the generator control panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2112 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Nov-2016


FAULT CODE 2113 - Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct?
STEP 2. | Check the engine contol module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the aftercooler water inlet temperature sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Verify that the threshold for the fault is set correctly. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2113 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the aftercooler water inlet temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the aftercooler water inlet temperature sensor
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES | NO
No Repair | No Repair

Go to 2A

Troubleshoot Fault Code 2111.

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the aftercooler water inlet temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the aftercooler water inlet temperature sensor.

Fault simulation enabled?
YES NO

Disable the fault simulation.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the threshold setting.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within the normal operating range for the oil pressure sensor.

Fault threshold set correctly?
YES NO

Reference the Coolant Temperature Above Normal - Gradual Overheat symptom tree, t022, and Coolant Temperature Above Normal - Sudden Overheat, t023, in Section TS of the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2113 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jun-2012


FAULT CODE 2114 - Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftercooler water inlet temperature sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading match the sensor reading?
STEP 2. | Check the engine control module (ECM) sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the aftercooler water inlet temperature sensor is not enabled. | Fault simulation enabled?
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2114 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the aftercooler water inlet temperature sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the aftercooler water inlet temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

Does the thermocouple reading match the sensor reading?
YES NO
No Repair

Go to Fault Code 2111.

Go to 2A

Fault Code 2111

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the aftercooler water inlet temperature sensor is not enabled.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the aftercooler water inlet temperature sensor.

Fault simulation enabled?
YES NO

Disable fault simulation

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check threshold setting.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within the normal operating range for the oil pressure sensor.

Fault threshold set correctly?
YES NO

Reference symptom trees Coolant Temperature Above Normal - Gradual Overheat and Coolant Temperature Above Normal - Sudden Overheat, in Section TS in the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2114 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate Troubleshooting steps

Last Modified: 23-Jun-2012


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM, OEM harness, and engine harness. |
 | STEP 2A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit in the battery 1 voltage power harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM, OEM harness, and engine harness.

Guided Step 2A - Inspect the ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the accelerator pedal or lever position sensor connector
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the engine harness and accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Use the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Reference the OEM service manual for accelerator pedal or lever position sensor repair instructions.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 4 pin in the engine harness ECM 50-pin connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the accelerator pedal or lever position sensor SUPPLY 4 wire.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Use the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the battery 1 voltage power harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector
  • Disconnect the engine power harness connector from the ECM 4-pin connector.

Action

Check for a short circuit to battery.

  • Measure the resistance between the sensor SUPPLY 4 pin in the engine harness ECM 50-pin connector and the ECM battery 1 voltage pin on the power harness ECM 4-pin connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

A short circuit to battery has been detected in the OEM harness or engine harness.

Replace the damaged section of harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Nov-2016


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control moduel (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer and circuits connected to the sensor supply 4. |
 | STEP 2A. Inspect the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer and circuit connected to the sensor supply 4 and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2186 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer and circuits connected to the sensor supply 4.

Guided Step 2A - Inspect the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer and circuit connected to the sensor supply 4 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the gain adjust potentiometer, generator output frequency potentiometer, and droop adjust potentiometer connectors from the extension wiring harness connector
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the harness connectors and gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the gain adjust potentiometer, generator output frequency potentiometer, droop adjust potentiometer, or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged gain adjust potentiometer, generator output frequency potentiometer, or droop adjust potentiometer.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the extension wiring harness. Refer to Procedure 019-175 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer connector from the OEM harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Refer to the OEM service manual for gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer repair instructions.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Replace the damaged section of harness.

Use the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector
  • Disconnect the gain adjust potentiometer connector from the extension wiring harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer sensor supply 4 pin in the engine harness ECM connector and all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer sensor supply 4 wire.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Use the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the extension wiring harness. Refer to Procedure 019-175 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector
  • Disconnect the gain adjust potentiometer connector from the extension wiring harness connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer sensor supply 4 pin in the engine harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

A short circuit has been detected in the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer sensor supply 4 wire.

Troubleshoot harnesses connected in series to determine which contains the short circuit to ground.

Use the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harnesses.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the extension wiring harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2186 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


Fault Code 2661 - At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2661 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2661 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location if the fault code will not reset.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.
  • Run the engine for 5 minutes to verify that fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Apr-2011


Fault Code 2662 - At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2662 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2662 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location if the fault code will not reset.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.
  • Run the engine for 5 minutes to verify that fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Apr-2011


FAULT CODE 2727 - SAE J1939 Engine Network - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2727 inactive?
STEP 2. | Check the OEM power harness and engine harness. |
 | STEP 2A. Inspect the 4-pin power connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the battery power circuits. | Voltage between 10.0 to 15.0-VDC for 12-VDC system or 21 to 27-VDC for 24-VDC system?
 | STEP 2C. Check battery supply for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) battery terminal. | Damaged wires?
 | STEP 2E. Check the keyswitch input to engine control module (ECM) wire. | Keyswitch wire uninterrupted?
 | STEP 2F. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 3. | Check the ECM harness. |
 | STEP 3A. Inspect the ECM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 engine network resistance in the engine harness. | Between 55 and 65 ohms?
 | STEP 3C. Check the SAE J1939 engine network terminator resistor. | Between 115 and 125 ohms?
 | STEP 3D. Check the SAE J1939 engine network circuit for an open or short circuit. | Between 55 and 65 ohms?
 | STEP 3E. Check for ECM communication to INSITE™ electronic service tool. | Does the ECM communicate?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2727 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2727 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM power harness and engine harness.

Guided Step 2A - Inspect the 4-pin power connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM1 (CM850) connector.

Action

Inspect the harness and the ECM1 (CM850) connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM1 (CM850) connector.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery voltage SUPPLY pin in the 4-pin power connector to engine block ground.
  • Reference the circuit diagram or wiring diagram for connector pin for identification.

Voltage between 10.0 to 15.0-VDC for 12-VDC system or 21 to 27-VDC for 24-VDC system?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check battery supply for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM1 (CM850) connector.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from a battery voltage SUPPLY pin in the 4-pin power connector to all other pins in the connector.
  • Measure the resistance from a battery voltage RETURN pin in the 4-pin power connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) battery terminal.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) battery terminal.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input-to-ECM wire.

  • Inspect the keyswitch wire from the ignition post in the ignition assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 2F

Go to 4A

Guided Step 2F - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the ignition post in the ignition assembly to the ignition input SUPPLY pin of the 50-pin engine harness connector.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-175 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM harness.

Guided Step 3A - Inspect the ECM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness 60-pin connector from the ECM 1.

Action

Inspect the ECM harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or ECM connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness connector pins. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3E

Go to 3B

Guided Step 3B - Check the SAE J1939 engine network resistance in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 60-pin connector.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Confirm that there are two SAE J1939 engine network terminator resistors. Remove any additional resistors from the circuit.
  • Measure the resistance between the SAE J1939 engine network SUPPLY pin and the SAE J1939 engine network RETURN pin in the ECM harness connector.
  • Reference the circuit diagram or wiring diagram for connector pin for identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 55 and 65 ohms?
YES NO

The SAE J1939 engine network resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed on the ECMs.

 No Repair

Go to 3E

Go to 3C

Guided Step 3C - Check the SAE J1939 engine network terminator resistor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 1 60-pin connector
  • Disconnect one of the SAE J1939 engine network terminator resistors from theECM harness.

Action

Check the SAE J1939 engine network terminator resistance.

Confirm that there are two SAE J1939 engine network terminator resistors.

  • Remove any additional resistors from the circuit.
  • Measure the resistance of both SAE J1939 engine network terminator resistors.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 115 and 125 ohms?
YES NO
No Repair

  • Replace any SAE J1939 engine network terminator resistor that does not meet the specified range. Refer to Procedure 019-428 in Section 19.

Go to 3D

Go to 3E

Guided Step 3D - Check the SAE J1939 engine network terminator resistor for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness connector from the ECM 1 60-pin connector.

Action

Check the SAE J1939 engine network circuit.

Measure the resistance between the SAE J1939 engine network SUPPLY pin and the SAE J1939 engine network RETURN pin in the ECM 60-pin connector.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 55 and 65 ohms?
YES NO
No Repair

An open or shorted SAE J1939 engine network circuit has been detected.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness.
  • Replace the damaged section of the ECM harness in the generator control panel. Refer to the OEM service manual.

Go to 3E

Go to 3E

Guided Step 3E - Check for ECM communication to INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for communication between INSITE™ and the ECM.

  • Use INSITE™ electronic service tool to check for communication with the ECM.

Does the ECM communicate?
YES | NO
No Repair | No Repair

Go to 4A

Go to the ECM - No Communication Troubleshooting Tree in Section TT.

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2727 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jun-2012


INDEX
162-fc112.htm

162-t05-112.htm

162-fc113.htm

162-t05-113.htm

162-fc115.htm

162-t05-115.htm

162-fc116.htm

162-t05-116.htm

162-fc117.htm

162-t05-117.htm

162-fc118.htm

162-t05-118.htm

162-fc119.htm

162-t05-119.htm

162-fc121.htm

162-t05-121.htm

162-fc122.htm

162-t05-122.htm

162-fc123.htm

162-t05-123.htm

162-fc135.htm

162-t05-135.htm

162-fc141.htm

162-t05-141.htm

162-fc143.htm

162-t05-143.htm

162-fc144.htm

162-t05-144.htm

162-fc145.htm

162-t05-145.htm

162-fc146.htm

162-t05-146.htm

162-fc151.htm

162-t05-151.htm

162-fc153.htm

162-t05-153.htm

162-fc154.htm

162-t05-154.htm

162-fc155.htm

162-t05-155.htm

162-fc185.htm

162-t05-185.htm

162-fc187.htm

162-t05-187.htm

162-fc195.htm

162-t05-195.htm

162-fc196.htm

162-t05-196.htm

162-fc197.htm

162-t05-197.htm

162-fc212.htm

162-t05-212.htm

162-fc213.htm

162-t05-213.htm

162-fc214.htm

162-t05-214.htm

162-fc221.htm

162-t05-221.htm

162-fc222.htm

162-t05-222.htm

162-fc223.htm

162-t05-223.htm

162-fc224.htm

162-t05-224.htm

162-fc227.htm

162-t05-227.htm

162-fc234.htm

162-t05-234.htm

162-fc235.htm

162-t05-235.htm

162-fc238.htm

162-t05-238.htm

162-fc254.htm

162-t05-254.htm

162-fc259.htm

162-t05-259.htm

162-fc261.htm

162-t05-261.htm

162-fc263.htm

162-t05-263.htm

162-fc265.htm

162-t05-265.htm

162-fc266.htm

162-t05-266.htm

162-fc285.htm

162-t05-285.htm

162-fc286.htm

162-t05-286.htm

162-fc316.htm

162-t05-316.htm

162-fc318.htm

162-t05-318.htm

162-fc342.htm

162-t05-342.htm

162-fc343.htm

162-t05-343.htm

162-fc346.htm

162-t05-346.htm

162-fc352.htm

162-t05-352.htm

162-fc386.htm

162-t05-386.htm

162-fc415.htm

162-t05-415.htm

162-fc421.htm

162-t05-421.htm

162-fc423.htm

162-t05-423.htm

162-fc426.htm

162-t05-426.htm

162-fc441.htm

162-t05-441.htm

162-fc442.htm

162-t05-442.htm

162-fc451.htm

162-t05-451.htm

162-fc452.htm

162-t05-452.htm

162-fc455.htm

162-t05-455.htm

162-fc467.htm

162-t05-467.htm

162-fc468.htm

162-t05-468.htm

162-fc488.htm

162-t05-488.htm

162-fc514.htm

162-t05-514.htm

162-fc553.htm

162-t05-553.htm

162-fc556.htm

162-t05-556.htm

162-fc689.htm

162-t05-689.htm

162-fc719.htm

162-t05-719.htm

162-fc729.htm

162-t05-729.htm

162-fc1117.htm

162-t05-1117.htm

162-fc1357.htm

162-t05-1357.htm

162-fc1411.htm

162-t05-1411.htm

162-fc1412.htm

162-t05-1412.htm

162-fc1418.htm

162-t05-1418.htm

162-fc1427.htm

162-t05-1427.htm

162-fc1517.htm

162-t05-1517.htm

162-fc1518.htm

162-t05-1518.htm

162-fc1519.htm

162-t05-1519.htm

162-fc1597.htm

162-t05-1597.htm

162-fc1847.htm

162-t05-1847.htm

162-fc1891.htm

162-t05-1891.htm

162-fc1978.htm

162-t05-1978.htm

162-fc1979.htm

162-t05-1979.htm

162-fc1992.htm

162-t05-1992.htm

162-fc2111.htm

162-t05-2111.htm

162-fc2112.htm

162-t05-2112.htm

162-fc2113.htm

162-t05-2113.htm

162-fc2114.htm

162-t05-2114.htm

162-fc2185.htm

162-t05-2185.htm

162-fc2186.htm

162-t05-2186.htm

162-fc2661.htm

162-t05-2661.htm

162-fc2662.htm

162-t05-2662.htm

162-fc2727.htm

162-t05-2727.htm